Introduction, Features & Installation

Mindscape Silverlight Elements
Introduction, Features & Installation

Mindscape Elements for Windows Phone

Mindscape Elements for Windows Phone includes a number of controls for building applications on Microsoft’s Silverlight platform.

Common controls include:

  • ColorPicker controls (palette and mixer)
  • DatePicker for selecting a date
  • DockPanel for laying out controls on a page
  • LoopingListBox for displaying a selection and choosing values in an attractive and fluid way
  • TimePicker for selecting a time of day

Phone Elements also includes an extensive charting subsystem for charting and data visualisation. Chart types include:

  • Bar charts
  • Line charts
  • Pie charts
  • Doughnut charts
  • Scatter charts
  • Bubble charts
  • Stacked charts

See the Charting section for more information.

Send comments on this topic to contact@mindscape.co.nz

(c) 2010-11 Mindscape Limited


Getting Started

Mindscape Silverlight Elements
Getting Started

To use Mindscape Phone Elements in your project, drag a control from the toolbox onto the visual design surface, or add a reference to the Mindscape.PhoneElements assembly using the Add Reference command. You can find the assembly in your Program Files directory under Mindscape > Phone Elements.

You may wish to copy Phone Elements to a project-specific directory (such as a Libraries or Lib directory), and reference it at this location, so that you can version it on a per-project basis.

If you are writing XAML by hand, use the following XML namespace declarations to refer to Phone Elements:

CopyPhone Elements XML namespace declarations
<!-- Non-charting controls -->
xmlns:ms="clr-namespace:Mindscape.PhoneElements;assembly=Mindscape.PhoneElements"
<!-- Charting controls and components -->
xmlns:ch="clr-namespace:Mindscape.PhoneElements.Charting;assembly=Mindscape.PhoneElements"


Samples

Mindscape Silverlight Elements
Samples

Phone Elements includes the following samples:

  • PhoneElementsSampleExplorer: Shows each of the Elements controls, plus many examples of different types of chart.

To open the samples in Visual Studio, choose Samples from the Mindscape Phone Elements group in the Start menu.


Color Picker Controls

Mindscape Silverlight Elements
Color Picker Controls

ColorPicker

The ColorPicker control allows users to select a color from a list of colors, from a themed palette, or by choosing RGB values using sliders. The control displays the color using a compact swatch and name. When the user taps the control, the control displays a page for the user to select a new value. The selection UI is determined by the ColorPickerMode property.

The SelectedColor property contains the selected color, and SelectedColorName contains the name or string representation of the selected color.

The ColorPicker control requires certain resources that must be supplied by your application. See Required Resources for details.

Standard Mode – Named Color List

When ColorPickerMode is set to Standard, the user can select from a vertical list of swatches, each with the color name shown next to it.

The list of colors shown is determined by the NamedColors property. The default is the list of ten colors seen in the Windows Phone 7 operating system color picker. You can override this with your own collection of NamedColor objects.

Mixer Mode

When ColorPickerMode is set to Mixer, the user can choose any RGB color by specifying the red, green and blue channel values. When editing, these channel values are displayed as sliders. Custom colors do not have names and are therefore displayed using RGB notation.

Palette Mode

When ColorPickerMode is set to Palette, the user can select from a compact set of swatches laid out in columns of related colors.

The color palette shown is determined by the Palette property. The default is a themed palette based on the color palettes in Microsoft Office applications. See the StandardPalettes class for built-in palettes or create your own. If you create your own, it should be a list of NamedColor objects. The ColorPicker expects this list to be arranged as follows:

  • 10 “theme” colors.
  • For each “theme” color, 5 variants of that color. Each block of variants must be contiguous and the blocks must appear in the same order as the “theme” colors. For example, elements 10-14 of the list would be the variants on theme color 0, elements 15-19 the variants of theme color 1, etc.
  • 10 “standard” colors.

Custom Mode

When ColorPickerMode is set to Custom, you can specify your own editing page using the PickerPageUri property. The page must derive from ColorPickerPageBase.

Accessing the Selected Color

To access the selected color, use the SelectedColor property. You can use the ColorToSolidColorBrushConverter to convert this color to a brush. The example shows how to bind the Background of another element to the ColorPicker selection.
CopyExample Usage
<UserControl.Resources>
  <ms:ColorToSolidColorBrushConverter x:Key="scb" />
</UserControl.Resources>

<StackPanel>
  <ms:ColorPicker Name="cp" />
  <Border Width="40" Height="40"
          Background="{Binding SelectedColor, ElementName=cp, Converter={StaticResource scb}}"
          />
</StackPanel>


Layout Controls

Mindscape Silverlight Elements
Layout Controls

DockPanel

The DockPanel control lays out multiple controls horizontally or vertically, with each control snapping to the top, bottom, left or right side of the DockPanel according to its DockPanel.Dock attached property. The final child control occupies the remaining area after the other controls have been laid out. (This can be suppressed by setting DockPanel.LastChildFill to false.)

CopyDocking controls with a DockPanel
<ms:DockPanel>
  <local:Dashboard ms:DockPanel.Dock="Top" />
  <local:ToolBox ms:DockPanel.Dock="Left" />
  <local:MainView />  <!-- fills remaining area -->
</ms:DockPanel>


List Controls

Mindscape Silverlight Elements
List Controls

LoopingListBox

The LoopingListBox control displays a selected item which the user can expand to a list of choices. The user can scroll through the list of choices by dragging or flicking it with a finger, and the list loops around so that if the user scrolls past the end then they are taken back to the beginning rather than stopping abruptly. The scrolling respects the speed of the user’s gesture, and decelerates over time, enabling the LoopingListBox to provide a convenient user interface over even moderately large sets of choices.

The set of items in the list is specified via the DataSource property. You can use a built-in data source or implement your own. Data sources are provided for days of the month (DayOfMonthDataSource), months of the year (MonthOfYearDataSource), years (YearlyDataSource), numeric ranges (NumericDataSource) and lists of arbitrary objects (ObjectDataSource).

You can customise how items are displayed in the LoopingListBox using the usual Silverlight data templating system and the ItemTemplate property.

The current selection is specified by the SelectedItem property.

By default, the LoopingListBox shows the list when it is selected by the user, and collapses again when it loses focus or when the user taps the item which is already selected. You can programmatically expand and collapse the list using the IsExpanded property.

CopyUsing a LoopingListBox
<ms:LoopingListBox SelectedItem="{Binding Rating, Mode=TwoWay}">
  <ms:LoopingListBox.DataSource>
    <ms:NumericDataSource MinValue="1" MaxValue="10" />
  </ms:LoopingListBox.DataSource>
<ms:LoopingListBox>


Time Controls

Mindscape Silverlight Elements
Time Controls

The DatePicker and TimePicker controls provide a way for users to select dates and times using large blocks which are easy to manipulate on the phone device, while still having the dates and times displayed in a compact way.

In both cases, the control’s default appearance is as a normal text block displaying the selected date or time. When the user taps the text block, the control displays a new page on which the user can select a new value.

The DatePicker and TimePicker controls require certain resources that must be supplied by your application. See Required Resources for details.

DatePicker

The DatePicker control supports the selection of a date. The SelectedDate property contains the selected date.

The date format can be specified using the DateFormat property. In display mode, this is the format in which the date is displayed. In selection mode, it determines which of the day, month and year are available for modification. For example, if the date format is MMMM yyyy, then the selection page shows only the month and year—the user cannot see or modify the day.

The day, month and year on the selection page are shown using LoopingListBox controls to create a user interface which is attractive, fluid and easy to manipulate.

CopyUsing a DatePicker
<ms:DatePicker DateFormat="dd MMMM" SelectedDate="{Binding Birthday, Mode=TwoWay}" />

TimePicker

The TimePicker control supports selecting a time of day. The SelectedTime property contains the selected time.

The time format can be specified using the TimeDisplayMode property. Times are always displayed as hours and minutes (no seconds), but can be chosen to be displayed using the 12-hour clock plus an AM/PM indicator or the 24-hour clock. The same format is used for selecting a time—for example, in 12-hour format the selection page includes an AM/PM indicator, and the hour selector loops around from 12 to 1, but in 24-hour format the selection page includes only hour and minute selectors, and the hour selector loops around from 24 to 1.

As with the DatePicker, the selection page uses LoopingListBox controls for interaction with the user.


Required Resources

Mindscape Silverlight Elements
Required Resources

Some Phone Elements controls display additional pages during user interaction. These pages require certain resources in order to display correctly. Due to limitations in Windows Phone 7, these resources must be supplied by your application. Phone Elements expects to find these resources at specific locations.

Therefore, if you are using the TimePicker, DatePicker or ColorPicker controls, you must create a folder in your project called Elements.Content, and this folder must contain the following files:

  • ApplicationBar.Cancel.png
  • ApplicationBar.Done.png

These files can be copied from the Resources\Elements.Content folder in the installation directory.


Charting Basics

Mindscape Silverlight Elements
Charting Basics

Phone Elements supports a number of chart types with extensive support for customization. This topic introduces the core steps required to show a chart in your application. See also the PhoneElementsSampleExplorer sample for examples.

Controls

The core control for most charts is the Chart control.

CopyAdding a Chart control to your page
<ch:Chart Title="My Chart" Width="600" Height="400" />

For pie charts only, use the PieChart control instead.

Data Series

A Chart or PieChart does not by itself display data. To specify the data to display, and how to display it, you must add one or more DataSeries to the chart. For example, to display data using a bar chart:

CopyAdding a Bar series to your chart
<ch:Chart Title="My Chart" Width="600" Height="400">
  <ch:BarSeries />
</ch:Chart>

The ItemsSource of the DataSeries must be set to the collection of data points you want to display. Use the XBinding and YBinding properties to specify the X-axis and Y-axis values respectively:

CopyPopulating a data series with data
<ch:Chart Title="My Chart" Width="600" Height="400">
  <!-- Assuming the DataContext is a collection of SalesFigure objects, where
       the SalesFigure class has Quarter and Amount properties -->
  <ch:BarSeries ItemsSource="{Binding}"
                XBinding="{Binding Quarter}"
                YBinding="{Binding Amount}"
                />
</ch:Chart>

You can display multiple series of data on the same chart:

CopyShowing multiple bar series on one chart
<ch:Chart Title="My Chart" Width="600" Height="400">
  <!-- Assuming the DataContext is a collection of SalesPerson objects, where
       the SalesPerson class has a Name property and a Sales collection property -->
  <ch:BarSeries DataContext="{Binding [0]}"
                ItemsSource="{Binding Sales}"
                Title="{Binding Name}"
                XBinding="{Binding Quarter}"
                YBinding="{Binding Amount}" />
  <ch:BarSeries DataContext="{Binding [1]}"
                ItemsSource="{Binding Sales}"
                Title="{Binding Name}"
                XBinding="{Binding Quarter}"
                YBinding="{Binding Amount}" />
</ch:Chart>

For a PieChart control, use PieSeries instead of a DataSeries-derived type.

Chart Axes

To customize the chart axes, use the XAxis and YAxis properties:

CopySetting the axis titles
<ch:Chart Title="My Chart" Width="600" Height="400">
  <ch:Chart.XAxis>
    <ch:ChartAxis Title="Quarter" />
  </ch:Chart.XAxis>
  <ch:Chart.YAxis>
    <ch:ChartAxis Title="Amount" Minimum="0" Maximum="35000" />
  </ch:Chart.YAxis>
</ch:Chart>

Exploring Charting Capabilities

To see code samples for both basic charts and customisation, see the PhoneElementsSampleExplorer sample.


Bar Charts

Bar Charts

To display a bar chart, use the Chart control and add a BarSeries to the chart. The BarSeries must specify an ItemsSource, which is a collection containing the data to be displayed, and will normally specify a XBinding and a YBinding, which are data bindings specifying how the position and height of the bar are determined from the data.
CopyCreating a bar chart
<ch:Chart Title="Sales" Width="600" Height="400">
  <ch:BarSeries ItemsSource="{Binding}"
                XBinding="{Binding Quarter}"
                YBinding="{Binding Amount}"
                />
</ch:Chart>

If the ItemsSource contains a collection of Point objects, you can omit the XBinding and YBinding.

By default, a BarSeries is displayed using vertical bars, rising or falling from the X axis. To display horizontal bars, set the Orientation property to Horizontal. In this case, the XBinding represents the length of the bars and the YBinding their vertical position.

CopyCreating a horizontal bar chart
<ch:BarSeries ItemsSource="{Binding}"
              Orientation="Horizontal"
              YBinding="{Binding TestIndex}"
              XBinding="{Binding TimeTaken}"
              />

To change the fill of the bars, use the SeriesBrush property:

CopyColoring the bars solid red
<ch:BarSeries SeriesBrush="Red" />

A chart may contain multiple series. By default, these are identified in the legend as “Series 1,” “Series 2,” etc. To customise the titles, set the Title property:

CopySetting the legend text
<ch:BarSeries ItemsSource="{Binding Predicted}" Title="Predicted sales" SeriesBrush="Gray" />
<ch:BarSeries ItemsSource="{Binding Actual}" Title="Actual sales" SeriesBrush="Blue" />

By default, all series are filled with the same default brush. If you are showing multiple series, be sure to set the SeriesBrush so that users can relate them to the legend.

To use a different fill for each bar, use the Brushes collection:

CopyMy eyes! The goggles do nothing!
<ch:BarSeries>
  <ch:BarSeries.Brushes>
    <SolidColorBrush Color="HotPink" />
    <SolidColorBrush Color="Yellow" />
    <SolidColorBrush Color="Lime" />
  </ch:BarSeries.Brushes>
</ch:BarSeries>

If there are more bars than brushes, then the brushes are used in rotation. If you are using multiple brushes, you will typically want the legend to distinguish individual items in the series (otherwise the first brush will be used in the legend, which may confuse users). To do this, use ShowAllLegendItems and DataTitleBinding:

CopyLegend entry for each item
<ch:BarSeries ItemsSource="{Binding}"
              XBinding="{Binding Quarter}"
              YBinding="{Binding Amount}"
              ShowAllLegendItems="True"
              DataTitleBinding="{Binding Quarter, Converter={StaticResource QuarterName}}"
              >
  <ch:BarSeries.Brushes>
    <SolidColorBrush Color="HotPink" />
    <SolidColorBrush Color="Yellow" />
    <VideoBrush SourceName="psychedelicMediaElement" />
    <SolidColorBrush Color="Lime" />
  </ch:BarSeries.Brushes>
</ch:BarSeries>

Styling the Bars

To customize the appearance of the bars over and above changing the brush, use the BarStyle property. The target type of the style should be Bar. You will typically set the control Template.

CopyFlat rounded bars
<ch:BarSeries>
  <ch:BarSeries.BarStyle>
    <Style TargetType="ch:Bar">
      <Setter Property="Template">
        <Setter.Value>
          <ControlTemplate>
            <Rectangle RadiusX="4" RadiusY="4" Fill="HotPink" />
          </ControlTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:BarSeries.BarStyle>
</ch:BarSeries>


Line and Area Charts

Mindscape Silverlight Elements
Line and Area Charts

Line Charts

To display a line chart, use the Chart control and add a LineSeries to the chart. The LineSeries must specify an ItemsSource, which is a collection containing the data to be displayed, and will normally specify a XBinding and a YBinding, which are data bindings specifying how the points along the line are determined from the data.
CopyCreating a line chart
<ch:Chart Title="Sales" Width="600" Height="400">
  <ch:LineSeries ItemsSource="{Binding}"
                 XBinding="{Binding Quarter}"
                 YBinding="{Binding Amount}"
                 />
</ch:Chart>

If the ItemsSource contains a collection of Point objects, you can omit the XBinding and YBinding.

To change the color of the line, use the SeriesBrush property:

CopySetting the line color
<ch:LineSeries SeriesBrush="Red" />

To show a dashed line, use the DashArray property. The XAML syntax for DashArray is the same as for Shape.StrokeDashArray—see the Silverlight SDK documentation for details.

CopyShowing a dashed line
<ch:LineSeries DashArray="2 1" />

To make broader changes to the appearance of the line, use the LineStyle property. The target type for the LineStyle should be Path.

CopySetting the line style
<ch:LineSeries>
  <ch:LineSeries.LineStyle>
    <Style TargetType="Path">
      <Setter Property="StrokeThickness" Value="4" />
      <Setter Property="Stroke" Value="Red" />
      <Setter Property="StrokeDashArray" Value="2 1" />
    </Style>
  </ch:LineSeries.LineStyle>
</ch:LineSeries>

You can optionally show a symbol at each point on the line by setting the SymbolStyle property. The target type of the SymbolStyle should be ChartSymbol, and to change the shape of the point you must set the control Template.

CopyDisplaying a square at each point of the line
<ch:LineSeries>
  <ch:LineSeries.SymbolStyle>
    <Style TargetType="ch:ChartSymbol">
      <Setter Property="Width" Value="8" />
      <Setter Property="Height" Value="8" />
      <Setter Property="Margin" Value="-4,-4,4,4" />
      <Setter Property="Template">
        <Setter.Value>
          <ControlTemplate TargetType="ch:ChartSymbol">
            <Rectangle Stroke="Red"
                       StrokeThickness="1"
                       Fill="Pink"
                       />
          </ControlTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:LineSeries.SymbolStyle>
</ch:LineSeries>

The template origin is the location of the data point. If you want your shape to be centred on the data point, set negative left and top margins equal to half the width and height respectively.

Area Charts

To display an area chart, add a AreaSeries to a Chart control.

Area series have the same options as line series and are drawn in the same way, except that the area between the line and the X axis is filled with the SeriesBrush. To make multiple overlapping area series visible, the fill is made slightly transparent. To make the fill opaque, or to otherwise customise the appearance of the filled area, use the AreaStyle property. The target type for the AreaStyle should be Path.

CopyAll glory to the hypnotoad
<ch:AreaSeries ItemsSource="{Binding}"
               XBinding="{Binding Quarter}"
               YBinding="{Binding Amount}"
               >
  <ch:AreaSeries.AreaStyle>
    <Style TargetType="Path">
      <Setter Property="Fill">
        <Setter.Value>
          <RadialGradientBrush SpreadMethod="Repeat">
            <GradientStop Offset="0" Color="Blue" />
            <GradientStop Offset="0.2" Color="Purple" />
            <GradientStop Offset="0.4" Color="Red" />
            <GradientStop Offset="0.6" Color="Yellow" />
            <GradientStop Offset="0.8" Color="Lime" />
            <GradientStop Offset="1" Color="Blue" />
          </RadialGradientBrush>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:AreaSeries.AreaStyle>
</ch:AreaSeries>

In the absence of LineStyle and AreaStyle, the SeriesBrush is used to draw the line and the fill, but these elements are drawn separately. Using a brush other than a SolidColorBrush for the SeriesBrush may not produce the expected visual effect.


Scatter Charts

Scatter Charts

To display a scatter chart, use the Chart control and add a ScatterSeries to the chart. The ScatterSeries must specify an ItemsSource, which is a collection containing the data to be displayed, and will normally specify a XBinding and a YBinding, which are data bindings specifying how the locations of the points on the scatter chart are determined from the data.
CopyCreating a scatter chart
<ch:Chart Title="Sales">
  <ch:ScatterSeries ItemsSource="{Binding}"
                    XBinding="{Binding Quarter}"
                    YBinding="{Binding Amount}"
                    />
</ch:Chart>

If the ItemsSource contains a collection of Point objects, you can omit the XBinding and YBinding.

To customize the appearance of points on the scatter chart, use the SymbolStyle property. The target type of the SymbolStyle should be ChartSymbol, and to change the shape of the point you must set the control Template.

CopyDisplaying points as red squares
<ch:ScatterSeries>
  <ch:ScatterSeries.SymbolStyle>
    <Style TargetType="ch:ChartSymbol">
      <Setter Property="Width" Value="8" />
      <Setter Property="Height" Value="8" />
      <Setter Property="Margin" Value="-4,-4,4,4" />
      <Setter Property="Template">
        <Setter.Value>
          <ControlTemplate TargetType="ch:ChartSymbol">
            <Rectangle Stroke="Red"
                       StrokeThickness="1"
                       Fill="Pink"
                       />
          </ControlTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:ScatterSeries.SymbolStyle>
</ch:ScatterSeries>

The template origin is the location of the data point. If you want your shape to be centred on the data point, set negative left and top margins equal to half the width and height respectively.


Bubble Charts

Bubble Charts

To display a bubble chart, use the Chart control and add a BubbleSeries to the chart. The BubbleSeries must specify an ItemsSource, which is a collection containing the data to be displayed, and a XBinding, a YBinding and a SizeBinding, which are data bindings specifying how the locations and sizes of the bubbles are determined from the data.
CopyCreating a bubble chart
<ch:Chart Title="Sales">
  <ch:ScatterSeries ItemsSource="{Binding}"
                    XBinding="{Binding RegionGeoX}"
                    YBinding="{Binding RegionGeoY}"
                    SizeBinding="{Binding Amount}"
                    />
</ch:Chart>

To change the color of the bubbles, set the SeriesBrush property:

CopyChanging the bubble color
<ch:BubbleSeries SeriesBrush="Red" />

The Chart control will apply a lighting effect to the brush to give it the “bubble” appearance. To override this effect with your own, use the BubbleStyle property. The target type of the BubbleStyle should be Bubble, and you will typically style the Template property.

CopyBasic front-lit bubbles
<ch:BubbleSeries SeriesBrush="Red" />
  <ch:BubbleSeries.BubbleStyle>
    <Style TargetType="ch:Bubble">
      <Setter Property="Template">
        <Setter.Value>
          <ControlTemplate TargetType="ch:Bubble">
            <Grid Width="{TemplateBinding Width}" Height="{TemplateBinding Height}">
              <Ellipse Fill="{TemplateBinding Background}" />
              <Ellipse>
                <Ellipse.Fill>
                  <RadialGradientBrush>
                    <GradientStop Offset="0" Color="#80FFFFFF" />
                    <GradientStop Offset="0.8" Color="#00FFFFFF" />
                  </RadialGradientBrush>
                </Ellipse.Fill>
              </Ellipse>
            </Grid>
          </ControlTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:BubbleSeries.BubbleStyle>
</ch:BubbleSeries>


Spline Charts

Spline Charts

Phone Elements also includes spline equivalents of the line and area series. These work in a similar way to LineSeries and AreaSeries but smooth out the line.

To create a spline chart, add a SplineSeries to a Chart control.

CopyCreating a spline chart
<ch:Chart Title="Sales" Width="600" Height="400">
  <ch:SplineSeries ItemsSource="{Binding}"
                   XBinding="{Binding Quarter}"
                   YBinding="{Binding Amount}"
                   />
</ch:Chart>

SplineSeries supports the same options as LineSeries, including SeriesBrush, DashArray, LineStyle and SymbolStyle.

To create a spline area chart – that is, an area chart with a smoothed curve – add a SplineAreaSeries to a Chart control. SplineAreaSeries supports the same options as AreaSeries.


Stacked Charts

Stacked Charts

Phone Elements offers stacked versions of bar, line, area, spline and spline area charts. In a stacked chart, each series ‘stacks’ on top of the one before instead of being displayed alongside or overlaid on it. This makes a stacked chart a good way to display data where the total over the series is important as well as the individual values. For example, if each series represents a sales region and each data point represents a time period and the sales during that time period, then the total value across the series is the total sales across all regions during the time period. Since the trend of total sales is likely to be of interest to users, a stacked graph might be a good choice here.

To create a stacked bar chart, add multiple StackedBarSeries to a Chart control:

CopyCreating a stacked bar chart
<ch:Chart Title="Sales" Width="600" Height="400">
  <ch:StackedBarSeries ItemsSource="{Binding [0]}"
                       XBinding="{Binding Quarter}"
                       YBinding="{Binding Amount}"
                       SeriesBrush="Blue"
                       Title="North Island"
                       />
  <ch:StackedBarSeries ItemsSource="{Binding [1]}"
                       XBinding="{Binding Quarter}"
                       YBinding="{Binding Amount}"
                       SeriesBrush="Red"
                       Title="South Island"
                       />
</ch:Chart>

A stacked series only stacks on other stacked series of the same type. If you put a (non-stacked) LineSeries and a StackedLineSeries into the same chart, the StackedLineSeries won’t factor in the values of the LineSeries. This allows you to add non-stacking data, such as averages or expectations, to a stacking chart.

Other kinds of stacked chart are created in a similar way using the appropriate stacked series: StackedLineSeries, StackedAreaSeries, StackedSplineSeries or StackedSplineAreaSeries. Each has the same options as the corresponding non-stacked equivalent: see Bar Charts, Line and Area Charts and Spline Charts for more information.


Pie and Doughnut Charts

Mindscape Silverlight Elements
Pie and Doughnut Charts

Pie Charts

To display a pie chart, use the PieChart control. (The Chart control is not used for pie charts.)

To display data in the pie chart, add a data set to the PieSeries collection:

CopyCreating a pie chart
<ch:PieChart Title="Sales" Width="600" Height="400">
  <ch:PieSeries ItemsSource="{Binding}" />
</ch:PieChart>

The example above assumes that the data context is a collection of numeric values. To display a collection of business objects, use the DataBinding property to specify the value you want to show in the chart, and the TitleBinding to specify the title (legend text) associated with the data item:

CopyCreating a pie chart
<ch:PieChart Title="Sales by Region" Width="600" Height="400">
  <ch:PieSeries ItemsSource="{Binding}"
                DataBinding="{Binding Amount}"
                TitleBinding="{Binding RegionName}"
                />
</ch:PieChart>

You can also alter the radius of each pie slice using RadiusBinding.

Multiple series in a pie chart are shown as nested charts. The first series is the outermost chart.

Partial Pies

It is sometimes useful to show a pie chart with a ‘missing’ slice. For example if you were using the pie chart to show contributions towards a target from different sources, but the contributions added up to less than the target, you could leave a missing slice to show the shortfall.

To make a partial pie, set the FullCircleTotal property of the PieSeries. The angle for each slice will then be calculated as a fraction of this value rather than as a fraction of the total slice values. If the total slice values fall short of the FullCircleTotal, then the pie will have a missing slice.

Doughnut Charts

To display a doughnut chart, use a PieChart and PieSeries as if you were creating a pie chart, but set PieSeries.DoughnutScale to a value less than 1. The lower the value, the larger the doughnut hole.

Customizing Pie Slice Colors

To control the fill for the pie slices, use the PieSeries.Brushes collection:

CopyAlternating colors for pie slices
<ch:PieSeries>
  <ch:PieSeries.Brushes>
    <SolidColorBrush Color="Orange" />
    <SolidColorBrush Color="Yellow" />
  </ch:PieSeries.Brushes>
</ch:PieSeries>

If there are more bars than brushes, then the brushes are used in rotation.

Styling the Pie Slices

To customize the appearance of the pie slices over and above changing the brush, use the PieSliceStyle property. The target type of the style should be PieSlice. You will typically set the control Template. The calculated geometry of the slice is available in the PathData property of the PieSlice.

CopyAdding a gaily colorful border to each slice
<ch:PieSeries>
  <ch:PieSeries.PieSliceStyle>
    <Style TargetType="ch:PieSlice">
      <Setter Property="Template">
        <Setter.Value>
          <ControlTemplate>
            <Path Fill="{TemplateBinding Background}"
                  Data="{Binding PathData, RelativeSource={RelativeSource TemplatedParent}}"
                  StrokeThickness="1" Stroke="Lime"
                  StrokeLineJoin="Round" />
          </ControlTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:PieSeries.PieSliceStyle>
</ch:PieSeries>


Styling Charts

Mindscape Silverlight Elements
Styling Charts

Styling

For general information about styling parts of the chart control or the data series, see other topics including the various data series topics, Axis Display Options, Legend Display Options and Data Labelling Options.

The PhoneElementsSampleExplorer sample includes lots of examples of styling charts which you can easily adapt to your own visual style.

Data-Dependent Styling

You can also create styles which adapt to the data being displayed: for example, displaying a different fill color depending on the range band a value falls into. To do this, you must specify a style for the data elements—the exact property will depend on the type of data series. For example, to apply data-dependent styling to a bar series, use the BarStyle property.

The key to data-dependent styling is to replace the control Template, and bind to the XObject and/or YObject property of the templated parent. (XObject and YObject are defined by the CardinalDataPoint class, from which classes such as Bar and ChartSymbol are derived.) In this example, we create a very simple flat rectangle, and use a value converter to specify the fill brush.

CopyStyling bars in a bar chart according to their value
<ch:BarSeries>

  <ch:BarSeries.Resources>
    <local:DataBrushConverter x:Key="DataBrush" />
  </ch:BarSeries.Resources>

  <ch:BarSeries.BarStyle>
    <Style TargetType="ch:Bar">
      <Setter Property="Template">
        <Setter.Value>
          <ControlTemplate>
            <Rectangle Fill="{Binding YObject, Converter={StaticResource DataBrush}, RelativeSource={RelativeSource TemplatedParent}}" />
          </ControlTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:BarSeries.BarStyle>

</ch:BarSeries>
CopyValue converter for above style
public class DataBrushConverter : IValueConverter
{
  public object Convert(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture)
  {
    return System.Convert.ToDouble(value) < 15000 ? new SolidColorBrush(Colors.Red) : new SolidColorBrush(Colors.Green);
  }

  public object ConvertBack(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture)
  {
    throw new NotImplementedException();
  }
}


Background and Foreground Elements

Mindscape Silverlight Elements
Background and Foreground Elements

Adding Background Elements to a Chart

To add background elements to a chart, use the BackgroundElements property. Background elements are displayed in the chart area only—not the legend, axis or title areas. This makes background elements ideal for displaying items that need to be shown alongside the data but are not associated with a particular data series.

A common use of the BackgroundElements collection is to display grid lines using a ChartGrid. The ChartGrid draws lines at each tick mark on the chart axes. To suppress lines in a particular direction, set the associated brush to Transparent. For example, to show horizontal grid lines only, set VerticalGridLineBrush=”Transparent”. Grid bands can be coloured in rotation using the HorizontalStripeBrushes and VerticalStripeBrushes properties.

You can also use the MarkedStripeGrid as a background element to display bands of color behind the chart, to help your users place the series data in context. For example, you might create colored bands for expected, lower than expected and higher than expected ranges. MarkedStripeGrid differs from ChartGrid in that it is not tied to tick marks and does not repeat color bands in rotation.

You are not restricted to these two components: you can place any UIElement in the BackgroundElements collection. You can also combine elements to achieve a desired visual effect. The following example uses a MarkedStripeGrid to show bands, and a ChartGrid to superimpose horizontal grid lines to improve readability.

CopyDrawing colored bands on a bar chart
<ch:Chart>
  <ch:Chart.Series>
    <ch:BarSeries ItemsSource="{Binding}" />
  </ch:Chart.Series>
  <ch:Chart.YAxis>
    <ch:ChartAxis Minimum="0" Maximum="10" />
  </ch:Chart.YAxis>
  <ch:Chart.BackgroundElements>
    <ch:MarkedStripeGrid>
      <ch:MarkedStripeGrid.MarkedStripes>
        <ch:MarkedStripe Value="2" Background="#D99694" />
        <ch:MarkedStripe Value="5" Background="#FAC08F" />
        <ch:MarkedStripe Value="10" Background="#C3D69B" />
      </ch:MarkedStripeGrid.MarkedStripes>
    </ch:MarkedStripeGrid>
    <ch:ChartGrid VerticalGridLineBrush="Transparent" />
  </ch:Chart.BackgroundElements>
</ch:Chart>

The BackgroundElements property differs from the Background property in that elements are shown only on the chart area, not over the entire Chart control, and in that it supports arbitrary UIElements, not just brushes.

For an example of using BackgroundElements, see the BarChartPage page, Data Dependent Style pivot item in the PhoneElementsSampleExplorer sample.

Adding Foreground Elements to a Chart

The Chart control has a ForegroundElements collection similar to the BackgroundElements collection described above. Foreground elements are displayed above the chart area (again, excluding areas such as the legend, axes and title).

Foreground elements should usually be largely transparent so as not to obscure the chart. A foreground element will interfere with selection unless IsHitTestVisible is set to false.


Axis Display Options

Mindscape Silverlight Elements
Axis Display Options

Chart Axis Display Options

The Chart control has XAxis and YAxis properties which you can use to customize the appearance and behavior of the chart axes. To customize an axis, set the appropriate property to a suitable ChartAxis object.

CopyAdding a title to the X axis
<ch:Chart Title="Sales">
  <ch:Chart.XAxis>
    <ch:ChartAxis Title="Quarter" />
  </ch:Chart.XAxis>
</ch:Chart>

Adding a Title to an Axis

To add a title to a chart axis, set the Title property as shown above.

Specifying the Axis Range

By default, the Chart control calculates the minimum and maximum of each axis based on the the values of the supplied data plus a nominal ‘zero’ data point. To override the default range, set the Minimum and Maximum properties:

CopySetting a fixed range for an axis
<ch:Chart Title="Results" Width="600" Height="400">
  <ch:Chart.YAxis>
    <ch:ChartAxis Title="Profit!" Minimum="100000" Maximum="250000" />
  </ch:Chart.YAxis>
</ch:Chart>

Customizing the Axis Appearance

You can customize the appearance of the axis by setting the ChartAxis.Style property. The target type of the style should be Border.

CopyDrawing the axis in red
<ch:Chart.YAxis>
  <ch:ChartAxis>
    <ch:ChartAxis.AxisLineStyle>
      <Style TargetType="Border">
        <Setter Property="BorderBrush" Value="Red" />
      </Style>
    </ch:ChartAxis.AxisLineStyle>
  </ch:ChartAxis>
</ch:Chart.YAxis>

You can entirely replace the appearance of the axes by setting the Chart.XAxisTemplate and/or Chart.YAxisTemplate properties. The templates are applied to ChartAxis objects.

Controlling Tick Marks and Labels

The Chart control shows tick marks at regular intervals along each axis, labelled with the associated data values. By default, the interval between tick marks on an axis is based on the minimum and maximum values. To override the default tick mark interval, set the MajorTickSpacing property:

CopySetting tick mark spacing on an axis
<ch:Chart.YAxis>
  <ch:ChartAxis MajorTickSpacing="2500" />
</ch:Chart.YAxis>

To show minor tick marks between the major tick marks, set the MinorTickMarkVisibility property.

By default, the zero tick mark and label are placed at the chart origin, and the maximum tick mark and label at the end of the axis. It is sometimes useful to have these appear only in the interior of the axis. For example, in a bar chart, you would not want the first and last bars to overspill the X axis. You can set the TickLayout and LabelLayout properties of the ChartAxis to override the default behavior.

To customise the appearance of tick marks, set the MajorTickMarkStyle and/or MinorTickMarkStyle. The target type of the style should be Border.

Label Presentation and Formatting

To format the label text, use the ChartAxis.LabelFormat property. This is a normal .NET formatting string.

CopyFormatting the label using a format string
<ch:Chart.YAxis>
  <ch:ChartAxis LabelFormat="{}{0:F2}">
</ch:Chart.YAxis>

If your format string starts with an open brace, precede it with an open-close brace ({}) so that Silverlight doesn’t try to interpret it as a markup extension.

For finer control over presentation and formatting, you can provide a DataTemplate using the LabelTemplate property. The template data context will be the data value on the axis.

<Path Data=”M 0,0 L 34,0 40,6 34,12 0,12 Z” Fill=”AliceBlue” Stroke=”CadetBlue” /> <TextBlock Text=”{Binding}” FontFamily=”Consolas” TextAlignment=”Right” VerticalAlignment=”Center” Margin=”0,0,8,0” />

Preventing Overlapping Labels on an Axis

If tick marks are very dense, especially along the horizontal axis, then the labels may overlap. To prevent this, you can rotate or stagger the labels.

To stagger the labels, set the LabelLevelCount property to a value greater than 1. The Chart control will stagger the labels across the specified number of levels (for example, a LabelLevelCount of 2 on the X axis will cause the labels to be staggered across two rows).

To rotate the labels, set the LabelRotation property.

Converting Between Values and Axis Positions

A chart axis normally maps data values linearly into the display space. However, sometimes data values are not numeric or the mapping of numeric values should not be linear. An example of non-numeric data being plotted along an axis is DateTime values. An example of non-linear mapping is logarithmic scaling.

Both of these situations are handled by the ChartAxis.ValueConverter property, which is of type IAxisValueConverter. IAxisValueConverter translates between your data values and a linear numeric range. The translated values are not necessarily physical coordinates—they need only represent relative positions along the axis, which the Chart control will then automatically scale to the physical length of the axis.

Phone Elements includes converters for DateTime plotting and for logarithmic scales. See DateTimeAxisValueConverter and LogarithmicAxisValueConverter respectively.

You don’t have to implement a converter to use a non-numeric axis. By default, non-numeric data will be arranged at equal intervals in the order in which is appears in the series. You need a converter only if you want to change or customize the positions at which values appear on the axis.

Displaying Multiple Y Axes

If you are displaying multiple data series, and their ranges are sufficiently different that it’s not practical to plot them on the same scale, you can create additional Y axes and plot each series against a different axis. To do this, add ChartAxis objects with suitable Minimum and Maximum properties to the Chart.AlternateYAxes collection. Each additional ChartAxis must have a unique Title. Then, for each data series that you want to use a nondefault Y axis, set its YAxisTitle to the title of the desired axis.


Legend and Title Display Options

Mindscape Silverlight Elements
Legend and Title Display Options

Legend Display Options

The Chart and PieChart controls display a legend to the right of the chart, helping users to identify the different data items displayed.

In the Chart control, the legend provides a caption for each displayed data series. The exception is if you are using a BarSeries and set the ShowAllLegendItems property to True, in which case the legend provides a caption for each data item (bar).

In the PieChart control, the legend provides a caption for each data item (slice of the pie).

Legend Position

To change the display position of the legend, set the Chart.LegendPosition or PieChart.LegendPosition property.

CopyDisplaying the legend above the chart
<ch:Chart LegendPosition="Left" />

Hiding the Legend

To hide the legend, set LegendPosition to None.

Legend Text

In the Chart control, the default legend text for each data series is “Series n”. To override this, set the series’ Title.

CopyProviding meaningful legend text - series level
<ch:BarSeries Title="Predicted" SeriesBrush="Black" />
<ch:BarSeries Title="Actual" SeriesBrush="Red" />

In the PieChart control, or when using a BarSeries with ShowAllLegendItems set to True, the default legend text for each item is “Item n”. To override this, set the TitleBinding on the PieSeries or BarSeries.

CopyProviding meaningful legend text - item level
<ch:PieChart>
  <ch:PieSeries ItemsSource="{Binding}"
                DataBinding="{Binding Amount}"
                TitleBinding="{Binding RegionName}" />
</ch:PieChart>

Customizing the Appearance of the Legend

The appearance of the legend box can be customized using the LegendStyle property. The target type of the style should be Legend. Legend is a HeaderedItemsControl: the Header is the legend title and the ItemsSource contains the legend entries in the form of LegendItem objects: use the LegendIconBrush to get the brush used for the item, and LegendLabel to get the item text.

CopyCustomizing the legend box
<ch:Chart Width="600" Height="400" LegendPosition="Top">
  <ch:Chart.LegendStyle>
    <Style TargetType="ch:Legend">
      <Setter Property="BorderBrush" Value="Black" />
      <Setter Property="Background" Value="Silver" />
      <Setter Property="Header" Value="Chart Key" />
      <Setter Property="ItemTemplate">
        <Setter.Value>
          <DataTemplate>
            <StackPanel Margin="4,0,4,0">
              <Ellipse Fill="{Binding LegendIconBrush}"
                       Width="8" Height="8"
                       Stroke="Black"
                       HorizontalAlignment="Center"
                       />
              <TextBlock Text="{Binding LegendLabel}"
                         TextAlignment="Center"
                         FontStyle="Italic"
                         />
            </StackPanel>
          </DataTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:Chart.LegendStyle>
</ch:Chart>

The appearance of legend icons (the color swatches shown next to the legend text) can be customized using the LegendIconTemplate property. The data context of the template is a LegendItem: use the LegendIconBrush to get the default item brush.

CopyDisplaying circular legend icons
<ch:BarSeries>
  <ch:BarSeries.LegendIconTemplate>
    <DataTemplate>
      <Ellipse Fill="{Binding LegendIconBrush}"
               Width="8" Height="8"
               Stroke="Black"
               />
    </DataTemplate>
  </ch:BarSeries.LegendIconTemplate>
</ch:BarSeries>

Title Display Options

To display a title on a chart, set the Title property. The title is displayed centred at the top of the chart control, above the chart itself.

To customize the display of the title, set the TitleTemplate property. The data context of the template is the title text.

CopyXML
<ch:Chart Title="Bar Chart" Width="600" Height="400">
  <ch:Chart.TitleTemplate>
    <DataTemplate>
      <Border BorderBrush="Red" BorderThickness="2"
              CornerRadius="8" Padding="16"
              Background="LightCoral">
        <TextBlock Text="{Binding}" FontSize="48"
                   TextAlignment="Center"
                   />
      </Border>
    </DataTemplate>
  </ch:Chart.TitleTemplate>
</ch:Chart>


Data Labelling Options

Data Labelling Options

In Phone Elements, you can label data items on your chart to help your users understand the data or provide more detail than they can obtain by eye.

For information about labels on the chart axes, see Axis Display Options.

Data label options vary depending on the type of data series. For example, BubbleSeries does not support data labels at all, and BarSeries does not support data label lines.

Showing Data Labels

In order to keep charts clean and unclutters, Phone Elements does not show data labels by default. To show data labels for a data series, set the ShowDataLabels property:

CopyLabelling points in a LineSeries
<ch:LineSeries ItemsSource="{Binding}"
               XBinding="{Binding Quarter}"
               YBinding="{Binding Amount}"
               ShowDataLabels="True"
               />

To draw a line from each label to the data point it identifies, set the ShowDataLabelLines property.

Customizing Data Label Appearance

Data labels are drawn by default as solid rectangles. They respect the SeriesBrush (and, for bar series, the Brushes collection).

To customize the appearance of data labels, use the DataLabelStyle property. The target type of the style should be DataLabel.

To change the appearance of the text, style properties such as Foreground, FontFamily and FontSize:

CopyCustomizing text properties of a data label
<ch:BarSeries SeriesBrush="Azure">
  <ch:BarSeries.DataLabelStyle>
    <Style TargetType="ch:DataLabel">
      <Setter Property="Foreground" Value="Black" />
      <Setter Property="FontStyle" Value="Italic" />
    </Style>
  </ch:BarSeries.DataLabelStyle>
</ch:BarSeries>

For more advanced customization, style the control Template property. To obtain the value being plotted, bind to the DataLabel.DependentData property.

CopyA custom label design
<ch:LineSeries>
  <ch:LineSeries.DataLabelStyle>
    <Style TargetType="ch:DataLabel">
      <Setter Property="Template">
        <Setter.Value>
          <ControlTemplate TargetType="ch:DataLabel">
            <Grid>
              <Path Data="M 10,0 L 40,0 A 10,10 180 1 1 40,20 L 10,20 A 10,10 180 1 1 10,0"
                    Fill="AliceBlue" Stroke="CadetBlue" />
              <TextBlock Text="{Binding DependentData, RelativeSource={RelativeSource TemplatedParent}}"
                         TextAlignment="Center" VerticalAlignment="Center"
                         Foreground="Black"
                         />
            </Grid>
          </ControlTemplate>
        </Setter.Value>
      </Setter>
    </Style>
  </ch:LineSeries.DataLabelStyle>
</ch:LineSeries>

If all you need to do is change the text color of the data label, style the Foreground property.


Zooming and Panning

Zooming and Panning

To enable zooming on a chart, set the Chart.ZoomMode property. You can constrain the user to zooming along only one axis (Horizontal or Vertical ZoomMode), or allow the user to zoom in on any part of the chart (Both ZoomMode).

CopyEnabling arbitrary zooming
<ch:Chart ZoomMode="Both" />

When zooming is enabled, users can zoom by pinching. Moving your fingers further apart zooms in. Moving your fingers closer together zooms out.

Once the chart is zoomed in, users can pan by dragging or flicking the chart.

Tick Marks and Zooming and Panning

The behavior of tick marks and labels on a chart axis during zooming and panning is determined by the TickMarkMode property of the ChartAxis.

If TickMarkMode is Stationary, then the tick marks and labels stay in the same place on the display, and the label values change as the user zooms and pans.

If TickMarkMode is Movable, then the tick marks and labels stay at the same values, and move along the axis as the user zooms and pans.

Programmatic Zooming and Panning

You can use the ChartAxis ActualMinimum and ActualMaximum properties to zoom in on a part of the range.


Selection and Interaction

Mindscape Silverlight Elements
Selection and Interaction

Selection and Highlighting

Selection and highlighting in Phone Elements charts are controlled by three properties.

The SelectionMode property at the chart level specifies how selection works across multiple data series. If Single (the default), then selecting data from one series removes the selection from any other series. If Multiple, then each series maintains its own selection, and selecting an item in one series does not affect the existing selection in any other series.

The SelectionMode property at the series level specifies which points should become selected when the user clicks on a data point in the series. If None (the default), then items are never selected. If Single, then only the clicked item is selected. If All, then all items in the series are selected when any one is clicked.

The HighlightMode property (at the series level) specifies what user actions should cause a data point to become ‘hot.’ If None (the default), then items are never hot. If ClosestXValue, items are hot when the user holds their finger on the chart close to their X coordinate.

Interaction Using Events

The Chart control also raises a set of ‘mouse’ events—ChartMouseLeftButtonDown, ChartMouseMove, etc. These events allow you to detect when user activity occurs within the chart itself—excluding the legend, title, etc.

Although there is no mouse on Windows Phone, the Mouse terminology is kept for consistency with the system UIElement class’ ‘mouse’ events, and with Silverlight Elements and WPF Elements.

The ChartMouseEventArgs event data allows you to get the data values (as opposed to the screen coordinates) via the ConstrainedLogicalPoint property.


Specify the Intervals on a Chart Axis

Mindscape Silverlight Elements
Specify the Intervals on a Chart Axis

To specify the intervals between tick marks on the axis of a Chart control, set the ChartAxis.MajorTickSpacing property:

CopySetting the interval on the Y axis
<ch:Chart Title="Bar Chart" Width="600" Height="400">
  <ch:Chart.YAxis>
    <ch:ChartAxis MajorTickSpacing="5000" />
  </ch:Chart.YAxis>
</ch:Chart>

To display minor tick marks between the major tick marks, set the ChartAxis.MinorTickMarkVisibility property. If displayed, there are always 4 minor tick marks between each major tick mark.


Change Colours on a Chart

Mindscape Silverlight Elements
Change Colours on a Chart

Use the SeriesBrush property to specify the brush to be used for drawing the data series:

CopyDisplaying multiple data sets with different brushes
<ch:Chart>
  <ch:LineSeries ItemsSource="{Binding PredictedSales}" SeriesBrush="Navy" />
</ch:Chart>

SeriesBrush is a per-series property so you can use different brushes for different data sets.

Some series types have additional styling properties which you can use to further customize the appearance of the chart. For example, line and area series have a LineStyle property which you can use to style all aspects of the Path object used to render the line, such as options for width, mitering and dash style. BarSeries has a Brushes property which you can use to apply different brushes to the bars in the same series.


Display Multiple Data Sets on a Chart

Mindscape Silverlight Elements
Display Multiple Data Sets on a Chart

Create a data series for each data set you want to display and add it to the Chart control’s Series collection:

CopyDisplaying multiple data sets on a chart
<ch:Chart>
  <ch:LineSeries ItemsSource="{Binding PredictedSales}" />
  <ch:LineSeries ItemsSource="{Binding ActualSales}" />
</ch:Chart>

To customize the color of each data set, use the SeriesBrush property:

CopyDisplaying multiple data sets with different brushes
<ch:Chart>
  <ch:LineSeries ItemsSource="{Binding PredictedSales}" SeriesBrush="Navy" />
  <ch:LineSeries ItemsSource="{Binding ActualSales}" SeriesBrush="Red" />
</ch:Chart>

Additional customization is possible through series-specific style properties. For example, to customize line widths in a line or area series, use LineStyle.

To display data series stacked on top of one another instead of overlaid or placed side by side, use a stacked series such as StackedAreaSeries.


Show Different Colours for Different Data Values

Mindscape Silverlight Elements
Show Different Colours for Different Data Values

You can use a binding and a value converter in a style to change the color (and other aspects of the appearance) of a data element according to the data values—for example, to color bars on a bar chart according to the range band that they fall into.

For an example of how to do this, see Styling Charts.


Create a Stacked Graph

Mindscape Silverlight Elements
Create a Stacked Graph

Use one of the following series types:

  • StackedAreaSeries
  • StackedBarSeries
  • StackedLineSeries
  • StackedSplineAreaSeries
  • StackedSplineSeries

See also Stacked Charts.


Create a Chart With a Logarithmic Scale

Mindscape Silverlight Elements
Create a Chart With a Logarithmic Scale

Create a LogarithmicAxisValueConverter, and set the ChartAxis.ValueConverter of the axis that you want to have the log scale to this converter:

CopyLog scaling the Y axis
<ch:Chart>
<ch:Chart.Resources>
  <ch:LogarithmicAxisValueConverter x:Key="LogScale" Base="10" />
</ch:Chart.Resources>
<ch:Chart.YAxis>
  <ch:ChartAxis ValueConverter="{StaticResource LogScale}" />
</ch:Chart.YAxis>
</ch:Chart>

Tick mark spacing is expressed in terms of post-conversion coordinates. Therefore, to have tick marks appear at every factor of the log base (e.g. every factor of 10), specify a tick mark interval of 1.


Create Great Visual Effects

Mindscape Silverlight Elements
Create Great Visual Effects

Phone Elements charting controls allow you to apply all sorts of cool visual effects to your charts through Silverlight’s templating and styling system.

The PhoneElementsSampleExplorer sample contains examples of attractive chart designs which you can adapt and modify for your own applications.


Mindscape.PhoneElements Namespace

[image]

Mindscape Phone Elements
Mindscape.PhoneElements Namespace
Send Feedback
The Mindscape.PhoneElements namespace contains the Phone Elements controls and supporting classes.

Classes

 | Class | Description
Public class | BooleanToThicknessConverter | Selects a Thickness according to a boolean value.
Public class | BooleanToVisibilityConverter | Converts a Boolean value to a visibility.
Public class | Clip | A helper class for allowing a visual element to clip its content using a rectangular bounds.
Public class | ColorChannelAdjustmentBrushConverter | Converts a color or solid brush to a gradient brush showing the effects of adjusting one channel on that color. This is used for displaying mixer channels in a ColorPicker template.
Public class | ColorChannelToTemplateConverter | Selects a ControlTemplate for the RepeatButton part of a channel mixer in a CustomColorPicker control.
Public class | ColorPicker | Allows the user to select a Color.
Public class | ColorPickerPage | A color picker page containing a list of NamedColor objects.
Public class | ColorPickerPageBase | A base class for a PhoneApplicationPage that can be opened by a ColorPicker.
Public class | ColorToSolidColorBrushConverter | Converts a Color to a SolidColorBrush.
Public class | CustomColorPicker | A control that displays a slider for each color channel allowing the user to create a custom color.
Public class | CustomColorPickerPage | A color picker page containing a CustomColorPicker()()()().
Public class | DatePicker | Allows the user to select a DateTime object.
Public class | DatePickerPage | The standard page that can be opened by a DatePicker.
Public class | DateTimeWrapper | A wrapper class for a DateTime object. This helps obtain culture dependent information from the DateTime.
Public class | DayOfMonthDataSource | A looping data source that loops through the days of the current month. This looping data source uses DateTimeWrapper objects.
Public class | DockPanel | A panel that arranges its children against its edges.
Public class | DragCompletedGestureEventArgs | Contains event data for the drag completed gesture.
Public class | DragDeltaGestureEventArgs | Contains event data for the drag delta gesture.
Public class | DragStartedGestureEventArgs | Contains event data for the drag started gesture.
Public class | DualGestureEventArgs | A base class for gesture event args that manage 2 touch points.
Public class | FlickGestureEventArgs | Contains event data related to the flick gesture.
Public class | FormattingConverter | Formats a binding source value using a format string.
Public class | GestureEventArgs | A base class for event args containing data for gestures.
Public class | GestureListener | Raises gesture events for a UIElement.
Public class | HeaderedItemsControl | A simple HeaderedItemsControl implementation.
Public class | ListToSubListConverter | Extracts a sub-list from a master list.
Public class | LoopingListBox | A control that loops through a data source allowing a user to select an item.
Public class | LoopingListBoxItem | Displays a single data item in a LoopingListBox control.
Public class | MonthOfYearDataSource | A looping data source that loops through the 12 months of a year. This looping data source uses DateTimeWrapper objects.
Public class | MovingGestureEventArgs | A base class for gesture event args that suggest some kind of movement.
Public class | NamedColor | Maps a Color to a name.
Public class | NotifyingColor | Encapsulates a Color and provides notification of changes to individual channels in order to support Silverlight data binding.
Public class | NumericDataSource | A looping data source that loops through a sequence of consecutive numbers.
Public class | ObjectDataSource | A looping data source the loops through a sequence of objects.
Public class | PaletteColorPicker | A control that display a color palette allowing the user to select a Color.
Public class | PaletteColorPickerPage | A color picker page containing a PaletteColorPicker.
Public class | PickerBase | A base class for picker controls that open up a page containg the picker UI.
Public class | PinchGestureEventArgs | Contains event data related to the PinchStarted, PinchDelta and PinchCompleted gestures.
Public class | StandardPalettes | Provides standard color palettes.
Public class | ThicknessToDoubleConverter | Converts a Thickness into a double. This is useful for binding a BorderThickness property to a StrokeThickness property.
Public class | TimePicker | Allows the user to select a time of day.
Public class | TimePickerPage | The standard page that can be opened by a TimePicker.
Public class | ViewModelBase | Provides property change notification servics for view model objects.
Public class | YearlyDataSource | A data source that lists a sequence of consecutive years from 1601 to 3000. This data source uses DateTimeWrapper objects. This data source does not loop through the sequence.

Structures

 | Structure | Description
Public structure | TimeOfDay | Represents a time of day.

Interfaces

 | Interface | Description
Public interface | IDataSource | Aids in virtualisation for a sequential list of data.
Public interface | IDatePickerPage | Represents a PhoneApplicationPage that can be opened by a DatePicker control.
Public interface | ITimePickerPage | Represents a PhoneApplicationPage that can be opened by a TimePicker control.

Enumerations

 | Enumeration | Description
Public enumeration | ColorChannel | Represents one of the four channels of a Color.
Public enumeration | ColorPickerMode | Defines which UI a ColorPicker should use for selecting a color.
Public enumeration | Dock | Specifies the edge of a DockPanel in which to arrange an element.
Public enumeration | FlickDirection | Defines the direction of movement for a flick gesture.
Public enumeration | TimeDisplayMode | Specifies how to visualy display time.


BooleanToThicknessConverter Class

[image]

Mindscape Phone Elements
BooleanToThicknessConverter Class
Members See Also Send Feedback
Selects a Thickness according to a boolean value.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BooleanToThicknessConverter : IValueConverter
Visual Basic
Public Class BooleanToThicknessConverter _
    Implements IValueConverter
Visual C++
public ref class BooleanToThicknessConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..BooleanToThicknessConverter

See Also

BooleanToThicknessConverter Members
Mindscape.PhoneElements Namespace


BooleanToThicknessConverter Members

[image] [image]

Mindscape Phone Elements
BooleanToThicknessConverter Members
BooleanToThicknessConverter Class Constructors Methods Properties See Also Send Feedback

The BooleanToThicknessConverter type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanToThicknessConverter | Initializes a new instance of the BooleanToThicknessConverter class

Methods

 | Name | Description
Public method | Convert | Selects a Thickness according to whether the input is true or false.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FalseThickness | The Thickness to select when the source value is false.
Public property | TrueThickness | The Thickness to select when the source value is true.

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


BooleanToThicknessConverter Constructor

[image]

Mindscape Phone Elements
BooleanToThicknessConverter Constructor
BooleanToThicknessConverter Class See Also Send Feedback
Initializes a new instance of the BooleanToThicknessConverter class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BooleanToThicknessConverter()
Visual Basic
Public Sub New
Visual C++
public:
BooleanToThicknessConverter()

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


BooleanToThicknessConverter Methods

[image] [image]

Mindscape Phone Elements
BooleanToThicknessConverter Methods
BooleanToThicknessConverter Class See Also Send Feedback

The BooleanToThicknessConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Selects a Thickness according to whether the input is true or false.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
BooleanToThicknessConverter..::..Convert Method
BooleanToThicknessConverter Class See Also Send Feedback
Selects a Thickness according to whether the input is true or false.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The selected Thickness.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
BooleanToThicknessConverter..::..ConvertBack Method
BooleanToThicknessConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


BooleanToThicknessConverter Properties

[image] [image]

Mindscape Phone Elements
BooleanToThicknessConverter Properties
BooleanToThicknessConverter Class See Also Send Feedback

The BooleanToThicknessConverter type exposes the following members.

Properties

 | Name | Description
Public property | FalseThickness | The Thickness to select when the source value is false.
Public property | TrueThickness | The Thickness to select when the source value is true.

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


FalseThickness Property

[image]

Mindscape Phone Elements
BooleanToThicknessConverter..::..FalseThickness Property
BooleanToThicknessConverter Class See Also Send Feedback
The Thickness to select when the source value is false.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Thickness FalseThickness { get; set; }
Visual Basic
Public Property FalseThickness As Thickness
    Get
    Set
Visual C++
public:
property Thickness FalseThickness {
    Thickness get ();
    void set (Thickness value);
}

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


TrueThickness Property

[image]

Mindscape Phone Elements
BooleanToThicknessConverter..::..TrueThickness Property
BooleanToThicknessConverter Class See Also Send Feedback
The Thickness to select when the source value is true.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Thickness TrueThickness { get; set; }
Visual Basic
Public Property TrueThickness As Thickness
    Get
    Set
Visual C++
public:
property Thickness TrueThickness {
    Thickness get ();
    void set (Thickness value);
}

See Also

BooleanToThicknessConverter Class
Mindscape.PhoneElements Namespace


BooleanToVisibilityConverter Class

[image]

Mindscape Phone Elements
BooleanToVisibilityConverter Class
Members See Also Send Feedback
Converts a Boolean value to a visibility.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BooleanToVisibilityConverter : IValueConverter
Visual Basic
Public Class BooleanToVisibilityConverter _
    Implements IValueConverter
Visual C++
public ref class BooleanToVisibilityConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..BooleanToVisibilityConverter

See Also

BooleanToVisibilityConverter Members
Mindscape.PhoneElements Namespace


BooleanToVisibilityConverter Members

[image] [image]

Mindscape Phone Elements
BooleanToVisibilityConverter Members
BooleanToVisibilityConverter Class Constructors Methods Properties See Also Send Feedback

The BooleanToVisibilityConverter type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanToVisibilityConverter | Initializes a new instance of the BooleanToVisibilityConverter class

Methods

 | Name | Description
Public method | Convert | Converts a Boolean value from a binding source for use as a Visibility by a binding target.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsInverted | Gets or sets whether the normal visibility logic should be inverted. If IsInverted is false (the default), true is converted to Visible and false to Collapsed. If IsInverted is true, true is converted to Collapsed and false to Visible.

See Also

BooleanToVisibilityConverter Class
Mindscape.PhoneElements Namespace


BooleanToVisibilityConverter Constructor

[image]

Mindscape Phone Elements
BooleanToVisibilityConverter Constructor
BooleanToVisibilityConverter Class See Also Send Feedback
Initializes a new instance of the BooleanToVisibilityConverter class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BooleanToVisibilityConverter()
Visual Basic
Public Sub New
Visual C++
public:
BooleanToVisibilityConverter()

See Also

BooleanToVisibilityConverter Class
Mindscape.PhoneElements Namespace


BooleanToVisibilityConverter Methods

[image] [image]

Mindscape Phone Elements
BooleanToVisibilityConverter Methods
BooleanToVisibilityConverter Class See Also Send Feedback

The BooleanToVisibilityConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a Boolean value from a binding source for use as a Visibility by a binding target.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToVisibilityConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
BooleanToVisibilityConverter..::..Convert Method
BooleanToVisibilityConverter Class See Also Send Feedback
Converts a Boolean value from a binding source for use as a Visibility by a binding target.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToVisibilityConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
BooleanToVisibilityConverter..::..ConvertBack Method
BooleanToVisibilityConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToVisibilityConverter Class
Mindscape.PhoneElements Namespace


BooleanToVisibilityConverter Properties

[image] [image]

Mindscape Phone Elements
BooleanToVisibilityConverter Properties
BooleanToVisibilityConverter Class See Also Send Feedback

The BooleanToVisibilityConverter type exposes the following members.

Properties

 | Name | Description
Public property | IsInverted | Gets or sets whether the normal visibility logic should be inverted. If IsInverted is false (the default), true is converted to Visible and false to Collapsed. If IsInverted is true, true is converted to Collapsed and false to Visible.

See Also

BooleanToVisibilityConverter Class
Mindscape.PhoneElements Namespace


IsInverted Property

[image]

Mindscape Phone Elements
BooleanToVisibilityConverter..::..IsInverted Property
BooleanToVisibilityConverter Class See Also Send Feedback
Gets or sets whether the normal visibility logic should be inverted. If IsInverted is false (the default), true is converted to Visible and false to Collapsed. If IsInverted is true, true is converted to Collapsed and false to Visible.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInverted { get; set; }
Visual Basic
Public Property IsInverted As Boolean
    Get
    Set
Visual C++
public:
property bool IsInverted {
    bool get ();
    void set (bool value);
}

See Also

BooleanToVisibilityConverter Class
Mindscape.PhoneElements Namespace


Clip Class

[image]

Mindscape Phone Elements
Clip Class
Members See Also Send Feedback
A helper class for allowing a visual element to clip its content using a rectangular bounds.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class Clip
Visual Basic
Public NotInheritable Class Clip
Visual C++
public ref class Clip abstract sealed

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..Clip

See Also

Clip Members
Mindscape.PhoneElements Namespace


Clip Members

[image] [image]

Mindscape Phone Elements
Clip Members
Clip Class Methods Fields Attached Properties See Also Send Feedback

The Clip type exposes the following members.

Methods

Name | Description
GetClipToBounds | Gets the ClipToBounds property value for the given DependencyObject.
SetClipToBounds | Sets the ClipToBounds property value for the given DependencyObject.

Fields

Name | Description
ClipToBoundsProperty | Identifies the ClipToBounds attached property.

Attached Properties

 | Name | Description
Public attached property | ClipToBounds | If set to True on an element, specifies that the element should be clipped to its bounds.

See Also

Clip Class
Mindscape.PhoneElements Namespace


Clip Fields

[image] [image]

Mindscape Phone Elements
Clip Fields
Clip Class See Also Send Feedback

The Clip type exposes the following members.

Fields

Name | Description
ClipToBoundsProperty | Identifies the ClipToBounds attached property.

See Also

Clip Class
Mindscape.PhoneElements Namespace


ClipToBoundsProperty Field

[image]

Mindscape Phone Elements
Clip..::..ClipToBoundsProperty Field
Clip Class See Also Send Feedback
Identifies the ClipToBounds attached property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ClipToBoundsProperty
Visual Basic
Public Shared ReadOnly ClipToBoundsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ClipToBoundsProperty

See Also

Clip Class
Mindscape.PhoneElements Namespace


Clip Methods

[image] [image]

Mindscape Phone Elements
Clip Methods
Clip Class See Also Send Feedback

The Clip type exposes the following members.

Methods

Name | Description
GetClipToBounds | Gets the ClipToBounds property value for the given DependencyObject.
SetClipToBounds | Sets the ClipToBounds property value for the given DependencyObject.

See Also

Clip Class
Mindscape.PhoneElements Namespace


GetClipToBounds Method

[image]

Mindscape Phone Elements
Clip..::..GetClipToBounds Method
Clip Class See Also Send Feedback
Gets the ClipToBounds property value for the given DependencyObject.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool GetClipToBounds(
    DependencyObject o
)
Visual Basic
Public Shared Function GetClipToBounds ( _
    o As DependencyObject _
) As Boolean
Visual C++
public:
static bool GetClipToBounds(
    DependencyObject^ o
)

Parameters

o
Type: System.Windows..::..DependencyObject
The DependencyObject to get the property value from.

Return Value

Whether or not the visual element should clip to bounds.

See Also

Clip Class
Mindscape.PhoneElements Namespace


SetClipToBounds Method

[image]

Mindscape Phone Elements
Clip..::..SetClipToBounds Method
Clip Class See Also Send Feedback
Sets the ClipToBounds property value for the given DependencyObject.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetClipToBounds(
    DependencyObject o,
    bool clipToBounds
)
Visual Basic
Public Shared Sub SetClipToBounds ( _
    o As DependencyObject, _
    clipToBounds As Boolean _
)
Visual C++
public:
static void SetClipToBounds(
    DependencyObject^ o,
    bool clipToBounds
)

Parameters

o
Type: System.Windows..::..DependencyObject
The DependencyObject to set the property value.
clipToBounds
Type: System..::..Boolean
Whether or not the visual element should clip to bounds.

See Also

Clip Class
Mindscape.PhoneElements Namespace


Clip Attached Properties

[image] [image]

Mindscape Phone Elements
Clip Attached Properties
Clip Class See Also Send Feedback

The Clip type exposes the following members.

Attached Properties

 | Name | Description
Public attached property | ClipToBounds | If set to True on an element, specifies that the element should be clipped to its bounds.

See Also

Clip Class
Mindscape.PhoneElements Namespace


ClipToBounds Attached Property

[image]

Mindscape Phone Elements
Clip..::..ClipToBounds Attached Property
Clip Class See Also Send Feedback
If set to True on an element, specifies that the element should be clipped to its bounds.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
See GetClipToBounds, SetClipToBounds
Visual Basic
See GetClipToBounds, SetClipToBounds
Visual C++
See GetClipToBounds, SetClipToBounds

See Also

Clip Class
Mindscape.PhoneElements Namespace


ColorChannel Enumeration

[image]

Mindscape Phone Elements
ColorChannel Enumeration
See Also Send Feedback
Represents one of the four channels of a Color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ColorChannel
Visual Basic
Public Enumeration ColorChannel
Visual C++
public enum class ColorChannel

Members

Member name | Value | Description
Alpha | 0 | The alpha channel.
Red | 1 | The red channel.
Green | 2 | The green channel.
Blue | 3 | The blue channel.

See Also

Mindscape.PhoneElements Namespace


ColorChannelAdjustmentBrushConverter Class

[image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter Class
Members See Also Send Feedback
Converts a color or solid brush to a gradient brush showing the effects of adjusting one channel on that color. This is used for displaying mixer channels in a ColorPicker template.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorChannelAdjustmentBrushConverter : IValueConverter
Visual Basic
Public Class ColorChannelAdjustmentBrushConverter _
    Implements IValueConverter
Visual C++
public ref class ColorChannelAdjustmentBrushConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ColorChannelAdjustmentBrushConverter

See Also

ColorChannelAdjustmentBrushConverter Members
Mindscape.PhoneElements Namespace


ColorChannelAdjustmentBrushConverter Members

[image] [image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter Members
ColorChannelAdjustmentBrushConverter Class Constructors Methods Properties See Also Send Feedback

The ColorChannelAdjustmentBrushConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ColorChannelAdjustmentBrushConverter | Initializes a new instance of the ColorChannelAdjustmentBrushConverter class

Methods

 | Name | Description
Public method | Convert | Converts a solid color to a gradient brush.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Channel | Gets or sets the channel that is affected by this ColorChannelAdjustmentBrushConverter.

See Also

ColorChannelAdjustmentBrushConverter Class
Mindscape.PhoneElements Namespace


ColorChannelAdjustmentBrushConverter Constructor

[image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter Constructor
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Initializes a new instance of the ColorChannelAdjustmentBrushConverter class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorChannelAdjustmentBrushConverter()
Visual Basic
Public Sub New
Visual C++
public:
ColorChannelAdjustmentBrushConverter()

See Also

ColorChannelAdjustmentBrushConverter Class
Mindscape.PhoneElements Namespace


ColorChannelAdjustmentBrushConverter Methods

[image] [image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter Methods
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback

The ColorChannelAdjustmentBrushConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a solid color to a gradient brush.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorChannelAdjustmentBrushConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter..::..Convert Method
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Converts a solid color to a gradient brush.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The Color or SolidColorBrush value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The value to which to set the specified Channel. This value must be convertible to Byte.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A gradient brush from the original to the adjusted color.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ColorChannelAdjustmentBrushConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter..::..ConvertBack Method
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ColorChannelAdjustmentBrushConverter Class
Mindscape.PhoneElements Namespace


ColorChannelAdjustmentBrushConverter Properties

[image] [image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter Properties
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback

The ColorChannelAdjustmentBrushConverter type exposes the following members.

Properties

 | Name | Description
Public property | Channel | Gets or sets the channel that is affected by this ColorChannelAdjustmentBrushConverter.

See Also

ColorChannelAdjustmentBrushConverter Class
Mindscape.PhoneElements Namespace


Channel Property

[image]

Mindscape Phone Elements
ColorChannelAdjustmentBrushConverter..::..Channel Property
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Gets or sets the channel that is affected by this ColorChannelAdjustmentBrushConverter.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorChannel Channel { get; set; }
Visual Basic
Public Property Channel As ColorChannel
    Get
    Set
Visual C++
public:
property ColorChannel Channel {
    ColorChannel get ();
    void set (ColorChannel value);
}

See Also

ColorChannelAdjustmentBrushConverter Class
Mindscape.PhoneElements Namespace


ColorChannelToTemplateConverter Class

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter Class
Members See Also Send Feedback
Selects a ControlTemplate for the RepeatButton part of a channel mixer in a CustomColorPicker control.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorChannelToTemplateConverter
Visual Basic
Public Class ColorChannelToTemplateConverter
Visual C++
public ref class ColorChannelToTemplateConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ColorChannelToTemplateConverter

See Also

ColorChannelToTemplateConverter Members
Mindscape.PhoneElements Namespace


ColorChannelToTemplateConverter Members

[image] [image]

Mindscape Phone Elements
ColorChannelToTemplateConverter Members
ColorChannelToTemplateConverter Class Constructors Methods Properties See Also Send Feedback

The ColorChannelToTemplateConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ColorChannelToTemplateConverter | Initializes a new instance of the ColorChannelToTemplateConverter class

Methods

 | Name | Description
Public method | Convert | Selects a ControlTemplate according to a ColorChannel value.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlphaTemplate | The template for alpha channel repeat buttons.
Public property | BlueTemplate | The template for blue channel repeat buttons.
Public property | GreenTemplate | The template for green channel repeat buttons.
Public property | RedTemplate | The template for red channel repeat buttons.

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


ColorChannelToTemplateConverter Constructor

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter Constructor
ColorChannelToTemplateConverter Class See Also Send Feedback
Initializes a new instance of the ColorChannelToTemplateConverter class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorChannelToTemplateConverter()
Visual Basic
Public Sub New
Visual C++
public:
ColorChannelToTemplateConverter()

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


ColorChannelToTemplateConverter Methods

[image] [image]

Mindscape Phone Elements
ColorChannelToTemplateConverter Methods
ColorChannelToTemplateConverter Class See Also Send Feedback

The ColorChannelToTemplateConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Selects a ControlTemplate according to a ColorChannel value.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter..::..Convert Method
ColorChannelToTemplateConverter Class See Also Send Feedback
Selects a ControlTemplate according to a ColorChannel value.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
)

Parameters

value
Type: System..::..Object
The ColorChannel value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The selected ControlTemplate.

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter..::..ConvertBack Method
ColorChannelToTemplateConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
)

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


ColorChannelToTemplateConverter Properties

[image] [image]

Mindscape Phone Elements
ColorChannelToTemplateConverter Properties
ColorChannelToTemplateConverter Class See Also Send Feedback

The ColorChannelToTemplateConverter type exposes the following members.

Properties

 | Name | Description
Public property | AlphaTemplate | The template for alpha channel repeat buttons.
Public property | BlueTemplate | The template for blue channel repeat buttons.
Public property | GreenTemplate | The template for green channel repeat buttons.
Public property | RedTemplate | The template for red channel repeat buttons.

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


AlphaTemplate Property

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter..::..AlphaTemplate Property
ColorChannelToTemplateConverter Class See Also Send Feedback
The template for alpha channel repeat buttons.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate AlphaTemplate { get; set; }
Visual Basic
Public Property AlphaTemplate As ControlTemplate
    Get
    Set
Visual C++
public:
property ControlTemplate^ AlphaTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


BlueTemplate Property

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter..::..BlueTemplate Property
ColorChannelToTemplateConverter Class See Also Send Feedback
The template for blue channel repeat buttons.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate BlueTemplate { get; set; }
Visual Basic
Public Property BlueTemplate As ControlTemplate
    Get
    Set
Visual C++
public:
property ControlTemplate^ BlueTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


GreenTemplate Property

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter..::..GreenTemplate Property
ColorChannelToTemplateConverter Class See Also Send Feedback
The template for green channel repeat buttons.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate GreenTemplate { get; set; }
Visual Basic
Public Property GreenTemplate As ControlTemplate
    Get
    Set
Visual C++
public:
property ControlTemplate^ GreenTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


RedTemplate Property

[image]

Mindscape Phone Elements
ColorChannelToTemplateConverter..::..RedTemplate Property
ColorChannelToTemplateConverter Class See Also Send Feedback
The template for red channel repeat buttons.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate RedTemplate { get; set; }
Visual Basic
Public Property RedTemplate As ControlTemplate
    Get
    Set
Visual C++
public:
property ControlTemplate^ RedTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorChannelToTemplateConverter Class
Mindscape.PhoneElements Namespace


ColorPicker Class

[image]

Mindscape Phone Elements
ColorPicker Class
Members See Also Send Feedback
Allows the user to select a Color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorPicker : PickerBase
Visual Basic
Public Class ColorPicker _
    Inherits PickerBase
Visual C++
public ref class ColorPicker : public PickerBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements..::..PickerBase
Mindscape.PhoneElements..::..ColorPicker

See Also

ColorPicker Members
Mindscape.PhoneElements Namespace


ColorPicker Members

[image] [image]

Mindscape Phone Elements
ColorPicker Members
ColorPicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The ColorPicker type exposes the following members.

Constructors

 | Name | Description
Public method | ColorPicker | Initializes a new instance of the ColorPicker class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page. (Inherited from PickerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application fame is navigated. (Overrides PickerBase..::..FrameNavigated(Object).)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Inherited from PickerBase.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from PickerBase.)
Protected method | PickerPageClosed | Called when the page is closed. (Overrides PickerBase..::..PickerPageClosed()()()().)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
ColorPickerModeProperty | Identifies the ColorPickerMode property.
NamedColorsProperty | Identifies the NamedColors property.
PaletteProperty | Identifies the Palette property.
SelectedColorNameProperty | Identifies the SelectedColorName property.
SelectedColorProperty | Identifies the SelectedColor property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPickerMode | Gets or sets the ColorPickerMode used to select a UI for picking colors. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NamedColors | Gets or sets a list of NamedColor objects. This is a dependency property.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Palette | Gets or sets the color palette. This is a dependency property.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property. (Inherited from PickerBase.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedColor | Gets or sets the currently selected Color. This is a dependency property.
Public property | SelectedColorName | Gets or sets the name of the selected Color. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes. (Inherited from PickerBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPicker Constructor

[image]

Mindscape Phone Elements
ColorPicker Constructor
ColorPicker Class See Also Send Feedback
Initializes a new instance of the ColorPicker class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPicker()
Visual Basic
Public Sub New
Visual C++
public:
ColorPicker()

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPicker Fields

[image] [image]

Mindscape Phone Elements
ColorPicker Fields
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Fields

Name | Description
ColorPickerModeProperty | Identifies the ColorPickerMode property.
NamedColorsProperty | Identifies the NamedColors property.
PaletteProperty | Identifies the Palette property.
SelectedColorNameProperty | Identifies the SelectedColorName property.
SelectedColorProperty | Identifies the SelectedColor property.

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPickerModeProperty Field

[image]

Mindscape Phone Elements
ColorPicker..::..ColorPickerModeProperty Field
ColorPicker Class See Also Send Feedback
Identifies the ColorPickerMode property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColorPickerModeProperty
Visual Basic
Public Shared ReadOnly ColorPickerModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColorPickerModeProperty

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


NamedColorsProperty Field

[image]

Mindscape Phone Elements
ColorPicker..::..NamedColorsProperty Field
ColorPicker Class See Also Send Feedback
Identifies the NamedColors property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty NamedColorsProperty
Visual Basic
Public Shared ReadOnly NamedColorsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NamedColorsProperty

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


PaletteProperty Field

[image]

Mindscape Phone Elements
ColorPicker..::..PaletteProperty Field
ColorPicker Class See Also Send Feedback
Identifies the Palette property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty PaletteProperty
Visual Basic
Public Shared ReadOnly PaletteProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PaletteProperty

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


SelectedColorNameProperty Field

[image]

Mindscape Phone Elements
ColorPicker..::..SelectedColorNameProperty Field
ColorPicker Class See Also Send Feedback
Identifies the SelectedColorName property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedColorNameProperty
Visual Basic
Public Shared ReadOnly SelectedColorNameProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedColorNameProperty

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


SelectedColorProperty Field

[image]

Mindscape Phone Elements
ColorPicker..::..SelectedColorProperty Field
ColorPicker Class See Also Send Feedback
Identifies the SelectedColor property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedColorProperty
Visual Basic
Public Shared ReadOnly SelectedColorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedColorProperty

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPicker Methods

[image] [image]

Mindscape Phone Elements
ColorPicker Methods
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page. (Inherited from PickerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application fame is navigated. (Overrides PickerBase..::..FrameNavigated(Object).)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Inherited from PickerBase.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from PickerBase.)
Protected method | PickerPageClosed | Called when the page is closed. (Overrides PickerBase..::..PickerPageClosed()()()().)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


FrameNavigated Method

[image]

Mindscape Phone Elements
ColorPicker..::..FrameNavigated Method
ColorPicker Class See Also Send Feedback
Called when the application fame is navigated.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void FrameNavigated(
    Object content
)
Visual Basic
Protected Overrides Sub FrameNavigated ( _
    content As Object _
)
Visual C++
protected:
virtual void FrameNavigated(
    Object^ content
) override

Parameters

content
Type: System..::..Object
The current content of the application frame.

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


PickerPageClosed Method

[image]

Mindscape Phone Elements
ColorPicker..::..PickerPageClosed Method
ColorPicker Class See Also Send Feedback
Called when the page is closed.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void PickerPageClosed()
Visual Basic
Protected Overrides Sub PickerPageClosed
Visual C++
protected:
virtual void PickerPageClosed() override

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPicker Properties

[image] [image]

Mindscape Phone Elements
ColorPicker Properties
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPickerMode | Gets or sets the ColorPickerMode used to select a UI for picking colors. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NamedColors | Gets or sets a list of NamedColor objects. This is a dependency property.
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Palette | Gets or sets the color palette. This is a dependency property.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property. (Inherited from PickerBase.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedColor | Gets or sets the currently selected Color. This is a dependency property.
Public property | SelectedColorName | Gets or sets the name of the selected Color. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPickerMode Property

[image]

Mindscape Phone Elements
ColorPicker..::..ColorPickerMode Property
ColorPicker Class See Also Send Feedback
Gets or sets the ColorPickerMode used to select a UI for picking colors. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPickerMode ColorPickerMode { get; set; }
Visual Basic
Public Property ColorPickerMode As ColorPickerMode
    Get
    Set
Visual C++
public:
property ColorPickerMode ColorPickerMode {
    ColorPickerMode get ();
    void set (ColorPickerMode value);
}

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


NamedColors Property

[image]

Mindscape Phone Elements
ColorPicker..::..NamedColors Property
ColorPicker Class See Also Send Feedback
Gets or sets a list of NamedColor objects. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<NamedColor> NamedColors { get; set; }
Visual Basic
Public Property NamedColors As ReadOnlyCollection(Of NamedColor)
    Get
    Set
Visual C++
public:
property ReadOnlyCollection<NamedColor^>^ NamedColors {
    ReadOnlyCollection<NamedColor^>^ get ();
    void set (ReadOnlyCollection<NamedColor^>^ value);
}

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


Palette Property

[image]

Mindscape Phone Elements
ColorPicker..::..Palette Property
ColorPicker Class See Also Send Feedback
Gets or sets the color palette. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<NamedColor> Palette { get; set; }
Visual Basic
Public Property Palette As ReadOnlyCollection(Of NamedColor)
    Get
    Set
Visual C++
public:
property ReadOnlyCollection<NamedColor^>^ Palette {
    ReadOnlyCollection<NamedColor^>^ get ();
    void set (ReadOnlyCollection<NamedColor^>^ value);
}

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


SelectedColor Property

[image]

Mindscape Phone Elements
ColorPicker..::..SelectedColor Property
ColorPicker Class See Also Send Feedback
Gets or sets the currently selected Color. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color SelectedColor { get; set; }
Visual Basic
Public Property SelectedColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


SelectedColorName Property

[image]

Mindscape Phone Elements
ColorPicker..::..SelectedColorName Property
ColorPicker Class See Also Send Feedback
Gets or sets the name of the selected Color. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SelectedColorName { get; set; }
Visual Basic
Public Property SelectedColorName As String
    Get
    Set
Visual C++
public:
property String^ SelectedColorName {
    String^ get ();
    void set (String^ value);
}

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPicker Events

[image] [image]

Mindscape Phone Elements
ColorPicker Events
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes. (Inherited from PickerBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ColorPicker Class
Mindscape.PhoneElements Namespace


ColorPickerMode Enumeration

[image]

Mindscape Phone Elements
ColorPickerMode Enumeration
See Also Send Feedback
Defines which UI a ColorPicker should use for selecting a color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ColorPickerMode
Visual Basic
Public Enumeration ColorPickerMode
Visual C++
public enum class ColorPickerMode

Members

Member name | Value | Description
Standard | 0 | The ColorPicker displays a list of named colors for the user to choose from.
Mixer | 1 | The ColorPicker displays Alpha, Red, Green and Blue color channel sliders for customizing a selected color.
Palette | 2 | The ColorPicker displays a palette of colors for the user to choose from.
Custom | 3 | The ColorPicker uses the PickerPageUri property to find a custom UI for picking colors.

See Also

Mindscape.PhoneElements Namespace


ColorPickerPage Class

[image]

Mindscape Phone Elements
ColorPickerPage Class
Members See Also Send Feedback
A color picker page containing a list of NamedColor objects.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorPickerPage : ColorPickerPageBase
Visual Basic
Public Class ColorPickerPage _
    Inherits ColorPickerPageBase
Visual C++
public ref class ColorPickerPage : public ColorPickerPageBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
System.Windows.Controls..::..Page
PhoneApplicationPage
Mindscape.PhoneElements..::..ColorPickerPageBase
Mindscape.PhoneElements..::..ColorPickerPage

See Also

ColorPickerPage Members
Mindscape.PhoneElements Namespace


ColorPickerPage Members

[image] [image]

Mindscape Phone Elements
ColorPickerPage Members
ColorPickerPage Class Constructors Methods Fields Properties Events See Also Send Feedback

The ColorPickerPage type exposes the following members.

Constructors

 | Name | Description
Public method | ColorPickerPage | Initializes a new instance of the ColorPickerPage class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes. (Overrides ColorPickerPageBase..::..OnColorPickerChanged()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
NamedColorsProperty | Identifies the NamedColors property.
SelectedColorProperty | Identifies the SelectedColor property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page. (Inherited from ColorPickerPageBase.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NamedColors | Gets or sets the list of NamedColor objects. This is a dependency property.
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedColor | Gets or sets the selected Color. This is a dependency property.
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property. (Inherited from ColorPickerPageBase.)
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


ColorPickerPage Constructor

[image]

Mindscape Phone Elements
ColorPickerPage Constructor
ColorPickerPage Class See Also Send Feedback
Initializes a new instance of the ColorPickerPage class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPickerPage()
Visual Basic
Public Sub New
Visual C++
public:
ColorPickerPage()

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


ColorPickerPage Fields

[image] [image]

Mindscape Phone Elements
ColorPickerPage Fields
ColorPickerPage Class See Also Send Feedback

The ColorPickerPage type exposes the following members.

Fields

Name | Description
NamedColorsProperty | Identifies the NamedColors property.
SelectedColorProperty | Identifies the SelectedColor property.

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


NamedColorsProperty Field

[image]

Mindscape Phone Elements
ColorPickerPage..::..NamedColorsProperty Field
ColorPickerPage Class See Also Send Feedback
Identifies the NamedColors property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty NamedColorsProperty
Visual Basic
Public Shared ReadOnly NamedColorsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NamedColorsProperty

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


SelectedColorProperty Field

[image]

Mindscape Phone Elements
ColorPickerPage..::..SelectedColorProperty Field
ColorPickerPage Class See Also Send Feedback
Identifies the SelectedColor property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedColorProperty
Visual Basic
Public Shared ReadOnly SelectedColorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedColorProperty

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


ColorPickerPage Methods

[image] [image]

Mindscape Phone Elements
ColorPickerPage Methods
ColorPickerPage Class See Also Send Feedback

The ColorPickerPage type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes. (Overrides ColorPickerPageBase..::..OnColorPickerChanged()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


InitializeComponent Method

[image]

Mindscape Phone Elements
ColorPickerPage..::..InitializeComponent Method
ColorPickerPage Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


OnColorPickerChanged Method

[image]

Mindscape Phone Elements
ColorPickerPage..::..OnColorPickerChanged Method
ColorPickerPage Class See Also Send Feedback
Called when the ColorPicker property changes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnColorPickerChanged()
Visual Basic
Protected Overrides Sub OnColorPickerChanged
Visual C++
protected:
virtual void OnColorPickerChanged() override

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


ColorPickerPage Properties

[image] [image]

Mindscape Phone Elements
ColorPickerPage Properties
ColorPickerPage Class See Also Send Feedback

The ColorPickerPage type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page. (Inherited from ColorPickerPageBase.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NamedColors | Gets or sets the list of NamedColor objects. This is a dependency property.
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedColor | Gets or sets the selected Color. This is a dependency property.
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property. (Inherited from ColorPickerPageBase.)
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


NamedColors Property

[image]

Mindscape Phone Elements
ColorPickerPage..::..NamedColors Property
ColorPickerPage Class See Also Send Feedback
Gets or sets the list of NamedColor objects. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<NamedColor> NamedColors { get; set; }
Visual Basic
Public Property NamedColors As ReadOnlyCollection(Of NamedColor)
    Get
    Set
Visual C++
public:
property ReadOnlyCollection<NamedColor^>^ NamedColors {
    ReadOnlyCollection<NamedColor^>^ get ();
    void set (ReadOnlyCollection<NamedColor^>^ value);
}

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


SelectedColor Property

[image]

Mindscape Phone Elements
ColorPickerPage..::..SelectedColor Property
ColorPickerPage Class See Also Send Feedback
Gets or sets the selected Color. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color SelectedColor { get; set; }
Visual Basic
Public Property SelectedColor As Color
    Get
    Set
Visual C++
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


ColorPickerPage Events

[image] [image]

Mindscape Phone Elements
ColorPickerPage Events
ColorPickerPage Class See Also Send Feedback

The ColorPickerPage type exposes the following members.

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ColorPickerPage Class
Mindscape.PhoneElements Namespace


ColorPickerPageBase Class

[image]

Mindscape Phone Elements
ColorPickerPageBase Class
Members See Also Send Feedback
A base class for a PhoneApplicationPage that can be opened by a ColorPicker.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ColorPickerPageBase : PhoneApplicationPage,
    IColorPickerPage
Visual Basic
Public MustInherit Class ColorPickerPageBase _
    Inherits PhoneApplicationPage _
    Implements IColorPickerPage
Visual C++
public ref class ColorPickerPageBase abstract : public PhoneApplicationPage,
    IColorPickerPage

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
System.Windows.Controls..::..Page
PhoneApplicationPage
Mindscape.PhoneElements..::..ColorPickerPageBase
Mindscape.PhoneElements..::..ColorPickerPage
Mindscape.PhoneElements..::..CustomColorPickerPage
Mindscape.PhoneElements..::..PaletteColorPickerPage

See Also

ColorPickerPageBase Members
Mindscape.PhoneElements Namespace


ColorPickerPageBase Members

[image] [image]

Mindscape Phone Elements
ColorPickerPageBase Members
ColorPickerPageBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The ColorPickerPageBase type exposes the following members.

Constructors

 | Name | Description
Protected method | ColorPickerPageBase | Initializes a new instance of the ColorPickerPageBase class

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes.
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
SelectedNamedColorProperty | Identifies the SelectedNamedColor property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page.
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property.
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


ColorPickerPageBase Constructor

[image]

Mindscape Phone Elements
ColorPickerPageBase Constructor
ColorPickerPageBase Class See Also Send Feedback
Initializes a new instance of the ColorPickerPageBase class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ColorPickerPageBase()
Visual Basic
Protected Sub New
Visual C++
protected:
ColorPickerPageBase()

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


ColorPickerPageBase Fields

[image] [image]

Mindscape Phone Elements
ColorPickerPageBase Fields
ColorPickerPageBase Class See Also Send Feedback

The ColorPickerPageBase type exposes the following members.

Fields

Name | Description
SelectedNamedColorProperty | Identifies the SelectedNamedColor property.

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


SelectedNamedColorProperty Field

[image]

Mindscape Phone Elements
ColorPickerPageBase..::..SelectedNamedColorProperty Field
ColorPickerPageBase Class See Also Send Feedback
Identifies the SelectedNamedColor property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedNamedColorProperty
Visual Basic
Public Shared ReadOnly SelectedNamedColorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedNamedColorProperty

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


ColorPickerPageBase Methods

[image] [image]

Mindscape Phone Elements
ColorPickerPageBase Methods
ColorPickerPageBase Class See Also Send Feedback

The ColorPickerPageBase type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes.
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


OnColorPickerChanged Method

[image]

Mindscape Phone Elements
ColorPickerPageBase..::..OnColorPickerChanged Method
ColorPickerPageBase Class See Also Send Feedback
Called when the ColorPicker property changes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract void OnColorPickerChanged()
Visual Basic
Protected MustOverride Sub OnColorPickerChanged
Visual C++
protected:
virtual void OnColorPickerChanged() abstract

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


ColorPickerPageBase Properties

[image] [image]

Mindscape Phone Elements
ColorPickerPageBase Properties
ColorPickerPageBase Class See Also Send Feedback

The ColorPickerPageBase type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page.
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property.
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


ColorPicker Property

[image]

Mindscape Phone Elements
ColorPickerPageBase..::..ColorPicker Property
ColorPickerPageBase Class See Also Send Feedback
Gets or sets the ColorPicker that opened the page.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPicker ColorPicker { get; set; }
Visual Basic
Public Property ColorPicker As ColorPicker
    Get
    Set
Visual C++
public:
virtual property ColorPicker^ ColorPicker {
    ColorPicker^ get () sealed;
    void set (ColorPicker^ value) sealed;
}

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


SelectedNamedColor Property

[image]

Mindscape Phone Elements
ColorPickerPageBase..::..SelectedNamedColor Property
ColorPickerPageBase Class See Also Send Feedback
Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NamedColor SelectedNamedColor { get; set; }
Visual Basic
Public Property SelectedNamedColor As NamedColor
    Get
    Set
Visual C++
public:
virtual property NamedColor^ SelectedNamedColor {
    NamedColor^ get () sealed;
    void set (NamedColor^ value) sealed;
}

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


ColorPickerPageBase Events

[image] [image]

Mindscape Phone Elements
ColorPickerPageBase Events
ColorPickerPageBase Class See Also Send Feedback

The ColorPickerPageBase type exposes the following members.

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ColorPickerPageBase Class
Mindscape.PhoneElements Namespace


ColorToSolidColorBrushConverter Class

[image]

Mindscape Phone Elements
ColorToSolidColorBrushConverter Class
Members See Also Send Feedback
Converts a Color to a SolidColorBrush.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorToSolidColorBrushConverter : IValueConverter
Visual Basic
Public Class ColorToSolidColorBrushConverter _
    Implements IValueConverter
Visual C++
public ref class ColorToSolidColorBrushConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ColorToSolidColorBrushConverter

See Also

ColorToSolidColorBrushConverter Members
Mindscape.PhoneElements Namespace


ColorToSolidColorBrushConverter Members

[image] [image]

Mindscape Phone Elements
ColorToSolidColorBrushConverter Members
ColorToSolidColorBrushConverter Class Constructors Methods See Also Send Feedback

The ColorToSolidColorBrushConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ColorToSolidColorBrushConverter | Initializes a new instance of the ColorToSolidColorBrushConverter class

Methods

 | Name | Description
Public method | Convert | Converts a Color to a SolidColorBrush.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorToSolidColorBrushConverter Class
Mindscape.PhoneElements Namespace


ColorToSolidColorBrushConverter Constructor

[image]

Mindscape Phone Elements
ColorToSolidColorBrushConverter Constructor
ColorToSolidColorBrushConverter Class See Also Send Feedback
Initializes a new instance of the ColorToSolidColorBrushConverter class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorToSolidColorBrushConverter()
Visual Basic
Public Sub New
Visual C++
public:
ColorToSolidColorBrushConverter()

See Also

ColorToSolidColorBrushConverter Class
Mindscape.PhoneElements Namespace


ColorToSolidColorBrushConverter Methods

[image] [image]

Mindscape Phone Elements
ColorToSolidColorBrushConverter Methods
ColorToSolidColorBrushConverter Class See Also Send Feedback

The ColorToSolidColorBrushConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a Color to a SolidColorBrush.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorToSolidColorBrushConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
ColorToSolidColorBrushConverter..::..Convert Method
ColorToSolidColorBrushConverter Class See Also Send Feedback
Converts a Color to a SolidColorBrush.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The Color value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A SolidColorBrush of the input color.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ColorToSolidColorBrushConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
ColorToSolidColorBrushConverter..::..ConvertBack Method
ColorToSolidColorBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ColorToSolidColorBrushConverter Class
Mindscape.PhoneElements Namespace


CustomColorPicker Class

[image]

Mindscape Phone Elements
CustomColorPicker Class
Members See Also Send Feedback
A control that displays a slider for each color channel allowing the user to create a custom color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CustomColorPicker : Control
Visual Basic
Public Class CustomColorPicker _
    Inherits Control
Visual C++
public ref class CustomColorPicker : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements..::..CustomColorPicker

See Also

CustomColorPicker Members
Mindscape.PhoneElements Namespace


CustomColorPicker Members

[image] [image]

Mindscape Phone Elements
CustomColorPicker Members
CustomColorPicker Class Constructors Methods Fields Properties Attached Properties Events See Also Send Feedback

The CustomColorPicker type exposes the following members.

Constructors

 | Name | Description
Public method | CustomColorPicker | Initializes a new instance of the CustomColorPicker class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
 | GetColorChannel | Gets the value of the ColorChannel attached property for a given DependencyObject.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetColorChannel | Sets the value of the ColorChannel attached property for a given DependencyObject.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
ColorChannelProperty | Identifies the ColorChannel attached property.
SelectedNamedColorProperty | Identifies the SelectedNamedColor property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor containing the selected color and its name. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Attached Properties

 | Name | Description
Public attached property | ColorChannel | When specified on a Slider control, specifies which channel (ARGB) of a color the slider will affect.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


CustomColorPicker Constructor

[image]

Mindscape Phone Elements
CustomColorPicker Constructor
CustomColorPicker Class See Also Send Feedback
Initializes a new instance of the CustomColorPicker class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CustomColorPicker()
Visual Basic
Public Sub New
Visual C++
public:
CustomColorPicker()

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


CustomColorPicker Fields

[image] [image]

Mindscape Phone Elements
CustomColorPicker Fields
CustomColorPicker Class See Also Send Feedback

The CustomColorPicker type exposes the following members.

Fields

Name | Description
ColorChannelProperty | Identifies the ColorChannel attached property.
SelectedNamedColorProperty | Identifies the SelectedNamedColor property.

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


ColorChannelProperty Field

[image]

Mindscape Phone Elements
CustomColorPicker..::..ColorChannelProperty Field
CustomColorPicker Class See Also Send Feedback
Identifies the ColorChannel attached property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColorChannelProperty
Visual Basic
Public Shared ReadOnly ColorChannelProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColorChannelProperty

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


SelectedNamedColorProperty Field

[image]

Mindscape Phone Elements
CustomColorPicker..::..SelectedNamedColorProperty Field
CustomColorPicker Class See Also Send Feedback
Identifies the SelectedNamedColor property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedNamedColorProperty
Visual Basic
Public Shared ReadOnly SelectedNamedColorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedNamedColorProperty

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


CustomColorPicker Methods

[image] [image]

Mindscape Phone Elements
CustomColorPicker Methods
CustomColorPicker Class See Also Send Feedback

The CustomColorPicker type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
 | GetColorChannel | Gets the value of the ColorChannel attached property for a given DependencyObject.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetColorChannel | Sets the value of the ColorChannel attached property for a given DependencyObject.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


GetColorChannel Method

[image]

Mindscape Phone Elements
CustomColorPicker..::..GetColorChannel Method
CustomColorPicker Class See Also Send Feedback
Gets the value of the ColorChannel attached property for a given DependencyObject.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ColorChannel GetColorChannel(
    DependencyObject obj
)
Visual Basic
Public Shared Function GetColorChannel ( _
    obj As DependencyObject _
) As ColorChannel
Visual C++
public:
static ColorChannel GetColorChannel(
    DependencyObject^ obj
)

Parameters

obj
Type: System.Windows..::..DependencyObject
The element from which to read the property value.

Return Value

The value of the ColorChannel attached property.

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


OnApplyTemplate Method

[image]

Mindscape Phone Elements
CustomColorPicker..::..OnApplyTemplate Method
CustomColorPicker Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


SetColorChannel Method

[image]

Mindscape Phone Elements
CustomColorPicker..::..SetColorChannel Method
CustomColorPicker Class See Also Send Feedback
Sets the value of the ColorChannel attached property for a given DependencyObject.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetColorChannel(
    DependencyObject obj,
    ColorChannel value
)
Visual Basic
Public Shared Sub SetColorChannel ( _
    obj As DependencyObject, _
    value As ColorChannel _
)
Visual C++
public:
static void SetColorChannel(
    DependencyObject^ obj,
    ColorChannel value
)

Parameters

obj
Type: System.Windows..::..DependencyObject
The element on which to set the property value.
value
Type: Mindscape.PhoneElements..::..ColorChannel
The color channel value to which to set the property.

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


CustomColorPicker Properties

[image] [image]

Mindscape Phone Elements
CustomColorPicker Properties
CustomColorPicker Class See Also Send Feedback

The CustomColorPicker type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor containing the selected color and its name. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


SelectedNamedColor Property

[image]

Mindscape Phone Elements
CustomColorPicker..::..SelectedNamedColor Property
CustomColorPicker Class See Also Send Feedback
Gets or sets a NamedColor containing the selected color and its name. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NamedColor SelectedNamedColor { get; set; }
Visual Basic
Public Property SelectedNamedColor As NamedColor
    Get
    Set
Visual C++
public:
property NamedColor^ SelectedNamedColor {
    NamedColor^ get ();
    void set (NamedColor^ value);
}

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


CustomColorPicker Events

[image] [image]

Mindscape Phone Elements
CustomColorPicker Events
CustomColorPicker Class See Also Send Feedback

The CustomColorPicker type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


CustomColorPicker Attached Properties

[image] [image]

Mindscape Phone Elements
CustomColorPicker Attached Properties
CustomColorPicker Class See Also Send Feedback

The CustomColorPicker type exposes the following members.

Attached Properties

 | Name | Description
Public attached property | ColorChannel | When specified on a Slider control, specifies which channel (ARGB) of a color the slider will affect.

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


ColorChannel Attached Property

[image]

Mindscape Phone Elements
CustomColorPicker..::..ColorChannel Attached Property
CustomColorPicker Class See Also Send Feedback
When specified on a Slider control, specifies which channel (ARGB) of a color the slider will affect.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
See GetColorChannel, SetColorChannel
Visual Basic
See GetColorChannel, SetColorChannel
Visual C++
See GetColorChannel, SetColorChannel

See Also

CustomColorPicker Class
Mindscape.PhoneElements Namespace


CustomColorPickerPage Class

[image]

Mindscape Phone Elements
CustomColorPickerPage Class
Members See Also Send Feedback
A color picker page containing a CustomColorPicker()()()().

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CustomColorPickerPage : ColorPickerPageBase
Visual Basic
Public Class CustomColorPickerPage _
    Inherits ColorPickerPageBase
Visual C++
public ref class CustomColorPickerPage : public ColorPickerPageBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
System.Windows.Controls..::..Page
PhoneApplicationPage
Mindscape.PhoneElements..::..ColorPickerPageBase
Mindscape.PhoneElements..::..CustomColorPickerPage

See Also

CustomColorPickerPage Members
Mindscape.PhoneElements Namespace


CustomColorPickerPage Members

[image] [image]

Mindscape Phone Elements
CustomColorPickerPage Members
CustomColorPickerPage Class Constructors Methods Properties Events See Also Send Feedback

The CustomColorPickerPage type exposes the following members.

Constructors

 | Name | Description
Public method | CustomColorPickerPage | Initializes a new instance of the CustomColorPickerPage class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes. (Overrides ColorPickerPageBase..::..OnColorPickerChanged()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page. (Inherited from ColorPickerPageBase.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property. (Inherited from ColorPickerPageBase.)
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CustomColorPickerPage Class
Mindscape.PhoneElements Namespace


CustomColorPickerPage Constructor

[image]

Mindscape Phone Elements
CustomColorPickerPage Constructor
CustomColorPickerPage Class See Also Send Feedback
Initializes a new instance of the CustomColorPickerPage class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CustomColorPickerPage()
Visual Basic
Public Sub New
Visual C++
public:
CustomColorPickerPage()

See Also

CustomColorPickerPage Class
Mindscape.PhoneElements Namespace


CustomColorPickerPage Methods

[image] [image]

Mindscape Phone Elements
CustomColorPickerPage Methods
CustomColorPickerPage Class See Also Send Feedback

The CustomColorPickerPage type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes. (Overrides ColorPickerPageBase..::..OnColorPickerChanged()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

CustomColorPickerPage Class
Mindscape.PhoneElements Namespace


InitializeComponent Method

[image]

Mindscape Phone Elements
CustomColorPickerPage..::..InitializeComponent Method
CustomColorPickerPage Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

CustomColorPickerPage Class
Mindscape.PhoneElements Namespace


OnColorPickerChanged Method

[image]

Mindscape Phone Elements
CustomColorPickerPage..::..OnColorPickerChanged Method
CustomColorPickerPage Class See Also Send Feedback
Called when the ColorPicker property changes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnColorPickerChanged()
Visual Basic
Protected Overrides Sub OnColorPickerChanged
Visual C++
protected:
virtual void OnColorPickerChanged() override

See Also

CustomColorPickerPage Class
Mindscape.PhoneElements Namespace


CustomColorPickerPage Properties

[image] [image]

Mindscape Phone Elements
CustomColorPickerPage Properties
CustomColorPickerPage Class See Also Send Feedback

The CustomColorPickerPage type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page. (Inherited from ColorPickerPageBase.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property. (Inherited from ColorPickerPageBase.)
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

CustomColorPickerPage Class
Mindscape.PhoneElements Namespace


CustomColorPickerPage Events

[image] [image]

Mindscape Phone Elements
CustomColorPickerPage Events
CustomColorPickerPage Class See Also Send Feedback

The CustomColorPickerPage type exposes the following members.

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CustomColorPickerPage Class
Mindscape.PhoneElements Namespace


DatePicker Class

[image]

Mindscape Phone Elements
DatePicker Class
Members See Also Send Feedback
Allows the user to select a DateTime object.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DatePicker : PickerBase
Visual Basic
Public Class DatePicker _
    Inherits PickerBase
Visual C++
public ref class DatePicker : public PickerBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements..::..PickerBase
Mindscape.PhoneElements..::..DatePicker

See Also

DatePicker Members
Mindscape.PhoneElements Namespace


DatePicker Members

[image] [image]

Mindscape Phone Elements
DatePicker Members
DatePicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The DatePicker type exposes the following members.

Constructors

 | Name | Description
Public method | DatePicker | Initializes a new instance of the DatePicker class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page. (Inherited from PickerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application frame is navigated. (Overrides PickerBase..::..FrameNavigated(Object).)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Inherited from PickerBase.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from PickerBase.)
Protected method | PickerPageClosed | Called when the page closes. (Overrides PickerBase..::..PickerPageClosed()()()().)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
CultureProperty | Identifies the Culture property.
DateFormatProperty | Identifies the DateFormat property.
SelectedDateProperty | Identifies the SelectedDate property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Culture | Gets or sets the current CultureInfo used to format the date. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DateFormat | Gets or sets the date format string. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property. (Inherited from PickerBase.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the selected DateTime object. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Text | Gets the text to be displayed in the DatePicker header.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes. (Inherited from PickerBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DatePicker Constructor

[image]

Mindscape Phone Elements
DatePicker Constructor
DatePicker Class See Also Send Feedback
Initializes a new instance of the DatePicker class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DatePicker()
Visual Basic
Public Sub New
Visual C++
public:
DatePicker()

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DatePicker Fields

[image] [image]

Mindscape Phone Elements
DatePicker Fields
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Fields

Name | Description
CultureProperty | Identifies the Culture property.
DateFormatProperty | Identifies the DateFormat property.
SelectedDateProperty | Identifies the SelectedDate property.

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


CultureProperty Field

[image]

Mindscape Phone Elements
DatePicker..::..CultureProperty Field
DatePicker Class See Also Send Feedback
Identifies the Culture property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CultureProperty
Visual Basic
Public Shared ReadOnly CultureProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CultureProperty

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DateFormatProperty Field

[image]

Mindscape Phone Elements
DatePicker..::..DateFormatProperty Field
DatePicker Class See Also Send Feedback
Identifies the DateFormat property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DateFormatProperty
Visual Basic
Public Shared ReadOnly DateFormatProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DateFormatProperty

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


SelectedDateProperty Field

[image]

Mindscape Phone Elements
DatePicker..::..SelectedDateProperty Field
DatePicker Class See Also Send Feedback
Identifies the SelectedDate property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedDateProperty
Visual Basic
Public Shared ReadOnly SelectedDateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedDateProperty

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DatePicker Methods

[image] [image]

Mindscape Phone Elements
DatePicker Methods
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page. (Inherited from PickerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application frame is navigated. (Overrides PickerBase..::..FrameNavigated(Object).)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Inherited from PickerBase.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from PickerBase.)
Protected method | PickerPageClosed | Called when the page closes. (Overrides PickerBase..::..PickerPageClosed()()()().)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


FrameNavigated Method

[image]

Mindscape Phone Elements
DatePicker..::..FrameNavigated Method
DatePicker Class See Also Send Feedback
Called when the application frame is navigated.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void FrameNavigated(
    Object content
)
Visual Basic
Protected Overrides Sub FrameNavigated ( _
    content As Object _
)
Visual C++
protected:
virtual void FrameNavigated(
    Object^ content
) override

Parameters

content
Type: System..::..Object
The current content of the application frame.

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


PickerPageClosed Method

[image]

Mindscape Phone Elements
DatePicker..::..PickerPageClosed Method
DatePicker Class See Also Send Feedback
Called when the page closes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void PickerPageClosed()
Visual Basic
Protected Overrides Sub PickerPageClosed
Visual C++
protected:
virtual void PickerPageClosed() override

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DatePicker Properties

[image] [image]

Mindscape Phone Elements
DatePicker Properties
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Culture | Gets or sets the current CultureInfo used to format the date. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DateFormat | Gets or sets the date format string. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property. (Inherited from PickerBase.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the selected DateTime object. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Text | Gets the text to be displayed in the DatePicker header.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
DatePicker..::..Culture Property
DatePicker Class See Also Send Feedback
Gets or sets the current CultureInfo used to format the date. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DateFormat Property

[image]

Mindscape Phone Elements
DatePicker..::..DateFormat Property
DatePicker Class See Also Send Feedback
Gets or sets the date format string. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DateFormat { get; set; }
Visual Basic
Public Property DateFormat As String
    Get
    Set
Visual C++
public:
property String^ DateFormat {
    String^ get ();
    void set (String^ value);
}

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


SelectedDate Property

[image]

Mindscape Phone Elements
DatePicker..::..SelectedDate Property
DatePicker Class See Also Send Feedback
Gets or sets the selected DateTime object. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime SelectedDate { get; set; }
Visual Basic
Public Property SelectedDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime SelectedDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


Text Property

[image]

Mindscape Phone Elements
DatePicker..::..Text Property
DatePicker Class See Also Send Feedback
Gets the text to be displayed in the DatePicker header.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Text { get; private set; }
Visual Basic
Public Property Text As String
    Get
    Private Set
Visual C++
public:
property String^ Text {
    String^ get ();
    private: void set (String^ value);
}

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DatePicker Events

[image] [image]

Mindscape Phone Elements
DatePicker Events
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes. (Inherited from PickerBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DatePicker Class
Mindscape.PhoneElements Namespace


DatePickerPage Class

[image]

Mindscape Phone Elements
DatePickerPage Class
Members See Also Send Feedback
The standard page that can be opened by a DatePicker.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DatePickerPage : PhoneApplicationPage,
    IDatePickerPage
Visual Basic
Public Class DatePickerPage _
    Inherits PhoneApplicationPage _
    Implements IDatePickerPage
Visual C++
public ref class DatePickerPage : public PhoneApplicationPage,
    IDatePickerPage

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
System.Windows.Controls..::..Page
PhoneApplicationPage
Mindscape.PhoneElements..::..DatePickerPage

See Also

DatePickerPage Members
Mindscape.PhoneElements Namespace


DatePickerPage Members

[image] [image]

Mindscape Phone Elements
DatePickerPage Members
DatePickerPage Class Constructors Methods Fields Properties Events See Also Send Feedback

The DatePickerPage type exposes the following members.

Constructors

 | Name | Description
Public method | DatePickerPage | Initializes a new instance of the DatePickerPage class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
CultureProperty | Identifies the Culture property.
DateFormatProperty | Identifies the DateFormat property.
SelectedDateProperty | Identifies the SelectedDate property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Culture | Gets or sets the CultureInfo used to format the date. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DateFormat | Gets or sets the date format string. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the selected DateTime object. This is a dependency property.
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DatePickerPage Constructor

[image]

Mindscape Phone Elements
DatePickerPage Constructor
DatePickerPage Class See Also Send Feedback
Initializes a new instance of the DatePickerPage class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DatePickerPage()
Visual Basic
Public Sub New
Visual C++
public:
DatePickerPage()

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DatePickerPage Fields

[image] [image]

Mindscape Phone Elements
DatePickerPage Fields
DatePickerPage Class See Also Send Feedback

The DatePickerPage type exposes the following members.

Fields

Name | Description
CultureProperty | Identifies the Culture property.
DateFormatProperty | Identifies the DateFormat property.
SelectedDateProperty | Identifies the SelectedDate property.

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


CultureProperty Field

[image]

Mindscape Phone Elements
DatePickerPage..::..CultureProperty Field
DatePickerPage Class See Also Send Feedback
Identifies the Culture property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CultureProperty
Visual Basic
Public Shared ReadOnly CultureProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CultureProperty

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DateFormatProperty Field

[image]

Mindscape Phone Elements
DatePickerPage..::..DateFormatProperty Field
DatePickerPage Class See Also Send Feedback
Identifies the DateFormat property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DateFormatProperty
Visual Basic
Public Shared ReadOnly DateFormatProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DateFormatProperty

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


SelectedDateProperty Field

[image]

Mindscape Phone Elements
DatePickerPage..::..SelectedDateProperty Field
DatePickerPage Class See Also Send Feedback
Identifies the SelectedDate property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedDateProperty
Visual Basic
Public Shared ReadOnly SelectedDateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedDateProperty

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DatePickerPage Methods

[image] [image]

Mindscape Phone Elements
DatePickerPage Methods
DatePickerPage Class See Also Send Feedback

The DatePickerPage type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


InitializeComponent Method

[image]

Mindscape Phone Elements
DatePickerPage..::..InitializeComponent Method
DatePickerPage Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DatePickerPage Properties

[image] [image]

Mindscape Phone Elements
DatePickerPage Properties
DatePickerPage Class See Also Send Feedback

The DatePickerPage type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Culture | Gets or sets the CultureInfo used to format the date. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DateFormat | Gets or sets the date format string. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDate | Gets or sets the selected DateTime object. This is a dependency property.
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
DatePickerPage..::..Culture Property
DatePickerPage Class See Also Send Feedback
Gets or sets the CultureInfo used to format the date. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
virtual property CultureInfo^ Culture {
    CultureInfo^ get () sealed;
    void set (CultureInfo^ value) sealed;
}

Implements

IDatePickerPage..::..Culture

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DateFormat Property

[image]

Mindscape Phone Elements
DatePickerPage..::..DateFormat Property
DatePickerPage Class See Also Send Feedback
Gets or sets the date format string. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DateFormat { get; set; }
Visual Basic
Public Property DateFormat As String
    Get
    Set
Visual C++
public:
virtual property String^ DateFormat {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IDatePickerPage..::..DateFormat

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


SelectedDate Property

[image]

Mindscape Phone Elements
DatePickerPage..::..SelectedDate Property
DatePickerPage Class See Also Send Feedback
Gets or sets the selected DateTime object. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime SelectedDate { get; set; }
Visual Basic
Public Property SelectedDate As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime SelectedDate {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Implements

IDatePickerPage..::..SelectedDate

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DatePickerPage Events

[image] [image]

Mindscape Phone Elements
DatePickerPage Events
DatePickerPage Class See Also Send Feedback

The DatePickerPage type exposes the following members.

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DatePickerPage Class
Mindscape.PhoneElements Namespace


DateTimeWrapper Class

[image]

Mindscape Phone Elements
DateTimeWrapper Class
Members See Also Send Feedback
A wrapper class for a DateTime object. This helps obtain culture dependent information from the DateTime.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateTimeWrapper
Visual Basic
Public Class DateTimeWrapper
Visual C++
public ref class DateTimeWrapper

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..DateTimeWrapper

See Also

DateTimeWrapper Members
Mindscape.PhoneElements Namespace


DateTimeWrapper Members

[image] [image]

Mindscape Phone Elements
DateTimeWrapper Members
DateTimeWrapper Class Constructors Methods Properties See Also Send Feedback

The DateTimeWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeWrapper(DateTime) | Initializes a new instance of the DateTimeWrapper class.
Public method | DateTimeWrapper(DateTime, CultureInfo) | Initializes a new instance of the DateTimeWrapper class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Culture | Gets the CultureInfo.
Public property | DateTime | Gets the DateTime object.
Public property | Day | Gets the 2 digit day value as a string.
Public property | DayOfWeek | Gets the name for the day of the week.
Public property | Month | Gets the 2 digit month value as a string.
Public property | MonthName | Gets the full month name.
Public property | Year | Gets the 4 digit year value as a string.

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


DateTimeWrapper Constructor

[image] [image]

Mindscape Phone Elements
DateTimeWrapper Constructor
DateTimeWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DateTimeWrapper(DateTime) | Initializes a new instance of the DateTimeWrapper class.
Public method | DateTimeWrapper(DateTime, CultureInfo) | Initializes a new instance of the DateTimeWrapper class.

See Also

DateTimeWrapper Class
DateTimeWrapper Members
Mindscape.PhoneElements Namespace


DateTimeWrapper Constructor (DateTime)

[image]

Mindscape Phone Elements
DateTimeWrapper Constructor (DateTime)
DateTimeWrapper Class See Also Send Feedback
Initializes a new instance of the DateTimeWrapper class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeWrapper(
    DateTime dateTime
)
Visual Basic
Public Sub New ( _
    dateTime As DateTime _
)
Visual C++
public:
DateTimeWrapper(
    DateTime dateTime
)

Parameters

dateTime
Type: System..::..DateTime
The DateTime object that the DateTimeWrapper will contain.

See Also

DateTimeWrapper Class
DateTimeWrapper Overload
Mindscape.PhoneElements Namespace


DateTimeWrapper Constructor (DateTime, CultureInfo)

[image]

Mindscape Phone Elements
DateTimeWrapper Constructor (DateTime, CultureInfo)
DateTimeWrapper Class See Also Send Feedback
Initializes a new instance of the DateTimeWrapper class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeWrapper(
    DateTime dateTime,
    CultureInfo culture
)
Visual Basic
Public Sub New ( _
    dateTime As DateTime, _
    culture As CultureInfo _
)
Visual C++
public:
DateTimeWrapper(
    DateTime dateTime,
    CultureInfo^ culture
)

Parameters

dateTime
Type: System..::..DateTime
The DateTime object that the DateTimeWrapper will contain.
culture
Type: System.Globalization..::..CultureInfo
The CultureInfo that the DateTimeWrapper will use.

See Also

DateTimeWrapper Class
DateTimeWrapper Overload
Mindscape.PhoneElements Namespace


DateTimeWrapper Methods

[image] [image]

Mindscape Phone Elements
DateTimeWrapper Methods
DateTimeWrapper Class See Also Send Feedback

The DateTimeWrapper type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


DateTimeWrapper Properties

[image] [image]

Mindscape Phone Elements
DateTimeWrapper Properties
DateTimeWrapper Class See Also Send Feedback

The DateTimeWrapper type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the CultureInfo.
Public property | DateTime | Gets the DateTime object.
Public property | Day | Gets the 2 digit day value as a string.
Public property | DayOfWeek | Gets the name for the day of the week.
Public property | Month | Gets the 2 digit month value as a string.
Public property | MonthName | Gets the full month name.
Public property | Year | Gets the 4 digit year value as a string.

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
DateTimeWrapper..::..Culture Property
DateTimeWrapper Class See Also Send Feedback
Gets the CultureInfo.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; private set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Private Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    private: void set (CultureInfo^ value);
}

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


DateTime Property

[image]

Mindscape Phone Elements
DateTimeWrapper..::..DateTime Property
DateTimeWrapper Class See Also Send Feedback
Gets the DateTime object.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime DateTime { get; private set; }
Visual Basic
Public Property DateTime As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime DateTime {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


Day Property

[image]

Mindscape Phone Elements
DateTimeWrapper..::..Day Property
DateTimeWrapper Class See Also Send Feedback
Gets the 2 digit day value as a string.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Day { get; }
Visual Basic
Public ReadOnly Property Day As String
    Get
Visual C++
public:
property String^ Day {
    String^ get ();
}

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


DayOfWeek Property

[image]

Mindscape Phone Elements
DateTimeWrapper..::..DayOfWeek Property
DateTimeWrapper Class See Also Send Feedback
Gets the name for the day of the week.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DayOfWeek { get; }
Visual Basic
Public ReadOnly Property DayOfWeek As String
    Get
Visual C++
public:
property String^ DayOfWeek {
    String^ get ();
}

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


Month Property

[image]

Mindscape Phone Elements
DateTimeWrapper..::..Month Property
DateTimeWrapper Class See Also Send Feedback
Gets the 2 digit month value as a string.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Month { get; }
Visual Basic
Public ReadOnly Property Month As String
    Get
Visual C++
public:
property String^ Month {
    String^ get ();
}

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


MonthName Property

[image]

Mindscape Phone Elements
DateTimeWrapper..::..MonthName Property
DateTimeWrapper Class See Also Send Feedback
Gets the full month name.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MonthName { get; }
Visual Basic
Public ReadOnly Property MonthName As String
    Get
Visual C++
public:
property String^ MonthName {
    String^ get ();
}

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


Year Property

[image]

Mindscape Phone Elements
DateTimeWrapper..::..Year Property
DateTimeWrapper Class See Also Send Feedback
Gets the 4 digit year value as a string.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Year { get; }
Visual Basic
Public ReadOnly Property Year As String
    Get
Visual C++
public:
property String^ Year {
    String^ get ();
}

See Also

DateTimeWrapper Class
Mindscape.PhoneElements Namespace


DayOfMonthDataSource Class

[image]

Mindscape Phone Elements
DayOfMonthDataSource Class
Members See Also Send Feedback
A looping data source that loops through the days of the current month. This looping data source uses DateTimeWrapper objects.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DayOfMonthDataSource : IDataSource
Visual Basic
Public Class DayOfMonthDataSource _
    Implements IDataSource
Visual C++
public ref class DayOfMonthDataSource : IDataSource

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..DayOfMonthDataSource

See Also

DayOfMonthDataSource Members
Mindscape.PhoneElements Namespace


DayOfMonthDataSource Members

[image] [image]

Mindscape Phone Elements
DayOfMonthDataSource Members
DayOfMonthDataSource Class Constructors Methods Properties See Also Send Feedback

The DayOfMonthDataSource type exposes the following members.

Constructors

 | Name | Description
Public method | DayOfMonthDataSource()()()() | Initializes a new instance of the DayOfMonthDataSource class.
Public method | DayOfMonthDataSource(CultureInfo) | Initializes a new instance of the DayOfMonthDataSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next day of the current month based on the delta value. If the day goes past the end of the month, then it will loop back to the start of the month.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Culture | Gets or sets the CultureInfo used to format the date.
Public property | FirstValue | Gets a DateTimeWrapper containing DateTime.Now.

See Also

DayOfMonthDataSource Class
Mindscape.PhoneElements Namespace


DayOfMonthDataSource Constructor

[image] [image]

Mindscape Phone Elements
DayOfMonthDataSource Constructor
DayOfMonthDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DayOfMonthDataSource()()()() | Initializes a new instance of the DayOfMonthDataSource class.
Public method | DayOfMonthDataSource(CultureInfo) | Initializes a new instance of the DayOfMonthDataSource class.

See Also

DayOfMonthDataSource Class
DayOfMonthDataSource Members
Mindscape.PhoneElements Namespace


DayOfMonthDataSource Constructor

[image]

Mindscape Phone Elements
DayOfMonthDataSource Constructor
DayOfMonthDataSource Class See Also Send Feedback
Initializes a new instance of the DayOfMonthDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayOfMonthDataSource()
Visual Basic
Public Sub New
Visual C++
public:
DayOfMonthDataSource()

See Also

DayOfMonthDataSource Class
DayOfMonthDataSource Overload
Mindscape.PhoneElements Namespace


DayOfMonthDataSource Constructor (CultureInfo)

[image]

Mindscape Phone Elements
DayOfMonthDataSource Constructor (CultureInfo)
DayOfMonthDataSource Class See Also Send Feedback
Initializes a new instance of the DayOfMonthDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayOfMonthDataSource(
    CultureInfo culture
)
Visual Basic
Public Sub New ( _
    culture As CultureInfo _
)
Visual C++
public:
DayOfMonthDataSource(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::..CultureInfo
The CultureInfo used to format the date.

See Also

DayOfMonthDataSource Class
DayOfMonthDataSource Overload
Mindscape.PhoneElements Namespace


DayOfMonthDataSource Methods

[image] [image]

Mindscape Phone Elements
DayOfMonthDataSource Methods
DayOfMonthDataSource Class See Also Send Feedback

The DayOfMonthDataSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next day of the current month based on the delta value. If the day goes past the end of the month, then it will loop back to the start of the month.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DayOfMonthDataSource Class
Mindscape.PhoneElements Namespace


GetNext Method

[image]

Mindscape Phone Elements
DayOfMonthDataSource..::..GetNext Method
DayOfMonthDataSource Class See Also Send Feedback
Returns the next day of the current month based on the delta value. If the day goes past the end of the month, then it will loop back to the start of the month.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetNext(
    Object current,
    int deltaIndex
)
Visual Basic
Public Function GetNext ( _
    current As Object, _
    deltaIndex As Integer _
) As Object
Visual C++
public:
virtual Object^ GetNext(
    Object^ current,
    int deltaIndex
) sealed

Parameters

current
Type: System..::..Object
The current DateTimeWrapper.
deltaIndex
Type: System..::..Int32
The number of days to advance through the sequence.

Return Value

The next DateTimeWrapper which is offset from the current DateTimeWrapper by the given number of days.

Implements

IDataSource..::..GetNext(Object, Int32)

See Also

DayOfMonthDataSource Class
Mindscape.PhoneElements Namespace


DayOfMonthDataSource Properties

[image] [image]

Mindscape Phone Elements
DayOfMonthDataSource Properties
DayOfMonthDataSource Class See Also Send Feedback

The DayOfMonthDataSource type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets or sets the CultureInfo used to format the date.
Public property | FirstValue | Gets a DateTimeWrapper containing DateTime.Now.

See Also

DayOfMonthDataSource Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
DayOfMonthDataSource..::..Culture Property
DayOfMonthDataSource Class See Also Send Feedback
Gets or sets the CultureInfo used to format the date.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

DayOfMonthDataSource Class
Mindscape.PhoneElements Namespace


FirstValue Property

[image]

Mindscape Phone Elements
DayOfMonthDataSource..::..FirstValue Property
DayOfMonthDataSource Class See Also Send Feedback
Gets a DateTimeWrapper containing DateTime.Now.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object FirstValue { get; }
Visual Basic
Public ReadOnly Property FirstValue As Object
    Get
Visual C++
public:
virtual property Object^ FirstValue {
    Object^ get () sealed;
}

Implements

IDataSource..::..FirstValue

See Also

DayOfMonthDataSource Class
Mindscape.PhoneElements Namespace


Dock Enumeration

[image]

Mindscape Phone Elements
Dock Enumeration
See Also Send Feedback
Specifies the edge of a DockPanel in which to arrange an element.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Dock
Visual Basic
Public Enumeration Dock
Visual C++
public enum class Dock

Members

Member name | Value | Description
Top | 0 | The top edge of the DockPanel.
Bottom | 1 | The bottom edge of the DockPanel.
Left | 2 | The left edge of the DockPanel.
Right | 3 | The right edge of the DockPanel.

See Also

Mindscape.PhoneElements Namespace


DockPanel Class

[image]

Mindscape Phone Elements
DockPanel Class
Members See Also Send Feedback
A panel that arranges its children against its edges.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DockPanel : Panel
Visual Basic
Public Class DockPanel _
    Inherits Panel
Visual C++
public ref class DockPanel : public Panel

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
Mindscape.PhoneElements..::..DockPanel

See Also

DockPanel Members
Mindscape.PhoneElements Namespace


DockPanel Members

[image] [image]

Mindscape Phone Elements
DockPanel Members
DockPanel Class Constructors Methods Fields Properties Attached Properties Events See Also Send Feedback

The DockPanel type exposes the following members.

Constructors

 | Name | Description
Public method | DockPanel | Initializes a new instance of the DockPanel class

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Called by the framework to arrange the child elements of the DockPanel. (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
 | GetDock | Gets which side of a DockPanel the element should be positioned against.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Called by the framework to measures the child elements of the DockPanel. (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetDock | Sets which side of a DockPanel the element should be positioned against.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
DockProperty | Identifies the Dock attched property.
LastChildFillProperty | Identifies the LastChildFill property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. This is a dependency property. (Inherited from Panel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LastChildFill | Gets or sets whether the last child of the DockPanel should fill all the remaining area after other children have been laid out. The default is true. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Attached Properties

 | Name | Description
Public attached property | Dock | Gets or sets a value that indicates the position of a child element within a parent DockPanel.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DockPanel Constructor

[image]

Mindscape Phone Elements
DockPanel Constructor
DockPanel Class See Also Send Feedback
Initializes a new instance of the DockPanel class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DockPanel()
Visual Basic
Public Sub New
Visual C++
public:
DockPanel()

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DockPanel Fields

[image] [image]

Mindscape Phone Elements
DockPanel Fields
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Fields

Name | Description
DockProperty | Identifies the Dock attched property.
LastChildFillProperty | Identifies the LastChildFill property.

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DockProperty Field

[image]

Mindscape Phone Elements
DockPanel..::..DockProperty Field
DockPanel Class See Also Send Feedback
Identifies the Dock attched property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DockProperty
Visual Basic
Public Shared ReadOnly DockProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DockProperty

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


LastChildFillProperty Field

[image]

Mindscape Phone Elements
DockPanel..::..LastChildFillProperty Field
DockPanel Class See Also Send Feedback
Identifies the LastChildFill property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LastChildFillProperty
Visual Basic
Public Shared ReadOnly LastChildFillProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LastChildFillProperty

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DockPanel Methods

[image] [image]

Mindscape Phone Elements
DockPanel Methods
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Called by the framework to arrange the child elements of the DockPanel. (Overrides FrameworkElement..::..ArrangeOverride(Size).)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
 | GetDock | Gets which side of a DockPanel the element should be positioned against.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Called by the framework to measures the child elements of the DockPanel. (Overrides FrameworkElement..::..MeasureOverride(Size).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
 | SetDock | Sets which side of a DockPanel the element should be positioned against.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


ArrangeOverride Method

[image]

Mindscape Phone Elements
DockPanel..::..ArrangeOverride Method
DockPanel Class See Also Send Feedback
Called by the framework to arrange the child elements of the DockPanel.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size
Visual C++
protected:
virtual Size ArrangeOverride(
    Size finalSize
) override

Parameters

finalSize
Type: System.Windows..::..Size
The maximum size that all the child elements will be contained within.

Return Value

The actual size of the dock panel once all the children have been arranged.

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


GetDock Method

[image]

Mindscape Phone Elements
DockPanel..::..GetDock Method
DockPanel Class See Also Send Feedback
Gets which side of a DockPanel the element should be positioned against.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Dock GetDock(
    DependencyObject obj
)
Visual Basic
Public Shared Function GetDock ( _
    obj As DependencyObject _
) As Dock
Visual C++
public:
static Dock GetDock(
    DependencyObject^ obj
)

Parameters

obj
Type: System.Windows..::..DependencyObject
The element from which the property value is read.

Return Value

The side of a DockPanel that the element will be positioned against.

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


MeasureOverride Method

[image]

Mindscape Phone Elements
DockPanel..::..MeasureOverride Method
DockPanel Class See Also Send Feedback
Called by the framework to measures the child elements of the DockPanel.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size
Visual C++
protected:
virtual Size MeasureOverride(
    Size availableSize
) override

Parameters

availableSize
Type: System.Windows..::..Size
The maximum available size to arrange the children inside.

Return Value

The desired size of the DockPanel.

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


SetDock Method

[image]

Mindscape Phone Elements
DockPanel..::..SetDock Method
DockPanel Class See Also Send Feedback
Sets which side of a DockPanel the element should be positioned against.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetDock(
    DependencyObject obj,
    Dock dock
)
Visual Basic
Public Shared Sub SetDock ( _
    obj As DependencyObject, _
    dock As Dock _
)
Visual C++
public:
static void SetDock(
    DependencyObject^ obj,
    Dock dock
)

Parameters

obj
Type: System.Windows..::..DependencyObject
The element on which the property value is set.
dock
Type: Mindscape.PhoneElements..::..Dock
Specifies which side of a DockPanel the element will be positioned against.

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DockPanel Properties

[image] [image]

Mindscape Phone Elements
DockPanel Properties
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. This is a dependency property. (Inherited from Panel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LastChildFill | Gets or sets whether the last child of the DockPanel should fill all the remaining area after other children have been laid out. The default is true. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


LastChildFill Property

[image]

Mindscape Phone Elements
DockPanel..::..LastChildFill Property
DockPanel Class See Also Send Feedback
Gets or sets whether the last child of the DockPanel should fill all the remaining area after other children have been laid out. The default is true. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool LastChildFill { get; set; }
Visual Basic
Public Property LastChildFill As Boolean
    Get
    Set
Visual C++
public:
property bool LastChildFill {
    bool get ();
    void set (bool value);
}

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DockPanel Events

[image] [image]

Mindscape Phone Elements
DockPanel Events
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DockPanel Attached Properties

[image] [image]

Mindscape Phone Elements
DockPanel Attached Properties
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Attached Properties

 | Name | Description
Public attached property | Dock | Gets or sets a value that indicates the position of a child element within a parent DockPanel.

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


Dock Attached Property

[image]

Mindscape Phone Elements
DockPanel..::..Dock Attached Property
DockPanel Class See Also Send Feedback
Gets or sets a value that indicates the position of a child element within a parent DockPanel.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
See GetDock, SetDock
Visual Basic
See GetDock, SetDock
Visual C++
See GetDock, SetDock

See Also

DockPanel Class
Mindscape.PhoneElements Namespace


DragCompletedGestureEventArgs Class

[image]

Mindscape Phone Elements
DragCompletedGestureEventArgs Class
Members See Also Send Feedback
Contains event data for the drag completed gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DragCompletedGestureEventArgs : GestureEventArgs
Visual Basic
Public Class DragCompletedGestureEventArgs _
    Inherits GestureEventArgs
Visual C++
public ref class DragCompletedGestureEventArgs : public GestureEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..DragCompletedGestureEventArgs

See Also

DragCompletedGestureEventArgs Members
Mindscape.PhoneElements Namespace


DragCompletedGestureEventArgs Members

[image] [image]

Mindscape Phone Elements
DragCompletedGestureEventArgs Members
DragCompletedGestureEventArgs Class Methods Properties See Also Send Feedback

The DragCompletedGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DragOrientation | Gets the orientation of the drag completed gesture. This is the same as the orientation of the drag started gesture.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | HorizontalChange | Gets the total horizontal change between the current touch point and the origin of the gesture.
Public property | HorizontalVelocity | Gets the horizontal velocity of the drag completed gesture.
Public property | VerticalChange | Gets the total vertical change between the current touch point and the origin of the gesture.
Public property | VerticalVelocity | Gets the vertical velocity of the drag completed gesture.

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragCompletedGestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
DragCompletedGestureEventArgs Methods
DragCompletedGestureEventArgs Class See Also Send Feedback

The DragCompletedGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
DragCompletedGestureEventArgs..::..GetPosition Method
DragCompletedGestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)

See Also

DragCompletedGestureEventArgs Class
DragCompletedGestureEventArgs Members
Mindscape.PhoneElements Namespace


DragCompletedGestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
DragCompletedGestureEventArgs Properties
DragCompletedGestureEventArgs Class See Also Send Feedback

The DragCompletedGestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DragOrientation | Gets the orientation of the drag completed gesture. This is the same as the orientation of the drag started gesture.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | HorizontalChange | Gets the total horizontal change between the current touch point and the origin of the gesture.
Public property | HorizontalVelocity | Gets the horizontal velocity of the drag completed gesture.
Public property | VerticalChange | Gets the total vertical change between the current touch point and the origin of the gesture.
Public property | VerticalVelocity | Gets the vertical velocity of the drag completed gesture.

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragOrientation Property

[image]

Mindscape Phone Elements
DragCompletedGestureEventArgs..::..DragOrientation Property
DragCompletedGestureEventArgs Class See Also Send Feedback
Gets the orientation of the drag completed gesture. This is the same as the orientation of the drag started gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation DragOrientation { get; private set; }
Visual Basic
Public Property DragOrientation As Orientation
    Get
    Private Set
Visual C++
public:
property Orientation DragOrientation {
    Orientation get ();
    private: void set (Orientation value);
}

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


HorizontalChange Property

[image]

Mindscape Phone Elements
DragCompletedGestureEventArgs..::..HorizontalChange Property
DragCompletedGestureEventArgs Class See Also Send Feedback
Gets the total horizontal change between the current touch point and the origin of the gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double HorizontalChange { get; private set; }
Visual Basic
Public Property HorizontalChange As Double
    Get
    Private Set
Visual C++
public:
property double HorizontalChange {
    double get ();
    private: void set (double value);
}

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


HorizontalVelocity Property

[image]

Mindscape Phone Elements
DragCompletedGestureEventArgs..::..HorizontalVelocity Property
DragCompletedGestureEventArgs Class See Also Send Feedback
Gets the horizontal velocity of the drag completed gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double HorizontalVelocity { get; private set; }
Visual Basic
Public Property HorizontalVelocity As Double
    Get
    Private Set
Visual C++
public:
property double HorizontalVelocity {
    double get ();
    private: void set (double value);
}

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


VerticalChange Property

[image]

Mindscape Phone Elements
DragCompletedGestureEventArgs..::..VerticalChange Property
DragCompletedGestureEventArgs Class See Also Send Feedback
Gets the total vertical change between the current touch point and the origin of the gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VerticalChange { get; private set; }
Visual Basic
Public Property VerticalChange As Double
    Get
    Private Set
Visual C++
public:
property double VerticalChange {
    double get ();
    private: void set (double value);
}

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


VerticalVelocity Property

[image]

Mindscape Phone Elements
DragCompletedGestureEventArgs..::..VerticalVelocity Property
DragCompletedGestureEventArgs Class See Also Send Feedback
Gets the vertical velocity of the drag completed gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VerticalVelocity { get; private set; }
Visual Basic
Public Property VerticalVelocity As Double
    Get
    Private Set
Visual C++
public:
property double VerticalVelocity {
    double get ();
    private: void set (double value);
}

See Also

DragCompletedGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragDeltaGestureEventArgs Class

[image]

Mindscape Phone Elements
DragDeltaGestureEventArgs Class
Members See Also Send Feedback
Contains event data for the drag delta gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DragDeltaGestureEventArgs : MovingGestureEventArgs
Visual Basic
Public Class DragDeltaGestureEventArgs _
    Inherits MovingGestureEventArgs
Visual C++
public ref class DragDeltaGestureEventArgs : public MovingGestureEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..MovingGestureEventArgs
Mindscape.PhoneElements..::..DragDeltaGestureEventArgs

See Also

DragDeltaGestureEventArgs Members
Mindscape.PhoneElements Namespace


DragDeltaGestureEventArgs Members

[image] [image]

Mindscape Phone Elements
DragDeltaGestureEventArgs Members
DragDeltaGestureEventArgs Class Methods Properties See Also Send Feedback

The DragDeltaGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DragOrientation | Gets the orientation of the drag delta gesture. This is the same as the orientation of the drag started gesture.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | HorizontalChange | Gets the total horizontal change between the current touch point and the origin of the gesture.
Public property | HorizontalDelta | Gets the horizontal difference between the current touch point and the previous touch point.
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | TouchPosition | Gets the current touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | VerticalChange | Gets the total vertical change between the current touch point and the origin of the gesture.
Public property | VerticalDelta | Gets the vertical difference between the current touch point and the previous touch point.

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragDeltaGestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
DragDeltaGestureEventArgs Methods
DragDeltaGestureEventArgs Class See Also Send Feedback

The DragDeltaGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
DragDeltaGestureEventArgs..::..GetPosition Method
DragDeltaGestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)

See Also

DragDeltaGestureEventArgs Class
DragDeltaGestureEventArgs Members
Mindscape.PhoneElements Namespace


DragDeltaGestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
DragDeltaGestureEventArgs Properties
DragDeltaGestureEventArgs Class See Also Send Feedback

The DragDeltaGestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DragOrientation | Gets the orientation of the drag delta gesture. This is the same as the orientation of the drag started gesture.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | HorizontalChange | Gets the total horizontal change between the current touch point and the origin of the gesture.
Public property | HorizontalDelta | Gets the horizontal difference between the current touch point and the previous touch point.
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | TouchPosition | Gets the current touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | VerticalChange | Gets the total vertical change between the current touch point and the origin of the gesture.
Public property | VerticalDelta | Gets the vertical difference between the current touch point and the previous touch point.

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragOrientation Property

[image]

Mindscape Phone Elements
DragDeltaGestureEventArgs..::..DragOrientation Property
DragDeltaGestureEventArgs Class See Also Send Feedback
Gets the orientation of the drag delta gesture. This is the same as the orientation of the drag started gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation DragOrientation { get; private set; }
Visual Basic
Public Property DragOrientation As Orientation
    Get
    Private Set
Visual C++
public:
property Orientation DragOrientation {
    Orientation get ();
    private: void set (Orientation value);
}

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


HorizontalChange Property

[image]

Mindscape Phone Elements
DragDeltaGestureEventArgs..::..HorizontalChange Property
DragDeltaGestureEventArgs Class See Also Send Feedback
Gets the total horizontal change between the current touch point and the origin of the gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double HorizontalChange { get; private set; }
Visual Basic
Public Property HorizontalChange As Double
    Get
    Private Set
Visual C++
public:
property double HorizontalChange {
    double get ();
    private: void set (double value);
}

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


HorizontalDelta Property

[image]

Mindscape Phone Elements
DragDeltaGestureEventArgs..::..HorizontalDelta Property
DragDeltaGestureEventArgs Class See Also Send Feedback
Gets the horizontal difference between the current touch point and the previous touch point.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double HorizontalDelta { get; private set; }
Visual Basic
Public Property HorizontalDelta As Double
    Get
    Private Set
Visual C++
public:
property double HorizontalDelta {
    double get ();
    private: void set (double value);
}

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


VerticalChange Property

[image]

Mindscape Phone Elements
DragDeltaGestureEventArgs..::..VerticalChange Property
DragDeltaGestureEventArgs Class See Also Send Feedback
Gets the total vertical change between the current touch point and the origin of the gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VerticalChange { get; private set; }
Visual Basic
Public Property VerticalChange As Double
    Get
    Private Set
Visual C++
public:
property double VerticalChange {
    double get ();
    private: void set (double value);
}

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


VerticalDelta Property

[image]

Mindscape Phone Elements
DragDeltaGestureEventArgs..::..VerticalDelta Property
DragDeltaGestureEventArgs Class See Also Send Feedback
Gets the vertical difference between the current touch point and the previous touch point.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VerticalDelta { get; private set; }
Visual Basic
Public Property VerticalDelta As Double
    Get
    Private Set
Visual C++
public:
property double VerticalDelta {
    double get ();
    private: void set (double value);
}

See Also

DragDeltaGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragStartedGestureEventArgs Class

[image]

Mindscape Phone Elements
DragStartedGestureEventArgs Class
Members See Also Send Feedback
Contains event data for the drag started gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DragStartedGestureEventArgs : GestureEventArgs
Visual Basic
Public Class DragStartedGestureEventArgs _
    Inherits GestureEventArgs
Visual C++
public ref class DragStartedGestureEventArgs : public GestureEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..DragStartedGestureEventArgs

See Also

DragStartedGestureEventArgs Members
Mindscape.PhoneElements Namespace


DragStartedGestureEventArgs Members

[image] [image]

Mindscape Phone Elements
DragStartedGestureEventArgs Members
DragStartedGestureEventArgs Class Methods Properties See Also Send Feedback

The DragStartedGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DragOrientation | Gets the orientation of the drag started gesture. This is based on the angle between the current touch point and the origin of the gesture.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)

See Also

DragStartedGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragStartedGestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
DragStartedGestureEventArgs Methods
DragStartedGestureEventArgs Class See Also Send Feedback

The DragStartedGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DragStartedGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
DragStartedGestureEventArgs..::..GetPosition Method
DragStartedGestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)

See Also

DragStartedGestureEventArgs Class
DragStartedGestureEventArgs Members
Mindscape.PhoneElements Namespace


DragStartedGestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
DragStartedGestureEventArgs Properties
DragStartedGestureEventArgs Class See Also Send Feedback

The DragStartedGestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DragOrientation | Gets the orientation of the drag started gesture. This is based on the angle between the current touch point and the origin of the gesture.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)

See Also

DragStartedGestureEventArgs Class
Mindscape.PhoneElements Namespace


DragOrientation Property

[image]

Mindscape Phone Elements
DragStartedGestureEventArgs..::..DragOrientation Property
DragStartedGestureEventArgs Class See Also Send Feedback
Gets the orientation of the drag started gesture. This is based on the angle between the current touch point and the origin of the gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation DragOrientation { get; private set; }
Visual Basic
Public Property DragOrientation As Orientation
    Get
    Private Set
Visual C++
public:
property Orientation DragOrientation {
    Orientation get ();
    private: void set (Orientation value);
}

See Also

DragStartedGestureEventArgs Class
Mindscape.PhoneElements Namespace


DualGestureEventArgs Class

[image]

Mindscape Phone Elements
DualGestureEventArgs Class
Members See Also Send Feedback
A base class for gesture event args that manage 2 touch points.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DualGestureEventArgs : MovingGestureEventArgs
Visual Basic
Public MustInherit Class DualGestureEventArgs _
    Inherits MovingGestureEventArgs
Visual C++
public ref class DualGestureEventArgs abstract : public MovingGestureEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..MovingGestureEventArgs
Mindscape.PhoneElements..::..DualGestureEventArgs
Mindscape.PhoneElements..::..PinchGestureEventArgs

See Also

DualGestureEventArgs Members
Mindscape.PhoneElements Namespace


DualGestureEventArgs Members

[image] [image]

Mindscape Phone Elements
DualGestureEventArgs Members
DualGestureEventArgs Class Methods Properties See Also Send Feedback

The DualGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | GestureOrigin2 | Gets the original position of the second touch point in screen coordinates.
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | PreviousTouchPosition2 | Gets the previous position of the second touch point in screen coordinates.
Public property | TouchPosition | Gets the current touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | TouchPosition2 | Gets the current position of the second touch point in screen coordinates.

See Also

DualGestureEventArgs Class
Mindscape.PhoneElements Namespace


DualGestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
DualGestureEventArgs Methods
DualGestureEventArgs Class See Also Send Feedback

The DualGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DualGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
DualGestureEventArgs..::..GetPosition Method
DualGestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)

See Also

DualGestureEventArgs Class
DualGestureEventArgs Members
Mindscape.PhoneElements Namespace


DualGestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
DualGestureEventArgs Properties
DualGestureEventArgs Class See Also Send Feedback

The DualGestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | GestureOrigin2 | Gets the original position of the second touch point in screen coordinates.
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | PreviousTouchPosition2 | Gets the previous position of the second touch point in screen coordinates.
Public property | TouchPosition | Gets the current touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | TouchPosition2 | Gets the current position of the second touch point in screen coordinates.

See Also

DualGestureEventArgs Class
Mindscape.PhoneElements Namespace


GestureOrigin2 Property

[image]

Mindscape Phone Elements
DualGestureEventArgs..::..GestureOrigin2 Property
DualGestureEventArgs Class See Also Send Feedback
Gets the original position of the second touch point in screen coordinates.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point GestureOrigin2 { get; private set; }
Visual Basic
Public Property GestureOrigin2 As Point
    Get
    Private Set
Visual C++
public:
property Point GestureOrigin2 {
    Point get ();
    private: void set (Point value);
}

See Also

DualGestureEventArgs Class
Mindscape.PhoneElements Namespace


PreviousTouchPosition2 Property

[image]

Mindscape Phone Elements
DualGestureEventArgs..::..PreviousTouchPosition2 Property
DualGestureEventArgs Class See Also Send Feedback
Gets the previous position of the second touch point in screen coordinates.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point PreviousTouchPosition2 { get; set; }
Visual Basic
Public Property PreviousTouchPosition2 As Point
    Get
    Set
Visual C++
public:
property Point PreviousTouchPosition2 {
    Point get ();
    void set (Point value);
}

See Also

DualGestureEventArgs Class
Mindscape.PhoneElements Namespace


TouchPosition2 Property

[image]

Mindscape Phone Elements
DualGestureEventArgs..::..TouchPosition2 Property
DualGestureEventArgs Class See Also Send Feedback
Gets the current position of the second touch point in screen coordinates.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point TouchPosition2 { get; private set; }
Visual Basic
Public Property TouchPosition2 As Point
    Get
    Private Set
Visual C++
public:
property Point TouchPosition2 {
    Point get ();
    private: void set (Point value);
}

See Also

DualGestureEventArgs Class
Mindscape.PhoneElements Namespace


FlickDirection Enumeration

[image]

Mindscape Phone Elements
FlickDirection Enumeration
See Also Send Feedback
Defines the direction of movement for a flick gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum FlickDirection
Visual Basic
Public Enumeration FlickDirection
Visual C++
public enum class FlickDirection

Members

Member name | Value | Description
Unknown | 0 | The flick direction is unknown.
Up | 1 | The flick was performed upwards.
Down | 2 | The flick was performed downwards.
Left | 3 | The flick was performed to the left.
Right | 4 | The flick was performed to the right.

See Also

Mindscape.PhoneElements Namespace


FlickGestureEventArgs Class

[image]

Mindscape Phone Elements
FlickGestureEventArgs Class
Members See Also Send Feedback
Contains event data related to the flick gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FlickGestureEventArgs : GestureEventArgs
Visual Basic
Public Class FlickGestureEventArgs _
    Inherits GestureEventArgs
Visual C++
public ref class FlickGestureEventArgs : public GestureEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..FlickGestureEventArgs

See Also

FlickGestureEventArgs Members
Mindscape.PhoneElements Namespace


FlickGestureEventArgs Members

[image] [image]

Mindscape Phone Elements
FlickGestureEventArgs Members
FlickGestureEventArgs Class Methods Properties See Also Send Feedback

The FlickGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | Gets the angle of the flick gesture movement.
Public property | FlickDirection | Gets the FlickDirection of the flick gesture.
Public property | FlickOrientation | Gets the orientation of the flick gesture movement. This will either be horizontal or vertical based on which velocity is larger.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | HorizontalVelocity | Gets the horizontal velocity of the flick gesture.
Public property | VerticalVelocity | Gets the vertical velocity of the flick gesture.

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


FlickGestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
FlickGestureEventArgs Methods
FlickGestureEventArgs Class See Also Send Feedback

The FlickGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
FlickGestureEventArgs..::..GetPosition Method
FlickGestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement. (Inherited from GestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)

See Also

FlickGestureEventArgs Class
FlickGestureEventArgs Members
Mindscape.PhoneElements Namespace


FlickGestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
FlickGestureEventArgs Properties
FlickGestureEventArgs Class See Also Send Feedback

The FlickGestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets the angle of the flick gesture movement.
Public property | FlickDirection | Gets the FlickDirection of the flick gesture.
Public property | FlickOrientation | Gets the orientation of the flick gesture movement. This will either be horizontal or vertical based on which velocity is larger.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | HorizontalVelocity | Gets the horizontal velocity of the flick gesture.
Public property | VerticalVelocity | Gets the vertical velocity of the flick gesture.

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


Angle Property

[image]

Mindscape Phone Elements
FlickGestureEventArgs..::..Angle Property
FlickGestureEventArgs Class See Also Send Feedback
Gets the angle of the flick gesture movement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Angle { get; }
Visual Basic
Public ReadOnly Property Angle As Double
    Get
Visual C++
public:
property double Angle {
    double get ();
}

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


FlickDirection Property

[image]

Mindscape Phone Elements
FlickGestureEventArgs..::..FlickDirection Property
FlickGestureEventArgs Class See Also Send Feedback
Gets the FlickDirection of the flick gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FlickDirection FlickDirection { get; }
Visual Basic
Public ReadOnly Property FlickDirection As FlickDirection
    Get
Visual C++
public:
property FlickDirection FlickDirection {
    FlickDirection get ();
}

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


FlickOrientation Property

[image]

Mindscape Phone Elements
FlickGestureEventArgs..::..FlickOrientation Property
FlickGestureEventArgs Class See Also Send Feedback
Gets the orientation of the flick gesture movement. This will either be horizontal or vertical based on which velocity is larger.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation FlickOrientation { get; }
Visual Basic
Public ReadOnly Property FlickOrientation As Orientation
    Get
Visual C++
public:
property Orientation FlickOrientation {
    Orientation get ();
}

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


HorizontalVelocity Property

[image]

Mindscape Phone Elements
FlickGestureEventArgs..::..HorizontalVelocity Property
FlickGestureEventArgs Class See Also Send Feedback
Gets the horizontal velocity of the flick gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double HorizontalVelocity { get; private set; }
Visual Basic
Public Property HorizontalVelocity As Double
    Get
    Private Set
Visual C++
public:
property double HorizontalVelocity {
    double get ();
    private: void set (double value);
}

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


VerticalVelocity Property

[image]

Mindscape Phone Elements
FlickGestureEventArgs..::..VerticalVelocity Property
FlickGestureEventArgs Class See Also Send Feedback
Gets the vertical velocity of the flick gesture.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double VerticalVelocity { get; private set; }
Visual Basic
Public Property VerticalVelocity As Double
    Get
    Private Set
Visual C++
public:
property double VerticalVelocity {
    double get ();
    private: void set (double value);
}

See Also

FlickGestureEventArgs Class
Mindscape.PhoneElements Namespace


FormattingConverter Class

[image]

Mindscape Phone Elements
FormattingConverter Class
Members See Also Send Feedback
Formats a binding source value using a format string.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FormattingConverter : IValueConverter
Visual Basic
Public Class FormattingConverter _
    Implements IValueConverter
Visual C++
public ref class FormattingConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..FormattingConverter

See Also

FormattingConverter Members
Mindscape.PhoneElements Namespace


FormattingConverter Members

[image] [image]

Mindscape Phone Elements
FormattingConverter Members
FormattingConverter Class Constructors Methods Properties See Also Send Feedback

The FormattingConverter type exposes the following members.

Constructors

 | Name | Description
Public method | FormattingConverter | Initializes a new instance of the FormattingConverter class.

Methods

 | Name | Description
Public method | Convert | Formats the binding source value using a format string.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FormatString | Gets or sets the format string.

See Also

FormattingConverter Class
Mindscape.PhoneElements Namespace


FormattingConverter Constructor

[image]

Mindscape Phone Elements
FormattingConverter Constructor
FormattingConverter Class See Also Send Feedback
Initializes a new instance of the FormattingConverter class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FormattingConverter()
Visual Basic
Public Sub New
Visual C++
public:
FormattingConverter()

See Also

FormattingConverter Class
Mindscape.PhoneElements Namespace


FormattingConverter Methods

[image] [image]

Mindscape Phone Elements
FormattingConverter Methods
FormattingConverter Class See Also Send Feedback

The FormattingConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Formats the binding source value using a format string.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormattingConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
FormattingConverter..::..Convert Method
FormattingConverter Class See Also Send Feedback
Formats the binding source value using a format string.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The object value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The formatted object string.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

FormattingConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
FormattingConverter..::..ConvertBack Method
FormattingConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

FormattingConverter Class
Mindscape.PhoneElements Namespace


FormattingConverter Properties

[image] [image]

Mindscape Phone Elements
FormattingConverter Properties
FormattingConverter Class See Also Send Feedback

The FormattingConverter type exposes the following members.

Properties

 | Name | Description
Public property | FormatString | Gets or sets the format string.

See Also

FormattingConverter Class
Mindscape.PhoneElements Namespace


FormatString Property

[image]

Mindscape Phone Elements
FormattingConverter..::..FormatString Property
FormattingConverter Class See Also Send Feedback
Gets or sets the format string.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FormatString { get; set; }
Visual Basic
Public Property FormatString As String
    Get
    Set
Visual C++
public:
property String^ FormatString {
    String^ get ();
    void set (String^ value);
}

See Also

FormattingConverter Class
Mindscape.PhoneElements Namespace


GestureEventArgs Class

[image]

Mindscape Phone Elements
GestureEventArgs Class
Members See Also Send Feedback
A base class for event args containing data for gestures.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GestureEventArgs : EventArgs
Visual Basic
Public Class GestureEventArgs _
    Inherits EventArgs
Visual C++
public ref class GestureEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..DragCompletedGestureEventArgs
Mindscape.PhoneElements..::..DragStartedGestureEventArgs
Mindscape.PhoneElements..::..FlickGestureEventArgs
Mindscape.PhoneElements..::..MovingGestureEventArgs

See Also

GestureEventArgs Members
Mindscape.PhoneElements Namespace


GestureEventArgs Members

[image] [image]

Mindscape Phone Elements
GestureEventArgs Members
GestureEventArgs Class Methods Properties See Also Send Feedback

The GestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement.
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates.

See Also

GestureEventArgs Class
Mindscape.PhoneElements Namespace


GestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
GestureEventArgs Methods
GestureEventArgs Class See Also Send Feedback

The GestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement.
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
GestureEventArgs..::..GetPosition Method
GestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Gets the position of the touch point relative to the given UIElement.
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement.

See Also

GestureEventArgs Class
GestureEventArgs Members
Mindscape.PhoneElements Namespace


GetPosition Method (UIElement)

[image]

Mindscape Phone Elements
GestureEventArgs..::..GetPosition Method (UIElement)
GestureEventArgs Class See Also Send Feedback
Gets the position of the touch point relative to the given UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual Point GetPosition(
    UIElement relativeTo
)
Visual Basic
Public Overridable Function GetPosition ( _
    relativeTo As UIElement _
) As Point
Visual C++
public:
virtual Point GetPosition(
    UIElement^ relativeTo
)

Parameters

relativeTo
Type: System.Windows..::..UIElement
The UIElement to derive the position.

Return Value

The touch point position relative to the given UIElement.

See Also

GestureEventArgs Class
GetPosition Overload
Mindscape.PhoneElements Namespace


GetPosition Method (UIElement, Point)

[image]

Mindscape Phone Elements
GestureEventArgs..::..GetPosition Method (UIElement, Point)
GestureEventArgs Class See Also Send Feedback
Returns the given screen position relative to the given UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Point GetPosition(
    UIElement relativeTo,
    Point screenPosition
)
Visual Basic
Protected Function GetPosition ( _
    relativeTo As UIElement, _
    screenPosition As Point _
) As Point
Visual C++
protected:
Point GetPosition(
    UIElement^ relativeTo,
    Point screenPosition
)

Parameters

relativeTo
Type: System.Windows..::..UIElement
The UIElement to derive the position.
screenPosition
Type: System.Windows..::..Point
A position in screen coordinates.

Return Value

The given screen position relative to the given UIElement.

See Also

GestureEventArgs Class
GetPosition Overload
Mindscape.PhoneElements Namespace


GestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
GestureEventArgs Properties
GestureEventArgs Class See Also Send Feedback

The GestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates.

See Also

GestureEventArgs Class
Mindscape.PhoneElements Namespace


GestureOrigin Property

[image]

Mindscape Phone Elements
GestureEventArgs..::..GestureOrigin Property
GestureEventArgs Class See Also Send Feedback
Gets the origin of the gesture in screen coordinates.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point GestureOrigin { get; private set; }
Visual Basic
Public Property GestureOrigin As Point
    Get
    Private Set
Visual C++
public:
property Point GestureOrigin {
    Point get ();
    private: void set (Point value);
}

See Also

GestureEventArgs Class
Mindscape.PhoneElements Namespace


GestureListener Class

[image]

Mindscape Phone Elements
GestureListener Class
Members See Also Send Feedback
Raises gesture events for a UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GestureListener
Visual Basic
Public Class GestureListener
Visual C++
public ref class GestureListener

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..GestureListener

See Also

GestureListener Members
Mindscape.PhoneElements Namespace


GestureListener Members

[image] [image]

Mindscape Phone Elements
GestureListener Members
GestureListener Class Constructors Methods Events See Also Send Feedback

The GestureListener type exposes the following members.

Constructors

 | Name | Description
Public method | GestureListener | Initializes a new instance of the GestureListener class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Terminate | Causes the GestureListener to permanently stop listening for gestures on the UIElement.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | DoubleTap | Raised when 2 tap gesture are performed in quick succssession with a minimal distance between each tap position.
Public event | DragCompleted | Raised when a drag gesture has been completed on the UIElement. A drag gesture is completed when the touch point is removed from the UIElement.
Public event | DragDelta | Raised when touch point movement is detected during a drag gesture on the UIElement.
Public event | DragStarted | Raised when a drag gesture has started on the UIElement.
Public event | Flick | Raised when a flick gesture is performed on the UIElement.
Public event | GestureCompleted | Raised when all touch points have left the UIElement.
Public event | GestureStarted | Raised when at least 1 touch point is created on the UIElement.
Public event | Hold | Raised when a single touch point is held on the UIElement without moving for 1 second.
Public event | PinchCompleted | Raised when a pinch gesture has been completed. A pinch gesture is completed when all the touch points have left the UIElement.
Public event | PinchDelta | Raised when touch point movement is detected during a pinch gesture on the UIElement. A pinch gesture consists of 2 fingers moving on the UIElement.
Public event | PinchStarted | Raised when a pinch gesture is started on the UIElement.
Public event | Tap | Raised when the UIElement is touched and then released at any time with no dragging movement in between.

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


GestureListener Constructor

[image]

Mindscape Phone Elements
GestureListener Constructor
GestureListener Class See Also Send Feedback
Initializes a new instance of the GestureListener class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GestureListener(
    UIElement element
)
Visual Basic
Public Sub New ( _
    element As UIElement _
)
Visual C++
public:
GestureListener(
    UIElement^ element
)

Parameters

element
Type: System.Windows..::..UIElement
The UIElement used to listen for gestures.

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


GestureListener Methods

[image] [image]

Mindscape Phone Elements
GestureListener Methods
GestureListener Class See Also Send Feedback

The GestureListener type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Terminate | Causes the GestureListener to permanently stop listening for gestures on the UIElement.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


Terminate Method

[image]

Mindscape Phone Elements
GestureListener..::..Terminate Method
GestureListener Class See Also Send Feedback
Causes the GestureListener to permanently stop listening for gestures on the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Terminate()
Visual Basic
Public Sub Terminate
Visual C++
public:
void Terminate()

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


GestureListener Events

[image] [image]

Mindscape Phone Elements
GestureListener Events
GestureListener Class See Also Send Feedback

The GestureListener type exposes the following members.

Events

 | Name | Description
Public event | DoubleTap | Raised when 2 tap gesture are performed in quick succssession with a minimal distance between each tap position.
Public event | DragCompleted | Raised when a drag gesture has been completed on the UIElement. A drag gesture is completed when the touch point is removed from the UIElement.
Public event | DragDelta | Raised when touch point movement is detected during a drag gesture on the UIElement.
Public event | DragStarted | Raised when a drag gesture has started on the UIElement.
Public event | Flick | Raised when a flick gesture is performed on the UIElement.
Public event | GestureCompleted | Raised when all touch points have left the UIElement.
Public event | GestureStarted | Raised when at least 1 touch point is created on the UIElement.
Public event | Hold | Raised when a single touch point is held on the UIElement without moving for 1 second.
Public event | PinchCompleted | Raised when a pinch gesture has been completed. A pinch gesture is completed when all the touch points have left the UIElement.
Public event | PinchDelta | Raised when touch point movement is detected during a pinch gesture on the UIElement. A pinch gesture consists of 2 fingers moving on the UIElement.
Public event | PinchStarted | Raised when a pinch gesture is started on the UIElement.
Public event | Tap | Raised when the UIElement is touched and then released at any time with no dragging movement in between.

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


DoubleTap Event

[image]

Mindscape Phone Elements
GestureListener..::..DoubleTap Event
GestureListener Class See Also Send Feedback
Raised when 2 tap gesture are performed in quick succssession with a minimal distance between each tap position.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<GestureEventArgs> DoubleTap
Visual Basic
Public Event DoubleTap As EventHandler(Of GestureEventArgs)
Visual C++
public:
 event EventHandler<GestureEventArgs^>^ DoubleTap {
    void add (EventHandler<GestureEventArgs^>^ value);
    void remove (EventHandler<GestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


DragCompleted Event

[image]

Mindscape Phone Elements
GestureListener..::..DragCompleted Event
GestureListener Class See Also Send Feedback
Raised when a drag gesture has been completed on the UIElement. A drag gesture is completed when the touch point is removed from the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<DragCompletedGestureEventArgs> DragCompleted
Visual Basic
Public Event DragCompleted As EventHandler(Of DragCompletedGestureEventArgs)
Visual C++
public:
 event EventHandler<DragCompletedGestureEventArgs^>^ DragCompleted {
    void add (EventHandler<DragCompletedGestureEventArgs^>^ value);
    void remove (EventHandler<DragCompletedGestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


DragDelta Event

[image]

Mindscape Phone Elements
GestureListener..::..DragDelta Event
GestureListener Class See Also Send Feedback
Raised when touch point movement is detected during a drag gesture on the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<DragDeltaGestureEventArgs> DragDelta
Visual Basic
Public Event DragDelta As EventHandler(Of DragDeltaGestureEventArgs)
Visual C++
public:
 event EventHandler<DragDeltaGestureEventArgs^>^ DragDelta {
    void add (EventHandler<DragDeltaGestureEventArgs^>^ value);
    void remove (EventHandler<DragDeltaGestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


DragStarted Event

[image]

Mindscape Phone Elements
GestureListener..::..DragStarted Event
GestureListener Class See Also Send Feedback
Raised when a drag gesture has started on the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<DragStartedGestureEventArgs> DragStarted
Visual Basic
Public Event DragStarted As EventHandler(Of DragStartedGestureEventArgs)
Visual C++
public:
 event EventHandler<DragStartedGestureEventArgs^>^ DragStarted {
    void add (EventHandler<DragStartedGestureEventArgs^>^ value);
    void remove (EventHandler<DragStartedGestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


Flick Event

[image]

Mindscape Phone Elements
GestureListener..::..Flick Event
GestureListener Class See Also Send Feedback
Raised when a flick gesture is performed on the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<FlickGestureEventArgs> Flick
Visual Basic
Public Event Flick As EventHandler(Of FlickGestureEventArgs)
Visual C++
public:
 event EventHandler<FlickGestureEventArgs^>^ Flick {
    void add (EventHandler<FlickGestureEventArgs^>^ value);
    void remove (EventHandler<FlickGestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


GestureCompleted Event

[image]

Mindscape Phone Elements
GestureListener..::..GestureCompleted Event
GestureListener Class See Also Send Feedback
Raised when all touch points have left the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<GestureEventArgs> GestureCompleted
Visual Basic
Public Event GestureCompleted As EventHandler(Of GestureEventArgs)
Visual C++
public:
 event EventHandler<GestureEventArgs^>^ GestureCompleted {
    void add (EventHandler<GestureEventArgs^>^ value);
    void remove (EventHandler<GestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


GestureStarted Event

[image]

Mindscape Phone Elements
GestureListener..::..GestureStarted Event
GestureListener Class See Also Send Feedback
Raised when at least 1 touch point is created on the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<GestureEventArgs> GestureStarted
Visual Basic
Public Event GestureStarted As EventHandler(Of GestureEventArgs)
Visual C++
public:
 event EventHandler<GestureEventArgs^>^ GestureStarted {
    void add (EventHandler<GestureEventArgs^>^ value);
    void remove (EventHandler<GestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


Hold Event

[image]

Mindscape Phone Elements
GestureListener..::..Hold Event
GestureListener Class See Also Send Feedback
Raised when a single touch point is held on the UIElement without moving for 1 second.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<GestureEventArgs> Hold
Visual Basic
Public Event Hold As EventHandler(Of GestureEventArgs)
Visual C++
public:
 event EventHandler<GestureEventArgs^>^ Hold {
    void add (EventHandler<GestureEventArgs^>^ value);
    void remove (EventHandler<GestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


PinchCompleted Event

[image]

Mindscape Phone Elements
GestureListener..::..PinchCompleted Event
GestureListener Class See Also Send Feedback
Raised when a pinch gesture has been completed. A pinch gesture is completed when all the touch points have left the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<PinchGestureEventArgs> PinchCompleted
Visual Basic
Public Event PinchCompleted As EventHandler(Of PinchGestureEventArgs)
Visual C++
public:
 event EventHandler<PinchGestureEventArgs^>^ PinchCompleted {
    void add (EventHandler<PinchGestureEventArgs^>^ value);
    void remove (EventHandler<PinchGestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


PinchDelta Event

[image]

Mindscape Phone Elements
GestureListener..::..PinchDelta Event
GestureListener Class See Also Send Feedback
Raised when touch point movement is detected during a pinch gesture on the UIElement. A pinch gesture consists of 2 fingers moving on the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<PinchGestureEventArgs> PinchDelta
Visual Basic
Public Event PinchDelta As EventHandler(Of PinchGestureEventArgs)
Visual C++
public:
 event EventHandler<PinchGestureEventArgs^>^ PinchDelta {
    void add (EventHandler<PinchGestureEventArgs^>^ value);
    void remove (EventHandler<PinchGestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


PinchStarted Event

[image]

Mindscape Phone Elements
GestureListener..::..PinchStarted Event
GestureListener Class See Also Send Feedback
Raised when a pinch gesture is started on the UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<PinchGestureEventArgs> PinchStarted
Visual Basic
Public Event PinchStarted As EventHandler(Of PinchGestureEventArgs)
Visual C++
public:
 event EventHandler<PinchGestureEventArgs^>^ PinchStarted {
    void add (EventHandler<PinchGestureEventArgs^>^ value);
    void remove (EventHandler<PinchGestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


Tap Event

[image]

Mindscape Phone Elements
GestureListener..::..Tap Event
GestureListener Class See Also Send Feedback
Raised when the UIElement is touched and then released at any time with no dragging movement in between.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<GestureEventArgs> Tap
Visual Basic
Public Event Tap As EventHandler(Of GestureEventArgs)
Visual C++
public:
 event EventHandler<GestureEventArgs^>^ Tap {
    void add (EventHandler<GestureEventArgs^>^ value);
    void remove (EventHandler<GestureEventArgs^>^ value);
}

See Also

GestureListener Class
Mindscape.PhoneElements Namespace


HeaderedItemsControl Class

[image]

Mindscape Phone Elements
HeaderedItemsControl Class
Members See Also Send Feedback
A simple HeaderedItemsControl implementation.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class HeaderedItemsControl : ItemsControl
Visual Basic
Public Class HeaderedItemsControl _
    Inherits ItemsControl
Visual C++
public ref class HeaderedItemsControl : public ItemsControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
Mindscape.PhoneElements..::..HeaderedItemsControl
Mindscape.PhoneElements.Charting..::..Legend

See Also

HeaderedItemsControl Members
Mindscape.PhoneElements Namespace


HeaderedItemsControl Members

[image] [image]

Mindscape Phone Elements
HeaderedItemsControl Members
HeaderedItemsControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Constructors

 | Name | Description
Public method | HeaderedItemsControl | Initializes a new instance of the HeaderedItemsControl.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
HeaderProperty | Identifies the Header property.
HeaderTemplateProperty | Identifies the HeaderTemplate property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Header | Gets or sets the item that labels the control. This is a dependency property.
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the contents of the control's header. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderedItemsControl Constructor

[image]

Mindscape Phone Elements
HeaderedItemsControl Constructor
HeaderedItemsControl Class See Also Send Feedback
Initializes a new instance of the HeaderedItemsControl.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HeaderedItemsControl()
Visual Basic
Public Sub New
Visual C++
public:
HeaderedItemsControl()

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderedItemsControl Fields

[image] [image]

Mindscape Phone Elements
HeaderedItemsControl Fields
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Fields

Name | Description
HeaderProperty | Identifies the Header property.
HeaderTemplateProperty | Identifies the HeaderTemplate property.

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderProperty Field

[image]

Mindscape Phone Elements
HeaderedItemsControl..::..HeaderProperty Field
HeaderedItemsControl Class See Also Send Feedback
Identifies the Header property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HeaderProperty
Visual Basic
Public Shared ReadOnly HeaderProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HeaderProperty

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderTemplateProperty Field

[image]

Mindscape Phone Elements
HeaderedItemsControl..::..HeaderTemplateProperty Field
HeaderedItemsControl Class See Also Send Feedback
Identifies the HeaderTemplate property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HeaderTemplateProperty
Visual Basic
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HeaderTemplateProperty

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderedItemsControl Methods

[image] [image]

Mindscape Phone Elements
HeaderedItemsControl Methods
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderedItemsControl Properties

[image] [image]

Mindscape Phone Elements
HeaderedItemsControl Properties
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Header | Gets or sets the item that labels the control. This is a dependency property.
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the contents of the control's header. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


Header Property

[image]

Mindscape Phone Elements
HeaderedItemsControl..::..Header Property
HeaderedItemsControl Class See Also Send Feedback
Gets or sets the item that labels the control. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Header { get; set; }
Visual Basic
Public Property Header As Object
    Get
    Set
Visual C++
public:
property Object^ Header {
    Object^ get ();
    void set (Object^ value);
}

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderTemplate Property

[image]

Mindscape Phone Elements
HeaderedItemsControl..::..HeaderTemplate Property
HeaderedItemsControl Class See Also Send Feedback
Gets or sets the DataTemplate used to display the contents of the control's header. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate HeaderTemplate { get; set; }
Visual Basic
Public Property HeaderTemplate As DataTemplate
    Get
    Set
Visual C++
public:
property DataTemplate^ HeaderTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


HeaderedItemsControl Events

[image] [image]

Mindscape Phone Elements
HeaderedItemsControl Events
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
Mindscape.PhoneElements Namespace


IDataSource Interface

[image]

Mindscape Phone Elements
IDataSource Interface
Members See Also Send Feedback
Aids in virtualisation for a sequential list of data.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IDataSource
Visual Basic
Public Interface IDataSource
Visual C++
public interface class IDataSource

See Also

IDataSource Members
Mindscape.PhoneElements Namespace


IDataSource Members

[image] [image]

Mindscape Phone Elements
IDataSource Members
IDataSource Interface Methods Properties See Also Send Feedback

The IDataSource type exposes the following members.

Methods

 | Name | Description
Public method | GetNext | Returns the next data object in the sequence based on the given delta value.

Properties

 | Name | Description
Public property | FirstValue | Gets the first object in the sequence.

See Also

IDataSource Interface
Mindscape.PhoneElements Namespace


IDataSource Methods

[image] [image]

Mindscape Phone Elements
IDataSource Methods
IDataSource Interface See Also Send Feedback

The IDataSource type exposes the following members.

Methods

 | Name | Description
Public method | GetNext | Returns the next data object in the sequence based on the given delta value.

See Also

IDataSource Interface
Mindscape.PhoneElements Namespace


GetNext Method

[image]

Mindscape Phone Elements
IDataSource..::..GetNext Method
IDataSource Interface See Also Send Feedback
Returns the next data object in the sequence based on the given delta value.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Object GetNext(
    Object current,
    int deltaIndex
)
Visual Basic
Function GetNext ( _
    current As Object, _
    deltaIndex As Integer _
) As Object
Visual C++
Object^ GetNext(
    Object^ current,
    int deltaIndex
)

Parameters

current
Type: System..::..Object
The current data object.
deltaIndex
Type: System..::..Int32
A delta value indicating how far to advance through the sequence.

Return Value

The next data object. This will be the current value offset by the delta value.

See Also

IDataSource Interface
Mindscape.PhoneElements Namespace


IDataSource Properties

[image] [image]

Mindscape Phone Elements
IDataSource Properties
IDataSource Interface See Also Send Feedback

The IDataSource type exposes the following members.

Properties

 | Name | Description
Public property | FirstValue | Gets the first object in the sequence.

See Also

IDataSource Interface
Mindscape.PhoneElements Namespace


FirstValue Property

[image]

Mindscape Phone Elements
IDataSource..::..FirstValue Property
IDataSource Interface See Also Send Feedback
Gets the first object in the sequence.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Object FirstValue { get; }
Visual Basic
ReadOnly Property FirstValue As Object
    Get
Visual C++
property Object^ FirstValue {
    Object^ get ();
}

See Also

IDataSource Interface
Mindscape.PhoneElements Namespace


IDatePickerPage Interface

[image]

Mindscape Phone Elements
IDatePickerPage Interface
Members See Also Send Feedback
Represents a PhoneApplicationPage that can be opened by a DatePicker control.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IDatePickerPage
Visual Basic
Public Interface IDatePickerPage
Visual C++
public interface class IDatePickerPage

See Also

IDatePickerPage Members
Mindscape.PhoneElements Namespace


IDatePickerPage Members

[image] [image]

Mindscape Phone Elements
IDatePickerPage Members
IDatePickerPage Interface Properties See Also Send Feedback

The IDatePickerPage type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the current CultureInfo used to format the date.
Public property | DateFormat | Gets or sets the date format string.
Public property | SelectedDate | Gets or sets the currently selected DateTime.

See Also

IDatePickerPage Interface
Mindscape.PhoneElements Namespace


IDatePickerPage Properties

[image] [image]

Mindscape Phone Elements
IDatePickerPage Properties
IDatePickerPage Interface See Also Send Feedback

The IDatePickerPage type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the current CultureInfo used to format the date.
Public property | DateFormat | Gets or sets the date format string.
Public property | SelectedDate | Gets or sets the currently selected DateTime.

See Also

IDatePickerPage Interface
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
IDatePickerPage..::..Culture Property
IDatePickerPage Interface See Also Send Feedback
Gets the current CultureInfo used to format the date.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
CultureInfo Culture { get; set; }
Visual Basic
Property Culture As CultureInfo
    Get
    Set
Visual C++
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

IDatePickerPage Interface
Mindscape.PhoneElements Namespace


DateFormat Property

[image]

Mindscape Phone Elements
IDatePickerPage..::..DateFormat Property
IDatePickerPage Interface See Also Send Feedback
Gets or sets the date format string.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
string DateFormat { get; set; }
Visual Basic
Property DateFormat As String
    Get
    Set
Visual C++
property String^ DateFormat {
    String^ get ();
    void set (String^ value);
}

See Also

IDatePickerPage Interface
Mindscape.PhoneElements Namespace


SelectedDate Property

[image]

Mindscape Phone Elements
IDatePickerPage..::..SelectedDate Property
IDatePickerPage Interface See Also Send Feedback
Gets or sets the currently selected DateTime.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
DateTime SelectedDate { get; set; }
Visual Basic
Property SelectedDate As DateTime
    Get
    Set
Visual C++
property DateTime SelectedDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

IDatePickerPage Interface
Mindscape.PhoneElements Namespace


ITimePickerPage Interface

[image]

Mindscape Phone Elements
ITimePickerPage Interface
Members See Also Send Feedback
Represents a PhoneApplicationPage that can be opened by a TimePicker control.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface ITimePickerPage
Visual Basic
Public Interface ITimePickerPage
Visual C++
public interface class ITimePickerPage

See Also

ITimePickerPage Members
Mindscape.PhoneElements Namespace


ITimePickerPage Members

[image] [image]

Mindscape Phone Elements
ITimePickerPage Members
ITimePickerPage Interface Properties See Also Send Feedback

The ITimePickerPage type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the current CultureInfo used to format the time.
Public property | SelectedTime | Gets or sets the currently selected TimeOfDay.
Public property | TimeDisplayMode | Gets or sets the TimeDisplayMode.

See Also

ITimePickerPage Interface
Mindscape.PhoneElements Namespace


ITimePickerPage Properties

[image] [image]

Mindscape Phone Elements
ITimePickerPage Properties
ITimePickerPage Interface See Also Send Feedback

The ITimePickerPage type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets the current CultureInfo used to format the time.
Public property | SelectedTime | Gets or sets the currently selected TimeOfDay.
Public property | TimeDisplayMode | Gets or sets the TimeDisplayMode.

See Also

ITimePickerPage Interface
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
ITimePickerPage..::..Culture Property
ITimePickerPage Interface See Also Send Feedback
Gets the current CultureInfo used to format the time.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
CultureInfo Culture { get; set; }
Visual Basic
Property Culture As CultureInfo
    Get
    Set
Visual C++
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

ITimePickerPage Interface
Mindscape.PhoneElements Namespace


SelectedTime Property

[image]

Mindscape Phone Elements
ITimePickerPage..::..SelectedTime Property
ITimePickerPage Interface See Also Send Feedback
Gets or sets the currently selected TimeOfDay.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
TimeOfDay SelectedTime { get; set; }
Visual Basic
Property SelectedTime As TimeOfDay
    Get
    Set
Visual C++
property TimeOfDay SelectedTime {
    TimeOfDay get ();
    void set (TimeOfDay value);
}

See Also

ITimePickerPage Interface
Mindscape.PhoneElements Namespace


TimeDisplayMode Property

[image]

Mindscape Phone Elements
ITimePickerPage..::..TimeDisplayMode Property
ITimePickerPage Interface See Also Send Feedback
Gets or sets the TimeDisplayMode.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
TimeDisplayMode TimeDisplayMode { get; set; }
Visual Basic
Property TimeDisplayMode As TimeDisplayMode
    Get
    Set
Visual C++
property TimeDisplayMode TimeDisplayMode {
    TimeDisplayMode get ();
    void set (TimeDisplayMode value);
}

See Also

ITimePickerPage Interface
Mindscape.PhoneElements Namespace


ListToSubListConverter Class

[image]

Mindscape Phone Elements
ListToSubListConverter Class
Members See Also Send Feedback
Extracts a sub-list from a master list.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListToSubListConverter : IValueConverter
Visual Basic
Public Class ListToSubListConverter _
    Implements IValueConverter
Visual C++
public ref class ListToSubListConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ListToSubListConverter

See Also

ListToSubListConverter Members
Mindscape.PhoneElements Namespace


ListToSubListConverter Members

[image] [image]

Mindscape Phone Elements
ListToSubListConverter Members
ListToSubListConverter Class Constructors Methods Properties See Also Send Feedback

The ListToSubListConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ListToSubListConverter | Initializes a new instance of the ListToSubListConverter class

Methods

 | Name | Description
Public method | Convert | Extracts a sub-list from a master list. The sub-list begins at StartIndex, and has Length elements.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Length | The length of the sub-list.
Public property | StartIndex | The index within the source list at which to start extracting the sub-list.

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


ListToSubListConverter Constructor

[image]

Mindscape Phone Elements
ListToSubListConverter Constructor
ListToSubListConverter Class See Also Send Feedback
Initializes a new instance of the ListToSubListConverter class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListToSubListConverter()
Visual Basic
Public Sub New
Visual C++
public:
ListToSubListConverter()

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


ListToSubListConverter Methods

[image] [image]

Mindscape Phone Elements
ListToSubListConverter Methods
ListToSubListConverter Class See Also Send Feedback

The ListToSubListConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Extracts a sub-list from a master list. The sub-list begins at StartIndex, and has Length elements.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
ListToSubListConverter..::..Convert Method
ListToSubListConverter Class See Also Send Feedback
Extracts a sub-list from a master list. The sub-list begins at StartIndex, and has Length elements.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The IList value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The sub-list extracted from the master list.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
ListToSubListConverter..::..ConvertBack Method
ListToSubListConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


ListToSubListConverter Properties

[image] [image]

Mindscape Phone Elements
ListToSubListConverter Properties
ListToSubListConverter Class See Also Send Feedback

The ListToSubListConverter type exposes the following members.

Properties

 | Name | Description
Public property | Length | The length of the sub-list.
Public property | StartIndex | The index within the source list at which to start extracting the sub-list.

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


Length Property

[image]

Mindscape Phone Elements
ListToSubListConverter..::..Length Property
ListToSubListConverter Class See Also Send Feedback
The length of the sub-list.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Length { get; set; }
Visual Basic
Public Property Length As Integer
    Get
    Set
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


StartIndex Property

[image]

Mindscape Phone Elements
ListToSubListConverter..::..StartIndex Property
ListToSubListConverter Class See Also Send Feedback
The index within the source list at which to start extracting the sub-list.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int StartIndex { get; set; }
Visual Basic
Public Property StartIndex As Integer
    Get
    Set
Visual C++
public:
property int StartIndex {
    int get ();
    void set (int value);
}

See Also

ListToSubListConverter Class
Mindscape.PhoneElements Namespace


LoopingListBox Class

[image]

Mindscape Phone Elements
LoopingListBox Class
Members See Also Send Feedback
A control that loops through a data source allowing a user to select an item.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoopingListBox : Control
Visual Basic
Public Class LoopingListBox _
    Inherits Control
Visual C++
public ref class LoopingListBox : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements..::..LoopingListBox

See Also

LoopingListBox Members
Mindscape.PhoneElements Namespace


LoopingListBox Members

[image] [image]

Mindscape Phone Elements
LoopingListBox Members
LoopingListBox Class Constructors Methods Fields Properties Events See Also Send Feedback

The LoopingListBox type exposes the following members.

Constructors

 | Name | Description
Public method | LoopingListBox | Initializes a new instance of the LoopingListBox class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | Called when the LoopingListBox looses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
DataSourceProperty | Identifies the DataSource property.
IsExpandedProperty | Identifies the IsExpanded property.
ItemTemplateProperty | Identifies the ItemTemplate property.
SelectedItemProperty | Identifies the SelectedItem property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataSource | Gets or sets the IDataSource used to define the items displayed by the LoopingListBox. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsExpanded | Gets or sets whether or not the LoopingListBox items are expanded or collapsed. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the LoopingListBox.
Public property | ItemMargin | Gets or sets the margin around an item in the LoopingListBox.
Public property | ItemTemplate | Gets or sets the DataTemplate used to display the data objects. This is a dependency property.
Public property | ItemWidth | Gets or sets the width of an item in the LoopingListBox.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedItem | Gets or sets the selected data object. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Raised when the selected data object is changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


LoopingListBox Constructor

[image]

Mindscape Phone Elements
LoopingListBox Constructor
LoopingListBox Class See Also Send Feedback
Initializes a new instance of the LoopingListBox class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoopingListBox()
Visual Basic
Public Sub New
Visual C++
public:
LoopingListBox()

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


LoopingListBox Fields

[image] [image]

Mindscape Phone Elements
LoopingListBox Fields
LoopingListBox Class See Also Send Feedback

The LoopingListBox type exposes the following members.

Fields

Name | Description
DataSourceProperty | Identifies the DataSource property.
IsExpandedProperty | Identifies the IsExpanded property.
ItemTemplateProperty | Identifies the ItemTemplate property.
SelectedItemProperty | Identifies the SelectedItem property.

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


DataSourceProperty Field

[image]

Mindscape Phone Elements
LoopingListBox..::..DataSourceProperty Field
LoopingListBox Class See Also Send Feedback
Identifies the DataSource property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DataSourceProperty
Visual Basic
Public Shared ReadOnly DataSourceProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DataSourceProperty

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


IsExpandedProperty Field

[image]

Mindscape Phone Elements
LoopingListBox..::..IsExpandedProperty Field
LoopingListBox Class See Also Send Feedback
Identifies the IsExpanded property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsExpandedProperty
Visual Basic
Public Shared ReadOnly IsExpandedProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsExpandedProperty

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


ItemTemplateProperty Field

[image]

Mindscape Phone Elements
LoopingListBox..::..ItemTemplateProperty Field
LoopingListBox Class See Also Send Feedback
Identifies the ItemTemplate property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemTemplateProperty
Visual Basic
Public Shared ReadOnly ItemTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemTemplateProperty

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


SelectedItemProperty Field

[image]

Mindscape Phone Elements
LoopingListBox..::..SelectedItemProperty Field
LoopingListBox Class See Also Send Feedback
Identifies the SelectedItem property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedItemProperty
Visual Basic
Public Shared ReadOnly SelectedItemProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedItemProperty

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


LoopingListBox Methods

[image] [image]

Mindscape Phone Elements
LoopingListBox Methods
LoopingListBox Class See Also Send Feedback

The LoopingListBox type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | Called when the LoopingListBox looses focus. (Overrides ControlOnLostFocus(RoutedEventArgs).)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


OnApplyTemplate Method

[image]

Mindscape Phone Elements
LoopingListBox..::..OnApplyTemplate Method
LoopingListBox Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


OnLostFocus Method

[image]

Mindscape Phone Elements
LoopingListBox..::..OnLostFocus Method
LoopingListBox Class See Also Send Feedback
Called when the LoopingListBox looses focus.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    RoutedEventArgs e
)
Visual Basic
Protected Overrides Sub OnLostFocus ( _
    e As RoutedEventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.Windows..::..RoutedEventArgs
The event data.

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


LoopingListBox Properties

[image] [image]

Mindscape Phone Elements
LoopingListBox Properties
LoopingListBox Class See Also Send Feedback

The LoopingListBox type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataSource | Gets or sets the IDataSource used to define the items displayed by the LoopingListBox. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsExpanded | Gets or sets whether or not the LoopingListBox items are expanded or collapsed. This is a dependency property.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of an item in the LoopingListBox.
Public property | ItemMargin | Gets or sets the margin around an item in the LoopingListBox.
Public property | ItemTemplate | Gets or sets the DataTemplate used to display the data objects. This is a dependency property.
Public property | ItemWidth | Gets or sets the width of an item in the LoopingListBox.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedItem | Gets or sets the selected data object. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


DataSource Property

[image]

Mindscape Phone Elements
LoopingListBox..::..DataSource Property
LoopingListBox Class See Also Send Feedback
Gets or sets the IDataSource used to define the items displayed by the LoopingListBox. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IDataSource DataSource { get; set; }
Visual Basic
Public Property DataSource As IDataSource
    Get
    Set
Visual C++
public:
property IDataSource^ DataSource {
    IDataSource^ get ();
    void set (IDataSource^ value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


IsExpanded Property

[image]

Mindscape Phone Elements
LoopingListBox..::..IsExpanded Property
LoopingListBox Class See Also Send Feedback
Gets or sets whether or not the LoopingListBox items are expanded or collapsed. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic
Public Property IsExpanded As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


ItemHeight Property

[image]

Mindscape Phone Elements
LoopingListBox..::..ItemHeight Property
LoopingListBox Class See Also Send Feedback
Gets or sets the height of an item in the LoopingListBox.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ItemHeight { get; set; }
Visual Basic
Public Property ItemHeight As Double
    Get
    Set
Visual C++
public:
property double ItemHeight {
    double get ();
    void set (double value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


ItemMargin Property

[image]

Mindscape Phone Elements
LoopingListBox..::..ItemMargin Property
LoopingListBox Class See Also Send Feedback
Gets or sets the margin around an item in the LoopingListBox.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Thickness ItemMargin { get; set; }
Visual Basic
Public Property ItemMargin As Thickness
    Get
    Set
Visual C++
public:
property Thickness ItemMargin {
    Thickness get ();
    void set (Thickness value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


ItemTemplate Property

[image]

Mindscape Phone Elements
LoopingListBox..::..ItemTemplate Property
LoopingListBox Class See Also Send Feedback
Gets or sets the DataTemplate used to display the data objects. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate ItemTemplate { get; set; }
Visual Basic
Public Property ItemTemplate As DataTemplate
    Get
    Set
Visual C++
public:
property DataTemplate^ ItemTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


ItemWidth Property

[image]

Mindscape Phone Elements
LoopingListBox..::..ItemWidth Property
LoopingListBox Class See Also Send Feedback
Gets or sets the width of an item in the LoopingListBox.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ItemWidth { get; set; }
Visual Basic
Public Property ItemWidth As Double
    Get
    Set
Visual C++
public:
property double ItemWidth {
    double get ();
    void set (double value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


SelectedItem Property

[image]

Mindscape Phone Elements
LoopingListBox..::..SelectedItem Property
LoopingListBox Class See Also Send Feedback
Gets or sets the selected data object. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic
Public Property SelectedItem As Object
    Get
    Set
Visual C++
public:
property Object^ SelectedItem {
    Object^ get ();
    void set (Object^ value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


LoopingListBox Events

[image] [image]

Mindscape Phone Elements
LoopingListBox Events
LoopingListBox Class See Also Send Feedback

The LoopingListBox type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SelectionChanged | Raised when the selected data object is changed.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


SelectionChanged Event

[image]

Mindscape Phone Elements
LoopingListBox..::..SelectionChanged Event
LoopingListBox Class See Also Send Feedback
Raised when the selected data object is changed.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event SelectionChangedEventHandler SelectionChanged
Visual Basic
Public Event SelectionChanged As SelectionChangedEventHandler
Visual C++
public:
 event SelectionChangedEventHandler^ SelectionChanged {
    void add (SelectionChangedEventHandler^ value);
    void remove (SelectionChangedEventHandler^ value);
}

See Also

LoopingListBox Class
Mindscape.PhoneElements Namespace


LoopingListBoxItem Class

[image]

Mindscape Phone Elements
LoopingListBoxItem Class
Members See Also Send Feedback
Displays a single data item in a LoopingListBox control.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LoopingListBoxItem : ContentControl
Visual Basic
Public Class LoopingListBoxItem _
    Inherits ContentControl
Visual C++
public ref class LoopingListBoxItem : public ContentControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
Mindscape.PhoneElements..::..LoopingListBoxItem

See Also

LoopingListBoxItem Members
Mindscape.PhoneElements Namespace


LoopingListBoxItem Members

[image] [image]

Mindscape Phone Elements
LoopingListBoxItem Members
LoopingListBoxItem Class Constructors Methods Properties Events See Also Send Feedback

The LoopingListBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | LoopingListBoxItem | Initializes a new instance of the LoopingListBoxItem class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LoopingListBoxItem Class
Mindscape.PhoneElements Namespace


LoopingListBoxItem Constructor

[image]

Mindscape Phone Elements
LoopingListBoxItem Constructor
LoopingListBoxItem Class See Also Send Feedback
Initializes a new instance of the LoopingListBoxItem class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LoopingListBoxItem()
Visual Basic
Public Sub New
Visual C++
public:
LoopingListBoxItem()

See Also

LoopingListBoxItem Class
Mindscape.PhoneElements Namespace


LoopingListBoxItem Methods

[image] [image]

Mindscape Phone Elements
LoopingListBoxItem Methods
LoopingListBoxItem Class See Also Send Feedback

The LoopingListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

LoopingListBoxItem Class
Mindscape.PhoneElements Namespace


LoopingListBoxItem Properties

[image] [image]

Mindscape Phone Elements
LoopingListBoxItem Properties
LoopingListBoxItem Class See Also Send Feedback

The LoopingListBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

LoopingListBoxItem Class
Mindscape.PhoneElements Namespace


LoopingListBoxItem Events

[image] [image]

Mindscape Phone Elements
LoopingListBoxItem Events
LoopingListBoxItem Class See Also Send Feedback

The LoopingListBoxItem type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LoopingListBoxItem Class
Mindscape.PhoneElements Namespace


MonthOfYearDataSource Class

[image]

Mindscape Phone Elements
MonthOfYearDataSource Class
Members See Also Send Feedback
A looping data source that loops through the 12 months of a year. This looping data source uses DateTimeWrapper objects.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MonthOfYearDataSource : IDataSource
Visual Basic
Public Class MonthOfYearDataSource _
    Implements IDataSource
Visual C++
public ref class MonthOfYearDataSource : IDataSource

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..MonthOfYearDataSource

See Also

MonthOfYearDataSource Members
Mindscape.PhoneElements Namespace


MonthOfYearDataSource Members

[image] [image]

Mindscape Phone Elements
MonthOfYearDataSource Members
MonthOfYearDataSource Class Constructors Methods Properties See Also Send Feedback

The MonthOfYearDataSource type exposes the following members.

Constructors

 | Name | Description
Public method | MonthOfYearDataSource()()()() | Initializes a new instance of the MonthOfYearDataSource class.
Public method | MonthOfYearDataSource(CultureInfo) | Initializes a new instance of the MonthOfYearDataSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Gets the next month based on the delta value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Culture | Gets or sets the CultureInfo used to format the date.
Public property | FirstValue | Gets a DateTimeWrapper containing DateTime.Now.

See Also

MonthOfYearDataSource Class
Mindscape.PhoneElements Namespace


MonthOfYearDataSource Constructor

[image] [image]

Mindscape Phone Elements
MonthOfYearDataSource Constructor
MonthOfYearDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MonthOfYearDataSource()()()() | Initializes a new instance of the MonthOfYearDataSource class.
Public method | MonthOfYearDataSource(CultureInfo) | Initializes a new instance of the MonthOfYearDataSource class.

See Also

MonthOfYearDataSource Class
MonthOfYearDataSource Members
Mindscape.PhoneElements Namespace


MonthOfYearDataSource Constructor

[image]

Mindscape Phone Elements
MonthOfYearDataSource Constructor
MonthOfYearDataSource Class See Also Send Feedback
Initializes a new instance of the MonthOfYearDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthOfYearDataSource()
Visual Basic
Public Sub New
Visual C++
public:
MonthOfYearDataSource()

See Also

MonthOfYearDataSource Class
MonthOfYearDataSource Overload
Mindscape.PhoneElements Namespace


MonthOfYearDataSource Constructor (CultureInfo)

[image]

Mindscape Phone Elements
MonthOfYearDataSource Constructor (CultureInfo)
MonthOfYearDataSource Class See Also Send Feedback
Initializes a new instance of the MonthOfYearDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthOfYearDataSource(
    CultureInfo culture
)
Visual Basic
Public Sub New ( _
    culture As CultureInfo _
)
Visual C++
public:
MonthOfYearDataSource(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::..CultureInfo
The CultureInfo used to format the date.

See Also

MonthOfYearDataSource Class
MonthOfYearDataSource Overload
Mindscape.PhoneElements Namespace


MonthOfYearDataSource Methods

[image] [image]

Mindscape Phone Elements
MonthOfYearDataSource Methods
MonthOfYearDataSource Class See Also Send Feedback

The MonthOfYearDataSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Gets the next month based on the delta value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthOfYearDataSource Class
Mindscape.PhoneElements Namespace


GetNext Method

[image]

Mindscape Phone Elements
MonthOfYearDataSource..::..GetNext Method
MonthOfYearDataSource Class See Also Send Feedback
Gets the next month based on the delta value.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetNext(
    Object current,
    int deltaIndex
)
Visual Basic
Public Function GetNext ( _
    current As Object, _
    deltaIndex As Integer _
) As Object
Visual C++
public:
virtual Object^ GetNext(
    Object^ current,
    int deltaIndex
) sealed

Parameters

current
Type: System..::..Object
The current DateTimeWrapper.
deltaIndex
Type: System..::..Int32
The number of months to advance through the sequence.

Return Value

The next DateTimeWrapper which is offset from the current DateTimeWrapper by the given number of months.

Implements

IDataSource..::..GetNext(Object, Int32)

See Also

MonthOfYearDataSource Class
Mindscape.PhoneElements Namespace


MonthOfYearDataSource Properties

[image] [image]

Mindscape Phone Elements
MonthOfYearDataSource Properties
MonthOfYearDataSource Class See Also Send Feedback

The MonthOfYearDataSource type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets or sets the CultureInfo used to format the date.
Public property | FirstValue | Gets a DateTimeWrapper containing DateTime.Now.

See Also

MonthOfYearDataSource Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
MonthOfYearDataSource..::..Culture Property
MonthOfYearDataSource Class See Also Send Feedback
Gets or sets the CultureInfo used to format the date.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

MonthOfYearDataSource Class
Mindscape.PhoneElements Namespace


FirstValue Property

[image]

Mindscape Phone Elements
MonthOfYearDataSource..::..FirstValue Property
MonthOfYearDataSource Class See Also Send Feedback
Gets a DateTimeWrapper containing DateTime.Now.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object FirstValue { get; }
Visual Basic
Public ReadOnly Property FirstValue As Object
    Get
Visual C++
public:
virtual property Object^ FirstValue {
    Object^ get () sealed;
}

Implements

IDataSource..::..FirstValue

See Also

MonthOfYearDataSource Class
Mindscape.PhoneElements Namespace


MovingGestureEventArgs Class

[image]

Mindscape Phone Elements
MovingGestureEventArgs Class
Members See Also Send Feedback
A base class for gesture event args that suggest some kind of movement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class MovingGestureEventArgs : GestureEventArgs
Visual Basic
Public MustInherit Class MovingGestureEventArgs _
    Inherits GestureEventArgs
Visual C++
public ref class MovingGestureEventArgs abstract : public GestureEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..MovingGestureEventArgs
Mindscape.PhoneElements..::..DragDeltaGestureEventArgs
Mindscape.PhoneElements..::..DualGestureEventArgs

See Also

MovingGestureEventArgs Members
Mindscape.PhoneElements Namespace


MovingGestureEventArgs Members

[image] [image]

Mindscape Phone Elements
MovingGestureEventArgs Members
MovingGestureEventArgs Class Methods Properties See Also Send Feedback

The MovingGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Overrides GestureEventArgs..::..GetPosition(UIElement).)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates.
Public property | TouchPosition | Gets the current touch position in screen coordinates.

See Also

MovingGestureEventArgs Class
Mindscape.PhoneElements Namespace


MovingGestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
MovingGestureEventArgs Methods
MovingGestureEventArgs Class See Also Send Feedback

The MovingGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Overrides GestureEventArgs..::..GetPosition(UIElement).)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MovingGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
MovingGestureEventArgs..::..GetPosition Method
MovingGestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Overrides GestureEventArgs..::..GetPosition(UIElement).)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)

See Also

MovingGestureEventArgs Class
MovingGestureEventArgs Members
Mindscape.PhoneElements Namespace


GetPosition Method (UIElement)

[image]

Mindscape Phone Elements
MovingGestureEventArgs..::..GetPosition Method (UIElement)
MovingGestureEventArgs Class See Also Send Feedback
Returns the current touch position relative to the given UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override Point GetPosition(
    UIElement relativeTo
)
Visual Basic
Public Overrides Function GetPosition ( _
    relativeTo As UIElement _
) As Point
Visual C++
public:
virtual Point GetPosition(
    UIElement^ relativeTo
) override

Parameters

relativeTo
Type: System.Windows..::..UIElement
The UIElement to derive the touch position.

Return Value

The current touch position relative to the given UIElement.

See Also

MovingGestureEventArgs Class
GetPosition Overload
Mindscape.PhoneElements Namespace


MovingGestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
MovingGestureEventArgs Properties
MovingGestureEventArgs Class See Also Send Feedback

The MovingGestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates.
Public property | TouchPosition | Gets the current touch position in screen coordinates.

See Also

MovingGestureEventArgs Class
Mindscape.PhoneElements Namespace


PreviousTouchPosition Property

[image]

Mindscape Phone Elements
MovingGestureEventArgs..::..PreviousTouchPosition Property
MovingGestureEventArgs Class See Also Send Feedback
Gets the previous touch position in screen coordinates.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point PreviousTouchPosition { get; private set; }
Visual Basic
Public Property PreviousTouchPosition As Point
    Get
    Private Set
Visual C++
public:
property Point PreviousTouchPosition {
    Point get ();
    private: void set (Point value);
}

See Also

MovingGestureEventArgs Class
Mindscape.PhoneElements Namespace


TouchPosition Property

[image]

Mindscape Phone Elements
MovingGestureEventArgs..::..TouchPosition Property
MovingGestureEventArgs Class See Also Send Feedback
Gets the current touch position in screen coordinates.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point TouchPosition { get; private set; }
Visual Basic
Public Property TouchPosition As Point
    Get
    Private Set
Visual C++
public:
property Point TouchPosition {
    Point get ();
    private: void set (Point value);
}

See Also

MovingGestureEventArgs Class
Mindscape.PhoneElements Namespace


NamedColor Class

[image]

Mindscape Phone Elements
NamedColor Class
Members See Also Send Feedback
Maps a Color to a name.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NamedColor
Visual Basic
Public Class NamedColor
Visual C++
public ref class NamedColor

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..NamedColor

See Also

NamedColor Members
Mindscape.PhoneElements Namespace


NamedColor Members

[image] [image]

Mindscape Phone Elements
NamedColor Members
NamedColor Class Constructors Methods Properties See Also Send Feedback

The NamedColor type exposes the following members.

Constructors

 | Name | Description
Public method | NamedColor | Initializes a new instance of the NamedColor class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Gets the Color.
Public property | Name | Gets the name of the Color.
 | WP7NamedColors | Gets a read only collection of NamedColor objects seen in the WP7 operating system color picker.

See Also

NamedColor Class
Mindscape.PhoneElements Namespace


NamedColor Constructor

[image]

Mindscape Phone Elements
NamedColor Constructor
NamedColor Class See Also Send Feedback
Initializes a new instance of the NamedColor class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NamedColor(
    string name,
    Color color
)
Visual Basic
Public Sub New ( _
    name As String, _
    color As Color _
)
Visual C++
public:
NamedColor(
    String^ name,
    Color color
)

Parameters

name
Type: System..::..String
The name of the color.
color
Type: System.Windows.Media..::..Color
The Color.

See Also

NamedColor Class
Mindscape.PhoneElements Namespace


NamedColor Methods

[image] [image]

Mindscape Phone Elements
NamedColor Methods
NamedColor Class See Also Send Feedback

The NamedColor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedColor Class
Mindscape.PhoneElements Namespace


NamedColor Properties

[image] [image]

Mindscape Phone Elements
NamedColor Properties
NamedColor Class See Also Send Feedback

The NamedColor type exposes the following members.

Properties

 | Name | Description
Public property | Color | Gets the Color.
Public property | Name | Gets the name of the Color.
 | WP7NamedColors | Gets a read only collection of NamedColor objects seen in the WP7 operating system color picker.

See Also

NamedColor Class
Mindscape.PhoneElements Namespace


Color Property

[image]

Mindscape Phone Elements
NamedColor..::..Color Property
NamedColor Class See Also Send Feedback
Gets the Color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color Color { get; private set; }
Visual Basic
Public Property Color As Color
    Get
    Private Set
Visual C++
public:
property Color Color {
    Color get ();
    private: void set (Color value);
}

See Also

NamedColor Class
Mindscape.PhoneElements Namespace


Name Property

[image]

Mindscape Phone Elements
NamedColor..::..Name Property
NamedColor Class See Also Send Feedback
Gets the name of the Color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set
Visual C++
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}

See Also

NamedColor Class
Mindscape.PhoneElements Namespace


WP7NamedColors Property

[image]

Mindscape Phone Elements
NamedColor..::..WP7NamedColors Property
NamedColor Class See Also Send Feedback
Gets a read only collection of NamedColor objects seen in the WP7 operating system color picker.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ReadOnlyCollection<NamedColor> WP7NamedColors { get; }
Visual Basic
Public Shared ReadOnly Property WP7NamedColors As ReadOnlyCollection(Of NamedColor)
    Get
Visual C++
public:
static property ReadOnlyCollection<NamedColor^>^ WP7NamedColors {
    ReadOnlyCollection<NamedColor^>^ get ();
}

See Also

NamedColor Class
Mindscape.PhoneElements Namespace


NotifyingColor Class

[image]

Mindscape Phone Elements
NotifyingColor Class
Members See Also Send Feedback
Encapsulates a Color and provides notification of changes to individual channels in order to support Silverlight data binding.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NotifyingColor : ViewModelBase
Visual Basic
Public Class NotifyingColor _
    Inherits ViewModelBase
Visual C++
public ref class NotifyingColor : public ViewModelBase

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ViewModelBase
Mindscape.PhoneElements..::..NotifyingColor

See Also

NotifyingColor Members
Mindscape.PhoneElements Namespace


NotifyingColor Members

[image] [image]

Mindscape Phone Elements
NotifyingColor Members
NotifyingColor Class Constructors Methods Properties Events See Also Send Feedback

The NotifyingColor type exposes the following members.

Constructors

 | Name | Description
Public method | NotifyingColor | Initializes a new instance of the NotifyingColor class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Protected method | Set<(Of <<'(T>)>>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
Public method | SetFromColor | Sets this NotifyingColor to wrap the specified color.
Public method | ToColor | Returns the color of this NotifyingColor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | A | Gets or sets the alpha channel value of the color.
Public property | B | Gets or sets the blue channel value of the color.
Public property | G | Gets or sets the green channel value of the color.
Public property | R | Gets or sets the red channel value of the color.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


NotifyingColor Constructor

[image]

Mindscape Phone Elements
NotifyingColor Constructor
NotifyingColor Class See Also Send Feedback
Initializes a new instance of the NotifyingColor class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NotifyingColor()
Visual Basic
Public Sub New
Visual C++
public:
NotifyingColor()

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


NotifyingColor Methods

[image] [image]

Mindscape Phone Elements
NotifyingColor Methods
NotifyingColor Class See Also Send Feedback

The NotifyingColor type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Protected method | Set<(Of <<'(T>)>>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
Public method | SetFromColor | Sets this NotifyingColor to wrap the specified color.
Public method | ToColor | Returns the color of this NotifyingColor.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


SetFromColor Method

[image]

Mindscape Phone Elements
NotifyingColor..::..SetFromColor Method
NotifyingColor Class See Also Send Feedback
Sets this NotifyingColor to wrap the specified color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetFromColor(
    Color color
)
Visual Basic
Public Sub SetFromColor ( _
    color As Color _
)
Visual C++
public:
void SetFromColor(
    Color color
)

Parameters

color
Type: System.Windows.Media..::..Color
The color to wrap.

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


ToColor Method

[image]

Mindscape Phone Elements
NotifyingColor..::..ToColor Method
NotifyingColor Class See Also Send Feedback
Returns the color of this NotifyingColor.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color ToColor()
Visual Basic
Public Function ToColor As Color
Visual C++
public:
Color ToColor()

Return Value

The color of this NotifyingColor.

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


NotifyingColor Properties

[image] [image]

Mindscape Phone Elements
NotifyingColor Properties
NotifyingColor Class See Also Send Feedback

The NotifyingColor type exposes the following members.

Properties

 | Name | Description
Public property | A | Gets or sets the alpha channel value of the color.
Public property | B | Gets or sets the blue channel value of the color.
Public property | G | Gets or sets the green channel value of the color.
Public property | R | Gets or sets the red channel value of the color.

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


A Property

[image]

Mindscape Phone Elements
NotifyingColor..::..A Property
NotifyingColor Class See Also Send Feedback
Gets or sets the alpha channel value of the color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte A { get; set; }
Visual Basic
Public Property A As Byte
    Get
    Set
Visual C++
public:
property unsigned char A {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


B Property

[image]

Mindscape Phone Elements
NotifyingColor..::..B Property
NotifyingColor Class See Also Send Feedback
Gets or sets the blue channel value of the color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte B { get; set; }
Visual Basic
Public Property B As Byte
    Get
    Set
Visual C++
public:
property unsigned char B {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


G Property

[image]

Mindscape Phone Elements
NotifyingColor..::..G Property
NotifyingColor Class See Also Send Feedback
Gets or sets the green channel value of the color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte G { get; set; }
Visual Basic
Public Property G As Byte
    Get
    Set
Visual C++
public:
property unsigned char G {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


R Property

[image]

Mindscape Phone Elements
NotifyingColor..::..R Property
NotifyingColor Class See Also Send Feedback
Gets or sets the red channel value of the color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte R { get; set; }
Visual Basic
Public Property R As Byte
    Get
    Set
Visual C++
public:
property unsigned char R {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


NotifyingColor Events

[image] [image]

Mindscape Phone Elements
NotifyingColor Events
NotifyingColor Class See Also Send Feedback

The NotifyingColor type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

NotifyingColor Class
Mindscape.PhoneElements Namespace


NumericDataSource Class

[image]

Mindscape Phone Elements
NumericDataSource Class
Members See Also Send Feedback
A looping data source that loops through a sequence of consecutive numbers.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NumericDataSource : IDataSource
Visual Basic
Public Class NumericDataSource _
    Implements IDataSource
Visual C++
public ref class NumericDataSource : IDataSource

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..NumericDataSource

See Also

NumericDataSource Members
Mindscape.PhoneElements Namespace


NumericDataSource Members

[image] [image]

Mindscape Phone Elements
NumericDataSource Members
NumericDataSource Class Constructors Methods Properties See Also Send Feedback

The NumericDataSource type exposes the following members.

Constructors

 | Name | Description
Public method | NumericDataSource()()()() | Initializes a new instance of the NumericDataSource class. The MinValue and MaxValue are set to Double.MinValue and Double.MaxValue respectivly.
Public method | NumericDataSource(Double, Double) | Initializes a new instance of the NumericDataSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next number in the sequence based on the given delta value. The sequence will loop around if an overflow occurs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirstValue | Returns 1.0
Public property | MaxValue | Gets or sets the maximum value of the sequence.
Public property | MinValue | Gets or sets the minimum value of the sequence.

See Also

NumericDataSource Class
Mindscape.PhoneElements Namespace


NumericDataSource Constructor

[image] [image]

Mindscape Phone Elements
NumericDataSource Constructor
NumericDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NumericDataSource()()()() | Initializes a new instance of the NumericDataSource class. The MinValue and MaxValue are set to Double.MinValue and Double.MaxValue respectivly.
Public method | NumericDataSource(Double, Double) | Initializes a new instance of the NumericDataSource class.

See Also

NumericDataSource Class
NumericDataSource Members
Mindscape.PhoneElements Namespace


NumericDataSource Constructor

[image]

Mindscape Phone Elements
NumericDataSource Constructor
NumericDataSource Class See Also Send Feedback
Initializes a new instance of the NumericDataSource class. The MinValue and MaxValue are set to Double.MinValue and Double.MaxValue respectivly.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NumericDataSource()
Visual Basic
Public Sub New
Visual C++
public:
NumericDataSource()

See Also

NumericDataSource Class
NumericDataSource Overload
Mindscape.PhoneElements Namespace


NumericDataSource Constructor (Double, Double)

[image]

Mindscape Phone Elements
NumericDataSource Constructor (Double, Double)
NumericDataSource Class See Also Send Feedback
Initializes a new instance of the NumericDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NumericDataSource(
    double min,
    double max
)
Visual Basic
Public Sub New ( _
    min As Double, _
    max As Double _
)
Visual C++
public:
NumericDataSource(
    double min,
    double max
)

Parameters

min
Type: System..::..Double
The minimum value in the data sequence.
max
Type: System..::..Double
The maximum value in the data sequence.

See Also

NumericDataSource Class
NumericDataSource Overload
Mindscape.PhoneElements Namespace


NumericDataSource Methods

[image] [image]

Mindscape Phone Elements
NumericDataSource Methods
NumericDataSource Class See Also Send Feedback

The NumericDataSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next number in the sequence based on the given delta value. The sequence will loop around if an overflow occurs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericDataSource Class
Mindscape.PhoneElements Namespace


GetNext Method

[image]

Mindscape Phone Elements
NumericDataSource..::..GetNext Method
NumericDataSource Class See Also Send Feedback
Returns the next number in the sequence based on the given delta value. The sequence will loop around if an overflow occurs.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetNext(
    Object current,
    int deltaIndex
)
Visual Basic
Public Function GetNext ( _
    current As Object, _
    deltaIndex As Integer _
) As Object
Visual C++
public:
virtual Object^ GetNext(
    Object^ current,
    int deltaIndex
) sealed

Parameters

current
Type: System..::..Object
The current number.
deltaIndex
Type: System..::..Int32
How many numbers to advance through the sequence.

Return Value

The next number in the squence which is offset from the current number by the given delta value.

Implements

IDataSource..::..GetNext(Object, Int32)

See Also

NumericDataSource Class
Mindscape.PhoneElements Namespace


NumericDataSource Properties

[image] [image]

Mindscape Phone Elements
NumericDataSource Properties
NumericDataSource Class See Also Send Feedback

The NumericDataSource type exposes the following members.

Properties

 | Name | Description
Public property | FirstValue | Returns 1.0
Public property | MaxValue | Gets or sets the maximum value of the sequence.
Public property | MinValue | Gets or sets the minimum value of the sequence.

See Also

NumericDataSource Class
Mindscape.PhoneElements Namespace


FirstValue Property

[image]

Mindscape Phone Elements
NumericDataSource..::..FirstValue Property
NumericDataSource Class See Also Send Feedback
Returns 1.0

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object FirstValue { get; }
Visual Basic
Public ReadOnly Property FirstValue As Object
    Get
Visual C++
public:
virtual property Object^ FirstValue {
    Object^ get () sealed;
}

Implements

IDataSource..::..FirstValue

See Also

NumericDataSource Class
Mindscape.PhoneElements Namespace


MaxValue Property

[image]

Mindscape Phone Elements
NumericDataSource..::..MaxValue Property
NumericDataSource Class See Also Send Feedback
Gets or sets the maximum value of the sequence.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MaxValue { get; set; }
Visual Basic
Public Property MaxValue As Double
    Get
    Set
Visual C++
public:
property double MaxValue {
    double get ();
    void set (double value);
}

See Also

NumericDataSource Class
Mindscape.PhoneElements Namespace


MinValue Property

[image]

Mindscape Phone Elements
NumericDataSource..::..MinValue Property
NumericDataSource Class See Also Send Feedback
Gets or sets the minimum value of the sequence.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MinValue { get; set; }
Visual Basic
Public Property MinValue As Double
    Get
    Set
Visual C++
public:
property double MinValue {
    double get ();
    void set (double value);
}

See Also

NumericDataSource Class
Mindscape.PhoneElements Namespace


ObjectDataSource Class

[image]

Mindscape Phone Elements
ObjectDataSource Class
Members See Also Send Feedback
A looping data source the loops through a sequence of objects.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ObjectDataSource : IDataSource
Visual Basic
Public Class ObjectDataSource _
    Implements IDataSource
Visual C++
public ref class ObjectDataSource : IDataSource

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ObjectDataSource

See Also

ObjectDataSource Members
Mindscape.PhoneElements Namespace


ObjectDataSource Members

[image] [image]

Mindscape Phone Elements
ObjectDataSource Members
ObjectDataSource Class Constructors Methods Properties See Also Send Feedback

The ObjectDataSource type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectDataSource()()()() | Initializes a new instance of the ObjectDataSource class.
Public method | ObjectDataSource(IList<(Of <<'(Object>)>>)) | Initializes a new instance of the ObjectDataSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next object in the sequence based on the given delta index value. If an overflow occurs then the next item will loop around the sequence.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirstValue | Return the first object in the sequence, or null if the sequence is empty.

See Also

ObjectDataSource Class
Mindscape.PhoneElements Namespace


ObjectDataSource Constructor

[image] [image]

Mindscape Phone Elements
ObjectDataSource Constructor
ObjectDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ObjectDataSource()()()() | Initializes a new instance of the ObjectDataSource class.
Public method | ObjectDataSource(IList<(Of <<'(Object>)>>)) | Initializes a new instance of the ObjectDataSource class.

See Also

ObjectDataSource Class
ObjectDataSource Members
Mindscape.PhoneElements Namespace


ObjectDataSource Constructor

[image]

Mindscape Phone Elements
ObjectDataSource Constructor
ObjectDataSource Class See Also Send Feedback
Initializes a new instance of the ObjectDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObjectDataSource()
Visual Basic
Public Sub New
Visual C++
public:
ObjectDataSource()

See Also

ObjectDataSource Class
ObjectDataSource Overload
Mindscape.PhoneElements Namespace


ObjectDataSource Constructor (IList(Object))

[image]

Mindscape Phone Elements
ObjectDataSource Constructor (IList<(Of <(<'Object>)>)>)
ObjectDataSource Class See Also Send Feedback
Initializes a new instance of the ObjectDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObjectDataSource(
    IList<Object> objects
)
Visual Basic
Public Sub New ( _
    objects As IList(Of Object) _
)
Visual C++
public:
ObjectDataSource(
    IList<Object^>^ objects
)

Parameters

objects
Type: System.Collections.Generic..::..IList <(Of <(<' Object >)>)>
The sequence of objects.

See Also

ObjectDataSource Class
ObjectDataSource Overload
Mindscape.PhoneElements Namespace


ObjectDataSource Methods

[image] [image]

Mindscape Phone Elements
ObjectDataSource Methods
ObjectDataSource Class See Also Send Feedback

The ObjectDataSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next object in the sequence based on the given delta index value. If an overflow occurs then the next item will loop around the sequence.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectDataSource Class
Mindscape.PhoneElements Namespace


GetNext Method

[image]

Mindscape Phone Elements
ObjectDataSource..::..GetNext Method
ObjectDataSource Class See Also Send Feedback
Returns the next object in the sequence based on the given delta index value. If an overflow occurs then the next item will loop around the sequence.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetNext(
    Object current,
    int deltaIndex
)
Visual Basic
Public Function GetNext ( _
    current As Object, _
    deltaIndex As Integer _
) As Object
Visual C++
public:
virtual Object^ GetNext(
    Object^ current,
    int deltaIndex
) sealed

Parameters

current
Type: System..::..Object
The current object.
deltaIndex
Type: System..::..Int32
The delta index to get the next object.

Return Value

The next object in the sequence based on the given delta index value.

Implements

IDataSource..::..GetNext(Object, Int32)

See Also

ObjectDataSource Class
Mindscape.PhoneElements Namespace


ObjectDataSource Properties

[image] [image]

Mindscape Phone Elements
ObjectDataSource Properties
ObjectDataSource Class See Also Send Feedback

The ObjectDataSource type exposes the following members.

Properties

 | Name | Description
Public property | FirstValue | Return the first object in the sequence, or null if the sequence is empty.

See Also

ObjectDataSource Class
Mindscape.PhoneElements Namespace


FirstValue Property

[image]

Mindscape Phone Elements
ObjectDataSource..::..FirstValue Property
ObjectDataSource Class See Also Send Feedback
Return the first object in the sequence, or null if the sequence is empty.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object FirstValue { get; }
Visual Basic
Public ReadOnly Property FirstValue As Object
    Get
Visual C++
public:
virtual property Object^ FirstValue {
    Object^ get () sealed;
}

Implements

IDataSource..::..FirstValue

See Also

ObjectDataSource Class
Mindscape.PhoneElements Namespace


PaletteColorPicker Class

[image]

Mindscape Phone Elements
PaletteColorPicker Class
Members See Also Send Feedback
A control that display a color palette allowing the user to select a Color.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PaletteColorPicker : Control
Visual Basic
Public Class PaletteColorPicker _
    Inherits Control
Visual C++
public ref class PaletteColorPicker : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements..::..PaletteColorPicker

See Also

PaletteColorPicker Members
Mindscape.PhoneElements Namespace


PaletteColorPicker Members

[image] [image]

Mindscape Phone Elements
PaletteColorPicker Members
PaletteColorPicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Constructors

 | Name | Description
Public method | PaletteColorPicker | Initializes a new instance of the PaletteColorPicker class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
PaletteProperty | Identifies the Palette property.
SelectedNamedColorProperty | Identifies the SelectedNamedColor property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Palette | Gets or sets the palette of colors that the user can choose from. This is a dependency property.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor containing the selected color and its name. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


PaletteColorPicker Constructor

[image]

Mindscape Phone Elements
PaletteColorPicker Constructor
PaletteColorPicker Class See Also Send Feedback
Initializes a new instance of the PaletteColorPicker class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PaletteColorPicker()
Visual Basic
Public Sub New
Visual C++
public:
PaletteColorPicker()

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


PaletteColorPicker Fields

[image] [image]

Mindscape Phone Elements
PaletteColorPicker Fields
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Fields

Name | Description
PaletteProperty | Identifies the Palette property.
SelectedNamedColorProperty | Identifies the SelectedNamedColor property.

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


PaletteProperty Field

[image]

Mindscape Phone Elements
PaletteColorPicker..::..PaletteProperty Field
PaletteColorPicker Class See Also Send Feedback
Identifies the Palette property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty PaletteProperty
Visual Basic
Public Shared ReadOnly PaletteProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PaletteProperty

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


SelectedNamedColorProperty Field

[image]

Mindscape Phone Elements
PaletteColorPicker..::..SelectedNamedColorProperty Field
PaletteColorPicker Class See Also Send Feedback
Identifies the SelectedNamedColor property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedNamedColorProperty
Visual Basic
Public Shared ReadOnly SelectedNamedColorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedNamedColorProperty

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


PaletteColorPicker Methods

[image] [image]

Mindscape Phone Elements
PaletteColorPicker Methods
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


PaletteColorPicker Properties

[image] [image]

Mindscape Phone Elements
PaletteColorPicker Properties
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Palette | Gets or sets the palette of colors that the user can choose from. This is a dependency property.
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor containing the selected color and its name. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


Palette Property

[image]

Mindscape Phone Elements
PaletteColorPicker..::..Palette Property
PaletteColorPicker Class See Also Send Feedback
Gets or sets the palette of colors that the user can choose from. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<NamedColor> Palette { get; set; }
Visual Basic
Public Property Palette As ReadOnlyCollection(Of NamedColor)
    Get
    Set
Visual C++
public:
property ReadOnlyCollection<NamedColor^>^ Palette {
    ReadOnlyCollection<NamedColor^>^ get ();
    void set (ReadOnlyCollection<NamedColor^>^ value);
}

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


SelectedNamedColor Property

[image]

Mindscape Phone Elements
PaletteColorPicker..::..SelectedNamedColor Property
PaletteColorPicker Class See Also Send Feedback
Gets or sets a NamedColor containing the selected color and its name. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NamedColor SelectedNamedColor { get; set; }
Visual Basic
Public Property SelectedNamedColor As NamedColor
    Get
    Set
Visual C++
public:
property NamedColor^ SelectedNamedColor {
    NamedColor^ get ();
    void set (NamedColor^ value);
}

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


PaletteColorPicker Events

[image] [image]

Mindscape Phone Elements
PaletteColorPicker Events
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PaletteColorPicker Class
Mindscape.PhoneElements Namespace


PaletteColorPickerPage Class

[image]

Mindscape Phone Elements
PaletteColorPickerPage Class
Members See Also Send Feedback
A color picker page containing a PaletteColorPicker.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PaletteColorPickerPage : ColorPickerPageBase
Visual Basic
Public Class PaletteColorPickerPage _
    Inherits ColorPickerPageBase
Visual C++
public ref class PaletteColorPickerPage : public ColorPickerPageBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
System.Windows.Controls..::..Page
PhoneApplicationPage
Mindscape.PhoneElements..::..ColorPickerPageBase
Mindscape.PhoneElements..::..PaletteColorPickerPage

See Also

PaletteColorPickerPage Members
Mindscape.PhoneElements Namespace


PaletteColorPickerPage Members

[image] [image]

Mindscape Phone Elements
PaletteColorPickerPage Members
PaletteColorPickerPage Class Constructors Methods Properties Events See Also Send Feedback

The PaletteColorPickerPage type exposes the following members.

Constructors

 | Name | Description
Public method | PaletteColorPickerPage | Initializes a new instance of the PaletteColorPickerPage.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes. (Overrides ColorPickerPageBase..::..OnColorPickerChanged()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page. (Inherited from ColorPickerPageBase.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property. (Inherited from ColorPickerPageBase.)
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PaletteColorPickerPage Class
Mindscape.PhoneElements Namespace


PaletteColorPickerPage Constructor

[image]

Mindscape Phone Elements
PaletteColorPickerPage Constructor
PaletteColorPickerPage Class See Also Send Feedback
Initializes a new instance of the PaletteColorPickerPage.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PaletteColorPickerPage()
Visual Basic
Public Sub New
Visual C++
public:
PaletteColorPickerPage()

See Also

PaletteColorPickerPage Class
Mindscape.PhoneElements Namespace


PaletteColorPickerPage Methods

[image] [image]

Mindscape Phone Elements
PaletteColorPickerPage Methods
PaletteColorPickerPage Class See Also Send Feedback

The PaletteColorPickerPage type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnColorPickerChanged | Called when the ColorPicker property changes. (Overrides ColorPickerPageBase..::..OnColorPickerChanged()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PaletteColorPickerPage Class
Mindscape.PhoneElements Namespace


InitializeComponent Method

[image]

Mindscape Phone Elements
PaletteColorPickerPage..::..InitializeComponent Method
PaletteColorPickerPage Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

PaletteColorPickerPage Class
Mindscape.PhoneElements Namespace


OnColorPickerChanged Method

[image]

Mindscape Phone Elements
PaletteColorPickerPage..::..OnColorPickerChanged Method
PaletteColorPickerPage Class See Also Send Feedback
Called when the ColorPicker property changes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnColorPickerChanged()
Visual Basic
Protected Overrides Sub OnColorPickerChanged
Visual C++
protected:
virtual void OnColorPickerChanged() override

See Also

PaletteColorPickerPage Class
Mindscape.PhoneElements Namespace


PaletteColorPickerPage Properties

[image] [image]

Mindscape Phone Elements
PaletteColorPickerPage Properties
PaletteColorPickerPage Class See Also Send Feedback

The PaletteColorPickerPage type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ColorPicker | Gets or sets the ColorPicker that opened the page. (Inherited from ColorPickerPageBase.)
Protected property | Content | (Inherited from UserControl.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedNamedColor | Gets or sets a NamedColor that contains the selected color and its name. This is a dependency property. (Inherited from ColorPickerPageBase.)
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

PaletteColorPickerPage Class
Mindscape.PhoneElements Namespace


PaletteColorPickerPage Events

[image] [image]

Mindscape Phone Elements
PaletteColorPickerPage Events
PaletteColorPickerPage Class See Also Send Feedback

The PaletteColorPickerPage type exposes the following members.

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PaletteColorPickerPage Class
Mindscape.PhoneElements Namespace


PickerBase Class

[image]

Mindscape Phone Elements
PickerBase Class
Members See Also Send Feedback
A base class for picker controls that open up a page containg the picker UI.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class PickerBase : Control,
    INotifyPropertyChanged
Visual Basic
Public MustInherit Class PickerBase _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class PickerBase abstract : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements..::..PickerBase
Mindscape.PhoneElements..::..ColorPicker
Mindscape.PhoneElements..::..DatePicker
Mindscape.PhoneElements..::..TimePicker

See Also

PickerBase Members
Mindscape.PhoneElements Namespace


PickerBase Members

[image] [image]

Mindscape Phone Elements
PickerBase Members
PickerBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The PickerBase type exposes the following members.

Constructors

 | Name | Description
Protected method | PickerBase | Initializes a new instance of the PickerBase class

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application frame is navigated.
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | PickerPageClosed | Called when the picker page closes.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
PickerPageUriProperty | Identifies the PickerPageUri property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property.
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerBase Constructor

[image]

Mindscape Phone Elements
PickerBase Constructor
PickerBase Class See Also Send Feedback
Initializes a new instance of the PickerBase class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected PickerBase()
Visual Basic
Protected Sub New
Visual C++
protected:
PickerBase()

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerBase Fields

[image] [image]

Mindscape Phone Elements
PickerBase Fields
PickerBase Class See Also Send Feedback

The PickerBase type exposes the following members.

Fields

Name | Description
PickerPageUriProperty | Identifies the PickerPageUri property.

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerPageUriProperty Field

[image]

Mindscape Phone Elements
PickerBase..::..PickerPageUriProperty Field
PickerBase Class See Also Send Feedback
Identifies the PickerPageUri property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty PickerPageUriProperty
Visual Basic
Public Shared ReadOnly PickerPageUriProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PickerPageUriProperty

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerBase Methods

[image] [image]

Mindscape Phone Elements
PickerBase Methods
PickerBase Class See Also Send Feedback

The PickerBase type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application frame is navigated.
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | PickerPageClosed | Called when the picker page closes.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


ClosePickerPage Method

[image]

Mindscape Phone Elements
PickerBase..::..ClosePickerPage Method
PickerBase Class See Also Send Feedback
closes the picker page.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void ClosePickerPage()
Visual Basic
Protected Sub ClosePickerPage
Visual C++
protected:
void ClosePickerPage()

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


FrameNavigated Method

[image]

Mindscape Phone Elements
PickerBase..::..FrameNavigated Method
PickerBase Class See Also Send Feedback
Called when the application frame is navigated.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract void FrameNavigated(
    Object content
)
Visual Basic
Protected MustOverride Sub FrameNavigated ( _
    content As Object _
)
Visual C++
protected:
virtual void FrameNavigated(
    Object^ content
) abstract

Parameters

content
Type: System..::..Object
The current content of the application frame.

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


OnApplyTemplate Method

[image]

Mindscape Phone Elements
PickerBase..::..OnApplyTemplate Method
PickerBase Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


OnPropertyChanged Method

[image]

Mindscape Phone Elements
PickerBase..::..OnPropertyChanged Method
PickerBase Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
The name of the property that changed.

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerPageClosed Method

[image]

Mindscape Phone Elements
PickerBase..::..PickerPageClosed Method
PickerBase Class See Also Send Feedback
Called when the picker page closes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract void PickerPageClosed()
Visual Basic
Protected MustOverride Sub PickerPageClosed
Visual C++
protected:
virtual void PickerPageClosed() abstract

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerBase Properties

[image] [image]

Mindscape Phone Elements
PickerBase Properties
PickerBase Class See Also Send Feedback

The PickerBase type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property.
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerPageUri Property

[image]

Mindscape Phone Elements
PickerBase..::..PickerPageUri Property
PickerBase Class See Also Send Feedback
Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Uri PickerPageUri { get; set; }
Visual Basic
Public Property PickerPageUri As Uri
    Get
    Set
Visual C++
public:
property Uri^ PickerPageUri {
    Uri^ get ();
    void set (Uri^ value);
}

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PickerBase Events

[image] [image]

Mindscape Phone Elements
PickerBase Events
PickerBase Class See Also Send Feedback

The PickerBase type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PropertyChanged Event

[image]

Mindscape Phone Elements
PickerBase..::..PropertyChanged Event
PickerBase Class See Also Send Feedback
Raised when a property value changes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

PickerBase Class
Mindscape.PhoneElements Namespace


PinchGestureEventArgs Class

[image]

Mindscape Phone Elements
PinchGestureEventArgs Class
Members See Also Send Feedback
Contains event data related to the PinchStarted, PinchDelta and PinchCompleted gestures.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PinchGestureEventArgs : DualGestureEventArgs
Visual Basic
Public Class PinchGestureEventArgs _
    Inherits DualGestureEventArgs
Visual C++
public ref class PinchGestureEventArgs : public DualGestureEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements..::..GestureEventArgs
Mindscape.PhoneElements..::..MovingGestureEventArgs
Mindscape.PhoneElements..::..DualGestureEventArgs
Mindscape.PhoneElements..::..PinchGestureEventArgs

See Also

PinchGestureEventArgs Members
Mindscape.PhoneElements Namespace


PinchGestureEventArgs Members

[image] [image]

Mindscape Phone Elements
PinchGestureEventArgs Members
PinchGestureEventArgs Class Methods Properties See Also Send Feedback

The PinchGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMidPoint | Returns the center point between the current touch points relative to the given UIElement.
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | Gets the current angle between the touch points.
Public property | DeltaScale | Gets the scale factor between the current touch points and the previous touch points.
Public property | Distance | Gets the current distance between the touch points.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | GestureOrigin2 | Gets the original position of the second touch point in screen coordinates. (Inherited from DualGestureEventArgs.)
Public property | MidPoint | Gets the center point between the current touch points relative to the screen coordinates.
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | PreviousTouchPosition2 | Gets the previous position of the second touch point in screen coordinates. (Inherited from DualGestureEventArgs.)
Public property | Scale | Gets the total scale factor between the current touch points and the original touch points.
Public property | TotalAngleDelta | Gets the total difference between the current angle and the original angle of the touch points.
Public property | TouchPosition | Gets the current touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | TouchPosition2 | Gets the current position of the second touch point in screen coordinates. (Inherited from DualGestureEventArgs.)

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


PinchGestureEventArgs Methods

[image] [image]

Mindscape Phone Elements
PinchGestureEventArgs Methods
PinchGestureEventArgs Class See Also Send Feedback

The PinchGestureEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMidPoint | Returns the center point between the current touch points relative to the given UIElement.
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetMidPoint Method

[image]

Mindscape Phone Elements
PinchGestureEventArgs..::..GetMidPoint Method
PinchGestureEventArgs Class See Also Send Feedback
Returns the center point between the current touch points relative to the given UIElement.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point GetMidPoint(
    UIElement relativeTo
)
Visual Basic
Public Function GetMidPoint ( _
    relativeTo As UIElement _
) As Point
Visual C++
public:
Point GetMidPoint(
    UIElement^ relativeTo
)

Parameters

relativeTo
Type: System.Windows..::..UIElement
The UIElement to derive the center point.

Return Value

The center point of the pinch gesture relative to a given UIElement.

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


GetPosition Method

[image] [image]

Mindscape Phone Elements
PinchGestureEventArgs..::..GetPosition Method
PinchGestureEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPosition(UIElement) | Returns the current touch position relative to the given UIElement. (Inherited from MovingGestureEventArgs.)
Protected method | GetPosition(UIElement, Point) | Returns the given screen position relative to the given UIElement. (Inherited from GestureEventArgs.)

See Also

PinchGestureEventArgs Class
PinchGestureEventArgs Members
Mindscape.PhoneElements Namespace


PinchGestureEventArgs Properties

[image] [image]

Mindscape Phone Elements
PinchGestureEventArgs Properties
PinchGestureEventArgs Class See Also Send Feedback

The PinchGestureEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets the current angle between the touch points.
Public property | DeltaScale | Gets the scale factor between the current touch points and the previous touch points.
Public property | Distance | Gets the current distance between the touch points.
Public property | GestureOrigin | Gets the origin of the gesture in screen coordinates. (Inherited from GestureEventArgs.)
Public property | GestureOrigin2 | Gets the original position of the second touch point in screen coordinates. (Inherited from DualGestureEventArgs.)
Public property | MidPoint | Gets the center point between the current touch points relative to the screen coordinates.
Public property | PreviousTouchPosition | Gets the previous touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | PreviousTouchPosition2 | Gets the previous position of the second touch point in screen coordinates. (Inherited from DualGestureEventArgs.)
Public property | Scale | Gets the total scale factor between the current touch points and the original touch points.
Public property | TotalAngleDelta | Gets the total difference between the current angle and the original angle of the touch points.
Public property | TouchPosition | Gets the current touch position in screen coordinates. (Inherited from MovingGestureEventArgs.)
Public property | TouchPosition2 | Gets the current position of the second touch point in screen coordinates. (Inherited from DualGestureEventArgs.)

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


Angle Property

[image]

Mindscape Phone Elements
PinchGestureEventArgs..::..Angle Property
PinchGestureEventArgs Class See Also Send Feedback
Gets the current angle between the touch points.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Angle { get; }
Visual Basic
Public ReadOnly Property Angle As Double
    Get
Visual C++
public:
property double Angle {
    double get ();
}

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


DeltaScale Property

[image]

Mindscape Phone Elements
PinchGestureEventArgs..::..DeltaScale Property
PinchGestureEventArgs Class See Also Send Feedback
Gets the scale factor between the current touch points and the previous touch points.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DeltaScale { get; }
Visual Basic
Public ReadOnly Property DeltaScale As Double
    Get
Visual C++
public:
property double DeltaScale {
    double get ();
}

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


Distance Property

[image]

Mindscape Phone Elements
PinchGestureEventArgs..::..Distance Property
PinchGestureEventArgs Class See Also Send Feedback
Gets the current distance between the touch points.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Distance { get; }
Visual Basic
Public ReadOnly Property Distance As Double
    Get
Visual C++
public:
property double Distance {
    double get ();
}

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


MidPoint Property

[image]

Mindscape Phone Elements
PinchGestureEventArgs..::..MidPoint Property
PinchGestureEventArgs Class See Also Send Feedback
Gets the center point between the current touch points relative to the screen coordinates.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point MidPoint { get; }
Visual Basic
Public ReadOnly Property MidPoint As Point
    Get
Visual C++
public:
property Point MidPoint {
    Point get ();
}

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


Scale Property

[image]

Mindscape Phone Elements
PinchGestureEventArgs..::..Scale Property
PinchGestureEventArgs Class See Also Send Feedback
Gets the total scale factor between the current touch points and the original touch points.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Scale { get; }
Visual Basic
Public ReadOnly Property Scale As Double
    Get
Visual C++
public:
property double Scale {
    double get ();
}

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


TotalAngleDelta Property

[image]

Mindscape Phone Elements
PinchGestureEventArgs..::..TotalAngleDelta Property
PinchGestureEventArgs Class See Also Send Feedback
Gets the total difference between the current angle and the original angle of the touch points.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double TotalAngleDelta { get; }
Visual Basic
Public ReadOnly Property TotalAngleDelta As Double
    Get
Visual C++
public:
property double TotalAngleDelta {
    double get ();
}

See Also

PinchGestureEventArgs Class
Mindscape.PhoneElements Namespace


StandardPalettes Class

[image]

Mindscape Phone Elements
StandardPalettes Class
Members See Also Send Feedback
Provides standard color palettes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class StandardPalettes
Visual Basic
Public NotInheritable Class StandardPalettes
Visual C++
public ref class StandardPalettes abstract sealed

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..StandardPalettes

See Also

StandardPalettes Members
Mindscape.PhoneElements Namespace


StandardPalettes Members

[image] [image]

Mindscape Phone Elements
StandardPalettes Members
StandardPalettes Class Properties See Also Send Feedback

The StandardPalettes type exposes the following members.

Properties

Name | Description
OfficePalette | Gets the office color palette.

See Also

StandardPalettes Class
Mindscape.PhoneElements Namespace


StandardPalettes Properties

[image] [image]

Mindscape Phone Elements
StandardPalettes Properties
StandardPalettes Class See Also Send Feedback

The StandardPalettes type exposes the following members.

Properties

Name | Description
OfficePalette | Gets the office color palette.

See Also

StandardPalettes Class
Mindscape.PhoneElements Namespace


OfficePalette Property

[image]

Mindscape Phone Elements
StandardPalettes..::..OfficePalette Property
StandardPalettes Class See Also Send Feedback
Gets the office color palette.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ReadOnlyCollection<NamedColor> OfficePalette { get; }
Visual Basic
Public Shared ReadOnly Property OfficePalette As ReadOnlyCollection(Of NamedColor)
    Get
Visual C++
public:
static property ReadOnlyCollection<NamedColor^>^ OfficePalette {
    ReadOnlyCollection<NamedColor^>^ get ();
}

See Also

StandardPalettes Class
Mindscape.PhoneElements Namespace


ThicknessToDoubleConverter Class

[image]

Mindscape Phone Elements
ThicknessToDoubleConverter Class
Members See Also Send Feedback
Converts a Thickness into a double. This is useful for binding a BorderThickness property to a StrokeThickness property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ThicknessToDoubleConverter : IValueConverter
Visual Basic
Public Class ThicknessToDoubleConverter _
    Implements IValueConverter
Visual C++
public ref class ThicknessToDoubleConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ThicknessToDoubleConverter

See Also

ThicknessToDoubleConverter Members
Mindscape.PhoneElements Namespace


ThicknessToDoubleConverter Members

[image] [image]

Mindscape Phone Elements
ThicknessToDoubleConverter Members
ThicknessToDoubleConverter Class Constructors Methods See Also Send Feedback

The ThicknessToDoubleConverter type exposes the following members.

Constructors

 | Name | Description
Public method | ThicknessToDoubleConverter | Initializes a new instance of the ThicknessToDoubleConverter class

Methods

 | Name | Description
Public method | Convert | Converts a Thickness value from a binding source for use as a double value by a binding target.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThicknessToDoubleConverter Class
Mindscape.PhoneElements Namespace


ThicknessToDoubleConverter Constructor

[image]

Mindscape Phone Elements
ThicknessToDoubleConverter Constructor
ThicknessToDoubleConverter Class See Also Send Feedback
Initializes a new instance of the ThicknessToDoubleConverter class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ThicknessToDoubleConverter()
Visual Basic
Public Sub New
Visual C++
public:
ThicknessToDoubleConverter()

See Also

ThicknessToDoubleConverter Class
Mindscape.PhoneElements Namespace


ThicknessToDoubleConverter Methods

[image] [image]

Mindscape Phone Elements
ThicknessToDoubleConverter Methods
ThicknessToDoubleConverter Class See Also Send Feedback

The ThicknessToDoubleConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a Thickness value from a binding source for use as a double value by a binding target.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThicknessToDoubleConverter Class
Mindscape.PhoneElements Namespace


Convert Method

[image]

Mindscape Phone Elements
ThicknessToDoubleConverter..::..Convert Method
ThicknessToDoubleConverter Class See Also Send Feedback
Converts a Thickness value from a binding source for use as a double value by a binding target.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

ThicknessToDoubleConverter Class
Mindscape.PhoneElements Namespace


ConvertBack Method

[image]

Mindscape Phone Elements
ThicknessToDoubleConverter..::..ConvertBack Method
ThicknessToDoubleConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

ThicknessToDoubleConverter Class
Mindscape.PhoneElements Namespace


TimeDisplayMode Enumeration

[image]

Mindscape Phone Elements
TimeDisplayMode Enumeration
See Also Send Feedback
Specifies how to visualy display time.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum TimeDisplayMode
Visual Basic
Public Enumeration TimeDisplayMode
Visual C++
public enum class TimeDisplayMode

Members

Member name | Value | Description
TwelveHourTime | 0 | Time should be displayed in twelve hour time. (e.g. 3:00PM)
TwentyFourHourTime | 1 | Time should be displayed in twenty four hour time. (e.g. 15:00)

See Also

Mindscape.PhoneElements Namespace


TimeOfDay Structure

[image]

Mindscape Phone Elements
TimeOfDay Structure
Members See Also Send Feedback
Represents a time of day.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct TimeOfDay : IComparable<TimeOfDay>
Visual Basic
Public Structure TimeOfDay _
    Implements IComparable(Of TimeOfDay)
Visual C++
public value class TimeOfDay : IComparable<TimeOfDay>

See Also

TimeOfDay Members
Mindscape.PhoneElements Namespace


TimeOfDay Members

[image] [image]

Mindscape Phone Elements
TimeOfDay Members
TimeOfDay Structure Constructors Methods Operators Properties See Also Send Feedback

The TimeOfDay type exposes the following members.

Constructors

 | Name | Description
Public method | TimeOfDay(Int32) | Initializes a new instance of the TimeOfDay class.
Public method | TimeOfDay(Int32, Int32) | Initializes a new instance of the TimeOfDay class.

Methods

 | Name | Description
Public method | CompareTo | Compares this TimeOfDay to another.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a string representation of the TimeOfDay. (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
GreaterThan | Gets whether one TimeOfDay is later than another.
GreaterThanOrEqual | Gets whether one TimeOfDay is later than or the same as another.
LessThan | Gets whether one TimeOfDay is earlier than another.
LessThanOrEqual | Gets whether one TimeOfDay is earlier than or the same as another.

Properties

 | Name | Description
Public property | Hour | The hour of the TimeOfDay.
Public property | Minute | The minute of the TimeOfDay.
 | Now | Returns a TimeOfDay representing the current system clock time.
Public property | TwelveHourClockHour | The hour of the TimeOfDay, considered on the twelve-hour clock (e.g. 14:30 returns 2).

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


TimeOfDay Constructor

[image] [image]

Mindscape Phone Elements
TimeOfDay Constructor
TimeOfDay Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | TimeOfDay(Int32) | Initializes a new instance of the TimeOfDay class.
Public method | TimeOfDay(Int32, Int32) | Initializes a new instance of the TimeOfDay class.

See Also

TimeOfDay Structure
TimeOfDay Members
Mindscape.PhoneElements Namespace


TimeOfDay Constructor (Int32)

[image]

Mindscape Phone Elements
TimeOfDay Constructor (Int32)
TimeOfDay Structure See Also Send Feedback
Initializes a new instance of the TimeOfDay class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay(
    int hour
)
Visual Basic
Public Sub New ( _
    hour As Integer _
)
Visual C++
public:
TimeOfDay(
    int hour
)

Parameters

hour
Type: System..::..Int32
The hour of the day.

See Also

TimeOfDay Structure
TimeOfDay Overload
Mindscape.PhoneElements Namespace


TimeOfDay Constructor (Int32, Int32)

[image]

Mindscape Phone Elements
TimeOfDay Constructor (Int32, Int32)
TimeOfDay Structure See Also Send Feedback
Initializes a new instance of the TimeOfDay class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay(
    int hour,
    int minute
)
Visual Basic
Public Sub New ( _
    hour As Integer, _
    minute As Integer _
)
Visual C++
public:
TimeOfDay(
    int hour,
    int minute
)

Parameters

hour
Type: System..::..Int32
The hour of the day.
minute
Type: System..::..Int32
The minute of the hour.

See Also

TimeOfDay Structure
TimeOfDay Overload
Mindscape.PhoneElements Namespace


TimeOfDay Methods

[image] [image]

Mindscape Phone Elements
TimeOfDay Methods
TimeOfDay Structure See Also Send Feedback

The TimeOfDay type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | Compares this TimeOfDay to another.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets a string representation of the TimeOfDay. (Overrides ValueType..::..ToString()()()().)

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


CompareTo Method

[image]

Mindscape Phone Elements
TimeOfDay..::..CompareTo Method
TimeOfDay Structure See Also Send Feedback
Compares this TimeOfDay to another.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    TimeOfDay other
)
Visual Basic
Public Function CompareTo ( _
    other As TimeOfDay _
) As Integer
Visual C++
public:
virtual int CompareTo(
    TimeOfDay other
) sealed

Parameters

other
Type: Mindscape.PhoneElements..::..TimeOfDay
The TimeOfDay to compare against.

Return Value

A negative value if this TimeOfDay occurs before the other; a positive value if this TimeOfDay occurs after the other; 0 if the two TimeOfDays coincide.

Implements

IComparable<(Of <(<'T>)>)>..::..CompareTo(T)

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


ToString Method

[image]

Mindscape Phone Elements
TimeOfDay..::..ToString Method
TimeOfDay Structure See Also Send Feedback
Gets a string representation of the TimeOfDay.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the TimeOfDay.

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


TimeOfDay Operators

[image] [image]

Mindscape Phone Elements
TimeOfDay Operators
TimeOfDay Structure See Also Send Feedback

The TimeOfDay type exposes the following members.

Operators

Name | Description
GreaterThan | Gets whether one TimeOfDay is later than another.
GreaterThanOrEqual | Gets whether one TimeOfDay is later than or the same as another.
LessThan | Gets whether one TimeOfDay is earlier than another.
LessThanOrEqual | Gets whether one TimeOfDay is earlier than or the same as another.

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


GreaterThan Operator

[image]

Mindscape Phone Elements
TimeOfDay..::..GreaterThan Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is later than another.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator >(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic
Public Shared Operator > ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator >(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.PhoneElements..::..TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.PhoneElements..::..TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is later than second; otherwise false.

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


GreaterThanOrEqual Operator

[image]

Mindscape Phone Elements
TimeOfDay..::..GreaterThanOrEqual Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is later than or the same as another.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator >=(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic
Public Shared Operator >= ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator >=(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.PhoneElements..::..TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.PhoneElements..::..TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is later than or the same as second; otherwise false.

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


LessThan Operator

[image]

Mindscape Phone Elements
TimeOfDay..::..LessThan Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is earlier than another.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator <(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic
Public Shared Operator < ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator <(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.PhoneElements..::..TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.PhoneElements..::..TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is earlier than second; otherwise false.

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


LessThanOrEqual Operator

[image]

Mindscape Phone Elements
TimeOfDay..::..LessThanOrEqual Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is earlier than or the same as another.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator <=(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic
Public Shared Operator <= ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator <=(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.PhoneElements..::..TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.PhoneElements..::..TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is earlier than or the same as second; otherwise false.

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


TimeOfDay Properties

[image] [image]

Mindscape Phone Elements
TimeOfDay Properties
TimeOfDay Structure See Also Send Feedback

The TimeOfDay type exposes the following members.

Properties

 | Name | Description
Public property | Hour | The hour of the TimeOfDay.
Public property | Minute | The minute of the TimeOfDay.
 | Now | Returns a TimeOfDay representing the current system clock time.
Public property | TwelveHourClockHour | The hour of the TimeOfDay, considered on the twelve-hour clock (e.g. 14:30 returns 2).

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


Hour Property

[image]

Mindscape Phone Elements
TimeOfDay..::..Hour Property
TimeOfDay Structure See Also Send Feedback
The hour of the TimeOfDay.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Hour { get; }
Visual Basic
Public ReadOnly Property Hour As Integer
    Get
Visual C++
public:
property int Hour {
    int get ();
}

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


Minute Property

[image]

Mindscape Phone Elements
TimeOfDay..::..Minute Property
TimeOfDay Structure See Also Send Feedback
The minute of the TimeOfDay.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Minute { get; }
Visual Basic
Public ReadOnly Property Minute As Integer
    Get
Visual C++
public:
property int Minute {
    int get ();
}

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


Now Property

[image]

Mindscape Phone Elements
TimeOfDay..::..Now Property
TimeOfDay Structure See Also Send Feedback
Returns a TimeOfDay representing the current system clock time.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TimeOfDay Now { get; }
Visual Basic
Public Shared ReadOnly Property Now As TimeOfDay
    Get
Visual C++
public:
static property TimeOfDay Now {
    TimeOfDay get ();
}

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


TwelveHourClockHour Property

[image]

Mindscape Phone Elements
TimeOfDay..::..TwelveHourClockHour Property
TimeOfDay Structure See Also Send Feedback
The hour of the TimeOfDay, considered on the twelve-hour clock (e.g. 14:30 returns 2).

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TwelveHourClockHour { get; }
Visual Basic
Public ReadOnly Property TwelveHourClockHour As Integer
    Get
Visual C++
public:
property int TwelveHourClockHour {
    int get ();
}

See Also

TimeOfDay Structure
Mindscape.PhoneElements Namespace


TimePicker Class

[image]

Mindscape Phone Elements
TimePicker Class
Members See Also Send Feedback
Allows the user to select a time of day.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimePicker : PickerBase
Visual Basic
Public Class TimePicker _
    Inherits PickerBase
Visual C++
public ref class TimePicker : public PickerBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements..::..PickerBase
Mindscape.PhoneElements..::..TimePicker

See Also

TimePicker Members
Mindscape.PhoneElements Namespace


TimePicker Members

[image] [image]

Mindscape Phone Elements
TimePicker Members
TimePicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The TimePicker type exposes the following members.

Constructors

 | Name | Description
Public method | TimePicker | Initializes a new instance of the TimePicker class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page. (Inherited from PickerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application frame is navigated. (Overrides PickerBase..::..FrameNavigated(Object).)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Inherited from PickerBase.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from PickerBase.)
Protected method | PickerPageClosed | Called when the page is closed. (Overrides PickerBase..::..PickerPageClosed()()()().)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
CultureProperty | Identifies the Culture property.
SelectedTimeProperty | Identifies the SelectedTime property.
TimeDisplayModeProperty | Identifies the TimeDisplayMode property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Culture | Gets or sets the Culture. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property. (Inherited from PickerBase.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedTime | Gets or sets the selected TimeOfDay. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Text | Gets the text to be displayed in the TimePicker header.
Public property | TimeDisplayMode | Gets or sets the TimeDisplayMode. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes. (Inherited from PickerBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimePicker Constructor

[image]

Mindscape Phone Elements
TimePicker Constructor
TimePicker Class See Also Send Feedback
Initializes a new instance of the TimePicker class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimePicker()
Visual Basic
Public Sub New
Visual C++
public:
TimePicker()

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimePicker Fields

[image] [image]

Mindscape Phone Elements
TimePicker Fields
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Fields

Name | Description
CultureProperty | Identifies the Culture property.
SelectedTimeProperty | Identifies the SelectedTime property.
TimeDisplayModeProperty | Identifies the TimeDisplayMode property.

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


CultureProperty Field

[image]

Mindscape Phone Elements
TimePicker..::..CultureProperty Field
TimePicker Class See Also Send Feedback
Identifies the Culture property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CultureProperty
Visual Basic
Public Shared ReadOnly CultureProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CultureProperty

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


SelectedTimeProperty Field

[image]

Mindscape Phone Elements
TimePicker..::..SelectedTimeProperty Field
TimePicker Class See Also Send Feedback
Identifies the SelectedTime property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedTimeProperty
Visual Basic
Public Shared ReadOnly SelectedTimeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedTimeProperty

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimeDisplayModeProperty Field

[image]

Mindscape Phone Elements
TimePicker..::..TimeDisplayModeProperty Field
TimePicker Class See Also Send Feedback
Identifies the TimeDisplayMode property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TimeDisplayModeProperty
Visual Basic
Public Shared ReadOnly TimeDisplayModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TimeDisplayModeProperty

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimePicker Methods

[image] [image]

Mindscape Phone Elements
TimePicker Methods
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Protected method | ClosePickerPage | closes the picker page. (Inherited from PickerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Protected method | FrameNavigated | Called when the application frame is navigated. (Overrides PickerBase..::..FrameNavigated(Object).)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Inherited from PickerBase.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event. (Inherited from PickerBase.)
Protected method | PickerPageClosed | Called when the page is closed. (Overrides PickerBase..::..PickerPageClosed()()()().)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


FrameNavigated Method

[image]

Mindscape Phone Elements
TimePicker..::..FrameNavigated Method
TimePicker Class See Also Send Feedback
Called when the application frame is navigated.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void FrameNavigated(
    Object content
)
Visual Basic
Protected Overrides Sub FrameNavigated ( _
    content As Object _
)
Visual C++
protected:
virtual void FrameNavigated(
    Object^ content
) override

Parameters

content
Type: System..::..Object
The current content of the application frame.

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


PickerPageClosed Method

[image]

Mindscape Phone Elements
TimePicker..::..PickerPageClosed Method
TimePicker Class See Also Send Feedback
Called when the page is closed.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void PickerPageClosed()
Visual Basic
Protected Overrides Sub PickerPageClosed
Visual C++
protected:
virtual void PickerPageClosed() override

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimePicker Properties

[image] [image]

Mindscape Phone Elements
TimePicker Properties
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Culture | Gets or sets the Culture. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PickerPageUri | Gets or sets the Uri used to get the PhoneApplicationPage to open. This is a dependency property. (Inherited from PickerBase.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedTime | Gets or sets the selected TimeOfDay. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Text | Gets the text to be displayed in the TimePicker header.
Public property | TimeDisplayMode | Gets or sets the TimeDisplayMode. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
TimePicker..::..Culture Property
TimePicker Class See Also Send Feedback
Gets or sets the Culture. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


SelectedTime Property

[image]

Mindscape Phone Elements
TimePicker..::..SelectedTime Property
TimePicker Class See Also Send Feedback
Gets or sets the selected TimeOfDay. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay SelectedTime { get; set; }
Visual Basic
Public Property SelectedTime As TimeOfDay
    Get
    Set
Visual C++
public:
property TimeOfDay SelectedTime {
    TimeOfDay get ();
    void set (TimeOfDay value);
}

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


Text Property

[image]

Mindscape Phone Elements
TimePicker..::..Text Property
TimePicker Class See Also Send Feedback
Gets the text to be displayed in the TimePicker header.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Text { get; private set; }
Visual Basic
Public Property Text As String
    Get
    Private Set
Visual C++
public:
property String^ Text {
    String^ get ();
    private: void set (String^ value);
}

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimeDisplayMode Property

[image]

Mindscape Phone Elements
TimePicker..::..TimeDisplayMode Property
TimePicker Class See Also Send Feedback
Gets or sets the TimeDisplayMode. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeDisplayMode TimeDisplayMode { get; set; }
Visual Basic
Public Property TimeDisplayMode As TimeDisplayMode
    Get
    Set
Visual C++
public:
property TimeDisplayMode TimeDisplayMode {
    TimeDisplayMode get ();
    void set (TimeDisplayMode value);
}

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimePicker Events

[image] [image]

Mindscape Phone Elements
TimePicker Events
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes. (Inherited from PickerBase.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

TimePicker Class
Mindscape.PhoneElements Namespace


TimePickerPage Class

[image]

Mindscape Phone Elements
TimePickerPage Class
Members See Also Send Feedback
The standard page that can be opened by a TimePicker.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimePickerPage : PhoneApplicationPage,
    ITimePickerPage
Visual Basic
Public Class TimePickerPage _
    Inherits PhoneApplicationPage _
    Implements ITimePickerPage
Visual C++
public ref class TimePickerPage : public PhoneApplicationPage,
    ITimePickerPage

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..UserControl
System.Windows.Controls..::..Page
PhoneApplicationPage
Mindscape.PhoneElements..::..TimePickerPage

See Also

TimePickerPage Members
Mindscape.PhoneElements Namespace


TimePickerPage Members

[image] [image]

Mindscape Phone Elements
TimePickerPage Members
TimePickerPage Class Constructors Methods Fields Properties Events See Also Send Feedback

The TimePickerPage type exposes the following members.

Constructors

 | Name | Description
Public method | TimePickerPage | Initializes a new instance of the TimePickerPage class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
CultureProperty | Identifies the Culture property.
SelectedTimeProperty | Identifies the SelectedTime property.
TimeDisplayModeProperty | Identifies the TimeDisplayMode property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Culture | Gets or sets the Culture. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedTime | Gets or sets the selected TimeOfDay. This is a dependency property.
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TimeDisplayMode | Gets or sets the TimeDisplayMode. This is a dependency property.
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


TimePickerPage Constructor

[image]

Mindscape Phone Elements
TimePickerPage Constructor
TimePickerPage Class See Also Send Feedback
Initializes a new instance of the TimePickerPage class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimePickerPage()
Visual Basic
Public Sub New
Visual C++
public:
TimePickerPage()

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


TimePickerPage Fields

[image] [image]

Mindscape Phone Elements
TimePickerPage Fields
TimePickerPage Class See Also Send Feedback

The TimePickerPage type exposes the following members.

Fields

Name | Description
CultureProperty | Identifies the Culture property.
SelectedTimeProperty | Identifies the SelectedTime property.
TimeDisplayModeProperty | Identifies the TimeDisplayMode property.

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


CultureProperty Field

[image]

Mindscape Phone Elements
TimePickerPage..::..CultureProperty Field
TimePickerPage Class See Also Send Feedback
Identifies the Culture property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CultureProperty
Visual Basic
Public Shared ReadOnly CultureProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CultureProperty

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


SelectedTimeProperty Field

[image]

Mindscape Phone Elements
TimePickerPage..::..SelectedTimeProperty Field
TimePickerPage Class See Also Send Feedback
Identifies the SelectedTime property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedTimeProperty
Visual Basic
Public Shared ReadOnly SelectedTimeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedTimeProperty

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


TimeDisplayModeProperty Field

[image]

Mindscape Phone Elements
TimePickerPage..::..TimeDisplayModeProperty Field
TimePickerPage Class See Also Send Feedback
Identifies the TimeDisplayMode property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TimeDisplayModeProperty
Visual Basic
Public Shared ReadOnly TimeDisplayModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TimeDisplayModeProperty

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


TimePickerPage Methods

[image] [image]

Mindscape Phone Elements
TimePickerPage Methods
TimePickerPage Class See Also Send Feedback

The TimePickerPage type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | (Inherited from PhoneApplicationPage.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InitializeComponent | InitializeComponent
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnBackKeyPress | (Inherited from PhoneApplicationPage.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnFragmentNavigation | (Inherited from Page.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | OnNavigatedFrom | (Inherited from Page.)
Protected method | OnNavigatedTo | (Inherited from Page.)
Protected method | OnNavigatingFrom | (Inherited from Page.)
Protected method | OnOrientationChanged | (Inherited from PhoneApplicationPage.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


InitializeComponent Method

[image]

Mindscape Phone Elements
TimePickerPage..::..InitializeComponent Method
TimePickerPage Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


TimePickerPage Properties

[image] [image]

Mindscape Phone Elements
TimePickerPage Properties
TimePickerPage Class See Also Send Feedback

The TimePickerPage type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ApplicationBar | (Inherited from PhoneApplicationPage.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Protected property | Content | (Inherited from UserControl.)
Public property | Culture | Gets or sets the Culture. This is a dependency property.
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | NavigationCacheMode | (Inherited from Page.)
Public property | NavigationContext | (Inherited from Page.)
Public property | NavigationService | Gets the navigation service that the host of the page is using to manage navigation. (Inherited from Page.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | (Inherited from PhoneApplicationPage.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedTime | Gets or sets the selected TimeOfDay. This is a dependency property.
Public property | State | (Inherited from PhoneApplicationPage.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportedOrientations | (Inherited from PhoneApplicationPage.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TimeDisplayMode | Gets or sets the TimeDisplayMode. This is a dependency property.
Public property | Title | Gets or sets the title of the Page. This is a dependency property. (Inherited from Page.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
TimePickerPage..::..Culture Property
TimePickerPage Class See Also Send Feedback
Gets or sets the Culture. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
virtual property CultureInfo^ Culture {
    CultureInfo^ get () sealed;
    void set (CultureInfo^ value) sealed;
}

Implements

ITimePickerPage..::..Culture

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


SelectedTime Property

[image]

Mindscape Phone Elements
TimePickerPage..::..SelectedTime Property
TimePickerPage Class See Also Send Feedback
Gets or sets the selected TimeOfDay. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay SelectedTime { get; set; }
Visual Basic
Public Property SelectedTime As TimeOfDay
    Get
    Set
Visual C++
public:
virtual property TimeOfDay SelectedTime {
    TimeOfDay get () sealed;
    void set (TimeOfDay value) sealed;
}

Implements

ITimePickerPage..::..SelectedTime

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


TimeDisplayMode Property

[image]

Mindscape Phone Elements
TimePickerPage..::..TimeDisplayMode Property
TimePickerPage Class See Also Send Feedback
Gets or sets the TimeDisplayMode. This is a dependency property.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeDisplayMode TimeDisplayMode { get; set; }
Visual Basic
Public Property TimeDisplayMode As TimeDisplayMode
    Get
    Set
Visual C++
public:
virtual property TimeDisplayMode TimeDisplayMode {
    TimeDisplayMode get () sealed;
    void set (TimeDisplayMode value) sealed;
}

Implements

ITimePickerPage..::..TimeDisplayMode

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


TimePickerPage Events

[image] [image]

Mindscape Phone Elements
TimePickerPage Events
TimePickerPage Class See Also Send Feedback

The TimePickerPage type exposes the following members.

Events

 | Name | Description
Public event | BackKeyPress | (Inherited from PhoneApplicationPage.)
Public event | BeginLayoutChanged | (Inherited from PhoneApplicationPage.)
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | OrientationChanged | (Inherited from PhoneApplicationPage.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

TimePickerPage Class
Mindscape.PhoneElements Namespace


ViewModelBase Class

[image]

Mindscape Phone Elements
ViewModelBase Class
Members See Also Send Feedback
Provides property change notification servics for view model objects.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ViewModelBase : INotifyPropertyChanged
Visual Basic
Public MustInherit Class ViewModelBase _
    Implements INotifyPropertyChanged
Visual C++
public ref class ViewModelBase abstract : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..ViewModelBase
Mindscape.PhoneElements..::..NotifyingColor

See Also

ViewModelBase Members
Mindscape.PhoneElements Namespace


ViewModelBase Members

[image] [image]

Mindscape Phone Elements
ViewModelBase Members
ViewModelBase Class Constructors Methods Events See Also Send Feedback

The ViewModelBase type exposes the following members.

Constructors

 | Name | Description
Protected method | ViewModelBase | Initializes a new instance of the ViewModelBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | Set<(Of <<'(T>)>>) | Sets the specified field, raising the PropertyChanged event if required.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

ViewModelBase Class
Mindscape.PhoneElements Namespace


ViewModelBase Constructor

[image]

Mindscape Phone Elements
ViewModelBase Constructor
ViewModelBase Class See Also Send Feedback
Initializes a new instance of the ViewModelBase class

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ViewModelBase()
Visual Basic
Protected Sub New
Visual C++
protected:
ViewModelBase()

See Also

ViewModelBase Class
Mindscape.PhoneElements Namespace


ViewModelBase Methods

[image] [image]

Mindscape Phone Elements
ViewModelBase Methods
ViewModelBase Class See Also Send Feedback

The ViewModelBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | Raises the PropertyChanged event.
Protected method | Set<(Of <<'(T>)>>) | Sets the specified field, raising the PropertyChanged event if required.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewModelBase Class
Mindscape.PhoneElements Namespace


OnPropertyChanged Method

[image]

Mindscape Phone Elements
ViewModelBase..::..OnPropertyChanged Method
ViewModelBase Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
The name of the property that changed.

See Also

ViewModelBase Class
Mindscape.PhoneElements Namespace


Set(T) Method

[image]

Mindscape Phone Elements
ViewModelBase..::..Set<(Of <(<'T>)>)> Method
ViewModelBase Class See Also Send Feedback
Sets the specified field, raising the PropertyChanged event if required.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void Set<T>(
    ref T field,
    T value,
    string propertyName
)
Visual Basic
Protected Sub Set(Of T) ( _
    ByRef field As T, _
    value As T, _
    propertyName As String _
)
Visual C++
protected:
generic<typename T>
void Set(
    T% field,
    T value,
    String^ propertyName
)

Parameters

field
Type: T%
The field to set.
value
Type: T
The value to which to set the field.
propertyName
Type: System..::..String
The name of the property for the PropertyChanged event.

Type Parameters

T
The type of field.

See Also

ViewModelBase Class
Mindscape.PhoneElements Namespace


ViewModelBase Events

[image] [image]

Mindscape Phone Elements
ViewModelBase Events
ViewModelBase Class See Also Send Feedback

The ViewModelBase type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

ViewModelBase Class
Mindscape.PhoneElements Namespace


PropertyChanged Event

[image]

Mindscape Phone Elements
ViewModelBase..::..PropertyChanged Event
ViewModelBase Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

ViewModelBase Class
Mindscape.PhoneElements Namespace


YearlyDataSource Class

[image]

Mindscape Phone Elements
YearlyDataSource Class
Members See Also Send Feedback
A data source that lists a sequence of consecutive years from 1601 to 3000. This data source uses DateTimeWrapper objects. This data source does not loop through the sequence.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class YearlyDataSource : IDataSource
Visual Basic
Public Class YearlyDataSource _
    Implements IDataSource
Visual C++
public ref class YearlyDataSource : IDataSource

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements..::..YearlyDataSource

See Also

YearlyDataSource Members
Mindscape.PhoneElements Namespace


YearlyDataSource Members

[image] [image]

Mindscape Phone Elements
YearlyDataSource Members
YearlyDataSource Class Constructors Methods Properties See Also Send Feedback

The YearlyDataSource type exposes the following members.

Constructors

 | Name | Description
Public method | YearlyDataSource()()()() | Initializes a new instance of the YearlyDataSource class.
Public method | YearlyDataSource(CultureInfo) | Initializes a new instance of the YearlyDataSource class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next year in the sequence based on the given delta value. This data source does not loop through the sequence. Null is returned if an overflow occurs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Culture | Gets or sets the CultureInfo used to format the date.
Public property | FirstValue | Gets a DateTimeWrapper containing DateTime.Now.

See Also

YearlyDataSource Class
Mindscape.PhoneElements Namespace


YearlyDataSource Constructor

[image] [image]

Mindscape Phone Elements
YearlyDataSource Constructor
YearlyDataSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | YearlyDataSource()()()() | Initializes a new instance of the YearlyDataSource class.
Public method | YearlyDataSource(CultureInfo) | Initializes a new instance of the YearlyDataSource class.

See Also

YearlyDataSource Class
YearlyDataSource Members
Mindscape.PhoneElements Namespace


YearlyDataSource Constructor

[image]

Mindscape Phone Elements
YearlyDataSource Constructor
YearlyDataSource Class See Also Send Feedback
Initializes a new instance of the YearlyDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public YearlyDataSource()
Visual Basic
Public Sub New
Visual C++
public:
YearlyDataSource()

See Also

YearlyDataSource Class
YearlyDataSource Overload
Mindscape.PhoneElements Namespace


YearlyDataSource Constructor (CultureInfo)

[image]

Mindscape Phone Elements
YearlyDataSource Constructor (CultureInfo)
YearlyDataSource Class See Also Send Feedback
Initializes a new instance of the YearlyDataSource class.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public YearlyDataSource(
    CultureInfo culture
)
Visual Basic
Public Sub New ( _
    culture As CultureInfo _
)
Visual C++
public:
YearlyDataSource(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::..CultureInfo
The CultureInfo used to format the date.

See Also

YearlyDataSource Class
YearlyDataSource Overload
Mindscape.PhoneElements Namespace


YearlyDataSource Methods

[image] [image]

Mindscape Phone Elements
YearlyDataSource Methods
YearlyDataSource Class See Also Send Feedback

The YearlyDataSource type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNext | Returns the next year in the sequence based on the given delta value. This data source does not loop through the sequence. Null is returned if an overflow occurs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

YearlyDataSource Class
Mindscape.PhoneElements Namespace


GetNext Method

[image]

Mindscape Phone Elements
YearlyDataSource..::..GetNext Method
YearlyDataSource Class See Also Send Feedback
Returns the next year in the sequence based on the given delta value. This data source does not loop through the sequence. Null is returned if an overflow occurs.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetNext(
    Object current,
    int deltaIndex
)
Visual Basic
Public Function GetNext ( _
    current As Object, _
    deltaIndex As Integer _
) As Object
Visual C++
public:
virtual Object^ GetNext(
    Object^ current,
    int deltaIndex
) sealed

Parameters

current
Type: System..::..Object
The current DateTimeWrapper.
deltaIndex
Type: System..::..Int32
The number of years to advance through the sequence.

Return Value

The next DateTimeWrapper which is offset from the current DateTimeWrapper by the given number of years.

Implements

IDataSource..::..GetNext(Object, Int32)

See Also

YearlyDataSource Class
Mindscape.PhoneElements Namespace


YearlyDataSource Properties

[image] [image]

Mindscape Phone Elements
YearlyDataSource Properties
YearlyDataSource Class See Also Send Feedback

The YearlyDataSource type exposes the following members.

Properties

 | Name | Description
Public property | Culture | Gets or sets the CultureInfo used to format the date.
Public property | FirstValue | Gets a DateTimeWrapper containing DateTime.Now.

See Also

YearlyDataSource Class
Mindscape.PhoneElements Namespace


Culture Property

[image]

Mindscape Phone Elements
YearlyDataSource..::..Culture Property
YearlyDataSource Class See Also Send Feedback
Gets or sets the CultureInfo used to format the date.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic
Public Property Culture As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

See Also

YearlyDataSource Class
Mindscape.PhoneElements Namespace


FirstValue Property

[image]

Mindscape Phone Elements
YearlyDataSource..::..FirstValue Property
YearlyDataSource Class See Also Send Feedback
Gets a DateTimeWrapper containing DateTime.Now.

Namespace: Mindscape.PhoneElements
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object FirstValue { get; }
Visual Basic
Public ReadOnly Property FirstValue As Object
    Get
Visual C++
public:
virtual property Object^ FirstValue {
    Object^ get () sealed;
}

Implements

IDataSource..::..FirstValue

See Also

YearlyDataSource Class
Mindscape.PhoneElements Namespace


Mindscape.PhoneElements.Charting Namespace

[image]

Mindscape Phone Elements
Mindscape.PhoneElements.Charting Namespace
Send Feedback
The Mindscape.PhoneElements.Charting namespace contains charting controls and supporting classes.

Classes

 | Class | Description
Public class | AreaSeries | Plots an area series on a Chart control.
Public class | AxisLabel | Represents an axis label. This class is primarily for internal use.
Public class | Bar | Represents a data point in a BarSeries.
Public class | BarSeries | Plots a bar series on a Chart control. A bar series is represented by a set of vertical bars.
Public class | BooleanToDoubleConverter | Selects a double value according to whether the binding source is true or false.
Public class | Bubble | Represents a data point in a BubbleSeries.
Public class | BubbleSeries | Plots a bubble series on a Chart control.
Public class | CartesianDataPoint | Represents a single data point to be plotted on cartesian (X/Y) axes.
Public class | Chart | A control for displaying data series on a chart.
Public class | ChartAxis | Represents an axis for a Chart.
Public class | ChartGrid | Renders grid lines and stripe lines based on a pair of ChartAxis objects.
Public class | ChartMouseEventArgs | Holds information about mouse events that occur on a chart canvas.
Public class | ChartSymbol | Represents a data point of a data series involving plotted points.
Public class | DataLabel | Represents a label for data points on a Chart.
Public class | DataLabelHost | Used internally for positioning data labels. Application code does not normally interact with DataLabelHost.
Public class | DataPoint | Represents a single piece of data to be plotted on a chart.
Public class | DataSeries | Represents a data series that can be plotted by a Chart control.
Public class | DateTimeAxisLabelConverter | A type of IAxisLabelConverter used for creating a DateTime axis scale.
Public class | DateTimeAxisValueConverter | A type of IAxisValueConverter used for creating a DateTime axis scale.
Public class | DoubleToHorizontalTranslationConverter | Converts a double to a horizontal TranslateTransform of the specified amount.
Public class | DoubleToRotateTransformConverter | Given a double input value, creates a RotateTransform with that angle.
Public class | DoubleToThicknessConverter | Converts a double to a Thickness.
Public class | FormattingConverter | Formats a binding source value using a format string.
Public class | Legend | Displays the title of each data series plotted on a Chart.
Public class | LegendItem | Represents an item to be displayed in a legend.
Public class | LegendItemToAreaBackgroundConverter | Determines the background brush to be applied to an area for a given LegendItem.
Public class | LegendItemToAreaChartSymbolMarginConverter | Returns the margin to be used on the chart symbol for a given LegendItem.
Public class | LegendItemToChartSymbolBackgroundConverter | Determines the background brush to be applied to a chart symbol for a given LegendItem.
Public class | LegendItemToChartSymbolBorderBrushConverter | Determines the border brush to be applied to a chart symbol for a given LegendItem.
Public class | LegendItemToDashArrayConverter | Returns a dash array to be used in the given LegendItem.
Public class | LegendItemToLineStrokeConverter | Determines the stroke brush to be applied to a path for a given LegendItem.
Public class | LegendPositionToIntegerConverter | Converts a LegendPosition into an integer value. This is typically used in custom templates for the Chart and PieChart controls when laying out the elements using a grid.
Public class | LegendPositionToVisibilityConverter | Converts a LegendPosition into a Visibility.
Public class | LineAreaSeriesBase | A base class for DataSeries that use lines to plot data, such as LineSeries.
Public class | LineSeries | Plots a line series on a Chart control. A line series is represented by a sequence of symbols, joined by lines.
Public class | LogarithmicAxisValueConverter | Plots data using a logarithmic scale.
Public class | MarkedStripe | Holds information about rendering colored zones against a ChartAxis in a MarkedStripeGrid.
Public class | MarkedStripeGrid | Renders colored axis zones based on a pair of ChartAxis objects.
Public class | MonthAxisLabelConverter | A type of IAxisLabelConverter used to create a month axis scale.
Public class | MonthAxisValueConverter | A type of IAxisValueConverter used to create a month axis scale.
Public class | OrientationToVisibilityConverter | Selects a Visibility based on an Orientation.
Public class | PieChart | A control for displaying PieSeries.
Public class | PieSeries | Holds data for a single pie chart series.
Public class | PieSlice | Represents a data point on a PieChart.
Public class | PieSliceToRadialGradientBrushConverter | Creates a RadialGradientBrush for a PieSlice.
Public class | PointSeriesBase | A base class for data series which plot data using points, such as line series or scatter graphs.
Public class | ScatterSeries | Plots a scatter series on a Chart control.
Public class | SplineAreaSeries | Plots a spline area series on a Chart control.
Public class | SplineSeries | Plots a spline series on a Chart control.
Public class | StackedAreaSeries | Plots a stacked area series on a Chart control.
Public class | StackedBarSeries | Plots a stcaked bar series on a Chart control.
Public class | StackedLineSeries | Plots a stacked line series on a Chart control.
Public class | StackedSplineAreaSeries | Plots a stacked spline area series on a Chart control.
Public class | StackedSplineSeries | Plots a stacked spline series on a Chart control.

Interfaces

 | Interface | Description
Public interface | IAxisLabelConverter | Converts between data values and logical axis positions to create custom axis scales.
Public interface | IAxisValueConverter | Converts between data values and logical axis positions to create custom axis scales.

Enumerations

 | Enumeration | Description
Public enumeration | AxisLabelLayout | Specifies how to position axis labels along a ChartAxis.
Public enumeration | AxisTickLayout | Specifies the layout of the tick marks along a ChartAxis.
Public enumeration | DataPointHighlightMode | Sepecifies how a DataPoint can be highlighted within its DataSeries.
Public enumeration | DataPointSelectionMode | Specifies how DataPoint objects can be selected within a DataSeries.
Public enumeration | DataSeriesSelectionMode | Specifies the selection mode of DataSeries within a Chart.
Public enumeration | LegendPosition | Specifies the location on a Chart where the legend is displayed.
Public enumeration | TickMarkMode | Specifies how tick marks respond to panning the chart canvas.
Public enumeration | ZoomMode | Specifies the zoom mode of a Chart control.


AreaSeries Class

[image]

Mindscape Phone Elements
AreaSeries Class
Members See Also Send Feedback
Plots an area series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AreaSeries : LineAreaSeriesBase
Visual Basic
Public Class AreaSeries _
    Inherits LineAreaSeriesBase
Visual C++
public ref class AreaSeries : public LineAreaSeriesBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..AreaSeries
Mindscape.PhoneElements.Charting..::..SplineAreaSeries
Mindscape.PhoneElements.Charting..::..StackedAreaSeries
Mindscape.PhoneElements.Charting..::..StackedSplineAreaSeries

See Also

AreaSeries Members
Mindscape.PhoneElements.Charting Namespace


AreaSeries Members

[image] [image]

Mindscape Phone Elements
AreaSeries Members
AreaSeries Class Constructors Methods Fields Properties Events See Also Send Feedback

The AreaSeries type exposes the following members.

Constructors

 | Name | Description
Public method | AreaSeries | Initializes a new instance of the AreaSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the AreaSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
AreaStyleProperty | Identifies the AreaStyle property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

AreaSeries Class


AreaSeries Constructor

[image]

Mindscape Phone Elements
AreaSeries Constructor
AreaSeries Class See Also Send Feedback
Initializes a new instance of the AreaSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AreaSeries()
Visual Basic
Public Sub New
Visual C++
public:
AreaSeries()

See Also

AreaSeries Class


AreaSeries Fields

[image] [image]

Mindscape Phone Elements
AreaSeries Fields
AreaSeries Class See Also Send Feedback

The AreaSeries type exposes the following members.

Fields

Name | Description
AreaStyleProperty | Identifies the AreaStyle property.

See Also

AreaSeries Class


AreaStyleProperty Field

[image]

Mindscape Phone Elements
AreaSeries..::..AreaStyleProperty Field
AreaSeries Class See Also Send Feedback
Identifies the AreaStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty AreaStyleProperty
Visual Basic
Public Shared ReadOnly AreaStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AreaStyleProperty

See Also

AreaSeries Class


AreaSeries Methods

[image] [image]

Mindscape Phone Elements
AreaSeries Methods
AreaSeries Class See Also Send Feedback

The AreaSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the AreaSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

AreaSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
AreaSeries..::..AddDataLabel Method
AreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

AreaSeries Class
AreaSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
AreaSeries..::..BuildChartCore Method
AreaSeries Class See Also Send Feedback
Plots the AreaSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

AreaSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
AreaSeries..::..GetPoint Method
AreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

AreaSeries Class
AreaSeries Members


AreaSeries Properties

[image] [image]

Mindscape Phone Elements
AreaSeries Properties
AreaSeries Class See Also Send Feedback

The AreaSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

AreaSeries Class


AreaStyle Property

[image]

Mindscape Phone Elements
AreaSeries..::..AreaStyle Property
AreaSeries Class See Also Send Feedback
Gets or sets the Style to be applied to the area. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style AreaStyle { get; set; }
Visual Basic
Public Property AreaStyle As Style
    Get
    Set
Visual C++
public:
property Style^ AreaStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

AreaSeries Class


AreaSeries Events

[image] [image]

Mindscape Phone Elements
AreaSeries Events
AreaSeries Class See Also Send Feedback

The AreaSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

AreaSeries Class


AxisLabel Class

[image]

Mindscape Phone Elements
AxisLabel Class
Members See Also Send Feedback
Represents an axis label. This class is primarily for internal use.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AxisLabel : Control, INotifyPropertyChanged
Visual Basic
Public Class AxisLabel _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class AxisLabel : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..AxisLabel

See Also

AxisLabel Members


AxisLabel Members

[image] [image]

Mindscape Phone Elements
AxisLabel Members
AxisLabel Class Methods Properties Events See Also Send Feedback

The AxisLabel type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Label | Gets the content of the AxisLabel.
Public property | LabelTemplate | Gets the DataTemplate used to display the axis label.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

AxisLabel Class


AxisLabel Methods

[image] [image]

Mindscape Phone Elements
AxisLabel Methods
AxisLabel Class See Also Send Feedback

The AxisLabel type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

AxisLabel Class


AxisLabel Properties

[image] [image]

Mindscape Phone Elements
AxisLabel Properties
AxisLabel Class See Also Send Feedback

The AxisLabel type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Label | Gets the content of the AxisLabel.
Public property | LabelTemplate | Gets the DataTemplate used to display the axis label.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

AxisLabel Class


Label Property

[image]

Mindscape Phone Elements
AxisLabel..::..Label Property
AxisLabel Class See Also Send Feedback
Gets the content of the AxisLabel.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Label { get; internal set; }
Visual Basic
Public Property Label As Object
    Get
    Friend Set
Visual C++
public:
property Object^ Label {
    Object^ get ();
    internal: void set (Object^ value);
}

See Also

AxisLabel Class


LabelTemplate Property

[image]

Mindscape Phone Elements
AxisLabel..::..LabelTemplate Property
AxisLabel Class See Also Send Feedback
Gets the DataTemplate used to display the axis label.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate LabelTemplate { get; internal set; }
Visual Basic
Public Property LabelTemplate As DataTemplate
    Get
    Friend Set
Visual C++
public:
property DataTemplate^ LabelTemplate {
    DataTemplate^ get ();
    internal: void set (DataTemplate^ value);
}

See Also

AxisLabel Class


AxisLabel Events

[image] [image]

Mindscape Phone Elements
AxisLabel Events
AxisLabel Class See Also Send Feedback

The AxisLabel type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

AxisLabel Class


PropertyChanged Event

[image]

Mindscape Phone Elements
AxisLabel..::..PropertyChanged Event
AxisLabel Class See Also Send Feedback
Raised when a property value changes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

AxisLabel Class


AxisLabelLayout Enumeration

[image]

Mindscape Phone Elements
AxisLabelLayout Enumeration
See Also Send Feedback
Specifies how to position axis labels along a ChartAxis.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum AxisLabelLayout
Visual Basic
Public Enumeration AxisLabelLayout
Visual C++
public enum class AxisLabelLayout

Members

Member name | Value | Description
Normal | 0 | Axis labels are positioned from the start to the end of the ChartAxis.
Inside | 1 | Axis labels start and end between a buffer placed at each end of the ChartAxis. This is useful for bar charts.

See Also


AxisTickLayout Enumeration

[image]

Mindscape Phone Elements
AxisTickLayout Enumeration
See Also Send Feedback
Specifies the layout of the tick marks along a ChartAxis.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum AxisTickLayout
Visual Basic
Public Enumeration AxisTickLayout
Visual C++
public enum class AxisTickLayout

Members

Member name | Value | Description
Normal | 0 | Tick marks are positioned from the start to the end of the ChartAxis.
Inside | 1 | Tick marks start and end between a buffer placed at each end of the ChartAxis.

See Also


Bar Class

[image]

Mindscape Phone Elements
Bar Class
Members See Also Send Feedback
Represents a data point in a BarSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Bar : CartesianDataPoint
Visual Basic
Public Class Bar _
    Inherits CartesianDataPoint
Visual C++
public ref class Bar : public CartesianDataPoint

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataPoint
Mindscape.PhoneElements.Charting..::..CartesianDataPoint
Mindscape.PhoneElements.Charting..::..Bar

See Also

Bar Members


Bar Members

[image] [image]

Mindscape Phone Elements
Bar Members
Bar Class Methods Fields Properties Events See Also Send Feedback

The Bar type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
TitleProperty | Identifies the Title property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsNegative | Gets whether or not the Bar is plotting a negative value.
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint. (Inherited from CartesianDataPoint.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the Bar.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the optional title of the data point. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Bar Class


Bar Fields

[image] [image]

Mindscape Phone Elements
Bar Fields
Bar Class See Also Send Feedback

The Bar type exposes the following members.

Fields

Name | Description
TitleProperty | Identifies the Title property.

See Also

Bar Class


TitleProperty Field

[image]

Mindscape Phone Elements
Bar..::..TitleProperty Field
Bar Class See Also Send Feedback
Identifies the Title property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleProperty

See Also

Bar Class


Bar Methods

[image] [image]

Mindscape Phone Elements
Bar Methods
Bar Class See Also Send Feedback

The Bar type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

Bar Class


Bar Properties

[image] [image]

Mindscape Phone Elements
Bar Properties
Bar Class See Also Send Feedback

The Bar type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsNegative | Gets whether or not the Bar is plotting a negative value.
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint. (Inherited from CartesianDataPoint.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets the Orientation of the Bar.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the optional title of the data point. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)

See Also

Bar Class


IsNegative Property

[image]

Mindscape Phone Elements
Bar..::..IsNegative Property
Bar Class See Also Send Feedback
Gets whether or not the Bar is plotting a negative value.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsNegative { get; internal set; }
Visual Basic
Public Property IsNegative As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsNegative {
    bool get ();
    internal: void set (bool value);
}

See Also

Bar Class


Orientation Property

[image]

Mindscape Phone Elements
Bar..::..Orientation Property
Bar Class See Also Send Feedback
Gets the Orientation of the Bar.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation Orientation { get; private set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Private Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    private: void set (Orientation value);
}

See Also

Bar Class


Title Property

[image]

Mindscape Phone Elements
Bar..::..Title Property
Bar Class See Also Send Feedback
Gets or sets the optional title of the data point. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Bar Class


Bar Events

[image] [image]

Mindscape Phone Elements
Bar Events
Bar Class See Also Send Feedback

The Bar type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Bar Class


BarSeries Class

[image]

Mindscape Phone Elements
BarSeries Class
Members See Also Send Feedback
Plots a bar series on a Chart control. A bar series is represented by a set of vertical bars.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BarSeries : DataSeries
Visual Basic
Public Class BarSeries _
    Inherits DataSeries
Visual C++
public ref class BarSeries : public DataSeries

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..BarSeries
Mindscape.PhoneElements.Charting..::..StackedBarSeries

See Also

BarSeries Members


BarSeries Members

[image] [image]

Mindscape Phone Elements
BarSeries Members
BarSeries Class Constructors Methods Fields Properties Events See Also Send Feedback

The BarSeries type exposes the following members.

Constructors

 | Name | Description
Public method | BarSeries | Initializes a new instance of the BarSeries class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the BarSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetTitle | Sets the title of the given Bar based on the TitleBinding property or the bar index if there is no TitleBinding.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
BarSizeFactorProperty | Identifies the BarSizeFactor property.
BarStyleProperty | Identifies the BarStyle property.
DataLabelStyleProperty | Identifies the DataLabelStyle property.
OrientationProperty | Identifies the Orientation property.
ShowAllLegendItemsProperty | Identifies the ShowAllLegendItems property.
ShowDataLabelsProperty | Identifies the ShowDataLabels property.
ZeroLineStyleProperty | Identifies the ZeroLineStyle property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BarSizeFactor | Gets or sets the size factor used to calculate the thickness of the bars. This will typically be a value between 0 and 1. This value is the factor between a single axis unit and the thickness of a bar. A value of 1 will cause all the bars to be adjacent with no gaps between them (like a histogram). Smaller values put spaces between the bars. When plotting multiple bar series, the BarSizeFactor is used to calculate the total thickness of all the bars plotted on the same independent axis value. This is a dependency property. The default is 0.8.
Public property | BarStyle | Gets or sets the Style applied to the bars. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Brushes | Gets the brushes used to fill the bars. If there are more bars than brushes, the brushes are used in rotation.
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the Style applied to the data labels. This is a dependency property.
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in a legend for this BarSeries. (Overrides DataSeries..::..LegendItems.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the bars. The default is Orientation.Vertical. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowAllLegendItems | Gets or sets whether or not each item in the ItemsSource should have its own legend item. This is a dependency property.
Public property | ShowDataLabels | Gets or sets the whether or not to display the data labels. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | TitleBinding | Gets or sets the data binding used to extract the bar title from each data point.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)
Public property | ZeroLineStyle | Gets or sets the style applied to the zero line of the bar chart. This is a dependency property.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

BarSeries Class


BarSeries Constructor

[image]

Mindscape Phone Elements
BarSeries Constructor
BarSeries Class See Also Send Feedback
Initializes a new instance of the BarSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BarSeries()
Visual Basic
Public Sub New
Visual C++
public:
BarSeries()

See Also

BarSeries Class


BarSeries Fields

[image] [image]

Mindscape Phone Elements
BarSeries Fields
BarSeries Class See Also Send Feedback

The BarSeries type exposes the following members.

Fields

Name | Description
BarSizeFactorProperty | Identifies the BarSizeFactor property.
BarStyleProperty | Identifies the BarStyle property.
DataLabelStyleProperty | Identifies the DataLabelStyle property.
OrientationProperty | Identifies the Orientation property.
ShowAllLegendItemsProperty | Identifies the ShowAllLegendItems property.
ShowDataLabelsProperty | Identifies the ShowDataLabels property.
ZeroLineStyleProperty | Identifies the ZeroLineStyle property.

See Also

BarSeries Class


BarSizeFactorProperty Field

[image]

Mindscape Phone Elements
BarSeries..::..BarSizeFactorProperty Field
BarSeries Class See Also Send Feedback
Identifies the BarSizeFactor property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty BarSizeFactorProperty
Visual Basic
Public Shared ReadOnly BarSizeFactorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ BarSizeFactorProperty

See Also

BarSeries Class


BarStyleProperty Field

[image]

Mindscape Phone Elements
BarSeries..::..BarStyleProperty Field
BarSeries Class See Also Send Feedback
Identifies the BarStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty BarStyleProperty
Visual Basic
Public Shared ReadOnly BarStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ BarStyleProperty

See Also

BarSeries Class


DataLabelStyleProperty Field

[image]

Mindscape Phone Elements
BarSeries..::..DataLabelStyleProperty Field
BarSeries Class See Also Send Feedback
Identifies the DataLabelStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DataLabelStyleProperty
Visual Basic
Public Shared ReadOnly DataLabelStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DataLabelStyleProperty

See Also

BarSeries Class


OrientationProperty Field

[image]

Mindscape Phone Elements
BarSeries..::..OrientationProperty Field
BarSeries Class See Also Send Feedback
Identifies the Orientation property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ OrientationProperty

See Also

BarSeries Class


ShowAllLegendItemsProperty Field

[image]

Mindscape Phone Elements
BarSeries..::..ShowAllLegendItemsProperty Field
BarSeries Class See Also Send Feedback
Identifies the ShowAllLegendItems property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowAllLegendItemsProperty
Visual Basic
Public Shared ReadOnly ShowAllLegendItemsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowAllLegendItemsProperty

See Also

BarSeries Class


ShowDataLabelsProperty Field

[image]

Mindscape Phone Elements
BarSeries..::..ShowDataLabelsProperty Field
BarSeries Class See Also Send Feedback
Identifies the ShowDataLabels property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowDataLabelsProperty
Visual Basic
Public Shared ReadOnly ShowDataLabelsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowDataLabelsProperty

See Also

BarSeries Class


ZeroLineStyleProperty Field

[image]

Mindscape Phone Elements
BarSeries..::..ZeroLineStyleProperty Field
BarSeries Class See Also Send Feedback
Identifies the ZeroLineStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ZeroLineStyleProperty
Visual Basic
Public Shared ReadOnly ZeroLineStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ZeroLineStyleProperty

See Also

BarSeries Class


BarSeries Methods

[image] [image]

Mindscape Phone Elements
BarSeries Methods
BarSeries Class See Also Send Feedback

The BarSeries type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the BarSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetTitle | Sets the title of the given Bar based on the TitleBinding property or the bar index if there is no TitleBinding.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

BarSeries Class


BuildChartCore Method

[image]

Mindscape Phone Elements
BarSeries..::..BuildChartCore Method
BarSeries Class See Also Send Feedback
Plots the BarSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

BarSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
BarSeries..::..GetPoint Method
BarSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

BarSeries Class
BarSeries Members


SetTitle Method

[image]

Mindscape Phone Elements
BarSeries..::..SetTitle Method
BarSeries Class See Also Send Feedback
Sets the title of the given Bar based on the TitleBinding property or the bar index if there is no TitleBinding.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void SetTitle(
    Bar bar,
    int index
)
Visual Basic
Protected Sub SetTitle ( _
    bar As Bar, _
    index As Integer _
)
Visual C++
protected:
void SetTitle(
    Bar^ bar,
    int index
)

Parameters

bar
Type: Mindscape.PhoneElements.Charting..::..Bar
The Bar to find a title for.
index
Type: System..::..Int32
The index of the Bar within the items source. This is used to create a default title if the Bar has no TitleBinding.

See Also

BarSeries Class


BarSeries Properties

[image] [image]

Mindscape Phone Elements
BarSeries Properties
BarSeries Class See Also Send Feedback

The BarSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BarSizeFactor | Gets or sets the size factor used to calculate the thickness of the bars. This will typically be a value between 0 and 1. This value is the factor between a single axis unit and the thickness of a bar. A value of 1 will cause all the bars to be adjacent with no gaps between them (like a histogram). Smaller values put spaces between the bars. When plotting multiple bar series, the BarSizeFactor is used to calculate the total thickness of all the bars plotted on the same independent axis value. This is a dependency property. The default is 0.8.
Public property | BarStyle | Gets or sets the Style applied to the bars. This is a dependency property.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Brushes | Gets the brushes used to fill the bars. If there are more bars than brushes, the brushes are used in rotation.
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the Style applied to the data labels. This is a dependency property.
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in a legend for this BarSeries. (Overrides DataSeries..::..LegendItems.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the bars. The default is Orientation.Vertical. This is a dependency property.
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowAllLegendItems | Gets or sets whether or not each item in the ItemsSource should have its own legend item. This is a dependency property.
Public property | ShowDataLabels | Gets or sets the whether or not to display the data labels. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | TitleBinding | Gets or sets the data binding used to extract the bar title from each data point.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)
Public property | ZeroLineStyle | Gets or sets the style applied to the zero line of the bar chart. This is a dependency property.

See Also

BarSeries Class


BarSizeFactor Property

[image]

Mindscape Phone Elements
BarSeries..::..BarSizeFactor Property
BarSeries Class See Also Send Feedback
Gets or sets the size factor used to calculate the thickness of the bars. This will typically be a value between 0 and 1. This value is the factor between a single axis unit and the thickness of a bar. A value of 1 will cause all the bars to be adjacent with no gaps between them (like a histogram). Smaller values put spaces between the bars. When plotting multiple bar series, the BarSizeFactor is used to calculate the total thickness of all the bars plotted on the same independent axis value. This is a dependency property. The default is 0.8.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BarSizeFactor { get; set; }
Visual Basic
Public Property BarSizeFactor As Double
    Get
    Set
Visual C++
public:
property double BarSizeFactor {
    double get ();
    void set (double value);
}

See Also

BarSeries Class


BarStyle Property

[image]

Mindscape Phone Elements
BarSeries..::..BarStyle Property
BarSeries Class See Also Send Feedback
Gets or sets the Style applied to the bars. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style BarStyle { get; set; }
Visual Basic
Public Property BarStyle As Style
    Get
    Set
Visual C++
public:
property Style^ BarStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

BarSeries Class


Brushes Property

[image]

Mindscape Phone Elements
BarSeries..::..Brushes Property
BarSeries Class See Also Send Feedback
Gets the brushes used to fill the bars. If there are more bars than brushes, the brushes are used in rotation.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObservableCollection<Brush> Brushes { get; }
Visual Basic
Public ReadOnly Property Brushes As ObservableCollection(Of Brush)
    Get
Visual C++
public:
property ObservableCollection<Brush^>^ Brushes {
    ObservableCollection<Brush^>^ get ();
}

See Also

BarSeries Class


DataLabelStyle Property

[image]

Mindscape Phone Elements
BarSeries..::..DataLabelStyle Property
BarSeries Class See Also Send Feedback
Gets or sets the Style applied to the data labels. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style DataLabelStyle { get; set; }
Visual Basic
Public Property DataLabelStyle As Style
    Get
    Set
Visual C++
public:
property Style^ DataLabelStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

BarSeries Class


LegendItems Property

[image]

Mindscape Phone Elements
BarSeries..::..LegendItems Property
BarSeries Class See Also Send Feedback
Gets a list of legend items to be displayed in a legend for this BarSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override IList<LegendItem> LegendItems { get; }
Visual Basic
Public Overrides ReadOnly Property LegendItems As IList(Of LegendItem)
    Get
Visual C++
public:
virtual property IList<LegendItem^>^ LegendItems {
    IList<LegendItem^>^ get () override;
}

See Also

BarSeries Class


Orientation Property

[image]

Mindscape Phone Elements
BarSeries..::..Orientation Property
BarSeries Class See Also Send Feedback
Gets or sets the Orientation of the bars. The default is Orientation.Vertical. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

BarSeries Class


ShowAllLegendItems Property

[image]

Mindscape Phone Elements
BarSeries..::..ShowAllLegendItems Property
BarSeries Class See Also Send Feedback
Gets or sets whether or not each item in the ItemsSource should have its own legend item. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowAllLegendItems { get; set; }
Visual Basic
Public Property ShowAllLegendItems As Boolean
    Get
    Set
Visual C++
public:
property bool ShowAllLegendItems {
    bool get ();
    void set (bool value);
}

See Also

BarSeries Class


ShowDataLabels Property

[image]

Mindscape Phone Elements
BarSeries..::..ShowDataLabels Property
BarSeries Class See Also Send Feedback
Gets or sets the whether or not to display the data labels. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowDataLabels { get; set; }
Visual Basic
Public Property ShowDataLabels As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDataLabels {
    bool get ();
    void set (bool value);
}

See Also

BarSeries Class


TitleBinding Property

[image]

Mindscape Phone Elements
BarSeries..::..TitleBinding Property
BarSeries Class See Also Send Feedback
Gets or sets the data binding used to extract the bar title from each data point.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding TitleBinding { get; set; }
Visual Basic
Public Property TitleBinding As Binding
    Get
    Set
Visual C++
public:
property Binding^ TitleBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

BarSeries Class


ZeroLineStyle Property

[image]

Mindscape Phone Elements
BarSeries..::..ZeroLineStyle Property
BarSeries Class See Also Send Feedback
Gets or sets the style applied to the zero line of the bar chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style ZeroLineStyle { get; set; }
Visual Basic
Public Property ZeroLineStyle As Style
    Get
    Set
Visual C++
public:
property Style^ ZeroLineStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

BarSeries Class


BarSeries Events

[image] [image]

Mindscape Phone Elements
BarSeries Events
BarSeries Class See Also Send Feedback

The BarSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

BarSeries Class


BooleanToDoubleConverter Class

[image]

Mindscape Phone Elements
BooleanToDoubleConverter Class
Members See Also Send Feedback
Selects a double value according to whether the binding source is true or false.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BooleanToDoubleConverter : IValueConverter
Visual Basic
Public Class BooleanToDoubleConverter _
    Implements IValueConverter
Visual C++
public ref class BooleanToDoubleConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..BooleanToDoubleConverter

See Also

BooleanToDoubleConverter Members


BooleanToDoubleConverter Members

[image] [image]

Mindscape Phone Elements
BooleanToDoubleConverter Members
BooleanToDoubleConverter Class Constructors Methods Properties See Also Send Feedback

The BooleanToDoubleConverter type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanToDoubleConverter | Initializes a new instance of the BooleanToDoubleConverter class

Methods

 | Name | Description
Public method | Convert | Selects a double according to whether the input is true or false.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FalseDouble | The double to return if the value if false.
Public property | TrueDouble | The double to return if the value is true.

See Also

BooleanToDoubleConverter Class


BooleanToDoubleConverter Constructor

[image]

Mindscape Phone Elements
BooleanToDoubleConverter Constructor
BooleanToDoubleConverter Class See Also Send Feedback
Initializes a new instance of the BooleanToDoubleConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BooleanToDoubleConverter()
Visual Basic
Public Sub New
Visual C++
public:
BooleanToDoubleConverter()

See Also

BooleanToDoubleConverter Class


BooleanToDoubleConverter Methods

[image] [image]

Mindscape Phone Elements
BooleanToDoubleConverter Methods
BooleanToDoubleConverter Class See Also Send Feedback

The BooleanToDoubleConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Selects a double according to whether the input is true or false.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToDoubleConverter Class


Convert Method

[image]

Mindscape Phone Elements
BooleanToDoubleConverter..::..Convert Method
BooleanToDoubleConverter Class See Also Send Feedback
Selects a double according to whether the input is true or false.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The boolean value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The selected double.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToDoubleConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
BooleanToDoubleConverter..::..ConvertBack Method
BooleanToDoubleConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToDoubleConverter Class


BooleanToDoubleConverter Properties

[image] [image]

Mindscape Phone Elements
BooleanToDoubleConverter Properties
BooleanToDoubleConverter Class See Also Send Feedback

The BooleanToDoubleConverter type exposes the following members.

Properties

 | Name | Description
Public property | FalseDouble | The double to return if the value if false.
Public property | TrueDouble | The double to return if the value is true.

See Also

BooleanToDoubleConverter Class


FalseDouble Property

[image]

Mindscape Phone Elements
BooleanToDoubleConverter..::..FalseDouble Property
BooleanToDoubleConverter Class See Also Send Feedback
The double to return if the value if false.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FalseDouble { get; set; }
Visual Basic
Public Property FalseDouble As Double
    Get
    Set
Visual C++
public:
property double FalseDouble {
    double get ();
    void set (double value);
}

See Also

BooleanToDoubleConverter Class


TrueDouble Property

[image]

Mindscape Phone Elements
BooleanToDoubleConverter..::..TrueDouble Property
BooleanToDoubleConverter Class See Also Send Feedback
The double to return if the value is true.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double TrueDouble { get; set; }
Visual Basic
Public Property TrueDouble As Double
    Get
    Set
Visual C++
public:
property double TrueDouble {
    double get ();
    void set (double value);
}

See Also

BooleanToDoubleConverter Class


Bubble Class

[image]

Mindscape Phone Elements
Bubble Class
Members See Also Send Feedback
Represents a data point in a BubbleSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Bubble : CartesianDataPoint
Visual Basic
Public Class Bubble _
    Inherits CartesianDataPoint
Visual C++
public ref class Bubble : public CartesianDataPoint

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataPoint
Mindscape.PhoneElements.Charting..::..CartesianDataPoint
Mindscape.PhoneElements.Charting..::..Bubble

See Also

Bubble Members


Bubble Members

[image] [image]

Mindscape Phone Elements
Bubble Members
Bubble Class Constructors Methods Fields Properties Events See Also Send Feedback

The Bubble type exposes the following members.

Constructors

 | Name | Description
Public method | Bubble | Initializes a new instance of the Bubble class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
SizeProperty | Identifies the Size property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsNegative | Gets whether or not this Bubble is plotting a negative value.
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint. (Inherited from CartesianDataPoint.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Size | Gets or sets the size of the bubble. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Bubble Class


Bubble Constructor

[image]

Mindscape Phone Elements
Bubble Constructor
Bubble Class See Also Send Feedback
Initializes a new instance of the Bubble class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Bubble()
Visual Basic
Public Sub New
Visual C++
public:
Bubble()

See Also

Bubble Class


Bubble Fields

[image] [image]

Mindscape Phone Elements
Bubble Fields
Bubble Class See Also Send Feedback

The Bubble type exposes the following members.

Fields

Name | Description
SizeProperty | Identifies the Size property.

See Also

Bubble Class


SizeProperty Field

[image]

Mindscape Phone Elements
Bubble..::..SizeProperty Field
Bubble Class See Also Send Feedback
Identifies the Size property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SizeProperty
Visual Basic
Public Shared ReadOnly SizeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SizeProperty

See Also

Bubble Class


Bubble Methods

[image] [image]

Mindscape Phone Elements
Bubble Methods
Bubble Class See Also Send Feedback

The Bubble type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

Bubble Class


Bubble Properties

[image] [image]

Mindscape Phone Elements
Bubble Properties
Bubble Class See Also Send Feedback

The Bubble type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsNegative | Gets whether or not this Bubble is plotting a negative value.
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint. (Inherited from CartesianDataPoint.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Size | Gets or sets the size of the bubble. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)

See Also

Bubble Class


IsNegative Property

[image]

Mindscape Phone Elements
Bubble..::..IsNegative Property
Bubble Class See Also Send Feedback
Gets whether or not this Bubble is plotting a negative value.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsNegative { get; internal set; }
Visual Basic
Public Property IsNegative As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsNegative {
    bool get ();
    internal: void set (bool value);
}

See Also

Bubble Class


Size Property

[image]

Mindscape Phone Elements
Bubble..::..Size Property
Bubble Class See Also Send Feedback
Gets or sets the size of the bubble. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Size { get; set; }
Visual Basic
Public Property Size As Double
    Get
    Set
Visual C++
public:
property double Size {
    double get ();
    void set (double value);
}

See Also

Bubble Class


Bubble Events

[image] [image]

Mindscape Phone Elements
Bubble Events
Bubble Class See Also Send Feedback

The Bubble type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Bubble Class


BubbleSeries Class

[image]

Mindscape Phone Elements
BubbleSeries Class
Members See Also Send Feedback
Plots a bubble series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BubbleSeries : DataSeries
Visual Basic
Public Class BubbleSeries _
    Inherits DataSeries
Visual C++
public ref class BubbleSeries : public DataSeries

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..BubbleSeries

See Also

BubbleSeries Members


BubbleSeries Members

[image] [image]

Mindscape Phone Elements
BubbleSeries Members
BubbleSeries Class Constructors Methods Fields Properties Events See Also Send Feedback

The BubbleSeries type exposes the following members.

Constructors

 | Name | Description
Public method | BubbleSeries | Initializes a new instance of the BubbleSeries class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the BubbleSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
BubbleStyleProperty | Identifies the BubbleStyle property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | BubbleStyle | Gets or sets the Style to be applied to the Bubble data points. This is a dependency property.
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | SizeBinding | Gets or sets the binding used to extract the bubble size from each data point.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

BubbleSeries Class


BubbleSeries Constructor

[image]

Mindscape Phone Elements
BubbleSeries Constructor
BubbleSeries Class See Also Send Feedback
Initializes a new instance of the BubbleSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BubbleSeries()
Visual Basic
Public Sub New
Visual C++
public:
BubbleSeries()

See Also

BubbleSeries Class


BubbleSeries Fields

[image] [image]

Mindscape Phone Elements
BubbleSeries Fields
BubbleSeries Class See Also Send Feedback

The BubbleSeries type exposes the following members.

Fields

Name | Description
BubbleStyleProperty | Identifies the BubbleStyle property.

See Also

BubbleSeries Class


BubbleStyleProperty Field

[image]

Mindscape Phone Elements
BubbleSeries..::..BubbleStyleProperty Field
BubbleSeries Class See Also Send Feedback
Identifies the BubbleStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty BubbleStyleProperty
Visual Basic
Public Shared ReadOnly BubbleStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ BubbleStyleProperty

See Also

BubbleSeries Class


BubbleSeries Methods

[image] [image]

Mindscape Phone Elements
BubbleSeries Methods
BubbleSeries Class See Also Send Feedback

The BubbleSeries type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the BubbleSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

BubbleSeries Class


BuildChartCore Method

[image]

Mindscape Phone Elements
BubbleSeries..::..BuildChartCore Method
BubbleSeries Class See Also Send Feedback
Plots the BubbleSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

BubbleSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
BubbleSeries..::..GetPoint Method
BubbleSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

BubbleSeries Class
BubbleSeries Members


BubbleSeries Properties

[image] [image]

Mindscape Phone Elements
BubbleSeries Properties
BubbleSeries Class See Also Send Feedback

The BubbleSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | BubbleStyle | Gets or sets the Style to be applied to the Bubble data points. This is a dependency property.
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | SizeBinding | Gets or sets the binding used to extract the bubble size from each data point.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

BubbleSeries Class


BubbleStyle Property

[image]

Mindscape Phone Elements
BubbleSeries..::..BubbleStyle Property
BubbleSeries Class See Also Send Feedback
Gets or sets the Style to be applied to the Bubble data points. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style BubbleStyle { get; set; }
Visual Basic
Public Property BubbleStyle As Style
    Get
    Set
Visual C++
public:
property Style^ BubbleStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

BubbleSeries Class


SizeBinding Property

[image]

Mindscape Phone Elements
BubbleSeries..::..SizeBinding Property
BubbleSeries Class See Also Send Feedback
Gets or sets the binding used to extract the bubble size from each data point.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding SizeBinding { get; set; }
Visual Basic
Public Property SizeBinding As Binding
    Get
    Set
Visual C++
public:
property Binding^ SizeBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

BubbleSeries Class


BubbleSeries Events

[image] [image]

Mindscape Phone Elements
BubbleSeries Events
BubbleSeries Class See Also Send Feedback

The BubbleSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

BubbleSeries Class


CartesianDataPoint Class

[image]

Mindscape Phone Elements
CartesianDataPoint Class
Members See Also Send Feedback
Represents a single data point to be plotted on cartesian (X/Y) axes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CartesianDataPoint : DataPoint
Visual Basic
Public Class CartesianDataPoint _
    Inherits DataPoint
Visual C++
public ref class CartesianDataPoint : public DataPoint

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataPoint
Mindscape.PhoneElements.Charting..::..CartesianDataPoint
Mindscape.PhoneElements.Charting..::..Bar
Mindscape.PhoneElements.Charting..::..Bubble
Mindscape.PhoneElements.Charting..::..ChartSymbol

See Also

CartesianDataPoint Members


CartesianDataPoint Members

[image] [image]

Mindscape Phone Elements
CartesianDataPoint Members
CartesianDataPoint Class Methods Fields Properties Events See Also Send Feedback

The CartesianDataPoint type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
XObjectProperty | Identifies the XObject property.
YObjectProperty | Identifies the YObject property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property.
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CartesianDataPoint Class


CartesianDataPoint Fields

[image] [image]

Mindscape Phone Elements
CartesianDataPoint Fields
CartesianDataPoint Class See Also Send Feedback

The CartesianDataPoint type exposes the following members.

Fields

Name | Description
XObjectProperty | Identifies the XObject property.
YObjectProperty | Identifies the YObject property.

See Also

CartesianDataPoint Class


XObjectProperty Field

[image]

Mindscape Phone Elements
CartesianDataPoint..::..XObjectProperty Field
CartesianDataPoint Class See Also Send Feedback
Identifies the XObject property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty XObjectProperty
Visual Basic
Public Shared ReadOnly XObjectProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ XObjectProperty

See Also

CartesianDataPoint Class


YObjectProperty Field

[image]

Mindscape Phone Elements
CartesianDataPoint..::..YObjectProperty Field
CartesianDataPoint Class See Also Send Feedback
Identifies the YObject property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty YObjectProperty
Visual Basic
Public Shared ReadOnly YObjectProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ YObjectProperty

See Also

CartesianDataPoint Class


CartesianDataPoint Methods

[image] [image]

Mindscape Phone Elements
CartesianDataPoint Methods
CartesianDataPoint Class See Also Send Feedback

The CartesianDataPoint type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

CartesianDataPoint Class


CartesianDataPoint Properties

[image] [image]

Mindscape Phone Elements
CartesianDataPoint Properties
CartesianDataPoint Class See Also Send Feedback

The CartesianDataPoint type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property.
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property.

See Also

CartesianDataPoint Class


LogicalPoint Property

[image]

Mindscape Phone Elements
CartesianDataPoint..::..LogicalPoint Property
CartesianDataPoint Class See Also Send Feedback
Gets the logical X,Y plotting position of the CartesianDataPoint.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point LogicalPoint { get; internal set; }
Visual Basic
Public Property LogicalPoint As Point
    Get
    Friend Set
Visual C++
public:
property Point LogicalPoint {
    Point get ();
    internal: void set (Point value);
}

See Also

CartesianDataPoint Class


XObject Property

[image]

Mindscape Phone Elements
CartesianDataPoint..::..XObject Property
CartesianDataPoint Class See Also Send Feedback
Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object XObject { get; set; }
Visual Basic
Public Property XObject As Object
    Get
    Set
Visual C++
public:
property Object^ XObject {
    Object^ get ();
    void set (Object^ value);
}

See Also

CartesianDataPoint Class


YObject Property

[image]

Mindscape Phone Elements
CartesianDataPoint..::..YObject Property
CartesianDataPoint Class See Also Send Feedback
Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object YObject { get; set; }
Visual Basic
Public Property YObject As Object
    Get
    Set
Visual C++
public:
property Object^ YObject {
    Object^ get ();
    void set (Object^ value);
}

See Also

CartesianDataPoint Class


CartesianDataPoint Events

[image] [image]

Mindscape Phone Elements
CartesianDataPoint Events
CartesianDataPoint Class See Also Send Feedback

The CartesianDataPoint type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

CartesianDataPoint Class


Chart Class

[image]

Mindscape Phone Elements
Chart Class
Members See Also Send Feedback
A control for displaying data series on a chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Chart : Control
Visual Basic
Public Class Chart _
    Inherits Control
Visual C++
public ref class Chart : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..Chart

See Also

Chart Members


Chart Members

[image] [image]

Mindscape Phone Elements
Chart Members
Chart Class Constructors Methods Fields Properties Events See Also Send Feedback

The Chart type exposes the following members.

Constructors

 | Name | Description
Public method | Chart | Initializes a new instance of the Chart class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
LegendPositionProperty | Identifies the LegendPosition property.
LegendStyleProperty | Identifies the LegendStyle property.
SelectionModeProperty | Identifies the SelectionMode property.
TitleProperty | Identifies the Title property.
TitleTemplateProperty | Identifies the TitleTemplate property.
XAxisProperty | Identifies the XAxis property.
XAxisTemplateProperty | Identifies the XAxisTemplate property.
YAxisProperty | Identifies the YAxis property.
YAxisTemplateProperty | Identifies the YAxisTemplate property.
ZoomModeProperty | Identifies the ZoomMode property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AlternativeYAxes | Gets a collection of alternative Y axes.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BackgroundElements | Gets the collection of UIElement objects displayed behind the chart.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | ForegroundElements | Gets the collection of UIElement objects displayed in front of the chart.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendItems | Gets the items to be displayed in the legend.
Public property | LegendPosition | Gets or sets the position on the Chart control where the legend is displayed. This is a dependency property.
Public property | LegendStyle | Gets or sets the Style applied to the HeaderedItemsControl that displays the legend items. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectionMode | Gets or sets the selection mode of the Chart. This is a dependency property.
Public property | Series | Gets the collection of the DataSeries plotted on the chart.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Chart. This is a dependency property.
Public property | TitleTemplate | Gets or sets the DataTemplate applied to the title of the Chart. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X (horizontal) axis of the Chart. This can be used to configure axis settings. This is a dependency property.
Public property | XAxisTemplate | Gets or sets the control template for the X axis. This is a dependency property.
Public property | YAxis | Gets or sets the YAxis used by the Chart. This is a dependency property.
Public property | YAxisTemplate | Gets or sets the control template for the Y axis. This is a dependency property.
Public property | ZoomMode | Gets or sets the current ZoomMode. This is a dependency property.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | ChartMouseEnter | Raised when the mouse enters the chart area.
Public event | ChartMouseLeave | Raised when the mouse leaves the chart area.
Public event | ChartMouseLeftButtonDown | Raised when the left mouse button is pressed over the chart area.
Public event | ChartMouseLeftButtonUp | Raised when the left mouse button is released over the the chart area.
Public event | ChartMouseMove | Raised when the mouse is moved over the chart area.
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Chart Class


Chart Constructor

[image]

Mindscape Phone Elements
Chart Constructor
Chart Class See Also Send Feedback
Initializes a new instance of the Chart class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Chart()
Visual Basic
Public Sub New
Visual C++
public:
Chart()

See Also

Chart Class


Chart Fields

[image] [image]

Mindscape Phone Elements
Chart Fields
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Fields

Name | Description
LegendPositionProperty | Identifies the LegendPosition property.
LegendStyleProperty | Identifies the LegendStyle property.
SelectionModeProperty | Identifies the SelectionMode property.
TitleProperty | Identifies the Title property.
TitleTemplateProperty | Identifies the TitleTemplate property.
XAxisProperty | Identifies the XAxis property.
XAxisTemplateProperty | Identifies the XAxisTemplate property.
YAxisProperty | Identifies the YAxis property.
YAxisTemplateProperty | Identifies the YAxisTemplate property.
ZoomModeProperty | Identifies the ZoomMode property.

See Also

Chart Class


LegendPositionProperty Field

[image]

Mindscape Phone Elements
Chart..::..LegendPositionProperty Field
Chart Class See Also Send Feedback
Identifies the LegendPosition property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LegendPositionProperty
Visual Basic
Public Shared ReadOnly LegendPositionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LegendPositionProperty

See Also

Chart Class


LegendStyleProperty Field

[image]

Mindscape Phone Elements
Chart..::..LegendStyleProperty Field
Chart Class See Also Send Feedback
Identifies the LegendStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LegendStyleProperty
Visual Basic
Public Shared ReadOnly LegendStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LegendStyleProperty

See Also

Chart Class


SelectionModeProperty Field

[image]

Mindscape Phone Elements
Chart..::..SelectionModeProperty Field
Chart Class See Also Send Feedback
Identifies the SelectionMode property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic
Public Shared ReadOnly SelectionModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectionModeProperty

See Also

Chart Class


TitleProperty Field

[image]

Mindscape Phone Elements
Chart..::..TitleProperty Field
Chart Class See Also Send Feedback
Identifies the Title property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleProperty

See Also

Chart Class


TitleTemplateProperty Field

[image]

Mindscape Phone Elements
Chart..::..TitleTemplateProperty Field
Chart Class See Also Send Feedback
Identifies the TitleTemplate property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleTemplateProperty
Visual Basic
Public Shared ReadOnly TitleTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleTemplateProperty

See Also

Chart Class


XAxisProperty Field

[image]

Mindscape Phone Elements
Chart..::..XAxisProperty Field
Chart Class See Also Send Feedback
Identifies the XAxis property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty XAxisProperty
Visual Basic
Public Shared ReadOnly XAxisProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ XAxisProperty

See Also

Chart Class


XAxisTemplateProperty Field

[image]

Mindscape Phone Elements
Chart..::..XAxisTemplateProperty Field
Chart Class See Also Send Feedback
Identifies the XAxisTemplate property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty XAxisTemplateProperty
Visual Basic
Public Shared ReadOnly XAxisTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ XAxisTemplateProperty

See Also

Chart Class


YAxisProperty Field

[image]

Mindscape Phone Elements
Chart..::..YAxisProperty Field
Chart Class See Also Send Feedback
Identifies the YAxis property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty YAxisProperty
Visual Basic
Public Shared ReadOnly YAxisProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ YAxisProperty

See Also

Chart Class


YAxisTemplateProperty Field

[image]

Mindscape Phone Elements
Chart..::..YAxisTemplateProperty Field
Chart Class See Also Send Feedback
Identifies the YAxisTemplate property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty YAxisTemplateProperty
Visual Basic
Public Shared ReadOnly YAxisTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ YAxisTemplateProperty

See Also

Chart Class


ZoomModeProperty Field

[image]

Mindscape Phone Elements
Chart..::..ZoomModeProperty Field
Chart Class See Also Send Feedback
Identifies the ZoomMode property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ZoomModeProperty
Visual Basic
Public Shared ReadOnly ZoomModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ZoomModeProperty

See Also

Chart Class


Chart Methods

[image] [image]

Mindscape Phone Elements
Chart Methods
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

Chart Class


OnApplyTemplate Method

[image]

Mindscape Phone Elements
Chart..::..OnApplyTemplate Method
Chart Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

Chart Class


Chart Properties

[image] [image]

Mindscape Phone Elements
Chart Properties
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AlternativeYAxes | Gets a collection of alternative Y axes.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BackgroundElements | Gets the collection of UIElement objects displayed behind the chart.
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | ForegroundElements | Gets the collection of UIElement objects displayed in front of the chart.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendItems | Gets the items to be displayed in the legend.
Public property | LegendPosition | Gets or sets the position on the Chart control where the legend is displayed. This is a dependency property.
Public property | LegendStyle | Gets or sets the Style applied to the HeaderedItemsControl that displays the legend items. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectionMode | Gets or sets the selection mode of the Chart. This is a dependency property.
Public property | Series | Gets the collection of the DataSeries plotted on the chart.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the Chart. This is a dependency property.
Public property | TitleTemplate | Gets or sets the DataTemplate applied to the title of the Chart. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X (horizontal) axis of the Chart. This can be used to configure axis settings. This is a dependency property.
Public property | XAxisTemplate | Gets or sets the control template for the X axis. This is a dependency property.
Public property | YAxis | Gets or sets the YAxis used by the Chart. This is a dependency property.
Public property | YAxisTemplate | Gets or sets the control template for the Y axis. This is a dependency property.
Public property | ZoomMode | Gets or sets the current ZoomMode. This is a dependency property.

See Also

Chart Class


AlternativeYAxes Property

[image]

Mindscape Phone Elements
Chart..::..AlternativeYAxes Property
Chart Class See Also Send Feedback
Gets a collection of alternative Y axes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Collection<ChartAxis> AlternativeYAxes { get; }
Visual Basic
Public ReadOnly Property AlternativeYAxes As Collection(Of ChartAxis)
    Get
Visual C++
public:
property Collection<ChartAxis^>^ AlternativeYAxes {
    Collection<ChartAxis^>^ get ();
}

Remarks

Multiple Y axes allow the plotting of data on different scales on the same graph.

See Also

Chart Class


BackgroundElements Property

[image]

Mindscape Phone Elements
Chart..::..BackgroundElements Property
Chart Class See Also Send Feedback
Gets the collection of UIElement objects displayed behind the chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Collection<UIElement> BackgroundElements { get; }
Visual Basic
Public ReadOnly Property BackgroundElements As Collection(Of UIElement)
    Get
Visual C++
public:
property Collection<UIElement^>^ BackgroundElements {
    Collection<UIElement^>^ get ();
}

See Also

Chart Class


ForegroundElements Property

[image]

Mindscape Phone Elements
Chart..::..ForegroundElements Property
Chart Class See Also Send Feedback
Gets the collection of UIElement objects displayed in front of the chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Collection<UIElement> ForegroundElements { get; }
Visual Basic
Public ReadOnly Property ForegroundElements As Collection(Of UIElement)
    Get
Visual C++
public:
property Collection<UIElement^>^ ForegroundElements {
    Collection<UIElement^>^ get ();
}

See Also

Chart Class


LegendItems Property

[image]

Mindscape Phone Elements
Chart..::..LegendItems Property
Chart Class See Also Send Feedback
Gets the items to be displayed in the legend.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<LegendItem> LegendItems { get; }
Visual Basic
Public ReadOnly Property LegendItems As ReadOnlyCollection(Of LegendItem)
    Get
Visual C++
public:
property ReadOnlyCollection<LegendItem^>^ LegendItems {
    ReadOnlyCollection<LegendItem^>^ get ();
}

See Also

Chart Class


LegendPosition Property

[image]

Mindscape Phone Elements
Chart..::..LegendPosition Property
Chart Class See Also Send Feedback
Gets or sets the position on the Chart control where the legend is displayed. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendPosition LegendPosition { get; set; }
Visual Basic
Public Property LegendPosition As LegendPosition
    Get
    Set
Visual C++
public:
property LegendPosition LegendPosition {
    LegendPosition get ();
    void set (LegendPosition value);
}

See Also

Chart Class


LegendStyle Property

[image]

Mindscape Phone Elements
Chart..::..LegendStyle Property
Chart Class See Also Send Feedback
Gets or sets the Style applied to the HeaderedItemsControl that displays the legend items. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style LegendStyle { get; set; }
Visual Basic
Public Property LegendStyle As Style
    Get
    Set
Visual C++
public:
property Style^ LegendStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

Chart Class


SelectionMode Property

[image]

Mindscape Phone Elements
Chart..::..SelectionMode Property
Chart Class See Also Send Feedback
Gets or sets the selection mode of the Chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataSeriesSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As DataSeriesSelectionMode
    Get
    Set
Visual C++
public:
property DataSeriesSelectionMode SelectionMode {
    DataSeriesSelectionMode get ();
    void set (DataSeriesSelectionMode value);
}

See Also

Chart Class


Series Property

[image]

Mindscape Phone Elements
Chart..::..Series Property
Chart Class See Also Send Feedback
Gets the collection of the DataSeries plotted on the chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObservableCollection<DataSeries> Series { get; }
Visual Basic
Public ReadOnly Property Series As ObservableCollection(Of DataSeries)
    Get
Visual C++
public:
property ObservableCollection<DataSeries^>^ Series {
    ObservableCollection<DataSeries^>^ get ();
}

See Also

Chart Class


Title Property

[image]

Mindscape Phone Elements
Chart..::..Title Property
Chart Class See Also Send Feedback
Gets or sets the title of the Chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Chart Class


TitleTemplate Property

[image]

Mindscape Phone Elements
Chart..::..TitleTemplate Property
Chart Class See Also Send Feedback
Gets or sets the DataTemplate applied to the title of the Chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate TitleTemplate { get; set; }
Visual Basic
Public Property TitleTemplate As DataTemplate
    Get
    Set
Visual C++
public:
property DataTemplate^ TitleTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

Chart Class


XAxis Property

[image]

Mindscape Phone Elements
Chart..::..XAxis Property
Chart Class See Also Send Feedback
Gets or sets the X (horizontal) axis of the Chart. This can be used to configure axis settings. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartAxis XAxis { get; set; }
Visual Basic
Public Property XAxis As ChartAxis
    Get
    Set
Visual C++
public:
property ChartAxis^ XAxis {
    ChartAxis^ get ();
    void set (ChartAxis^ value);
}

See Also

Chart Class


XAxisTemplate Property

[image]

Mindscape Phone Elements
Chart..::..XAxisTemplate Property
Chart Class See Also Send Feedback
Gets or sets the control template for the X axis. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate XAxisTemplate { get; set; }
Visual Basic
Public Property XAxisTemplate As ControlTemplate
    Get
    Set
Visual C++
public:
property ControlTemplate^ XAxisTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

Chart Class


YAxis Property

[image]

Mindscape Phone Elements
Chart..::..YAxis Property
Chart Class See Also Send Feedback
Gets or sets the YAxis used by the Chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartAxis YAxis { get; set; }
Visual Basic
Public Property YAxis As ChartAxis
    Get
    Set
Visual C++
public:
property ChartAxis^ YAxis {
    ChartAxis^ get ();
    void set (ChartAxis^ value);
}

See Also

Chart Class


YAxisTemplate Property

[image]

Mindscape Phone Elements
Chart..::..YAxisTemplate Property
Chart Class See Also Send Feedback
Gets or sets the control template for the Y axis. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate YAxisTemplate { get; set; }
Visual Basic
Public Property YAxisTemplate As ControlTemplate
    Get
    Set
Visual C++
public:
property ControlTemplate^ YAxisTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

Chart Class


ZoomMode Property

[image]

Mindscape Phone Elements
Chart..::..ZoomMode Property
Chart Class See Also Send Feedback
Gets or sets the current ZoomMode. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic
Public Property ZoomMode As ZoomMode
    Get
    Set
Visual C++
public:
property ZoomMode ZoomMode {
    ZoomMode get ();
    void set (ZoomMode value);
}

See Also

Chart Class


Chart Events

[image] [image]

Mindscape Phone Elements
Chart Events
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | ChartMouseEnter | Raised when the mouse enters the chart area.
Public event | ChartMouseLeave | Raised when the mouse leaves the chart area.
Public event | ChartMouseLeftButtonDown | Raised when the left mouse button is pressed over the chart area.
Public event | ChartMouseLeftButtonUp | Raised when the left mouse button is released over the the chart area.
Public event | ChartMouseMove | Raised when the mouse is moved over the chart area.
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Chart Class


ChartMouseEnter Event

[image]

Mindscape Phone Elements
Chart..::..ChartMouseEnter Event
Chart Class See Also Send Feedback
Raised when the mouse enters the chart area.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<ChartMouseEventArgs> ChartMouseEnter
Visual Basic
Public Event ChartMouseEnter As EventHandler(Of ChartMouseEventArgs)
Visual C++
public:
 event EventHandler<ChartMouseEventArgs^>^ ChartMouseEnter {
    void add (EventHandler<ChartMouseEventArgs^>^ value);
    void remove (EventHandler<ChartMouseEventArgs^>^ value);
}

See Also

Chart Class


ChartMouseLeave Event

[image]

Mindscape Phone Elements
Chart..::..ChartMouseLeave Event
Chart Class See Also Send Feedback
Raised when the mouse leaves the chart area.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<ChartMouseEventArgs> ChartMouseLeave
Visual Basic
Public Event ChartMouseLeave As EventHandler(Of ChartMouseEventArgs)
Visual C++
public:
 event EventHandler<ChartMouseEventArgs^>^ ChartMouseLeave {
    void add (EventHandler<ChartMouseEventArgs^>^ value);
    void remove (EventHandler<ChartMouseEventArgs^>^ value);
}

See Also

Chart Class


ChartMouseLeftButtonDown Event

[image]

Mindscape Phone Elements
Chart..::..ChartMouseLeftButtonDown Event
Chart Class See Also Send Feedback
Raised when the left mouse button is pressed over the chart area.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<ChartMouseEventArgs> ChartMouseLeftButtonDown
Visual Basic
Public Event ChartMouseLeftButtonDown As EventHandler(Of ChartMouseEventArgs)
Visual C++
public:
 event EventHandler<ChartMouseEventArgs^>^ ChartMouseLeftButtonDown {
    void add (EventHandler<ChartMouseEventArgs^>^ value);
    void remove (EventHandler<ChartMouseEventArgs^>^ value);
}

See Also

Chart Class


ChartMouseLeftButtonUp Event

[image]

Mindscape Phone Elements
Chart..::..ChartMouseLeftButtonUp Event
Chart Class See Also Send Feedback
Raised when the left mouse button is released over the the chart area.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<ChartMouseEventArgs> ChartMouseLeftButtonUp
Visual Basic
Public Event ChartMouseLeftButtonUp As EventHandler(Of ChartMouseEventArgs)
Visual C++
public:
 event EventHandler<ChartMouseEventArgs^>^ ChartMouseLeftButtonUp {
    void add (EventHandler<ChartMouseEventArgs^>^ value);
    void remove (EventHandler<ChartMouseEventArgs^>^ value);
}

See Also

Chart Class


ChartMouseMove Event

[image]

Mindscape Phone Elements
Chart..::..ChartMouseMove Event
Chart Class See Also Send Feedback
Raised when the mouse is moved over the chart area.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<ChartMouseEventArgs> ChartMouseMove
Visual Basic
Public Event ChartMouseMove As EventHandler(Of ChartMouseEventArgs)
Visual C++
public:
 event EventHandler<ChartMouseEventArgs^>^ ChartMouseMove {
    void add (EventHandler<ChartMouseEventArgs^>^ value);
    void remove (EventHandler<ChartMouseEventArgs^>^ value);
}

See Also

Chart Class


ChartAxis Class

[image]

Mindscape Phone Elements
ChartAxis Class
Members See Also Send Feedback
Represents an axis for a Chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ChartAxis : Control, INotifyPropertyChanged
Visual Basic
Public Class ChartAxis _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class ChartAxis : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..ChartAxis

See Also

ChartAxis Members


ChartAxis Members

[image] [image]

Mindscape Phone Elements
ChartAxis Members
ChartAxis Class Constructors Methods Fields Properties Events See Also Send Feedback

The ChartAxis type exposes the following members.

Constructors

 | Name | Description
Public method | ChartAxis | Initializes a new instance of the ChartAxis class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLogicalPosition | Calculates the logical data position of the given object against the ChartAxis.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetRange | Sets both the minimum and maximum values of the ChartAxis.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
ActualMaximumProperty | Identifies the ActualMaximum property.
ActualMinimumProperty | Identifies the ActualMinimum property.
AxisLineStyleProperty | Identifies the AxisLineStyle property.
MaximumProperty | Identifies the Maximum property.
MinimumProperty | Identifies the Minimum property.
TitleProperty | Identifies the Title property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualMaximum | Gets or sets the maximum value that is currently visible on the ChartAxis. This is a dependency property.
Public property | ActualMinimum | Gets or sets the minimum value that is currently visible on the ChartAxis. This is a dependency property.
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AxisLineStyle | Gets or sets the Style applied to the axis line. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | LabelFormat | Gets or sets the string format used to display the axis labels.
Public property | LabelLayout | Gets or sets the AxisLabelLayout of the ChartAxis.
Public property | LabelLevelCount | Gets or sets the number of levels used for placing the axis labels.
Public property | LabelTemplate | Gets or sets the DataTemplate applied to the axis labels.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MajorTickMarks | Gets a collection of major tick marks.
Public property | MajorTickMarkStyle | Gets or sets the Style applied to major tick marks. Tick marks are Border objects.
Public property | MajorTickSpacing | Gets or sets the logical axis distance between the major tick marks.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value that the ChartAxis can display. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value that the ChartAxis can display. This is a dependency property.
Public property | MinimumRange | Gets or sets the minimum logic distance between the ActualMinimum and ActualMaximum. The default is 0.004
Public property | MinorTickMarks | Gets a collection of minor tick marks.
Public property | MinorTickMarkStyle | Gets or sets the Style applied to the minor tick marks. Tick marks are Border objects.
Public property | MinorTickMarkVisibility | Gets or sets the Visibility of the minor tick marks.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TickLayout | Gets or sets the AxisTickLayout that specifies how the tick marks are arranged along the axis.
Public property | TickMarkMode | Gets or sets how tick marks behave when the user pans a zoomed-in chart.
Public property | Title | Gets or sets the title of the ChartAxis. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | ValueConverter | Gets or sets the IAxisValueConverter used for converting between axis values and objects.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | AxisUpdated | Raised when the axis is updated.
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ChartAxis Class


ChartAxis Constructor

[image]

Mindscape Phone Elements
ChartAxis Constructor
ChartAxis Class See Also Send Feedback
Initializes a new instance of the ChartAxis class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartAxis()
Visual Basic
Public Sub New
Visual C++
public:
ChartAxis()

See Also

ChartAxis Class


ChartAxis Fields

[image] [image]

Mindscape Phone Elements
ChartAxis Fields
ChartAxis Class See Also Send Feedback

The ChartAxis type exposes the following members.

Fields

Name | Description
ActualMaximumProperty | Identifies the ActualMaximum property.
ActualMinimumProperty | Identifies the ActualMinimum property.
AxisLineStyleProperty | Identifies the AxisLineStyle property.
MaximumProperty | Identifies the Maximum property.
MinimumProperty | Identifies the Minimum property.
TitleProperty | Identifies the Title property.

See Also

ChartAxis Class


ActualMaximumProperty Field

[image]

Mindscape Phone Elements
ChartAxis..::..ActualMaximumProperty Field
ChartAxis Class See Also Send Feedback
Identifies the ActualMaximum property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ActualMaximumProperty
Visual Basic
Public Shared ReadOnly ActualMaximumProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ActualMaximumProperty

See Also

ChartAxis Class


ActualMinimumProperty Field

[image]

Mindscape Phone Elements
ChartAxis..::..ActualMinimumProperty Field
ChartAxis Class See Also Send Feedback
Identifies the ActualMinimum property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ActualMinimumProperty
Visual Basic
Public Shared ReadOnly ActualMinimumProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ActualMinimumProperty

See Also

ChartAxis Class


AxisLineStyleProperty Field

[image]

Mindscape Phone Elements
ChartAxis..::..AxisLineStyleProperty Field
ChartAxis Class See Also Send Feedback
Identifies the AxisLineStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty AxisLineStyleProperty
Visual Basic
Public Shared ReadOnly AxisLineStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AxisLineStyleProperty

See Also

ChartAxis Class


MaximumProperty Field

[image]

Mindscape Phone Elements
ChartAxis..::..MaximumProperty Field
ChartAxis Class See Also Send Feedback
Identifies the Maximum property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MaximumProperty
Visual Basic
Public Shared ReadOnly MaximumProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MaximumProperty

See Also

ChartAxis Class


MinimumProperty Field

[image]

Mindscape Phone Elements
ChartAxis..::..MinimumProperty Field
ChartAxis Class See Also Send Feedback
Identifies the Minimum property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MinimumProperty
Visual Basic
Public Shared ReadOnly MinimumProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MinimumProperty

See Also

ChartAxis Class


TitleProperty Field

[image]

Mindscape Phone Elements
ChartAxis..::..TitleProperty Field
ChartAxis Class See Also Send Feedback
Identifies the Title property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleProperty

See Also

ChartAxis Class


ChartAxis Methods

[image] [image]

Mindscape Phone Elements
ChartAxis Methods
ChartAxis Class See Also Send Feedback

The ChartAxis type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLogicalPosition | Calculates the logical data position of the given object against the ChartAxis.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetRange | Sets both the minimum and maximum values of the ChartAxis.
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ChartAxis Class


GetLogicalPosition Method

[image]

Mindscape Phone Elements
ChartAxis..::..GetLogicalPosition Method
ChartAxis Class See Also Send Feedback
Calculates the logical data position of the given object against the ChartAxis.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetLogicalPosition(
    Object o
)
Visual Basic
Public Function GetLogicalPosition ( _
    o As Object _
) As Double
Visual C++
public:
double GetLogicalPosition(
    Object^ o
)

Parameters

o
Type: System..::..Object
The object to calculate the position of.

Return Value

The logical position of the given object against the ChartAxis.

See Also

ChartAxis Class


OnApplyTemplate Method

[image]

Mindscape Phone Elements
ChartAxis..::..OnApplyTemplate Method
ChartAxis Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ChartAxis Class


SetRange Method

[image]

Mindscape Phone Elements
ChartAxis..::..SetRange Method
ChartAxis Class See Also Send Feedback
Sets both the minimum and maximum values of the ChartAxis.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetRange(
    double min,
    double max
)
Visual Basic
Public Sub SetRange ( _
    min As Double, _
    max As Double _
)
Visual C++
public:
void SetRange(
    double min,
    double max
)

Parameters

min
Type: System..::..Double
The new minimum value.
max
Type: System..::..Double
The new maximum value.

See Also

ChartAxis Class


ChartAxis Properties

[image] [image]

Mindscape Phone Elements
ChartAxis Properties
ChartAxis Class See Also Send Feedback

The ChartAxis type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualMaximum | Gets or sets the maximum value that is currently visible on the ChartAxis. This is a dependency property.
Public property | ActualMinimum | Gets or sets the minimum value that is currently visible on the ChartAxis. This is a dependency property.
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AxisLineStyle | Gets or sets the Style applied to the axis line. This is a dependency property.
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | LabelFormat | Gets or sets the string format used to display the axis labels.
Public property | LabelLayout | Gets or sets the AxisLabelLayout of the ChartAxis.
Public property | LabelLevelCount | Gets or sets the number of levels used for placing the axis labels.
Public property | LabelTemplate | Gets or sets the DataTemplate applied to the axis labels.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MajorTickMarks | Gets a collection of major tick marks.
Public property | MajorTickMarkStyle | Gets or sets the Style applied to major tick marks. Tick marks are Border objects.
Public property | MajorTickSpacing | Gets or sets the logical axis distance between the major tick marks.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Maximum | Gets or sets the maximum value that the ChartAxis can display. This is a dependency property.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Minimum | Gets or sets the minimum value that the ChartAxis can display. This is a dependency property.
Public property | MinimumRange | Gets or sets the minimum logic distance between the ActualMinimum and ActualMaximum. The default is 0.004
Public property | MinorTickMarks | Gets a collection of minor tick marks.
Public property | MinorTickMarkStyle | Gets or sets the Style applied to the minor tick marks. Tick marks are Border objects.
Public property | MinorTickMarkVisibility | Gets or sets the Visibility of the minor tick marks.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TickLayout | Gets or sets the AxisTickLayout that specifies how the tick marks are arranged along the axis.
Public property | TickMarkMode | Gets or sets how tick marks behave when the user pans a zoomed-in chart.
Public property | Title | Gets or sets the title of the ChartAxis. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | ValueConverter | Gets or sets the IAxisValueConverter used for converting between axis values and objects.
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ChartAxis Class


ActualMaximum Property

[image]

Mindscape Phone Elements
ChartAxis..::..ActualMaximum Property
ChartAxis Class See Also Send Feedback
Gets or sets the maximum value that is currently visible on the ChartAxis. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ActualMaximum { get; set; }
Visual Basic
Public Property ActualMaximum As Double
    Get
    Set
Visual C++
public:
property double ActualMaximum {
    double get ();
    void set (double value);
}

Remarks

This property can be used for programmatic panning and zooming.

See Also

ChartAxis Class


ActualMinimum Property

[image]

Mindscape Phone Elements
ChartAxis..::..ActualMinimum Property
ChartAxis Class See Also Send Feedback
Gets or sets the minimum value that is currently visible on the ChartAxis. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ActualMinimum { get; set; }
Visual Basic
Public Property ActualMinimum As Double
    Get
    Set
Visual C++
public:
property double ActualMinimum {
    double get ();
    void set (double value);
}

Remarks

This property can be used for programmatic panning and zooming.

See Also

ChartAxis Class


AxisLineStyle Property

[image]

Mindscape Phone Elements
ChartAxis..::..AxisLineStyle Property
ChartAxis Class See Also Send Feedback
Gets or sets the Style applied to the axis line. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style AxisLineStyle { get; set; }
Visual Basic
Public Property AxisLineStyle As Style
    Get
    Set
Visual C++
public:
property Style^ AxisLineStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

ChartAxis Class


LabelFormat Property

[image]

Mindscape Phone Elements
ChartAxis..::..LabelFormat Property
ChartAxis Class See Also Send Feedback
Gets or sets the string format used to display the axis labels.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LabelFormat { get; set; }
Visual Basic
Public Property LabelFormat As String
    Get
    Set
Visual C++
public:
property String^ LabelFormat {
    String^ get ();
    void set (String^ value);
}

See Also

ChartAxis Class


LabelLayout Property

[image]

Mindscape Phone Elements
ChartAxis..::..LabelLayout Property
ChartAxis Class See Also Send Feedback
Gets or sets the AxisLabelLayout of the ChartAxis.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AxisLabelLayout LabelLayout { get; set; }
Visual Basic
Public Property LabelLayout As AxisLabelLayout
    Get
    Set
Visual C++
public:
property AxisLabelLayout LabelLayout {
    AxisLabelLayout get ();
    void set (AxisLabelLayout value);
}

See Also

ChartAxis Class


LabelLevelCount Property

[image]

Mindscape Phone Elements
ChartAxis..::..LabelLevelCount Property
ChartAxis Class See Also Send Feedback
Gets or sets the number of levels used for placing the axis labels.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LabelLevelCount { get; set; }
Visual Basic
Public Property LabelLevelCount As Integer
    Get
    Set
Visual C++
public:
property int LabelLevelCount {
    int get ();
    void set (int value);
}

See Also

ChartAxis Class


LabelTemplate Property

[image]

Mindscape Phone Elements
ChartAxis..::..LabelTemplate Property
ChartAxis Class See Also Send Feedback
Gets or sets the DataTemplate applied to the axis labels.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate LabelTemplate { get; set; }
Visual Basic
Public Property LabelTemplate As DataTemplate
    Get
    Set
Visual C++
public:
property DataTemplate^ LabelTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

ChartAxis Class


MajorTickMarks Property

[image]

Mindscape Phone Elements
ChartAxis..::..MajorTickMarks Property
ChartAxis Class See Also Send Feedback
Gets a collection of major tick marks.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<Border> MajorTickMarks { get; }
Visual Basic
Public ReadOnly Property MajorTickMarks As ReadOnlyCollection(Of Border)
    Get
Visual C++
public:
property ReadOnlyCollection<Border^>^ MajorTickMarks {
    ReadOnlyCollection<Border^>^ get ();
}

See Also

ChartAxis Class


MajorTickMarkStyle Property

[image]

Mindscape Phone Elements
ChartAxis..::..MajorTickMarkStyle Property
ChartAxis Class See Also Send Feedback
Gets or sets the Style applied to major tick marks. Tick marks are Border objects.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style MajorTickMarkStyle { get; set; }
Visual Basic
Public Property MajorTickMarkStyle As Style
    Get
    Set
Visual C++
public:
property Style^ MajorTickMarkStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

ChartAxis Class


MajorTickSpacing Property

[image]

Mindscape Phone Elements
ChartAxis..::..MajorTickSpacing Property
ChartAxis Class See Also Send Feedback
Gets or sets the logical axis distance between the major tick marks.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MajorTickSpacing { get; set; }
Visual Basic
Public Property MajorTickSpacing As Double
    Get
    Set
Visual C++
public:
property double MajorTickSpacing {
    double get ();
    void set (double value);
}

Remarks

If this property is zero (the default), the logical tick mark spacing will be calculated automatically based on the actual minimum and maximum property values. When setting this property manually, make sure it is reasonable based on the actual minimum and maximum property values so as not to create too many tick marks.

See Also

ChartAxis Class


Maximum Property

[image]

Mindscape Phone Elements
ChartAxis..::..Maximum Property
ChartAxis Class See Also Send Feedback
Gets or sets the maximum value that the ChartAxis can display. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Maximum { get; set; }
Visual Basic
Public Property Maximum As Double
    Get
    Set
Visual C++
public:
property double Maximum {
    double get ();
    void set (double value);
}

See Also

ChartAxis Class


Minimum Property

[image]

Mindscape Phone Elements
ChartAxis..::..Minimum Property
ChartAxis Class See Also Send Feedback
Gets or sets the minimum value that the ChartAxis can display. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Minimum { get; set; }
Visual Basic
Public Property Minimum As Double
    Get
    Set
Visual C++
public:
property double Minimum {
    double get ();
    void set (double value);
}

See Also

ChartAxis Class


MinimumRange Property

[image]

Mindscape Phone Elements
ChartAxis..::..MinimumRange Property
ChartAxis Class See Also Send Feedback
Gets or sets the minimum logic distance between the ActualMinimum and ActualMaximum. The default is 0.004

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MinimumRange { get; set; }
Visual Basic
Public Property MinimumRange As Double
    Get
    Set
Visual C++
public:
property double MinimumRange {
    double get ();
    void set (double value);
}

See Also

ChartAxis Class


MinorTickMarks Property

[image]

Mindscape Phone Elements
ChartAxis..::..MinorTickMarks Property
ChartAxis Class See Also Send Feedback
Gets a collection of minor tick marks.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<Border> MinorTickMarks { get; }
Visual Basic
Public ReadOnly Property MinorTickMarks As ReadOnlyCollection(Of Border)
    Get
Visual C++
public:
property ReadOnlyCollection<Border^>^ MinorTickMarks {
    ReadOnlyCollection<Border^>^ get ();
}

See Also

ChartAxis Class


MinorTickMarkStyle Property

[image]

Mindscape Phone Elements
ChartAxis..::..MinorTickMarkStyle Property
ChartAxis Class See Also Send Feedback
Gets or sets the Style applied to the minor tick marks. Tick marks are Border objects.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style MinorTickMarkStyle { get; set; }
Visual Basic
Public Property MinorTickMarkStyle As Style
    Get
    Set
Visual C++
public:
property Style^ MinorTickMarkStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

ChartAxis Class


MinorTickMarkVisibility Property

[image]

Mindscape Phone Elements
ChartAxis..::..MinorTickMarkVisibility Property
ChartAxis Class See Also Send Feedback
Gets or sets the Visibility of the minor tick marks.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility MinorTickMarkVisibility { get; set; }
Visual Basic
Public Property MinorTickMarkVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility MinorTickMarkVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

ChartAxis Class


TickLayout Property

[image]

Mindscape Phone Elements
ChartAxis..::..TickLayout Property
ChartAxis Class See Also Send Feedback
Gets or sets the AxisTickLayout that specifies how the tick marks are arranged along the axis.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AxisTickLayout TickLayout { get; set; }
Visual Basic
Public Property TickLayout As AxisTickLayout
    Get
    Set
Visual C++
public:
property AxisTickLayout TickLayout {
    AxisTickLayout get ();
    void set (AxisTickLayout value);
}

See Also

ChartAxis Class


TickMarkMode Property

[image]

Mindscape Phone Elements
ChartAxis..::..TickMarkMode Property
ChartAxis Class See Also Send Feedback
Gets or sets how tick marks behave when the user pans a zoomed-in chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TickMarkMode TickMarkMode { get; set; }
Visual Basic
Public Property TickMarkMode As TickMarkMode
    Get
    Set
Visual C++
public:
property TickMarkMode TickMarkMode {
    TickMarkMode get ();
    void set (TickMarkMode value);
}

See Also

ChartAxis Class


Title Property

[image]

Mindscape Phone Elements
ChartAxis..::..Title Property
ChartAxis Class See Also Send Feedback
Gets or sets the title of the ChartAxis. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

ChartAxis Class


ValueConverter Property

[image]

Mindscape Phone Elements
ChartAxis..::..ValueConverter Property
ChartAxis Class See Also Send Feedback
Gets or sets the IAxisValueConverter used for converting between axis values and objects.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IAxisValueConverter ValueConverter { get; set; }
Visual Basic
Public Property ValueConverter As IAxisValueConverter
    Get
    Set
Visual C++
public:
property IAxisValueConverter^ ValueConverter {
    IAxisValueConverter^ get ();
    void set (IAxisValueConverter^ value);
}

See Also

ChartAxis Class


ChartAxis Events

[image] [image]

Mindscape Phone Elements
ChartAxis Events
ChartAxis Class See Also Send Feedback

The ChartAxis type exposes the following members.

Events

 | Name | Description
Public event | AxisUpdated | Raised when the axis is updated.
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ChartAxis Class


AxisUpdated Event

[image]

Mindscape Phone Elements
ChartAxis..::..AxisUpdated Event
ChartAxis Class See Also Send Feedback
Raised when the axis is updated.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler AxisUpdated
Visual Basic
Public Event AxisUpdated As EventHandler
Visual C++
public:
 event EventHandler^ AxisUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ChartAxis Class


PropertyChanged Event

[image]

Mindscape Phone Elements
ChartAxis..::..PropertyChanged Event
ChartAxis Class See Also Send Feedback
Raised when a property changes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

ChartAxis Class


ChartGrid Class

[image]

Mindscape Phone Elements
ChartGrid Class
Members See Also Send Feedback
Renders grid lines and stripe lines based on a pair of ChartAxis objects.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ChartGrid : Canvas
Visual Basic
Public Class ChartGrid _
    Inherits Canvas
Visual C++
public ref class ChartGrid : public Canvas

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
System.Windows.Controls..::..Canvas
Mindscape.PhoneElements.Charting..::..ChartGrid

See Also

ChartGrid Members


ChartGrid Members

[image] [image]

Mindscape Phone Elements
ChartGrid Members
ChartGrid Class Constructors Methods Fields Properties Events See Also Send Feedback

The ChartGrid type exposes the following members.

Constructors

 | Name | Description
Public method | ChartGrid | Initializes a new instance of the ChartGrid class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
HorizontalDashArrayProperty | Identifies the HorizontalDashArray property.
HorizontalGridLineBrushProperty | Identifies the HorizontalGridLineBrush property.
MinorHorizontalDashArrayProperty | Identifies the MinorHorizontalDashArray property.
MinorHorizontalGridLineBrushProperty | Identifies the MinorHorizontalGridLineBrush property.
MinorVerticalDashArrayProperty | Identifies the MinorVerticalDashArray property.
MinorVerticalGridLineBrushProperty | Identifies the MinorVerticalGridLineBrush property.
VerticalDashArrayProperty | Identifies the VerticalDashArray property.
VerticalGridLineBrushProperty | Identifies the VerticalGridLineBrush property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalDashArray | Gets or sets the dash array used by horizontal grid lines. This is a dependency property.
Public property | HorizontalGridLineBrush | Gets or sets the brush applied to horizontal grid lines. This is a dependency property.
Public property | HorizontalStripeBrushes | Gets the collection of horizontal stripe brushes. These are used in rotation to fill the horizontal stripes of the grid, beginning with the bottom row.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. This is a dependency property. (Inherited from Panel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinorHorizontalDashArray | Gets or sets the dash array used by horizontal grid lines on minor tick marks. This is a dependency property.
Public property | MinorHorizontalGridLineBrush | Gets or sets the brush used to draw horizontal grid lines on minor tick marks. This is a dependency property.
Public property | MinorVerticalDashArray | Gets or sets the dash array used by vertical grid lines on minor tick marks. This is a dependency property.
Public property | MinorVerticalGridLineBrush | Gets or sets the brush used to draw vertical grid lines on minor tick marks. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalDashArray | Gets or sets the dash array used by vertical grid lines. This is a dependency property.
Public property | VerticalGridLineBrush | Gets or sets the brush applied to vertical grid lines. This is a dependency property.
Public property | VerticalStripeBrushes | Gets the collection of vertical stripe brushes. These are used in rotation to fill the vertical stripes of the grid, beginning with the leftmost column.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ChartGrid Class


ChartGrid Constructor

[image]

Mindscape Phone Elements
ChartGrid Constructor
ChartGrid Class See Also Send Feedback
Initializes a new instance of the ChartGrid class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartGrid()
Visual Basic
Public Sub New
Visual C++
public:
ChartGrid()

See Also

ChartGrid Class


ChartGrid Fields

[image] [image]

Mindscape Phone Elements
ChartGrid Fields
ChartGrid Class See Also Send Feedback

The ChartGrid type exposes the following members.

Fields

Name | Description
HorizontalDashArrayProperty | Identifies the HorizontalDashArray property.
HorizontalGridLineBrushProperty | Identifies the HorizontalGridLineBrush property.
MinorHorizontalDashArrayProperty | Identifies the MinorHorizontalDashArray property.
MinorHorizontalGridLineBrushProperty | Identifies the MinorHorizontalGridLineBrush property.
MinorVerticalDashArrayProperty | Identifies the MinorVerticalDashArray property.
MinorVerticalGridLineBrushProperty | Identifies the MinorVerticalGridLineBrush property.
VerticalDashArrayProperty | Identifies the VerticalDashArray property.
VerticalGridLineBrushProperty | Identifies the VerticalGridLineBrush property.

See Also

ChartGrid Class


HorizontalDashArrayProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..HorizontalDashArrayProperty Field
ChartGrid Class See Also Send Feedback
Identifies the HorizontalDashArray property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HorizontalDashArrayProperty
Visual Basic
Public Shared ReadOnly HorizontalDashArrayProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HorizontalDashArrayProperty

See Also

ChartGrid Class


HorizontalGridLineBrushProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..HorizontalGridLineBrushProperty Field
ChartGrid Class See Also Send Feedback
Identifies the HorizontalGridLineBrush property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HorizontalGridLineBrushProperty
Visual Basic
Public Shared ReadOnly HorizontalGridLineBrushProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HorizontalGridLineBrushProperty

See Also

ChartGrid Class


MinorHorizontalDashArrayProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..MinorHorizontalDashArrayProperty Field
ChartGrid Class See Also Send Feedback
Identifies the MinorHorizontalDashArray property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MinorHorizontalDashArrayProperty
Visual Basic
Public Shared ReadOnly MinorHorizontalDashArrayProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MinorHorizontalDashArrayProperty

See Also

ChartGrid Class


MinorHorizontalGridLineBrushProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..MinorHorizontalGridLineBrushProperty Field
ChartGrid Class See Also Send Feedback
Identifies the MinorHorizontalGridLineBrush property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MinorHorizontalGridLineBrushProperty
Visual Basic
Public Shared ReadOnly MinorHorizontalGridLineBrushProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MinorHorizontalGridLineBrushProperty

See Also

ChartGrid Class


MinorVerticalDashArrayProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..MinorVerticalDashArrayProperty Field
ChartGrid Class See Also Send Feedback
Identifies the MinorVerticalDashArray property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MinorVerticalDashArrayProperty
Visual Basic
Public Shared ReadOnly MinorVerticalDashArrayProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MinorVerticalDashArrayProperty

See Also

ChartGrid Class


MinorVerticalGridLineBrushProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..MinorVerticalGridLineBrushProperty Field
ChartGrid Class See Also Send Feedback
Identifies the MinorVerticalGridLineBrush property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MinorVerticalGridLineBrushProperty
Visual Basic
Public Shared ReadOnly MinorVerticalGridLineBrushProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MinorVerticalGridLineBrushProperty

See Also

ChartGrid Class


VerticalDashArrayProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..VerticalDashArrayProperty Field
ChartGrid Class See Also Send Feedback
Identifies the VerticalDashArray property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty VerticalDashArrayProperty
Visual Basic
Public Shared ReadOnly VerticalDashArrayProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ VerticalDashArrayProperty

See Also

ChartGrid Class


VerticalGridLineBrushProperty Field

[image]

Mindscape Phone Elements
ChartGrid..::..VerticalGridLineBrushProperty Field
ChartGrid Class See Also Send Feedback
Identifies the VerticalGridLineBrush property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty VerticalGridLineBrushProperty
Visual Basic
Public Shared ReadOnly VerticalGridLineBrushProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ VerticalGridLineBrushProperty

See Also

ChartGrid Class


ChartGrid Methods

[image] [image]

Mindscape Phone Elements
ChartGrid Methods
ChartGrid Class See Also Send Feedback

The ChartGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ChartGrid Class


ChartGrid Properties

[image] [image]

Mindscape Phone Elements
ChartGrid Properties
ChartGrid Class See Also Send Feedback

The ChartGrid type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalDashArray | Gets or sets the dash array used by horizontal grid lines. This is a dependency property.
Public property | HorizontalGridLineBrush | Gets or sets the brush applied to horizontal grid lines. This is a dependency property.
Public property | HorizontalStripeBrushes | Gets the collection of horizontal stripe brushes. These are used in rotation to fill the horizontal stripes of the grid, beginning with the bottom row.
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. This is a dependency property. (Inherited from Panel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinorHorizontalDashArray | Gets or sets the dash array used by horizontal grid lines on minor tick marks. This is a dependency property.
Public property | MinorHorizontalGridLineBrush | Gets or sets the brush used to draw horizontal grid lines on minor tick marks. This is a dependency property.
Public property | MinorVerticalDashArray | Gets or sets the dash array used by vertical grid lines on minor tick marks. This is a dependency property.
Public property | MinorVerticalGridLineBrush | Gets or sets the brush used to draw vertical grid lines on minor tick marks. This is a dependency property.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalDashArray | Gets or sets the dash array used by vertical grid lines. This is a dependency property.
Public property | VerticalGridLineBrush | Gets or sets the brush applied to vertical grid lines. This is a dependency property.
Public property | VerticalStripeBrushes | Gets the collection of vertical stripe brushes. These are used in rotation to fill the vertical stripes of the grid, beginning with the leftmost column.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

ChartGrid Class


HorizontalDashArray Property

[image]

Mindscape Phone Elements
ChartGrid..::..HorizontalDashArray Property
ChartGrid Class See Also Send Feedback
Gets or sets the dash array used by horizontal grid lines. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleCollection HorizontalDashArray { get; set; }
Visual Basic
Public Property HorizontalDashArray As DoubleCollection
    Get
    Set
Visual C++
public:
property DoubleCollection^ HorizontalDashArray {
    DoubleCollection^ get ();
    void set (DoubleCollection^ value);
}

See Also

ChartGrid Class


HorizontalGridLineBrush Property

[image]

Mindscape Phone Elements
ChartGrid..::..HorizontalGridLineBrush Property
ChartGrid Class See Also Send Feedback
Gets or sets the brush applied to horizontal grid lines. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush HorizontalGridLineBrush { get; set; }
Visual Basic
Public Property HorizontalGridLineBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HorizontalGridLineBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ChartGrid Class


HorizontalStripeBrushes Property

[image]

Mindscape Phone Elements
ChartGrid..::..HorizontalStripeBrushes Property
ChartGrid Class See Also Send Feedback
Gets the collection of horizontal stripe brushes. These are used in rotation to fill the horizontal stripes of the grid, beginning with the bottom row.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Collection<Brush> HorizontalStripeBrushes { get; }
Visual Basic
Public ReadOnly Property HorizontalStripeBrushes As Collection(Of Brush)
    Get
Visual C++
public:
property Collection<Brush^>^ HorizontalStripeBrushes {
    Collection<Brush^>^ get ();
}

Remarks

Horizontal stripes are drawn over the top of vertical stripes. Therefore, an opaque horizontal brush will obscure the vertical stripe color where the stripes overlap.

See Also

ChartGrid Class


MinorHorizontalDashArray Property

[image]

Mindscape Phone Elements
ChartGrid..::..MinorHorizontalDashArray Property
ChartGrid Class See Also Send Feedback
Gets or sets the dash array used by horizontal grid lines on minor tick marks. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleCollection MinorHorizontalDashArray { get; set; }
Visual Basic
Public Property MinorHorizontalDashArray As DoubleCollection
    Get
    Set
Visual C++
public:
property DoubleCollection^ MinorHorizontalDashArray {
    DoubleCollection^ get ();
    void set (DoubleCollection^ value);
}

See Also

ChartGrid Class


MinorHorizontalGridLineBrush Property

[image]

Mindscape Phone Elements
ChartGrid..::..MinorHorizontalGridLineBrush Property
ChartGrid Class See Also Send Feedback
Gets or sets the brush used to draw horizontal grid lines on minor tick marks. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush MinorHorizontalGridLineBrush { get; set; }
Visual Basic
Public Property MinorHorizontalGridLineBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ MinorHorizontalGridLineBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ChartGrid Class


MinorVerticalDashArray Property

[image]

Mindscape Phone Elements
ChartGrid..::..MinorVerticalDashArray Property
ChartGrid Class See Also Send Feedback
Gets or sets the dash array used by vertical grid lines on minor tick marks. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleCollection MinorVerticalDashArray { get; set; }
Visual Basic
Public Property MinorVerticalDashArray As DoubleCollection
    Get
    Set
Visual C++
public:
property DoubleCollection^ MinorVerticalDashArray {
    DoubleCollection^ get ();
    void set (DoubleCollection^ value);
}

See Also

ChartGrid Class


MinorVerticalGridLineBrush Property

[image]

Mindscape Phone Elements
ChartGrid..::..MinorVerticalGridLineBrush Property
ChartGrid Class See Also Send Feedback
Gets or sets the brush used to draw vertical grid lines on minor tick marks. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush MinorVerticalGridLineBrush { get; set; }
Visual Basic
Public Property MinorVerticalGridLineBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ MinorVerticalGridLineBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ChartGrid Class


VerticalDashArray Property

[image]

Mindscape Phone Elements
ChartGrid..::..VerticalDashArray Property
ChartGrid Class See Also Send Feedback
Gets or sets the dash array used by vertical grid lines. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleCollection VerticalDashArray { get; set; }
Visual Basic
Public Property VerticalDashArray As DoubleCollection
    Get
    Set
Visual C++
public:
property DoubleCollection^ VerticalDashArray {
    DoubleCollection^ get ();
    void set (DoubleCollection^ value);
}

See Also

ChartGrid Class


VerticalGridLineBrush Property

[image]

Mindscape Phone Elements
ChartGrid..::..VerticalGridLineBrush Property
ChartGrid Class See Also Send Feedback
Gets or sets the brush applied to vertical grid lines. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush VerticalGridLineBrush { get; set; }
Visual Basic
Public Property VerticalGridLineBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ VerticalGridLineBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ChartGrid Class


VerticalStripeBrushes Property

[image]

Mindscape Phone Elements
ChartGrid..::..VerticalStripeBrushes Property
ChartGrid Class See Also Send Feedback
Gets the collection of vertical stripe brushes. These are used in rotation to fill the vertical stripes of the grid, beginning with the leftmost column.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Collection<Brush> VerticalStripeBrushes { get; }
Visual Basic
Public ReadOnly Property VerticalStripeBrushes As Collection(Of Brush)
    Get
Visual C++
public:
property Collection<Brush^>^ VerticalStripeBrushes {
    Collection<Brush^>^ get ();
}

Remarks

Horizontal stripes are drawn over the top of vertical stripes. Therefore, an opaque horizontal brush will obscure the vertical stripe color where the stripes overlap.

See Also

ChartGrid Class


ChartGrid Events

[image] [image]

Mindscape Phone Elements
ChartGrid Events
ChartGrid Class See Also Send Feedback

The ChartGrid type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ChartGrid Class


ChartMouseEventArgs Class

[image]

Mindscape Phone Elements
ChartMouseEventArgs Class
Members See Also Send Feedback
Holds information about mouse events that occur on a chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ChartMouseEventArgs : EventArgs
Visual Basic
Public Class ChartMouseEventArgs _
    Inherits EventArgs
Visual C++
public ref class ChartMouseEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Mindscape.PhoneElements.Charting..::..ChartMouseEventArgs

See Also

ChartMouseEventArgs Members


ChartMouseEventArgs Members

[image] [image]

Mindscape Phone Elements
ChartMouseEventArgs Members
ChartMouseEventArgs Class Methods Properties See Also Send Feedback

The ChartMouseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConstrainedLogicalPoint | Gets the logical postion of the mouse pointer constrained by the dimensions of the chart canvas.
Public property | IsMouseDown | Gets whether or not the left mouse button is down.
Public property | IsMouseOver | Gets whether or not the mouse pointer is within the bounds of the chart canvas.
Public property | LogicalPoint | Gets the logical position of the mouse pointer over the chart canvas.
Public property | PhysicalPoint | Gets the physical position of the mouse pointer over the chart canvas.

See Also

ChartMouseEventArgs Class


ChartMouseEventArgs Methods

[image] [image]

Mindscape Phone Elements
ChartMouseEventArgs Methods
ChartMouseEventArgs Class See Also Send Feedback

The ChartMouseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartMouseEventArgs Class


ChartMouseEventArgs Properties

[image] [image]

Mindscape Phone Elements
ChartMouseEventArgs Properties
ChartMouseEventArgs Class See Also Send Feedback

The ChartMouseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ConstrainedLogicalPoint | Gets the logical postion of the mouse pointer constrained by the dimensions of the chart canvas.
Public property | IsMouseDown | Gets whether or not the left mouse button is down.
Public property | IsMouseOver | Gets whether or not the mouse pointer is within the bounds of the chart canvas.
Public property | LogicalPoint | Gets the logical position of the mouse pointer over the chart canvas.
Public property | PhysicalPoint | Gets the physical position of the mouse pointer over the chart canvas.

See Also

ChartMouseEventArgs Class


ConstrainedLogicalPoint Property

[image]

Mindscape Phone Elements
ChartMouseEventArgs..::..ConstrainedLogicalPoint Property
ChartMouseEventArgs Class See Also Send Feedback
Gets the logical postion of the mouse pointer constrained by the dimensions of the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point ConstrainedLogicalPoint { get; private set; }
Visual Basic
Public Property ConstrainedLogicalPoint As Point
    Get
    Private Set
Visual C++
public:
property Point ConstrainedLogicalPoint {
    Point get ();
    private: void set (Point value);
}

See Also

ChartMouseEventArgs Class


IsMouseDown Property

[image]

Mindscape Phone Elements
ChartMouseEventArgs..::..IsMouseDown Property
ChartMouseEventArgs Class See Also Send Feedback
Gets whether or not the left mouse button is down.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsMouseDown { get; private set; }
Visual Basic
Public Property IsMouseDown As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsMouseDown {
    bool get ();
    private: void set (bool value);
}

See Also

ChartMouseEventArgs Class


IsMouseOver Property

[image]

Mindscape Phone Elements
ChartMouseEventArgs..::..IsMouseOver Property
ChartMouseEventArgs Class See Also Send Feedback
Gets whether or not the mouse pointer is within the bounds of the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsMouseOver { get; private set; }
Visual Basic
Public Property IsMouseOver As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsMouseOver {
    bool get ();
    private: void set (bool value);
}

See Also

ChartMouseEventArgs Class


LogicalPoint Property

[image]

Mindscape Phone Elements
ChartMouseEventArgs..::..LogicalPoint Property
ChartMouseEventArgs Class See Also Send Feedback
Gets the logical position of the mouse pointer over the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point LogicalPoint { get; private set; }
Visual Basic
Public Property LogicalPoint As Point
    Get
    Private Set
Visual C++
public:
property Point LogicalPoint {
    Point get ();
    private: void set (Point value);
}

See Also

ChartMouseEventArgs Class


PhysicalPoint Property

[image]

Mindscape Phone Elements
ChartMouseEventArgs..::..PhysicalPoint Property
ChartMouseEventArgs Class See Also Send Feedback
Gets the physical position of the mouse pointer over the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point PhysicalPoint { get; private set; }
Visual Basic
Public Property PhysicalPoint As Point
    Get
    Private Set
Visual C++
public:
property Point PhysicalPoint {
    Point get ();
    private: void set (Point value);
}

See Also

ChartMouseEventArgs Class


ChartSymbol Class

[image]

Mindscape Phone Elements
ChartSymbol Class
Members See Also Send Feedback
Represents a data point of a data series involving plotted points.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ChartSymbol : CartesianDataPoint
Visual Basic
Public Class ChartSymbol _
    Inherits CartesianDataPoint
Visual C++
public ref class ChartSymbol : public CartesianDataPoint

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataPoint
Mindscape.PhoneElements.Charting..::..CartesianDataPoint
Mindscape.PhoneElements.Charting..::..ChartSymbol

See Also

ChartSymbol Members


ChartSymbol Members

[image] [image]

Mindscape Phone Elements
ChartSymbol Members
ChartSymbol Class Constructors Methods Properties Events See Also Send Feedback

The ChartSymbol type exposes the following members.

Constructors

 | Name | Description
Public method | ChartSymbol | Initializes a new instance of the ChartSymbol class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint. (Inherited from CartesianDataPoint.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ChartSymbol Class


ChartSymbol Constructor

[image]

Mindscape Phone Elements
ChartSymbol Constructor
ChartSymbol Class See Also Send Feedback
Initializes a new instance of the ChartSymbol class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartSymbol()
Visual Basic
Public Sub New
Visual C++
public:
ChartSymbol()

See Also

ChartSymbol Class


ChartSymbol Methods

[image] [image]

Mindscape Phone Elements
ChartSymbol Methods
ChartSymbol Class See Also Send Feedback

The ChartSymbol type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ChartSymbol Class


ChartSymbol Properties

[image] [image]

Mindscape Phone Elements
ChartSymbol Properties
ChartSymbol Class See Also Send Feedback

The ChartSymbol type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LogicalPoint | Gets the logical X,Y plotting position of the CartesianDataPoint. (Inherited from CartesianDataPoint.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XObject | Gets or sets the object that specifies the X value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)
Public property | YObject | Gets or sets the object that specifies the Y value of the CartesianDataPoint. This is a dependency property. (Inherited from CartesianDataPoint.)

See Also

ChartSymbol Class


ChartSymbol Events

[image] [image]

Mindscape Phone Elements
ChartSymbol Events
ChartSymbol Class See Also Send Feedback

The ChartSymbol type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ChartSymbol Class


DataLabel Class

[image]

Mindscape Phone Elements
DataLabel Class
Members See Also Send Feedback
Represents a label for data points on a Chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataLabel : Control
Visual Basic
Public Class DataLabel _
    Inherits Control
Visual C++
public ref class DataLabel : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataLabel

See Also

DataLabel Members


DataLabel Members

[image] [image]

Mindscape Phone Elements
DataLabel Members
DataLabel Class Methods Properties Events See Also Send Feedback

The DataLabel type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataPoint | Gets the DataPoint control that the DataLabel maps to. This can be used to obtain any piece of data that the data point is made up of.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DependentData | Gets the plotted data value along the dependent axis.
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataLabel Class


DataLabel Methods

[image] [image]

Mindscape Phone Elements
DataLabel Methods
DataLabel Class See Also Send Feedback

The DataLabel type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DataLabel Class


DataLabel Properties

[image] [image]

Mindscape Phone Elements
DataLabel Properties
DataLabel Class See Also Send Feedback

The DataLabel type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataPoint | Gets the DataPoint control that the DataLabel maps to. This can be used to obtain any piece of data that the data point is made up of.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DependentData | Gets the plotted data value along the dependent axis.
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DataLabel Class


DataPoint Property

[image]

Mindscape Phone Elements
DataLabel..::..DataPoint Property
DataLabel Class See Also Send Feedback
Gets the DataPoint control that the DataLabel maps to. This can be used to obtain any piece of data that the data point is made up of.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataPoint DataPoint { get; private set; }
Visual Basic
Public Property DataPoint As DataPoint
    Get
    Private Set
Visual C++
public:
property DataPoint^ DataPoint {
    DataPoint^ get ();
    private: void set (DataPoint^ value);
}

See Also

DataLabel Class


DependentData Property

[image]

Mindscape Phone Elements
DataLabel..::..DependentData Property
DataLabel Class See Also Send Feedback
Gets the plotted data value along the dependent axis.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object DependentData { get; private set; }
Visual Basic
Public Property DependentData As Object
    Get
    Private Set
Visual C++
public:
property Object^ DependentData {
    Object^ get ();
    private: void set (Object^ value);
}

See Also

DataLabel Class


DataLabel Events

[image] [image]

Mindscape Phone Elements
DataLabel Events
DataLabel Class See Also Send Feedback

The DataLabel type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataLabel Class


DataLabelHost Class

[image]

Mindscape Phone Elements
DataLabelHost Class
Members See Also Send Feedback
Used internally for positioning data labels. Application code does not normally interact with DataLabelHost.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataLabelHost : Control
Visual Basic
Public Class DataLabelHost _
    Inherits Control
Visual C++
public ref class DataLabelHost : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataLabelHost

See Also

DataLabelHost Members


DataLabelHost Members

[image] [image]

Mindscape Phone Elements
DataLabelHost Members
DataLabelHost Class Methods Properties Events See Also Send Feedback

The DataLabelHost type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Label | Gets the DataLabel.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataLabelHost Class


DataLabelHost Methods

[image] [image]

Mindscape Phone Elements
DataLabelHost Methods
DataLabelHost Class See Also Send Feedback

The DataLabelHost type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DataLabelHost Class


DataLabelHost Properties

[image] [image]

Mindscape Phone Elements
DataLabelHost Properties
DataLabelHost Class See Also Send Feedback

The DataLabelHost type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Label | Gets the DataLabel.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DataLabelHost Class


Label Property

[image]

Mindscape Phone Elements
DataLabelHost..::..Label Property
DataLabelHost Class See Also Send Feedback
Gets the DataLabel.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataLabel Label { get; internal set; }
Visual Basic
Public Property Label As DataLabel
    Get
    Friend Set
Visual C++
public:
property DataLabel^ Label {
    DataLabel^ get ();
    internal: void set (DataLabel^ value);
}

See Also

DataLabelHost Class


DataLabelHost Events

[image] [image]

Mindscape Phone Elements
DataLabelHost Events
DataLabelHost Class See Also Send Feedback

The DataLabelHost type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataLabelHost Class


DataPoint Class

[image]

Mindscape Phone Elements
DataPoint Class
Members See Also Send Feedback
Represents a single piece of data to be plotted on a chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DataPoint : Control
Visual Basic
Public MustInherit Class DataPoint _
    Inherits Control
Visual C++
public ref class DataPoint abstract : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataPoint
Mindscape.PhoneElements.Charting..::..CartesianDataPoint
Mindscape.PhoneElements.Charting..::..PieSlice

See Also

DataPoint Members


DataPoint Members

[image] [image]

Mindscape Phone Elements
DataPoint Members
DataPoint Class Constructors Methods Properties Events See Also Send Feedback

The DataPoint type exposes the following members.

Constructors

 | Name | Description
Protected method | DataPoint | Initializes a new instance of the DataPoint class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes.
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataPoint Class


DataPoint Constructor

[image]

Mindscape Phone Elements
DataPoint Constructor
DataPoint Class See Also Send Feedback
Initializes a new instance of the DataPoint class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DataPoint()
Visual Basic
Protected Sub New
Visual C++
protected:
DataPoint()

See Also

DataPoint Class


DataPoint Methods

[image] [image]

Mindscape Phone Elements
DataPoint Methods
DataPoint Class See Also Send Feedback

The DataPoint type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DataPoint Class


OnMouseLeftButtonDown Method

[image]

Mindscape Phone Elements
DataPoint..::..OnMouseLeftButtonDown Method
DataPoint Class See Also Send Feedback
Called when the left mouse button is pressed over the DataPoint.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::..MouseButtonEventArgs
The event data.

See Also

DataPoint Class


DataPoint Properties

[image] [image]

Mindscape Phone Elements
DataPoint Properties
DataPoint Class See Also Send Feedback

The DataPoint type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

DataPoint Class


IsSelected Property

[image]

Mindscape Phone Elements
DataPoint..::..IsSelected Property
DataPoint Class See Also Send Feedback
Gets or sets whether or not the DataPoint is currently selected.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

DataPoint Class


DataPoint Events

[image] [image]

Mindscape Phone Elements
DataPoint Events
DataPoint Class See Also Send Feedback

The DataPoint type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes.
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataPoint Class


IsSelectedChanged Event

[image]

Mindscape Phone Elements
DataPoint..::..IsSelectedChanged Event
DataPoint Class See Also Send Feedback
Raised when the IsSelected property changes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler IsSelectedChanged
Visual Basic
Public Event IsSelectedChanged As EventHandler
Visual C++
public:
 event EventHandler^ IsSelectedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DataPoint Class


DataPointHighlightMode Enumeration

[image]

Mindscape Phone Elements
DataPointHighlightMode Enumeration
See Also Send Feedback
Sepecifies how a DataPoint can be highlighted within its DataSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DataPointHighlightMode
Visual Basic
Public Enumeration DataPointHighlightMode
Visual C++
public enum class DataPointHighlightMode

Members

Member name | Value | Description
None | 0 | DataPoint objects in the DataSeries can not be highlighted.
ClosestXValue | 1 | DataPoint objects within the DataSeries are highlighted when the user taps close to their respective X values.

See Also


DataPointSelectionMode Enumeration

[image]

Mindscape Phone Elements
DataPointSelectionMode Enumeration
See Also Send Feedback
Specifies how DataPoint objects can be selected within a DataSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DataPointSelectionMode
Visual Basic
Public Enumeration DataPointSelectionMode
Visual C++
public enum class DataPointSelectionMode

Members

Member name | Value | Description
None | 0 | No DataPoint objects in the DataSeries can be selected.
Single | 1 | Only a single DataPoint within the DataSeries can be selected at a time.
Multiple | 2 | Multiple DataPoint objects can be selected.
All | 3 | All DataPoint objects in the DataSeries are selected at once.

See Also


DataSeries Class

[image]

Mindscape Phone Elements
DataSeries Class
Members See Also Send Feedback
Represents a data series that can be plotted by a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DataSeries : Control
Visual Basic
Public MustInherit Class DataSeries _
    Inherits Control
Visual C++
public ref class DataSeries abstract : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..BarSeries
Mindscape.PhoneElements.Charting..::..BubbleSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase

See Also

DataSeries Members


DataSeries Members

[image] [image]

Mindscape Phone Elements
DataSeries Members
DataSeries Class Constructors Methods Fields Properties Events See Also Send Feedback

The DataSeries type exposes the following members.

Constructors

 | Name | Description
Protected method | DataSeries | Initializes a new instance of the DataSeries class

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the DataSeries on the chart canvas.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint.
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event.
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series.
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
HighlightModeProperty | Identifies the HighlightMode property.
ItemsSourceProperty | Identifies the ItemsSource property.
LegendIconTemplateProperty | Identifies the LegendIconTemplate property.
SelectionModeProperty | Identifies the SelectionMode property.
SeriesBrushProperty | Identifies the SeriesBrush property.
TitleProperty | Identifies the Title property.
YAxisTitleProperty | Identifies the YAxisTitle property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property.
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected.
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property.
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one.
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against.
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object.
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against.
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property.
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes.
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataSeries Class


DataSeries Constructor

[image]

Mindscape Phone Elements
DataSeries Constructor
DataSeries Class See Also Send Feedback
Initializes a new instance of the DataSeries class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DataSeries()
Visual Basic
Protected Sub New
Visual C++
protected:
DataSeries()

See Also

DataSeries Class


DataSeries Fields

[image] [image]

Mindscape Phone Elements
DataSeries Fields
DataSeries Class See Also Send Feedback

The DataSeries type exposes the following members.

Fields

Name | Description
HighlightModeProperty | Identifies the HighlightMode property.
ItemsSourceProperty | Identifies the ItemsSource property.
LegendIconTemplateProperty | Identifies the LegendIconTemplate property.
SelectionModeProperty | Identifies the SelectionMode property.
SeriesBrushProperty | Identifies the SeriesBrush property.
TitleProperty | Identifies the Title property.
YAxisTitleProperty | Identifies the YAxisTitle property.

See Also

DataSeries Class


HighlightModeProperty Field

[image]

Mindscape Phone Elements
DataSeries..::..HighlightModeProperty Field
DataSeries Class See Also Send Feedback
Identifies the HighlightMode property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HighlightModeProperty
Visual Basic
Public Shared ReadOnly HighlightModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HighlightModeProperty

See Also

DataSeries Class


ItemsSourceProperty Field

[image]

Mindscape Phone Elements
DataSeries..::..ItemsSourceProperty Field
DataSeries Class See Also Send Feedback
Identifies the ItemsSource property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemsSourceProperty

See Also

DataSeries Class


LegendIconTemplateProperty Field

[image]

Mindscape Phone Elements
DataSeries..::..LegendIconTemplateProperty Field
DataSeries Class See Also Send Feedback
Identifies the LegendIconTemplate property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LegendIconTemplateProperty
Visual Basic
Public Shared ReadOnly LegendIconTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LegendIconTemplateProperty

See Also

DataSeries Class


SelectionModeProperty Field

[image]

Mindscape Phone Elements
DataSeries..::..SelectionModeProperty Field
DataSeries Class See Also Send Feedback
Identifies the SelectionMode property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic
Public Shared ReadOnly SelectionModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectionModeProperty

See Also

DataSeries Class


SeriesBrushProperty Field

[image]

Mindscape Phone Elements
DataSeries..::..SeriesBrushProperty Field
DataSeries Class See Also Send Feedback
Identifies the SeriesBrush property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SeriesBrushProperty
Visual Basic
Public Shared ReadOnly SeriesBrushProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SeriesBrushProperty

See Also

DataSeries Class


TitleProperty Field

[image]

Mindscape Phone Elements
DataSeries..::..TitleProperty Field
DataSeries Class See Also Send Feedback
Identifies the Title property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleProperty

See Also

DataSeries Class


YAxisTitleProperty Field

[image]

Mindscape Phone Elements
DataSeries..::..YAxisTitleProperty Field
DataSeries Class See Also Send Feedback
Identifies the YAxisTitle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty YAxisTitleProperty
Visual Basic
Public Shared ReadOnly YAxisTitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ YAxisTitleProperty

See Also

DataSeries Class


DataSeries Methods

[image] [image]

Mindscape Phone Elements
DataSeries Methods
DataSeries Class See Also Send Feedback

The DataSeries type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the DataSeries on the chart canvas.
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint.
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts.
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event.
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications.
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series.
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

DataSeries Class


BuildChartCore Method

[image]

Mindscape Phone Elements
DataSeries..::..BuildChartCore Method
DataSeries Class See Also Send Feedback
Plots the DataSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract void BuildChartCore()
Visual Basic
Protected MustOverride Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() abstract

See Also

DataSeries Class


ConvertLogicalToPhysicalPoint Method

[image]

Mindscape Phone Elements
DataSeries..::..ConvertLogicalToPhysicalPoint Method
DataSeries Class See Also Send Feedback
Converts the given logical data point to a physical point on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point ConvertLogicalToPhysicalPoint(
    Point point
)
Visual Basic
Public Function ConvertLogicalToPhysicalPoint ( _
    point As Point _
) As Point
Visual C++
public:
Point ConvertLogicalToPhysicalPoint(
    Point point
)

Parameters

point
Type: System.Windows..::..Point
The logical data point to convert.

Return Value

A physical position on the chart canvas based on the given logical data point.

See Also

DataSeries Class


GetDataPoint Method

[image]

Mindscape Phone Elements
DataSeries..::..GetDataPoint Method
DataSeries Class See Also Send Feedback
Gets the CartesianDataPoint mapped to the given data object and index.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected CartesianDataPoint GetDataPoint(
    Object o,
    int index
)
Visual Basic
Protected Function GetDataPoint ( _
    o As Object, _
    index As Integer _
) As CartesianDataPoint
Visual C++
protected:
CartesianDataPoint^ GetDataPoint(
    Object^ o,
    int index
)

Parameters

o
Type: System..::..Object
The data object.
index
Type: System..::..Int32
The index of the data object within the ItemsSource.

Return Value

The CartesianDataPoint mapped to the given object if it exists.

See Also

DataSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
DataSeries..::..GetPoint Method
DataSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint.
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts.

See Also

DataSeries Class
DataSeries Members


GetPoint Method (CartesianDataPoint)

[image]

Mindscape Phone Elements
DataSeries..::..GetPoint Method (CartesianDataPoint)
DataSeries Class See Also Send Feedback
Returns a Point containing the X and Y logical axis values of the given DataPoint.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal Point GetPoint(
    CartesianDataPoint dataPoint
)
Visual Basic
Protected Friend Function GetPoint ( _
    dataPoint As CartesianDataPoint _
) As Point
Visual C++
protected public:
Point GetPoint(
    CartesianDataPoint^ dataPoint
)

Parameters

dataPoint
Type: Mindscape.PhoneElements.Charting..::..CartesianDataPoint
The DataPoint holding the data to be plotted.

Return Value

A Point containg the X and Y axis values for the given DataPoint.

See Also

DataSeries Class
GetPoint Overload


GetPoint Method (CartesianDataPoint, Boolean)

[image]

Mindscape Phone Elements
DataSeries..::..GetPoint Method (CartesianDataPoint, Boolean)
DataSeries Class See Also Send Feedback
Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal Point GetPoint(
    CartesianDataPoint dataPoint,
    bool reverseAxes
)
Visual Basic
Protected Friend Function GetPoint ( _
    dataPoint As CartesianDataPoint, _
    reverseAxes As Boolean _
) As Point
Visual C++
protected public:
Point GetPoint(
    CartesianDataPoint^ dataPoint,
    bool reverseAxes
)

Parameters

dataPoint
Type: Mindscape.PhoneElements.Charting..::..CartesianDataPoint
The CartesianDataPoint holding the data to calculate a Point for.
reverseAxes
Type: System..::..Boolean
Specifies whether or not the YAxis is the independent axis.

Return Value

A Point containg the X and Y axis values for the given data object.

See Also

DataSeries Class
GetPoint Overload


OnLegendItemsChanged Method

[image]

Mindscape Phone Elements
DataSeries..::..OnLegendItemsChanged Method
DataSeries Class See Also Send Feedback
Raises the LegendItemsChanged event.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnLegendItemsChanged()
Visual Basic
Protected Sub OnLegendItemsChanged
Visual C++
protected:
void OnLegendItemsChanged()

See Also

DataSeries Class


PrepareDataPoint Method

[image]

Mindscape Phone Elements
DataSeries..::..PrepareDataPoint Method
DataSeries Class See Also Send Feedback
Prepares the given CartesianDataPoint to participate in selection features and data notifications.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void PrepareDataPoint(
    CartesianDataPoint dataPoint,
    int index
)
Visual Basic
Protected Sub PrepareDataPoint ( _
    dataPoint As CartesianDataPoint, _
    index As Integer _
)
Visual C++
protected:
void PrepareDataPoint(
    CartesianDataPoint^ dataPoint,
    int index
)

Parameters

dataPoint
Type: Mindscape.PhoneElements.Charting..::..CartesianDataPoint
The CartesianDataPoint to prepare.
index
Type: System..::..Int32
The index of the data object within the ItemsSource.

See Also

DataSeries Class


Rebuild Method

[image]

Mindscape Phone Elements
DataSeries..::..Rebuild Method
DataSeries Class See Also Send Feedback
Forces the parent Chart control to rebuild all the data series.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal void Rebuild()
Visual Basic
Protected Friend Sub Rebuild
Visual C++
protected public:
void Rebuild()

See Also

DataSeries Class


DataSeries Properties

[image] [image]

Mindscape Phone Elements
DataSeries Properties
DataSeries Class See Also Send Feedback

The DataSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property.
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering.
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property.
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering.
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering.
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected.
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property.
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one.
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against.
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object.
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against.
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property.
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object.

See Also

DataSeries Class


Canvas Property

[image]

Mindscape Phone Elements
DataSeries..::..Canvas Property
DataSeries Class See Also Send Feedback
Gets the Canvas that the DataSeries will be rendered on.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal Canvas Canvas { get; internal set; }
Visual Basic
Protected Friend Property Canvas As Canvas
    Get
    Friend Set
Visual C++
protected public:
property Canvas^ Canvas {
    Canvas^ get ();
    internal: void set (Canvas^ value);
}

See Also

DataSeries Class


DataPoints Property

[image]

Mindscape Phone Elements
DataSeries..::..DataPoints Property
DataSeries Class See Also Send Feedback
Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<CartesianDataPoint> DataPoints { get; }
Visual Basic
Public ReadOnly Property DataPoints As ReadOnlyCollection(Of CartesianDataPoint)
    Get
Visual C++
public:
property ReadOnlyCollection<CartesianDataPoint^>^ DataPoints {
    ReadOnlyCollection<CartesianDataPoint^>^ get ();
}

See Also

DataSeries Class


HighlightMode Property

[image]

Mindscape Phone Elements
DataSeries..::..HighlightMode Property
DataSeries Class See Also Send Feedback
Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataPointHighlightMode HighlightMode { get; set; }
Visual Basic
Public Property HighlightMode As DataPointHighlightMode
    Get
    Set
Visual C++
public:
property DataPointHighlightMode HighlightMode {
    DataPointHighlightMode get ();
    void set (DataPointHighlightMode value);
}

See Also

DataSeries Class


IndexStep Property

[image]

Mindscape Phone Elements
DataSeries..::..IndexStep Property
DataSeries Class See Also Send Feedback
Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int IndexStep { get; private set; }
Visual Basic
Protected Property IndexStep As Integer
    Get
    Private Set
Visual C++
protected:
property int IndexStep {
    int get ();
    private: void set (int value);
}

Remarks

This property should be accessed only from the BuildChartCore()()()() method, and is only meaningful if SupportsDataSampling is true for the series.

See Also

DataSeries Class


ItemsSource Property

[image]

Mindscape Phone Elements
DataSeries..::..ItemsSource Property
DataSeries Class See Also Send Feedback
Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IList ItemsSource { get; set; }
Visual Basic
Public Property ItemsSource As IList
    Get
    Set
Visual C++
public:
property IList^ ItemsSource {
    IList^ get ();
    void set (IList^ value);
}

See Also

DataSeries Class


LegendIconTemplate Property

[image]

Mindscape Phone Elements
DataSeries..::..LegendIconTemplate Property
DataSeries Class See Also Send Feedback
Gets or sets the LegendIconTemplate. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate LegendIconTemplate { get; set; }
Visual Basic
Public Property LegendIconTemplate As DataTemplate
    Get
    Set
Visual C++
public:
property DataTemplate^ LegendIconTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

DataSeries Class


LegendItems Property

[image]

Mindscape Phone Elements
DataSeries..::..LegendItems Property
DataSeries Class See Also Send Feedback
Gets a list of legend items to be displayed in the legend for this DataSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual IList<LegendItem> LegendItems { get; }
Visual Basic
Public Overridable ReadOnly Property LegendItems As IList(Of LegendItem)
    Get
Visual C++
public:
virtual property IList<LegendItem^>^ LegendItems {
    IList<LegendItem^>^ get ();
}

See Also

DataSeries Class


MaximumIndex Property

[image]

Mindscape Phone Elements
DataSeries..::..MaximumIndex Property
DataSeries Class See Also Send Feedback
Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int MaximumIndex { get; private set; }
Visual Basic
Protected Property MaximumIndex As Integer
    Get
    Private Set
Visual C++
protected:
property int MaximumIndex {
    int get ();
    private: void set (int value);
}

Remarks

This property should be accessed only from the BuildChartCore()()()() method, and is only meaningful if SupportsDataSampling is true for the series.

See Also

DataSeries Class


MinimumIndex Property

[image]

Mindscape Phone Elements
DataSeries..::..MinimumIndex Property
DataSeries Class See Also Send Feedback
Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int MinimumIndex { get; private set; }
Visual Basic
Protected Property MinimumIndex As Integer
    Get
    Private Set
Visual C++
protected:
property int MinimumIndex {
    int get ();
    private: void set (int value);
}

Remarks

This property should be accessed only from the BuildChartCore()()()() method, and is only meaningful if SupportsDataSampling is true for the series.

See Also

DataSeries Class


SelectedDataPoint Property

[image]

Mindscape Phone Elements
DataSeries..::..SelectedDataPoint Property
DataSeries Class See Also Send Feedback
Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CartesianDataPoint SelectedDataPoint { get; private set; }
Visual Basic
Public Property SelectedDataPoint As CartesianDataPoint
    Get
    Private Set
Visual C++
public:
property CartesianDataPoint^ SelectedDataPoint {
    CartesianDataPoint^ get ();
    private: void set (CartesianDataPoint^ value);
}

See Also

DataSeries Class


SelectionMode Property

[image]

Mindscape Phone Elements
DataSeries..::..SelectionMode Property
DataSeries Class See Also Send Feedback
Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataPointSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As DataPointSelectionMode
    Get
    Set
Visual C++
public:
property DataPointSelectionMode SelectionMode {
    DataPointSelectionMode get ();
    void set (DataPointSelectionMode value);
}

See Also

DataSeries Class


Series Property

[image]

Mindscape Phone Elements
DataSeries..::..Series Property
DataSeries Class See Also Send Feedback
Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal ObservableCollection<DataSeries> Series { get; private set; }
Visual Basic
Protected Friend Property Series As ObservableCollection(Of DataSeries)
    Get
    Private Set
Visual C++
protected public:
property ObservableCollection<DataSeries^>^ Series {
    ObservableCollection<DataSeries^>^ get ();
    private: void set (ObservableCollection<DataSeries^>^ value);
}

See Also

DataSeries Class


SeriesBrush Property

[image]

Mindscape Phone Elements
DataSeries..::..SeriesBrush Property
DataSeries Class See Also Send Feedback
Gets or sets the Brush used to color the DataSeries. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush SeriesBrush { get; set; }
Visual Basic
Public Property SeriesBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SeriesBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataSeries Class


SupportsDataSampling Property

[image]

Mindscape Phone Elements
DataSeries..::..SupportsDataSampling Property
DataSeries Class See Also Send Feedback
Gets whether the DataSeries supports sampling for large data sets.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual bool SupportsDataSampling { get; }
Visual Basic
Public Overridable ReadOnly Property SupportsDataSampling As Boolean
    Get
Visual C++
public:
virtual property bool SupportsDataSampling {
    bool get ();
}

See Also

DataSeries Class


Title Property

[image]

Mindscape Phone Elements
DataSeries..::..Title Property
DataSeries Class See Also Send Feedback
Gets or sets the title of the DataSeries. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

DataSeries Class


XAxis Property

[image]

Mindscape Phone Elements
DataSeries..::..XAxis Property
DataSeries Class See Also Send Feedback
Gets the X axis that the DataSeries is plotted against.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartAxis XAxis { get; internal set; }
Visual Basic
Public Property XAxis As ChartAxis
    Get
    Friend Set
Visual C++
public:
property ChartAxis^ XAxis {
    ChartAxis^ get ();
    internal: void set (ChartAxis^ value);
}

See Also

DataSeries Class


XBinding Property

[image]

Mindscape Phone Elements
DataSeries..::..XBinding Property
DataSeries Class See Also Send Feedback
Gets or sets a binding used to extract the X axis value from a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding XBinding { get; set; }
Visual Basic
Public Property XBinding As Binding
    Get
    Set
Visual C++
public:
property Binding^ XBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

DataSeries Class


YAxis Property

[image]

Mindscape Phone Elements
DataSeries..::..YAxis Property
DataSeries Class See Also Send Feedback
Gets the Y axis that the DataSeries is plotted against.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartAxis YAxis { get; internal set; }
Visual Basic
Public Property YAxis As ChartAxis
    Get
    Friend Set
Visual C++
public:
property ChartAxis^ YAxis {
    ChartAxis^ get ();
    internal: void set (ChartAxis^ value);
}

See Also

DataSeries Class


YAxisTitle Property

[image]

Mindscape Phone Elements
DataSeries..::..YAxisTitle Property
DataSeries Class See Also Send Feedback
Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string YAxisTitle { get; set; }
Visual Basic
Public Property YAxisTitle As String
    Get
    Set
Visual C++
public:
property String^ YAxisTitle {
    String^ get ();
    void set (String^ value);
}

See Also

DataSeries Class


YBinding Property

[image]

Mindscape Phone Elements
DataSeries..::..YBinding Property
DataSeries Class See Also Send Feedback
Gets or sets a binding used to extract the Y axis value from a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding YBinding { get; set; }
Visual Basic
Public Property YBinding As Binding
    Get
    Set
Visual C++
public:
property Binding^ YBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

DataSeries Class


DataSeries Events

[image] [image]

Mindscape Phone Elements
DataSeries Events
DataSeries Class See Also Send Feedback

The DataSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes.
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

DataSeries Class


LegendItemsChanged Event

[image]

Mindscape Phone Elements
DataSeries..::..LegendItemsChanged Event
DataSeries Class See Also Send Feedback
Raised when the legend items for this DataSeries changes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler LegendItemsChanged
Visual Basic
Public Event LegendItemsChanged As EventHandler
Visual C++
public:
 event EventHandler^ LegendItemsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

DataSeries Class


DataSeriesSelectionMode Enumeration

[image]

Mindscape Phone Elements
DataSeriesSelectionMode Enumeration
See Also Send Feedback
Specifies the selection mode of DataSeries within a Chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DataSeriesSelectionMode
Visual Basic
Public Enumeration DataSeriesSelectionMode
Visual C++
public enum class DataSeriesSelectionMode

Members

Member name | Value | Description
Single | 0 | Only DataPoint objects from a single DataSeries can be selected at a time. Selecting a DataPoint within a DataSeries will deselect any data points in the previously selected DataSeries.
Multiple | 1 | Any number of DataSeries can have selected DataPoint objects.

See Also


DateTimeAxisLabelConverter Class

[image]

Mindscape Phone Elements
DateTimeAxisLabelConverter Class
Members See Also Send Feedback
A type of IAxisLabelConverter used for creating a DateTime axis scale.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateTimeAxisLabelConverter : IAxisLabelConverter
Visual Basic
Public Class DateTimeAxisLabelConverter _
    Implements IAxisLabelConverter
Visual C++
public ref class DateTimeAxisLabelConverter : IAxisLabelConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..DateTimeAxisLabelConverter

See Also

DateTimeAxisLabelConverter Members


DateTimeAxisLabelConverter Members

[image] [image]

Mindscape Phone Elements
DateTimeAxisLabelConverter Members
DateTimeAxisLabelConverter Class Constructors Methods See Also Send Feedback

The DateTimeAxisLabelConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeAxisLabelConverter | Initializes a new instance of the DateTimeAxisLabelConverter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Converts the given data object to a logical axis plot position.
Public method | GetDataObjectAt | Converts the given logical axis position to a data object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeAxisLabelConverter Class


DateTimeAxisLabelConverter Constructor

[image]

Mindscape Phone Elements
DateTimeAxisLabelConverter Constructor
DateTimeAxisLabelConverter Class See Also Send Feedback
Initializes a new instance of the DateTimeAxisLabelConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeAxisLabelConverter()
Visual Basic
Public Sub New
Visual C++
public:
DateTimeAxisLabelConverter()

See Also

DateTimeAxisLabelConverter Class


DateTimeAxisLabelConverter Methods

[image] [image]

Mindscape Phone Elements
DateTimeAxisLabelConverter Methods
DateTimeAxisLabelConverter Class See Also Send Feedback

The DateTimeAxisLabelConverter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Converts the given data object to a logical axis plot position.
Public method | GetDataObjectAt | Converts the given logical axis position to a data object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeAxisLabelConverter Class


GetAxisPlotPosition Method

[image]

Mindscape Phone Elements
DateTimeAxisLabelConverter..::..GetAxisPlotPosition Method
DateTimeAxisLabelConverter Class See Also Send Feedback
Converts the given data object to a logical axis plot position.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetAxisPlotPosition(
    Object o
)
Visual Basic
Public Function GetAxisPlotPosition ( _
    o As Object _
) As Double
Visual C++
public:
virtual double GetAxisPlotPosition(
    Object^ o
) sealed

Parameters

o
Type: System..::..Object
The data object to convert.

Return Value

The logical axis position of the given data object.

Implements

IAxisLabelConverter..::..GetAxisPlotPosition(Object)

See Also

DateTimeAxisLabelConverter Class


GetDataObjectAt Method

[image]

Mindscape Phone Elements
DateTimeAxisLabelConverter..::..GetDataObjectAt Method
DateTimeAxisLabelConverter Class See Also Send Feedback
Converts the given logical axis position to a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetDataObjectAt(
    double d
)
Visual Basic
Public Function GetDataObjectAt ( _
    d As Double _
) As Object
Visual C++
public:
virtual Object^ GetDataObjectAt(
    double d
) sealed

Parameters

d
Type: System..::..Double
The logical axis position.

Return Value

The converted data object.

Implements

IAxisLabelConverter..::..GetDataObjectAt(Double)

See Also

DateTimeAxisLabelConverter Class


DateTimeAxisValueConverter Class

[image]

Mindscape Phone Elements
DateTimeAxisValueConverter Class
Members See Also Send Feedback
A type of IAxisValueConverter used for creating a DateTime axis scale.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateTimeAxisValueConverter : IAxisValueConverter
Visual Basic
Public Class DateTimeAxisValueConverter _
    Implements IAxisValueConverter
Visual C++
public ref class DateTimeAxisValueConverter : IAxisValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..DateTimeAxisValueConverter

See Also

DateTimeAxisValueConverter Members


DateTimeAxisValueConverter Members

[image] [image]

Mindscape Phone Elements
DateTimeAxisValueConverter Members
DateTimeAxisValueConverter Class Constructors Methods See Also Send Feedback

The DateTimeAxisValueConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeAxisValueConverter | Initializes a new instance of the DateTimeAxisValueConverter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Gets the logical axis position for a DateTime.
Public method | GetDataObjectAt | Gets the DateTime corresponding to a logical axis position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeAxisValueConverter Class


DateTimeAxisValueConverter Constructor

[image]

Mindscape Phone Elements
DateTimeAxisValueConverter Constructor
DateTimeAxisValueConverter Class See Also Send Feedback
Initializes a new instance of the DateTimeAxisValueConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeAxisValueConverter()
Visual Basic
Public Sub New
Visual C++
public:
DateTimeAxisValueConverter()

See Also

DateTimeAxisValueConverter Class


DateTimeAxisValueConverter Methods

[image] [image]

Mindscape Phone Elements
DateTimeAxisValueConverter Methods
DateTimeAxisValueConverter Class See Also Send Feedback

The DateTimeAxisValueConverter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Gets the logical axis position for a DateTime.
Public method | GetDataObjectAt | Gets the DateTime corresponding to a logical axis position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeAxisValueConverter Class


GetAxisPlotPosition Method

[image]

Mindscape Phone Elements
DateTimeAxisValueConverter..::..GetAxisPlotPosition Method
DateTimeAxisValueConverter Class See Also Send Feedback
Gets the logical axis position for a DateTime.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetAxisPlotPosition(
    Object o
)
Visual Basic
Public Function GetAxisPlotPosition ( _
    o As Object _
) As Double
Visual C++
public:
virtual double GetAxisPlotPosition(
    Object^ o
) sealed

Parameters

o
Type: System..::..Object
The DateTime whose plot position is required.

Return Value

The logical axis position of the given DateTime.

Implements

IAxisValueConverter..::..GetAxisPlotPosition(Object)

See Also

DateTimeAxisValueConverter Class


GetDataObjectAt Method

[image]

Mindscape Phone Elements
DateTimeAxisValueConverter..::..GetDataObjectAt Method
DateTimeAxisValueConverter Class See Also Send Feedback
Gets the DateTime corresponding to a logical axis position.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetDataObjectAt(
    double axisPosition
)
Visual Basic
Public Function GetDataObjectAt ( _
    axisPosition As Double _
) As Object
Visual C++
public:
virtual Object^ GetDataObjectAt(
    double axisPosition
) sealed

Parameters

axisPosition
Type: System..::..Double
The logical axis position.

Return Value

The DateTime represented on the axis at that position.

Implements

IAxisValueConverter..::..GetDataObjectAt(Double)

See Also

DateTimeAxisValueConverter Class


DoubleToHorizontalTranslationConverter Class

[image]

Mindscape Phone Elements
DoubleToHorizontalTranslationConverter Class
Members See Also Send Feedback
Converts a double to a horizontal TranslateTransform of the specified amount.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DoubleToHorizontalTranslationConverter : IValueConverter
Visual Basic
Public Class DoubleToHorizontalTranslationConverter _
    Implements IValueConverter
Visual C++
public ref class DoubleToHorizontalTranslationConverter : IValueConverter

Remarks

This converter works around data binding issues in the Silverlight transform system.

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..DoubleToHorizontalTranslationConverter

See Also

DoubleToHorizontalTranslationConverter Members


DoubleToHorizontalTranslationConverter Members

[image] [image]

Mindscape Phone Elements
DoubleToHorizontalTranslationConverter Members
DoubleToHorizontalTranslationConverter Class Constructors Methods See Also Send Feedback

The DoubleToHorizontalTranslationConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleToHorizontalTranslationConverter | Initializes a new instance of the DoubleToHorizontalTranslationConverter class

Methods

 | Name | Description
Public method | Convert | Returns a TranslateTransform whose X value is the input double and whose Y value is zero.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleToHorizontalTranslationConverter Class


DoubleToHorizontalTranslationConverter Constructor

[image]

Mindscape Phone Elements
DoubleToHorizontalTranslationConverter Constructor
DoubleToHorizontalTranslationConverter Class See Also Send Feedback
Initializes a new instance of the DoubleToHorizontalTranslationConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleToHorizontalTranslationConverter()
Visual Basic
Public Sub New
Visual C++
public:
DoubleToHorizontalTranslationConverter()

See Also

DoubleToHorizontalTranslationConverter Class


DoubleToHorizontalTranslationConverter Methods

[image] [image]

Mindscape Phone Elements
DoubleToHorizontalTranslationConverter Methods
DoubleToHorizontalTranslationConverter Class See Also Send Feedback

The DoubleToHorizontalTranslationConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a TranslateTransform whose X value is the input double and whose Y value is zero.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleToHorizontalTranslationConverter Class


Convert Method

[image]

Mindscape Phone Elements
DoubleToHorizontalTranslationConverter..::..Convert Method
DoubleToHorizontalTranslationConverter Class See Also Send Feedback
Returns a TranslateTransform whose X value is the input double and whose Y value is zero.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The double value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A TranslateTransform with an X translation equal to the given double.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

DoubleToHorizontalTranslationConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
DoubleToHorizontalTranslationConverter..::..ConvertBack Method
DoubleToHorizontalTranslationConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

DoubleToHorizontalTranslationConverter Class


DoubleToRotateTransformConverter Class

[image]

Mindscape Phone Elements
DoubleToRotateTransformConverter Class
Members See Also Send Feedback
Given a double input value, creates a RotateTransform with that angle.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DoubleToRotateTransformConverter : IValueConverter
Visual Basic
Public Class DoubleToRotateTransformConverter _
    Implements IValueConverter
Visual C++
public ref class DoubleToRotateTransformConverter : IValueConverter

Remarks

This converter works around data binding issues in the Silverlight transform system.

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..DoubleToRotateTransformConverter

See Also

DoubleToRotateTransformConverter Members


DoubleToRotateTransformConverter Members

[image] [image]

Mindscape Phone Elements
DoubleToRotateTransformConverter Members
DoubleToRotateTransformConverter Class Constructors Methods See Also Send Feedback

The DoubleToRotateTransformConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleToRotateTransformConverter | Initializes a new instance of the DoubleToRotateTransformConverter class

Methods

 | Name | Description
Public method | Convert | Converts a double to a RotateTransform of that angle.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleToRotateTransformConverter Class


DoubleToRotateTransformConverter Constructor

[image]

Mindscape Phone Elements
DoubleToRotateTransformConverter Constructor
DoubleToRotateTransformConverter Class See Also Send Feedback
Initializes a new instance of the DoubleToRotateTransformConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleToRotateTransformConverter()
Visual Basic
Public Sub New
Visual C++
public:
DoubleToRotateTransformConverter()

See Also

DoubleToRotateTransformConverter Class


DoubleToRotateTransformConverter Methods

[image] [image]

Mindscape Phone Elements
DoubleToRotateTransformConverter Methods
DoubleToRotateTransformConverter Class See Also Send Feedback

The DoubleToRotateTransformConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Converts a double to a RotateTransform of that angle.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleToRotateTransformConverter Class


Convert Method

[image]

Mindscape Phone Elements
DoubleToRotateTransformConverter..::..Convert Method
DoubleToRotateTransformConverter Class See Also Send Feedback
Converts a double to a RotateTransform of that angle.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The double value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A RotateTransform whose Angle is equal to the input value, around (0.5, 0.5).

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

DoubleToRotateTransformConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
DoubleToRotateTransformConverter..::..ConvertBack Method
DoubleToRotateTransformConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

DoubleToRotateTransformConverter Class


DoubleToThicknessConverter Class

[image]

Mindscape Phone Elements
DoubleToThicknessConverter Class
Members See Also Send Feedback
Converts a double to a Thickness.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DoubleToThicknessConverter : IValueConverter
Visual Basic
Public Class DoubleToThicknessConverter _
    Implements IValueConverter
Visual C++
public ref class DoubleToThicknessConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..DoubleToThicknessConverter

See Also

DoubleToThicknessConverter Members


DoubleToThicknessConverter Members

[image] [image]

Mindscape Phone Elements
DoubleToThicknessConverter Members
DoubleToThicknessConverter Class Constructors Methods Properties See Also Send Feedback

The DoubleToThicknessConverter type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleToThicknessConverter | Initializes a new instance of the DoubleToThicknessConverter class

Methods

 | Name | Description
Public method | Convert | Returns a Thickness.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsBottom | Gets or sets whether or not the double is applied to the bottom of the Thickness.
Public property | IsLeft | Gets or sets whether or not the double is applied to the left of the Thickness.
Public property | IsRight | Gets or sets whether or not the double is applied to the right of the Thickness.
Public property | IsTop | Gets or sets whether or not the double is applied to the top of the Thickness.

See Also

DoubleToThicknessConverter Class


DoubleToThicknessConverter Constructor

[image]

Mindscape Phone Elements
DoubleToThicknessConverter Constructor
DoubleToThicknessConverter Class See Also Send Feedback
Initializes a new instance of the DoubleToThicknessConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleToThicknessConverter()
Visual Basic
Public Sub New
Visual C++
public:
DoubleToThicknessConverter()

See Also

DoubleToThicknessConverter Class


DoubleToThicknessConverter Methods

[image] [image]

Mindscape Phone Elements
DoubleToThicknessConverter Methods
DoubleToThicknessConverter Class See Also Send Feedback

The DoubleToThicknessConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a Thickness.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleToThicknessConverter Class


Convert Method

[image]

Mindscape Phone Elements
DoubleToThicknessConverter..::..Convert Method
DoubleToThicknessConverter Class See Also Send Feedback
Returns a Thickness.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The double value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A Thickness based on the given double.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

DoubleToThicknessConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
DoubleToThicknessConverter..::..ConvertBack Method
DoubleToThicknessConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

DoubleToThicknessConverter Class


DoubleToThicknessConverter Properties

[image] [image]

Mindscape Phone Elements
DoubleToThicknessConverter Properties
DoubleToThicknessConverter Class See Also Send Feedback

The DoubleToThicknessConverter type exposes the following members.

Properties

 | Name | Description
Public property | IsBottom | Gets or sets whether or not the double is applied to the bottom of the Thickness.
Public property | IsLeft | Gets or sets whether or not the double is applied to the left of the Thickness.
Public property | IsRight | Gets or sets whether or not the double is applied to the right of the Thickness.
Public property | IsTop | Gets or sets whether or not the double is applied to the top of the Thickness.

See Also

DoubleToThicknessConverter Class


IsBottom Property

[image]

Mindscape Phone Elements
DoubleToThicknessConverter..::..IsBottom Property
DoubleToThicknessConverter Class See Also Send Feedback
Gets or sets whether or not the double is applied to the bottom of the Thickness.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsBottom { get; set; }
Visual Basic
Public Property IsBottom As Boolean
    Get
    Set
Visual C++
public:
property bool IsBottom {
    bool get ();
    void set (bool value);
}

See Also

DoubleToThicknessConverter Class


IsLeft Property

[image]

Mindscape Phone Elements
DoubleToThicknessConverter..::..IsLeft Property
DoubleToThicknessConverter Class See Also Send Feedback
Gets or sets whether or not the double is applied to the left of the Thickness.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLeft { get; set; }
Visual Basic
Public Property IsLeft As Boolean
    Get
    Set
Visual C++
public:
property bool IsLeft {
    bool get ();
    void set (bool value);
}

See Also

DoubleToThicknessConverter Class


IsRight Property

[image]

Mindscape Phone Elements
DoubleToThicknessConverter..::..IsRight Property
DoubleToThicknessConverter Class See Also Send Feedback
Gets or sets whether or not the double is applied to the right of the Thickness.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsRight { get; set; }
Visual Basic
Public Property IsRight As Boolean
    Get
    Set
Visual C++
public:
property bool IsRight {
    bool get ();
    void set (bool value);
}

See Also

DoubleToThicknessConverter Class


IsTop Property

[image]

Mindscape Phone Elements
DoubleToThicknessConverter..::..IsTop Property
DoubleToThicknessConverter Class See Also Send Feedback
Gets or sets whether or not the double is applied to the top of the Thickness.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsTop { get; set; }
Visual Basic
Public Property IsTop As Boolean
    Get
    Set
Visual C++
public:
property bool IsTop {
    bool get ();
    void set (bool value);
}

See Also

DoubleToThicknessConverter Class


FormattingConverter Class

[image]

Mindscape Phone Elements
FormattingConverter Class
Members See Also Send Feedback
Formats a binding source value using a format string.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FormattingConverter : IValueConverter
Visual Basic
Public Class FormattingConverter _
    Implements IValueConverter
Visual C++
public ref class FormattingConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..FormattingConverter

See Also

FormattingConverter Members


FormattingConverter Members

[image] [image]

Mindscape Phone Elements
FormattingConverter Members
FormattingConverter Class Constructors Methods Properties See Also Send Feedback

The FormattingConverter type exposes the following members.

Constructors

 | Name | Description
Public method | FormattingConverter | Initializes a new instance of the FormattingConverter class.

Methods

 | Name | Description
Public method | Convert | Formats the binding source value using a format string.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FormatString | Gets or sets the format string.

See Also

FormattingConverter Class


FormattingConverter Constructor

[image]

Mindscape Phone Elements
FormattingConverter Constructor
FormattingConverter Class See Also Send Feedback
Initializes a new instance of the FormattingConverter class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FormattingConverter()
Visual Basic
Public Sub New
Visual C++
public:
FormattingConverter()

See Also

FormattingConverter Class


FormattingConverter Methods

[image] [image]

Mindscape Phone Elements
FormattingConverter Methods
FormattingConverter Class See Also Send Feedback

The FormattingConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Formats the binding source value using a format string.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormattingConverter Class


Convert Method

[image]

Mindscape Phone Elements
FormattingConverter..::..Convert Method
FormattingConverter Class See Also Send Feedback
Formats the binding source value using a format string.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The object value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The formatted object string.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

FormattingConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
FormattingConverter..::..ConvertBack Method
FormattingConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

FormattingConverter Class


FormattingConverter Properties

[image] [image]

Mindscape Phone Elements
FormattingConverter Properties
FormattingConverter Class See Also Send Feedback

The FormattingConverter type exposes the following members.

Properties

 | Name | Description
Public property | FormatString | Gets or sets the format string.

See Also

FormattingConverter Class


FormatString Property

[image]

Mindscape Phone Elements
FormattingConverter..::..FormatString Property
FormattingConverter Class See Also Send Feedback
Gets or sets the format string.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FormatString { get; set; }
Visual Basic
Public Property FormatString As String
    Get
    Set
Visual C++
public:
property String^ FormatString {
    String^ get ();
    void set (String^ value);
}

See Also

FormattingConverter Class


IAxisLabelConverter Interface

[image]

Mindscape Phone Elements
IAxisLabelConverter Interface
Members See Also Send Feedback
Converts between data values and logical axis positions to create custom axis scales.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IAxisLabelConverter
Visual Basic
Public Interface IAxisLabelConverter
Visual C++
public interface class IAxisLabelConverter

See Also

IAxisLabelConverter Members


IAxisLabelConverter Members

[image] [image]

Mindscape Phone Elements
IAxisLabelConverter Members
IAxisLabelConverter Interface Methods See Also Send Feedback

The IAxisLabelConverter type exposes the following members.

Methods

 | Name | Description
Public method | GetAxisPlotPosition | Gets the logical axis plot position for a data object.
Public method | GetDataObjectAt | Gets the data object corresponding to a logical axis position.

See Also

IAxisLabelConverter Interface


IAxisLabelConverter Methods

[image] [image]

Mindscape Phone Elements
IAxisLabelConverter Methods
IAxisLabelConverter Interface See Also Send Feedback

The IAxisLabelConverter type exposes the following members.

Methods

 | Name | Description
Public method | GetAxisPlotPosition | Gets the logical axis plot position for a data object.
Public method | GetDataObjectAt | Gets the data object corresponding to a logical axis position.

See Also

IAxisLabelConverter Interface


GetAxisPlotPosition Method

[image]

Mindscape Phone Elements
IAxisLabelConverter..::..GetAxisPlotPosition Method
IAxisLabelConverter Interface See Also Send Feedback
Gets the logical axis plot position for a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
double GetAxisPlotPosition(
    Object o
)
Visual Basic
Function GetAxisPlotPosition ( _
    o As Object _
) As Double
Visual C++
double GetAxisPlotPosition(
    Object^ o
)

Parameters

o
Type: System..::..Object
The data object whose plot position is required.

Return Value

The logical axis position of the given data object.

See Also

IAxisLabelConverter Interface


GetDataObjectAt Method

[image]

Mindscape Phone Elements
IAxisLabelConverter..::..GetDataObjectAt Method
IAxisLabelConverter Interface See Also Send Feedback
Gets the data object corresponding to a logical axis position.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Object GetDataObjectAt(
    double axisPosition
)
Visual Basic
Function GetDataObjectAt ( _
    axisPosition As Double _
) As Object
Visual C++
Object^ GetDataObjectAt(
    double axisPosition
)

Parameters

axisPosition
Type: System..::..Double
The logical axis position.

Return Value

The object represented on the axis at that position.

See Also

IAxisLabelConverter Interface


IAxisValueConverter Interface

[image]

Mindscape Phone Elements
IAxisValueConverter Interface
Members See Also Send Feedback
Converts between data values and logical axis positions to create custom axis scales.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IAxisValueConverter
Visual Basic
Public Interface IAxisValueConverter
Visual C++
public interface class IAxisValueConverter

See Also

IAxisValueConverter Members


IAxisValueConverter Members

[image] [image]

Mindscape Phone Elements
IAxisValueConverter Members
IAxisValueConverter Interface Methods See Also Send Feedback

The IAxisValueConverter type exposes the following members.

Methods

 | Name | Description
Public method | GetAxisPlotPosition | Gets the logical axis position for a data object.
Public method | GetDataObjectAt | Gets the data object corresponding to a logical axis position.

See Also

IAxisValueConverter Interface


IAxisValueConverter Methods

[image] [image]

Mindscape Phone Elements
IAxisValueConverter Methods
IAxisValueConverter Interface See Also Send Feedback

The IAxisValueConverter type exposes the following members.

Methods

 | Name | Description
Public method | GetAxisPlotPosition | Gets the logical axis position for a data object.
Public method | GetDataObjectAt | Gets the data object corresponding to a logical axis position.

See Also

IAxisValueConverter Interface


GetAxisPlotPosition Method

[image]

Mindscape Phone Elements
IAxisValueConverter..::..GetAxisPlotPosition Method
IAxisValueConverter Interface See Also Send Feedback
Gets the logical axis position for a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
double GetAxisPlotPosition(
    Object o
)
Visual Basic
Function GetAxisPlotPosition ( _
    o As Object _
) As Double
Visual C++
double GetAxisPlotPosition(
    Object^ o
)

Parameters

o
Type: System..::..Object
The data object whose plot position is required.

Return Value

The logical axis position of the given data object.

See Also

IAxisValueConverter Interface


GetDataObjectAt Method

[image]

Mindscape Phone Elements
IAxisValueConverter..::..GetDataObjectAt Method
IAxisValueConverter Interface See Also Send Feedback
Gets the data object corresponding to a logical axis position.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
Object GetDataObjectAt(
    double axisPosition
)
Visual Basic
Function GetDataObjectAt ( _
    axisPosition As Double _
) As Object
Visual C++
Object^ GetDataObjectAt(
    double axisPosition
)

Parameters

axisPosition
Type: System..::..Double
The logical axis position.

Return Value

The object represented on the axis at that position.

See Also

IAxisValueConverter Interface


Legend Class

[image]

Mindscape Phone Elements
Legend Class
Members See Also Send Feedback
Displays the title of each data series plotted on a Chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Legend : HeaderedItemsControl
Visual Basic
Public Class Legend _
    Inherits HeaderedItemsControl
Visual C++
public ref class Legend : public HeaderedItemsControl

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ItemsControl
Mindscape.PhoneElements..::..HeaderedItemsControl
Mindscape.PhoneElements.Charting..::..Legend

See Also

Legend Members


Legend Members

[image] [image]

Mindscape Phone Elements
Legend Members
Legend Class Constructors Methods Fields Properties Events See Also Send Feedback

The Legend type exposes the following members.

Constructors

 | Name | Description
Public method | Legend | Initializes a new instance of the Legend class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
LegendPositionProperty | Identifies the LegendPosition property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendPosition | Gets or sets the position of the Legend. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Legend Class


Legend Constructor

[image]

Mindscape Phone Elements
Legend Constructor
Legend Class See Also Send Feedback
Initializes a new instance of the Legend class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Legend()
Visual Basic
Public Sub New
Visual C++
public:
Legend()

See Also

Legend Class


Legend Fields

[image] [image]

Mindscape Phone Elements
Legend Fields
Legend Class See Also Send Feedback

The Legend type exposes the following members.

Fields

Name | Description
LegendPositionProperty | Identifies the LegendPosition property.

See Also

Legend Class


LegendPositionProperty Field

[image]

Mindscape Phone Elements
Legend..::..LegendPositionProperty Field
Legend Class See Also Send Feedback
Identifies the LegendPosition property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LegendPositionProperty
Visual Basic
Public Shared ReadOnly LegendPositionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LegendPositionProperty

See Also

Legend Class


Legend Methods

[image] [image]

Mindscape Phone Elements
Legend Methods
Legend Class See Also Send Feedback

The Legend type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Protected method | ClearContainerForItemOverride | When overridden in a derived class, undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Inherited from ItemsControl.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Inherited from ItemsControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Protected method | IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Inherited from ItemsControl.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnItemsChanged | Invoked when the Items property changes. (Inherited from ItemsControl.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from ItemsControl.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

Legend Class


Legend Properties

[image] [image]

Mindscape Phone Elements
Legend Properties
Legend Class See Also Send Feedback

The Legend type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayMemberPath | Gets or sets a path to a value on the source object to serve as the visual representation of the object. This is a dependency property. (Inherited from ItemsControl.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Header | Gets or sets the item that labels the control. This is a dependency property. (Inherited from HeaderedItemsControl.)
Public property | HeaderTemplate | Gets or sets the DataTemplate used to display the contents of the control's header. This is a dependency property. (Inherited from HeaderedItemsControl.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemContainerGenerator | Gets the ItemContainerGenerator that is associated with the control. (Inherited from ItemsControl.)
Public property | Items | Gets the collection used to generate the content of the ItemsControl. (Inherited from ItemsControl.)
Public property | ItemsPanel | Gets or sets the template that defines the panel that controls the layout of items. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemsSource | Gets or sets a collection used to generate the content of the ItemsControl. This is a dependency property. (Inherited from ItemsControl.)
Public property | ItemTemplate | Gets or sets the DataTemplate used to display each item. This is a dependency property. (Inherited from ItemsControl.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendPosition | Gets or sets the position of the Legend. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

Legend Class


LegendPosition Property

[image]

Mindscape Phone Elements
Legend..::..LegendPosition Property
Legend Class See Also Send Feedback
Gets or sets the position of the Legend. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendPosition LegendPosition { get; set; }
Visual Basic
Public Property LegendPosition As LegendPosition
    Get
    Set
Visual C++
public:
property LegendPosition LegendPosition {
    LegendPosition get ();
    void set (LegendPosition value);
}

See Also

Legend Class


Legend Events

[image] [image]

Mindscape Phone Elements
Legend Events
Legend Class See Also Send Feedback

The Legend type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

Legend Class


LegendItem Class

[image]

Mindscape Phone Elements
LegendItem Class
Members See Also Send Feedback
Represents an item to be displayed in a legend.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendItem
Visual Basic
Public Class LegendItem
Visual C++
public ref class LegendItem

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendItem

See Also

LegendItem Members


LegendItem Members

[image] [image]

Mindscape Phone Elements
LegendItem Members
LegendItem Class Methods Properties See Also Send Feedback

The LegendItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataSeries | Gets the DataSeries that created the LegendItem.
Public property | LegendIconBrush | Gets the Brush used to color the legend icon.
Public property | LegendIconTemplate | Gets the DataTemplate used to display the legend icon.
Public property | LegendLabel | Gets the text to be displayed by the LegendItem.

See Also

LegendItem Class


LegendItem Methods

[image] [image]

Mindscape Phone Elements
LegendItem Methods
LegendItem Class See Also Send Feedback

The LegendItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItem Class


LegendItem Properties

[image] [image]

Mindscape Phone Elements
LegendItem Properties
LegendItem Class See Also Send Feedback

The LegendItem type exposes the following members.

Properties

 | Name | Description
Public property | DataSeries | Gets the DataSeries that created the LegendItem.
Public property | LegendIconBrush | Gets the Brush used to color the legend icon.
Public property | LegendIconTemplate | Gets the DataTemplate used to display the legend icon.
Public property | LegendLabel | Gets the text to be displayed by the LegendItem.

See Also

LegendItem Class


DataSeries Property

[image]

Mindscape Phone Elements
LegendItem..::..DataSeries Property
LegendItem Class See Also Send Feedback
Gets the DataSeries that created the LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataSeries DataSeries { get; private set; }
Visual Basic
Public Property DataSeries As DataSeries
    Get
    Private Set
Visual C++
public:
property DataSeries^ DataSeries {
    DataSeries^ get ();
    private: void set (DataSeries^ value);
}

See Also

LegendItem Class


LegendIconBrush Property

[image]

Mindscape Phone Elements
LegendItem..::..LegendIconBrush Property
LegendItem Class See Also Send Feedback
Gets the Brush used to color the legend icon.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush LegendIconBrush { get; private set; }
Visual Basic
Public Property LegendIconBrush As Brush
    Get
    Private Set
Visual C++
public:
property Brush^ LegendIconBrush {
    Brush^ get ();
    private: void set (Brush^ value);
}

See Also

LegendItem Class


LegendIconTemplate Property

[image]

Mindscape Phone Elements
LegendItem..::..LegendIconTemplate Property
LegendItem Class See Also Send Feedback
Gets the DataTemplate used to display the legend icon.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate LegendIconTemplate { get; private set; }
Visual Basic
Public Property LegendIconTemplate As DataTemplate
    Get
    Private Set
Visual C++
public:
property DataTemplate^ LegendIconTemplate {
    DataTemplate^ get ();
    private: void set (DataTemplate^ value);
}

See Also

LegendItem Class


LegendLabel Property

[image]

Mindscape Phone Elements
LegendItem..::..LegendLabel Property
LegendItem Class See Also Send Feedback
Gets the text to be displayed by the LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LegendLabel { get; private set; }
Visual Basic
Public Property LegendLabel As String
    Get
    Private Set
Visual C++
public:
property String^ LegendLabel {
    String^ get ();
    private: void set (String^ value);
}

See Also

LegendItem Class


LegendItemToAreaBackgroundConverter Class

[image]

Mindscape Phone Elements
LegendItemToAreaBackgroundConverter Class
Members See Also Send Feedback
Determines the background brush to be applied to an area for a given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendItemToAreaBackgroundConverter : IValueConverter
Visual Basic
Public Class LegendItemToAreaBackgroundConverter _
    Implements IValueConverter
Visual C++
public ref class LegendItemToAreaBackgroundConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendItemToAreaBackgroundConverter

See Also

LegendItemToAreaBackgroundConverter Members


LegendItemToAreaBackgroundConverter Members

[image] [image]

Mindscape Phone Elements
LegendItemToAreaBackgroundConverter Members
LegendItemToAreaBackgroundConverter Class Constructors Methods See Also Send Feedback

The LegendItemToAreaBackgroundConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendItemToAreaBackgroundConverter | Initializes a new instance of the LegendItemToAreaBackgroundConverter class

Methods

 | Name | Description
Public method | Convert | Returns a background brush to apply to an area for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToAreaBackgroundConverter Class


LegendItemToAreaBackgroundConverter Constructor

[image]

Mindscape Phone Elements
LegendItemToAreaBackgroundConverter Constructor
LegendItemToAreaBackgroundConverter Class See Also Send Feedback
Initializes a new instance of the LegendItemToAreaBackgroundConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendItemToAreaBackgroundConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendItemToAreaBackgroundConverter()

See Also

LegendItemToAreaBackgroundConverter Class


LegendItemToAreaBackgroundConverter Methods

[image] [image]

Mindscape Phone Elements
LegendItemToAreaBackgroundConverter Methods
LegendItemToAreaBackgroundConverter Class See Also Send Feedback

The LegendItemToAreaBackgroundConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a background brush to apply to an area for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToAreaBackgroundConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendItemToAreaBackgroundConverter..::..Convert Method
LegendItemToAreaBackgroundConverter Class See Also Send Feedback
Returns a background brush to apply to an area for the given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The LegendItem object produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The background brush.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendItemToAreaBackgroundConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendItemToAreaBackgroundConverter..::..ConvertBack Method
LegendItemToAreaBackgroundConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendItemToAreaBackgroundConverter Class


LegendItemToAreaChartSymbolMarginConverter Class

[image]

Mindscape Phone Elements
LegendItemToAreaChartSymbolMarginConverter Class
Members See Also Send Feedback
Returns the margin to be used on the chart symbol for a given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendItemToAreaChartSymbolMarginConverter : IValueConverter
Visual Basic
Public Class LegendItemToAreaChartSymbolMarginConverter _
    Implements IValueConverter
Visual C++
public ref class LegendItemToAreaChartSymbolMarginConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendItemToAreaChartSymbolMarginConverter

See Also

LegendItemToAreaChartSymbolMarginConverter Members


LegendItemToAreaChartSymbolMarginConverter Members

[image] [image]

Mindscape Phone Elements
LegendItemToAreaChartSymbolMarginConverter Members
LegendItemToAreaChartSymbolMarginConverter Class Constructors Methods See Also Send Feedback

The LegendItemToAreaChartSymbolMarginConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendItemToAreaChartSymbolMarginConverter | Initializes a new instance of the LegendItemToAreaChartSymbolMarginConverter class

Methods

 | Name | Description
Public method | Convert | Returns a Thickness to be used on the chart symbol for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToAreaChartSymbolMarginConverter Class


LegendItemToAreaChartSymbolMarginConverter Constructor

[image]

Mindscape Phone Elements
LegendItemToAreaChartSymbolMarginConverter Constructor
LegendItemToAreaChartSymbolMarginConverter Class See Also Send Feedback
Initializes a new instance of the LegendItemToAreaChartSymbolMarginConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendItemToAreaChartSymbolMarginConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendItemToAreaChartSymbolMarginConverter()

See Also

LegendItemToAreaChartSymbolMarginConverter Class


LegendItemToAreaChartSymbolMarginConverter Methods

[image] [image]

Mindscape Phone Elements
LegendItemToAreaChartSymbolMarginConverter Methods
LegendItemToAreaChartSymbolMarginConverter Class See Also Send Feedback

The LegendItemToAreaChartSymbolMarginConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a Thickness to be used on the chart symbol for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToAreaChartSymbolMarginConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendItemToAreaChartSymbolMarginConverter..::..Convert Method
LegendItemToAreaChartSymbolMarginConverter Class See Also Send Feedback
Returns a Thickness to be used on the chart symbol for the given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The Thickness value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The Thickness for the chart symbol.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendItemToAreaChartSymbolMarginConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendItemToAreaChartSymbolMarginConverter..::..ConvertBack Method
LegendItemToAreaChartSymbolMarginConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendItemToAreaChartSymbolMarginConverter Class


LegendItemToChartSymbolBackgroundConverter Class

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBackgroundConverter Class
Members See Also Send Feedback
Determines the background brush to be applied to a chart symbol for a given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendItemToChartSymbolBackgroundConverter : IValueConverter
Visual Basic
Public Class LegendItemToChartSymbolBackgroundConverter _
    Implements IValueConverter
Visual C++
public ref class LegendItemToChartSymbolBackgroundConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendItemToChartSymbolBackgroundConverter

See Also

LegendItemToChartSymbolBackgroundConverter Members


LegendItemToChartSymbolBackgroundConverter Members

[image] [image]

Mindscape Phone Elements
LegendItemToChartSymbolBackgroundConverter Members
LegendItemToChartSymbolBackgroundConverter Class Constructors Methods See Also Send Feedback

The LegendItemToChartSymbolBackgroundConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendItemToChartSymbolBackgroundConverter | Initializes a new instance of the LegendItemToChartSymbolBackgroundConverter class

Methods

 | Name | Description
Public method | Convert | Returns a background brush for a chart symbol for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToChartSymbolBackgroundConverter Class


LegendItemToChartSymbolBackgroundConverter Constructor

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBackgroundConverter Constructor
LegendItemToChartSymbolBackgroundConverter Class See Also Send Feedback
Initializes a new instance of the LegendItemToChartSymbolBackgroundConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendItemToChartSymbolBackgroundConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendItemToChartSymbolBackgroundConverter()

See Also

LegendItemToChartSymbolBackgroundConverter Class


LegendItemToChartSymbolBackgroundConverter Methods

[image] [image]

Mindscape Phone Elements
LegendItemToChartSymbolBackgroundConverter Methods
LegendItemToChartSymbolBackgroundConverter Class See Also Send Feedback

The LegendItemToChartSymbolBackgroundConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a background brush for a chart symbol for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToChartSymbolBackgroundConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBackgroundConverter..::..Convert Method
LegendItemToChartSymbolBackgroundConverter Class See Also Send Feedback
Returns a background brush for a chart symbol for the given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The LegendItem object produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The background brush.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendItemToChartSymbolBackgroundConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBackgroundConverter..::..ConvertBack Method
LegendItemToChartSymbolBackgroundConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendItemToChartSymbolBackgroundConverter Class


LegendItemToChartSymbolBorderBrushConverter Class

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBorderBrushConverter Class
Members See Also Send Feedback
Determines the border brush to be applied to a chart symbol for a given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendItemToChartSymbolBorderBrushConverter : IValueConverter
Visual Basic
Public Class LegendItemToChartSymbolBorderBrushConverter _
    Implements IValueConverter
Visual C++
public ref class LegendItemToChartSymbolBorderBrushConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendItemToChartSymbolBorderBrushConverter

See Also

LegendItemToChartSymbolBorderBrushConverter Members


LegendItemToChartSymbolBorderBrushConverter Members

[image] [image]

Mindscape Phone Elements
LegendItemToChartSymbolBorderBrushConverter Members
LegendItemToChartSymbolBorderBrushConverter Class Constructors Methods See Also Send Feedback

The LegendItemToChartSymbolBorderBrushConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendItemToChartSymbolBorderBrushConverter | Initializes a new instance of the LegendItemToChartSymbolBorderBrushConverter class

Methods

 | Name | Description
Public method | Convert | Returns a border brush for a chart symbol for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToChartSymbolBorderBrushConverter Class


LegendItemToChartSymbolBorderBrushConverter Constructor

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBorderBrushConverter Constructor
LegendItemToChartSymbolBorderBrushConverter Class See Also Send Feedback
Initializes a new instance of the LegendItemToChartSymbolBorderBrushConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendItemToChartSymbolBorderBrushConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendItemToChartSymbolBorderBrushConverter()

See Also

LegendItemToChartSymbolBorderBrushConverter Class


LegendItemToChartSymbolBorderBrushConverter Methods

[image] [image]

Mindscape Phone Elements
LegendItemToChartSymbolBorderBrushConverter Methods
LegendItemToChartSymbolBorderBrushConverter Class See Also Send Feedback

The LegendItemToChartSymbolBorderBrushConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a border brush for a chart symbol for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToChartSymbolBorderBrushConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBorderBrushConverter..::..Convert Method
LegendItemToChartSymbolBorderBrushConverter Class See Also Send Feedback
Returns a border brush for a chart symbol for the given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The LegendItem object produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The border brush.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendItemToChartSymbolBorderBrushConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendItemToChartSymbolBorderBrushConverter..::..ConvertBack Method
LegendItemToChartSymbolBorderBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendItemToChartSymbolBorderBrushConverter Class


LegendItemToDashArrayConverter Class

[image]

Mindscape Phone Elements
LegendItemToDashArrayConverter Class
Members See Also Send Feedback
Returns a dash array to be used in the given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendItemToDashArrayConverter : IValueConverter
Visual Basic
Public Class LegendItemToDashArrayConverter _
    Implements IValueConverter
Visual C++
public ref class LegendItemToDashArrayConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendItemToDashArrayConverter

See Also

LegendItemToDashArrayConverter Members


LegendItemToDashArrayConverter Members

[image] [image]

Mindscape Phone Elements
LegendItemToDashArrayConverter Members
LegendItemToDashArrayConverter Class Constructors Methods See Also Send Feedback

The LegendItemToDashArrayConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendItemToDashArrayConverter | Initializes a new instance of the LegendItemToDashArrayConverter class

Methods

 | Name | Description
Public method | Convert | Returns a dash array for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToDashArrayConverter Class


LegendItemToDashArrayConverter Constructor

[image]

Mindscape Phone Elements
LegendItemToDashArrayConverter Constructor
LegendItemToDashArrayConverter Class See Also Send Feedback
Initializes a new instance of the LegendItemToDashArrayConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendItemToDashArrayConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendItemToDashArrayConverter()

See Also

LegendItemToDashArrayConverter Class


LegendItemToDashArrayConverter Methods

[image] [image]

Mindscape Phone Elements
LegendItemToDashArrayConverter Methods
LegendItemToDashArrayConverter Class See Also Send Feedback

The LegendItemToDashArrayConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a dash array for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToDashArrayConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendItemToDashArrayConverter..::..Convert Method
LegendItemToDashArrayConverter Class See Also Send Feedback
Returns a dash array for the given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The LegendItem object produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The dash array.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendItemToDashArrayConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendItemToDashArrayConverter..::..ConvertBack Method
LegendItemToDashArrayConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendItemToDashArrayConverter Class


LegendItemToLineStrokeConverter Class

[image]

Mindscape Phone Elements
LegendItemToLineStrokeConverter Class
Members See Also Send Feedback
Determines the stroke brush to be applied to a path for a given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendItemToLineStrokeConverter : IValueConverter
Visual Basic
Public Class LegendItemToLineStrokeConverter _
    Implements IValueConverter
Visual C++
public ref class LegendItemToLineStrokeConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendItemToLineStrokeConverter

See Also

LegendItemToLineStrokeConverter Members


LegendItemToLineStrokeConverter Members

[image] [image]

Mindscape Phone Elements
LegendItemToLineStrokeConverter Members
LegendItemToLineStrokeConverter Class Constructors Methods See Also Send Feedback

The LegendItemToLineStrokeConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendItemToLineStrokeConverter | Initializes a new instance of the LegendItemToLineStrokeConverter class

Methods

 | Name | Description
Public method | Convert | Returns a line stroke to be applied to a path for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToLineStrokeConverter Class


LegendItemToLineStrokeConverter Constructor

[image]

Mindscape Phone Elements
LegendItemToLineStrokeConverter Constructor
LegendItemToLineStrokeConverter Class See Also Send Feedback
Initializes a new instance of the LegendItemToLineStrokeConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendItemToLineStrokeConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendItemToLineStrokeConverter()

See Also

LegendItemToLineStrokeConverter Class


LegendItemToLineStrokeConverter Methods

[image] [image]

Mindscape Phone Elements
LegendItemToLineStrokeConverter Methods
LegendItemToLineStrokeConverter Class See Also Send Feedback

The LegendItemToLineStrokeConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a line stroke to be applied to a path for the given LegendItem.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemToLineStrokeConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendItemToLineStrokeConverter..::..Convert Method
LegendItemToLineStrokeConverter Class See Also Send Feedback
Returns a line stroke to be applied to a path for the given LegendItem.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The LegendItem object produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The line stroke.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendItemToLineStrokeConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendItemToLineStrokeConverter..::..ConvertBack Method
LegendItemToLineStrokeConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendItemToLineStrokeConverter Class


LegendPosition Enumeration

[image]

Mindscape Phone Elements
LegendPosition Enumeration
See Also Send Feedback
Specifies the location on a Chart where the legend is displayed.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum LegendPosition
Visual Basic
Public Enumeration LegendPosition
Visual C++
public enum class LegendPosition

Members

Member name | Value | Description
Left | 0 | The legend is placed to the left of the charting area.
Right | 1 | The legend is placed to the right of the charting area.
Top | 2 | The legend is placed above the charting area.
Bottom | 3 | The legend is placed below the charting area.
Center | 4 | The legend is placed within the charting area (though typically not centered on the chart itself).
None | 5 | The legend is invisible.

See Also


LegendPositionToIntegerConverter Class

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter Class
Members See Also Send Feedback
Converts a LegendPosition into an integer value. This is typically used in custom templates for the Chart and PieChart controls when laying out the elements using a grid.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendPositionToIntegerConverter : IValueConverter
Visual Basic
Public Class LegendPositionToIntegerConverter _
    Implements IValueConverter
Visual C++
public ref class LegendPositionToIntegerConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendPositionToIntegerConverter

See Also

LegendPositionToIntegerConverter Members


LegendPositionToIntegerConverter Members

[image] [image]

Mindscape Phone Elements
LegendPositionToIntegerConverter Members
LegendPositionToIntegerConverter Class Constructors Methods Properties See Also Send Feedback

The LegendPositionToIntegerConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendPositionToIntegerConverter | Initializes a new instance of the LegendPositionToIntegerConverter class

Methods

 | Name | Description
Public method | Convert | Returns an integer based on the given LegendPosition.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BottomInteger | Gets or sets the integer to be returned if the LegendPosition is Bottom.
Public property | CenterInteger | Gets or sets the integer to be returned if the LegendPosition is Center.
Public property | LeftInteger | Gets or sets the integer to be returned if the LegendPosition is Left.
Public property | NoneInteger | Gets or sets the integer to be returned if the LegendPosition is None.
Public property | RightInteger | Gets or sets the integer to be returned if the LegendPosition is Right.
Public property | TopInteger | Gets or sets the integer to be returned if the LegendPosition is Top.

See Also

LegendPositionToIntegerConverter Class


LegendPositionToIntegerConverter Constructor

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter Constructor
LegendPositionToIntegerConverter Class See Also Send Feedback
Initializes a new instance of the LegendPositionToIntegerConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendPositionToIntegerConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendPositionToIntegerConverter()

See Also

LegendPositionToIntegerConverter Class


LegendPositionToIntegerConverter Methods

[image] [image]

Mindscape Phone Elements
LegendPositionToIntegerConverter Methods
LegendPositionToIntegerConverter Class See Also Send Feedback

The LegendPositionToIntegerConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns an integer based on the given LegendPosition.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendPositionToIntegerConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..Convert Method
LegendPositionToIntegerConverter Class See Also Send Feedback
Returns an integer based on the given LegendPosition.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The LegendPosition value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

An integer based on the given LegendPosition.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendPositionToIntegerConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..ConvertBack Method
LegendPositionToIntegerConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendPositionToIntegerConverter Class


LegendPositionToIntegerConverter Properties

[image] [image]

Mindscape Phone Elements
LegendPositionToIntegerConverter Properties
LegendPositionToIntegerConverter Class See Also Send Feedback

The LegendPositionToIntegerConverter type exposes the following members.

Properties

 | Name | Description
Public property | BottomInteger | Gets or sets the integer to be returned if the LegendPosition is Bottom.
Public property | CenterInteger | Gets or sets the integer to be returned if the LegendPosition is Center.
Public property | LeftInteger | Gets or sets the integer to be returned if the LegendPosition is Left.
Public property | NoneInteger | Gets or sets the integer to be returned if the LegendPosition is None.
Public property | RightInteger | Gets or sets the integer to be returned if the LegendPosition is Right.
Public property | TopInteger | Gets or sets the integer to be returned if the LegendPosition is Top.

See Also

LegendPositionToIntegerConverter Class


BottomInteger Property

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..BottomInteger Property
LegendPositionToIntegerConverter Class See Also Send Feedback
Gets or sets the integer to be returned if the LegendPosition is Bottom.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int BottomInteger { get; set; }
Visual Basic
Public Property BottomInteger As Integer
    Get
    Set
Visual C++
public:
property int BottomInteger {
    int get ();
    void set (int value);
}

See Also

LegendPositionToIntegerConverter Class


CenterInteger Property

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..CenterInteger Property
LegendPositionToIntegerConverter Class See Also Send Feedback
Gets or sets the integer to be returned if the LegendPosition is Center.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CenterInteger { get; set; }
Visual Basic
Public Property CenterInteger As Integer
    Get
    Set
Visual C++
public:
property int CenterInteger {
    int get ();
    void set (int value);
}

See Also

LegendPositionToIntegerConverter Class


LeftInteger Property

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..LeftInteger Property
LegendPositionToIntegerConverter Class See Also Send Feedback
Gets or sets the integer to be returned if the LegendPosition is Left.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LeftInteger { get; set; }
Visual Basic
Public Property LeftInteger As Integer
    Get
    Set
Visual C++
public:
property int LeftInteger {
    int get ();
    void set (int value);
}

See Also

LegendPositionToIntegerConverter Class


NoneInteger Property

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..NoneInteger Property
LegendPositionToIntegerConverter Class See Also Send Feedback
Gets or sets the integer to be returned if the LegendPosition is None.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int NoneInteger { get; set; }
Visual Basic
Public Property NoneInteger As Integer
    Get
    Set
Visual C++
public:
property int NoneInteger {
    int get ();
    void set (int value);
}

See Also

LegendPositionToIntegerConverter Class


RightInteger Property

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..RightInteger Property
LegendPositionToIntegerConverter Class See Also Send Feedback
Gets or sets the integer to be returned if the LegendPosition is Right.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int RightInteger { get; set; }
Visual Basic
Public Property RightInteger As Integer
    Get
    Set
Visual C++
public:
property int RightInteger {
    int get ();
    void set (int value);
}

See Also

LegendPositionToIntegerConverter Class


TopInteger Property

[image]

Mindscape Phone Elements
LegendPositionToIntegerConverter..::..TopInteger Property
LegendPositionToIntegerConverter Class See Also Send Feedback
Gets or sets the integer to be returned if the LegendPosition is Top.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TopInteger { get; set; }
Visual Basic
Public Property TopInteger As Integer
    Get
    Set
Visual C++
public:
property int TopInteger {
    int get ();
    void set (int value);
}

See Also

LegendPositionToIntegerConverter Class


LegendPositionToVisibilityConverter Class

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter Class
Members See Also Send Feedback
Converts a LegendPosition into a Visibility.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LegendPositionToVisibilityConverter : IValueConverter
Visual Basic
Public Class LegendPositionToVisibilityConverter _
    Implements IValueConverter
Visual C++
public ref class LegendPositionToVisibilityConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LegendPositionToVisibilityConverter

See Also

LegendPositionToVisibilityConverter Members


LegendPositionToVisibilityConverter Members

[image] [image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter Members
LegendPositionToVisibilityConverter Class Constructors Methods Properties See Also Send Feedback

The LegendPositionToVisibilityConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LegendPositionToVisibilityConverter | Initializes a new instance of the LegendPositionToVisibilityConverter class.

Methods

 | Name | Description
Public method | Convert | Returns a Visibility based on the given LegendPosition.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BottomVisibility | Gets or sets the Visibility to return if the LegendPosition is Bottom.
Public property | CenterVisibility | Gets or sets the Visibility to return if the LegendPosition is Center.
Public property | LeftVisibility | Gets or sets the Visibility to return if the LegendPosition is Left.
Public property | NoneVisibility | Gets or sets the Visibility to return if the LegendPosition is None.
Public property | RightVisibility | Gets or sets the Visibility to return if the LegendPosition is Right.
Public property | TopVisibility | Gets or sets the Visibility to return if the LegendPosition is Top.

See Also

LegendPositionToVisibilityConverter Class


LegendPositionToVisibilityConverter Constructor

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter Constructor
LegendPositionToVisibilityConverter Class See Also Send Feedback
Initializes a new instance of the LegendPositionToVisibilityConverter class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendPositionToVisibilityConverter()
Visual Basic
Public Sub New
Visual C++
public:
LegendPositionToVisibilityConverter()

See Also

LegendPositionToVisibilityConverter Class


LegendPositionToVisibilityConverter Methods

[image] [image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter Methods
LegendPositionToVisibilityConverter Class See Also Send Feedback

The LegendPositionToVisibilityConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Returns a Visibility based on the given LegendPosition.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendPositionToVisibilityConverter Class


Convert Method

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..Convert Method
LegendPositionToVisibilityConverter Class See Also Send Feedback
Returns a Visibility based on the given LegendPosition.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The LegendPosition value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

A Visibility based on the given LegendPosition.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

LegendPositionToVisibilityConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..ConvertBack Method
LegendPositionToVisibilityConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

LegendPositionToVisibilityConverter Class


LegendPositionToVisibilityConverter Properties

[image] [image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter Properties
LegendPositionToVisibilityConverter Class See Also Send Feedback

The LegendPositionToVisibilityConverter type exposes the following members.

Properties

 | Name | Description
Public property | BottomVisibility | Gets or sets the Visibility to return if the LegendPosition is Bottom.
Public property | CenterVisibility | Gets or sets the Visibility to return if the LegendPosition is Center.
Public property | LeftVisibility | Gets or sets the Visibility to return if the LegendPosition is Left.
Public property | NoneVisibility | Gets or sets the Visibility to return if the LegendPosition is None.
Public property | RightVisibility | Gets or sets the Visibility to return if the LegendPosition is Right.
Public property | TopVisibility | Gets or sets the Visibility to return if the LegendPosition is Top.

See Also

LegendPositionToVisibilityConverter Class


BottomVisibility Property

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..BottomVisibility Property
LegendPositionToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to return if the LegendPosition is Bottom.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility BottomVisibility { get; set; }
Visual Basic
Public Property BottomVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility BottomVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

LegendPositionToVisibilityConverter Class


CenterVisibility Property

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..CenterVisibility Property
LegendPositionToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to return if the LegendPosition is Center.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility CenterVisibility { get; set; }
Visual Basic
Public Property CenterVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility CenterVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

LegendPositionToVisibilityConverter Class


LeftVisibility Property

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..LeftVisibility Property
LegendPositionToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to return if the LegendPosition is Left.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility LeftVisibility { get; set; }
Visual Basic
Public Property LeftVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility LeftVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

LegendPositionToVisibilityConverter Class


NoneVisibility Property

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..NoneVisibility Property
LegendPositionToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to return if the LegendPosition is None.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility NoneVisibility { get; set; }
Visual Basic
Public Property NoneVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility NoneVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

LegendPositionToVisibilityConverter Class


RightVisibility Property

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..RightVisibility Property
LegendPositionToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to return if the LegendPosition is Right.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility RightVisibility { get; set; }
Visual Basic
Public Property RightVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility RightVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

LegendPositionToVisibilityConverter Class


TopVisibility Property

[image]

Mindscape Phone Elements
LegendPositionToVisibilityConverter..::..TopVisibility Property
LegendPositionToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to return if the LegendPosition is Top.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility TopVisibility { get; set; }
Visual Basic
Public Property TopVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility TopVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

LegendPositionToVisibilityConverter Class


LineAreaSeriesBase Class

[image]

Mindscape Phone Elements
LineAreaSeriesBase Class
Members See Also Send Feedback
A base class for DataSeries that use lines to plot data, such as LineSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class LineAreaSeriesBase : PointSeriesBase
Visual Basic
Public MustInherit Class LineAreaSeriesBase _
    Inherits PointSeriesBase
Visual C++
public ref class LineAreaSeriesBase abstract : public PointSeriesBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..AreaSeries
Mindscape.PhoneElements.Charting..::..LineSeries
Mindscape.PhoneElements.Charting..::..SplineSeries
Mindscape.PhoneElements.Charting..::..StackedLineSeries
Mindscape.PhoneElements.Charting..::..StackedSplineSeries

See Also

LineAreaSeriesBase Members


LineAreaSeriesBase Members

[image] [image]

Mindscape Phone Elements
LineAreaSeriesBase Members
LineAreaSeriesBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The LineAreaSeriesBase type exposes the following members.

Constructors

 | Name | Description
Protected method | LineAreaSeriesBase | Initializes a new instance of the LineAreaSeriesBase class

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the DataSeries on the chart canvas. (Inherited from DataSeries.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
DashArrayProperty | Identifies the DashArray property.
LineStyleProperty | Identifies the LineStyle property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property.
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Overrides DataSeries..::..SupportsDataSampling.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LineAreaSeriesBase Class


LineAreaSeriesBase Constructor

[image]

Mindscape Phone Elements
LineAreaSeriesBase Constructor
LineAreaSeriesBase Class See Also Send Feedback
Initializes a new instance of the LineAreaSeriesBase class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected LineAreaSeriesBase()
Visual Basic
Protected Sub New
Visual C++
protected:
LineAreaSeriesBase()

See Also

LineAreaSeriesBase Class


LineAreaSeriesBase Fields

[image] [image]

Mindscape Phone Elements
LineAreaSeriesBase Fields
LineAreaSeriesBase Class See Also Send Feedback

The LineAreaSeriesBase type exposes the following members.

Fields

Name | Description
DashArrayProperty | Identifies the DashArray property.
LineStyleProperty | Identifies the LineStyle property.

See Also

LineAreaSeriesBase Class


DashArrayProperty Field

[image]

Mindscape Phone Elements
LineAreaSeriesBase..::..DashArrayProperty Field
LineAreaSeriesBase Class See Also Send Feedback
Identifies the DashArray property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DashArrayProperty
Visual Basic
Public Shared ReadOnly DashArrayProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DashArrayProperty

See Also

LineAreaSeriesBase Class


LineStyleProperty Field

[image]

Mindscape Phone Elements
LineAreaSeriesBase..::..LineStyleProperty Field
LineAreaSeriesBase Class See Also Send Feedback
Identifies the LineStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LineStyleProperty
Visual Basic
Public Shared ReadOnly LineStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LineStyleProperty

See Also

LineAreaSeriesBase Class


LineAreaSeriesBase Methods

[image] [image]

Mindscape Phone Elements
LineAreaSeriesBase Methods
LineAreaSeriesBase Class See Also Send Feedback

The LineAreaSeriesBase type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the DataSeries on the chart canvas. (Inherited from DataSeries.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data.
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

LineAreaSeriesBase Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
LineAreaSeriesBase..::..AddDataLabel Method
LineAreaSeriesBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

LineAreaSeriesBase Class
LineAreaSeriesBase Members


GetPoint Method

[image] [image]

Mindscape Phone Elements
LineAreaSeriesBase..::..GetPoint Method
LineAreaSeriesBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

LineAreaSeriesBase Class
LineAreaSeriesBase Members


GetY Method

[image]

Mindscape Phone Elements
LineAreaSeriesBase..::..GetY Method
LineAreaSeriesBase Class See Also Send Feedback
Returns the logical Y axis value for the given X axis value limited to the currently plotted data.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual double GetY(
    double x
)
Visual Basic
Public Overridable Function GetY ( _
    x As Double _
) As Double
Visual C++
public:
virtual double GetY(
    double x
)

Parameters

x
Type: System..::..Double
The logical X axis value.

Return Value

The logical Y axis value.

See Also

LineAreaSeriesBase Class


LineAreaSeriesBase Properties

[image] [image]

Mindscape Phone Elements
LineAreaSeriesBase Properties
LineAreaSeriesBase Class See Also Send Feedback

The LineAreaSeriesBase type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property.
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Overrides DataSeries..::..SupportsDataSampling.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

LineAreaSeriesBase Class


DashArray Property

[image]

Mindscape Phone Elements
LineAreaSeriesBase..::..DashArray Property
LineAreaSeriesBase Class See Also Send Feedback
Gets or sets the dash array for the line. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DoubleCollection DashArray { get; set; }
Visual Basic
Public Property DashArray As DoubleCollection
    Get
    Set
Visual C++
public:
property DoubleCollection^ DashArray {
    DoubleCollection^ get ();
    void set (DoubleCollection^ value);
}

See Also

LineAreaSeriesBase Class


LineStyle Property

[image]

Mindscape Phone Elements
LineAreaSeriesBase..::..LineStyle Property
LineAreaSeriesBase Class See Also Send Feedback
Gets or sets the style to be applied to the line. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style LineStyle { get; set; }
Visual Basic
Public Property LineStyle As Style
    Get
    Set
Visual C++
public:
property Style^ LineStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

LineAreaSeriesBase Class


SupportsDataSampling Property

[image]

Mindscape Phone Elements
LineAreaSeriesBase..::..SupportsDataSampling Property
LineAreaSeriesBase Class See Also Send Feedback
Gets whether the DataSeries supports sampling for large data sets.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool SupportsDataSampling { get; }
Visual Basic
Public Overrides ReadOnly Property SupportsDataSampling As Boolean
    Get
Visual C++
public:
virtual property bool SupportsDataSampling {
    bool get () override;
}

See Also

LineAreaSeriesBase Class


LineAreaSeriesBase Events

[image] [image]

Mindscape Phone Elements
LineAreaSeriesBase Events
LineAreaSeriesBase Class See Also Send Feedback

The LineAreaSeriesBase type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LineAreaSeriesBase Class


LineSeries Class

[image]

Mindscape Phone Elements
LineSeries Class
Members See Also Send Feedback
Plots a line series on a Chart control. A line series is represented by a sequence of symbols, joined by lines.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LineSeries : LineAreaSeriesBase
Visual Basic
Public Class LineSeries _
    Inherits LineAreaSeriesBase
Visual C++
public ref class LineSeries : public LineAreaSeriesBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..LineSeries

See Also

LineSeries Members


LineSeries Members

[image] [image]

Mindscape Phone Elements
LineSeries Members
LineSeries Class Constructors Methods Properties Events See Also Send Feedback

The LineSeries type exposes the following members.

Constructors

 | Name | Description
Public method | LineSeries | Initializes a new instance of the LineSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the LineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LineSeries Class


LineSeries Constructor

[image]

Mindscape Phone Elements
LineSeries Constructor
LineSeries Class See Also Send Feedback
Initializes a new instance of the LineSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LineSeries()
Visual Basic
Public Sub New
Visual C++
public:
LineSeries()

See Also

LineSeries Class


LineSeries Methods

[image] [image]

Mindscape Phone Elements
LineSeries Methods
LineSeries Class See Also Send Feedback

The LineSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the LineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

LineSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
LineSeries..::..AddDataLabel Method
LineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

LineSeries Class
LineSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
LineSeries..::..BuildChartCore Method
LineSeries Class See Also Send Feedback
Plots the LineSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

LineSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
LineSeries..::..GetPoint Method
LineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

LineSeries Class
LineSeries Members


LineSeries Properties

[image] [image]

Mindscape Phone Elements
LineSeries Properties
LineSeries Class See Also Send Feedback

The LineSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

LineSeries Class


LineSeries Events

[image] [image]

Mindscape Phone Elements
LineSeries Events
LineSeries Class See Also Send Feedback

The LineSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

LineSeries Class


LogarithmicAxisValueConverter Class

[image]

Mindscape Phone Elements
LogarithmicAxisValueConverter Class
Members See Also Send Feedback
Plots data using a logarithmic scale.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LogarithmicAxisValueConverter : IAxisValueConverter
Visual Basic
Public Class LogarithmicAxisValueConverter _
    Implements IAxisValueConverter
Visual C++
public ref class LogarithmicAxisValueConverter : IAxisValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..LogarithmicAxisValueConverter

See Also

LogarithmicAxisValueConverter Members


LogarithmicAxisValueConverter Members

[image] [image]

Mindscape Phone Elements
LogarithmicAxisValueConverter Members
LogarithmicAxisValueConverter Class Constructors Methods Properties See Also Send Feedback

The LogarithmicAxisValueConverter type exposes the following members.

Constructors

 | Name | Description
Public method | LogarithmicAxisValueConverter | Initializes a new instance of the LogarithmicAxisValueConverter class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Gets the logical axis position for a data object.
Public method | GetDataObjectAt | Gets the data object corresponding to a logical axis position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Base | Gets or sets the base of the logarithm scale. The default is 10.

See Also

LogarithmicAxisValueConverter Class


LogarithmicAxisValueConverter Constructor

[image]

Mindscape Phone Elements
LogarithmicAxisValueConverter Constructor
LogarithmicAxisValueConverter Class See Also Send Feedback
Initializes a new instance of the LogarithmicAxisValueConverter class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LogarithmicAxisValueConverter()
Visual Basic
Public Sub New
Visual C++
public:
LogarithmicAxisValueConverter()

See Also

LogarithmicAxisValueConverter Class


LogarithmicAxisValueConverter Methods

[image] [image]

Mindscape Phone Elements
LogarithmicAxisValueConverter Methods
LogarithmicAxisValueConverter Class See Also Send Feedback

The LogarithmicAxisValueConverter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Gets the logical axis position for a data object.
Public method | GetDataObjectAt | Gets the data object corresponding to a logical axis position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogarithmicAxisValueConverter Class


GetAxisPlotPosition Method

[image]

Mindscape Phone Elements
LogarithmicAxisValueConverter..::..GetAxisPlotPosition Method
LogarithmicAxisValueConverter Class See Also Send Feedback
Gets the logical axis position for a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetAxisPlotPosition(
    Object o
)
Visual Basic
Public Function GetAxisPlotPosition ( _
    o As Object _
) As Double
Visual C++
public:
virtual double GetAxisPlotPosition(
    Object^ o
) sealed

Parameters

o
Type: System..::..Object
The data object whose plot position is required.

Return Value

The logical axis position of the given data object.

Implements

IAxisValueConverter..::..GetAxisPlotPosition(Object)

See Also

LogarithmicAxisValueConverter Class


GetDataObjectAt Method

[image]

Mindscape Phone Elements
LogarithmicAxisValueConverter..::..GetDataObjectAt Method
LogarithmicAxisValueConverter Class See Also Send Feedback
Gets the data object corresponding to a logical axis position.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetDataObjectAt(
    double axisPosition
)
Visual Basic
Public Function GetDataObjectAt ( _
    axisPosition As Double _
) As Object
Visual C++
public:
virtual Object^ GetDataObjectAt(
    double axisPosition
) sealed

Parameters

axisPosition
Type: System..::..Double
The logical axis position.

Return Value

The object represented on the axis at that position.

Implements

IAxisValueConverter..::..GetDataObjectAt(Double)

See Also

LogarithmicAxisValueConverter Class


LogarithmicAxisValueConverter Properties

[image] [image]

Mindscape Phone Elements
LogarithmicAxisValueConverter Properties
LogarithmicAxisValueConverter Class See Also Send Feedback

The LogarithmicAxisValueConverter type exposes the following members.

Properties

 | Name | Description
Public property | Base | Gets or sets the base of the logarithm scale. The default is 10.

See Also

LogarithmicAxisValueConverter Class


Base Property

[image]

Mindscape Phone Elements
LogarithmicAxisValueConverter..::..Base Property
LogarithmicAxisValueConverter Class See Also Send Feedback
Gets or sets the base of the logarithm scale. The default is 10.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Base { get; set; }
Visual Basic
Public Property Base As Double
    Get
    Set
Visual C++
public:
property double Base {
    double get ();
    void set (double value);
}

See Also

LogarithmicAxisValueConverter Class


MarkedStripe Class

[image]

Mindscape Phone Elements
MarkedStripe Class
Members See Also Send Feedback
Holds information about rendering colored zones against a ChartAxis in a MarkedStripeGrid.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MarkedStripe
Visual Basic
Public Class MarkedStripe
Visual C++
public ref class MarkedStripe

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..MarkedStripe

See Also

MarkedStripe Members


MarkedStripe Members

[image] [image]

Mindscape Phone Elements
MarkedStripe Members
MarkedStripe Class Constructors Methods Properties See Also Send Feedback

The MarkedStripe type exposes the following members.

Constructors

 | Name | Description
Public method | MarkedStripe | Initializes a new instance of the MarkedStripe class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Background | Gets or sets the background brush of the MarkedStripe.
Public property | Value | Gets or sets the axis value that the MarkedStripe is below.

See Also

MarkedStripe Class


MarkedStripe Constructor

[image]

Mindscape Phone Elements
MarkedStripe Constructor
MarkedStripe Class See Also Send Feedback
Initializes a new instance of the MarkedStripe class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MarkedStripe()
Visual Basic
Public Sub New
Visual C++
public:
MarkedStripe()

See Also

MarkedStripe Class


MarkedStripe Methods

[image] [image]

Mindscape Phone Elements
MarkedStripe Methods
MarkedStripe Class See Also Send Feedback

The MarkedStripe type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MarkedStripe Class


MarkedStripe Properties

[image] [image]

Mindscape Phone Elements
MarkedStripe Properties
MarkedStripe Class See Also Send Feedback

The MarkedStripe type exposes the following members.

Properties

 | Name | Description
Public property | Background | Gets or sets the background brush of the MarkedStripe.
Public property | Value | Gets or sets the axis value that the MarkedStripe is below.

See Also

MarkedStripe Class


Background Property

[image]

Mindscape Phone Elements
MarkedStripe..::..Background Property
MarkedStripe Class See Also Send Feedback
Gets or sets the background brush of the MarkedStripe.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

MarkedStripe Class


Value Property

[image]

Mindscape Phone Elements
MarkedStripe..::..Value Property
MarkedStripe Class See Also Send Feedback
Gets or sets the axis value that the MarkedStripe is below.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

MarkedStripe Class


MarkedStripeGrid Class

[image]

Mindscape Phone Elements
MarkedStripeGrid Class
Members See Also Send Feedback
Renders colored axis zones based on a pair of ChartAxis objects.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MarkedStripeGrid : Canvas
Visual Basic
Public Class MarkedStripeGrid _
    Inherits Canvas
Visual C++
public ref class MarkedStripeGrid : public Canvas

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
System.Windows.Controls..::..Canvas
Mindscape.PhoneElements.Charting..::..MarkedStripeGrid

See Also

MarkedStripeGrid Members


MarkedStripeGrid Members

[image] [image]

Mindscape Phone Elements
MarkedStripeGrid Members
MarkedStripeGrid Class Constructors Methods Fields Properties Events See Also Send Feedback

The MarkedStripeGrid type exposes the following members.

Constructors

 | Name | Description
Public method | MarkedStripeGrid | Initializes a new instance of the MarkedStripeGrid class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
XAxisProperty | Identifies the XAxis property.
YAxisProperty | Identifies the YAxis property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. This is a dependency property. (Inherited from Panel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MarkedStripes | Gets the collection of MarkedStripe objects used to render the MarkedStripeGrid.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis. By default, this is the X axis of the containing Chart control. This is a dependency property.
Public property | YAxis | Gets or sets the Y axis. By default, this is the Y axis of the containing Chart control. This is a dependency property.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

MarkedStripeGrid Class


MarkedStripeGrid Constructor

[image]

Mindscape Phone Elements
MarkedStripeGrid Constructor
MarkedStripeGrid Class See Also Send Feedback
Initializes a new instance of the MarkedStripeGrid class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MarkedStripeGrid()
Visual Basic
Public Sub New
Visual C++
public:
MarkedStripeGrid()

See Also

MarkedStripeGrid Class


MarkedStripeGrid Fields

[image] [image]

Mindscape Phone Elements
MarkedStripeGrid Fields
MarkedStripeGrid Class See Also Send Feedback

The MarkedStripeGrid type exposes the following members.

Fields

Name | Description
XAxisProperty | Identifies the XAxis property.
YAxisProperty | Identifies the YAxis property.

See Also

MarkedStripeGrid Class


XAxisProperty Field

[image]

Mindscape Phone Elements
MarkedStripeGrid..::..XAxisProperty Field
MarkedStripeGrid Class See Also Send Feedback
Identifies the XAxis property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty XAxisProperty
Visual Basic
Public Shared ReadOnly XAxisProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ XAxisProperty

See Also

MarkedStripeGrid Class


YAxisProperty Field

[image]

Mindscape Phone Elements
MarkedStripeGrid..::..YAxisProperty Field
MarkedStripeGrid Class See Also Send Feedback
Identifies the YAxis property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty YAxisProperty
Visual Basic
Public Shared ReadOnly YAxisProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ YAxisProperty

See Also

MarkedStripeGrid Class


MarkedStripeGrid Methods

[image] [image]

Mindscape Phone Elements
MarkedStripeGrid Methods
MarkedStripeGrid Class See Also Send Feedback

The MarkedStripeGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | Arranges the content of a Canvas element. (Inherited from Canvas.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | Measures the child elements of a Canvas in anticipation of arranging them during the ArrangeOverride(Size) pass. (Inherited from Canvas.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

MarkedStripeGrid Class


MarkedStripeGrid Properties

[image] [image]

Mindscape Phone Elements
MarkedStripeGrid Properties
MarkedStripeGrid Class See Also Send Feedback

The MarkedStripeGrid type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a Brush that is used to fill the area between the borders of a Panel. This is a dependency property. (Inherited from Panel.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | Gets a UIElementCollection of child elements of this Panel. (Inherited from Panel.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsItemsHost | Gets or sets a value that indicates that this Panel is a container for user interface (UI) items that are generated by an ItemsControl. This is a dependency property. (Inherited from Panel.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MarkedStripes | Gets the collection of MarkedStripe objects used to render the MarkedStripeGrid.
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets or sets the X axis. By default, this is the X axis of the containing Chart control. This is a dependency property.
Public property | YAxis | Gets or sets the Y axis. By default, this is the Y axis of the containing Chart control. This is a dependency property.

See Also

MarkedStripeGrid Class


MarkedStripes Property

[image]

Mindscape Phone Elements
MarkedStripeGrid..::..MarkedStripes Property
MarkedStripeGrid Class See Also Send Feedback
Gets the collection of MarkedStripe objects used to render the MarkedStripeGrid.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Collection<MarkedStripe> MarkedStripes { get; }
Visual Basic
Public ReadOnly Property MarkedStripes As Collection(Of MarkedStripe)
    Get
Visual C++
public:
property Collection<MarkedStripe^>^ MarkedStripes {
    Collection<MarkedStripe^>^ get ();
}

See Also

MarkedStripeGrid Class


XAxis Property

[image]

Mindscape Phone Elements
MarkedStripeGrid..::..XAxis Property
MarkedStripeGrid Class See Also Send Feedback
Gets or sets the X axis. By default, this is the X axis of the containing Chart control. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartAxis XAxis { get; set; }
Visual Basic
Public Property XAxis As ChartAxis
    Get
    Set
Visual C++
public:
property ChartAxis^ XAxis {
    ChartAxis^ get ();
    void set (ChartAxis^ value);
}

See Also

MarkedStripeGrid Class


YAxis Property

[image]

Mindscape Phone Elements
MarkedStripeGrid..::..YAxis Property
MarkedStripeGrid Class See Also Send Feedback
Gets or sets the Y axis. By default, this is the Y axis of the containing Chart control. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChartAxis YAxis { get; set; }
Visual Basic
Public Property YAxis As ChartAxis
    Get
    Set
Visual C++
public:
property ChartAxis^ YAxis {
    ChartAxis^ get ();
    void set (ChartAxis^ value);
}

See Also

MarkedStripeGrid Class


MarkedStripeGrid Events

[image] [image]

Mindscape Phone Elements
MarkedStripeGrid Events
MarkedStripeGrid Class See Also Send Feedback

The MarkedStripeGrid type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

MarkedStripeGrid Class


MonthAxisLabelConverter Class

[image]

Mindscape Phone Elements
MonthAxisLabelConverter Class
Members See Also Send Feedback
A type of IAxisLabelConverter used to create a month axis scale.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MonthAxisLabelConverter : IAxisLabelConverter
Visual Basic
Public Class MonthAxisLabelConverter _
    Implements IAxisLabelConverter
Visual C++
public ref class MonthAxisLabelConverter : IAxisLabelConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..MonthAxisLabelConverter

See Also

MonthAxisLabelConverter Members


MonthAxisLabelConverter Members

[image] [image]

Mindscape Phone Elements
MonthAxisLabelConverter Members
MonthAxisLabelConverter Class Constructors Methods See Also Send Feedback

The MonthAxisLabelConverter type exposes the following members.

Constructors

 | Name | Description
Public method | MonthAxisLabelConverter | Initializes a new instance of the MonthAxisLabelConverter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Converts the given data object to a logical axis plot position.
Public method | GetDataObjectAt | Converts the given logical axis position to a data object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthAxisLabelConverter Class


MonthAxisLabelConverter Constructor

[image]

Mindscape Phone Elements
MonthAxisLabelConverter Constructor
MonthAxisLabelConverter Class See Also Send Feedback
Initializes a new instance of the MonthAxisLabelConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthAxisLabelConverter()
Visual Basic
Public Sub New
Visual C++
public:
MonthAxisLabelConverter()

See Also

MonthAxisLabelConverter Class


MonthAxisLabelConverter Methods

[image] [image]

Mindscape Phone Elements
MonthAxisLabelConverter Methods
MonthAxisLabelConverter Class See Also Send Feedback

The MonthAxisLabelConverter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Converts the given data object to a logical axis plot position.
Public method | GetDataObjectAt | Converts the given logical axis position to a data object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthAxisLabelConverter Class


GetAxisPlotPosition Method

[image]

Mindscape Phone Elements
MonthAxisLabelConverter..::..GetAxisPlotPosition Method
MonthAxisLabelConverter Class See Also Send Feedback
Converts the given data object to a logical axis plot position.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetAxisPlotPosition(
    Object o
)
Visual Basic
Public Function GetAxisPlotPosition ( _
    o As Object _
) As Double
Visual C++
public:
virtual double GetAxisPlotPosition(
    Object^ o
) sealed

Parameters

o
Type: System..::..Object
The data object to convert.

Return Value

The logical axis position of the given data object.

Implements

IAxisLabelConverter..::..GetAxisPlotPosition(Object)

See Also

MonthAxisLabelConverter Class


GetDataObjectAt Method

[image]

Mindscape Phone Elements
MonthAxisLabelConverter..::..GetDataObjectAt Method
MonthAxisLabelConverter Class See Also Send Feedback
Converts the given logical axis position to a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetDataObjectAt(
    double d
)
Visual Basic
Public Function GetDataObjectAt ( _
    d As Double _
) As Object
Visual C++
public:
virtual Object^ GetDataObjectAt(
    double d
) sealed

Parameters

d
Type: System..::..Double
The logical axis position.

Return Value

The converted data object.

Implements

IAxisLabelConverter..::..GetDataObjectAt(Double)

See Also

MonthAxisLabelConverter Class


MonthAxisValueConverter Class

[image]

Mindscape Phone Elements
MonthAxisValueConverter Class
Members See Also Send Feedback
A type of IAxisValueConverter used to create a month axis scale.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MonthAxisValueConverter : IAxisValueConverter
Visual Basic
Public Class MonthAxisValueConverter _
    Implements IAxisValueConverter
Visual C++
public ref class MonthAxisValueConverter : IAxisValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..MonthAxisValueConverter

See Also

MonthAxisValueConverter Members


MonthAxisValueConverter Members

[image] [image]

Mindscape Phone Elements
MonthAxisValueConverter Members
MonthAxisValueConverter Class Constructors Methods See Also Send Feedback

The MonthAxisValueConverter type exposes the following members.

Constructors

 | Name | Description
Public method | MonthAxisValueConverter | Initializes a new instance of the MonthAxisValueConverter class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Gets the logical axis position for a DateTime based on the year and month only.
Public method | GetDataObjectAt | Gets the date corresponding to a logical axis position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthAxisValueConverter Class


MonthAxisValueConverter Constructor

[image]

Mindscape Phone Elements
MonthAxisValueConverter Constructor
MonthAxisValueConverter Class See Also Send Feedback
Initializes a new instance of the MonthAxisValueConverter class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthAxisValueConverter()
Visual Basic
Public Sub New
Visual C++
public:
MonthAxisValueConverter()

See Also

MonthAxisValueConverter Class


MonthAxisValueConverter Methods

[image] [image]

Mindscape Phone Elements
MonthAxisValueConverter Methods
MonthAxisValueConverter Class See Also Send Feedback

The MonthAxisValueConverter type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAxisPlotPosition | Gets the logical axis position for a DateTime based on the year and month only.
Public method | GetDataObjectAt | Gets the date corresponding to a logical axis position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthAxisValueConverter Class


GetAxisPlotPosition Method

[image]

Mindscape Phone Elements
MonthAxisValueConverter..::..GetAxisPlotPosition Method
MonthAxisValueConverter Class See Also Send Feedback
Gets the logical axis position for a DateTime based on the year and month only.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetAxisPlotPosition(
    Object o
)
Visual Basic
Public Function GetAxisPlotPosition ( _
    o As Object _
) As Double
Visual C++
public:
virtual double GetAxisPlotPosition(
    Object^ o
) sealed

Parameters

o
Type: System..::..Object
The DateTime whose plot position is required.

Return Value

The logical axis position of the given DateTime.

Implements

IAxisValueConverter..::..GetAxisPlotPosition(Object)

See Also

MonthAxisValueConverter Class


GetDataObjectAt Method

[image]

Mindscape Phone Elements
MonthAxisValueConverter..::..GetDataObjectAt Method
MonthAxisValueConverter Class See Also Send Feedback
Gets the date corresponding to a logical axis position.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object GetDataObjectAt(
    double axisPosition
)
Visual Basic
Public Function GetDataObjectAt ( _
    axisPosition As Double _
) As Object
Visual C++
public:
virtual Object^ GetDataObjectAt(
    double axisPosition
) sealed

Parameters

axisPosition
Type: System..::..Double
The logical axis position.

Return Value

A DateTime representing the month on the axis at that position.

Implements

IAxisValueConverter..::..GetDataObjectAt(Double)

See Also

MonthAxisValueConverter Class


OrientationToVisibilityConverter Class

[image]

Mindscape Phone Elements
OrientationToVisibilityConverter Class
Members See Also Send Feedback
Selects a Visibility based on an Orientation.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class OrientationToVisibilityConverter : IValueConverter
Visual Basic
Public Class OrientationToVisibilityConverter _
    Implements IValueConverter
Visual C++
public ref class OrientationToVisibilityConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..OrientationToVisibilityConverter

See Also

OrientationToVisibilityConverter Members


OrientationToVisibilityConverter Members

[image] [image]

Mindscape Phone Elements
OrientationToVisibilityConverter Members
OrientationToVisibilityConverter Class Constructors Methods Properties See Also Send Feedback

The OrientationToVisibilityConverter type exposes the following members.

Constructors

 | Name | Description
Public method | OrientationToVisibilityConverter | Initializes a new instance of the OrientationToVisibilityConverter class.

Methods

 | Name | Description
Public method | Convert | Selects a Visibility according to whether the input is vertical or horizontal.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HorizontalVisibility | Gets or sets the Visibility to be returned if the orientation is horizontal. The default is Visibility.Collapsed.
Public property | VerticalVisibility | Gets or sets the Visibility to be returned if the orientation is vertical. The default is Visibility.Visible.

See Also

OrientationToVisibilityConverter Class


OrientationToVisibilityConverter Constructor

[image]

Mindscape Phone Elements
OrientationToVisibilityConverter Constructor
OrientationToVisibilityConverter Class See Also Send Feedback
Initializes a new instance of the OrientationToVisibilityConverter class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public OrientationToVisibilityConverter()
Visual Basic
Public Sub New
Visual C++
public:
OrientationToVisibilityConverter()

See Also

OrientationToVisibilityConverter Class


OrientationToVisibilityConverter Methods

[image] [image]

Mindscape Phone Elements
OrientationToVisibilityConverter Methods
OrientationToVisibilityConverter Class See Also Send Feedback

The OrientationToVisibilityConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Selects a Visibility according to whether the input is vertical or horizontal.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrientationToVisibilityConverter Class


Convert Method

[image]

Mindscape Phone Elements
OrientationToVisibilityConverter..::..Convert Method
OrientationToVisibilityConverter Class See Also Send Feedback
Selects a Visibility according to whether the input is vertical or horizontal.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The Orientation value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The selected Visibility.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

OrientationToVisibilityConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
OrientationToVisibilityConverter..::..ConvertBack Method
OrientationToVisibilityConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

OrientationToVisibilityConverter Class


OrientationToVisibilityConverter Properties

[image] [image]

Mindscape Phone Elements
OrientationToVisibilityConverter Properties
OrientationToVisibilityConverter Class See Also Send Feedback

The OrientationToVisibilityConverter type exposes the following members.

Properties

 | Name | Description
Public property | HorizontalVisibility | Gets or sets the Visibility to be returned if the orientation is horizontal. The default is Visibility.Collapsed.
Public property | VerticalVisibility | Gets or sets the Visibility to be returned if the orientation is vertical. The default is Visibility.Visible.

See Also

OrientationToVisibilityConverter Class


HorizontalVisibility Property

[image]

Mindscape Phone Elements
OrientationToVisibilityConverter..::..HorizontalVisibility Property
OrientationToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to be returned if the orientation is horizontal. The default is Visibility.Collapsed.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility HorizontalVisibility { get; set; }
Visual Basic
Public Property HorizontalVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility HorizontalVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

OrientationToVisibilityConverter Class


VerticalVisibility Property

[image]

Mindscape Phone Elements
OrientationToVisibilityConverter..::..VerticalVisibility Property
OrientationToVisibilityConverter Class See Also Send Feedback
Gets or sets the Visibility to be returned if the orientation is vertical. The default is Visibility.Visible.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Visibility VerticalVisibility { get; set; }
Visual Basic
Public Property VerticalVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility VerticalVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

OrientationToVisibilityConverter Class


PieChart Class

[image]

Mindscape Phone Elements
PieChart Class
Members See Also Send Feedback
A control for displaying PieSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PieChart : Control
Visual Basic
Public Class PieChart _
    Inherits Control
Visual C++
public ref class PieChart : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..PieChart

See Also

PieChart Members


PieChart Members

[image] [image]

Mindscape Phone Elements
PieChart Members
PieChart Class Constructors Methods Fields Properties Events See Also Send Feedback

The PieChart type exposes the following members.

Constructors

 | Name | Description
Public method | PieChart | Initializes a new instance of the PieChart class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
LegendPositionProperty | Identifies the LegendPosition property.
LegendStyleProperty | Identifies the LegendStyle property.
SelectionModeProperty | Identifies the SelectionMode property.
TitleProperty | Identifies the Title property.
TitleTemplateProperty | Identifies the TitleTemplate property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendItems | Gets the items to be displayed in the legend.
Public property | LegendPosition | Gets or sets the position on the PieChart control where the legend is displayed. This is a dependency property.
Public property | LegendStyle | Gets or sets the Style applied to the HeaderedItemsControl that displays the legend items. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectionMode | Gets or sets the selection mode of the PieChart. This is a dependency property.
Public property | Series | Gets the collection of PieSeries displayed by the PieChart.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the PieChart. This is a dependency property.
Public property | TitleTemplate | Gets or sets the DataTemplate applied to the title of the PieChart. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PieChart Class


PieChart Constructor

[image]

Mindscape Phone Elements
PieChart Constructor
PieChart Class See Also Send Feedback
Initializes a new instance of the PieChart class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PieChart()
Visual Basic
Public Sub New
Visual C++
public:
PieChart()

See Also

PieChart Class


PieChart Fields

[image] [image]

Mindscape Phone Elements
PieChart Fields
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Fields

Name | Description
LegendPositionProperty | Identifies the LegendPosition property.
LegendStyleProperty | Identifies the LegendStyle property.
SelectionModeProperty | Identifies the SelectionMode property.
TitleProperty | Identifies the Title property.
TitleTemplateProperty | Identifies the TitleTemplate property.

See Also

PieChart Class


LegendPositionProperty Field

[image]

Mindscape Phone Elements
PieChart..::..LegendPositionProperty Field
PieChart Class See Also Send Feedback
Identifies the LegendPosition property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LegendPositionProperty
Visual Basic
Public Shared ReadOnly LegendPositionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LegendPositionProperty

See Also

PieChart Class


LegendStyleProperty Field

[image]

Mindscape Phone Elements
PieChart..::..LegendStyleProperty Field
PieChart Class See Also Send Feedback
Identifies the LegendStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LegendStyleProperty
Visual Basic
Public Shared ReadOnly LegendStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LegendStyleProperty

See Also

PieChart Class


SelectionModeProperty Field

[image]

Mindscape Phone Elements
PieChart..::..SelectionModeProperty Field
PieChart Class See Also Send Feedback
Identifies the SelectionMode property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic
Public Shared ReadOnly SelectionModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectionModeProperty

See Also

PieChart Class


TitleProperty Field

[image]

Mindscape Phone Elements
PieChart..::..TitleProperty Field
PieChart Class See Also Send Feedback
Identifies the Title property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleProperty

See Also

PieChart Class


TitleTemplateProperty Field

[image]

Mindscape Phone Elements
PieChart..::..TitleTemplateProperty Field
PieChart Class See Also Send Feedback
Identifies the TitleTemplate property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleTemplateProperty
Visual Basic
Public Shared ReadOnly TitleTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleTemplateProperty

See Also

PieChart Class


PieChart Methods

[image] [image]

Mindscape Phone Elements
PieChart Methods
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::..OnApplyTemplate()()()().)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PieChart Class


OnApplyTemplate Method

[image]

Mindscape Phone Elements
PieChart..::..OnApplyTemplate Method
PieChart Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

PieChart Class


PieChart Properties

[image] [image]

Mindscape Phone Elements
PieChart Properties
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendItems | Gets the items to be displayed in the legend.
Public property | LegendPosition | Gets or sets the position on the PieChart control where the legend is displayed. This is a dependency property.
Public property | LegendStyle | Gets or sets the Style applied to the HeaderedItemsControl that displays the legend items. This is a dependency property.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectionMode | Gets or sets the selection mode of the PieChart. This is a dependency property.
Public property | Series | Gets the collection of PieSeries displayed by the PieChart.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the PieChart. This is a dependency property.
Public property | TitleTemplate | Gets or sets the DataTemplate applied to the title of the PieChart. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

PieChart Class


LegendItems Property

[image]

Mindscape Phone Elements
PieChart..::..LegendItems Property
PieChart Class See Also Send Feedback
Gets the items to be displayed in the legend.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<LegendItem> LegendItems { get; }
Visual Basic
Public ReadOnly Property LegendItems As ReadOnlyCollection(Of LegendItem)
    Get
Visual C++
public:
property ReadOnlyCollection<LegendItem^>^ LegendItems {
    ReadOnlyCollection<LegendItem^>^ get ();
}

See Also

PieChart Class


LegendPosition Property

[image]

Mindscape Phone Elements
PieChart..::..LegendPosition Property
PieChart Class See Also Send Feedback
Gets or sets the position on the PieChart control where the legend is displayed. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LegendPosition LegendPosition { get; set; }
Visual Basic
Public Property LegendPosition As LegendPosition
    Get
    Set
Visual C++
public:
property LegendPosition LegendPosition {
    LegendPosition get ();
    void set (LegendPosition value);
}

See Also

PieChart Class


LegendStyle Property

[image]

Mindscape Phone Elements
PieChart..::..LegendStyle Property
PieChart Class See Also Send Feedback
Gets or sets the Style applied to the HeaderedItemsControl that displays the legend items. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style LegendStyle { get; set; }
Visual Basic
Public Property LegendStyle As Style
    Get
    Set
Visual C++
public:
property Style^ LegendStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

PieChart Class


SelectionMode Property

[image]

Mindscape Phone Elements
PieChart..::..SelectionMode Property
PieChart Class See Also Send Feedback
Gets or sets the selection mode of the PieChart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataSeriesSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As DataSeriesSelectionMode
    Get
    Set
Visual C++
public:
property DataSeriesSelectionMode SelectionMode {
    DataSeriesSelectionMode get ();
    void set (DataSeriesSelectionMode value);
}

See Also

PieChart Class


Series Property

[image]

Mindscape Phone Elements
PieChart..::..Series Property
PieChart Class See Also Send Feedback
Gets the collection of PieSeries displayed by the PieChart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Collection<PieSeries> Series { get; }
Visual Basic
Public ReadOnly Property Series As Collection(Of PieSeries)
    Get
Visual C++
public:
property Collection<PieSeries^>^ Series {
    Collection<PieSeries^>^ get ();
}

See Also

PieChart Class


Title Property

[image]

Mindscape Phone Elements
PieChart..::..Title Property
PieChart Class See Also Send Feedback
Gets or sets the title of the PieChart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

PieChart Class


TitleTemplate Property

[image]

Mindscape Phone Elements
PieChart..::..TitleTemplate Property
PieChart Class See Also Send Feedback
Gets or sets the DataTemplate applied to the title of the PieChart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate TitleTemplate { get; set; }
Visual Basic
Public Property TitleTemplate As DataTemplate
    Get
    Set
Visual C++
public:
property DataTemplate^ TitleTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

PieChart Class


PieChart Events

[image] [image]

Mindscape Phone Elements
PieChart Events
PieChart Class See Also Send Feedback

The PieChart type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PieChart Class


PieSeries Class

[image]

Mindscape Phone Elements
PieSeries Class
Members See Also Send Feedback
Holds data for a single pie chart series.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PieSeries : Control
Visual Basic
Public Class PieSeries _
    Inherits Control
Visual C++
public ref class PieSeries : public Control

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..PieSeries

See Also

PieSeries Members


PieSeries Members

[image] [image]

Mindscape Phone Elements
PieSeries Members
PieSeries Class Constructors Methods Fields Properties Events See Also Send Feedback

The PieSeries type exposes the following members.

Constructors

 | Name | Description
Public method | PieSeries | Initializes a new instance of the PieSeries class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
DataLabelOffsetFactorProperty | Identifies the DataLabelOffsetFactor property.
DataLabelStyleProperty | Identifies the DataLabelStyle property.
DoughnutScaleProperty | Identifies the DoughnutScale property.
FullCircleTotalProperty | Identifies the FullCircleTotal property.
IsSingleDataLineVisibleProperty | Identifies the IsSingleDataLineVisible property.
ItemsSourceProperty | Identifies the ItemsSource property.
LegendIconTemplateProperty | Identifies the LegendIconTemplate property.
PieSliceStyleProperty | Identifies the PieSliceStyle property.
SelectionModeProperty | Identifies the SelectionMode property.
ShowDataLabelLinesProperty | Identifies the ShowDataLabelLines property.
ShowDataLabelsProperty | Identifies the ShowDataLabels property.
StartAngleProperty | Identifies the StartAngle property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Brushes | Gets the observable collection of brushes used to color each piece of the pie chart.
Public property | CacheMode | (Inherited from UIElement.)
Public property | Canvas | Gets the Canvas that the pie series is plotted on.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataBinding | Gets or sets a binding used to extract a data value from a data object in the ItemsSource.
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelOffsetFactor | Gets or sets a value used to determine the distance between a data label and the center of the pie chart. This is a dependency property.
Public property | DataLabelStyle | Gets or sets the Style to be applied to the DataLabel objects. This is a dependency property.
Public property | DataPoints | Gets a read only collection containing the PieSlice objects within the PieSeries. A PieSlice is the graphical representation of plotted data and is created by the PieSeries.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DoughnutScale | Gets or sets a value used to determine the thickness of a doughnut. This should be a value between 0 and 1. A value of 1 will create a pie chart. The default is 1. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | FullCircleTotal | Gets or sets a value that determines if a partial chart or a full chart should be drawn. If the total sum of data is less than the FullCircleTotal, then this is a partial PieSeries. The default is zero. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSingleDataLineVisible | Gets or sets whether or not to display the line from the center to the edge when there is only a single piece of data. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data that the PieChart displays. If the sum of the given data values is less than 1, then a partial pie chart is created. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property.
Public property | LegendItems | Gets a list of legend items to be displayed in a legend for this PieSeries.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PieSliceStyle | Gets or sets the Style to apply to the PieSlice objects. This is a dependency property.
Public property | Projection | (Inherited from UIElement.)
Public property | RadiusBinding | Gets or sets a binding used to extract a radius factor from a data object in the ItemsSource. This can be used to create a pie chart with data pieces of different radius scales.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected.
Public property | SelectionMode | Gets or sets the SelectionMode. This is a dependency property.
Public property | ShowDataLabelLines | Gets or sets whether or not to display a line from the data labels to the data pieces. This is a dependency property.
Public property | ShowDataLabels | Gets or sets whether or not the data lables are displayed. This is a dependency property.
Public property | StartAngle | Gets or sets the starting angle of the PieSeries in degrees. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TitleBinding | A binding used to extract the title of a data object.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items changed.
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PieSeries Class


PieSeries Constructor

[image]

Mindscape Phone Elements
PieSeries Constructor
PieSeries Class See Also Send Feedback
Initializes a new instance of the PieSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PieSeries()
Visual Basic
Public Sub New
Visual C++
public:
PieSeries()

See Also

PieSeries Class


PieSeries Fields

[image] [image]

Mindscape Phone Elements
PieSeries Fields
PieSeries Class See Also Send Feedback

The PieSeries type exposes the following members.

Fields

Name | Description
DataLabelOffsetFactorProperty | Identifies the DataLabelOffsetFactor property.
DataLabelStyleProperty | Identifies the DataLabelStyle property.
DoughnutScaleProperty | Identifies the DoughnutScale property.
FullCircleTotalProperty | Identifies the FullCircleTotal property.
IsSingleDataLineVisibleProperty | Identifies the IsSingleDataLineVisible property.
ItemsSourceProperty | Identifies the ItemsSource property.
LegendIconTemplateProperty | Identifies the LegendIconTemplate property.
PieSliceStyleProperty | Identifies the PieSliceStyle property.
SelectionModeProperty | Identifies the SelectionMode property.
ShowDataLabelLinesProperty | Identifies the ShowDataLabelLines property.
ShowDataLabelsProperty | Identifies the ShowDataLabels property.
StartAngleProperty | Identifies the StartAngle property.

See Also

PieSeries Class


DataLabelOffsetFactorProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..DataLabelOffsetFactorProperty Field
PieSeries Class See Also Send Feedback
Identifies the DataLabelOffsetFactor property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DataLabelOffsetFactorProperty
Visual Basic
Public Shared ReadOnly DataLabelOffsetFactorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DataLabelOffsetFactorProperty

See Also

PieSeries Class


DataLabelStyleProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..DataLabelStyleProperty Field
PieSeries Class See Also Send Feedback
Identifies the DataLabelStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DataLabelStyleProperty
Visual Basic
Public Shared ReadOnly DataLabelStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DataLabelStyleProperty

See Also

PieSeries Class


DoughnutScaleProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..DoughnutScaleProperty Field
PieSeries Class See Also Send Feedback
Identifies the DoughnutScale property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DoughnutScaleProperty
Visual Basic
Public Shared ReadOnly DoughnutScaleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DoughnutScaleProperty

See Also

PieSeries Class


FullCircleTotalProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..FullCircleTotalProperty Field
PieSeries Class See Also Send Feedback
Identifies the FullCircleTotal property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty FullCircleTotalProperty
Visual Basic
Public Shared ReadOnly FullCircleTotalProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ FullCircleTotalProperty

See Also

PieSeries Class


IsSingleDataLineVisibleProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..IsSingleDataLineVisibleProperty Field
PieSeries Class See Also Send Feedback
Identifies the IsSingleDataLineVisible property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsSingleDataLineVisibleProperty
Visual Basic
Public Shared ReadOnly IsSingleDataLineVisibleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsSingleDataLineVisibleProperty

See Also

PieSeries Class


ItemsSourceProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..ItemsSourceProperty Field
PieSeries Class See Also Send Feedback
Identifies the ItemsSource property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemsSourceProperty

See Also

PieSeries Class


LegendIconTemplateProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..LegendIconTemplateProperty Field
PieSeries Class See Also Send Feedback
Identifies the LegendIconTemplate property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LegendIconTemplateProperty
Visual Basic
Public Shared ReadOnly LegendIconTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LegendIconTemplateProperty

See Also

PieSeries Class


PieSliceStyleProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..PieSliceStyleProperty Field
PieSeries Class See Also Send Feedback
Identifies the PieSliceStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty PieSliceStyleProperty
Visual Basic
Public Shared ReadOnly PieSliceStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PieSliceStyleProperty

See Also

PieSeries Class


SelectionModeProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..SelectionModeProperty Field
PieSeries Class See Also Send Feedback
Identifies the SelectionMode property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic
Public Shared ReadOnly SelectionModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectionModeProperty

See Also

PieSeries Class


ShowDataLabelLinesProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..ShowDataLabelLinesProperty Field
PieSeries Class See Also Send Feedback
Identifies the ShowDataLabelLines property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowDataLabelLinesProperty
Visual Basic
Public Shared ReadOnly ShowDataLabelLinesProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowDataLabelLinesProperty

See Also

PieSeries Class


ShowDataLabelsProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..ShowDataLabelsProperty Field
PieSeries Class See Also Send Feedback
Identifies the ShowDataLabels property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowDataLabelsProperty
Visual Basic
Public Shared ReadOnly ShowDataLabelsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowDataLabelsProperty

See Also

PieSeries Class


StartAngleProperty Field

[image]

Mindscape Phone Elements
PieSeries..::..StartAngleProperty Field
PieSeries Class See Also Send Feedback
Identifies the StartAngle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty StartAngleProperty
Visual Basic
Public Shared ReadOnly StartAngleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ StartAngleProperty

See Also

PieSeries Class


PieSeries Methods

[image] [image]

Mindscape Phone Elements
PieSeries Methods
PieSeries Class See Also Send Feedback

The PieSeries type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PieSeries Class


PieSeries Properties

[image] [image]

Mindscape Phone Elements
PieSeries Properties
PieSeries Class See Also Send Feedback

The PieSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Brushes | Gets the observable collection of brushes used to color each piece of the pie chart.
Public property | CacheMode | (Inherited from UIElement.)
Public property | Canvas | Gets the Canvas that the pie series is plotted on.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataBinding | Gets or sets a binding used to extract a data value from a data object in the ItemsSource.
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelOffsetFactor | Gets or sets a value used to determine the distance between a data label and the center of the pie chart. This is a dependency property.
Public property | DataLabelStyle | Gets or sets the Style to be applied to the DataLabel objects. This is a dependency property.
Public property | DataPoints | Gets a read only collection containing the PieSlice objects within the PieSeries. A PieSlice is the graphical representation of plotted data and is created by the PieSeries.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DoughnutScale | Gets or sets a value used to determine the thickness of a doughnut. This should be a value between 0 and 1. A value of 1 will create a pie chart. The default is 1. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | FullCircleTotal | Gets or sets a value that determines if a partial chart or a full chart should be drawn. If the total sum of data is less than the FullCircleTotal, then this is a partial PieSeries. The default is zero. This is a dependency property.
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSingleDataLineVisible | Gets or sets whether or not to display the line from the center to the edge when there is only a single piece of data. This is a dependency property.
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data that the PieChart displays. If the sum of the given data values is less than 1, then a partial pie chart is created. This is a dependency property.
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property.
Public property | LegendItems | Gets a list of legend items to be displayed in a legend for this PieSeries.
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PieSliceStyle | Gets or sets the Style to apply to the PieSlice objects. This is a dependency property.
Public property | Projection | (Inherited from UIElement.)
Public property | RadiusBinding | Gets or sets a binding used to extract a radius factor from a data object in the ItemsSource. This can be used to create a pie chart with data pieces of different radius scales.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected.
Public property | SelectionMode | Gets or sets the SelectionMode. This is a dependency property.
Public property | ShowDataLabelLines | Gets or sets whether or not to display a line from the data labels to the data pieces. This is a dependency property.
Public property | ShowDataLabels | Gets or sets whether or not the data lables are displayed. This is a dependency property.
Public property | StartAngle | Gets or sets the starting angle of the PieSeries in degrees. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TitleBinding | A binding used to extract the title of a data object.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

PieSeries Class


Brushes Property

[image]

Mindscape Phone Elements
PieSeries..::..Brushes Property
PieSeries Class See Also Send Feedback
Gets the observable collection of brushes used to color each piece of the pie chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObservableCollection<Brush> Brushes { get; }
Visual Basic
Public ReadOnly Property Brushes As ObservableCollection(Of Brush)
    Get
Visual C++
public:
property ObservableCollection<Brush^>^ Brushes {
    ObservableCollection<Brush^>^ get ();
}

See Also

PieSeries Class


Canvas Property

[image]

Mindscape Phone Elements
PieSeries..::..Canvas Property
PieSeries Class See Also Send Feedback
Gets the Canvas that the pie series is plotted on.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Canvas Canvas { get; internal set; }
Visual Basic
Public Property Canvas As Canvas
    Get
    Friend Set
Visual C++
public:
property Canvas^ Canvas {
    Canvas^ get ();
    internal: void set (Canvas^ value);
}

See Also

PieSeries Class


DataBinding Property

[image]

Mindscape Phone Elements
PieSeries..::..DataBinding Property
PieSeries Class See Also Send Feedback
Gets or sets a binding used to extract a data value from a data object in the ItemsSource.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding DataBinding { get; set; }
Visual Basic
Public Property DataBinding As Binding
    Get
    Set
Visual C++
public:
property Binding^ DataBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

PieSeries Class


DataLabelOffsetFactor Property

[image]

Mindscape Phone Elements
PieSeries..::..DataLabelOffsetFactor Property
PieSeries Class See Also Send Feedback
Gets or sets a value used to determine the distance between a data label and the center of the pie chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DataLabelOffsetFactor { get; set; }
Visual Basic
Public Property DataLabelOffsetFactor As Double
    Get
    Set
Visual C++
public:
property double DataLabelOffsetFactor {
    double get ();
    void set (double value);
}

See Also

PieSeries Class


DataLabelStyle Property

[image]

Mindscape Phone Elements
PieSeries..::..DataLabelStyle Property
PieSeries Class See Also Send Feedback
Gets or sets the Style to be applied to the DataLabel objects. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style DataLabelStyle { get; set; }
Visual Basic
Public Property DataLabelStyle As Style
    Get
    Set
Visual C++
public:
property Style^ DataLabelStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

PieSeries Class


DataPoints Property

[image]

Mindscape Phone Elements
PieSeries..::..DataPoints Property
PieSeries Class See Also Send Feedback
Gets a read only collection containing the PieSlice objects within the PieSeries. A PieSlice is the graphical representation of plotted data and is created by the PieSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<PieSlice> DataPoints { get; }
Visual Basic
Public ReadOnly Property DataPoints As ReadOnlyCollection(Of PieSlice)
    Get
Visual C++
public:
property ReadOnlyCollection<PieSlice^>^ DataPoints {
    ReadOnlyCollection<PieSlice^>^ get ();
}

See Also

PieSeries Class


DoughnutScale Property

[image]

Mindscape Phone Elements
PieSeries..::..DoughnutScale Property
PieSeries Class See Also Send Feedback
Gets or sets a value used to determine the thickness of a doughnut. This should be a value between 0 and 1. A value of 1 will create a pie chart. The default is 1. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DoughnutScale { get; set; }
Visual Basic
Public Property DoughnutScale As Double
    Get
    Set
Visual C++
public:
property double DoughnutScale {
    double get ();
    void set (double value);
}

See Also

PieSeries Class


FullCircleTotal Property

[image]

Mindscape Phone Elements
PieSeries..::..FullCircleTotal Property
PieSeries Class See Also Send Feedback
Gets or sets a value that determines if a partial chart or a full chart should be drawn. If the total sum of data is less than the FullCircleTotal, then this is a partial PieSeries. The default is zero. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FullCircleTotal { get; set; }
Visual Basic
Public Property FullCircleTotal As Double
    Get
    Set
Visual C++
public:
property double FullCircleTotal {
    double get ();
    void set (double value);
}

See Also

PieSeries Class


IsSingleDataLineVisible Property

[image]

Mindscape Phone Elements
PieSeries..::..IsSingleDataLineVisible Property
PieSeries Class See Also Send Feedback
Gets or sets whether or not to display the line from the center to the edge when there is only a single piece of data. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSingleDataLineVisible { get; set; }
Visual Basic
Public Property IsSingleDataLineVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsSingleDataLineVisible {
    bool get ();
    void set (bool value);
}

See Also

PieSeries Class


ItemsSource Property

[image]

Mindscape Phone Elements
PieSeries..::..ItemsSource Property
PieSeries Class See Also Send Feedback
Gets or sets the ItemsSource. This is the data that the PieChart displays. If the sum of the given data values is less than 1, then a partial pie chart is created. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IList ItemsSource { get; set; }
Visual Basic
Public Property ItemsSource As IList
    Get
    Set
Visual C++
public:
property IList^ ItemsSource {
    IList^ get ();
    void set (IList^ value);
}

See Also

PieSeries Class


LegendIconTemplate Property

[image]

Mindscape Phone Elements
PieSeries..::..LegendIconTemplate Property
PieSeries Class See Also Send Feedback
Gets or sets the LegendIconTemplate. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate LegendIconTemplate { get; set; }
Visual Basic
Public Property LegendIconTemplate As DataTemplate
    Get
    Set
Visual C++
public:
property DataTemplate^ LegendIconTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

PieSeries Class


LegendItems Property

[image]

Mindscape Phone Elements
PieSeries..::..LegendItems Property
PieSeries Class See Also Send Feedback
Gets a list of legend items to be displayed in a legend for this PieSeries.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IEnumerable<LegendItem> LegendItems { get; }
Visual Basic
Public ReadOnly Property LegendItems As IEnumerable(Of LegendItem)
    Get
Visual C++
public:
property IEnumerable<LegendItem^>^ LegendItems {
    IEnumerable<LegendItem^>^ get ();
}

See Also

PieSeries Class


PieSliceStyle Property

[image]

Mindscape Phone Elements
PieSeries..::..PieSliceStyle Property
PieSeries Class See Also Send Feedback
Gets or sets the Style to apply to the PieSlice objects. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style PieSliceStyle { get; set; }
Visual Basic
Public Property PieSliceStyle As Style
    Get
    Set
Visual C++
public:
property Style^ PieSliceStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

PieSeries Class


RadiusBinding Property

[image]

Mindscape Phone Elements
PieSeries..::..RadiusBinding Property
PieSeries Class See Also Send Feedback
Gets or sets a binding used to extract a radius factor from a data object in the ItemsSource. This can be used to create a pie chart with data pieces of different radius scales.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding RadiusBinding { get; set; }
Visual Basic
Public Property RadiusBinding As Binding
    Get
    Set
Visual C++
public:
property Binding^ RadiusBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

PieSeries Class


SelectedDataPoint Property

[image]

Mindscape Phone Elements
PieSeries..::..SelectedDataPoint Property
PieSeries Class See Also Send Feedback
Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PieSlice SelectedDataPoint { get; private set; }
Visual Basic
Public Property SelectedDataPoint As PieSlice
    Get
    Private Set
Visual C++
public:
property PieSlice^ SelectedDataPoint {
    PieSlice^ get ();
    private: void set (PieSlice^ value);
}

See Also

PieSeries Class


SelectionMode Property

[image]

Mindscape Phone Elements
PieSeries..::..SelectionMode Property
PieSeries Class See Also Send Feedback
Gets or sets the SelectionMode. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataPointSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As DataPointSelectionMode
    Get
    Set
Visual C++
public:
property DataPointSelectionMode SelectionMode {
    DataPointSelectionMode get ();
    void set (DataPointSelectionMode value);
}

See Also

PieSeries Class


ShowDataLabelLines Property

[image]

Mindscape Phone Elements
PieSeries..::..ShowDataLabelLines Property
PieSeries Class See Also Send Feedback
Gets or sets whether or not to display a line from the data labels to the data pieces. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowDataLabelLines { get; set; }
Visual Basic
Public Property ShowDataLabelLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDataLabelLines {
    bool get ();
    void set (bool value);
}

See Also

PieSeries Class


ShowDataLabels Property

[image]

Mindscape Phone Elements
PieSeries..::..ShowDataLabels Property
PieSeries Class See Also Send Feedback
Gets or sets whether or not the data lables are displayed. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowDataLabels { get; set; }
Visual Basic
Public Property ShowDataLabels As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDataLabels {
    bool get ();
    void set (bool value);
}

See Also

PieSeries Class


StartAngle Property

[image]

Mindscape Phone Elements
PieSeries..::..StartAngle Property
PieSeries Class See Also Send Feedback
Gets or sets the starting angle of the PieSeries in degrees. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic
Public Property StartAngle As Double
    Get
    Set
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

See Also

PieSeries Class


TitleBinding Property

[image]

Mindscape Phone Elements
PieSeries..::..TitleBinding Property
PieSeries Class See Also Send Feedback
A binding used to extract the title of a data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding TitleBinding { get; set; }
Visual Basic
Public Property TitleBinding As Binding
    Get
    Set
Visual C++
public:
property Binding^ TitleBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

PieSeries Class


PieSeries Events

[image] [image]

Mindscape Phone Elements
PieSeries Events
PieSeries Class See Also Send Feedback

The PieSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items changed.
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PieSeries Class


LegendItemsChanged Event

[image]

Mindscape Phone Elements
PieSeries..::..LegendItemsChanged Event
PieSeries Class See Also Send Feedback
Raised when the legend items changed.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler LegendItemsChanged
Visual Basic
Public Event LegendItemsChanged As EventHandler
Visual C++
public:
 event EventHandler^ LegendItemsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

PieSeries Class


PieSlice Class

[image]

Mindscape Phone Elements
PieSlice Class
Members See Also Send Feedback
Represents a data point on a PieChart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PieSlice : DataPoint, INotifyPropertyChanged
Visual Basic
Public Class PieSlice _
    Inherits DataPoint _
    Implements INotifyPropertyChanged
Visual C++
public ref class PieSlice : public DataPoint,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataPoint
Mindscape.PhoneElements.Charting..::..PieSlice

See Also

PieSlice Members


PieSlice Members

[image] [image]

Mindscape Phone Elements
PieSlice Members
PieSlice Class Methods Fields Properties Events See Also Send Feedback

The PieSlice type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
DataValueProperty | Identifies the DataValue property.
ExplodedDistanceProperty | Identifies the ExplodedDistance property.
RadiusFactorProperty | Identifies the RadiusFactor property.
TitleProperty | Identifies the Title property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | CenterPoint | Gets the position of the center corner of the PieSlice relative to the Canvas that the pie chart is being hosted in.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataValue | Gets or sets the numerical data value that the PieSlice is plotting. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Diameter | Gets the diameter of the pie chart.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DoughnutScale | Gets the doughnut scale of the PieSlice. By multiplying this value with the radius, you get the thickness of the douughnut shape.
Public property | ExplodedDistance | Gets or sets the distance of the PieSlice from the center of the pie chart. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PathData | Gets a PathGeometry that specifies the shape and position of the PieSlice.
Public property | Percentage | Gets the percentage of the PieSlice.
Public property | Projection | (Inherited from UIElement.)
Public property | Radius | Gets the radius of the PieSlice.
Public property | RadiusFactor | Gets or sets the radius factor of the PieSlice. This is generally a value between 0 and 1. This property can be set using the RadiusBinding property of a PieSeries. This is a dependency property.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Self | Gets this pie slice. This is useful for binding to this pie slice when the center point changes.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the PieSlice. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | ExplodedDistanceChanged | Raised when the exploded distance changes.
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PieSlice Class


PieSlice Fields

[image] [image]

Mindscape Phone Elements
PieSlice Fields
PieSlice Class See Also Send Feedback

The PieSlice type exposes the following members.

Fields

Name | Description
DataValueProperty | Identifies the DataValue property.
ExplodedDistanceProperty | Identifies the ExplodedDistance property.
RadiusFactorProperty | Identifies the RadiusFactor property.
TitleProperty | Identifies the Title property.

See Also

PieSlice Class


DataValueProperty Field

[image]

Mindscape Phone Elements
PieSlice..::..DataValueProperty Field
PieSlice Class See Also Send Feedback
Identifies the DataValue property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DataValueProperty
Visual Basic
Public Shared ReadOnly DataValueProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DataValueProperty

See Also

PieSlice Class


ExplodedDistanceProperty Field

[image]

Mindscape Phone Elements
PieSlice..::..ExplodedDistanceProperty Field
PieSlice Class See Also Send Feedback
Identifies the ExplodedDistance property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ExplodedDistanceProperty
Visual Basic
Public Shared ReadOnly ExplodedDistanceProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ExplodedDistanceProperty

See Also

PieSlice Class


RadiusFactorProperty Field

[image]

Mindscape Phone Elements
PieSlice..::..RadiusFactorProperty Field
PieSlice Class See Also Send Feedback
Identifies the RadiusFactor property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty RadiusFactorProperty
Visual Basic
Public Shared ReadOnly RadiusFactorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ RadiusFactorProperty

See Also

PieSlice Class


TitleProperty Field

[image]

Mindscape Phone Elements
PieSlice..::..TitleProperty Field
PieSlice Class See Also Send Feedback
Identifies the Title property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TitleProperty
Visual Basic
Public Shared ReadOnly TitleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TitleProperty

See Also

PieSlice Class


PieSlice Methods

[image] [image]

Mindscape Phone Elements
PieSlice Methods
PieSlice Class See Also Send Feedback

The PieSlice type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | Called when the left mouse button is pressed over the DataPoint. (Inherited from DataPoint.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PieSlice Class


PieSlice Properties

[image] [image]

Mindscape Phone Elements
PieSlice Properties
PieSlice Class See Also Send Feedback

The PieSlice type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Public property | CenterPoint | Gets the position of the center corner of the PieSlice relative to the Canvas that the pie chart is being hosted in.
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataValue | Gets or sets the numerical data value that the PieSlice is plotting. This is a dependency property.
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Diameter | Gets the diameter of the pie chart.
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DoughnutScale | Gets the doughnut scale of the PieSlice. By multiplying this value with the radius, you get the thickness of the douughnut shape.
Public property | ExplodedDistance | Gets or sets the distance of the PieSlice from the center of the pie chart. This is a dependency property.
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsSelected | Gets or sets whether or not the DataPoint is currently selected. (Inherited from DataPoint.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PathData | Gets a PathGeometry that specifies the shape and position of the PieSlice.
Public property | Percentage | Gets the percentage of the PieSlice.
Public property | Projection | (Inherited from UIElement.)
Public property | Radius | Gets the radius of the PieSlice.
Public property | RadiusFactor | Gets or sets the radius factor of the PieSlice. This is generally a value between 0 and 1. This property can be set using the RadiusBinding property of a PieSeries. This is a dependency property.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Self | Gets this pie slice. This is useful for binding to this pie slice when the center point changes.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the PieSlice. This is a dependency property.
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

PieSlice Class


CenterPoint Property

[image]

Mindscape Phone Elements
PieSlice..::..CenterPoint Property
PieSlice Class See Also Send Feedback
Gets the position of the center corner of the PieSlice relative to the Canvas that the pie chart is being hosted in.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point CenterPoint { get; internal set; }
Visual Basic
Public Property CenterPoint As Point
    Get
    Friend Set
Visual C++
public:
property Point CenterPoint {
    Point get ();
    internal: void set (Point value);
}

See Also

PieSlice Class


DataValue Property

[image]

Mindscape Phone Elements
PieSlice..::..DataValue Property
PieSlice Class See Also Send Feedback
Gets or sets the numerical data value that the PieSlice is plotting. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DataValue { get; set; }
Visual Basic
Public Property DataValue As Double
    Get
    Set
Visual C++
public:
property double DataValue {
    double get ();
    void set (double value);
}

See Also

PieSlice Class


Diameter Property

[image]

Mindscape Phone Elements
PieSlice..::..Diameter Property
PieSlice Class See Also Send Feedback
Gets the diameter of the pie chart.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Diameter { get; internal set; }
Visual Basic
Public Property Diameter As Double
    Get
    Friend Set
Visual C++
public:
property double Diameter {
    double get ();
    internal: void set (double value);
}

See Also

PieSlice Class


DoughnutScale Property

[image]

Mindscape Phone Elements
PieSlice..::..DoughnutScale Property
PieSlice Class See Also Send Feedback
Gets the doughnut scale of the PieSlice. By multiplying this value with the radius, you get the thickness of the douughnut shape.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DoughnutScale { get; private set; }
Visual Basic
Public Property DoughnutScale As Double
    Get
    Private Set
Visual C++
public:
property double DoughnutScale {
    double get ();
    private: void set (double value);
}

See Also

PieSlice Class


ExplodedDistance Property

[image]

Mindscape Phone Elements
PieSlice..::..ExplodedDistance Property
PieSlice Class See Also Send Feedback
Gets or sets the distance of the PieSlice from the center of the pie chart. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ExplodedDistance { get; set; }
Visual Basic
Public Property ExplodedDistance As Double
    Get
    Set
Visual C++
public:
property double ExplodedDistance {
    double get ();
    void set (double value);
}

See Also

PieSlice Class


PathData Property

[image]

Mindscape Phone Elements
PieSlice..::..PathData Property
PieSlice Class See Also Send Feedback
Gets a PathGeometry that specifies the shape and position of the PieSlice.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PathGeometry PathData { get; internal set; }
Visual Basic
Public Property PathData As PathGeometry
    Get
    Friend Set
Visual C++
public:
property PathGeometry^ PathData {
    PathGeometry^ get ();
    internal: void set (PathGeometry^ value);
}

See Also

PieSlice Class


Percentage Property

[image]

Mindscape Phone Elements
PieSlice..::..Percentage Property
PieSlice Class See Also Send Feedback
Gets the percentage of the PieSlice.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Percentage { get; internal set; }
Visual Basic
Public Property Percentage As Double
    Get
    Friend Set
Visual C++
public:
property double Percentage {
    double get ();
    internal: void set (double value);
}

See Also

PieSlice Class


Radius Property

[image]

Mindscape Phone Elements
PieSlice..::..Radius Property
PieSlice Class See Also Send Feedback
Gets the radius of the PieSlice.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Radius { get; internal set; }
Visual Basic
Public Property Radius As Double
    Get
    Friend Set
Visual C++
public:
property double Radius {
    double get ();
    internal: void set (double value);
}

See Also

PieSlice Class


RadiusFactor Property

[image]

Mindscape Phone Elements
PieSlice..::..RadiusFactor Property
PieSlice Class See Also Send Feedback
Gets or sets the radius factor of the PieSlice. This is generally a value between 0 and 1. This property can be set using the RadiusBinding property of a PieSeries. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RadiusFactor { get; set; }
Visual Basic
Public Property RadiusFactor As Double
    Get
    Set
Visual C++
public:
property double RadiusFactor {
    double get ();
    void set (double value);
}

See Also

PieSlice Class


Self Property

[image]

Mindscape Phone Elements
PieSlice..::..Self Property
PieSlice Class See Also Send Feedback
Gets this pie slice. This is useful for binding to this pie slice when the center point changes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PieSlice Self { get; }
Visual Basic
Public ReadOnly Property Self As PieSlice
    Get
Visual C++
public:
property PieSlice^ Self {
    PieSlice^ get ();
}

See Also

PieSlice Class


Title Property

[image]

Mindscape Phone Elements
PieSlice..::..Title Property
PieSlice Class See Also Send Feedback
Gets or sets the title of the PieSlice. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

PieSlice Class


PieSlice Events

[image] [image]

Mindscape Phone Elements
PieSlice Events
PieSlice Class See Also Send Feedback

The PieSlice type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | ExplodedDistanceChanged | Raised when the exploded distance changes.
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | IsSelectedChanged | Raised when the IsSelected property changes. (Inherited from DataPoint.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PropertyChanged | Raised when a property value changes.
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PieSlice Class


ExplodedDistanceChanged Event

[image]

Mindscape Phone Elements
PieSlice..::..ExplodedDistanceChanged Event
PieSlice Class See Also Send Feedback
Raised when the exploded distance changes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler ExplodedDistanceChanged
Visual Basic
Public Event ExplodedDistanceChanged As EventHandler
Visual C++
public:
 event EventHandler^ ExplodedDistanceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

PieSlice Class


PropertyChanged Event

[image]

Mindscape Phone Elements
PieSlice..::..PropertyChanged Event
PieSlice Class See Also Send Feedback
Raised when a property value changes.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

PieSlice Class


PieSliceToRadialGradientBrushConverter Class

[image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter Class
Members See Also Send Feedback
Creates a RadialGradientBrush for a PieSlice.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PieSliceToRadialGradientBrushConverter : IValueConverter
Visual Basic
Public Class PieSliceToRadialGradientBrushConverter _
    Implements IValueConverter
Visual C++
public ref class PieSliceToRadialGradientBrushConverter : IValueConverter

Inheritance Hierarchy

System..::..Object
Mindscape.PhoneElements.Charting..::..PieSliceToRadialGradientBrushConverter

See Also

PieSliceToRadialGradientBrushConverter Members


PieSliceToRadialGradientBrushConverter Members

[image] [image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter Members
PieSliceToRadialGradientBrushConverter Class Constructors Methods Properties See Also Send Feedback

The PieSliceToRadialGradientBrushConverter type exposes the following members.

Constructors

 | Name | Description
Public method | PieSliceToRadialGradientBrushConverter | Initializes a new instance of the PieSliceToRadialGradientBrushConverter class.

Methods

 | Name | Description
Public method | Convert | Creates a RadialGradientBrush for the given PieSlice.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DoughnutGradientStops | Gets the collection of GradientStop objects to use if the pie slice has a doughnut shape.
Public property | GradientCenter | Gets or sets the center point of the RadialGradientBrush. This point will typically be made up of values between 0 and 1 which are factors relative to the bounding box of all the pie slices in the chart. The default is (0.5, 0.5).
Public property | GradientStops | Gets the collection of GradientStop objects for the RadialGradientBrush.

See Also

PieSliceToRadialGradientBrushConverter Class


PieSliceToRadialGradientBrushConverter Constructor

[image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter Constructor
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback
Initializes a new instance of the PieSliceToRadialGradientBrushConverter class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PieSliceToRadialGradientBrushConverter()
Visual Basic
Public Sub New
Visual C++
public:
PieSliceToRadialGradientBrushConverter()

See Also

PieSliceToRadialGradientBrushConverter Class


PieSliceToRadialGradientBrushConverter Methods

[image] [image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter Methods
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback

The PieSliceToRadialGradientBrushConverter type exposes the following members.

Methods

 | Name | Description
Public method | Convert | Creates a RadialGradientBrush for the given PieSlice.
Public method | ConvertBack | Converts a value from a binding target for writing to a binding source.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PieSliceToRadialGradientBrushConverter Class


Convert Method

[image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter..::..Convert Method
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback
Creates a RadialGradientBrush for the given PieSlice.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The PieSlice value produced by the binding source.
targetType
Type: System..::..Type
The type of the binding target property.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

The created RadialGradientBrush.

Implements

IValueConverter..::..Convert(Object, Type, Object, CultureInfo)

See Also

PieSliceToRadialGradientBrushConverter Class


ConvertBack Method

[image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter..::..ConvertBack Method
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::..Object
The value produced by the binding target.
targetType
Type: System..::..Type
The type to convert to.
parameter
Type: System..::..Object
The converter parameter to use.
culture
Type: System.Globalization..::..CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::..ConvertBack(Object, Type, Object, CultureInfo)

See Also

PieSliceToRadialGradientBrushConverter Class


PieSliceToRadialGradientBrushConverter Properties

[image] [image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter Properties
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback

The PieSliceToRadialGradientBrushConverter type exposes the following members.

Properties

 | Name | Description
Public property | DoughnutGradientStops | Gets the collection of GradientStop objects to use if the pie slice has a doughnut shape.
Public property | GradientCenter | Gets or sets the center point of the RadialGradientBrush. This point will typically be made up of values between 0 and 1 which are factors relative to the bounding box of all the pie slices in the chart. The default is (0.5, 0.5).
Public property | GradientStops | Gets the collection of GradientStop objects for the RadialGradientBrush.

See Also

PieSliceToRadialGradientBrushConverter Class


DoughnutGradientStops Property

[image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter..::..DoughnutGradientStops Property
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback
Gets the collection of GradientStop objects to use if the pie slice has a doughnut shape.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObservableCollection<GradientStop> DoughnutGradientStops { get; }
Visual Basic
Public ReadOnly Property DoughnutGradientStops As ObservableCollection(Of GradientStop)
    Get
Visual C++
public:
property ObservableCollection<GradientStop^>^ DoughnutGradientStops {
    ObservableCollection<GradientStop^>^ get ();
}

See Also

PieSliceToRadialGradientBrushConverter Class


GradientCenter Property

[image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter..::..GradientCenter Property
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback
Gets or sets the center point of the RadialGradientBrush. This point will typically be made up of values between 0 and 1 which are factors relative to the bounding box of all the pie slices in the chart. The default is (0.5, 0.5).

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point GradientCenter { get; set; }
Visual Basic
Public Property GradientCenter As Point
    Get
    Set
Visual C++
public:
property Point GradientCenter {
    Point get ();
    void set (Point value);
}

See Also

PieSliceToRadialGradientBrushConverter Class


GradientStops Property

[image]

Mindscape Phone Elements
PieSliceToRadialGradientBrushConverter..::..GradientStops Property
PieSliceToRadialGradientBrushConverter Class See Also Send Feedback
Gets the collection of GradientStop objects for the RadialGradientBrush.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObservableCollection<GradientStop> GradientStops { get; }
Visual Basic
Public ReadOnly Property GradientStops As ObservableCollection(Of GradientStop)
    Get
Visual C++
public:
property ObservableCollection<GradientStop^>^ GradientStops {
    ObservableCollection<GradientStop^>^ get ();
}

See Also

PieSliceToRadialGradientBrushConverter Class


PointSeriesBase Class

[image]

Mindscape Phone Elements
PointSeriesBase Class
Members See Also Send Feedback
A base class for data series which plot data using points, such as line series or scatter graphs.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class PointSeriesBase : DataSeries
Visual Basic
Public MustInherit Class PointSeriesBase _
    Inherits DataSeries
Visual C++
public ref class PointSeriesBase abstract : public DataSeries

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..ScatterSeries

See Also

PointSeriesBase Members


PointSeriesBase Members

[image] [image]

Mindscape Phone Elements
PointSeriesBase Members
PointSeriesBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The PointSeriesBase type exposes the following members.

Constructors

 | Name | Description
Protected method | PointSeriesBase | Initializes a new instance of the PointSeriesBase class

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas.
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the DataSeries on the chart canvas. (Inherited from DataSeries.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object.
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label.
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Fields

Name | Description
DataLabelStyleProperty | Identifies the DataLabelStyle property.
ShowDataLabelLinesProperty | Identifies the ShowDataLabelLines property.
ShowDataLabelsProperty | Identifies the ShowDataLabels property.
SymbolStyleProperty | Identifies the SymbolStyle property.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property.
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property.
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PointSeriesBase Class


PointSeriesBase Constructor

[image]

Mindscape Phone Elements
PointSeriesBase Constructor
PointSeriesBase Class See Also Send Feedback
Initializes a new instance of the PointSeriesBase class

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected PointSeriesBase()
Visual Basic
Protected Sub New
Visual C++
protected:
PointSeriesBase()

See Also

PointSeriesBase Class


PointSeriesBase Fields

[image] [image]

Mindscape Phone Elements
PointSeriesBase Fields
PointSeriesBase Class See Also Send Feedback

The PointSeriesBase type exposes the following members.

Fields

Name | Description
DataLabelStyleProperty | Identifies the DataLabelStyle property.
ShowDataLabelLinesProperty | Identifies the ShowDataLabelLines property.
ShowDataLabelsProperty | Identifies the ShowDataLabels property.
SymbolStyleProperty | Identifies the SymbolStyle property.

See Also

PointSeriesBase Class


DataLabelStyleProperty Field

[image]

Mindscape Phone Elements
PointSeriesBase..::..DataLabelStyleProperty Field
PointSeriesBase Class See Also Send Feedback
Identifies the DataLabelStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DataLabelStyleProperty
Visual Basic
Public Shared ReadOnly DataLabelStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DataLabelStyleProperty

See Also

PointSeriesBase Class


ShowDataLabelLinesProperty Field

[image]

Mindscape Phone Elements
PointSeriesBase..::..ShowDataLabelLinesProperty Field
PointSeriesBase Class See Also Send Feedback
Identifies the ShowDataLabelLines property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowDataLabelLinesProperty
Visual Basic
Public Shared ReadOnly ShowDataLabelLinesProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowDataLabelLinesProperty

See Also

PointSeriesBase Class


ShowDataLabelsProperty Field

[image]

Mindscape Phone Elements
PointSeriesBase..::..ShowDataLabelsProperty Field
PointSeriesBase Class See Also Send Feedback
Identifies the ShowDataLabels property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowDataLabelsProperty
Visual Basic
Public Shared ReadOnly ShowDataLabelsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowDataLabelsProperty

See Also

PointSeriesBase Class


SymbolStyleProperty Field

[image]

Mindscape Phone Elements
PointSeriesBase..::..SymbolStyleProperty Field
PointSeriesBase Class See Also Send Feedback
Identifies the SymbolStyle property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SymbolStyleProperty
Visual Basic
Public Shared ReadOnly SymbolStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SymbolStyleProperty

See Also

PointSeriesBase Class


PointSeriesBase Methods

[image] [image]

Mindscape Phone Elements
PointSeriesBase Methods
PointSeriesBase Class See Also Send Feedback

The PointSeriesBase type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas.
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas.
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the DataSeries on the chart canvas. (Inherited from DataSeries.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object.
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label.
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

PointSeriesBase Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
PointSeriesBase..::..AddDataLabel Method
PointSeriesBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas.
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas.

See Also

PointSeriesBase Class
PointSeriesBase Members


AddDataLabel Method (Int32, Brush)

[image]

Mindscape Phone Elements
PointSeriesBase..::..AddDataLabel Method (Int32, Brush)
PointSeriesBase Class See Also Send Feedback
Adds a data label to the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal void AddDataLabel(
    int index,
    Brush brush
)
Visual Basic
Protected Friend Sub AddDataLabel ( _
    index As Integer, _
    brush As Brush _
)
Visual C++
protected public:
void AddDataLabel(
    int index,
    Brush^ brush
)

Parameters

index
Type: System..::..Int32
The index of the data to create a label for.
brush
Type: System.Windows.Media..::..Brush
The Brush used to color the data label.

See Also

PointSeriesBase Class
AddDataLabel Overload


AddDataLabel Method (Int32, Point, Point, Brush)

[image]

Mindscape Phone Elements
PointSeriesBase..::..AddDataLabel Method (Int32, Point, Point, Brush)
PointSeriesBase Class See Also Send Feedback
Adds a data label to the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal void AddDataLabel(
    int index,
    Point currentPoint,
    Point nextPoint,
    Brush brush
)
Visual Basic
Protected Friend Sub AddDataLabel ( _
    index As Integer, _
    currentPoint As Point, _
    nextPoint As Point, _
    brush As Brush _
)
Visual C++
protected public:
void AddDataLabel(
    int index,
    Point currentPoint,
    Point nextPoint,
    Brush^ brush
)

Parameters

index
Type: System..::..Int32
The index of the data to create a label for.
currentPoint
Type: System.Windows..::..Point
The current logical data position.
nextPoint
Type: System.Windows..::..Point
The next logical data position.
brush
Type: System.Windows.Media..::..Brush
The Brush used to color the data label.

See Also

PointSeriesBase Class
AddDataLabel Overload


GetChartSymbol Method

[image]

Mindscape Phone Elements
PointSeriesBase..::..GetChartSymbol Method
PointSeriesBase Class See Also Send Feedback
Gets the ChartSymbol for the given data object.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ChartSymbol GetChartSymbol(
    Object o,
    int index,
    out Point point
)
Visual Basic
Protected Function GetChartSymbol ( _
    o As Object, _
    index As Integer, _
    <OutAttribute> ByRef point As Point _
) As ChartSymbol
Visual C++
protected:
ChartSymbol^ GetChartSymbol(
    Object^ o,
    int index,
    [OutAttribute] Point% point
)

Parameters

o
Type: System..::..Object
The data object that the ChartSymbol displays.
index
Type: System..::..Int32
The index of the data.
point
Type: System.Windows..::..Point %
The logical plot position of the data.

Return Value

The ChartSymbol to display the given data object.

See Also

PointSeriesBase Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
PointSeriesBase..::..GetPoint Method
PointSeriesBase Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

PointSeriesBase Class
PointSeriesBase Members


PerformLabelBoundsCorrection Method

[image]

Mindscape Phone Elements
PointSeriesBase..::..PerformLabelBoundsCorrection Method
PointSeriesBase Class See Also Send Feedback
Returns the constrained position of a data label.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Point PerformLabelBoundsCorrection(
    double left,
    double top,
    double labelWidth,
    double labelHeight
)
Visual Basic
Protected Function PerformLabelBoundsCorrection ( _
    left As Double, _
    top As Double, _
    labelWidth As Double, _
    labelHeight As Double _
) As Point
Visual C++
protected:
Point PerformLabelBoundsCorrection(
    double left,
    double top,
    double labelWidth,
    double labelHeight
)

Parameters

left
Type: System..::..Double
The desired horizontal position of the data label.
top
Type: System..::..Double
The desired vertical position of the data label.
labelWidth
Type: System..::..Double
The width of the data label.
labelHeight
Type: System..::..Double
The height of the data label.

Return Value

The position of the data label constrained by the bounds of the chart canvas.

See Also

PointSeriesBase Class


PointSeriesBase Properties

[image] [image]

Mindscape Phone Elements
PointSeriesBase Properties
PointSeriesBase Class See Also Send Feedback

The PointSeriesBase type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property.
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property.
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property.
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property.
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

PointSeriesBase Class


DataLabelStyle Property

[image]

Mindscape Phone Elements
PointSeriesBase..::..DataLabelStyle Property
PointSeriesBase Class See Also Send Feedback
Gets or sets the DataLabelStyle. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style DataLabelStyle { get; set; }
Visual Basic
Public Property DataLabelStyle As Style
    Get
    Set
Visual C++
public:
property Style^ DataLabelStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

PointSeriesBase Class


ShowDataLabelLines Property

[image]

Mindscape Phone Elements
PointSeriesBase..::..ShowDataLabelLines Property
PointSeriesBase Class See Also Send Feedback
Gets or sets whether or not to display the data label lines. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowDataLabelLines { get; set; }
Visual Basic
Public Property ShowDataLabelLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDataLabelLines {
    bool get ();
    void set (bool value);
}

See Also

PointSeriesBase Class


ShowDataLabels Property

[image]

Mindscape Phone Elements
PointSeriesBase..::..ShowDataLabels Property
PointSeriesBase Class See Also Send Feedback
Gets or sets whether or not to display the data labels. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowDataLabels { get; set; }
Visual Basic
Public Property ShowDataLabels As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDataLabels {
    bool get ();
    void set (bool value);
}

See Also

PointSeriesBase Class


SymbolStyle Property

[image]

Mindscape Phone Elements
PointSeriesBase..::..SymbolStyle Property
PointSeriesBase Class See Also Send Feedback
Gets or sets the Style applied to the data points. This is a dependency property.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style SymbolStyle { get; set; }
Visual Basic
Public Property SymbolStyle As Style
    Get
    Set
Visual C++
public:
property Style^ SymbolStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

PointSeriesBase Class


PointSeriesBase Events

[image] [image]

Mindscape Phone Elements
PointSeriesBase Events
PointSeriesBase Class See Also Send Feedback

The PointSeriesBase type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PointSeriesBase Class


ScatterSeries Class

[image]

Mindscape Phone Elements
ScatterSeries Class
Members See Also Send Feedback
Plots a scatter series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScatterSeries : PointSeriesBase
Visual Basic
Public Class ScatterSeries _
    Inherits PointSeriesBase
Visual C++
public ref class ScatterSeries : public PointSeriesBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..ScatterSeries

See Also

ScatterSeries Members


ScatterSeries Members

[image] [image]

Mindscape Phone Elements
ScatterSeries Members
ScatterSeries Class Constructors Methods Properties Events See Also Send Feedback

The ScatterSeries type exposes the following members.

Constructors

 | Name | Description
Public method | ScatterSeries | Initializes a new instance of the ScatterSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the ScatterSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ScatterSeries Class


ScatterSeries Constructor

[image]

Mindscape Phone Elements
ScatterSeries Constructor
ScatterSeries Class See Also Send Feedback
Initializes a new instance of the ScatterSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScatterSeries()
Visual Basic
Public Sub New
Visual C++
public:
ScatterSeries()

See Also

ScatterSeries Class


ScatterSeries Methods

[image] [image]

Mindscape Phone Elements
ScatterSeries Methods
ScatterSeries Class See Also Send Feedback

The ScatterSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the ScatterSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

ScatterSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
ScatterSeries..::..AddDataLabel Method
ScatterSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

ScatterSeries Class
ScatterSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
ScatterSeries..::..BuildChartCore Method
ScatterSeries Class See Also Send Feedback
Plots the ScatterSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

ScatterSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
ScatterSeries..::..GetPoint Method
ScatterSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

ScatterSeries Class
ScatterSeries Members


ScatterSeries Properties

[image] [image]

Mindscape Phone Elements
ScatterSeries Properties
ScatterSeries Class See Also Send Feedback

The ScatterSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

ScatterSeries Class


ScatterSeries Events

[image] [image]

Mindscape Phone Elements
ScatterSeries Events
ScatterSeries Class See Also Send Feedback

The ScatterSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

ScatterSeries Class


SplineAreaSeries Class

[image]

Mindscape Phone Elements
SplineAreaSeries Class
Members See Also Send Feedback
Plots a spline area series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SplineAreaSeries : AreaSeries
Visual Basic
Public Class SplineAreaSeries _
    Inherits AreaSeries
Visual C++
public ref class SplineAreaSeries : public AreaSeries

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..AreaSeries
Mindscape.PhoneElements.Charting..::..SplineAreaSeries

See Also

SplineAreaSeries Members


SplineAreaSeries Members

[image] [image]

Mindscape Phone Elements
SplineAreaSeries Members
SplineAreaSeries Class Constructors Methods Properties Events See Also Send Feedback

The SplineAreaSeries type exposes the following members.

Constructors

 | Name | Description
Public method | SplineAreaSeries | Initializes a new instance of the SplineAreaSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the SplineAreaSeries on the chart canvas. (Overrides AreaSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property. (Inherited from AreaSeries.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

SplineAreaSeries Class


SplineAreaSeries Constructor

[image]

Mindscape Phone Elements
SplineAreaSeries Constructor
SplineAreaSeries Class See Also Send Feedback
Initializes a new instance of the SplineAreaSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SplineAreaSeries()
Visual Basic
Public Sub New
Visual C++
public:
SplineAreaSeries()

See Also

SplineAreaSeries Class


SplineAreaSeries Methods

[image] [image]

Mindscape Phone Elements
SplineAreaSeries Methods
SplineAreaSeries Class See Also Send Feedback

The SplineAreaSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the SplineAreaSeries on the chart canvas. (Overrides AreaSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

SplineAreaSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
SplineAreaSeries..::..AddDataLabel Method
SplineAreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

SplineAreaSeries Class
SplineAreaSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
SplineAreaSeries..::..BuildChartCore Method
SplineAreaSeries Class See Also Send Feedback
Plots the SplineAreaSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

SplineAreaSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
SplineAreaSeries..::..GetPoint Method
SplineAreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

SplineAreaSeries Class
SplineAreaSeries Members


GetY Method

[image]

Mindscape Phone Elements
SplineAreaSeries..::..GetY Method
SplineAreaSeries Class See Also Send Feedback
Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override double GetY(
    double x
)
Visual Basic
Public Overrides Function GetY ( _
    x As Double _
) As Double
Visual C++
public:
virtual double GetY(
    double x
) override

Parameters

x
Type: System..::..Double
The logical X axis value.

Return Value

The logical Y axis value.

See Also

SplineAreaSeries Class


SplineAreaSeries Properties

[image] [image]

Mindscape Phone Elements
SplineAreaSeries Properties
SplineAreaSeries Class See Also Send Feedback

The SplineAreaSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property. (Inherited from AreaSeries.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

SplineAreaSeries Class


SplineAreaSeries Events

[image] [image]

Mindscape Phone Elements
SplineAreaSeries Events
SplineAreaSeries Class See Also Send Feedback

The SplineAreaSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

SplineAreaSeries Class


SplineSeries Class

[image]

Mindscape Phone Elements
SplineSeries Class
Members See Also Send Feedback
Plots a spline series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SplineSeries : LineAreaSeriesBase
Visual Basic
Public Class SplineSeries _
    Inherits LineAreaSeriesBase
Visual C++
public ref class SplineSeries : public LineAreaSeriesBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..SplineSeries

See Also

SplineSeries Members


SplineSeries Members

[image] [image]

Mindscape Phone Elements
SplineSeries Members
SplineSeries Class Constructors Methods Properties Events See Also Send Feedback

The SplineSeries type exposes the following members.

Constructors

 | Name | Description
Public method | SplineSeries | Initializes a new instance of the SplineSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the SplineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

SplineSeries Class


SplineSeries Constructor

[image]

Mindscape Phone Elements
SplineSeries Constructor
SplineSeries Class See Also Send Feedback
Initializes a new instance of the SplineSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SplineSeries()
Visual Basic
Public Sub New
Visual C++
public:
SplineSeries()

See Also

SplineSeries Class


SplineSeries Methods

[image] [image]

Mindscape Phone Elements
SplineSeries Methods
SplineSeries Class See Also Send Feedback

The SplineSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the SplineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

SplineSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
SplineSeries..::..AddDataLabel Method
SplineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

SplineSeries Class
SplineSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
SplineSeries..::..BuildChartCore Method
SplineSeries Class See Also Send Feedback
Plots the SplineSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

SplineSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
SplineSeries..::..GetPoint Method
SplineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

SplineSeries Class
SplineSeries Members


GetY Method

[image]

Mindscape Phone Elements
SplineSeries..::..GetY Method
SplineSeries Class See Also Send Feedback
Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override double GetY(
    double x
)
Visual Basic
Public Overrides Function GetY ( _
    x As Double _
) As Double
Visual C++
public:
virtual double GetY(
    double x
) override

Parameters

x
Type: System..::..Double
The logical X axis value.

Return Value

The logical Y axis value.

See Also

SplineSeries Class


SplineSeries Properties

[image] [image]

Mindscape Phone Elements
SplineSeries Properties
SplineSeries Class See Also Send Feedback

The SplineSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

SplineSeries Class


SplineSeries Events

[image] [image]

Mindscape Phone Elements
SplineSeries Events
SplineSeries Class See Also Send Feedback

The SplineSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

SplineSeries Class


StackedAreaSeries Class

[image]

Mindscape Phone Elements
StackedAreaSeries Class
Members See Also Send Feedback
Plots a stacked area series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StackedAreaSeries : AreaSeries
Visual Basic
Public Class StackedAreaSeries _
    Inherits AreaSeries
Visual C++
public ref class StackedAreaSeries : public AreaSeries

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..AreaSeries
Mindscape.PhoneElements.Charting..::..StackedAreaSeries

See Also

StackedAreaSeries Members


StackedAreaSeries Members

[image] [image]

Mindscape Phone Elements
StackedAreaSeries Members
StackedAreaSeries Class Constructors Methods Properties Events See Also Send Feedback

The StackedAreaSeries type exposes the following members.

Constructors

 | Name | Description
Public method | StackedAreaSeries | Initializes a new instance of the StackedAreaSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedAreaSeries on the chart canvas. (Overrides AreaSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property. (Inherited from AreaSeries.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedAreaSeries Class


StackedAreaSeries Constructor

[image]

Mindscape Phone Elements
StackedAreaSeries Constructor
StackedAreaSeries Class See Also Send Feedback
Initializes a new instance of the StackedAreaSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StackedAreaSeries()
Visual Basic
Public Sub New
Visual C++
public:
StackedAreaSeries()

See Also

StackedAreaSeries Class


StackedAreaSeries Methods

[image] [image]

Mindscape Phone Elements
StackedAreaSeries Methods
StackedAreaSeries Class See Also Send Feedback

The StackedAreaSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedAreaSeries on the chart canvas. (Overrides AreaSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

StackedAreaSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
StackedAreaSeries..::..AddDataLabel Method
StackedAreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

StackedAreaSeries Class
StackedAreaSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
StackedAreaSeries..::..BuildChartCore Method
StackedAreaSeries Class See Also Send Feedback
Plots the StackedAreaSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

StackedAreaSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
StackedAreaSeries..::..GetPoint Method
StackedAreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

StackedAreaSeries Class
StackedAreaSeries Members


StackedAreaSeries Properties

[image] [image]

Mindscape Phone Elements
StackedAreaSeries Properties
StackedAreaSeries Class See Also Send Feedback

The StackedAreaSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property. (Inherited from AreaSeries.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

StackedAreaSeries Class


StackedAreaSeries Events

[image] [image]

Mindscape Phone Elements
StackedAreaSeries Events
StackedAreaSeries Class See Also Send Feedback

The StackedAreaSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedAreaSeries Class


StackedBarSeries Class

[image]

Mindscape Phone Elements
StackedBarSeries Class
Members See Also Send Feedback
Plots a stcaked bar series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StackedBarSeries : BarSeries
Visual Basic
Public Class StackedBarSeries _
    Inherits BarSeries
Visual C++
public ref class StackedBarSeries : public BarSeries

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..BarSeries
Mindscape.PhoneElements.Charting..::..StackedBarSeries

See Also

StackedBarSeries Members


StackedBarSeries Members

[image] [image]

Mindscape Phone Elements
StackedBarSeries Members
StackedBarSeries Class Constructors Methods Properties Events See Also Send Feedback

The StackedBarSeries type exposes the following members.

Constructors

 | Name | Description
Public method | StackedBarSeries | Initializes a new instance of the StackedBarSeries class.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedBarSeries on the chart canvas. (Overrides BarSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetTitle | Sets the title of the given Bar based on the TitleBinding property or the bar index if there is no TitleBinding. (Inherited from BarSeries.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BarSizeFactor | Gets or sets the size factor used to calculate the thickness of the bars. This will typically be a value between 0 and 1. This value is the factor between a single axis unit and the thickness of a bar. A value of 1 will cause all the bars to be adjacent with no gaps between them (like a histogram). Smaller values put spaces between the bars. When plotting multiple bar series, the BarSizeFactor is used to calculate the total thickness of all the bars plotted on the same independent axis value. This is a dependency property. The default is 0.8. (Inherited from BarSeries.)
Public property | BarStyle | Gets or sets the Style applied to the bars. This is a dependency property. (Inherited from BarSeries.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Brushes | Gets the brushes used to fill the bars. If there are more bars than brushes, the brushes are used in rotation. (Inherited from BarSeries.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the Style applied to the data labels. This is a dependency property. (Inherited from BarSeries.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in a legend for this BarSeries. (Inherited from BarSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the bars. The default is Orientation.Vertical. This is a dependency property. (Inherited from BarSeries.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowAllLegendItems | Gets or sets whether or not each item in the ItemsSource should have its own legend item. This is a dependency property. (Inherited from BarSeries.)
Public property | ShowDataLabels | Gets or sets the whether or not to display the data labels. This is a dependency property. (Inherited from BarSeries.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | TitleBinding | Gets or sets the data binding used to extract the bar title from each data point. (Inherited from BarSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)
Public property | ZeroLineStyle | Gets or sets the style applied to the zero line of the bar chart. This is a dependency property. (Inherited from BarSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedBarSeries Class


StackedBarSeries Constructor

[image]

Mindscape Phone Elements
StackedBarSeries Constructor
StackedBarSeries Class See Also Send Feedback
Initializes a new instance of the StackedBarSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StackedBarSeries()
Visual Basic
Public Sub New
Visual C++
public:
StackedBarSeries()

See Also

StackedBarSeries Class


StackedBarSeries Methods

[image] [image]

Mindscape Phone Elements
StackedBarSeries Methods
StackedBarSeries Class See Also Send Feedback

The StackedBarSeries type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedBarSeries on the chart canvas. (Overrides BarSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Protected method | SetTitle | Sets the title of the given Bar based on the TitleBinding property or the bar index if there is no TitleBinding. (Inherited from BarSeries.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

StackedBarSeries Class


BuildChartCore Method

[image]

Mindscape Phone Elements
StackedBarSeries..::..BuildChartCore Method
StackedBarSeries Class See Also Send Feedback
Plots the StackedBarSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

StackedBarSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
StackedBarSeries..::..GetPoint Method
StackedBarSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

StackedBarSeries Class
StackedBarSeries Members


StackedBarSeries Properties

[image] [image]

Mindscape Phone Elements
StackedBarSeries Properties
StackedBarSeries Class See Also Send Feedback

The StackedBarSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BarSizeFactor | Gets or sets the size factor used to calculate the thickness of the bars. This will typically be a value between 0 and 1. This value is the factor between a single axis unit and the thickness of a bar. A value of 1 will cause all the bars to be adjacent with no gaps between them (like a histogram). Smaller values put spaces between the bars. When plotting multiple bar series, the BarSizeFactor is used to calculate the total thickness of all the bars plotted on the same independent axis value. This is a dependency property. The default is 0.8. (Inherited from BarSeries.)
Public property | BarStyle | Gets or sets the Style applied to the bars. This is a dependency property. (Inherited from BarSeries.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Brushes | Gets the brushes used to fill the bars. If there are more bars than brushes, the brushes are used in rotation. (Inherited from BarSeries.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the Style applied to the data labels. This is a dependency property. (Inherited from BarSeries.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in a legend for this BarSeries. (Inherited from BarSeries.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Orientation | Gets or sets the Orientation of the bars. The default is Orientation.Vertical. This is a dependency property. (Inherited from BarSeries.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowAllLegendItems | Gets or sets whether or not each item in the ItemsSource should have its own legend item. This is a dependency property. (Inherited from BarSeries.)
Public property | ShowDataLabels | Gets or sets the whether or not to display the data labels. This is a dependency property. (Inherited from BarSeries.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from DataSeries.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | TitleBinding | Gets or sets the data binding used to extract the bar title from each data point. (Inherited from BarSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)
Public property | ZeroLineStyle | Gets or sets the style applied to the zero line of the bar chart. This is a dependency property. (Inherited from BarSeries.)

See Also

StackedBarSeries Class


StackedBarSeries Events

[image] [image]

Mindscape Phone Elements
StackedBarSeries Events
StackedBarSeries Class See Also Send Feedback

The StackedBarSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedBarSeries Class


StackedLineSeries Class

[image]

Mindscape Phone Elements
StackedLineSeries Class
Members See Also Send Feedback
Plots a stacked line series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StackedLineSeries : LineAreaSeriesBase
Visual Basic
Public Class StackedLineSeries _
    Inherits LineAreaSeriesBase
Visual C++
public ref class StackedLineSeries : public LineAreaSeriesBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..StackedLineSeries

See Also

StackedLineSeries Members


StackedLineSeries Members

[image] [image]

Mindscape Phone Elements
StackedLineSeries Members
StackedLineSeries Class Constructors Methods Properties Events See Also Send Feedback

The StackedLineSeries type exposes the following members.

Constructors

 | Name | Description
Public method | StackedLineSeries | Initializes a new instance of the StackedLineSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedLineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedLineSeries Class


StackedLineSeries Constructor

[image]

Mindscape Phone Elements
StackedLineSeries Constructor
StackedLineSeries Class See Also Send Feedback
Initializes a new instance of the StackedLineSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StackedLineSeries()
Visual Basic
Public Sub New
Visual C++
public:
StackedLineSeries()

See Also

StackedLineSeries Class


StackedLineSeries Methods

[image] [image]

Mindscape Phone Elements
StackedLineSeries Methods
StackedLineSeries Class See Also Send Feedback

The StackedLineSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedLineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. (Inherited from LineAreaSeriesBase.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

StackedLineSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
StackedLineSeries..::..AddDataLabel Method
StackedLineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

StackedLineSeries Class
StackedLineSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
StackedLineSeries..::..BuildChartCore Method
StackedLineSeries Class See Also Send Feedback
Plots the StackedLineSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

StackedLineSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
StackedLineSeries..::..GetPoint Method
StackedLineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

StackedLineSeries Class
StackedLineSeries Members


StackedLineSeries Properties

[image] [image]

Mindscape Phone Elements
StackedLineSeries Properties
StackedLineSeries Class See Also Send Feedback

The StackedLineSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

StackedLineSeries Class


StackedLineSeries Events

[image] [image]

Mindscape Phone Elements
StackedLineSeries Events
StackedLineSeries Class See Also Send Feedback

The StackedLineSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedLineSeries Class


StackedSplineAreaSeries Class

[image]

Mindscape Phone Elements
StackedSplineAreaSeries Class
Members See Also Send Feedback
Plots a stacked spline area series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StackedSplineAreaSeries : AreaSeries
Visual Basic
Public Class StackedSplineAreaSeries _
    Inherits AreaSeries
Visual C++
public ref class StackedSplineAreaSeries : public AreaSeries

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..AreaSeries
Mindscape.PhoneElements.Charting..::..StackedSplineAreaSeries

See Also

StackedSplineAreaSeries Members


StackedSplineAreaSeries Members

[image] [image]

Mindscape Phone Elements
StackedSplineAreaSeries Members
StackedSplineAreaSeries Class Constructors Methods Properties Events See Also Send Feedback

The StackedSplineAreaSeries type exposes the following members.

Constructors

 | Name | Description
Public method | StackedSplineAreaSeries | Initializes a new instance of the StackedSplineAreaSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedSplineAreaSeries on the chart canvas. (Overrides AreaSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property. (Inherited from AreaSeries.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedSplineAreaSeries Class


StackedSplineAreaSeries Constructor

[image]

Mindscape Phone Elements
StackedSplineAreaSeries Constructor
StackedSplineAreaSeries Class See Also Send Feedback
Initializes a new instance of the StackedSplineAreaSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StackedSplineAreaSeries()
Visual Basic
Public Sub New
Visual C++
public:
StackedSplineAreaSeries()

See Also

StackedSplineAreaSeries Class


StackedSplineAreaSeries Methods

[image] [image]

Mindscape Phone Elements
StackedSplineAreaSeries Methods
StackedSplineAreaSeries Class See Also Send Feedback

The StackedSplineAreaSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedSplineAreaSeries on the chart canvas. (Overrides AreaSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

StackedSplineAreaSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
StackedSplineAreaSeries..::..AddDataLabel Method
StackedSplineAreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

StackedSplineAreaSeries Class
StackedSplineAreaSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
StackedSplineAreaSeries..::..BuildChartCore Method
StackedSplineAreaSeries Class See Also Send Feedback
Plots the StackedSplineAreaSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

StackedSplineAreaSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
StackedSplineAreaSeries..::..GetPoint Method
StackedSplineAreaSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

StackedSplineAreaSeries Class
StackedSplineAreaSeries Members


GetY Method

[image]

Mindscape Phone Elements
StackedSplineAreaSeries..::..GetY Method
StackedSplineAreaSeries Class See Also Send Feedback
Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override double GetY(
    double x
)
Visual Basic
Public Overrides Function GetY ( _
    x As Double _
) As Double
Visual C++
public:
virtual double GetY(
    double x
) override

Parameters

x
Type: System..::..Double
The logical X axis value.

Return Value

The logical Y axis value.

See Also

StackedSplineAreaSeries Class


StackedSplineAreaSeries Properties

[image] [image]

Mindscape Phone Elements
StackedSplineAreaSeries Properties
StackedSplineAreaSeries Class See Also Send Feedback

The StackedSplineAreaSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AreaStyle | Gets or sets the Style to be applied to the area. This is a dependency property. (Inherited from AreaSeries.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

StackedSplineAreaSeries Class


StackedSplineAreaSeries Events

[image] [image]

Mindscape Phone Elements
StackedSplineAreaSeries Events
StackedSplineAreaSeries Class See Also Send Feedback

The StackedSplineAreaSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedSplineAreaSeries Class


StackedSplineSeries Class

[image]

Mindscape Phone Elements
StackedSplineSeries Class
Members See Also Send Feedback
Plots a stacked spline series on a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StackedSplineSeries : LineAreaSeriesBase
Visual Basic
Public Class StackedSplineSeries _
    Inherits LineAreaSeriesBase
Visual C++
public ref class StackedSplineSeries : public LineAreaSeriesBase

Inheritance Hierarchy

System..::..Object
System.Windows..::..DependencyObject
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
Mindscape.PhoneElements.Charting..::..DataSeries
Mindscape.PhoneElements.Charting..::..PointSeriesBase
Mindscape.PhoneElements.Charting..::..LineAreaSeriesBase
Mindscape.PhoneElements.Charting..::..StackedSplineSeries

See Also

StackedSplineSeries Members


StackedSplineSeries Members

[image] [image]

Mindscape Phone Elements
StackedSplineSeries Members
StackedSplineSeries Class Constructors Methods Properties Events See Also Send Feedback

The StackedSplineSeries type exposes the following members.

Constructors

 | Name | Description
Public method | StackedSplineSeries | Initializes a new instance of the StackedSplineSeries class.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedSplineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedSplineSeries Class


StackedSplineSeries Constructor

[image]

Mindscape Phone Elements
StackedSplineSeries Constructor
StackedSplineSeries Class See Also Send Feedback
Initializes a new instance of the StackedSplineSeries class.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StackedSplineSeries()
Visual Basic
Public Sub New
Visual C++
public:
StackedSplineSeries()

See Also

StackedSplineSeries Class


StackedSplineSeries Methods

[image] [image]

Mindscape Phone Elements
StackedSplineSeries Methods
StackedSplineSeries Class See Also Send Feedback

The StackedSplineSeries type exposes the following members.

Methods

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Public method | AddHandler | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | ApplyTemplate | (Inherited from Control.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeOverride | When overridden in a derived class, positions child elements and determines a size for a FrameworkElement derived class. (Inherited from FrameworkElement.)
Protected method | BuildChartCore | Plots the StackedSplineSeries on the chart canvas. (Overrides DataSeries..::..BuildChartCore()()()().)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CheckAccess | (Inherited from DependencyObject.)
Public method | ClearValue | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ConvertLogicalToPhysicalPoint | Converts the given logical data point to a physical point on the chart canvas. (Inherited from DataSeries.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | Focus | (Inherited from Control.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Protected method | GetChartSymbol | Gets the ChartSymbol for the given data object. (Inherited from PointSeriesBase.)
Protected method | GetDataPoint | Gets the CartesianDataPoint mapped to the given data object and index. (Inherited from DataSeries.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)
Protected method | GetTemplateChild | (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | GetY | Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty. (Overrides LineAreaSeriesBase..::..GetY(Double).)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureOverride | When overridden in a derived class, measures the size in layout required for child elements and determines a size for the FrameworkElement-derived class. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Returns class-specific AutomationPeer implementations for the Windows Presentation Foundation (WPF) infrastructure. (Inherited from UIElement.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLegendItemsChanged | Raises the LegendItemsChanged event. (Inherited from DataSeries.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnLostMouseCapture | (Inherited from Control.)
Protected method | OnManipulationCompleted | (Inherited from Control.)
Protected method | OnManipulationDelta | (Inherited from Control.)
Protected method | OnManipulationStarted | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseLeftButtonDown | (Inherited from Control.)
Protected method | OnMouseLeftButtonUp | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from Control.)
Protected method | PerformLabelBoundsCorrection | Returns the constrained position of a data label. (Inherited from PointSeriesBase.)
Protected method | PrepareDataPoint | Prepares the given CartesianDataPoint to participate in selection features and data notifications. (Inherited from DataSeries.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Protected method | Rebuild | Forces the parent Chart control to rebuild all the data series. (Inherited from DataSeries.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)

See Also

StackedSplineSeries Class


AddDataLabel Method

[image] [image]

Mindscape Phone Elements
StackedSplineSeries..::..AddDataLabel Method
StackedSplineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AddDataLabel(Int32, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)
Protected method | AddDataLabel(Int32, Point, Point, Brush) | Adds a data label to the chart canvas. (Inherited from PointSeriesBase.)

See Also

StackedSplineSeries Class
StackedSplineSeries Members


BuildChartCore Method

[image]

Mindscape Phone Elements
StackedSplineSeries..::..BuildChartCore Method
StackedSplineSeries Class See Also Send Feedback
Plots the StackedSplineSeries on the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void BuildChartCore()
Visual Basic
Protected Overrides Sub BuildChartCore
Visual C++
protected:
virtual void BuildChartCore() override

See Also

StackedSplineSeries Class


GetPoint Method

[image] [image]

Mindscape Phone Elements
StackedSplineSeries..::..GetPoint Method
StackedSplineSeries Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetPoint(CartesianDataPoint) | Returns a Point containing the X and Y logical axis values of the given DataPoint. (Inherited from DataSeries.)
Protected method | GetPoint(CartesianDataPoint, Boolean) | Returns a Point containing the X and Y logical axis values of the given DataPoint. In the case that the given data object is a primitive numerical value, the reverseAxes parameter can be used to specify that YAxis is the independent axis instead of the XAxis by default. This is useful for data series such as horizontal bar charts. (Inherited from DataSeries.)

See Also

StackedSplineSeries Class
StackedSplineSeries Members


GetY Method

[image]

Mindscape Phone Elements
StackedSplineSeries..::..GetY Method
StackedSplineSeries Class See Also Send Feedback
Returns the logical Y axis value for the given X axis value limited to the currently plotted data. Double.NaN is returned if the series is empty.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override double GetY(
    double x
)
Visual Basic
Public Overrides Function GetY ( _
    x As Double _
) As Double
Visual C++
public:
virtual double GetY(
    double x
) override

Parameters

x
Type: System..::..Double
The logical X axis value.

Return Value

The logical Y axis value.

See Also

StackedSplineSeries Class


StackedSplineSeries Properties

[image] [image]

Mindscape Phone Elements
StackedSplineSeries Properties
StackedSplineSeries Class See Also Send Feedback

The StackedSplineSeries type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | CacheMode | (Inherited from UIElement.)
Protected property | Canvas | Gets the Canvas that the DataSeries will be rendered on. (Inherited from DataSeries.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DashArray | Gets or sets the dash array for the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataLabelStyle | Gets or sets the DataLabelStyle. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | DataPoints | Gets a read only collection containing the CartesianDataPoint objects within the DataSeries. A CartesianDataPoint is the graphical representation of plotted data and is created by the DataSeries. (Inherited from DataSeries.)
Protected property | DefaultStyleKey | (Inherited from Control.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HighlightMode | Gets or sets the highlight mode of the DataPoint objects in the DataSeries. The default is DataPointHighlightMode.None. This is a dependency property. (Inherited from DataSeries.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | IndexStep | Gets the index step between data point that are to be rendered. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | ItemsSource | Gets or sets the ItemsSource. This is the data to be plotted on a Chart control. This is a dependency property. (Inherited from DataSeries.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LegendIconTemplate | Gets or sets the LegendIconTemplate. This is a dependency property. (Inherited from DataSeries.)
Public property | LegendItems | Gets a list of legend items to be displayed in the legend for this DataSeries. (Inherited from DataSeries.)
Public property | LineStyle | Gets or sets the style to be applied to the line. This is a dependency property. (Inherited from LineAreaSeriesBase.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MaximumIndex | Gets the index of the data that is closest to the actual maximum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | MinimumIndex | Gets the index of the data that is closest to the actual minimum value of the independent axis. Custom data series can use this value to optimise chart rendering. (Inherited from DataSeries.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | Projection | (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SelectedDataPoint | Gets the currently selected CartesianDataPoint. This will be null if none of the data points in the DataSeries are selected. (Inherited from DataSeries.)
Public property | SelectionMode | Gets or sets the selection mode for the DataPoint objects displayed in the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Protected property | Series | Gets the observable collection of DataSeries. This contains all the data series that are being plotted by the same Chart as this one. (Inherited from DataSeries.)
Public property | SeriesBrush | Gets or sets the Brush used to color the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | ShowDataLabelLines | Gets or sets whether or not to display the data label lines. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | ShowDataLabels | Gets or sets whether or not to display the data labels. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Public property | SupportsDataSampling | Gets whether the DataSeries supports sampling for large data sets. (Inherited from LineAreaSeriesBase.)
Public property | SymbolStyle | Gets or sets the Style applied to the data points. This is a dependency property. (Inherited from PointSeriesBase.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | Title | Gets or sets the title of the DataSeries. This is a dependency property. (Inherited from DataSeries.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | XAxis | Gets the X axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | XBinding | Gets or sets a binding used to extract the X axis value from a data object. (Inherited from DataSeries.)
Public property | YAxis | Gets the Y axis that the DataSeries is plotted against. (Inherited from DataSeries.)
Public property | YAxisTitle | Gets or sets the title of the Y axis that this data series will be plotted against. This is used for plotting along an alternate Y axis of the Chart. This is a dependency property. (Inherited from DataSeries.)
Public property | YBinding | Gets or sets a binding used to extract the Y axis value from a data object. (Inherited from DataSeries.)

See Also

StackedSplineSeries Class


StackedSplineSeries Events

[image] [image]

Mindscape Phone Elements
StackedSplineSeries Events
StackedSplineSeries Class See Also Send Feedback

The StackedSplineSeries type exposes the following members.

Events

 | Name | Description
Public event | BindingValidationError | (Inherited from FrameworkElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | IsEnabledChanged | (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | LegendItemsChanged | Raised when the legend items for this DataSeries changes. (Inherited from DataSeries.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

StackedSplineSeries Class


TickMarkMode Enumeration

[image]

Mindscape Phone Elements
TickMarkMode Enumeration
See Also Send Feedback
Specifies how tick marks respond to panning the chart canvas.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum TickMarkMode
Visual Basic
Public Enumeration TickMarkMode
Visual C++
public enum class TickMarkMode

Members

Member name | Value | Description
Stationary | 0 | Tick marks are stationary. The first tick mark will always start at the very start of the axis and adopt whatever axis value they land on.
Movable | 1 | Tick marks will slide as the chart canvas is panned. This will allow tick marks to be lined up with number series such as 0,1,2,3... or 0,0.5,1,1.5... or 0,10,20,30...

See Also


ZoomMode Enumeration

[image]

Mindscape Phone Elements
ZoomMode Enumeration
See Also Send Feedback
Specifies the zoom mode of a Chart control.

Namespace: Mindscape.PhoneElements.Charting
Assembly: Mindscape.PhoneElements (in Mindscape.PhoneElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ZoomMode
Visual Basic
Public Enumeration ZoomMode
Visual C++
public enum class ZoomMode

Members

Member name | Value | Description
None | 0 | No zooming.
Vertical | 1 | Zooming can be performed along the vertical axis only.
Horizontal | 2 | Zooming can be performed along the horizontal axis only.
Both | 3 | Zooming can be performed along both vertical and horizontal axes.

See Also