Introduction, Features & Installation

Mindscape Silverlight Elements
Introduction, Features & Installation

Mindscape Elements for Silverlight

Mindscape Elements for Silverlight includes a number of controls for building applications on Microsoft’s Silverlight platform. Controls include:

  • ColorPicker controls (palette and mixer)
  • CoverFlow animated list display
  • ListView for tabular data layout
  • MulticolumnTreeView for hierarchical presentation of tabular data
  • RichTextEditor supporting HTML
  • Scheduler for Outlook-style calendars

Dependencies

Some features of Silverlight Elements depend on non-core Silverlight components such as the Silverlight Toolkit. In particular, the MulticolumnTreeView control requires the System.Windows.Controls.Toolkit DLL from the October 2009 Silverlight Toolkit. This can be obtained from CodePlex or is included in the Silverlight Elements installation directory.

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


Getting Started

Getting Started

To use Silverlight Elements in your project, drag a control from the toolbox onto the visual design surface, or add a reference to the Mindscape.SilverlightElements assembly using the Add Reference command. You can find the assembly in your Program Files directory under Mindscape > Silverlight Elements.

You may wish to copy Silverlight Elements to a project-specific directory (such as a Libraries or Lib directory), and reference it at this location, so that you can version it on a per-project basis.

If you are writing XAML by hand, use the following XML namespace declaration to bring Silverlight Elements:

CopyXML
xmlns:ms="clr-namespace:Mindscape.SilverlightElements;assembly=Mindscape.SilverlightElements"


Samples

Samples

Silverlight Elements includes the following samples:

  • QuickStart: Shows each of the Elements controls in isolation.

To open the samples in Visual Studio, choose Samples from the Mindscape Silverlight Elements group in the Start menu.


Color Picker Controls

Color Picker Controls

ColorPicker

The ColorPicker control allows users to select a color from a standard palette of named colors, or by choosing RGB values using sliders.

Optionally, you can also provide your own color palette, similar to the color palettes in Microsoft Office applications. See the StandardPalettes class for built-in palettes or create your own. If you create your own, it should be a list of ColorPickerItem objects. The default display expects this list to be arranged as follows:

  • 10 “theme” colors.
  • For each “theme” color, 5 variants of that color. Each block of variants must be contiguous and the blocks must appear in the same order as the “theme” colors. For example, elements 10-14 of the list would be the variants on theme color 0, elements 15-19 the variants of theme color 1, etc.
  • 10 “standard” colors.
To access the selected color, use the SelectedColor property. You can use the ColorToSolidColorBrushConverter to convert this color to a brush. The example shows how to bind the Background of another element to the ColorPicker selection.
CopyExample Usage
<UserControl.Resources>
  <ms:ColorToSolidColorBrushConverter x:Key="scb" />
</UserControl.Resources>

<StackPanel>
  <ms:ColorPicker Name="cp" />
  <Border Width="40" Height="40"
          Background="{Binding SelectedColor, ElementName=cp, Converter={StaticResource scb}}"
          />
</StackPanel>

PaletteColorPicker

The PaletteColorPicker restricts the user to selecting from a specific palette which you provide. The rules for constructing this palette are the same as for the ColorPicker, except that the list must contain an additional “automatic” color as the first element, i.e.

  • 1 “automatic” color.
  • 10 “theme” colors.
  • For each “theme” color, 5 variants of that color (as above).
  • 10 “standard” colors.
CopyExample Usage - Simple
<ms:PaletteColorPicker SelectedColor="AliceBlue" />
To customise the display of the collapsed part of the PaletteColorPicker, for example to provide a legend or visual hint as to what is affected by the selection, use the CollapsedViewTemplate property. The specified template will be bound to a ColorPickerItem representing the current selection.
CopyExample Usage - Template
<UserControl.Resources>
  <ms:ColorToSolidColorBrushConverter x:Key="scb" />
</UserControl.Resources>

<ms:PaletteColorPicker SelectedColor="DarkRed">
  <ms:PaletteColorPicker.CollapsedViewTemplate>
    <DataTemplate>
      <Border Width="28" Height="20">
        <TextBlock Text="A"
                   TextAlignment="Center"
                   FontSize="16"
                   FontWeight="Bold"
                   Foreground="{Binding Color, Converter={StaticResource scb}}" />
      </Border>
    </DataTemplate>
  </ms:PaletteColorPicker.CollapsedViewTemplate>
</ms:PaletteColorPicker>


CoverFlow Control

CoverFlow Control

CoverFlow

The CoverFlow control presents a collection of items as a horizontal list, with the selected item centred and enlarged. Unselected items are shown smaller around the selected item, optionally with a pseudo-3D “tilt” effect.

CoverFlow is typically used to present a gallery of images such as book covers or video previews.

The CoverFlow control has a large number of options which you can use to control the visual appearance of the list, including:

  • the tilt, perspective and spacing of unselected items
  • the spacing of the selected item
  • the relative scaling of selected and unselected items
  • showing a reflection below the items

You can also select whether the user needs to click to select an item, or merely point. (Pointing provides a very easy and attractive way to sweep through a large number of items, but may require careful layout to ensure that the user is able to stop once the desired item is selected.) The QuickStart sample provides a dashboard that you can use to experiment with these options to choose the right user interaction and visual appearance for your application.

CopyExample Usage
<ms:CoverFlow ItemsSource="{Binding Images}"
              ItemWidth="180" ItemHeight="180"
              ShearAngle="12"
              ItemSeparation="110"
              SelectedItemSeparation="200"
              ScaleX="0.75" ScaleY="0.75"
              ShowReflection="True"
              ReflectionScaleY="0.6"
              MouseSelectionMode="MouseEnter"
              />


ListView Control

ListView Control

ListView

The ListView control provides a tabular view of data, similar to a ListBox but with multiple columns.

To set up the columns of a ListView, use the Columns property, and provide a collection of GridViewColumn objects. For each GridViewColumn, you will typically want to set:

  • Header: the content displayed in the column header
  • Width: the width of the column
  • One of DisplayMemberBinding, CellTemplate and CellTemplateSelector. For simple textual display, specify DisplayMemberBinding. To apply a DataTemplate, specify CellTemplate: the DataTemplate will be applied to the item being shown in the row, just as in a ListBox. To choose between a set of DataTemplates based on custom criteria, use CellTemplateSelector.

The following example uses DisplayMemberBinding for a simple textual display:

CopyExample Usage
<ms:ListView ItemsSource="{Binding}">
  <ms:ListView.Columns>
    <ms:GridViewColumn Header="Name" Width="100" DisplayMemberBinding="{Binding Name}" />
    <ms:GridViewColumn Header="Owner" Width="100" DisplayMemberBinding="{Binding Owner}" />
    <ms:GridViewColumn Header="Height" Width="100" DisplayMemberBinding="{Binding Height}" />
  </ms:ListView.Columns>
</ms:ListView>

The following example uses CellTemplate to allow users to edit the displayed value:

CopyExample Usage
<UserControl.Resources>
  <DataTemplate x:Key="NameEditor">
    <TextBox Text="{Binding Name, Mode=TwoWay}" />
  </DataTemplate>
</UserControl.Resources>

<ms:ListView ItemsSource="{Binding}">
  <ms:ListView.Columns>
    <ms:GridViewColumn Header="Name" Width="100" CellTemplate="{StaticResource NameEditor}" />
  </ms:ListView.Columns>
</ms:ListView>

Customizing the ListView Control

You can customize the appearance of headers using the ColumnHeaderTemplate and ColumnHeaderContainerStyle properties. Per-column customization is available via the HeaderTemplate, HeaderTemplateSelector and HeaderContainerStyle properties on GridViewColumn.

To allow users to reorder the columns, set the AllowsColumnReorder property.


MulticolumnTreeView Control

MulticolumnTreeView Control

MulticolumnTreeView

Using the MulticolumnTreeView

The MulticolumnTreeView control extends the Silverlight SDK TreeView control to support showing multiple columns in a grid or ListView-like format.

To set up the columns of a MulticolumnTreeView, follow the same instructions as for a ListView.

In addition to defining the columns, you must also tell the MulticolumnTreeView how to determine the children for each item in the tree. To do this, you must provide an ItemTemplate of type HierarchicalDataTemplate, with its ItemsSource property set to tell the tree how to expand the hierarchy.

Here is an example in which the sub-items for each item in the tree are derived from the Children property:

CopyExample Usage
<ms:MulticolumnTreeView Name="mctv" Margin="30" Grid.Column="1" ItemsSource="{Binding}">
  <ms:MulticolumnTreeView.ItemTemplate>
    <swc:HierarchicalDataTemplate ItemsSource="{Binding Children}" />
  </ms:MulticolumnTreeView.ItemTemplate>
  <ms:MulticolumnTreeView.Columns>
    <ms:GridViewColumn Header="Name" Width="100" DisplayMemberBinding="{Binding Name}" />
    <ms:GridViewColumn Header="Owner" Width="100" DisplayMemberBinding="{Binding Owner}" />
    <ms:GridViewColumn Header="Height" Width="100" DisplayMemberBinding="{Binding Height}" />
  </ms:MulticolumnTreeView.Columns>
</ms:MulticolumnTreeView>

See ListView for further examples.

To use different expansion paths at different levels of the tree, set HierarchicalDataTemplate.ItemTemplate to be the template for the next level down.

Note that any content in the HierarchicalDataTemplate is ignored. Items in a MulticolumnTreeView are displayed in a tabular format according to the Columns property, and cells are presented according to the column’s settings.

Customizing the MulticolumnTreeView Control

You can customize a MulticolumnTreeView in the same way as a ListView.

In addition, you can customize the expand/collapse user interface by setting the ExpandingDecorator property. This property contains a template which the MulticolumnTreeView wraps around the leftmost column. The default template is identified by the ExpandingCellTemplateKey.

Templating the MulticolumnTreeView

When templating the MulticolumnTreeView, your template should base its layout on the WrappedColumns property, not the Columns property. This ensures that your template will inherit the expand/collapse user interface supplied by the MulticolumnTreeView. If you do not do this then users of your template will have to supply their own expand/collapse user interface as part of their CellTemplates.


Rich Text Editor Control

Rich Text Editor Control

RichTextEditor

The RichTextEditor control allows users to edit text and apply different formats to different parts of that text. The following formatting options are supported:

  • Font family and size
  • Font style and weight (italics, bold, underline)
  • Foreground color
  • Background color
  • Bulleted and numbered lists
  • Paragraph alignment (left, right, center)
  • Hyperlinks

The easiest way to provide these formatting options to your users is using the StandardRichTextEditorToolBar. This provides a user interface for applying all of the above options. Set the Editor property to attach a toolbar to an editor:

CopyExample Usage
<ms:StandardRichTextEditorToolBar Editor="{Binding ElementName=TextEditor}" />
<ms:RichTextEditor x:Name="TextEditor" />

If you want to provide your own user interface for applying formatting, use the various Apply methods on the RichTextEditor control.

Importing and Exporting HTML

To export HTML from the RichTextEditor control, use the Html property. HTML is generated on demand and the Html property is therefore not suitable for use as a binding source (the control does not raise change notifications for it). This reflects the usual pattern of HTML editing where the user chooses when to post or preview their content, for example by clicking a button.

To load HTML into the RichTextEditor control, call the LoadHtml method. LoadHtml does not implement a full HTML parser, and will ignore elements or styles that it does not recognise. You should generally use LoadHtml only to reload HTML that was originally exported from the RichTextEditor via the Html property.

CopySetting HTML Page Content - HTML
<div id="htmlDisplay" />
CopySetting HTML Page Content - C#
private void ShowHtmlOnPage()
{
  HtmlElement element = HtmlPage.Document.GetElementById("htmlDisplay");
  if (element != null)
  {
    element.SetProperty("innerHTML", TextEditor.Html);
  }
}


Scheduler Control

Scheduler Control

Scheduler

The Scheduler control provides an interface for creating, viewing and editing time-based items on a calendar-style user interface. A Scheduler can present day-based, week-based or month-based views, and provides a user interface for users to select views and navigate between dates. You can use a Scheduler to show appointments, tasks, bookings and so on.

CopyExample Usage - XAML
<ms:Scheduler x:Name="SchedulerControl" />

Customising the Add and Edit Behavior

When the user creates a new schedule item, the Scheduler raises the ItemAdded event. By default, this displays a child window where the user can edit the new item (e.g. setting a name, editing the duration, setting up recurrence). To suppress the default behaviour and show your own “Add Item” user interface instead, handle the ItemAdded event. If you want to show the default user interface, but still need to be notified when items are added, set ShowDefaultEditor to true in the AddScheduleItemEventArgs.

When the user double-clicks a schedule item, the Scheduler raises the ItemActivated event. If you want to allow the user to edit the item they have double-clicked, create and show a ScheduleItemDialog, passing the ScheduleItem from the ScheduleItemEventArgs.

Setting Up the Schedule

You can access the schedule via the Schedule property. See the Schedule class for more information. Use the AddItem method to add items to the Schedule and RemoveItem to remove them.

Each item in the schedule is represented by a ScheduleItem. This contains information such as the start and end time, the name of the item, etc. You can subclass ScheduleItem to include additional information such as the priority of a task. (Note that the various “create item” UI elements in the Scheduler control itself only create ScheduleItem base class objects.)

CopyExample Usage - Code
private void AddTryTask()
{
  SchedulerControl.Schedule.AddItem(new ScheduleItem
  {
    StartTime = DateTime.Now.Date.AddHours(8),
    EndTime = DateTime.Now.Date.AddHours(9),
    Name = "Try Silverlight Elements"
  });
}

Saving and Loading Schedules

The Scheduler control does not provide a built-in way to store or load a schedule. This is because schedules will typically be stored in a database, so as to allow querying, raising alerts, etc. Storage will therefore be dependent on the database design, the WCF service interface, etc.

To save or load the schedule, use the Scheduler.Schedule property. To read the contents of the schedule so that you can store them, use the Schedule.Items property. To populate a schedule when loading from a store, use the Schedule.AddItem method.

The following code provides a simple example of saving and loading using XML. This could for example be used to store a schedule in isolated storage on the client machine.

CopyExample - Saving and Loading a Schedule
private static void WriteSchedule(Stream stm, Schedule schedule)
{
  XElement element = new XElement("Schedule", schedule.Items.Select(si => new XElement("Item",
    new XAttribute("Name", si.Name),
    new XAttribute("StartTime", si.StartTime),
    new XAttribute("EndTime", si.EndTime),
    si.IsRecurring ?
      new XElement("Recurrence",
        new XAttribute("StartDate", si.RecurrenceInfo.StartDate),
        new XAttribute("StartTime", si.RecurrenceInfo.StartTime),
        new XAttribute("Duration", si.RecurrenceInfo.Duration),
        new XAttribute("EndDate", si.RecurrenceInfo.EndDate),
        new XAttribute("EndType", si.RecurrenceInfo.EndType),
        new XAttribute("MaxOccurrences", si.RecurrenceInfo.MaxOccurrences),
        si.RecurrenceInfo.RecurrencePattern.ToXml()
        )
      : null
    )));
  element.Save(stm);
}

private static void ReadSchedule(Stream stm, Schedule schedule)
{
  XDocument document = XDocument.Load(stm);
  IEnumerable<ScheduleItem> items = document.Elements("Schedule").Elements("Item").Select(e => new ScheduleItem
  {
    Name = (string)e.Attribute("Name"),
    StartTime = (DateTime)e.Attribute("StartTime"),
    EndTime = (DateTime)e.Attribute("EndTime"),
    RecurrenceInfo = e.Elements("Recurrence").Select(rel => new RecurrenceInfo
    (
      (DateTime)rel.Attribute("StartDate"),
      (TimeSpan)rel.Attribute("StartTime"),
      (TimeSpan)rel.Attribute("Duration"),
      rel.Elements().First().ParseRecurrencePattern(),
      (RecurrenceEndType)(Enum.Parse(typeof(RecurrenceEndType), (string)rel.Attribute("EndType"), true)),
      (DateTime)rel.Attribute("EndDate"),
      (int)rel.Attribute("MaxOccurrences")
    )).FirstOrDefault()
  });

  schedule.Clear();

  foreach (ScheduleItem item in items)
  {
    schedule.AddItem(item);
  }
}

Silverlight Elements does provide a pair of helper methods for saving recurrence information as XML, in the RecurrencePatternXmlSerializer class. It is not recommended that you save recurrence information as XML in your database, as this will make querying difficult, but these methods may be useful for creating and parsing serialisable representations to be passed to or from a WCF service, or if you are storing data locally using isolated storage. Usage of these helper methods is shown in the sample code above.


Mindscape.SilverlightElements Namespace

[image]

Mindscape Silverlight Elements
Mindscape.SilverlightElements Namespace
Send Feedback
The Mindscape.SilverlightElements namespace contains the Silverlight Elements controls and supporting classes.

Classes

Class | Description
AddScheduleItemEventArgs | Contains event data relating to adding a ScheduleItem to a schedule.
BooleanToBrushConverter | Selects a brush according to a boolean value.
BooleanToStyleConverter | Selects a style according to a boolean value.
BooleanToThicknessConverter | Selects a Thickness according to a boolean value.
BooleanToVisibilityConverter | Converts a Boolean value to a visibility.
Click | Provides attached properties for assigning commands to buttons.
ColorChannelAdjustmentBrushConverter | Converts a color or solid brush to a gradient brush showing the effects of adjusting one channel on that color. This is used for displaying mixer channels in a ColorPicker template.
ColorPicker | A control where users can select a color from a swatch or palette or using a mixer.
ColorPickerBase | The common base class for color selection controls.
ColorPickerItem | Represents an entry (a color selection) in a ColorPickerBase control.
ColorSliderRepeatButtonTemplateSelector | Selects a ControlTemplate for the RepeatButton part of a channel mixer in a ColorPicker control.
ColorToNameConverter | Converts between Color values and names.
ColorToSolidColorBrushConverter | Converts a Color to a SolidColorBrush.
ContentColumnMapping | Contains the mapping between content and columns in a ListView.
CoverFlow | A control that arranges items in a row such that the selected object is displayed in the center of the control, with the other items arranged to either side in a pseudo-perspective view, and animates the transition when the selection changes.
CoverFlowItem | Implements a selectable item within a CoverFlow.
DataTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element.
DateRangeDisplayConverter | Formats the date range of a ScheduleView suitably for display in the SchedulerNavigationBar.
DateTimeToDayOfMonthStringConverter | Converts a date to a string suitable for display as the day caption in a monthly view. By default, this is the day of the month (e.g. "15"). However, if the day is part of a week that spans a month boundary, then the month is appended if the day is the first day of that week, or the first day of the month. For example, in the week beginning 29 March 2010, 29 March would be formatted as "29 Mar", 30 March as "30", 31 March as "31" and 1 April as "1 Apr". Similar display logic applies to weeks that span a year boundary.
DateTimeToDayOfWeekStringConverter | Formats a DateTime as a day of the week (e.g. "Monday").
DateTimeToFullDateStringConverter | Converts a date to its full date representation (e.g. "1 January 2010").
DateTimeToMonthStringConverter | Converts a DateTime value to its full month name (e.g. "January").
DayView | Represents a single-day view in a Scheduler control.
DimensionConverter | Converts a dimension to an adjusted value.
EditableTextBlock | Represents a text area that is read-only normally, but can be clicked to enable editing.
ElementViewStatusToBrushConverter | Selects a brush according to an ElementViewStatus.
EveryNDaysRecurrencePattern | Represents the recurrence of a ScheduleItem at a regular daily interval.
EveryWeekdayRecurrencePattern | Represents the recurrence of a ScheduleItem on every weekday (Monday to Friday).
ExpandableCellTemplateInfo | Contains templating information for an expandable cell in a MulticolumnTreeView.
GridViewColumn | Represents a column definition in a ListView or MulticolumnTreeView.
GridViewColumnCollection | Represents a collection of GridViewColumn objects.
GridViewColumnHeader | Displays a single column header in a ListView.
GridViewColumnResizer | Provides a user interface for resizing a GridViewColumn by dragging or double-clicking the mouse.
HyperlinkDialog | Represents a dialog for adding or editing a hyperlink in a RichTextEditor.
LeftMarginConverter | Converts a double value to a Thickness representing a left margin offset.
LevelToIndentConverter | Converts an integer level to a Thickness for indenting that level.
ListStyleTypePicker | A control for selecting list styles in a RichTextEditor.
ListStyleTypes | Provides access to the list styles supported by the RichTextEditor.
ListToSubListConverter | Extracts a sub-list from a master list.
ListView | A control which displays a list of items in a tabular format with multiple columns.
ListViewHeaderRow | Displays column headers in a ListView.
ListViewItem | Represents an item in a ListView.
ListViewItemBase | Represents an item in a ListView.
MinuteOfHourBrushConverter | Selects a brush according to whether a minutes value is on the hour or not.
MonthlyPatternRecurrencePattern | Represents the recurrence of a ScheduleItem on a monthly schedule defined by a pattern (e.g. last Friday of every second month).
MonthlyRecurrencePattern | Represents the recurrence of a ScheduleItem on a monthly basis.
MonthView | Represents a month view in a Scheduler control.
MonthViewDayElement | Displays a single day in the month view of a Scheduler.
MouseWheel | Provides access to mouse wheel events.
MouseWheelEventArgs | Contains data for mouse wheel events.
MulticolumnTreeView | A control with the expand/collapse functionality of a TreeView, but supporting multiple columns like a ListView.
MulticolumnTreeViewItem | Implements a selectable item in a MulticolumnTreeView control.
NamedColor | Associates a name with a color according to the Silverlight color naming standard.
NegativeConverter | Converts a double value to its negative.
NotifyingColor | Encapsulates a Color and provides notification of changes to individual channels in order to support Silverlight data binding.
NthDayOfMonthRecurrencePattern | Represents the recurrence of a ScheduleItem on a monthly basis on specific day of the month (e.g. the 20th of every third month).
PaletteColorPicker | A control where users can select a color from a fixed palette.
RecurrenceDialog | Provides a user interface for editing the recurrence pattern of a recurring ScheduleItem.
RecurrenceInfo | Specifies the recurrence schedule for a ScheduleItem.
RecurrencePattern | Represents the recurrence pattern of a recurring ScheduleItem.
RecurrencePatternXmlSerializer | Contains helper methods for serializing recurrence patterns to XML.
ReflectionPositionConverter | Calculates the offset of reflection elements within a CoverFlow.
RichTextEditor | Provides a user interface for editing formatted text such as HTML.
ScalingConverter | Scales the input by a specified amount.
Schedule | Contains schedule data for display in a Scheduler control.
ScheduleItem | Represents an item such as an appointment or task in a Schedule.
ScheduleItemCollectionChangedEventArgs | Provides event data for when a ScheduleItem is added to or removed from a collection.
ScheduleItemDialog | Provides a dialog-based interface for editing a ScheduleItem.
ScheduleItemEventArgs | Provides data for an event pertaining to a ScheduleItem.
ScheduleItemMover | Provides a user interface for moving a ScheduleItem by dragging with the mouse.
ScheduleItemTimeChanger | Provides a user interface for changing the start or end time of a ScheduleItem by dragging with the mouse.
Scheduler | A control which displays a schedule, for example of appointments or tasks, using a set of calendar views.
SchedulerCanvas | Represents a canvas on which schedule items can be laid out in a detail view.
SchedulerCanvasBase | Represents a canvas on which schedule items can be laid out.
SchedulerElement | Represents a ScheduleItem on a display surface (typically a SchedulerCanvasBase.
SchedulerElementDisplayStateToCornerRadiusConverter | Calculates the corner radius for displaying a SchedulerElement in a view. The element is given rounded corners on the left or top if it includes the start of the schedule item, and on the right or bottom if it includes the end of the schedule item; otherwise, the item is given non-rounded corners.
SchedulerElementDisplayStateToThicknessConverter | Calculates the margin for displaying a SchedulerElement in a view. The element is offset from the left if includes the start of the schedule item, and from the right if includes the end of the schedule item; otherwise, the element bleeds to the edge of the view.
SchedulerElementDisplayStateToTimeStringConverter | Formats the time component of a SchedulerElementDisplayState for display.
SchedulerNavigationBar | Provides a user interface for navigating through a Schedule displayed in a Scheduler control.
ScheduleView | The base class for specific views in the Scheduler (day, week and month views).
SizeToMarginConverter | Scales and converts a Size to a Thickness for use as a margin.
SmallSchedulerCanvas | Represents a canvas on which schedule items can be laid out in a summary view.
SpecificDateYearlyRecurrencePattern | Represents the recurrence of a ScheduleItem on a yearly basis on specific day of the year (e.g. every 25th of April).
StandardPalettes | Provides standard palettes for use with the ColorPicker control.
StandardRichTextEditorToolBar | Provides a standard toolbar for use with the RichTextEditor control.
StringTemplate | Maps a string to a data template in a StringToDataTemplateConverter.
StringToDataTemplateConverter | Selects a data template using strings as keys.
TemplateSelectableContentControl | Displays content using either a content template, a content template selector or a simple display member binding.
TimeOfDayToMinuteStringConverter | Converts a time to a string suitable for display in the "minute" portion of the "time of day" bar in a day or week view.
TimeOfDayToStringConverter | Converts a TimeOfDay object into a formatted string displaying the hours, minutes and AM/PM designator. Hours are displayed in 12 hour clock time. Minutes are always displayed with 2 digits.
TimeOfDayVerticalOffsetConverter | Determines the vertical offset at which to display items corresponding to a particular time of day.
TimePicker | Provides a user interface for selecting a time of day by entering a time or selecting from a drop-down list.
TimeSlot | Represents a slot on the display surface of a Scheduler control.
TimeSlotStateToBrushConverter | Selects a brush according to an TimeSlotState.
TimeSpanPicker | Provides a user interface for selecting a duration or TimeSpan by entering a value directly or selecting from a drop-down list.
TimeSpanToLinearDimensionConverter | Converts a TimeSpan to a linear dimension.
TimeSpanToStringConverter | Converts a TimeSpan to a formated string showing the number of minutes, hours, days or weeks.
TimeStringConverterBase | Provides a base class for converters that output strings representing times.
TypeMatchVisibilityConverter | Selects the visibility of an element according to whether the input is of a specified type.
UniformGrid | Provides uniform sizing and spacing in a single row or column.
ViewModelBase | Provides property change notification servics for view model objects.
WeeklyRecurrencePattern | Represents the recurrence of a ScheduleItem on a weekly basis.
WeekToStringConverter | Formats a week as a date range string.
WeekView | Represents a week view in a Scheduler control.
YearlyPatternRecurrencePattern | Represents the recurrence of a ScheduleItem on a yearly basis according to a pattern (e.g. the first Tuesday of November every four years).
YearlyRecurrencePattern | Represents the recurrence of a ScheduleItem on a yearly basis.
ZeroPaddingConverter | Converts a doube value to a zero-padded string.

Structures

Structure | Description
DateRange | Represents a range of dates.
DateRangeDisplayInfo | Provides display information for a date range.
SchedulerElementDisplayState | Contains display information for a SchedulerElement.
TimeOfDay | Represents a time of day.

Interfaces

Interface | Description
IDoubleClickObserver | Implemented by controls that want to receive notifications when the user double-clicks.
IListStyleType | Represents a list style, such as round bullets or Roman numbering.
IMouseWheelObserver | Implemented by controls that want to be notified of mouse wheel events.
IRecurrencePattern | Represents the recurrence pattern of a recurring ScheduleItem.

Enumerations

Enumeration | Description
ColorChannel | Represents one of the four channels of a Color.
CoverFlowMouseSelectionMode | Specifies how the mouse can be used to interactively select an item within a CoverFlow.
DateDisplayMode | Specifies whether dates should be formatted with the day of the month or as the month name only.
DayOfRecurrence | The day on which a recurring schedule item recurs. This may be a day of the week, or it may match multiple days of the week (as in "last day of the month" or "first weekday in January"). It is used in conjunction with the Occurrence type.
ElementViewStatus | Provides status information for use in rendering a MonthViewDayElement.
GridViewColumnHeaderRole | Defines the state or role of a GridViewColumnHeader control.
HyperlinkDialogType | Specifies whether to display a HyperlinkDialog as an edit or create dialog.
ListType | Specifies whether a list in a RichTextEditor has ordered captions.
Occurrence | Specifies on which occurrence of a day in a month a recurring schedule item recurs (as in "last Friday of the month" or "first weekday in January"). This is used in conjunction with the DayOfRecurrence type.
RecurrenceEndType | Specifies when a recurring schedule item will end.
RichTextEditorBlockType | Specifies the type of block element containing the caret in a RichTextEditor.
TimeEnd | Specifies which end (start or finish) of a schedule item is being referred to.
TimeSlotState | Specifies status information used for rendering a TimeSlot.
WeekViewMode | Specifies whether to show a full week in Week view, or only the work week (Monday to Friday).


AddScheduleItemEventArgs Class

[image]

Mindscape Silverlight Elements
AddScheduleItemEventArgs Class
Members See Also Send Feedback
Contains event data relating to adding a ScheduleItem to a schedule.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AddScheduleItemEventArgs : ScheduleItemEventArgs
Visual Basic (Declaration)
Public Class AddScheduleItemEventArgs _
    Inherits ScheduleItemEventArgs
Visual C++
public ref class AddScheduleItemEventArgs : public ScheduleItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mindscape.SilverlightElements..::.ScheduleItemEventArgs
Mindscape.SilverlightElements..::.AddScheduleItemEventArgs

See Also

AddScheduleItemEventArgs Members
Mindscape.SilverlightElements Namespace


AddScheduleItemEventArgs Members

[image] [image]

Mindscape Silverlight Elements
AddScheduleItemEventArgs Members
AddScheduleItemEventArgs Class Methods Properties See Also Send Feedback

The AddScheduleItemEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Gets or sets whether to cancel adding the item.
Item | The ScheduleItem to which the event pertains. (Inherited from ScheduleItemEventArgs.)
ShowDefaultEditor | Gets or sets whether to show the default editor (the ScheduleItemDialog. The default is that the default editor will be shown if the event is unhandled, but will be suppressed if the event is handled. Event handlers can set this property to true to override this behaviour.

See Also

AddScheduleItemEventArgs Class


AddScheduleItemEventArgs Methods

[image] [image]

Mindscape Silverlight Elements
AddScheduleItemEventArgs Methods
AddScheduleItemEventArgs Class See Also Send Feedback

The AddScheduleItemEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddScheduleItemEventArgs Class


AddScheduleItemEventArgs Properties

[image] [image]

Mindscape Silverlight Elements
AddScheduleItemEventArgs Properties
AddScheduleItemEventArgs Class See Also Send Feedback

The AddScheduleItemEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets whether to cancel adding the item.
Item | The ScheduleItem to which the event pertains. (Inherited from ScheduleItemEventArgs.)
ShowDefaultEditor | Gets or sets whether to show the default editor (the ScheduleItemDialog. The default is that the default editor will be shown if the event is unhandled, but will be suppressed if the event is handled. Event handlers can set this property to true to override this behaviour.

See Also

AddScheduleItemEventArgs Class


Cancel Property

[image]

Mindscape Silverlight Elements
AddScheduleItemEventArgs..::.Cancel Property
AddScheduleItemEventArgs Class See Also Send Feedback
Gets or sets whether to cancel adding the item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual C++
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

AddScheduleItemEventArgs Class


ShowDefaultEditor Property

[image]

Mindscape Silverlight Elements
AddScheduleItemEventArgs..::.ShowDefaultEditor Property
AddScheduleItemEventArgs Class See Also Send Feedback
Gets or sets whether to show the default editor (the ScheduleItemDialog. The default is that the default editor will be shown if the event is unhandled, but will be suppressed if the event is handled. Event handlers can set this property to true to override this behaviour.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowDefaultEditor { get; set; }
Visual Basic (Declaration)
Public Property ShowDefaultEditor As Boolean
Visual C++
public:
property bool ShowDefaultEditor {
    bool get ();
    void set (bool value);
}

See Also

AddScheduleItemEventArgs Class


BooleanToBrushConverter Class

[image]

Mindscape Silverlight Elements
BooleanToBrushConverter Class
Members See Also Send Feedback
Selects a brush according to a boolean value.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BooleanToBrushConverter : IValueConverter
Visual Basic (Declaration)
Public Class BooleanToBrushConverter _
    Implements IValueConverter
Visual C++
public ref class BooleanToBrushConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.BooleanToBrushConverter

See Also

BooleanToBrushConverter Members


BooleanToBrushConverter Members

[image] [image]

Mindscape Silverlight Elements
BooleanToBrushConverter Members
BooleanToBrushConverter Class Constructors Methods Properties See Also Send Feedback

The BooleanToBrushConverter type exposes the following members.

Constructors

Name | Description
BooleanToBrushConverter | Initializes a new instance of the BooleanToBrushConverter class

Methods

Name | Description
Convert | Selects a brush according to whether the input is true or false.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FalseBrush | The brush to select when the source value is false.
TrueBrush | The brush to select when the source value is true.

See Also

BooleanToBrushConverter Class


BooleanToBrushConverter Constructor

[image]

Mindscape Silverlight Elements
BooleanToBrushConverter Constructor
BooleanToBrushConverter Class See Also Send Feedback
Initializes a new instance of the BooleanToBrushConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BooleanToBrushConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BooleanToBrushConverter()

See Also

BooleanToBrushConverter Class


BooleanToBrushConverter Methods

[image] [image]

Mindscape Silverlight Elements
BooleanToBrushConverter Methods
BooleanToBrushConverter Class See Also Send Feedback

The BooleanToBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Selects a brush according to whether the input is true or false.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToBrushConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
BooleanToBrushConverter..::.Convert Method
BooleanToBrushConverter Class See Also Send Feedback
Selects a brush according to whether the input is true or false.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The boolean value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The selected brush.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToBrushConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
BooleanToBrushConverter..::.ConvertBack Method
BooleanToBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToBrushConverter Class


BooleanToBrushConverter Properties

[image] [image]

Mindscape Silverlight Elements
BooleanToBrushConverter Properties
BooleanToBrushConverter Class See Also Send Feedback

The BooleanToBrushConverter type exposes the following members.

Properties

Name | Description
FalseBrush | The brush to select when the source value is false.
TrueBrush | The brush to select when the source value is true.

See Also

BooleanToBrushConverter Class


FalseBrush Property

[image]

Mindscape Silverlight Elements
BooleanToBrushConverter..::.FalseBrush Property
BooleanToBrushConverter Class See Also Send Feedback
The brush to select when the source value is false.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush FalseBrush { get; set; }
Visual Basic (Declaration)
Public Property FalseBrush As Brush
Visual C++
public:
property Brush^ FalseBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

BooleanToBrushConverter Class


TrueBrush Property

[image]

Mindscape Silverlight Elements
BooleanToBrushConverter..::.TrueBrush Property
BooleanToBrushConverter Class See Also Send Feedback
The brush to select when the source value is true.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush TrueBrush { get; set; }
Visual Basic (Declaration)
Public Property TrueBrush As Brush
Visual C++
public:
property Brush^ TrueBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

BooleanToBrushConverter Class


BooleanToStyleConverter Class

[image]

Mindscape Silverlight Elements
BooleanToStyleConverter Class
Members See Also Send Feedback
Selects a style according to a boolean value.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BooleanToStyleConverter : IValueConverter
Visual Basic (Declaration)
Public Class BooleanToStyleConverter _
    Implements IValueConverter
Visual C++
public ref class BooleanToStyleConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.BooleanToStyleConverter

See Also

BooleanToStyleConverter Members


BooleanToStyleConverter Members

[image] [image]

Mindscape Silverlight Elements
BooleanToStyleConverter Members
BooleanToStyleConverter Class Constructors Methods Properties See Also Send Feedback

The BooleanToStyleConverter type exposes the following members.

Constructors

Name | Description
BooleanToStyleConverter | Initializes a new instance of the BooleanToStyleConverter class

Methods

Name | Description
Convert | Selects a style according to whether the input is true or false.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FalseStyle | The style to select when the source value is false.
TrueStyle | The style to select when the source value is true.

See Also

BooleanToStyleConverter Class


BooleanToStyleConverter Constructor

[image]

Mindscape Silverlight Elements
BooleanToStyleConverter Constructor
BooleanToStyleConverter Class See Also Send Feedback
Initializes a new instance of the BooleanToStyleConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BooleanToStyleConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BooleanToStyleConverter()

See Also

BooleanToStyleConverter Class


BooleanToStyleConverter Methods

[image] [image]

Mindscape Silverlight Elements
BooleanToStyleConverter Methods
BooleanToStyleConverter Class See Also Send Feedback

The BooleanToStyleConverter type exposes the following members.

Methods

Name | Description
Convert | Selects a style according to whether the input is true or false.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToStyleConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
BooleanToStyleConverter..::.Convert Method
BooleanToStyleConverter Class See Also Send Feedback
Selects a style according to whether the input is true or false.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The selected style.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToStyleConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
BooleanToStyleConverter..::.ConvertBack Method
BooleanToStyleConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToStyleConverter Class


BooleanToStyleConverter Properties

[image] [image]

Mindscape Silverlight Elements
BooleanToStyleConverter Properties
BooleanToStyleConverter Class See Also Send Feedback

The BooleanToStyleConverter type exposes the following members.

Properties

Name | Description
FalseStyle | The style to select when the source value is false.
TrueStyle | The style to select when the source value is true.

See Also

BooleanToStyleConverter Class


FalseStyle Property

[image]

Mindscape Silverlight Elements
BooleanToStyleConverter..::.FalseStyle Property
BooleanToStyleConverter Class See Also Send Feedback
The style to select when the source value is false.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style FalseStyle { get; set; }
Visual Basic (Declaration)
Public Property FalseStyle As Style
Visual C++
public:
property Style^ FalseStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

BooleanToStyleConverter Class


TrueStyle Property

[image]

Mindscape Silverlight Elements
BooleanToStyleConverter..::.TrueStyle Property
BooleanToStyleConverter Class See Also Send Feedback
The style to select when the source value is true.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style TrueStyle { get; set; }
Visual Basic (Declaration)
Public Property TrueStyle As Style
Visual C++
public:
property Style^ TrueStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

BooleanToStyleConverter Class


BooleanToThicknessConverter Class

[image]

Mindscape Silverlight Elements
BooleanToThicknessConverter Class
Members See Also Send Feedback
Selects a Thickness according to a boolean value.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BooleanToThicknessConverter : IValueConverter
Visual Basic (Declaration)
Public Class BooleanToThicknessConverter _
    Implements IValueConverter
Visual C++
public ref class BooleanToThicknessConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.BooleanToThicknessConverter

See Also

BooleanToThicknessConverter Members


BooleanToThicknessConverter Members

[image] [image]

Mindscape Silverlight Elements
BooleanToThicknessConverter Members
BooleanToThicknessConverter Class Constructors Methods Properties See Also Send Feedback

The BooleanToThicknessConverter type exposes the following members.

Constructors

Name | Description
BooleanToThicknessConverter | Initializes a new instance of the BooleanToThicknessConverter class

Methods

Name | Description
Convert | Selects a Thickness according to whether the input is true or false.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FalseThickness | The Thickness to select when the source value is false.
TrueThickness | The Thickness to select when the source value is true.

See Also

BooleanToThicknessConverter Class


BooleanToThicknessConverter Constructor

[image]

Mindscape Silverlight Elements
BooleanToThicknessConverter Constructor
BooleanToThicknessConverter Class See Also Send Feedback
Initializes a new instance of the BooleanToThicknessConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BooleanToThicknessConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BooleanToThicknessConverter()

See Also

BooleanToThicknessConverter Class


BooleanToThicknessConverter Methods

[image] [image]

Mindscape Silverlight Elements
BooleanToThicknessConverter Methods
BooleanToThicknessConverter Class See Also Send Feedback

The BooleanToThicknessConverter type exposes the following members.

Methods

Name | Description
Convert | Selects a Thickness according to whether the input is true or false.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToThicknessConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
BooleanToThicknessConverter..::.Convert Method
BooleanToThicknessConverter Class See Also Send Feedback
Selects a Thickness according to whether the input is true or false.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The selected Thickness.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToThicknessConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
BooleanToThicknessConverter..::.ConvertBack Method
BooleanToThicknessConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToThicknessConverter Class


BooleanToThicknessConverter Properties

[image] [image]

Mindscape Silverlight Elements
BooleanToThicknessConverter Properties
BooleanToThicknessConverter Class See Also Send Feedback

The BooleanToThicknessConverter type exposes the following members.

Properties

Name | Description
FalseThickness | The Thickness to select when the source value is false.
TrueThickness | The Thickness to select when the source value is true.

See Also

BooleanToThicknessConverter Class


FalseThickness Property

[image]

Mindscape Silverlight Elements
BooleanToThicknessConverter..::.FalseThickness Property
BooleanToThicknessConverter Class See Also Send Feedback
The Thickness to select when the source value is false.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Thickness FalseThickness { get; set; }
Visual Basic (Declaration)
Public Property FalseThickness As Thickness
Visual C++
public:
property Thickness FalseThickness {
    Thickness get ();
    void set (Thickness value);
}

See Also

BooleanToThicknessConverter Class


TrueThickness Property

[image]

Mindscape Silverlight Elements
BooleanToThicknessConverter..::.TrueThickness Property
BooleanToThicknessConverter Class See Also Send Feedback
The Thickness to select when the source value is true.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Thickness TrueThickness { get; set; }
Visual Basic (Declaration)
Public Property TrueThickness As Thickness
Visual C++
public:
property Thickness TrueThickness {
    Thickness get ();
    void set (Thickness value);
}

See Also

BooleanToThicknessConverter Class


BooleanToVisibilityConverter Class

[image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter Class
Members See Also Send Feedback
Converts a Boolean value to a visibility.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BooleanToVisibilityConverter : IValueConverter
Visual Basic (Declaration)
Public Class BooleanToVisibilityConverter _
    Implements IValueConverter
Visual C++
public ref class BooleanToVisibilityConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.BooleanToVisibilityConverter

See Also

BooleanToVisibilityConverter Members


BooleanToVisibilityConverter Members

[image] [image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter Members
BooleanToVisibilityConverter Class Constructors Methods Properties See Also Send Feedback

The BooleanToVisibilityConverter type exposes the following members.

Constructors

Name | Description
BooleanToVisibilityConverter | Initializes a new instance of the BooleanToVisibilityConverter class

Methods

Name | Description
Convert | Converts a Boolean value from a binding source for use as a Visibility by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsInverted | Gets or sets whether the normal visibility logic should be inverted. If IsInverted is false (the default), true is converted to Visible and false to Collapsed. If IsInverted is true, true is converted to Collapsed and false to Visible.

See Also

BooleanToVisibilityConverter Class


BooleanToVisibilityConverter Constructor

[image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter Constructor
BooleanToVisibilityConverter Class See Also Send Feedback
Initializes a new instance of the BooleanToVisibilityConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BooleanToVisibilityConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BooleanToVisibilityConverter()

See Also

BooleanToVisibilityConverter Class


BooleanToVisibilityConverter Methods

[image] [image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter Methods
BooleanToVisibilityConverter Class See Also Send Feedback

The BooleanToVisibilityConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a Boolean value from a binding source for use as a Visibility by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanToVisibilityConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter..::.Convert Method
BooleanToVisibilityConverter Class See Also Send Feedback
Converts a Boolean value from a binding source for use as a Visibility by a binding target.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

BooleanToVisibilityConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter..::.ConvertBack Method
BooleanToVisibilityConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

BooleanToVisibilityConverter Class


BooleanToVisibilityConverter Properties

[image] [image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter Properties
BooleanToVisibilityConverter Class See Also Send Feedback

The BooleanToVisibilityConverter type exposes the following members.

Properties

Name | Description
IsInverted | Gets or sets whether the normal visibility logic should be inverted. If IsInverted is false (the default), true is converted to Visible and false to Collapsed. If IsInverted is true, true is converted to Collapsed and false to Visible.

See Also

BooleanToVisibilityConverter Class


IsInverted Property

[image]

Mindscape Silverlight Elements
BooleanToVisibilityConverter..::.IsInverted Property
BooleanToVisibilityConverter Class See Also Send Feedback
Gets or sets whether the normal visibility logic should be inverted. If IsInverted is false (the default), true is converted to Visible and false to Collapsed. If IsInverted is true, true is converted to Collapsed and false to Visible.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInverted { get; set; }
Visual Basic (Declaration)
Public Property IsInverted As Boolean
Visual C++
public:
property bool IsInverted {
    bool get ();
    void set (bool value);
}

See Also

BooleanToVisibilityConverter Class


Click Class

[image]

Mindscape Silverlight Elements
Click Class
Members See Also Send Feedback
Provides attached properties for assigning commands to buttons.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class Click
Visual Basic (Declaration)
Public NotInheritable Class Click
Visual C++
public ref class Click abstract sealed

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.Click

See Also

Click Members


Click Members

[image] [image]

Mindscape Silverlight Elements
Click Members
Click Class Methods Fields Attached Properties See Also Send Feedback

The Click type exposes the following members.

Methods

Name | Description
GetCommand | Gets the value of the Command attached property for a given DependencyObject.
GetCommandParameter | Gets the value of the CommandParameter attached property for a given DependencyObject.
SetCommand | Sets the value of the Command attached property for a given DependencyObject.
SetCommandParameter | Sets the value of the CommandParameter attached property for a given DependencyObject.

Fields

Name | Description
CommandParameterProperty | Identifies the CommandParameter attached property.
CommandProperty | Identifies the Command attached property.

Attached Properties

Name | Description
Command |
CommandParameter |

See Also

Click Class


Click Fields

[image] [image]

Mindscape Silverlight Elements
Click Fields
Click Class See Also Send Feedback

The Click type exposes the following members.

Fields

Name | Description
CommandParameterProperty | Identifies the CommandParameter attached property.
CommandProperty | Identifies the Command attached property.

See Also

Click Class


CommandParameterProperty Field

[image]

Mindscape Silverlight Elements
Click..::.CommandParameterProperty Field
Click Class See Also Send Feedback
Identifies the CommandParameter attached property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CommandParameterProperty
Visual Basic (Declaration)
Public Shared ReadOnly CommandParameterProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CommandParameterProperty

See Also

Click Class


CommandProperty Field

[image]

Mindscape Silverlight Elements
Click..::.CommandProperty Field
Click Class See Also Send Feedback
Identifies the Command attached property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CommandProperty
Visual Basic (Declaration)
Public Shared ReadOnly CommandProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CommandProperty

See Also

Click Class


Click Methods

[image] [image]

Mindscape Silverlight Elements
Click Methods
Click Class See Also Send Feedback

The Click type exposes the following members.

Methods

Name | Description
GetCommand | Gets the value of the Command attached property for a given DependencyObject.
GetCommandParameter | Gets the value of the CommandParameter attached property for a given DependencyObject.
SetCommand | Sets the value of the Command attached property for a given DependencyObject.
SetCommandParameter | Sets the value of the CommandParameter attached property for a given DependencyObject.

See Also

Click Class


GetCommand Method

[image]

Mindscape Silverlight Elements
Click..::.GetCommand Method
Click Class See Also Send Feedback
Gets the value of the Command attached property for a given DependencyObject.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ICommand GetCommand(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetCommand ( _
    obj As DependencyObject _
) As ICommand
Visual C++
public:
static ICommand^ GetCommand(
    DependencyObject^ obj
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element from which to read the property value.

Return Value

The value of the Command attached property.

See Also

Click Class


GetCommandParameter Method

[image]

Mindscape Silverlight Elements
Click..::.GetCommandParameter Method
Click Class See Also Send Feedback
Gets the value of the CommandParameter attached property for a given DependencyObject.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Object GetCommandParameter(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetCommandParameter ( _
    obj As DependencyObject _
) As Object
Visual C++
public:
static Object^ GetCommandParameter(
    DependencyObject^ obj
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element from which to read the property value.

Return Value

The value of the CommandParameter attached property.

See Also

Click Class


SetCommand Method

[image]

Mindscape Silverlight Elements
Click..::.SetCommand Method
Click Class See Also Send Feedback
Sets the value of the Command attached property for a given DependencyObject.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetCommand(
    DependencyObject obj,
    ICommand value
)
Visual Basic (Declaration)
Public Shared Sub SetCommand ( _
    obj As DependencyObject, _
    value As ICommand _
)
Visual C++
public:
static void SetCommand(
    DependencyObject^ obj,
    ICommand^ value
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element on which to set the property value.
value
Type: System.Windows.Input..::.ICommand
The value to which to set the property.

See Also

Click Class


SetCommandParameter Method

[image]

Mindscape Silverlight Elements
Click..::.SetCommandParameter Method
Click Class See Also Send Feedback
Sets the value of the CommandParameter attached property for a given DependencyObject.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetCommandParameter(
    DependencyObject obj,
    Object value
)
Visual Basic (Declaration)
Public Shared Sub SetCommandParameter ( _
    obj As DependencyObject, _
    value As Object _
)
Visual C++
public:
static void SetCommandParameter(
    DependencyObject^ obj,
    Object^ value
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element on which to set the property value.
value
Type: System..::.Object
The value to which to set the property.

See Also

Click Class


Click Attached Properties

[image] [image]

Mindscape Silverlight Elements
Click Attached Properties
Click Class See Also Send Feedback

The Click type exposes the following members.

Attached Properties

Name | Description
Command |
CommandParameter |

See Also

Click Class


Command Attached Property

[image]

Mindscape Silverlight Elements
Click..::.Command Attached Property
Click Class See Also Send Feedback

[Missing <summary> documentation for "P:Mindscape.SilverlightElements.Click.Command"]

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
See GetCommand, SetCommand
Visual Basic (Declaration)
See GetCommand, SetCommand
Visual C++
See GetCommand, SetCommand

See Also

Click Class


CommandParameter Attached Property

[image]

Mindscape Silverlight Elements
Click..::.CommandParameter Attached Property
Click Class See Also Send Feedback

[Missing <summary> documentation for "P:Mindscape.SilverlightElements.Click.CommandParameter"]

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
See GetCommandParameter, SetCommandParameter
Visual Basic (Declaration)
See GetCommandParameter, SetCommandParameter
Visual C++
See GetCommandParameter, SetCommandParameter

See Also

Click Class


ColorChannel Enumeration

[image]

Mindscape Silverlight Elements
ColorChannel Enumeration
See Also Send Feedback
Represents one of the four channels of a Color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ColorChannel
Visual Basic (Declaration)
Public Enumeration ColorChannel
Visual C++
public enum class ColorChannel

Members

Member name | Description
Alpha | The alpha channel.
Red | The red channel.
Green | The green channel.
Blue | The blue channel.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


ColorChannelAdjustmentBrushConverter Class

[image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter Class
Members See Also Send Feedback
Converts a color or solid brush to a gradient brush showing the effects of adjusting one channel on that color. This is used for displaying mixer channels in a ColorPicker template.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorChannelAdjustmentBrushConverter : IValueConverter
Visual Basic (Declaration)
Public Class ColorChannelAdjustmentBrushConverter _
    Implements IValueConverter
Visual C++
public ref class ColorChannelAdjustmentBrushConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ColorChannelAdjustmentBrushConverter

See Also

ColorChannelAdjustmentBrushConverter Members


ColorChannelAdjustmentBrushConverter Members

[image] [image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter Members
ColorChannelAdjustmentBrushConverter Class Constructors Methods Properties See Also Send Feedback

The ColorChannelAdjustmentBrushConverter type exposes the following members.

Constructors

Name | Description
ColorChannelAdjustmentBrushConverter | Initializes a new instance of the ColorChannelAdjustmentBrushConverter class

Methods

Name | Description
Convert | Converts a solid color to a gradient brush.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channel | Gets or sets the channel that is affected by this ColorChannelAdjustmentBrushConverter.

See Also

ColorChannelAdjustmentBrushConverter Class


ColorChannelAdjustmentBrushConverter Constructor

[image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter Constructor
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Initializes a new instance of the ColorChannelAdjustmentBrushConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorChannelAdjustmentBrushConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorChannelAdjustmentBrushConverter()

See Also

ColorChannelAdjustmentBrushConverter Class


ColorChannelAdjustmentBrushConverter Methods

[image] [image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter Methods
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback

The ColorChannelAdjustmentBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a solid color to a gradient brush.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorChannelAdjustmentBrushConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter..::.Convert Method
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Converts a solid color to a gradient brush.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The Color or SolidColorBrush value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The value to which to set the specified Channel. This value must be convertible to Byte.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A gradient brush from the original to the adjusted color.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ColorChannelAdjustmentBrushConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter..::.ConvertBack Method
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ColorChannelAdjustmentBrushConverter Class


ColorChannelAdjustmentBrushConverter Properties

[image] [image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter Properties
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback

The ColorChannelAdjustmentBrushConverter type exposes the following members.

Properties

Name | Description
Channel | Gets or sets the channel that is affected by this ColorChannelAdjustmentBrushConverter.

See Also

ColorChannelAdjustmentBrushConverter Class


Channel Property

[image]

Mindscape Silverlight Elements
ColorChannelAdjustmentBrushConverter..::.Channel Property
ColorChannelAdjustmentBrushConverter Class See Also Send Feedback
Gets or sets the channel that is affected by this ColorChannelAdjustmentBrushConverter.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorChannel Channel { get; set; }
Visual Basic (Declaration)
Public Property Channel As ColorChannel
Visual C++
public:
property ColorChannel Channel {
    ColorChannel get ();
    void set (ColorChannel value);
}

See Also

ColorChannelAdjustmentBrushConverter Class


ColorPicker Class

[image]

Mindscape Silverlight Elements
ColorPicker Class
Members See Also Send Feedback
A control where users can select a color from a swatch or palette or using a mixer.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorPicker : ColorPickerBase
Visual Basic (Declaration)
Public Class ColorPicker _
    Inherits ColorPickerBase
Visual C++
public ref class ColorPicker : public ColorPickerBase

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ColorPickerBase
Mindscape.SilverlightElements..::.ColorPicker

See Also

ColorPicker Members


ColorPicker Members

[image] [image]

Mindscape Silverlight Elements
ColorPicker Members
ColorPicker Class Constructors Methods Fields Properties Attached Properties Events See Also Send Feedback

The ColorPicker type exposes the following members.

Constructors

Name | Description
ColorPicker | Initializes a new instance of the ColorPicker control.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetColorChannel | Gets the value of the ColorChannel attached property for a given DependencyObject.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyItemIsSelectedChanged | Handles selection change messages from ColorPickerItem objects. (Inherited from ColorPickerBase.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemIsSelectedChanged | Selects this color in the ColorPicker. (Overrides ColorPickerBase..::.OnItemIsSelectedChanged(ColorPickerItem).)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnSelectedColorChanged | Raises the SelectedColorChanged event. (Overrides ColorPickerBase..::.OnSelectedColorChanged()()().)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetColorChannel | Sets the value of the ColorChannel attached property for a given DependencyObject.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ColorChannelProperty | Identifies the ColorChannel attached property.
NamedColorsProperty | Identifies the NamedColors property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NamedColors | Gets or sets the NamedColors. This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets the colours displayed in the palette. This is a dependency property. (Inherited from ColorPickerBase.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedColor | Gets or sets the currently selected color. This is a dependency property. (Inherited from ColorPickerBase.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Attached Properties

Name | Description
ColorChannel |

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedColorChanged | Occurs when the selected color changes. (Inherited from ColorPickerBase.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ColorPicker Class


ColorPicker Constructor

[image]

Mindscape Silverlight Elements
ColorPicker Constructor
ColorPicker Class See Also Send Feedback
Initializes a new instance of the ColorPicker control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorPicker()

See Also

ColorPicker Class


ColorPicker Fields

[image] [image]

Mindscape Silverlight Elements
ColorPicker Fields
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Fields

Name | Description
ColorChannelProperty | Identifies the ColorChannel attached property.
NamedColorsProperty | Identifies the NamedColors property.

See Also

ColorPicker Class


ColorChannelProperty Field

[image]

Mindscape Silverlight Elements
ColorPicker..::.ColorChannelProperty Field
ColorPicker Class See Also Send Feedback
Identifies the ColorChannel attached property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColorChannelProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColorChannelProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColorChannelProperty

See Also

ColorPicker Class


NamedColorsProperty Field

[image]

Mindscape Silverlight Elements
ColorPicker..::.NamedColorsProperty Field
ColorPicker Class See Also Send Feedback
Identifies the NamedColors property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty NamedColorsProperty
Visual Basic (Declaration)
Public Shared ReadOnly NamedColorsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NamedColorsProperty

See Also

ColorPicker Class


ColorPicker Methods

[image] [image]

Mindscape Silverlight Elements
ColorPicker Methods
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetColorChannel | Gets the value of the ColorChannel attached property for a given DependencyObject.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyItemIsSelectedChanged | Handles selection change messages from ColorPickerItem objects. (Inherited from ColorPickerBase.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemIsSelectedChanged | Selects this color in the ColorPicker. (Overrides ColorPickerBase..::.OnItemIsSelectedChanged(ColorPickerItem).)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnSelectedColorChanged | Raises the SelectedColorChanged event. (Overrides ColorPickerBase..::.OnSelectedColorChanged()()().)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetColorChannel | Sets the value of the ColorChannel attached property for a given DependencyObject.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ColorPicker Class


GetColorChannel Method

[image]

Mindscape Silverlight Elements
ColorPicker..::.GetColorChannel Method
ColorPicker Class See Also Send Feedback
Gets the value of the ColorChannel attached property for a given DependencyObject.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ColorChannel GetColorChannel(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetColorChannel ( _
    obj As DependencyObject _
) As ColorChannel
Visual C++
public:
static ColorChannel GetColorChannel(
    DependencyObject^ obj
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element from which to read the property value.

Return Value

The value of the ColorChannel attached property.

See Also

ColorPicker Class


OnItemIsSelectedChanged Method

[image]

Mindscape Silverlight Elements
ColorPicker..::.OnItemIsSelectedChanged Method
ColorPicker Class See Also Send Feedback
Selects this color in the ColorPicker.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnItemIsSelectedChanged(
    ColorPickerItem item
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemIsSelectedChanged ( _
    item As ColorPickerItem _
)
Visual C++
protected:
virtual void OnItemIsSelectedChanged(
    ColorPickerItem^ item
) override

Parameters

item
Type: Mindscape.SilverlightElements..::.ColorPickerItem
The ColorPickerItem that has been selected.

See Also

ColorPicker Class


OnSelectedColorChanged Method

[image]

Mindscape Silverlight Elements
ColorPicker..::.OnSelectedColorChanged Method
ColorPicker Class See Also Send Feedback
Raises the SelectedColorChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnSelectedColorChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnSelectedColorChanged
Visual C++
protected:
virtual void OnSelectedColorChanged() override

See Also

ColorPicker Class


SetColorChannel Method

[image]

Mindscape Silverlight Elements
ColorPicker..::.SetColorChannel Method
ColorPicker Class See Also Send Feedback
Sets the value of the ColorChannel attached property for a given DependencyObject.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetColorChannel(
    DependencyObject obj,
    ColorChannel value
)
Visual Basic (Declaration)
Public Shared Sub SetColorChannel ( _
    obj As DependencyObject, _
    value As ColorChannel _
)
Visual C++
public:
static void SetColorChannel(
    DependencyObject^ obj,
    ColorChannel value
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element on which to set the property value.
value
Type: Mindscape.SilverlightElements..::.ColorChannel
The value to which to set the property.

See Also

ColorPicker Class


ColorPicker Properties

[image] [image]

Mindscape Silverlight Elements
ColorPicker Properties
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NamedColors | Gets or sets the NamedColors. This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets the colours displayed in the palette. This is a dependency property. (Inherited from ColorPickerBase.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedColor | Gets or sets the currently selected color. This is a dependency property. (Inherited from ColorPickerBase.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ColorPicker Class


NamedColors Property

[image]

Mindscape Silverlight Elements
ColorPicker..::.NamedColors Property
ColorPicker Class See Also Send Feedback
Gets or sets the NamedColors. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<ColorPickerItem> NamedColors { get; set; }
Visual Basic (Declaration)
Public Property NamedColors As ReadOnlyCollection(Of ColorPickerItem)
Visual C++
public:
property ReadOnlyCollection<ColorPickerItem^>^ NamedColors {
    ReadOnlyCollection<ColorPickerItem^>^ get ();
    void set (ReadOnlyCollection<ColorPickerItem^>^ value);
}

See Also

ColorPicker Class


ColorPicker Events

[image] [image]

Mindscape Silverlight Elements
ColorPicker Events
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedColorChanged | Occurs when the selected color changes. (Inherited from ColorPickerBase.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ColorPicker Class


ColorPicker Attached Properties

[image] [image]

Mindscape Silverlight Elements
ColorPicker Attached Properties
ColorPicker Class See Also Send Feedback

The ColorPicker type exposes the following members.

Attached Properties

Name | Description
ColorChannel |

See Also

ColorPicker Class


ColorChannel Attached Property

[image]

Mindscape Silverlight Elements
ColorPicker..::.ColorChannel Attached Property
ColorPicker Class See Also Send Feedback

[Missing <summary> documentation for "P:Mindscape.SilverlightElements.ColorPicker.ColorChannel"]

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
See GetColorChannel, SetColorChannel
Visual Basic (Declaration)
See GetColorChannel, SetColorChannel
Visual C++
See GetColorChannel, SetColorChannel

See Also

ColorPicker Class


ColorPickerBase Class

[image]

Mindscape Silverlight Elements
ColorPickerBase Class
Members See Also Send Feedback
The common base class for color selection controls.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ColorPickerBase : Control
Visual Basic (Declaration)
Public MustInherit Class ColorPickerBase _
    Inherits Control
Visual C++
public ref class ColorPickerBase abstract : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ColorPickerBase
Mindscape.SilverlightElements..::.ColorPicker
Mindscape.SilverlightElements..::.PaletteColorPicker

See Also

ColorPickerBase Members


ColorPickerBase Members

[image] [image]

Mindscape Silverlight Elements
ColorPickerBase Members
ColorPickerBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The ColorPickerBase type exposes the following members.

Constructors

Name | Description
ColorPickerBase | Initializes a new instance of the ColorPickerBase class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyItemIsSelectedChanged | Handles selection change messages from ColorPickerItem objects.
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemIsSelectedChanged | Processes selection status changes from contained ColorPickerItem objects.
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnSelectedColorChanged | Raises the SelectedColorChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
PaletteProperty | Identifies the Palette property.
SelectedColorProperty | Identifies the SelectedColor property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets the colours displayed in the palette. This is a dependency property.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedColor | Gets or sets the currently selected color. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedColorChanged | Occurs when the selected color changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ColorPickerBase Class


ColorPickerBase Constructor

[image]

Mindscape Silverlight Elements
ColorPickerBase Constructor
ColorPickerBase Class See Also Send Feedback
Initializes a new instance of the ColorPickerBase class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ColorPickerBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ColorPickerBase()

See Also

ColorPickerBase Class


ColorPickerBase Fields

[image] [image]

Mindscape Silverlight Elements
ColorPickerBase Fields
ColorPickerBase Class See Also Send Feedback

The ColorPickerBase type exposes the following members.

Fields

Name | Description
PaletteProperty | Identifies the Palette property.
SelectedColorProperty | Identifies the SelectedColor property.

See Also

ColorPickerBase Class


PaletteProperty Field

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.PaletteProperty Field
ColorPickerBase Class See Also Send Feedback
Identifies the Palette property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty PaletteProperty
Visual Basic (Declaration)
Public Shared ReadOnly PaletteProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PaletteProperty

See Also

ColorPickerBase Class


SelectedColorProperty Field

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.SelectedColorProperty Field
ColorPickerBase Class See Also Send Feedback
Identifies the SelectedColor property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedColorProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedColorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedColorProperty

See Also

ColorPickerBase Class


ColorPickerBase Methods

[image] [image]

Mindscape Silverlight Elements
ColorPickerBase Methods
ColorPickerBase Class See Also Send Feedback

The ColorPickerBase type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyItemIsSelectedChanged | Handles selection change messages from ColorPickerItem objects.
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemIsSelectedChanged | Processes selection status changes from contained ColorPickerItem objects.
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnSelectedColorChanged | Raises the SelectedColorChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ColorPickerBase Class


NotifyItemIsSelectedChanged Method

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.NotifyItemIsSelectedChanged Method
ColorPickerBase Class See Also Send Feedback
Handles selection change messages from ColorPickerItem objects.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void NotifyItemIsSelectedChanged(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Sub NotifyItemIsSelectedChanged ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
protected:
void NotifyItemIsSelectedChanged(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::.Object
The item whose selection status has changed.
e
Type: System..::.EventArgs
The event data.

See Also

ColorPickerBase Class


OnItemIsSelectedChanged Method

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.OnItemIsSelectedChanged Method
ColorPickerBase Class See Also Send Feedback
Processes selection status changes from contained ColorPickerItem objects.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnItemIsSelectedChanged(
    ColorPickerItem item
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemIsSelectedChanged ( _
    item As ColorPickerItem _
)
Visual C++
protected:
virtual void OnItemIsSelectedChanged(
    ColorPickerItem^ item
)

Parameters

item
Type: Mindscape.SilverlightElements..::.ColorPickerItem
The item whose selection status has changed.

See Also

ColorPickerBase Class


OnSelectedColorChanged Method

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.OnSelectedColorChanged Method
ColorPickerBase Class See Also Send Feedback
Raises the SelectedColorChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnSelectedColorChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnSelectedColorChanged
Visual C++
protected:
virtual void OnSelectedColorChanged()

See Also

ColorPickerBase Class


ColorPickerBase Properties

[image] [image]

Mindscape Silverlight Elements
ColorPickerBase Properties
ColorPickerBase Class See Also Send Feedback

The ColorPickerBase type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets the colours displayed in the palette. This is a dependency property.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedColor | Gets or sets the currently selected color. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ColorPickerBase Class


Palette Property

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.Palette Property
ColorPickerBase Class See Also Send Feedback
Gets or sets the colours displayed in the palette. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<ColorPickerItem> Palette { get; set; }
Visual Basic (Declaration)
Public Property Palette As ReadOnlyCollection(Of ColorPickerItem)
Visual C++
public:
property ReadOnlyCollection<ColorPickerItem^>^ Palette {
    ReadOnlyCollection<ColorPickerItem^>^ get ();
    void set (ReadOnlyCollection<ColorPickerItem^>^ value);
}

Remarks

Dependency Property Information
Identifier field | PaletteProperty
Metadata properties set to true | None

See Also

ColorPickerBase Class


SelectedColor Property

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.SelectedColor Property
ColorPickerBase Class See Also Send Feedback
Gets or sets the currently selected color. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color SelectedColor { get; set; }
Visual Basic (Declaration)
Public Property SelectedColor As Color
Visual C++
public:
property Color SelectedColor {
    Color get ();
    void set (Color value);
}

Remarks

Dependency Property Information
Identifier field | SelectedColorProperty
Metadata properties set to true | None

See Also

ColorPickerBase Class


ColorPickerBase Events

[image] [image]

Mindscape Silverlight Elements
ColorPickerBase Events
ColorPickerBase Class See Also Send Feedback

The ColorPickerBase type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedColorChanged | Occurs when the selected color changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ColorPickerBase Class


SelectedColorChanged Event

[image]

Mindscape Silverlight Elements
ColorPickerBase..::.SelectedColorChanged Event
ColorPickerBase Class See Also Send Feedback
Occurs when the selected color changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler SelectedColorChanged
Visual Basic (Declaration)
Public Event SelectedColorChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectedColorChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ColorPickerBase Class


ColorPickerItem Class

[image]

Mindscape Silverlight Elements
ColorPickerItem Class
Members See Also Send Feedback
Represents an entry (a color selection) in a ColorPickerBase control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorPickerItem : DependencyObject
Visual Basic (Declaration)
Public Class ColorPickerItem _
    Inherits DependencyObject
Visual C++
public ref class ColorPickerItem : public DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
Mindscape.SilverlightElements..::.ColorPickerItem

See Also

ColorPickerItem Members


ColorPickerItem Members

[image] [image]

Mindscape Silverlight Elements
ColorPickerItem Members
ColorPickerItem Class Constructors Methods Fields Properties See Also Send Feedback

The ColorPickerItem type exposes the following members.

Constructors

Name | Description
ColorPickerItem | Overloaded.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColorProperty | Identifies the Color property.
IsSelectedProperty | Identifies the IsSelected property.
NameProperty | Identifies the Name property.

Properties

Name | Description
Color | Gets or sets the color selection represented by this ColorPickerItem. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
IsSelected | Gets or sets whether the item is selected. This is a dependency property.
Name | Gets or sets the name of the color. This is a dependency property.
SelectCommand | Gets a command which selects this ColorPickerItem.

See Also

ColorPickerItem Class


ColorPickerItem Constructor

[image] [image]

Mindscape Silverlight Elements
ColorPickerItem Constructor
ColorPickerItem Class See Also Send Feedback

Overload List

Name | Description
ColorPickerItem()()() | Initializes a new instance of the ColorPickerItem class.
ColorPickerItem(Color) | Initializes a new instance of the ColorPickerItem class.
ColorPickerItem(Color, String) | Initializes a new instance of the ColorPickerItem class.

See Also

ColorPickerItem Class
ColorPickerItem Members


ColorPickerItem Constructor

[image]

Mindscape Silverlight Elements
ColorPickerItem Constructor
ColorPickerItem Class See Also Send Feedback
Initializes a new instance of the ColorPickerItem class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPickerItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorPickerItem()

See Also

ColorPickerItem Class
ColorPickerItem Overload


ColorPickerItem Constructor (Color)

[image]

Mindscape Silverlight Elements
ColorPickerItem Constructor (Color)
ColorPickerItem Class See Also Send Feedback
Initializes a new instance of the ColorPickerItem class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPickerItem(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
ColorPickerItem(
    Color color
)

Parameters

color
Type: System.Windows.Media..::.Color
The color selection represented by this ColorPickerItem.

See Also

ColorPickerItem Class
ColorPickerItem Overload


ColorPickerItem Constructor (Color, String)

[image]

Mindscape Silverlight Elements
ColorPickerItem Constructor (Color, String)
ColorPickerItem Class See Also Send Feedback
Initializes a new instance of the ColorPickerItem class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPickerItem(
    Color color,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    name As String _
)
Visual C++
public:
ColorPickerItem(
    Color color,
    String^ name
)

Parameters

color
Type: System.Windows.Media..::.Color
The color selection represented by this ColorPickerItem.
name
Type: System..::.String
The name of the color.

See Also

ColorPickerItem Class
ColorPickerItem Overload


ColorPickerItem Fields

[image] [image]

Mindscape Silverlight Elements
ColorPickerItem Fields
ColorPickerItem Class See Also Send Feedback

The ColorPickerItem type exposes the following members.

Fields

Name | Description
ColorProperty | Identifies the Color property.
IsSelectedProperty | Identifies the IsSelected property.
NameProperty | Identifies the Name property.

See Also

ColorPickerItem Class


ColorProperty Field

[image]

Mindscape Silverlight Elements
ColorPickerItem..::.ColorProperty Field
ColorPickerItem Class See Also Send Feedback
Identifies the Color property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColorProperty

See Also

ColorPickerItem Class


IsSelectedProperty Field

[image]

Mindscape Silverlight Elements
ColorPickerItem..::.IsSelectedProperty Field
ColorPickerItem Class See Also Send Feedback
Identifies the IsSelected property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsSelectedProperty

See Also

ColorPickerItem Class


NameProperty Field

[image]

Mindscape Silverlight Elements
ColorPickerItem..::.NameProperty Field
ColorPickerItem Class See Also Send Feedback
Identifies the Name property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty NameProperty
Visual Basic (Declaration)
Public Shared ReadOnly NameProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NameProperty

See Also

ColorPickerItem Class


ColorPickerItem Methods

[image] [image]

Mindscape Silverlight Elements
ColorPickerItem Methods
ColorPickerItem Class See Also Send Feedback

The ColorPickerItem type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorPickerItem Class


ColorPickerItem Properties

[image] [image]

Mindscape Silverlight Elements
ColorPickerItem Properties
ColorPickerItem Class See Also Send Feedback

The ColorPickerItem type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color selection represented by this ColorPickerItem. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
IsSelected | Gets or sets whether the item is selected. This is a dependency property.
Name | Gets or sets the name of the color. This is a dependency property.
SelectCommand | Gets a command which selects this ColorPickerItem.

See Also

ColorPickerItem Class


Color Property

[image]

Mindscape Silverlight Elements
ColorPickerItem..::.Color Property
ColorPickerItem Class See Also Send Feedback
Gets or sets the color selection represented by this ColorPickerItem. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

ColorPickerItem Class


IsSelected Property

[image]

Mindscape Silverlight Elements
ColorPickerItem..::.IsSelected Property
ColorPickerItem Class See Also Send Feedback
Gets or sets whether the item is selected. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

ColorPickerItem Class


Name Property

[image]

Mindscape Silverlight Elements
ColorPickerItem..::.Name Property
ColorPickerItem Class See Also Send Feedback
Gets or sets the name of the color. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ColorPickerItem Class


SelectCommand Property

[image]

Mindscape Silverlight Elements
ColorPickerItem..::.SelectCommand Property
ColorPickerItem Class See Also Send Feedback
Gets a command which selects this ColorPickerItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand SelectCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectCommand As ICommand
Visual C++
public:
property ICommand^ SelectCommand {
    ICommand^ get ();
}

See Also

ColorPickerItem Class


ColorSliderRepeatButtonTemplateSelector Class

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector Class
Members See Also Send Feedback
Selects a ControlTemplate for the RepeatButton part of a channel mixer in a ColorPicker control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorSliderRepeatButtonTemplateSelector : IValueConverter
Visual Basic (Declaration)
Public Class ColorSliderRepeatButtonTemplateSelector _
    Implements IValueConverter
Visual C++
public ref class ColorSliderRepeatButtonTemplateSelector : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ColorSliderRepeatButtonTemplateSelector

See Also

ColorSliderRepeatButtonTemplateSelector Members


ColorSliderRepeatButtonTemplateSelector Members

[image] [image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector Members
ColorSliderRepeatButtonTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The ColorSliderRepeatButtonTemplateSelector type exposes the following members.

Constructors

Name | Description
ColorSliderRepeatButtonTemplateSelector | Initializes a new instance of the ColorSliderRepeatButtonTemplateSelector class

Methods

Name | Description
Convert | Selects a ControlTemplate according to a ColorChannel value.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AlphaTemplate | The template for alpha channel repeat buttons.
BlueTemplate | The template for blue channel repeat buttons.
GreenTemplate | The template for green channel repeat buttons.
RedTemplate | The template for red channel repeat buttons.

See Also

ColorSliderRepeatButtonTemplateSelector Class


ColorSliderRepeatButtonTemplateSelector Constructor

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector Constructor
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback
Initializes a new instance of the ColorSliderRepeatButtonTemplateSelector class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorSliderRepeatButtonTemplateSelector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorSliderRepeatButtonTemplateSelector()

See Also

ColorSliderRepeatButtonTemplateSelector Class


ColorSliderRepeatButtonTemplateSelector Methods

[image] [image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector Methods
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback

The ColorSliderRepeatButtonTemplateSelector type exposes the following members.

Methods

Name | Description
Convert | Selects a ControlTemplate according to a ColorChannel value.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorSliderRepeatButtonTemplateSelector Class


Convert Method

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector..::.Convert Method
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback
Selects a ControlTemplate according to a ColorChannel value.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The ColorChannel value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The selected ControlTemplate.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ColorSliderRepeatButtonTemplateSelector Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector..::.ConvertBack Method
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ColorSliderRepeatButtonTemplateSelector Class


ColorSliderRepeatButtonTemplateSelector Properties

[image] [image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector Properties
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback

The ColorSliderRepeatButtonTemplateSelector type exposes the following members.

Properties

Name | Description
AlphaTemplate | The template for alpha channel repeat buttons.
BlueTemplate | The template for blue channel repeat buttons.
GreenTemplate | The template for green channel repeat buttons.
RedTemplate | The template for red channel repeat buttons.

See Also

ColorSliderRepeatButtonTemplateSelector Class


AlphaTemplate Property

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector..::.AlphaTemplate Property
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback
The template for alpha channel repeat buttons.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate AlphaTemplate { get; set; }
Visual Basic (Declaration)
Public Property AlphaTemplate As ControlTemplate
Visual C++
public:
property ControlTemplate^ AlphaTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorSliderRepeatButtonTemplateSelector Class


BlueTemplate Property

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector..::.BlueTemplate Property
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback
The template for blue channel repeat buttons.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate BlueTemplate { get; set; }
Visual Basic (Declaration)
Public Property BlueTemplate As ControlTemplate
Visual C++
public:
property ControlTemplate^ BlueTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorSliderRepeatButtonTemplateSelector Class


GreenTemplate Property

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector..::.GreenTemplate Property
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback
The template for green channel repeat buttons.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate GreenTemplate { get; set; }
Visual Basic (Declaration)
Public Property GreenTemplate As ControlTemplate
Visual C++
public:
property ControlTemplate^ GreenTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorSliderRepeatButtonTemplateSelector Class


RedTemplate Property

[image]

Mindscape Silverlight Elements
ColorSliderRepeatButtonTemplateSelector..::.RedTemplate Property
ColorSliderRepeatButtonTemplateSelector Class See Also Send Feedback
The template for red channel repeat buttons.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ControlTemplate RedTemplate { get; set; }
Visual Basic (Declaration)
Public Property RedTemplate As ControlTemplate
Visual C++
public:
property ControlTemplate^ RedTemplate {
    ControlTemplate^ get ();
    void set (ControlTemplate^ value);
}

See Also

ColorSliderRepeatButtonTemplateSelector Class


ColorToNameConverter Class

[image]

Mindscape Silverlight Elements
ColorToNameConverter Class
Members See Also Send Feedback
Converts between Color values and names.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorToNameConverter : IValueConverter
Visual Basic (Declaration)
Public Class ColorToNameConverter _
    Implements IValueConverter
Visual C++
public ref class ColorToNameConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ColorToNameConverter

See Also

ColorToNameConverter Members


ColorToNameConverter Members

[image] [image]

Mindscape Silverlight Elements
ColorToNameConverter Members
ColorToNameConverter Class Constructors Methods See Also Send Feedback

The ColorToNameConverter type exposes the following members.

Constructors

Name | Description
ColorToNameConverter | Initializes a new instance of the ColorToNameConverter class

Methods

Name | Description
Convert | Converts a Color value to a name.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorToNameConverter Class


ColorToNameConverter Constructor

[image]

Mindscape Silverlight Elements
ColorToNameConverter Constructor
ColorToNameConverter Class See Also Send Feedback
Initializes a new instance of the ColorToNameConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorToNameConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorToNameConverter()

See Also

ColorToNameConverter Class


ColorToNameConverter Methods

[image] [image]

Mindscape Silverlight Elements
ColorToNameConverter Methods
ColorToNameConverter Class See Also Send Feedback

The ColorToNameConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a Color value to a name.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorToNameConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ColorToNameConverter..::.Convert Method
ColorToNameConverter Class See Also Send Feedback
Converts a Color value to a name.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The Color value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The name of the color, if it is a standard color (named in the Colors class); otherwise a string representation of the color.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ColorToNameConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ColorToNameConverter..::.ConvertBack Method
ColorToNameConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ColorToNameConverter Class


ColorToSolidColorBrushConverter Class

[image]

Mindscape Silverlight Elements
ColorToSolidColorBrushConverter Class
Members See Also Send Feedback
Converts a Color to a SolidColorBrush.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ColorToSolidColorBrushConverter : IValueConverter
Visual Basic (Declaration)
Public Class ColorToSolidColorBrushConverter _
    Implements IValueConverter
Visual C++
public ref class ColorToSolidColorBrushConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ColorToSolidColorBrushConverter

See Also

ColorToSolidColorBrushConverter Members


ColorToSolidColorBrushConverter Members

[image] [image]

Mindscape Silverlight Elements
ColorToSolidColorBrushConverter Members
ColorToSolidColorBrushConverter Class Constructors Methods See Also Send Feedback

The ColorToSolidColorBrushConverter type exposes the following members.

Constructors

Name | Description
ColorToSolidColorBrushConverter | Initializes a new instance of the ColorToSolidColorBrushConverter class

Methods

Name | Description
Convert | Converts a Color to a SolidColorBrush.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorToSolidColorBrushConverter Class


ColorToSolidColorBrushConverter Constructor

[image]

Mindscape Silverlight Elements
ColorToSolidColorBrushConverter Constructor
ColorToSolidColorBrushConverter Class See Also Send Feedback
Initializes a new instance of the ColorToSolidColorBrushConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorToSolidColorBrushConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorToSolidColorBrushConverter()

See Also

ColorToSolidColorBrushConverter Class


ColorToSolidColorBrushConverter Methods

[image] [image]

Mindscape Silverlight Elements
ColorToSolidColorBrushConverter Methods
ColorToSolidColorBrushConverter Class See Also Send Feedback

The ColorToSolidColorBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a Color to a SolidColorBrush.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorToSolidColorBrushConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ColorToSolidColorBrushConverter..::.Convert Method
ColorToSolidColorBrushConverter Class See Also Send Feedback
Converts a Color to a SolidColorBrush.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The Color value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A SolidColorBrush of the input color.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ColorToSolidColorBrushConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ColorToSolidColorBrushConverter..::.ConvertBack Method
ColorToSolidColorBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ColorToSolidColorBrushConverter Class


ContentColumnMapping Class

[image]

Mindscape Silverlight Elements
ContentColumnMapping Class
Members See Also Send Feedback
Contains the mapping between content and columns in a ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ContentColumnMapping
Visual Basic (Declaration)
Public Class ContentColumnMapping
Visual C++
public ref class ContentColumnMapping

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ContentColumnMapping

See Also

ContentColumnMapping Members


ContentColumnMapping Members

[image] [image]

Mindscape Silverlight Elements
ContentColumnMapping Members
ContentColumnMapping Class Methods Properties See Also Send Feedback

The ContentColumnMapping type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Column | Gets the GridViewColumn.
Content | Gets the content.

See Also

ContentColumnMapping Class


ContentColumnMapping Methods

[image] [image]

Mindscape Silverlight Elements
ContentColumnMapping Methods
ContentColumnMapping Class See Also Send Feedback

The ContentColumnMapping type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContentColumnMapping Class


ContentColumnMapping Properties

[image] [image]

Mindscape Silverlight Elements
ContentColumnMapping Properties
ContentColumnMapping Class See Also Send Feedback

The ContentColumnMapping type exposes the following members.

Properties

Name | Description
Column | Gets the GridViewColumn.
Content | Gets the content.

See Also

ContentColumnMapping Class


Column Property

[image]

Mindscape Silverlight Elements
ContentColumnMapping..::.Column Property
ContentColumnMapping Class See Also Send Feedback
Gets the GridViewColumn.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumn Column { get; }
Visual Basic (Declaration)
Public ReadOnly Property Column As GridViewColumn
Visual C++
public:
property GridViewColumn^ Column {
    GridViewColumn^ get ();
}

See Also

ContentColumnMapping Class


Content Property

[image]

Mindscape Silverlight Elements
ContentColumnMapping..::.Content Property
ContentColumnMapping Class See Also Send Feedback
Gets the content.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Content { get; }
Visual Basic (Declaration)
Public ReadOnly Property Content As Object
Visual C++
public:
property Object^ Content {
    Object^ get ();
}

See Also

ContentColumnMapping Class


CoverFlow Class

[image]

Mindscape Silverlight Elements
CoverFlow Class
Members See Also Send Feedback
A control that arranges items in a row such that the selected object is displayed in the center of the control, with the other items arranged to either side in a pseudo-perspective view, and animates the transition when the selection changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CoverFlow : ListBox
Visual Basic (Declaration)
Public Class CoverFlow _
    Inherits ListBox
Visual C++
public ref class CoverFlow : public ListBox

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
System.Windows.Controls.Primitives..::.Selector
System.Windows.Controls..::.ListBox
Mindscape.SilverlightElements..::.CoverFlow

See Also

CoverFlow Members


CoverFlow Members

[image] [image]

Mindscape Silverlight Elements
CoverFlow Members
CoverFlow Class Constructors Methods Fields Properties Events See Also Send Feedback

The CoverFlow type exposes the following members.

Constructors

Name | Description
CoverFlow | Initializes a new instance of the CoverFlow item.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from Selector.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Overrides ListBox..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides ListBox..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBox.)
OnCreateAutomationPeer | (Inherited from ListBox.)
OnGotFocus | (Inherited from ListBox.)
OnItemsChanged | Invoked when the Items property changes. (Overrides Selector..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from ListBox.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBox.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides SelectorPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
ScrollIntoView | (Inherited from ListBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ItemHeightProperty | Identifies the ItemHeight property.
ItemSeparationProperty | Identifies the ItemSeparation property.
ItemWidthProperty | Identifies the ItemWidth property.
MouseSelectionModeProperty | Identifies the MouseSelectionMode property.
ReflectionBrushProperty | Identifies the ReflectionBrush property.
ReflectionScaleYProperty | Identifies the ReflectionScaleY property.
ScaleXProperty | Identifies the ScaleX property.
ScaleYProperty | Identifies the ScaleY property.
SelectedItemSeparationProperty | Identifies the SelectedItemSeparation property.
ShearAngleProperty | Identifies the ShearAngle property.
ShowReflectionProperty | Identifies the ShowReflection property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from ListBox.)
ItemHeight | Gets or sets the height of the items within the CoverFlow. This represents the size of the selected item; the ScaleX and ScaleY properties are applied to non-selected items. This is a dependency property.
Items | (Inherited from ItemsControl.)
ItemSeparation | Gets or sets the item spacing within the CoverFlow. This is a dependency property.
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemWidth | Gets or sets the width of the items within the CoverFlow. This represents the size of the selected item; the ScaleX and ScaleY properties are applied to non-selected items. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseSelectionMode | Gets or sets how the user can select items using the mouse. The default is MousePressed. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
ReflectionBrush | Gets or sets the Brush used in the reflection of each CoverFlowItem. This brush is overlaid on the reflection and should typically contain a gradient from a solid color (equal to the background color of the CoverFlow) to a translucent version of that color. This is a dependency property.
ReflectionScaleY | Gets or sets the vertical scale applied to the reflection. This must be between 0 and 1. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScaleX | Gets or sets the horizontal scaling applied to the non-selected items. This is a dependency property.
ScaleY | Gets or sets the vertical scaling applied to the non-selected items. This is a dependency property.
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
SelectedItems | (Inherited from ListBox.)
SelectedItemSeparation | Gets or sets the separation between the selected item and the items adjacent to it. This is instead of, not additional to, the ItemSeparation property, and should usually be larger than it. This is a dependency property.
SelectionMode | (Inherited from ListBox.)
ShearAngle | Gets or sets the vertical shear of the items within this CoverFlow, in degrees. This is a dependency property.
ShowReflection | Gets or sets whether the CoverFlow shows reflections below each item. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CoverFlow Class


CoverFlow Constructor

[image]

Mindscape Silverlight Elements
CoverFlow Constructor
CoverFlow Class See Also Send Feedback
Initializes a new instance of the CoverFlow item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CoverFlow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CoverFlow()

See Also

CoverFlow Class


CoverFlow Fields

[image] [image]

Mindscape Silverlight Elements
CoverFlow Fields
CoverFlow Class See Also Send Feedback

The CoverFlow type exposes the following members.

Fields

Name | Description
ItemHeightProperty | Identifies the ItemHeight property.
ItemSeparationProperty | Identifies the ItemSeparation property.
ItemWidthProperty | Identifies the ItemWidth property.
MouseSelectionModeProperty | Identifies the MouseSelectionMode property.
ReflectionBrushProperty | Identifies the ReflectionBrush property.
ReflectionScaleYProperty | Identifies the ReflectionScaleY property.
ScaleXProperty | Identifies the ScaleX property.
ScaleYProperty | Identifies the ScaleY property.
SelectedItemSeparationProperty | Identifies the SelectedItemSeparation property.
ShearAngleProperty | Identifies the ShearAngle property.
ShowReflectionProperty | Identifies the ShowReflection property.

See Also

CoverFlow Class


ItemHeightProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ItemHeightProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ItemHeight property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemHeightProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemHeightProperty

See Also

CoverFlow Class


ItemSeparationProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ItemSeparationProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ItemSeparation property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemSeparationProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemSeparationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemSeparationProperty

See Also

CoverFlow Class


ItemWidthProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ItemWidthProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ItemWidth property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemWidthProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemWidthProperty

See Also

CoverFlow Class


MouseSelectionModeProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.MouseSelectionModeProperty Field
CoverFlow Class See Also Send Feedback
Identifies the MouseSelectionMode property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MouseSelectionModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly MouseSelectionModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MouseSelectionModeProperty

See Also

CoverFlow Class


ReflectionBrushProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ReflectionBrushProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ReflectionBrush property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ReflectionBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReflectionBrushProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ReflectionBrushProperty

See Also

CoverFlow Class


ReflectionScaleYProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ReflectionScaleYProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ReflectionScaleY property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ReflectionScaleYProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReflectionScaleYProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ReflectionScaleYProperty

See Also

CoverFlow Class


ScaleXProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ScaleXProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ScaleX property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ScaleXProperty
Visual Basic (Declaration)
Public Shared ReadOnly ScaleXProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ScaleXProperty

See Also

CoverFlow Class


ScaleYProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ScaleYProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ScaleY property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ScaleYProperty
Visual Basic (Declaration)
Public Shared ReadOnly ScaleYProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ScaleYProperty

See Also

CoverFlow Class


SelectedItemSeparationProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.SelectedItemSeparationProperty Field
CoverFlow Class See Also Send Feedback
Identifies the SelectedItemSeparation property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedItemSeparationProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemSeparationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedItemSeparationProperty

See Also

CoverFlow Class


ShearAngleProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ShearAngleProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ShearAngle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShearAngleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShearAngleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShearAngleProperty

See Also

CoverFlow Class


ShowReflectionProperty Field

[image]

Mindscape Silverlight Elements
CoverFlow..::.ShowReflectionProperty Field
CoverFlow Class See Also Send Feedback
Identifies the ShowReflection property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowReflectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowReflectionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowReflectionProperty

See Also

CoverFlow Class


CoverFlow Methods

[image] [image]

Mindscape Silverlight Elements
CoverFlow Methods
CoverFlow Class See Also Send Feedback

The CoverFlow type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from Selector.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Overrides ListBox..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides ListBox..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBox.)
OnCreateAutomationPeer | (Inherited from ListBox.)
OnGotFocus | (Inherited from ListBox.)
OnItemsChanged | Invoked when the Items property changes. (Overrides Selector..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from ListBox.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBox.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides SelectorPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
ScrollIntoView | (Inherited from ListBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

CoverFlow Class


GetContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
CoverFlow..::.GetContainerForItemOverride Method
CoverFlow Class See Also Send Feedback
Creates or identifies the element that is used to display the given item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject
Visual C++
protected:
virtual DependencyObject^ GetContainerForItemOverride() override

Return Value

The element that is used to display the given item.

See Also

CoverFlow Class


IsItemItsOwnContainerOverride Method

[image]

Mindscape Silverlight Elements
CoverFlow..::.IsItemItsOwnContainerOverride Method
CoverFlow Class See Also Send Feedback
Determines if the specified item is (or is eligible to be) its own container.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean
Visual C++
protected:
virtual bool IsItemItsOwnContainerOverride(
    Object^ item
) override

Parameters

item
Type: System..::.Object
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

CoverFlow Class


OnItemsChanged Method

[image]

Mindscape Silverlight Elements
CoverFlow..::.OnItemsChanged Method
CoverFlow Class See Also Send Feedback
Invoked when the Items property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
virtual void OnItemsChanged(
    NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
Information about the change.

See Also

CoverFlow Class


PrepareContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
CoverFlow..::.PrepareContainerForItemOverride Method
CoverFlow Class See Also Send Feedback
Prepares the specified element to display the specified item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)
Visual C++
protected:
virtual void PrepareContainerForItemOverride(
    DependencyObject^ element,
    Object^ item
) override

Parameters

element
Type: System.Windows..::.DependencyObject
The element used to display the specified item.
item
Type: System..::.Object
The item to display.

See Also

CoverFlow Class


CoverFlow Properties

[image] [image]

Mindscape Silverlight Elements
CoverFlow Properties
CoverFlow Class See Also Send Feedback

The CoverFlow type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from ListBox.)
ItemHeight | Gets or sets the height of the items within the CoverFlow. This represents the size of the selected item; the ScaleX and ScaleY properties are applied to non-selected items. This is a dependency property.
Items | (Inherited from ItemsControl.)
ItemSeparation | Gets or sets the item spacing within the CoverFlow. This is a dependency property.
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemWidth | Gets or sets the width of the items within the CoverFlow. This represents the size of the selected item; the ScaleX and ScaleY properties are applied to non-selected items. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseSelectionMode | Gets or sets how the user can select items using the mouse. The default is MousePressed. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
ReflectionBrush | Gets or sets the Brush used in the reflection of each CoverFlowItem. This brush is overlaid on the reflection and should typically contain a gradient from a solid color (equal to the background color of the CoverFlow) to a translucent version of that color. This is a dependency property.
ReflectionScaleY | Gets or sets the vertical scale applied to the reflection. This must be between 0 and 1. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScaleX | Gets or sets the horizontal scaling applied to the non-selected items. This is a dependency property.
ScaleY | Gets or sets the vertical scaling applied to the non-selected items. This is a dependency property.
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
SelectedItems | (Inherited from ListBox.)
SelectedItemSeparation | Gets or sets the separation between the selected item and the items adjacent to it. This is instead of, not additional to, the ItemSeparation property, and should usually be larger than it. This is a dependency property.
SelectionMode | (Inherited from ListBox.)
ShearAngle | Gets or sets the vertical shear of the items within this CoverFlow, in degrees. This is a dependency property.
ShowReflection | Gets or sets whether the CoverFlow shows reflections below each item. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

CoverFlow Class


ItemHeight Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ItemHeight Property
CoverFlow Class See Also Send Feedback
Gets or sets the height of the items within the CoverFlow. This represents the size of the selected item; the ScaleX and ScaleY properties are applied to non-selected items. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ItemHeight { get; set; }
Visual Basic (Declaration)
Public Property ItemHeight As Double
Visual C++
public:
property double ItemHeight {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ItemHeightProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ItemSeparation Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ItemSeparation Property
CoverFlow Class See Also Send Feedback
Gets or sets the item spacing within the CoverFlow. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ItemSeparation { get; set; }
Visual Basic (Declaration)
Public Property ItemSeparation As Double
Visual C++
public:
property double ItemSeparation {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ItemSeparationProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ItemWidth Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ItemWidth Property
CoverFlow Class See Also Send Feedback
Gets or sets the width of the items within the CoverFlow. This represents the size of the selected item; the ScaleX and ScaleY properties are applied to non-selected items. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ItemWidth { get; set; }
Visual Basic (Declaration)
Public Property ItemWidth As Double
Visual C++
public:
property double ItemWidth {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ItemWidthProperty
Metadata properties set to true | None

See Also

CoverFlow Class


MouseSelectionMode Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.MouseSelectionMode Property
CoverFlow Class See Also Send Feedback
Gets or sets how the user can select items using the mouse. The default is MousePressed. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CoverFlowMouseSelectionMode MouseSelectionMode { get; set; }
Visual Basic (Declaration)
Public Property MouseSelectionMode As CoverFlowMouseSelectionMode
Visual C++
public:
property CoverFlowMouseSelectionMode MouseSelectionMode {
    CoverFlowMouseSelectionMode get ();
    void set (CoverFlowMouseSelectionMode value);
}

Remarks

Dependency Property Information
Identifier field | MouseSelectionModeProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ReflectionBrush Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ReflectionBrush Property
CoverFlow Class See Also Send Feedback
Gets or sets the Brush used in the reflection of each CoverFlowItem. This brush is overlaid on the reflection and should typically contain a gradient from a solid color (equal to the background color of the CoverFlow) to a translucent version of that color. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush ReflectionBrush { get; set; }
Visual Basic (Declaration)
Public Property ReflectionBrush As Brush
Visual C++
public:
property Brush^ ReflectionBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Remarks

Dependency Property Information
Identifier field | ReflectionBrushProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ReflectionScaleY Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ReflectionScaleY Property
CoverFlow Class See Also Send Feedback
Gets or sets the vertical scale applied to the reflection. This must be between 0 and 1. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ReflectionScaleY { get; set; }
Visual Basic (Declaration)
Public Property ReflectionScaleY As Double
Visual C++
public:
property double ReflectionScaleY {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ReflectionScaleYProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ScaleX Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ScaleX Property
CoverFlow Class See Also Send Feedback
Gets or sets the horizontal scaling applied to the non-selected items. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ScaleX { get; set; }
Visual Basic (Declaration)
Public Property ScaleX As Double
Visual C++
public:
property double ScaleX {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ScaleXProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ScaleY Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ScaleY Property
CoverFlow Class See Also Send Feedback
Gets or sets the vertical scaling applied to the non-selected items. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ScaleY { get; set; }
Visual Basic (Declaration)
Public Property ScaleY As Double
Visual C++
public:
property double ScaleY {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ScaleYProperty
Metadata properties set to true | None

See Also

CoverFlow Class


SelectedItemSeparation Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.SelectedItemSeparation Property
CoverFlow Class See Also Send Feedback
Gets or sets the separation between the selected item and the items adjacent to it. This is instead of, not additional to, the ItemSeparation property, and should usually be larger than it. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double SelectedItemSeparation { get; set; }
Visual Basic (Declaration)
Public Property SelectedItemSeparation As Double
Visual C++
public:
property double SelectedItemSeparation {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | SelectedItemSeparationProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ShearAngle Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ShearAngle Property
CoverFlow Class See Also Send Feedback
Gets or sets the vertical shear of the items within this CoverFlow, in degrees. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ShearAngle { get; set; }
Visual Basic (Declaration)
Public Property ShearAngle As Double
Visual C++
public:
property double ShearAngle {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ShearAngleProperty
Metadata properties set to true | None

See Also

CoverFlow Class


ShowReflection Property

[image]

Mindscape Silverlight Elements
CoverFlow..::.ShowReflection Property
CoverFlow Class See Also Send Feedback
Gets or sets whether the CoverFlow shows reflections below each item. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowReflection { get; set; }
Visual Basic (Declaration)
Public Property ShowReflection As Boolean
Visual C++
public:
property bool ShowReflection {
    bool get ();
    void set (bool value);
}

Remarks

Dependency Property Information
Identifier field | ShowReflectionProperty
Metadata properties set to true | None

See Also

CoverFlow Class


CoverFlow Events

[image] [image]

Mindscape Silverlight Elements
CoverFlow Events
CoverFlow Class See Also Send Feedback

The CoverFlow type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CoverFlow Class


CoverFlowItem Class

[image]

Mindscape Silverlight Elements
CoverFlowItem Class
Members See Also Send Feedback
Implements a selectable item within a CoverFlow.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CoverFlowItem : ListBoxItem
Visual Basic (Declaration)
Public Class CoverFlowItem _
    Inherits ListBoxItem
Visual C++
public ref class CoverFlowItem : public ListBoxItem

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.SilverlightElements..::.CoverFlowItem

See Also

CoverFlowItem Members


CoverFlowItem Members

[image] [image]

Mindscape Silverlight Elements
CoverFlowItem Members
CoverFlowItem Class Constructors Methods Fields Properties Events See Also Send Feedback

The CoverFlowItem type exposes the following members.

Constructors

Name | Description
CoverFlowItem | Initializes a new instance of the CoverFlowItem class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnContentChanged | Called when the value of the Content property changes. (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | Called before the MouseEnter event occurs. (Overrides ListBoxItem..::.OnMouseEnter(MouseEventArgs).)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | (Inherited from ListBoxItem.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ClipBottomLeftProperty | Identifies the ClipBottomLeft property.
ClipBottomRightProperty | Identifies the ClipBottomRight property.
ClipTopRightProperty | Identifies the ClipTopRight property.
ContentHeightProperty | Identifies the ContentHeight property.
ReflectionBrushProperty | Identifies the ReflectionBrush property.
ReflectionBrushRenderTransformProperty | Identifies the ReflectionBrushRenderTransform property.
ReflectionRenderTransformProperty | Identifies the ReflectionRenderTransform property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipBottomLeft | Gets the bottom left of the clip parallelogram. This is a dependency property.
ClipBottomRight | Gets the bottom right of the clip parallelogram. This is a dependency property.
ClipTopRight | Gets the top right of the clip parallelogram. This is a dependency property.
Content | (Inherited from ContentControl.)
ContentHeight | Gets or sets the ContentHeight. This is a dependency property.
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
ReflectionBrush | Gets or sets the ReflectionBrush. This is a dependency property.
ReflectionBrushRenderTransform | Gets or sets the ReflectionBrushRenderTransform. This is a dependency property.
ReflectionRenderTransform | Gets or sets the ReflectionRenderTransform. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TransitionAnimationKey | Identifies the template for selection transition animation.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CoverFlowItem Class


CoverFlowItem Constructor

[image]

Mindscape Silverlight Elements
CoverFlowItem Constructor
CoverFlowItem Class See Also Send Feedback
Initializes a new instance of the CoverFlowItem class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CoverFlowItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CoverFlowItem()

See Also

CoverFlowItem Class


CoverFlowItem Fields

[image] [image]

Mindscape Silverlight Elements
CoverFlowItem Fields
CoverFlowItem Class See Also Send Feedback

The CoverFlowItem type exposes the following members.

Fields

Name | Description
ClipBottomLeftProperty | Identifies the ClipBottomLeft property.
ClipBottomRightProperty | Identifies the ClipBottomRight property.
ClipTopRightProperty | Identifies the ClipTopRight property.
ContentHeightProperty | Identifies the ContentHeight property.
ReflectionBrushProperty | Identifies the ReflectionBrush property.
ReflectionBrushRenderTransformProperty | Identifies the ReflectionBrushRenderTransform property.
ReflectionRenderTransformProperty | Identifies the ReflectionRenderTransform property.

See Also

CoverFlowItem Class


ClipBottomLeftProperty Field

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ClipBottomLeftProperty Field
CoverFlowItem Class See Also Send Feedback
Identifies the ClipBottomLeft property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ClipBottomLeftProperty
Visual Basic (Declaration)
Public Shared ReadOnly ClipBottomLeftProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ClipBottomLeftProperty

See Also

CoverFlowItem Class


ClipBottomRightProperty Field

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ClipBottomRightProperty Field
CoverFlowItem Class See Also Send Feedback
Identifies the ClipBottomRight property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ClipBottomRightProperty
Visual Basic (Declaration)
Public Shared ReadOnly ClipBottomRightProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ClipBottomRightProperty

See Also

CoverFlowItem Class


ClipTopRightProperty Field

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ClipTopRightProperty Field
CoverFlowItem Class See Also Send Feedback
Identifies the ClipTopRight property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ClipTopRightProperty
Visual Basic (Declaration)
Public Shared ReadOnly ClipTopRightProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ClipTopRightProperty

See Also

CoverFlowItem Class


ContentHeightProperty Field

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ContentHeightProperty Field
CoverFlowItem Class See Also Send Feedback
Identifies the ContentHeight property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ContentHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentHeightProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ContentHeightProperty

See Also

CoverFlowItem Class


ReflectionBrushProperty Field

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ReflectionBrushProperty Field
CoverFlowItem Class See Also Send Feedback
Identifies the ReflectionBrush property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ReflectionBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReflectionBrushProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ReflectionBrushProperty

See Also

CoverFlowItem Class


ReflectionBrushRenderTransformProperty Field

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ReflectionBrushRenderTransformProperty Field
CoverFlowItem Class See Also Send Feedback
Identifies the ReflectionBrushRenderTransform property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ReflectionBrushRenderTransformProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReflectionBrushRenderTransformProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ReflectionBrushRenderTransformProperty

See Also

CoverFlowItem Class


ReflectionRenderTransformProperty Field

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ReflectionRenderTransformProperty Field
CoverFlowItem Class See Also Send Feedback
Identifies the ReflectionRenderTransform property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ReflectionRenderTransformProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReflectionRenderTransformProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ReflectionRenderTransformProperty

See Also

CoverFlowItem Class


CoverFlowItem Methods

[image] [image]

Mindscape Silverlight Elements
CoverFlowItem Methods
CoverFlowItem Class See Also Send Feedback

The CoverFlowItem type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnContentChanged | Called when the value of the Content property changes. (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | Called before the MouseEnter event occurs. (Overrides ListBoxItem..::.OnMouseEnter(MouseEventArgs).)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | (Inherited from ListBoxItem.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

CoverFlowItem Class


OnContentChanged Method

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.OnContentChanged Method
CoverFlowItem Class See Also Send Feedback
Called when the value of the Content property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)
Visual C++
protected:
virtual void OnContentChanged(
    Object^ oldContent,
    Object^ newContent
) override

Parameters

oldContent
Type: System..::.Object
The old value of the Content property.
newContent
Type: System..::.Object
The new value of the Content property.

See Also

CoverFlowItem Class


OnMouseEnter Method

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.OnMouseEnter Method
CoverFlowItem Class See Also Send Feedback
Called before the MouseEnter event occurs.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseEnter ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The data for the event.

See Also

CoverFlowItem Class


CoverFlowItem Properties

[image] [image]

Mindscape Silverlight Elements
CoverFlowItem Properties
CoverFlowItem Class See Also Send Feedback

The CoverFlowItem type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ClipBottomLeft | Gets the bottom left of the clip parallelogram. This is a dependency property.
ClipBottomRight | Gets the bottom right of the clip parallelogram. This is a dependency property.
ClipTopRight | Gets the top right of the clip parallelogram. This is a dependency property.
Content | (Inherited from ContentControl.)
ContentHeight | Gets or sets the ContentHeight. This is a dependency property.
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
ReflectionBrush | Gets or sets the ReflectionBrush. This is a dependency property.
ReflectionBrushRenderTransform | Gets or sets the ReflectionBrushRenderTransform. This is a dependency property.
ReflectionRenderTransform | Gets or sets the ReflectionRenderTransform. This is a dependency property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TransitionAnimationKey | Identifies the template for selection transition animation.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

CoverFlowItem Class


ClipBottomLeft Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ClipBottomLeft Property
CoverFlowItem Class See Also Send Feedback
Gets the bottom left of the clip parallelogram. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point ClipBottomLeft { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClipBottomLeft As Point
Visual C++
public:
property Point ClipBottomLeft {
    Point get ();
}

Remarks

Dependency Property Information
Identifier field | ClipBottomLeftProperty
Metadata properties set to true | None

See Also

CoverFlowItem Class


ClipBottomRight Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ClipBottomRight Property
CoverFlowItem Class See Also Send Feedback
Gets the bottom right of the clip parallelogram. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point ClipBottomRight { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClipBottomRight As Point
Visual C++
public:
property Point ClipBottomRight {
    Point get ();
}

Remarks

Dependency Property Information
Identifier field | ClipBottomRightProperty
Metadata properties set to true | None

See Also

CoverFlowItem Class


ClipTopRight Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ClipTopRight Property
CoverFlowItem Class See Also Send Feedback
Gets the top right of the clip parallelogram. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point ClipTopRight { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClipTopRight As Point
Visual C++
public:
property Point ClipTopRight {
    Point get ();
}

Remarks

Dependency Property Information
Identifier field | ClipTopRightProperty
Metadata properties set to true | None

See Also

CoverFlowItem Class


ContentHeight Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ContentHeight Property
CoverFlowItem Class See Also Send Feedback
Gets or sets the ContentHeight. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ContentHeight { get; set; }
Visual Basic (Declaration)
Public Property ContentHeight As Double
Visual C++
public:
property double ContentHeight {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | ContentHeightProperty
Metadata properties set to true | None

See Also

CoverFlowItem Class


ReflectionBrush Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ReflectionBrush Property
CoverFlowItem Class See Also Send Feedback
Gets or sets the ReflectionBrush. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush ReflectionBrush { get; set; }
Visual Basic (Declaration)
Public Property ReflectionBrush As Brush
Visual C++
public:
property Brush^ ReflectionBrush {
    Brush^ get ();
    void set (Brush^ value);
}

Remarks

Dependency Property Information
Identifier field | ReflectionBrushProperty
Metadata properties set to true | None

See Also

CoverFlowItem Class


ReflectionBrushRenderTransform Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ReflectionBrushRenderTransform Property
CoverFlowItem Class See Also Send Feedback
Gets or sets the ReflectionBrushRenderTransform. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Transform ReflectionBrushRenderTransform { get; set; }
Visual Basic (Declaration)
Public Property ReflectionBrushRenderTransform As Transform
Visual C++
public:
property Transform^ ReflectionBrushRenderTransform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

Dependency Property Information
Identifier field | ReflectionBrushRenderTransformProperty
Metadata properties set to true | None

See Also

CoverFlowItem Class


ReflectionRenderTransform Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.ReflectionRenderTransform Property
CoverFlowItem Class See Also Send Feedback
Gets or sets the ReflectionRenderTransform. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Transform ReflectionRenderTransform { get; set; }
Visual Basic (Declaration)
Public Property ReflectionRenderTransform As Transform
Visual C++
public:
property Transform^ ReflectionRenderTransform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

Dependency Property Information
Identifier field | ReflectionRenderTransformProperty
Metadata properties set to true | None

See Also

CoverFlowItem Class


TransitionAnimationKey Property

[image]

Mindscape Silverlight Elements
CoverFlowItem..::.TransitionAnimationKey Property
CoverFlowItem Class See Also Send Feedback
Identifies the template for selection transition animation.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string TransitionAnimationKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TransitionAnimationKey As String
Visual C++
public:
static property String^ TransitionAnimationKey {
    String^ get ();
}

See Also

CoverFlowItem Class


CoverFlowItem Events

[image] [image]

Mindscape Silverlight Elements
CoverFlowItem Events
CoverFlowItem Class See Also Send Feedback

The CoverFlowItem type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

CoverFlowItem Class


CoverFlowMouseSelectionMode Enumeration

[image]

Mindscape Silverlight Elements
CoverFlowMouseSelectionMode Enumeration
See Also Send Feedback
Specifies how the mouse can be used to interactively select an item within a CoverFlow.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum CoverFlowMouseSelectionMode
Visual Basic (Declaration)
Public Enumeration CoverFlowMouseSelectionMode
Visual C++
public enum class CoverFlowMouseSelectionMode

Members

Member name | Description
MouseEnter | Items can be selected by moving the mouse over them.
MousePressed | Items can be selected by clicking them with the mouse.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


DataTemplateSelector Class

[image]

Mindscape Silverlight Elements
DataTemplateSelector Class
Members See Also Send Feedback
Provides a way to choose a DataTemplate based on the data object and the data-bound element.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataTemplateSelector
Visual Basic (Declaration)
Public Class DataTemplateSelector
Visual C++
public ref class DataTemplateSelector

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.DataTemplateSelector

See Also

DataTemplateSelector Members


DataTemplateSelector Members

[image] [image]

Mindscape Silverlight Elements
DataTemplateSelector Members
DataTemplateSelector Class Constructors Methods See Also Send Feedback

The DataTemplateSelector type exposes the following members.

Constructors

Name | Description
DataTemplateSelector | Initializes a new instance of the DataTemplateSelector class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SelectTemplate | When overridden in a derived class, returns a DataTemplate based on custom logic.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataTemplateSelector Class


DataTemplateSelector Constructor

[image]

Mindscape Silverlight Elements
DataTemplateSelector Constructor
DataTemplateSelector Class See Also Send Feedback
Initializes a new instance of the DataTemplateSelector class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplateSelector()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataTemplateSelector()

See Also

DataTemplateSelector Class


DataTemplateSelector Methods

[image] [image]

Mindscape Silverlight Elements
DataTemplateSelector Methods
DataTemplateSelector Class See Also Send Feedback

The DataTemplateSelector type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SelectTemplate | When overridden in a derived class, returns a DataTemplate based on custom logic.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataTemplateSelector Class


SelectTemplate Method

[image]

Mindscape Silverlight Elements
DataTemplateSelector..::.SelectTemplate Method
DataTemplateSelector Class See Also Send Feedback
When overridden in a derived class, returns a DataTemplate based on custom logic.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public virtual DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overridable Function SelectTemplate ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate
Visual C++
public:
virtual DataTemplate^ SelectTemplate(
    Object^ item,
    DependencyObject^ container
)

Parameters

item
Type: System..::.Object
The data object for which to select the template.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The desired DataTemplate, or null.

See Also

DataTemplateSelector Class


DateDisplayMode Enumeration

[image]

Mindscape Silverlight Elements
DateDisplayMode Enumeration
See Also Send Feedback
Specifies whether dates should be formatted with the day of the month or as the month name only.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DateDisplayMode
Visual Basic (Declaration)
Public Enumeration DateDisplayMode
Visual C++
public enum class DateDisplayMode

Members

Member name | Description
Day | Dates should be formatted with the day of the month.
Month | Dates should be formatted using the month name only.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


DateRange Structure

[image]

Mindscape Silverlight Elements
DateRange Structure
Members See Also Send Feedback
Represents a range of dates.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct DateRange
Visual Basic (Declaration)
Public Structure DateRange
Visual C++
public value class DateRange

See Also

DateRange Members


DateRange Members

[image] [image]

Mindscape Silverlight Elements
DateRange Members
DateRange Structure Methods Properties See Also Send Feedback

The DateRange type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
EndDate | Gets the end of the range.
StartDate | Gets the start of the range.

See Also

DateRange Structure


DateRange Methods

[image] [image]

Mindscape Silverlight Elements
DateRange Methods
DateRange Structure See Also Send Feedback

The DateRange type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

DateRange Structure


DateRange Properties

[image] [image]

Mindscape Silverlight Elements
DateRange Properties
DateRange Structure See Also Send Feedback

The DateRange type exposes the following members.

Properties

Name | Description
EndDate | Gets the end of the range.
StartDate | Gets the start of the range.

See Also

DateRange Structure


EndDate Property

[image]

Mindscape Silverlight Elements
DateRange..::.EndDate Property
DateRange Structure See Also Send Feedback
Gets the end of the range.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime EndDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndDate As DateTime
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
}

See Also

DateRange Structure


StartDate Property

[image]

Mindscape Silverlight Elements
DateRange..::.StartDate Property
DateRange Structure See Also Send Feedback
Gets the start of the range.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime StartDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
}

See Also

DateRange Structure


DateRangeDisplayConverter Class

[image]

Mindscape Silverlight Elements
DateRangeDisplayConverter Class
Members See Also Send Feedback
Formats the date range of a ScheduleView suitably for display in the SchedulerNavigationBar.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateRangeDisplayConverter : IValueConverter
Visual Basic (Declaration)
Public Class DateRangeDisplayConverter _
    Implements IValueConverter
Visual C++
public ref class DateRangeDisplayConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.DateRangeDisplayConverter

See Also

DateRangeDisplayConverter Members


DateRangeDisplayConverter Members

[image] [image]

Mindscape Silverlight Elements
DateRangeDisplayConverter Members
DateRangeDisplayConverter Class Constructors Methods Properties See Also Send Feedback

The DateRangeDisplayConverter type exposes the following members.

Constructors

Name | Description
DateRangeDisplayConverter | Initializes a new instance of the DateRangeDisplayConverter class

Methods

Name | Description
Convert | Formats the DateRangeDisplayInfo value for display in a view title.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MonthFormat | Gets or sets the format string to be used for displaying months. The default is full month name (e.g. "January").

See Also

DateRangeDisplayConverter Class


DateRangeDisplayConverter Constructor

[image]

Mindscape Silverlight Elements
DateRangeDisplayConverter Constructor
DateRangeDisplayConverter Class See Also Send Feedback
Initializes a new instance of the DateRangeDisplayConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateRangeDisplayConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateRangeDisplayConverter()

See Also

DateRangeDisplayConverter Class


DateRangeDisplayConverter Methods

[image] [image]

Mindscape Silverlight Elements
DateRangeDisplayConverter Methods
DateRangeDisplayConverter Class See Also Send Feedback

The DateRangeDisplayConverter type exposes the following members.

Methods

Name | Description
Convert | Formats the DateRangeDisplayInfo value for display in a view title.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateRangeDisplayConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
DateRangeDisplayConverter..::.Convert Method
DateRangeDisplayConverter Class See Also Send Feedback
Formats the DateRangeDisplayInfo value for display in a view title.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The DateRangeDisplayInfo value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A formatted representation of the date range.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DateRangeDisplayConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
DateRangeDisplayConverter..::.ConvertBack Method
DateRangeDisplayConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DateRangeDisplayConverter Class


DateRangeDisplayConverter Properties

[image] [image]

Mindscape Silverlight Elements
DateRangeDisplayConverter Properties
DateRangeDisplayConverter Class See Also Send Feedback

The DateRangeDisplayConverter type exposes the following members.

Properties

Name | Description
MonthFormat | Gets or sets the format string to be used for displaying months. The default is full month name (e.g. "January").

See Also

DateRangeDisplayConverter Class


MonthFormat Property

[image]

Mindscape Silverlight Elements
DateRangeDisplayConverter..::.MonthFormat Property
DateRangeDisplayConverter Class See Also Send Feedback
Gets or sets the format string to be used for displaying months. The default is full month name (e.g. "January").

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MonthFormat { get; set; }
Visual Basic (Declaration)
Public Property MonthFormat As String
Visual C++
public:
property String^ MonthFormat {
    String^ get ();
    void set (String^ value);
}

See Also

DateRangeDisplayConverter Class


DateRangeDisplayInfo Structure

[image]

Mindscape Silverlight Elements
DateRangeDisplayInfo Structure
Members See Also Send Feedback
Provides display information for a date range.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct DateRangeDisplayInfo
Visual Basic (Declaration)
Public Structure DateRangeDisplayInfo
Visual C++
public value class DateRangeDisplayInfo

See Also

DateRangeDisplayInfo Members


DateRangeDisplayInfo Members

[image] [image]

Mindscape Silverlight Elements
DateRangeDisplayInfo Members
DateRangeDisplayInfo Structure Methods Properties See Also Send Feedback

The DateRangeDisplayInfo type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
DisplayMode | Gets whether the date range should be formatted as days or as a month name.
EndDate | Gets the end of the date range.
IsSingleDate | Gets whether the range represents a single date.
StartDate | Gets the start of the date range.

See Also

DateRangeDisplayInfo Structure


DateRangeDisplayInfo Methods

[image] [image]

Mindscape Silverlight Elements
DateRangeDisplayInfo Methods
DateRangeDisplayInfo Structure See Also Send Feedback

The DateRangeDisplayInfo type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

DateRangeDisplayInfo Structure


DateRangeDisplayInfo Properties

[image] [image]

Mindscape Silverlight Elements
DateRangeDisplayInfo Properties
DateRangeDisplayInfo Structure See Also Send Feedback

The DateRangeDisplayInfo type exposes the following members.

Properties

Name | Description
DisplayMode | Gets whether the date range should be formatted as days or as a month name.
EndDate | Gets the end of the date range.
IsSingleDate | Gets whether the range represents a single date.
StartDate | Gets the start of the date range.

See Also

DateRangeDisplayInfo Structure


DisplayMode Property

[image]

Mindscape Silverlight Elements
DateRangeDisplayInfo..::.DisplayMode Property
DateRangeDisplayInfo Structure See Also Send Feedback
Gets whether the date range should be formatted as days or as a month name.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateDisplayMode DisplayMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property DisplayMode As DateDisplayMode
Visual C++
public:
property DateDisplayMode DisplayMode {
    DateDisplayMode get ();
}

See Also

DateRangeDisplayInfo Structure


EndDate Property

[image]

Mindscape Silverlight Elements
DateRangeDisplayInfo..::.EndDate Property
DateRangeDisplayInfo Structure See Also Send Feedback
Gets the end of the date range.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime EndDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndDate As DateTime
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
}

See Also

DateRangeDisplayInfo Structure


IsSingleDate Property

[image]

Mindscape Silverlight Elements
DateRangeDisplayInfo..::.IsSingleDate Property
DateRangeDisplayInfo Structure See Also Send Feedback
Gets whether the range represents a single date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSingleDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSingleDate As Boolean
Visual C++
public:
property bool IsSingleDate {
    bool get ();
}

See Also

DateRangeDisplayInfo Structure


StartDate Property

[image]

Mindscape Silverlight Elements
DateRangeDisplayInfo..::.StartDate Property
DateRangeDisplayInfo Structure See Also Send Feedback
Gets the start of the date range.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime StartDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
}

See Also

DateRangeDisplayInfo Structure


DateTimeToDayOfMonthStringConverter Class

[image]

Mindscape Silverlight Elements
DateTimeToDayOfMonthStringConverter Class
Members See Also Send Feedback
Converts a date to a string suitable for display as the day caption in a monthly view. By default, this is the day of the month (e.g. "15"). However, if the day is part of a week that spans a month boundary, then the month is appended if the day is the first day of that week, or the first day of the month. For example, in the week beginning 29 March 2010, 29 March would be formatted as "29 Mar", 30 March as "30", 31 March as "31" and 1 April as "1 Apr". Similar display logic applies to weeks that span a year boundary.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateTimeToDayOfMonthStringConverter : IValueConverter
Visual Basic (Declaration)
Public Class DateTimeToDayOfMonthStringConverter _
    Implements IValueConverter
Visual C++
public ref class DateTimeToDayOfMonthStringConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.DateTimeToDayOfMonthStringConverter

See Also

DateTimeToDayOfMonthStringConverter Members


DateTimeToDayOfMonthStringConverter Members

[image] [image]

Mindscape Silverlight Elements
DateTimeToDayOfMonthStringConverter Members
DateTimeToDayOfMonthStringConverter Class Constructors Methods See Also Send Feedback

The DateTimeToDayOfMonthStringConverter type exposes the following members.

Constructors

Name | Description
DateTimeToDayOfMonthStringConverter | Initializes a new instance of the DateTimeToDayOfMonthStringConverter class

Methods

Name | Description
Convert | Converts a date to a string suitable for display as the day caption in a monthly view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToDayOfMonthStringConverter Class


DateTimeToDayOfMonthStringConverter Constructor

[image]

Mindscape Silverlight Elements
DateTimeToDayOfMonthStringConverter Constructor
DateTimeToDayOfMonthStringConverter Class See Also Send Feedback
Initializes a new instance of the DateTimeToDayOfMonthStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeToDayOfMonthStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimeToDayOfMonthStringConverter()

See Also

DateTimeToDayOfMonthStringConverter Class


DateTimeToDayOfMonthStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
DateTimeToDayOfMonthStringConverter Methods
DateTimeToDayOfMonthStringConverter Class See Also Send Feedback

The DateTimeToDayOfMonthStringConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a date to a string suitable for display as the day caption in a monthly view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToDayOfMonthStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
DateTimeToDayOfMonthStringConverter..::.Convert Method
DateTimeToDayOfMonthStringConverter Class See Also Send Feedback
Converts a date to a string suitable for display as the day caption in a monthly view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The DateTime value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string suitable for display as the day caption in a monthly view.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DateTimeToDayOfMonthStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
DateTimeToDayOfMonthStringConverter..::.ConvertBack Method
DateTimeToDayOfMonthStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DateTimeToDayOfMonthStringConverter Class


DateTimeToDayOfWeekStringConverter Class

[image]

Mindscape Silverlight Elements
DateTimeToDayOfWeekStringConverter Class
Members See Also Send Feedback
Formats a DateTime as a day of the week (e.g. "Monday").

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateTimeToDayOfWeekStringConverter : IValueConverter
Visual Basic (Declaration)
Public Class DateTimeToDayOfWeekStringConverter _
    Implements IValueConverter
Visual C++
public ref class DateTimeToDayOfWeekStringConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.DateTimeToDayOfWeekStringConverter

See Also

DateTimeToDayOfWeekStringConverter Members


DateTimeToDayOfWeekStringConverter Members

[image] [image]

Mindscape Silverlight Elements
DateTimeToDayOfWeekStringConverter Members
DateTimeToDayOfWeekStringConverter Class Constructors Methods See Also Send Feedback

The DateTimeToDayOfWeekStringConverter type exposes the following members.

Constructors

Name | Description
DateTimeToDayOfWeekStringConverter | Initializes a new instance of the DateTimeToDayOfWeekStringConverter class

Methods

Name | Description
Convert | Formats a DateTime as a day of the week (e.g. "Monday").
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToDayOfWeekStringConverter Class


DateTimeToDayOfWeekStringConverter Constructor

[image]

Mindscape Silverlight Elements
DateTimeToDayOfWeekStringConverter Constructor
DateTimeToDayOfWeekStringConverter Class See Also Send Feedback
Initializes a new instance of the DateTimeToDayOfWeekStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeToDayOfWeekStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimeToDayOfWeekStringConverter()

See Also

DateTimeToDayOfWeekStringConverter Class


DateTimeToDayOfWeekStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
DateTimeToDayOfWeekStringConverter Methods
DateTimeToDayOfWeekStringConverter Class See Also Send Feedback

The DateTimeToDayOfWeekStringConverter type exposes the following members.

Methods

Name | Description
Convert | Formats a DateTime as a day of the week (e.g. "Monday").
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToDayOfWeekStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
DateTimeToDayOfWeekStringConverter..::.Convert Method
DateTimeToDayOfWeekStringConverter Class See Also Send Feedback
Formats a DateTime as a day of the week (e.g. "Monday").

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The DateTime value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string containing the day of the week of the input date.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DateTimeToDayOfWeekStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
DateTimeToDayOfWeekStringConverter..::.ConvertBack Method
DateTimeToDayOfWeekStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DateTimeToDayOfWeekStringConverter Class


DateTimeToFullDateStringConverter Class

[image]

Mindscape Silverlight Elements
DateTimeToFullDateStringConverter Class
Members See Also Send Feedback
Converts a date to its full date representation (e.g. "1 January 2010").

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateTimeToFullDateStringConverter : IValueConverter
Visual Basic (Declaration)
Public Class DateTimeToFullDateStringConverter _
    Implements IValueConverter
Visual C++
public ref class DateTimeToFullDateStringConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.DateTimeToFullDateStringConverter

See Also

DateTimeToFullDateStringConverter Members


DateTimeToFullDateStringConverter Members

[image] [image]

Mindscape Silverlight Elements
DateTimeToFullDateStringConverter Members
DateTimeToFullDateStringConverter Class Constructors Methods See Also Send Feedback

The DateTimeToFullDateStringConverter type exposes the following members.

Constructors

Name | Description
DateTimeToFullDateStringConverter | Initializes a new instance of the DateTimeToFullDateStringConverter class

Methods

Name | Description
Convert | Converts a date to its full date representation (e.g. "1 January 2010").
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToFullDateStringConverter Class


DateTimeToFullDateStringConverter Constructor

[image]

Mindscape Silverlight Elements
DateTimeToFullDateStringConverter Constructor
DateTimeToFullDateStringConverter Class See Also Send Feedback
Initializes a new instance of the DateTimeToFullDateStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeToFullDateStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimeToFullDateStringConverter()

See Also

DateTimeToFullDateStringConverter Class


DateTimeToFullDateStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
DateTimeToFullDateStringConverter Methods
DateTimeToFullDateStringConverter Class See Also Send Feedback

The DateTimeToFullDateStringConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a date to its full date representation (e.g. "1 January 2010").
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToFullDateStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
DateTimeToFullDateStringConverter..::.Convert Method
DateTimeToFullDateStringConverter Class See Also Send Feedback
Converts a date to its full date representation (e.g. "1 January 2010").

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The DateTime value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string containing the formatted date. (Time components are ignored.)

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DateTimeToFullDateStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
DateTimeToFullDateStringConverter..::.ConvertBack Method
DateTimeToFullDateStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DateTimeToFullDateStringConverter Class


DateTimeToMonthStringConverter Class

[image]

Mindscape Silverlight Elements
DateTimeToMonthStringConverter Class
Members See Also Send Feedback
Converts a DateTime value to its full month name (e.g. "January").

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DateTimeToMonthStringConverter : IValueConverter
Visual Basic (Declaration)
Public Class DateTimeToMonthStringConverter _
    Implements IValueConverter
Visual C++
public ref class DateTimeToMonthStringConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.DateTimeToMonthStringConverter

See Also

DateTimeToMonthStringConverter Members


DateTimeToMonthStringConverter Members

[image] [image]

Mindscape Silverlight Elements
DateTimeToMonthStringConverter Members
DateTimeToMonthStringConverter Class Constructors Methods See Also Send Feedback

The DateTimeToMonthStringConverter type exposes the following members.

Constructors

Name | Description
DateTimeToMonthStringConverter | Initializes a new instance of the DateTimeToMonthStringConverter class

Methods

Name | Description
Convert | Converts a date to its full month name.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToMonthStringConverter Class


DateTimeToMonthStringConverter Constructor

[image]

Mindscape Silverlight Elements
DateTimeToMonthStringConverter Constructor
DateTimeToMonthStringConverter Class See Also Send Feedback
Initializes a new instance of the DateTimeToMonthStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTimeToMonthStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimeToMonthStringConverter()

See Also

DateTimeToMonthStringConverter Class


DateTimeToMonthStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
DateTimeToMonthStringConverter Methods
DateTimeToMonthStringConverter Class See Also Send Feedback

The DateTimeToMonthStringConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a date to its full month name.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeToMonthStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
DateTimeToMonthStringConverter..::.Convert Method
DateTimeToMonthStringConverter Class See Also Send Feedback
Converts a date to its full month name.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The DateTime value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string containing the full name of the month of the date.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DateTimeToMonthStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
DateTimeToMonthStringConverter..::.ConvertBack Method
DateTimeToMonthStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DateTimeToMonthStringConverter Class


DayOfRecurrence Enumeration

[image]

Mindscape Silverlight Elements
DayOfRecurrence Enumeration
See Also Send Feedback
The day on which a recurring schedule item recurs. This may be a day of the week, or it may match multiple days of the week (as in "last day of the month" or "first weekday in January"). It is used in conjunction with the Occurrence type.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DayOfRecurrence
Visual Basic (Declaration)
Public Enumeration DayOfRecurrence
Visual C++
public enum class DayOfRecurrence

Members

Member name | Description
Day | The Occurrence counts all days.
Weekday | The Occurrence counts all weekdays (Monday to Friday).
WeekendDay | The Occurrence counts weekend days (Saturday and Sunday);
Sunday | The Occurrence counts Sundays.
Monday | The Occurrence counts Mondays.
Tuesday | The Occurrence counts Tuesdays.
Wednesday | The Occurrence counts Wednesdays.
Thursday | The Occurrence counts Thursdays.
Friday | The Occurrence counts Fridays.
Saturday | The Occurrence counts Saturdays.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


DayView Class

[image]

Mindscape Silverlight Elements
DayView Class
Members See Also Send Feedback
Represents a single-day view in a Scheduler control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DayView : ScheduleView
Visual Basic (Declaration)
Public Class DayView _
    Inherits ScheduleView
Visual C++
public ref class DayView : public ScheduleView

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ScheduleView
Mindscape.SilverlightElements..::.DayView

See Also

DayView Members


DayView Members

[image] [image]

Mindscape Silverlight Elements
DayView Members
DayView Class Constructors Methods Properties Events See Also Send Feedback

The DayView type exposes the following members.

Constructors

Name | Description
DayView | Overloaded.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | Cancels tha addition of the specified item. (Overrides ScheduleView..::.CancelAdd(ScheduleItem).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | Adds a new schedule item at the current selection. (Overrides ScheduleView..::.CreateScheduleItemForAdd()()().)
DecrementView | Moves the view to the previous day. (Overrides ScheduleView..::.DecrementView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | Gets a suitable start date for the control to display the requested date. (Overrides ScheduleView..::.GetStartDateContaining(DateTime).)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view to the next day. (Overrides ScheduleView..::.IncrementView()()().)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range. (Inherited from ScheduleView.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ScheduleView.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection. (Inherited from ScheduleView.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title. (Inherited from ScheduleView.)
DateRangeDisplayMode | Gets how to format dates in the view title. (Overrides ScheduleView..::.DateRangeDisplayMode.)
Day | Gets the day being displayed.
Days | Gets a list containing the day being represented.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view. (Overrides ScheduleView..::.EndDate.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled. (Inherited from ScheduleView.)
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled. (Inherited from ScheduleView.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week). (Inherited from ScheduleView.)
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view. (Inherited from ScheduleView.)
Now | Gets the current date and time. (Inherited from ScheduleView.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week). (Inherited from ScheduleView.)
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view. (Inherited from ScheduleView.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed. (Inherited from ScheduleView.)
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item). (Inherited from ScheduleView.)
StartDate | Gets or sets the start date of the view. (Overrides ScheduleView..::.StartDate.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day. (Inherited from ScheduleView.)
TimeSlots | Gets the collection of timeslots to be displayed in the view.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes. (Inherited from ScheduleView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DayView Class


DayView Constructor

[image] [image]

Mindscape Silverlight Elements
DayView Constructor
DayView Class See Also Send Feedback

Overload List

Name | Description
DayView()()() | Initializes a new instance of the DayView class.
DayView(Schedule, DateTime) | Initializes a new instance of the DayView class.

See Also

DayView Class
DayView Members


DayView Constructor

[image]

Mindscape Silverlight Elements
DayView Constructor
DayView Class See Also Send Feedback
Initializes a new instance of the DayView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DayView()

See Also

DayView Class
DayView Overload


DayView Constructor (Schedule, DateTime)

[image]

Mindscape Silverlight Elements
DayView Constructor (Schedule, DateTime)
DayView Class See Also Send Feedback
Initializes a new instance of the DayView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayView(
    Schedule schedule,
    DateTime startDate
)
Visual Basic (Declaration)
Public Sub New ( _
    schedule As Schedule, _
    startDate As DateTime _
)
Visual C++
public:
DayView(
    Schedule^ schedule,
    DateTime startDate
)

Parameters

schedule
Type: Mindscape.SilverlightElements..::.Schedule
The Schedule to be displayed.
startDate
Type: System..::.DateTime
The start date for the display.

See Also

DayView Class
DayView Overload


DayView Methods

[image] [image]

Mindscape Silverlight Elements
DayView Methods
DayView Class See Also Send Feedback

The DayView type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | Cancels tha addition of the specified item. (Overrides ScheduleView..::.CancelAdd(ScheduleItem).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | Adds a new schedule item at the current selection. (Overrides ScheduleView..::.CreateScheduleItemForAdd()()().)
DecrementView | Moves the view to the previous day. (Overrides ScheduleView..::.DecrementView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | Gets a suitable start date for the control to display the requested date. (Overrides ScheduleView..::.GetStartDateContaining(DateTime).)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view to the next day. (Overrides ScheduleView..::.IncrementView()()().)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range. (Inherited from ScheduleView.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ScheduleView.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DayView Class


CancelAdd Method

[image]

Mindscape Silverlight Elements
DayView..::.CancelAdd Method
DayView Class See Also Send Feedback
Cancels tha addition of the specified item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void CancelAdd(
    ScheduleItem item
)
Visual Basic (Declaration)
Protected Overrides Sub CancelAdd ( _
    item As ScheduleItem _
)
Visual C++
protected:
virtual void CancelAdd(
    ScheduleItem^ item
) override

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to cancel.

See Also

DayView Class


CreateScheduleItemForAdd Method

[image]

Mindscape Silverlight Elements
DayView..::.CreateScheduleItemForAdd Method
DayView Class See Also Send Feedback
Adds a new schedule item at the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override ScheduleItem CreateScheduleItemForAdd()
Visual Basic (Declaration)
Protected Overrides Function CreateScheduleItemForAdd As ScheduleItem
Visual C++
protected:
virtual ScheduleItem^ CreateScheduleItemForAdd() override

Return Value

The new item.

See Also

DayView Class


DecrementView Method

[image]

Mindscape Silverlight Elements
DayView..::.DecrementView Method
DayView Class See Also Send Feedback
Moves the view to the previous day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void DecrementView()
Visual Basic (Declaration)
Public Overrides Sub DecrementView
Visual C++
public:
virtual void DecrementView() override

See Also

DayView Class


GetStartDateContaining Method

[image]

Mindscape Silverlight Elements
DayView..::.GetStartDateContaining Method
DayView Class See Also Send Feedback
Gets a suitable start date for the control to display the requested date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime GetStartDateContaining(
    DateTime date
)
Visual Basic (Declaration)
Protected Overrides Function GetStartDateContaining ( _
    date As DateTime _
) As DateTime
Visual C++
protected:
virtual DateTime GetStartDateContaining(
    DateTime date
) override

Parameters

date
Type: System..::.DateTime
The date to be displayed.

Return Value

A start date for the view that will cause this date to be displayed.

See Also

DayView Class


IncrementView Method

[image]

Mindscape Silverlight Elements
DayView..::.IncrementView Method
DayView Class See Also Send Feedback
Moves the view to the next day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void IncrementView()
Visual Basic (Declaration)
Public Overrides Sub IncrementView
Visual C++
public:
virtual void IncrementView() override

See Also

DayView Class


OnApplyTemplate Method

[image]

Mindscape Silverlight Elements
DayView..::.OnApplyTemplate Method
DayView Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

DayView Class


DayView Properties

[image] [image]

Mindscape Silverlight Elements
DayView Properties
DayView Class See Also Send Feedback

The DayView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection. (Inherited from ScheduleView.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title. (Inherited from ScheduleView.)
DateRangeDisplayMode | Gets how to format dates in the view title. (Overrides ScheduleView..::.DateRangeDisplayMode.)
Day | Gets the day being displayed.
Days | Gets a list containing the day being represented.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view. (Overrides ScheduleView..::.EndDate.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled. (Inherited from ScheduleView.)
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled. (Inherited from ScheduleView.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week). (Inherited from ScheduleView.)
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view. (Inherited from ScheduleView.)
Now | Gets the current date and time. (Inherited from ScheduleView.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week). (Inherited from ScheduleView.)
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view. (Inherited from ScheduleView.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed. (Inherited from ScheduleView.)
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item). (Inherited from ScheduleView.)
StartDate | Gets or sets the start date of the view. (Overrides ScheduleView..::.StartDate.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day. (Inherited from ScheduleView.)
TimeSlots | Gets the collection of timeslots to be displayed in the view.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DayView Class


DateRangeDisplayMode Property

[image]

Mindscape Silverlight Elements
DayView..::.DateRangeDisplayMode Property
DayView Class See Also Send Feedback
Gets how to format dates in the view title.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateDisplayMode DateRangeDisplayMode { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DateRangeDisplayMode As DateDisplayMode
Visual C++
protected:
virtual property DateDisplayMode DateRangeDisplayMode {
    DateDisplayMode get () override;
}

See Also

DayView Class


Day Property

[image]

Mindscape Silverlight Elements
DayView..::.Day Property
DayView Class See Also Send Feedback
Gets the day being displayed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayModel Day { get; private set; }
Visual Basic (Declaration)
Public Property Day As DayModel
Visual C++
public:
property DayModel^ Day {
    DayModel^ get ();
    void set (DayModel^ value);
}

See Also

DayView Class


Days Property

[image]

Mindscape Silverlight Elements
DayView..::.Days Property
DayView Class See Also Send Feedback
Gets a list containing the day being represented.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IList<DayModel> Days { get; }
Visual Basic (Declaration)
Public ReadOnly Property Days As IList(Of DayModel)
Visual C++
public:
property IList<DayModel^>^ Days {
    IList<DayModel^>^ get ();
}

Remarks

This member is used for binding.

See Also

DayView Class


EndDate Property

[image]

Mindscape Silverlight Elements
DayView..::.EndDate Property
DayView Class See Also Send Feedback
Gets the end date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime EndDate { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property EndDate As DateTime
Visual C++
protected:
virtual property DateTime EndDate {
    DateTime get () override;
}

See Also

DayView Class


StartDate Property

[image]

Mindscape Silverlight Elements
DayView..::.StartDate Property
DayView Class See Also Send Feedback
Gets or sets the start date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Overrides Property StartDate As DateTime
Visual C++
public:
virtual property DateTime StartDate {
    DateTime get () override;
    void set (DateTime value) override;
}

See Also

DayView Class


TimeSlots Property

[image]

Mindscape Silverlight Elements
DayView..::.TimeSlots Property
DayView Class See Also Send Feedback
Gets the collection of timeslots to be displayed in the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<TimeSlot> TimeSlots { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeSlots As ReadOnlyCollection(Of TimeSlot)
Visual C++
public:
property ReadOnlyCollection<TimeSlot^>^ TimeSlots {
    ReadOnlyCollection<TimeSlot^>^ get ();
}

See Also

DayView Class


DayView Events

[image] [image]

Mindscape Silverlight Elements
DayView Events
DayView Class See Also Send Feedback

The DayView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes. (Inherited from ScheduleView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DayView Class


DimensionConverter Class

[image]

Mindscape Silverlight Elements
DimensionConverter Class
Members See Also Send Feedback
Converts a dimension to an adjusted value.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DimensionConverter : IValueConverter
Visual Basic (Declaration)
Public Class DimensionConverter _
    Implements IValueConverter
Visual C++
public ref class DimensionConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.DimensionConverter

See Also

DimensionConverter Members


DimensionConverter Members

[image] [image]

Mindscape Silverlight Elements
DimensionConverter Members
DimensionConverter Class Constructors Methods Properties See Also Send Feedback

The DimensionConverter type exposes the following members.

Constructors

Name | Description
DimensionConverter | Initializes a new instance of the DimensionConverter class

Methods

Name | Description
Convert | Converts a dimension from a binding source for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Add | The amount to be added to the input dimension.

See Also

DimensionConverter Class


DimensionConverter Constructor

[image]

Mindscape Silverlight Elements
DimensionConverter Constructor
DimensionConverter Class See Also Send Feedback
Initializes a new instance of the DimensionConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DimensionConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DimensionConverter()

See Also

DimensionConverter Class


DimensionConverter Methods

[image] [image]

Mindscape Silverlight Elements
DimensionConverter Methods
DimensionConverter Class See Also Send Feedback

The DimensionConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a dimension from a binding source for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
DimensionConverter..::.Convert Method
DimensionConverter Class See Also Send Feedback
Converts a dimension from a binding source for use by a binding target.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DimensionConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
DimensionConverter..::.ConvertBack Method
DimensionConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DimensionConverter Class


DimensionConverter Properties

[image] [image]

Mindscape Silverlight Elements
DimensionConverter Properties
DimensionConverter Class See Also Send Feedback

The DimensionConverter type exposes the following members.

Properties

Name | Description
Add | The amount to be added to the input dimension.

See Also

DimensionConverter Class


Add Property

[image]

Mindscape Silverlight Elements
DimensionConverter..::.Add Property
DimensionConverter Class See Also Send Feedback
The amount to be added to the input dimension.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Add { get; set; }
Visual Basic (Declaration)
Public Property Add As Double
Visual C++
public:
property double Add {
    double get ();
    void set (double value);
}

See Also

DimensionConverter Class


EditableTextBlock Class

[image]

Mindscape Silverlight Elements
EditableTextBlock Class
Members See Also Send Feedback
Represents a text area that is read-only normally, but can be clicked to enable editing.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class EditableTextBlock : TextBox
Visual Basic (Declaration)
Public Class EditableTextBlock _
    Inherits TextBox
Visual C++
public ref class EditableTextBlock : public TextBox

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.TextBox
Mindscape.SilverlightElements..::.EditableTextBlock

See Also

EditableTextBlock Members


EditableTextBlock Members

[image] [image]

Mindscape Silverlight Elements
EditableTextBlock Members
EditableTextBlock Class Constructors Methods Fields Properties Events See Also Send Feedback

The EditableTextBlock type exposes the following members.

Constructors

Name | Description
EditableTextBlock | Initializes a new instance of the EditableTextBlock class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from TextBox.)
OnGotFocus | (Inherited from TextBox.)
OnKeyDown | Called by the framework when the user presses a key. (Overrides TextBoxOnKeyDown(KeyEventArgs).)
OnKeyUp | (Inherited from TextBox.)
OnLostFocus | Called by the framework when the control loses focus. (Overrides TextBoxOnLostFocus(RoutedEventArgs).)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from TextBox.)
OnMouseLeave | (Inherited from TextBox.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides TextBoxOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides TextBoxOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | (Inherited from TextBox.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
Select | (Inherited from TextBox.)
SelectAll | (Inherited from TextBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsInEditModeProperty | Identifies the IsInEditMode property.

Properties

Name | Description
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CaretBrush | (Inherited from TextBox.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontSource | (Inherited from TextBox.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | (Inherited from TextBox.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsInEditMode | Gets or sets whether the EditableTextBlock is in edit mode. This is a dependency property.
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedText | (Inherited from TextBox.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
SelectionLength | (Inherited from TextBox.)
SelectionStart | (Inherited from TextBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextWrapping | (Inherited from TextBox.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | (Inherited from TextBox.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | (Inherited from TextBox.)
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | (Inherited from TextBox.)

See Also

EditableTextBlock Class


EditableTextBlock Constructor

[image]

Mindscape Silverlight Elements
EditableTextBlock Constructor
EditableTextBlock Class See Also Send Feedback
Initializes a new instance of the EditableTextBlock class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EditableTextBlock()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EditableTextBlock()

See Also

EditableTextBlock Class


EditableTextBlock Fields

[image] [image]

Mindscape Silverlight Elements
EditableTextBlock Fields
EditableTextBlock Class See Also Send Feedback

The EditableTextBlock type exposes the following members.

Fields

Name | Description
IsInEditModeProperty | Identifies the IsInEditMode property.

See Also

EditableTextBlock Class


IsInEditModeProperty Field

[image]

Mindscape Silverlight Elements
EditableTextBlock..::.IsInEditModeProperty Field
EditableTextBlock Class See Also Send Feedback
Identifies the IsInEditMode property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsInEditModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsInEditModeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsInEditModeProperty

See Also

EditableTextBlock Class


EditableTextBlock Methods

[image] [image]

Mindscape Silverlight Elements
EditableTextBlock Methods
EditableTextBlock Class See Also Send Feedback

The EditableTextBlock type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from TextBox.)
OnGotFocus | (Inherited from TextBox.)
OnKeyDown | Called by the framework when the user presses a key. (Overrides TextBoxOnKeyDown(KeyEventArgs).)
OnKeyUp | (Inherited from TextBox.)
OnLostFocus | Called by the framework when the control loses focus. (Overrides TextBoxOnLostFocus(RoutedEventArgs).)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from TextBox.)
OnMouseLeave | (Inherited from TextBox.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides TextBoxOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides TextBoxOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | (Inherited from TextBox.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
Select | (Inherited from TextBox.)
SelectAll | (Inherited from TextBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

EditableTextBlock Class


OnKeyDown Method

[image]

Mindscape Silverlight Elements
EditableTextBlock..::.OnKeyDown Method
EditableTextBlock Class See Also Send Feedback
Called by the framework when the user presses a key.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.KeyEventArgs
The key event data.

See Also

EditableTextBlock Class


OnLostFocus Method

[image]

Mindscape Silverlight Elements
EditableTextBlock..::.OnLostFocus Method
EditableTextBlock Class See Also Send Feedback
Called by the framework when the control loses focus.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnLostFocus(
    RoutedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLostFocus ( _
    e As RoutedEventArgs _
)
Visual C++
protected:
virtual void OnLostFocus(
    RoutedEventArgs^ e
) override

Parameters

e
Type: System.Windows..::.RoutedEventArgs
The event data.

See Also

EditableTextBlock Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
EditableTextBlock..::.OnMouseLeftButtonDown Method
EditableTextBlock Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

EditableTextBlock Class


OnMouseLeftButtonUp Method

[image]

Mindscape Silverlight Elements
EditableTextBlock..::.OnMouseLeftButtonUp Method
EditableTextBlock Class See Also Send Feedback
Called by the framework when the user releases the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

EditableTextBlock Class


EditableTextBlock Properties

[image] [image]

Mindscape Silverlight Elements
EditableTextBlock Properties
EditableTextBlock Class See Also Send Feedback

The EditableTextBlock type exposes the following members.

Properties

Name | Description
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
CaretBrush | (Inherited from TextBox.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontSource | (Inherited from TextBox.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | (Inherited from TextBox.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsInEditMode | Gets or sets whether the EditableTextBlock is in edit mode. This is a dependency property.
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedText | (Inherited from TextBox.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
SelectionLength | (Inherited from TextBox.)
SelectionStart | (Inherited from TextBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextWrapping | (Inherited from TextBox.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | (Inherited from TextBox.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

EditableTextBlock Class


IsInEditMode Property

[image]

Mindscape Silverlight Elements
EditableTextBlock..::.IsInEditMode Property
EditableTextBlock Class See Also Send Feedback
Gets or sets whether the EditableTextBlock is in edit mode. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInEditMode { get; set; }
Visual Basic (Declaration)
Public Property IsInEditMode As Boolean
Visual C++
public:
property bool IsInEditMode {
    bool get ();
    void set (bool value);
}

Remarks

Dependency Property Information
Identifier field | IsInEditModeProperty
Metadata properties set to true | None

See Also

EditableTextBlock Class


EditableTextBlock Events

[image] [image]

Mindscape Silverlight Elements
EditableTextBlock Events
EditableTextBlock Class See Also Send Feedback

The EditableTextBlock type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | (Inherited from TextBox.)
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | (Inherited from TextBox.)

See Also

EditableTextBlock Class


ElementViewStatus Enumeration

[image]

Mindscape Silverlight Elements
ElementViewStatus Enumeration
See Also Send Feedback
Provides status information for use in rendering a MonthViewDayElement.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ElementViewStatus
Visual Basic (Declaration)
Public Enumeration ElementViewStatus
Visual C++
public enum class ElementViewStatus

Members

Member name | Description
Normal | The element is not in any of the other states.
Selected | The element is selected.
MouseOver | The mouse is over the element.
Padding | The element represents a day which is not part of the month being displayed.
MouseOverPadding | The mouse is over the element which also represents a day which is not part of the month being displayed.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


ElementViewStatusToBrushConverter Class

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter Class
Members See Also Send Feedback
Selects a brush according to an ElementViewStatus.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ElementViewStatusToBrushConverter : IValueConverter
Visual Basic (Declaration)
Public Class ElementViewStatusToBrushConverter _
    Implements IValueConverter
Visual C++
public ref class ElementViewStatusToBrushConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ElementViewStatusToBrushConverter

See Also

ElementViewStatusToBrushConverter Members


ElementViewStatusToBrushConverter Members

[image] [image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter Members
ElementViewStatusToBrushConverter Class Constructors Methods Properties See Also Send Feedback

The ElementViewStatusToBrushConverter type exposes the following members.

Constructors

Name | Description
ElementViewStatusToBrushConverter | Initializes a new instance of the ElementViewStatusToBrushConverter class

Methods

Name | Description
Convert | Selects a brush according to the input ElementViewStatus.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MouseOverBrush | The brush to use if the ElementViewStatus is MouseOver.
MouseOverPaddingBrush | The brush to use if the ElementViewStatus is MouseOverPadding.
NormalBrush | The brush to use if the ElementViewStatus is Normal.
PaddingBrush | The brush to use if the ElementViewStatus is Padding.
SelectedBrush | The brush to use if the ElementViewStatus is Selected.

See Also

ElementViewStatusToBrushConverter Class


ElementViewStatusToBrushConverter Constructor

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter Constructor
ElementViewStatusToBrushConverter Class See Also Send Feedback
Initializes a new instance of the ElementViewStatusToBrushConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ElementViewStatusToBrushConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementViewStatusToBrushConverter()

See Also

ElementViewStatusToBrushConverter Class


ElementViewStatusToBrushConverter Methods

[image] [image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter Methods
ElementViewStatusToBrushConverter Class See Also Send Feedback

The ElementViewStatusToBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Selects a brush according to the input ElementViewStatus.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementViewStatusToBrushConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter..::.Convert Method
ElementViewStatusToBrushConverter Class See Also Send Feedback
Selects a brush according to the input ElementViewStatus.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The ElementViewStatus value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The selected brush.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ElementViewStatusToBrushConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter..::.ConvertBack Method
ElementViewStatusToBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ElementViewStatusToBrushConverter Class


ElementViewStatusToBrushConverter Properties

[image] [image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter Properties
ElementViewStatusToBrushConverter Class See Also Send Feedback

The ElementViewStatusToBrushConverter type exposes the following members.

Properties

Name | Description
MouseOverBrush | The brush to use if the ElementViewStatus is MouseOver.
MouseOverPaddingBrush | The brush to use if the ElementViewStatus is MouseOverPadding.
NormalBrush | The brush to use if the ElementViewStatus is Normal.
PaddingBrush | The brush to use if the ElementViewStatus is Padding.
SelectedBrush | The brush to use if the ElementViewStatus is Selected.

See Also

ElementViewStatusToBrushConverter Class


MouseOverBrush Property

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter..::.MouseOverBrush Property
ElementViewStatusToBrushConverter Class See Also Send Feedback
The brush to use if the ElementViewStatus is MouseOver.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush MouseOverBrush { get; set; }
Visual Basic (Declaration)
Public Property MouseOverBrush As Brush
Visual C++
public:
property Brush^ MouseOverBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ElementViewStatusToBrushConverter Class


MouseOverPaddingBrush Property

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter..::.MouseOverPaddingBrush Property
ElementViewStatusToBrushConverter Class See Also Send Feedback
The brush to use if the ElementViewStatus is MouseOverPadding.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush MouseOverPaddingBrush { get; set; }
Visual Basic (Declaration)
Public Property MouseOverPaddingBrush As Brush
Visual C++
public:
property Brush^ MouseOverPaddingBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ElementViewStatusToBrushConverter Class


NormalBrush Property

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter..::.NormalBrush Property
ElementViewStatusToBrushConverter Class See Also Send Feedback
The brush to use if the ElementViewStatus is Normal.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush NormalBrush { get; set; }
Visual Basic (Declaration)
Public Property NormalBrush As Brush
Visual C++
public:
property Brush^ NormalBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ElementViewStatusToBrushConverter Class


PaddingBrush Property

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter..::.PaddingBrush Property
ElementViewStatusToBrushConverter Class See Also Send Feedback
The brush to use if the ElementViewStatus is Padding.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush PaddingBrush { get; set; }
Visual Basic (Declaration)
Public Property PaddingBrush As Brush
Visual C++
public:
property Brush^ PaddingBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ElementViewStatusToBrushConverter Class


SelectedBrush Property

[image]

Mindscape Silverlight Elements
ElementViewStatusToBrushConverter..::.SelectedBrush Property
ElementViewStatusToBrushConverter Class See Also Send Feedback
The brush to use if the ElementViewStatus is Selected.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush SelectedBrush { get; set; }
Visual Basic (Declaration)
Public Property SelectedBrush As Brush
Visual C++
public:
property Brush^ SelectedBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ElementViewStatusToBrushConverter Class


EveryNDaysRecurrencePattern Class

[image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem at a regular daily interval.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class EveryNDaysRecurrencePattern : RecurrencePattern
Visual Basic (Declaration)
Public Class EveryNDaysRecurrencePattern _
    Inherits RecurrencePattern
Visual C++
public ref class EveryNDaysRecurrencePattern : public RecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.EveryNDaysRecurrencePattern

See Also

EveryNDaysRecurrencePattern Members


EveryNDaysRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern Members
EveryNDaysRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The EveryNDaysRecurrencePattern type exposes the following members.

Constructors

Name | Description
EveryNDaysRecurrencePattern | Initializes a new instance of the EveryNDaysRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DailyInterval | Gets the number of days between occurrences.

See Also

EveryNDaysRecurrencePattern Class


EveryNDaysRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern Constructor
EveryNDaysRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the EveryNDaysRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EveryNDaysRecurrencePattern(
    int dailyInterval
)
Visual Basic (Declaration)
Public Sub New ( _
    dailyInterval As Integer _
)
Visual C++
public:
EveryNDaysRecurrencePattern(
    int dailyInterval
)

Parameters

dailyInterval
Type: System..::.Int32
The number of days between occurrences.

See Also

EveryNDaysRecurrencePattern Class


EveryNDaysRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern Methods
EveryNDaysRecurrencePattern Class See Also Send Feedback

The EveryNDaysRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EveryNDaysRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern..::.Includes Method
EveryNDaysRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides RecurrencePattern..::.Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)

See Also

EveryNDaysRecurrencePattern Class
EveryNDaysRecurrencePattern Members


Includes Method (DateTime, DateTime, Boolean, Nullable(Int32))

[image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern..::.Includes Method (DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>))
EveryNDaysRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

EveryNDaysRecurrencePattern Class
Includes Overload


EveryNDaysRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern Properties
EveryNDaysRecurrencePattern Class See Also Send Feedback

The EveryNDaysRecurrencePattern type exposes the following members.

Properties

Name | Description
DailyInterval | Gets the number of days between occurrences.

See Also

EveryNDaysRecurrencePattern Class


DailyInterval Property

[image]

Mindscape Silverlight Elements
EveryNDaysRecurrencePattern..::.DailyInterval Property
EveryNDaysRecurrencePattern Class See Also Send Feedback
Gets the number of days between occurrences.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int DailyInterval { get; }
Visual Basic (Declaration)
Public ReadOnly Property DailyInterval As Integer
Visual C++
public:
property int DailyInterval {
    int get ();
}

See Also

EveryNDaysRecurrencePattern Class


EveryWeekdayRecurrencePattern Class

[image]

Mindscape Silverlight Elements
EveryWeekdayRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on every weekday (Monday to Friday).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class EveryWeekdayRecurrencePattern : RecurrencePattern
Visual Basic (Declaration)
Public Class EveryWeekdayRecurrencePattern _
    Inherits RecurrencePattern
Visual C++
public ref class EveryWeekdayRecurrencePattern : public RecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.EveryWeekdayRecurrencePattern

See Also

EveryWeekdayRecurrencePattern Members


EveryWeekdayRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
EveryWeekdayRecurrencePattern Members
EveryWeekdayRecurrencePattern Class Constructors Methods See Also Send Feedback

The EveryWeekdayRecurrencePattern type exposes the following members.

Constructors

Name | Description
EveryWeekdayRecurrencePattern | Initializes a new instance of the EveryWeekdayRecurrencePattern class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EveryWeekdayRecurrencePattern Class


EveryWeekdayRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
EveryWeekdayRecurrencePattern Constructor
EveryWeekdayRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the EveryWeekdayRecurrencePattern class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public EveryWeekdayRecurrencePattern()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EveryWeekdayRecurrencePattern()

See Also

EveryWeekdayRecurrencePattern Class


EveryWeekdayRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
EveryWeekdayRecurrencePattern Methods
EveryWeekdayRecurrencePattern Class See Also Send Feedback

The EveryWeekdayRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EveryWeekdayRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
EveryWeekdayRecurrencePattern..::.Includes Method
EveryWeekdayRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides RecurrencePattern..::.Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)

See Also

EveryWeekdayRecurrencePattern Class
EveryWeekdayRecurrencePattern Members


Includes Method (DateTime, DateTime, Boolean, Nullable(Int32))

[image]

Mindscape Silverlight Elements
EveryWeekdayRecurrencePattern..::.Includes Method (DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>))
EveryWeekdayRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

EveryWeekdayRecurrencePattern Class
Includes Overload


ExpandableCellTemplateInfo Class

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo Class
Members See Also Send Feedback
Contains templating information for an expandable cell in a MulticolumnTreeView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ExpandableCellTemplateInfo
Visual Basic (Declaration)
Public Class ExpandableCellTemplateInfo
Visual C++
public ref class ExpandableCellTemplateInfo

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ExpandableCellTemplateInfo

See Also

ExpandableCellTemplateInfo Members


ExpandableCellTemplateInfo Members

[image] [image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo Members
ExpandableCellTemplateInfo Class Methods Properties Events See Also Send Feedback

The ExpandableCellTemplateInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnIsExpandedChanged | Raises the IsExpandedChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Content | Gets the content of the cell.
HasItems | Gets whether the cell has child items.
IsExpanded | Gets or sets whether the cell is expanded.
Level | Gets the level (depth) of the cell in the tree hierarchy.
OriginalCellTemplate | Gets the CellTemplate originally specified on the GridViewColumn.
OriginalCellTemplateSelector | Gets the CellTemplateSelector originally specified on the GridViewColumn.
OriginalDisplayMemberBinding | Gets the DisplayMemberBinding originally specified on the GridViewColumn.

Events

Name | Description
IsExpandedChanged | Occurs when the cell is expanded or collapsed.

See Also

ExpandableCellTemplateInfo Class


ExpandableCellTemplateInfo Methods

[image] [image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo Methods
ExpandableCellTemplateInfo Class See Also Send Feedback

The ExpandableCellTemplateInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnIsExpandedChanged | Raises the IsExpandedChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpandableCellTemplateInfo Class


OnIsExpandedChanged Method

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.OnIsExpandedChanged Method
ExpandableCellTemplateInfo Class See Also Send Feedback
Raises the IsExpandedChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnIsExpandedChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnIsExpandedChanged
Visual C++
protected:
virtual void OnIsExpandedChanged()

See Also

ExpandableCellTemplateInfo Class


ExpandableCellTemplateInfo Properties

[image] [image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo Properties
ExpandableCellTemplateInfo Class See Also Send Feedback

The ExpandableCellTemplateInfo type exposes the following members.

Properties

Name | Description
Content | Gets the content of the cell.
HasItems | Gets whether the cell has child items.
IsExpanded | Gets or sets whether the cell is expanded.
Level | Gets the level (depth) of the cell in the tree hierarchy.
OriginalCellTemplate | Gets the CellTemplate originally specified on the GridViewColumn.
OriginalCellTemplateSelector | Gets the CellTemplateSelector originally specified on the GridViewColumn.
OriginalDisplayMemberBinding | Gets the DisplayMemberBinding originally specified on the GridViewColumn.

See Also

ExpandableCellTemplateInfo Class


Content Property

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.Content Property
ExpandableCellTemplateInfo Class See Also Send Feedback
Gets the content of the cell.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Content { get; internal set; }
Visual Basic (Declaration)
Public Property Content As Object
Visual C++
public:
property Object^ Content {
    Object^ get ();
    void set (Object^ value);
}

See Also

ExpandableCellTemplateInfo Class


HasItems Property

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.HasItems Property
ExpandableCellTemplateInfo Class See Also Send Feedback
Gets whether the cell has child items.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HasItems { get; internal set; }
Visual Basic (Declaration)
Public Property HasItems As Boolean
Visual C++
public:
property bool HasItems {
    bool get ();
    void set (bool value);
}

See Also

ExpandableCellTemplateInfo Class


IsExpanded Property

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.IsExpanded Property
ExpandableCellTemplateInfo Class See Also Send Feedback
Gets or sets whether the cell is expanded.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

ExpandableCellTemplateInfo Class


Level Property

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.Level Property
ExpandableCellTemplateInfo Class See Also Send Feedback
Gets the level (depth) of the cell in the tree hierarchy.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Level { get; internal set; }
Visual Basic (Declaration)
Public Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
    void set (int value);
}

See Also

ExpandableCellTemplateInfo Class


OriginalCellTemplate Property

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.OriginalCellTemplate Property
ExpandableCellTemplateInfo Class See Also Send Feedback
Gets the CellTemplate originally specified on the GridViewColumn.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate OriginalCellTemplate { get; internal set; }
Visual Basic (Declaration)
Public Property OriginalCellTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ OriginalCellTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

ExpandableCellTemplateInfo Class


OriginalCellTemplateSelector Property

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.OriginalCellTemplateSelector Property
ExpandableCellTemplateInfo Class See Also Send Feedback
Gets the CellTemplateSelector originally specified on the GridViewColumn.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplateSelector OriginalCellTemplateSelector { get; internal set; }
Visual Basic (Declaration)
Public Property OriginalCellTemplateSelector As DataTemplateSelector
Visual C++
public:
property DataTemplateSelector^ OriginalCellTemplateSelector {
    DataTemplateSelector^ get ();
    void set (DataTemplateSelector^ value);
}

See Also

ExpandableCellTemplateInfo Class


OriginalDisplayMemberBinding Property

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.OriginalDisplayMemberBinding Property
ExpandableCellTemplateInfo Class See Also Send Feedback
Gets the DisplayMemberBinding originally specified on the GridViewColumn.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding OriginalDisplayMemberBinding { get; internal set; }
Visual Basic (Declaration)
Public Property OriginalDisplayMemberBinding As Binding
Visual C++
public:
property Binding^ OriginalDisplayMemberBinding {
    Binding^ get ();
    void set (Binding^ value);
}

See Also

ExpandableCellTemplateInfo Class


ExpandableCellTemplateInfo Events

[image] [image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo Events
ExpandableCellTemplateInfo Class See Also Send Feedback

The ExpandableCellTemplateInfo type exposes the following members.

Events

Name | Description
IsExpandedChanged | Occurs when the cell is expanded or collapsed.

See Also

ExpandableCellTemplateInfo Class


IsExpandedChanged Event

[image]

Mindscape Silverlight Elements
ExpandableCellTemplateInfo..::.IsExpandedChanged Event
ExpandableCellTemplateInfo Class See Also Send Feedback
Occurs when the cell is expanded or collapsed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler IsExpandedChanged
Visual Basic (Declaration)
Public Event IsExpandedChanged As EventHandler
Visual C++
public:
 event EventHandler^ IsExpandedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ExpandableCellTemplateInfo Class


GridViewColumn Class

[image]

Mindscape Silverlight Elements
GridViewColumn Class
Members See Also Send Feedback
Represents a column definition in a ListView or MulticolumnTreeView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GridViewColumn : DependencyObject,
    INotifyPropertyChanged
Visual Basic (Declaration)
Public Class GridViewColumn _
    Inherits DependencyObject _
    Implements INotifyPropertyChanged
Visual C++
public ref class GridViewColumn : public DependencyObject,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
Mindscape.SilverlightElements..::.GridViewColumn

See Also

GridViewColumn Members


GridViewColumn Members

[image] [image]

Mindscape Silverlight Elements
GridViewColumn Members
GridViewColumn Class Constructors Methods Fields Properties Events See Also Send Feedback

The GridViewColumn type exposes the following members.

Constructors

Name | Description
GridViewColumn | Initializes a new instance of the GridViewColumn class

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CellTemplateProperty | Identifies the CellTemplate property.
CellTemplateSelectorProperty | Identifies the CellTemplateSelector property.
DisplayMemberBindingProperty | Identifies the DisplayMemberBinding property.
HeaderContainerStyleProperty | Identifies the HeaderContainerStyle property.
HeaderProperty | Identifies the Header property.
HeaderTemplateProperty | Identifies the HeaderTemplate property.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector property.
WidthProperty | Identifies the Width property.

Properties

Name | Description
CellTemplate | Gets or sets the template to use to display the contents of a column cell. This is a dependency property.
CellTemplateSelector | Gets or sets a DataTemplateSelector that determines the template to use to display cells in a column. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberBinding | Gets or sets the data item to bind to for this column. This is a dependency property.
Header | Gets or sets the column header. This is a dependency property.
HeaderContainerStyle | Gets or sets the Style applied to header UI elements. This is a dependency property.
HeaderTemplate | Gets or sets the DataTemplate applied to column header content. This is a dependency property.
HeaderTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for column header content. This is a dependency property.
Width | Gets or sets the column width. This is a dependency property.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

GridViewColumn Class


GridViewColumn Constructor

[image]

Mindscape Silverlight Elements
GridViewColumn Constructor
GridViewColumn Class See Also Send Feedback
Initializes a new instance of the GridViewColumn class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumn()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewColumn()

See Also

GridViewColumn Class


GridViewColumn Fields

[image] [image]

Mindscape Silverlight Elements
GridViewColumn Fields
GridViewColumn Class See Also Send Feedback

The GridViewColumn type exposes the following members.

Fields

Name | Description
CellTemplateProperty | Identifies the CellTemplate property.
CellTemplateSelectorProperty | Identifies the CellTemplateSelector property.
DisplayMemberBindingProperty | Identifies the DisplayMemberBinding property.
HeaderContainerStyleProperty | Identifies the HeaderContainerStyle property.
HeaderProperty | Identifies the Header property.
HeaderTemplateProperty | Identifies the HeaderTemplate property.
HeaderTemplateSelectorProperty | Identifies the HeaderTemplateSelector property.
WidthProperty | Identifies the Width property.

See Also

GridViewColumn Class


CellTemplateProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.CellTemplateProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the CellTemplate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CellTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly CellTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CellTemplateProperty

See Also

GridViewColumn Class


CellTemplateSelectorProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.CellTemplateSelectorProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the CellTemplateSelector property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CellTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly CellTemplateSelectorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CellTemplateSelectorProperty

See Also

GridViewColumn Class


DisplayMemberBindingProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.DisplayMemberBindingProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the DisplayMemberBinding property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DisplayMemberBindingProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisplayMemberBindingProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DisplayMemberBindingProperty

See Also

GridViewColumn Class


HeaderContainerStyleProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.HeaderContainerStyleProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the HeaderContainerStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HeaderContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderContainerStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HeaderContainerStyleProperty

See Also

GridViewColumn Class


HeaderProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.HeaderProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the Header property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HeaderProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HeaderProperty

See Also

GridViewColumn Class


HeaderTemplateProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.HeaderTemplateProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the HeaderTemplate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HeaderTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HeaderTemplateProperty

See Also

GridViewColumn Class


HeaderTemplateSelectorProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.HeaderTemplateSelectorProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the HeaderTemplateSelector property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty HeaderTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderTemplateSelectorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ HeaderTemplateSelectorProperty

See Also

GridViewColumn Class


WidthProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumn..::.WidthProperty Field
GridViewColumn Class See Also Send Feedback
Identifies the Width property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty WidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly WidthProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ WidthProperty

See Also

GridViewColumn Class


GridViewColumn Methods

[image] [image]

Mindscape Silverlight Elements
GridViewColumn Methods
GridViewColumn Class See Also Send Feedback

The GridViewColumn type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridViewColumn Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
GridViewColumn..::.OnPropertyChanged Method
GridViewColumn Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Overridable Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

GridViewColumn Class


GridViewColumn Properties

[image] [image]

Mindscape Silverlight Elements
GridViewColumn Properties
GridViewColumn Class See Also Send Feedback

The GridViewColumn type exposes the following members.

Properties

Name | Description
CellTemplate | Gets or sets the template to use to display the contents of a column cell. This is a dependency property.
CellTemplateSelector | Gets or sets a DataTemplateSelector that determines the template to use to display cells in a column. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberBinding | Gets or sets the data item to bind to for this column. This is a dependency property.
Header | Gets or sets the column header. This is a dependency property.
HeaderContainerStyle | Gets or sets the Style applied to header UI elements. This is a dependency property.
HeaderTemplate | Gets or sets the DataTemplate applied to column header content. This is a dependency property.
HeaderTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for column header content. This is a dependency property.
Width | Gets or sets the column width. This is a dependency property.

See Also

GridViewColumn Class


CellTemplate Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.CellTemplate Property
GridViewColumn Class See Also Send Feedback
Gets or sets the template to use to display the contents of a column cell. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate CellTemplate { get; set; }
Visual Basic (Declaration)
Public Property CellTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ CellTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Remarks

CellTemplate takes precedence over CellTemplateSelector, but defers to DisplayMemberBinding, if more than one is specified.

Dependency Property Information
Identifier field | CellTemplateProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


CellTemplateSelector Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.CellTemplateSelector Property
GridViewColumn Class See Also Send Feedback
Gets or sets a DataTemplateSelector that determines the template to use to display cells in a column. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplateSelector CellTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property CellTemplateSelector As DataTemplateSelector
Visual C++
public:
property DataTemplateSelector^ CellTemplateSelector {
    DataTemplateSelector^ get ();
    void set (DataTemplateSelector^ value);
}

Remarks

DisplayMemberBinding and CellTemplate take precedence over CellTemplateSelector if more than one is specified.

Dependency Property Information
Identifier field | CellTemplateSelectorProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


DisplayMemberBinding Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.DisplayMemberBinding Property
GridViewColumn Class See Also Send Feedback
Gets or sets the data item to bind to for this column. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding DisplayMemberBinding { get; set; }
Visual Basic (Declaration)
Public Property DisplayMemberBinding As Binding
Visual C++
public:
property Binding^ DisplayMemberBinding {
    Binding^ get ();
    void set (Binding^ value);
}

Remarks

DisplayMemberBinding takes precedence over CellTemplate and CellTemplateSelector if more than one is specified.

Dependency Property Information
Identifier field | DisplayMemberBindingProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


Header Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.Header Property
GridViewColumn Class See Also Send Feedback
Gets or sets the column header. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Header { get; set; }
Visual Basic (Declaration)
Public Property Header As Object
Visual C++
public:
property Object^ Header {
    Object^ get ();
    void set (Object^ value);
}

Remarks

Dependency Property Information
Identifier field | HeaderProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


HeaderContainerStyle Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.HeaderContainerStyle Property
GridViewColumn Class See Also Send Feedback
Gets or sets the Style applied to header UI elements. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style HeaderContainerStyle { get; set; }
Visual Basic (Declaration)
Public Property HeaderContainerStyle As Style
Visual C++
public:
property Style^ HeaderContainerStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | HeaderContainerStyleProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


HeaderTemplate Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.HeaderTemplate Property
GridViewColumn Class See Also Send Feedback
Gets or sets the DataTemplate applied to column header content. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate HeaderTemplate { get; set; }
Visual Basic (Declaration)
Public Property HeaderTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ HeaderTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Remarks

Dependency Property Information
Identifier field | HeaderTemplateProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


HeaderTemplateSelector Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.HeaderTemplateSelector Property
GridViewColumn Class See Also Send Feedback
Gets or sets the DataTemplateSelector used to select the template for column header content. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplateSelector HeaderTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property HeaderTemplateSelector As DataTemplateSelector
Visual C++
public:
property DataTemplateSelector^ HeaderTemplateSelector {
    DataTemplateSelector^ get ();
    void set (DataTemplateSelector^ value);
}

Remarks

Dependency Property Information
Identifier field | HeaderTemplateSelectorProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


Width Property

[image]

Mindscape Silverlight Elements
GridViewColumn..::.Width Property
GridViewColumn Class See Also Send Feedback
Gets or sets the column width. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Double
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

Dependency Property Information
Identifier field | WidthProperty
Metadata properties set to true | None

See Also

GridViewColumn Class


GridViewColumn Events

[image] [image]

Mindscape Silverlight Elements
GridViewColumn Events
GridViewColumn Class See Also Send Feedback

The GridViewColumn type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

GridViewColumn Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
GridViewColumn..::.PropertyChanged Event
GridViewColumn Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

Remarks

The PropertyChanged event is not raised for all properties on this class.

See Also

GridViewColumn Class


GridViewColumnCollection Class

[image]

Mindscape Silverlight Elements
GridViewColumnCollection Class
Members See Also Send Feedback
Represents a collection of GridViewColumn objects.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GridViewColumnCollection : ObservableCollection<GridViewColumn>
Visual Basic (Declaration)
Public Class GridViewColumnCollection _
    Inherits ObservableCollection(Of GridViewColumn)
Visual C++
public ref class GridViewColumnCollection : public ObservableCollection<GridViewColumn^>

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( GridViewColumn >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( GridViewColumn >)>)
Mindscape.SilverlightElements..::.GridViewColumnCollection

See Also

GridViewColumnCollection Members


GridViewColumnCollection Members

[image] [image]

Mindscape Silverlight Elements
GridViewColumnCollection Members
GridViewColumnCollection Class Constructors Methods Properties Events See Also Send Feedback

The GridViewColumnCollection type exposes the following members.

Constructors

Name | Description
GridViewColumnCollection | Initializes a new instance of the GridViewColumnCollection class

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( GridViewColumn >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( GridViewColumn >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( GridViewColumn >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)

See Also

GridViewColumnCollection Class


GridViewColumnCollection Constructor

[image]

Mindscape Silverlight Elements
GridViewColumnCollection Constructor
GridViewColumnCollection Class See Also Send Feedback
Initializes a new instance of the GridViewColumnCollection class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewColumnCollection()

See Also

GridViewColumnCollection Class


GridViewColumnCollection Methods

[image] [image]

Mindscape Silverlight Elements
GridViewColumnCollection Methods
GridViewColumnCollection Class See Also Send Feedback

The GridViewColumnCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( GridViewColumn >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( GridViewColumn >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridViewColumnCollection Class


GridViewColumnCollection Properties

[image] [image]

Mindscape Silverlight Elements
GridViewColumnCollection Properties
GridViewColumnCollection Class See Also Send Feedback

The GridViewColumnCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( GridViewColumn >)>).)
Items | Gets a IList<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( GridViewColumn >)>).)

See Also

GridViewColumnCollection Class


GridViewColumnCollection Events

[image] [image]

Mindscape Silverlight Elements
GridViewColumnCollection Events
GridViewColumnCollection Class See Also Send Feedback

The GridViewColumnCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( GridViewColumn >)>).)

See Also

GridViewColumnCollection Class


GridViewColumnHeader Class

[image]

Mindscape Silverlight Elements
GridViewColumnHeader Class
Members See Also Send Feedback
Displays a single column header in a ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GridViewColumnHeader : Button
Visual Basic (Declaration)
Public Class GridViewColumnHeader _
    Inherits Button
Visual C++
public ref class GridViewColumnHeader : public Button

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls..::.Button
Mindscape.SilverlightElements..::.GridViewColumnHeader

See Also

GridViewColumnHeader Members


GridViewColumnHeader Members

[image] [image]

Mindscape Silverlight Elements
GridViewColumnHeader Members
GridViewColumnHeader Class Constructors Methods Fields Properties Events See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Constructors

Name | Description
GridViewColumnHeader | Initializes a new instance of the GridViewColumnHeader class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Button.)
OnClick | (Inherited from Button.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from Button.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnLostMouseCapture | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ButtonBase..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ButtonBase..::.OnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ButtonBase..::.OnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ColumnProperty | Identifies the Column property.
RoleProperty | Identifies the Role property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Column | Gets or sets the GridViewColumn for which this is the header. This is a dependency property.
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Role | Gets or sets the role of the GridViewColumnHeader. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class


GridViewColumnHeader Constructor

[image]

Mindscape Silverlight Elements
GridViewColumnHeader Constructor
GridViewColumnHeader Class See Also Send Feedback
Initializes a new instance of the GridViewColumnHeader class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewColumnHeader()

See Also

GridViewColumnHeader Class


GridViewColumnHeader Fields

[image] [image]

Mindscape Silverlight Elements
GridViewColumnHeader Fields
GridViewColumnHeader Class See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Fields

Name | Description
ColumnProperty | Identifies the Column property.
RoleProperty | Identifies the Role property.

See Also

GridViewColumnHeader Class


ColumnProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumnHeader..::.ColumnProperty Field
GridViewColumnHeader Class See Also Send Feedback
Identifies the Column property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnProperty

See Also

GridViewColumnHeader Class


RoleProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumnHeader..::.RoleProperty Field
GridViewColumnHeader Class See Also Send Feedback
Identifies the Role property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty RoleProperty
Visual Basic (Declaration)
Public Shared ReadOnly RoleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ RoleProperty

See Also

GridViewColumnHeader Class


GridViewColumnHeader Methods

[image] [image]

Mindscape Silverlight Elements
GridViewColumnHeader Methods
GridViewColumnHeader Class See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Button.)
OnClick | (Inherited from Button.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from Button.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnLostMouseCapture | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ButtonBase..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ButtonBase..::.OnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ButtonBase..::.OnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

GridViewColumnHeader Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
GridViewColumnHeader..::.OnMouseLeftButtonDown Method
GridViewColumnHeader Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

GridViewColumnHeader Class


OnMouseLeftButtonUp Method

[image]

Mindscape Silverlight Elements
GridViewColumnHeader..::.OnMouseLeftButtonUp Method
GridViewColumnHeader Class See Also Send Feedback
Called by the framework when the user releases the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

GridViewColumnHeader Class


OnMouseMove Method

[image]

Mindscape Silverlight Elements
GridViewColumnHeader..::.OnMouseMove Method
GridViewColumnHeader Class See Also Send Feedback
Called by the framework when the user moves the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The mouse event data.

See Also

GridViewColumnHeader Class


GridViewColumnHeader Properties

[image] [image]

Mindscape Silverlight Elements
GridViewColumnHeader Properties
GridViewColumnHeader Class See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Column | Gets or sets the GridViewColumn for which this is the header. This is a dependency property.
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Role | Gets or sets the role of the GridViewColumnHeader. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class


Column Property

[image]

Mindscape Silverlight Elements
GridViewColumnHeader..::.Column Property
GridViewColumnHeader Class See Also Send Feedback
Gets or sets the GridViewColumn for which this is the header. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumn Column { get; set; }
Visual Basic (Declaration)
Public Property Column As GridViewColumn
Visual C++
public:
property GridViewColumn^ Column {
    GridViewColumn^ get ();
    void set (GridViewColumn^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnProperty
Metadata properties set to true | None

See Also

GridViewColumnHeader Class


Role Property

[image]

Mindscape Silverlight Elements
GridViewColumnHeader..::.Role Property
GridViewColumnHeader Class See Also Send Feedback
Gets or sets the role of the GridViewColumnHeader. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnHeaderRole Role { get; set; }
Visual Basic (Declaration)
Public Property Role As GridViewColumnHeaderRole
Visual C++
public:
property GridViewColumnHeaderRole Role {
    GridViewColumnHeaderRole get ();
    void set (GridViewColumnHeaderRole value);
}

Remarks

Dependency Property Information
Identifier field | RoleProperty
Metadata properties set to true | None

See Also

GridViewColumnHeader Class


GridViewColumnHeader Events

[image] [image]

Mindscape Silverlight Elements
GridViewColumnHeader Events
GridViewColumnHeader Class See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class


GridViewColumnHeaderRole Enumeration

[image]

Mindscape Silverlight Elements
GridViewColumnHeaderRole Enumeration
See Also Send Feedback
Defines the state or role of a GridViewColumnHeader control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum GridViewColumnHeaderRole
Visual Basic (Declaration)
Public Enumeration GridViewColumnHeaderRole
Visual C++
public enum class GridViewColumnHeaderRole

Members

Member name | Description
Normal | The column header displays above its associated column.
Padding | The column header is the last header in the row of column headers and is used for padding.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


GridViewColumnResizer Class

[image]

Mindscape Silverlight Elements
GridViewColumnResizer Class
Members See Also Send Feedback
Provides a user interface for resizing a GridViewColumn by dragging or double-clicking the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GridViewColumnResizer : Control,
    IDoubleClickObserver
Visual Basic (Declaration)
Public Class GridViewColumnResizer _
    Inherits Control _
    Implements IDoubleClickObserver
Visual C++
public ref class GridViewColumnResizer : public Control,
    IDoubleClickObserver

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.GridViewColumnResizer

See Also

GridViewColumnResizer Members


GridViewColumnResizer Members

[image] [image]

Mindscape Silverlight Elements
GridViewColumnResizer Members
GridViewColumnResizer Class Constructors Methods Fields Properties Events See Also Send Feedback

The GridViewColumnResizer type exposes the following members.

Constructors

Name | Description
GridViewColumnResizer | Initializes a new instance of the GridViewColumnResizer class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ControlOnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ColumnHeaderProperty | Identifies the ColumnHeader property.
ColumnProperty | Identifies the Column property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Column | Gets or sets the GridViewColumn resized by this resizer. This is a dependency property.
ColumnHeader | Gets or sets the GridViewColumnHeader to which the resizer is attached. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

GridViewColumnResizer Class


GridViewColumnResizer Constructor

[image]

Mindscape Silverlight Elements
GridViewColumnResizer Constructor
GridViewColumnResizer Class See Also Send Feedback
Initializes a new instance of the GridViewColumnResizer class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnResizer()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GridViewColumnResizer()

See Also

GridViewColumnResizer Class


GridViewColumnResizer Fields

[image] [image]

Mindscape Silverlight Elements
GridViewColumnResizer Fields
GridViewColumnResizer Class See Also Send Feedback

The GridViewColumnResizer type exposes the following members.

Fields

Name | Description
ColumnHeaderProperty | Identifies the ColumnHeader property.
ColumnProperty | Identifies the Column property.

See Also

GridViewColumnResizer Class


ColumnHeaderProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumnResizer..::.ColumnHeaderProperty Field
GridViewColumnResizer Class See Also Send Feedback
Identifies the ColumnHeader property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderProperty

See Also

GridViewColumnResizer Class


ColumnProperty Field

[image]

Mindscape Silverlight Elements
GridViewColumnResizer..::.ColumnProperty Field
GridViewColumnResizer Class See Also Send Feedback
Identifies the Column property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnProperty

See Also

GridViewColumnResizer Class


GridViewColumnResizer Methods

[image] [image]

Mindscape Silverlight Elements
GridViewColumnResizer Methods
GridViewColumnResizer Class See Also Send Feedback

The GridViewColumnResizer type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ControlOnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

GridViewColumnResizer Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
GridViewColumnResizer..::.OnMouseLeftButtonDown Method
GridViewColumnResizer Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

GridViewColumnResizer Class


OnMouseLeftButtonUp Method

[image]

Mindscape Silverlight Elements
GridViewColumnResizer..::.OnMouseLeftButtonUp Method
GridViewColumnResizer Class See Also Send Feedback
Called by the framework when the user releases the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

GridViewColumnResizer Class


OnMouseMove Method

[image]

Mindscape Silverlight Elements
GridViewColumnResizer..::.OnMouseMove Method
GridViewColumnResizer Class See Also Send Feedback
Called by the framework when the user moves the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The mouse event data.

See Also

GridViewColumnResizer Class


GridViewColumnResizer Properties

[image] [image]

Mindscape Silverlight Elements
GridViewColumnResizer Properties
GridViewColumnResizer Class See Also Send Feedback

The GridViewColumnResizer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Column | Gets or sets the GridViewColumn resized by this resizer. This is a dependency property.
ColumnHeader | Gets or sets the GridViewColumnHeader to which the resizer is attached. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

GridViewColumnResizer Class


Column Property

[image]

Mindscape Silverlight Elements
GridViewColumnResizer..::.Column Property
GridViewColumnResizer Class See Also Send Feedback
Gets or sets the GridViewColumn resized by this resizer. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumn Column { get; set; }
Visual Basic (Declaration)
Public Property Column As GridViewColumn
Visual C++
public:
property GridViewColumn^ Column {
    GridViewColumn^ get ();
    void set (GridViewColumn^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnProperty
Metadata properties set to true | None

See Also

GridViewColumnResizer Class


ColumnHeader Property

[image]

Mindscape Silverlight Elements
GridViewColumnResizer..::.ColumnHeader Property
GridViewColumnResizer Class See Also Send Feedback
Gets or sets the GridViewColumnHeader to which the resizer is attached. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnHeader ColumnHeader { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeader As GridViewColumnHeader
Visual C++
public:
property GridViewColumnHeader^ ColumnHeader {
    GridViewColumnHeader^ get ();
    void set (GridViewColumnHeader^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnHeaderProperty
Metadata properties set to true | None

See Also

GridViewColumnResizer Class


GridViewColumnResizer Events

[image] [image]

Mindscape Silverlight Elements
GridViewColumnResizer Events
GridViewColumnResizer Class See Also Send Feedback

The GridViewColumnResizer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

GridViewColumnResizer Class


HyperlinkDialog Class

[image]

Mindscape Silverlight Elements
HyperlinkDialog Class
Members See Also Send Feedback
Represents a dialog for adding or editing a hyperlink in a RichTextEditor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public sealed class HyperlinkDialog : ChildWindow
Visual Basic (Declaration)
Public NotInheritable Class HyperlinkDialog _
    Inherits ChildWindow
Visual C++
public ref class HyperlinkDialog sealed : public ChildWindow

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
ChildWindow
Mindscape.SilverlightElements..::.HyperlinkDialog

See Also

HyperlinkDialog Members


HyperlinkDialog Members

[image] [image]

Mindscape Silverlight Elements
HyperlinkDialog Members
HyperlinkDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The HyperlinkDialog type exposes the following members.

Constructors

Name | Description
HyperlinkDialog | Initializes a new instance of the HyperlinkDialog class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | (Inherited from ChildWindow.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InitializeComponent | InitializeComponent
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ChildWindow.)
OnClosed | (Inherited from ChildWindow.)
OnClosing | (Inherited from ChildWindow.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ChildWindow.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnOpened | (Inherited from ChildWindow.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | (Inherited from ChildWindow.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DialogTypeProperty | Identifies the DialogType property.
UrlProperty | Identifies the Url property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DialogResult | (Inherited from ChildWindow.)
DialogType | Gets or sets whether to display the dialog as an edit or create dialog. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasCloseButton | (Inherited from ChildWindow.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverlayBrush | (Inherited from ChildWindow.)
OverlayOpacity | (Inherited from ChildWindow.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Title | (Inherited from ChildWindow.)
Triggers | (Inherited from FrameworkElement.)
Url | Gets or sets the URL. This is a dependency property.
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | (Inherited from ChildWindow.)
Closing | (Inherited from ChildWindow.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

HyperlinkDialog Class


HyperlinkDialog Constructor

[image]

Mindscape Silverlight Elements
HyperlinkDialog Constructor
HyperlinkDialog Class See Also Send Feedback
Initializes a new instance of the HyperlinkDialog class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HyperlinkDialog()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HyperlinkDialog()

See Also

HyperlinkDialog Class


HyperlinkDialog Fields

[image] [image]

Mindscape Silverlight Elements
HyperlinkDialog Fields
HyperlinkDialog Class See Also Send Feedback

The HyperlinkDialog type exposes the following members.

Fields

Name | Description
DialogTypeProperty | Identifies the DialogType property.
UrlProperty | Identifies the Url property.

See Also

HyperlinkDialog Class


DialogTypeProperty Field

[image]

Mindscape Silverlight Elements
HyperlinkDialog..::.DialogTypeProperty Field
HyperlinkDialog Class See Also Send Feedback
Identifies the DialogType property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DialogTypeProperty
Visual Basic (Declaration)
Public Shared ReadOnly DialogTypeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DialogTypeProperty

See Also

HyperlinkDialog Class


UrlProperty Field

[image]

Mindscape Silverlight Elements
HyperlinkDialog..::.UrlProperty Field
HyperlinkDialog Class See Also Send Feedback
Identifies the Url property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty UrlProperty
Visual Basic (Declaration)
Public Shared ReadOnly UrlProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ UrlProperty

See Also

HyperlinkDialog Class


HyperlinkDialog Methods

[image] [image]

Mindscape Silverlight Elements
HyperlinkDialog Methods
HyperlinkDialog Class See Also Send Feedback

The HyperlinkDialog type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | (Inherited from ChildWindow.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InitializeComponent | InitializeComponent
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ChildWindow.)
OnClosed | (Inherited from ChildWindow.)
OnClosing | (Inherited from ChildWindow.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ChildWindow.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnOpened | (Inherited from ChildWindow.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | (Inherited from ChildWindow.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

HyperlinkDialog Class


InitializeComponent Method

[image]

Mindscape Silverlight Elements
HyperlinkDialog..::.InitializeComponent Method
HyperlinkDialog Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

HyperlinkDialog Class


HyperlinkDialog Properties

[image] [image]

Mindscape Silverlight Elements
HyperlinkDialog Properties
HyperlinkDialog Class See Also Send Feedback

The HyperlinkDialog type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DialogResult | (Inherited from ChildWindow.)
DialogType | Gets or sets whether to display the dialog as an edit or create dialog. This is a dependency property.
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasCloseButton | (Inherited from ChildWindow.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverlayBrush | (Inherited from ChildWindow.)
OverlayOpacity | (Inherited from ChildWindow.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Title | (Inherited from ChildWindow.)
Triggers | (Inherited from FrameworkElement.)
Url | Gets or sets the URL. This is a dependency property.
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

HyperlinkDialog Class


DialogType Property

[image]

Mindscape Silverlight Elements
HyperlinkDialog..::.DialogType Property
HyperlinkDialog Class See Also Send Feedback
Gets or sets whether to display the dialog as an edit or create dialog. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HyperlinkDialogType DialogType { get; set; }
Visual Basic (Declaration)
Public Property DialogType As HyperlinkDialogType
Visual C++
public:
property HyperlinkDialogType DialogType {
    HyperlinkDialogType get ();
    void set (HyperlinkDialogType value);
}

Remarks

Dependency Property Information
Identifier field | DialogTypeProperty
Metadata properties set to true | None

See Also

HyperlinkDialog Class


Url Property

[image]

Mindscape Silverlight Elements
HyperlinkDialog..::.Url Property
HyperlinkDialog Class See Also Send Feedback
Gets or sets the URL. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

Remarks

Dependency Property Information
Identifier field | UrlProperty
Metadata properties set to true | None

See Also

HyperlinkDialog Class


HyperlinkDialog Events

[image] [image]

Mindscape Silverlight Elements
HyperlinkDialog Events
HyperlinkDialog Class See Also Send Feedback

The HyperlinkDialog type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | (Inherited from ChildWindow.)
Closing | (Inherited from ChildWindow.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

HyperlinkDialog Class


HyperlinkDialogType Enumeration

[image]

Mindscape Silverlight Elements
HyperlinkDialogType Enumeration
See Also Send Feedback
Specifies whether to display a HyperlinkDialog as an edit or create dialog.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum HyperlinkDialogType
Visual Basic (Declaration)
Public Enumeration HyperlinkDialogType
Visual C++
public enum class HyperlinkDialogType

Members

Member name | Description
Create | Display as a Create Hyperlink dialog.
Edit | Display as an Edit Hyperlink dialog.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


IDoubleClickObserver Interface

[image]

Mindscape Silverlight Elements
IDoubleClickObserver Interface
Members See Also Send Feedback
Implemented by controls that want to receive notifications when the user double-clicks.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IDoubleClickObserver
Visual Basic (Declaration)
Public Interface IDoubleClickObserver
Visual C++
public interface class IDoubleClickObserver

See Also

IDoubleClickObserver Members


IDoubleClickObserver Members

[image] [image]

Mindscape Silverlight Elements
IDoubleClickObserver Members
IDoubleClickObserver Interface Methods Events See Also Send Feedback

The IDoubleClickObserver type exposes the following members.

Methods

Name | Description
OnDoubleClick | Called when the user double-clicks the IDoubleClickObserver.

Events

Name | Description
MouseLeftButtonPressed | An event which implementers must raise when the user clicks the mouse button.

See Also

IDoubleClickObserver Interface


IDoubleClickObserver Methods

[image] [image]

Mindscape Silverlight Elements
IDoubleClickObserver Methods
IDoubleClickObserver Interface See Also Send Feedback

The IDoubleClickObserver type exposes the following members.

Methods

Name | Description
OnDoubleClick | Called when the user double-clicks the IDoubleClickObserver.

See Also

IDoubleClickObserver Interface


OnDoubleClick Method

[image]

Mindscape Silverlight Elements
IDoubleClickObserver..::.OnDoubleClick Method
IDoubleClickObserver Interface See Also Send Feedback
Called when the user double-clicks the IDoubleClickObserver.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void OnDoubleClick()
Visual Basic (Declaration)
Sub OnDoubleClick
Visual C++
void OnDoubleClick()

See Also

IDoubleClickObserver Interface


IDoubleClickObserver Events

[image] [image]

Mindscape Silverlight Elements
IDoubleClickObserver Events
IDoubleClickObserver Interface See Also Send Feedback

The IDoubleClickObserver type exposes the following members.

Events

Name | Description
MouseLeftButtonPressed | An event which implementers must raise when the user clicks the mouse button.

See Also

IDoubleClickObserver Interface


MouseLeftButtonPressed Event

[image]

Mindscape Silverlight Elements
IDoubleClickObserver..::.MouseLeftButtonPressed Event
IDoubleClickObserver Interface See Also Send Feedback
An event which implementers must raise when the user clicks the mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
event MouseButtonEventHandler MouseLeftButtonPressed
Visual Basic (Declaration)
Event MouseLeftButtonPressed As MouseButtonEventHandler
Visual C++
 event MouseButtonEventHandler^ MouseLeftButtonPressed {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}

See Also

IDoubleClickObserver Interface


IListStyleType Interface

[image]

Mindscape Silverlight Elements
IListStyleType Interface
Members See Also Send Feedback
Represents a list style, such as round bullets or Roman numbering.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IListStyleType
Visual Basic (Declaration)
Public Interface IListStyleType
Visual C++
public interface class IListStyleType

See Also

IListStyleType Members


IListStyleType Members

[image] [image]

Mindscape Silverlight Elements
IListStyleType Members
IListStyleType Interface Methods Properties See Also Send Feedback

The IListStyleType type exposes the following members.

Methods

Name | Description
GetString | Gets the prefix string for the list item at the specified index.

Properties

Name | Description
Id | An identifying string for the style. This may be used in a StringToDataTemplateConverter to map list styles to resources.

See Also

IListStyleType Interface


IListStyleType Methods

[image] [image]

Mindscape Silverlight Elements
IListStyleType Methods
IListStyleType Interface See Also Send Feedback

The IListStyleType type exposes the following members.

Methods

Name | Description
GetString | Gets the prefix string for the list item at the specified index.

See Also

IListStyleType Interface


GetString Method

[image]

Mindscape Silverlight Elements
IListStyleType..::.GetString Method
IListStyleType Interface See Also Send Feedback
Gets the prefix string for the list item at the specified index.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
string GetString(
    int index
)
Visual Basic (Declaration)
Function GetString ( _
    index As Integer _
) As String
Visual C++
String^ GetString(
    int index
)

Parameters

index
Type: System..::.Int32
The list item index.

Return Value

The prefix string. This may be null or empty for non-string prefixes such as bulleted lists.

See Also

IListStyleType Interface


IListStyleType Properties

[image] [image]

Mindscape Silverlight Elements
IListStyleType Properties
IListStyleType Interface See Also Send Feedback

The IListStyleType type exposes the following members.

Properties

Name | Description
Id | An identifying string for the style. This may be used in a StringToDataTemplateConverter to map list styles to resources.

See Also

IListStyleType Interface


Id Property

[image]

Mindscape Silverlight Elements
IListStyleType..::.Id Property
IListStyleType Interface See Also Send Feedback
An identifying string for the style. This may be used in a StringToDataTemplateConverter to map list styles to resources.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

IListStyleType Interface


IMouseWheelObserver Interface

[image]

Mindscape Silverlight Elements
IMouseWheelObserver Interface
Members See Also Send Feedback
Implemented by controls that want to be notified of mouse wheel events.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IMouseWheelObserver
Visual Basic (Declaration)
Public Interface IMouseWheelObserver
Visual C++
public interface class IMouseWheelObserver

See Also

IMouseWheelObserver Members


IMouseWheelObserver Members

[image] [image]

Mindscape Silverlight Elements
IMouseWheelObserver Members
IMouseWheelObserver Interface Methods Events See Also Send Feedback

The IMouseWheelObserver type exposes the following members.

Methods

Name | Description
OnMouseWheel | Called when the user scrolls the mouse wheel.

Events

Name | Description
MouseEnter | An event which implementers must raise when the mouse enters the implementing control.
MouseLeave | An event which implementers must raise when the mouse leaves the implementing control.

See Also

IMouseWheelObserver Interface


IMouseWheelObserver Methods

[image] [image]

Mindscape Silverlight Elements
IMouseWheelObserver Methods
IMouseWheelObserver Interface See Also Send Feedback

The IMouseWheelObserver type exposes the following members.

Methods

Name | Description
OnMouseWheel | Called when the user scrolls the mouse wheel.

See Also

IMouseWheelObserver Interface


OnMouseWheel Method

[image]

Mindscape Silverlight Elements
IMouseWheelObserver..::.OnMouseWheel Method
IMouseWheelObserver Interface See Also Send Feedback
Called when the user scrolls the mouse wheel.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
void OnMouseWheel(
    MouseWheelEventArgs e
)
Visual Basic (Declaration)
Sub OnMouseWheel ( _
    e As MouseWheelEventArgs _
)
Visual C++
void OnMouseWheel(
    MouseWheelEventArgs^ e
)

Parameters

e
Type: Mindscape.SilverlightElements..::.MouseWheelEventArgs
The mouse wheel event data.

See Also

IMouseWheelObserver Interface


IMouseWheelObserver Events

[image] [image]

Mindscape Silverlight Elements
IMouseWheelObserver Events
IMouseWheelObserver Interface See Also Send Feedback

The IMouseWheelObserver type exposes the following members.

Events

Name | Description
MouseEnter | An event which implementers must raise when the mouse enters the implementing control.
MouseLeave | An event which implementers must raise when the mouse leaves the implementing control.

See Also

IMouseWheelObserver Interface


MouseEnter Event

[image]

Mindscape Silverlight Elements
IMouseWheelObserver..::.MouseEnter Event
IMouseWheelObserver Interface See Also Send Feedback
An event which implementers must raise when the mouse enters the implementing control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
event MouseEventHandler MouseEnter
Visual Basic (Declaration)
Event MouseEnter As MouseEventHandler
Visual C++
 event MouseEventHandler^ MouseEnter {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

IMouseWheelObserver Interface


MouseLeave Event

[image]

Mindscape Silverlight Elements
IMouseWheelObserver..::.MouseLeave Event
IMouseWheelObserver Interface See Also Send Feedback
An event which implementers must raise when the mouse leaves the implementing control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
event MouseEventHandler MouseLeave
Visual Basic (Declaration)
Event MouseLeave As MouseEventHandler
Visual C++
 event MouseEventHandler^ MouseLeave {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

IMouseWheelObserver Interface


IRecurrencePattern Interface

[image]

Mindscape Silverlight Elements
IRecurrencePattern Interface
Members See Also Send Feedback
Represents the recurrence pattern of a recurring ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface IRecurrencePattern
Visual Basic (Declaration)
Public Interface IRecurrencePattern
Visual C++
public interface class IRecurrencePattern

See Also

IRecurrencePattern Members


IRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
IRecurrencePattern Members
IRecurrencePattern Interface Methods See Also Send Feedback

The IRecurrencePattern type exposes the following members.

Methods

Name | Description
Includes | Overloaded.

Extension Methods

Name | Description
ToXml | Gets an XElement containing the details of the recurrence pattern. (Defined by RecurrencePatternXmlSerializer.)

See Also

IRecurrencePattern Interface


IRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
IRecurrencePattern Methods
IRecurrencePattern Interface See Also Send Feedback

The IRecurrencePattern type exposes the following members.

Methods

Name | Description
Includes | Overloaded.

Extension Methods

Name | Description
ToXml | Gets an XElement containing the details of the recurrence pattern. (Defined by RecurrencePatternXmlSerializer.)

See Also

IRecurrencePattern Interface


Includes Method

[image] [image]

Mindscape Silverlight Elements
IRecurrencePattern..::.Includes Method
IRecurrencePattern Interface See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date.
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date.
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

See Also

IRecurrencePattern Interface
IRecurrencePattern Members


Includes Method (DateTime, DateTime)

[image]

Mindscape Silverlight Elements
IRecurrencePattern..::.Includes Method (DateTime, DateTime)
IRecurrencePattern Interface See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool Includes(
    DateTime startDate,
    DateTime day
)
Visual Basic (Declaration)
Function Includes ( _
    startDate As DateTime, _
    day As DateTime _
) As Boolean
Visual C++
bool Includes(
    DateTime startDate,
    DateTime day
)

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

IRecurrencePattern Interface
Includes Overload


Includes Method (DateTime, DateTime, DateTime)

[image]

Mindscape Silverlight Elements
IRecurrencePattern..::.Includes Method (DateTime, DateTime, DateTime)
IRecurrencePattern Interface See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start and end date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool Includes(
    DateTime startDate,
    DateTime day,
    DateTime endDate
)
Visual Basic (Declaration)
Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    endDate As DateTime _
) As Boolean
Visual C++
bool Includes(
    DateTime startDate,
    DateTime day,
    DateTime endDate
)

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
endDate
Type: System..::.DateTime
The end date of recurrence.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

IRecurrencePattern Interface
Includes Overload


Includes Method (DateTime, DateTime, Int32)

[image]

Mindscape Silverlight Elements
IRecurrencePattern..::.Includes Method (DateTime, DateTime, Int32)
IRecurrencePattern Interface See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
bool Includes(
    DateTime startDate,
    DateTime day,
    int occurrenceCount
)
Visual Basic (Declaration)
Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    occurrenceCount As Integer _
) As Boolean
Visual C++
bool Includes(
    DateTime startDate,
    DateTime day,
    int occurrenceCount
)

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
occurrenceCount
Type: System..::.Int32
The maximum number of occurrences to consider.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

IRecurrencePattern Interface
Includes Overload


LeftMarginConverter Class

[image]

Mindscape Silverlight Elements
LeftMarginConverter Class
Members See Also Send Feedback
Converts a double value to a Thickness representing a left margin offset.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LeftMarginConverter : IValueConverter
Visual Basic (Declaration)
Public Class LeftMarginConverter _
    Implements IValueConverter
Visual C++
public ref class LeftMarginConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.LeftMarginConverter

See Also

LeftMarginConverter Members


LeftMarginConverter Members

[image] [image]

Mindscape Silverlight Elements
LeftMarginConverter Members
LeftMarginConverter Class Constructors Methods See Also Send Feedback

The LeftMarginConverter type exposes the following members.

Constructors

Name | Description
LeftMarginConverter | Initializes a new instance of the LeftMarginConverter class

Methods

Name | Description
Convert | Converts a double value from a binding source to a Thickness for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeftMarginConverter Class


LeftMarginConverter Constructor

[image]

Mindscape Silverlight Elements
LeftMarginConverter Constructor
LeftMarginConverter Class See Also Send Feedback
Initializes a new instance of the LeftMarginConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LeftMarginConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeftMarginConverter()

See Also

LeftMarginConverter Class


LeftMarginConverter Methods

[image] [image]

Mindscape Silverlight Elements
LeftMarginConverter Methods
LeftMarginConverter Class See Also Send Feedback

The LeftMarginConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a double value from a binding source to a Thickness for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeftMarginConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
LeftMarginConverter..::.Convert Method
LeftMarginConverter Class See Also Send Feedback
Converts a double value from a binding source to a Thickness for use by a binding target.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

LeftMarginConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
LeftMarginConverter..::.ConvertBack Method
LeftMarginConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

LeftMarginConverter Class


LevelToIndentConverter Class

[image]

Mindscape Silverlight Elements
LevelToIndentConverter Class
Members See Also Send Feedback
Converts an integer level to a Thickness for indenting that level.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class LevelToIndentConverter : IValueConverter
Visual Basic (Declaration)
Public Class LevelToIndentConverter _
    Implements IValueConverter
Visual C++
public ref class LevelToIndentConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.LevelToIndentConverter

See Also

LevelToIndentConverter Members


LevelToIndentConverter Members

[image] [image]

Mindscape Silverlight Elements
LevelToIndentConverter Members
LevelToIndentConverter Class Constructors Methods Properties See Also Send Feedback

The LevelToIndentConverter type exposes the following members.

Constructors

Name | Description
LevelToIndentConverter | Initializes a new instance of the LevelToIndentConverter class

Methods

Name | Description
Convert | Converts a level in the MulticolumnTreeView hierarchy to an indent.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Indent | Gets or sets the indent to apply at each level.

See Also

LevelToIndentConverter Class


LevelToIndentConverter Constructor

[image]

Mindscape Silverlight Elements
LevelToIndentConverter Constructor
LevelToIndentConverter Class See Also Send Feedback
Initializes a new instance of the LevelToIndentConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LevelToIndentConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LevelToIndentConverter()

See Also

LevelToIndentConverter Class


LevelToIndentConverter Methods

[image] [image]

Mindscape Silverlight Elements
LevelToIndentConverter Methods
LevelToIndentConverter Class See Also Send Feedback

The LevelToIndentConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a level in the MulticolumnTreeView hierarchy to an indent.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelToIndentConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
LevelToIndentConverter..::.Convert Method
LevelToIndentConverter Class See Also Send Feedback
Converts a level in the MulticolumnTreeView hierarchy to an indent.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The integer level.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A Thickness representing the indent.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

LevelToIndentConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
LevelToIndentConverter..::.ConvertBack Method
LevelToIndentConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

LevelToIndentConverter Class


LevelToIndentConverter Properties

[image] [image]

Mindscape Silverlight Elements
LevelToIndentConverter Properties
LevelToIndentConverter Class See Also Send Feedback

The LevelToIndentConverter type exposes the following members.

Properties

Name | Description
Indent | Gets or sets the indent to apply at each level.

See Also

LevelToIndentConverter Class


Indent Property

[image]

Mindscape Silverlight Elements
LevelToIndentConverter..::.Indent Property
LevelToIndentConverter Class See Also Send Feedback
Gets or sets the indent to apply at each level.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Indent { get; set; }
Visual Basic (Declaration)
Public Property Indent As Double
Visual C++
public:
property double Indent {
    double get ();
    void set (double value);
}

See Also

LevelToIndentConverter Class


ListStyleTypePicker Class

[image]

Mindscape Silverlight Elements
ListStyleTypePicker Class
Members See Also Send Feedback
A control for selecting list styles in a RichTextEditor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListStyleTypePicker : Control
Visual Basic (Declaration)
Public Class ListStyleTypePicker _
    Inherits Control
Visual C++
public ref class ListStyleTypePicker : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ListStyleTypePicker

See Also

ListStyleTypePicker Members


ListStyleTypePicker Members

[image] [image]

Mindscape Silverlight Elements
ListStyleTypePicker Members
ListStyleTypePicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The ListStyleTypePicker type exposes the following members.

Constructors

Name | Description
ListStyleTypePicker | Initializes a new instance of the ListStyleTypePicker class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsCheckedProperty | Identifies the IsChecked property.
ItemsSourceProperty | Identifies the ItemsSource property.
SelectedStyleTypeProperty | Identifies the SelectedStyleType property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | Gets or sets the whether any style is selected. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource | Gets or sets the items to be displayed in the ListStyleTypePicker. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedStyleType | Gets or sets the SelectedStyleType. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedStyleTypeChanged | Occurs when the SelectedStyleType changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListStyleTypePicker Class


ListStyleTypePicker Constructor

[image]

Mindscape Silverlight Elements
ListStyleTypePicker Constructor
ListStyleTypePicker Class See Also Send Feedback
Initializes a new instance of the ListStyleTypePicker class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListStyleTypePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListStyleTypePicker()

See Also

ListStyleTypePicker Class


ListStyleTypePicker Fields

[image] [image]

Mindscape Silverlight Elements
ListStyleTypePicker Fields
ListStyleTypePicker Class See Also Send Feedback

The ListStyleTypePicker type exposes the following members.

Fields

Name | Description
IsCheckedProperty | Identifies the IsChecked property.
ItemsSourceProperty | Identifies the ItemsSource property.
SelectedStyleTypeProperty | Identifies the SelectedStyleType property.

See Also

ListStyleTypePicker Class


IsCheckedProperty Field

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.IsCheckedProperty Field
ListStyleTypePicker Class See Also Send Feedback
Identifies the IsChecked property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsCheckedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsCheckedProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsCheckedProperty

See Also

ListStyleTypePicker Class


ItemsSourceProperty Field

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.ItemsSourceProperty Field
ListStyleTypePicker Class See Also Send Feedback
Identifies the ItemsSource property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemsSourceProperty

See Also

ListStyleTypePicker Class


SelectedStyleTypeProperty Field

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.SelectedStyleTypeProperty Field
ListStyleTypePicker Class See Also Send Feedback
Identifies the SelectedStyleType property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedStyleTypeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedStyleTypeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedStyleTypeProperty

See Also

ListStyleTypePicker Class


ListStyleTypePicker Methods

[image] [image]

Mindscape Silverlight Elements
ListStyleTypePicker Methods
ListStyleTypePicker Class See Also Send Feedback

The ListStyleTypePicker type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ListStyleTypePicker Class


OnApplyTemplate Method

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.OnApplyTemplate Method
ListStyleTypePicker Class See Also Send Feedback
Called by the framework when the template is applied.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ListStyleTypePicker Class


ListStyleTypePicker Properties

[image] [image]

Mindscape Silverlight Elements
ListStyleTypePicker Properties
ListStyleTypePicker Class See Also Send Feedback

The ListStyleTypePicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | Gets or sets the whether any style is selected. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource | Gets or sets the items to be displayed in the ListStyleTypePicker. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedStyleType | Gets or sets the SelectedStyleType. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ListStyleTypePicker Class


IsChecked Property

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.IsChecked Property
ListStyleTypePicker Class See Also Send Feedback
Gets or sets the whether any style is selected. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic (Declaration)
Public Property IsChecked As Boolean
Visual C++
public:
property bool IsChecked {
    bool get ();
    void set (bool value);
}

Remarks

Dependency Property Information
Identifier field | IsCheckedProperty
Metadata properties set to true | None

See Also

ListStyleTypePicker Class


ItemsSource Property

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.ItemsSource Property
ListStyleTypePicker Class See Also Send Feedback
Gets or sets the items to be displayed in the ListStyleTypePicker. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<IListStyleType> ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As ReadOnlyCollection(Of IListStyleType)
Visual C++
public:
property ReadOnlyCollection<IListStyleType^>^ ItemsSource {
    ReadOnlyCollection<IListStyleType^>^ get ();
    void set (ReadOnlyCollection<IListStyleType^>^ value);
}

Remarks

Dependency Property Information
Identifier field | ItemsSourceProperty
Metadata properties set to true | None

See Also

ListStyleTypePicker Class


SelectedStyleType Property

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.SelectedStyleType Property
ListStyleTypePicker Class See Also Send Feedback
Gets or sets the SelectedStyleType. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IListStyleType SelectedStyleType { get; set; }
Visual Basic (Declaration)
Public Property SelectedStyleType As IListStyleType
Visual C++
public:
property IListStyleType^ SelectedStyleType {
    IListStyleType^ get ();
    void set (IListStyleType^ value);
}

Remarks

Dependency Property Information
Identifier field | SelectedStyleTypeProperty
Metadata properties set to true | None

See Also

ListStyleTypePicker Class


ListStyleTypePicker Events

[image] [image]

Mindscape Silverlight Elements
ListStyleTypePicker Events
ListStyleTypePicker Class See Also Send Feedback

The ListStyleTypePicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedStyleTypeChanged | Occurs when the SelectedStyleType changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListStyleTypePicker Class


SelectedStyleTypeChanged Event

[image]

Mindscape Silverlight Elements
ListStyleTypePicker..::.SelectedStyleTypeChanged Event
ListStyleTypePicker Class See Also Send Feedback
Occurs when the SelectedStyleType changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event RoutedEventHandler SelectedStyleTypeChanged
Visual Basic (Declaration)
Public Event SelectedStyleTypeChanged As RoutedEventHandler
Visual C++
public:
 event RoutedEventHandler^ SelectedStyleTypeChanged {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

See Also

ListStyleTypePicker Class


ListStyleTypes Class

[image]

Mindscape Silverlight Elements
ListStyleTypes Class
Members See Also Send Feedback
Provides access to the list styles supported by the RichTextEditor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class ListStyleTypes
Visual Basic (Declaration)
Public NotInheritable Class ListStyleTypes
Visual C++
public ref class ListStyleTypes abstract sealed

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ListStyleTypes

See Also

ListStyleTypes Members


ListStyleTypes Members

[image] [image]

Mindscape Silverlight Elements
ListStyleTypes Members
ListStyleTypes Class Properties See Also Send Feedback

The ListStyleTypes type exposes the following members.

Properties

Name | Description
AlphaLower | Lower-case letters (a., b., c....).
AlphaUpper | Upper-case letters (A., B., C....).
Decimal | Numbered list (1., 2., 3....);
DecimalLeadingZero | Numbered list with leading zero for numbers less than 10 (01., 02., 03....);
Disc | List items prefixed with a solid circle.
NoBullets | Unordered list with no prefix.
NoNumbers | Ordered list with no prefix.
RomanLower | Lower-case Roman numerals (i., ii., iii....).
RomanUpper | Upper-case Roman numerals (I., II., III....).
Round | List items prefixed with a hollow circle.
Square | List items prefixed with a solid square.

See Also

ListStyleTypes Class


ListStyleTypes Properties

[image] [image]

Mindscape Silverlight Elements
ListStyleTypes Properties
ListStyleTypes Class See Also Send Feedback

The ListStyleTypes type exposes the following members.

Properties

Name | Description
AlphaLower | Lower-case letters (a., b., c....).
AlphaUpper | Upper-case letters (A., B., C....).
Decimal | Numbered list (1., 2., 3....);
DecimalLeadingZero | Numbered list with leading zero for numbers less than 10 (01., 02., 03....);
Disc | List items prefixed with a solid circle.
NoBullets | Unordered list with no prefix.
NoNumbers | Ordered list with no prefix.
RomanLower | Lower-case Roman numerals (i., ii., iii....).
RomanUpper | Upper-case Roman numerals (I., II., III....).
Round | List items prefixed with a hollow circle.
Square | List items prefixed with a solid square.

See Also

ListStyleTypes Class


AlphaLower Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.AlphaLower Property
ListStyleTypes Class See Also Send Feedback
Lower-case letters (a., b., c....).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType AlphaLower { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AlphaLower As IListStyleType
Visual C++
public:
static property IListStyleType^ AlphaLower {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


AlphaUpper Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.AlphaUpper Property
ListStyleTypes Class See Also Send Feedback
Upper-case letters (A., B., C....).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType AlphaUpper { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AlphaUpper As IListStyleType
Visual C++
public:
static property IListStyleType^ AlphaUpper {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


Decimal Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.Decimal Property
ListStyleTypes Class See Also Send Feedback
Numbered list (1., 2., 3....);

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType Decimal { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Decimal As IListStyleType
Visual C++
public:
static property IListStyleType^ Decimal {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


DecimalLeadingZero Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.DecimalLeadingZero Property
ListStyleTypes Class See Also Send Feedback
Numbered list with leading zero for numbers less than 10 (01., 02., 03....);

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType DecimalLeadingZero { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DecimalLeadingZero As IListStyleType
Visual C++
public:
static property IListStyleType^ DecimalLeadingZero {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


Disc Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.Disc Property
ListStyleTypes Class See Also Send Feedback
List items prefixed with a solid circle.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType Disc { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Disc As IListStyleType
Visual C++
public:
static property IListStyleType^ Disc {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


NoBullets Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.NoBullets Property
ListStyleTypes Class See Also Send Feedback
Unordered list with no prefix.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType NoBullets { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoBullets As IListStyleType
Visual C++
public:
static property IListStyleType^ NoBullets {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


NoNumbers Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.NoNumbers Property
ListStyleTypes Class See Also Send Feedback
Ordered list with no prefix.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType NoNumbers { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NoNumbers As IListStyleType
Visual C++
public:
static property IListStyleType^ NoNumbers {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


RomanLower Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.RomanLower Property
ListStyleTypes Class See Also Send Feedback
Lower-case Roman numerals (i., ii., iii....).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType RomanLower { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RomanLower As IListStyleType
Visual C++
public:
static property IListStyleType^ RomanLower {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


RomanUpper Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.RomanUpper Property
ListStyleTypes Class See Also Send Feedback
Upper-case Roman numerals (I., II., III....).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType RomanUpper { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RomanUpper As IListStyleType
Visual C++
public:
static property IListStyleType^ RomanUpper {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


Round Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.Round Property
ListStyleTypes Class See Also Send Feedback
List items prefixed with a hollow circle.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType Round { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Round As IListStyleType
Visual C++
public:
static property IListStyleType^ Round {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


Square Property

[image]

Mindscape Silverlight Elements
ListStyleTypes..::.Square Property
ListStyleTypes Class See Also Send Feedback
List items prefixed with a solid square.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IListStyleType Square { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Square As IListStyleType
Visual C++
public:
static property IListStyleType^ Square {
    IListStyleType^ get ();
}

See Also

ListStyleTypes Class


ListToSubListConverter Class

[image]

Mindscape Silverlight Elements
ListToSubListConverter Class
Members See Also Send Feedback
Extracts a sub-list from a master list.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListToSubListConverter : IValueConverter
Visual Basic (Declaration)
Public Class ListToSubListConverter _
    Implements IValueConverter
Visual C++
public ref class ListToSubListConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ListToSubListConverter

See Also

ListToSubListConverter Members


ListToSubListConverter Members

[image] [image]

Mindscape Silverlight Elements
ListToSubListConverter Members
ListToSubListConverter Class Constructors Methods Properties See Also Send Feedback

The ListToSubListConverter type exposes the following members.

Constructors

Name | Description
ListToSubListConverter | Initializes a new instance of the ListToSubListConverter class

Methods

Name | Description
Convert | Extracts a sub-list from a master list. The sub-list begins at StartIndex, and has Length elements.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Length | The length of the sub-list.
StartIndex | The index within the source list at which to start extracting the sub-list.

See Also

ListToSubListConverter Class


ListToSubListConverter Constructor

[image]

Mindscape Silverlight Elements
ListToSubListConverter Constructor
ListToSubListConverter Class See Also Send Feedback
Initializes a new instance of the ListToSubListConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListToSubListConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListToSubListConverter()

See Also

ListToSubListConverter Class


ListToSubListConverter Methods

[image] [image]

Mindscape Silverlight Elements
ListToSubListConverter Methods
ListToSubListConverter Class See Also Send Feedback

The ListToSubListConverter type exposes the following members.

Methods

Name | Description
Convert | Extracts a sub-list from a master list. The sub-list begins at StartIndex, and has Length elements.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListToSubListConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ListToSubListConverter..::.Convert Method
ListToSubListConverter Class See Also Send Feedback
Extracts a sub-list from a master list. The sub-list begins at StartIndex, and has Length elements.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The IList value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The sub-list extracted from the master list.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ListToSubListConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ListToSubListConverter..::.ConvertBack Method
ListToSubListConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ListToSubListConverter Class


ListToSubListConverter Properties

[image] [image]

Mindscape Silverlight Elements
ListToSubListConverter Properties
ListToSubListConverter Class See Also Send Feedback

The ListToSubListConverter type exposes the following members.

Properties

Name | Description
Length | The length of the sub-list.
StartIndex | The index within the source list at which to start extracting the sub-list.

See Also

ListToSubListConverter Class


Length Property

[image]

Mindscape Silverlight Elements
ListToSubListConverter..::.Length Property
ListToSubListConverter Class See Also Send Feedback
The length of the sub-list.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

See Also

ListToSubListConverter Class


StartIndex Property

[image]

Mindscape Silverlight Elements
ListToSubListConverter..::.StartIndex Property
ListToSubListConverter Class See Also Send Feedback
The index within the source list at which to start extracting the sub-list.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int StartIndex { get; set; }
Visual Basic (Declaration)
Public Property StartIndex As Integer
Visual C++
public:
property int StartIndex {
    int get ();
    void set (int value);
}

See Also

ListToSubListConverter Class


ListType Enumeration

[image]

Mindscape Silverlight Elements
ListType Enumeration
See Also Send Feedback
Specifies whether a list in a RichTextEditor has ordered captions.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ListType
Visual Basic (Declaration)
Public Enumeration ListType
Visual C++
public enum class ListType

Members

Member name | Description
Ordered | List entry captions are ordered (e.g. 1, 2, 3...).
Unordered | List entry captions are not ordered (e.g. a bullet list).

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


ListView Class

[image]

Mindscape Silverlight Elements
ListView Class
Members See Also Send Feedback
A control which displays a list of items in a tabular format with multiple columns.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListView : ListBox
Visual Basic (Declaration)
Public Class ListView _
    Inherits ListBox
Visual C++
public ref class ListView : public ListBox

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
System.Windows.Controls.Primitives..::.Selector
System.Windows.Controls..::.ListBox
Mindscape.SilverlightElements..::.ListView

See Also

ListView Members


ListView Members

[image] [image]

Mindscape Silverlight Elements
ListView Members
ListView Class Constructors Methods Fields Properties Events See Also Send Feedback

The ListView type exposes the following members.

Constructors

Name | Description
ListView | Initializes a new instance of the ListView class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Overrides SelectorClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates an item to display a data item. (Overrides ListBox..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides ListBox..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the template is applied. (Overrides ListBoxOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from ListBox.)
OnGotFocus | (Inherited from ListBox.)
OnItemsChanged | Called when the value of the Items property changes. (Overrides Selector..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from ListBox.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBox.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
PrepareContainerForItemOverride | Prepares a ListViewItem for display in the ListView. (Overrides SelectorPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
ScrollIntoView | (Inherited from ListBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AllowsColumnReorderProperty | Identifies the AllowsColumnReorder property.
ColumnHeaderContainerStyleProperty | Identifies the ColumnHeaderContainerStyle property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowsColumnReorder | Gets or sets whether the user can reorder columns in the ListView. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ColumnHeaderContainerStyle | Gets or sets the Style applied to column headers. This is a dependency property.
ColumnHeaderTemplate | Gets or sets the DataTemplate used to display column headers. This is a dependency property.
Columns | Gets the collection of columns in the ListView.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from ListBox.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
SelectedItems | (Inherited from ListBox.)
SelectionMode | (Inherited from ListBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListView Class


ListView Constructor

[image]

Mindscape Silverlight Elements
ListView Constructor
ListView Class See Also Send Feedback
Initializes a new instance of the ListView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListView()

See Also

ListView Class


ListView Fields

[image] [image]

Mindscape Silverlight Elements
ListView Fields
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Fields

Name | Description
AllowsColumnReorderProperty | Identifies the AllowsColumnReorder property.
ColumnHeaderContainerStyleProperty | Identifies the ColumnHeaderContainerStyle property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate property.

See Also

ListView Class


AllowsColumnReorderProperty Field

[image]

Mindscape Silverlight Elements
ListView..::.AllowsColumnReorderProperty Field
ListView Class See Also Send Feedback
Identifies the AllowsColumnReorder property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty AllowsColumnReorderProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowsColumnReorderProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AllowsColumnReorderProperty

See Also

ListView Class


ColumnHeaderContainerStyleProperty Field

[image]

Mindscape Silverlight Elements
ListView..::.ColumnHeaderContainerStyleProperty Field
ListView Class See Also Send Feedback
Identifies the ColumnHeaderContainerStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderContainerStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderContainerStyleProperty

See Also

ListView Class


ColumnHeaderTemplateProperty Field

[image]

Mindscape Silverlight Elements
ListView..::.ColumnHeaderTemplateProperty Field
ListView Class See Also Send Feedback
Identifies the ColumnHeaderTemplate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderTemplateProperty

See Also

ListView Class


ListView Methods

[image] [image]

Mindscape Silverlight Elements
ListView Methods
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | Undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method. (Overrides SelectorClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates an item to display a data item. (Overrides ListBox..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides ListBox..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the template is applied. (Overrides ListBoxOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from ListBox.)
OnGotFocus | (Inherited from ListBox.)
OnItemsChanged | Called when the value of the Items property changes. (Overrides Selector..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from ListBox.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBox.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
PrepareContainerForItemOverride | Prepares a ListViewItem for display in the ListView. (Overrides SelectorPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
ScrollIntoView | (Inherited from ListBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ListView Class


ClearContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
ListView..::.ClearContainerForItemOverride Method
ListView Class See Also Send Feedback
Undoes the effects of the PrepareContainerForItemOverride(DependencyObject, Object) method.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)
Visual C++
protected:
virtual void ClearContainerForItemOverride(
    DependencyObject^ element,
    Object^ item
) override

Parameters

element
Type: System.Windows..::.DependencyObject
The container element.
item
Type: System..::.Object
The data item.

See Also

ListView Class


GetContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
ListView..::.GetContainerForItemOverride Method
ListView Class See Also Send Feedback
Creates an item to display a data item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject
Visual C++
protected:
virtual DependencyObject^ GetContainerForItemOverride() override

Return Value

The element that is used to display the item.

See Also

ListView Class


IsItemItsOwnContainerOverride Method

[image]

Mindscape Silverlight Elements
ListView..::.IsItemItsOwnContainerOverride Method
ListView Class See Also Send Feedback
Determines if the specified item is (or is eligible to be) its own container.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean
Visual C++
protected:
virtual bool IsItemItsOwnContainerOverride(
    Object^ item
) override

Parameters

item
Type: System..::.Object
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

ListView Class


OnApplyTemplate Method

[image]

Mindscape Silverlight Elements
ListView..::.OnApplyTemplate Method
ListView Class See Also Send Feedback
Called by the framework when the template is applied.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

ListView Class


OnItemsChanged Method

[image]

Mindscape Silverlight Elements
ListView..::.OnItemsChanged Method
ListView Class See Also Send Feedback
Called when the value of the Items property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
virtual void OnItemsChanged(
    NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
The event data.

See Also

ListView Class


PrepareContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
ListView..::.PrepareContainerForItemOverride Method
ListView Class See Also Send Feedback
Prepares a ListViewItem for display in the ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)
Visual C++
protected:
virtual void PrepareContainerForItemOverride(
    DependencyObject^ element,
    Object^ item
) override

Parameters

element
Type: System.Windows..::.DependencyObject
The ListViewItem.
item
Type: System..::.Object
The data to be displayed in the ListViewItem.

See Also

ListView Class


ListView Properties

[image] [image]

Mindscape Silverlight Elements
ListView Properties
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowsColumnReorder | Gets or sets whether the user can reorder columns in the ListView. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ColumnHeaderContainerStyle | Gets or sets the Style applied to column headers. This is a dependency property.
ColumnHeaderTemplate | Gets or sets the DataTemplate used to display column headers. This is a dependency property.
Columns | Gets the collection of columns in the ListView.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSynchronizedWithCurrentItem | (Inherited from Selector.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from ListBox.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | (Inherited from Selector.)
SelectedItem | (Inherited from Selector.)
SelectedItems | (Inherited from ListBox.)
SelectionMode | (Inherited from ListBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ListView Class


AllowsColumnReorder Property

[image]

Mindscape Silverlight Elements
ListView..::.AllowsColumnReorder Property
ListView Class See Also Send Feedback
Gets or sets whether the user can reorder columns in the ListView. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowsColumnReorder { get; set; }
Visual Basic (Declaration)
Public Property AllowsColumnReorder As Boolean
Visual C++
public:
property bool AllowsColumnReorder {
    bool get ();
    void set (bool value);
}

Remarks

Dependency Property Information
Identifier field | AllowsColumnReorderProperty
Metadata properties set to true | None

See Also

ListView Class


ColumnHeaderContainerStyle Property

[image]

Mindscape Silverlight Elements
ListView..::.ColumnHeaderContainerStyle Property
ListView Class See Also Send Feedback
Gets or sets the Style applied to column headers. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style ColumnHeaderContainerStyle { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderContainerStyle As Style
Visual C++
public:
property Style^ ColumnHeaderContainerStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnHeaderContainerStyleProperty
Metadata properties set to true | None

See Also

ListView Class


ColumnHeaderTemplate Property

[image]

Mindscape Silverlight Elements
ListView..::.ColumnHeaderTemplate Property
ListView Class See Also Send Feedback
Gets or sets the DataTemplate used to display column headers. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate ColumnHeaderTemplate { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ ColumnHeaderTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnHeaderTemplateProperty
Metadata properties set to true | None

See Also

ListView Class


Columns Property

[image]

Mindscape Silverlight Elements
ListView..::.Columns Property
ListView Class See Also Send Feedback
Gets the collection of columns in the ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As GridViewColumnCollection
Visual C++
public:
property GridViewColumnCollection^ Columns {
    GridViewColumnCollection^ get ();
}

See Also

ListView Class


ListView Events

[image] [image]

Mindscape Silverlight Elements
ListView Events
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectionChanged | (Inherited from Selector.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListView Class


ListViewHeaderRow Class

[image]

Mindscape Silverlight Elements
ListViewHeaderRow Class
Members See Also Send Feedback
Displays column headers in a ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListViewHeaderRow : ListViewItemBase,
    INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ListViewHeaderRow _
    Inherits ListViewItemBase _
    Implements INotifyPropertyChanged
Visual C++
public ref class ListViewHeaderRow : public ListViewItemBase,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.SilverlightElements..::.ListViewItemBase
Mindscape.SilverlightElements..::.ListViewHeaderRow

See Also

ListViewHeaderRow Members


ListViewHeaderRow Members

[image] [image]

Mindscape Silverlight Elements
ListViewHeaderRow Members
ListViewHeaderRow Class Constructors Methods Fields Properties Events See Also Send Feedback

The ListViewHeaderRow type exposes the following members.

Constructors

Name | Description
ListViewHeaderRow | Initializes a new instance of the ListViewHeaderRow class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnColumnsChanged | Called by the framework when the Columns property changes. (Inherited from ListViewItemBase.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | (Inherited from ListBoxItem.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AllowsColumnReorderProperty | Identifies the AllowsColumnReorder property.
ColumnHeaderContainerStyleProperty | Identifies the ColumnHeaderContainerStyle property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate property.
ColumnHeaderTemplateSelectorProperty | Identifies the ColumnHeaderTemplateSelector property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowsColumnReorder | Gets or sets whether the user can reorder columns. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ColumnDropRequestPosition | Gets the position at which a column is being dropped, if column reordering is in progress.
ColumnHeaderContainerStyle | Gets or sets the Style applied to column headers. This is a dependency property.
ColumnHeaderTemplate | Gets or sets the DataTemplate for the column headers. This is a dependency property.
ColumnHeaderTemplateSelector | Gets or sets the DataTemplateSelector for the column headers. This is a dependency property.
Columns | Gets or sets the columns associated with the ListViewItemBase. This is a dependency property. (Inherited from ListViewItemBase.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequestingColumnDropPosition | Gets whether a column reordering is in progress.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListViewHeaderRow Class


ListViewHeaderRow Constructor

[image]

Mindscape Silverlight Elements
ListViewHeaderRow Constructor
ListViewHeaderRow Class See Also Send Feedback
Initializes a new instance of the ListViewHeaderRow class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListViewHeaderRow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListViewHeaderRow()

See Also

ListViewHeaderRow Class


ListViewHeaderRow Fields

[image] [image]

Mindscape Silverlight Elements
ListViewHeaderRow Fields
ListViewHeaderRow Class See Also Send Feedback

The ListViewHeaderRow type exposes the following members.

Fields

Name | Description
AllowsColumnReorderProperty | Identifies the AllowsColumnReorder property.
ColumnHeaderContainerStyleProperty | Identifies the ColumnHeaderContainerStyle property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate property.
ColumnHeaderTemplateSelectorProperty | Identifies the ColumnHeaderTemplateSelector property.

See Also

ListViewHeaderRow Class


AllowsColumnReorderProperty Field

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.AllowsColumnReorderProperty Field
ListViewHeaderRow Class See Also Send Feedback
Identifies the AllowsColumnReorder property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty AllowsColumnReorderProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowsColumnReorderProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AllowsColumnReorderProperty

See Also

ListViewHeaderRow Class


ColumnHeaderContainerStyleProperty Field

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.ColumnHeaderContainerStyleProperty Field
ListViewHeaderRow Class See Also Send Feedback
Identifies the ColumnHeaderContainerStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderContainerStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderContainerStyleProperty

See Also

ListViewHeaderRow Class


ColumnHeaderTemplateProperty Field

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.ColumnHeaderTemplateProperty Field
ListViewHeaderRow Class See Also Send Feedback
Identifies the ColumnHeaderTemplate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderTemplateProperty

See Also

ListViewHeaderRow Class


ColumnHeaderTemplateSelectorProperty Field

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.ColumnHeaderTemplateSelectorProperty Field
ListViewHeaderRow Class See Also Send Feedback
Identifies the ColumnHeaderTemplateSelector property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderTemplateSelectorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderTemplateSelectorProperty

See Also

ListViewHeaderRow Class


ListViewHeaderRow Methods

[image] [image]

Mindscape Silverlight Elements
ListViewHeaderRow Methods
ListViewHeaderRow Class See Also Send Feedback

The ListViewHeaderRow type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnColumnsChanged | Called by the framework when the Columns property changes. (Inherited from ListViewItemBase.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | (Inherited from ListBoxItem.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ListViewHeaderRow Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.OnPropertyChanged Method
ListViewHeaderRow Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String
The name of the property that changed.

See Also

ListViewHeaderRow Class


ListViewHeaderRow Properties

[image] [image]

Mindscape Silverlight Elements
ListViewHeaderRow Properties
ListViewHeaderRow Class See Also Send Feedback

The ListViewHeaderRow type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowsColumnReorder | Gets or sets whether the user can reorder columns. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ColumnDropRequestPosition | Gets the position at which a column is being dropped, if column reordering is in progress.
ColumnHeaderContainerStyle | Gets or sets the Style applied to column headers. This is a dependency property.
ColumnHeaderTemplate | Gets or sets the DataTemplate for the column headers. This is a dependency property.
ColumnHeaderTemplateSelector | Gets or sets the DataTemplateSelector for the column headers. This is a dependency property.
Columns | Gets or sets the columns associated with the ListViewItemBase. This is a dependency property. (Inherited from ListViewItemBase.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsRequestingColumnDropPosition | Gets whether a column reordering is in progress.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ListViewHeaderRow Class


AllowsColumnReorder Property

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.AllowsColumnReorder Property
ListViewHeaderRow Class See Also Send Feedback
Gets or sets whether the user can reorder columns. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowsColumnReorder { get; set; }
Visual Basic (Declaration)
Public Property AllowsColumnReorder As Boolean
Visual C++
public:
property bool AllowsColumnReorder {
    bool get ();
    void set (bool value);
}

Remarks

Dependency Property Information
Identifier field | AllowsColumnReorderProperty
Metadata properties set to true | None

See Also

ListViewHeaderRow Class


ColumnDropRequestPosition Property

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.ColumnDropRequestPosition Property
ListViewHeaderRow Class See Also Send Feedback
Gets the position at which a column is being dropped, if column reordering is in progress.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ColumnDropRequestPosition { get; internal set; }
Visual Basic (Declaration)
Public Property ColumnDropRequestPosition As Double
Visual C++
public:
property double ColumnDropRequestPosition {
    double get ();
    void set (double value);
}

See Also

ListViewHeaderRow Class


ColumnHeaderContainerStyle Property

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.ColumnHeaderContainerStyle Property
ListViewHeaderRow Class See Also Send Feedback
Gets or sets the Style applied to column headers. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style ColumnHeaderContainerStyle { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderContainerStyle As Style
Visual C++
public:
property Style^ ColumnHeaderContainerStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnHeaderContainerStyleProperty
Metadata properties set to true | None

See Also

ListViewHeaderRow Class


ColumnHeaderTemplate Property

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.ColumnHeaderTemplate Property
ListViewHeaderRow Class See Also Send Feedback
Gets or sets the DataTemplate for the column headers. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate ColumnHeaderTemplate { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ ColumnHeaderTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnHeaderTemplateProperty
Metadata properties set to true | None

See Also

ListViewHeaderRow Class


ColumnHeaderTemplateSelector Property

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.ColumnHeaderTemplateSelector Property
ListViewHeaderRow Class See Also Send Feedback
Gets or sets the DataTemplateSelector for the column headers. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplateSelector ColumnHeaderTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderTemplateSelector As DataTemplateSelector
Visual C++
public:
property DataTemplateSelector^ ColumnHeaderTemplateSelector {
    DataTemplateSelector^ get ();
    void set (DataTemplateSelector^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnHeaderTemplateSelectorProperty
Metadata properties set to true | None

See Also

ListViewHeaderRow Class


IsRequestingColumnDropPosition Property

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.IsRequestingColumnDropPosition Property
ListViewHeaderRow Class See Also Send Feedback
Gets whether a column reordering is in progress.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsRequestingColumnDropPosition { get; internal set; }
Visual Basic (Declaration)
Public Property IsRequestingColumnDropPosition As Boolean
Visual C++
public:
property bool IsRequestingColumnDropPosition {
    bool get ();
    void set (bool value);
}

See Also

ListViewHeaderRow Class


ListViewHeaderRow Events

[image] [image]

Mindscape Silverlight Elements
ListViewHeaderRow Events
ListViewHeaderRow Class See Also Send Feedback

The ListViewHeaderRow type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListViewHeaderRow Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
ListViewHeaderRow..::.PropertyChanged Event
ListViewHeaderRow Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ListViewHeaderRow Class


ListViewItem Class

[image]

Mindscape Silverlight Elements
ListViewItem Class
Members See Also Send Feedback
Represents an item in a ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ListViewItem : ListViewItemBase,
    INotifyPropertyChanged, IMouseWheelObserver, IDoubleClickObserver
Visual Basic (Declaration)
Public Class ListViewItem _
    Inherits ListViewItemBase _
    Implements INotifyPropertyChanged, IMouseWheelObserver, IDoubleClickObserver
Visual C++
public ref class ListViewItem : public ListViewItemBase,
    INotifyPropertyChanged, IMouseWheelObserver, IDoubleClickObserver

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.SilverlightElements..::.ListViewItemBase
Mindscape.SilverlightElements..::.ListViewItem

See Also

ListViewItem Members


ListViewItem Members

[image] [image]

Mindscape Silverlight Elements
ListViewItem Members
ListViewItem Class Constructors Methods Fields Properties Events See Also Send Feedback

The ListViewItem type exposes the following members.

Constructors

Name | Description
ListViewItem | Initializes a new instance of the ListViewItem class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnColumnsChanged | Called by the framework when the Columns property changes. (Overrides ListViewItemBase..::.OnColumnsChanged()()().)
OnContentChanged | Called by the framework when the Content property changes. (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ListBoxItem..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AlternativeFirstCellContentProperty | Identifies the AlternativeFirstCellContent property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AlternativeFirstCellContent | Gets or sets an item which replaces the content in the first column. This is typically used to provide decorators for the first column. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Columns | Gets or sets the columns associated with the ListViewItemBase. This is a dependency property. (Inherited from ListViewItemBase.)
Content | (Inherited from ContentControl.)
ContentColumnList | Gets the mapping of content data to columns.
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FirstColumnWidth | Gets the width of the first column.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListViewItem Class


ListViewItem Constructor

[image]

Mindscape Silverlight Elements
ListViewItem Constructor
ListViewItem Class See Also Send Feedback
Initializes a new instance of the ListViewItem class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ListViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ListViewItem()

See Also

ListViewItem Class


ListViewItem Fields

[image] [image]

Mindscape Silverlight Elements
ListViewItem Fields
ListViewItem Class See Also Send Feedback

The ListViewItem type exposes the following members.

Fields

Name | Description
AlternativeFirstCellContentProperty | Identifies the AlternativeFirstCellContent property.

See Also

ListViewItem Class


AlternativeFirstCellContentProperty Field

[image]

Mindscape Silverlight Elements
ListViewItem..::.AlternativeFirstCellContentProperty Field
ListViewItem Class See Also Send Feedback
Identifies the AlternativeFirstCellContent property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty AlternativeFirstCellContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly AlternativeFirstCellContentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AlternativeFirstCellContentProperty

See Also

ListViewItem Class


ListViewItem Methods

[image] [image]

Mindscape Silverlight Elements
ListViewItem Methods
ListViewItem Class See Also Send Feedback

The ListViewItem type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnColumnsChanged | Called by the framework when the Columns property changes. (Overrides ListViewItemBase..::.OnColumnsChanged()()().)
OnContentChanged | Called by the framework when the Content property changes. (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ListBoxItem..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ListViewItem Class


OnColumnsChanged Method

[image]

Mindscape Silverlight Elements
ListViewItem..::.OnColumnsChanged Method
ListViewItem Class See Also Send Feedback
Called by the framework when the Columns property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnColumnsChanged()
Visual Basic (Declaration)
Protected Overrides Sub OnColumnsChanged
Visual C++
protected:
virtual void OnColumnsChanged() override

See Also

ListViewItem Class


OnContentChanged Method

[image]

Mindscape Silverlight Elements
ListViewItem..::.OnContentChanged Method
ListViewItem Class See Also Send Feedback
Called by the framework when the Content property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)
Visual C++
protected:
virtual void OnContentChanged(
    Object^ oldContent,
    Object^ newContent
) override

Parameters

oldContent
Type: System..::.Object
The old content.
newContent
Type: System..::.Object
The new content.

See Also

ListViewItem Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
ListViewItem..::.OnMouseLeftButtonDown Method
ListViewItem Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

ListViewItem Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
ListViewItem..::.OnPropertyChanged Method
ListViewItem Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

ListViewItem Class


ListViewItem Properties

[image] [image]

Mindscape Silverlight Elements
ListViewItem Properties
ListViewItem Class See Also Send Feedback

The ListViewItem type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AlternativeFirstCellContent | Gets or sets an item which replaces the content in the first column. This is typically used to provide decorators for the first column. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Columns | Gets or sets the columns associated with the ListViewItemBase. This is a dependency property. (Inherited from ListViewItemBase.)
Content | (Inherited from ContentControl.)
ContentColumnList | Gets the mapping of content data to columns.
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FirstColumnWidth | Gets the width of the first column.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ListViewItem Class


AlternativeFirstCellContent Property

[image]

Mindscape Silverlight Elements
ListViewItem..::.AlternativeFirstCellContent Property
ListViewItem Class See Also Send Feedback
Gets or sets an item which replaces the content in the first column. This is typically used to provide decorators for the first column. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object AlternativeFirstCellContent { get; set; }
Visual Basic (Declaration)
Public Property AlternativeFirstCellContent As Object
Visual C++
public:
property Object^ AlternativeFirstCellContent {
    Object^ get ();
    void set (Object^ value);
}

Remarks

Dependency Property Information
Identifier field | AlternativeFirstCellContentProperty
Metadata properties set to true | None

See Also

ListViewItem Class


ContentColumnList Property

[image]

Mindscape Silverlight Elements
ListViewItem..::.ContentColumnList Property
ListViewItem Class See Also Send Feedback
Gets the mapping of content data to columns.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<ContentColumnMapping> ContentColumnList { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentColumnList As ReadOnlyCollection(Of ContentColumnMapping)
Visual C++
public:
property ReadOnlyCollection<ContentColumnMapping^>^ ContentColumnList {
    ReadOnlyCollection<ContentColumnMapping^>^ get ();
}

See Also

ListViewItem Class


FirstColumnWidth Property

[image]

Mindscape Silverlight Elements
ListViewItem..::.FirstColumnWidth Property
ListViewItem Class See Also Send Feedback
Gets the width of the first column.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double FirstColumnWidth { get; private set; }
Visual Basic (Declaration)
Public Property FirstColumnWidth As Double
Visual C++
public:
property double FirstColumnWidth {
    double get ();
    void set (double value);
}

See Also

ListViewItem Class


ListViewItem Events

[image] [image]

Mindscape Silverlight Elements
ListViewItem Events
ListViewItem Class See Also Send Feedback

The ListViewItem type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListViewItem Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
ListViewItem..::.PropertyChanged Event
ListViewItem Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

Remarks

The PropertyChanged event is not raised for all properties on this class.

See Also

ListViewItem Class


ListViewItemBase Class

[image]

Mindscape Silverlight Elements
ListViewItemBase Class
Members See Also Send Feedback
Represents an item in a ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ListViewItemBase : ListBoxItem
Visual Basic (Declaration)
Public MustInherit Class ListViewItemBase _
    Inherits ListBoxItem
Visual C++
public ref class ListViewItemBase abstract : public ListBoxItem

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.SilverlightElements..::.ListViewItemBase
Mindscape.SilverlightElements..::.ListViewHeaderRow
Mindscape.SilverlightElements..::.ListViewItem

See Also

ListViewItemBase Members


ListViewItemBase Members

[image] [image]

Mindscape Silverlight Elements
ListViewItemBase Members
ListViewItemBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The ListViewItemBase type exposes the following members.

Constructors

Name | Description
ListViewItemBase | Initializes a new instance of the ListViewItemBase class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnColumnsChanged | Called by the framework when the Columns property changes.
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | (Inherited from ListBoxItem.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ColumnsProperty | Identifies the Columns property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Columns | Gets or sets the columns associated with the ListViewItemBase. This is a dependency property.
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListViewItemBase Class


ListViewItemBase Constructor

[image]

Mindscape Silverlight Elements
ListViewItemBase Constructor
ListViewItemBase Class See Also Send Feedback
Initializes a new instance of the ListViewItemBase class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ListViewItemBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ListViewItemBase()

See Also

ListViewItemBase Class


ListViewItemBase Fields

[image] [image]

Mindscape Silverlight Elements
ListViewItemBase Fields
ListViewItemBase Class See Also Send Feedback

The ListViewItemBase type exposes the following members.

Fields

Name | Description
ColumnsProperty | Identifies the Columns property.

See Also

ListViewItemBase Class


ColumnsProperty Field

[image]

Mindscape Silverlight Elements
ListViewItemBase..::.ColumnsProperty Field
ListViewItemBase Class See Also Send Feedback
Identifies the Columns property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnsProperty

See Also

ListViewItemBase Class


ListViewItemBase Methods

[image] [image]

Mindscape Silverlight Elements
ListViewItemBase Methods
ListViewItemBase Class See Also Send Feedback

The ListViewItemBase type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnColumnsChanged | Called by the framework when the Columns property changes.
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | (Inherited from ListBoxItem.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ListViewItemBase Class


OnColumnsChanged Method

[image]

Mindscape Silverlight Elements
ListViewItemBase..::.OnColumnsChanged Method
ListViewItemBase Class See Also Send Feedback
Called by the framework when the Columns property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnColumnsChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnColumnsChanged
Visual C++
protected:
virtual void OnColumnsChanged()

See Also

ListViewItemBase Class


ListViewItemBase Properties

[image] [image]

Mindscape Silverlight Elements
ListViewItemBase Properties
ListViewItemBase Class See Also Send Feedback

The ListViewItemBase type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Columns | Gets or sets the columns associated with the ListViewItemBase. This is a dependency property.
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ListViewItemBase Class


Columns Property

[image]

Mindscape Silverlight Elements
ListViewItemBase..::.Columns Property
ListViewItemBase Class See Also Send Feedback
Gets or sets the columns associated with the ListViewItemBase. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnCollection Columns { get; set; }
Visual Basic (Declaration)
Public Property Columns As GridViewColumnCollection
Visual C++
public:
property GridViewColumnCollection^ Columns {
    GridViewColumnCollection^ get ();
    void set (GridViewColumnCollection^ value);
}

Remarks

Dependency Property Information
Identifier field | ColumnsProperty
Metadata properties set to true | None

See Also

ListViewItemBase Class


ListViewItemBase Events

[image] [image]

Mindscape Silverlight Elements
ListViewItemBase Events
ListViewItemBase Class See Also Send Feedback

The ListViewItemBase type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ListViewItemBase Class


MinuteOfHourBrushConverter Class

[image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter Class
Members See Also Send Feedback
Selects a brush according to whether a minutes value is on the hour or not.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MinuteOfHourBrushConverter : IValueConverter
Visual Basic (Declaration)
Public Class MinuteOfHourBrushConverter _
    Implements IValueConverter
Visual C++
public ref class MinuteOfHourBrushConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.MinuteOfHourBrushConverter

See Also

MinuteOfHourBrushConverter Members


MinuteOfHourBrushConverter Members

[image] [image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter Members
MinuteOfHourBrushConverter Class Constructors Methods Properties See Also Send Feedback

The MinuteOfHourBrushConverter type exposes the following members.

Constructors

Name | Description
MinuteOfHourBrushConverter | Initializes a new instance of the MinuteOfHourBrushConverter class

Methods

Name | Description
Convert | Selects a brush according to whether the input value is on the hour or not.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DefaultBrush | Gets or sets the brush to use if the minutes value is not 0.
OnTheHourBrush | Gets or sets the brush to use if the minutes value is 0.

See Also

MinuteOfHourBrushConverter Class


MinuteOfHourBrushConverter Constructor

[image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter Constructor
MinuteOfHourBrushConverter Class See Also Send Feedback
Initializes a new instance of the MinuteOfHourBrushConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MinuteOfHourBrushConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MinuteOfHourBrushConverter()

See Also

MinuteOfHourBrushConverter Class


MinuteOfHourBrushConverter Methods

[image] [image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter Methods
MinuteOfHourBrushConverter Class See Also Send Feedback

The MinuteOfHourBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Selects a brush according to whether the input value is on the hour or not.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MinuteOfHourBrushConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter..::.Convert Method
MinuteOfHourBrushConverter Class See Also Send Feedback
Selects a brush according to whether the input value is on the hour or not.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The integer value, representing a number of minutes, produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The selected brush.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

MinuteOfHourBrushConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter..::.ConvertBack Method
MinuteOfHourBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

MinuteOfHourBrushConverter Class


MinuteOfHourBrushConverter Properties

[image] [image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter Properties
MinuteOfHourBrushConverter Class See Also Send Feedback

The MinuteOfHourBrushConverter type exposes the following members.

Properties

Name | Description
DefaultBrush | Gets or sets the brush to use if the minutes value is not 0.
OnTheHourBrush | Gets or sets the brush to use if the minutes value is 0.

See Also

MinuteOfHourBrushConverter Class


DefaultBrush Property

[image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter..::.DefaultBrush Property
MinuteOfHourBrushConverter Class See Also Send Feedback
Gets or sets the brush to use if the minutes value is not 0.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush DefaultBrush { get; set; }
Visual Basic (Declaration)
Public Property DefaultBrush As Brush
Visual C++
public:
property Brush^ DefaultBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

MinuteOfHourBrushConverter Class


OnTheHourBrush Property

[image]

Mindscape Silverlight Elements
MinuteOfHourBrushConverter..::.OnTheHourBrush Property
MinuteOfHourBrushConverter Class See Also Send Feedback
Gets or sets the brush to use if the minutes value is 0.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush OnTheHourBrush { get; set; }
Visual Basic (Declaration)
Public Property OnTheHourBrush As Brush
Visual C++
public:
property Brush^ OnTheHourBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

MinuteOfHourBrushConverter Class


MonthlyPatternRecurrencePattern Class

[image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on a monthly schedule defined by a pattern (e.g. last Friday of every second month).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MonthlyPatternRecurrencePattern : MonthlyRecurrencePattern
Visual Basic (Declaration)
Public Class MonthlyPatternRecurrencePattern _
    Inherits MonthlyRecurrencePattern
Visual C++
public ref class MonthlyPatternRecurrencePattern : public MonthlyRecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.MonthlyRecurrencePattern
Mindscape.SilverlightElements..::.MonthlyPatternRecurrencePattern

See Also

MonthlyPatternRecurrencePattern Members


MonthlyPatternRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern Members
MonthlyPatternRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The MonthlyPatternRecurrencePattern type exposes the following members.

Constructors

Name | Description
MonthlyPatternRecurrencePattern | Initializes a new instance of the MonthlyPatternRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
IncludesCore | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides MonthlyRecurrencePattern..::.IncludesCore(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DayOfRecurrence | Gets the days counted by Occurrence (e.g. weekdays, Fridays).
MonthlyInterval | Gets the number of months between recurrences. (Inherited from MonthlyRecurrencePattern.)
Occurrence | Gets which occurrence of the DayOfRecurrence the item recurs on (e.g. first, last).

See Also

MonthlyPatternRecurrencePattern Class


MonthlyPatternRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern Constructor
MonthlyPatternRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the MonthlyPatternRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthlyPatternRecurrencePattern(
    int monthlyInterval,
    Occurrence occurrence,
    DayOfRecurrence dayOfRecurrence
)
Visual Basic (Declaration)
Public Sub New ( _
    monthlyInterval As Integer, _
    occurrence As Occurrence, _
    dayOfRecurrence As DayOfRecurrence _
)
Visual C++
public:
MonthlyPatternRecurrencePattern(
    int monthlyInterval,
    Occurrence occurrence,
    DayOfRecurrence dayOfRecurrence
)

Parameters

monthlyInterval
Type: System..::.Int32
The number of months between recurrences.
occurrence
Type: Mindscape.SilverlightElements..::.Occurrence
Which occurrence of the dayOfRecurrence the item recurs on (e.g. first, last).
dayOfRecurrence
Type: Mindscape.SilverlightElements..::.DayOfRecurrence
The days counted by occurrence (e.g. weekdays, Fridays).

See Also

MonthlyPatternRecurrencePattern Class


MonthlyPatternRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern Methods
MonthlyPatternRecurrencePattern Class See Also Send Feedback

The MonthlyPatternRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
IncludesCore | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides MonthlyRecurrencePattern..::.IncludesCore(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthlyPatternRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern..::.Includes Method
MonthlyPatternRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from MonthlyRecurrencePattern.)

See Also

MonthlyPatternRecurrencePattern Class
MonthlyPatternRecurrencePattern Members


IncludesCore Method

[image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern..::.IncludesCore Method
MonthlyPatternRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool IncludesCore(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function IncludesCore ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool IncludesCore(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

MonthlyPatternRecurrencePattern Class


MonthlyPatternRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern Properties
MonthlyPatternRecurrencePattern Class See Also Send Feedback

The MonthlyPatternRecurrencePattern type exposes the following members.

Properties

Name | Description
DayOfRecurrence | Gets the days counted by Occurrence (e.g. weekdays, Fridays).
MonthlyInterval | Gets the number of months between recurrences. (Inherited from MonthlyRecurrencePattern.)
Occurrence | Gets which occurrence of the DayOfRecurrence the item recurs on (e.g. first, last).

See Also

MonthlyPatternRecurrencePattern Class


DayOfRecurrence Property

[image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern..::.DayOfRecurrence Property
MonthlyPatternRecurrencePattern Class See Also Send Feedback
Gets the days counted by Occurrence (e.g. weekdays, Fridays).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayOfRecurrence DayOfRecurrence { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayOfRecurrence As DayOfRecurrence
Visual C++
public:
property DayOfRecurrence DayOfRecurrence {
    DayOfRecurrence get ();
}

See Also

MonthlyPatternRecurrencePattern Class


Occurrence Property

[image]

Mindscape Silverlight Elements
MonthlyPatternRecurrencePattern..::.Occurrence Property
MonthlyPatternRecurrencePattern Class See Also Send Feedback
Gets which occurrence of the DayOfRecurrence the item recurs on (e.g. first, last).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Occurrence Occurrence { get; }
Visual Basic (Declaration)
Public ReadOnly Property Occurrence As Occurrence
Visual C++
public:
property Occurrence Occurrence {
    Occurrence get ();
}

See Also

MonthlyPatternRecurrencePattern Class


MonthlyRecurrencePattern Class

[image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on a monthly basis.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class MonthlyRecurrencePattern : RecurrencePattern
Visual Basic (Declaration)
Public MustInherit Class MonthlyRecurrencePattern _
    Inherits RecurrencePattern
Visual C++
public ref class MonthlyRecurrencePattern abstract : public RecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.MonthlyRecurrencePattern
Mindscape.SilverlightElements..::.MonthlyPatternRecurrencePattern
Mindscape.SilverlightElements..::.NthDayOfMonthRecurrencePattern

See Also

MonthlyRecurrencePattern Members


MonthlyRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern Members
MonthlyRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The MonthlyRecurrencePattern type exposes the following members.

Constructors

Name | Description
MonthlyRecurrencePattern | Initializes a new instance of the MonthlyRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
IncludesCore | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MonthlyInterval | Gets the number of months between recurrences.

See Also

MonthlyRecurrencePattern Class


MonthlyRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern Constructor
MonthlyRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the MonthlyRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected MonthlyRecurrencePattern(
    int monthlyInterval
)
Visual Basic (Declaration)
Protected Sub New ( _
    monthlyInterval As Integer _
)
Visual C++
protected:
MonthlyRecurrencePattern(
    int monthlyInterval
)

Parameters

monthlyInterval
Type: System..::.Int32
The number of months between recurrences.

See Also

MonthlyRecurrencePattern Class


MonthlyRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern Methods
MonthlyRecurrencePattern Class See Also Send Feedback

The MonthlyRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
IncludesCore | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonthlyRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern..::.Includes Method
MonthlyRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides RecurrencePattern..::.Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)

See Also

MonthlyRecurrencePattern Class
MonthlyRecurrencePattern Members


Includes Method (DateTime, DateTime, Boolean, Nullable(Int32))

[image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern..::.Includes Method (DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>))
MonthlyRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

MonthlyRecurrencePattern Class
Includes Overload


IncludesCore Method

[image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern..::.IncludesCore Method
MonthlyRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract bool IncludesCore(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected MustOverride Function IncludesCore ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool IncludesCore(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) abstract

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

MonthlyRecurrencePattern Class


MonthlyRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern Properties
MonthlyRecurrencePattern Class See Also Send Feedback

The MonthlyRecurrencePattern type exposes the following members.

Properties

Name | Description
MonthlyInterval | Gets the number of months between recurrences.

See Also

MonthlyRecurrencePattern Class


MonthlyInterval Property

[image]

Mindscape Silverlight Elements
MonthlyRecurrencePattern..::.MonthlyInterval Property
MonthlyRecurrencePattern Class See Also Send Feedback
Gets the number of months between recurrences.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int MonthlyInterval { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonthlyInterval As Integer
Visual C++
public:
property int MonthlyInterval {
    int get ();
}

See Also

MonthlyRecurrencePattern Class


MonthView Class

[image]

Mindscape Silverlight Elements
MonthView Class
Members See Also Send Feedback
Represents a month view in a Scheduler control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MonthView : ScheduleView
Visual Basic (Declaration)
Public Class MonthView _
    Inherits ScheduleView
Visual C++
public ref class MonthView : public ScheduleView

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ScheduleView
Mindscape.SilverlightElements..::.MonthView

See Also

MonthView Members


MonthView Members

[image] [image]

Mindscape Silverlight Elements
MonthView Members
MonthView Class Constructors Methods Properties Events See Also Send Feedback

The MonthView type exposes the following members.

Constructors

Name | Description
MonthView | Overloaded.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | Cancels tha addition of the specified item. (Overrides ScheduleView..::.CancelAdd(ScheduleItem).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | Adds a new schedule item at the current selection. (Overrides ScheduleView..::.CreateScheduleItemForAdd()()().)
DecrementView | Moves the view to the previous month. (Overrides ScheduleView..::.DecrementView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | Gets a suitable start date for the control to display the requested date. (Overrides ScheduleView..::.GetStartDateContaining(DateTime).)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view to the next month. (Overrides ScheduleView..::.IncrementView()()().)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range. (Inherited from ScheduleView.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ScheduleView.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection. (Inherited from ScheduleView.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title. (Inherited from ScheduleView.)
DateRangeDisplayMode | Gets how to format dates in the view title. (Overrides ScheduleView..::.DateRangeDisplayMode.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view. (Overrides ScheduleView..::.EndDate.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled. (Inherited from ScheduleView.)
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled. (Inherited from ScheduleView.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Month | Gets the month being displayed.
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week). (Inherited from ScheduleView.)
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view. (Inherited from ScheduleView.)
Now | Gets the current date and time. (Inherited from ScheduleView.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week). (Inherited from ScheduleView.)
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view. (Inherited from ScheduleView.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed. (Inherited from ScheduleView.)
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item). (Inherited from ScheduleView.)
StartDate | Gets or sets the start date of the view. (Overrides ScheduleView..::.StartDate.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day. (Inherited from ScheduleView.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes. (Inherited from ScheduleView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MonthView Class


MonthView Constructor

[image] [image]

Mindscape Silverlight Elements
MonthView Constructor
MonthView Class See Also Send Feedback

Overload List

Name | Description
MonthView()()() | Initializes a new instance of the MonthView class.
MonthView(Schedule) | Initializes a new instance of the MonthView class.
MonthView(Schedule, DateTime) | Initializes a new instance of the MonthView class.

See Also

MonthView Class
MonthView Members


MonthView Constructor

[image]

Mindscape Silverlight Elements
MonthView Constructor
MonthView Class See Also Send Feedback
Initializes a new instance of the MonthView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MonthView()

See Also

MonthView Class
MonthView Overload


MonthView Constructor (Schedule)

[image]

Mindscape Silverlight Elements
MonthView Constructor (Schedule)
MonthView Class See Also Send Feedback
Initializes a new instance of the MonthView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthView(
    Schedule schedule
)
Visual Basic (Declaration)
Public Sub New ( _
    schedule As Schedule _
)
Visual C++
public:
MonthView(
    Schedule^ schedule
)

Parameters

schedule
Type: Mindscape.SilverlightElements..::.Schedule
The Schedule to be displayed.

See Also

MonthView Class
MonthView Overload


MonthView Constructor (Schedule, DateTime)

[image]

Mindscape Silverlight Elements
MonthView Constructor (Schedule, DateTime)
MonthView Class See Also Send Feedback
Initializes a new instance of the MonthView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthView(
    Schedule schedule,
    DateTime startDate
)
Visual Basic (Declaration)
Public Sub New ( _
    schedule As Schedule, _
    startDate As DateTime _
)
Visual C++
public:
MonthView(
    Schedule^ schedule,
    DateTime startDate
)

Parameters

schedule
Type: Mindscape.SilverlightElements..::.Schedule
The Schedule to be displayed.
startDate
Type: System..::.DateTime
The start date for the display.

See Also

MonthView Class
MonthView Overload


MonthView Methods

[image] [image]

Mindscape Silverlight Elements
MonthView Methods
MonthView Class See Also Send Feedback

The MonthView type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | Cancels tha addition of the specified item. (Overrides ScheduleView..::.CancelAdd(ScheduleItem).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | Adds a new schedule item at the current selection. (Overrides ScheduleView..::.CreateScheduleItemForAdd()()().)
DecrementView | Moves the view to the previous month. (Overrides ScheduleView..::.DecrementView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | Gets a suitable start date for the control to display the requested date. (Overrides ScheduleView..::.GetStartDateContaining(DateTime).)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view to the next month. (Overrides ScheduleView..::.IncrementView()()().)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range. (Inherited from ScheduleView.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ScheduleView.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

MonthView Class


CancelAdd Method

[image]

Mindscape Silverlight Elements
MonthView..::.CancelAdd Method
MonthView Class See Also Send Feedback
Cancels tha addition of the specified item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void CancelAdd(
    ScheduleItem item
)
Visual Basic (Declaration)
Protected Overrides Sub CancelAdd ( _
    item As ScheduleItem _
)
Visual C++
protected:
virtual void CancelAdd(
    ScheduleItem^ item
) override

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to cancel.

See Also

MonthView Class


CreateScheduleItemForAdd Method

[image]

Mindscape Silverlight Elements
MonthView..::.CreateScheduleItemForAdd Method
MonthView Class See Also Send Feedback
Adds a new schedule item at the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override ScheduleItem CreateScheduleItemForAdd()
Visual Basic (Declaration)
Protected Overrides Function CreateScheduleItemForAdd As ScheduleItem
Visual C++
protected:
virtual ScheduleItem^ CreateScheduleItemForAdd() override

Return Value

The new item.

See Also

MonthView Class


DecrementView Method

[image]

Mindscape Silverlight Elements
MonthView..::.DecrementView Method
MonthView Class See Also Send Feedback
Moves the view to the previous month.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void DecrementView()
Visual Basic (Declaration)
Public Overrides Sub DecrementView
Visual C++
public:
virtual void DecrementView() override

See Also

MonthView Class


GetStartDateContaining Method

[image]

Mindscape Silverlight Elements
MonthView..::.GetStartDateContaining Method
MonthView Class See Also Send Feedback
Gets a suitable start date for the control to display the requested date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime GetStartDateContaining(
    DateTime date
)
Visual Basic (Declaration)
Protected Overrides Function GetStartDateContaining ( _
    date As DateTime _
) As DateTime
Visual C++
protected:
virtual DateTime GetStartDateContaining(
    DateTime date
) override

Parameters

date
Type: System..::.DateTime
The date to be displayed.

Return Value

A start date for the view that will cause this date to be displayed.

See Also

MonthView Class


IncrementView Method

[image]

Mindscape Silverlight Elements
MonthView..::.IncrementView Method
MonthView Class See Also Send Feedback
Moves the view to the next month.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void IncrementView()
Visual Basic (Declaration)
Public Overrides Sub IncrementView
Visual C++
public:
virtual void IncrementView() override

See Also

MonthView Class


MonthView Properties

[image] [image]

Mindscape Silverlight Elements
MonthView Properties
MonthView Class See Also Send Feedback

The MonthView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection. (Inherited from ScheduleView.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title. (Inherited from ScheduleView.)
DateRangeDisplayMode | Gets how to format dates in the view title. (Overrides ScheduleView..::.DateRangeDisplayMode.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view. (Overrides ScheduleView..::.EndDate.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled. (Inherited from ScheduleView.)
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled. (Inherited from ScheduleView.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Month | Gets the month being displayed.
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week). (Inherited from ScheduleView.)
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view. (Inherited from ScheduleView.)
Now | Gets the current date and time. (Inherited from ScheduleView.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week). (Inherited from ScheduleView.)
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view. (Inherited from ScheduleView.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed. (Inherited from ScheduleView.)
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item). (Inherited from ScheduleView.)
StartDate | Gets or sets the start date of the view. (Overrides ScheduleView..::.StartDate.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day. (Inherited from ScheduleView.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

MonthView Class


DateRangeDisplayMode Property

[image]

Mindscape Silverlight Elements
MonthView..::.DateRangeDisplayMode Property
MonthView Class See Also Send Feedback
Gets how to format dates in the view title.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateDisplayMode DateRangeDisplayMode { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DateRangeDisplayMode As DateDisplayMode
Visual C++
protected:
virtual property DateDisplayMode DateRangeDisplayMode {
    DateDisplayMode get () override;
}

See Also

MonthView Class


EndDate Property

[image]

Mindscape Silverlight Elements
MonthView..::.EndDate Property
MonthView Class See Also Send Feedback
Gets the end date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime EndDate { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property EndDate As DateTime
Visual C++
protected:
virtual property DateTime EndDate {
    DateTime get () override;
}

See Also

MonthView Class


Month Property

[image]

Mindscape Silverlight Elements
MonthView..::.Month Property
MonthView Class See Also Send Feedback
Gets the month being displayed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthModel Month { get; private set; }
Visual Basic (Declaration)
Public Property Month As MonthModel
Visual C++
public:
property MonthModel^ Month {
    MonthModel^ get ();
    void set (MonthModel^ value);
}

See Also

MonthView Class


StartDate Property

[image]

Mindscape Silverlight Elements
MonthView..::.StartDate Property
MonthView Class See Also Send Feedback
Gets or sets the start date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Overrides Property StartDate As DateTime
Visual C++
public:
virtual property DateTime StartDate {
    DateTime get () override;
    void set (DateTime value) override;
}

See Also

MonthView Class


MonthView Events

[image] [image]

Mindscape Silverlight Elements
MonthView Events
MonthView Class See Also Send Feedback

The MonthView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes. (Inherited from ScheduleView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MonthView Class


MonthViewDayElement Class

[image]

Mindscape Silverlight Elements
MonthViewDayElement Class
Members See Also Send Feedback
Displays a single day in the month view of a Scheduler.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MonthViewDayElement : ListBoxItem,
    INotifyPropertyChanged, IDoubleClickObserver
Visual Basic (Declaration)
Public Class MonthViewDayElement _
    Inherits ListBoxItem _
    Implements INotifyPropertyChanged, IDoubleClickObserver
Visual C++
public ref class MonthViewDayElement : public ListBoxItem,
    INotifyPropertyChanged, IDoubleClickObserver

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.SilverlightElements..::.MonthViewDayElement

See Also

MonthViewDayElement Members


MonthViewDayElement Members

[image] [image]

Mindscape Silverlight Elements
MonthViewDayElement Members
MonthViewDayElement Class Methods Properties Events See Also Send Feedback

The MonthViewDayElement type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | Called by the framework when the mouse enters the control. (Overrides ListBoxItem..::.OnMouseEnter(MouseEventArgs).)
OnMouseLeave | Called by the framework when the mouse leaves the control. (Overrides ListBoxItem..::.OnMouseLeave(MouseEventArgs).)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ListBoxItem..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BelongsToTargetMonth | Gets whether the represented day belongs to the month being displayed.
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Day | Gets the day represented by this MonthViewDayElement.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasOverflowItems | Gets whether the control contains more ScheduleItem objects than it can render.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewDetailsCommand | Gets a command for viewing the details of the day that is represented.
ViewStatus | Gets display information for the MonthViewDayElement.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonPressed | Raised when the user clicks the mouse button.
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

MonthViewDayElement Class


MonthViewDayElement Methods

[image] [image]

Mindscape Silverlight Elements
MonthViewDayElement Methods
MonthViewDayElement Class See Also Send Feedback

The MonthViewDayElement type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | Called by the framework when the mouse enters the control. (Overrides ListBoxItem..::.OnMouseEnter(MouseEventArgs).)
OnMouseLeave | Called by the framework when the mouse leaves the control. (Overrides ListBoxItem..::.OnMouseLeave(MouseEventArgs).)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ListBoxItem..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

MonthViewDayElement Class


OnMouseEnter Method

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.OnMouseEnter Method
MonthViewDayElement Class See Also Send Feedback
Called by the framework when the mouse enters the control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseEnter(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseEnter ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseEnter(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The mouse event data.

See Also

MonthViewDayElement Class


OnMouseLeave Method

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.OnMouseLeave Method
MonthViewDayElement Class See Also Send Feedback
Called by the framework when the mouse leaves the control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The mouse event data.

See Also

MonthViewDayElement Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.OnMouseLeftButtonDown Method
MonthViewDayElement Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

MonthViewDayElement Class


OnMouseLeftButtonUp Method

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.OnMouseLeftButtonUp Method
MonthViewDayElement Class See Also Send Feedback
Called by the framework when the user releases the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

MonthViewDayElement Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.OnPropertyChanged Method
MonthViewDayElement Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

MonthViewDayElement Class


MonthViewDayElement Properties

[image] [image]

Mindscape Silverlight Elements
MonthViewDayElement Properties
MonthViewDayElement Class See Also Send Feedback

The MonthViewDayElement type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BelongsToTargetMonth | Gets whether the represented day belongs to the month being displayed.
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Day | Gets the day represented by this MonthViewDayElement.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasOverflowItems | Gets whether the control contains more ScheduleItem objects than it can render.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewDetailsCommand | Gets a command for viewing the details of the day that is represented.
ViewStatus | Gets display information for the MonthViewDayElement.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

MonthViewDayElement Class


BelongsToTargetMonth Property

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.BelongsToTargetMonth Property
MonthViewDayElement Class See Also Send Feedback
Gets whether the represented day belongs to the month being displayed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool BelongsToTargetMonth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BelongsToTargetMonth As Boolean
Visual C++
public:
property bool BelongsToTargetMonth {
    bool get ();
}

See Also

MonthViewDayElement Class


Day Property

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.Day Property
MonthViewDayElement Class See Also Send Feedback
Gets the day represented by this MonthViewDayElement.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayModel Day { get; }
Visual Basic (Declaration)
Public ReadOnly Property Day As DayModel
Visual C++
public:
property DayModel^ Day {
    DayModel^ get ();
}

See Also

MonthViewDayElement Class


HasOverflowItems Property

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.HasOverflowItems Property
MonthViewDayElement Class See Also Send Feedback
Gets whether the control contains more ScheduleItem objects than it can render.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool HasOverflowItems { get; internal set; }
Visual Basic (Declaration)
Public Property HasOverflowItems As Boolean
Visual C++
public:
property bool HasOverflowItems {
    bool get ();
    void set (bool value);
}

See Also

MonthViewDayElement Class


ViewDetailsCommand Property

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.ViewDetailsCommand Property
MonthViewDayElement Class See Also Send Feedback
Gets a command for viewing the details of the day that is represented.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand ViewDetailsCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewDetailsCommand As ICommand
Visual C++
public:
property ICommand^ ViewDetailsCommand {
    ICommand^ get ();
}

See Also

MonthViewDayElement Class


ViewStatus Property

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.ViewStatus Property
MonthViewDayElement Class See Also Send Feedback
Gets display information for the MonthViewDayElement.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ElementViewStatus ViewStatus { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewStatus As ElementViewStatus
Visual C++
public:
property ElementViewStatus ViewStatus {
    ElementViewStatus get ();
}

See Also

MonthViewDayElement Class


MonthViewDayElement Events

[image] [image]

Mindscape Silverlight Elements
MonthViewDayElement Events
MonthViewDayElement Class See Also Send Feedback

The MonthViewDayElement type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonPressed | Raised when the user clicks the mouse button.
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

MonthViewDayElement Class


MouseLeftButtonPressed Event

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.MouseLeftButtonPressed Event
MonthViewDayElement Class See Also Send Feedback
Raised when the user clicks the mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event MouseButtonEventHandler MouseLeftButtonPressed
Visual Basic (Declaration)
Public Event MouseLeftButtonPressed As MouseButtonEventHandler
Visual C++
public:
virtual  event MouseButtonEventHandler^ MouseLeftButtonPressed {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}

Implements

IDoubleClickObserver..::.MouseLeftButtonPressed

See Also

MonthViewDayElement Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
MonthViewDayElement..::.PropertyChanged Event
MonthViewDayElement Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

MonthViewDayElement Class


MouseWheel Class

[image]

Mindscape Silverlight Elements
MouseWheel Class
Members See Also Send Feedback
Provides access to mouse wheel events.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MouseWheel
Visual Basic (Declaration)
Public Class MouseWheel
Visual C++
public ref class MouseWheel

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.MouseWheel

See Also

MouseWheel Members


MouseWheel Members

[image] [image]

Mindscape Silverlight Elements
MouseWheel Members
MouseWheel Class Methods Properties See Also Send Feedback

The MouseWheel type exposes the following members.

Methods

Name | Description
AddObserver | Registers the specified element to receive mouse wheel events.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Instance | The single instance of the MouseWheel class.

See Also

MouseWheel Class


MouseWheel Methods

[image] [image]

Mindscape Silverlight Elements
MouseWheel Methods
MouseWheel Class See Also Send Feedback

The MouseWheel type exposes the following members.

Methods

Name | Description
AddObserver | Registers the specified element to receive mouse wheel events.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheel Class


AddObserver Method

[image]

Mindscape Silverlight Elements
MouseWheel..::.AddObserver Method
MouseWheel Class See Also Send Feedback
Registers the specified element to receive mouse wheel events.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddObserver(
    IMouseWheelObserver element
)
Visual Basic (Declaration)
Public Sub AddObserver ( _
    element As IMouseWheelObserver _
)
Visual C++
public:
void AddObserver(
    IMouseWheelObserver^ element
)

Parameters

element
Type: Mindscape.SilverlightElements..::.IMouseWheelObserver
The element to receive mouse wheel events.

See Also

MouseWheel Class


MouseWheel Properties

[image] [image]

Mindscape Silverlight Elements
MouseWheel Properties
MouseWheel Class See Also Send Feedback

The MouseWheel type exposes the following members.

Properties

Name | Description
Instance | The single instance of the MouseWheel class.

See Also

MouseWheel Class


Instance Property

[image]

Mindscape Silverlight Elements
MouseWheel..::.Instance Property
MouseWheel Class See Also Send Feedback
The single instance of the MouseWheel class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static MouseWheel Instance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As MouseWheel
Visual C++
public:
static property MouseWheel^ Instance {
    MouseWheel^ get ();
}

See Also

MouseWheel Class


MouseWheelEventArgs Class

[image]

Mindscape Silverlight Elements
MouseWheelEventArgs Class
Members See Also Send Feedback
Contains data for mouse wheel events.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MouseWheelEventArgs : EventArgs
Visual Basic (Declaration)
Public Class MouseWheelEventArgs _
    Inherits EventArgs
Visual C++
public ref class MouseWheelEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mindscape.SilverlightElements..::.MouseWheelEventArgs

See Also

MouseWheelEventArgs Members


MouseWheelEventArgs Members

[image] [image]

Mindscape Silverlight Elements
MouseWheelEventArgs Members
MouseWheelEventArgs Class Methods Properties See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AltKey | Gets whether the Alt key was pressed.
CtrlKey | Gets whether the Ctrl key was pressed.
Delta | Gets the mouse wheel delta.
ShiftKey | Gets whether the Shift key was pressed.

See Also

MouseWheelEventArgs Class


MouseWheelEventArgs Methods

[image] [image]

Mindscape Silverlight Elements
MouseWheelEventArgs Methods
MouseWheelEventArgs Class See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheelEventArgs Class


MouseWheelEventArgs Properties

[image] [image]

Mindscape Silverlight Elements
MouseWheelEventArgs Properties
MouseWheelEventArgs Class See Also Send Feedback

The MouseWheelEventArgs type exposes the following members.

Properties

Name | Description
AltKey | Gets whether the Alt key was pressed.
CtrlKey | Gets whether the Ctrl key was pressed.
Delta | Gets the mouse wheel delta.
ShiftKey | Gets whether the Shift key was pressed.

See Also

MouseWheelEventArgs Class


AltKey Property

[image]

Mindscape Silverlight Elements
MouseWheelEventArgs..::.AltKey Property
MouseWheelEventArgs Class See Also Send Feedback
Gets whether the Alt key was pressed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AltKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property AltKey As Boolean
Visual C++
public:
property bool AltKey {
    bool get ();
}

See Also

MouseWheelEventArgs Class


CtrlKey Property

[image]

Mindscape Silverlight Elements
MouseWheelEventArgs..::.CtrlKey Property
MouseWheelEventArgs Class See Also Send Feedback
Gets whether the Ctrl key was pressed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CtrlKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property CtrlKey As Boolean
Visual C++
public:
property bool CtrlKey {
    bool get ();
}

See Also

MouseWheelEventArgs Class


Delta Property

[image]

Mindscape Silverlight Elements
MouseWheelEventArgs..::.Delta Property
MouseWheelEventArgs Class See Also Send Feedback
Gets the mouse wheel delta.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Delta { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delta As Double
Visual C++
public:
property double Delta {
    double get ();
}

See Also

MouseWheelEventArgs Class


ShiftKey Property

[image]

Mindscape Silverlight Elements
MouseWheelEventArgs..::.ShiftKey Property
MouseWheelEventArgs Class See Also Send Feedback
Gets whether the Shift key was pressed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShiftKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShiftKey As Boolean
Visual C++
public:
property bool ShiftKey {
    bool get ();
}

See Also

MouseWheelEventArgs Class


MulticolumnTreeView Class

[image]

Mindscape Silverlight Elements
MulticolumnTreeView Class
Members See Also Send Feedback
A control with the expand/collapse functionality of a TreeView, but supporting multiple columns like a ListView.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MulticolumnTreeView : TreeView
Visual Basic (Declaration)
Public Class MulticolumnTreeView _
    Inherits TreeView
Visual C++
public ref class MulticolumnTreeView : public TreeView

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
System.Windows.Controls..::.TreeView
Mindscape.SilverlightElements..::.MulticolumnTreeView

See Also

MulticolumnTreeView Members


MulticolumnTreeView Members

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeView Members
MulticolumnTreeView Class Constructors Methods Fields Properties Events See Also Send Feedback

The MulticolumnTreeView type exposes the following members.

Constructors

Name | Description
MulticolumnTreeView | Initialises a new instance of the MulticolumnTreeView class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from TreeView.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Overrides TreeView..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides TreeView..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from TreeView.)
OnCreateAutomationPeer | (Inherited from TreeView.)
OnGotFocus | (Inherited from TreeView.)
OnItemsChanged | Called when the value of the Items property changes. (Overrides TreeView..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from TreeView.)
OnKeyUp | (Inherited from TreeView.)
OnLostFocus | (Inherited from TreeView.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from TreeView.)
OnMouseLeave | (Inherited from TreeView.)
OnMouseLeftButtonDown | (Inherited from TreeView.)
OnMouseLeftButtonUp | (Inherited from TreeView.)
OnMouseMove | (Inherited from TreeView.)
OnMouseWheel | (Inherited from Control.)
OnSelectedItemChanged | (Inherited from TreeView.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides TreeViewPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AllowsColumnReorderProperty | Identifies the AllowsColumnReorder property.
ColumnHeaderContainerStyleProperty | Identifies the ColumnHeaderContainerStyle property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate property.
ColumnHeaderTemplateSelectorProperty | Identifies the ColumnHeaderTemplateSelector property.
ColumnsProperty | Identifies the Columns property.
ExpandingDecoratorProperty | Identifies the ExpandingDecorator property.
WrappedColumnsProperty | Identifies the WrappedColumns property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowsColumnReorder | Gets or sets whether the user can reorder columns using the mouse.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ColumnHeaderContainerStyle | Gets or sets the style applied to the column headers. This is a dependency property.
ColumnHeaderTemplate | Gets or sets the template applied to the column header content. This is a dependency property.
ColumnHeaderTemplateSelector | Gets or sets an object which selects the template applied to the column header content. This is a dependency property.
Columns | Gets or sets the columns displayed in the MulticolumnTreeView. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
ExpandingDecorator | Gets or sets the decorator applied to cells used for expanding the tree. This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from TreeView.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedItem | (Inherited from TreeView.)
SelectedValue | (Inherited from TreeView.)
SelectedValuePath | (Inherited from TreeView.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
WrappedColumns | Gets the grid columns, wrapped to provide a tree expansion UI. This is a dependency property.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedItemChanged | (Inherited from TreeView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MulticolumnTreeView Class


MulticolumnTreeView Constructor

[image]

Mindscape Silverlight Elements
MulticolumnTreeView Constructor
MulticolumnTreeView Class See Also Send Feedback
Initialises a new instance of the MulticolumnTreeView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MulticolumnTreeView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MulticolumnTreeView()

See Also

MulticolumnTreeView Class


MulticolumnTreeView Fields

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeView Fields
MulticolumnTreeView Class See Also Send Feedback

The MulticolumnTreeView type exposes the following members.

Fields

Name | Description
AllowsColumnReorderProperty | Identifies the AllowsColumnReorder property.
ColumnHeaderContainerStyleProperty | Identifies the ColumnHeaderContainerStyle property.
ColumnHeaderTemplateProperty | Identifies the ColumnHeaderTemplate property.
ColumnHeaderTemplateSelectorProperty | Identifies the ColumnHeaderTemplateSelector property.
ColumnsProperty | Identifies the Columns property.
ExpandingDecoratorProperty | Identifies the ExpandingDecorator property.
WrappedColumnsProperty | Identifies the WrappedColumns property.

See Also

MulticolumnTreeView Class


AllowsColumnReorderProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.AllowsColumnReorderProperty Field
MulticolumnTreeView Class See Also Send Feedback
Identifies the AllowsColumnReorder property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty AllowsColumnReorderProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowsColumnReorderProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AllowsColumnReorderProperty

See Also

MulticolumnTreeView Class


ColumnHeaderContainerStyleProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ColumnHeaderContainerStyleProperty Field
MulticolumnTreeView Class See Also Send Feedback
Identifies the ColumnHeaderContainerStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderContainerStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderContainerStyleProperty

See Also

MulticolumnTreeView Class


ColumnHeaderTemplateProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ColumnHeaderTemplateProperty Field
MulticolumnTreeView Class See Also Send Feedback
Identifies the ColumnHeaderTemplate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderTemplateProperty

See Also

MulticolumnTreeView Class


ColumnHeaderTemplateSelectorProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ColumnHeaderTemplateSelectorProperty Field
MulticolumnTreeView Class See Also Send Feedback
Identifies the ColumnHeaderTemplateSelector property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderTemplateSelectorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnHeaderTemplateSelectorProperty

See Also

MulticolumnTreeView Class


ColumnsProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ColumnsProperty Field
MulticolumnTreeView Class See Also Send Feedback
Identifies the Columns property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ColumnsProperty

See Also

MulticolumnTreeView Class


ExpandingDecoratorProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ExpandingDecoratorProperty Field
MulticolumnTreeView Class See Also Send Feedback
Identifies the ExpandingDecorator property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ExpandingDecoratorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExpandingDecoratorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ExpandingDecoratorProperty

See Also

MulticolumnTreeView Class


WrappedColumnsProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.WrappedColumnsProperty Field
MulticolumnTreeView Class See Also Send Feedback
Identifies the WrappedColumns property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty WrappedColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly WrappedColumnsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ WrappedColumnsProperty

See Also

MulticolumnTreeView Class


MulticolumnTreeView Methods

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeView Methods
MulticolumnTreeView Class See Also Send Feedback

The MulticolumnTreeView type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from TreeView.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Overrides TreeView..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides TreeView..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from TreeView.)
OnCreateAutomationPeer | (Inherited from TreeView.)
OnGotFocus | (Inherited from TreeView.)
OnItemsChanged | Called when the value of the Items property changes. (Overrides TreeView..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from TreeView.)
OnKeyUp | (Inherited from TreeView.)
OnLostFocus | (Inherited from TreeView.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from TreeView.)
OnMouseLeave | (Inherited from TreeView.)
OnMouseLeftButtonDown | (Inherited from TreeView.)
OnMouseLeftButtonUp | (Inherited from TreeView.)
OnMouseMove | (Inherited from TreeView.)
OnMouseWheel | (Inherited from Control.)
OnSelectedItemChanged | (Inherited from TreeView.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides TreeViewPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

MulticolumnTreeView Class


GetContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.GetContainerForItemOverride Method
MulticolumnTreeView Class See Also Send Feedback
Creates or identifies the element that is used to display the given item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject
Visual C++
protected:
virtual DependencyObject^ GetContainerForItemOverride() override

Return Value

The element that is used to display the given item.

See Also

MulticolumnTreeView Class


IsItemItsOwnContainerOverride Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.IsItemItsOwnContainerOverride Method
MulticolumnTreeView Class See Also Send Feedback
Determines if the specified item is (or is eligible to be) its own container.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean
Visual C++
protected:
virtual bool IsItemItsOwnContainerOverride(
    Object^ item
) override

Parameters

item
Type: System..::.Object
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise, false.

See Also

MulticolumnTreeView Class


OnItemsChanged Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.OnItemsChanged Method
MulticolumnTreeView Class See Also Send Feedback
Called when the value of the Items property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
virtual void OnItemsChanged(
    NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
The event data.

See Also

MulticolumnTreeView Class


PrepareContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.PrepareContainerForItemOverride Method
MulticolumnTreeView Class See Also Send Feedback
Prepares the specified element to display the specified item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)
Visual C++
protected:
virtual void PrepareContainerForItemOverride(
    DependencyObject^ element,
    Object^ item
) override

Parameters

element
Type: System.Windows..::.DependencyObject
Element used to display the specified item.
item
Type: System..::.Object
Specified item.

See Also

MulticolumnTreeView Class


MulticolumnTreeView Properties

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeView Properties
MulticolumnTreeView Class See Also Send Feedback

The MulticolumnTreeView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowsColumnReorder | Gets or sets whether the user can reorder columns using the mouse.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ColumnHeaderContainerStyle | Gets or sets the style applied to the column headers. This is a dependency property.
ColumnHeaderTemplate | Gets or sets the template applied to the column header content. This is a dependency property.
ColumnHeaderTemplateSelector | Gets or sets an object which selects the template applied to the column header content. This is a dependency property.
Columns | Gets or sets the columns displayed in the MulticolumnTreeView. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
ExpandingDecorator | Gets or sets the decorator applied to cells used for expanding the tree. This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from TreeView.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedItem | (Inherited from TreeView.)
SelectedValue | (Inherited from TreeView.)
SelectedValuePath | (Inherited from TreeView.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
WrappedColumns | Gets the grid columns, wrapped to provide a tree expansion UI. This is a dependency property.

See Also

MulticolumnTreeView Class


AllowsColumnReorder Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.AllowsColumnReorder Property
MulticolumnTreeView Class See Also Send Feedback
Gets or sets whether the user can reorder columns using the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AllowsColumnReorder { get; set; }
Visual Basic (Declaration)
Public Property AllowsColumnReorder As Boolean
Visual C++
public:
property bool AllowsColumnReorder {
    bool get ();
    void set (bool value);
}

See Also

MulticolumnTreeView Class


ColumnHeaderContainerStyle Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ColumnHeaderContainerStyle Property
MulticolumnTreeView Class See Also Send Feedback
Gets or sets the style applied to the column headers. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style ColumnHeaderContainerStyle { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderContainerStyle As Style
Visual C++
public:
property Style^ ColumnHeaderContainerStyle {
    Style^ get ();
    void set (Style^ value);
}

See Also

MulticolumnTreeView Class


ColumnHeaderTemplate Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ColumnHeaderTemplate Property
MulticolumnTreeView Class See Also Send Feedback
Gets or sets the template applied to the column header content. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate ColumnHeaderTemplate { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ ColumnHeaderTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

MulticolumnTreeView Class


ColumnHeaderTemplateSelector Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ColumnHeaderTemplateSelector Property
MulticolumnTreeView Class See Also Send Feedback
Gets or sets an object which selects the template applied to the column header content. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplateSelector ColumnHeaderTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderTemplateSelector As DataTemplateSelector
Visual C++
public:
property DataTemplateSelector^ ColumnHeaderTemplateSelector {
    DataTemplateSelector^ get ();
    void set (DataTemplateSelector^ value);
}

See Also

MulticolumnTreeView Class


Columns Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.Columns Property
MulticolumnTreeView Class See Also Send Feedback
Gets or sets the columns displayed in the MulticolumnTreeView. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnCollection Columns { get; set; }
Visual Basic (Declaration)
Public Property Columns As GridViewColumnCollection
Visual C++
public:
property GridViewColumnCollection^ Columns {
    GridViewColumnCollection^ get ();
    void set (GridViewColumnCollection^ value);
}

See Also

MulticolumnTreeView Class


ExpandingDecorator Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.ExpandingDecorator Property
MulticolumnTreeView Class See Also Send Feedback
Gets or sets the decorator applied to cells used for expanding the tree. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate ExpandingDecorator { get; set; }
Visual Basic (Declaration)
Public Property ExpandingDecorator As DataTemplate
Visual C++
public:
property DataTemplate^ ExpandingDecorator {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Remarks

Dependency Property Information
Identifier field | ExpandingDecoratorProperty
Metadata properties set to true | None

See Also

MulticolumnTreeView Class


WrappedColumns Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeView..::.WrappedColumns Property
MulticolumnTreeView Class See Also Send Feedback
Gets the grid columns, wrapped to provide a tree expansion UI. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnCollection WrappedColumns { get; private set; }
Visual Basic (Declaration)
Public Property WrappedColumns As GridViewColumnCollection
Visual C++
public:
property GridViewColumnCollection^ WrappedColumns {
    GridViewColumnCollection^ get ();
    void set (GridViewColumnCollection^ value);
}

Remarks

Dependency Property Information
Identifier field | WrappedColumnsProperty
Metadata properties set to true | None

See Also

MulticolumnTreeView Class


MulticolumnTreeView Events

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeView Events
MulticolumnTreeView Class See Also Send Feedback

The MulticolumnTreeView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedItemChanged | (Inherited from TreeView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

MulticolumnTreeView Class


MulticolumnTreeViewItem Class

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem Class
Members See Also Send Feedback
Implements a selectable item in a MulticolumnTreeView control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MulticolumnTreeViewItem : TreeViewItem,
    INotifyPropertyChanged
Visual Basic (Declaration)
Public Class MulticolumnTreeViewItem _
    Inherits TreeViewItem _
    Implements INotifyPropertyChanged
Visual C++
public ref class MulticolumnTreeViewItem : public TreeViewItem,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
System.Windows.Controls..::.HeaderedItemsControl
System.Windows.Controls..::.TreeViewItem
Mindscape.SilverlightElements..::.MulticolumnTreeViewItem

See Also

MulticolumnTreeViewItem Members


MulticolumnTreeViewItem Members

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem Members
MulticolumnTreeViewItem Class Constructors Methods Fields Properties Events See Also Send Feedback

The MulticolumnTreeViewItem type exposes the following members.

Constructors

Name | Description
MulticolumnTreeViewItem | Initializes a new instance of the MulticolumnTreeViewItem class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from TreeViewItem.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Overrides TreeViewItem..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Overrides TreeViewItem..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from TreeViewItem.)
OnCollapsed | (Inherited from TreeViewItem.)
OnCreateAutomationPeer | (Inherited from TreeViewItem.)
OnExpanded | (Inherited from TreeViewItem.)
OnGotFocus | (Inherited from TreeViewItem.)
OnHeaderChanged | Called by the framework when the Header changes. (Overrides HeaderedItemsControl..::.OnHeaderChanged(Object, Object).)
OnHeaderTemplateChanged | (Inherited from HeaderedItemsControl.)
OnItemsChanged | Called by the framework when the Items collection changes. (Overrides TreeViewItem..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from TreeViewItem.)
OnKeyUp | (Inherited from TreeViewItem.)
OnLostFocus | (Inherited from TreeViewItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from TreeViewItem.)
OnMouseLeave | (Inherited from TreeViewItem.)
OnMouseLeftButtonDown | (Inherited from TreeViewItem.)
OnMouseLeftButtonUp | (Inherited from TreeViewItem.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
OnSelected | (Inherited from TreeViewItem.)
OnUnselected | (Inherited from TreeViewItem.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides TreeViewItemPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
WrappedColumnsProperty | Identifies the WrappedColumns property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FirstCellTemplateInfo | Contains decorated content for the leftmost column.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | (Inherited from TreeViewItem.)
Header | (Inherited from HeaderedItemsControl.)
HeaderTemplate | (Inherited from HeaderedItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsExpanded | (Inherited from TreeViewItem.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from TreeViewItem.)
IsSelectionActive | (Inherited from TreeViewItem.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from HeaderedItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Level | Gets the level of the MulticolumnTreeViewItem in the hierarchy.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
WrappedColumns | Gets or sets a GridViewColumnCollection representing the columns after the MulticolumnTreeView has added additional display elements. This is a dependency property.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Collapsed | (Inherited from TreeViewItem.)
Expanded | (Inherited from TreeViewItem.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
Selected | (Inherited from TreeViewItem.)
SizeChanged | (Inherited from FrameworkElement.)
Unselected | (Inherited from TreeViewItem.)

See Also

MulticolumnTreeViewItem Class


MulticolumnTreeViewItem Constructor

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem Constructor
MulticolumnTreeViewItem Class See Also Send Feedback
Initializes a new instance of the MulticolumnTreeViewItem class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MulticolumnTreeViewItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MulticolumnTreeViewItem()

See Also

MulticolumnTreeViewItem Class


MulticolumnTreeViewItem Fields

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem Fields
MulticolumnTreeViewItem Class See Also Send Feedback

The MulticolumnTreeViewItem type exposes the following members.

Fields

Name | Description
WrappedColumnsProperty | Identifies the WrappedColumns property.

See Also

MulticolumnTreeViewItem Class


WrappedColumnsProperty Field

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.WrappedColumnsProperty Field
MulticolumnTreeViewItem Class See Also Send Feedback
Identifies the WrappedColumns property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty WrappedColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly WrappedColumnsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ WrappedColumnsProperty

See Also

MulticolumnTreeViewItem Class


MulticolumnTreeViewItem Methods

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem Methods
MulticolumnTreeViewItem Class See Also Send Feedback

The MulticolumnTreeViewItem type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from TreeViewItem.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetContainerForItemOverride | Creates or identifies the element used to display a specified item. (Overrides TreeViewItem..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own ItemContainer. (Overrides TreeViewItem..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from TreeViewItem.)
OnCollapsed | (Inherited from TreeViewItem.)
OnCreateAutomationPeer | (Inherited from TreeViewItem.)
OnExpanded | (Inherited from TreeViewItem.)
OnGotFocus | (Inherited from TreeViewItem.)
OnHeaderChanged | Called by the framework when the Header changes. (Overrides HeaderedItemsControl..::.OnHeaderChanged(Object, Object).)
OnHeaderTemplateChanged | (Inherited from HeaderedItemsControl.)
OnItemsChanged | Called by the framework when the Items collection changes. (Overrides TreeViewItem..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | (Inherited from TreeViewItem.)
OnKeyUp | (Inherited from TreeViewItem.)
OnLostFocus | (Inherited from TreeViewItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from TreeViewItem.)
OnMouseLeave | (Inherited from TreeViewItem.)
OnMouseLeftButtonDown | (Inherited from TreeViewItem.)
OnMouseLeftButtonUp | (Inherited from TreeViewItem.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
OnSelected | (Inherited from TreeViewItem.)
OnUnselected | (Inherited from TreeViewItem.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides TreeViewItemPrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

MulticolumnTreeViewItem Class


GetContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.GetContainerForItemOverride Method
MulticolumnTreeViewItem Class See Also Send Feedback
Creates or identifies the element used to display a specified item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject
Visual C++
protected:
virtual DependencyObject^ GetContainerForItemOverride() override

Return Value

A new MulticolumnTreeViewItem.

See Also

MulticolumnTreeViewItem Class


IsItemItsOwnContainerOverride Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.IsItemItsOwnContainerOverride Method
MulticolumnTreeViewItem Class See Also Send Feedback
Determines if the specified item is (or is eligible to be) its own ItemContainer.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean
Visual C++
protected:
virtual bool IsItemItsOwnContainerOverride(
    Object^ item
) override

Parameters

item
Type: System..::.Object
The object to evaluate.

Return Value

true if item is a MulticolumnTreeViewItem; otherwise, false.

See Also

MulticolumnTreeViewItem Class


OnHeaderChanged Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.OnHeaderChanged Method
MulticolumnTreeViewItem Class See Also Send Feedback
Called by the framework when the Header changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnHeaderChanged(
    Object oldHeader,
    Object newHeader
)
Visual Basic (Declaration)
Protected Overrides Sub OnHeaderChanged ( _
    oldHeader As Object, _
    newHeader As Object _
)
Visual C++
protected:
virtual void OnHeaderChanged(
    Object^ oldHeader,
    Object^ newHeader
) override

Parameters

oldHeader
Type: System..::.Object
The old header content.
newHeader
Type: System..::.Object
The new header content.

See Also

MulticolumnTreeViewItem Class


OnItemsChanged Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.OnItemsChanged Method
MulticolumnTreeViewItem Class See Also Send Feedback
Called by the framework when the Items collection changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)
Visual C++
protected:
virtual void OnItemsChanged(
    NotifyCollectionChangedEventArgs^ e
) override

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
The event data.

See Also

MulticolumnTreeViewItem Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.OnPropertyChanged Method
MulticolumnTreeViewItem Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

MulticolumnTreeViewItem Class


PrepareContainerForItemOverride Method

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.PrepareContainerForItemOverride Method
MulticolumnTreeViewItem Class See Also Send Feedback
Prepares the specified element to display the specified item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)
Visual C++
protected:
virtual void PrepareContainerForItemOverride(
    DependencyObject^ element,
    Object^ item
) override

Parameters

element
Type: System.Windows..::.DependencyObject
Element used to display the specified item.
item
Type: System..::.Object
Specified item.

See Also

MulticolumnTreeViewItem Class


MulticolumnTreeViewItem Properties

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem Properties
MulticolumnTreeViewItem Class See Also Send Feedback

The MulticolumnTreeViewItem type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
Effect | (Inherited from UIElement.)
FirstCellTemplateInfo | Contains decorated content for the leftmost column.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | (Inherited from TreeViewItem.)
Header | (Inherited from HeaderedItemsControl.)
HeaderTemplate | (Inherited from HeaderedItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsExpanded | (Inherited from TreeViewItem.)
IsHitTestVisible | (Inherited from UIElement.)
IsSelected | (Inherited from TreeViewItem.)
IsSelectionActive | (Inherited from TreeViewItem.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | (Inherited from ItemsControl.)
ItemContainerStyle | (Inherited from HeaderedItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Level | Gets the level of the MulticolumnTreeViewItem in the hierarchy.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
WrappedColumns | Gets or sets a GridViewColumnCollection representing the columns after the MulticolumnTreeView has added additional display elements. This is a dependency property.

See Also

MulticolumnTreeViewItem Class


FirstCellTemplateInfo Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.FirstCellTemplateInfo Property
MulticolumnTreeViewItem Class See Also Send Feedback
Contains decorated content for the leftmost column.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object FirstCellTemplateInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstCellTemplateInfo As Object
Visual C++
public:
property Object^ FirstCellTemplateInfo {
    Object^ get ();
}

See Also

MulticolumnTreeViewItem Class


Level Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.Level Property
MulticolumnTreeViewItem Class See Also Send Feedback
Gets the level of the MulticolumnTreeViewItem in the hierarchy.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Level { get; private set; }
Visual Basic (Declaration)
Public Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
    void set (int value);
}

See Also

MulticolumnTreeViewItem Class


WrappedColumns Property

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.WrappedColumns Property
MulticolumnTreeViewItem Class See Also Send Feedback
Gets or sets a GridViewColumnCollection representing the columns after the MulticolumnTreeView has added additional display elements. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GridViewColumnCollection WrappedColumns { get; set; }
Visual Basic (Declaration)
Public Property WrappedColumns As GridViewColumnCollection
Visual C++
public:
property GridViewColumnCollection^ WrappedColumns {
    GridViewColumnCollection^ get ();
    void set (GridViewColumnCollection^ value);
}

Remarks

Dependency Property Information
Identifier field | WrappedColumnsProperty
Metadata properties set to true | None

See Also

MulticolumnTreeViewItem Class


MulticolumnTreeViewItem Events

[image] [image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem Events
MulticolumnTreeViewItem Class See Also Send Feedback

The MulticolumnTreeViewItem type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Collapsed | (Inherited from TreeViewItem.)
Expanded | (Inherited from TreeViewItem.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
Selected | (Inherited from TreeViewItem.)
SizeChanged | (Inherited from FrameworkElement.)
Unselected | (Inherited from TreeViewItem.)

See Also

MulticolumnTreeViewItem Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
MulticolumnTreeViewItem..::.PropertyChanged Event
MulticolumnTreeViewItem Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

Remarks

The PropertyChanged event is not raised for all properties on this class.

See Also

MulticolumnTreeViewItem Class


NamedColor Class

[image]

Mindscape Silverlight Elements
NamedColor Class
Members See Also Send Feedback
Associates a name with a color according to the Silverlight color naming standard.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NamedColor
Visual Basic (Declaration)
Public Class NamedColor
Visual C++
public ref class NamedColor

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.NamedColor

See Also

NamedColor Members


NamedColor Members

[image] [image]

Mindscape Silverlight Elements
NamedColor Members
NamedColor Class Constructors Methods Properties See Also Send Feedback

The NamedColor type exposes the following members.

Constructors

Name | Description
NamedColor | Initialises a new instance of the NamedColor class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets the color value.
ColorNames | Gets a mapping of colors to names, as defined in the Silverlight Colors class.
Name | Gets the name of the color.
NamedColors | Gets a list of all named colors, as defined in the Silverlight Colors class.

See Also

NamedColor Class


NamedColor Constructor

[image]

Mindscape Silverlight Elements
NamedColor Constructor
NamedColor Class See Also Send Feedback
Initialises a new instance of the NamedColor class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NamedColor(
    string name,
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    color As Color _
)
Visual C++
public:
NamedColor(
    String^ name,
    Color color
)

Parameters

name
Type: System..::.String
The name of the color.
color
Type: System.Windows.Media..::.Color
The color value.

See Also

NamedColor Class


NamedColor Methods

[image] [image]

Mindscape Silverlight Elements
NamedColor Methods
NamedColor Class See Also Send Feedback

The NamedColor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedColor Class


NamedColor Properties

[image] [image]

Mindscape Silverlight Elements
NamedColor Properties
NamedColor Class See Also Send Feedback

The NamedColor type exposes the following members.

Properties

Name | Description
Color | Gets the color value.
ColorNames | Gets a mapping of colors to names, as defined in the Silverlight Colors class.
Name | Gets the name of the color.
NamedColors | Gets a list of all named colors, as defined in the Silverlight Colors class.

See Also

NamedColor Class


Color Property

[image]

Mindscape Silverlight Elements
NamedColor..::.Color Property
NamedColor Class See Also Send Feedback
Gets the color value.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
}

See Also

NamedColor Class


ColorNames Property

[image]

Mindscape Silverlight Elements
NamedColor..::.ColorNames Property
NamedColor Class See Also Send Feedback
Gets a mapping of colors to names, as defined in the Silverlight Colors class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Dictionary<Color, string> ColorNames { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ColorNames As Dictionary(Of Color, String)
Visual C++
public:
static property Dictionary<Color, String^>^ ColorNames {
    Dictionary<Color, String^>^ get ();
}

Remarks

In rare cases a color value may have multiple names (e.g. Cyan and Aqua). In such cases, the ColorNames dictionary will contain only one of these names; which name is chosen is not defined.

See Also

NamedColor Class


Name Property

[image]

Mindscape Silverlight Elements
NamedColor..::.Name Property
NamedColor Class See Also Send Feedback
Gets the name of the color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

NamedColor Class


NamedColors Property

[image]

Mindscape Silverlight Elements
NamedColor..::.NamedColors Property
NamedColor Class See Also Send Feedback
Gets a list of all named colors, as defined in the Silverlight Colors class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ReadOnlyCollection<NamedColor> NamedColors { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NamedColors As ReadOnlyCollection(Of NamedColor)
Visual C++
public:
static property ReadOnlyCollection<NamedColor^>^ NamedColors {
    ReadOnlyCollection<NamedColor^>^ get ();
}

See Also

NamedColor Class


NegativeConverter Class

[image]

Mindscape Silverlight Elements
NegativeConverter Class
Members See Also Send Feedback
Converts a double value to its negative.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NegativeConverter : IValueConverter
Visual Basic (Declaration)
Public Class NegativeConverter _
    Implements IValueConverter
Visual C++
public ref class NegativeConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.NegativeConverter

See Also

NegativeConverter Members


NegativeConverter Members

[image] [image]

Mindscape Silverlight Elements
NegativeConverter Members
NegativeConverter Class Constructors Methods See Also Send Feedback

The NegativeConverter type exposes the following members.

Constructors

Name | Description
NegativeConverter | Initializes a new instance of the NegativeConverter class

Methods

Name | Description
Convert | Converts a double value from a binding source to its negative for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NegativeConverter Class


NegativeConverter Constructor

[image]

Mindscape Silverlight Elements
NegativeConverter Constructor
NegativeConverter Class See Also Send Feedback
Initializes a new instance of the NegativeConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NegativeConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NegativeConverter()

See Also

NegativeConverter Class


NegativeConverter Methods

[image] [image]

Mindscape Silverlight Elements
NegativeConverter Methods
NegativeConverter Class See Also Send Feedback

The NegativeConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a double value from a binding source to its negative for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NegativeConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
NegativeConverter..::.Convert Method
NegativeConverter Class See Also Send Feedback
Converts a double value from a binding source to its negative for use by a binding target.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The double value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The negative of the original double value.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

NegativeConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
NegativeConverter..::.ConvertBack Method
NegativeConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

NegativeConverter Class


NotifyingColor Class

[image]

Mindscape Silverlight Elements
NotifyingColor Class
Members See Also Send Feedback
Encapsulates a Color and provides notification of changes to individual channels in order to support Silverlight data binding.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NotifyingColor : ViewModelBase
Visual Basic (Declaration)
Public Class NotifyingColor _
    Inherits ViewModelBase
Visual C++
public ref class NotifyingColor : public ViewModelBase

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ViewModelBase
Mindscape.SilverlightElements..::.NotifyingColor

See Also

NotifyingColor Members


NotifyingColor Members

[image] [image]

Mindscape Silverlight Elements
NotifyingColor Members
NotifyingColor Class Constructors Methods Properties Events See Also Send Feedback

The NotifyingColor type exposes the following members.

Constructors

Name | Description
NotifyingColor | Initializes a new instance of the NotifyingColor class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetFromColor | Sets this NotifyingColor to wrap the specified color.
ToColor | Returns the color of this NotifyingColor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
A | Gets or sets the alpha channel value of the color.
B | Gets or sets the blue channel value of the color.
G | Gets or sets the green channel value of the color.
R | Gets or sets the red channel value of the color.

Events

Name | Description
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

NotifyingColor Class


NotifyingColor Constructor

[image]

Mindscape Silverlight Elements
NotifyingColor Constructor
NotifyingColor Class See Also Send Feedback
Initializes a new instance of the NotifyingColor class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NotifyingColor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotifyingColor()

See Also

NotifyingColor Class


NotifyingColor Methods

[image] [image]

Mindscape Silverlight Elements
NotifyingColor Methods
NotifyingColor Class See Also Send Feedback

The NotifyingColor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetFromColor | Sets this NotifyingColor to wrap the specified color.
ToColor | Returns the color of this NotifyingColor.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotifyingColor Class


SetFromColor Method

[image]

Mindscape Silverlight Elements
NotifyingColor..::.SetFromColor Method
NotifyingColor Class See Also Send Feedback
Sets this NotifyingColor to wrap the specified color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetFromColor(
    Color color
)
Visual Basic (Declaration)
Public Sub SetFromColor ( _
    color As Color _
)
Visual C++
public:
void SetFromColor(
    Color color
)

Parameters

color
Type: System.Windows.Media..::.Color
The color to wrap.

See Also

NotifyingColor Class


ToColor Method

[image]

Mindscape Silverlight Elements
NotifyingColor..::.ToColor Method
NotifyingColor Class See Also Send Feedback
Returns the color of this NotifyingColor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color ToColor()
Visual Basic (Declaration)
Public Function ToColor As Color
Visual C++
public:
Color ToColor()

Return Value

The color of this NotifyingColor.

See Also

NotifyingColor Class


NotifyingColor Properties

[image] [image]

Mindscape Silverlight Elements
NotifyingColor Properties
NotifyingColor Class See Also Send Feedback

The NotifyingColor type exposes the following members.

Properties

Name | Description
A | Gets or sets the alpha channel value of the color.
B | Gets or sets the blue channel value of the color.
G | Gets or sets the green channel value of the color.
R | Gets or sets the red channel value of the color.

See Also

NotifyingColor Class


A Property

[image]

Mindscape Silverlight Elements
NotifyingColor..::.A Property
NotifyingColor Class See Also Send Feedback
Gets or sets the alpha channel value of the color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte A { get; set; }
Visual Basic (Declaration)
Public Property A As Byte
Visual C++
public:
property unsigned char A {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class


B Property

[image]

Mindscape Silverlight Elements
NotifyingColor..::.B Property
NotifyingColor Class See Also Send Feedback
Gets or sets the blue channel value of the color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte B { get; set; }
Visual Basic (Declaration)
Public Property B As Byte
Visual C++
public:
property unsigned char B {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class


G Property

[image]

Mindscape Silverlight Elements
NotifyingColor..::.G Property
NotifyingColor Class See Also Send Feedback
Gets or sets the green channel value of the color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte G { get; set; }
Visual Basic (Declaration)
Public Property G As Byte
Visual C++
public:
property unsigned char G {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class


R Property

[image]

Mindscape Silverlight Elements
NotifyingColor..::.R Property
NotifyingColor Class See Also Send Feedback
Gets or sets the red channel value of the color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte R { get; set; }
Visual Basic (Declaration)
Public Property R As Byte
Visual C++
public:
property unsigned char R {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

NotifyingColor Class


NotifyingColor Events

[image] [image]

Mindscape Silverlight Elements
NotifyingColor Events
NotifyingColor Class See Also Send Feedback

The NotifyingColor type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

NotifyingColor Class


NthDayOfMonthRecurrencePattern Class

[image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on a monthly basis on specific day of the month (e.g. the 20th of every third month).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NthDayOfMonthRecurrencePattern : MonthlyRecurrencePattern
Visual Basic (Declaration)
Public Class NthDayOfMonthRecurrencePattern _
    Inherits MonthlyRecurrencePattern
Visual C++
public ref class NthDayOfMonthRecurrencePattern : public MonthlyRecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.MonthlyRecurrencePattern
Mindscape.SilverlightElements..::.NthDayOfMonthRecurrencePattern

See Also

NthDayOfMonthRecurrencePattern Members


NthDayOfMonthRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern Members
NthDayOfMonthRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The NthDayOfMonthRecurrencePattern type exposes the following members.

Constructors

Name | Description
NthDayOfMonthRecurrencePattern | Initializes a new instance of the NthDayOfMonthRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
IncludesCore | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides MonthlyRecurrencePattern..::.IncludesCore(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DayOfMonth | Gets the day of the month on which the item occurs.
MonthlyInterval | Gets the number of months between recurrences. (Inherited from MonthlyRecurrencePattern.)

See Also

NthDayOfMonthRecurrencePattern Class


NthDayOfMonthRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern Constructor
NthDayOfMonthRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the NthDayOfMonthRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NthDayOfMonthRecurrencePattern(
    int monthlyInterval,
    int dayOfMonth
)
Visual Basic (Declaration)
Public Sub New ( _
    monthlyInterval As Integer, _
    dayOfMonth As Integer _
)
Visual C++
public:
NthDayOfMonthRecurrencePattern(
    int monthlyInterval,
    int dayOfMonth
)

Parameters

monthlyInterval
Type: System..::.Int32
The number of months between recurrences.
dayOfMonth
Type: System..::.Int32
The day of the month on which the item occurs.

See Also

NthDayOfMonthRecurrencePattern Class


NthDayOfMonthRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern Methods
NthDayOfMonthRecurrencePattern Class See Also Send Feedback

The NthDayOfMonthRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
IncludesCore | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides MonthlyRecurrencePattern..::.IncludesCore(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NthDayOfMonthRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern..::.Includes Method
NthDayOfMonthRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from MonthlyRecurrencePattern.)

See Also

NthDayOfMonthRecurrencePattern Class
NthDayOfMonthRecurrencePattern Members


IncludesCore Method

[image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern..::.IncludesCore Method
NthDayOfMonthRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool IncludesCore(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function IncludesCore ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool IncludesCore(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

NthDayOfMonthRecurrencePattern Class


NthDayOfMonthRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern Properties
NthDayOfMonthRecurrencePattern Class See Also Send Feedback

The NthDayOfMonthRecurrencePattern type exposes the following members.

Properties

Name | Description
DayOfMonth | Gets the day of the month on which the item occurs.
MonthlyInterval | Gets the number of months between recurrences. (Inherited from MonthlyRecurrencePattern.)

See Also

NthDayOfMonthRecurrencePattern Class


DayOfMonth Property

[image]

Mindscape Silverlight Elements
NthDayOfMonthRecurrencePattern..::.DayOfMonth Property
NthDayOfMonthRecurrencePattern Class See Also Send Feedback
Gets the day of the month on which the item occurs.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int DayOfMonth { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayOfMonth As Integer
Visual C++
public:
property int DayOfMonth {
    int get ();
}

See Also

NthDayOfMonthRecurrencePattern Class


Occurrence Enumeration

[image]

Mindscape Silverlight Elements
Occurrence Enumeration
See Also Send Feedback
Specifies on which occurrence of a day in a month a recurring schedule item recurs (as in "last Friday of the month" or "first weekday in January"). This is used in conjunction with the DayOfRecurrence type.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Occurrence
Visual Basic (Declaration)
Public Enumeration Occurrence
Visual C++
public enum class Occurrence

Members

Member name | Description
First | The item occurs on the first DayOfRecurrence in the month.
Second | The item occurs on the second DayOfRecurrence in the month.
Third | The item occurs on the third DayOfRecurrence in the month.
Fourth | The item occurs on the fourth DayOfRecurrence in the month.
Last | The item occurs on the last DayOfRecurrence in the month.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


PaletteColorPicker Class

[image]

Mindscape Silverlight Elements
PaletteColorPicker Class
Members See Also Send Feedback
A control where users can select a color from a fixed palette.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PaletteColorPicker : ColorPickerBase
Visual Basic (Declaration)
Public Class PaletteColorPicker _
    Inherits ColorPickerBase
Visual C++
public ref class PaletteColorPicker : public ColorPickerBase

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ColorPickerBase
Mindscape.SilverlightElements..::.PaletteColorPicker

See Also

PaletteColorPicker Members


PaletteColorPicker Members

[image] [image]

Mindscape Silverlight Elements
PaletteColorPicker Members
PaletteColorPicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Constructors

Name | Description
PaletteColorPicker | Initializes a new instance of the PaletteColorPicker class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyItemIsSelectedChanged | Handles selection change messages from ColorPickerItem objects. (Inherited from ColorPickerBase.)
OnApplyTemplate | Called by the framework when applying the template. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemIsSelectedChanged | Processes selection status changes from contained ColorPickerItem objects. (Overrides ColorPickerBase..::.OnItemIsSelectedChanged(ColorPickerItem).)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnSelectedColorChanged | Raises the SelectedColorChanged event. (Inherited from ColorPickerBase.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CollapsedViewTemplateProperty | Identifies the CollapsedViewTemplate property.
SelectedColorPickerItemProperty | Identifies the SelectedColorPickerItem property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
CollapsedViewTemplate | Gets or sets a DataTemplate used to display the selected color when the PaletteColorPicker is collapsed. The template is bound to the SelectedColorPickerItem. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets the colours displayed in the palette. This is a dependency property. (Inherited from ColorPickerBase.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RaiseSelectionChangedCommand | Gets a command that raises the SelectedColorChanged event.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedColor | Gets or sets the currently selected color. This is a dependency property. (Inherited from ColorPickerBase.)
SelectedColorPickerItem | Gets or sets the selected ColorPickerItem. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedColorChanged | Occurs when the selected color changes. (Inherited from ColorPickerBase.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PaletteColorPicker Class


PaletteColorPicker Constructor

[image]

Mindscape Silverlight Elements
PaletteColorPicker Constructor
PaletteColorPicker Class See Also Send Feedback
Initializes a new instance of the PaletteColorPicker class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PaletteColorPicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaletteColorPicker()

See Also

PaletteColorPicker Class


PaletteColorPicker Fields

[image] [image]

Mindscape Silverlight Elements
PaletteColorPicker Fields
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Fields

Name | Description
CollapsedViewTemplateProperty | Identifies the CollapsedViewTemplate property.
SelectedColorPickerItemProperty | Identifies the SelectedColorPickerItem property.

See Also

PaletteColorPicker Class


CollapsedViewTemplateProperty Field

[image]

Mindscape Silverlight Elements
PaletteColorPicker..::.CollapsedViewTemplateProperty Field
PaletteColorPicker Class See Also Send Feedback
Identifies the CollapsedViewTemplate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CollapsedViewTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly CollapsedViewTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CollapsedViewTemplateProperty

See Also

PaletteColorPicker Class


SelectedColorPickerItemProperty Field

[image]

Mindscape Silverlight Elements
PaletteColorPicker..::.SelectedColorPickerItemProperty Field
PaletteColorPicker Class See Also Send Feedback
Identifies the SelectedColorPickerItem property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedColorPickerItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedColorPickerItemProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedColorPickerItemProperty

See Also

PaletteColorPicker Class


PaletteColorPicker Methods

[image] [image]

Mindscape Silverlight Elements
PaletteColorPicker Methods
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyItemIsSelectedChanged | Handles selection change messages from ColorPickerItem objects. (Inherited from ColorPickerBase.)
OnApplyTemplate | Called by the framework when applying the template. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemIsSelectedChanged | Processes selection status changes from contained ColorPickerItem objects. (Overrides ColorPickerBase..::.OnItemIsSelectedChanged(ColorPickerItem).)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnSelectedColorChanged | Raises the SelectedColorChanged event. (Inherited from ColorPickerBase.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

PaletteColorPicker Class


OnApplyTemplate Method

[image]

Mindscape Silverlight Elements
PaletteColorPicker..::.OnApplyTemplate Method
PaletteColorPicker Class See Also Send Feedback
Called by the framework when applying the template.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

PaletteColorPicker Class


OnItemIsSelectedChanged Method

[image]

Mindscape Silverlight Elements
PaletteColorPicker..::.OnItemIsSelectedChanged Method
PaletteColorPicker Class See Also Send Feedback
Processes selection status changes from contained ColorPickerItem objects.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnItemIsSelectedChanged(
    ColorPickerItem item
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemIsSelectedChanged ( _
    item As ColorPickerItem _
)
Visual C++
protected:
virtual void OnItemIsSelectedChanged(
    ColorPickerItem^ item
) override

Parameters

item
Type: Mindscape.SilverlightElements..::.ColorPickerItem
The item whose selection status has changed.

See Also

PaletteColorPicker Class


PaletteColorPicker Properties

[image] [image]

Mindscape Silverlight Elements
PaletteColorPicker Properties
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
CollapsedViewTemplate | Gets or sets a DataTemplate used to display the selected color when the PaletteColorPicker is collapsed. The template is bound to the SelectedColorPickerItem. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets the colours displayed in the palette. This is a dependency property. (Inherited from ColorPickerBase.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RaiseSelectionChangedCommand | Gets a command that raises the SelectedColorChanged event.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedColor | Gets or sets the currently selected color. This is a dependency property. (Inherited from ColorPickerBase.)
SelectedColorPickerItem | Gets or sets the selected ColorPickerItem. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

PaletteColorPicker Class


CollapsedViewTemplate Property

[image]

Mindscape Silverlight Elements
PaletteColorPicker..::.CollapsedViewTemplate Property
PaletteColorPicker Class See Also Send Feedback
Gets or sets a DataTemplate used to display the selected color when the PaletteColorPicker is collapsed. The template is bound to the SelectedColorPickerItem. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate CollapsedViewTemplate { get; set; }
Visual Basic (Declaration)
Public Property CollapsedViewTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ CollapsedViewTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Remarks

Dependency Property Information
Identifier field | CollapsedViewTemplateProperty
Metadata properties set to true | None

See Also

PaletteColorPicker Class


RaiseSelectionChangedCommand Property

[image]

Mindscape Silverlight Elements
PaletteColorPicker..::.RaiseSelectionChangedCommand Property
PaletteColorPicker Class See Also Send Feedback
Gets a command that raises the SelectedColorChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand RaiseSelectionChangedCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property RaiseSelectionChangedCommand As ICommand
Visual C++
public:
property ICommand^ RaiseSelectionChangedCommand {
    ICommand^ get ();
}

See Also

PaletteColorPicker Class


SelectedColorPickerItem Property

[image]

Mindscape Silverlight Elements
PaletteColorPicker..::.SelectedColorPickerItem Property
PaletteColorPicker Class See Also Send Feedback
Gets or sets the selected ColorPickerItem. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ColorPickerItem SelectedColorPickerItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedColorPickerItem As ColorPickerItem
Visual C++
public:
property ColorPickerItem^ SelectedColorPickerItem {
    ColorPickerItem^ get ();
    void set (ColorPickerItem^ value);
}

See Also

PaletteColorPicker Class


PaletteColorPicker Events

[image] [image]

Mindscape Silverlight Elements
PaletteColorPicker Events
PaletteColorPicker Class See Also Send Feedback

The PaletteColorPicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedColorChanged | Occurs when the selected color changes. (Inherited from ColorPickerBase.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PaletteColorPicker Class


RecurrenceDialog Class

[image]

Mindscape Silverlight Elements
RecurrenceDialog Class
Members See Also Send Feedback
Provides a user interface for editing the recurrence pattern of a recurring ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RecurrenceDialog : ChildWindow
Visual Basic (Declaration)
Public Class RecurrenceDialog _
    Inherits ChildWindow
Visual C++
public ref class RecurrenceDialog : public ChildWindow

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
ChildWindow
Mindscape.SilverlightElements..::.RecurrenceDialog

See Also

RecurrenceDialog Members


RecurrenceDialog Members

[image] [image]

Mindscape Silverlight Elements
RecurrenceDialog Members
RecurrenceDialog Class Constructors Methods Properties Events See Also Send Feedback

The RecurrenceDialog type exposes the following members.

Constructors

Name | Description
RecurrenceDialog | Initializes a new instance of the RecurrenceDialog class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | (Inherited from ChildWindow.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InitializeComponent | InitializeComponent
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ChildWindow.)
OnClosed | (Inherited from ChildWindow.)
OnClosing | (Inherited from ChildWindow.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ChildWindow.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnOpened | (Inherited from ChildWindow.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | (Inherited from ChildWindow.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DialogResult | (Inherited from ChildWindow.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasCloseButton | (Inherited from ChildWindow.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverlayBrush | (Inherited from ChildWindow.)
OverlayOpacity | (Inherited from ChildWindow.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RecurrenceInfo | Gets or sets the recurrence information for the ScheduleItem.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Title | (Inherited from ChildWindow.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | (Inherited from ChildWindow.)
Closing | (Inherited from ChildWindow.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

RecurrenceDialog Class


RecurrenceDialog Constructor

[image]

Mindscape Silverlight Elements
RecurrenceDialog Constructor
RecurrenceDialog Class See Also Send Feedback
Initializes a new instance of the RecurrenceDialog class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RecurrenceDialog(
    ScheduleItem item,
    RecurrenceInfo currentInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    item As ScheduleItem, _
    currentInfo As RecurrenceInfo _
)
Visual C++
public:
RecurrenceDialog(
    ScheduleItem^ item,
    RecurrenceInfo^ currentInfo
)

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to be edited.
currentInfo
Type: Mindscape.SilverlightElements..::.RecurrenceInfo
The current recurrence settings for the item.

See Also

RecurrenceDialog Class


RecurrenceDialog Methods

[image] [image]

Mindscape Silverlight Elements
RecurrenceDialog Methods
RecurrenceDialog Class See Also Send Feedback

The RecurrenceDialog type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | (Inherited from ChildWindow.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InitializeComponent | InitializeComponent
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ChildWindow.)
OnClosed | (Inherited from ChildWindow.)
OnClosing | (Inherited from ChildWindow.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ChildWindow.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnOpened | (Inherited from ChildWindow.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | (Inherited from ChildWindow.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

RecurrenceDialog Class


InitializeComponent Method

[image]

Mindscape Silverlight Elements
RecurrenceDialog..::.InitializeComponent Method
RecurrenceDialog Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

RecurrenceDialog Class


RecurrenceDialog Properties

[image] [image]

Mindscape Silverlight Elements
RecurrenceDialog Properties
RecurrenceDialog Class See Also Send Feedback

The RecurrenceDialog type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DialogResult | (Inherited from ChildWindow.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasCloseButton | (Inherited from ChildWindow.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverlayBrush | (Inherited from ChildWindow.)
OverlayOpacity | (Inherited from ChildWindow.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RecurrenceInfo | Gets or sets the recurrence information for the ScheduleItem.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Title | (Inherited from ChildWindow.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

RecurrenceDialog Class


RecurrenceInfo Property

[image]

Mindscape Silverlight Elements
RecurrenceDialog..::.RecurrenceInfo Property
RecurrenceDialog Class See Also Send Feedback
Gets or sets the recurrence information for the ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RecurrenceInfo RecurrenceInfo { get; private set; }
Visual Basic (Declaration)
Public Property RecurrenceInfo As RecurrenceInfo
Visual C++
public:
property RecurrenceInfo^ RecurrenceInfo {
    RecurrenceInfo^ get ();
    void set (RecurrenceInfo^ value);
}

See Also

RecurrenceDialog Class


RecurrenceDialog Events

[image] [image]

Mindscape Silverlight Elements
RecurrenceDialog Events
RecurrenceDialog Class See Also Send Feedback

The RecurrenceDialog type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | (Inherited from ChildWindow.)
Closing | (Inherited from ChildWindow.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

RecurrenceDialog Class


RecurrenceEndType Enumeration

[image]

Mindscape Silverlight Elements
RecurrenceEndType Enumeration
See Also Send Feedback
Specifies when a recurring schedule item will end.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum RecurrenceEndType
Visual Basic (Declaration)
Public Enumeration RecurrenceEndType
Visual C++
public enum class RecurrenceEndType

Members

Member name | Description
NoEndDate | States that a recurrence has no end date.
EndAfter | States that a recurrence can last for some maximum number of occurrences.
EndBy | States that a recurrence must end by a particular date.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


RecurrenceInfo Class

[image]

Mindscape Silverlight Elements
RecurrenceInfo Class
Members See Also Send Feedback
Specifies the recurrence schedule for a ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RecurrenceInfo
Visual Basic (Declaration)
Public Class RecurrenceInfo
Visual C++
public ref class RecurrenceInfo

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrenceInfo

See Also

RecurrenceInfo Members


RecurrenceInfo Members

[image] [image]

Mindscape Silverlight Elements
RecurrenceInfo Members
RecurrenceInfo Class Constructors Methods Properties See Also Send Feedback

The RecurrenceInfo type exposes the following members.

Constructors

Name | Description
RecurrenceInfo | Initializes a new instance of the RecurrenceInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Forever | Creates a RecurrenceInfo that runs indefinitely.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToEndDate | Creates a RecurrenceInfo that runs until a specified date.
ToMaxOccurrences | Creates a RecurrenceInfo that runs for a specified number of occurrences.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Duration | Gets the duration of the recurring item.
EndDate | Gets the end date of the recurrence.
EndType | Gets the end criterion for the recurrence.
MaxOccurrences | Gets the maximum number of occurrences.
RecurrencePattern | Gets the recurrence pattern.
StartDate | Gets the start date of the recurrence.
StartTime | Gets the start time of day of the recurrence.

See Also

RecurrenceInfo Class


RecurrenceInfo Constructor

[image]

Mindscape Silverlight Elements
RecurrenceInfo Constructor
RecurrenceInfo Class See Also Send Feedback
Initializes a new instance of the RecurrenceInfo class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RecurrenceInfo(
    DateTime startDate,
    TimeSpan startTime,
    TimeSpan duration,
    IRecurrencePattern recurrencePattern,
    RecurrenceEndType endType,
    DateTime endDate,
    int maxOccurrences
)
Visual Basic (Declaration)
Public Sub New ( _
    startDate As DateTime, _
    startTime As TimeSpan, _
    duration As TimeSpan, _
    recurrencePattern As IRecurrencePattern, _
    endType As RecurrenceEndType, _
    endDate As DateTime, _
    maxOccurrences As Integer _
)
Visual C++
public:
RecurrenceInfo(
    DateTime startDate,
    TimeSpan startTime,
    TimeSpan duration,
    IRecurrencePattern^ recurrencePattern,
    RecurrenceEndType endType,
    DateTime endDate,
    int maxOccurrences
)

Parameters

startDate
Type: System..::.DateTime
The start date of the recurrence.
startTime
Type: System..::.TimeSpan
The start time of day of the recurrence.
duration
Type: System..::.TimeSpan
The duration of the ScheduleItem.
recurrencePattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern.
endType
Type: Mindscape.SilverlightElements..::.RecurrenceEndType
The end criterion for the recurrence.
endDate
Type: System..::.DateTime
The date on which the recurrence is to end (for RecurrenceEndType.EndBy).
maxOccurrences
Type: System..::.Int32
The number of occurrences (for RecurrenceEndType.EndAfter).

Remarks

This constructor is primarily for deserialisation purposes. The factory methods ToEndDate(DateTime, TimeSpan, DateTime, IRecurrencePattern), ToMaxOccurrences(DateTime, TimeSpan, Int32, IRecurrencePattern) and Forever(DateTime, TimeSpan, IRecurrencePattern) provide a simpler API for creating specific types of RecurrenceInfo.

See Also

RecurrenceInfo Class


RecurrenceInfo Methods

[image] [image]

Mindscape Silverlight Elements
RecurrenceInfo Methods
RecurrenceInfo Class See Also Send Feedback

The RecurrenceInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Forever | Creates a RecurrenceInfo that runs indefinitely.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToEndDate | Creates a RecurrenceInfo that runs until a specified date.
ToMaxOccurrences | Creates a RecurrenceInfo that runs for a specified number of occurrences.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RecurrenceInfo Class


Forever Method

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.Forever Method
RecurrenceInfo Class See Also Send Feedback
Creates a RecurrenceInfo that runs indefinitely.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static RecurrenceInfo Forever(
    DateTime start,
    TimeSpan duration,
    IRecurrencePattern recurrencePattern
)
Visual Basic (Declaration)
Public Shared Function Forever ( _
    start As DateTime, _
    duration As TimeSpan, _
    recurrencePattern As IRecurrencePattern _
) As RecurrenceInfo
Visual C++
public:
static RecurrenceInfo^ Forever(
    DateTime start,
    TimeSpan duration,
    IRecurrencePattern^ recurrencePattern
)

Parameters

start
Type: System..::.DateTime
The start date and time of the recurrence.
duration
Type: System..::.TimeSpan
The duration of the ScheduleItem.
recurrencePattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern.

Return Value

A RecurrenceInfo representing the specified recurrence schedule.

See Also

RecurrenceInfo Class


ToEndDate Method

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.ToEndDate Method
RecurrenceInfo Class See Also Send Feedback
Creates a RecurrenceInfo that runs until a specified date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static RecurrenceInfo ToEndDate(
    DateTime start,
    TimeSpan duration,
    DateTime endDate,
    IRecurrencePattern recurrencePattern
)
Visual Basic (Declaration)
Public Shared Function ToEndDate ( _
    start As DateTime, _
    duration As TimeSpan, _
    endDate As DateTime, _
    recurrencePattern As IRecurrencePattern _
) As RecurrenceInfo
Visual C++
public:
static RecurrenceInfo^ ToEndDate(
    DateTime start,
    TimeSpan duration,
    DateTime endDate,
    IRecurrencePattern^ recurrencePattern
)

Parameters

start
Type: System..::.DateTime
The start date and time of the recurrence.
duration
Type: System..::.TimeSpan
The duration of the ScheduleItem.
endDate
Type: System..::.DateTime
The date on which the recurrence is to end.
recurrencePattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern.

Return Value

A RecurrenceInfo representing the specified recurrence schedule.

See Also

RecurrenceInfo Class


ToMaxOccurrences Method

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.ToMaxOccurrences Method
RecurrenceInfo Class See Also Send Feedback
Creates a RecurrenceInfo that runs for a specified number of occurrences.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static RecurrenceInfo ToMaxOccurrences(
    DateTime start,
    TimeSpan duration,
    int maxOccurrences,
    IRecurrencePattern recurrencePattern
)
Visual Basic (Declaration)
Public Shared Function ToMaxOccurrences ( _
    start As DateTime, _
    duration As TimeSpan, _
    maxOccurrences As Integer, _
    recurrencePattern As IRecurrencePattern _
) As RecurrenceInfo
Visual C++
public:
static RecurrenceInfo^ ToMaxOccurrences(
    DateTime start,
    TimeSpan duration,
    int maxOccurrences,
    IRecurrencePattern^ recurrencePattern
)

Parameters

start
Type: System..::.DateTime
The start date and time of the recurrence.
duration
Type: System..::.TimeSpan
The duration of the ScheduleItem.
maxOccurrences
Type: System..::.Int32
The number of occurrences.
recurrencePattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern.

Return Value

A RecurrenceInfo representing the specified recurrence schedule.

See Also

RecurrenceInfo Class


RecurrenceInfo Properties

[image] [image]

Mindscape Silverlight Elements
RecurrenceInfo Properties
RecurrenceInfo Class See Also Send Feedback

The RecurrenceInfo type exposes the following members.

Properties

Name | Description
Duration | Gets the duration of the recurring item.
EndDate | Gets the end date of the recurrence.
EndType | Gets the end criterion for the recurrence.
MaxOccurrences | Gets the maximum number of occurrences.
RecurrencePattern | Gets the recurrence pattern.
StartDate | Gets the start date of the recurrence.
StartTime | Gets the start time of day of the recurrence.

See Also

RecurrenceInfo Class


Duration Property

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.Duration Property
RecurrenceInfo Class See Also Send Feedback
Gets the duration of the recurring item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpan Duration { get; }
Visual Basic (Declaration)
Public ReadOnly Property Duration As TimeSpan
Visual C++
public:
property TimeSpan Duration {
    TimeSpan get ();
}

See Also

RecurrenceInfo Class


EndDate Property

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.EndDate Property
RecurrenceInfo Class See Also Send Feedback
Gets the end date of the recurrence.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime EndDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndDate As DateTime
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
}

See Also

RecurrenceInfo Class


EndType Property

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.EndType Property
RecurrenceInfo Class See Also Send Feedback
Gets the end criterion for the recurrence.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RecurrenceEndType EndType { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndType As RecurrenceEndType
Visual C++
public:
property RecurrenceEndType EndType {
    RecurrenceEndType get ();
}

See Also

RecurrenceInfo Class


MaxOccurrences Property

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.MaxOccurrences Property
RecurrenceInfo Class See Also Send Feedback
Gets the maximum number of occurrences.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int MaxOccurrences { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxOccurrences As Integer
Visual C++
public:
property int MaxOccurrences {
    int get ();
}

See Also

RecurrenceInfo Class


RecurrencePattern Property

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.RecurrencePattern Property
RecurrenceInfo Class See Also Send Feedback
Gets the recurrence pattern.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IRecurrencePattern RecurrencePattern { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecurrencePattern As IRecurrencePattern
Visual C++
public:
property IRecurrencePattern^ RecurrencePattern {
    IRecurrencePattern^ get ();
}

See Also

RecurrenceInfo Class


StartDate Property

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.StartDate Property
RecurrenceInfo Class See Also Send Feedback
Gets the start date of the recurrence.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime StartDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
}

See Also

RecurrenceInfo Class


StartTime Property

[image]

Mindscape Silverlight Elements
RecurrenceInfo..::.StartTime Property
RecurrenceInfo Class See Also Send Feedback
Gets the start time of day of the recurrence.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpan StartTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartTime As TimeSpan
Visual C++
public:
property TimeSpan StartTime {
    TimeSpan get ();
}

See Also

RecurrenceInfo Class


RecurrencePattern Class

[image]

Mindscape Silverlight Elements
RecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence pattern of a recurring ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class RecurrencePattern : IRecurrencePattern
Visual Basic (Declaration)
Public MustInherit Class RecurrencePattern _
    Implements IRecurrencePattern
Visual C++
public ref class RecurrencePattern abstract : IRecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.EveryNDaysRecurrencePattern
Mindscape.SilverlightElements..::.EveryWeekdayRecurrencePattern
Mindscape.SilverlightElements..::.MonthlyRecurrencePattern
Mindscape.SilverlightElements..::.WeeklyRecurrencePattern
Mindscape.SilverlightElements..::.YearlyRecurrencePattern

See Also

RecurrencePattern Members


RecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
RecurrencePattern Members
RecurrencePattern Class Constructors Methods See Also Send Feedback

The RecurrencePattern type exposes the following members.

Constructors

Name | Description
RecurrencePattern | Initializes a new instance of the RecurrencePattern class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

Name | Description
ToXml | Gets an XElement containing the details of the recurrence pattern. (Defined by RecurrencePatternXmlSerializer.)

See Also

RecurrencePattern Class


RecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
RecurrencePattern Constructor
RecurrencePattern Class See Also Send Feedback
Initializes a new instance of the RecurrencePattern class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected RecurrencePattern()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
RecurrencePattern()

See Also

RecurrencePattern Class


RecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
RecurrencePattern Methods
RecurrencePattern Class See Also Send Feedback

The RecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

Name | Description
ToXml | Gets an XElement containing the details of the recurrence pattern. (Defined by RecurrencePatternXmlSerializer.)

See Also

RecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
RecurrencePattern..::.Includes Method
RecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date.
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date.
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | When overridden in a derived class, gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

See Also

RecurrencePattern Class
RecurrencePattern Members


Includes Method (DateTime, DateTime)

[image]

Mindscape Silverlight Elements
RecurrencePattern..::.Includes Method (DateTime, DateTime)
RecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Includes(
    DateTime startDate,
    DateTime day
)
Visual Basic (Declaration)
Public Function Includes ( _
    startDate As DateTime, _
    day As DateTime _
) As Boolean
Visual C++
public:
virtual bool Includes(
    DateTime startDate,
    DateTime day
) sealed

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.

Return Value

true if the pattern occurs on day; otherwise false.

Implements

IRecurrencePattern..::.Includes(DateTime, DateTime)

See Also

RecurrencePattern Class
Includes Overload


Includes Method (DateTime, DateTime, DateTime)

[image]

Mindscape Silverlight Elements
RecurrencePattern..::.Includes Method (DateTime, DateTime, DateTime)
RecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start and end date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Includes(
    DateTime startDate,
    DateTime day,
    DateTime endDate
)
Visual Basic (Declaration)
Public Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    endDate As DateTime _
) As Boolean
Visual C++
public:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    DateTime endDate
) sealed

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
endDate
Type: System..::.DateTime
The end date of recurrence.

Return Value

true if the pattern occurs on day; otherwise false.

Implements

IRecurrencePattern..::.Includes(DateTime, DateTime, DateTime)

See Also

RecurrencePattern Class
Includes Overload


Includes Method (DateTime, DateTime, Int32)

[image]

Mindscape Silverlight Elements
RecurrencePattern..::.Includes Method (DateTime, DateTime, Int32)
RecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Includes(
    DateTime startDate,
    DateTime day,
    int occurrenceCount
)
Visual Basic (Declaration)
Public Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    occurrenceCount As Integer _
) As Boolean
Visual C++
public:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    int occurrenceCount
) sealed

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
occurrenceCount
Type: System..::.Int32
The maximum number of occurrences to consider.

Return Value

true if the pattern occurs on day; otherwise false.

Implements

IRecurrencePattern..::.Includes(DateTime, DateTime, Int32)

See Also

RecurrencePattern Class
Includes Overload


Includes Method (DateTime, DateTime, Boolean, Nullable(Int32))

[image]

Mindscape Silverlight Elements
RecurrencePattern..::.Includes Method (DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>))
RecurrencePattern Class See Also Send Feedback
When overridden in a derived class, gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected MustOverride Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) abstract

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

RecurrencePattern Class
Includes Overload


RecurrencePatternXmlSerializer Class

[image]

Mindscape Silverlight Elements
RecurrencePatternXmlSerializer Class
Members See Also Send Feedback
Contains helper methods for serializing recurrence patterns to XML.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class RecurrencePatternXmlSerializer
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class RecurrencePatternXmlSerializer
Visual C++
[ExtensionAttribute]
public ref class RecurrencePatternXmlSerializer abstract sealed

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePatternXmlSerializer

See Also

RecurrencePatternXmlSerializer Members


RecurrencePatternXmlSerializer Members

[image] [image]

Mindscape Silverlight Elements
RecurrencePatternXmlSerializer Members
RecurrencePatternXmlSerializer Class Methods See Also Send Feedback

The RecurrencePatternXmlSerializer type exposes the following members.

Methods

Name | Description
ParseRecurrencePattern | Parses a recurrence pattern from XML.
ToXml | Gets an XElement containing the details of the recurrence pattern.

See Also

RecurrencePatternXmlSerializer Class


RecurrencePatternXmlSerializer Methods

[image] [image]

Mindscape Silverlight Elements
RecurrencePatternXmlSerializer Methods
RecurrencePatternXmlSerializer Class See Also Send Feedback

The RecurrencePatternXmlSerializer type exposes the following members.

Methods

Name | Description
ParseRecurrencePattern | Parses a recurrence pattern from XML.
ToXml | Gets an XElement containing the details of the recurrence pattern.

See Also

RecurrencePatternXmlSerializer Class


ParseRecurrencePattern Method

[image]

Mindscape Silverlight Elements
RecurrencePatternXmlSerializer..::.ParseRecurrencePattern Method
RecurrencePatternXmlSerializer Class See Also Send Feedback
Parses a recurrence pattern from XML.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IRecurrencePattern ParseRecurrencePattern(
    this XElement xml
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ParseRecurrencePattern ( _
    xml As XElement _
) As IRecurrencePattern
Visual C++
[ExtensionAttribute]
public:
static IRecurrencePattern^ ParseRecurrencePattern(
    XElement^ xml
)

Parameters

xml
Type: System.Xml.Linq..::.XElement
An XElement containing details of the recurrence pattern, as produced by the ToXml method.

Return Value

An IRecurrencePattern.

See Also

RecurrencePatternXmlSerializer Class


ToXml Method

[image]

Mindscape Silverlight Elements
RecurrencePatternXmlSerializer..::.ToXml Method
RecurrencePatternXmlSerializer Class See Also Send Feedback
Gets an XElement containing the details of the recurrence pattern.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static XElement ToXml(
    this IRecurrencePattern pattern
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ToXml ( _
    pattern As IRecurrencePattern _
) As XElement
Visual C++
[ExtensionAttribute]
public:
static XElement^ ToXml(
    IRecurrencePattern^ pattern
)

Parameters

pattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern to serialize.

Return Value

An XElement representing the recurrence pattern.

See Also

RecurrencePatternXmlSerializer Class


ReflectionPositionConverter Class

[image]

Mindscape Silverlight Elements
ReflectionPositionConverter Class
Members See Also Send Feedback
Calculates the offset of reflection elements within a CoverFlow.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ReflectionPositionConverter : IValueConverter
Visual Basic (Declaration)
Public Class ReflectionPositionConverter _
    Implements IValueConverter
Visual C++
public ref class ReflectionPositionConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ReflectionPositionConverter

See Also

ReflectionPositionConverter Members


ReflectionPositionConverter Members

[image] [image]

Mindscape Silverlight Elements
ReflectionPositionConverter Members
ReflectionPositionConverter Class Constructors Methods Properties See Also Send Feedback

The ReflectionPositionConverter type exposes the following members.

Constructors

Name | Description
ReflectionPositionConverter | Initializes a new instance of the ReflectionPositionConverter class

Methods

Name | Description
Convert | Converts a value from a binding source for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Offset | An offset that is added to the supplied value.

See Also

ReflectionPositionConverter Class


ReflectionPositionConverter Constructor

[image]

Mindscape Silverlight Elements
ReflectionPositionConverter Constructor
ReflectionPositionConverter Class See Also Send Feedback
Initializes a new instance of the ReflectionPositionConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReflectionPositionConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReflectionPositionConverter()

See Also

ReflectionPositionConverter Class


ReflectionPositionConverter Methods

[image] [image]

Mindscape Silverlight Elements
ReflectionPositionConverter Methods
ReflectionPositionConverter Class See Also Send Feedback

The ReflectionPositionConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a value from a binding source for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReflectionPositionConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ReflectionPositionConverter..::.Convert Method
ReflectionPositionConverter Class See Also Send Feedback
Converts a value from a binding source for use by a binding target.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ReflectionPositionConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ReflectionPositionConverter..::.ConvertBack Method
ReflectionPositionConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ReflectionPositionConverter Class


ReflectionPositionConverter Properties

[image] [image]

Mindscape Silverlight Elements
ReflectionPositionConverter Properties
ReflectionPositionConverter Class See Also Send Feedback

The ReflectionPositionConverter type exposes the following members.

Properties

Name | Description
Offset | An offset that is added to the supplied value.

See Also

ReflectionPositionConverter Class


Offset Property

[image]

Mindscape Silverlight Elements
ReflectionPositionConverter..::.Offset Property
ReflectionPositionConverter Class See Also Send Feedback
An offset that is added to the supplied value.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Double
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

See Also

ReflectionPositionConverter Class


RichTextEditor Class

[image]

Mindscape Silverlight Elements
RichTextEditor Class
Members See Also Send Feedback
Provides a user interface for editing formatted text such as HTML.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RichTextEditor : MultipleBlockEditor
Visual Basic (Declaration)
Public Class RichTextEditor _
    Inherits MultipleBlockEditor
Visual C++
public ref class RichTextEditor : public MultipleBlockEditor

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
MultipleBlockEditor
Mindscape.SilverlightElements..::.RichTextEditor

See Also

RichTextEditor Members


RichTextEditor Members

[image] [image]

Mindscape Silverlight Elements
RichTextEditor Members
RichTextEditor Class Constructors Methods Properties Events See Also Send Feedback

The RichTextEditor type exposes the following members.

Constructors

Name | Description
RichTextEditor | Initializes a new instance of the RichTextEditor class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyBackground | Applies the specified background to the current selection.
ApplyFontFamily | Applies the specified font family to the current selection.
ApplyFontSize | Applies the specified font size to the current selection.
ApplyFontStyle | Applies the specified font style to the current selection.
ApplyFontWeight | Applies the specified font weight to the current selection.
ApplyForeground | Applies the specified foreground to the current selection.
ApplyHyperlink | Formats the current selection as a hyperlink.
ApplyTemplate | (Inherited from Control.)
ApplyTextDecorations | Applies the specified text decorations to the current selection.
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
EditHyperlink | Changes the destination of the hyperlink of the current selection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindElementAtPoint | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorFindElementAtPoint(Point, Int32%).)
FindIndexOfEditor | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorFindIndexOfEditor(SingleBlockEditor).)
FindIndexOfElement | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorFindIndexOfElement(UIElement).)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
ForceOverflowWithBackspace | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorForceOverflowWithBackspace(Object).)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InsertList | Inserts a list at the current caret position.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
ItemFocusedCore | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorItemFocusedCore()()().)
LoadHtml | Loads existing HTML into the RichTextEditor.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveHyperlink | Removes any hyperlink from the current selection.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SplitListAtCaret | Splits the current list at the caret position. If the caret is not in a list, this has no effect.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Html | Gets a HTML representation of the formatted text in the RichTextEditor.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedBlockType | Gets the current type of selection in the RichTextEditor.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets the paragraph alignment of the current selection.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

RichTextEditor Class


RichTextEditor Constructor

[image]

Mindscape Silverlight Elements
RichTextEditor Constructor
RichTextEditor Class See Also Send Feedback
Initializes a new instance of the RichTextEditor class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RichTextEditor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RichTextEditor()

See Also

RichTextEditor Class


RichTextEditor Methods

[image] [image]

Mindscape Silverlight Elements
RichTextEditor Methods
RichTextEditor Class See Also Send Feedback

The RichTextEditor type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyBackground | Applies the specified background to the current selection.
ApplyFontFamily | Applies the specified font family to the current selection.
ApplyFontSize | Applies the specified font size to the current selection.
ApplyFontStyle | Applies the specified font style to the current selection.
ApplyFontWeight | Applies the specified font weight to the current selection.
ApplyForeground | Applies the specified foreground to the current selection.
ApplyHyperlink | Formats the current selection as a hyperlink.
ApplyTemplate | (Inherited from Control.)
ApplyTextDecorations | Applies the specified text decorations to the current selection.
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
EditHyperlink | Changes the destination of the hyperlink of the current selection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindElementAtPoint | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorFindElementAtPoint(Point, Int32%).)
FindIndexOfEditor | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorFindIndexOfEditor(SingleBlockEditor).)
FindIndexOfElement | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorFindIndexOfElement(UIElement).)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
ForceOverflowWithBackspace | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorForceOverflowWithBackspace(Object).)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InsertList | Inserts a list at the current caret position.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
ItemFocusedCore | This member supports the RichTextEditor control and is not intended for use from your code. (Overrides MultipleBlockEditorItemFocusedCore()()().)
LoadHtml | Loads existing HTML into the RichTextEditor.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
RemoveHyperlink | Removes any hyperlink from the current selection.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SplitListAtCaret | Splits the current list at the caret position. If the caret is not in a list, this has no effect.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

RichTextEditor Class


ApplyBackground Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyBackground Method
RichTextEditor Class See Also Send Feedback
Applies the specified background to the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyBackground(
    Brush background
)
Visual Basic (Declaration)
Public Sub ApplyBackground ( _
    background As Brush _
)
Visual C++
public:
virtual void ApplyBackground(
    Brush^ background
) sealed

Parameters

background
Type: System.Windows.Media..::.Brush
The background to be applied. This must be a SolidColorBrush.

See Also

RichTextEditor Class


ApplyFontFamily Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyFontFamily Method
RichTextEditor Class See Also Send Feedback
Applies the specified font family to the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyFontFamily(
    FontFamily fontFamily
)
Visual Basic (Declaration)
Public Sub ApplyFontFamily ( _
    fontFamily As FontFamily _
)
Visual C++
public:
virtual void ApplyFontFamily(
    FontFamily^ fontFamily
) sealed

Parameters

fontFamily
Type: System.Windows.Media..::.FontFamily
The font to be applied.

See Also

RichTextEditor Class


ApplyFontSize Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyFontSize Method
RichTextEditor Class See Also Send Feedback
Applies the specified font size to the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyFontSize(
    double fontSize
)
Visual Basic (Declaration)
Public Sub ApplyFontSize ( _
    fontSize As Double _
)
Visual C++
public:
virtual void ApplyFontSize(
    double fontSize
) sealed

Parameters

fontSize
Type: System..::.Double
The size to be applied.

See Also

RichTextEditor Class


ApplyFontStyle Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyFontStyle Method
RichTextEditor Class See Also Send Feedback
Applies the specified font style to the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyFontStyle(
    FontStyle fontStyle
)
Visual Basic (Declaration)
Public Sub ApplyFontStyle ( _
    fontStyle As FontStyle _
)
Visual C++
public:
virtual void ApplyFontStyle(
    FontStyle fontStyle
) sealed

Parameters

fontStyle
Type: System.Windows..::.FontStyle
The style to be applied.

See Also

RichTextEditor Class


ApplyFontWeight Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyFontWeight Method
RichTextEditor Class See Also Send Feedback
Applies the specified font weight to the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyFontWeight(
    FontWeight fontWeight
)
Visual Basic (Declaration)
Public Sub ApplyFontWeight ( _
    fontWeight As FontWeight _
)
Visual C++
public:
virtual void ApplyFontWeight(
    FontWeight fontWeight
) sealed

Parameters

fontWeight
Type: System.Windows..::.FontWeight
The font weight to be applied.

See Also

RichTextEditor Class


ApplyForeground Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyForeground Method
RichTextEditor Class See Also Send Feedback
Applies the specified foreground to the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyForeground(
    Brush foreground
)
Visual Basic (Declaration)
Public Sub ApplyForeground ( _
    foreground As Brush _
)
Visual C++
public:
virtual void ApplyForeground(
    Brush^ foreground
) sealed

Parameters

foreground
Type: System.Windows.Media..::.Brush
The foreground to be applied. This must be a SolidColorBrush.

See Also

RichTextEditor Class


ApplyHyperlink Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyHyperlink Method
RichTextEditor Class See Also Send Feedback
Formats the current selection as a hyperlink.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyHyperlink(
    string hyperlink
)
Visual Basic (Declaration)
Public Sub ApplyHyperlink ( _
    hyperlink As String _
)
Visual C++
public:
virtual void ApplyHyperlink(
    String^ hyperlink
) sealed

Parameters

hyperlink
Type: System..::.String
The URL to hyperlink to.

See Also

RichTextEditor Class


ApplyTextDecorations Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ApplyTextDecorations Method
RichTextEditor Class See Also Send Feedback
Applies the specified text decorations to the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ApplyTextDecorations(
    TextDecorationCollection textDecorations
)
Visual Basic (Declaration)
Public Sub ApplyTextDecorations ( _
    textDecorations As TextDecorationCollection _
)
Visual C++
public:
virtual void ApplyTextDecorations(
    TextDecorationCollection^ textDecorations
) sealed

Parameters

textDecorations
Type: System.Windows..::.TextDecorationCollection
The decorations to be applied.

See Also

RichTextEditor Class


EditHyperlink Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.EditHyperlink Method
RichTextEditor Class See Also Send Feedback
Changes the destination of the hyperlink of the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void EditHyperlink(
    string newHyperlink
)
Visual Basic (Declaration)
Public Sub EditHyperlink ( _
    newHyperlink As String _
)
Visual C++
public:
virtual void EditHyperlink(
    String^ newHyperlink
) sealed

Parameters

newHyperlink
Type: System..::.String
The URL to hyperlink to.

See Also

RichTextEditor Class


FindElementAtPoint Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.FindElementAtPoint Method
RichTextEditor Class See Also Send Feedback
This member supports the RichTextEditor control and is not intended for use from your code.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override IContainerEditor FindElementAtPoint(
    Point p,
    out int index
)
Visual Basic (Declaration)
Protected Overrides Function FindElementAtPoint ( _
    p As Point, _
    <OutAttribute> ByRef index As Integer _
) As IContainerEditor
Visual C++
protected:
virtual IContainerEditor^ FindElementAtPoint(
    Point p,
    [OutAttribute] int% index
) override

Parameters

p
Type: System.Windows..::.Point

[Missing <param name="p"/> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.FindElementAtPoint(System.Windows.Point,System.Int32@)"]

index
Type: System..::.Int32 %

[Missing <param name="index"/> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.FindElementAtPoint(System.Windows.Point,System.Int32@)"]

Return Value

[Missing <returns> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.FindElementAtPoint(System.Windows.Point,System.Int32@)"]

See Also

RichTextEditor Class


FindIndexOfEditor Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.FindIndexOfEditor Method
RichTextEditor Class See Also Send Feedback
This member supports the RichTextEditor control and is not intended for use from your code.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override int FindIndexOfEditor(
    SingleBlockEditor editor
)
Visual Basic (Declaration)
Protected Overrides Function FindIndexOfEditor ( _
    editor As SingleBlockEditor _
) As Integer
Visual C++
protected:
virtual int FindIndexOfEditor(
    SingleBlockEditor^ editor
) override

Parameters

editor
Type: SingleBlockEditor

[Missing <param name="editor"/> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.FindIndexOfEditor(Mindscape.SilverlightElements.Internal.SingleBlockEditor)"]

Return Value

[Missing <returns> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.FindIndexOfEditor(Mindscape.SilverlightElements.Internal.SingleBlockEditor)"]

See Also

RichTextEditor Class


FindIndexOfElement Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.FindIndexOfElement Method
RichTextEditor Class See Also Send Feedback
This member supports the RichTextEditor control and is not intended for use from your code.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override int FindIndexOfElement(
    UIElement element
)
Visual Basic (Declaration)
Protected Overrides Function FindIndexOfElement ( _
    element As UIElement _
) As Integer
Visual C++
protected:
virtual int FindIndexOfElement(
    UIElement^ element
) override

Parameters

element
Type: System.Windows..::.UIElement

[Missing <param name="element"/> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.FindIndexOfElement(System.Windows.UIElement)"]

Return Value

[Missing <returns> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.FindIndexOfElement(System.Windows.UIElement)"]

See Also

RichTextEditor Class


ForceOverflowWithBackspace Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ForceOverflowWithBackspace Method
RichTextEditor Class See Also Send Feedback
This member supports the RichTextEditor control and is not intended for use from your code.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void ForceOverflowWithBackspace(
    Object element
)
Visual Basic (Declaration)
Protected Overrides Sub ForceOverflowWithBackspace ( _
    element As Object _
)
Visual C++
protected:
virtual void ForceOverflowWithBackspace(
    Object^ element
) override

Parameters

element
Type: System..::.Object

[Missing <param name="element"/> documentation for "M:Mindscape.SilverlightElements.RichTextEditor.ForceOverflowWithBackspace(System.Object)"]

See Also

RichTextEditor Class


InsertList Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.InsertList Method
RichTextEditor Class See Also Send Feedback
Inserts a list at the current caret position.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InsertList(
    IListStyleType listStyleType,
    ListType listType
)
Visual Basic (Declaration)
Public Sub InsertList ( _
    listStyleType As IListStyleType, _
    listType As ListType _
)
Visual C++
public:
void InsertList(
    IListStyleType^ listStyleType,
    ListType listType
)

Parameters

listStyleType
Type: Mindscape.SilverlightElements..::.IListStyleType
The style for the list.
listType
Type: Mindscape.SilverlightElements..::.ListType
Whether the list is ordered or unordered.

See Also

RichTextEditor Class


ItemFocusedCore Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.ItemFocusedCore Method
RichTextEditor Class See Also Send Feedback
This member supports the RichTextEditor control and is not intended for use from your code.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void ItemFocusedCore()
Visual Basic (Declaration)
Protected Overrides Sub ItemFocusedCore
Visual C++
protected:
virtual void ItemFocusedCore() override

See Also

RichTextEditor Class


LoadHtml Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.LoadHtml Method
RichTextEditor Class See Also Send Feedback
Loads existing HTML into the RichTextEditor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void LoadHtml(
    string html
)
Visual Basic (Declaration)
Public Sub LoadHtml ( _
    html As String _
)
Visual C++
public:
void LoadHtml(
    String^ html
)

Parameters

html
Type: System..::.String
The HTML to load for editing.

Remarks

The RichTextEditor supports only a limited subset of HTML. Unrecognised tags or styles will be discarded.

See Also

RichTextEditor Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.OnMouseLeftButtonDown Method
RichTextEditor Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

RichTextEditor Class


RemoveHyperlink Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.RemoveHyperlink Method
RichTextEditor Class See Also Send Feedback
Removes any hyperlink from the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RemoveHyperlink()
Visual Basic (Declaration)
Public Sub RemoveHyperlink
Visual C++
public:
virtual void RemoveHyperlink() sealed

See Also

RichTextEditor Class


SplitListAtCaret Method

[image]

Mindscape Silverlight Elements
RichTextEditor..::.SplitListAtCaret Method
RichTextEditor Class See Also Send Feedback
Splits the current list at the caret position. If the caret is not in a list, this has no effect.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SplitListAtCaret()
Visual Basic (Declaration)
Public Sub SplitListAtCaret
Visual C++
public:
void SplitListAtCaret()

See Also

RichTextEditor Class


RichTextEditor Properties

[image] [image]

Mindscape Silverlight Elements
RichTextEditor Properties
RichTextEditor Class See Also Send Feedback

The RichTextEditor type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Html | Gets a HTML representation of the formatted text in the RichTextEditor.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedBlockType | Gets the current type of selection in the RichTextEditor.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets the paragraph alignment of the current selection.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

RichTextEditor Class


Html Property

[image]

Mindscape Silverlight Elements
RichTextEditor..::.Html Property
RichTextEditor Class See Also Send Feedback
Gets a HTML representation of the formatted text in the RichTextEditor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Html { get; }
Visual Basic (Declaration)
Public ReadOnly Property Html As String
Visual C++
public:
property String^ Html {
    String^ get ();
}

See Also

RichTextEditor Class


SelectedBlockType Property

[image]

Mindscape Silverlight Elements
RichTextEditor..::.SelectedBlockType Property
RichTextEditor Class See Also Send Feedback
Gets the current type of selection in the RichTextEditor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RichTextEditorBlockType SelectedBlockType { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedBlockType As RichTextEditorBlockType
Visual C++
public:
property RichTextEditorBlockType SelectedBlockType {
    RichTextEditorBlockType get ();
}

See Also

RichTextEditor Class


TextAlignment Property

[image]

Mindscape Silverlight Elements
RichTextEditor..::.TextAlignment Property
RichTextEditor Class See Also Send Feedback
Gets or sets the paragraph alignment of the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public HorizontalAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As HorizontalAlignment
Visual C++
public:
virtual property HorizontalAlignment TextAlignment {
    HorizontalAlignment get () sealed;
    void set (HorizontalAlignment value) sealed;
}

See Also

RichTextEditor Class


RichTextEditor Events

[image] [image]

Mindscape Silverlight Elements
RichTextEditor Events
RichTextEditor Class See Also Send Feedback

The RichTextEditor type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

RichTextEditor Class


RichTextEditorBlockType Enumeration

[image]

Mindscape Silverlight Elements
RichTextEditorBlockType Enumeration
See Also Send Feedback
Specifies the type of block element containing the caret in a RichTextEditor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum RichTextEditorBlockType
Visual Basic (Declaration)
Public Enumeration RichTextEditorBlockType
Visual C++
public enum class RichTextEditorBlockType

Members

Member name | Description
Paragraph | A paragraph element (equivalent to a P tag in HTML).
OrderedList | An ordered list element (equivalent to an OL tag in HTML).
UnorderedList | An unordered list element (equivalent to a UL tag in HTML).

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


ScalingConverter Class

[image]

Mindscape Silverlight Elements
ScalingConverter Class
Members See Also Send Feedback
Scales the input by a specified amount.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScalingConverter : IValueConverter
Visual Basic (Declaration)
Public Class ScalingConverter _
    Implements IValueConverter
Visual C++
public ref class ScalingConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ScalingConverter

See Also

ScalingConverter Members


ScalingConverter Members

[image] [image]

Mindscape Silverlight Elements
ScalingConverter Members
ScalingConverter Class Constructors Methods Properties See Also Send Feedback

The ScalingConverter type exposes the following members.

Constructors

Name | Description
ScalingConverter | Initializes a new instance of the ScalingConverter class

Methods

Name | Description
Convert | Converts a double value by scaling according to the ScaleFactor.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ScaleFactor | The amount by which to scale the input.

See Also

ScalingConverter Class


ScalingConverter Constructor

[image]

Mindscape Silverlight Elements
ScalingConverter Constructor
ScalingConverter Class See Also Send Feedback
Initializes a new instance of the ScalingConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScalingConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScalingConverter()

See Also

ScalingConverter Class


ScalingConverter Methods

[image] [image]

Mindscape Silverlight Elements
ScalingConverter Methods
ScalingConverter Class See Also Send Feedback

The ScalingConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a double value by scaling according to the ScaleFactor.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScalingConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ScalingConverter..::.Convert Method
ScalingConverter Class See Also Send Feedback
Converts a double value by scaling according to the ScaleFactor.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value to be scaled.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The scaled value.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ScalingConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ScalingConverter..::.ConvertBack Method
ScalingConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ScalingConverter Class


ScalingConverter Properties

[image] [image]

Mindscape Silverlight Elements
ScalingConverter Properties
ScalingConverter Class See Also Send Feedback

The ScalingConverter type exposes the following members.

Properties

Name | Description
ScaleFactor | The amount by which to scale the input.

See Also

ScalingConverter Class


ScaleFactor Property

[image]

Mindscape Silverlight Elements
ScalingConverter..::.ScaleFactor Property
ScalingConverter Class See Also Send Feedback
The amount by which to scale the input.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ScaleFactor { get; set; }
Visual Basic (Declaration)
Public Property ScaleFactor As Double
Visual C++
public:
property double ScaleFactor {
    double get ();
    void set (double value);
}

See Also

ScalingConverter Class


Schedule Class

[image]

Mindscape Silverlight Elements
Schedule Class
Members See Also Send Feedback
Contains schedule data for display in a Scheduler control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Schedule
Visual Basic (Declaration)
Public Class Schedule
Visual C++
public ref class Schedule

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.Schedule

See Also

Schedule Members


Schedule Members

[image] [image]

Mindscape Silverlight Elements
Schedule Members
Schedule Class Constructors Methods Properties See Also Send Feedback

The Schedule type exposes the following members.

Constructors

Name | Description
Schedule | Initializes a new instance of the Schedule class.

Methods

Name | Description
AddItem | Adds a new item to the schedule.
Clear | Removes all items from the schedule.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveItem | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Items | Gets the collection of items in the Schedule.
SelectedItem | Gets the currently selected schedule item.

See Also

Schedule Class


Schedule Constructor

[image]

Mindscape Silverlight Elements
Schedule Constructor
Schedule Class See Also Send Feedback
Initializes a new instance of the Schedule class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Schedule()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Schedule()

See Also

Schedule Class


Schedule Methods

[image] [image]

Mindscape Silverlight Elements
Schedule Methods
Schedule Class See Also Send Feedback

The Schedule type exposes the following members.

Methods

Name | Description
AddItem | Adds a new item to the schedule.
Clear | Removes all items from the schedule.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RemoveItem | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Schedule Class


AddItem Method

[image]

Mindscape Silverlight Elements
Schedule..::.AddItem Method
Schedule Class See Also Send Feedback
Adds a new item to the schedule.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddItem(
    ScheduleItem scheduleItem
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    scheduleItem As ScheduleItem _
)
Visual C++
public:
void AddItem(
    ScheduleItem^ scheduleItem
)

Parameters

scheduleItem
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to be added.

See Also

Schedule Class


Clear Method

[image]

Mindscape Silverlight Elements
Schedule..::.Clear Method
Schedule Class See Also Send Feedback
Removes all items from the schedule.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Schedule Class


RemoveItem Method

[image] [image]

Mindscape Silverlight Elements
Schedule..::.RemoveItem Method
Schedule Class See Also Send Feedback

Overload List

Name | Description
RemoveItem(ScheduleItem) | Removes an item from the schedule.
RemoveItem(ScheduleItem, Boolean) | Removes an item from the schedule.

See Also

Schedule Class
Schedule Members


RemoveItem Method (ScheduleItem)

[image]

Mindscape Silverlight Elements
Schedule..::.RemoveItem Method (ScheduleItem)
Schedule Class See Also Send Feedback
Removes an item from the schedule.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RemoveItem(
    ScheduleItem item
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    item As ScheduleItem _
)
Visual C++
public:
void RemoveItem(
    ScheduleItem^ item
)

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to be removed.

See Also

Schedule Class
RemoveItem Overload


RemoveItem Method (ScheduleItem, Boolean)

[image]

Mindscape Silverlight Elements
Schedule..::.RemoveItem Method (ScheduleItem, Boolean)
Schedule Class See Also Send Feedback
Removes an item from the schedule.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RemoveItem(
    ScheduleItem item,
    bool removeAllOccurrences
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    item As ScheduleItem, _
    removeAllOccurrences As Boolean _
)
Visual C++
public:
void RemoveItem(
    ScheduleItem^ item,
    bool removeAllOccurrences
)

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to be removed.
removeAllOccurrences
Type: System..::.Boolean
true to remove all occurrences of a recurring item; false to remove only the specified item.

See Also

Schedule Class
RemoveItem Overload


Schedule Properties

[image] [image]

Mindscape Silverlight Elements
Schedule Properties
Schedule Class See Also Send Feedback

The Schedule type exposes the following members.

Properties

Name | Description
Items | Gets the collection of items in the Schedule.
SelectedItem | Gets the currently selected schedule item.

See Also

Schedule Class


Items Property

[image]

Mindscape Silverlight Elements
Schedule..::.Items Property
Schedule Class See Also Send Feedback
Gets the collection of items in the Schedule.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<ScheduleItem> Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ReadOnlyCollection(Of ScheduleItem)
Visual C++
public:
property ReadOnlyCollection<ScheduleItem^>^ Items {
    ReadOnlyCollection<ScheduleItem^>^ get ();
}

See Also

Schedule Class


SelectedItem Property

[image]

Mindscape Silverlight Elements
Schedule..::.SelectedItem Property
Schedule Class See Also Send Feedback
Gets the currently selected schedule item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem SelectedItem { get; private set; }
Visual Basic (Declaration)
Public Property SelectedItem As ScheduleItem
Visual C++
public:
property ScheduleItem^ SelectedItem {
    ScheduleItem^ get ();
    void set (ScheduleItem^ value);
}

See Also

Schedule Class


ScheduleItem Class

[image]

Mindscape Silverlight Elements
ScheduleItem Class
Members See Also Send Feedback
Represents an item such as an appointment or task in a Schedule.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScheduleItem : ViewModelBase
Visual Basic (Declaration)
Public Class ScheduleItem _
    Inherits ViewModelBase
Visual C++
public ref class ScheduleItem : public ViewModelBase

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ViewModelBase
Mindscape.SilverlightElements..::.ScheduleItem

See Also

ScheduleItem Members


ScheduleItem Members

[image] [image]

Mindscape Silverlight Elements
ScheduleItem Members
ScheduleItem Class Constructors Methods Properties Events See Also Send Feedback

The ScheduleItem type exposes the following members.

Constructors

Name | Description
ScheduleItem | Initializes a new instance of the ScheduleItem class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBy | Moves the item by the specified time.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
OnRecurrenceChanged | Raises the RecurrenceChanged event.
RecurForever | Specifies that the ScheduleItem should recur indefinitely.
RecurTimes | Specifies that the ScheduleItem should recur for the specified number of occurrences.
RecurUntil | Specifies that the ScheduleItem should recur until the specified date.
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
EndTime | Gets or sets when the item ends.
IsInstanceOfRecurringItem | Gets whether the item is an instance of a recurring ScheduleItem.
IsRecurring | Gets whether the item is recurring.
IsSelected | Gets or sets whether the item is selected.
Name | Gets or sets the name of the item.
RecurrenceInfo | Gets or sets the item's recurrence behaviour. This will be null if the item is not recurring.
StartTime | Gets or sets when the item starts.

Events

Name | Description
EndTimeChanged | Occurs when the item's EndTime changes.
IsSelectedChanged | Occurs when the item's selection status changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RecurrenceChanged | Occurs when the item's recurrence information changes.
StartTimeChanged | Occurs when the item's StartTime changes.

See Also

ScheduleItem Class


ScheduleItem Constructor

[image]

Mindscape Silverlight Elements
ScheduleItem Constructor
ScheduleItem Class See Also Send Feedback
Initializes a new instance of the ScheduleItem class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScheduleItem()

See Also

ScheduleItem Class


ScheduleItem Methods

[image] [image]

Mindscape Silverlight Elements
ScheduleItem Methods
ScheduleItem Class See Also Send Feedback

The ScheduleItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveBy | Moves the item by the specified time.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
OnRecurrenceChanged | Raises the RecurrenceChanged event.
RecurForever | Specifies that the ScheduleItem should recur indefinitely.
RecurTimes | Specifies that the ScheduleItem should recur for the specified number of occurrences.
RecurUntil | Specifies that the ScheduleItem should recur until the specified date.
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleItem Class


MoveBy Method

[image]

Mindscape Silverlight Elements
ScheduleItem..::.MoveBy Method
ScheduleItem Class See Also Send Feedback
Moves the item by the specified time.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void MoveBy(
    int deltaMinutes
)
Visual Basic (Declaration)
Public Sub MoveBy ( _
    deltaMinutes As Integer _
)
Visual C++
public:
void MoveBy(
    int deltaMinutes
)

Parameters

deltaMinutes
Type: System..::.Int32
The time to offset the item, in minutes.

See Also

ScheduleItem Class


OnRecurrenceChanged Method

[image]

Mindscape Silverlight Elements
ScheduleItem..::.OnRecurrenceChanged Method
ScheduleItem Class See Also Send Feedback
Raises the RecurrenceChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnRecurrenceChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnRecurrenceChanged
Visual C++
protected:
virtual void OnRecurrenceChanged()

See Also

ScheduleItem Class


RecurForever Method

[image]

Mindscape Silverlight Elements
ScheduleItem..::.RecurForever Method
ScheduleItem Class See Also Send Feedback
Specifies that the ScheduleItem should recur indefinitely.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RecurForever(
    IRecurrencePattern recurrencePattern
)
Visual Basic (Declaration)
Public Sub RecurForever ( _
    recurrencePattern As IRecurrencePattern _
)
Visual C++
public:
void RecurForever(
    IRecurrencePattern^ recurrencePattern
)

Parameters

recurrencePattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern.

See Also

ScheduleItem Class


RecurTimes Method

[image]

Mindscape Silverlight Elements
ScheduleItem..::.RecurTimes Method
ScheduleItem Class See Also Send Feedback
Specifies that the ScheduleItem should recur for the specified number of occurrences.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RecurTimes(
    int maxOccurrences,
    IRecurrencePattern recurrencePattern
)
Visual Basic (Declaration)
Public Sub RecurTimes ( _
    maxOccurrences As Integer, _
    recurrencePattern As IRecurrencePattern _
)
Visual C++
public:
void RecurTimes(
    int maxOccurrences,
    IRecurrencePattern^ recurrencePattern
)

Parameters

maxOccurrences
Type: System..::.Int32
The number of times the item should recur.
recurrencePattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern.

See Also

ScheduleItem Class


RecurUntil Method

[image]

Mindscape Silverlight Elements
ScheduleItem..::.RecurUntil Method
ScheduleItem Class See Also Send Feedback
Specifies that the ScheduleItem should recur until the specified date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RecurUntil(
    DateTime until,
    IRecurrencePattern recurrencePattern
)
Visual Basic (Declaration)
Public Sub RecurUntil ( _
    until As DateTime, _
    recurrencePattern As IRecurrencePattern _
)
Visual C++
public:
void RecurUntil(
    DateTime until,
    IRecurrencePattern^ recurrencePattern
)

Parameters

until
Type: System..::.DateTime
The date until which the item should recur.
recurrencePattern
Type: Mindscape.SilverlightElements..::.IRecurrencePattern
The recurrence pattern.

See Also

ScheduleItem Class


ScheduleItem Properties

[image] [image]

Mindscape Silverlight Elements
ScheduleItem Properties
ScheduleItem Class See Also Send Feedback

The ScheduleItem type exposes the following members.

Properties

Name | Description
EndTime | Gets or sets when the item ends.
IsInstanceOfRecurringItem | Gets whether the item is an instance of a recurring ScheduleItem.
IsRecurring | Gets whether the item is recurring.
IsSelected | Gets or sets whether the item is selected.
Name | Gets or sets the name of the item.
RecurrenceInfo | Gets or sets the item's recurrence behaviour. This will be null if the item is not recurring.
StartTime | Gets or sets when the item starts.

See Also

ScheduleItem Class


EndTime Property

[image]

Mindscape Silverlight Elements
ScheduleItem..::.EndTime Property
ScheduleItem Class See Also Send Feedback
Gets or sets when the item ends.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic (Declaration)
Public Property EndTime As DateTime
Visual C++
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

ScheduleItem Class


IsInstanceOfRecurringItem Property

[image]

Mindscape Silverlight Elements
ScheduleItem..::.IsInstanceOfRecurringItem Property
ScheduleItem Class See Also Send Feedback
Gets whether the item is an instance of a recurring ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInstanceOfRecurringItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInstanceOfRecurringItem As Boolean
Visual C++
public:
property bool IsInstanceOfRecurringItem {
    bool get ();
}

See Also

ScheduleItem Class


IsRecurring Property

[image]

Mindscape Silverlight Elements
ScheduleItem..::.IsRecurring Property
ScheduleItem Class See Also Send Feedback
Gets whether the item is recurring.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsRecurring { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRecurring As Boolean
Visual C++
public:
property bool IsRecurring {
    bool get ();
}

See Also

ScheduleItem Class


IsSelected Property

[image]

Mindscape Silverlight Elements
ScheduleItem..::.IsSelected Property
ScheduleItem Class See Also Send Feedback
Gets or sets whether the item is selected.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

ScheduleItem Class


Name Property

[image]

Mindscape Silverlight Elements
ScheduleItem..::.Name Property
ScheduleItem Class See Also Send Feedback
Gets or sets the name of the item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ScheduleItem Class


RecurrenceInfo Property

[image]

Mindscape Silverlight Elements
ScheduleItem..::.RecurrenceInfo Property
ScheduleItem Class See Also Send Feedback
Gets or sets the item's recurrence behaviour. This will be null if the item is not recurring.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RecurrenceInfo RecurrenceInfo { get; set; }
Visual Basic (Declaration)
Public Property RecurrenceInfo As RecurrenceInfo
Visual C++
public:
property RecurrenceInfo^ RecurrenceInfo {
    RecurrenceInfo^ get ();
    void set (RecurrenceInfo^ value);
}

See Also

ScheduleItem Class


StartTime Property

[image]

Mindscape Silverlight Elements
ScheduleItem..::.StartTime Property
ScheduleItem Class See Also Send Feedback
Gets or sets when the item starts.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime StartTime { get; set; }
Visual Basic (Declaration)
Public Property StartTime As DateTime
Visual C++
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

ScheduleItem Class


ScheduleItem Events

[image] [image]

Mindscape Silverlight Elements
ScheduleItem Events
ScheduleItem Class See Also Send Feedback

The ScheduleItem type exposes the following members.

Events

Name | Description
EndTimeChanged | Occurs when the item's EndTime changes.
IsSelectedChanged | Occurs when the item's selection status changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RecurrenceChanged | Occurs when the item's recurrence information changes.
StartTimeChanged | Occurs when the item's StartTime changes.

See Also

ScheduleItem Class


EndTimeChanged Event

[image]

Mindscape Silverlight Elements
ScheduleItem..::.EndTimeChanged Event
ScheduleItem Class See Also Send Feedback
Occurs when the item's EndTime changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler EndTimeChanged
Visual Basic (Declaration)
Public Event EndTimeChanged As EventHandler
Visual C++
public:
 event EventHandler^ EndTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ScheduleItem Class


IsSelectedChanged Event

[image]

Mindscape Silverlight Elements
ScheduleItem..::.IsSelectedChanged Event
ScheduleItem Class See Also Send Feedback
Occurs when the item's selection status changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler IsSelectedChanged
Visual Basic (Declaration)
Public Event IsSelectedChanged As EventHandler
Visual C++
public:
 event EventHandler^ IsSelectedChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ScheduleItem Class


RecurrenceChanged Event

[image]

Mindscape Silverlight Elements
ScheduleItem..::.RecurrenceChanged Event
ScheduleItem Class See Also Send Feedback
Occurs when the item's recurrence information changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler RecurrenceChanged
Visual Basic (Declaration)
Public Event RecurrenceChanged As EventHandler
Visual C++
public:
 event EventHandler^ RecurrenceChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ScheduleItem Class


StartTimeChanged Event

[image]

Mindscape Silverlight Elements
ScheduleItem..::.StartTimeChanged Event
ScheduleItem Class See Also Send Feedback
Occurs when the item's StartTime changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler StartTimeChanged
Visual Basic (Declaration)
Public Event StartTimeChanged As EventHandler
Visual C++
public:
 event EventHandler^ StartTimeChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

ScheduleItem Class


ScheduleItemCollectionChangedEventArgs Class

[image]

Mindscape Silverlight Elements
ScheduleItemCollectionChangedEventArgs Class
Members See Also Send Feedback
Provides event data for when a ScheduleItem is added to or removed from a collection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScheduleItemCollectionChangedEventArgs : ScheduleItemEventArgs
Visual Basic (Declaration)
Public Class ScheduleItemCollectionChangedEventArgs _
    Inherits ScheduleItemEventArgs
Visual C++
public ref class ScheduleItemCollectionChangedEventArgs : public ScheduleItemEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mindscape.SilverlightElements..::.ScheduleItemEventArgs
Mindscape.SilverlightElements..::.ScheduleItemCollectionChangedEventArgs

See Also

ScheduleItemCollectionChangedEventArgs Members


ScheduleItemCollectionChangedEventArgs Members

[image] [image]

Mindscape Silverlight Elements
ScheduleItemCollectionChangedEventArgs Members
ScheduleItemCollectionChangedEventArgs Class Methods Properties See Also Send Feedback

The ScheduleItemCollectionChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | Whether the ScheduleItem is being added to or removed from the collection.
Item | The ScheduleItem to which the event pertains. (Inherited from ScheduleItemEventArgs.)

See Also

ScheduleItemCollectionChangedEventArgs Class


ScheduleItemCollectionChangedEventArgs Methods

[image] [image]

Mindscape Silverlight Elements
ScheduleItemCollectionChangedEventArgs Methods
ScheduleItemCollectionChangedEventArgs Class See Also Send Feedback

The ScheduleItemCollectionChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleItemCollectionChangedEventArgs Class


ScheduleItemCollectionChangedEventArgs Properties

[image] [image]

Mindscape Silverlight Elements
ScheduleItemCollectionChangedEventArgs Properties
ScheduleItemCollectionChangedEventArgs Class See Also Send Feedback

The ScheduleItemCollectionChangedEventArgs type exposes the following members.

Properties

Name | Description
Action | Whether the ScheduleItem is being added to or removed from the collection.
Item | The ScheduleItem to which the event pertains. (Inherited from ScheduleItemEventArgs.)

See Also

ScheduleItemCollectionChangedEventArgs Class


Action Property

[image]

Mindscape Silverlight Elements
ScheduleItemCollectionChangedEventArgs..::.Action Property
ScheduleItemCollectionChangedEventArgs Class See Also Send Feedback
Whether the ScheduleItem is being added to or removed from the collection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NotifyCollectionChangedAction Action { get; }
Visual Basic (Declaration)
Public ReadOnly Property Action As NotifyCollectionChangedAction
Visual C++
public:
property NotifyCollectionChangedAction Action {
    NotifyCollectionChangedAction get ();
}

See Also

ScheduleItemCollectionChangedEventArgs Class


ScheduleItemDialog Class

[image]

Mindscape Silverlight Elements
ScheduleItemDialog Class
Members See Also Send Feedback
Provides a dialog-based interface for editing a ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScheduleItemDialog : ChildWindow
Visual Basic (Declaration)
Public Class ScheduleItemDialog _
    Inherits ChildWindow
Visual C++
public ref class ScheduleItemDialog : public ChildWindow

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
ChildWindow
Mindscape.SilverlightElements..::.ScheduleItemDialog

See Also

ScheduleItemDialog Members


ScheduleItemDialog Members

[image] [image]

Mindscape Silverlight Elements
ScheduleItemDialog Members
ScheduleItemDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The ScheduleItemDialog type exposes the following members.

Constructors

Name | Description
ScheduleItemDialog | Initializes a new instance of the ScheduleItemDialog class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | (Inherited from ChildWindow.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InitializeComponent | InitializeComponent
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ChildWindow.)
OnClosed | (Inherited from ChildWindow.)
OnClosing | (Inherited from ChildWindow.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ChildWindow.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnOpened | (Inherited from ChildWindow.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | (Inherited from ChildWindow.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
EndDateProperty | Identifies the EndDate property.
EndTimeProperty | Identifies the EndTime property.
StartDateProperty | Identifies the StartDate property.
StartTimeProperty | Identifies the StartTime property.
SubjectProperty | Identifies the Subject property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DialogResult | (Inherited from ChildWindow.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets or sets the EndDate. This is a dependency property.
EndTime | Gets or sets the EndTime. This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasCloseButton | (Inherited from ChildWindow.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverlayBrush | (Inherited from ChildWindow.)
OverlayOpacity | (Inherited from ChildWindow.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets the ScheduleItem being edited.
StartDate | Gets or sets the StartDate. This is a dependency property.
StartTime | Gets or sets the StartTime. This is a dependency property.
Style | (Inherited from FrameworkElement.)
Subject | Gets or sets the Subject. This is a dependency property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Title | (Inherited from ChildWindow.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | (Inherited from ChildWindow.)
Closing | (Inherited from ChildWindow.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleItemDialog Class


ScheduleItemDialog Constructor

[image]

Mindscape Silverlight Elements
ScheduleItemDialog Constructor
ScheduleItemDialog Class See Also Send Feedback
Initializes a new instance of the ScheduleItemDialog class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItemDialog(
    ScheduleItem item
)
Visual Basic (Declaration)
Public Sub New ( _
    item As ScheduleItem _
)
Visual C++
public:
ScheduleItemDialog(
    ScheduleItem^ item
)

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to be edited.

See Also

ScheduleItemDialog Class


ScheduleItemDialog Fields

[image] [image]

Mindscape Silverlight Elements
ScheduleItemDialog Fields
ScheduleItemDialog Class See Also Send Feedback

The ScheduleItemDialog type exposes the following members.

Fields

Name | Description
EndDateProperty | Identifies the EndDate property.
EndTimeProperty | Identifies the EndTime property.
StartDateProperty | Identifies the StartDate property.
StartTimeProperty | Identifies the StartTime property.
SubjectProperty | Identifies the Subject property.

See Also

ScheduleItemDialog Class


EndDateProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.EndDateProperty Field
ScheduleItemDialog Class See Also Send Feedback
Identifies the EndDate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty EndDateProperty
Visual Basic (Declaration)
Public Shared ReadOnly EndDateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ EndDateProperty

See Also

ScheduleItemDialog Class


EndTimeProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.EndTimeProperty Field
ScheduleItemDialog Class See Also Send Feedback
Identifies the EndTime property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty EndTimeProperty
Visual Basic (Declaration)
Public Shared ReadOnly EndTimeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ EndTimeProperty

See Also

ScheduleItemDialog Class


StartDateProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.StartDateProperty Field
ScheduleItemDialog Class See Also Send Feedback
Identifies the StartDate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty StartDateProperty
Visual Basic (Declaration)
Public Shared ReadOnly StartDateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ StartDateProperty

See Also

ScheduleItemDialog Class


StartTimeProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.StartTimeProperty Field
ScheduleItemDialog Class See Also Send Feedback
Identifies the StartTime property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty StartTimeProperty
Visual Basic (Declaration)
Public Shared ReadOnly StartTimeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ StartTimeProperty

See Also

ScheduleItemDialog Class


SubjectProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.SubjectProperty Field
ScheduleItemDialog Class See Also Send Feedback
Identifies the Subject property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SubjectProperty
Visual Basic (Declaration)
Public Shared ReadOnly SubjectProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SubjectProperty

See Also

ScheduleItemDialog Class


ScheduleItemDialog Methods

[image] [image]

Mindscape Silverlight Elements
ScheduleItemDialog Methods
ScheduleItemDialog Class See Also Send Feedback

The ScheduleItemDialog type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | (Inherited from ChildWindow.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InitializeComponent | InitializeComponent
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ChildWindow.)
OnClosed | (Inherited from ChildWindow.)
OnClosing | (Inherited from ChildWindow.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ChildWindow.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnOpened | (Inherited from ChildWindow.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | (Inherited from ChildWindow.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ScheduleItemDialog Class


InitializeComponent Method

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.InitializeComponent Method
ScheduleItemDialog Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

ScheduleItemDialog Class


ScheduleItemDialog Properties

[image] [image]

Mindscape Silverlight Elements
ScheduleItemDialog Properties
ScheduleItemDialog Class See Also Send Feedback

The ScheduleItemDialog type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DialogResult | (Inherited from ChildWindow.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets or sets the EndDate. This is a dependency property.
EndTime | Gets or sets the EndTime. This is a dependency property.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasCloseButton | (Inherited from ChildWindow.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OverlayBrush | (Inherited from ChildWindow.)
OverlayOpacity | (Inherited from ChildWindow.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets the ScheduleItem being edited.
StartDate | Gets or sets the StartDate. This is a dependency property.
StartTime | Gets or sets the StartTime. This is a dependency property.
Style | (Inherited from FrameworkElement.)
Subject | Gets or sets the Subject. This is a dependency property.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Title | (Inherited from ChildWindow.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ScheduleItemDialog Class


EndDate Property

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.EndDate Property
ScheduleItemDialog Class See Also Send Feedback
Gets or sets the EndDate. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic (Declaration)
Public Property EndDate As DateTime
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ScheduleItemDialog Class


EndTime Property

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.EndTime Property
ScheduleItemDialog Class See Also Send Feedback
Gets or sets the EndTime. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay EndTime { get; set; }
Visual Basic (Declaration)
Public Property EndTime As TimeOfDay
Visual C++
public:
property TimeOfDay EndTime {
    TimeOfDay get ();
    void set (TimeOfDay value);
}

See Also

ScheduleItemDialog Class


ScheduleItem Property

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.ScheduleItem Property
ScheduleItemDialog Class See Also Send Feedback
Gets the ScheduleItem being edited.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem ScheduleItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScheduleItem As ScheduleItem
Visual C++
public:
property ScheduleItem^ ScheduleItem {
    ScheduleItem^ get ();
}

See Also

ScheduleItemDialog Class


StartDate Property

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.StartDate Property
ScheduleItemDialog Class See Also Send Feedback
Gets or sets the StartDate. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ScheduleItemDialog Class


StartTime Property

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.StartTime Property
ScheduleItemDialog Class See Also Send Feedback
Gets or sets the StartTime. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay StartTime { get; set; }
Visual Basic (Declaration)
Public Property StartTime As TimeOfDay
Visual C++
public:
property TimeOfDay StartTime {
    TimeOfDay get ();
    void set (TimeOfDay value);
}

See Also

ScheduleItemDialog Class


Subject Property

[image]

Mindscape Silverlight Elements
ScheduleItemDialog..::.Subject Property
ScheduleItemDialog Class See Also Send Feedback
Gets or sets the Subject. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Subject { get; set; }
Visual Basic (Declaration)
Public Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

ScheduleItemDialog Class


ScheduleItemDialog Events

[image] [image]

Mindscape Silverlight Elements
ScheduleItemDialog Events
ScheduleItemDialog Class See Also Send Feedback

The ScheduleItemDialog type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | (Inherited from ChildWindow.)
Closing | (Inherited from ChildWindow.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleItemDialog Class


ScheduleItemEventArgs Class

[image]

Mindscape Silverlight Elements
ScheduleItemEventArgs Class
Members See Also Send Feedback
Provides data for an event pertaining to a ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScheduleItemEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ScheduleItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class ScheduleItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Mindscape.SilverlightElements..::.ScheduleItemEventArgs
Mindscape.SilverlightElements..::.AddScheduleItemEventArgs
Mindscape.SilverlightElements..::.ScheduleItemCollectionChangedEventArgs

See Also

ScheduleItemEventArgs Members


ScheduleItemEventArgs Members

[image] [image]

Mindscape Silverlight Elements
ScheduleItemEventArgs Members
ScheduleItemEventArgs Class Methods Properties See Also Send Feedback

The ScheduleItemEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | The ScheduleItem to which the event pertains.

See Also

ScheduleItemEventArgs Class


ScheduleItemEventArgs Methods

[image] [image]

Mindscape Silverlight Elements
ScheduleItemEventArgs Methods
ScheduleItemEventArgs Class See Also Send Feedback

The ScheduleItemEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleItemEventArgs Class


ScheduleItemEventArgs Properties

[image] [image]

Mindscape Silverlight Elements
ScheduleItemEventArgs Properties
ScheduleItemEventArgs Class See Also Send Feedback

The ScheduleItemEventArgs type exposes the following members.

Properties

Name | Description
Item | The ScheduleItem to which the event pertains.

See Also

ScheduleItemEventArgs Class


Item Property

[image]

Mindscape Silverlight Elements
ScheduleItemEventArgs..::.Item Property
ScheduleItemEventArgs Class See Also Send Feedback
The ScheduleItem to which the event pertains.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem Item { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item As ScheduleItem
Visual C++
public:
property ScheduleItem^ Item {
    ScheduleItem^ get ();
}

See Also

ScheduleItemEventArgs Class


ScheduleItemMover Class

[image]

Mindscape Silverlight Elements
ScheduleItemMover Class
Members See Also Send Feedback
Provides a user interface for moving a ScheduleItem by dragging with the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScheduleItemMover : Control
Visual Basic (Declaration)
Public Class ScheduleItemMover _
    Inherits Control
Visual C++
public ref class ScheduleItemMover : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ScheduleItemMover

See Also

ScheduleItemMover Members


ScheduleItemMover Members

[image] [image]

Mindscape Silverlight Elements
ScheduleItemMover Members
ScheduleItemMover Class Constructors Methods Fields Properties Events See Also Send Feedback

The ScheduleItemMover type exposes the following members.

Constructors

Name | Description
ScheduleItemMover | Initializes a new instance of the ScheduleItemMover class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | Called by the framework when the mouse leaves the control. (Overrides ControlOnMouseLeave(MouseEventArgs).)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ControlOnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ScheduleItemProperty | Identifies the ScheduleItem property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets or sets the ScheduleItem associated with the mover. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleItemMover Class


ScheduleItemMover Constructor

[image]

Mindscape Silverlight Elements
ScheduleItemMover Constructor
ScheduleItemMover Class See Also Send Feedback
Initializes a new instance of the ScheduleItemMover class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItemMover()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScheduleItemMover()

See Also

ScheduleItemMover Class


ScheduleItemMover Fields

[image] [image]

Mindscape Silverlight Elements
ScheduleItemMover Fields
ScheduleItemMover Class See Also Send Feedback

The ScheduleItemMover type exposes the following members.

Fields

Name | Description
ScheduleItemProperty | Identifies the ScheduleItem property.

See Also

ScheduleItemMover Class


ScheduleItemProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemMover..::.ScheduleItemProperty Field
ScheduleItemMover Class See Also Send Feedback
Identifies the ScheduleItem property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ScheduleItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly ScheduleItemProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ScheduleItemProperty

See Also

ScheduleItemMover Class


ScheduleItemMover Methods

[image] [image]

Mindscape Silverlight Elements
ScheduleItemMover Methods
ScheduleItemMover Class See Also Send Feedback

The ScheduleItemMover type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | Called by the framework when the mouse leaves the control. (Overrides ControlOnMouseLeave(MouseEventArgs).)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ControlOnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ScheduleItemMover Class


OnMouseLeave Method

[image]

Mindscape Silverlight Elements
ScheduleItemMover..::.OnMouseLeave Method
ScheduleItemMover Class See Also Send Feedback
Called by the framework when the mouse leaves the control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeave(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The mouse event data.

See Also

ScheduleItemMover Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
ScheduleItemMover..::.OnMouseLeftButtonDown Method
ScheduleItemMover Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

ScheduleItemMover Class


OnMouseLeftButtonUp Method

[image]

Mindscape Silverlight Elements
ScheduleItemMover..::.OnMouseLeftButtonUp Method
ScheduleItemMover Class See Also Send Feedback
Called by the framework when the user releases the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

ScheduleItemMover Class


OnMouseMove Method

[image]

Mindscape Silverlight Elements
ScheduleItemMover..::.OnMouseMove Method
ScheduleItemMover Class See Also Send Feedback
Called by the framework when the user moves the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The mouse event data.

See Also

ScheduleItemMover Class


ScheduleItemMover Properties

[image] [image]

Mindscape Silverlight Elements
ScheduleItemMover Properties
ScheduleItemMover Class See Also Send Feedback

The ScheduleItemMover type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets or sets the ScheduleItem associated with the mover. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ScheduleItemMover Class


ScheduleItem Property

[image]

Mindscape Silverlight Elements
ScheduleItemMover..::.ScheduleItem Property
ScheduleItemMover Class See Also Send Feedback
Gets or sets the ScheduleItem associated with the mover. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem ScheduleItem { get; set; }
Visual Basic (Declaration)
Public Property ScheduleItem As ScheduleItem
Visual C++
public:
property ScheduleItem^ ScheduleItem {
    ScheduleItem^ get ();
    void set (ScheduleItem^ value);
}

Remarks

Dependency Property Information
Identifier field | ScheduleItemProperty
Metadata properties set to true | None

See Also

ScheduleItemMover Class


ScheduleItemMover Events

[image] [image]

Mindscape Silverlight Elements
ScheduleItemMover Events
ScheduleItemMover Class See Also Send Feedback

The ScheduleItemMover type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleItemMover Class


ScheduleItemTimeChanger Class

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger Class
Members See Also Send Feedback
Provides a user interface for changing the start or end time of a ScheduleItem by dragging with the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ScheduleItemTimeChanger : Control
Visual Basic (Declaration)
Public Class ScheduleItemTimeChanger _
    Inherits Control
Visual C++
public ref class ScheduleItemTimeChanger : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ScheduleItemTimeChanger

See Also

ScheduleItemTimeChanger Members


ScheduleItemTimeChanger Members

[image] [image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger Members
ScheduleItemTimeChanger Class Constructors Methods Fields Properties Events See Also Send Feedback

The ScheduleItemTimeChanger type exposes the following members.

Constructors

Name | Description
ScheduleItemTimeChanger | Initializes a new instance of the ScheduleItemTimeChanger class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ControlOnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ScheduleItemProperty | Identifies the ScheduleItem property.
TimeEndProperty | Identifies the TimeEnd property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets or sets the ScheduleItem associated with the changer. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TimeEnd | Gets or sets the end (start or finish) of the ScheduleItem will be changed by dragging this ScheduleItemTimeChanger. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleItemTimeChanger Class


ScheduleItemTimeChanger Constructor

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger Constructor
ScheduleItemTimeChanger Class See Also Send Feedback
Initializes a new instance of the ScheduleItemTimeChanger class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItemTimeChanger()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ScheduleItemTimeChanger()

See Also

ScheduleItemTimeChanger Class


ScheduleItemTimeChanger Fields

[image] [image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger Fields
ScheduleItemTimeChanger Class See Also Send Feedback

The ScheduleItemTimeChanger type exposes the following members.

Fields

Name | Description
ScheduleItemProperty | Identifies the ScheduleItem property.
TimeEndProperty | Identifies the TimeEnd property.

See Also

ScheduleItemTimeChanger Class


ScheduleItemProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger..::.ScheduleItemProperty Field
ScheduleItemTimeChanger Class See Also Send Feedback
Identifies the ScheduleItem property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ScheduleItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly ScheduleItemProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ScheduleItemProperty

See Also

ScheduleItemTimeChanger Class


TimeEndProperty Field

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger..::.TimeEndProperty Field
ScheduleItemTimeChanger Class See Also Send Feedback
Identifies the TimeEnd property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TimeEndProperty
Visual Basic (Declaration)
Public Shared ReadOnly TimeEndProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TimeEndProperty

See Also

ScheduleItemTimeChanger Class


ScheduleItemTimeChanger Methods

[image] [image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger Methods
ScheduleItemTimeChanger Class See Also Send Feedback

The ScheduleItemTimeChanger type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ControlOnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | Called by the framework when the user releases the left mouse button. (Overrides ControlOnMouseLeftButtonUp(MouseButtonEventArgs).)
OnMouseMove | Called by the framework when the user moves the mouse. (Overrides ControlOnMouseMove(MouseEventArgs).)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ScheduleItemTimeChanger Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger..::.OnMouseLeftButtonDown Method
ScheduleItemTimeChanger Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

ScheduleItemTimeChanger Class


OnMouseLeftButtonUp Method

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger..::.OnMouseLeftButtonUp Method
ScheduleItemTimeChanger Class See Also Send Feedback
Called by the framework when the user releases the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonUp(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonUp ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonUp(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

ScheduleItemTimeChanger Class


OnMouseMove Method

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger..::.OnMouseMove Method
ScheduleItemTimeChanger Class See Also Send Feedback
Called by the framework when the user moves the mouse.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseMove(
    MouseEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The mouse event data.

See Also

ScheduleItemTimeChanger Class


ScheduleItemTimeChanger Properties

[image] [image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger Properties
ScheduleItemTimeChanger Class See Also Send Feedback

The ScheduleItemTimeChanger type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets or sets the ScheduleItem associated with the changer. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TimeEnd | Gets or sets the end (start or finish) of the ScheduleItem will be changed by dragging this ScheduleItemTimeChanger. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ScheduleItemTimeChanger Class


ScheduleItem Property

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger..::.ScheduleItem Property
ScheduleItemTimeChanger Class See Also Send Feedback
Gets or sets the ScheduleItem associated with the changer. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem ScheduleItem { get; set; }
Visual Basic (Declaration)
Public Property ScheduleItem As ScheduleItem
Visual C++
public:
property ScheduleItem^ ScheduleItem {
    ScheduleItem^ get ();
    void set (ScheduleItem^ value);
}

Remarks

Dependency Property Information
Identifier field | ScheduleItemProperty
Metadata properties set to true | None

See Also

ScheduleItemTimeChanger Class


TimeEnd Property

[image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger..::.TimeEnd Property
ScheduleItemTimeChanger Class See Also Send Feedback
Gets or sets the end (start or finish) of the ScheduleItem will be changed by dragging this ScheduleItemTimeChanger. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeEnd TimeEnd { get; set; }
Visual Basic (Declaration)
Public Property TimeEnd As TimeEnd
Visual C++
public:
property TimeEnd TimeEnd {
    TimeEnd get ();
    void set (TimeEnd value);
}

Remarks

Dependency Property Information
Identifier field | TimeEndProperty
Metadata properties set to true | None

See Also

ScheduleItemTimeChanger Class


ScheduleItemTimeChanger Events

[image] [image]

Mindscape Silverlight Elements
ScheduleItemTimeChanger Events
ScheduleItemTimeChanger Class See Also Send Feedback

The ScheduleItemTimeChanger type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleItemTimeChanger Class


Scheduler Class

[image]

Mindscape Silverlight Elements
Scheduler Class
Members See Also Send Feedback
A control which displays a schedule, for example of appointments or tasks, using a set of calendar views.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Scheduler : Control, INotifyPropertyChanged
Visual Basic (Declaration)
Public Class Scheduler _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class Scheduler : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.Scheduler

See Also

Scheduler Members


Scheduler Members

[image] [image]

Mindscape Silverlight Elements
Scheduler Members
Scheduler Class Constructors Methods Fields Properties Events See Also Send Feedback

The Scheduler type exposes the following members.

Constructors

Name | Description
Scheduler | Initializes a new instance of the Scheduler class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemActivated | Raises the ItemActivated event.
OnItemAdded | Raises the ItemAdded event.
OnKeyDown | Called by the framework when the user presses a key. (Overrides ControlOnKeyDown(KeyEventArgs).)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DayViewStyleProperty | Identifies the DayViewStyle property.
MonthViewStyleProperty | Identifies the MonthViewStyle property.
WeekViewStyleProperty | Identifies the WeekViewStyle property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
CurrentView | Gets the currently displayed view.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DayViewStyle | Gets or sets the DayViewStyle. This is a dependency property.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsInDayView | Gets whether the Scheduler is currently displaying a single day view.
IsInMonthView | Gets whether the Scheduler is currently displaying a month view.
IsInWeekView | Gets whether the Scheduler is currently displaying a weekly view.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthViewStyle | Gets or sets the MonthViewStyle. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets the Schedule associated with this Scheduler.
SelectedItem | Gets the currently selected ScheduleItem.
ShowFullWeekCommand | A command that can be sent to the Scheduler to switch the week view into full week mode.
ShowWorkWeekCommand | A command that can be sent to the Scheduler to switch the week view into work week only mode.
Style | (Inherited from FrameworkElement.)
SwitchToDayViewCommand | A command that can be sent to the Scheduler to switch it into single-day view.
SwitchToMonthViewCommand | A command that can be sent to the Scheduler to switch it into month view.
SwitchToWeekViewCommand | A command that can be sent to the Scheduler to switch it into week view.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
WeekViewStyle | Gets or sets the WeekViewStyle. This is a dependency property.
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
ItemActivated | Occurs when the user activates an item (for example by double-clicking).
ItemAdded | Occurs when the user adds a schedule item to the Scheduler.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

Scheduler Class


Scheduler Constructor

[image]

Mindscape Silverlight Elements
Scheduler Constructor
Scheduler Class See Also Send Feedback
Initializes a new instance of the Scheduler class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Scheduler()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Scheduler()

See Also

Scheduler Class


Scheduler Fields

[image] [image]

Mindscape Silverlight Elements
Scheduler Fields
Scheduler Class See Also Send Feedback

The Scheduler type exposes the following members.

Fields

Name | Description
DayViewStyleProperty | Identifies the DayViewStyle property.
MonthViewStyleProperty | Identifies the MonthViewStyle property.
WeekViewStyleProperty | Identifies the WeekViewStyle property.

See Also

Scheduler Class


DayViewStyleProperty Field

[image]

Mindscape Silverlight Elements
Scheduler..::.DayViewStyleProperty Field
Scheduler Class See Also Send Feedback
Identifies the DayViewStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DayViewStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DayViewStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DayViewStyleProperty

See Also

Scheduler Class


MonthViewStyleProperty Field

[image]

Mindscape Silverlight Elements
Scheduler..::.MonthViewStyleProperty Field
Scheduler Class See Also Send Feedback
Identifies the MonthViewStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty MonthViewStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly MonthViewStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ MonthViewStyleProperty

See Also

Scheduler Class


WeekViewStyleProperty Field

[image]

Mindscape Silverlight Elements
Scheduler..::.WeekViewStyleProperty Field
Scheduler Class See Also Send Feedback
Identifies the WeekViewStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty WeekViewStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly WeekViewStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ WeekViewStyleProperty

See Also

Scheduler Class


Scheduler Methods

[image] [image]

Mindscape Silverlight Elements
Scheduler Methods
Scheduler Class See Also Send Feedback

The Scheduler type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnItemActivated | Raises the ItemActivated event.
OnItemAdded | Raises the ItemAdded event.
OnKeyDown | Called by the framework when the user presses a key. (Overrides ControlOnKeyDown(KeyEventArgs).)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Scheduler Class


OnApplyTemplate Method

[image]

Mindscape Silverlight Elements
Scheduler..::.OnApplyTemplate Method
Scheduler Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

Scheduler Class


OnItemActivated Method

[image]

Mindscape Silverlight Elements
Scheduler..::.OnItemActivated Method
Scheduler Class See Also Send Feedback
Raises the ItemActivated event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal virtual void OnItemActivated(
    ScheduleItem item
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnItemActivated ( _
    item As ScheduleItem _
)
Visual C++
protected public:
virtual void OnItemActivated(
    ScheduleItem^ item
)

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item being activated.

See Also

Scheduler Class


OnItemAdded Method

[image]

Mindscape Silverlight Elements
Scheduler..::.OnItemAdded Method
Scheduler Class See Also Send Feedback
Raises the ItemAdded event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected internal virtual void OnItemAdded(
    ScheduleItem item,
    out bool cancel,
    out bool showDefaultEditor
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnItemAdded ( _
    item As ScheduleItem, _
    <OutAttribute> ByRef cancel As Boolean, _
    <OutAttribute> ByRef showDefaultEditor As Boolean _
)
Visual C++
protected public:
virtual void OnItemAdded(
    ScheduleItem^ item,
    [OutAttribute] bool% cancel,
    [OutAttribute] bool% showDefaultEditor
)

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item being added.
cancel
Type: System..::.Boolean %
true to cancel the add (and remove the item again); false to permit the new item.
showDefaultEditor
Type: System..::.Boolean %
true to show the default editor (ScheduleItemDialog); false to suppress the default editor.

See Also

Scheduler Class


OnKeyDown Method

[image]

Mindscape Silverlight Elements
Scheduler..::.OnKeyDown Method
Scheduler Class See Also Send Feedback
Called by the framework when the user presses a key.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.KeyEventArgs
The key event data.

See Also

Scheduler Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
Scheduler..::.OnPropertyChanged Method
Scheduler Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

Scheduler Class


Scheduler Properties

[image] [image]

Mindscape Silverlight Elements
Scheduler Properties
Scheduler Class See Also Send Feedback

The Scheduler type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
CurrentView | Gets the currently displayed view.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DayViewStyle | Gets or sets the DayViewStyle. This is a dependency property.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsInDayView | Gets whether the Scheduler is currently displaying a single day view.
IsInMonthView | Gets whether the Scheduler is currently displaying a month view.
IsInWeekView | Gets whether the Scheduler is currently displaying a weekly view.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MonthViewStyle | Gets or sets the MonthViewStyle. This is a dependency property.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets the Schedule associated with this Scheduler.
SelectedItem | Gets the currently selected ScheduleItem.
ShowFullWeekCommand | A command that can be sent to the Scheduler to switch the week view into full week mode.
ShowWorkWeekCommand | A command that can be sent to the Scheduler to switch the week view into work week only mode.
Style | (Inherited from FrameworkElement.)
SwitchToDayViewCommand | A command that can be sent to the Scheduler to switch it into single-day view.
SwitchToMonthViewCommand | A command that can be sent to the Scheduler to switch it into month view.
SwitchToWeekViewCommand | A command that can be sent to the Scheduler to switch it into week view.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
WeekViewStyle | Gets or sets the WeekViewStyle. This is a dependency property.
Width | (Inherited from FrameworkElement.)

See Also

Scheduler Class


CurrentView Property

[image]

Mindscape Silverlight Elements
Scheduler..::.CurrentView Property
Scheduler Class See Also Send Feedback
Gets the currently displayed view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleView CurrentView { get; private set; }
Visual Basic (Declaration)
Public Property CurrentView As ScheduleView
Visual C++
public:
property ScheduleView^ CurrentView {
    ScheduleView^ get ();
    void set (ScheduleView^ value);
}

See Also

Scheduler Class


DayViewStyle Property

[image]

Mindscape Silverlight Elements
Scheduler..::.DayViewStyle Property
Scheduler Class See Also Send Feedback
Gets or sets the DayViewStyle. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style DayViewStyle { get; set; }
Visual Basic (Declaration)
Public Property DayViewStyle As Style
Visual C++
public:
property Style^ DayViewStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | DayViewStyleProperty
Metadata properties set to true | None

See Also

Scheduler Class


IsInDayView Property

[image]

Mindscape Silverlight Elements
Scheduler..::.IsInDayView Property
Scheduler Class See Also Send Feedback
Gets whether the Scheduler is currently displaying a single day view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInDayView { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInDayView As Boolean
Visual C++
public:
property bool IsInDayView {
    bool get ();
}

See Also

Scheduler Class


IsInMonthView Property

[image]

Mindscape Silverlight Elements
Scheduler..::.IsInMonthView Property
Scheduler Class See Also Send Feedback
Gets whether the Scheduler is currently displaying a month view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInMonthView { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInMonthView As Boolean
Visual C++
public:
property bool IsInMonthView {
    bool get ();
}

See Also

Scheduler Class


IsInWeekView Property

[image]

Mindscape Silverlight Elements
Scheduler..::.IsInWeekView Property
Scheduler Class See Also Send Feedback
Gets whether the Scheduler is currently displaying a weekly view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsInWeekView { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInWeekView As Boolean
Visual C++
public:
property bool IsInWeekView {
    bool get ();
}

See Also

Scheduler Class


MonthViewStyle Property

[image]

Mindscape Silverlight Elements
Scheduler..::.MonthViewStyle Property
Scheduler Class See Also Send Feedback
Gets or sets the MonthViewStyle. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style MonthViewStyle { get; set; }
Visual Basic (Declaration)
Public Property MonthViewStyle As Style
Visual C++
public:
property Style^ MonthViewStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | MonthViewStyleProperty
Metadata properties set to true | None

See Also

Scheduler Class


Schedule Property

[image]

Mindscape Silverlight Elements
Scheduler..::.Schedule Property
Scheduler Class See Also Send Feedback
Gets the Schedule associated with this Scheduler.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Schedule Schedule { get; }
Visual Basic (Declaration)
Public ReadOnly Property Schedule As Schedule
Visual C++
public:
property Schedule^ Schedule {
    Schedule^ get ();
}

See Also

Scheduler Class


SelectedItem Property

[image]

Mindscape Silverlight Elements
Scheduler..::.SelectedItem Property
Scheduler Class See Also Send Feedback
Gets the currently selected ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem SelectedItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItem As ScheduleItem
Visual C++
public:
property ScheduleItem^ SelectedItem {
    ScheduleItem^ get ();
}

See Also

Scheduler Class


ShowFullWeekCommand Property

[image]

Mindscape Silverlight Elements
Scheduler..::.ShowFullWeekCommand Property
Scheduler Class See Also Send Feedback
A command that can be sent to the Scheduler to switch the week view into full week mode.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand ShowFullWeekCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowFullWeekCommand As ICommand
Visual C++
public:
property ICommand^ ShowFullWeekCommand {
    ICommand^ get ();
}

See Also

Scheduler Class


ShowWorkWeekCommand Property

[image]

Mindscape Silverlight Elements
Scheduler..::.ShowWorkWeekCommand Property
Scheduler Class See Also Send Feedback
A command that can be sent to the Scheduler to switch the week view into work week only mode.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand ShowWorkWeekCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowWorkWeekCommand As ICommand
Visual C++
public:
property ICommand^ ShowWorkWeekCommand {
    ICommand^ get ();
}

See Also

Scheduler Class


SwitchToDayViewCommand Property

[image]

Mindscape Silverlight Elements
Scheduler..::.SwitchToDayViewCommand Property
Scheduler Class See Also Send Feedback
A command that can be sent to the Scheduler to switch it into single-day view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand SwitchToDayViewCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property SwitchToDayViewCommand As ICommand
Visual C++
public:
property ICommand^ SwitchToDayViewCommand {
    ICommand^ get ();
}

See Also

Scheduler Class


SwitchToMonthViewCommand Property

[image]

Mindscape Silverlight Elements
Scheduler..::.SwitchToMonthViewCommand Property
Scheduler Class See Also Send Feedback
A command that can be sent to the Scheduler to switch it into month view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand SwitchToMonthViewCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property SwitchToMonthViewCommand As ICommand
Visual C++
public:
property ICommand^ SwitchToMonthViewCommand {
    ICommand^ get ();
}

See Also

Scheduler Class


SwitchToWeekViewCommand Property

[image]

Mindscape Silverlight Elements
Scheduler..::.SwitchToWeekViewCommand Property
Scheduler Class See Also Send Feedback
A command that can be sent to the Scheduler to switch it into week view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand SwitchToWeekViewCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property SwitchToWeekViewCommand As ICommand
Visual C++
public:
property ICommand^ SwitchToWeekViewCommand {
    ICommand^ get ();
}

See Also

Scheduler Class


WeekViewStyle Property

[image]

Mindscape Silverlight Elements
Scheduler..::.WeekViewStyle Property
Scheduler Class See Also Send Feedback
Gets or sets the WeekViewStyle. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style WeekViewStyle { get; set; }
Visual Basic (Declaration)
Public Property WeekViewStyle As Style
Visual C++
public:
property Style^ WeekViewStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | WeekViewStyleProperty
Metadata properties set to true | None

See Also

Scheduler Class


Scheduler Events

[image] [image]

Mindscape Silverlight Elements
Scheduler Events
Scheduler Class See Also Send Feedback

The Scheduler type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
ItemActivated | Occurs when the user activates an item (for example by double-clicking).
ItemAdded | Occurs when the user adds a schedule item to the Scheduler.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

Scheduler Class


ItemActivated Event

[image]

Mindscape Silverlight Elements
Scheduler..::.ItemActivated Event
Scheduler Class See Also Send Feedback
Occurs when the user activates an item (for example by double-clicking).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<ScheduleItemEventArgs> ItemActivated
Visual Basic (Declaration)
Public Event ItemActivated As EventHandler(Of ScheduleItemEventArgs)
Visual C++
public:
 event EventHandler<ScheduleItemEventArgs^>^ ItemActivated {
    void add (EventHandler<ScheduleItemEventArgs^>^ value);
    void remove (EventHandler<ScheduleItemEventArgs^>^ value);
}

See Also

Scheduler Class


ItemAdded Event

[image]

Mindscape Silverlight Elements
Scheduler..::.ItemAdded Event
Scheduler Class See Also Send Feedback
Occurs when the user adds a schedule item to the Scheduler.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event EventHandler<AddScheduleItemEventArgs> ItemAdded
Visual Basic (Declaration)
Public Event ItemAdded As EventHandler(Of AddScheduleItemEventArgs)
Visual C++
public:
 event EventHandler<AddScheduleItemEventArgs^>^ ItemAdded {
    void add (EventHandler<AddScheduleItemEventArgs^>^ value);
    void remove (EventHandler<AddScheduleItemEventArgs^>^ value);
}

See Also

Scheduler Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
Scheduler..::.PropertyChanged Event
Scheduler Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Scheduler Class


SchedulerCanvas Class

[image]

Mindscape Silverlight Elements
SchedulerCanvas Class
Members See Also Send Feedback
Represents a canvas on which schedule items can be laid out in a detail view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SchedulerCanvas : SchedulerCanvasBase,
    IDoubleClickObserver, INotifyPropertyChanged
Visual Basic (Declaration)
Public Class SchedulerCanvas _
    Inherits SchedulerCanvasBase _
    Implements IDoubleClickObserver, INotifyPropertyChanged
Visual C++
public ref class SchedulerCanvas : public SchedulerCanvasBase,
    IDoubleClickObserver, INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
System.Windows.Controls..::.Canvas
Mindscape.SilverlightElements..::.SchedulerCanvasBase
Mindscape.SilverlightElements..::.SchedulerCanvas

See Also

SchedulerCanvas Members


SchedulerCanvas Members

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvas Members
SchedulerCanvas Class Constructors Methods Fields Properties Events See Also Send Feedback

The SchedulerCanvas type exposes the following members.

Constructors

Name | Description
SchedulerCanvas | Initializes a new instance of the SchedulerCanvas class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetDateTime | Gets the time corresponding to a location on the canvas. (Overrides SchedulerCanvasBase..::.GetDateTime(Double, Double, TimeEnd).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDaysChanged | Updates the user interface in response to changes to the Days property. (Overrides SchedulerCanvasBase..::.OnDaysChanged(DependencyPropertyChangedEventArgs).)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
RelayoutCreateHereButton | Performs layout of the "create here" button when a setting or selection changes. (Inherited from SchedulerCanvasBase.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveCreateHereButton | Removes the "create here" button. (Inherited from SchedulerCanvasBase.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ItemStyleProperty | Identifies the ItemStyle property.
TimeSlotTemplateProperty | Identifies the TimeSlotTemplate property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CreateHereButtonStyle | Gets or sets the style for the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereDayIndex | Gets the day index on which to display the "create here" button. (Inherited from SchedulerCanvasBase.)
CreateHereElementDuration | Gets or sets the duration in minutes for a schedule item that is added useing the "Create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereElementStyle | Gets or sets the style for the "new appointment" element that appears when the user clicks the "create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereHintContent | Gets or sets the content displayed on the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereTime | Gets the time at whose location to display the "create here" button. (Inherited from SchedulerCanvasBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Days | Gets or sets the per-day data to be represented on the canvas. This member supports the Scheduler control and is not intended for use in your code, but may be referenced in advanced styling and templating scenarios. This is a dependency property. (Inherited from SchedulerCanvasBase.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HourSlotHeight | Gets or sets the height of each hourly slot.
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
IsMouseDown | Gets whether the mouse button is down over the SchedulerCanvasBase. (Inherited from SchedulerCanvasBase.)
ItemStyle | Gets or sets the Style for schedule items displayed on the canvas. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelScrollFactor | Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel. (Overrides SchedulerCanvasBase..::.MouseWheelScrollFactor.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RightAreaBuffer | Gets or sets the width of the empty area left to the right of each SchedulerElement.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
TimeSlotTemplate | Gets or sets the DataTemplate for presenting TimeSlot objects on the canvas. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonPressed | Raised when the user clicks the mouse button.
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerCanvas Class


SchedulerCanvas Constructor

[image]

Mindscape Silverlight Elements
SchedulerCanvas Constructor
SchedulerCanvas Class See Also Send Feedback
Initializes a new instance of the SchedulerCanvas class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SchedulerCanvas()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerCanvas()

See Also

SchedulerCanvas Class


SchedulerCanvas Fields

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvas Fields
SchedulerCanvas Class See Also Send Feedback

The SchedulerCanvas type exposes the following members.

Fields

Name | Description
ItemStyleProperty | Identifies the ItemStyle property.
TimeSlotTemplateProperty | Identifies the TimeSlotTemplate property.

See Also

SchedulerCanvas Class


ItemStyleProperty Field

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.ItemStyleProperty Field
SchedulerCanvas Class See Also Send Feedback
Identifies the ItemStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemStyleProperty

See Also

SchedulerCanvas Class


TimeSlotTemplateProperty Field

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.TimeSlotTemplateProperty Field
SchedulerCanvas Class See Also Send Feedback
Identifies the TimeSlotTemplate property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TimeSlotTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly TimeSlotTemplateProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TimeSlotTemplateProperty

See Also

SchedulerCanvas Class


SchedulerCanvas Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvas Methods
SchedulerCanvas Class See Also Send Feedback

The SchedulerCanvas type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetDateTime | Gets the time corresponding to a location on the canvas. (Overrides SchedulerCanvasBase..::.GetDateTime(Double, Double, TimeEnd).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDaysChanged | Updates the user interface in response to changes to the Days property. (Overrides SchedulerCanvasBase..::.OnDaysChanged(DependencyPropertyChangedEventArgs).)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
RelayoutCreateHereButton | Performs layout of the "create here" button when a setting or selection changes. (Inherited from SchedulerCanvasBase.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveCreateHereButton | Removes the "create here" button. (Inherited from SchedulerCanvasBase.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

SchedulerCanvas Class


GetDateTime Method

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.GetDateTime Method
SchedulerCanvas Class See Also Send Feedback
Gets the time corresponding to a location on the canvas.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime GetDateTime(
    double x,
    double y,
    TimeEnd timeEnd
)
Visual Basic (Declaration)
Protected Overrides Function GetDateTime ( _
    x As Double, _
    y As Double, _
    timeEnd As TimeEnd _
) As DateTime
Visual C++
protected:
virtual DateTime GetDateTime(
    double x,
    double y,
    TimeEnd timeEnd
) override

Parameters

x
Type: System..::.Double
The x-coordinate of the location.
y
Type: System..::.Double
The y-coordinate of the location.
timeEnd
Type: Mindscape.SilverlightElements..::.TimeEnd
Whether to adjust the time for the start or end of a ScheduleItem.

Return Value

The date and time corresponding to x and y.

See Also

SchedulerCanvas Class


OnDaysChanged Method

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.OnDaysChanged Method
SchedulerCanvas Class See Also Send Feedback
Updates the user interface in response to changes to the Days property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnDaysChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnDaysChanged ( _
    e As DependencyPropertyChangedEventArgs _
)
Visual C++
protected:
virtual void OnDaysChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.Windows..::.DependencyPropertyChangedEventArgs
Contains information about changes to the Days property.

See Also

SchedulerCanvas Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.OnPropertyChanged Method
SchedulerCanvas Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

SchedulerCanvas Class


SchedulerCanvas Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvas Properties
SchedulerCanvas Class See Also Send Feedback

The SchedulerCanvas type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CreateHereButtonStyle | Gets or sets the style for the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereDayIndex | Gets the day index on which to display the "create here" button. (Inherited from SchedulerCanvasBase.)
CreateHereElementDuration | Gets or sets the duration in minutes for a schedule item that is added useing the "Create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereElementStyle | Gets or sets the style for the "new appointment" element that appears when the user clicks the "create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereHintContent | Gets or sets the content displayed on the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereTime | Gets the time at whose location to display the "create here" button. (Inherited from SchedulerCanvasBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Days | Gets or sets the per-day data to be represented on the canvas. This member supports the Scheduler control and is not intended for use in your code, but may be referenced in advanced styling and templating scenarios. This is a dependency property. (Inherited from SchedulerCanvasBase.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HourSlotHeight | Gets or sets the height of each hourly slot.
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
IsMouseDown | Gets whether the mouse button is down over the SchedulerCanvasBase. (Inherited from SchedulerCanvasBase.)
ItemStyle | Gets or sets the Style for schedule items displayed on the canvas. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelScrollFactor | Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel. (Overrides SchedulerCanvasBase..::.MouseWheelScrollFactor.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RightAreaBuffer | Gets or sets the width of the empty area left to the right of each SchedulerElement.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
TimeSlotTemplate | Gets or sets the DataTemplate for presenting TimeSlot objects on the canvas. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

SchedulerCanvas Class


HourSlotHeight Property

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.HourSlotHeight Property
SchedulerCanvas Class See Also Send Feedback
Gets or sets the height of each hourly slot.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double HourSlotHeight { get; set; }
Visual Basic (Declaration)
Public Property HourSlotHeight As Double
Visual C++
public:
property double HourSlotHeight {
    double get ();
    void set (double value);
}

See Also

SchedulerCanvas Class


ItemStyle Property

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.ItemStyle Property
SchedulerCanvas Class See Also Send Feedback
Gets or sets the Style for schedule items displayed on the canvas. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style ItemStyle { get; set; }
Visual Basic (Declaration)
Public Property ItemStyle As Style
Visual C++
public:
property Style^ ItemStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | ItemStyleProperty
Metadata properties set to true | None

See Also

SchedulerCanvas Class


MouseWheelScrollFactor Property

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.MouseWheelScrollFactor Property
SchedulerCanvas Class See Also Send Feedback
Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override double MouseWheelScrollFactor { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property MouseWheelScrollFactor As Double
Visual C++
protected:
virtual property double MouseWheelScrollFactor {
    double get () override;
}

See Also

SchedulerCanvas Class


RightAreaBuffer Property

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.RightAreaBuffer Property
SchedulerCanvas Class See Also Send Feedback
Gets or sets the width of the empty area left to the right of each SchedulerElement.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RightAreaBuffer { get; set; }
Visual Basic (Declaration)
Public Property RightAreaBuffer As Double
Visual C++
public:
property double RightAreaBuffer {
    double get ();
    void set (double value);
}

See Also

SchedulerCanvas Class


TimeSlotTemplate Property

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.TimeSlotTemplate Property
SchedulerCanvas Class See Also Send Feedback
Gets or sets the DataTemplate for presenting TimeSlot objects on the canvas. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate TimeSlotTemplate { get; set; }
Visual Basic (Declaration)
Public Property TimeSlotTemplate As DataTemplate
Visual C++
public:
property DataTemplate^ TimeSlotTemplate {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

Remarks

Dependency Property Information
Identifier field | TimeSlotTemplateProperty
Metadata properties set to true | None

See Also

SchedulerCanvas Class


SchedulerCanvas Events

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvas Events
SchedulerCanvas Class See Also Send Feedback

The SchedulerCanvas type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonPressed | Raised when the user clicks the mouse button.
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerCanvas Class


MouseLeftButtonPressed Event

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.MouseLeftButtonPressed Event
SchedulerCanvas Class See Also Send Feedback
Raised when the user clicks the mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event MouseButtonEventHandler MouseLeftButtonPressed
Visual Basic (Declaration)
Public Event MouseLeftButtonPressed As MouseButtonEventHandler
Visual C++
public:
virtual  event MouseButtonEventHandler^ MouseLeftButtonPressed {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}

Implements

IDoubleClickObserver..::.MouseLeftButtonPressed

See Also

SchedulerCanvas Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
SchedulerCanvas..::.PropertyChanged Event
SchedulerCanvas Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

SchedulerCanvas Class


SchedulerCanvasBase Class

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase Class
Members See Also Send Feedback
Represents a canvas on which schedule items can be laid out.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class SchedulerCanvasBase : Canvas,
    IMouseWheelObserver
Visual Basic (Declaration)
Public MustInherit Class SchedulerCanvasBase _
    Inherits Canvas _
    Implements IMouseWheelObserver
Visual C++
public ref class SchedulerCanvasBase abstract : public Canvas,
    IMouseWheelObserver

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
System.Windows.Controls..::.Canvas
Mindscape.SilverlightElements..::.SchedulerCanvasBase
Mindscape.SilverlightElements..::.SchedulerCanvas
Mindscape.SilverlightElements..::.SmallSchedulerCanvas

See Also

SchedulerCanvasBase Members


SchedulerCanvasBase Members

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvasBase Members
SchedulerCanvasBase Class Constructors Methods Fields Properties Events See Also Send Feedback

The SchedulerCanvasBase type exposes the following members.

Constructors

Name | Description
SchedulerCanvasBase | Initializes a new instance of the SchedulerCanvasBase class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetDateTime | When overridden in a derived class, gets the time corresponding to a location on the canvas.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDaysChanged | When overridden in a derived class, handles changes to the Days property.
ReadLocalValue | (Inherited from DependencyObject.)
RelayoutCreateHereButton | Performs layout of the "create here" button when a setting or selection changes.
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveCreateHereButton | Removes the "create here" button.
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CreateHereButtonStyleProperty | Identifies the CreateHereButtonStyle property.
CreateHereElementDurationProperty | Identifies the CreateHereElementDuration property.
CreateHereElementStyleProperty | Identifies the CreateHereElementStyle property.
CreateHereHintContentProperty | Identifies the CreateHereHintContent property.
DaysProperty | Identifies the Days property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CreateHereButtonStyle | Gets or sets the style for the "create here" button that is displayed when the user hovers over the control. This is a dependency property.
CreateHereDayIndex | Gets the day index on which to display the "create here" button.
CreateHereElementDuration | Gets or sets the duration in minutes for a schedule item that is added useing the "Create here" button. This is a dependency property.
CreateHereElementStyle | Gets or sets the style for the "new appointment" element that appears when the user clicks the "create here" button. This is a dependency property.
CreateHereHintContent | Gets or sets the content displayed on the "create here" button that is displayed when the user hovers over the control. This is a dependency property.
CreateHereTime | Gets the time at whose location to display the "create here" button.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Days | Gets or sets the per-day data to be represented on the canvas. This member supports the Scheduler control and is not intended for use in your code, but may be referenced in advanced styling and templating scenarios. This is a dependency property.
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
IsMouseDown | Gets whether the mouse button is down over the SchedulerCanvasBase.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelScrollFactor | Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerCanvasBase Class


SchedulerCanvasBase Constructor

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase Constructor
SchedulerCanvasBase Class See Also Send Feedback
Initializes a new instance of the SchedulerCanvasBase class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected SchedulerCanvasBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
SchedulerCanvasBase()

See Also

SchedulerCanvasBase Class


SchedulerCanvasBase Fields

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvasBase Fields
SchedulerCanvasBase Class See Also Send Feedback

The SchedulerCanvasBase type exposes the following members.

Fields

Name | Description
CreateHereButtonStyleProperty | Identifies the CreateHereButtonStyle property.
CreateHereElementDurationProperty | Identifies the CreateHereElementDuration property.
CreateHereElementStyleProperty | Identifies the CreateHereElementStyle property.
CreateHereHintContentProperty | Identifies the CreateHereHintContent property.
DaysProperty | Identifies the Days property.

See Also

SchedulerCanvasBase Class


CreateHereButtonStyleProperty Field

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereButtonStyleProperty Field
SchedulerCanvasBase Class See Also Send Feedback
Identifies the CreateHereButtonStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CreateHereButtonStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly CreateHereButtonStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CreateHereButtonStyleProperty

See Also

SchedulerCanvasBase Class


CreateHereElementDurationProperty Field

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereElementDurationProperty Field
SchedulerCanvasBase Class See Also Send Feedback
Identifies the CreateHereElementDuration property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CreateHereElementDurationProperty
Visual Basic (Declaration)
Public Shared ReadOnly CreateHereElementDurationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CreateHereElementDurationProperty

See Also

SchedulerCanvasBase Class


CreateHereElementStyleProperty Field

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereElementStyleProperty Field
SchedulerCanvasBase Class See Also Send Feedback
Identifies the CreateHereElementStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CreateHereElementStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly CreateHereElementStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CreateHereElementStyleProperty

See Also

SchedulerCanvasBase Class


CreateHereHintContentProperty Field

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereHintContentProperty Field
SchedulerCanvasBase Class See Also Send Feedback
Identifies the CreateHereHintContent property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty CreateHereHintContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly CreateHereHintContentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CreateHereHintContentProperty

See Also

SchedulerCanvasBase Class


DaysProperty Field

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.DaysProperty Field
SchedulerCanvasBase Class See Also Send Feedback
Identifies the Days property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DaysProperty
Visual Basic (Declaration)
Public Shared ReadOnly DaysProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DaysProperty

See Also

SchedulerCanvasBase Class


SchedulerCanvasBase Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvasBase Methods
SchedulerCanvasBase Class See Also Send Feedback

The SchedulerCanvasBase type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetDateTime | When overridden in a derived class, gets the time corresponding to a location on the canvas.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDaysChanged | When overridden in a derived class, handles changes to the Days property.
ReadLocalValue | (Inherited from DependencyObject.)
RelayoutCreateHereButton | Performs layout of the "create here" button when a setting or selection changes.
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveCreateHereButton | Removes the "create here" button.
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

SchedulerCanvasBase Class


GetDateTime Method

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.GetDateTime Method
SchedulerCanvasBase Class See Also Send Feedback
When overridden in a derived class, gets the time corresponding to a location on the canvas.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract DateTime GetDateTime(
    double x,
    double y,
    TimeEnd timeEnd
)
Visual Basic (Declaration)
Protected MustOverride Function GetDateTime ( _
    x As Double, _
    y As Double, _
    timeEnd As TimeEnd _
) As DateTime
Visual C++
protected:
virtual DateTime GetDateTime(
    double x,
    double y,
    TimeEnd timeEnd
) abstract

Parameters

x
Type: System..::.Double
The x-coordinate of the location.
y
Type: System..::.Double
The y-coordinate of the location.
timeEnd
Type: Mindscape.SilverlightElements..::.TimeEnd
Whether to adjust the time for the start or end of a ScheduleItem.

Return Value

The date and time corresponding to x and y.

See Also

SchedulerCanvasBase Class


OnDaysChanged Method

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.OnDaysChanged Method
SchedulerCanvasBase Class See Also Send Feedback
When overridden in a derived class, handles changes to the Days property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnDaysChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDaysChanged ( _
    e As DependencyPropertyChangedEventArgs _
)
Visual C++
protected:
virtual void OnDaysChanged(
    DependencyPropertyChangedEventArgs e
)

Parameters

e
Type: System.Windows..::.DependencyPropertyChangedEventArgs
Contains information about changes to the Days property.

See Also

SchedulerCanvasBase Class


RelayoutCreateHereButton Method

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.RelayoutCreateHereButton Method
SchedulerCanvasBase Class See Also Send Feedback
Performs layout of the "create here" button when a setting or selection changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void RelayoutCreateHereButton(
    int dayIndex,
    int timeSlotIndex,
    DateTime time
)
Visual Basic (Declaration)
Protected Sub RelayoutCreateHereButton ( _
    dayIndex As Integer, _
    timeSlotIndex As Integer, _
    time As DateTime _
)
Visual C++
protected:
void RelayoutCreateHereButton(
    int dayIndex,
    int timeSlotIndex,
    DateTime time
)

Parameters

dayIndex
Type: System..::.Int32

[Missing <param name="dayIndex"/> documentation for "M:Mindscape.SilverlightElements.SchedulerCanvasBase.RelayoutCreateHereButton(System.Int32,System.Int32,System.DateTime)"]

timeSlotIndex
Type: System..::.Int32

[Missing <param name="timeSlotIndex"/> documentation for "M:Mindscape.SilverlightElements.SchedulerCanvasBase.RelayoutCreateHereButton(System.Int32,System.Int32,System.DateTime)"]

time
Type: System..::.DateTime

[Missing <param name="time"/> documentation for "M:Mindscape.SilverlightElements.SchedulerCanvasBase.RelayoutCreateHereButton(System.Int32,System.Int32,System.DateTime)"]

See Also

SchedulerCanvasBase Class


RemoveCreateHereButton Method

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.RemoveCreateHereButton Method
SchedulerCanvasBase Class See Also Send Feedback
Removes the "create here" button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void RemoveCreateHereButton()
Visual Basic (Declaration)
Protected Sub RemoveCreateHereButton
Visual C++
protected:
void RemoveCreateHereButton()

See Also

SchedulerCanvasBase Class


SchedulerCanvasBase Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvasBase Properties
SchedulerCanvasBase Class See Also Send Feedback

The SchedulerCanvasBase type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CreateHereButtonStyle | Gets or sets the style for the "create here" button that is displayed when the user hovers over the control. This is a dependency property.
CreateHereDayIndex | Gets the day index on which to display the "create here" button.
CreateHereElementDuration | Gets or sets the duration in minutes for a schedule item that is added useing the "Create here" button. This is a dependency property.
CreateHereElementStyle | Gets or sets the style for the "new appointment" element that appears when the user clicks the "create here" button. This is a dependency property.
CreateHereHintContent | Gets or sets the content displayed on the "create here" button that is displayed when the user hovers over the control. This is a dependency property.
CreateHereTime | Gets the time at whose location to display the "create here" button.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Days | Gets or sets the per-day data to be represented on the canvas. This member supports the Scheduler control and is not intended for use in your code, but may be referenced in advanced styling and templating scenarios. This is a dependency property.
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
IsMouseDown | Gets whether the mouse button is down over the SchedulerCanvasBase.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelScrollFactor | Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

SchedulerCanvasBase Class


CreateHereButtonStyle Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereButtonStyle Property
SchedulerCanvasBase Class See Also Send Feedback
Gets or sets the style for the "create here" button that is displayed when the user hovers over the control. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style CreateHereButtonStyle { get; set; }
Visual Basic (Declaration)
Public Property CreateHereButtonStyle As Style
Visual C++
public:
property Style^ CreateHereButtonStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | CreateHereButtonStyleProperty
Metadata properties set to true | None

See Also

SchedulerCanvasBase Class


CreateHereDayIndex Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereDayIndex Property
SchedulerCanvasBase Class See Also Send Feedback
Gets the day index on which to display the "create here" button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected int CreateHereDayIndex { get; private set; }
Visual Basic (Declaration)
Protected Property CreateHereDayIndex As Integer
Visual C++
protected:
property int CreateHereDayIndex {
    int get ();
    void set (int value);
}

See Also

SchedulerCanvasBase Class


CreateHereElementDuration Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereElementDuration Property
SchedulerCanvasBase Class See Also Send Feedback
Gets or sets the duration in minutes for a schedule item that is added useing the "Create here" button. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CreateHereElementDuration { get; set; }
Visual Basic (Declaration)
Public Property CreateHereElementDuration As Integer
Visual C++
public:
property int CreateHereElementDuration {
    int get ();
    void set (int value);
}

See Also

SchedulerCanvasBase Class


CreateHereElementStyle Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereElementStyle Property
SchedulerCanvasBase Class See Also Send Feedback
Gets or sets the style for the "new appointment" element that appears when the user clicks the "create here" button. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style CreateHereElementStyle { get; set; }
Visual Basic (Declaration)
Public Property CreateHereElementStyle As Style
Visual C++
public:
property Style^ CreateHereElementStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | CreateHereElementStyleProperty
Metadata properties set to true | None

See Also

SchedulerCanvasBase Class


CreateHereHintContent Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereHintContent Property
SchedulerCanvasBase Class See Also Send Feedback
Gets or sets the content displayed on the "create here" button that is displayed when the user hovers over the control. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object CreateHereHintContent { get; set; }
Visual Basic (Declaration)
Public Property CreateHereHintContent As Object
Visual C++
public:
property Object^ CreateHereHintContent {
    Object^ get ();
    void set (Object^ value);
}

Remarks

Dependency Property Information
Identifier field | CreateHereHintContentProperty
Metadata properties set to true | None

See Also

SchedulerCanvasBase Class


CreateHereTime Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.CreateHereTime Property
SchedulerCanvasBase Class See Also Send Feedback
Gets the time at whose location to display the "create here" button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected DateTime CreateHereTime { get; private set; }
Visual Basic (Declaration)
Protected Property CreateHereTime As DateTime
Visual C++
protected:
property DateTime CreateHereTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

SchedulerCanvasBase Class


Days Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.Days Property
SchedulerCanvasBase Class See Also Send Feedback
Gets or sets the per-day data to be represented on the canvas. This member supports the Scheduler control and is not intended for use in your code, but may be referenced in advanced styling and templating scenarios. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IList<DayModel> Days { get; set; }
Visual Basic (Declaration)
Public Property Days As IList(Of DayModel)
Visual C++
public:
property IList<DayModel^>^ Days {
    IList<DayModel^>^ get ();
    void set (IList<DayModel^>^ value);
}

Remarks

Dependency Property Information
Identifier field | DaysProperty
Metadata properties set to true | None

See Also

SchedulerCanvasBase Class


IsMouseDown Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.IsMouseDown Property
SchedulerCanvasBase Class See Also Send Feedback
Gets whether the mouse button is down over the SchedulerCanvasBase.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool IsMouseDown { get; set; }
Visual Basic (Declaration)
Protected Property IsMouseDown As Boolean
Visual C++
protected:
property bool IsMouseDown {
    bool get ();
    void set (bool value);
}

See Also

SchedulerCanvasBase Class


MouseWheelScrollFactor Property

[image]

Mindscape Silverlight Elements
SchedulerCanvasBase..::.MouseWheelScrollFactor Property
SchedulerCanvasBase Class See Also Send Feedback
Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract double MouseWheelScrollFactor { get; }
Visual Basic (Declaration)
Protected MustOverride ReadOnly Property MouseWheelScrollFactor As Double
Visual C++
protected:
virtual property double MouseWheelScrollFactor {
    double get () abstract;
}

See Also

SchedulerCanvasBase Class


SchedulerCanvasBase Events

[image] [image]

Mindscape Silverlight Elements
SchedulerCanvasBase Events
SchedulerCanvasBase Class See Also Send Feedback

The SchedulerCanvasBase type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerCanvasBase Class


SchedulerElement Class

[image]

Mindscape Silverlight Elements
SchedulerElement Class
Members See Also Send Feedback
Represents a ScheduleItem on a display surface (typically a SchedulerCanvasBase.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SchedulerElement : ListBoxItem,
    INotifyPropertyChanged, IDoubleClickObserver
Visual Basic (Declaration)
Public Class SchedulerElement _
    Inherits ListBoxItem _
    Implements INotifyPropertyChanged, IDoubleClickObserver
Visual C++
public ref class SchedulerElement : public ListBoxItem,
    INotifyPropertyChanged, IDoubleClickObserver

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.SilverlightElements..::.SchedulerElement

See Also

SchedulerElement Members


SchedulerElement Members

[image] [image]

Mindscape Silverlight Elements
SchedulerElement Members
SchedulerElement Class Methods Properties Events See Also Send Feedback

The SchedulerElement type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ListBoxItem..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
ElementState | Gets display information for the SchedulerElement.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsScheduleItemEndVisible | Gets whether the start of the ScheduleItem represented by this SchedulerElement is on a displayed date.
IsScheduleItemStartVisible | Gets whether the start of the ScheduleItem represented by this SchedulerElement is on a displayed date.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets the ScheduleItem represented by this SchedulerElement.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerElement Class


SchedulerElement Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerElement Methods
SchedulerElement Class See Also Send Feedback

The SchedulerElement type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ListBoxItem.)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from ListBoxItem.)
OnGotFocus | (Inherited from ListBoxItem.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from ListBoxItem.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from ListBoxItem.)
OnMouseLeave | (Inherited from ListBoxItem.)
OnMouseLeftButtonDown | Called by the framework when the user presses the left mouse button. (Overrides ListBoxItem..::.OnMouseLeftButtonDown(MouseButtonEventArgs).)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

SchedulerElement Class


OnMouseLeftButtonDown Method

[image]

Mindscape Silverlight Elements
SchedulerElement..::.OnMouseLeftButtonDown Method
SchedulerElement Class See Also Send Feedback
Called by the framework when the user presses the left mouse button.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnMouseLeftButtonDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeftButtonDown ( _
    e As MouseButtonEventArgs _
)
Visual C++
protected:
virtual void OnMouseLeftButtonDown(
    MouseButtonEventArgs^ e
) override

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The mouse event data.

See Also

SchedulerElement Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
SchedulerElement..::.OnPropertyChanged Method
SchedulerElement Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

SchedulerElement Class


SchedulerElement Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerElement Properties
SchedulerElement Class See Also Send Feedback

The SchedulerElement type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
ElementState | Gets display information for the SchedulerElement.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsScheduleItemEndVisible | Gets whether the start of the ScheduleItem represented by this SchedulerElement is on a displayed date.
IsScheduleItemStartVisible | Gets whether the start of the ScheduleItem represented by this SchedulerElement is on a displayed date.
IsSelected | (Inherited from ListBoxItem.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ScheduleItem | Gets the ScheduleItem represented by this SchedulerElement.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

SchedulerElement Class


ElementState Property

[image]

Mindscape Silverlight Elements
SchedulerElement..::.ElementState Property
SchedulerElement Class See Also Send Feedback
Gets display information for the SchedulerElement.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SchedulerElementDisplayState ElementState { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElementState As SchedulerElementDisplayState
Visual C++
public:
property SchedulerElementDisplayState ElementState {
    SchedulerElementDisplayState get ();
}

See Also

SchedulerElement Class


IsScheduleItemEndVisible Property

[image]

Mindscape Silverlight Elements
SchedulerElement..::.IsScheduleItemEndVisible Property
SchedulerElement Class See Also Send Feedback
Gets whether the start of the ScheduleItem represented by this SchedulerElement is on a displayed date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsScheduleItemEndVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsScheduleItemEndVisible As Boolean
Visual C++
public:
property bool IsScheduleItemEndVisible {
    bool get ();
}

See Also

SchedulerElement Class


IsScheduleItemStartVisible Property

[image]

Mindscape Silverlight Elements
SchedulerElement..::.IsScheduleItemStartVisible Property
SchedulerElement Class See Also Send Feedback
Gets whether the start of the ScheduleItem represented by this SchedulerElement is on a displayed date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsScheduleItemStartVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsScheduleItemStartVisible As Boolean
Visual C++
public:
property bool IsScheduleItemStartVisible {
    bool get ();
}

See Also

SchedulerElement Class


ScheduleItem Property

[image]

Mindscape Silverlight Elements
SchedulerElement..::.ScheduleItem Property
SchedulerElement Class See Also Send Feedback
Gets the ScheduleItem represented by this SchedulerElement.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ScheduleItem ScheduleItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScheduleItem As ScheduleItem
Visual C++
public:
property ScheduleItem^ ScheduleItem {
    ScheduleItem^ get ();
}

See Also

SchedulerElement Class


SchedulerElement Events

[image] [image]

Mindscape Silverlight Elements
SchedulerElement Events
SchedulerElement Class See Also Send Feedback

The SchedulerElement type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerElement Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
SchedulerElement..::.PropertyChanged Event
SchedulerElement Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

SchedulerElement Class


SchedulerElementDisplayState Structure

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayState Structure
Members See Also Send Feedback
Contains display information for a SchedulerElement.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct SchedulerElementDisplayState
Visual Basic (Declaration)
Public Structure SchedulerElementDisplayState
Visual C++
public value class SchedulerElementDisplayState

See Also

SchedulerElementDisplayState Members


SchedulerElementDisplayState Members

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayState Members
SchedulerElementDisplayState Structure Methods Properties See Also Send Feedback

The SchedulerElementDisplayState type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
IsScheduleItemEndVisible | Gets whether the end of the item is on a displayed date.
IsScheduleItemStartVisible | Gets whether the start of the item is on a displayed date.
ScheduleItemEndTime | Gets the end time of the item.
ScheduleItemStartTime | Gets the start time of the item.

See Also

SchedulerElementDisplayState Structure


SchedulerElementDisplayState Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayState Methods
SchedulerElementDisplayState Structure See Also Send Feedback

The SchedulerElementDisplayState type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SchedulerElementDisplayState Structure


SchedulerElementDisplayState Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayState Properties
SchedulerElementDisplayState Structure See Also Send Feedback

The SchedulerElementDisplayState type exposes the following members.

Properties

Name | Description
IsScheduleItemEndVisible | Gets whether the end of the item is on a displayed date.
IsScheduleItemStartVisible | Gets whether the start of the item is on a displayed date.
ScheduleItemEndTime | Gets the end time of the item.
ScheduleItemStartTime | Gets the start time of the item.

See Also

SchedulerElementDisplayState Structure


IsScheduleItemEndVisible Property

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayState..::.IsScheduleItemEndVisible Property
SchedulerElementDisplayState Structure See Also Send Feedback
Gets whether the end of the item is on a displayed date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsScheduleItemEndVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsScheduleItemEndVisible As Boolean
Visual C++
public:
property bool IsScheduleItemEndVisible {
    bool get ();
}

See Also

SchedulerElementDisplayState Structure


IsScheduleItemStartVisible Property

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayState..::.IsScheduleItemStartVisible Property
SchedulerElementDisplayState Structure See Also Send Feedback
Gets whether the start of the item is on a displayed date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsScheduleItemStartVisible { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsScheduleItemStartVisible As Boolean
Visual C++
public:
property bool IsScheduleItemStartVisible {
    bool get ();
}

See Also

SchedulerElementDisplayState Structure


ScheduleItemEndTime Property

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayState..::.ScheduleItemEndTime Property
SchedulerElementDisplayState Structure See Also Send Feedback
Gets the end time of the item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime ScheduleItemEndTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScheduleItemEndTime As DateTime
Visual C++
public:
property DateTime ScheduleItemEndTime {
    DateTime get ();
}

See Also

SchedulerElementDisplayState Structure


ScheduleItemStartTime Property

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayState..::.ScheduleItemStartTime Property
SchedulerElementDisplayState Structure See Also Send Feedback
Gets the start time of the item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime ScheduleItemStartTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScheduleItemStartTime As DateTime
Visual C++
public:
property DateTime ScheduleItemStartTime {
    DateTime get ();
}

See Also

SchedulerElementDisplayState Structure


SchedulerElementDisplayStateToCornerRadiusConverter Class

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter Class
Members See Also Send Feedback
Calculates the corner radius for displaying a SchedulerElement in a view. The element is given rounded corners on the left or top if it includes the start of the schedule item, and on the right or bottom if it includes the end of the schedule item; otherwise, the item is given non-rounded corners.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SchedulerElementDisplayStateToCornerRadiusConverter : IValueConverter
Visual Basic (Declaration)
Public Class SchedulerElementDisplayStateToCornerRadiusConverter _
    Implements IValueConverter
Visual C++
public ref class SchedulerElementDisplayStateToCornerRadiusConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.SchedulerElementDisplayStateToCornerRadiusConverter

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Members


SchedulerElementDisplayStateToCornerRadiusConverter Members

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter Members
SchedulerElementDisplayStateToCornerRadiusConverter Class Constructors Methods Properties See Also Send Feedback

The SchedulerElementDisplayStateToCornerRadiusConverter type exposes the following members.

Constructors

Name | Description
SchedulerElementDisplayStateToCornerRadiusConverter | Initializes a new instance of the SchedulerElementDisplayStateToCornerRadiusConverter class

Methods

Name | Description
Convert | Calculates corner rounding for displaying a SchedulerElement in a summary view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Orientation | Gets or sets the orientation of the item. If Vertical, the rounding will be applied to the top and/or bottom pairs of corners; if Horizontal, to the left and/or right pairs of corners.
ScheduleElementEndRadius | Gets or sets the corner rounding to be applied at each end of the SchedulerElement if that end is included in the SchedulerElementDisplayState.

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


SchedulerElementDisplayStateToCornerRadiusConverter Constructor

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter Constructor
SchedulerElementDisplayStateToCornerRadiusConverter Class See Also Send Feedback
Initializes a new instance of the SchedulerElementDisplayStateToCornerRadiusConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SchedulerElementDisplayStateToCornerRadiusConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerElementDisplayStateToCornerRadiusConverter()

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


SchedulerElementDisplayStateToCornerRadiusConverter Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter Methods
SchedulerElementDisplayStateToCornerRadiusConverter Class See Also Send Feedback

The SchedulerElementDisplayStateToCornerRadiusConverter type exposes the following members.

Methods

Name | Description
Convert | Calculates corner rounding for displaying a SchedulerElement in a summary view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter..::.Convert Method
SchedulerElementDisplayStateToCornerRadiusConverter Class See Also Send Feedback
Calculates corner rounding for displaying a SchedulerElement in a summary view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The SchedulerElementDisplayState value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A CornerRadius with left/top and right/bottom values set to the ScheduleElementEndRadius if the SchedulerElement includes the relevant end of the schedule item, otherwise unrounded.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter..::.ConvertBack Method
SchedulerElementDisplayStateToCornerRadiusConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


SchedulerElementDisplayStateToCornerRadiusConverter Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter Properties
SchedulerElementDisplayStateToCornerRadiusConverter Class See Also Send Feedback

The SchedulerElementDisplayStateToCornerRadiusConverter type exposes the following members.

Properties

Name | Description
Orientation | Gets or sets the orientation of the item. If Vertical, the rounding will be applied to the top and/or bottom pairs of corners; if Horizontal, to the left and/or right pairs of corners.
ScheduleElementEndRadius | Gets or sets the corner rounding to be applied at each end of the SchedulerElement if that end is included in the SchedulerElementDisplayState.

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


Orientation Property

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter..::.Orientation Property
SchedulerElementDisplayStateToCornerRadiusConverter Class See Also Send Feedback
Gets or sets the orientation of the item. If Vertical, the rounding will be applied to the top and/or bottom pairs of corners; if Horizontal, to the left and/or right pairs of corners.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


ScheduleElementEndRadius Property

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToCornerRadiusConverter..::.ScheduleElementEndRadius Property
SchedulerElementDisplayStateToCornerRadiusConverter Class See Also Send Feedback
Gets or sets the corner rounding to be applied at each end of the SchedulerElement if that end is included in the SchedulerElementDisplayState.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ScheduleElementEndRadius { get; set; }
Visual Basic (Declaration)
Public Property ScheduleElementEndRadius As Double
Visual C++
public:
property double ScheduleElementEndRadius {
    double get ();
    void set (double value);
}

See Also

SchedulerElementDisplayStateToCornerRadiusConverter Class


SchedulerElementDisplayStateToThicknessConverter Class

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter Class
Members See Also Send Feedback
Calculates the margin for displaying a SchedulerElement in a view. The element is offset from the left if includes the start of the schedule item, and from the right if includes the end of the schedule item; otherwise, the element bleeds to the edge of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SchedulerElementDisplayStateToThicknessConverter : IValueConverter
Visual Basic (Declaration)
Public Class SchedulerElementDisplayStateToThicknessConverter _
    Implements IValueConverter
Visual C++
public ref class SchedulerElementDisplayStateToThicknessConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.SchedulerElementDisplayStateToThicknessConverter

See Also

SchedulerElementDisplayStateToThicknessConverter Members


SchedulerElementDisplayStateToThicknessConverter Members

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter Members
SchedulerElementDisplayStateToThicknessConverter Class Constructors Methods Properties See Also Send Feedback

The SchedulerElementDisplayStateToThicknessConverter type exposes the following members.

Constructors

Name | Description
SchedulerElementDisplayStateToThicknessConverter | Initializes a new instance of the SchedulerElementDisplayStateToThicknessConverter class

Methods

Name | Description
Convert | Calculates the margin for displaying a SchedulerElement in a view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ScheduleElementEndOffset | Gets or sets the offset to be applied at each end of the SchedulerElement if that end is included in the SchedulerElementDisplayState.

See Also

SchedulerElementDisplayStateToThicknessConverter Class


SchedulerElementDisplayStateToThicknessConverter Constructor

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter Constructor
SchedulerElementDisplayStateToThicknessConverter Class See Also Send Feedback
Initializes a new instance of the SchedulerElementDisplayStateToThicknessConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SchedulerElementDisplayStateToThicknessConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerElementDisplayStateToThicknessConverter()

See Also

SchedulerElementDisplayStateToThicknessConverter Class


SchedulerElementDisplayStateToThicknessConverter Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter Methods
SchedulerElementDisplayStateToThicknessConverter Class See Also Send Feedback

The SchedulerElementDisplayStateToThicknessConverter type exposes the following members.

Methods

Name | Description
Convert | Calculates the margin for displaying a SchedulerElement in a view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SchedulerElementDisplayStateToThicknessConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter..::.Convert Method
SchedulerElementDisplayStateToThicknessConverter Class See Also Send Feedback
Calculates the margin for displaying a SchedulerElement in a view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The SchedulerElementDisplayState value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A Thickness with left and right values set to the ScheduleElementEndOffset if the SchedulerElement includes the relevant end of the schedule item, otherwise 0.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

SchedulerElementDisplayStateToThicknessConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter..::.ConvertBack Method
SchedulerElementDisplayStateToThicknessConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

SchedulerElementDisplayStateToThicknessConverter Class


SchedulerElementDisplayStateToThicknessConverter Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter Properties
SchedulerElementDisplayStateToThicknessConverter Class See Also Send Feedback

The SchedulerElementDisplayStateToThicknessConverter type exposes the following members.

Properties

Name | Description
ScheduleElementEndOffset | Gets or sets the offset to be applied at each end of the SchedulerElement if that end is included in the SchedulerElementDisplayState.

See Also

SchedulerElementDisplayStateToThicknessConverter Class


ScheduleElementEndOffset Property

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToThicknessConverter..::.ScheduleElementEndOffset Property
SchedulerElementDisplayStateToThicknessConverter Class See Also Send Feedback
Gets or sets the offset to be applied at each end of the SchedulerElement if that end is included in the SchedulerElementDisplayState.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double ScheduleElementEndOffset { get; set; }
Visual Basic (Declaration)
Public Property ScheduleElementEndOffset As Double
Visual C++
public:
property double ScheduleElementEndOffset {
    double get ();
    void set (double value);
}

See Also

SchedulerElementDisplayStateToThicknessConverter Class


SchedulerElementDisplayStateToTimeStringConverter Class

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToTimeStringConverter Class
Members See Also Send Feedback
Formats the time component of a SchedulerElementDisplayState for display.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SchedulerElementDisplayStateToTimeStringConverter : TimeStringConverterBase,
    IValueConverter
Visual Basic (Declaration)
Public Class SchedulerElementDisplayStateToTimeStringConverter _
    Inherits TimeStringConverterBase _
    Implements IValueConverter
Visual C++
public ref class SchedulerElementDisplayStateToTimeStringConverter : public TimeStringConverterBase,
    IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeStringConverterBase
Mindscape.SilverlightElements..::.SchedulerElementDisplayStateToTimeStringConverter

See Also

SchedulerElementDisplayStateToTimeStringConverter Members


SchedulerElementDisplayStateToTimeStringConverter Members

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToTimeStringConverter Members
SchedulerElementDisplayStateToTimeStringConverter Class Constructors Methods Properties See Also Send Feedback

The SchedulerElementDisplayStateToTimeStringConverter type exposes the following members.

Constructors

Name | Description
SchedulerElementDisplayStateToTimeStringConverter | Initializes a new instance of the SchedulerElementDisplayStateToTimeStringConverter class

Methods

Name | Description
Convert | Formats the time component of a SchedulerElementDisplayState for display.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TimeEnd | Gets or sets which end of a range is to be formatted. (Inherited from TimeStringConverterBase.)

See Also

SchedulerElementDisplayStateToTimeStringConverter Class


SchedulerElementDisplayStateToTimeStringConverter Constructor

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToTimeStringConverter Constructor
SchedulerElementDisplayStateToTimeStringConverter Class See Also Send Feedback
Initializes a new instance of the SchedulerElementDisplayStateToTimeStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SchedulerElementDisplayStateToTimeStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerElementDisplayStateToTimeStringConverter()

See Also

SchedulerElementDisplayStateToTimeStringConverter Class


SchedulerElementDisplayStateToTimeStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToTimeStringConverter Methods
SchedulerElementDisplayStateToTimeStringConverter Class See Also Send Feedback

The SchedulerElementDisplayStateToTimeStringConverter type exposes the following members.

Methods

Name | Description
Convert | Formats the time component of a SchedulerElementDisplayState for display.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SchedulerElementDisplayStateToTimeStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToTimeStringConverter..::.Convert Method
SchedulerElementDisplayStateToTimeStringConverter Class See Also Send Feedback
Formats the time component of a SchedulerElementDisplayState for display.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The SchedulerElementDisplayState value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A formatted representation of the time selected by the TimeEnd property.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

SchedulerElementDisplayStateToTimeStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToTimeStringConverter..::.ConvertBack Method
SchedulerElementDisplayStateToTimeStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

SchedulerElementDisplayStateToTimeStringConverter Class


SchedulerElementDisplayStateToTimeStringConverter Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerElementDisplayStateToTimeStringConverter Properties
SchedulerElementDisplayStateToTimeStringConverter Class See Also Send Feedback

The SchedulerElementDisplayStateToTimeStringConverter type exposes the following members.

Properties

Name | Description
TimeEnd | Gets or sets which end of a range is to be formatted. (Inherited from TimeStringConverterBase.)

See Also

SchedulerElementDisplayStateToTimeStringConverter Class


SchedulerNavigationBar Class

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar Class
Members See Also Send Feedback
Provides a user interface for navigating through a Schedule displayed in a Scheduler control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SchedulerNavigationBar : Control
Visual Basic (Declaration)
Public Class SchedulerNavigationBar _
    Inherits Control
Visual C++
public ref class SchedulerNavigationBar : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.SchedulerNavigationBar

See Also

SchedulerNavigationBar Members


SchedulerNavigationBar Members

[image] [image]

Mindscape Silverlight Elements
SchedulerNavigationBar Members
SchedulerNavigationBar Class Constructors Methods Fields Properties Events See Also Send Feedback

The SchedulerNavigationBar type exposes the following members.

Constructors

Name | Description
SchedulerNavigationBar | Initializes a new instance of the SchedulerNavigationBar class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AddScheduleItemCommandProperty | Identifies the AddScheduleItemCommand property.
DateRangeProperty | Identifies the DateRange property.
NextCommandProperty | Identifies the NextCommand property.
PreviousCommandProperty | Identifies the PreviousCommand property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets or sets a command to add a new item to the schedule. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRange | Gets or sets the date range to be displayed in the title. This is a dependency property.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets or sets a command to go to the next view (e.g. next week). This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets or sets a command to go to the previous view (e.g. previous week). This is a dependency property.
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerNavigationBar Class


SchedulerNavigationBar Constructor

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar Constructor
SchedulerNavigationBar Class See Also Send Feedback
Initializes a new instance of the SchedulerNavigationBar class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SchedulerNavigationBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SchedulerNavigationBar()

See Also

SchedulerNavigationBar Class


SchedulerNavigationBar Fields

[image] [image]

Mindscape Silverlight Elements
SchedulerNavigationBar Fields
SchedulerNavigationBar Class See Also Send Feedback

The SchedulerNavigationBar type exposes the following members.

Fields

Name | Description
AddScheduleItemCommandProperty | Identifies the AddScheduleItemCommand property.
DateRangeProperty | Identifies the DateRange property.
NextCommandProperty | Identifies the NextCommand property.
PreviousCommandProperty | Identifies the PreviousCommand property.

See Also

SchedulerNavigationBar Class


AddScheduleItemCommandProperty Field

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.AddScheduleItemCommandProperty Field
SchedulerNavigationBar Class See Also Send Feedback
Identifies the AddScheduleItemCommand property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty AddScheduleItemCommandProperty
Visual Basic (Declaration)
Public Shared ReadOnly AddScheduleItemCommandProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ AddScheduleItemCommandProperty

See Also

SchedulerNavigationBar Class


DateRangeProperty Field

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.DateRangeProperty Field
SchedulerNavigationBar Class See Also Send Feedback
Identifies the DateRange property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DateRangeProperty
Visual Basic (Declaration)
Public Shared ReadOnly DateRangeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DateRangeProperty

See Also

SchedulerNavigationBar Class


NextCommandProperty Field

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.NextCommandProperty Field
SchedulerNavigationBar Class See Also Send Feedback
Identifies the NextCommand property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty NextCommandProperty
Visual Basic (Declaration)
Public Shared ReadOnly NextCommandProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ NextCommandProperty

See Also

SchedulerNavigationBar Class


PreviousCommandProperty Field

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.PreviousCommandProperty Field
SchedulerNavigationBar Class See Also Send Feedback
Identifies the PreviousCommand property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty PreviousCommandProperty
Visual Basic (Declaration)
Public Shared ReadOnly PreviousCommandProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ PreviousCommandProperty

See Also

SchedulerNavigationBar Class


SchedulerNavigationBar Methods

[image] [image]

Mindscape Silverlight Elements
SchedulerNavigationBar Methods
SchedulerNavigationBar Class See Also Send Feedback

The SchedulerNavigationBar type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

SchedulerNavigationBar Class


SchedulerNavigationBar Properties

[image] [image]

Mindscape Silverlight Elements
SchedulerNavigationBar Properties
SchedulerNavigationBar Class See Also Send Feedback

The SchedulerNavigationBar type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets or sets a command to add a new item to the schedule. This is a dependency property.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRange | Gets or sets the date range to be displayed in the title. This is a dependency property.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets or sets a command to go to the next view (e.g. next week). This is a dependency property.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets or sets a command to go to the previous view (e.g. previous week). This is a dependency property.
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

SchedulerNavigationBar Class


AddScheduleItemCommand Property

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.AddScheduleItemCommand Property
SchedulerNavigationBar Class See Also Send Feedback
Gets or sets a command to add a new item to the schedule. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand AddScheduleItemCommand { get; set; }
Visual Basic (Declaration)
Public Property AddScheduleItemCommand As ICommand
Visual C++
public:
property ICommand^ AddScheduleItemCommand {
    ICommand^ get ();
    void set (ICommand^ value);
}

Remarks

Dependency Property Information
Identifier field | AddScheduleItemCommandProperty
Metadata properties set to true | None

See Also

SchedulerNavigationBar Class


DateRange Property

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.DateRange Property
SchedulerNavigationBar Class See Also Send Feedback
Gets or sets the date range to be displayed in the title. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateRangeDisplayInfo DateRange { get; set; }
Visual Basic (Declaration)
Public Property DateRange As DateRangeDisplayInfo
Visual C++
public:
property DateRangeDisplayInfo DateRange {
    DateRangeDisplayInfo get ();
    void set (DateRangeDisplayInfo value);
}

Remarks

Dependency Property Information
Identifier field | DateRangeProperty
Metadata properties set to true | None

See Also

SchedulerNavigationBar Class


NextCommand Property

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.NextCommand Property
SchedulerNavigationBar Class See Also Send Feedback
Gets or sets a command to go to the next view (e.g. next week). This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand NextCommand { get; set; }
Visual Basic (Declaration)
Public Property NextCommand As ICommand
Visual C++
public:
property ICommand^ NextCommand {
    ICommand^ get ();
    void set (ICommand^ value);
}

Remarks

Dependency Property Information
Identifier field | NextCommandProperty
Metadata properties set to true | None

See Also

SchedulerNavigationBar Class


PreviousCommand Property

[image]

Mindscape Silverlight Elements
SchedulerNavigationBar..::.PreviousCommand Property
SchedulerNavigationBar Class See Also Send Feedback
Gets or sets a command to go to the previous view (e.g. previous week). This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand PreviousCommand { get; set; }
Visual Basic (Declaration)
Public Property PreviousCommand As ICommand
Visual C++
public:
property ICommand^ PreviousCommand {
    ICommand^ get ();
    void set (ICommand^ value);
}

Remarks

Dependency Property Information
Identifier field | PreviousCommandProperty
Metadata properties set to true | None

See Also

SchedulerNavigationBar Class


SchedulerNavigationBar Events

[image] [image]

Mindscape Silverlight Elements
SchedulerNavigationBar Events
SchedulerNavigationBar Class See Also Send Feedback

The SchedulerNavigationBar type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SchedulerNavigationBar Class


ScheduleView Class

[image]

Mindscape Silverlight Elements
ScheduleView Class
Members See Also Send Feedback
The base class for specific views in the Scheduler (day, week and month views).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ScheduleView : Control,
    INotifyPropertyChanged
Visual Basic (Declaration)
Public MustInherit Class ScheduleView _
    Inherits Control _
    Implements INotifyPropertyChanged
Visual C++
public ref class ScheduleView abstract : public Control,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ScheduleView
Mindscape.SilverlightElements..::.DayView
Mindscape.SilverlightElements..::.MonthView
Mindscape.SilverlightElements..::.WeekView

See Also

ScheduleView Members


ScheduleView Members

[image] [image]

Mindscape Silverlight Elements
ScheduleView Members
ScheduleView Class Constructors Methods Properties Events See Also Send Feedback

The ScheduleView type exposes the following members.

Constructors

Name | Description
ScheduleView | Initializes a new instance of the ScheduleView class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | When overridden in a derived class, cancels the addition of the specified ScheduleItem.
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | When overridden in a derived class, creates a ScheduleItem at the current selection.
DecrementView | Moves the view backward to the previous block (e.g. previous week);
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | When overridden in a derived class, gets a start date that is appropriate for that type of view to display the given date.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view forward to the next block (e.g. next week);
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range.
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title.
DateRangeDisplayMode | Gets how the title should be formatted in the view.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled.
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week).
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view.
Now | Gets the current date and time.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week).
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view.
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed.
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item).
StartDate | Gets or sets the start date of the view.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleView Class


ScheduleView Constructor

[image]

Mindscape Silverlight Elements
ScheduleView Constructor
ScheduleView Class See Also Send Feedback
Initializes a new instance of the ScheduleView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ScheduleView()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ScheduleView()

See Also

ScheduleView Class


ScheduleView Methods

[image] [image]

Mindscape Silverlight Elements
ScheduleView Methods
ScheduleView Class See Also Send Feedback

The ScheduleView type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | When overridden in a derived class, cancels the addition of the specified ScheduleItem.
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | When overridden in a derived class, creates a ScheduleItem at the current selection.
DecrementView | Moves the view backward to the previous block (e.g. previous week);
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | When overridden in a derived class, gets a start date that is appropriate for that type of view to display the given date.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view forward to the next block (e.g. next week);
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range.
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ScheduleView Class


CancelAdd Method

[image]

Mindscape Silverlight Elements
ScheduleView..::.CancelAdd Method
ScheduleView Class See Also Send Feedback
When overridden in a derived class, cancels the addition of the specified ScheduleItem.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract void CancelAdd(
    ScheduleItem item
)
Visual Basic (Declaration)
Protected MustOverride Sub CancelAdd ( _
    item As ScheduleItem _
)
Visual C++
protected:
virtual void CancelAdd(
    ScheduleItem^ item
) abstract

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to be cancelled.

See Also

ScheduleView Class


CreateScheduleItemForAdd Method

[image]

Mindscape Silverlight Elements
ScheduleView..::.CreateScheduleItemForAdd Method
ScheduleView Class See Also Send Feedback
When overridden in a derived class, creates a ScheduleItem at the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract ScheduleItem CreateScheduleItemForAdd()
Visual Basic (Declaration)
Protected MustOverride Function CreateScheduleItemForAdd As ScheduleItem
Visual C++
protected:
virtual ScheduleItem^ CreateScheduleItemForAdd() abstract

Return Value

The new schedule item.

See Also

ScheduleView Class


DecrementView Method

[image]

Mindscape Silverlight Elements
ScheduleView..::.DecrementView Method
ScheduleView Class See Also Send Feedback
Moves the view backward to the previous block (e.g. previous week);

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void DecrementView()
Visual Basic (Declaration)
Public MustOverride Sub DecrementView
Visual C++
public:
virtual void DecrementView() abstract

See Also

ScheduleView Class


GetStartDateContaining Method

[image]

Mindscape Silverlight Elements
ScheduleView..::.GetStartDateContaining Method
ScheduleView Class See Also Send Feedback
When overridden in a derived class, gets a start date that is appropriate for that type of view to display the given date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract DateTime GetStartDateContaining(
    DateTime date
)
Visual Basic (Declaration)
Protected MustOverride Function GetStartDateContaining ( _
    date As DateTime _
) As DateTime
Visual C++
protected:
virtual DateTime GetStartDateContaining(
    DateTime date
) abstract

Parameters

date
Type: System..::.DateTime
The date to be displayed.

Return Value

A date which is suitable as a start date for displaying the given date.

See Also

ScheduleView Class


IncrementView Method

[image]

Mindscape Silverlight Elements
ScheduleView..::.IncrementView Method
ScheduleView Class See Also Send Feedback
Moves the view forward to the next block (e.g. next week);

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract void IncrementView()
Visual Basic (Declaration)
Public MustOverride Sub IncrementView
Visual C++
public:
virtual void IncrementView() abstract

See Also

ScheduleView Class


NotifyDateRangeChanged Method

[image]

Mindscape Silverlight Elements
ScheduleView..::.NotifyDateRangeChanged Method
ScheduleView Class See Also Send Feedback
Raises change notification events required when the view changes to displaying a different date range.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void NotifyDateRangeChanged()
Visual Basic (Declaration)
Protected Sub NotifyDateRangeChanged
Visual C++
protected:
void NotifyDateRangeChanged()

See Also

ScheduleView Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
ScheduleView..::.OnPropertyChanged Method
ScheduleView Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic (Declaration)
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the property that changed.

See Also

ScheduleView Class


ScheduleView Properties

[image] [image]

Mindscape Silverlight Elements
ScheduleView Properties
ScheduleView Class See Also Send Feedback

The ScheduleView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title.
DateRangeDisplayMode | Gets how the title should be formatted in the view.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled.
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week).
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view.
Now | Gets the current date and time.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week).
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view.
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed.
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item).
StartDate | Gets or sets the start date of the view.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ScheduleView Class


AddScheduleItemCommand Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.AddScheduleItemCommand Property
ScheduleView Class See Also Send Feedback
Gets a command for adding an item to the Schedule at the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand AddScheduleItemCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property AddScheduleItemCommand As ICommand
Visual C++
public:
property ICommand^ AddScheduleItemCommand {
    ICommand^ get ();
}

See Also

ScheduleView Class


DateRangeDisplayInfo Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.DateRangeDisplayInfo Property
ScheduleView Class See Also Send Feedback
Gets display information for the view title.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateRangeDisplayInfo DateRangeDisplayInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateRangeDisplayInfo As DateRangeDisplayInfo
Visual C++
public:
property DateRangeDisplayInfo DateRangeDisplayInfo {
    DateRangeDisplayInfo get ();
}

See Also

ScheduleView Class


DateRangeDisplayMode Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.DateRangeDisplayMode Property
ScheduleView Class See Also Send Feedback
Gets how the title should be formatted in the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract DateDisplayMode DateRangeDisplayMode { get; }
Visual Basic (Declaration)
Protected MustOverride ReadOnly Property DateRangeDisplayMode As DateDisplayMode
Visual C++
protected:
virtual property DateDisplayMode DateRangeDisplayMode {
    DateDisplayMode get () abstract;
}

See Also

ScheduleView Class


EndDate Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.EndDate Property
ScheduleView Class See Also Send Feedback
Gets the end date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected abstract DateTime EndDate { get; }
Visual Basic (Declaration)
Protected MustOverride ReadOnly Property EndDate As DateTime
Visual C++
protected:
virtual property DateTime EndDate {
    DateTime get () abstract;
}

See Also

ScheduleView Class


IsNextWingEnabled Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.IsNextWingEnabled Property
ScheduleView Class See Also Send Feedback
Gets whether the "next item" wing button is enabled.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsNextWingEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNextWingEnabled As Boolean
Visual C++
public:
property bool IsNextWingEnabled {
    bool get ();
}

See Also

ScheduleView Class


IsPreviousWingEnabled Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.IsPreviousWingEnabled Property
ScheduleView Class See Also Send Feedback
Gets whether the "previous item" wing button is enabled.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsPreviousWingEnabled { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPreviousWingEnabled As Boolean
Visual C++
public:
property bool IsPreviousWingEnabled {
    bool get ();
}

See Also

ScheduleView Class


NextCommand Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.NextCommand Property
ScheduleView Class See Also Send Feedback
Gets a command for moving to the next block (e.g. next week).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand NextCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextCommand As ICommand
Visual C++
public:
property ICommand^ NextCommand {
    ICommand^ get ();
}

See Also

ScheduleView Class


NextItemCommand Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.NextItemCommand Property
ScheduleView Class See Also Send Feedback
Gets a command for moving to the next ScheduleItem after the end of this view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand NextItemCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextItemCommand As ICommand
Visual C++
public:
property ICommand^ NextItemCommand {
    ICommand^ get ();
}

See Also

ScheduleView Class


Now Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.Now Property
ScheduleView Class See Also Send Feedback
Gets the current date and time.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime Now { get; }
Visual Basic (Declaration)
Public ReadOnly Property Now As DateTime
Visual C++
public:
property DateTime Now {
    DateTime get ();
}

Remarks

This is used for binding, to provide change notifications as time passes. It returns the same value as DateTime.Now.

See Also

ScheduleView Class


PreviousCommand Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.PreviousCommand Property
ScheduleView Class See Also Send Feedback
Gets a command for moving to the previous block (e.g. previous week).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand PreviousCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviousCommand As ICommand
Visual C++
public:
property ICommand^ PreviousCommand {
    ICommand^ get ();
}

See Also

ScheduleView Class


PreviousItemCommand Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.PreviousItemCommand Property
ScheduleView Class See Also Send Feedback
Gets a command for moving to the first ScheduleItem prior to the start of this view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ICommand PreviousItemCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviousItemCommand As ICommand
Visual C++
public:
property ICommand^ PreviousItemCommand {
    ICommand^ get ();
}

See Also

ScheduleView Class


Schedule Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.Schedule Property
ScheduleView Class See Also Send Feedback
Gets or sets the Schedule being displayed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected Schedule Schedule { get; set; }
Visual Basic (Declaration)
Protected Property Schedule As Schedule
Visual C++
protected:
property Schedule^ Schedule {
    Schedule^ get ();
    void set (Schedule^ value);
}

See Also

ScheduleView Class


ShowWings Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.ShowWings Property
ScheduleView Class See Also Send Feedback
Gets whether the view needs to display the "wing" buttons (previous and next schedule item).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowWings { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowWings As Boolean
Visual C++
public:
property bool ShowWings {
    bool get ();
}

See Also

ScheduleView Class


StartDate Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.StartDate Property
ScheduleView Class See Also Send Feedback
Gets or sets the start date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public MustOverride Property StartDate As DateTime
Visual C++
public:
virtual property DateTime StartDate {
    DateTime get () abstract;
    void set (DateTime value) abstract;
}

See Also

ScheduleView Class


Times Property

[image]

Mindscape Silverlight Elements
ScheduleView..::.Times Property
ScheduleView Class See Also Send Feedback
Gets the hours of the day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<TimeOfDay> Times { get; }
Visual Basic (Declaration)
Public ReadOnly Property Times As ReadOnlyCollection(Of TimeOfDay)
Visual C++
public:
property ReadOnlyCollection<TimeOfDay>^ Times {
    ReadOnlyCollection<TimeOfDay>^ get ();
}

See Also

ScheduleView Class


ScheduleView Events

[image] [image]

Mindscape Silverlight Elements
ScheduleView Events
ScheduleView Class See Also Send Feedback

The ScheduleView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

ScheduleView Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
ScheduleView..::.PropertyChanged Event
ScheduleView Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ScheduleView Class


SizeToMarginConverter Class

[image]

Mindscape Silverlight Elements
SizeToMarginConverter Class
Members See Also Send Feedback
Scales and converts a Size to a Thickness for use as a margin.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SizeToMarginConverter : IValueConverter
Visual Basic (Declaration)
Public Class SizeToMarginConverter _
    Implements IValueConverter
Visual C++
public ref class SizeToMarginConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.SizeToMarginConverter

See Also

SizeToMarginConverter Members


SizeToMarginConverter Members

[image] [image]

Mindscape Silverlight Elements
SizeToMarginConverter Members
SizeToMarginConverter Class Constructors Methods Properties See Also Send Feedback

The SizeToMarginConverter type exposes the following members.

Constructors

Name | Description
SizeToMarginConverter | Initializes a new instance of the SizeToMarginConverter class

Methods

Name | Description
Convert | Converts a Size to a Thickness, with scaling.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BottomFactor | The scale factor from Size.Height to Thickness.Bottom. The default is 0 (no bottom margin).
LeftFactor | The scale factor from Size.Width to Thickness.Left. The default is 0 (no left margin).
RightFactor | The scale factor from Size.Width to Thickness.Right. The default is 0 (no right margin).
TopFactor | The scale factor from Size.Height to Thickness.Top. The default is 0 (no top margin).

See Also

SizeToMarginConverter Class


SizeToMarginConverter Constructor

[image]

Mindscape Silverlight Elements
SizeToMarginConverter Constructor
SizeToMarginConverter Class See Also Send Feedback
Initializes a new instance of the SizeToMarginConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SizeToMarginConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SizeToMarginConverter()

See Also

SizeToMarginConverter Class


SizeToMarginConverter Methods

[image] [image]

Mindscape Silverlight Elements
SizeToMarginConverter Methods
SizeToMarginConverter Class See Also Send Feedback

The SizeToMarginConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a Size to a Thickness, with scaling.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SizeToMarginConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
SizeToMarginConverter..::.Convert Method
SizeToMarginConverter Class See Also Send Feedback
Converts a Size to a Thickness, with scaling.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The Size value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A Thickness suitable for use as a margin.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

SizeToMarginConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
SizeToMarginConverter..::.ConvertBack Method
SizeToMarginConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

SizeToMarginConverter Class


SizeToMarginConverter Properties

[image] [image]

Mindscape Silverlight Elements
SizeToMarginConverter Properties
SizeToMarginConverter Class See Also Send Feedback

The SizeToMarginConverter type exposes the following members.

Properties

Name | Description
BottomFactor | The scale factor from Size.Height to Thickness.Bottom. The default is 0 (no bottom margin).
LeftFactor | The scale factor from Size.Width to Thickness.Left. The default is 0 (no left margin).
RightFactor | The scale factor from Size.Width to Thickness.Right. The default is 0 (no right margin).
TopFactor | The scale factor from Size.Height to Thickness.Top. The default is 0 (no top margin).

See Also

SizeToMarginConverter Class


BottomFactor Property

[image]

Mindscape Silverlight Elements
SizeToMarginConverter..::.BottomFactor Property
SizeToMarginConverter Class See Also Send Feedback
The scale factor from Size.Height to Thickness.Bottom. The default is 0 (no bottom margin).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double BottomFactor { get; set; }
Visual Basic (Declaration)
Public Property BottomFactor As Double
Visual C++
public:
property double BottomFactor {
    double get ();
    void set (double value);
}

See Also

SizeToMarginConverter Class


LeftFactor Property

[image]

Mindscape Silverlight Elements
SizeToMarginConverter..::.LeftFactor Property
SizeToMarginConverter Class See Also Send Feedback
The scale factor from Size.Width to Thickness.Left. The default is 0 (no left margin).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double LeftFactor { get; set; }
Visual Basic (Declaration)
Public Property LeftFactor As Double
Visual C++
public:
property double LeftFactor {
    double get ();
    void set (double value);
}

See Also

SizeToMarginConverter Class


RightFactor Property

[image]

Mindscape Silverlight Elements
SizeToMarginConverter..::.RightFactor Property
SizeToMarginConverter Class See Also Send Feedback
The scale factor from Size.Width to Thickness.Right. The default is 0 (no right margin).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double RightFactor { get; set; }
Visual Basic (Declaration)
Public Property RightFactor As Double
Visual C++
public:
property double RightFactor {
    double get ();
    void set (double value);
}

See Also

SizeToMarginConverter Class


TopFactor Property

[image]

Mindscape Silverlight Elements
SizeToMarginConverter..::.TopFactor Property
SizeToMarginConverter Class See Also Send Feedback
The scale factor from Size.Height to Thickness.Top. The default is 0 (no top margin).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double TopFactor { get; set; }
Visual Basic (Declaration)
Public Property TopFactor As Double
Visual C++
public:
property double TopFactor {
    double get ();
    void set (double value);
}

See Also

SizeToMarginConverter Class


SmallSchedulerCanvas Class

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas Class
Members See Also Send Feedback
Represents a canvas on which schedule items can be laid out in a summary view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SmallSchedulerCanvas : SchedulerCanvasBase,
    IMouseWheelObserver
Visual Basic (Declaration)
Public Class SmallSchedulerCanvas _
    Inherits SchedulerCanvasBase _
    Implements IMouseWheelObserver
Visual C++
public ref class SmallSchedulerCanvas : public SchedulerCanvasBase,
    IMouseWheelObserver

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
System.Windows.Controls..::.Canvas
Mindscape.SilverlightElements..::.SchedulerCanvasBase
Mindscape.SilverlightElements..::.SmallSchedulerCanvas

See Also

SmallSchedulerCanvas Members


SmallSchedulerCanvas Members

[image] [image]

Mindscape Silverlight Elements
SmallSchedulerCanvas Members
SmallSchedulerCanvas Class Constructors Methods Fields Properties Events See Also Send Feedback

The SmallSchedulerCanvas type exposes the following members.

Constructors

Name | Description
SmallSchedulerCanvas | Initializes a new instance of the SmallSchedulerCanvas class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetDateTime | Gets the time corresponding to a location on the canvas. (Overrides SchedulerCanvasBase..::.GetDateTime(Double, Double, TimeEnd).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDaysChanged | Updates the user interface in response to changes to the Days property. (Overrides SchedulerCanvasBase..::.OnDaysChanged(DependencyPropertyChangedEventArgs).)
ReadLocalValue | (Inherited from DependencyObject.)
RelayoutCreateHereButton | Performs layout of the "create here" button when a setting or selection changes. (Inherited from SchedulerCanvasBase.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveCreateHereButton | Removes the "create here" button. (Inherited from SchedulerCanvasBase.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
BottomBufferProperty | Identifies the BottomBuffer property.
DayElementStyleProperty | Identifies the DayElementStyle property.
EnlargeWhenFullProperty | Identifies the EnlargeWhenFull property.
LongItemStyleProperty | Identifies the LongItemStyle property.
ShortItemStyleProperty | Identifies the ShortItemStyle property.
ShowShortItemsProperty | Identifies the ShowShortItems property.
TargetMonthProperty | Identifies the TargetMonth property.
TargetWeekProperty | Identifies the TargetWeek property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
BottomBuffer | Gets or sets the minimum amount of space to be available underneath the elements within this SmallSchedulerCanvas. This is a dependency property.
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CreateHereButtonStyle | Gets or sets the style for the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereDayIndex | Gets the day index on which to display the "create here" button. (Inherited from SchedulerCanvasBase.)
CreateHereElementDuration | Gets or sets the duration in minutes for a schedule item that is added useing the "Create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereElementStyle | Gets or sets the style for the "new appointment" element that appears when the user clicks the "create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereHintContent | Gets or sets the content displayed on the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereTime | Gets the time at whose location to display the "create here" button. (Inherited from SchedulerCanvasBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DayElementStyle | Gets or sets the Style applies to MonthViewDayElement objects displayed on the canvas. This is a dependency property.
Days | Gets or sets the per-day data to be represented on the canvas. This member supports the Scheduler control and is not intended for use in your code, but may be referenced in advanced styling and templating scenarios. This is a dependency property. (Inherited from SchedulerCanvasBase.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EnlargeWhenFull | Gets or sets whether the canvas should auto-enlarge to display its contents. This is a dependency property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
IsMouseDown | Gets whether the mouse button is down over the SchedulerCanvasBase. (Inherited from SchedulerCanvasBase.)
Language | (Inherited from FrameworkElement.)
LongItemStyle | Gets or sets the Style applied to SchedulerElement controls representing multi-day items. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelScrollFactor | Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel. (Overrides SchedulerCanvasBase..::.MouseWheelScrollFactor.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShortItemStyle | Gets or sets the Style applied to SchedulerElement controls representing single-day items. This is a dependency property.
ShowShortItems | Gets or sets whether to show single-day items. This should be set to true for summary views such as month views, and false if the single-day items are shown elsewhere as in day and week views. This is a dependency property.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
TargetMonth | Gets or sets the month in whose view the canvas appears. This is a dependency property.
TargetWeek | Gets or sets the TargetWeek. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SmallSchedulerCanvas Class


SmallSchedulerCanvas Constructor

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas Constructor
SmallSchedulerCanvas Class See Also Send Feedback
Initializes a new instance of the SmallSchedulerCanvas class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SmallSchedulerCanvas()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SmallSchedulerCanvas()

See Also

SmallSchedulerCanvas Class


SmallSchedulerCanvas Fields

[image] [image]

Mindscape Silverlight Elements
SmallSchedulerCanvas Fields
SmallSchedulerCanvas Class See Also Send Feedback

The SmallSchedulerCanvas type exposes the following members.

Fields

Name | Description
BottomBufferProperty | Identifies the BottomBuffer property.
DayElementStyleProperty | Identifies the DayElementStyle property.
EnlargeWhenFullProperty | Identifies the EnlargeWhenFull property.
LongItemStyleProperty | Identifies the LongItemStyle property.
ShortItemStyleProperty | Identifies the ShortItemStyle property.
ShowShortItemsProperty | Identifies the ShowShortItems property.
TargetMonthProperty | Identifies the TargetMonth property.
TargetWeekProperty | Identifies the TargetWeek property.

See Also

SmallSchedulerCanvas Class


BottomBufferProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.BottomBufferProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the BottomBuffer property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty BottomBufferProperty
Visual Basic (Declaration)
Public Shared ReadOnly BottomBufferProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ BottomBufferProperty

See Also

SmallSchedulerCanvas Class


DayElementStyleProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.DayElementStyleProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the DayElementStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DayElementStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DayElementStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DayElementStyleProperty

See Also

SmallSchedulerCanvas Class


EnlargeWhenFullProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.EnlargeWhenFullProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the EnlargeWhenFull property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty EnlargeWhenFullProperty
Visual Basic (Declaration)
Public Shared ReadOnly EnlargeWhenFullProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ EnlargeWhenFullProperty

See Also

SmallSchedulerCanvas Class


LongItemStyleProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.LongItemStyleProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the LongItemStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty LongItemStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly LongItemStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LongItemStyleProperty

See Also

SmallSchedulerCanvas Class


ShortItemStyleProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.ShortItemStyleProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the ShortItemStyle property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShortItemStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShortItemStyleProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShortItemStyleProperty

See Also

SmallSchedulerCanvas Class


ShowShortItemsProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.ShowShortItemsProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the ShowShortItems property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowShortItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowShortItemsProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ShowShortItemsProperty

See Also

SmallSchedulerCanvas Class


TargetMonthProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.TargetMonthProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the TargetMonth property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TargetMonthProperty
Visual Basic (Declaration)
Public Shared ReadOnly TargetMonthProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TargetMonthProperty

See Also

SmallSchedulerCanvas Class


TargetWeekProperty Field

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.TargetWeekProperty Field
SmallSchedulerCanvas Class See Also Send Feedback
Identifies the TargetWeek property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TargetWeekProperty
Visual Basic (Declaration)
Public Shared ReadOnly TargetWeekProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TargetWeekProperty

See Also

SmallSchedulerCanvas Class


SmallSchedulerCanvas Methods

[image] [image]

Mindscape Silverlight Elements
SmallSchedulerCanvas Methods
SmallSchedulerCanvas Class See Also Send Feedback

The SmallSchedulerCanvas type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from Canvas.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetDateTime | Gets the time corresponding to a location on the canvas. (Overrides SchedulerCanvasBase..::.GetDateTime(Double, Double, TimeEnd).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from Canvas.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDaysChanged | Updates the user interface in response to changes to the Days property. (Overrides SchedulerCanvasBase..::.OnDaysChanged(DependencyPropertyChangedEventArgs).)
ReadLocalValue | (Inherited from DependencyObject.)
RelayoutCreateHereButton | Performs layout of the "create here" button when a setting or selection changes. (Inherited from SchedulerCanvasBase.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveCreateHereButton | Removes the "create here" button. (Inherited from SchedulerCanvasBase.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

SmallSchedulerCanvas Class


GetDateTime Method

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.GetDateTime Method
SmallSchedulerCanvas Class See Also Send Feedback
Gets the time corresponding to a location on the canvas.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime GetDateTime(
    double x,
    double y,
    TimeEnd timeEnd
)
Visual Basic (Declaration)
Protected Overrides Function GetDateTime ( _
    x As Double, _
    y As Double, _
    timeEnd As TimeEnd _
) As DateTime
Visual C++
protected:
virtual DateTime GetDateTime(
    double x,
    double y,
    TimeEnd timeEnd
) override

Parameters

x
Type: System..::.Double
The x-coordinate of the location.
y
Type: System..::.Double
The y-coordinate of the location.
timeEnd
Type: Mindscape.SilverlightElements..::.TimeEnd
Whether to adjust the time for the start or end of a ScheduleItem.

Return Value

The date and time corresponding to x and y.

See Also

SmallSchedulerCanvas Class


OnDaysChanged Method

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.OnDaysChanged Method
SmallSchedulerCanvas Class See Also Send Feedback
Updates the user interface in response to changes to the Days property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnDaysChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnDaysChanged ( _
    e As DependencyPropertyChangedEventArgs _
)
Visual C++
protected:
virtual void OnDaysChanged(
    DependencyPropertyChangedEventArgs e
) override

Parameters

e
Type: System.Windows..::.DependencyPropertyChangedEventArgs
Contains information about changes to the Days property.

See Also

SmallSchedulerCanvas Class


SmallSchedulerCanvas Properties

[image] [image]

Mindscape Silverlight Elements
SmallSchedulerCanvas Properties
SmallSchedulerCanvas Class See Also Send Feedback

The SmallSchedulerCanvas type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
BottomBuffer | Gets or sets the minimum amount of space to be available underneath the elements within this SmallSchedulerCanvas. This is a dependency property.
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
CreateHereButtonStyle | Gets or sets the style for the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereDayIndex | Gets the day index on which to display the "create here" button. (Inherited from SchedulerCanvasBase.)
CreateHereElementDuration | Gets or sets the duration in minutes for a schedule item that is added useing the "Create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereElementStyle | Gets or sets the style for the "new appointment" element that appears when the user clicks the "create here" button. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereHintContent | Gets or sets the content displayed on the "create here" button that is displayed when the user hovers over the control. This is a dependency property. (Inherited from SchedulerCanvasBase.)
CreateHereTime | Gets the time at whose location to display the "create here" button. (Inherited from SchedulerCanvasBase.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DayElementStyle | Gets or sets the Style applies to MonthViewDayElement objects displayed on the canvas. This is a dependency property.
Days | Gets or sets the per-day data to be represented on the canvas. This member supports the Scheduler control and is not intended for use in your code, but may be referenced in advanced styling and templating scenarios. This is a dependency property. (Inherited from SchedulerCanvasBase.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EnlargeWhenFull | Gets or sets whether the canvas should auto-enlarge to display its contents. This is a dependency property.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
IsMouseDown | Gets whether the mouse button is down over the SchedulerCanvasBase. (Inherited from SchedulerCanvasBase.)
Language | (Inherited from FrameworkElement.)
LongItemStyle | Gets or sets the Style applied to SchedulerElement controls representing multi-day items. This is a dependency property.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseWheelScrollFactor | Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel. (Overrides SchedulerCanvasBase..::.MouseWheelScrollFactor.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShortItemStyle | Gets or sets the Style applied to SchedulerElement controls representing single-day items. This is a dependency property.
ShowShortItems | Gets or sets whether to show single-day items. This should be set to true for summary views such as month views, and false if the single-day items are shown elsewhere as in day and week views. This is a dependency property.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
TargetMonth | Gets or sets the month in whose view the canvas appears. This is a dependency property.
TargetWeek | Gets or sets the TargetWeek. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

SmallSchedulerCanvas Class


BottomBuffer Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.BottomBuffer Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets the minimum amount of space to be available underneath the elements within this SmallSchedulerCanvas. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float BottomBuffer { get; set; }
Visual Basic (Declaration)
Public Property BottomBuffer As Single
Visual C++
public:
property float BottomBuffer {
    float get ();
    void set (float value);
}

See Also

SmallSchedulerCanvas Class


DayElementStyle Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.DayElementStyle Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets the Style applies to MonthViewDayElement objects displayed on the canvas. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style DayElementStyle { get; set; }
Visual Basic (Declaration)
Public Property DayElementStyle As Style
Visual C++
public:
property Style^ DayElementStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | DayElementStyleProperty
Metadata properties set to true | None

See Also

SmallSchedulerCanvas Class


EnlargeWhenFull Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.EnlargeWhenFull Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets whether the canvas should auto-enlarge to display its contents. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool EnlargeWhenFull { get; set; }
Visual Basic (Declaration)
Public Property EnlargeWhenFull As Boolean
Visual C++
public:
property bool EnlargeWhenFull {
    bool get ();
    void set (bool value);
}

Remarks

Dependency Property Information
Identifier field | EnlargeWhenFullProperty
Metadata properties set to true | None

See Also

SmallSchedulerCanvas Class


LongItemStyle Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.LongItemStyle Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets the Style applied to SchedulerElement controls representing multi-day items. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style LongItemStyle { get; set; }
Visual Basic (Declaration)
Public Property LongItemStyle As Style
Visual C++
public:
property Style^ LongItemStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | LongItemStyleProperty
Metadata properties set to true | None

See Also

SmallSchedulerCanvas Class


MouseWheelScrollFactor Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.MouseWheelScrollFactor Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets the amount to scroll the SchedulerCanvasBase in response to the mouse wheel.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override double MouseWheelScrollFactor { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property MouseWheelScrollFactor As Double
Visual C++
protected:
virtual property double MouseWheelScrollFactor {
    double get () override;
}

See Also

SmallSchedulerCanvas Class


ShortItemStyle Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.ShortItemStyle Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets the Style applied to SchedulerElement controls representing single-day items. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Style ShortItemStyle { get; set; }
Visual Basic (Declaration)
Public Property ShortItemStyle As Style
Visual C++
public:
property Style^ ShortItemStyle {
    Style^ get ();
    void set (Style^ value);
}

Remarks

Dependency Property Information
Identifier field | ShortItemStyleProperty
Metadata properties set to true | None

See Also

SmallSchedulerCanvas Class


ShowShortItems Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.ShowShortItems Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets whether to show single-day items. This should be set to true for summary views such as month views, and false if the single-day items are shown elsewhere as in day and week views. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ShowShortItems { get; set; }
Visual Basic (Declaration)
Public Property ShowShortItems As Boolean
Visual C++
public:
property bool ShowShortItems {
    bool get ();
    void set (bool value);
}

Remarks

Dependency Property Information
Identifier field | ShowShortItemsProperty
Metadata properties set to true | None

See Also

SmallSchedulerCanvas Class


TargetMonth Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.TargetMonth Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets the month in whose view the canvas appears. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MonthModel TargetMonth { get; set; }
Visual Basic (Declaration)
Public Property TargetMonth As MonthModel
Visual C++
public:
property MonthModel^ TargetMonth {
    MonthModel^ get ();
    void set (MonthModel^ value);
}

Remarks

Dependency Property Information
Identifier field | TargetMonthProperty
Metadata properties set to true | None

See Also

SmallSchedulerCanvas Class


TargetWeek Property

[image]

Mindscape Silverlight Elements
SmallSchedulerCanvas..::.TargetWeek Property
SmallSchedulerCanvas Class See Also Send Feedback
Gets or sets the TargetWeek. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WeekModel TargetWeek { get; set; }
Visual Basic (Declaration)
Public Property TargetWeek As WeekModel
Visual C++
public:
property WeekModel^ TargetWeek {
    WeekModel^ get ();
    void set (WeekModel^ value);
}

See Also

SmallSchedulerCanvas Class


SmallSchedulerCanvas Events

[image] [image]

Mindscape Silverlight Elements
SmallSchedulerCanvas Events
SmallSchedulerCanvas Class See Also Send Feedback

The SmallSchedulerCanvas type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

SmallSchedulerCanvas Class


SpecificDateYearlyRecurrencePattern Class

[image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on a yearly basis on specific day of the year (e.g. every 25th of April).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SpecificDateYearlyRecurrencePattern : YearlyRecurrencePattern
Visual Basic (Declaration)
Public Class SpecificDateYearlyRecurrencePattern _
    Inherits YearlyRecurrencePattern
Visual C++
public ref class SpecificDateYearlyRecurrencePattern : public YearlyRecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.YearlyRecurrencePattern
Mindscape.SilverlightElements..::.SpecificDateYearlyRecurrencePattern

See Also

SpecificDateYearlyRecurrencePattern Members


SpecificDateYearlyRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern Members
SpecificDateYearlyRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The SpecificDateYearlyRecurrencePattern type exposes the following members.

Constructors

Name | Description
SpecificDateYearlyRecurrencePattern | Initializes a new instance of the SpecificDateYearlyRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DayOfMonth | Gets the day of the month on which the item occurs.
Month | Gets the month in which the item recurs. (Inherited from YearlyRecurrencePattern.)
YearlyInterval | Gets the number of years between recurrences. (Inherited from YearlyRecurrencePattern.)

See Also

SpecificDateYearlyRecurrencePattern Class


SpecificDateYearlyRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern Constructor
SpecificDateYearlyRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the SpecificDateYearlyRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SpecificDateYearlyRecurrencePattern(
    int yearlyInterval,
    int month,
    int dayOfMonth
)
Visual Basic (Declaration)
Public Sub New ( _
    yearlyInterval As Integer, _
    month As Integer, _
    dayOfMonth As Integer _
)
Visual C++
public:
SpecificDateYearlyRecurrencePattern(
    int yearlyInterval,
    int month,
    int dayOfMonth
)

Parameters

yearlyInterval
Type: System..::.Int32
The number of years between recurrences.
month
Type: System..::.Int32
The month in which the item recurs. (1 through 12)
dayOfMonth
Type: System..::.Int32
The day of the month on which the item occurs.

See Also

SpecificDateYearlyRecurrencePattern Class


SpecificDateYearlyRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern Methods
SpecificDateYearlyRecurrencePattern Class See Also Send Feedback

The SpecificDateYearlyRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpecificDateYearlyRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern..::.Includes Method
SpecificDateYearlyRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides RecurrencePattern..::.Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)

See Also

SpecificDateYearlyRecurrencePattern Class
SpecificDateYearlyRecurrencePattern Members


Includes Method (DateTime, DateTime, Boolean, Nullable(Int32))

[image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern..::.Includes Method (DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>))
SpecificDateYearlyRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

SpecificDateYearlyRecurrencePattern Class
Includes Overload


SpecificDateYearlyRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern Properties
SpecificDateYearlyRecurrencePattern Class See Also Send Feedback

The SpecificDateYearlyRecurrencePattern type exposes the following members.

Properties

Name | Description
DayOfMonth | Gets the day of the month on which the item occurs.
Month | Gets the month in which the item recurs. (Inherited from YearlyRecurrencePattern.)
YearlyInterval | Gets the number of years between recurrences. (Inherited from YearlyRecurrencePattern.)

See Also

SpecificDateYearlyRecurrencePattern Class


DayOfMonth Property

[image]

Mindscape Silverlight Elements
SpecificDateYearlyRecurrencePattern..::.DayOfMonth Property
SpecificDateYearlyRecurrencePattern Class See Also Send Feedback
Gets the day of the month on which the item occurs.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int DayOfMonth { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayOfMonth As Integer
Visual C++
public:
property int DayOfMonth {
    int get ();
}

See Also

SpecificDateYearlyRecurrencePattern Class


StandardPalettes Class

[image]

Mindscape Silverlight Elements
StandardPalettes Class
Members See Also Send Feedback
Provides standard palettes for use with the ColorPicker control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class StandardPalettes
Visual Basic (Declaration)
Public NotInheritable Class StandardPalettes
Visual C++
public ref class StandardPalettes abstract sealed

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.StandardPalettes

See Also

StandardPalettes Members


StandardPalettes Members

[image] [image]

Mindscape Silverlight Elements
StandardPalettes Members
StandardPalettes Class Methods Properties See Also Send Feedback

The StandardPalettes type exposes the following members.

Methods

Name | Description
GetOffice2007PaletteAuto | Gets a palette containing Office-style theme colors and an "automatic" color.

Properties

Name | Description
Office2007Palette | Gets a palette containing Office-style theme colors.

See Also

StandardPalettes Class


StandardPalettes Methods

[image] [image]

Mindscape Silverlight Elements
StandardPalettes Methods
StandardPalettes Class See Also Send Feedback

The StandardPalettes type exposes the following members.

Methods

Name | Description
GetOffice2007PaletteAuto | Gets a palette containing Office-style theme colors and an "automatic" color.

See Also

StandardPalettes Class


GetOffice2007PaletteAuto Method

[image]

Mindscape Silverlight Elements
StandardPalettes..::.GetOffice2007PaletteAuto Method
StandardPalettes Class See Also Send Feedback
Gets a palette containing Office-style theme colors and an "automatic" color.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ReadOnlyCollection<ColorPickerItem> GetOffice2007PaletteAuto(
    Color automaticColor
)
Visual Basic (Declaration)
Public Shared Function GetOffice2007PaletteAuto ( _
    automaticColor As Color _
) As ReadOnlyCollection(Of ColorPickerItem)
Visual C++
public:
static ReadOnlyCollection<ColorPickerItem^>^ GetOffice2007PaletteAuto(
    Color automaticColor
)

Parameters

automaticColor
Type: System.Windows.Media..::.Color

[Missing <param name="automaticColor"/> documentation for "M:Mindscape.SilverlightElements.StandardPalettes.GetOffice2007PaletteAuto(System.Windows.Media.Color)"]

Return Value

[Missing <returns> documentation for "M:Mindscape.SilverlightElements.StandardPalettes.GetOffice2007PaletteAuto(System.Windows.Media.Color)"]

See Also

StandardPalettes Class


StandardPalettes Properties

[image] [image]

Mindscape Silverlight Elements
StandardPalettes Properties
StandardPalettes Class See Also Send Feedback

The StandardPalettes type exposes the following members.

Properties

Name | Description
Office2007Palette | Gets a palette containing Office-style theme colors.

See Also

StandardPalettes Class


Office2007Palette Property

[image]

Mindscape Silverlight Elements
StandardPalettes..::.Office2007Palette Property
StandardPalettes Class See Also Send Feedback
Gets a palette containing Office-style theme colors.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static ReadOnlyCollection<ColorPickerItem> Office2007Palette { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Office2007Palette As ReadOnlyCollection(Of ColorPickerItem)
Visual C++
public:
static property ReadOnlyCollection<ColorPickerItem^>^ Office2007Palette {
    ReadOnlyCollection<ColorPickerItem^>^ get ();
}

See Also

StandardPalettes Class


StandardRichTextEditorToolBar Class

[image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar Class
Members See Also Send Feedback
Provides a standard toolbar for use with the RichTextEditor control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StandardRichTextEditorToolBar : Control
Visual Basic (Declaration)
Public Class StandardRichTextEditorToolBar _
    Inherits Control
Visual C++
public ref class StandardRichTextEditorToolBar : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.StandardRichTextEditorToolBar

See Also

StandardRichTextEditorToolBar Members


StandardRichTextEditorToolBar Members

[image] [image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar Members
StandardRichTextEditorToolBar Class Constructors Methods Fields Properties Events See Also Send Feedback

The StandardRichTextEditorToolBar type exposes the following members.

Constructors

Name | Description
StandardRichTextEditorToolBar | Initializes a new instance of the StandardRichTextEditorToolBar class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
EditorProperty | Identifies the Editor property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Editor | Gets or sets the RichTextEditor to which the toolbar applies. This is a dependency property.
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OrderedListStyles | Gets the collection of ordered list styles offered in the toolbar.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UnorderedListStyles | Gets the collection of unordered list styles offered in the toolbar.
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

StandardRichTextEditorToolBar Class


StandardRichTextEditorToolBar Constructor

[image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar Constructor
StandardRichTextEditorToolBar Class See Also Send Feedback
Initializes a new instance of the StandardRichTextEditorToolBar class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StandardRichTextEditorToolBar()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StandardRichTextEditorToolBar()

See Also

StandardRichTextEditorToolBar Class


StandardRichTextEditorToolBar Fields

[image] [image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar Fields
StandardRichTextEditorToolBar Class See Also Send Feedback

The StandardRichTextEditorToolBar type exposes the following members.

Fields

Name | Description
EditorProperty | Identifies the Editor property.

See Also

StandardRichTextEditorToolBar Class


EditorProperty Field

[image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar..::.EditorProperty Field
StandardRichTextEditorToolBar Class See Also Send Feedback
Identifies the Editor property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty EditorProperty
Visual Basic (Declaration)
Public Shared ReadOnly EditorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ EditorProperty

See Also

StandardRichTextEditorToolBar Class


StandardRichTextEditorToolBar Methods

[image] [image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar Methods
StandardRichTextEditorToolBar Class See Also Send Feedback

The StandardRichTextEditorToolBar type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

StandardRichTextEditorToolBar Class


OnApplyTemplate Method

[image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar..::.OnApplyTemplate Method
StandardRichTextEditorToolBar Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

StandardRichTextEditorToolBar Class


StandardRichTextEditorToolBar Properties

[image] [image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar Properties
StandardRichTextEditorToolBar Class See Also Send Feedback

The StandardRichTextEditorToolBar type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Editor | Gets or sets the RichTextEditor to which the toolbar applies. This is a dependency property.
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
OrderedListStyles | Gets the collection of ordered list styles offered in the toolbar.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UnorderedListStyles | Gets the collection of unordered list styles offered in the toolbar.
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

StandardRichTextEditorToolBar Class


Editor Property

[image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar..::.Editor Property
StandardRichTextEditorToolBar Class See Also Send Feedback
Gets or sets the RichTextEditor to which the toolbar applies. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RichTextEditor Editor { get; set; }
Visual Basic (Declaration)
Public Property Editor As RichTextEditor
Visual C++
public:
property RichTextEditor^ Editor {
    RichTextEditor^ get ();
    void set (RichTextEditor^ value);
}

Remarks

Dependency Property Information
Identifier field | EditorProperty
Metadata properties set to true | None

See Also

StandardRichTextEditorToolBar Class


OrderedListStyles Property

[image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar..::.OrderedListStyles Property
StandardRichTextEditorToolBar Class See Also Send Feedback
Gets the collection of ordered list styles offered in the toolbar.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<IListStyleType> OrderedListStyles { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrderedListStyles As ReadOnlyCollection(Of IListStyleType)
Visual C++
public:
property ReadOnlyCollection<IListStyleType^>^ OrderedListStyles {
    ReadOnlyCollection<IListStyleType^>^ get ();
}

See Also

StandardRichTextEditorToolBar Class


UnorderedListStyles Property

[image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar..::.UnorderedListStyles Property
StandardRichTextEditorToolBar Class See Also Send Feedback
Gets the collection of unordered list styles offered in the toolbar.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<IListStyleType> UnorderedListStyles { get; }
Visual Basic (Declaration)
Public ReadOnly Property UnorderedListStyles As ReadOnlyCollection(Of IListStyleType)
Visual C++
public:
property ReadOnlyCollection<IListStyleType^>^ UnorderedListStyles {
    ReadOnlyCollection<IListStyleType^>^ get ();
}

See Also

StandardRichTextEditorToolBar Class


StandardRichTextEditorToolBar Events

[image] [image]

Mindscape Silverlight Elements
StandardRichTextEditorToolBar Events
StandardRichTextEditorToolBar Class See Also Send Feedback

The StandardRichTextEditorToolBar type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

StandardRichTextEditorToolBar Class


StringTemplate Class

[image]

Mindscape Silverlight Elements
StringTemplate Class
Members See Also Send Feedback
Maps a string to a data template in a StringToDataTemplateConverter.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StringTemplate
Visual Basic (Declaration)
Public Class StringTemplate
Visual C++
public ref class StringTemplate

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.StringTemplate

See Also

StringTemplate Members


StringTemplate Members

[image] [image]

Mindscape Silverlight Elements
StringTemplate Members
StringTemplate Class Constructors Methods Properties See Also Send Feedback

The StringTemplate type exposes the following members.

Constructors

Name | Description
StringTemplate | Initializes a new instance of the StringTemplate class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
String | Gets or sets the string key.
Template | Gets or sets the data template.

See Also

StringTemplate Class


StringTemplate Constructor

[image]

Mindscape Silverlight Elements
StringTemplate Constructor
StringTemplate Class See Also Send Feedback
Initializes a new instance of the StringTemplate class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StringTemplate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringTemplate()

See Also

StringTemplate Class


StringTemplate Methods

[image] [image]

Mindscape Silverlight Elements
StringTemplate Methods
StringTemplate Class See Also Send Feedback

The StringTemplate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringTemplate Class


StringTemplate Properties

[image] [image]

Mindscape Silverlight Elements
StringTemplate Properties
StringTemplate Class See Also Send Feedback

The StringTemplate type exposes the following members.

Properties

Name | Description
String | Gets or sets the string key.
Template | Gets or sets the data template.

See Also

StringTemplate Class


String Property

[image]

Mindscape Silverlight Elements
StringTemplate..::.String Property
StringTemplate Class See Also Send Feedback
Gets or sets the string key.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string String { get; set; }
Visual Basic (Declaration)
Public Property String As String
Visual C++
public:
property String^ String {
    String^ get ();
    void set (String^ value);
}

See Also

StringTemplate Class


Template Property

[image]

Mindscape Silverlight Elements
StringTemplate..::.Template Property
StringTemplate Class See Also Send Feedback
Gets or sets the data template.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplate Template { get; set; }
Visual Basic (Declaration)
Public Property Template As DataTemplate
Visual C++
public:
property DataTemplate^ Template {
    DataTemplate^ get ();
    void set (DataTemplate^ value);
}

See Also

StringTemplate Class


StringToDataTemplateConverter Class

[image]

Mindscape Silverlight Elements
StringToDataTemplateConverter Class
Members See Also Send Feedback
Selects a data template using strings as keys.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StringToDataTemplateConverter : IValueConverter
Visual Basic (Declaration)
Public Class StringToDataTemplateConverter _
    Implements IValueConverter
Visual C++
public ref class StringToDataTemplateConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.StringToDataTemplateConverter

See Also

StringToDataTemplateConverter Members


StringToDataTemplateConverter Members

[image] [image]

Mindscape Silverlight Elements
StringToDataTemplateConverter Members
StringToDataTemplateConverter Class Constructors Methods Properties See Also Send Feedback

The StringToDataTemplateConverter type exposes the following members.

Constructors

Name | Description
StringToDataTemplateConverter | Initializes a new instance of the StringToDataTemplateConverter class

Methods

Name | Description
Convert | Selects the data template corresponding to the specified string key.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
StringTemplateMap | Gets the mapping of string keys to data templates.

See Also

StringToDataTemplateConverter Class


StringToDataTemplateConverter Constructor

[image]

Mindscape Silverlight Elements
StringToDataTemplateConverter Constructor
StringToDataTemplateConverter Class See Also Send Feedback
Initializes a new instance of the StringToDataTemplateConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StringToDataTemplateConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StringToDataTemplateConverter()

See Also

StringToDataTemplateConverter Class


StringToDataTemplateConverter Methods

[image] [image]

Mindscape Silverlight Elements
StringToDataTemplateConverter Methods
StringToDataTemplateConverter Class See Also Send Feedback

The StringToDataTemplateConverter type exposes the following members.

Methods

Name | Description
Convert | Selects the data template corresponding to the specified string key.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringToDataTemplateConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
StringToDataTemplateConverter..::.Convert Method
StringToDataTemplateConverter Class See Also Send Feedback
Selects the data template corresponding to the specified string key.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The String value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The data template to which the string is mapped in the StringTemplateMap, or null if the string is not mapped to a template.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

Remarks

String matching is case sensitive.

See Also

StringToDataTemplateConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
StringToDataTemplateConverter..::.ConvertBack Method
StringToDataTemplateConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

StringToDataTemplateConverter Class


StringToDataTemplateConverter Properties

[image] [image]

Mindscape Silverlight Elements
StringToDataTemplateConverter Properties
StringToDataTemplateConverter Class See Also Send Feedback

The StringToDataTemplateConverter type exposes the following members.

Properties

Name | Description
StringTemplateMap | Gets the mapping of string keys to data templates.

See Also

StringToDataTemplateConverter Class


StringTemplateMap Property

[image]

Mindscape Silverlight Elements
StringToDataTemplateConverter..::.StringTemplateMap Property
StringToDataTemplateConverter Class See Also Send Feedback
Gets the mapping of string keys to data templates.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ObservableCollection<StringTemplate> StringTemplateMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property StringTemplateMap As ObservableCollection(Of StringTemplate)
Visual C++
public:
property ObservableCollection<StringTemplate^>^ StringTemplateMap {
    ObservableCollection<StringTemplate^>^ get ();
}

See Also

StringToDataTemplateConverter Class


TemplateSelectableContentControl Class

[image]

Mindscape Silverlight Elements
TemplateSelectableContentControl Class
Members See Also Send Feedback
Displays content using either a content template, a content template selector or a simple display member binding.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TemplateSelectableContentControl : ContentControl
Visual Basic (Declaration)
Public Class TemplateSelectableContentControl _
    Inherits ContentControl
Visual C++
public ref class TemplateSelectableContentControl : public ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
Mindscape.SilverlightElements..::.TemplateSelectableContentControl

See Also

TemplateSelectableContentControl Members


TemplateSelectableContentControl Members

[image] [image]

Mindscape Silverlight Elements
TemplateSelectableContentControl Members
TemplateSelectableContentControl Class Constructors Methods Fields Properties Events See Also Send Feedback

The TemplateSelectableContentControl type exposes the following members.

Constructors

Name | Description
TemplateSelectableContentControl | Initializes a new instance of the TemplateSelectableContentControl class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnContentChanged | Called by the framework when the Content property changes. (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ContentTemplateSelectorProperty | Identifies the ContentTemplateSelector property.
DisplayMemberBindingProperty | Identifies the DisplayMemberBinding property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberBinding | Gets or sets the a binding for the content to be displayed if neither the ContentTemplate nor the ContentTemplateSelector is specified. This is a dependency property.
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

TemplateSelectableContentControl Class


TemplateSelectableContentControl Constructor

[image]

Mindscape Silverlight Elements
TemplateSelectableContentControl Constructor
TemplateSelectableContentControl Class See Also Send Feedback
Initializes a new instance of the TemplateSelectableContentControl class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TemplateSelectableContentControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateSelectableContentControl()

See Also

TemplateSelectableContentControl Class


TemplateSelectableContentControl Fields

[image] [image]

Mindscape Silverlight Elements
TemplateSelectableContentControl Fields
TemplateSelectableContentControl Class See Also Send Feedback

The TemplateSelectableContentControl type exposes the following members.

Fields

Name | Description
ContentTemplateSelectorProperty | Identifies the ContentTemplateSelector property.
DisplayMemberBindingProperty | Identifies the DisplayMemberBinding property.

See Also

TemplateSelectableContentControl Class


ContentTemplateSelectorProperty Field

[image]

Mindscape Silverlight Elements
TemplateSelectableContentControl..::.ContentTemplateSelectorProperty Field
TemplateSelectableContentControl Class See Also Send Feedback
Identifies the ContentTemplateSelector property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ContentTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentTemplateSelectorProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ContentTemplateSelectorProperty

See Also

TemplateSelectableContentControl Class


DisplayMemberBindingProperty Field

[image]

Mindscape Silverlight Elements
TemplateSelectableContentControl..::.DisplayMemberBindingProperty Field
TemplateSelectableContentControl Class See Also Send Feedback
Identifies the DisplayMemberBinding property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty DisplayMemberBindingProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisplayMemberBindingProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ DisplayMemberBindingProperty

See Also

TemplateSelectableContentControl Class


TemplateSelectableContentControl Methods

[image] [image]

Mindscape Silverlight Elements
TemplateSelectableContentControl Methods
TemplateSelectableContentControl Class See Also Send Feedback

The TemplateSelectableContentControl type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnContentChanged | Called by the framework when the Content property changes. (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

TemplateSelectableContentControl Class


OnContentChanged Method

[image]

Mindscape Silverlight Elements
TemplateSelectableContentControl..::.OnContentChanged Method
TemplateSelectableContentControl Class See Also Send Feedback
Called by the framework when the Content property changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)
Visual C++
protected:
virtual void OnContentChanged(
    Object^ oldContent,
    Object^ newContent
) override

Parameters

oldContent
Type: System..::.Object
The old content.
newContent
Type: System..::.Object
The new content.

See Also

TemplateSelectableContentControl Class


TemplateSelectableContentControl Properties

[image] [image]

Mindscape Silverlight Elements
TemplateSelectableContentControl Properties
TemplateSelectableContentControl Class See Also Send Feedback

The TemplateSelectableContentControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. This is a dependency property.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberBinding | Gets or sets the a binding for the content to be displayed if neither the ContentTemplate nor the ContentTemplateSelector is specified. This is a dependency property.
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

TemplateSelectableContentControl Class


ContentTemplateSelector Property

[image]

Mindscape Silverlight Elements
TemplateSelectableContentControl..::.ContentTemplateSelector Property
TemplateSelectableContentControl Class See Also Send Feedback
Gets or sets a template selector that enables an application writer to provide custom template-selection logic. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataTemplateSelector ContentTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ContentTemplateSelector As DataTemplateSelector
Visual C++
public:
property DataTemplateSelector^ ContentTemplateSelector {
    DataTemplateSelector^ get ();
    void set (DataTemplateSelector^ value);
}

See Also

TemplateSelectableContentControl Class


DisplayMemberBinding Property

[image]

Mindscape Silverlight Elements
TemplateSelectableContentControl..::.DisplayMemberBinding Property
TemplateSelectableContentControl Class See Also Send Feedback
Gets or sets the a binding for the content to be displayed if neither the ContentTemplate nor the ContentTemplateSelector is specified. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Binding DisplayMemberBinding { get; set; }
Visual Basic (Declaration)
Public Property DisplayMemberBinding As Binding
Visual C++
public:
property Binding^ DisplayMemberBinding {
    Binding^ get ();
    void set (Binding^ value);
}

Remarks

Dependency Property Information
Identifier field | DisplayMemberBindingProperty
Metadata properties set to true | None

See Also

TemplateSelectableContentControl Class


TemplateSelectableContentControl Events

[image] [image]

Mindscape Silverlight Elements
TemplateSelectableContentControl Events
TemplateSelectableContentControl Class See Also Send Feedback

The TemplateSelectableContentControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

TemplateSelectableContentControl Class


TimeEnd Enumeration

[image]

Mindscape Silverlight Elements
TimeEnd Enumeration
See Also Send Feedback
Specifies which end (start or finish) of a schedule item is being referred to.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum TimeEnd
Visual Basic (Declaration)
Public Enumeration TimeEnd
Visual C++
public enum class TimeEnd

Members

Member name | Description
StartTime | The start of a schedule item.
EndTime | The end of a schedule item.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


TimeOfDay Structure

[image]

Mindscape Silverlight Elements
TimeOfDay Structure
Members See Also Send Feedback
Represents a time of day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct TimeOfDay : IComparable<TimeOfDay>
Visual Basic (Declaration)
Public Structure TimeOfDay _
    Implements IComparable(Of TimeOfDay)
Visual C++
public value class TimeOfDay : IComparable<TimeOfDay>

See Also

TimeOfDay Members


TimeOfDay Members

[image] [image]

Mindscape Silverlight Elements
TimeOfDay Members
TimeOfDay Structure Constructors Methods Properties See Also Send Feedback

The TimeOfDay type exposes the following members.

Constructors

Name | Description
TimeOfDay | Overloaded.

Methods

Name | Description
CompareTo | Compares this TimeOfDay to another.
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Gets a string representation of the TimeOfDay. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
GreaterThan | Gets whether one TimeOfDay is later than another.
GreaterThanOrEqual | Gets whether one TimeOfDay is later than or the same as another.
LessThan | Gets whether one TimeOfDay is earlier than another.
LessThanOrEqual | Gets whether one TimeOfDay is earlier than or the same as another.

Properties

Name | Description
Hour | The hour of the TimeOfDay.
Minute | The minute of the TimeOfDay.
TwelveHourClockHour | The hour of the TimeOfDay, considered on the twelve-hour clock (e.g. 14:30 returns 2).

See Also

TimeOfDay Structure


TimeOfDay Constructor

[image] [image]

Mindscape Silverlight Elements
TimeOfDay Constructor
TimeOfDay Structure See Also Send Feedback

Overload List

Name | Description
TimeOfDay(Int32) | Initializes a new instance of the TimeOfDay class.
TimeOfDay(Int32, Int32) | Initializes a new instance of the TimeOfDay class.

See Also

TimeOfDay Structure
TimeOfDay Members


TimeOfDay Constructor (Int32)

[image]

Mindscape Silverlight Elements
TimeOfDay Constructor (Int32)
TimeOfDay Structure See Also Send Feedback
Initializes a new instance of the TimeOfDay class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay(
    int hour
)
Visual Basic (Declaration)
Public Sub New ( _
    hour As Integer _
)
Visual C++
public:
TimeOfDay(
    int hour
)

Parameters

hour
Type: System..::.Int32
The hour of the day.

See Also

TimeOfDay Structure
TimeOfDay Overload


TimeOfDay Constructor (Int32, Int32)

[image]

Mindscape Silverlight Elements
TimeOfDay Constructor (Int32, Int32)
TimeOfDay Structure See Also Send Feedback
Initializes a new instance of the TimeOfDay class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay(
    int hour,
    int minute
)
Visual Basic (Declaration)
Public Sub New ( _
    hour As Integer, _
    minute As Integer _
)
Visual C++
public:
TimeOfDay(
    int hour,
    int minute
)

Parameters

hour
Type: System..::.Int32
The hour of the day.
minute
Type: System..::.Int32
The minute of the hour.

See Also

TimeOfDay Structure
TimeOfDay Overload


TimeOfDay Methods

[image] [image]

Mindscape Silverlight Elements
TimeOfDay Methods
TimeOfDay Structure See Also Send Feedback

The TimeOfDay type exposes the following members.

Methods

Name | Description
CompareTo | Compares this TimeOfDay to another.
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Gets a string representation of the TimeOfDay. (Overrides ValueType..::.ToString()()().)

Operators

Name | Description
GreaterThan | Gets whether one TimeOfDay is later than another.
GreaterThanOrEqual | Gets whether one TimeOfDay is later than or the same as another.
LessThan | Gets whether one TimeOfDay is earlier than another.
LessThanOrEqual | Gets whether one TimeOfDay is earlier than or the same as another.

See Also

TimeOfDay Structure


CompareTo Method

[image]

Mindscape Silverlight Elements
TimeOfDay..::.CompareTo Method
TimeOfDay Structure See Also Send Feedback
Compares this TimeOfDay to another.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    TimeOfDay other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As TimeOfDay _
) As Integer
Visual C++
public:
virtual int CompareTo(
    TimeOfDay other
) sealed

Parameters

other
Type: Mindscape.SilverlightElements..::.TimeOfDay
The TimeOfDay to compare against.

Return Value

A negative value if this TimeOfDay occurs before the other; a positive value if this TimeOfDay occurs after the other; 0 if the two TimeOfDays coincide.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

TimeOfDay Structure


GreaterThan Operator

[image]

Mindscape Silverlight Elements
TimeOfDay..::.GreaterThan Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is later than another.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator >(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator >(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.SilverlightElements..::.TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.SilverlightElements..::.TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is later than second; otherwise false.

See Also

TimeOfDay Structure


GreaterThanOrEqual Operator

[image]

Mindscape Silverlight Elements
TimeOfDay..::.GreaterThanOrEqual Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is later than or the same as another.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator >=(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic (Declaration)
Public Shared Operator >= ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator >=(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.SilverlightElements..::.TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.SilverlightElements..::.TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is later than or the same as second; otherwise false.

See Also

TimeOfDay Structure


LessThan Operator

[image]

Mindscape Silverlight Elements
TimeOfDay..::.LessThan Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is earlier than another.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator <(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator <(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.SilverlightElements..::.TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.SilverlightElements..::.TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is earlier than second; otherwise false.

See Also

TimeOfDay Structure


LessThanOrEqual Operator

[image]

Mindscape Silverlight Elements
TimeOfDay..::.LessThanOrEqual Operator
TimeOfDay Structure See Also Send Feedback
Gets whether one TimeOfDay is earlier than or the same as another.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator <=(
    TimeOfDay first,
    TimeOfDay second
)
Visual Basic (Declaration)
Public Shared Operator <= ( _
    first As TimeOfDay, _
    second As TimeOfDay _
) As Boolean
Visual C++
public:
static bool operator <=(
    TimeOfDay first,
    TimeOfDay second
)

Parameters

first
Type: Mindscape.SilverlightElements..::.TimeOfDay
The first TimeOfDay to compare.
second
Type: Mindscape.SilverlightElements..::.TimeOfDay
The second TimeOfDay to compare.

Return Value

true if first is earlier than or the same as second; otherwise false.

See Also

TimeOfDay Structure


ToString Method

[image]

Mindscape Silverlight Elements
TimeOfDay..::.ToString Method
TimeOfDay Structure See Also Send Feedback
Gets a string representation of the TimeOfDay.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of the TimeOfDay.

See Also

TimeOfDay Structure


TimeOfDay Properties

[image] [image]

Mindscape Silverlight Elements
TimeOfDay Properties
TimeOfDay Structure See Also Send Feedback

The TimeOfDay type exposes the following members.

Properties

Name | Description
Hour | The hour of the TimeOfDay.
Minute | The minute of the TimeOfDay.
TwelveHourClockHour | The hour of the TimeOfDay, considered on the twelve-hour clock (e.g. 14:30 returns 2).

See Also

TimeOfDay Structure


Hour Property

[image]

Mindscape Silverlight Elements
TimeOfDay..::.Hour Property
TimeOfDay Structure See Also Send Feedback
The hour of the TimeOfDay.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Hour { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hour As Integer
Visual C++
public:
property int Hour {
    int get ();
}

See Also

TimeOfDay Structure


Minute Property

[image]

Mindscape Silverlight Elements
TimeOfDay..::.Minute Property
TimeOfDay Structure See Also Send Feedback
The minute of the TimeOfDay.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Minute { get; }
Visual Basic (Declaration)
Public ReadOnly Property Minute As Integer
Visual C++
public:
property int Minute {
    int get ();
}

See Also

TimeOfDay Structure


TwelveHourClockHour Property

[image]

Mindscape Silverlight Elements
TimeOfDay..::.TwelveHourClockHour Property
TimeOfDay Structure See Also Send Feedback
The hour of the TimeOfDay, considered on the twelve-hour clock (e.g. 14:30 returns 2).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int TwelveHourClockHour { get; }
Visual Basic (Declaration)
Public ReadOnly Property TwelveHourClockHour As Integer
Visual C++
public:
property int TwelveHourClockHour {
    int get ();
}

See Also

TimeOfDay Structure


TimeOfDayToMinuteStringConverter Class

[image]

Mindscape Silverlight Elements
TimeOfDayToMinuteStringConverter Class
Members See Also Send Feedback
Converts a time to a string suitable for display in the "minute" portion of the "time of day" bar in a day or week view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeOfDayToMinuteStringConverter : IValueConverter
Visual Basic (Declaration)
Public Class TimeOfDayToMinuteStringConverter _
    Implements IValueConverter
Visual C++
public ref class TimeOfDayToMinuteStringConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeOfDayToMinuteStringConverter

See Also

TimeOfDayToMinuteStringConverter Members


TimeOfDayToMinuteStringConverter Members

[image] [image]

Mindscape Silverlight Elements
TimeOfDayToMinuteStringConverter Members
TimeOfDayToMinuteStringConverter Class Constructors Methods See Also Send Feedback

The TimeOfDayToMinuteStringConverter type exposes the following members.

Constructors

Name | Description
TimeOfDayToMinuteStringConverter | Initializes a new instance of the TimeOfDayToMinuteStringConverter class

Methods

Name | Description
Convert | Converts a time to a string suitable for display in the "minute" portion of the "time of day" bar in a day or week view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeOfDayToMinuteStringConverter Class


TimeOfDayToMinuteStringConverter Constructor

[image]

Mindscape Silverlight Elements
TimeOfDayToMinuteStringConverter Constructor
TimeOfDayToMinuteStringConverter Class See Also Send Feedback
Initializes a new instance of the TimeOfDayToMinuteStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDayToMinuteStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeOfDayToMinuteStringConverter()

See Also

TimeOfDayToMinuteStringConverter Class


TimeOfDayToMinuteStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
TimeOfDayToMinuteStringConverter Methods
TimeOfDayToMinuteStringConverter Class See Also Send Feedback

The TimeOfDayToMinuteStringConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a time to a string suitable for display in the "minute" portion of the "time of day" bar in a day or week view.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeOfDayToMinuteStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
TimeOfDayToMinuteStringConverter..::.Convert Method
TimeOfDayToMinuteStringConverter Class See Also Send Feedback
Converts a time to a string suitable for display in the "minute" portion of the "time of day" bar in a day or week view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The DateTime value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string for display in the time bar of a day or week view.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

TimeOfDayToMinuteStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
TimeOfDayToMinuteStringConverter..::.ConvertBack Method
TimeOfDayToMinuteStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeOfDayToMinuteStringConverter Class


TimeOfDayToStringConverter Class

[image]

Mindscape Silverlight Elements
TimeOfDayToStringConverter Class
Members See Also Send Feedback
Converts a TimeOfDay object into a formatted string displaying the hours, minutes and AM/PM designator. Hours are displayed in 12 hour clock time. Minutes are always displayed with 2 digits.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeOfDayToStringConverter : TimeStringConverterBase,
    IValueConverter
Visual Basic (Declaration)
Public Class TimeOfDayToStringConverter _
    Inherits TimeStringConverterBase _
    Implements IValueConverter
Visual C++
public ref class TimeOfDayToStringConverter : public TimeStringConverterBase,
    IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeStringConverterBase
Mindscape.SilverlightElements..::.TimeOfDayToStringConverter

See Also

TimeOfDayToStringConverter Members


TimeOfDayToStringConverter Members

[image] [image]

Mindscape Silverlight Elements
TimeOfDayToStringConverter Members
TimeOfDayToStringConverter Class Constructors Methods Properties See Also Send Feedback

The TimeOfDayToStringConverter type exposes the following members.

Constructors

Name | Description
TimeOfDayToStringConverter | Initializes a new instance of the TimeOfDayToStringConverter class

Methods

Name | Description
Convert | Converts a TimeOfDay to a display string.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TimeEnd | Gets or sets which end of a range is to be formatted. (Inherited from TimeStringConverterBase.)

See Also

TimeOfDayToStringConverter Class


TimeOfDayToStringConverter Constructor

[image]

Mindscape Silverlight Elements
TimeOfDayToStringConverter Constructor
TimeOfDayToStringConverter Class See Also Send Feedback
Initializes a new instance of the TimeOfDayToStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDayToStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeOfDayToStringConverter()

See Also

TimeOfDayToStringConverter Class


TimeOfDayToStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
TimeOfDayToStringConverter Methods
TimeOfDayToStringConverter Class See Also Send Feedback

The TimeOfDayToStringConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a TimeOfDay to a display string.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeOfDayToStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
TimeOfDayToStringConverter..::.Convert Method
TimeOfDayToStringConverter Class See Also Send Feedback
Converts a TimeOfDay to a display string.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The TimeOfDay value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string containing the formatted TimeOfDay.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

TimeOfDayToStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
TimeOfDayToStringConverter..::.ConvertBack Method
TimeOfDayToStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeOfDayToStringConverter Class


TimeOfDayToStringConverter Properties

[image] [image]

Mindscape Silverlight Elements
TimeOfDayToStringConverter Properties
TimeOfDayToStringConverter Class See Also Send Feedback

The TimeOfDayToStringConverter type exposes the following members.

Properties

Name | Description
TimeEnd | Gets or sets which end of a range is to be formatted. (Inherited from TimeStringConverterBase.)

See Also

TimeOfDayToStringConverter Class


TimeOfDayVerticalOffsetConverter Class

[image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter Class
Members See Also Send Feedback
Determines the vertical offset at which to display items corresponding to a particular time of day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeOfDayVerticalOffsetConverter : IValueConverter
Visual Basic (Declaration)
Public Class TimeOfDayVerticalOffsetConverter _
    Implements IValueConverter
Visual C++
public ref class TimeOfDayVerticalOffsetConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeOfDayVerticalOffsetConverter

See Also

TimeOfDayVerticalOffsetConverter Members


TimeOfDayVerticalOffsetConverter Members

[image] [image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter Members
TimeOfDayVerticalOffsetConverter Class Constructors Methods Properties See Also Send Feedback

The TimeOfDayVerticalOffsetConverter type exposes the following members.

Constructors

Name | Description
TimeOfDayVerticalOffsetConverter | Initializes a new instance of the TimeOfDayVerticalOffsetConverter class

Methods

Name | Description
Convert | Determines the vertical offset corresponding to the time of day.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HourSlotHeight | Gets or sets the vertical offset to be applied per hour of the time of day.

See Also

TimeOfDayVerticalOffsetConverter Class


TimeOfDayVerticalOffsetConverter Constructor

[image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter Constructor
TimeOfDayVerticalOffsetConverter Class See Also Send Feedback
Initializes a new instance of the TimeOfDayVerticalOffsetConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDayVerticalOffsetConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeOfDayVerticalOffsetConverter()

See Also

TimeOfDayVerticalOffsetConverter Class


TimeOfDayVerticalOffsetConverter Methods

[image] [image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter Methods
TimeOfDayVerticalOffsetConverter Class See Also Send Feedback

The TimeOfDayVerticalOffsetConverter type exposes the following members.

Methods

Name | Description
Convert | Determines the vertical offset corresponding to the time of day.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeOfDayVerticalOffsetConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter..::.Convert Method
TimeOfDayVerticalOffsetConverter Class See Also Send Feedback
Determines the vertical offset corresponding to the time of day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The DateTime value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The vertical offset corresponding to the time of day of the input value. (Date components of the input DateTime are ignored.)

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

TimeOfDayVerticalOffsetConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter..::.ConvertBack Method
TimeOfDayVerticalOffsetConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeOfDayVerticalOffsetConverter Class


TimeOfDayVerticalOffsetConverter Properties

[image] [image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter Properties
TimeOfDayVerticalOffsetConverter Class See Also Send Feedback

The TimeOfDayVerticalOffsetConverter type exposes the following members.

Properties

Name | Description
HourSlotHeight | Gets or sets the vertical offset to be applied per hour of the time of day.

See Also

TimeOfDayVerticalOffsetConverter Class


HourSlotHeight Property

[image]

Mindscape Silverlight Elements
TimeOfDayVerticalOffsetConverter..::.HourSlotHeight Property
TimeOfDayVerticalOffsetConverter Class See Also Send Feedback
Gets or sets the vertical offset to be applied per hour of the time of day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double HourSlotHeight { get; set; }
Visual Basic (Declaration)
Public Property HourSlotHeight As Double
Visual C++
public:
property double HourSlotHeight {
    double get ();
    void set (double value);
}

See Also

TimeOfDayVerticalOffsetConverter Class


TimePicker Class

[image]

Mindscape Silverlight Elements
TimePicker Class
Members See Also Send Feedback
Provides a user interface for selecting a time of day by entering a time or selecting from a drop-down list.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimePicker : Control
Visual Basic (Declaration)
Public Class TimePicker _
    Inherits Control
Visual C++
public ref class TimePicker : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.TimePicker

See Also

TimePicker Members


TimePicker Members

[image] [image]

Mindscape Silverlight Elements
TimePicker Members
TimePicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The TimePicker type exposes the following members.

Constructors

Name | Description
TimePicker | Initializes a new instance of the TimePicker class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsDropDownOpenProperty | Identifies the IsDropDownOpen property.
ItemsSourceProperty | Identifies the ItemsSource property.
SelectedTimeProperty | Identifies the SelectedTime property.
TextProperty | Identifies the Text property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Gets or sets whether the drop-down part of the TimePicker is open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource | Gets or sets the collection of times to be displayed in the drop-down part of the control. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedTime | Gets or sets the selected TimeOfDay. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text displayed in the TimePicker. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedTimeChanged | Raised when the SelectedTime changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

TimePicker Class


TimePicker Constructor

[image]

Mindscape Silverlight Elements
TimePicker Constructor
TimePicker Class See Also Send Feedback
Initializes a new instance of the TimePicker class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimePicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimePicker()

See Also

TimePicker Class


TimePicker Fields

[image] [image]

Mindscape Silverlight Elements
TimePicker Fields
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Fields

Name | Description
IsDropDownOpenProperty | Identifies the IsDropDownOpen property.
ItemsSourceProperty | Identifies the ItemsSource property.
SelectedTimeProperty | Identifies the SelectedTime property.
TextProperty | Identifies the Text property.

See Also

TimePicker Class


IsDropDownOpenProperty Field

[image]

Mindscape Silverlight Elements
TimePicker..::.IsDropDownOpenProperty Field
TimePicker Class See Also Send Feedback
Identifies the IsDropDownOpen property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsDropDownOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsDropDownOpenProperty

See Also

TimePicker Class


ItemsSourceProperty Field

[image]

Mindscape Silverlight Elements
TimePicker..::.ItemsSourceProperty Field
TimePicker Class See Also Send Feedback
Identifies the ItemsSource property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemsSourceProperty

See Also

TimePicker Class


SelectedTimeProperty Field

[image]

Mindscape Silverlight Elements
TimePicker..::.SelectedTimeProperty Field
TimePicker Class See Also Send Feedback
Identifies the SelectedTime property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedTimeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedTimeProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedTimeProperty

See Also

TimePicker Class


TextProperty Field

[image]

Mindscape Silverlight Elements
TimePicker..::.TextProperty Field
TimePicker Class See Also Send Feedback
Identifies the Text property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextProperty

See Also

TimePicker Class


TimePicker Methods

[image] [image]

Mindscape Silverlight Elements
TimePicker Methods
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

TimePicker Class


TimePicker Properties

[image] [image]

Mindscape Silverlight Elements
TimePicker Properties
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Gets or sets whether the drop-down part of the TimePicker is open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource | Gets or sets the collection of times to be displayed in the drop-down part of the control. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedTime | Gets or sets the selected TimeOfDay. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text displayed in the TimePicker. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

TimePicker Class


IsDropDownOpen Property

[image]

Mindscape Silverlight Elements
TimePicker..::.IsDropDownOpen Property
TimePicker Class See Also Send Feedback
Gets or sets whether the drop-down part of the TimePicker is open. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean
Visual C++
public:
property bool IsDropDownOpen {
    bool get ();
    void set (bool value);
}

See Also

TimePicker Class


ItemsSource Property

[image]

Mindscape Silverlight Elements
TimePicker..::.ItemsSource Property
TimePicker Class See Also Send Feedback
Gets or sets the collection of times to be displayed in the drop-down part of the control. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IList<TimeOfDay> ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As IList(Of TimeOfDay)
Visual C++
public:
property IList<TimeOfDay>^ ItemsSource {
    IList<TimeOfDay>^ get ();
    void set (IList<TimeOfDay>^ value);
}

See Also

TimePicker Class


SelectedTime Property

[image]

Mindscape Silverlight Elements
TimePicker..::.SelectedTime Property
TimePicker Class See Also Send Feedback
Gets or sets the selected TimeOfDay. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeOfDay SelectedTime { get; set; }
Visual Basic (Declaration)
Public Property SelectedTime As TimeOfDay
Visual C++
public:
property TimeOfDay SelectedTime {
    TimeOfDay get ();
    void set (TimeOfDay value);
}

See Also

TimePicker Class


Text Property

[image]

Mindscape Silverlight Elements
TimePicker..::.Text Property
TimePicker Class See Also Send Feedback
Gets or sets the text displayed in the TimePicker. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TimePicker Class


TimePicker Events

[image] [image]

Mindscape Silverlight Elements
TimePicker Events
TimePicker Class See Also Send Feedback

The TimePicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedTimeChanged | Raised when the SelectedTime changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

TimePicker Class


SelectedTimeChanged Event

[image]

Mindscape Silverlight Elements
TimePicker..::.SelectedTimeChanged Event
TimePicker Class See Also Send Feedback
Raised when the SelectedTime changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event RoutedEventHandler SelectedTimeChanged
Visual Basic (Declaration)
Public Event SelectedTimeChanged As RoutedEventHandler
Visual C++
public:
 event RoutedEventHandler^ SelectedTimeChanged {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

See Also

TimePicker Class


TimeSlot Class

[image]

Mindscape Silverlight Elements
TimeSlot Class
Members See Also Send Feedback
Represents a slot on the display surface of a Scheduler control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeSlot : ViewModelBase, IComparable<TimeSlot>
Visual Basic (Declaration)
Public Class TimeSlot _
    Inherits ViewModelBase _
    Implements IComparable(Of TimeSlot)
Visual C++
public ref class TimeSlot : public ViewModelBase,
    IComparable<TimeSlot^>

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ViewModelBase
Mindscape.SilverlightElements..::.TimeSlot

See Also

TimeSlot Members


TimeSlot Members

[image] [image]

Mindscape Silverlight Elements
TimeSlot Members
TimeSlot Class Methods Properties Events See Also Send Feedback

The TimeSlot type exposes the following members.

Methods

Name | Description
CompareTo | Compares this TimeSlot to another.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DateTime | Gets the time of the TimeSlot.
Hour | Gets the hour of the TimeSlot.
IsSelected | Gets whether the TimeSlot is selected.
Minute | Gets the minute of the TimeSlot.
TimeSlotState | Gets the display status of the TimeSlot.

Events

Name | Description
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

TimeSlot Class


TimeSlot Methods

[image] [image]

Mindscape Silverlight Elements
TimeSlot Methods
TimeSlot Class See Also Send Feedback

The TimeSlot type exposes the following members.

Methods

Name | Description
CompareTo | Compares this TimeSlot to another.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSlot Class


CompareTo Method

[image]

Mindscape Silverlight Elements
TimeSlot..::.CompareTo Method
TimeSlot Class See Also Send Feedback
Compares this TimeSlot to another.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    TimeSlot other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As TimeSlot _
) As Integer
Visual C++
public:
virtual int CompareTo(
    TimeSlot^ other
) sealed

Parameters

other
Type: Mindscape.SilverlightElements..::.TimeSlot
The TimeSlot to compare against.

Return Value

A negative value if this TimeSlot occurs before the other; a positive value if this TimeSlot occurs after the other; 0 if the two TimeSlots coincide.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

TimeSlot Class


TimeSlot Properties

[image] [image]

Mindscape Silverlight Elements
TimeSlot Properties
TimeSlot Class See Also Send Feedback

The TimeSlot type exposes the following members.

Properties

Name | Description
DateTime | Gets the time of the TimeSlot.
Hour | Gets the hour of the TimeSlot.
IsSelected | Gets whether the TimeSlot is selected.
Minute | Gets the minute of the TimeSlot.
TimeSlotState | Gets the display status of the TimeSlot.

See Also

TimeSlot Class


DateTime Property

[image]

Mindscape Silverlight Elements
TimeSlot..::.DateTime Property
TimeSlot Class See Also Send Feedback
Gets the time of the TimeSlot.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime DateTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property DateTime As DateTime
Visual C++
public:
property DateTime DateTime {
    DateTime get ();
}

See Also

TimeSlot Class


Hour Property

[image]

Mindscape Silverlight Elements
TimeSlot..::.Hour Property
TimeSlot Class See Also Send Feedback
Gets the hour of the TimeSlot.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Hour { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hour As Integer
Visual C++
public:
property int Hour {
    int get ();
}

See Also

TimeSlot Class


IsSelected Property

[image]

Mindscape Silverlight Elements
TimeSlot..::.IsSelected Property
TimeSlot Class See Also Send Feedback
Gets whether the TimeSlot is selected.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSelected { get; internal set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

TimeSlot Class


Minute Property

[image]

Mindscape Silverlight Elements
TimeSlot..::.Minute Property
TimeSlot Class See Also Send Feedback
Gets the minute of the TimeSlot.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Minute { get; }
Visual Basic (Declaration)
Public ReadOnly Property Minute As Integer
Visual C++
public:
property int Minute {
    int get ();
}

See Also

TimeSlot Class


TimeSlotState Property

[image]

Mindscape Silverlight Elements
TimeSlot..::.TimeSlotState Property
TimeSlot Class See Also Send Feedback
Gets the display status of the TimeSlot.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSlotState TimeSlotState { get; private set; }
Visual Basic (Declaration)
Public Property TimeSlotState As TimeSlotState
Visual C++
public:
property TimeSlotState TimeSlotState {
    TimeSlotState get ();
    void set (TimeSlotState value);
}

See Also

TimeSlot Class


TimeSlot Events

[image] [image]

Mindscape Silverlight Elements
TimeSlot Events
TimeSlot Class See Also Send Feedback

The TimeSlot type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

TimeSlot Class


TimeSlotState Enumeration

[image]

Mindscape Silverlight Elements
TimeSlotState Enumeration
See Also Send Feedback
Specifies status information used for rendering a TimeSlot.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum TimeSlotState
Visual Basic (Declaration)
Public Enumeration TimeSlotState
Visual C++
public enum class TimeSlotState

Members

Member name | Description
WorkTime | The timeslot is unselected and within working hours.
NotWorkTime | The timeslot is unselected and outside working hours.
SelectedWorkTime | The timeslot is selected and within working hours.
SelectedNotWorkTime | The timeslot is selected and outside working hours.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


TimeSlotStateToBrushConverter Class

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter Class
Members See Also Send Feedback
Selects a brush according to an TimeSlotState.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeSlotStateToBrushConverter : IValueConverter
Visual Basic (Declaration)
Public Class TimeSlotStateToBrushConverter _
    Implements IValueConverter
Visual C++
public ref class TimeSlotStateToBrushConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeSlotStateToBrushConverter

See Also

TimeSlotStateToBrushConverter Members


TimeSlotStateToBrushConverter Members

[image] [image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter Members
TimeSlotStateToBrushConverter Class Constructors Methods Properties See Also Send Feedback

The TimeSlotStateToBrushConverter type exposes the following members.

Constructors

Name | Description
TimeSlotStateToBrushConverter | Initializes a new instance of the TimeSlotStateToBrushConverter class

Methods

Name | Description
Convert | Selects a brush according to the input TimeSlotState.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NotWorkTimeBrush | The brush to use if the TimeSlotState is NotWorkTime.
SelectedNotWorkTimeBrush | The brush to use if the TimeSlotState is SelectedNotWorkTime.
SelectedWorkTimeBrush | The brush to use if the TimeSlotState is SelectedWorkTime.
WorkTimeBrush | The brush to use if the TimeSlotState is WorkTime.

See Also

TimeSlotStateToBrushConverter Class


TimeSlotStateToBrushConverter Constructor

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter Constructor
TimeSlotStateToBrushConverter Class See Also Send Feedback
Initializes a new instance of the TimeSlotStateToBrushConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSlotStateToBrushConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeSlotStateToBrushConverter()

See Also

TimeSlotStateToBrushConverter Class


TimeSlotStateToBrushConverter Methods

[image] [image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter Methods
TimeSlotStateToBrushConverter Class See Also Send Feedback

The TimeSlotStateToBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Selects a brush according to the input TimeSlotState.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSlotStateToBrushConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter..::.Convert Method
TimeSlotStateToBrushConverter Class See Also Send Feedback
Selects a brush according to the input TimeSlotState.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The TimeSlotState value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The selected brush.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

TimeSlotStateToBrushConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter..::.ConvertBack Method
TimeSlotStateToBrushConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeSlotStateToBrushConverter Class


TimeSlotStateToBrushConverter Properties

[image] [image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter Properties
TimeSlotStateToBrushConverter Class See Also Send Feedback

The TimeSlotStateToBrushConverter type exposes the following members.

Properties

Name | Description
NotWorkTimeBrush | The brush to use if the TimeSlotState is NotWorkTime.
SelectedNotWorkTimeBrush | The brush to use if the TimeSlotState is SelectedNotWorkTime.
SelectedWorkTimeBrush | The brush to use if the TimeSlotState is SelectedWorkTime.
WorkTimeBrush | The brush to use if the TimeSlotState is WorkTime.

See Also

TimeSlotStateToBrushConverter Class


NotWorkTimeBrush Property

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter..::.NotWorkTimeBrush Property
TimeSlotStateToBrushConverter Class See Also Send Feedback
The brush to use if the TimeSlotState is NotWorkTime.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush NotWorkTimeBrush { get; set; }
Visual Basic (Declaration)
Public Property NotWorkTimeBrush As Brush
Visual C++
public:
property Brush^ NotWorkTimeBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

TimeSlotStateToBrushConverter Class


SelectedNotWorkTimeBrush Property

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter..::.SelectedNotWorkTimeBrush Property
TimeSlotStateToBrushConverter Class See Also Send Feedback
The brush to use if the TimeSlotState is SelectedNotWorkTime.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush SelectedNotWorkTimeBrush { get; set; }
Visual Basic (Declaration)
Public Property SelectedNotWorkTimeBrush As Brush
Visual C++
public:
property Brush^ SelectedNotWorkTimeBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

TimeSlotStateToBrushConverter Class


SelectedWorkTimeBrush Property

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter..::.SelectedWorkTimeBrush Property
TimeSlotStateToBrushConverter Class See Also Send Feedback
The brush to use if the TimeSlotState is SelectedWorkTime.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush SelectedWorkTimeBrush { get; set; }
Visual Basic (Declaration)
Public Property SelectedWorkTimeBrush As Brush
Visual C++
public:
property Brush^ SelectedWorkTimeBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

TimeSlotStateToBrushConverter Class


WorkTimeBrush Property

[image]

Mindscape Silverlight Elements
TimeSlotStateToBrushConverter..::.WorkTimeBrush Property
TimeSlotStateToBrushConverter Class See Also Send Feedback
The brush to use if the TimeSlotState is WorkTime.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Brush WorkTimeBrush { get; set; }
Visual Basic (Declaration)
Public Property WorkTimeBrush As Brush
Visual C++
public:
property Brush^ WorkTimeBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

TimeSlotStateToBrushConverter Class


TimeSpanPicker Class

[image]

Mindscape Silverlight Elements
TimeSpanPicker Class
Members See Also Send Feedback
Provides a user interface for selecting a duration or TimeSpan by entering a value directly or selecting from a drop-down list.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeSpanPicker : Control
Visual Basic (Declaration)
Public Class TimeSpanPicker _
    Inherits Control
Visual C++
public ref class TimeSpanPicker : public Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.TimeSpanPicker

See Also

TimeSpanPicker Members


TimeSpanPicker Members

[image] [image]

Mindscape Silverlight Elements
TimeSpanPicker Members
TimeSpanPicker Class Constructors Methods Fields Properties Events See Also Send Feedback

The TimeSpanPicker type exposes the following members.

Constructors

Name | Description
TimeSpanPicker | Initializes a new instance of the TimeSpanPicker class.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsDropDownOpenProperty | Identifies the IsDropDownOpen property.
ItemsSourceProperty | Identifies the ItemsSource property.
SelectedTimeSpanProperty | Identifies the SelectedTimeSpan property.
TextProperty | Identifies the Text property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Gets or sets whether the drop-down part of the TimeSpanPicker is open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource | Gets or sets the collection of TimeSpan values offered in the drop-down part of the TimeSpanPicker. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedTimeSpan | Gets or sets the selected TimeSpan. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text displayed in the TimeSpanPicker. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedTimeSpanChanged | Raised when the SelectedTimeSpan changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

TimeSpanPicker Class


TimeSpanPicker Constructor

[image]

Mindscape Silverlight Elements
TimeSpanPicker Constructor
TimeSpanPicker Class See Also Send Feedback
Initializes a new instance of the TimeSpanPicker class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpanPicker()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeSpanPicker()

See Also

TimeSpanPicker Class


TimeSpanPicker Fields

[image] [image]

Mindscape Silverlight Elements
TimeSpanPicker Fields
TimeSpanPicker Class See Also Send Feedback

The TimeSpanPicker type exposes the following members.

Fields

Name | Description
IsDropDownOpenProperty | Identifies the IsDropDownOpen property.
ItemsSourceProperty | Identifies the ItemsSource property.
SelectedTimeSpanProperty | Identifies the SelectedTimeSpan property.
TextProperty | Identifies the Text property.

See Also

TimeSpanPicker Class


IsDropDownOpenProperty Field

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.IsDropDownOpenProperty Field
TimeSpanPicker Class See Also Send Feedback
Identifies the IsDropDownOpen property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsDropDownOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ IsDropDownOpenProperty

See Also

TimeSpanPicker Class


ItemsSourceProperty Field

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.ItemsSourceProperty Field
TimeSpanPicker Class See Also Send Feedback
Identifies the ItemsSource property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ ItemsSourceProperty

See Also

TimeSpanPicker Class


SelectedTimeSpanProperty Field

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.SelectedTimeSpanProperty Field
TimeSpanPicker Class See Also Send Feedback
Identifies the SelectedTimeSpan property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedTimeSpanProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedTimeSpanProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ SelectedTimeSpanProperty

See Also

TimeSpanPicker Class


TextProperty Field

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.TextProperty Field
TimeSpanPicker Class See Also Send Feedback
Identifies the Text property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ TextProperty

See Also

TimeSpanPicker Class


TimeSpanPicker Methods

[image] [image]

Mindscape Silverlight Elements
TimeSpanPicker Methods
TimeSpanPicker Class See Also Send Feedback

The TimeSpanPicker type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

TimeSpanPicker Class


TimeSpanPicker Properties

[image] [image]

Mindscape Silverlight Elements
TimeSpanPicker Properties
TimeSpanPicker Class See Also Send Feedback

The TimeSpanPicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Gets or sets whether the drop-down part of the TimeSpanPicker is open. This is a dependency property.
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource | Gets or sets the collection of TimeSpan values offered in the drop-down part of the TimeSpanPicker. This is a dependency property.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedTimeSpan | Gets or sets the selected TimeSpan. This is a dependency property.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text displayed in the TimeSpanPicker. This is a dependency property.
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

TimeSpanPicker Class


IsDropDownOpen Property

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.IsDropDownOpen Property
TimeSpanPicker Class See Also Send Feedback
Gets or sets whether the drop-down part of the TimeSpanPicker is open. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean
Visual C++
public:
property bool IsDropDownOpen {
    bool get ();
    void set (bool value);
}

See Also

TimeSpanPicker Class


ItemsSource Property

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.ItemsSource Property
TimeSpanPicker Class See Also Send Feedback
Gets or sets the collection of TimeSpan values offered in the drop-down part of the TimeSpanPicker. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IList<TimeSpan> ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As IList(Of TimeSpan)
Visual C++
public:
property IList<TimeSpan>^ ItemsSource {
    IList<TimeSpan>^ get ();
    void set (IList<TimeSpan>^ value);
}

See Also

TimeSpanPicker Class


SelectedTimeSpan Property

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.SelectedTimeSpan Property
TimeSpanPicker Class See Also Send Feedback
Gets or sets the selected TimeSpan. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpan SelectedTimeSpan { get; set; }
Visual Basic (Declaration)
Public Property SelectedTimeSpan As TimeSpan
Visual C++
public:
property TimeSpan SelectedTimeSpan {
    TimeSpan get ();
    void set (TimeSpan value);
}

See Also

TimeSpanPicker Class


Text Property

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.Text Property
TimeSpanPicker Class See Also Send Feedback
Gets or sets the text displayed in the TimeSpanPicker. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TimeSpanPicker Class


TimeSpanPicker Events

[image] [image]

Mindscape Silverlight Elements
TimeSpanPicker Events
TimeSpanPicker Class See Also Send Feedback

The TimeSpanPicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SelectedTimeSpanChanged | Raised when the SelectedTimeSpan changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

TimeSpanPicker Class


SelectedTimeSpanChanged Event

[image]

Mindscape Silverlight Elements
TimeSpanPicker..::.SelectedTimeSpanChanged Event
TimeSpanPicker Class See Also Send Feedback
Raised when the SelectedTimeSpan changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event RoutedEventHandler SelectedTimeSpanChanged
Visual Basic (Declaration)
Public Event SelectedTimeSpanChanged As RoutedEventHandler
Visual C++
public:
 event RoutedEventHandler^ SelectedTimeSpanChanged {
    void add (RoutedEventHandler^ value);
    void remove (RoutedEventHandler^ value);
}

See Also

TimeSpanPicker Class


TimeSpanToLinearDimensionConverter Class

[image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter Class
Members See Also Send Feedback
Converts a TimeSpan to a linear dimension.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeSpanToLinearDimensionConverter : IValueConverter
Visual Basic (Declaration)
Public Class TimeSpanToLinearDimensionConverter _
    Implements IValueConverter
Visual C++
public ref class TimeSpanToLinearDimensionConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeSpanToLinearDimensionConverter

See Also

TimeSpanToLinearDimensionConverter Members


TimeSpanToLinearDimensionConverter Members

[image] [image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter Members
TimeSpanToLinearDimensionConverter Class Constructors Methods Properties See Also Send Feedback

The TimeSpanToLinearDimensionConverter type exposes the following members.

Constructors

Name | Description
TimeSpanToLinearDimensionConverter | Initializes a new instance of the TimeSpanToLinearDimensionConverter class

Methods

Name | Description
Convert | Converts a TimeSpan value from a binding source to a linear dimension for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PixelsPerHour | The scale factor for the linear dimension.

See Also

TimeSpanToLinearDimensionConverter Class


TimeSpanToLinearDimensionConverter Constructor

[image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter Constructor
TimeSpanToLinearDimensionConverter Class See Also Send Feedback
Initializes a new instance of the TimeSpanToLinearDimensionConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpanToLinearDimensionConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeSpanToLinearDimensionConverter()

See Also

TimeSpanToLinearDimensionConverter Class


TimeSpanToLinearDimensionConverter Methods

[image] [image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter Methods
TimeSpanToLinearDimensionConverter Class See Also Send Feedback

The TimeSpanToLinearDimensionConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a TimeSpan value from a binding source to a linear dimension for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSpanToLinearDimensionConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter..::.Convert Method
TimeSpanToLinearDimensionConverter Class See Also Send Feedback
Converts a TimeSpan value from a binding source to a linear dimension for use by a binding target.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The TimeSpan value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A linear dimension value suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

Remarks

The converter will output a double or Thickness depending on the target type. For Thickness values, the dimension is returned as the Top value, i.e. the Thickness may be used only as a vertical offset.

See Also

TimeSpanToLinearDimensionConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter..::.ConvertBack Method
TimeSpanToLinearDimensionConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeSpanToLinearDimensionConverter Class


TimeSpanToLinearDimensionConverter Properties

[image] [image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter Properties
TimeSpanToLinearDimensionConverter Class See Also Send Feedback

The TimeSpanToLinearDimensionConverter type exposes the following members.

Properties

Name | Description
PixelsPerHour | The scale factor for the linear dimension.

See Also

TimeSpanToLinearDimensionConverter Class


PixelsPerHour Property

[image]

Mindscape Silverlight Elements
TimeSpanToLinearDimensionConverter..::.PixelsPerHour Property
TimeSpanToLinearDimensionConverter Class See Also Send Feedback
The scale factor for the linear dimension.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double PixelsPerHour { get; set; }
Visual Basic (Declaration)
Public Property PixelsPerHour As Double
Visual C++
public:
property double PixelsPerHour {
    double get ();
    void set (double value);
}

See Also

TimeSpanToLinearDimensionConverter Class


TimeSpanToStringConverter Class

[image]

Mindscape Silverlight Elements
TimeSpanToStringConverter Class
Members See Also Send Feedback
Converts a TimeSpan to a formated string showing the number of minutes, hours, days or weeks.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeSpanToStringConverter : IValueConverter
Visual Basic (Declaration)
Public Class TimeSpanToStringConverter _
    Implements IValueConverter
Visual C++
public ref class TimeSpanToStringConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeSpanToStringConverter

See Also

TimeSpanToStringConverter Members


TimeSpanToStringConverter Members

[image] [image]

Mindscape Silverlight Elements
TimeSpanToStringConverter Members
TimeSpanToStringConverter Class Constructors Methods See Also Send Feedback

The TimeSpanToStringConverter type exposes the following members.

Constructors

Name | Description
TimeSpanToStringConverter | Initializes a new instance of the TimeSpanToStringConverter class

Methods

Name | Description
Convert | Converts a TimeSpan to a formated string.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSpanToStringConverter Class


TimeSpanToStringConverter Constructor

[image]

Mindscape Silverlight Elements
TimeSpanToStringConverter Constructor
TimeSpanToStringConverter Class See Also Send Feedback
Initializes a new instance of the TimeSpanToStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpanToStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeSpanToStringConverter()

See Also

TimeSpanToStringConverter Class


TimeSpanToStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
TimeSpanToStringConverter Methods
TimeSpanToStringConverter Class See Also Send Feedback

The TimeSpanToStringConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a TimeSpan to a formated string.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSpanToStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
TimeSpanToStringConverter..::.Convert Method
TimeSpanToStringConverter Class See Also Send Feedback
Converts a TimeSpan to a formated string.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The TimeSpan value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string containing the formatted TimeSpan.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

TimeSpanToStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
TimeSpanToStringConverter..::.ConvertBack Method
TimeSpanToStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

TimeSpanToStringConverter Class


TimeStringConverterBase Class

[image]

Mindscape Silverlight Elements
TimeStringConverterBase Class
Members See Also Send Feedback
Provides a base class for converters that output strings representing times.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TimeStringConverterBase
Visual Basic (Declaration)
Public Class TimeStringConverterBase
Visual C++
public ref class TimeStringConverterBase

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TimeStringConverterBase
Mindscape.SilverlightElements..::.SchedulerElementDisplayStateToTimeStringConverter
Mindscape.SilverlightElements..::.TimeOfDayToStringConverter

See Also

TimeStringConverterBase Members


TimeStringConverterBase Members

[image] [image]

Mindscape Silverlight Elements
TimeStringConverterBase Members
TimeStringConverterBase Class Constructors Methods Properties See Also Send Feedback

The TimeStringConverterBase type exposes the following members.

Constructors

Name | Description
TimeStringConverterBase | Initializes a new instance of the TimeStringConverterBase class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatTimeOfDay | Formats a time of day for display.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TimeEnd | Gets or sets which end of a range is to be formatted.

See Also

TimeStringConverterBase Class


TimeStringConverterBase Constructor

[image]

Mindscape Silverlight Elements
TimeStringConverterBase Constructor
TimeStringConverterBase Class See Also Send Feedback
Initializes a new instance of the TimeStringConverterBase class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeStringConverterBase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeStringConverterBase()

See Also

TimeStringConverterBase Class


TimeStringConverterBase Methods

[image] [image]

Mindscape Silverlight Elements
TimeStringConverterBase Methods
TimeStringConverterBase Class See Also Send Feedback

The TimeStringConverterBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FormatTimeOfDay | Formats a time of day for display.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeStringConverterBase Class


FormatTimeOfDay Method

[image]

Mindscape Silverlight Elements
TimeStringConverterBase..::.FormatTimeOfDay Method
TimeStringConverterBase Class See Also Send Feedback
Formats a time of day for display.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected static string FormatTimeOfDay(
    DateTime timeToConvert,
    CultureInfo culture
)
Visual Basic (Declaration)
Protected Shared Function FormatTimeOfDay ( _
    timeToConvert As DateTime, _
    culture As CultureInfo _
) As String
Visual C++
protected:
static String^ FormatTimeOfDay(
    DateTime timeToConvert,
    CultureInfo^ culture
)

Parameters

timeToConvert
Type: System..::.DateTime
The time to be displayed.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in formatting.

Return Value

A string representing the time of day part of the timeToConvert.

See Also

TimeStringConverterBase Class


TimeStringConverterBase Properties

[image] [image]

Mindscape Silverlight Elements
TimeStringConverterBase Properties
TimeStringConverterBase Class See Also Send Feedback

The TimeStringConverterBase type exposes the following members.

Properties

Name | Description
TimeEnd | Gets or sets which end of a range is to be formatted.

See Also

TimeStringConverterBase Class


TimeEnd Property

[image]

Mindscape Silverlight Elements
TimeStringConverterBase..::.TimeEnd Property
TimeStringConverterBase Class See Also Send Feedback
Gets or sets which end of a range is to be formatted.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeEnd TimeEnd { get; set; }
Visual Basic (Declaration)
Public Property TimeEnd As TimeEnd
Visual C++
public:
property TimeEnd TimeEnd {
    TimeEnd get ();
    void set (TimeEnd value);
}

See Also

TimeStringConverterBase Class


TypeMatchVisibilityConverter Class

[image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter Class
Members See Also Send Feedback
Selects the visibility of an element according to whether the input is of a specified type.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TypeMatchVisibilityConverter : IValueConverter
Visual Basic (Declaration)
Public Class TypeMatchVisibilityConverter _
    Implements IValueConverter
Visual C++
public ref class TypeMatchVisibilityConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.TypeMatchVisibilityConverter

See Also

TypeMatchVisibilityConverter Members


TypeMatchVisibilityConverter Members

[image] [image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter Members
TypeMatchVisibilityConverter Class Constructors Methods Properties See Also Send Feedback

The TypeMatchVisibilityConverter type exposes the following members.

Constructors

Name | Description
TypeMatchVisibilityConverter | Initializes a new instance of the TypeMatchVisibilityConverter class

Methods

Name | Description
Convert | Selects a Visibility according to whether the input is of a specified type.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
TypeName | The name of the type to check for. This should be an unqualified type name, i.e. excluding any namespace or assembly information.

See Also

TypeMatchVisibilityConverter Class


TypeMatchVisibilityConverter Constructor

[image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter Constructor
TypeMatchVisibilityConverter Class See Also Send Feedback
Initializes a new instance of the TypeMatchVisibilityConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TypeMatchVisibilityConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TypeMatchVisibilityConverter()

See Also

TypeMatchVisibilityConverter Class


TypeMatchVisibilityConverter Methods

[image] [image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter Methods
TypeMatchVisibilityConverter Class See Also Send Feedback

The TypeMatchVisibilityConverter type exposes the following members.

Methods

Name | Description
Convert | Selects a Visibility according to whether the input is of a specified type.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypeMatchVisibilityConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter..::.Convert Method
TypeMatchVisibilityConverter Class See Also Send Feedback
Selects a Visibility according to whether the input is of a specified type.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

Visibility.Visible if the object's type name is equal to the TypeName string; otherwise Visibility.Collapsed.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

Remarks

The type check is for an exact match, i.e. equality of type names. Inheritance is not considered; derived types will not match.

See Also

TypeMatchVisibilityConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter..::.ConvertBack Method
TypeMatchVisibilityConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

TypeMatchVisibilityConverter Class


TypeMatchVisibilityConverter Properties

[image] [image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter Properties
TypeMatchVisibilityConverter Class See Also Send Feedback

The TypeMatchVisibilityConverter type exposes the following members.

Properties

Name | Description
TypeName | The name of the type to check for. This should be an unqualified type name, i.e. excluding any namespace or assembly information.

See Also

TypeMatchVisibilityConverter Class


TypeName Property

[image]

Mindscape Silverlight Elements
TypeMatchVisibilityConverter..::.TypeName Property
TypeMatchVisibilityConverter Class See Also Send Feedback
The name of the type to check for. This should be an unqualified type name, i.e. excluding any namespace or assembly information.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic (Declaration)
Public Property TypeName As String
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Remarks

The type check is for an exact match, i.e. equality of type names. Inheritance is not considered; derived types will not match.

See Also

TypeMatchVisibilityConverter Class


UniformGrid Class

[image]

Mindscape Silverlight Elements
UniformGrid Class
Members See Also Send Feedback
Provides uniform sizing and spacing in a single row or column.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UniformGrid : Panel
Visual Basic (Declaration)
Public Class UniformGrid _
    Inherits Panel
Visual C++
public ref class UniformGrid : public Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
Mindscape.SilverlightElements..::.UniformGrid

See Also

UniformGrid Members


UniformGrid Members

[image] [image]

Mindscape Silverlight Elements
UniformGrid Members
UniformGrid Class Constructors Methods Fields Properties Events See Also Send Feedback

The UniformGrid type exposes the following members.

Constructors

Name | Description
UniformGrid | Initializes a new instance of the UniformGrid class

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | Arranges the content of the element. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the child elements of the control. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
OrientationProperty | Identifies the Orientation property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the orientation. This is a dependency property.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

UniformGrid Class


UniformGrid Constructor

[image]

Mindscape Silverlight Elements
UniformGrid Constructor
UniformGrid Class See Also Send Feedback
Initializes a new instance of the UniformGrid class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UniformGrid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UniformGrid()

See Also

UniformGrid Class


UniformGrid Fields

[image] [image]

Mindscape Silverlight Elements
UniformGrid Fields
UniformGrid Class See Also Send Feedback

The UniformGrid type exposes the following members.

Fields

Name | Description
OrientationProperty | Identifies the Orientation property.

See Also

UniformGrid Class


OrientationProperty Field

[image]

Mindscape Silverlight Elements
UniformGrid..::.OrientationProperty Field
UniformGrid Class See Also Send Feedback
Identifies the Orientation property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ OrientationProperty

See Also

UniformGrid Class


UniformGrid Methods

[image] [image]

Mindscape Silverlight Elements
UniformGrid Methods
UniformGrid Class See Also Send Feedback

The UniformGrid type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | Arranges the content of the element. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the child elements of the control. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from FrameworkElement.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

UniformGrid Class


ArrangeOverride Method

[image]

Mindscape Silverlight Elements
UniformGrid..::.ArrangeOverride Method
UniformGrid Class See Also Send Feedback
Arranges the content of the element.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override Size ArrangeOverride(
    Size arrangeSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    arrangeSize As Size _
) As Size
Visual C++
protected:
virtual Size ArrangeOverride(
    Size arrangeSize
) override

Parameters

arrangeSize
Type: System.Windows..::.Size
The size that this element should use to arrange its child elements.

Return Value

The arranged size of this element and its children.

See Also

UniformGrid Class


MeasureOverride Method

[image]

Mindscape Silverlight Elements
UniformGrid..::.MeasureOverride Method
UniformGrid Class See Also Send Feedback
Measures the child elements of the control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size
Visual C++
protected:
virtual Size MeasureOverride(
    Size constraint
) override

Parameters

constraint
Type: System.Windows..::.Size
An upper limit size that should not be exceeded.

Return Value

The desired size of the element.

See Also

UniformGrid Class


UniformGrid Properties

[image] [image]

Mindscape Silverlight Elements
UniformGrid Properties
UniformGrid Class See Also Send Feedback

The UniformGrid type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
CacheMode | (Inherited from UIElement.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsItemsHost | (Inherited from Panel.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the orientation. This is a dependency property.
Parent | (Inherited from FrameworkElement.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

UniformGrid Class


Orientation Property

[image]

Mindscape Silverlight Elements
UniformGrid..::.Orientation Property
UniformGrid Class See Also Send Feedback
Gets or sets the orientation. This is a dependency property.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

Remarks

Dependency Property Information
Identifier field | OrientationProperty
Metadata properties set to true | None

See Also

UniformGrid Class


UniformGrid Events

[image] [image]

Mindscape Silverlight Elements
UniformGrid Events
UniformGrid Class See Also Send Feedback

The UniformGrid type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

UniformGrid Class


ViewModelBase Class

[image]

Mindscape Silverlight Elements
ViewModelBase Class
Members See Also Send Feedback
Provides property change notification servics for view model objects.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class ViewModelBase : INotifyPropertyChanged
Visual Basic (Declaration)
Public MustInherit Class ViewModelBase _
    Implements INotifyPropertyChanged
Visual C++
public ref class ViewModelBase abstract : INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ViewModelBase
Mindscape.SilverlightElements..::.NotifyingColor
Mindscape.SilverlightElements..::.ScheduleItem
Mindscape.SilverlightElements..::.TimeSlot

See Also

ViewModelBase Members


ViewModelBase Members

[image] [image]

Mindscape Silverlight Elements
ViewModelBase Members
ViewModelBase Class Constructors Methods Events See Also Send Feedback

The ViewModelBase type exposes the following members.

Constructors

Name | Description
ViewModelBase | Initializes a new instance of the ViewModelBase class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event.
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

ViewModelBase Class


ViewModelBase Constructor

[image]

Mindscape Silverlight Elements
ViewModelBase Constructor
ViewModelBase Class See Also Send Feedback
Initializes a new instance of the ViewModelBase class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected ViewModelBase()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ViewModelBase()

See Also

ViewModelBase Class


ViewModelBase Methods

[image] [image]

Mindscape Silverlight Elements
ViewModelBase Methods
ViewModelBase Class See Also Send Feedback

The ViewModelBase type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event.
Set<(Of <(T>)>) | Sets the specified field, raising the PropertyChanged event if required.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewModelBase Class


OnPropertyChanged Method

[image]

Mindscape Silverlight Elements
ViewModelBase..::.OnPropertyChanged Method
ViewModelBase Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::.String
The name of the property that changed.

See Also

ViewModelBase Class


Set(T) Method

[image]

Mindscape Silverlight Elements
ViewModelBase..::.Set<(Of <(T>)>) Method
ViewModelBase Class See Also Send Feedback
Sets the specified field, raising the PropertyChanged event if required.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void Set<T>(
    ref T field,
    T value,
    string propertyName
)
Visual Basic (Declaration)
Protected Sub Set(Of T) ( _
    ByRef field As T, _
    value As T, _
    propertyName As String _
)
Visual C++
protected:
generic<typename T>
void Set(
    T% field,
    T value,
    String^ propertyName
)

Parameters

field
Type: T %
The field to set.
value
Type: T
The value to which to set the field.
propertyName
Type: System..::.String
The name of the property for the PropertyChanged event.

Type Parameters

T
The type of field.

See Also

ViewModelBase Class


ViewModelBase Events

[image] [image]

Mindscape Silverlight Elements
ViewModelBase Events
ViewModelBase Class See Also Send Feedback

The ViewModelBase type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

ViewModelBase Class


PropertyChanged Event

[image]

Mindscape Silverlight Elements
ViewModelBase..::.PropertyChanged Event
ViewModelBase Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ViewModelBase Class


WeeklyRecurrencePattern Class

[image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on a weekly basis.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class WeeklyRecurrencePattern : RecurrencePattern
Visual Basic (Declaration)
Public Class WeeklyRecurrencePattern _
    Inherits RecurrencePattern
Visual C++
public ref class WeeklyRecurrencePattern : public RecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.WeeklyRecurrencePattern

See Also

WeeklyRecurrencePattern Members


WeeklyRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern Members
WeeklyRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The WeeklyRecurrencePattern type exposes the following members.

Constructors

Name | Description
WeeklyRecurrencePattern | Initializes a new instance of the WeeklyRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DaysOfWeek | Gets the days of the week on which the item recurs.
WeeklyInterval | Gets the number of weeks between recurrences.

See Also

WeeklyRecurrencePattern Class


WeeklyRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern Constructor
WeeklyRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the WeeklyRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WeeklyRecurrencePattern(
    int weeklyInterval,
    params DayOfWeek[] daysOfWeek
)
Visual Basic (Declaration)
Public Sub New ( _
    weeklyInterval As Integer, _
    ParamArray daysOfWeek As DayOfWeek() _
)
Visual C++
public:
WeeklyRecurrencePattern(
    int weeklyInterval,
    ... array<DayOfWeek>^ daysOfWeek
)

Parameters

weeklyInterval
Type: System..::.Int32
The number of weeks between recurrences.
daysOfWeek
Type: array< System..::.DayOfWeek >[]()[]
The days of the week on which the item recurs.

See Also

WeeklyRecurrencePattern Class


WeeklyRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern Methods
WeeklyRecurrencePattern Class See Also Send Feedback

The WeeklyRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeeklyRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern..::.Includes Method
WeeklyRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides RecurrencePattern..::.Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)

See Also

WeeklyRecurrencePattern Class
WeeklyRecurrencePattern Members


Includes Method (DateTime, DateTime, Boolean, Nullable(Int32))

[image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern..::.Includes Method (DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>))
WeeklyRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

WeeklyRecurrencePattern Class
Includes Overload


WeeklyRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern Properties
WeeklyRecurrencePattern Class See Also Send Feedback

The WeeklyRecurrencePattern type exposes the following members.

Properties

Name | Description
DaysOfWeek | Gets the days of the week on which the item recurs.
WeeklyInterval | Gets the number of weeks between recurrences.

See Also

WeeklyRecurrencePattern Class


DaysOfWeek Property

[image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern..::.DaysOfWeek Property
WeeklyRecurrencePattern Class See Also Send Feedback
Gets the days of the week on which the item recurs.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ReadOnlyCollection<DayOfWeek> DaysOfWeek { get; }
Visual Basic (Declaration)
Public ReadOnly Property DaysOfWeek As ReadOnlyCollection(Of DayOfWeek)
Visual C++
public:
property ReadOnlyCollection<DayOfWeek>^ DaysOfWeek {
    ReadOnlyCollection<DayOfWeek>^ get ();
}

See Also

WeeklyRecurrencePattern Class


WeeklyInterval Property

[image]

Mindscape Silverlight Elements
WeeklyRecurrencePattern..::.WeeklyInterval Property
WeeklyRecurrencePattern Class See Also Send Feedback
Gets the number of weeks between recurrences.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int WeeklyInterval { get; }
Visual Basic (Declaration)
Public ReadOnly Property WeeklyInterval As Integer
Visual C++
public:
property int WeeklyInterval {
    int get ();
}

See Also

WeeklyRecurrencePattern Class


WeekToStringConverter Class

[image]

Mindscape Silverlight Elements
WeekToStringConverter Class
Members See Also Send Feedback
Formats a week as a date range string.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class WeekToStringConverter : IValueConverter
Visual Basic (Declaration)
Public Class WeekToStringConverter _
    Implements IValueConverter
Visual C++
public ref class WeekToStringConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.WeekToStringConverter

See Also

WeekToStringConverter Members


WeekToStringConverter Members

[image] [image]

Mindscape Silverlight Elements
WeekToStringConverter Members
WeekToStringConverter Class Constructors Methods See Also Send Feedback

The WeekToStringConverter type exposes the following members.

Constructors

Name | Description
WeekToStringConverter | Initializes a new instance of the WeekToStringConverter class

Methods

Name | Description
Convert | Formats a week as a date range string, e.g. "1 - 7 January 2010" or "31 December 2009 - 6 January 2010".
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeekToStringConverter Class


WeekToStringConverter Constructor

[image]

Mindscape Silverlight Elements
WeekToStringConverter Constructor
WeekToStringConverter Class See Also Send Feedback
Initializes a new instance of the WeekToStringConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WeekToStringConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WeekToStringConverter()

See Also

WeekToStringConverter Class


WeekToStringConverter Methods

[image] [image]

Mindscape Silverlight Elements
WeekToStringConverter Methods
WeekToStringConverter Class See Also Send Feedback

The WeekToStringConverter type exposes the following members.

Methods

Name | Description
Convert | Formats a week as a date range string, e.g. "1 - 7 January 2010" or "31 December 2009 - 6 January 2010".
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeekToStringConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
WeekToStringConverter..::.Convert Method
WeekToStringConverter Class See Also Send Feedback
Formats a week as a date range string, e.g. "1 - 7 January 2010" or "31 December 2009 - 6 January 2010".

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The WeekModel value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A string containing the date range represented by the input value.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

WeekToStringConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
WeekToStringConverter..::.ConvertBack Method
WeekToStringConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

WeekToStringConverter Class


WeekView Class

[image]

Mindscape Silverlight Elements
WeekView Class
Members See Also Send Feedback
Represents a week view in a Scheduler control.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class WeekView : ScheduleView
Visual Basic (Declaration)
Public Class WeekView _
    Inherits ScheduleView
Visual C++
public ref class WeekView : public ScheduleView

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.SilverlightElements..::.ScheduleView
Mindscape.SilverlightElements..::.WeekView

See Also

WeekView Members


WeekView Members

[image] [image]

Mindscape Silverlight Elements
WeekView Members
WeekView Class Constructors Methods Properties Events See Also Send Feedback

The WeekView type exposes the following members.

Constructors

Name | Description
WeekView | Overloaded.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | Cancels the addition of the specified item. (Overrides ScheduleView..::.CancelAdd(ScheduleItem).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | Adds a new schedule item at the current selection. (Overrides ScheduleView..::.CreateScheduleItemForAdd()()().)
DecrementView | Moves the view to the previous week. (Overrides ScheduleView..::.DecrementView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | Gets a suitable start date for the control to display the requested date. (Overrides ScheduleView..::.GetStartDateContaining(DateTime).)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view to the next week. (Overrides ScheduleView..::.IncrementView()()().)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range. (Inherited from ScheduleView.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ScheduleView.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection. (Inherited from ScheduleView.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ContainsToday | Gets whether the view contains the current day.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title. (Inherited from ScheduleView.)
DateRangeDisplayMode | Gets how to format dates in the view title. (Overrides ScheduleView..::.DateRangeDisplayMode.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view. (Overrides ScheduleView..::.EndDate.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled. (Inherited from ScheduleView.)
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled. (Inherited from ScheduleView.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week). (Inherited from ScheduleView.)
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view. (Inherited from ScheduleView.)
Now | Gets the current date and time. (Inherited from ScheduleView.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week). (Inherited from ScheduleView.)
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view. (Inherited from ScheduleView.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed. (Inherited from ScheduleView.)
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item). (Inherited from ScheduleView.)
StartDate | Gets or sets the start date of the view. (Overrides ScheduleView..::.StartDate.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day. (Inherited from ScheduleView.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Week | Gets the week being displayed.
WeekViewMode | Gets or sets whether to display the full week or the work week only.
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes. (Inherited from ScheduleView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

WeekView Class


WeekView Constructor

[image] [image]

Mindscape Silverlight Elements
WeekView Constructor
WeekView Class See Also Send Feedback

Overload List

Name | Description
WeekView()()() | Initializes a new instance of the WeekView class.
WeekView(Schedule, DateTime) | Initializes a new instance of the WeekView class.

See Also

WeekView Class
WeekView Members


WeekView Constructor

[image]

Mindscape Silverlight Elements
WeekView Constructor
WeekView Class See Also Send Feedback
Initializes a new instance of the WeekView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WeekView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WeekView()

See Also

WeekView Class
WeekView Overload


WeekView Constructor (Schedule, DateTime)

[image]

Mindscape Silverlight Elements
WeekView Constructor (Schedule, DateTime)
WeekView Class See Also Send Feedback
Initializes a new instance of the WeekView class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WeekView(
    Schedule schedule,
    DateTime startDate
)
Visual Basic (Declaration)
Public Sub New ( _
    schedule As Schedule, _
    startDate As DateTime _
)
Visual C++
public:
WeekView(
    Schedule^ schedule,
    DateTime startDate
)

Parameters

schedule
Type: Mindscape.SilverlightElements..::.Schedule
The Schedule to be displayed.
startDate
Type: System..::.DateTime
The start date for the display.

See Also

WeekView Class
WeekView Overload


WeekView Methods

[image] [image]

Mindscape Silverlight Elements
WeekView Methods
WeekView Class See Also Send Feedback

The WeekView type exposes the following members.

Methods

Name | Description
AddHandler | (Inherited from UIElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CancelAdd | Cancels the addition of the specified item. (Overrides ScheduleView..::.CancelAdd(ScheduleItem).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateScheduleItemForAdd | Adds a new schedule item at the current selection. (Overrides ScheduleView..::.CreateScheduleItemForAdd()()().)
DecrementView | Moves the view to the previous week. (Overrides ScheduleView..::.DecrementView()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBindingExpression | (Inherited from FrameworkElement.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetStartDateContaining | Gets a suitable start date for the control to display the requested date. (Overrides ScheduleView..::.GetStartDateContaining(DateTime).)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
IncrementView | Moves the view to the next week. (Overrides ScheduleView..::.IncrementView()()().)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NotifyDateRangeChanged | Raises change notification events required when the view changes to displaying a different date range. (Inherited from ScheduleView.)
OnApplyTemplate | Called by the framework when the control template is applied. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from Control.)
OnKeyDown | (Inherited from Control.)
OnKeyUp | (Inherited from Control.)
OnLostFocus | (Inherited from Control.)
OnLostMouseCapture | (Inherited from Control.)
OnMouseEnter | (Inherited from Control.)
OnMouseLeave | (Inherited from Control.)
OnMouseLeftButtonDown | (Inherited from Control.)
OnMouseLeftButtonUp | (Inherited from Control.)
OnMouseMove | (Inherited from Control.)
OnMouseWheel | (Inherited from Control.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ScheduleView.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveHandler | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

WeekView Class


CancelAdd Method

[image]

Mindscape Silverlight Elements
WeekView..::.CancelAdd Method
WeekView Class See Also Send Feedback
Cancels the addition of the specified item.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void CancelAdd(
    ScheduleItem item
)
Visual Basic (Declaration)
Protected Overrides Sub CancelAdd ( _
    item As ScheduleItem _
)
Visual C++
protected:
virtual void CancelAdd(
    ScheduleItem^ item
) override

Parameters

item
Type: Mindscape.SilverlightElements..::.ScheduleItem
The item to cancel.

See Also

WeekView Class


CreateScheduleItemForAdd Method

[image]

Mindscape Silverlight Elements
WeekView..::.CreateScheduleItemForAdd Method
WeekView Class See Also Send Feedback
Adds a new schedule item at the current selection.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override ScheduleItem CreateScheduleItemForAdd()
Visual Basic (Declaration)
Protected Overrides Function CreateScheduleItemForAdd As ScheduleItem
Visual C++
protected:
virtual ScheduleItem^ CreateScheduleItemForAdd() override

Return Value

The new item.

See Also

WeekView Class


DecrementView Method

[image]

Mindscape Silverlight Elements
WeekView..::.DecrementView Method
WeekView Class See Also Send Feedback
Moves the view to the previous week.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void DecrementView()
Visual Basic (Declaration)
Public Overrides Sub DecrementView
Visual C++
public:
virtual void DecrementView() override

See Also

WeekView Class


GetStartDateContaining Method

[image]

Mindscape Silverlight Elements
WeekView..::.GetStartDateContaining Method
WeekView Class See Also Send Feedback
Gets a suitable start date for the control to display the requested date.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime GetStartDateContaining(
    DateTime date
)
Visual Basic (Declaration)
Protected Overrides Function GetStartDateContaining ( _
    date As DateTime _
) As DateTime
Visual C++
protected:
virtual DateTime GetStartDateContaining(
    DateTime date
) override

Parameters

date
Type: System..::.DateTime
The date to be displayed.

Return Value

A start date for the view that will cause this date to be displayed.

See Also

WeekView Class


IncrementView Method

[image]

Mindscape Silverlight Elements
WeekView..::.IncrementView Method
WeekView Class See Also Send Feedback
Moves the view to the next week.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void IncrementView()
Visual Basic (Declaration)
Public Overrides Sub IncrementView
Visual C++
public:
virtual void IncrementView() override

See Also

WeekView Class


OnApplyTemplate Method

[image]

Mindscape Silverlight Elements
WeekView..::.OnApplyTemplate Method
WeekView Class See Also Send Feedback
Called by the framework when the control template is applied.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate
Visual C++
public:
virtual void OnApplyTemplate() override

See Also

WeekView Class


WeekView Properties

[image] [image]

Mindscape Silverlight Elements
WeekView Properties
WeekView Class See Also Send Feedback

The WeekView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AddScheduleItemCommand | Gets a command for adding an item to the Schedule at the current selection. (Inherited from ScheduleView.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CacheMode | (Inherited from UIElement.)
Clip | (Inherited from UIElement.)
ContainsToday | Gets whether the view contains the current day.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DateRangeDisplayInfo | Gets display information for the view title. (Inherited from ScheduleView.)
DateRangeDisplayMode | Gets how to format dates in the view title. (Overrides ScheduleView..::.DateRangeDisplayMode.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Effect | (Inherited from UIElement.)
EndDate | Gets the end date of the view. (Overrides ScheduleView..::.EndDate.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsNextWingEnabled | Gets whether the "next item" wing button is enabled. (Inherited from ScheduleView.)
IsPreviousWingEnabled | Gets whether the "previous item" wing button is enabled. (Inherited from ScheduleView.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextCommand | Gets a command for moving to the next block (e.g. next week). (Inherited from ScheduleView.)
NextItemCommand | Gets a command for moving to the next ScheduleItem after the end of this view. (Inherited from ScheduleView.)
Now | Gets the current date and time. (Inherited from ScheduleView.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreviousCommand | Gets a command for moving to the previous block (e.g. previous week). (Inherited from ScheduleView.)
PreviousItemCommand | Gets a command for moving to the first ScheduleItem prior to the start of this view. (Inherited from ScheduleView.)
Projection | (Inherited from UIElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Schedule | Gets or sets the Schedule being displayed. (Inherited from ScheduleView.)
ShowWings | Gets whether the view needs to display the "wing" buttons (previous and next schedule item). (Inherited from ScheduleView.)
StartDate | Gets or sets the start date of the view. (Overrides ScheduleView..::.StartDate.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Times | Gets the hours of the day. (Inherited from ScheduleView.)
Triggers | (Inherited from FrameworkElement.)
UseLayoutRounding | (Inherited from UIElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Week | Gets the week being displayed.
WeekViewMode | Gets or sets whether to display the full week or the work week only.
Width | (Inherited from FrameworkElement.)

See Also

WeekView Class


ContainsToday Property

[image]

Mindscape Silverlight Elements
WeekView..::.ContainsToday Property
WeekView Class See Also Send Feedback
Gets whether the view contains the current day.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ContainsToday { get; private set; }
Visual Basic (Declaration)
Public Property ContainsToday As Boolean
Visual C++
public:
property bool ContainsToday {
    bool get ();
    void set (bool value);
}

See Also

WeekView Class


DateRangeDisplayMode Property

[image]

Mindscape Silverlight Elements
WeekView..::.DateRangeDisplayMode Property
WeekView Class See Also Send Feedback
Gets how to format dates in the view title.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateDisplayMode DateRangeDisplayMode { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DateRangeDisplayMode As DateDisplayMode
Visual C++
protected:
virtual property DateDisplayMode DateRangeDisplayMode {
    DateDisplayMode get () override;
}

See Also

WeekView Class


EndDate Property

[image]

Mindscape Silverlight Elements
WeekView..::.EndDate Property
WeekView Class See Also Send Feedback
Gets the end date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override DateTime EndDate { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property EndDate As DateTime
Visual C++
protected:
virtual property DateTime EndDate {
    DateTime get () override;
}

See Also

WeekView Class


StartDate Property

[image]

Mindscape Silverlight Elements
WeekView..::.StartDate Property
WeekView Class See Also Send Feedback
Gets or sets the start date of the view.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Overrides Property StartDate As DateTime
Visual C++
public:
virtual property DateTime StartDate {
    DateTime get () override;
    void set (DateTime value) override;
}

See Also

WeekView Class


Week Property

[image]

Mindscape Silverlight Elements
WeekView..::.Week Property
WeekView Class See Also Send Feedback
Gets the week being displayed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WeekModel Week { get; private set; }
Visual Basic (Declaration)
Public Property Week As WeekModel
Visual C++
public:
property WeekModel^ Week {
    WeekModel^ get ();
    void set (WeekModel^ value);
}

See Also

WeekView Class


WeekViewMode Property

[image]

Mindscape Silverlight Elements
WeekView..::.WeekViewMode Property
WeekView Class See Also Send Feedback
Gets or sets whether to display the full week or the work week only.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WeekViewMode WeekViewMode { get; set; }
Visual Basic (Declaration)
Public Property WeekViewMode As WeekViewMode
Visual C++
public:
property WeekViewMode WeekViewMode {
    WeekViewMode get ();
    void set (WeekViewMode value);
}

See Also

WeekView Class


WeekView Events

[image] [image]

Mindscape Silverlight Elements
WeekView Events
WeekView Class See Also Send Feedback

The WeekView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsEnabledChanged | (Inherited from Control.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LostMouseCapture | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
MouseWheel | (Inherited from UIElement.)
PropertyChanged | Occurs when a property value changes. (Inherited from ScheduleView.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

WeekView Class


WeekViewMode Enumeration

[image]

Mindscape Silverlight Elements
WeekViewMode Enumeration
See Also Send Feedback
Specifies whether to show a full week in Week view, or only the work week (Monday to Friday).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum WeekViewMode
Visual Basic (Declaration)
Public Enumeration WeekViewMode
Visual C++
public enum class WeekViewMode

Members

Member name | Description
WorkWeek | Show only the work week (Monday to Friday).
FullWeek | Show the full week.

See Also

Mindscape.SilverlightElements Namespace

Send comments on this topic to contact@mindscape.co.nz

(c) 2010 Mindscape Limited


YearlyPatternRecurrencePattern Class

[image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on a yearly basis according to a pattern (e.g. the first Tuesday of November every four years).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class YearlyPatternRecurrencePattern : YearlyRecurrencePattern
Visual Basic (Declaration)
Public Class YearlyPatternRecurrencePattern _
    Inherits YearlyRecurrencePattern
Visual C++
public ref class YearlyPatternRecurrencePattern : public YearlyRecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.YearlyRecurrencePattern
Mindscape.SilverlightElements..::.YearlyPatternRecurrencePattern

See Also

YearlyPatternRecurrencePattern Members


YearlyPatternRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern Members
YearlyPatternRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The YearlyPatternRecurrencePattern type exposes the following members.

Constructors

Name | Description
YearlyPatternRecurrencePattern | Initializes a new instance of the YearlyPatternRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DayOfRecurrence | Gets the days counted by Occurrence (e.g. weekdays, Fridays).
Month | Gets the month in which the item recurs. (Inherited from YearlyRecurrencePattern.)
Occurrence | Gets which occurrence of the DayOfRecurrence the item recurs on (e.g. first, last).
YearlyInterval | Gets the number of years between recurrences. (Inherited from YearlyRecurrencePattern.)

See Also

YearlyPatternRecurrencePattern Class


YearlyPatternRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern Constructor
YearlyPatternRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the YearlyPatternRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public YearlyPatternRecurrencePattern(
    int yearlyInterval,
    int month,
    Occurrence occurrence,
    DayOfRecurrence dayOfRecurrence
)
Visual Basic (Declaration)
Public Sub New ( _
    yearlyInterval As Integer, _
    month As Integer, _
    occurrence As Occurrence, _
    dayOfRecurrence As DayOfRecurrence _
)
Visual C++
public:
YearlyPatternRecurrencePattern(
    int yearlyInterval,
    int month,
    Occurrence occurrence,
    DayOfRecurrence dayOfRecurrence
)

Parameters

yearlyInterval
Type: System..::.Int32
The number of years between recurrences.
month
Type: System..::.Int32
The month in which the item recurs. (1 through 12)
occurrence
Type: Mindscape.SilverlightElements..::.Occurrence
Which occurrence of the dayOfRecurrence the item recurs on (e.g. first, last).
dayOfRecurrence
Type: Mindscape.SilverlightElements..::.DayOfRecurrence
The days counted by occurrence (e.g. weekdays, Fridays).

See Also

YearlyPatternRecurrencePattern Class


YearlyPatternRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern Methods
YearlyPatternRecurrencePattern Class See Also Send Feedback

The YearlyPatternRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

YearlyPatternRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern..::.Includes Method
YearlyPatternRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Overrides RecurrencePattern..::.Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)).)

See Also

YearlyPatternRecurrencePattern Class
YearlyPatternRecurrencePattern Members


Includes Method (DateTime, DateTime, Boolean, Nullable(Int32))

[image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern..::.Includes Method (DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>))
YearlyPatternRecurrencePattern Class See Also Send Feedback
Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
)
Visual Basic (Declaration)
Protected Overrides Function Includes ( _
    startDate As DateTime, _
    day As DateTime, _
    limitOccurrences As Boolean, _
    occurrenceCount As Nullable(Of Integer) _
) As Boolean
Visual C++
protected:
virtual bool Includes(
    DateTime startDate,
    DateTime day,
    bool limitOccurrences,
    Nullable<int> occurrenceCount
) override

Parameters

startDate
Type: System..::.DateTime
The start date of recurrence.
day
Type: System..::.DateTime
The day for which to check whether the recurrence occurs.
limitOccurrences
Type: System..::.Boolean
Whether to limit the number of occurrences considered.
occurrenceCount
Type: System..::.Nullable <(Of <( Int32 >)>)
The maximum number of occurrences to consider, if limitOccurrences is true.

Return Value

true if the pattern occurs on day; otherwise false.

See Also

YearlyPatternRecurrencePattern Class
Includes Overload


YearlyPatternRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern Properties
YearlyPatternRecurrencePattern Class See Also Send Feedback

The YearlyPatternRecurrencePattern type exposes the following members.

Properties

Name | Description
DayOfRecurrence | Gets the days counted by Occurrence (e.g. weekdays, Fridays).
Month | Gets the month in which the item recurs. (Inherited from YearlyRecurrencePattern.)
Occurrence | Gets which occurrence of the DayOfRecurrence the item recurs on (e.g. first, last).
YearlyInterval | Gets the number of years between recurrences. (Inherited from YearlyRecurrencePattern.)

See Also

YearlyPatternRecurrencePattern Class


DayOfRecurrence Property

[image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern..::.DayOfRecurrence Property
YearlyPatternRecurrencePattern Class See Also Send Feedback
Gets the days counted by Occurrence (e.g. weekdays, Fridays).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DayOfRecurrence DayOfRecurrence { get; }
Visual Basic (Declaration)
Public ReadOnly Property DayOfRecurrence As DayOfRecurrence
Visual C++
public:
property DayOfRecurrence DayOfRecurrence {
    DayOfRecurrence get ();
}

See Also

YearlyPatternRecurrencePattern Class


Occurrence Property

[image]

Mindscape Silverlight Elements
YearlyPatternRecurrencePattern..::.Occurrence Property
YearlyPatternRecurrencePattern Class See Also Send Feedback
Gets which occurrence of the DayOfRecurrence the item recurs on (e.g. first, last).

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Occurrence Occurrence { get; }
Visual Basic (Declaration)
Public ReadOnly Property Occurrence As Occurrence
Visual C++
public:
property Occurrence Occurrence {
    Occurrence get ();
}

See Also

YearlyPatternRecurrencePattern Class


YearlyRecurrencePattern Class

[image]

Mindscape Silverlight Elements
YearlyRecurrencePattern Class
Members See Also Send Feedback
Represents the recurrence of a ScheduleItem on a yearly basis.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class YearlyRecurrencePattern : RecurrencePattern
Visual Basic (Declaration)
Public MustInherit Class YearlyRecurrencePattern _
    Inherits RecurrencePattern
Visual C++
public ref class YearlyRecurrencePattern abstract : public RecurrencePattern

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.RecurrencePattern
Mindscape.SilverlightElements..::.YearlyRecurrencePattern
Mindscape.SilverlightElements..::.SpecificDateYearlyRecurrencePattern
Mindscape.SilverlightElements..::.YearlyPatternRecurrencePattern

See Also

YearlyRecurrencePattern Members


YearlyRecurrencePattern Members

[image] [image]

Mindscape Silverlight Elements
YearlyRecurrencePattern Members
YearlyRecurrencePattern Class Constructors Methods Properties See Also Send Feedback

The YearlyRecurrencePattern type exposes the following members.

Constructors

Name | Description
YearlyRecurrencePattern | Initializes a new instance of the YearlyRecurrencePattern class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Month | Gets the month in which the item recurs.
YearlyInterval | Gets the number of years between recurrences.

See Also

YearlyRecurrencePattern Class


YearlyRecurrencePattern Constructor

[image]

Mindscape Silverlight Elements
YearlyRecurrencePattern Constructor
YearlyRecurrencePattern Class See Also Send Feedback
Initializes a new instance of the YearlyRecurrencePattern class.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected YearlyRecurrencePattern(
    int yearlyInterval,
    int month
)
Visual Basic (Declaration)
Protected Sub New ( _
    yearlyInterval As Integer, _
    month As Integer _
)
Visual C++
protected:
YearlyRecurrencePattern(
    int yearlyInterval,
    int month
)

Parameters

yearlyInterval
Type: System..::.Int32
The number of years between recurrences.
month
Type: System..::.Int32
The month in which the item recurs. (1 through 12)

See Also

YearlyRecurrencePattern Class


YearlyRecurrencePattern Methods

[image] [image]

Mindscape Silverlight Elements
YearlyRecurrencePattern Methods
YearlyRecurrencePattern Class See Also Send Feedback

The YearlyRecurrencePattern type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Includes | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

YearlyRecurrencePattern Class


Includes Method

[image] [image]

Mindscape Silverlight Elements
YearlyRecurrencePattern..::.Includes Method
YearlyRecurrencePattern Class See Also Send Feedback

Overload List

Name | Description
Includes(DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, DateTime) | Gets whether the pattern occurs on the specified day, assuming a given start and end date. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Int32) | Gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)
Includes(DateTime, DateTime, Boolean, Nullable<(Of <(Int32>)>)) | When overridden in a derived class, gets whether the pattern occurs on the specified day, assuming a given start date and maximum occurrence count. (Inherited from RecurrencePattern.)

See Also

YearlyRecurrencePattern Class
YearlyRecurrencePattern Members


YearlyRecurrencePattern Properties

[image] [image]

Mindscape Silverlight Elements
YearlyRecurrencePattern Properties
YearlyRecurrencePattern Class See Also Send Feedback

The YearlyRecurrencePattern type exposes the following members.

Properties

Name | Description
Month | Gets the month in which the item recurs.
YearlyInterval | Gets the number of years between recurrences.

See Also

YearlyRecurrencePattern Class


Month Property

[image]

Mindscape Silverlight Elements
YearlyRecurrencePattern..::.Month Property
YearlyRecurrencePattern Class See Also Send Feedback
Gets the month in which the item recurs.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Month { get; }
Visual Basic (Declaration)
Public ReadOnly Property Month As Integer
Visual C++
public:
property int Month {
    int get ();
}

See Also

YearlyRecurrencePattern Class


YearlyInterval Property

[image]

Mindscape Silverlight Elements
YearlyRecurrencePattern..::.YearlyInterval Property
YearlyRecurrencePattern Class See Also Send Feedback
Gets the number of years between recurrences.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int YearlyInterval { get; }
Visual Basic (Declaration)
Public ReadOnly Property YearlyInterval As Integer
Visual C++
public:
property int YearlyInterval {
    int get ();
}

See Also

YearlyRecurrencePattern Class


ZeroPaddingConverter Class

[image]

Mindscape Silverlight Elements
ZeroPaddingConverter Class
Members See Also Send Feedback
Converts a doube value to a zero-padded string.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ZeroPaddingConverter : IValueConverter
Visual Basic (Declaration)
Public Class ZeroPaddingConverter _
    Implements IValueConverter
Visual C++
public ref class ZeroPaddingConverter : IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.SilverlightElements..::.ZeroPaddingConverter

See Also

ZeroPaddingConverter Members


ZeroPaddingConverter Members

[image] [image]

Mindscape Silverlight Elements
ZeroPaddingConverter Members
ZeroPaddingConverter Class Constructors Methods Properties See Also Send Feedback

The ZeroPaddingConverter type exposes the following members.

Constructors

Name | Description
ZeroPaddingConverter | Initializes a new instance of the ZeroPaddingConverter class

Methods

Name | Description
Convert | Converts a double value from a binding source to a string for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DecimalDigits | Gets or sets the number of digits to display the fractional part of the number. The default is 0, meaning no fractional part is displayed.
IntegerDigits | Gets or sets the number of digits to display the integral part of the number.

See Also

ZeroPaddingConverter Class


ZeroPaddingConverter Constructor

[image]

Mindscape Silverlight Elements
ZeroPaddingConverter Constructor
ZeroPaddingConverter Class See Also Send Feedback
Initializes a new instance of the ZeroPaddingConverter class

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ZeroPaddingConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ZeroPaddingConverter()

See Also

ZeroPaddingConverter Class


ZeroPaddingConverter Methods

[image] [image]

Mindscape Silverlight Elements
ZeroPaddingConverter Methods
ZeroPaddingConverter Class See Also Send Feedback

The ZeroPaddingConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a double value from a binding source to a string for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZeroPaddingConverter Class


Convert Method

[image]

Mindscape Silverlight Elements
ZeroPaddingConverter..::.Convert Method
ZeroPaddingConverter Class See Also Send Feedback
Converts a double value from a binding source to a string for use by a binding target.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ Convert(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ZeroPaddingConverter Class


ConvertBack Method

[image]

Mindscape Silverlight Elements
ZeroPaddingConverter..::.ConvertBack Method
ZeroPaddingConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object
Visual C++
public:
virtual Object^ ConvertBack(
    Object^ value,
    Type^ targetType,
    Object^ parameter,
    CultureInfo^ culture
) sealed

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ZeroPaddingConverter Class


ZeroPaddingConverter Properties

[image] [image]

Mindscape Silverlight Elements
ZeroPaddingConverter Properties
ZeroPaddingConverter Class See Also Send Feedback

The ZeroPaddingConverter type exposes the following members.

Properties

Name | Description
DecimalDigits | Gets or sets the number of digits to display the fractional part of the number. The default is 0, meaning no fractional part is displayed.
IntegerDigits | Gets or sets the number of digits to display the integral part of the number.

See Also

ZeroPaddingConverter Class


DecimalDigits Property

[image]

Mindscape Silverlight Elements
ZeroPaddingConverter..::.DecimalDigits Property
ZeroPaddingConverter Class See Also Send Feedback
Gets or sets the number of digits to display the fractional part of the number. The default is 0, meaning no fractional part is displayed.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int DecimalDigits { get; set; }
Visual Basic (Declaration)
Public Property DecimalDigits As Integer
Visual C++
public:
property int DecimalDigits {
    int get ();
    void set (int value);
}

See Also

ZeroPaddingConverter Class


IntegerDigits Property

[image]

Mindscape Silverlight Elements
ZeroPaddingConverter..::.IntegerDigits Property
ZeroPaddingConverter Class See Also Send Feedback
Gets or sets the number of digits to display the integral part of the number.

Namespace: Mindscape.SilverlightElements
Assembly: Mindscape.SilverlightElements (in Mindscape.SilverlightElements.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int IntegerDigits { get; set; }
Visual Basic (Declaration)
Public Property IntegerDigits As Integer
Visual C++
public:
property int IntegerDigits {
    int get ();
    void set (int value);
}

See Also

ZeroPaddingConverter Class