Introduction, Features & Installation

Mindscape WPF Diagramming
Introduction, Features & Installation

Mindscape Diagramming for Windows Presentation Foundation

Mindscape WPF Diagrams is a Windows Presentation Foundation library for displaying and editing diagrams of all kinds. The library supports common diagram elements, including shape, flow and star diagrams, out of the box and provides built-in display styles, and can be customised with additional node types and your own visual styles.

See QuickStart to see how to get started with the product.

Installation

Mindscape WPF Diagrams is provided as a Windows Installer (MSI) file. Run this file to install the product. The installer creates Start menu entries under Mindscape > WPF Diagrams. If Visual Studio is present on the machine, the installer also creates a Mindscape tab in the Visual Studio toolbox and adds the DiagramSurface control to this tab (see Troubleshooting if the tab does not appear).

Getting Support

If you have questions or need assistance, please visit the support forum. This is also linked off the WPF Diagrams menu in the Start menu.

Send comments on this topic to contact@mindscapehq.com

Copyright © 2009-2011, Mindscape Ltd, All rights reserved


QuickStart

Mindscape WPF Diagramming
QuickStart

Getting Started

To use WPF Diagrams, add a reference to the Mindscape.WpfDiagramming.Foundation assembly. The diagramming controls are in the http://namespaces.mindscape.co.nz/wpf namespace which is usually aliased to the ms: prefix.

The main class for working with diagrams is the DiagramSurface class. DiagramSurface is a WPF control for presenting diagrams. You can create a DiagramSurface in XAML in the usual way, but you’ll usually also want to take advantage of the built-in styles and templates, so you should also merge in the DiagramShapes resource dictionary.

CopyCreating a DiagramSurface
<Window.Resources>
  <ResourceDictionary>
    <ResourceDictionary.MergedDictionaries>
      <ms:DiagramShapes />
    </ResourceDictionary.MergedDictionaries>
  </ResourceDictionary>
</Window.Resources>

<ms:DiagramSurface Name="ds" />

By default the DiagramSurface displays an empty diagram, so the first thing to do is to add some shapes to it. You can do this in code using the ShapeNode class:

CopyCreating a diagram in code
ds.Diagram.Nodes.Add(new ShapeNode { Shape = DiagramShapes.Rectangle, Bounds = new Rect(20, 20, 150, 80) });

Or you can add a DiagramToolBox to your window so that users can create shapes of their own:

CopyProviding a shape toolbox
<ms:DiagramToolBox>
  <ms:DiagramToolBoxGroup Header="Basic Shapes">
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Rectangle" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Ellipse" />
  </ms:DiagramToolBoxGroup>
</ms:DiagramToolBox>

When you select a shape, you will see that it has a number of connection points. You can drag the mouse between connection points to create a connection.

Finally, you can save and reload the diagrams you create using the DiagramXmlSerializer, and print them using the DiagramPrinter class.

In this quick introduction, we’ve seen the basics of creating a diagramming control and building simple diagrams on it. For more detail and to understand how to customise the appearance and layout of shapes and connections, see the QuickStart walkthrough.


Samples

Mindscape WPF Diagramming
Samples

WPF Diagrams includes a number of samples to help you understand how to use or customise specific parts of the product. You can find all of the samples in the Samples directory under the installation folder.

Use the Sample Explorer to preview and launch individual samples.

Get Started

  • QuickStart provides a simple example of displaying and editing a shape diagram.
  • QuickStart.FlowDiagrams provides a simple example of displaying and editing a flow diagram.
  • QuickStart.StarDiagrans provides a simple example of displaying and editing a star diagram.

Explore the Options

  • FeatureExplorer allows you to try out many of the options for displaying and interacting with diagrams.
  • LayoutAlgorithmExplorer allows you to try out and compare different automatic diagram layouts.

Extend and Enhance

  • CustomNodeType.FlowDiagrams demonstrates how to define, display and serialize node types that represent your own application-specific concepts.
  • CustomStyle.FlowDiagrams provides an example of restyling standard elements to fit your own visual theme.
  • CustomDataSerialization gives examples of working with non-text node data.
  • Cosmic.StarDiagrams shows how to create your own node types and visual styles for star diagrams.
  • ActivityDiagrams shows how to implement your own diagram type with its own node types, constraints and validation logic.

Go Deep

  • CustomDiagramType shows how to implement your own diagram type using the low-level Foundation classes and interfaces for maximum control and flexibility.
  • ConnectionValidation.FlowDiagrams shows how to constrain how the user is allowed to connect nodes.
  • ConnectionPointValidation.FlowDiagrams shows how to constrain how the user is allowed to use individual connection points on a node.
  • ConnectionPointRelocation.FlowDiagrams demonstrates how to change the positions of connection points on a node.

For a walkthrough of building a diagramming application, please see the QuickStart walkthrough.


DiagramSurface

Mindscape WPF Diagramming
DiagramSurface

The DiagramSurface Control

The DiagramSurface control is the core control for WPF Diagrams. To display a diagram in your application, create a DiagramSurface control and set its DiagramSurface.Diagram property.

DiagramSurface has a number of properties which you can use to configure the behaviour and appearance of the diagram. The following list summarises key properties:

Visual style properties
MarqueeStyle | The style for selection rectangles (when the user drags over an area to select).
SnapLineDrawing | Controls the drawing of snap lines on the background. See Background.
DefaultCreateConnectionLineStyle | Used when the user is creating a connection, and no specific style is provided for the tool being used
Formatter | Controls diagram visual style in the low-level API. See Formatting.
Scrolling properties
IsSmartScrollingEnabled | Scrolls the viewport as the user moves items.
OverflowBehavior | Controls whether the user is allowed to scroll when the diagram already fits within the control.
Editing properties
IsReadOnly | Prevents the user making changes to the diagram.
ShowConnectionPoints | Controls whether connection points are displayed.
SelectionMode | Controls whether the surface allows single or multiple selection.
Zoom properties
Zoom | The current zoom level.
ZoomMode | Controls how the user can change the zoom level.
Snapping properties
HorizontalSnapSpecifier | Controls horizontal snapping behaviour. See Snapping.
VerticalSnapSpecifier | Controls vertical snapping behaviour. See Snapping.
Collision control properties
AllowNodeCollisions | Controls whether nodes can overlap.
AllowSegmentToNodeCollisions | Controls whether nodes and connections can overlap.
CollisionBuffer | Controls the minimum distance between nodes and connections.

DiagramSurface also exposes several properties and methods which are not related to appearance or behaviour but may be important when using the control in a broader application context:

Contained UI elements
DiagramElements | The UI elements representing the contents of the diagram.
NodeElements | The UI elements for the diagram nodes.
ConnectionElements | The UI elements for the diagram connections.
ScrollViewer | The scroll viewer used for scrolling the diagram viewport.
Selection properties
SelectedItem | The currently selected diagram model item.
SelectedItems | The collection of currently selected diagram model items.
SelectedElement | The currently selected diagram element (UI element).
SelectedElements | The collection of currently selected diagram elements (UI elements).
Diagram status
IsDirty | Whether the diagram displayed on the surface has been changed.


Creating Diagrams

Mindscape WPF Diagramming
Creating Diagrams

You can use WPF Diagrams in three ways:

  • For many diagramming projects, you will simply use the standard diagram model and its classes. This supports arbitrary diagrams, in which users can place shapes as required, and there are no particular semantics or rules associated with the different shapes.
  • If a project requires a specific kind of diagram which is included in WPF Diagrams, such as flow diagrams, then you can use the diagram model and classes for that kind of diagram.
  • If a project requires a specific kind of diagram which is not included in WPF Diagrams, such as BPMN process diagrams, then you can use the Foundation classes and interfaces to define a semantic model and rules, and visual styles, for this kind of diagram. The Foundation classes are also used for advanced customisation of the built-in diagram types.

This section describes how to work with the standard diagram model.

  • For specific types of diagram included in WPF Diagrams, see Flow Diagrams and Star Diagrams.
  • For creating your own kinds of diagram and advanced customisation using the Foundation classes, see Diagram Foundation.

The Diagram Class

A standard diagram is represented by the Diagram class. A diagram consists of a number of nodes and connections, represented by the DiagramNode (frequently ShapeNode) and DiagramConnection classes.

A Diagram is purely a data (model) object. It does not contain any WPF UI elements, and contains only minimal presentation information such as node positions and sizes. You can build up a diagram programmatically by adding items to its Nodes and Connections collections, or just create an empty (blank) diagram for your users to place items onto.

To display a diagram, use the DiagramSurface control. The DiagramSurface takes care of all presentation elements, optionally using a DiagramFormatter to control appearance and styling.

CopyCreating a blank diagram
this.DataContext = new Diagram();
CopyDisplaying a diagram
<ms:DiagramSurface Diagram="{Binding}" />

Nodes and Connections

The base Node type does not contain any information about layout or connectivity. This is provided through derived classes such as TitleNode or ShapeNode, and through templates referenced through the diagram formatter.

The base Connection type uses a default layout which the user can modify. Typically you will use derived types of Connection to specify features such as routing, styling, arrows, etc. through templates referenced through the diagram formatter.

For a step by step example of setting up and displaying a standard diagram, see the QuickStart.

Representing Your Business Objects as a Diagram

You can use Diagram as a model in itself, or you can use it as a view model over a business class. In the latter case, you will need to create adapter code to synchronise the model (business object) and view model (diagram model). The best approach in this case is to have the diagram observe the business object and update itself as the business object changes, but not vice versa. WPF Diagramming supports this by allowing you to map user actions (such as creating nodes and connections) to business object actions, thereby avoiding the need for two-way synchronisation.


Simple Diagrams

Mindscape WPF Diagramming
Simple Diagrams

For a more detailed walkthrough of creating a simple diagramming application, see the QuickStart walkthrough.

The Mindscape.WpfDiagramming namespace contains all the classes you need to create diagrams using absolute-positioned shapes. In this section we will build a simple shape diagramming application using the built-in shapes.

Step 1. Decide how you want shapes to look.

WPF Diagrams defines a default style for shapes, but you can override this to suit your application theme. The target type for the style must be Path.

CopyExample shape style
<Style x:Key="ShapeNodePathStyle" TargetType="Path">
  <Setter Property="Stroke" Value="Navy" />
  <Setter Property="StrokeThickness" Value="1" />
  <Setter Property="Fill" Value="LightSteelBlue" />
  <Setter Property="Stretch" Value="Fill" />
</Style>

Step 2. Decide how you want connections to look.

WPF Diagrams defines a default style for shapes, but you can override this to suit your application theme. The target type for the style must be Path, and the key must be DiagramShapes.DefaultDiagramConnectionStyleKey.

CopySetting a path style for all connections
<Style x:Key="{x:Static ms:DiagramLineTypes.DefaultDiagramConnectionStyleKey}" TargetType="Path">
  <Setter Property="Stroke" Value="Goldenrod" />
  <Setter Property="StrokeThickness" Value="2" />
</Style>

Step 3. Create a DiagramSurface and hook it up to your styles.

The DiagramSurface control is where the diagram will be displayed. The connection style is hooked up automatically but you need to tell the DiagramSurface about the shape style. The easiest way to do this is via the ShapeTool.ShapePathStyle attached property.

CopyInstantiating a DiagramSurface
<ms:DiagramSurface ms:ShapeTool.ShapePathStyle="{StaticResource ShapeNodePathStyle}" />

The ShapeTool.ShapePathStyle attached property is used only when using the ‘shorthand’ shape toolbox syntax below. For other kinds of node, or when you need finer control of the nodes or the toolbox, you’ll use a DiagramFormatter.

Step 4. Create a DiagramToolBox.

Now you have a blank DiagramSurface, you need a way for users to add elements to the diagram. You can do this using the DiagramToolBox control. You must specify a style for drawing the shapes in the toolbox: typically this is the same as the node style but you can make it different if you are using a different color scheme in the toolbox.

The toolbox is divided into groups. Each group has a string header, and contains DiagramNodeTool and/or DiagramConnectionTool objects. To lay out the DiagramNodeTool and DiagramConnectionTool objects, provide styles which specify the Margin, Width and Height of each tool.

You need to create a DiagramNodeTool for each shape you want users to be able to drag from the toolbox. Use the ShapeTool.Shape attached property to specify which shape the tool represents.

Similarly, you need to create a DiagramConnectionTool for each type of line you want users to be able to draw. Use the ConnectionTool.LineType attached property to specify which line type the tool represents.

CopyInstantiating a DiagramToolBox
<ms:DiagramToolBox ms:ShapeTool.ShapePathStyle="{StaticResource ShapeNodePathStyle}">
  <ms:DiagramToolBox.Resources>
    <Style TargetType="ms:DiagramNodeTool">
      <Setter Property="Margin" Value="10" />
      <Setter Property="Width" Value="40" />
      <Setter Property="Height" Value="30" />
    </Style>
    <Style TargetType="ms:DiagramConnectionTool">
      <Setter Property="Margin" Value="10" />
      <Setter Property="Width" Value="40" />
      <Setter Property="Height" Value="30" />
    </Style>
  </ms:DiagramToolBox.Resources>
  <ms:DiagramToolBoxGroup Header="Lines">
    <ms:DiagramConnectionTool ms:ConnectionTool.LineType="Straight" />
    <ms:DiagramConnectionTool ms:ConnectionTool.LineType="Elbow" />
  </ms:DiagramToolBoxGroup>
  <ms:DiagramToolBoxGroup Header="Rectangles">
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Rectangle" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="RoundedRectangle" />
  </ms:DiagramToolBoxGroup>
  <ms:DiagramToolBoxGroup Header="Basic Shapes">
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Ellipse" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Parallelogram" />
  </ms:DiagramToolBoxGroup>
</ms:DiagramToolBox>

For shapes defined in the DiagramShapes class, and line types defined in the DiagramLineTypes class, you can just type the name of the shape or line type. For user-defined shapes or line types, you will need to use the Static markup extension to refer to the shape object itself.


Creating Your Own Shapes

Mindscape WPF Diagramming
Creating Your Own Shapes

WPF Diagrams defines a number of standard shapes that cover many common diagramming needs. You can also create your own shapes which users can manipulate in the same way as the standard shapes.

Declaring a Custom Shape

The first step is to create an identifier for the custom shape. This is an object of type DiagramShape. The identifier just specifies some basic information about the shape, such as its name.
CopyCreating a shape identifier
public static class MyShapes
{
  public static readonly DiagramShape WShape = new DiagramShape("WShape").Freeze();
}

By default, the shape’s display name is the same as its name, and it has one connection point on each side. You can override these defaults using properties of DiagramShape:

CopyCreating a shape identifier with custom settings
public static readonly DiagramShape WShape = new DiagramShape("WShape")
{
  DisplayName = "W Shape",
  TopConnectionPointCount = 0,
  BottomConnectionPointCount = 3
}.Freeze();

The Freeze method prevents users of the shape from accidentally modifying these settings after you have specified them, so it’s a good idea to call Freeze on any shapes you declare.

Laying Out the Custom Shape

The identifier doesn’t specify the geometry of the custom shape, because it’s usually more convenient to describe geometry and layout in XAML rather than in code. To specify the layout of the shape, create a ShapeLayout resource in XAML, whose key is the shape identifier:

CopySpecifying the shape geometry
<ms:ShapeLayout x:Key="{x:Static local:MyShapes.WShape}"
                Geometry="M 0 0 L 0 1 L 0.5 0.5 L 1 1 L 1 0 Z"
                />

The geometry is relative to the bounding box, so the top left is 0 0 and the bottom right is 1 1. WPF Diagrams will scale the geometry to the actual size of the node as required.

By default, the connection point positions are halfway along each side of the shape’s bounding box. You can override this using ShapeLayout.ConnectionPointPositions. You can populate this with ShapeConnectionPointPosition objects using XAML collection syntax, or use a shorthand notation similar to the geometry notation:

CopySpecifying connection point positions using shorthand
<!-- Use L, T, R, B to indicate which side the positions are for
     Use semicolons to separate positions
     Specify each position as x,y where 0 is top/left and 1 is bottom/right of the bounding box
     Optionally apply absolute position modifiers using + and - e.g. 0 + 20 is 20px from top/left, 1 - 30 is 30px from bottom/right
     NOTE: Unlike geometry notation, commas in positions are NOT optional
-->
<ms:ShapeLayout ConnectionPointPositions="L 0,0.25 R 1,0.25 B 0,1; 0.5,0.5; 1,1" />

By default, the content of the node is displayed at the centre of the bounding box. If the shape layout is imbalanced, this may not be central within the shape. To control the position of the content, set the ShapeLayout.ContentMargins property. You can use star sizing to specify that the margin should be a proportion of the shape size. For example, in the W shape the content might be placed towards the top of the shape, so you would specify a large bottom margin compared to the top.

CopyOverriding the content margin
<ms:ShapeLayout ContentMargin="*,*,*,4*" />  <!-- LTRB order -->

Laying Out Compound Shapes

Some shapes cannot be described as a single geometry because they consist of multiple sections which may need different shading or styling. An example of this in the built-in shapes is the curved arrow, where the ‘back’ of the arrow appears shaded. To do this in your own shapes, specify the ShapeLayout.Paths collection instead of ShapeLayout.Geometry. You can then apply styles directly to the individual paths.

Adding the Custom Shape to the Toolbox

You can add the custom shape to the toolbox in the same way as built-in shapes, using the DiagramNodeTool control and the ShapeTool.Shape attached property. To identify the shape in ShapeTool.Shape, specify the shape identifier object:

CopyAdding a custom shape to the toolbox
<ms:DiagramNodeTool ms:ShapeTool.Shape="{x:Static local:MyShapes.WShape}" />

If your shape is a compound shape, defined using ShapeLayout.Paths instead of ShapeLayout.Geometry, you may find that the styles you have defined for paths do not work well in the reduced-size environment of the toolbox. For each path, you can specify a style to be used in the toolbox by setting the ShapeLayout.ToolboxIconStyle attached property on that path.

If a path represents fine detail that you don’t want to show in the toolbox at all, give it an all-transparent ToolboxIconStyle.

Similarly, you can control how paths are rendered when dragging the tool over the diagram surface using the ShapeLayout.CursorVisualStyle attached property.

Serializing and Deserializing Custom Shapes

The DiagramXmlSerializer serializes custom shape nodes using the name you specified in the shape identifier. You will therefore want to make sure that all the shapes you allow have unique names.

However, when deserializing, the DiagramXmlSerializer does not know how to resolve user-defined shape names. You must therefore set DiagramXmlSerializer.ShapeNameResolver to a function which maps custom shape names to custom shape identifier objects:

CopyC#
serializer.ShapeNameResolver = name => name == "WShape" ? MyShapes.WShape : null;

Your function should return null to indicate that it doesn’t recognise the shape name.


Node Visuals

Mindscape WPF Diagramming
Node Visuals

WPF Diagrams includes built-in visual styles for nodes and connectors, which are automatically made available when you import the DiagramShapes resource dictionary. You can override node styles as follows.

Setting a Global Default Style

To set a global path style for shape nodes, set the ShapeTool.ShapePathStyle attached property on the DiagramSurface. The style is applied to the path used to draw the shape, and must have a TargetType of Path.

CopySetting a path style for all shape nodes
<Window.Resources>
  <Style x:Key="ShapeNodePathStyle" TargetType="Path">
    <Setter Property="Stroke" Value="Navy" />
    <Setter Property="StrokeThickness" Value="1" />
    <Setter Property="Fill" Value="LightSteelBlue" />
    <Setter Property="Stretch" Value="Fill" />
  </Style>
</Window.Resources>

<ms:DiagramSurface ms:ShapeTool.ShapePathStyle="{StaticResource ShapeNodePathStyle}" />

Composite shapes define individual path styles for each part of the composite. These individual path styles override the global default style. Composite shapes therefore cannot be styled in this way.

Overriding the Global Style at the Node Level

To control node styles at a finer level, you must provide a DiagramFormatter object and set its NodeStyleSelector property:

CopyAssociating a custom diagram formatter with a diagram surface
<Window.Resources>
  <ms:DiagramFormatter x:Key="Formatter"
                       NodeStyleSelector="{StaticResource NodeStyleSelector}"
                       />
</Window.Resources>

<ms:DiagramSurface Formatter="{StaticResource Formatter}" />

Your style selector will typically be an instance of ShapeNodeStyleSelector. This allows you to leverage the built-in styling and layout behavior for shapes that you do not need to customise. For shapes that you do need to customise, add appropriate style matcher objects to the selector. The most common kind of matcher is TypeStyle, which maps a class type to a style:

CopyCustomising node types in a style selector
<ms:ShapeNodeStyleSelector x:Key="NodeStyleSelector">
  <ms:TypeStyle DataType="ms:StepNode" Style="{StaticResource StepNodeStyle}" />
  <ms:TypeStyle DataType="ms:StartNode" Style="{StaticResource StartNodeStyle}" />
  <ms:TypeStyle DataType="ms:EndNode" Style="{StaticResource EndNodeStyle}" />
  <ms:TypeStyle DataType="ms:DecisionNode" Style="{StaticResource DecisionNodeStyle}" />
</ms:ShapeNodeStyleSelector>

Styles should have a TargetType of DiagramNodeElement. Your style implementations can be cosmetic, such as modifying path styles, or you can replace the entire template for nodes of this type.

Custom Node Styles – Tweaking Appearance Settings

You can tweak the appearance of a node without modifying its shape or structure by setting properties of DiagramNodeElement and the ShapeTool.ShapePathStyle attached property:

CopyStyling a node at a cosmetic level
<Style x:Key="StepNodePathStyle" TargetType="Path">
  <Setter Property="Fill" Value="HotPink" />
  <Setter Property="StrokeThickness" Value="5" />
  <Setter Property="Stroke" Value="Lime" />
  <Setter Property="StrokeLineJoin" Value="Round" />
</Style>

<Style x:Key="StepNodeStyle" TargetType="ms:DiagramNodeElement">
  <Setter Property="FontWeight" Value="Bold" />
  <Setter Property="ms:ShapeTool.ShapePathStyle" Value="{StaticResource StepNodePathStyle}" />
</Style>

These declarations will cause nodes to be displayed with bold text and in a colorful style, while keeping the declared geometry and the default content template (an editable text box).

Custom Node Styles – Custom Templates

If you have a node for which the default ‘geometry plus text box’ style is not suitable, you can override it by styling the NodeTemplate property with a custom DataTemplate. An example of this might be a node with a complex Data property, where you want to display multiple text boxes with bindings to individual properties of the Data.

In the example below we want a StartNode to display nested borders with different fills. This can’t be done with path styling so we use a custom template instead.

CopyStyling a node at the template level
<Style x:Key="StartNodeStyle" TargetType="ms:DiagramNodeElement">
  <Setter Property="NodeTemplate">
    <Setter.Value>
      <DataTemplate>
        <Grid>
          <Border CornerRadius="15,15,0,0"
                  Background="{StaticResource StartNodeBorder}"
                  IsHitTestVisible="False"
                  />
          <Border CornerRadius="15,15,0,0"
                  Background="{StaticResource StartNodeBackground}"
                  IsHitTestVisible="False"
                  BorderThickness="5"
                  BorderBrush="{StaticResource StartNodeBorder}" />
          <ContentPresenter Content="{Binding}"
                            ContentTemplateSelector="{Binding NodeContentTemplateSelector, RelativeSource={RelativeSource AncestorType={x:Type ms:DiagramNodeElement}}}" />
        </Grid>
      </DataTemplate>
    </Setter.Value>
  </Setter>
</Style>

You must set IsHitTestVisible=”False” on each template element unless that element requires user interaction (such as the content presenter above, which the user uses to edit the data). Elements which are hit-test visible will be treated as interactive, and will therefore not be available for the user to drag the node to a new position.

You should usually set IsHitTestVisible=”False” on at least all Border, Shape and read-only elements.


Connection Visuals

Mindscape WPF Diagramming
Connection Visuals

WPF Diagrams includes built-in visual styles for nodes and connectors, which are automatically made available when you import the DiagramShapes resource dictionary. You can override connection styles as follows.

Setting a Global Default Style

To set a global style for connections, declare a style resource with key DiagramLineTypes.DefaultDiagramConnectionStyleKey and a target type of Path:

CopySetting a path style for all connections
<Style x:Key="{x:Static ms:DiagramLineTypes.DefaultDiagramConnectionStyleKey}" TargetType="Path">
  <Setter Property="Stroke" Value="Goldenrod" />
  <Setter Property="StrokeThickness" Value="2" />
</Style>

You may also want to customise the appearance of arrowheads: you can do this by declaring a style with key DiagramArrowheadTypes.DefaultArrowheadPathStyleKey and a target type of Path:

CopySetting a path style for all arrowheads
<Style x:Key="{x:Static ms:DiagramArrowheadTypes.DefaultArrowheadPathStyleKey}" TargetType="Path">
  <Setter Property="Fill" Value="Yellow" />
  <Setter Property="StrokeThickness" Value="1" />
  <Setter Property="Stroke" Value="Goldenrod" />
</Style>

Overriding the Global Style at the Connection Level

To control connection styles at a finer level, you must provide a DiagramFormatter object and set its ConnectionStyleSelector property:

CopyAssociating a custom diagram formatter with a diagram surface
<Window.Resources>
  <ms:DiagramFormatter x:Key="Formatter"
                       ConnectionStyleSelector="{StaticResource ConnectionStyleSelector}"
                       />
</Window.Resources>

<ms:DiagramSurface Formatter="{StaticResource Formatter}" />

Your style selector will typically be an instance of DiagramConnectionStyleSelector or a custom derived class. This allows you to leverage the built-in styling and layout behavior for connection types that you do not need to customise.

Styles should have a TargetType of DiagramConnectionElement. Typically, you will style the PathStyle, StartArrowTemplate and EndArrowTemplate properties.

CopyCustomising the style for straight connections
<Style x:Key="Luminous" TargetType="Path">
  <Setter Property="StrokeThickness" Value="3" />
  <Setter Property="Stroke" Value="Lime" />
</Style>

<local:LineTypeStyleSelector x:Key="ConnectionStyleSelector">
  <local:LineTypeStyle LineType="Straight">
    <Style TargetType="ms:DiagramConnectionElement">
      <Setter Property="PathStyle" Value="{StaticResource Luminous}" />
    </Style>
  </local:LineTypeStyle>
  <local:LineTypeStyle LineType="StraightArrow">
    <Style TargetType="ms:DiagramConnectionElement">
      <Setter Property="PathStyle" Value="{StaticResource Luminous}" />
      <Setter Property="EndArrowTemplate" Value="{StaticResource {x:Static ms:DiagramArrowheadTypes.Notched}}" />
    </Style>
  </local:LineTypeStyle>
  <local:LineTypeStyle LineType="StraightDoubleArrow">
    <Style TargetType="ms:DiagramConnectionElement">
      <Setter Property="PathStyle" Value="{StaticResource Luminous}" />
      <Setter Property="StartArrowTemplate" Value="{StaticResource {x:Static ms:DiagramArrowheadTypes.Notched}}" />
      <Setter Property="EndArrowTemplate" Value="{StaticResource {x:Static ms:DiagramArrowheadTypes.Notched}}" />
    </Style>
  </local:LineTypeStyle>
</local:LineTypeStyleSelector>


Snapping Items

Mindscape WPF Diagramming
Snapping Items

It is often desirable to snap items to a grid or to guidelines, so that users can easily line them up accurately.

In WPF Diagrams, snapping is controlled using the DiagramSurface.HorizontalSnapSpecifier and DiagramSurface.VerticalSnapSpecifier properties.

To snap items to a regular grid, set these properties to a SnapToIntervalSnapSpecifier. You can do this by creating an instance of SnapToIntervalSnapSpecifier as a resource:
CopySnapping to a regular grid
<Window.Resources>
  <ms:SnapToIntervalSnapSpecifier x:Key="Every20Units" Interval="20" />
</Window.Resources>

<ms:DiagramSurface HorizontalSnapSpecifier="{StaticResource Every20Units}" />

or by using the SnapToInterval markup extension:

CopySnapping to a regular grid
<ms:DiagramSurface HorizontalSnapSpecifier="{ms:SnapToInterval 20}" />
To create your own snapping algorithm, for example to use a non-regular grid (e.g. snap to guidelines or snap to other objects), implement ISnapSpecifier.

For information about drawing snap lines, see Drawing the Diagram Background.


Drawing the Diagram Background

Mindscape WPF Diagramming
Drawing the Diagram Background

The basic background for a DiagramSurface is controlled by the standard Background property. This can be set to any brush, allowing you to use graphics or gradients as backgrounds for your diagram.

If you are using snapping, you may want to draw the snap lines over the background. To do this, set the DiagramSurface.SnapLineDrawing property to an ISnapLineDrawing. The toolkit includes three standard snap line drawing implementations:

  • IntersectionSnapLineDrawing draws a dot at each snap line intersection. This is similar to the grid display in the Visual Studio Windows Forms designer or of many vector drawing programs.
  • LineSnapLineDrawing draws the snap lines. This is similar to the “show guidelines” view of vector drawing programs.
  • IntervalLineSnapLineDrawing draws the snap lines, but draws every nth line in a different style (typically emphasised). This produces an effect similar to mathematical graph paper.

You can control the exact appearance of each line drawing using brushes or pens. For example:

CopyDrawing snap lines
<Window.Resources>
<ms:IntervalLineSnapLineDrawing x:Key="SnapLineDrawing">
  <ms:IntervalLineSnapLineDrawing.MainPen>
    <Pen Brush="DarkGreen" Thickness="0.1" />
  </ms:IntervalLineSnapLineDrawing.MainPen>
  <ms:IntervalLineSnapLineDrawing.IntervalPen>
    <Pen Brush="Black" Thickness="0.3" />
  </ms:IntervalLineSnapLineDrawing.IntervalPen>
</ms:IntervalLineSnapLineDrawing>
</Window.Resources>

<ms:DiagramSurface SnapLineDrawing="{StaticResource GraphPaper}" />

You can create your own implementations of ISnapLineDrawing if you want to render snapping information in your own custom style.


Toolboxes

Mindscape WPF Diagramming
Toolboxes

If your application allows users to create or modify diagrams, you will need to provide some kind of user interface for creating new nodes and connections. WPF Diagrams provides a standard toolbox control, or you can create your user interface or leverage the classes and resources provided.

The easiest way to provide a user interface for adding elements to diagrams is to use the DiagramToolBox control. A DiagramToolBox contains a number of tools, each either a DiagramNodeTool for creating nodes, or a DiagramConnectionTool for connecting nodes (that is, creating connections).

Toolbox Items for Creating Nodes

For a tool to create simple shape nodes, specify a DiagramNodeTool with the ShapeTool.Shape attached property:

CopyA toolbox item for creating rectangle nodes
<ms:DiagramNodeTool ms:ShapeTool.Shape="Rectangle" />

You can also create tools for user-defined shapes in the same way:

CopyA toolbox item for creating nodes of a custom shape
<ms:DiagramNodeTool ms:ShapeTool.Shape="{x:Static local:MyShapes.WShape}" />

Toolbox items for nodes have the following behaviour:

  • The user can drag an item and drop it onto the DiagramSurface to create a node of default size at the drop location.
  • The user can click on an item, move the cursor over the DiagramSurface, and click again to create a node of default size at the second click location. (This is referred to as a “charged cursor” because the first click “charges up” the mouse pointer with the appropriate node type.)
  • The user can click on an item, move the cursor over the DiagramSurface, and drag the cursor across the DiagramSurface to create a node sized to fit the drag rectangle.

Toolbox Items for Connecting Nodes

For a tool to connect nodes using simple lines, specify a DiagramConnectionTool with the ConnectionTool.LineType attached property. As with nodes, this can be a built-in line type or a user-defined line type:

CopyToolbox items for creating connections
<ms:DiagramConnectionTool ms:ConnectionTool.LineType="ElbowDoubleArrow" />
<ms:DiagramConnectionTool ms:ConnectionTool.LineType="{x:Static local:MyShapes.DashedPinkLineWithArrow}" />

The user interface for toolbox connection items is to click on the item and then drag from one connection point to another. The selection remains in effect after drawing a line, making it easy for the user to draw multiple connections of the same kind.

Using the DiagramToolBox Control

A DiagramToolbox is divided into a number of groups, represented by DiagramToolBoxGroup entries. The toolbox control allows the user to show and hide groups to avoid clutter. Each group contains a number of tools as described above.
CopyUsing the DiagramToolBox control
<ms:DiagramToolBox>
  <ms:DiagramToolBoxGroup Header="Lines">
    <ms:DiagramConnectionTool ms:ConnectionTool.LineType="Straight" />
    <ms:DiagramConnectionTool ms:ConnectionTool.LineType="StraightArrow" />
    <ms:DiagramConnectionTool ms:ConnectionTool.LineType="StraightDoubleArrow" />
  </ms:DiagramToolBoxGroup>
  <ms:DiagramToolBoxGroup Header="Shapes">
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Rectangle" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Ellipse" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="{x:Static local:MyShapes.Triskaidecagon}" />
  </ms:DiagramToolBoxGroup>
  <ms:DiagramToolBoxGroup Header="Annotations">
    <StaticResource ResourceKey="{x:Static ms:DiagramShapes.TitleNodeToolKey}" />
    <StaticResource ResourceKey="{x:Static ms:DiagramShapes.CommentNodeToolKey}" />
  </ms:DiagramToolBoxGroup>
</ms:DiagramToolBox>

Standard Toolbox Items

WPF Diagrams contains a number of assemblies for working with specific diagram types such as flow diagrams. These assemblies contain standard toolbox items which you can use in a DiagramToolBox. To do this, merge the relevant resource dictionary into your resources section, then reference the toolbox items you want to use with a StaticResource element.

CopyUsing flow diagram toolbox items
<Window.Resources>
  <ResourceDictionary>
    <ResourceDictionary.MergedDictionaries>
      <ms:StandardFlowDiagramToolBoxItems />
    </ResourceDictionary.MergedDictionaries>
  </ResourceDictionary>
</Window.Resources>

<ms:DiagramToolBox>
  <ms:DiagramToolBoxGroup Header="Flowchart">
    <StaticResource ResourceKey="{x:Static ms:StandardFlowDiagramToolBoxItems.StartNodeToolKey}" />
    <StaticResource ResourceKey="{x:Static ms:StandardFlowDiagramToolBoxItems.DecisionNodeToolKey}" />
    <StaticResource ResourceKey="{x:Static ms:StandardFlowDiagramToolBoxItems.EndNodeToolKey}" />
    <StaticResource ResourceKey="{x:Static ms:DiagramShapes.TitleNodeToolKey}" />
    <StaticResource ResourceKey="{x:Static ms:DiagramShapes.CommentNodeToolKey}" />
  </ms:DiagramToolBoxGroup>
</ms:DiagramToolBox>

Notice that you must merge in the relevant resource dictionary to be able to access these resources.

Customising the Appearance of Toolbox Icons

To customise the appearance of shapes and lines in the toolbox, apply the ShapeTool.ShapePathStyle, ConnectionTool.ConnectionPathStyle and ConnectionTool.ArrowPathStyle attached properties. (Note that these properties affect only tools set up through the ShapeTool and ConnectionTool attached properties. The WPF Diagrams Foundation supports hand-crafting of toolbox items and these are not affected by the auto tool properties.) In each case the value should be a style whose target type is Path.

The attached properties can be applied at the DiagramToolBox level, to style all toolbox items, or at the individual item level.

CopyCustomising the appearance of toolbox icons
<Window.Resources>
  <Style x:Key="ToolboxNodePathStyle" TargetType="Path">
    <Setter Property="Stroke" Value="Red" />
    <Setter Property="StrokeThickness" Value="1" />
    <Setter Property="Fill" Value="Pink" />
    <Setter Property="Stretch" Value="Fill" />
  </Style>

  <Style x:Key="ToolboxLinePathStyle" TargetType="Path">
    <Setter Property="Stroke" Value="Yellow" />
    <Setter Property="StrokeThickness" Value="3" />
    <Setter Property="Stretch" Value="Fill" />
    <Setter Property="Width" Value="40" />
    <Setter Property="Height" Value="30" />
  </Style>

  <Style x:Key="ToolboxArrowPathStyle" TargetType="Path">
    <Setter Property="Fill" Value="Lime" />
    <Setter Property="StrokeThickness" Value="0" />
  </Style>
</Window.Resources>

<ms:DiagramToolBox ms:ShapeTool.ShapePathStyle="{StaticResource ToolboxNodePathStyle}"
                   ms:ConnectionTool.ConnectionPathStyle="{StaticResource ToolboxLinePathStyle}"
                   ms:ConnectionTool.ArrowPathStyle="{StaticResource ToolboxArrowPathStyle}"
                   >
  <ms:DiagramToolBoxGroup Header="Lines">
    <!-- Gets the toolbox-level style -->
    <ms:DiagramConnectionTool ms:ConnectionTool.LineType="Elbow" />
    <!-- Overrides the toolbox-level style -->
    <ms:DiagramConnectionTool ms:ConnectionTool.LineType="ElbowArrow">
      <ms:ConnectionTool.ConnectionPathStyle>
        <Style TargetType="Path" BasedOn="{StaticResource ToolboxLinePathStyle}">
          <Setter Property="Stroke" Value="Red" />
        </Style>
      </ms:ConnectionTool.ConnectionPathStyle>
    </ms:DiagramConnectionTool>
  </ms:DiagramToolBoxGroup>
  <ms:DiagramToolBoxGroup Header="Basic Shapes">
    <!-- Gets the toolbox-level style -->
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Rectangle" />
    <!-- Overrides the toolbox-level style -->
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Ellipse">
      <ms:ShapeTool.ShapePathStyle>
        <Style TargetType="Path" BasedOn="{StaticResource ToolboxNodePathStyle}">
          <Setter Property="Fill" Value="Lime" />
        </Style>
      </ms:ShapeTool.ShapePathStyle>
    </ms:DiagramNodeTool>
  </ms:DiagramToolBoxGroup>
</ms:DiagramToolBox>


Saving and Loading Diagrams

Mindscape WPF Diagramming
Saving and Loading Diagrams

If you are using WPF Diagrams to represent a business object graph then you will typically store the business objects directly, for example in a database. However if you need a way to save and load diagrams without regard to any underlying business objects, WPF Diagrams provides a quick way to do so using XML.

Serializing Diagrams as XML

To save or load a diagram using XML, use the DiagramXmlSerializer class. The two main methods on this class are:

  • Serialize serializes a Diagram to XML. It returns an XDocument object which you can save immediately, embed into a larger XML document or otherwise process as required.
  • Deserialize deserializes an XDocument object containing the source XML into a Diagram object.
CopySaving a diagram to a file
new DiagramXmlSerializer().Serialize(diagram).Save(fileName);
CopyLoading a diagram from a file
ds.Diagram = new DiagramXmlSerializer().Deserialize(XDocument.Load(fileName));

Handling Custom Shapes and Line Types

The DiagramXmlSerializer only knows about the shapes and line types built into WPF Diagrams. If you have defined your own shapes or line types then it will serialize them using the Name property, but for deserialization you will need to provide resolver methods to map these names to your own shapes or line types. A resolver method must have a single string, and a return type of DiagramShape or DiagramLineType as appropriate.

CopyResolver methods for user-defined shapes and line types
var serializer = new DiagramXmlSerializer
{
  ShapeNameResolver = UserShapes.TryResolveShapeName,
  LineTypeNameResolver = UserShapes.TryResolveLineTypeName,
};

public static class UserShapes
{
  public static DiagramShape TryResolveShapeName(string name)
  {
    if (name == "WShape")
      return UserShapes.WShape;
    return null;
  }
}

A resolver method should return null to indicate that it didn’t recognise the name that was passed to it.

Serializing Custom Element Types

To serialize custom node or connection types, subclass DiagramXmlSerializer and override the NodeElementCore and ConnectionElementCore methods. You can call the base class methods for nodes and connections that are not of your custom types.

CopySerializing custom node types
private static readonly XName MyNodeElementName = "MyNode";

protected override XElement NodeElementCore(DiagramNode node)
{
  if (node is MyNode)
  {
    return new XElement(MyNodeElementName);
  }
  return base.NodeElementCore(node);
}

You don’t need to explicitly serialize the Bounds, Rotation, ZOrder or textual Data of a node. These are serialized automatically.

You don’t need to explicitly serialize the connection points, LineType, Segments, ZOrder or textual Data of a connection. These are serialized automatically.

CopyDeserializing custom node types
protected override DiagramNode CreateNode(XElement xml)
{
  if (xml.Name == MyNodeElementName)
  {
    return new MyNode();
  }
  return base.CreateNode(xml);
}

Again, you don’t need to explicitly deserialize the core attributes listed above. These are deserialized automatically.

Serializing Custom Data

The DiagramXmlSerializer assumes that the Data property for nodes and connections contains text. If your node or connection’s Data value is not text, then you can override the way it is serialized and deserialized by setting the OnSerializeCustomNodeData, OnSerializeCustomConnectionData, OnDeserializeCustomNodeData and OnDeserializeCustomConnectionData callbacks.

The Serialize callbacks receive an XElement and a node or connection object. Your callback should examine the node or connection object data and, if it determines that the data requires custom serialization, it should add the necessary attributes or child elements to the XElement, and return true. If the data does not require custom serialization, the callback should return false, indicating that it did not process the data and the default (text) processing should be applied.

The Deserialize callbacks receive an XElement. Your callback should return the desired value of the node or connection Data property, or null to indicate that it did not process the element and the default (text) processing should be applied.

This means you can’t return null from a Deserialize callback. Instead, return an appropriate ‘empty’ value for your custom data type.

CopySerializing and deserializing a non-string Data property
private static bool SerializeData(XElement element, DiagramNode node)
{
  List<string> strings = node.Data as List<string>;
  if (strings != null)
  {
    element.Add(new XElement("Values", strings.Select(s =>
      new XElement("Value",
        new XAttribute("Text", s)))));
    return true;
  }
  return false;  // default serialization
}

private static object DeserializeData(XElement element)
{
  XElement values = element.Element("Values");
  if (values != null)
  {
    return values.Elements("Value")
                 .Select(e => (string)(e.Attribute("Text")))
                 .ToList();
  }
  return null;  // default deserialization
}

// Usage:
DiagramXmlSerializer serializer = new DiagramXmlSerializer
{
  OnSerializeCustomNodeData = SerializeData,
  OnDeserializeCustomNodeData = DeserializeData
};


Printing

Mindscape WPF Diagramming
Printing

To print a diagram, use the DiagramPrinter class. This provides you with a DiagramPrintDocument which in turn yields a WPF FixedDocument which can be passed to an XpsDocumentWriter.

For more information, see Printing in the QuickStart walkthrough.


Bitmap Export

Mindscape WPF Diagramming
Bitmap Export

To export a diagram to a bitmap, use the DiagramBitmapRenderer class. Renderers are supplied out of the box for exporting diagrams to PNG, JPEG and BMP format, and renderers can be easily created to support other formats such as GIF or TIFF.

Rendering a Bitmap

To render a diagram to a bitmap, call the Render method, passing the DiagramSurface you want to render:

CopyC#
DiagramBitmapRenderer.Png.Render(ds, filename);

Rendering to New Formats

To render to a format that is not supported out of the box, e.g. GIF or TIFF, create a subclass of DiagramBitmapRenderer and override the GetBitmapEncoder method.


Commands

Mindscape WPF Diagramming
Commands

Several commands are defined for use with the DiagramSurface control. You can send these commands to the DiagramSurface from whatever user interface you choose – menus, toolbars, keystrokes, etc. The built-in commands cover the following areas:

  • Aligning nodes
  • Distributing (spacing out) nodes
  • Z-ordering nodes (bring forward / send backward)
  • Size to fit

See the DiagramCommands class for the list of built-in commands. The DiagramSurface also responds to the built-in Delete, Undo, Redo and SelectAll commands.

To programatically send a command to a DiagramSurface, set the CommandTarget to the DiagramSurface control.

CopyAlignment commands on a toolbar
<ToolBar>
  <Button Command="ms:DiagramCommands.AlignLeft" CommandTarget="{Binding ElementName=ds}">Align Left</Button>
  <Button Command="ms:DiagramCommands.AlignCenter" CommandTarget="{Binding ElementName=ds}">Align Center</Button>
  <Button Command="ms:DiagramCommands.AlignRight" CommandTarget="{Binding ElementName=ds}">Align Right</Button>
  <Button Command="ms:DiagramCommands.AlignTop" CommandTarget="{Binding ElementName=ds}">Align Top</Button>
  <Button Command="ms:DiagramCommands.AlignMiddle" CommandTarget="{Binding ElementName=ds}">Align Middle</Button>
  <Button Command="ms:DiagramCommands.AlignBottom" CommandTarget="{Binding ElementName=ds}">Align Bottom</Button>
</ToolBar>

<ms:DiagramSurface Name="ds" />


Troubleshooting

Troubleshooting

Q. When I run my application, I get a XamlParseException. The inner exception is “An instance of type ‘Mindscape.WpfDiagramming.Foundation.DiagramSurface’ was being created, and a valid license could not be granted for the type ‘Mindscape.WpfDiagramming.Foundation.DiagramSurface’.”

A. If you receive this exception and you have a full licence or a trial licence which has not expired, check that your project contains a licences.licx file (in the Properties folder). This file should be automatically generated by the Visual Studio WPF designer when you add a DiagramSurface control either via the designer or the XAML editor. If Visual Studio has not generated this file, either: (a) drag a DiagramSurface from the toolbox onto the designer (and delete it again) to get Visual Studio to regenerate the licences.licx file; or (b) copy a licenses.licx file from one of the sample projects.

If you are building an application (EXE) which uses a library (DLL) which uses WPF Diagrams, you will also need to add a licenses.licx to the application project.

You will also receive this exception if you are using a trial licence which has expired.

Q. After installation, I don’t see a Mindscape tab in the Visual Studio toolbox.

This is an issue with the Visual Studio Toolbox Controls Installer. Use the normal Add Tab and Choose Items menu options to add the control to the toolbar, or if you prefer to work in XAML rather than the designer, just use Add Reference in your project. The diagramming assemblies are located in the Mindscape folder under your Program Files directory and a link is provided in the Start menu.


Introduction

Mindscape WPF Diagramming
Introduction

Most applications require only high-level diagramming services: standard shapes, the occasional custom shape and connections. These applications can use the Mindscape.WpfDiagramming classes to handle most of their needs. However some applications may need extra control or customisation, for example to surface rich data or to create user interactions that are not handled by the built-in diagrams.

The built-in diagram types are built on top of a very flexible foundation layer, which you can find in the Mindscape.WpfDiagramming.Foundation namespace. Using the foundation classes is not as easy as using the high-level classes, but they provide a great deal more flexibility.


Formatting

Mindscape WPF Diagramming
Formatting

Diagram formatting is controlled by the DiagramSurface.Formatter property. This is of type IDiagramFormatter. A formatter effectively defines a “theme” or style. For flow diagrams, this is implemented by FlowDiagramFormatter, and for star diagrams by StarDiagramFormatter; for custom diagram types you can create your own implementation of IDiagramFormatter.

You will normally instantiate a formatter in XAML as a resource, and reference the formatter from your DiagramSurface declaration.

The properties of the formatter should be set as follows.

NodeStyleSelector

This allows you to customise the elements that make up a diagram node element: for example, if you want to change the appearance of the resize UI. You will rarely need to specify this property. For more information, see Node Visuals.

ConnectionStyleSelector

A StyleSelector which defines a visual style for each type of connection—typically properties such as colour and thickness. For more information, see Connection Visuals.

NodeContentTemplateSelector

A DataTemplateSelector which selects a DataTemplate for the content of each node in the diagram. For example, a text box in which the user can edit the node content. For more information, see Node Visuals.

ConnectionContentTemplateSelector

A DataTemplateSelector which selects a DataTemplate for the content of each connection in the diagram. For example, a text block displaying a label for a decision branch. For more information, see Connection Visuals.

ConnectionPointTemplateSelector

A DataTemplateSelector which selects a DataTemplate for each connection point in the diagram. This permits fine control over connection point visuals. For more information, see Connection Visuals.

Layout

This allows you to customise where nodes should be placed on the DiagramSurface. By default, nodes are placed at the location specified by their IDiagramNode.Bounds property. You will rarely need to specify this property.


Node Visuals

Mindscape WPF Diagramming
Node Visuals

WPF Diagrams includes built-in visual styles for shapes and for flow and star diagrams. To use a built-in visual style, set DiagramSurface.Formatter to the resource identified by the appropriate key. For example:
CopyXML
<ms:DiagramSurface Formatter="{StaticResource {x:Static ms:FlowDiagramStyles.GradientStyleFormatterKey}}" />

(A suitable formatter for shapes is used by default and does not need to be specified.)

You will usually need to customise node visuals at the Foundation level only if you want to use a new node type which is not defined in the core package. In this case there are two steps: define a new style, and hook up a style selector to specify when to use the new style.

If you are creating your own shapes, but you are still using ShapeNode, you do not need to create a special style for them.

Defining the Style for a New Node Type

The Style you define will be applied to a DiagramNodeElement. The framework ensures that the element is instantiated at the correct position on the DiagramSurface and with the correct size, as specified by the Bounds property.

In most cases, the only property you need to set in your Style is the NodeTemplate property. This should be set to a DataTemplate which describes how you want to render the node and its data.

If your template is a simple shape such as a Rectangle, Ellipse or Border, it will size automatically. If you are using a more complex shape such as a Path, you should use the Bounds property to determine the location of points on the path.

A typical template consists of a background shape with a text box and/or other controls on top of it. By default, all of these elements are “live”—that is, the user can interact with them as normal, and mouse activity over these elements is not translated into a drag-move. Any element which is not intended to be “live,” and which the user should therefore be able to use for dragging, must have its IsHitTestVisible property set to false, so that mouse activity can be passed on to the underlying MoveThumb. Typically, you should set IsHitTestVisible to false on the background shape, but not on any of the foreground controls.

You can choose content controls explicitly, for example, by specifying a TextBox or Button control as part of your template, or delegate back to the DiagramFormatter’s NodeContentTemplateSelector. The default content template is a text box but you can create a selector that allows you to present different kinds of node content consistently across different node types/styles.

Other properties you may wish to style include ConnectionPointPositions, which specifies where on the shape the connection points should appear.

The first example shows a style which defines a custom shape and custom connection point positions, but displays the node data using the default template (typically a text box in which the user can edit the node data).

CopyCustom style using default content display and customising connection point positions
<Style TargetType="ms:DiagramNodeElement">
  <Setter Property="ConnectionPointPositions" Value="L 0.2,0.5" />
  <Setter Property="NodeTemplate">
    <Setter.Value>
      <DataTemplate>
        <Grid>
          <Path Stroke="CadetBlue" StrokeThickness="1"
                Fill="AliceBlue" ms:DiagramNodeElement.IsGeometryProvider="True"
                IsHitTestVisible="False" Stretch="Fill"
                Data="M 0 0 L 0.8 0 L 1 0.5 L 0.8 1 L 0 1 L 0.2 0.5 Z" />
          <ContentPresenter Content="{Binding}"
                            ContentTemplateSelector="{Binding NodeContentTemplateSelector, RelativeSource={RelativeSource AncestorType={x:Type ms:DiagramNodeElement}}}" />
        </Grid>
      </DataTemplate>
    </Setter.Value>
  </Setter>
</Style>

The second example shows a style where the node background comprises a simple ellipse, but instead of editing the node data using a text box the style specifies a read-only display and a pair of up-down buttons. This would be suitable for displaying numeric content.

CopyCustom style using its own controls to display and edit content
<Style TargetType="ms:DiagramNodeElement">
  <Setter Property="NodeTemplate">
    <Setter.Value>
      <DataTemplate>
        <Grid>
          <Grid.RowDefinitions>
            <RowDefinition Height="*" />
            <RowDefinition Height="Auto" />
            <RowDefinition Height="*" />
          </Grid.RowDefinitions>
          <Grid.ColumnDefinitions>
            <ColumnDefinition Width="*" />
            <ColumnDefinition Width="Auto" />
            <ColumnDefinition Width="*" />
          </Grid.ColumnDefinitions>
          <Ellipse Stroke="CadetBlue" StrokeThickness="1" Fill="AliceBlue"
                   IsHitTestVisible="False"
                   Grid.RowSpan="3" Grid.ColumnSpan="3" />
          <TextBlock Text="{Binding Data}"
                     FontSize="20" LineHeight="20"
                     Grid.Row="1" Grid.Column="1"
                     VerticalAlignment="Center" Margin="0,2,0,6" />
          <RepeatButton FontSize="8" Grid.Row="0" Grid.Column="1" Style="{StaticResource FlatButton}"
                        HorizontalAlignment="Center" VerticalAlignment="Bottom" Click="UpButton_Click" Tag="{Binding}">
            <Polygon Points="0,6 6,0 12,6" Fill="CadetBlue" />
          </RepeatButton>
          <RepeatButton FontSize="8" Grid.Row="2" Grid.Column="1" Style="{StaticResource FlatButton}"
                        HorizontalAlignment="Center" VerticalAlignment="Top" Click="DownButton_Click" Tag="{Binding}">
            <Polygon Points="0,0 6,6 12,0" Fill="CadetBlue" />
          </RepeatButton>
        </Grid>
      </DataTemplate>
    </Setter.Value>
  </Setter>
</Style>

Selecting the New Style

To add the Style to the formatter, you must first create a StyleSelector to load your template. You will typically do this by instantiating a MatchingStyleSelector, or TypeStyleSelector and adding a TypeStyle that references your node type and your style. In order to continue to use the style default templates for other node types, set the DelegatingDataTemplateSelector.BasedOn property to the built-in style identified by the NodeStyleSelectorKey for the built-in style you want. For example:
CopyXML
<ms:MatchingStyleSelector x:Key="NodeStyleSelector" BasedOn="{StaticResource {x:Static ms:GradientStyle.NodeStyleSelectorKey}}">
  <ms:TypeStyle DataType="local:SendMessageNode" Style="{StaticResource SendMessageNodeStyle}" />
  <ms:TypeStyle DataType="local:WaitNode" Style="{StaticResource WaitNodeStyle}" />
</ms:MatchingStyleSelector>

You must then create an instance of IDiagramFormatter whose NodeTemplateSelector is set to your DataTemplateSelector. Other properties can be set to the style defaults. For example:

CopyHooking up the style selector
<Window.Resources>
  <ms:DiagramFormatter x:Key="Formatter"
                       NodeStyleSelector="{StaticResource NodeStyleSelector}"
                       />
</Window.Resources>

<ms:DiagramSurface Formatter="{StaticResource Formatter}" />

Additional Considerations

If your connection points are interior to the bounding rectangle (because the node does not occupy the entire rectangle), you should specify the DiagramNodeElement.IsGeometryProvider on the element which defines the node outline. Otherwise, the entire bounding rectangle will be draggable to move the node, and users will not be able to drag connections off connection points in order to relocate them.

For a worked example, please refer to the CustomStyle.FlowDiagrams sample.


Connection Visuals

Mindscape WPF Diagramming
Connection Visuals

WPF Diagrams includes built-in visual styles for the predefined DiagramConnection class, which can be extended by setting the LineType and configuring a suitable LineTypeLayout resource.

You will usually need to customise connection visuals at the Foundation level only you are creating your own diagram type and need to implement your own connection data model or connectivity logic. Even then, most requirements can be met by extending DiagramConnection and adding suitable connectivity logic to node classes, rather than implementing a whole new connection type.

However if you do need to rip and replace connection visuals then you can do so by defining a Style and hooking up that style to the DiagramSurface through the Formatter property.

Creating a Custom Connection Style

Most customisation of connection appearance can be carried out by creating one or more Styles in your XAML representing the appearance you require. You must then create a StyleSelector which references these styles. In most cases, you will create only one Style, and will use a FixedStyleSelector to select it. (The use of a selector is to provide additional flexibility for special scenarios.)

Your style must have a TargetType of DiagramConnectionElement, and will typically set the Template property to replace the control template. DiagramConnectionElement control templates are often relatively complex because a connection has lots of parts. A full example is shown in the CustomStyle sample. Your ControlTemplate will typically define the following elements.

  • A Canvas on which the following elements are placed.
  • A Path representing the connection itself. The Path.Data property should be derived from the Segments property of the bound IDiagramConnection, using a suitable converter such as the CorneredConnectionPathConverter. The Path’s Style is typically inherited from the containing DiagramConnectionElement using a RelativeSource binding, but it can be applied directly. This Path is what determines the geometry and appearance of the connection.
  • A Path whose Data property is the same as the main Path (data bound), but which has a larger StrokeThickness and a transparent Stroke (#00FFFFFF). The purpose of this is to enable users to select the connection by clicking near the connection—otherwise selecting the connection would require pixel accuracy.
  • A Path whose Data property is the same as the main Path (data bound), but which has a larger StrokeThickness and whose Visibility is Collapsed, plus a DataTrigger to set its Visibility to Visible when the containing DiagramConnectionElement is selected. The purpose of this is to highlight the connection when it is selected.
  • One or two Paths representing the arrowhead(s). You can also use ContentControls whose ContentTemplate is {TemplateBinding StartArrowTemplate} (or EndArrowTemplate) and suitable rotation and translation transforms – this allows arrow drawing to be delegated back to a default. See the CustomStyle sample for an example.
  • A TextBox or other control to show and allow editing of the connection caption. Again, you can instead specify a ContentPresenter instead of a specific control to delegate content display back to a default.
  • An ItemsControl whose ItemsSource is the DiagramConnectionElement.MovableSegments and whose ItemTemplate consists of a DiagramSegmentThumb. The ItemPanelTemplate for this ItemsControl is typically a Canvas and the DiagramSegmentThumbs are positioned by binding the Canvas.Left and Canvas.Top properties in ItemContainerStyle to the Midpoint.X and Midpoint.Y properties of the segment. The Visibility of the ItemsControl should be set to Collapsed, with a DataTrigger to make it visible when the mouse is over the connection.
  • Two ConnectionRelocatorThumb controls, positioned over the From and To connection points. The Visibility of these controls should be set to Collapsed, with a DataTrigger to make them visible when the mouse is over the connection.
  • A ConnectionPointThumb to be displayed as the dynamic connection point when the user drags the end of another connection near to this connection. The position of this shape should be bound to DiagramConnectionElement.RequestedConnectionPoint and the Visibility should be Collapsed, with a DataTrigger to make it visible when DiagramConnectionElement.IsRequestingConnectionPoint is true.

Selecting the New Style

Once you have created this style, you must create a StyleSelector to select it. If you are using the same style for all connections, as is typical, you can use the FixedStyleSelector for this.

Finally you must create a DiagramFormatter instance which references your StyleSelector.

For a worked example, please refer to the CustomStyle sample.


Positioning Connection Points

Mindscape WPF Diagramming
Positioning Connection Points

WPF Diagrams represents the points at which connections can join to nodes as connection points. The pre-defined styles define connection points for each of the pre-defined node types. You will typically need to know how to specify connection point locations only if you have created a node style with a shape where the default connection point locations (the centre of each side of the bounding rectangle) are not appropriate.

Connection Points for a Custom Node Type

Connection point locations are defined by the DiagramNodeElement.ConnectionPointPositions property. This can be set through the node style. The easiest way to set this property is using a string that describes the edges and positions of the connection points.

CopyStyling the connection point positions
<Setter Property="ConnectionPointPositions" Value="L 0, 0.25 R 1, 0.75 B 0.3, 1-20; 0.7, 1-20" />

The string format is as follows:

  • A letter indicating the edge on which you want a connection point or points: L for left, T for top, R for right or B for bottom.
  • One or more positions. Each position is a comma-separated pair of X, Y values. Multiple positions must be separated by semicolons. Positions are as fractions of the bounding box, e.g. an X coordinate of 0.5 means half way across the bounding box, optionally +/- an absolute pixel offset.

For example, the string “L 0, 0.5 R 1, 0.3; 0.9, 0.7” specifies one connection point on the Left edge at (0, 0.5) (half way down the left side) and two connection points on the Right edge, one at (1, 0.3) (30% of the way down the right edge) and one at (0.9, 0.7) (70% of the way down the right edge and indented by 10%). The string “B 0 + 100, 1 – 100” specifies a bottom connection point that is 100 pixels to the right of the left-hand edge, and 100 pixels above the bottom edge.


Serialization for Custom Diagram Types

Mindscape WPF Diagramming
Serialization for Custom Diagram Types

WPF Diagrams includes the DiagramXmlSerializer class for saving diagrams to XML and loading them from XML. The DiagramXmlSerializer class works with Diagram objects, ShapeNode, TitleNode and CommentNode nodes, and DiagramConnection connections. If you create a custom diagram type with custom node or connection classes, and you want to use DiagramXmlSerializer to save and load your diagrams, you will need to extend it to handle your custom node or connection classes.

To do this, override the following methods:

  • For custom node classes: SerializeNodeCore (serialization) and CreateNode (deserialization)
  • For custom connection classes: SerializeConnectionCore (serialization) and CreateConnection (deserialization)
  • For custom diagram classes: CreateDiagram (deserialization)

The Serialize methods should return a XElement which identifies the type of node or connection in a way that will be recognised by the deserialization methods. The Serialize methods should populate any custom data specified by the node or connection class (this can also be done through the OnSerializeCustomNodeData and OnDeserializeCustomConnectionData callbacks, but these may be set by the user and should therefore not be relied on for essential custom data). The Serialize methods should call the base class implementation if they want default serialization behaviour for the node or connection – note that the DiagramXmlSerializer base implementation handles only the built-in shape, title and comment node types.

Typically you’ll return an empty XElement whose name corresponds to the type of node or connection.

CopySerialization support for a custom node type
protected override XElement SerializeNodeCore(DiagramNode node)
{
  if (node is BranchNode)
  {
    return new XElement("BranchNode");
  }
  return base.SerializeNodeCore(node);
}

The Create (deserialize) methods should return an object (node, connection or diagram) appropriate to the XElement passed in. The Create methods should load any custom data specified by the node or connection class (this can also be done through the OnDeserializeCustomNodeData and OnDeserializeCustomConnectionData callbacks, but these may be set by the user and should therefore not be relied on for essential custom data). The Create methods should call the base class implementation if they want the default deserialization behaviour for the XML element.

Typically you’ll switch on the XElement name and return a new node or connection of the appropriate type.

CopyDeserialization support for a custom node type
protected override DiagramNode CreateNode(XElement xml)
{
  if (xml.Name.LocalName == "BranchNode")
  {
    return new BranchNode();
  }
  return base.CreateNode(xml);
}

Deserializing custom connection types requires a little more code because connections need to be hooked up to their connection points, and need to call the correct constructor depending on whether there were segments associated with the connection:

CopyDeserialization support for a custom node type
protected override DiagramConnection CreateConnection(XElement xml, DiagramConnectionPoint source, DiagramConnectionPoint destination, IList<DiagramConnectionSegment> segments)
{
  if (xml.Name == ActivityDiagramConnectionElementName)
  {
    if (segments.Count == 0)
    {
      return new ActivityDiagramConnection(source, destination);
    }
    else
    {
      return new ActivityDiagramConnection(source, destination, segments);
    }
  }
  return base.CreateConnection(xml, source, destination, segments);
}


Toolboxes

Mindscape WPF Diagramming
Toolboxes

Creating Your Own Toolbox Items Using Built-In Classes

You can create your own toolbox items to allow users to create instances of a custom shape or node type that you’ve defined. Toolbox items must be instances of DiagramNodeTool or DiagramConnectionTool.

For a node tool, you will need to set three properties on the DiagramNodeTool:

  • Builder: An IDiagramNodeBuilder which creates a node of the appropriate type and adds it to the diagram. You can create the builder instance as a resource or use the BuilderType markup extension.
  • CursorVisual: A Visual to be displayed when the toolbox item is being dragged onto the diagram surface, or when the user has selected the tool and is hovering over the diagram surface (the “charged cursor” mode).
  • Content: The UIElement or text to be displayed in the toolbox itself.

For a connection tool, you will need to set two properties on the DiagramConnectionTool:

  • Builder: An IDiagramConnectionBuilder which creates a node of the appropriate type and adds it to the diagram. You can create the builder instance as a resource or use the BuilderType markup extension.
  • Content: The UIElement or text to be displayed in the toolbox itself.
CopyCustom toolbox items
<local:CarConnectionBuilder x:Key="TowingConnector" CarConnectionKind="Towing" />

<ms:DiagramNodeTool Builder="{ms:BuilderType local:CarNodeBuilder}">
  <ms:DiagramNodeTool.CursorVisual>
    <TextBlock Text="Car" />
  </ms:DiagramNodeTool.CursorVisual>
  <TextBlock Text="Car" />
</ms:DiagramNodeTool>

<ms:DiagramConnectionTool Builder="{StaticResource TowingConnector}">
  <Path Style="{StaticResource ConnectionPathStyle}" Data="M 0 0 L 1 1" />
</ms:DiagramConnectionTool>

It is also common to provide a tooltip by setting the ToolTip property.

Toolbox items created in this way have the same behaviour as the standard toolbox items: in particular, they can be used in the same ways (drag, charged cursor, dragging of charged cursor) described above.

For a worked example, see the CustomNodeType sample.

Creating Your Own User Interface

You can of course create a completely custom user interface and have it call the diagramming API to create new nodes:

CopyC#
IDiagramModel diagram = GetDiagram();  // e.g. diagramSurface.Diagram
StartNode node = CreateStartNode(someText, someBounds);
diagram.Nodes.Add(node);


Introduction

Mindscape WPF Diagramming
Introduction

WPF Diagrams includes an assembly, Mindscape.WpfDiagramming.FlowDiagrams, which implements additional node types specific to flow diagramming applications, such as Start, End and Decision nodes.

To use the flow diagram functionality, reference the Mindscape.WpfDiagramming.FlowDiagrams assembly, and merge the following resource dictionaries instead of the normal DiagramShapes dictionary:

CopyMerging resource dictionaries for flow diagrams
<Window.Resources>
  <ResourceDictionary>
    <ResourceDictionary.MergedDictionaries>
      <ms:FlowDiagramStyles />
      <ms:StandardFlowDiagramToolBoxItems />
    </ResourceDictionary.MergedDictionaries>
  </ResourceDictionary>
</Window.Resources>

Two built-in styles are provided for flow diagrams, a pale minimalist style and a colourful gradient style. To choose which style you want, set DiagramSurface.Formatter:

CopyXML
<ms:DiagramSurface Formatter="{StaticResource {x:Static ms:FlowDiagramStyles.GradientStyleFormatterKey}}" />

Finally, set your DiagramSurface.Diagram to be an instance of FlowDiagramModel instead of the base Diagram class:

CopyC#
ds.Diagram = new FlowDiagramModel();

FlowDiagramModel works with the special node types to enforce a ‘flow’ through the diagram nodes and connections.


Node Types

Mindscape WPF Diagramming
Node Types

The flow diagrams assembly defines a number of additional node types. You can use these node types in diagrams of type FlowDiagramModel.

StartNode and EndNode

Use these to represent the start and end of a flow diagram. StartNode permits only a single outbound connection; EndNode permits only inbound connections.

StepNode

Use StepNode to represent a normal (non-branching) step in a flow diagram. Because a flow can contain different kinds of steps, StepNode is parameterised with a DiagramShape to specify how it is displayed. StepNode permits multiple inbound connections but only a single outbound connection.

DecisionNode

Use DecisionNode to represent a branching step in a flow diagram. DecisionNode permits multiple inbound and outbound connections. Outbound connections are captioned with the decision outcomes they represent: WPF Diagrams tries to infer appropriate captions but users can edit these as required.


Toolbox Items

Mindscape WPF Diagramming
Toolbox Items

Because the custom node types introduced in the flow diagrams assembly are not simple shape nodes, you cannot create toolbox items for them using the ShapeTool.Shape attached property.

Creating Toolbox Items for Start, End and Decision Nodes

The flow diagrams assembly includes toolbox item resources for Start, End and Decision nodes which you can reference using the StaticResource element:

CopyA toolbox group for fixed flow diagram nodes
<ms:DiagramToolBoxGroup Header="Flow Control">
  <StaticResource ResourceKey="{x:Static ms:StandardFlowDiagramToolBoxItems.StartNodeToolKey}" />
  <StaticResource ResourceKey="{x:Static ms:StandardFlowDiagramToolBoxItems.DecisionNodeToolKey}" />
  <StaticResource ResourceKey="{x:Static ms:StandardFlowDiagramToolBoxItems.EndNodeToolKey}" />
</ms:DiagramToolBoxGroup>

Remember to merge the StandardFlowDiagramsToolBoxItems resource dictionary.

Creating Toolbox Items for Step Nodes

As a StepNode needs to be parameterised by a shape, there isn’t a singular tool resource you can use for step nodes. Instead, use the StepNodeTool.Shape attached property to configure a DiagramNodeTool to create step nodes.

CopyEvery diagram needs punched tape
<ms:DiagramToolBoxGroup Header="Step Nodes">
  <ms:DiagramNodeTool ms:StepNodeTool.Shape="Process" />
  <ms:DiagramNodeTool ms:StepNodeTool.Shape="Data" />
  <ms:DiagramNodeTool ms:StepNodeTool.Shape="Document" />
  <ms:DiagramNodeTool ms:StepNodeTool.Shape="PunchedTape" />
</ms:DiagramToolBoxGroup>


Saving and Loading Diagrams

Mindscape WPF Diagramming
Saving and Loading Diagrams

To save and load flow diagrams, use the FlowDiagramXmlSerializer instead of the base DiagramXmlSerializer. This serializer is equipped to handle the custom node types introduced by the flow diagramming assembly.

The serializer is used in the same way as the base serializer, and can be extended in a similar way if required.


Introduction

Mindscape WPF Diagramming
Introduction

WPF Diagrams includes an assembly, Mindscape.WpfDiagramming.StarDiagrams, which implements diagramming logic specific to star (hierarchical) diagramming applications.

To use the star diagram functionality, reference the Mindscape.WpfDiagramming.StarDiagrams assembly, and merge the following resource dictionaries in addition to the normal DiagramShapes dictionary:

CopyMerging resource dictionaries for flow diagrams
<Window.Resources>
  <ResourceDictionary>
    <ResourceDictionary.MergedDictionaries>
      <ms:DiagramShapes />
      <ms:StarDiagramStyles />
      <ms:StandardStarDiagramToolBoxItems />
    </ResourceDictionary.MergedDictionaries>
  </ResourceDictionary>
</Window.Resources>

Two built-in styles are provided for flow diagrams, a pale minimalist style and a colourful gradient style. To choose which style you want, set DiagramSurface.Formatter:

CopyXML
<ms:DiagramSurface Formatter="{StaticResource {x:Static ms:StarDiagramStyles.GradientStyleFormatterKey}}" />

Finally, set your DiagramSurface.Diagram to be an instance of StarDiagramModel instead of the base Diagram class:

CopyC#
ds.Diagram = new StarDiagramModel();

StarDiagramModel works with the StarDiagramNode node type to manage the hierarchy of the star diagram.


Node Types

Mindscape WPF Diagramming
Node Types

The star diagrams assembly defines an additional node type, DataNode, and a base node type StarDiagramNode, to be used in diagrams of type StarDiagramModel.

StarDiagramNode handles the logic of hierarchical relations between nodes via properties such as Parent, Children and Level. It also provides a Mass property which is used for force-based layouts as these are common in star diagramming applications. StarDiagramNode also implements the logic of having a single connection point representing the entire node.

As StarDiagramNode is an abstract class, you will typically use the DataNode derived class when building star diagrams.


Toolbox Items

Mindscape WPF Diagramming
Toolbox Items

Because the custom DataNode type introduced in the star diagrams assembly is not a simple shape nodes, you cannot create a toolbox item for it using the ShapeTool.Shape attached property.

Instead, the star diagrams assembly includes a toolbox item resource for DataNode which you can reference using the StaticResource element:

CopyA toolbox group for fixed flow diagram nodes
<ms:DiagramToolBoxGroup Header="Nodes">
  <StaticResource ResourceKey="{x:Static ms:StandardStarDiagramToolBoxItems.DataNodeToolKey}" />
</ms:DiagramToolBoxGroup>

Remember to merge the StandardStarDiagramsToolBoxItems resource dictionary.


Saving and Loading Diagrams

Mindscape WPF Diagramming
Saving and Loading Diagrams

To save and load star diagrams, use the StarDiagramXmlSerializer instead of the base DiagramXmlSerializer. This serializer is equipped to handle the DataNode type introduced by the star diagramming assembly.

The serializer is used in the same way as the base serializer, and can be extended in a similar way if required.


Specify Snap to Grid

Mindscape WPF Diagramming
Specify Snap to Grid

How Do I Specify Snap to Grid?

Set the HorizontalSnapSpecifier and the VerticalSnapSpecifier properties of the DiagramSurface. Use an instance of the SnapToIntervalSnapSpecifier, or use the SnapToIntervalExtension markup extension as shown in the QuickStart:

CopyXML
<ms:DiagramSurface HorizontalSnapSpecifier="{ms:SnapToInterval 10}" />

To customise snapping behaviour, implement the ISnapSpecifier interface.


Draw Snap Lines on the Background

Mindscape WPF Diagramming
Draw Snap Lines on the Background

How Do I Draw Snap Lines on the Background?

Set the SnapLineDrawing property of the DiagramSurface.

The toolkit includes three drawing styles: IntersectionSnapLineDrawing (grid of dots), LineSnapLineDrawing (grid of lines) and IntervalLineSnapLineDrawing (grid of lines with every nth line drawn using a different pen for emphasis). Create an instance of your desired style as a resource and set SnapLineDrawing to refer to that.

To create your own snap line drawing style, implement ISnapLineDrawing.


Style Nodes and Connections

Mindscape WPF Diagramming
Style Nodes and Connections

How Do I Style Nodes and Connections?

If you are using simple shape nodes and connections, see Node Visuals and Connection Visuals.

If you are creating custom node types, or want to style nodes and connections other than simple ones, you can create a Style to control the appearance or a node or connection. The Style’s TargetType should be DiagramNodeElement or DiagramConnectionElement as appropriate. Set the NodeTemplate property to define a data template to be bound to the node object, or the Template property to fully customize the appearance of the element. See the Foundation documentation on Node Visuals and Connection Visuals for more information.

Refer to the CustomStyle.FlowDiagrams and Cosmic.StarDiagrams samples for a comprehensive illustration of styling. Refer to the CustomNodeType.FlowDiagrams sample for information about templating your own nodes.


Create Custom Diagram Node Types

Mindscape WPF Diagramming
Create Custom Diagram Node Types

How Do I Create Custom Node Types in a Diagram?

Each diagram type included in WPF Diagrams defines a number of standard node types but you may need to add more. To do so, create a class the implements IDiagramNode. The easiest way to do this for standard diagrams is to derive from the Node class. (For flow diagrams, derive from FlowDiagramNode; for star diagrams, from StarDiagramNode.)

Your custom node class will need to:

  • Specify where connection points fall on the custom node class.
  • Support the Clone method in order to participate in undo/redo.

Your window or application resources must also provide a DataTemplate for displaying the custom node type, and link the two via the NodeTemplateSelector of the DiagramSurface’s Formatter.

If your application uses one of the built-in serializers to save and load diagrams, you will need to handle the UnknownNode events to handle serialisation and deserialisation of the custom node data.

Refer to the CustomNodeType sample for an example of creating a custom node type.


Save and Load a Diagram

Mindscape WPF Diagramming
Save and Load a Diagram

How Do I Save and Load a Diagram?

Each built-in diagram type has its own XML serializer which you can use to save the diagram to XML and load it back in again.

For standard diagrams, use the DiagramXmlSerializer. For flow diagrams, use the FlowDiagramXmlSerializer; for star diagrams, use the StarDiagramXmlSerializer.

If you have a custom diagram type, or if you don’t want to use XML, you can traverse the diagram model programmatically using the Nodes and Connections lists.


Lay Out a Diagram

Mindscape WPF Diagramming
Lay Out a Diagram

How Do I Lay Out a Diagram?

Create an instance of ILayoutAlgorithm and call Run on your diagram.

WPF Diagrams includes a number of layout algorithms:

  • ForceBasedLayoutAlgorithm uses a simulated physics engine to space the nodes in a radial format.
  • GridLayoutAlgorithm arranges the nodes on a grid in a way that respects the connection structure of the diagram.
  • HierarchicalLayoutAlgorithm arranges the nodes in a hierarchical tree structure.
  • CircularLayoutAlgorithm arranges the nodes in a circle.
  • RandomLayoutAlgorithm arranges the nodes randomly.

The force-based algorithms works iteratively. To use this algorithm, either specify a large number of iterations, or run it repeatedly using a timer. The latter option is useful for creating a smooth animated layout effect.

To create your own layout algorithm, implement ILayoutAlgorithm.


Export a Diagram to a Bitmap

Mindscape WPF Diagramming
Export a Diagram to a Bitmap

How Do I Export a Diagram to a Bitmap?

Use the DiagramBitmapRenderer class.

Renderers for PNG, JPEG and BMP file formats are included; to export to additional formats, derive your own class from DiagramBitmapRenderer and override the GetBitmapEncoder method.


WPF Diagrams 2.0

Mindscape WPF Diagramming
WPF Diagrams 2.0

WPF Diagrams 2.0 Release Notes

WPF Diagrams has been extensively revised in the 2.0 release, and it is therefore not appropriate to include a detailed list of individual changes and fixes. Major changes include:

  • Added a high-level API to facilitate working with shape-and-line diagrams, and to provide a firmer base for developing custom diagram types
  • Combined WPF Flow Diagrams and WPF Star Diagrams into WPF Diagrams product
  • Some existing classes moved out of the Foundation namespace and into the root diagramming namespace
  • Reworked the XML serialiser to make it easier to integrate custom data and custom node types
  • Combined some formatting options (removing some template selectors from the IDiagramFormatter interface)
  • Some changes to flow diagram node types
  • Some breaking changes to the Flow Diagrams and Star Diagrams XML serialisation format


Introduction

Mindscape WPF Diagramming
Introduction

Getting Started with WPF Diagrams

In this walkthrough, we will build a simple diagramming application using Mindscape WPF Diagrams. Users can place a number of simple shapes on the diagram, and connect them together using various styles of connector.

This tutorial will illustrate:

  • How to display a diagram.
  • How to enable editing of the diagram.
  • How to save and load diagrams.
  • How to print diagrams or export them for use in other applications.

To begin, open Visual Studio 2008 and create a new project of type WPF Application.

Next: Referencing the Diagramming Controls.


Referencing the Diagramming Controls

Referencing the Diagramming Controls

The first thing we need to do is reference the diagramming controls.

If you prefer to use the Visual Studio WPF design surface:

  • Open the Toolbox.
  • Open the Mindscape tab.
  • Drag the DiagramSurface icon from the Toolbox onto the designer window.
  • In Solution Explorer, open the Properties folder and verify that Visual Studio has created a file named licenses.licx.

If you prefer to use the XAML editor, or if you do not see a toolbox icon, or if Visual Studio does not create a licenses.licx file:

  • Add references to the Mindscape.WpfDiagramming.Foundation assembly.
  • Copy licenses.licx from the Samples directory into your project’s Properties directory.
  • In Solution Explorer, choose View Hidden Files, open the project’s Properties folder, right-click licenses.licx and choose Include in Project. Check that the Build Action is set to Embedded Resource.

Next: Creating the Diagram Surface.


Creating the Diagram Surface

Creating the Diagram Surface

The DiagramSurface control is the starting point for all WPF Diagrams applications. A DiagramSurface is responsible for the display of a diagram.

If you are using the visual designer, you can create a DiagramSurface by dragging and dropping from the Toolbox. For this walkthrough, we recommend creating a DockPanel first and adding the DiagramSurface to that.

If you are using the XAML editor, you can create a DiagramSurface as follows:

  • Add the namespace declaration xmlns:ms=”http://namespaces.mindscape.co.nz/wpf” to the Window element.
  • Replace the Grid element inside the Window with a DockPanel element.
  • Inside the DockPanel, add the following declaration:
CopyCreating a diagram surface
<ms:DiagramSurface Name="ds" />

Our application is going to use the built-in shapes and styles, so we also need to reference those shapes and styles by importing the DiagramShapes resource dictionary. Add the following to your Window.Resources section:

CopyImporting common diagramming resources
<Window.Resources>
  <ResourceDictionary>
    <ResourceDictionary.MergedDictionaries>
      <ms:DiagramShapes />
    </ResourceDictionary.MergedDictionaries>
  </ResourceDictionary>
</Window.Resources>

This is sufficient to create the DiagramSurface, but if you run the application now, it won’t display anything, because the diagram doesn’t contain anything to be displayed. In the next step, we’ll add some simple shapes to the diagram.

Next: Adding Nodes to the Diagram.


Adding Nodes to the Diagram

Adding Nodes to the Diagram

We have now implemented a DiagramSurface control. Now we need to add something to the diagram to be displayed.

In this step, we’ll add some elements to the diagram programmatically, just to get started. In a future step, we’ll provide a toolbox so the user can add their own elements to the diagram.

WPF Diagrams distinguishes between the DiagramSurface, the control on which a diagram is displayed, and the diagram model itself, which is represented by the DiagramSurface.Diagram property. When you add, remove or change diagram elements, you always work with the diagram model, not with the visual controls.

When you create a DiagramSurface, it has a default blank diagram. You can assign your own diagram, or modify the blank one. For the walkthrough, we’ll modify the blank diagram; you might assign your own diagram if you create a diagram from a business object, or load a diagram from a file or database.

To add nodes to the blank diagram, we just add ShapeNode objects to its Nodes to collection. We can do this in the window constructor, after the call to InitializeComponent. A ShapeNode needs to know two things: the kind of shape to display (which you can get from the DiagramShapes class), and the position and size of the shape, expressed as a boundary rectangle.

CopyAdding nodes to the diagram
ds.Diagram.Nodes.Add(new ShapeNode { Shape = DiagramShapes.Rectangle, Bounds = new Rect(20, 20, 80, 140) });
ds.Diagram.Nodes.Add(new ShapeNode { Shape = DiagramShapes.Ellipse, Bounds = new Rect(120, 120, 150, 70) });

At this point we can run up the application and see the two shapes, the rectangle and the ellipse. However, these shapes are displayed using WPF Diagrams’s default appearance, and we’d like to be able to override this to suit our application. We’ll see how to do this in the next step.

Next: Defining the Display Style.


Customising the Display Style

Customising the Display Style

Our diagram surface is now displaying content using a default built-in style. However, many applications will have their own visual themes so it’s worth knowing how to do this.

Creating the Style

The visual style for shape nodes is specified as a standard WPF Style object, with a TargetType of Path. For this walkthrough we will use a simple flat-color style.

CopyThe style for shape nodes
<Style x:Key="ShapeNodePathStyle" TargetType="Path">
  <Setter Property="Stroke" Value="Navy" />
  <Setter Property="StrokeThickness" Value="1" />
  <Setter Property="Fill" Value="LightSteelBlue" />
  <Setter Property="Stretch" Value="Fill" />
</Style>

Wiring up the Style

For full control over the diagram display style, we would need to supply a diagram formatter object. However, for a diagram based only on shapes, we can skip this step because the DiagramSurface will use a default formatter. Instead, we can use the ShapeTool helper class to wire up the shape node style directly on the DiagramSurface.

CopyWiring up the style to the DiagramSurface
<ms:DiagramSurface Name="ds"
                   ms:ShapeTool.ShapePathStyle="{StaticResource ShapeNodePathStyle}"
                   />

Now we can add shape nodes to our diagram and have them displayed in our chosen style. Of course, we really want the user to be able to add items to the diagram, rather than adding items ourselves through code. So the next step is to add a toolbox.

Next: Adding a Toolbox.


Adding a Toolbox

Adding a Toolbox

We can now write code to display diagrams, but we don’t yet have a way for users to add their own shapes to the diagram. Of course we could hook up our existing node adding code to a custom user interface, but WPF Diagramming provides a built-in toolbox control which automatically displays the correct icons, supports both dragging and charged cursor modes, and provides grouping and filtering for large toolboxes.

A DiagramToolBox control contains a set of DiagramToolBoxGroup entries, each of which in turn contains a set of tools. For creating nodes, the tools are of type DiagranNodeTool. DiagramNodeTool is a pretty flexible class, but for shapes we don’t need all its flexibility. Instead, we will use the ShapeTool class to associate each DiagramNodeTool with a shape.

CopyA minimal diagramming toolbox
<ms:DiagramToolBox>
  <ms:DiagramToolBoxGroup Header="Rectangles">
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Rectangle" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="RoundedRectangle" />
  </ms:DiagramToolBoxGroup>
  <ms:DiagramToolBoxGroup Header="Basic Shapes">
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Ellipse" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Parallelogram" />
    <ms:DiagramNodeTool ms:ShapeTool.Shape="Hexagon" />
  </ms:DiagramToolBoxGroup>
</ms:DiagramToolBox>

As on the DiagramSurface, we need to tell the DiagramToolBox how to display the tool icons. Again, the ShapeTool class provides a handy shortcut, which we can apply in exactly the same way as we did on the DiagramSurface:

CopyA minimal diagramming toolbox
<ms:DiagramToolBox ms:ShapeTool.ShapePathStyle="{StaticResource ShapeNodePathStyle}">
  <!-- as before -->
</ms:DiagramToolBox>

(In this case we are using the same style in the toolbox as we do for display on the DiagramSurface, but you can create a different style, for example if your toolbox has a distinctive color scheme.)

Finally, we need to specify the size and layout of tool icons. Again, this is done using a style. In this case the simplest approach is to override the DiagramNodeTool defaults by providing a type-level style:

CopyA minimal diagramming toolbox
<ms:DiagramToolBox ms:ShapeTool.ShapePathStyle="{StaticResource ShapeNodePathStyle}">
  <ms:DiagramToolBox.Resources>
    <Style TargetType="ms:DiagramNodeTool">
      <Setter Property="Margin" Value="10" />
      <Setter Property="Width" Value="40" />
      <Setter Property="Height" Value="30" />
    </Style>
  </ms:DiagramToolBox.Resources>
  <!-- as before -->
</ms:DiagramToolBox>

Our node toolbox is now complete. If you run the application now, you will find that you can drag nodes on from the toolbox, or click toolbox icons then click and drag on the DiagramSurface to create nodes. Note also the collapsible groups and the filter option that the toolbox gives you. And of course you can add more shapes from the DiagramShapes class to the toolbox, just by creating more DiagramNodeTool objects.

However, at this stage we still haven’t seen how to show relationships between shapes. To remedy that, we need to introduce a new kind of element: connections.

Next: Defining the Connection Display Style.


Defining the Connection Display Style

Defining the Connection Display Style

Relationships between diagram elements are represented as connections. In the diagram model, these are represented by the DiagramConnection class. The Diagram class has a Connections collection to which you can add connections programmatically, or the user can add connections using the mouse.

Although we haven’t done anything to implement connection support, our simple diagramming application already allows users to create connections. When the user selects a shape, it displays a number of connection points. The user can drag a connection point to another connection point (on the same or another shape) to create a connection.

At the moment the connection uses a built-in style. This is consistent with the default node style, but can be overridden by defining a style with the key DiagramLineTypes.DefaultDiagramConnectionStyleKey:

CopyOverriding the default connection style
<Style x:Key="{x:Static ms:DiagramLineTypes.DefaultDiagramConnectionStyleKey}" TargetType="Path">
  <Setter Property="Stroke" Value="Red" />
  <Setter Property="StrokeThickness" Value="2" />
</Style>

If your application uses lines with arrows, you’ll probably also want to override the arrowhead style. To do this, define a Style whose key is DiagramArrowheadTypes.DefaultArrowheadPathStyleKey:

CopyOverriding the default arrowhead path style
<Style x:Key="{x:Static ms:DiagramArrowheadTypes.DefaultArrowheadPathStyleKey}" TargetType="Path">
  <Setter Property="Fill" Value="Yellow" />
  <Setter Property="StrokeThickness" Value="1" />
  <Setter Property="Stroke" Value="Goldenrod" />
</Style>

Now we need to provide users with a way to create different kinds of connection. We will address this in the next topic.

Next: Adding Connections to the Toolbox.


Adding Connections to the Toolbox

Adding Connections to the Toolbox

We have seen that users can automatically create connections by dragging the mouse from one connection point to another, but that this creates a ‘default’ line. We need to give users a way of creating other line types, such as routed lines or lines with arrows at their ends. This is most easily done by adding connection tools to our existing toolbox.

WPF Diagrams defines a number of built-in line types, and you can specify these as toolbox entries by creating a DiagramConnectionTool and setting the ConnectionTool.LineType attached property:

CopyXML
<ms:DiagramToolBoxGroup Header="Lines">
  <ms:DiagramConnectionTool ms:ConnectionTool.LineType="Straight" />
  <ms:DiagramConnectionTool ms:ConnectionTool.LineType="StraightArrow" />
  <ms:DiagramConnectionTool ms:ConnectionTool.LineType="StraightDoubleArrow" />
  <ms:DiagramConnectionTool ms:ConnectionTool.LineType="Elbow" />
  <ms:DiagramConnectionTool ms:ConnectionTool.LineType="ElbowArrow" />
  <ms:DiagramConnectionTool ms:ConnectionTool.LineType="ElbowDoubleArrow" />
</ms:DiagramToolBoxGroup>

Now the user can click a line type in the toolbox and drag between two connection points, and the resulting line will have the appropriate routing and arrows.

Next: Loading and Saving.


Loading and Saving Diagrams

Loading and Saving Diagrams

Most users will want to be able to save and re-load their diagrams. Because you have full access to the Diagram model, you can write your own code to load and save diagrams however you like. This allows you to persist using existing file formats, or as a relational model in a database. And if you are using the Diagram class as a view model over a business object, you would just store the business object and reconstruct the Diagram object on demand.

However, if you don’t have specific requirements for persistence, you can easily load and save diagrams as XML using the DiagramXmlSerializer.

Add a toolbar to your application as follows:

CopyXML
<ToolBar DockPanel.Dock="Top">
  <!-- Commands would be better here but we will use Click for simplicity -->
  <Button Name="OpenCmd" Click="OpenCmd_Click">Open</Button>
  <Button Name="SaveCmd" Click="SaveCmd_Click">Save</Button>
</ToolBar>

Here is the code for loading a diagram from a file:

CopyOpening a diagram from an XML file
private void OpenCmd_Click(object sender, RoutedEventArgs e)
{
  OpenFileDialog dlg = new OpenFileDialog();
  dlg.InitialDirectory = ProjectFolder;
  dlg.Multiselect = false;
  dlg.Filter = "XML files (*.xml)|*.xml|All files (*.*)|*.*";

  if (dlg.ShowDialog() ?? false)
  {
    DiagramXmlSerializer ser = new DiagramXmlSerializer();
    XDocument document = XDocument.Load(dlg.FileName);
    ds.Diagram = ser.Deserialize(document);
  }
}

Most of this code is just getting the filename and setting up a XmlReader over the file. The important lines are the last three:

CopyOpening a diagram from an XML file
DiagramXmlSerializer ser = new DiagramXmlSerializer();
XDocument document = XDocument.Load(dlg.FileName);
ds.Diagram = ser.Deserialize(document);

The code for saving a diagram to a file is similar, except it of course uses a SaveFileDialog and an XmlWriter, and calls the Serialize method instead of Deserialize:

CopyC#
DiagramXmlSerializer ser = new DiagramXmlSerializer();
XDocument document = ser.Serialize((Diagram)(ds.Diagram));
document.Save(dlg.FileName);

(In real world applications you would typically have a reference to the Diagram so you would not need the cast.)

We can now persist diagrams, but what if we need to exchange them with people who do not have access to our diagramming application? WPF Diagrams supports two ways of doing this: printing and exporting to bitmap.

Next: Printing the Diagram.


Printing the Diagram

Printing the Diagram

To print a diagram, use the DiagramPrinter class. This provides you with a DiagramPrintDocument which in turn yields a WPF FixedDocument which can be passed to an XpsDocumentWriter.

You’ll need to reference the System.Printing and ReachFramework DLLs to get printing support for your application.

Here’s the basic code to print a diagram using a user-selected printer:

CopyC#
PrintDocumentImageableArea imageableArea = null;
// This prompts the user to select a printer
XpsDocumentWriter writer = PrintQueue.CreateXpsDocumentWriter("demo", ref imageableArea);
if (writer != null)
{
  DiagramPrinter printer = new DiagramPrinter
  {
    Diagram = ds.Diagram,
    Formatter = ds.Formatter,
    Zoom = 1.5
  };

  DiagramPrintDocument doc = printer.GetPrintDocument(imageableArea);

  writer.Write(doc.Document);
}

The DiagramPrinter must be supplied with a diagram and a formatter just as a DiagramSurface must be. In this case, we just reference the diagram and formatter on the DiagramSurface, because we want the printout to look like the display, but we could have used a different formatter specialised for printing, or we could print a diagram without ever displaying it at all.

What if you want to share diagrams electronically, for example via email or the Web? One option is to print to an XPS file, but for most applications it’s easier to export to a bitmap file. We’ll see how to do that next.

Next: Exporting to a Bitmap.


Exporting to a Bitmap

Exporting to a Bitmap

If you want to email a diagram, or embed it in a Web page or Office document, the most convenient format is a bitmap. WPF Diagrams supports exporting diagrams to PNG, JPEG and BMP format out of the box, and can be easily extended to support other formats such as GIF or TIFF.

The key class for bitmap exports is the DiagramBitmapRenderer. Here’s how to use it for exporting to PNG:

CopyC#
DiagramBitmapRenderer.Png.Render(ds, filename);

This concludes our introduction to the WPF Diagrams library. See the QuickStart sample for full code. You are now ready to build your own applications, or to go on and look at the other samples to get an idea of the built-in options or learn how to customise the diagrams to your own application needs.


API Reference

[image]

Mindscape WPF Diagrams
API Reference
Send Feedback
Contains controls and models for Windows Presentation Foundation diagrams.

Namespaces

Namespace | Description
Mindscape.WpfDiagramming | Contains diagramming classes for Windows Presentation Foundation
Mindscape.WpfDiagramming.FlowDiagrams | Contains classes for displaying and editing flow diagrams.
Mindscape.WpfDiagramming.FlowDiagrams.Styles | Contains standard flow diagram visual styles.
Mindscape.WpfDiagramming.Foundation | Contains low-level diagramming primitives.
Mindscape.WpfDiagramming.StarDiagrams | Contains classes for displaying and editing star diagrams.
Mindscape.WpfDiagramming.StarDiagrams.Styles | Contains standard star diagram visual styles.


Mindscape.WpfDiagramming Namespace

[image]

Mindscape WPF Diagrams
Mindscape.WpfDiagramming Namespace
Send Feedback
Contains diagramming classes for Windows Presentation Foundation

Classes

Class | Description
CommentNode | Displays a comment on the diagram.
ConnectionTool | Provides attached properties which configure a DiagramConnectionTool to create connections of a specified DiagramLineType.
ContentMargin | Controls the positioning of the content on a DiagramShape.
Diagram | Represents a standard shape diagram.
DiagramArrowheadType | Identifies a type of arrowhead.
DiagramArrowheadTypes | Identifies standard arrowhead types.
DiagramBitmapRenderer | Renders a diagram as a bitmap.
DiagramCommands | Provides a standard set of diagram-related commands.
DiagramConnection | Represents a connection on a standard shape diagram.
DiagramConnectionPoint | Represents a point at which a connection connects to a source or destination in a standard shape diagram.
DiagramConnectionStyleSelector | Selects a style for a DiagramConnection using the LineTypeLayout resource whose key is the DiagramConnection.LineType.
DiagramConnectionTool | Represents a control which, when selected, puts the cursor into "draw connection" mode.
DiagramFormatter | Specifies how a IDiagramModel should be displayed on a DiagramSurface.
DiagramLineType | Identifies a type of line.
DiagramLineTypes | Identifies standard line types.
DiagramNode | Represents a node in a standard shape diagram.
DiagramNodeTool | Represents a control which can be dragged from a toolbox onto a DiagramSurface to create new diagram nodes.
DiagramNodeToolDroppedEventArgs | Provides information about the DiagramNodeToolDropped event of a DiagramNodeTool control.
DiagramPrinter | Provides support for printing diagrams.
DiagramShape | Represents a geometrical shape in a diagram.
DiagramShapes | Contains standard shapes for use in diagrams.
DiagramSurface | Represents the surface on which a diagram is displayed.
DiagramToolBox | Displays diagram tools and provides various filtering options.
DiagramToolBoxGroup | Groups together a collection of related diagram tools.
DiagramXmlSerializer | Serializes and deserializes Diagram objects as XML.
EdgeHelper | Provides utility methods for working with Edge values.
LineTypeLayout | Specifies how to display a DiagramLineType.
MarqueeDragCompletedEventArgs | Provides information about the MarqueeDragCompleted event of a DiagramSurface.
MarqueeDragStartedEventArgs | Provides information about the MarqueeDragStarted event of a DiagramSurface.
ShapeConnectionPointPosition | Specifies the location of a connection point on a DiagramShape.
ShapeLayout | Specifies how to display a DiagramShape.
ShapeNode | Represents a node in a diagram that displays a geometric shape.
ShapeNodeStyleSelector | Selects a style for a ShapeNode using the ShapeLayout resource whose key is the ShapeNode object.
ShapeTool | Provides attached properties which configure a DiagramNodeTool to create nodes of a specified DiagramShape.
TitleNode | Displays a title on the diagram, with optional pre-title and subtitle text.

Enumerations

Enumeration | Description
Edge | Identifies the edge of an element.
OverflowBehavior | Specifies the behavior of a DiagramSurface when the diagram is too big for the control to display.
ToolboxIconStyle | When applied to a Path in ToolboxIconPaths, specifies how the path should be styled if no explicit style is specified.
ZoomMode | Specifies the zooming behavior of a DiagramSurface.


CommentNode Class

[image]

Mindscape WPF Diagrams
CommentNode Class
Members See Also Send Feedback
Displays a comment on the diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class CommentNode : DiagramNode
Visual Basic (Declaration)
Public Class CommentNode _
    Inherits DiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming..::.CommentNode

See Also

CommentNode Members
Mindscape.WpfDiagramming Namespace


CommentNode Members

[image] [image]

Mindscape WPF Diagrams
CommentNode Members
CommentNode Class Constructors Methods Fields Properties Events See Also Send Feedback

The CommentNode type exposes the following members.

Constructors

Name | Description
CommentNode |

Methods

Name | Description
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

Fields

Name | Description
DefaultBuilder | Gets an IDiagramNodeBuilder that a toolbox item can use to construct CommentNode objects.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false. A CommentNode can not originate any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. A CommentNode can not receive any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


CommentNode Constructor

[image]

Mindscape WPF Diagrams
CommentNode Constructor
CommentNode Class See Also Send Feedback
Initializes a new instance of the CommentNode class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CommentNode()
Visual Basic (Declaration)
Public Sub New

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


CommentNode Fields

[image] [image]

Mindscape WPF Diagrams
CommentNode Fields
CommentNode Class See Also Send Feedback

The CommentNode type exposes the following members.

Fields

Name | Description
DefaultBuilder | Gets an IDiagramNodeBuilder that a toolbox item can use to construct CommentNode objects.

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


DefaultBuilder Field

[image]

Mindscape WPF Diagrams
CommentNode..::.DefaultBuilder Field
CommentNode Class See Also Send Feedback
Gets an IDiagramNodeBuilder that a toolbox item can use to construct CommentNode objects.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly IDiagramNodeBuilder DefaultBuilder
Visual Basic (Declaration)
Public Shared ReadOnly DefaultBuilder As IDiagramNodeBuilder

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


CommentNode Methods

[image] [image]

Mindscape WPF Diagrams
CommentNode Methods
CommentNode Class See Also Send Feedback

The CommentNode type exposes the following members.

Methods

Name | Description
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


Clone Method

[image]

Mindscape WPF Diagrams
CommentNode..::.Clone Method
CommentNode Class See Also Send Feedback
Gets an IDiagramNodeState that represents the current state of this node at the time this method is called.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IDiagramNodeState Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As IDiagramNodeState

Return Value

An IDiagramNodeState that represents the current state of this node.

Implements

IDiagramNode..::.Clone()()()

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


SetAs Method

[image]

Mindscape WPF Diagrams
CommentNode..::.SetAs Method
CommentNode Class See Also Send Feedback
Sets all the properties of this node to match those of the given IDiagramNodeState.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void SetAs(
    IDiagramNodeState state
)
Visual Basic (Declaration)
Public Overrides Sub SetAs ( _
    state As IDiagramNodeState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNodeState
The IDiagramNodeState that will have its property values applied to this node.

Implements

IDiagramNode..::.SetAs(IDiagramNodeState)

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


CommentNode Properties

[image] [image]

Mindscape WPF Diagrams
CommentNode Properties
CommentNode Class See Also Send Feedback

The CommentNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false. A CommentNode can not originate any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. A CommentNode can not receive any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
CommentNode..::.CanOriginateNewConnections Property
CommentNode Class See Also Send Feedback
Returns false. A CommentNode can not originate any connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
CommentNode..::.CanReceiveNewConnections Property
CommentNode Class See Also Send Feedback
Returns false. A CommentNode can not receive any connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

CommentNode Class
Mindscape.WpfDiagramming Namespace


ConnectionTool Class

[image]

Mindscape WPF Diagrams
ConnectionTool Class
Members See Also Send Feedback
Provides attached properties which configure a DiagramConnectionTool to create connections of a specified DiagramLineType.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class ConnectionTool
Visual Basic (Declaration)
Public NotInheritable Class ConnectionTool

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.ConnectionTool

See Also

ConnectionTool Members
Mindscape.WpfDiagramming Namespace


ConnectionTool Members

[image] [image]

Mindscape WPF Diagrams
ConnectionTool Members
ConnectionTool Class Methods Fields See Also Send Feedback

The ConnectionTool type exposes the following members.

Methods

Name | Description
GetArrowPathStyle | Gets the Style to be applied to the path that represents an arrow on a line type in a DiagramConnectionTool.
GetConnectionPathStyle | Gets the Style to be applied to the path that represents a line type in a DiagramConnectionTool.
GetLineType | Gets the DiagramLineType for this DiagramConnectionTool.
SetArrowPathStyle | Sets the Style to be applied to the path that represents an arrow on a line type in a DiagramConnectionTool.
SetConnectionPathStyle | Sets the Style to be applied to the path that represents a line type in a DiagramConnectionTool.
SetLineType | Sets the DiagramLineType for this DiagramConnectionTool.

Fields

Name | Description
ArrowPathStyleProperty | Identifies the ConnectionPathStyle attached property.
ConnectionPathStyleProperty | Identifies the ConnectionPathStyle attached property.
LineTypeProperty | Identifies the LineType attached property.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


ConnectionTool Fields

[image] [image]

Mindscape WPF Diagrams
ConnectionTool Fields
ConnectionTool Class See Also Send Feedback

The ConnectionTool type exposes the following members.

Fields

Name | Description
ArrowPathStyleProperty | Identifies the ConnectionPathStyle attached property.
ConnectionPathStyleProperty | Identifies the ConnectionPathStyle attached property.
LineTypeProperty | Identifies the LineType attached property.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


ArrowPathStyleProperty Field

[image]

Mindscape WPF Diagrams
ConnectionTool..::.ArrowPathStyleProperty Field
ConnectionTool Class See Also Send Feedback
Identifies the ConnectionPathStyle attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ArrowPathStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ArrowPathStyleProperty As DependencyProperty

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


ConnectionPathStyleProperty Field

[image]

Mindscape WPF Diagrams
ConnectionTool..::.ConnectionPathStyleProperty Field
ConnectionTool Class See Also Send Feedback
Identifies the ConnectionPathStyle attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionPathStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionPathStyleProperty As DependencyProperty

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


LineTypeProperty Field

[image]

Mindscape WPF Diagrams
ConnectionTool..::.LineTypeProperty Field
ConnectionTool Class See Also Send Feedback
Identifies the LineType attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty LineTypeProperty
Visual Basic (Declaration)
Public Shared ReadOnly LineTypeProperty As DependencyProperty

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


ConnectionTool Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionTool Methods
ConnectionTool Class See Also Send Feedback

The ConnectionTool type exposes the following members.

Methods

Name | Description
GetArrowPathStyle | Gets the Style to be applied to the path that represents an arrow on a line type in a DiagramConnectionTool.
GetConnectionPathStyle | Gets the Style to be applied to the path that represents a line type in a DiagramConnectionTool.
GetLineType | Gets the DiagramLineType for this DiagramConnectionTool.
SetArrowPathStyle | Sets the Style to be applied to the path that represents an arrow on a line type in a DiagramConnectionTool.
SetConnectionPathStyle | Sets the Style to be applied to the path that represents a line type in a DiagramConnectionTool.
SetLineType | Sets the DiagramLineType for this DiagramConnectionTool.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


GetArrowPathStyle Method

[image]

Mindscape WPF Diagrams
ConnectionTool..::.GetArrowPathStyle Method
ConnectionTool Class See Also Send Feedback
Gets the Style to be applied to the path that represents an arrow on a line type in a DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Style GetArrowPathStyle(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetArrowPathStyle ( _
    obj As DependencyObject _
) As Style

Parameters

obj
Type: System.Windows..::.DependencyObject
The DiagramConnectionTool or container from which the property value is read.

Return Value

The value of the ArrowPathStyle attached property on the specified object.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


GetConnectionPathStyle Method

[image]

Mindscape WPF Diagrams
ConnectionTool..::.GetConnectionPathStyle Method
ConnectionTool Class See Also Send Feedback
Gets the Style to be applied to the path that represents a line type in a DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Style GetConnectionPathStyle(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetConnectionPathStyle ( _
    obj As DependencyObject _
) As Style

Parameters

obj
Type: System.Windows..::.DependencyObject
The DiagramConnectionTool or container from which the property value is read.

Return Value

The value of the ConnectionPathStyle attached property on the specified object.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


GetLineType Method

[image]

Mindscape WPF Diagrams
ConnectionTool..::.GetLineType Method
ConnectionTool Class See Also Send Feedback
Gets the DiagramLineType for this DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static DiagramLineType GetLineType(
    DiagramConnectionTool obj
)
Visual Basic (Declaration)
Public Shared Function GetLineType ( _
    obj As DiagramConnectionTool _
) As DiagramLineType

Parameters

obj
Type: Mindscape.WpfDiagramming..::.DiagramConnectionTool
The element from which the property value is read.

Return Value

The DiagramLineType of the specified DiagramConnectionTool.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


SetArrowPathStyle Method

[image]

Mindscape WPF Diagrams
ConnectionTool..::.SetArrowPathStyle Method
ConnectionTool Class See Also Send Feedback
Sets the Style to be applied to the path that represents an arrow on a line type in a DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetArrowPathStyle(
    DependencyObject obj,
    Style value
)
Visual Basic (Declaration)
Public Shared Sub SetArrowPathStyle ( _
    obj As DependencyObject, _
    value As Style _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The DiagramConnectionTool or container to which the property value is written.
value
Type: System.Windows..::.Style
The value of the ArrowPathStyle attached property on the specified object.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


SetConnectionPathStyle Method

[image]

Mindscape WPF Diagrams
ConnectionTool..::.SetConnectionPathStyle Method
ConnectionTool Class See Also Send Feedback
Sets the Style to be applied to the path that represents a line type in a DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetConnectionPathStyle(
    DependencyObject obj,
    Style value
)
Visual Basic (Declaration)
Public Shared Sub SetConnectionPathStyle ( _
    obj As DependencyObject, _
    value As Style _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The DiagramConnectionTool or container to which the property value is written.
value
Type: System.Windows..::.Style
The value of the ConnectionPathStyle attached property on the specified object.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


SetLineType Method

[image]

Mindscape WPF Diagrams
ConnectionTool..::.SetLineType Method
ConnectionTool Class See Also Send Feedback
Sets the DiagramLineType for this DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetLineType(
    DiagramConnectionTool obj,
    DiagramLineType value
)
Visual Basic (Declaration)
Public Shared Sub SetLineType ( _
    obj As DiagramConnectionTool, _
    value As DiagramLineType _
)

Parameters

obj
Type: Mindscape.WpfDiagramming..::.DiagramConnectionTool
The element to which the property value is written.
value
Type: Mindscape.WpfDiagramming..::.DiagramLineType
The DiagramLineType of the specified DiagramConnectionTool.

See Also

ConnectionTool Class
Mindscape.WpfDiagramming Namespace


ContentMargin Class

[image]

Mindscape WPF Diagrams
ContentMargin Class
Members See Also Send Feedback
Controls the positioning of the content on a DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ContentMargin
Visual Basic (Declaration)
Public Class ContentMargin

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.ContentMargin

See Also

ContentMargin Members
Mindscape.WpfDiagramming Namespace


ContentMargin Members

[image] [image]

Mindscape WPF Diagrams
ContentMargin Members
ContentMargin Class Constructors Properties See Also Send Feedback

The ContentMargin type exposes the following members.

Constructors

Name | Description
ContentMargin |

Properties

Name | Description
Bottom | Gets or sets the margin below the content.
Left | Gets or sets the margin to the left of the content.
Right | Gets or sets the margin to the right of the content.
Top | Gets or sets the margin above the content.

See Also

ContentMargin Class
Mindscape.WpfDiagramming Namespace


ContentMargin Constructor

[image]

Mindscape WPF Diagrams
ContentMargin Constructor
ContentMargin Class See Also Send Feedback
Initializes a new instance of the ContentMargin class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ContentMargin()
Visual Basic (Declaration)
Public Sub New

See Also

ContentMargin Class
Mindscape.WpfDiagramming Namespace


ContentMargin Properties

[image] [image]

Mindscape WPF Diagrams
ContentMargin Properties
ContentMargin Class See Also Send Feedback

The ContentMargin type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the margin below the content.
Left | Gets or sets the margin to the left of the content.
Right | Gets or sets the margin to the right of the content.
Top | Gets or sets the margin above the content.

See Also

ContentMargin Class
Mindscape.WpfDiagramming Namespace


Bottom Property

[image]

Mindscape WPF Diagrams
ContentMargin..::.Bottom Property
ContentMargin Class See Also Send Feedback
Gets or sets the margin below the content.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public GridLength Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As GridLength

See Also

ContentMargin Class
Mindscape.WpfDiagramming Namespace


Left Property

[image]

Mindscape WPF Diagrams
ContentMargin..::.Left Property
ContentMargin Class See Also Send Feedback
Gets or sets the margin to the left of the content.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public GridLength Left { get; set; }
Visual Basic (Declaration)
Public Property Left As GridLength

See Also

ContentMargin Class
Mindscape.WpfDiagramming Namespace


Right Property

[image]

Mindscape WPF Diagrams
ContentMargin..::.Right Property
ContentMargin Class See Also Send Feedback
Gets or sets the margin to the right of the content.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public GridLength Right { get; set; }
Visual Basic (Declaration)
Public Property Right As GridLength

See Also

ContentMargin Class
Mindscape.WpfDiagramming Namespace


Top Property

[image]

Mindscape WPF Diagrams
ContentMargin..::.Top Property
ContentMargin Class See Also Send Feedback
Gets or sets the margin above the content.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public GridLength Top { get; set; }
Visual Basic (Declaration)
Public Property Top As GridLength

See Also

ContentMargin Class
Mindscape.WpfDiagramming Namespace


Diagram Class

[image]

Mindscape WPF Diagrams
Diagram Class
Members See Also Send Feedback
Represents a standard shape diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Diagram : DiagramModelBase<DiagramNode, DiagramConnection>
Visual Basic (Declaration)
Public Class Diagram _
    Inherits DiagramModelBase(Of DiagramNode, DiagramConnection)

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DiagramModelBase <(Of <( DiagramNode, DiagramConnection >)>)
Mindscape.WpfDiagramming..::.Diagram
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramModel
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramModel

See Also

Diagram Members
Mindscape.WpfDiagramming Namespace


Diagram Members

[image] [image]

Mindscape WPF Diagrams
Diagram Members
Diagram Class Constructors Properties See Also Send Feedback

The Diagram type exposes the following members.

Constructors

Name | Description
Diagram | Initializes a new instance of the Diagram class.

Properties

Name | Description
ConnectionRelocator | Gets or sets the IDiagramConnectionRelocator for relocating connections in the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
ConnectionRemover | Gets or sets the IDiagramConnectionRemover for removing connections from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Connections | Gets the connections of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
CustomItems | Gets null. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
DefaultConnectionBuilder | Gets or sets the default IDiagramConnectionBuilder for building diagram connections. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
NodeRemover | Gets or sets the IDiagramNodeRemover for removing nodes from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Nodes | Gets the nodes of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Source | Gets the business object represented by the diagram. For the Diagram class this is always null. (Overrides DiagramModelBase <(Of <( DiagramNode, DiagramConnection >)>)..::. Source.)

See Also

Diagram Class
Mindscape.WpfDiagramming Namespace


Diagram Constructor

[image]

Mindscape WPF Diagrams
Diagram Constructor
Diagram Class See Also Send Feedback
Initializes a new instance of the Diagram class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Diagram()
Visual Basic (Declaration)
Public Sub New

See Also

Diagram Class
Mindscape.WpfDiagramming Namespace


Diagram Properties

[image] [image]

Mindscape WPF Diagrams
Diagram Properties
Diagram Class See Also Send Feedback

The Diagram type exposes the following members.

Properties

Name | Description
ConnectionRelocator | Gets or sets the IDiagramConnectionRelocator for relocating connections in the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
ConnectionRemover | Gets or sets the IDiagramConnectionRemover for removing connections from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Connections | Gets the connections of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
CustomItems | Gets null. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
DefaultConnectionBuilder | Gets or sets the default IDiagramConnectionBuilder for building diagram connections. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
NodeRemover | Gets or sets the IDiagramNodeRemover for removing nodes from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Nodes | Gets the nodes of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Source | Gets the business object represented by the diagram. For the Diagram class this is always null. (Overrides DiagramModelBase <(Of <( DiagramNode, DiagramConnection >)>)..::. Source.)

See Also

Diagram Class
Mindscape.WpfDiagramming Namespace


Source Property

[image]

Mindscape WPF Diagrams
Diagram..::.Source Property
Diagram Class See Also Send Feedback
Gets the business object represented by the diagram. For the Diagram class this is always null.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override Object Source { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Source As Object

Implements

IDiagramModel..::.Source

See Also

Diagram Class
Mindscape.WpfDiagramming Namespace


DiagramArrowheadType Class

[image]

Mindscape WPF Diagrams
DiagramArrowheadType Class
Members See Also Send Feedback
Identifies a type of arrowhead.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramArrowheadType
Visual Basic (Declaration)
Public Class DiagramArrowheadType

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramArrowheadType

See Also

DiagramArrowheadType Members
Mindscape.WpfDiagramming Namespace


DiagramArrowheadType Members

[image] [image]

Mindscape WPF Diagrams
DiagramArrowheadType Members
DiagramArrowheadType Class Constructors Properties See Also Send Feedback

The DiagramArrowheadType type exposes the following members.

Constructors

Name | Description
DiagramArrowheadType | Initializes a new instance of the DiagramArrowheadType class.

Properties

Name | Description
Name | Gets the name of the arrowhead type.

See Also

DiagramArrowheadType Class
Mindscape.WpfDiagramming Namespace


DiagramArrowheadType Constructor

[image]

Mindscape WPF Diagrams
DiagramArrowheadType Constructor
DiagramArrowheadType Class See Also Send Feedback
Initializes a new instance of the DiagramArrowheadType class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramArrowheadType(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
The name of the line type.

See Also

DiagramArrowheadType Class
Mindscape.WpfDiagramming Namespace


DiagramArrowheadType Properties

[image] [image]

Mindscape WPF Diagrams
DiagramArrowheadType Properties
DiagramArrowheadType Class See Also Send Feedback

The DiagramArrowheadType type exposes the following members.

Properties

Name | Description
Name | Gets the name of the arrowhead type.

See Also

DiagramArrowheadType Class
Mindscape.WpfDiagramming Namespace


Name Property

[image]

Mindscape WPF Diagrams
DiagramArrowheadType..::.Name Property
DiagramArrowheadType Class See Also Send Feedback
Gets the name of the arrowhead type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

DiagramArrowheadType Class
Mindscape.WpfDiagramming Namespace


DiagramArrowheadTypes Class

[image]

Mindscape WPF Diagrams
DiagramArrowheadTypes Class
Members See Also Send Feedback
Identifies standard arrowhead types.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class DiagramArrowheadTypes
Visual Basic (Declaration)
Public NotInheritable Class DiagramArrowheadTypes

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramArrowheadTypes

See Also

DiagramArrowheadTypes Members
Mindscape.WpfDiagramming Namespace


DiagramArrowheadTypes Members

[image] [image]

Mindscape WPF Diagrams
DiagramArrowheadTypes Members
DiagramArrowheadTypes Class Fields Properties See Also Send Feedback

The DiagramArrowheadTypes type exposes the following members.

Fields

Name | Description
None | Represents no arrowhead.
Notched | Represents a notched arrowhead.

Properties

Name | Description
DefaultArrowheadPathStyleKey | Gets the ResourceKey for the Style for paths representing arrowheads.
DefaultArrowheadToolboxPathStyleKey | Gets the ResourceKey for the Style for paths representing arrowheads in a toolbox.

See Also

DiagramArrowheadTypes Class
Mindscape.WpfDiagramming Namespace


DiagramArrowheadTypes Fields

[image] [image]

Mindscape WPF Diagrams
DiagramArrowheadTypes Fields
DiagramArrowheadTypes Class See Also Send Feedback

The DiagramArrowheadTypes type exposes the following members.

Fields

Name | Description
None | Represents no arrowhead.
Notched | Represents a notched arrowhead.

See Also

DiagramArrowheadTypes Class
Mindscape.WpfDiagramming Namespace


None Field

[image]

Mindscape WPF Diagrams
DiagramArrowheadTypes..::.None Field
DiagramArrowheadTypes Class See Also Send Feedback
Represents no arrowhead.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramArrowheadType None
Visual Basic (Declaration)
Public Shared ReadOnly None As DiagramArrowheadType

See Also

DiagramArrowheadTypes Class
Mindscape.WpfDiagramming Namespace


Notched Field

[image]

Mindscape WPF Diagrams
DiagramArrowheadTypes..::.Notched Field
DiagramArrowheadTypes Class See Also Send Feedback
Represents a notched arrowhead.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramArrowheadType Notched
Visual Basic (Declaration)
Public Shared ReadOnly Notched As DiagramArrowheadType

See Also

DiagramArrowheadTypes Class
Mindscape.WpfDiagramming Namespace


DiagramArrowheadTypes Properties

[image] [image]

Mindscape WPF Diagrams
DiagramArrowheadTypes Properties
DiagramArrowheadTypes Class See Also Send Feedback

The DiagramArrowheadTypes type exposes the following members.

Properties

Name | Description
DefaultArrowheadPathStyleKey | Gets the ResourceKey for the Style for paths representing arrowheads.
DefaultArrowheadToolboxPathStyleKey | Gets the ResourceKey for the Style for paths representing arrowheads in a toolbox.

See Also

DiagramArrowheadTypes Class
Mindscape.WpfDiagramming Namespace


DefaultArrowheadPathStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramArrowheadTypes..::.DefaultArrowheadPathStyleKey Property
DiagramArrowheadTypes Class See Also Send Feedback
Gets the ResourceKey for the Style for paths representing arrowheads.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultArrowheadPathStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultArrowheadPathStyleKey As ComponentResourceKey

See Also

DiagramArrowheadTypes Class
Mindscape.WpfDiagramming Namespace


DefaultArrowheadToolboxPathStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramArrowheadTypes..::.DefaultArrowheadToolboxPathStyleKey Property
DiagramArrowheadTypes Class See Also Send Feedback
Gets the ResourceKey for the Style for paths representing arrowheads in a toolbox.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultArrowheadToolboxPathStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultArrowheadToolboxPathStyleKey As ComponentResourceKey

See Also

DiagramArrowheadTypes Class
Mindscape.WpfDiagramming Namespace


DiagramBitmapRenderer Class

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer Class
Members See Also Send Feedback
Renders a diagram as a bitmap.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DiagramBitmapRenderer
Visual Basic (Declaration)
Public MustInherit Class DiagramBitmapRenderer

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramBitmapRenderer

See Also

DiagramBitmapRenderer Members
Mindscape.WpfDiagramming Namespace


DiagramBitmapRenderer Members

[image] [image]

Mindscape WPF Diagrams
DiagramBitmapRenderer Members
DiagramBitmapRenderer Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramBitmapRenderer type exposes the following members.

Constructors

Name | Description
DiagramBitmapRenderer | Initializes a new instance of the DiagramBitmapRenderer class.

Methods

Name | Description
Render | Overloaded.

Fields

Name | Description
Bmp | Renders a diagram using the BMP bitmap format.
Jpeg | Renders a diagram using the JPEG bitmap format.
Png | Renders a diagram using the PNG bitmap format.

Properties

Name | Description
BitmapEncoder | When overridden in a derived class, gets the BitmapEncoder used to encode the rendered bitmap.
PixelFormat | Gets the PixelFormat of the rendered bitmap. The default is Pbgra32.

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


DiagramBitmapRenderer Constructor

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer Constructor
DiagramBitmapRenderer Class See Also Send Feedback
Initializes a new instance of the DiagramBitmapRenderer class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramBitmapRenderer()
Visual Basic (Declaration)
Protected Sub New

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


DiagramBitmapRenderer Fields

[image] [image]

Mindscape WPF Diagrams
DiagramBitmapRenderer Fields
DiagramBitmapRenderer Class See Also Send Feedback

The DiagramBitmapRenderer type exposes the following members.

Fields

Name | Description
Bmp | Renders a diagram using the BMP bitmap format.
Jpeg | Renders a diagram using the JPEG bitmap format.
Png | Renders a diagram using the PNG bitmap format.

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


Bmp Field

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.Bmp Field
DiagramBitmapRenderer Class See Also Send Feedback
Renders a diagram using the BMP bitmap format.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramBitmapRenderer Bmp
Visual Basic (Declaration)
Public Shared ReadOnly Bmp As DiagramBitmapRenderer

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


Jpeg Field

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.Jpeg Field
DiagramBitmapRenderer Class See Also Send Feedback
Renders a diagram using the JPEG bitmap format.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramBitmapRenderer Jpeg
Visual Basic (Declaration)
Public Shared ReadOnly Jpeg As DiagramBitmapRenderer

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


Png Field

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.Png Field
DiagramBitmapRenderer Class See Also Send Feedback
Renders a diagram using the PNG bitmap format.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramBitmapRenderer Png
Visual Basic (Declaration)
Public Shared ReadOnly Png As DiagramBitmapRenderer

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


DiagramBitmapRenderer Methods

[image] [image]

Mindscape WPF Diagrams
DiagramBitmapRenderer Methods
DiagramBitmapRenderer Class See Also Send Feedback

Methods

Name | Description
Render | Overloaded.

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


Render Method

[image] [image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.Render Method
DiagramBitmapRenderer Class See Also Send Feedback

Overload List

Name | Description
Render(DiagramSurface, Stream) | Renders a diagram as a bitmap to a stream.
Render(DiagramSurface, String) | Renders a diagram as a bitmap to a file.

See Also

DiagramBitmapRenderer Class
DiagramBitmapRenderer Members
Mindscape.WpfDiagramming Namespace


Render Method (DiagramSurface, Stream)

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.Render Method (DiagramSurface, Stream)
DiagramBitmapRenderer Class See Also Send Feedback
Renders a diagram as a bitmap to a stream.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Render(
    DiagramSurface surface,
    Stream stream
)
Visual Basic (Declaration)
Public Sub Render ( _
    surface As DiagramSurface, _
    stream As Stream _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The diagram to be rendered.
stream
Type: System.IO..::.Stream
The stream into which to write the bitmap data.

See Also

DiagramBitmapRenderer Class
Render Overload
Mindscape.WpfDiagramming Namespace


Render Method (DiagramSurface, String)

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.Render Method (DiagramSurface, String)
DiagramBitmapRenderer Class See Also Send Feedback
Renders a diagram as a bitmap to a file.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Render(
    DiagramSurface diagram,
    string path
)
Visual Basic (Declaration)
Public Sub Render ( _
    diagram As DiagramSurface, _
    path As String _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The diagram to be rendered.
path
Type: System..::.String
The file into which to write the bitmap data.

Remarks

If the file exists, it is overwritten.

See Also

DiagramBitmapRenderer Class
Render Overload
Mindscape.WpfDiagramming Namespace


DiagramBitmapRenderer Properties

[image] [image]

Mindscape WPF Diagrams
DiagramBitmapRenderer Properties
DiagramBitmapRenderer Class See Also Send Feedback

The DiagramBitmapRenderer type exposes the following members.

Properties

Name | Description
BitmapEncoder | When overridden in a derived class, gets the BitmapEncoder used to encode the rendered bitmap.
PixelFormat | Gets the PixelFormat of the rendered bitmap. The default is Pbgra32.

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


BitmapEncoder Property

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.BitmapEncoder Property
DiagramBitmapRenderer Class See Also Send Feedback
When overridden in a derived class, gets the BitmapEncoder used to encode the rendered bitmap.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract BitmapEncoder BitmapEncoder { get; }
Visual Basic (Declaration)
Protected MustOverride ReadOnly Property BitmapEncoder As BitmapEncoder

Return Value

A BitmapEncoder to encode the rendered bitmap.

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


PixelFormat Property

[image]

Mindscape WPF Diagrams
DiagramBitmapRenderer..::.PixelFormat Property
DiagramBitmapRenderer Class See Also Send Feedback
Gets the PixelFormat of the rendered bitmap. The default is Pbgra32.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual PixelFormat PixelFormat { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property PixelFormat As PixelFormat

See Also

DiagramBitmapRenderer Class
Mindscape.WpfDiagramming Namespace


DiagramCommands Class

[image]

Mindscape WPF Diagrams
DiagramCommands Class
Members See Also Send Feedback
Provides a standard set of diagram-related commands.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class DiagramCommands
Visual Basic (Declaration)
Public NotInheritable Class DiagramCommands

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramCommands

See Also

DiagramCommands Members
Mindscape.WpfDiagramming Namespace


DiagramCommands Members

[image] [image]

Mindscape WPF Diagrams
DiagramCommands Members
DiagramCommands Class Fields See Also Send Feedback

The DiagramCommands type exposes the following members.

Fields

Name | Description
AlignBottom | A command for aligning diagram nodes along their bottom edge.
AlignCenter | A command for aligning diagram nodes along a vertical line.
AlignLeft | A command for aligning diagram nodes along their left edge.
AlignMiddle | A command for aligning diagram nodes along a horizontal line.
AlignRight | A command for aligning diagram nodes along their right edge.
AlignTop | A command for aligning diagram nodes along their top edge.
BringForwardCommand | Gets the value that represents the Bring Forward command.
BringToFrontCommand | Gets the value that represents the Bring to Front command.
DistributeHorizontally | A command for distibuting an equal horizontal space between selected nodes. The left most node and right most node do not move.
DistributeVertically | A command for distributing an equal vertical space between selected nodes. The top most and bottom most nodes do not move.
SendBackwardCommand | Gets the value that represents the Send Backward command.
SendToBackCommand | Gets the value that represents the Send to Back command.
SizeToFit | A command for automatically zooming and panning the diagram in a way that fits the diagram to the size of the DiagramSurface.

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


DiagramCommands Fields

[image] [image]

Mindscape WPF Diagrams
DiagramCommands Fields
DiagramCommands Class See Also Send Feedback

The DiagramCommands type exposes the following members.

Fields

Name | Description
AlignBottom | A command for aligning diagram nodes along their bottom edge.
AlignCenter | A command for aligning diagram nodes along a vertical line.
AlignLeft | A command for aligning diagram nodes along their left edge.
AlignMiddle | A command for aligning diagram nodes along a horizontal line.
AlignRight | A command for aligning diagram nodes along their right edge.
AlignTop | A command for aligning diagram nodes along their top edge.
BringForwardCommand | Gets the value that represents the Bring Forward command.
BringToFrontCommand | Gets the value that represents the Bring to Front command.
DistributeHorizontally | A command for distibuting an equal horizontal space between selected nodes. The left most node and right most node do not move.
DistributeVertically | A command for distributing an equal vertical space between selected nodes. The top most and bottom most nodes do not move.
SendBackwardCommand | Gets the value that represents the Send Backward command.
SendToBackCommand | Gets the value that represents the Send to Back command.
SizeToFit | A command for automatically zooming and panning the diagram in a way that fits the diagram to the size of the DiagramSurface.

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


AlignBottom Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.AlignBottom Field
DiagramCommands Class See Also Send Feedback
A command for aligning diagram nodes along their bottom edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand AlignBottom
Visual Basic (Declaration)
Public Shared ReadOnly AlignBottom As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


AlignCenter Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.AlignCenter Field
DiagramCommands Class See Also Send Feedback
A command for aligning diagram nodes along a vertical line.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand AlignCenter
Visual Basic (Declaration)
Public Shared ReadOnly AlignCenter As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


AlignLeft Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.AlignLeft Field
DiagramCommands Class See Also Send Feedback
A command for aligning diagram nodes along their left edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand AlignLeft
Visual Basic (Declaration)
Public Shared ReadOnly AlignLeft As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


AlignMiddle Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.AlignMiddle Field
DiagramCommands Class See Also Send Feedback
A command for aligning diagram nodes along a horizontal line.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand AlignMiddle
Visual Basic (Declaration)
Public Shared ReadOnly AlignMiddle As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


AlignRight Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.AlignRight Field
DiagramCommands Class See Also Send Feedback
A command for aligning diagram nodes along their right edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand AlignRight
Visual Basic (Declaration)
Public Shared ReadOnly AlignRight As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


AlignTop Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.AlignTop Field
DiagramCommands Class See Also Send Feedback
A command for aligning diagram nodes along their top edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand AlignTop
Visual Basic (Declaration)
Public Shared ReadOnly AlignTop As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


BringForwardCommand Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.BringForwardCommand Field
DiagramCommands Class See Also Send Feedback
Gets the value that represents the Bring Forward command.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand BringForwardCommand
Visual Basic (Declaration)
Public Shared ReadOnly BringForwardCommand As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


BringToFrontCommand Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.BringToFrontCommand Field
DiagramCommands Class See Also Send Feedback
Gets the value that represents the Bring to Front command.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand BringToFrontCommand
Visual Basic (Declaration)
Public Shared ReadOnly BringToFrontCommand As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


DistributeHorizontally Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.DistributeHorizontally Field
DiagramCommands Class See Also Send Feedback
A command for distibuting an equal horizontal space between selected nodes. The left most node and right most node do not move.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand DistributeHorizontally
Visual Basic (Declaration)
Public Shared ReadOnly DistributeHorizontally As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


DistributeVertically Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.DistributeVertically Field
DiagramCommands Class See Also Send Feedback
A command for distributing an equal vertical space between selected nodes. The top most and bottom most nodes do not move.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand DistributeVertically
Visual Basic (Declaration)
Public Shared ReadOnly DistributeVertically As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


SendBackwardCommand Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.SendBackwardCommand Field
DiagramCommands Class See Also Send Feedback
Gets the value that represents the Send Backward command.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand SendBackwardCommand
Visual Basic (Declaration)
Public Shared ReadOnly SendBackwardCommand As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


SendToBackCommand Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.SendToBackCommand Field
DiagramCommands Class See Also Send Feedback
Gets the value that represents the Send to Back command.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand SendToBackCommand
Visual Basic (Declaration)
Public Shared ReadOnly SendToBackCommand As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


SizeToFit Field

[image]

Mindscape WPF Diagrams
DiagramCommands..::.SizeToFit Field
DiagramCommands Class See Also Send Feedback
A command for automatically zooming and panning the diagram in a way that fits the diagram to the size of the DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedCommand SizeToFit
Visual Basic (Declaration)
Public Shared ReadOnly SizeToFit As RoutedCommand

See Also

DiagramCommands Class
Mindscape.WpfDiagramming Namespace


DiagramConnection Class

[image]

Mindscape WPF Diagrams
DiagramConnection Class
Members See Also Send Feedback
Represents a connection on a standard shape diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramConnection : DiagramConnectionBase<DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint>
Visual Basic (Declaration)
Public Class DiagramConnection _
    Inherits DiagramConnectionBase(Of DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint)

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramConnection
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramConnection
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnection

See Also

DiagramConnection Members
Mindscape.WpfDiagramming Namespace


DiagramConnection Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnection Members
DiagramConnection Class Constructors Methods Properties Events See Also Send Feedback

The DiagramConnection type exposes the following members.

Constructors

Name | Description
DiagramConnection | Overloaded.

Methods

Name | Description
AddConnectionPoint | Adds a new mounted connection point to this connection. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. AddConnectionPoint(Point, Double).)
ApplyPathfinding | Re-routes this connection using its pathfinder. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Clone | Gets the state of the connection for undo purposes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can be the source of a new outgoing connection. Always returns true. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether the connection can be the destination of a new incoming connection. Always returns true. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
LineType | Gets or sets the DiagramLineType used to draw the connection.
Pathfinder | Gets the routing algorithm for the connection. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. Pathfinder.)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Events

Name | Description
DataChanged | Raised when the Data property changes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


DiagramConnection Constructor

[image] [image]

Mindscape WPF Diagrams
DiagramConnection Constructor
DiagramConnection Class See Also Send Feedback

Overload List

Name | Description
DiagramConnection(DiagramConnectionPoint, DiagramConnectionPoint) | Initializes a new instance of the DiagramConnection class.
DiagramConnection(DiagramConnectionPoint, DiagramConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>)) | Initializes a new instance of the DiagramConnection class.

See Also

DiagramConnection Class
DiagramConnection Members
Mindscape.WpfDiagramming Namespace


DiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint)

[image]

Mindscape WPF Diagrams
DiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint)
DiagramConnection Class See Also Send Feedback
Initializes a new instance of the DiagramConnection class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnection(
    DiagramConnectionPoint fromConnectionPoint,
    DiagramConnectionPoint toConnectionPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As DiagramConnectionPoint, _
    toConnectionPoint As DiagramConnectionPoint _
)

Parameters

fromConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The source of the connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The destination of the connection.

See Also

DiagramConnection Class
DiagramConnection Overload
Mindscape.WpfDiagramming Namespace


DiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint, IList(DiagramConnectionSegment))

[image]

Mindscape WPF Diagrams
DiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>))
DiagramConnection Class See Also Send Feedback
Initializes a new instance of the DiagramConnection class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnection(
    DiagramConnectionPoint fromConnectionPoint,
    DiagramConnectionPoint toConnectionPoint,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As DiagramConnectionPoint, _
    toConnectionPoint As DiagramConnectionPoint, _
    segments As IList(Of DiagramConnectionSegment) _
)

Parameters

fromConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The source of the connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The destination of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects within this DiagramConnection.

See Also

DiagramConnection Class
DiagramConnection Overload
Mindscape.WpfDiagramming Namespace


DiagramConnection Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnection Methods
DiagramConnection Class See Also Send Feedback

The DiagramConnection type exposes the following members.

Methods

Name | Description
AddConnectionPoint | Adds a new mounted connection point to this connection. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. AddConnectionPoint(Point, Double).)
ApplyPathfinding | Re-routes this connection using its pathfinder. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Clone | Gets the state of the connection for undo purposes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


AddConnectionPoint Method

[image]

Mindscape WPF Diagrams
DiagramConnection..::.AddConnectionPoint Method
DiagramConnection Class See Also Send Feedback
Adds a new mounted connection point to this connection.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override DiagramConnectionPoint AddConnectionPoint(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Public Overrides Function AddConnectionPoint ( _
    point As Point, _
    buffer As Double _
) As DiagramConnectionPoint

Parameters

point
Type: System.Windows..::.Point
A point used to derive the position of the mounted connection point.
buffer
Type: System..::.Double
The minimum distance away from the connection corners that the mounted point can be placed.

Return Value

The connection point that is created and mounted to this connection.

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


DiagramConnection Properties

[image] [image]

Mindscape WPF Diagrams
DiagramConnection Properties
DiagramConnection Class See Also Send Feedback

The DiagramConnection type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can be the source of a new outgoing connection. Always returns true. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether the connection can be the destination of a new incoming connection. Always returns true. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
LineType | Gets or sets the DiagramLineType used to draw the connection.
Pathfinder | Gets the routing algorithm for the connection. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. Pathfinder.)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramConnection..::.CanOriginateNewConnections Property
DiagramConnection Class See Also Send Feedback
Gets whether the connection can be the source of a new outgoing connection. Always returns true.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramConnection..::.CanReceiveNewConnections Property
DiagramConnection Class See Also Send Feedback
Gets whether the connection can be the destination of a new incoming connection. Always returns true.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


LineType Property

[image]

Mindscape WPF Diagrams
DiagramConnection..::.LineType Property
DiagramConnection Class See Also Send Feedback
Gets or sets the DiagramLineType used to draw the connection.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramLineType LineType { get; set; }
Visual Basic (Declaration)
Public Property LineType As DiagramLineType

Remarks

Changes to this property after the connection is displayed do not affect the display. Set the LineType property before adding the connection to the diagram model. If you need to change the line type while the connection is displayed, remove the connection from the diagram model, set the property, then reinstate the connection.

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


Pathfinder Property

[image]

Mindscape WPF Diagrams
DiagramConnection..::.Pathfinder Property
DiagramConnection Class See Also Send Feedback
Gets the routing algorithm for the connection.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IPathfinder Pathfinder { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Pathfinder As IPathfinder

Implements

IDiagramConnection..::.Pathfinder

See Also

DiagramConnection Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Class

[image]

Mindscape WPF Diagrams
DiagramConnectionPoint Class
Members See Also Send Feedback
Represents a point at which a connection connects to a source or destination in a standard shape diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramConnectionPoint : DiagramConnectionPointBase<DiagramConnection>
Visual Basic (Declaration)
Public Class DiagramConnectionPoint _
    Inherits DiagramConnectionPointBase(Of DiagramConnection)

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionPointBase <(Of <( DiagramConnection >)>)
Mindscape.WpfDiagramming..::.DiagramConnectionPoint
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramConnectionPoint
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionPoint

See Also

DiagramConnectionPoint Members
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPoint Members
DiagramConnectionPoint Class Constructors Methods Properties Events See Also Send Feedback

The DiagramConnectionPoint type exposes the following members.

Constructors

Name | Description
DiagramConnectionPoint | Overloaded.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this DiagramConnectionPoint. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. AddConnection(IDiagramConnection).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
RemoveConnection | Removes the given IDiagramConnection from this DiagramConnectionPoint. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. RemoveConnection(IDiagramConnection).)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetPosition | Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

Properties

Name | Description
CanOriginateNewConnections | Gets whether the user should be allowed to drag new connections from this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
CanReceiveNewConnections | Gets whether the user should be allowed to drop new connections onto this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connectable | Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connections | Gets the connections attached to this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Data | Gets or sets the data object held by this connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Edge | Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
FlowDirection | Gets whether the connection point supports inbound connections, outbound connections or both. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. FlowDirection.)
Index | Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Position | Gets or sets the position of the connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionCalculator | Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

Events

Name | Description
IndexChanged | Raised when the Index property value changes. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionChanged | Raised when the Position property value changes. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

DiagramConnectionPoint Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Constructor

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPoint Constructor
DiagramConnectionPoint Class See Also Send Feedback

Overload List

Name | Description
DiagramConnectionPoint(IDiagramConnectable, Edge) | Initializes a new instance of the DiagramConnectionPoint class.
DiagramConnectionPoint(IDiagramConnectable, Edge, ConnectionPointDirection) | Initializes a new instance of the DiagramConnectionPoint class.
DiagramConnectionPoint(IDiagramConnectable, Edge, Int32) | Initializes a new instance of the DiagramConnectionPoint class.

See Also

DiagramConnectionPoint Class
DiagramConnectionPoint Members
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Constructor (IDiagramConnectable, Edge)

[image]

Mindscape WPF Diagrams
DiagramConnectionPoint Constructor (IDiagramConnectable, Edge)
DiagramConnectionPoint Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionPoint class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionPoint(
    IDiagramConnectable connectable,
    Edge edge
)
Visual Basic (Declaration)
Public Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The node or connection on which the connection point sits.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The edge of the node or connection on which the connection point sits

See Also

DiagramConnectionPoint Class
DiagramConnectionPoint Overload
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Constructor (IDiagramConnectable, Edge, ConnectionPointDirection)

[image]

Mindscape WPF Diagrams
DiagramConnectionPoint Constructor (IDiagramConnectable, Edge, ConnectionPointDirection)
DiagramConnectionPoint Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionPoint class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionPoint(
    IDiagramConnectable connectable,
    Edge edge,
    ConnectionPointDirection flowDirection
)
Visual Basic (Declaration)
Public Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge, _
    flowDirection As ConnectionPointDirection _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The node or connection on which the connection point sits.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The edge of the node or connection on which the connection point sits
flowDirection
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionPointDirection
Specifies whether the connection point supports inbound connections, outbound connections or both.

See Also

DiagramConnectionPoint Class
DiagramConnectionPoint Overload
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Constructor (IDiagramConnectable, Edge, Int32)

[image]

Mindscape WPF Diagrams
DiagramConnectionPoint Constructor (IDiagramConnectable, Edge, Int32)
DiagramConnectionPoint Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionPoint class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionPoint(
    IDiagramConnectable connectable,
    Edge edge,
    int index
)
Visual Basic (Declaration)
Public Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge, _
    index As Integer _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The node or connection on which the connection point sits.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The edge of the node or connection on which the connection point sits
index
Type: System..::.Int32
The index identifier for this connection point.

See Also

DiagramConnectionPoint Class
DiagramConnectionPoint Overload
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPoint Methods
DiagramConnectionPoint Class See Also Send Feedback

The DiagramConnectionPoint type exposes the following members.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this DiagramConnectionPoint. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. AddConnection(IDiagramConnection).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
RemoveConnection | Removes the given IDiagramConnection from this DiagramConnectionPoint. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. RemoveConnection(IDiagramConnection).)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetPosition | Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

See Also

DiagramConnectionPoint Class
Mindscape.WpfDiagramming Namespace


AddConnection Method

[image]

Mindscape WPF Diagrams
DiagramConnectionPoint..::.AddConnection Method
DiagramConnectionPoint Class See Also Send Feedback
Attaches the given IDiagramConnection to this DiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void AddConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overrides Sub AddConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to attach.

Implements

IDiagramConnectionPoint..::.AddConnection(IDiagramConnection)

See Also

DiagramConnectionPoint Class
Mindscape.WpfDiagramming Namespace


RemoveConnection Method

[image]

Mindscape WPF Diagrams
DiagramConnectionPoint..::.RemoveConnection Method
DiagramConnectionPoint Class See Also Send Feedback
Removes the given IDiagramConnection from this DiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void RemoveConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overrides Sub RemoveConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to remove.

Implements

IDiagramConnectionPoint..::.RemoveConnection(IDiagramConnection)

See Also

DiagramConnectionPoint Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionPoint Properties

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPoint Properties
DiagramConnectionPoint Class See Also Send Feedback

The DiagramConnectionPoint type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the user should be allowed to drag new connections from this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
CanReceiveNewConnections | Gets whether the user should be allowed to drop new connections onto this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connectable | Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connections | Gets the connections attached to this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Data | Gets or sets the data object held by this connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Edge | Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
FlowDirection | Gets whether the connection point supports inbound connections, outbound connections or both. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. FlowDirection.)
Index | Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Position | Gets or sets the position of the connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionCalculator | Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

See Also

DiagramConnectionPoint Class
Mindscape.WpfDiagramming Namespace


FlowDirection Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPoint..::.FlowDirection Property
DiagramConnectionPoint Class See Also Send Feedback
Gets whether the connection point supports inbound connections, outbound connections or both.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override ConnectionPointDirection FlowDirection { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property FlowDirection As ConnectionPointDirection

Implements

IDiagramConnectionPoint..::.FlowDirection

See Also

DiagramConnectionPoint Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionStyleSelector Class

[image]

Mindscape WPF Diagrams
DiagramConnectionStyleSelector Class
Members See Also Send Feedback
Selects a style for a DiagramConnection using the LineTypeLayout resource whose key is the DiagramConnection.LineType.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramConnectionStyleSelector : MatchingStyleSelector
Visual Basic (Declaration)
Public Class DiagramConnectionStyleSelector _
    Inherits MatchingStyleSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingStyleSelector
Mindscape.WpfDiagramming.Foundation..::.MatchingStyleSelector
Mindscape.WpfDiagramming..::.DiagramConnectionStyleSelector

See Also

DiagramConnectionStyleSelector Members
Mindscape.WpfDiagramming Namespace


DiagramConnectionStyleSelector Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionStyleSelector Members
DiagramConnectionStyleSelector Class Constructors Methods Properties See Also Send Feedback

The DiagramConnectionStyleSelector type exposes the following members.

Constructors

Name | Description
DiagramConnectionStyleSelector |

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Selects a style for the specified DiagramConnection. (Overrides MatchingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector. (Inherited from DelegatingStyleSelector.)
DefaultStyle | Gets or sets the default Style. (Inherited from MatchingStyleSelector.)
Styles | Gets the list of styles and matching criteria. (Inherited from MatchingStyleSelector.)

See Also

DiagramConnectionStyleSelector Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionStyleSelector Constructor

[image]

Mindscape WPF Diagrams
DiagramConnectionStyleSelector Constructor
DiagramConnectionStyleSelector Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionStyleSelector class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionStyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramConnectionStyleSelector Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionStyleSelector Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionStyleSelector Methods
DiagramConnectionStyleSelector Class See Also Send Feedback

The DiagramConnectionStyleSelector type exposes the following members.

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Selects a style for the specified DiagramConnection. (Overrides MatchingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

See Also

DiagramConnectionStyleSelector Class
Mindscape.WpfDiagramming Namespace


SelectStyleCore Method

[image]

Mindscape WPF Diagrams
DiagramConnectionStyleSelector..::.SelectStyleCore Method
DiagramConnectionStyleSelector Class See Also Send Feedback
Selects a style for the specified DiagramConnection.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Style SelectStyleCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected Overrides Function SelectStyleCore ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The DiagramConnection for which a style is required.
container
Type: System.Windows..::.DependencyObject
The FrameworkElement that contains the DiagramConnection.

Return Value

A Style for displaying the specified connection.

See Also

DiagramConnectionStyleSelector Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionTool Class

[image]

Mindscape WPF Diagrams
DiagramConnectionTool Class
Members See Also Send Feedback
Represents a control which, when selected, puts the cursor into "draw connection" mode.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[StyleTypedPropertyAttribute(Property = "LineStyle", StyleTargetType = typeof(Line))]
public class DiagramConnectionTool : Button, IDiagramToolboxTool
Visual Basic (Declaration)
<StyleTypedPropertyAttribute(Property := "LineStyle", StyleTargetType := GetType(Line))> _
Public Class DiagramConnectionTool _
    Inherits Button _
    Implements IDiagramToolboxTool

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls..::.Button
Mindscape.WpfDiagramming..::.DiagramConnectionTool

See Also

DiagramConnectionTool Members
Mindscape.WpfDiagramming Namespace


DiagramConnectionTool Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionTool Members
DiagramConnectionTool Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramConnectionTool type exposes the following members.

Constructors

Name | Description
DiagramConnectionTool |

Methods

Name | Description
OnClick | Called whenever a mouse button is pressed over this DiagramConnectionTool. This method sets the current cursor action to be a new CreateConnectionCursorAction. This method does nothing if the ToolScope property is set to null. (Overrides Button ..::. OnClick()()().)

Fields

Name | Description
BuilderProperty | Identifies the Builder property.
ConnectionCursorProperty | Identifies the ConnectionCursor property.
LineStyleProperty | Identifies the LineStyle property.
ToolScopeProperty | Identifies the ToolScope property.

Properties

Name | Description
Builder | Gets or sets the IDiagramConnectionBuilder which takes effect when the control is selected. This is a dependency property.
ConnectionCursor | Gets or sets the Cursor used to express that the application is in 'add connection' mode. This is a dependency property.
DefaultLineStyleKey | Gets the ResourceKey for the default Style used for drawing connections in progress.
LineStyle | Gets or sets the Style applied to the line used to draw the connection while the user is dragging the tool. This is a dependency property.
ToolScope | Gets or sets the object within which the tool may be applied. This is a dependency property.

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionTool Constructor

[image]

Mindscape WPF Diagrams
DiagramConnectionTool Constructor
DiagramConnectionTool Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionTool class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionTool()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionTool Fields

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionTool Fields
DiagramConnectionTool Class See Also Send Feedback

The DiagramConnectionTool type exposes the following members.

Fields

Name | Description
BuilderProperty | Identifies the Builder property.
ConnectionCursorProperty | Identifies the ConnectionCursor property.
LineStyleProperty | Identifies the LineStyle property.
ToolScopeProperty | Identifies the ToolScope property.

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


BuilderProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.BuilderProperty Field
DiagramConnectionTool Class See Also Send Feedback
Identifies the Builder property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty BuilderProperty
Visual Basic (Declaration)
Public Shared ReadOnly BuilderProperty As DependencyProperty

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


ConnectionCursorProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.ConnectionCursorProperty Field
DiagramConnectionTool Class See Also Send Feedback
Identifies the ConnectionCursor property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionCursorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionCursorProperty As DependencyProperty

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


LineStyleProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.LineStyleProperty Field
DiagramConnectionTool Class See Also Send Feedback
Identifies the LineStyle property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty LineStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly LineStyleProperty As DependencyProperty

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


ToolScopeProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.ToolScopeProperty Field
DiagramConnectionTool Class See Also Send Feedback
Identifies the ToolScope property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ToolScopeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolScopeProperty As DependencyProperty

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionTool Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionTool Methods
DiagramConnectionTool Class See Also Send Feedback

The DiagramConnectionTool type exposes the following members.

Methods

Name | Description
OnClick | Called whenever a mouse button is pressed over this DiagramConnectionTool. This method sets the current cursor action to be a new CreateConnectionCursorAction. This method does nothing if the ToolScope property is set to null. (Overrides Button ..::. OnClick()()().)

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


OnClick Method

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.OnClick Method
DiagramConnectionTool Class See Also Send Feedback
Called whenever a mouse button is pressed over this DiagramConnectionTool. This method sets the current cursor action to be a new CreateConnectionCursorAction. This method does nothing if the ToolScope property is set to null.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnClick()
Visual Basic (Declaration)
Protected Overrides Sub OnClick

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


DiagramConnectionTool Properties

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionTool Properties
DiagramConnectionTool Class See Also Send Feedback

The DiagramConnectionTool type exposes the following members.

Properties

Name | Description
Builder | Gets or sets the IDiagramConnectionBuilder which takes effect when the control is selected. This is a dependency property.
ConnectionCursor | Gets or sets the Cursor used to express that the application is in 'add connection' mode. This is a dependency property.
DefaultLineStyleKey | Gets the ResourceKey for the default Style used for drawing connections in progress.
LineStyle | Gets or sets the Style applied to the line used to draw the connection while the user is dragging the tool. This is a dependency property.
ToolScope | Gets or sets the object within which the tool may be applied. This is a dependency property.

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


Builder Property

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.Builder Property
DiagramConnectionTool Class See Also Send Feedback
Gets or sets the IDiagramConnectionBuilder which takes effect when the control is selected. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionBuilder Builder { get; set; }
Visual Basic (Declaration)
Public Property Builder As IDiagramConnectionBuilder

Remarks

Dependency Property Information
Identifier field | BuilderProperty
Metadata properties set to true | None

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


ConnectionCursor Property

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.ConnectionCursor Property
DiagramConnectionTool Class See Also Send Feedback
Gets or sets the Cursor used to express that the application is in 'add connection' mode. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Cursor ConnectionCursor { get; set; }
Visual Basic (Declaration)
Public Property ConnectionCursor As Cursor

Remarks

Dependency Property Information
Identifier field | ConnectionCursorProperty
Metadata properties set to true | None

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


DefaultLineStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.DefaultLineStyleKey Property
DiagramConnectionTool Class See Also Send Feedback
Gets the ResourceKey for the default Style used for drawing connections in progress.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultLineStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultLineStyleKey As ComponentResourceKey

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


LineStyle Property

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.LineStyle Property
DiagramConnectionTool Class See Also Send Feedback
Gets or sets the Style applied to the line used to draw the connection while the user is dragging the tool. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As Style

Remarks

Dependency Property Information
Identifier field | LineStyleProperty
Metadata properties set to true | None

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


ToolScope Property

[image]

Mindscape WPF Diagrams
DiagramConnectionTool..::.ToolScope Property
DiagramConnectionTool Class See Also Send Feedback
Gets or sets the object within which the tool may be applied. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DependencyObject ToolScope { get; set; }
Visual Basic (Declaration)
Public Property ToolScope As DependencyObject

Implements

IDiagramToolboxTool..::.ToolScope

Remarks

Dependency Property Information
Identifier field | ToolScopeProperty
Metadata properties set to true | None

See Also

DiagramConnectionTool Class
Mindscape.WpfDiagramming Namespace


DiagramFormatter Class

[image]

Mindscape WPF Diagrams
DiagramFormatter Class
Members See Also Send Feedback
Specifies how a IDiagramModel should be displayed on a DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramFormatter : IDiagramFormatter
Visual Basic (Declaration)
Public Class DiagramFormatter _
    Implements IDiagramFormatter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramFormatter

See Also

DiagramFormatter Members
Mindscape.WpfDiagramming Namespace


DiagramFormatter Members

[image] [image]

Mindscape WPF Diagrams
DiagramFormatter Members
DiagramFormatter Class Constructors Properties See Also Send Feedback

The DiagramFormatter type exposes the following members.

Constructors

Name | Description
DiagramFormatter |

Properties

Name | Description
ConnectionContentTemplateSelector | Gets or sets the DataTemplateSelector used for displaying the data content of IDiagramConnection objects.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used for selecting a template for diagram connection points.
ConnectionStyleSelector | Gets or sets the StyleSelector used for styling connections.
Layout | Gets or sets the ILayout used for positioning.
NodeContentTemplateSelector | Gets or sets the DataTemplateSelector used for displaying the data content of IDiagramNode objects.
NodeStyleSelector | Gets or sets the StyleSelector used for styling nodes.

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


DiagramFormatter Constructor

[image]

Mindscape WPF Diagrams
DiagramFormatter Constructor
DiagramFormatter Class See Also Send Feedback
Initializes a new instance of the DiagramFormatter class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramFormatter()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


DiagramFormatter Properties

[image] [image]

Mindscape WPF Diagrams
DiagramFormatter Properties
DiagramFormatter Class See Also Send Feedback

The DiagramFormatter type exposes the following members.

Properties

Name | Description
ConnectionContentTemplateSelector | Gets or sets the DataTemplateSelector used for displaying the data content of IDiagramConnection objects.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used for selecting a template for diagram connection points.
ConnectionStyleSelector | Gets or sets the StyleSelector used for styling connections.
Layout | Gets or sets the ILayout used for positioning.
NodeContentTemplateSelector | Gets or sets the DataTemplateSelector used for displaying the data content of IDiagramNode objects.
NodeStyleSelector | Gets or sets the StyleSelector used for styling nodes.

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


ConnectionContentTemplateSelector Property

[image]

Mindscape WPF Diagrams
DiagramFormatter..::.ConnectionContentTemplateSelector Property
DiagramFormatter Class See Also Send Feedback
Gets or sets the DataTemplateSelector used for displaying the data content of IDiagramConnection objects.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplateSelector ConnectionContentTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ConnectionContentTemplateSelector As DataTemplateSelector

Implements

IDiagramFormatter..::.ConnectionContentTemplateSelector

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


ConnectionPointTemplateSelector Property

[image]

Mindscape WPF Diagrams
DiagramFormatter..::.ConnectionPointTemplateSelector Property
DiagramFormatter Class See Also Send Feedback
Gets or sets the DataTemplateSelector used for selecting a template for diagram connection points.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplateSelector ConnectionPointTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ConnectionPointTemplateSelector As DataTemplateSelector

Implements

IDiagramFormatter..::.ConnectionPointTemplateSelector

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


ConnectionStyleSelector Property

[image]

Mindscape WPF Diagrams
DiagramFormatter..::.ConnectionStyleSelector Property
DiagramFormatter Class See Also Send Feedback
Gets or sets the StyleSelector used for styling connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StyleSelector ConnectionStyleSelector { get; set; }
Visual Basic (Declaration)
Public Property ConnectionStyleSelector As StyleSelector

Implements

IDiagramFormatter..::.ConnectionStyleSelector

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


Layout Property

[image]

Mindscape WPF Diagrams
DiagramFormatter..::.Layout Property
DiagramFormatter Class See Also Send Feedback
Gets or sets the ILayout used for positioning.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ILayout Layout { get; set; }
Visual Basic (Declaration)
Public Property Layout As ILayout

Implements

IDiagramFormatter..::.Layout

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


NodeContentTemplateSelector Property

[image]

Mindscape WPF Diagrams
DiagramFormatter..::.NodeContentTemplateSelector Property
DiagramFormatter Class See Also Send Feedback
Gets or sets the DataTemplateSelector used for displaying the data content of IDiagramNode objects.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplateSelector NodeContentTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property NodeContentTemplateSelector As DataTemplateSelector

Implements

IDiagramFormatter..::.NodeContentTemplateSelector

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


NodeStyleSelector Property

[image]

Mindscape WPF Diagrams
DiagramFormatter..::.NodeStyleSelector Property
DiagramFormatter Class See Also Send Feedback
Gets or sets the StyleSelector used for styling nodes.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StyleSelector NodeStyleSelector { get; set; }
Visual Basic (Declaration)
Public Property NodeStyleSelector As StyleSelector

Implements

IDiagramFormatter..::.NodeStyleSelector

See Also

DiagramFormatter Class
Mindscape.WpfDiagramming Namespace


DiagramLineType Class

[image]

Mindscape WPF Diagrams
DiagramLineType Class
Members See Also Send Feedback
Identifies a type of line.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramLineType
Visual Basic (Declaration)
Public Class DiagramLineType

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramLineType

See Also

DiagramLineType Members
Mindscape.WpfDiagramming Namespace


DiagramLineType Members

[image] [image]

Mindscape WPF Diagrams
DiagramLineType Members
DiagramLineType Class Constructors Methods Properties See Also Send Feedback

The DiagramLineType type exposes the following members.

Constructors

Name | Description
DiagramLineType | Initializes a new instance of the DiagramLineType class.

Methods

Name | Description
Freeze | Freezes the DiagramLineType so that it cannot be modified.
ToString | Provides a string representation of the DiagramLineType. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
DisplayName | Gets or sets a display name which can be used in tooltips or other user interface text to identify the line type.
Name | Gets the name of the line type.
Pathfinder | Gets or sets the routing algorithm for lines of this type.

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


DiagramLineType Constructor

[image]

Mindscape WPF Diagrams
DiagramLineType Constructor
DiagramLineType Class See Also Send Feedback
Initializes a new instance of the DiagramLineType class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramLineType(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
The name of the line type.

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


DiagramLineType Methods

[image] [image]

Mindscape WPF Diagrams
DiagramLineType Methods
DiagramLineType Class See Also Send Feedback

The DiagramLineType type exposes the following members.

Methods

Name | Description
Freeze | Freezes the DiagramLineType so that it cannot be modified.
ToString | Provides a string representation of the DiagramLineType. (Overrides Object ..::. ToString()()().)

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


Freeze Method

[image]

Mindscape WPF Diagrams
DiagramLineType..::.Freeze Method
DiagramLineType Class See Also Send Feedback
Freezes the DiagramLineType so that it cannot be modified.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramLineType Freeze()
Visual Basic (Declaration)
Public Function Freeze As DiagramLineType

Return Value

The frozen DiagramLineType.

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


ToString Method

[image]

Mindscape WPF Diagrams
DiagramLineType..::.ToString Method
DiagramLineType Class See Also Send Feedback
Provides a string representation of the DiagramLineType.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string representation of the DiagramLineType

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


DiagramLineType Properties

[image] [image]

Mindscape WPF Diagrams
DiagramLineType Properties
DiagramLineType Class See Also Send Feedback

The DiagramLineType type exposes the following members.

Properties

Name | Description
DisplayName | Gets or sets a display name which can be used in tooltips or other user interface text to identify the line type.
Name | Gets the name of the line type.
Pathfinder | Gets or sets the routing algorithm for lines of this type.

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


DisplayName Property

[image]

Mindscape WPF Diagrams
DiagramLineType..::.DisplayName Property
DiagramLineType Class See Also Send Feedback
Gets or sets a display name which can be used in tooltips or other user interface text to identify the line type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


Name Property

[image]

Mindscape WPF Diagrams
DiagramLineType..::.Name Property
DiagramLineType Class See Also Send Feedback
Gets the name of the line type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


Pathfinder Property

[image]

Mindscape WPF Diagrams
DiagramLineType..::.Pathfinder Property
DiagramLineType Class See Also Send Feedback
Gets or sets the routing algorithm for lines of this type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IPathfinder Pathfinder { get; set; }
Visual Basic (Declaration)
Public Property Pathfinder As IPathfinder

See Also

DiagramLineType Class
Mindscape.WpfDiagramming Namespace


DiagramLineTypes Class

[image]

Mindscape WPF Diagrams
DiagramLineTypes Class
Members See Also Send Feedback
Identifies standard line types.
DiagramLineTypes

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramLineTypes : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class DiagramLineTypes _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming..::.DiagramLineTypes

See Also

DiagramLineTypes Members
Mindscape.WpfDiagramming Namespace


DiagramLineTypes Members

[image] [image]

Mindscape WPF Diagrams
DiagramLineTypes Members
DiagramLineTypes Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramLineTypes type exposes the following members.

Constructors

Name | Description
DiagramLineTypes | Initializes a new instance of the DiagramLineTypes class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Fields

Name | Description
Elbow | Represents an elbow-routed line with no arrows.
ElbowArrow | Represents an elbow-routed line with an arrow at the destination end.
ElbowDoubleArrow | Represents an elbow-routed line with arrow at both ends.
Straight | Represents a straight line with no arrows.
StraightArrow | Represents a straight line with an arrow at the destination end.
StraightDoubleArrow | Represents a straight line with arrows at both ends.

Properties

Name | Description
DefaultConnectionToolboxItemArrowheadStyleKey | Gets the ResourceKey for the Style for toolbox items representing diagram connections.
DefaultConnectionToolboxItemStyleKey | Gets the ResourceKey for the Style for toolbox items representing diagram connections.
DefaultDiagramConnectionStyleKey | Gets the ResourceKey for the Style for diagram connections.

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DiagramLineTypes Constructor

[image]

Mindscape WPF Diagrams
DiagramLineTypes Constructor
DiagramLineTypes Class See Also Send Feedback
Initializes a new instance of the DiagramLineTypes class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramLineTypes()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DiagramLineTypes Fields

[image] [image]

Mindscape WPF Diagrams
DiagramLineTypes Fields
DiagramLineTypes Class See Also Send Feedback

The DiagramLineTypes type exposes the following members.

Fields

Name | Description
Elbow | Represents an elbow-routed line with no arrows.
ElbowArrow | Represents an elbow-routed line with an arrow at the destination end.
ElbowDoubleArrow | Represents an elbow-routed line with arrow at both ends.
Straight | Represents a straight line with no arrows.
StraightArrow | Represents a straight line with an arrow at the destination end.
StraightDoubleArrow | Represents a straight line with arrows at both ends.

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


Elbow Field

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.Elbow Field
DiagramLineTypes Class See Also Send Feedback
Represents an elbow-routed line with no arrows.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramLineType Elbow
Visual Basic (Declaration)
Public Shared ReadOnly Elbow As DiagramLineType

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


ElbowArrow Field

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.ElbowArrow Field
DiagramLineTypes Class See Also Send Feedback
Represents an elbow-routed line with an arrow at the destination end.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramLineType ElbowArrow
Visual Basic (Declaration)
Public Shared ReadOnly ElbowArrow As DiagramLineType

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


ElbowDoubleArrow Field

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.ElbowDoubleArrow Field
DiagramLineTypes Class See Also Send Feedback
Represents an elbow-routed line with arrow at both ends.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramLineType ElbowDoubleArrow
Visual Basic (Declaration)
Public Shared ReadOnly ElbowDoubleArrow As DiagramLineType

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


Straight Field

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.Straight Field
DiagramLineTypes Class See Also Send Feedback
Represents a straight line with no arrows.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramLineType Straight
Visual Basic (Declaration)
Public Shared ReadOnly Straight As DiagramLineType

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


StraightArrow Field

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.StraightArrow Field
DiagramLineTypes Class See Also Send Feedback
Represents a straight line with an arrow at the destination end.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramLineType StraightArrow
Visual Basic (Declaration)
Public Shared ReadOnly StraightArrow As DiagramLineType

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


StraightDoubleArrow Field

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.StraightDoubleArrow Field
DiagramLineTypes Class See Also Send Feedback
Represents a straight line with arrows at both ends.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramLineType StraightDoubleArrow
Visual Basic (Declaration)
Public Shared ReadOnly StraightDoubleArrow As DiagramLineType

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DiagramLineTypes Methods

[image] [image]

Mindscape WPF Diagrams
DiagramLineTypes Methods
DiagramLineTypes Class See Also Send Feedback

The DiagramLineTypes type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.InitializeComponent Method
DiagramLineTypes Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DiagramLineTypes Properties

[image] [image]

Mindscape WPF Diagrams
DiagramLineTypes Properties
DiagramLineTypes Class See Also Send Feedback

The DiagramLineTypes type exposes the following members.

Properties

Name | Description
DefaultConnectionToolboxItemArrowheadStyleKey | Gets the ResourceKey for the Style for toolbox items representing diagram connections.
DefaultConnectionToolboxItemStyleKey | Gets the ResourceKey for the Style for toolbox items representing diagram connections.
DefaultDiagramConnectionStyleKey | Gets the ResourceKey for the Style for diagram connections.

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DefaultConnectionToolboxItemArrowheadStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.DefaultConnectionToolboxItemArrowheadStyleKey Property
DiagramLineTypes Class See Also Send Feedback
Gets the ResourceKey for the Style for toolbox items representing diagram connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultConnectionToolboxItemArrowheadStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultConnectionToolboxItemArrowheadStyleKey As ComponentResourceKey

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DefaultConnectionToolboxItemStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.DefaultConnectionToolboxItemStyleKey Property
DiagramLineTypes Class See Also Send Feedback
Gets the ResourceKey for the Style for toolbox items representing diagram connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultConnectionToolboxItemStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultConnectionToolboxItemStyleKey As ComponentResourceKey

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DefaultDiagramConnectionStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramLineTypes..::.DefaultDiagramConnectionStyleKey Property
DiagramLineTypes Class See Also Send Feedback
Gets the ResourceKey for the Style for diagram connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultDiagramConnectionStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultDiagramConnectionStyleKey As ComponentResourceKey

See Also

DiagramLineTypes Class
Mindscape.WpfDiagramming Namespace


DiagramNode Class

[image]

Mindscape WPF Diagrams
DiagramNode Class
Members See Also Send Feedback
Represents a node in a standard shape diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramNode : DiagramNodeBase<DiagramConnectionPoint>
Visual Basic (Declaration)
Public Class DiagramNode _
    Inherits DiagramNodeBase(Of DiagramConnectionPoint)

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming.FlowDiagrams..::.EndNode
Mindscape.WpfDiagramming.FlowDiagrams..::.DecisionNode
Mindscape.WpfDiagramming.FlowDiagrams..::.StartNode
Mindscape.WpfDiagramming..::.TitleNode
Mindscape.WpfDiagramming..::.CommentNode
Mindscape.WpfDiagramming..::.ShapeNode
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode

See Also

DiagramNode Members
Mindscape.WpfDiagramming Namespace


DiagramNode Members

[image] [image]

Mindscape WPF Diagrams
DiagramNode Members
DiagramNode Class Constructors Methods Properties Events See Also Send Feedback

The DiagramNode type exposes the following members.

Constructors

Name | Description
DiagramNode |

Methods

Name | Description
Clone | Returns an IDiagramNodeState that represents the current state of this DiagramNodeBase at the time this method is called. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this DiagramNodeBase to match those of the given IDiagramNodeState. This method can be overriden to include the setting of other properties introduced by sub classes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns true. DiagramNodeBase objects can accept any number of out going connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanReceiveNewConnections | Returns true. DiagramNodeBase objects can accept any number of incomming connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. ConnectionPoints.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

DiagramNode Class
Mindscape.WpfDiagramming Namespace


DiagramNode Constructor

[image]

Mindscape WPF Diagrams
DiagramNode Constructor
DiagramNode Class See Also Send Feedback
Initializes a new instance of the DiagramNode class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramNode()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramNode Class
Mindscape.WpfDiagramming Namespace


DiagramNode Properties

[image] [image]

Mindscape WPF Diagrams
DiagramNode Properties
DiagramNode Class See Also Send Feedback

The DiagramNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns true. DiagramNodeBase objects can accept any number of out going connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanReceiveNewConnections | Returns true. DiagramNodeBase objects can accept any number of incomming connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. ConnectionPoints.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

DiagramNode Class
Mindscape.WpfDiagramming Namespace


ConnectionPoints Property

[image]

Mindscape WPF Diagrams
DiagramNode..::.ConnectionPoints Property
DiagramNode Class See Also Send Feedback
Gets the collection of connection points on this DiagramNode.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IList<DiagramConnectionPoint> ConnectionPoints { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ConnectionPoints As IList(Of DiagramConnectionPoint)

See Also

DiagramNode Class
Mindscape.WpfDiagramming Namespace


DiagramNodeTool Class

[image]

Mindscape WPF Diagrams
DiagramNodeTool Class
Members See Also Send Feedback
Represents a control which can be dragged from a toolbox onto a DiagramSurface to create new diagram nodes.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramNodeTool : ContentControl, IDiagramToolboxTool
Visual Basic (Declaration)
Public Class DiagramNodeTool _
    Inherits ContentControl _
    Implements IDiagramToolboxTool

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
Mindscape.WpfDiagramming..::.DiagramNodeTool

See Also

DiagramNodeTool Members
Mindscape.WpfDiagramming Namespace


DiagramNodeTool Members

[image] [image]

Mindscape WPF Diagrams
DiagramNodeTool Members
DiagramNodeTool Class Constructors Fields Properties Events See Also Send Feedback

The DiagramNodeTool type exposes the following members.

Constructors

Name | Description
DiagramNodeTool | Initializes a new instance of the DiagramNodeTool class.

Fields

Name | Description
BuilderProperty | Identifies the Builder property.
CursorVisualProperty | Identifies the CursorVisual property.
DiagramNodeToolDroppedEvent | Identifies the DiagramNodeToolDropped routed event.
ToolScopeProperty | Identifies the ToolScope property.

Properties

Name | Description
Builder | Gets or sets the IDiagramNodeBuilder which takes effect when the control is selected. This is a dependency property.
CursorVisual | Gets or sets the Visual displayed while dragging or when the cursor is charged. This is a dependency property.
ToolScope | Gets or sets the object within which the tool may be applied in a charged-cursor scenario. This is a dependency property.

Events

Name | Description
DiagramNodeToolDropped | Occurs when a user drags or drops the tool.

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


DiagramNodeTool Constructor

[image]

Mindscape WPF Diagrams
DiagramNodeTool Constructor
DiagramNodeTool Class See Also Send Feedback
Initializes a new instance of the DiagramNodeTool class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramNodeTool()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


DiagramNodeTool Fields

[image] [image]

Mindscape WPF Diagrams
DiagramNodeTool Fields
DiagramNodeTool Class See Also Send Feedback

The DiagramNodeTool type exposes the following members.

Fields

Name | Description
BuilderProperty | Identifies the Builder property.
CursorVisualProperty | Identifies the CursorVisual property.
DiagramNodeToolDroppedEvent | Identifies the DiagramNodeToolDropped routed event.
ToolScopeProperty | Identifies the ToolScope property.

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


BuilderProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.BuilderProperty Field
DiagramNodeTool Class See Also Send Feedback
Identifies the Builder property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty BuilderProperty
Visual Basic (Declaration)
Public Shared ReadOnly BuilderProperty As DependencyProperty

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


CursorVisualProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.CursorVisualProperty Field
DiagramNodeTool Class See Also Send Feedback
Identifies the CursorVisual property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CursorVisualProperty
Visual Basic (Declaration)
Public Shared ReadOnly CursorVisualProperty As DependencyProperty

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


DiagramNodeToolDroppedEvent Field

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.DiagramNodeToolDroppedEvent Field
DiagramNodeTool Class See Also Send Feedback
Identifies the DiagramNodeToolDropped routed event.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent DiagramNodeToolDroppedEvent
Visual Basic (Declaration)
Public Shared ReadOnly DiagramNodeToolDroppedEvent As RoutedEvent

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


ToolScopeProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.ToolScopeProperty Field
DiagramNodeTool Class See Also Send Feedback
Identifies the ToolScope property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ToolScopeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolScopeProperty As DependencyProperty

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


DiagramNodeTool Properties

[image] [image]

Mindscape WPF Diagrams
DiagramNodeTool Properties
DiagramNodeTool Class See Also Send Feedback

The DiagramNodeTool type exposes the following members.

Properties

Name | Description
Builder | Gets or sets the IDiagramNodeBuilder which takes effect when the control is selected. This is a dependency property.
CursorVisual | Gets or sets the Visual displayed while dragging or when the cursor is charged. This is a dependency property.
ToolScope | Gets or sets the object within which the tool may be applied in a charged-cursor scenario. This is a dependency property.

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


Builder Property

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.Builder Property
DiagramNodeTool Class See Also Send Feedback
Gets or sets the IDiagramNodeBuilder which takes effect when the control is selected. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramNodeBuilder Builder { get; set; }
Visual Basic (Declaration)
Public Property Builder As IDiagramNodeBuilder

Remarks

Dependency Property Information
Identifier field | BuilderProperty
Metadata properties set to true | None

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


CursorVisual Property

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.CursorVisual Property
DiagramNodeTool Class See Also Send Feedback
Gets or sets the Visual displayed while dragging or when the cursor is charged. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Visual CursorVisual { get; set; }
Visual Basic (Declaration)
Public Property CursorVisual As Visual

Remarks

Dependency Property Information
Identifier field | CursorVisualProperty
Metadata properties set to true | None

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


ToolScope Property

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.ToolScope Property
DiagramNodeTool Class See Also Send Feedback
Gets or sets the object within which the tool may be applied in a charged-cursor scenario. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DependencyObject ToolScope { get; set; }
Visual Basic (Declaration)
Public Property ToolScope As DependencyObject

Implements

IDiagramToolboxTool..::.ToolScope

Remarks

If null, the tool will not exhibit charged-cursor behaviour: it will support only drag-and-drop.

Dependency Property Information
Identifier field | ToolScopeProperty
Metadata properties set to true | None

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


DiagramNodeTool Events

[image] [image]

Mindscape WPF Diagrams
DiagramNodeTool Events
DiagramNodeTool Class See Also Send Feedback

The DiagramNodeTool type exposes the following members.

Events

Name | Description
DiagramNodeToolDropped | Occurs when a user drags or drops the tool.

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


DiagramNodeToolDropped Event

[image]

Mindscape WPF Diagrams
DiagramNodeTool..::.DiagramNodeToolDropped Event
DiagramNodeTool Class See Also Send Feedback
Occurs when a user drags or drops the tool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<DiagramNodeToolDroppedEventArgs> DiagramNodeToolDropped
Visual Basic (Declaration)
Public Event DiagramNodeToolDropped As EventHandler(Of DiagramNodeToolDroppedEventArgs)

See Also

DiagramNodeTool Class
Mindscape.WpfDiagramming Namespace


DiagramNodeToolDroppedEventArgs Class

[image]

Mindscape WPF Diagrams
DiagramNodeToolDroppedEventArgs Class
Members See Also Send Feedback
Provides information about the DiagramNodeToolDropped event of a DiagramNodeTool control.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramNodeToolDroppedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class DiagramNodeToolDroppedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming..::.DiagramNodeToolDroppedEventArgs

See Also

DiagramNodeToolDroppedEventArgs Members
Mindscape.WpfDiagramming Namespace


DiagramNodeToolDroppedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
DiagramNodeToolDroppedEventArgs Members
DiagramNodeToolDroppedEventArgs Class Constructors Properties See Also Send Feedback

The DiagramNodeToolDroppedEventArgs type exposes the following members.

Constructors

Name | Description
DiagramNodeToolDroppedEventArgs | Initializes a new instance of the DiagramNodeToolDroppedEventArgs class.

Properties

Name | Description
Bounds | Gets the bounds of the drop, in thumb coordinates.
Builder | Gets the IDiagramNodeBuilder associated with the dropped tool.
UseDefaultSize | Gets whether the node should be created with the default size (i.e. the tool was dropped) rather than being sized according to the Bounds (i.e. a click-drag-size).

See Also

DiagramNodeToolDroppedEventArgs Class
Mindscape.WpfDiagramming Namespace


DiagramNodeToolDroppedEventArgs Constructor

[image]

Mindscape WPF Diagrams
DiagramNodeToolDroppedEventArgs Constructor
DiagramNodeToolDroppedEventArgs Class See Also Send Feedback
Initializes a new instance of the DiagramNodeToolDroppedEventArgs class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramNodeToolDroppedEventArgs(
    IDiagramNodeBuilder builder,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub New ( _
    builder As IDiagramNodeBuilder, _
    bounds As Rect _
)

Parameters

builder
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNodeBuilder
The IDiagramNodeBuilder associated with the dropped tool.
bounds
Type: System.Windows..::.Rect
The bounds of the drop, in tool coordinates.

See Also

DiagramNodeToolDroppedEventArgs Class
Mindscape.WpfDiagramming Namespace


DiagramNodeToolDroppedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
DiagramNodeToolDroppedEventArgs Properties
DiagramNodeToolDroppedEventArgs Class See Also Send Feedback

The DiagramNodeToolDroppedEventArgs type exposes the following members.

Properties

Name | Description
Bounds | Gets the bounds of the drop, in thumb coordinates.
Builder | Gets the IDiagramNodeBuilder associated with the dropped tool.
UseDefaultSize | Gets whether the node should be created with the default size (i.e. the tool was dropped) rather than being sized according to the Bounds (i.e. a click-drag-size).

See Also

DiagramNodeToolDroppedEventArgs Class
Mindscape.WpfDiagramming Namespace


Bounds Property

[image]

Mindscape WPF Diagrams
DiagramNodeToolDroppedEventArgs..::.Bounds Property
DiagramNodeToolDroppedEventArgs Class See Also Send Feedback
Gets the bounds of the drop, in thumb coordinates.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect Bounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bounds As Rect

See Also

DiagramNodeToolDroppedEventArgs Class
Mindscape.WpfDiagramming Namespace


Builder Property

[image]

Mindscape WPF Diagrams
DiagramNodeToolDroppedEventArgs..::.Builder Property
DiagramNodeToolDroppedEventArgs Class See Also Send Feedback
Gets the IDiagramNodeBuilder associated with the dropped tool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramNodeBuilder Builder { get; }
Visual Basic (Declaration)
Public ReadOnly Property Builder As IDiagramNodeBuilder

See Also

DiagramNodeToolDroppedEventArgs Class
Mindscape.WpfDiagramming Namespace


UseDefaultSize Property

[image]

Mindscape WPF Diagrams
DiagramNodeToolDroppedEventArgs..::.UseDefaultSize Property
DiagramNodeToolDroppedEventArgs Class See Also Send Feedback
Gets whether the node should be created with the default size (i.e. the tool was dropped) rather than being sized according to the Bounds (i.e. a click-drag-size).

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool UseDefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseDefaultSize As Boolean

See Also

DiagramNodeToolDroppedEventArgs Class
Mindscape.WpfDiagramming Namespace


DiagramPrinter Class

[image]

Mindscape WPF Diagrams
DiagramPrinter Class
Members See Also Send Feedback
Provides support for printing diagrams.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramPrinter : DependencyObject
Visual Basic (Declaration)
Public Class DiagramPrinter _
    Inherits DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
Mindscape.WpfDiagramming..::.DiagramPrinter

See Also

DiagramPrinter Members
Mindscape.WpfDiagramming Namespace


DiagramPrinter Members

[image] [image]

Mindscape WPF Diagrams
DiagramPrinter Members
DiagramPrinter Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramPrinter type exposes the following members.

Constructors

Name | Description
DiagramPrinter |

Methods

Name | Description
GetPrintDocument | Overloaded.

Fields

Name | Description
DiagramProperty | Identifies the Diagram property.
FormatterProperty | Identifies the Formatter property.
PrintCallbackProperty | Identifies the PrintCallback property.
ZoomProperty | Identifies the Zoom property.

Properties

Name | Description
Diagram | Gets or sets the diagram to be printed. This is a dependency property.
Formatter | Gets or sets formatting and display settings for the diagram. This is a dependency property.
PrintCallback | Gets or sets the callback for additional printing. This is a dependency property.
Zoom | Gets or sets the zoom level. This is a dependency property.

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


DiagramPrinter Constructor

[image]

Mindscape WPF Diagrams
DiagramPrinter Constructor
DiagramPrinter Class See Also Send Feedback
Initializes a new instance of the DiagramPrinter class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramPrinter()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


DiagramPrinter Fields

[image] [image]

Mindscape WPF Diagrams
DiagramPrinter Fields
DiagramPrinter Class See Also Send Feedback

The DiagramPrinter type exposes the following members.

Fields

Name | Description
DiagramProperty | Identifies the Diagram property.
FormatterProperty | Identifies the Formatter property.
PrintCallbackProperty | Identifies the PrintCallback property.
ZoomProperty | Identifies the Zoom property.

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


DiagramProperty Field

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.DiagramProperty Field
DiagramPrinter Class See Also Send Feedback
Identifies the Diagram property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty DiagramProperty
Visual Basic (Declaration)
Public Shared ReadOnly DiagramProperty As DependencyProperty

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


FormatterProperty Field

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.FormatterProperty Field
DiagramPrinter Class See Also Send Feedback
Identifies the Formatter property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty FormatterProperty
Visual Basic (Declaration)
Public Shared ReadOnly FormatterProperty As DependencyProperty

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


PrintCallbackProperty Field

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.PrintCallbackProperty Field
DiagramPrinter Class See Also Send Feedback
Identifies the PrintCallback property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty PrintCallbackProperty
Visual Basic (Declaration)
Public Shared ReadOnly PrintCallbackProperty As DependencyProperty

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


ZoomProperty Field

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.ZoomProperty Field
DiagramPrinter Class See Also Send Feedback
Identifies the Zoom property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ZoomProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomProperty As DependencyProperty

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


DiagramPrinter Methods

[image] [image]

Mindscape WPF Diagrams
DiagramPrinter Methods
DiagramPrinter Class See Also Send Feedback

Methods

Name | Description
GetPrintDocument | Overloaded.

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


GetPrintDocument Method

[image] [image]

Mindscape WPF Diagrams
DiagramPrinter..::.GetPrintDocument Method
DiagramPrinter Class See Also Send Feedback

Overload List

Name | Description
GetPrintDocument(PrintDocumentImageableArea) | Gets a DiagramPrintDocument sized to the specified PrintDocumentImageableArea.
GetPrintDocument(Size, Point, Size) | Gets a DiagramPrintDocument sized to the specified printing dimensions.

See Also

DiagramPrinter Class
DiagramPrinter Members
Mindscape.WpfDiagramming Namespace


GetPrintDocument Method (PrintDocumentImageableArea)

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.GetPrintDocument Method (PrintDocumentImageableArea)
DiagramPrinter Class See Also Send Feedback
Gets a DiagramPrintDocument sized to the specified PrintDocumentImageableArea.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramPrintDocument GetPrintDocument(
    PrintDocumentImageableArea imageableArea
)
Visual Basic (Declaration)
Public Function GetPrintDocument ( _
    imageableArea As PrintDocumentImageableArea _
) As DiagramPrintDocument

Parameters

imageableArea
Type: System.Printing..::.PrintDocumentImageableArea
The imageable area of the print target.

Return Value

A DiagramPrintDocument sized to the specified imageable area.

See Also

DiagramPrinter Class
GetPrintDocument Overload
Mindscape.WpfDiagramming Namespace


GetPrintDocument Method (Size, Point, Size)

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.GetPrintDocument Method (Size, Point, Size)
DiagramPrinter Class See Also Send Feedback
Gets a DiagramPrintDocument sized to the specified printing dimensions.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramPrintDocument GetPrintDocument(
    Size pageSize,
    Point printableOrigin,
    Size printableSize
)
Visual Basic (Declaration)
Public Function GetPrintDocument ( _
    pageSize As Size, _
    printableOrigin As Point, _
    printableSize As Size _
) As DiagramPrintDocument

Parameters

pageSize
Type: System.Windows..::.Size
The total page size.
printableOrigin
Type: System.Windows..::.Point
The top left of the printable area.
printableSize
Type: System.Windows..::.Size
The size of the printable area.

Return Value

A DiagramPrintDocument sized to the specified dimensions.

See Also

DiagramPrinter Class
GetPrintDocument Overload
Mindscape.WpfDiagramming Namespace


DiagramPrinter Properties

[image] [image]

Mindscape WPF Diagrams
DiagramPrinter Properties
DiagramPrinter Class See Also Send Feedback

The DiagramPrinter type exposes the following members.

Properties

Name | Description
Diagram | Gets or sets the diagram to be printed. This is a dependency property.
Formatter | Gets or sets formatting and display settings for the diagram. This is a dependency property.
PrintCallback | Gets or sets the callback for additional printing. This is a dependency property.
Zoom | Gets or sets the zoom level. This is a dependency property.

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


Diagram Property

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.Diagram Property
DiagramPrinter Class See Also Send Feedback
Gets or sets the diagram to be printed. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramModel Diagram { get; set; }
Visual Basic (Declaration)
Public Property Diagram As IDiagramModel

Remarks

Dependency Property Information
Identifier field | DiagramProperty
Metadata properties set to true | None

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


Formatter Property

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.Formatter Property
DiagramPrinter Class See Also Send Feedback
Gets or sets formatting and display settings for the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramFormatter Formatter { get; set; }
Visual Basic (Declaration)
Public Property Formatter As IDiagramFormatter

Remarks

Dependency Property Information
Identifier field | FormatterProperty
Metadata properties set to true | None

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


PrintCallback Property

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.PrintCallback Property
DiagramPrinter Class See Also Send Feedback
Gets or sets the callback for additional printing. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramPrintCallback PrintCallback { get; set; }
Visual Basic (Declaration)
Public Property PrintCallback As IDiagramPrintCallback

Remarks

Dependency Property Information
Identifier field | PrintCallbackProperty
Metadata properties set to true | None

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


Zoom Property

[image]

Mindscape WPF Diagrams
DiagramPrinter..::.Zoom Property
DiagramPrinter Class See Also Send Feedback
Gets or sets the zoom level. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Double

Remarks

Dependency Property Information
Identifier field | ZoomProperty
Metadata properties set to true | None

See Also

DiagramPrinter Class
Mindscape.WpfDiagramming Namespace


DiagramShape Class

[image]

Mindscape WPF Diagrams
DiagramShape Class
Members See Also Send Feedback
Represents a geometrical shape in a diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramShape
Visual Basic (Declaration)
Public Class DiagramShape

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramShape

See Also

DiagramShape Members
Mindscape.WpfDiagramming Namespace


DiagramShape Members

[image] [image]

Mindscape WPF Diagrams
DiagramShape Members
DiagramShape Class Constructors Methods Properties See Also Send Feedback

The DiagramShape type exposes the following members.

Constructors

Name | Description
DiagramShape | Initializes a new instance of the DiagramShape class.

Methods

Name | Description
Freeze | Freezes the DiagramShape so that it cannot be modified.
ToString | Provides a string representation of the DiagramShape. (Overrides Object ..::. ToString()()().)

Properties

Name | Description
BottomConnectionPointCount | Gets or sets the number of connection points on the shape's bottom edge.
DefaultSize | Gets or sets the default size when creating nodes of this shape.
DisplayName | Gets or sets a display name which can be used in tooltips or other user interface text to identify the shape.
LeftConnectionPointCount | Gets or sets the number of connection points on the shape's left edge.
Name | Gets the name of the shape.
RightConnectionPointCount | Gets or sets the number of connection points on the shape's right edge.
TopConnectionPointCount | Gets or sets the number of connection points on the shape's top edge.

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


DiagramShape Constructor

[image]

Mindscape WPF Diagrams
DiagramShape Constructor
DiagramShape Class See Also Send Feedback
Initializes a new instance of the DiagramShape class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramShape(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
The name of the shape.

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


DiagramShape Methods

[image] [image]

Mindscape WPF Diagrams
DiagramShape Methods
DiagramShape Class See Also Send Feedback

The DiagramShape type exposes the following members.

Methods

Name | Description
Freeze | Freezes the DiagramShape so that it cannot be modified.
ToString | Provides a string representation of the DiagramShape. (Overrides Object ..::. ToString()()().)

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


Freeze Method

[image]

Mindscape WPF Diagrams
DiagramShape..::.Freeze Method
DiagramShape Class See Also Send Feedback
Freezes the DiagramShape so that it cannot be modified.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramShape Freeze()
Visual Basic (Declaration)
Public Function Freeze As DiagramShape

Return Value

The frozen DiagramShape.

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


ToString Method

[image]

Mindscape WPF Diagrams
DiagramShape..::.ToString Method
DiagramShape Class See Also Send Feedback
Provides a string representation of the DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string representation of the DiagramShape

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


DiagramShape Properties

[image] [image]

Mindscape WPF Diagrams
DiagramShape Properties
DiagramShape Class See Also Send Feedback

The DiagramShape type exposes the following members.

Properties

Name | Description
BottomConnectionPointCount | Gets or sets the number of connection points on the shape's bottom edge.
DefaultSize | Gets or sets the default size when creating nodes of this shape.
DisplayName | Gets or sets a display name which can be used in tooltips or other user interface text to identify the shape.
LeftConnectionPointCount | Gets or sets the number of connection points on the shape's left edge.
Name | Gets the name of the shape.
RightConnectionPointCount | Gets or sets the number of connection points on the shape's right edge.
TopConnectionPointCount | Gets or sets the number of connection points on the shape's top edge.

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


BottomConnectionPointCount Property

[image]

Mindscape WPF Diagrams
DiagramShape..::.BottomConnectionPointCount Property
DiagramShape Class See Also Send Feedback
Gets or sets the number of connection points on the shape's bottom edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int BottomConnectionPointCount { get; set; }
Visual Basic (Declaration)
Public Property BottomConnectionPointCount As Integer

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
DiagramShape..::.DefaultSize Property
DiagramShape Class See Also Send Feedback
Gets or sets the default size when creating nodes of this shape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; set; }
Visual Basic (Declaration)
Public Property DefaultSize As Size

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


DisplayName Property

[image]

Mindscape WPF Diagrams
DiagramShape..::.DisplayName Property
DiagramShape Class See Also Send Feedback
Gets or sets a display name which can be used in tooltips or other user interface text to identify the shape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


LeftConnectionPointCount Property

[image]

Mindscape WPF Diagrams
DiagramShape..::.LeftConnectionPointCount Property
DiagramShape Class See Also Send Feedback
Gets or sets the number of connection points on the shape's left edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int LeftConnectionPointCount { get; set; }
Visual Basic (Declaration)
Public Property LeftConnectionPointCount As Integer

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


Name Property

[image]

Mindscape WPF Diagrams
DiagramShape..::.Name Property
DiagramShape Class See Also Send Feedback
Gets the name of the shape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


RightConnectionPointCount Property

[image]

Mindscape WPF Diagrams
DiagramShape..::.RightConnectionPointCount Property
DiagramShape Class See Also Send Feedback
Gets or sets the number of connection points on the shape's right edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int RightConnectionPointCount { get; set; }
Visual Basic (Declaration)
Public Property RightConnectionPointCount As Integer

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


TopConnectionPointCount Property

[image]

Mindscape WPF Diagrams
DiagramShape..::.TopConnectionPointCount Property
DiagramShape Class See Also Send Feedback
Gets or sets the number of connection points on the shape's top edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int TopConnectionPointCount { get; set; }
Visual Basic (Declaration)
Public Property TopConnectionPointCount As Integer

See Also

DiagramShape Class
Mindscape.WpfDiagramming Namespace


DiagramShapes Class

[image]

Mindscape WPF Diagrams
DiagramShapes Class
Members See Also Send Feedback
Contains standard shapes for use in diagrams.
DiagramShapes

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramShapes : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class DiagramShapes _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming..::.DiagramShapes

See Also

DiagramShapes Members
Mindscape.WpfDiagramming Namespace


DiagramShapes Members

[image] [image]

Mindscape WPF Diagrams
DiagramShapes Members
DiagramShapes Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramShapes type exposes the following members.

Constructors

Name | Description
DiagramShapes | Initializes a new instance of the DiagramShapes resource dictionary.

Methods

Name | Description
InitializeComponent | InitializeComponent

Fields

Name | Description
AlternateProcess | Represents
BentArrow | Represents an arrow initially pointing upwards, but then bends to the right.
BentUpArrow | Represents an angular arrow that initially point right, but then angles upwards.
Card | Represents
Chevron | Represents
CircularArrow | Represents
Collate | Represents
Connector | Represents
CurvedDownArrow | Represents an arrow curving downwards.
CurvedLeftArrow | Represents an arrow curving to the left.
CurvedRightArrow | Represents an arrow curving to the right.
CurvedUpArrow | Represents an arrow curving upwards.
Data | Represents
Decision | Represents
Delay | Represents
Diamond | Represents a diamond.
DirectAccessStorage | Represents
Display | Represents
Document | Represents
DownArrow | Represents an arrow pointing down.
DownArrowCallout | Represents
Ellipse | Represents an ellipse.
Extract | Represents
FivePointStar | Represents a five pointed star.
FourPointStar | Represents four pointed star.
Hexagon | Represents a regular hexagon.
InternalStorage | Represents
IsoscelesTriangle | Represents an isosceles triangle.
LeftArrow | Represents an arrow pointing left.
LeftArrowCallout | Represents
LeftRightArrow | Represents a two-way arrow pointing left and right.
LeftRightArrowCallout | Represents
LeftRightUpArrow | Represents a three-way arrow pointing left, right and up.
LeftUpArrow | Represents a two-way arrow pointing left and up.
MagneticDisk | Represents
ManualInput | Represents
ManualOperation | Represents
Merge | Represents
Multidocument | Represents
NotchedRightArrow | Represents
OffPageConnector | Represents
Or | Represents
Parallelogram | Represents a parallelogram.
Pentagon | Represents
PredefinedProcess | Represents
Preparation | Represents
Process | Represents
PunchedTape | Represents
QuadArrow | Represents an arrow pointing in all 4 directions.
QuadArrowCallout | Represents
Rectangle | Represents a rectangle.
RegularPentagon | Represents a regular pentagon.
RightArrow | Represents an arrow pointing right.
RightArrowCallout | Represents
RightTriangle | Represents a right angled triangle.
RoundDiagonalCornerRectangle | Represents a rectangle with top-left and bottom-right rounded corners.
RoundedRectangle | Represents a rectangle with rounded corners.
RoundSameSideCornerRectangle | Represents a rectangle with two rounded corner on the top edge.
RoundSingleCornerRectangle | Represents a rectangle with a top-right rounded corner.
SequentialAccessStorage | Represents
SnipAndRoundSingleCornerRectangle | Represents a rectangle with a top-left rounded corner and a top-right beveled corner.
SnipDiagonalCornerRectangle | Represents a rectangle with the top-right and bottom-left corners beveled.
SnipSameSideCornerRectangle | Represents a rectangle with the top two corners beveled.
SnipSingleCornerRectangle | Represents a rectangle with a top-right beveled corner.
Sort | Represents
StoredData | Represents
StripedRightArrow | Represents
SummingJunction | Represents
Teardrop | Represents a teardrop.
Terminator | Represents
Trapezoid | Represents a trapezium.
UpArrow | Represents an arrow pointing up.
UpArrowCallout | Represents
UpDownArrow | Represents a two-way arrow pointing up and down.
UTurnArrow | Represents a u-turn arrow.

Properties

Name | Description
CommentNodeToolKey | Gets the ResourceKey for the DiagramNodeTool representing a toolbox entry for CommentNode nodes.
DefaultConnectionContentTemplateKey | Gets the ResourceKey for the DataTemplate representing the default connection content (a text box).
DefaultConnectionPointTemplateKey | Gets the ResourceKey for the DataTemplate representing the default appearance of connection points.
DefaultNodeContentTemplateKey | Gets the ResourceKey for the DataTemplate representing the default node content (a text box).
DefaultShapePathStyleKey | Gets the ResourceKey for the Style representing the default style for diagram shapes.
TitleNodeToolKey | Gets the ResourceKey for the DiagramNodeTool representing a toolbox entry for TitleNode nodes.

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DiagramShapes Constructor

[image]

Mindscape WPF Diagrams
DiagramShapes Constructor
DiagramShapes Class See Also Send Feedback
Initializes a new instance of the DiagramShapes resource dictionary.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramShapes()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DiagramShapes Fields

[image] [image]

Mindscape WPF Diagrams
DiagramShapes Fields
DiagramShapes Class See Also Send Feedback

The DiagramShapes type exposes the following members.

Fields

Name | Description
AlternateProcess | Represents
BentArrow | Represents an arrow initially pointing upwards, but then bends to the right.
BentUpArrow | Represents an angular arrow that initially point right, but then angles upwards.
Card | Represents
Chevron | Represents
CircularArrow | Represents
Collate | Represents
Connector | Represents
CurvedDownArrow | Represents an arrow curving downwards.
CurvedLeftArrow | Represents an arrow curving to the left.
CurvedRightArrow | Represents an arrow curving to the right.
CurvedUpArrow | Represents an arrow curving upwards.
Data | Represents
Decision | Represents
Delay | Represents
Diamond | Represents a diamond.
DirectAccessStorage | Represents
Display | Represents
Document | Represents
DownArrow | Represents an arrow pointing down.
DownArrowCallout | Represents
Ellipse | Represents an ellipse.
Extract | Represents
FivePointStar | Represents a five pointed star.
FourPointStar | Represents four pointed star.
Hexagon | Represents a regular hexagon.
InternalStorage | Represents
IsoscelesTriangle | Represents an isosceles triangle.
LeftArrow | Represents an arrow pointing left.
LeftArrowCallout | Represents
LeftRightArrow | Represents a two-way arrow pointing left and right.
LeftRightArrowCallout | Represents
LeftRightUpArrow | Represents a three-way arrow pointing left, right and up.
LeftUpArrow | Represents a two-way arrow pointing left and up.
MagneticDisk | Represents
ManualInput | Represents
ManualOperation | Represents
Merge | Represents
Multidocument | Represents
NotchedRightArrow | Represents
OffPageConnector | Represents
Or | Represents
Parallelogram | Represents a parallelogram.
Pentagon | Represents
PredefinedProcess | Represents
Preparation | Represents
Process | Represents
PunchedTape | Represents
QuadArrow | Represents an arrow pointing in all 4 directions.
QuadArrowCallout | Represents
Rectangle | Represents a rectangle.
RegularPentagon | Represents a regular pentagon.
RightArrow | Represents an arrow pointing right.
RightArrowCallout | Represents
RightTriangle | Represents a right angled triangle.
RoundDiagonalCornerRectangle | Represents a rectangle with top-left and bottom-right rounded corners.
RoundedRectangle | Represents a rectangle with rounded corners.
RoundSameSideCornerRectangle | Represents a rectangle with two rounded corner on the top edge.
RoundSingleCornerRectangle | Represents a rectangle with a top-right rounded corner.
SequentialAccessStorage | Represents
SnipAndRoundSingleCornerRectangle | Represents a rectangle with a top-left rounded corner and a top-right beveled corner.
SnipDiagonalCornerRectangle | Represents a rectangle with the top-right and bottom-left corners beveled.
SnipSameSideCornerRectangle | Represents a rectangle with the top two corners beveled.
SnipSingleCornerRectangle | Represents a rectangle with a top-right beveled corner.
Sort | Represents
StoredData | Represents
StripedRightArrow | Represents
SummingJunction | Represents
Teardrop | Represents a teardrop.
Terminator | Represents
Trapezoid | Represents a trapezium.
UpArrow | Represents an arrow pointing up.
UpArrowCallout | Represents
UpDownArrow | Represents a two-way arrow pointing up and down.
UTurnArrow | Represents a u-turn arrow.

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


AlternateProcess Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.AlternateProcess Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape AlternateProcess
Visual Basic (Declaration)
Public Shared ReadOnly AlternateProcess As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


BentArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.BentArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow initially pointing upwards, but then bends to the right.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape BentArrow
Visual Basic (Declaration)
Public Shared ReadOnly BentArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


BentUpArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.BentUpArrow Field
DiagramShapes Class See Also Send Feedback
Represents an angular arrow that initially point right, but then angles upwards.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape BentUpArrow
Visual Basic (Declaration)
Public Shared ReadOnly BentUpArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Card Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Card Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Card
Visual Basic (Declaration)
Public Shared ReadOnly Card As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Chevron Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Chevron Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Chevron
Visual Basic (Declaration)
Public Shared ReadOnly Chevron As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


CircularArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.CircularArrow Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape CircularArrow
Visual Basic (Declaration)
Public Shared ReadOnly CircularArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Collate Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Collate Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Collate
Visual Basic (Declaration)
Public Shared ReadOnly Collate As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Connector Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Connector Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Connector
Visual Basic (Declaration)
Public Shared ReadOnly Connector As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


CurvedDownArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.CurvedDownArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow curving downwards.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape CurvedDownArrow
Visual Basic (Declaration)
Public Shared ReadOnly CurvedDownArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


CurvedLeftArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.CurvedLeftArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow curving to the left.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape CurvedLeftArrow
Visual Basic (Declaration)
Public Shared ReadOnly CurvedLeftArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


CurvedRightArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.CurvedRightArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow curving to the right.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape CurvedRightArrow
Visual Basic (Declaration)
Public Shared ReadOnly CurvedRightArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


CurvedUpArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.CurvedUpArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow curving upwards.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape CurvedUpArrow
Visual Basic (Declaration)
Public Shared ReadOnly CurvedUpArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Data Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Data Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Data
Visual Basic (Declaration)
Public Shared ReadOnly Data As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Decision Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Decision Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Decision
Visual Basic (Declaration)
Public Shared ReadOnly Decision As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Delay Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Delay Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Delay
Visual Basic (Declaration)
Public Shared ReadOnly Delay As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Diamond Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Diamond Field
DiagramShapes Class See Also Send Feedback
Represents a diamond.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Diamond
Visual Basic (Declaration)
Public Shared ReadOnly Diamond As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DirectAccessStorage Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.DirectAccessStorage Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape DirectAccessStorage
Visual Basic (Declaration)
Public Shared ReadOnly DirectAccessStorage As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Display Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Display Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Display
Visual Basic (Declaration)
Public Shared ReadOnly Display As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Document Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Document Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Document
Visual Basic (Declaration)
Public Shared ReadOnly Document As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DownArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.DownArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow pointing down.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape DownArrow
Visual Basic (Declaration)
Public Shared ReadOnly DownArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DownArrowCallout Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.DownArrowCallout Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape DownArrowCallout
Visual Basic (Declaration)
Public Shared ReadOnly DownArrowCallout As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Ellipse Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Ellipse Field
DiagramShapes Class See Also Send Feedback
Represents an ellipse.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Ellipse
Visual Basic (Declaration)
Public Shared ReadOnly Ellipse As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Extract Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Extract Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Extract
Visual Basic (Declaration)
Public Shared ReadOnly Extract As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


FivePointStar Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.FivePointStar Field
DiagramShapes Class See Also Send Feedback
Represents a five pointed star.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape FivePointStar
Visual Basic (Declaration)
Public Shared ReadOnly FivePointStar As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


FourPointStar Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.FourPointStar Field
DiagramShapes Class See Also Send Feedback
Represents four pointed star.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape FourPointStar
Visual Basic (Declaration)
Public Shared ReadOnly FourPointStar As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Hexagon Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Hexagon Field
DiagramShapes Class See Also Send Feedback
Represents a regular hexagon.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Hexagon
Visual Basic (Declaration)
Public Shared ReadOnly Hexagon As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


InternalStorage Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.InternalStorage Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape InternalStorage
Visual Basic (Declaration)
Public Shared ReadOnly InternalStorage As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


IsoscelesTriangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.IsoscelesTriangle Field
DiagramShapes Class See Also Send Feedback
Represents an isosceles triangle.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape IsoscelesTriangle
Visual Basic (Declaration)
Public Shared ReadOnly IsoscelesTriangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


LeftArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.LeftArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow pointing left.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape LeftArrow
Visual Basic (Declaration)
Public Shared ReadOnly LeftArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


LeftArrowCallout Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.LeftArrowCallout Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape LeftArrowCallout
Visual Basic (Declaration)
Public Shared ReadOnly LeftArrowCallout As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


LeftRightArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.LeftRightArrow Field
DiagramShapes Class See Also Send Feedback
Represents a two-way arrow pointing left and right.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape LeftRightArrow
Visual Basic (Declaration)
Public Shared ReadOnly LeftRightArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


LeftRightArrowCallout Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.LeftRightArrowCallout Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape LeftRightArrowCallout
Visual Basic (Declaration)
Public Shared ReadOnly LeftRightArrowCallout As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


LeftRightUpArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.LeftRightUpArrow Field
DiagramShapes Class See Also Send Feedback
Represents a three-way arrow pointing left, right and up.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape LeftRightUpArrow
Visual Basic (Declaration)
Public Shared ReadOnly LeftRightUpArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


LeftUpArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.LeftUpArrow Field
DiagramShapes Class See Also Send Feedback
Represents a two-way arrow pointing left and up.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape LeftUpArrow
Visual Basic (Declaration)
Public Shared ReadOnly LeftUpArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


MagneticDisk Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.MagneticDisk Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape MagneticDisk
Visual Basic (Declaration)
Public Shared ReadOnly MagneticDisk As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


ManualInput Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.ManualInput Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape ManualInput
Visual Basic (Declaration)
Public Shared ReadOnly ManualInput As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


ManualOperation Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.ManualOperation Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape ManualOperation
Visual Basic (Declaration)
Public Shared ReadOnly ManualOperation As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Merge Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Merge Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Merge
Visual Basic (Declaration)
Public Shared ReadOnly Merge As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Multidocument Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Multidocument Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Multidocument
Visual Basic (Declaration)
Public Shared ReadOnly Multidocument As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


NotchedRightArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.NotchedRightArrow Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape NotchedRightArrow
Visual Basic (Declaration)
Public Shared ReadOnly NotchedRightArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


OffPageConnector Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.OffPageConnector Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape OffPageConnector
Visual Basic (Declaration)
Public Shared ReadOnly OffPageConnector As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Or Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Or Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Or
Visual Basic (Declaration)
Public Shared ReadOnly Or As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Parallelogram Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Parallelogram Field
DiagramShapes Class See Also Send Feedback
Represents a parallelogram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Parallelogram
Visual Basic (Declaration)
Public Shared ReadOnly Parallelogram As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Pentagon Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Pentagon Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Pentagon
Visual Basic (Declaration)
Public Shared ReadOnly Pentagon As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


PredefinedProcess Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.PredefinedProcess Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape PredefinedProcess
Visual Basic (Declaration)
Public Shared ReadOnly PredefinedProcess As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Preparation Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Preparation Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Preparation
Visual Basic (Declaration)
Public Shared ReadOnly Preparation As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Process Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Process Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Process
Visual Basic (Declaration)
Public Shared ReadOnly Process As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


PunchedTape Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.PunchedTape Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape PunchedTape
Visual Basic (Declaration)
Public Shared ReadOnly PunchedTape As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


QuadArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.QuadArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow pointing in all 4 directions.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape QuadArrow
Visual Basic (Declaration)
Public Shared ReadOnly QuadArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


QuadArrowCallout Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.QuadArrowCallout Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape QuadArrowCallout
Visual Basic (Declaration)
Public Shared ReadOnly QuadArrowCallout As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Rectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Rectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Rectangle
Visual Basic (Declaration)
Public Shared ReadOnly Rectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RegularPentagon Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RegularPentagon Field
DiagramShapes Class See Also Send Feedback
Represents a regular pentagon.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RegularPentagon
Visual Basic (Declaration)
Public Shared ReadOnly RegularPentagon As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RightArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RightArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow pointing right.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RightArrow
Visual Basic (Declaration)
Public Shared ReadOnly RightArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RightArrowCallout Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RightArrowCallout Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RightArrowCallout
Visual Basic (Declaration)
Public Shared ReadOnly RightArrowCallout As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RightTriangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RightTriangle Field
DiagramShapes Class See Also Send Feedback
Represents a right angled triangle.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RightTriangle
Visual Basic (Declaration)
Public Shared ReadOnly RightTriangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RoundDiagonalCornerRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RoundDiagonalCornerRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with top-left and bottom-right rounded corners.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RoundDiagonalCornerRectangle
Visual Basic (Declaration)
Public Shared ReadOnly RoundDiagonalCornerRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RoundedRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RoundedRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with rounded corners.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RoundedRectangle
Visual Basic (Declaration)
Public Shared ReadOnly RoundedRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RoundSameSideCornerRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RoundSameSideCornerRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with two rounded corner on the top edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RoundSameSideCornerRectangle
Visual Basic (Declaration)
Public Shared ReadOnly RoundSameSideCornerRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


RoundSingleCornerRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.RoundSingleCornerRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with a top-right rounded corner.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape RoundSingleCornerRectangle
Visual Basic (Declaration)
Public Shared ReadOnly RoundSingleCornerRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


SequentialAccessStorage Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.SequentialAccessStorage Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape SequentialAccessStorage
Visual Basic (Declaration)
Public Shared ReadOnly SequentialAccessStorage As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


SnipAndRoundSingleCornerRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.SnipAndRoundSingleCornerRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with a top-left rounded corner and a top-right beveled corner.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape SnipAndRoundSingleCornerRectangle
Visual Basic (Declaration)
Public Shared ReadOnly SnipAndRoundSingleCornerRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


SnipDiagonalCornerRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.SnipDiagonalCornerRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with the top-right and bottom-left corners beveled.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape SnipDiagonalCornerRectangle
Visual Basic (Declaration)
Public Shared ReadOnly SnipDiagonalCornerRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


SnipSameSideCornerRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.SnipSameSideCornerRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with the top two corners beveled.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape SnipSameSideCornerRectangle
Visual Basic (Declaration)
Public Shared ReadOnly SnipSameSideCornerRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


SnipSingleCornerRectangle Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.SnipSingleCornerRectangle Field
DiagramShapes Class See Also Send Feedback
Represents a rectangle with a top-right beveled corner.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape SnipSingleCornerRectangle
Visual Basic (Declaration)
Public Shared ReadOnly SnipSingleCornerRectangle As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Sort Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Sort Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Sort
Visual Basic (Declaration)
Public Shared ReadOnly Sort As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


StoredData Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.StoredData Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape StoredData
Visual Basic (Declaration)
Public Shared ReadOnly StoredData As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


StripedRightArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.StripedRightArrow Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape StripedRightArrow
Visual Basic (Declaration)
Public Shared ReadOnly StripedRightArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


SummingJunction Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.SummingJunction Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape SummingJunction
Visual Basic (Declaration)
Public Shared ReadOnly SummingJunction As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Teardrop Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Teardrop Field
DiagramShapes Class See Also Send Feedback
Represents a teardrop.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Teardrop
Visual Basic (Declaration)
Public Shared ReadOnly Teardrop As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Terminator Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Terminator Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Terminator
Visual Basic (Declaration)
Public Shared ReadOnly Terminator As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


Trapezoid Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.Trapezoid Field
DiagramShapes Class See Also Send Feedback
Represents a trapezium.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape Trapezoid
Visual Basic (Declaration)
Public Shared ReadOnly Trapezoid As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


UpArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.UpArrow Field
DiagramShapes Class See Also Send Feedback
Represents an arrow pointing up.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape UpArrow
Visual Basic (Declaration)
Public Shared ReadOnly UpArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


UpArrowCallout Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.UpArrowCallout Field
DiagramShapes Class See Also Send Feedback
Represents

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape UpArrowCallout
Visual Basic (Declaration)
Public Shared ReadOnly UpArrowCallout As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


UpDownArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.UpDownArrow Field
DiagramShapes Class See Also Send Feedback
Represents a two-way arrow pointing up and down.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape UpDownArrow
Visual Basic (Declaration)
Public Shared ReadOnly UpDownArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


UTurnArrow Field

[image]

Mindscape WPF Diagrams
DiagramShapes..::.UTurnArrow Field
DiagramShapes Class See Also Send Feedback
Represents a u-turn arrow.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DiagramShape UTurnArrow
Visual Basic (Declaration)
Public Shared ReadOnly UTurnArrow As DiagramShape

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DiagramShapes Methods

[image] [image]

Mindscape WPF Diagrams
DiagramShapes Methods
DiagramShapes Class See Also Send Feedback

The DiagramShapes type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
DiagramShapes..::.InitializeComponent Method
DiagramShapes Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DiagramShapes Properties

[image] [image]

Mindscape WPF Diagrams
DiagramShapes Properties
DiagramShapes Class See Also Send Feedback

The DiagramShapes type exposes the following members.

Properties

Name | Description
CommentNodeToolKey | Gets the ResourceKey for the DiagramNodeTool representing a toolbox entry for CommentNode nodes.
DefaultConnectionContentTemplateKey | Gets the ResourceKey for the DataTemplate representing the default connection content (a text box).
DefaultConnectionPointTemplateKey | Gets the ResourceKey for the DataTemplate representing the default appearance of connection points.
DefaultNodeContentTemplateKey | Gets the ResourceKey for the DataTemplate representing the default node content (a text box).
DefaultShapePathStyleKey | Gets the ResourceKey for the Style representing the default style for diagram shapes.
TitleNodeToolKey | Gets the ResourceKey for the DiagramNodeTool representing a toolbox entry for TitleNode nodes.

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


CommentNodeToolKey Property

[image]

Mindscape WPF Diagrams
DiagramShapes..::.CommentNodeToolKey Property
DiagramShapes Class See Also Send Feedback
Gets the ResourceKey for the DiagramNodeTool representing a toolbox entry for CommentNode nodes.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey CommentNodeToolKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CommentNodeToolKey As ComponentResourceKey

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DefaultConnectionContentTemplateKey Property

[image]

Mindscape WPF Diagrams
DiagramShapes..::.DefaultConnectionContentTemplateKey Property
DiagramShapes Class See Also Send Feedback
Gets the ResourceKey for the DataTemplate representing the default connection content (a text box).

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultConnectionContentTemplateKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultConnectionContentTemplateKey As ComponentResourceKey

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DefaultConnectionPointTemplateKey Property

[image]

Mindscape WPF Diagrams
DiagramShapes..::.DefaultConnectionPointTemplateKey Property
DiagramShapes Class See Also Send Feedback
Gets the ResourceKey for the DataTemplate representing the default appearance of connection points.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultConnectionPointTemplateKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultConnectionPointTemplateKey As ComponentResourceKey

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DefaultNodeContentTemplateKey Property

[image]

Mindscape WPF Diagrams
DiagramShapes..::.DefaultNodeContentTemplateKey Property
DiagramShapes Class See Also Send Feedback
Gets the ResourceKey for the DataTemplate representing the default node content (a text box).

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultNodeContentTemplateKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultNodeContentTemplateKey As ComponentResourceKey

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DefaultShapePathStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramShapes..::.DefaultShapePathStyleKey Property
DiagramShapes Class See Also Send Feedback
Gets the ResourceKey for the Style representing the default style for diagram shapes.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultShapePathStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultShapePathStyleKey As ComponentResourceKey

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


TitleNodeToolKey Property

[image]

Mindscape WPF Diagrams
DiagramShapes..::.TitleNodeToolKey Property
DiagramShapes Class See Also Send Feedback
Gets the ResourceKey for the DiagramNodeTool representing a toolbox entry for TitleNode nodes.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey TitleNodeToolKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TitleNodeToolKey As ComponentResourceKey

See Also

DiagramShapes Class
Mindscape.WpfDiagramming Namespace


DiagramSurface Class

[image]

Mindscape WPF Diagrams
DiagramSurface Class
Members See Also Send Feedback
Represents the surface on which a diagram is displayed.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramSurface : Control
Visual Basic (Declaration)
Public Class DiagramSurface _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.WpfDiagramming..::.DiagramSurface

See Also

DiagramSurface Members
Mindscape.WpfDiagramming Namespace


DiagramSurface Members

[image] [image]

Mindscape WPF Diagrams
DiagramSurface Members
DiagramSurface Class Constructors Methods Fields Properties Events See Also Send Feedback

The DiagramSurface type exposes the following members.

Constructors

Name | Description
DiagramSurface | Initializes a new instance of the DiagramSurface class.

Methods

Name | Description
ApplyLayoutAlgorithm | Applies the given layout algorithm to the diagram, re-formats all the connections and takes a snapshot for undo/redo integration.
CancelLastSnapshot | Cancels the last snapshot that was taken so that it is ignored by the undo command.
ClearDirty | Clears the IsDirty flag. Call this method when saving the diagram.
FindConnectionElement | Returns the DiagramConnectionElement that represents the visual for the given IDiagramConnection. This method returns null if no such DiagramConnectionElement can be found.
FindElementAtPoint | Returns the DiagramElement that interescts with the given Point. This could be a DiagramNodeElement or a DiagramConnectionElement. Returns null if there is no DiagramElement at the given point.
FindMouseOverElement | Returns the DiagramElement that the mouse is currently over. This could be a DiagramNodeElement or a DiagramConnectionElement. Returns null if the mouse is not currently over any DiagramElement.
FindNodeElement | Returns the DiagramNodeElement that represents the visual for the given IDiagramNode. This method returns null if no such DiagramNodeElement can be found.
GetLogicalBounds | Gets the diagram model bounds corresponding to a rectangle on the display (in control coordinates). This method is used to compensate for the effects of zooming and scrolling on a DiagramSurface.
GetMousePosition | Returns a Point reflecting the position of the mouse pointer relative to the (0, 0) coordinate on this DiagramSurface.
GetPhysicalBounds | Gets the display rectangle (in control coordinates) corresponding to a region of the diagram model. This method is used to compensate for the effects of zooming and scrolling on a DiagramSurface.
GetViewport | Gets the viewport (the part of the diagram which is visible).
InstallLicense | Performs manual licensing for specialized deployment scenarios.
OnApplyTemplate | Called by the framework when a template is applied to the control. (Overrides FrameworkElement ..::. OnApplyTemplate()()().)
OnKeyDown | Called when a key is pressed while this DiagramSurface has focus. (Overrides UIElement ..::. OnKeyDown(KeyEventArgs).)
OnKeyUp | Called when a key is released while this DiagramSurface has focus. (Overrides UIElement ..::. OnKeyUp(KeyEventArgs).)
OnMouseDown | Invoked when an unhandled Mouse.MouseDown attached event reaches an element in its route that is derived from this class. (Overrides UIElement ..::. OnMouseDown(MouseButtonEventArgs).)
OnMouseMove | Invoked when an unhandled Mouse.MouseUp attached event reaches an element in its route that is derived from this class. (Overrides UIElement ..::. OnMouseMove(MouseEventArgs).)
OnMouseUp | Invoked when an unhandled Mouse.MouseUp attached event reaches an element in its route that is derived from this class. (Overrides UIElement ..::. OnMouseUp(MouseButtonEventArgs).)
ResetUndo | Resets the undo feature by clearing all the snapshots that have been made up to now.
SetDirty | Marks the diagram as dirty (having changed).
SetViewport | Sets the viewport (the part of the diagram which is visible).
SizeToFit | Sets the viewport of the ScrollViewer to fit the entire diagram of this DiagramSurface.
TakeSnapshot | Saves the current state of the diagram that this DiagramSurface is displaying. This saved state is used for undo purposes. This method should be called AFTER an action has modified the DiagramSurface.

Fields

Name | Description
AllowNodeCollisionsProperty | Identifies the AllowNodeCollisions property.
AllowSegmentToNodeCollisionsProperty | Identifies the AllowSegmentToNodeCollisions property.
CanAddOrRemoveNodesProperty | Identifies the CanAddOrRemoveNodes property.
CanConnectToConnectionsProperty | Identifies the CanConnectToConnections property.
CanModifyConnectionContentProperty | Identifies the CanModifyConnectionContent property.
CanModifyConnectivityProperty | Identifies the CanModifyConnectivity property.
CanModifyNodeContentProperty | Identifies the CanModifyNodeContent property.
CanRotateNodesProperty | Identifies the CanRotateNodes property.
CollisionBufferProperty | Identifies the CollisionBuffer property.
DefaultCreateConnectionLineStyleProperty | Identifies the DefaultCreateConnectionLineStyle property.
DiagramElementsProperty | Identifies the DiagramElements property.
DiagramProperty | Identifies the Diagram property.
DragActionProperty | Identifies the DragAction property.
ElementFactoryProperty | Identifies the ElementFactory property.
FormatterProperty | Identifies the Formatter property.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility property.
HorizontalSnapSpecifierProperty | Identifies the HorizontalSnapSpecifier property.
IsDirtyProperty | Identifies the IsDirty property.
IsReadOnlyProperty | Identifies the IsReadOnly property.
IsSmartScrollingEnabledProperty | Identifies the IsSmartScrollingEnabled property.
MarqueeDragCompletedEvent | Identifies the MarqueeDragCompleted routed event.
MarqueeDragStartedEvent | Identifies the MarqueeDragStarted routed event.
MarqueeStyleProperty | Identifies the MarqueeStyle property.
OverflowBehaviorProperty | Identifies the OverflowBehavior property.
ReadOnlyCanSelectProperty | Identifies the ReadOnlyCanSelect property.
ScrollViewerProperty | Identifies the ScrollViewer property.
SelectedElementProperty | Identifies the SelectedElement property.
SelectedElementsProperty | Identifies the SelectedElements property.
SelectedItemProperty | Identifies the SelectedItem property.
SelectedItemsProperty | Identifies the SelectedItems property.
SelectionModeProperty | Identifies the SelectionMode property.
ShowConnectionPointsProperty | Identifies the ShowConnectionPoints property.
SnapLineDrawingProperty | Identifies the SnapLineDrawing property.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility property.
VerticalSnapSpecifierProperty | Identifies the VerticalSnapSpecifier property.
ZoomModeProperty | Identifies the ZoomMode property.
ZoomProperty | Identifies the Zoom property.

Properties

Name | Description
AllowNodeCollisions | Gets or sets whether this DiagramSurface should detect and manage collisions between two IDiagramNode objects. If this property is set to true, then collisions will be ignored.
AllowSegmentToNodeCollisions | Gets or sets whether this DiagramSurface should detect and manage collisions between DiagramConnectionSegment objects and DiagramNodeElement objects. If this property is set to true, then collisions will be ignored. Note that if this property is set to true, collisions still can not occur with a segment and the node that it is directly connected to.
CanAddOrRemoveNodes | Gets or sets if diagram nodes can be added or removed from the diagram of this DiagramSurface. The default is true. This is a dependency property.
CanConnectToConnections | Gets or sets whether or not connections are allowed to be connected to other connections from the time this property is set.
CanModifyConnectionContent | Gets or sets if the content of a connection within this DiagramSurface can be changed or not. The default is true; This is a dependency property.
CanModifyConnectivity | Gets or sets if connections can be relocated, added or removed from the diagram of this DiagramSurface. The default is true; This is a dependency property.
CanModifyNodeContent | Gets or sets if the content of a node within this DiagramSurface can be changed or not. The default is true; This is a dependency property.
CanRotateNodes | Gets or sets whether or not diagram nodes can be rotated. The default is false. This is a dependency property.
CollisionBuffer | Gets or sets the minimum distance between nodes and connection segments. This is a dependency property.
ConnectionElements | Gets all the DiagramConnectionElement objects displayed on this DiagramSurface.
DefaultCreateConnectionLineStyle | Gets or sets the Style used when the user drags to create a connection, if no DiagramConnectionTool is selected or the tool does not specify its own style. This is a dependency property.
DefaultMarqueeStyleKey | Gets the ResourceKey for the default Style used for drawing marquee selection rectangles.
Diagram | Gets or sets the diagram to be displayed. This is a dependency property.
DiagramBounds | Gets the bounding Rect of this DiagramSurface. This such rectangle is the smallest rectangle that fits all of the diagram elements in this DiagramSurface.
DiagramElements | Gets the collection of DiagramElement objects displayed on this DiagramSurface. This collection is sorted based on the ZIndex of the elements. This is a dependency property.
DragAction | Gets or sets the DiagramSurfaceDragAction to determine the behaviour of dragging the DiagramSurface. This is a dependency property.
ElementFactory | Gets or sets the IDiagramElementFactory used to construct DiagramElement objects for custom items. This must be populated if the diagram model contains custom items; it is ignored if the diagram model does not contain custom items. This is a dependency property.
Formatter | Gets or sets formatting and display settings for the diagram. This is a dependency property.
HorizontalOffset | Gets the HorizontalOffset property of the DiagramScrollViewer of this DiagramSurface. If the scroll viewer is null, then 0 is returned.
HorizontalScrollBarVisibility | Gets or sets the HorizontalScrollBarVisibility. The default is ScrollBarVisibility.Visible. This is a dependency property.
HorizontalSnapSpecifier | Gets or sets horizontal snapping for mouse dragging of nodes. This is a dependency property.
IsDirty | Gets or sets whether or not a change has been made to this DiagramSurface since the last time the diagram was saved. This is a dependency property.
IsReadOnly | Gets or sets whether the diagram display is read-only (cannot be modified by the user). This is a dependency property.
IsSmartScrollingEnabled | Gets or sets whether or not this DiagramSurface uses smart scrolling. Smart scrolling allows the viewport of the DiagramScrollViewer to be dynamically updated when an element is moved or sized of the screen. This is a dependency property.
MarqueeStyle | Gets or sets the Style applied to marquee selection rectangles. This is a dependency property.
NodeElements | Gets all the DiagramNodeElement objects displayed on this DiagramSurface.
OverflowBehavior | Gets or sets the overflow behavior. This is a dependency property.
PrintStyleKey | Gets the ResourceKey for the Style for formatting a DiagramSurface for printing.
ReadOnlyCanSelect | Gets or sets whether diagram elements can still be selected in read-only mode. The default is false. This is a dependency property.
ScrollViewer | Gets the DiagramScrollViewer used for scrolling the diagram view. This is a dependency property.
SelectedElement | Gets or sets the selected DiagramElement (node or connection). This is a dependency property.
SelectedElements | Gets the collection of selected elements. This is a dependency property.
SelectedItem | Gets or sets the selected diagram model item (IDiagramNode or IDiagramConnection. This is a dependency property.
SelectedItems | Gets the collection of selected diagram model items. This is a dependency property.
SelectionMode | Gets or sets the selection behavior for a DiagramSurface. The default is Single selection. This is a dependency property.
ShowConnectionPoints | Gets or sets whether to show connection points. This is a dependency property.
SnapLineDrawing | Gets or sets the method used to draw snap lines. This is a dependency property.
VerticalOffset | Gets the VerticalOffset property of the DiagramScrollViewer of this DiagramSurface. If the scroll viewer is null, then 0 is returned.
VerticalScrollBarVisibility | Gets or sets the VerticalScrollBarVisibility. The default is ScrollBarVisibility.Visible. This is a dependency property.
VerticalSnapSpecifier | Gets or sets the vertical snapping for mouse dragging of nodes. This is a dependency property.
Zoom | Gets or sets the zoom factor. This is a dependency property.
ZoomMode | Gets or sets built-in zooming behavior. This is a dependency property.

Events

Name | Description
MarqueeDragCompleted | Occurs when a marquee drag is completed.
MarqueeDragStarted | Occurs when a marquee drag has begun.
SelectedElementChanged | Raised whenever the SelectedElement property of this DiagramSurface changes.
SelectedElementsChanged | Raised when the SelectedElements property changes.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramSurface Constructor

[image]

Mindscape WPF Diagrams
DiagramSurface Constructor
DiagramSurface Class See Also Send Feedback
Initializes a new instance of the DiagramSurface class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramSurface()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramSurface Fields

[image] [image]

Mindscape WPF Diagrams
DiagramSurface Fields
DiagramSurface Class See Also Send Feedback

The DiagramSurface type exposes the following members.

Fields

Name | Description
AllowNodeCollisionsProperty | Identifies the AllowNodeCollisions property.
AllowSegmentToNodeCollisionsProperty | Identifies the AllowSegmentToNodeCollisions property.
CanAddOrRemoveNodesProperty | Identifies the CanAddOrRemoveNodes property.
CanConnectToConnectionsProperty | Identifies the CanConnectToConnections property.
CanModifyConnectionContentProperty | Identifies the CanModifyConnectionContent property.
CanModifyConnectivityProperty | Identifies the CanModifyConnectivity property.
CanModifyNodeContentProperty | Identifies the CanModifyNodeContent property.
CanRotateNodesProperty | Identifies the CanRotateNodes property.
CollisionBufferProperty | Identifies the CollisionBuffer property.
DefaultCreateConnectionLineStyleProperty | Identifies the DefaultCreateConnectionLineStyle property.
DiagramElementsProperty | Identifies the DiagramElements property.
DiagramProperty | Identifies the Diagram property.
DragActionProperty | Identifies the DragAction property.
ElementFactoryProperty | Identifies the ElementFactory property.
FormatterProperty | Identifies the Formatter property.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility property.
HorizontalSnapSpecifierProperty | Identifies the HorizontalSnapSpecifier property.
IsDirtyProperty | Identifies the IsDirty property.
IsReadOnlyProperty | Identifies the IsReadOnly property.
IsSmartScrollingEnabledProperty | Identifies the IsSmartScrollingEnabled property.
MarqueeDragCompletedEvent | Identifies the MarqueeDragCompleted routed event.
MarqueeDragStartedEvent | Identifies the MarqueeDragStarted routed event.
MarqueeStyleProperty | Identifies the MarqueeStyle property.
OverflowBehaviorProperty | Identifies the OverflowBehavior property.
ReadOnlyCanSelectProperty | Identifies the ReadOnlyCanSelect property.
ScrollViewerProperty | Identifies the ScrollViewer property.
SelectedElementProperty | Identifies the SelectedElement property.
SelectedElementsProperty | Identifies the SelectedElements property.
SelectedItemProperty | Identifies the SelectedItem property.
SelectedItemsProperty | Identifies the SelectedItems property.
SelectionModeProperty | Identifies the SelectionMode property.
ShowConnectionPointsProperty | Identifies the ShowConnectionPoints property.
SnapLineDrawingProperty | Identifies the SnapLineDrawing property.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility property.
VerticalSnapSpecifierProperty | Identifies the VerticalSnapSpecifier property.
ZoomModeProperty | Identifies the ZoomMode property.
ZoomProperty | Identifies the Zoom property.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


AllowNodeCollisionsProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.AllowNodeCollisionsProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the AllowNodeCollisions property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty AllowNodeCollisionsProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowNodeCollisionsProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


AllowSegmentToNodeCollisionsProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.AllowSegmentToNodeCollisionsProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the AllowSegmentToNodeCollisions property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty AllowSegmentToNodeCollisionsProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowSegmentToNodeCollisionsProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanAddOrRemoveNodesProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanAddOrRemoveNodesProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the CanAddOrRemoveNodes property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CanAddOrRemoveNodesProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanAddOrRemoveNodesProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanConnectToConnectionsProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanConnectToConnectionsProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the CanConnectToConnections property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CanConnectToConnectionsProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanConnectToConnectionsProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanModifyConnectionContentProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanModifyConnectionContentProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the CanModifyConnectionContent property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CanModifyConnectionContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanModifyConnectionContentProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanModifyConnectivityProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanModifyConnectivityProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the CanModifyConnectivity property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CanModifyConnectivityProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanModifyConnectivityProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanModifyNodeContentProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanModifyNodeContentProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the CanModifyNodeContent property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CanModifyNodeContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanModifyNodeContentProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanRotateNodesProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanRotateNodesProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the CanRotateNodes property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CanRotateNodesProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanRotateNodesProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CollisionBufferProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CollisionBufferProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the CollisionBuffer property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CollisionBufferProperty
Visual Basic (Declaration)
Public Shared ReadOnly CollisionBufferProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DefaultCreateConnectionLineStyleProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DefaultCreateConnectionLineStyleProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the DefaultCreateConnectionLineStyle property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty DefaultCreateConnectionLineStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DefaultCreateConnectionLineStyleProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramElementsProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DiagramElementsProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the DiagramElements property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty DiagramElementsProperty
Visual Basic (Declaration)
Public Shared ReadOnly DiagramElementsProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DiagramProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the Diagram property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty DiagramProperty
Visual Basic (Declaration)
Public Shared ReadOnly DiagramProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DragActionProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DragActionProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the DragAction property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty DragActionProperty
Visual Basic (Declaration)
Public Shared ReadOnly DragActionProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ElementFactoryProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ElementFactoryProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the ElementFactory property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ElementFactoryProperty
Visual Basic (Declaration)
Public Shared ReadOnly ElementFactoryProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


FormatterProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.FormatterProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the Formatter property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty FormatterProperty
Visual Basic (Declaration)
Public Shared ReadOnly FormatterProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.HorizontalScrollBarVisibilityProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the HorizontalScrollBarVisibility property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty HorizontalScrollBarVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalScrollBarVisibilityProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


HorizontalSnapSpecifierProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.HorizontalSnapSpecifierProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the HorizontalSnapSpecifier property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty HorizontalSnapSpecifierProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalSnapSpecifierProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


IsDirtyProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.IsDirtyProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the IsDirty property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsDirtyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDirtyProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


IsReadOnlyProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.IsReadOnlyProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the IsReadOnly property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsReadOnlyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


IsSmartScrollingEnabledProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.IsSmartScrollingEnabledProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the IsSmartScrollingEnabled property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsSmartScrollingEnabledProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSmartScrollingEnabledProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


MarqueeDragCompletedEvent Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.MarqueeDragCompletedEvent Field
DiagramSurface Class See Also Send Feedback
Identifies the MarqueeDragCompleted routed event.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent MarqueeDragCompletedEvent
Visual Basic (Declaration)
Public Shared ReadOnly MarqueeDragCompletedEvent As RoutedEvent

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


MarqueeDragStartedEvent Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.MarqueeDragStartedEvent Field
DiagramSurface Class See Also Send Feedback
Identifies the MarqueeDragStarted routed event.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent MarqueeDragStartedEvent
Visual Basic (Declaration)
Public Shared ReadOnly MarqueeDragStartedEvent As RoutedEvent

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


MarqueeStyleProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.MarqueeStyleProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the MarqueeStyle property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty MarqueeStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly MarqueeStyleProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OverflowBehaviorProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OverflowBehaviorProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the OverflowBehavior property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty OverflowBehaviorProperty
Visual Basic (Declaration)
Public Shared ReadOnly OverflowBehaviorProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ReadOnlyCanSelectProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ReadOnlyCanSelectProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the ReadOnlyCanSelect property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ReadOnlyCanSelectProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReadOnlyCanSelectProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ScrollViewerProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ScrollViewerProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the ScrollViewer property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ScrollViewerProperty
Visual Basic (Declaration)
Public Shared ReadOnly ScrollViewerProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedElementProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedElementProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the SelectedElement property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedElementProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedElementProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedElementsProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedElementsProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the SelectedElements property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedElementsProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedElementsProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedItemProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedItemProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the SelectedItem property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedItemsProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedItemsProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the SelectedItems property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectedItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemsProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectionModeProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectionModeProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the SelectionMode property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ShowConnectionPointsProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ShowConnectionPointsProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the ShowConnectionPoints property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowConnectionPointsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowConnectionPointsProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SnapLineDrawingProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SnapLineDrawingProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the SnapLineDrawing property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SnapLineDrawingProperty
Visual Basic (Declaration)
Public Shared ReadOnly SnapLineDrawingProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


VerticalScrollBarVisibilityProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.VerticalScrollBarVisibilityProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the VerticalScrollBarVisibility property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty VerticalScrollBarVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalScrollBarVisibilityProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


VerticalSnapSpecifierProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.VerticalSnapSpecifierProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the VerticalSnapSpecifier property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty VerticalSnapSpecifierProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalSnapSpecifierProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ZoomModeProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ZoomModeProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the ZoomMode property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ZoomModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomModeProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ZoomProperty Field

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ZoomProperty Field
DiagramSurface Class See Also Send Feedback
Identifies the Zoom property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ZoomProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomProperty As DependencyProperty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramSurface Methods

[image] [image]

Mindscape WPF Diagrams
DiagramSurface Methods
DiagramSurface Class See Also Send Feedback

The DiagramSurface type exposes the following members.

Methods

Name | Description
ApplyLayoutAlgorithm | Applies the given layout algorithm to the diagram, re-formats all the connections and takes a snapshot for undo/redo integration.
CancelLastSnapshot | Cancels the last snapshot that was taken so that it is ignored by the undo command.
ClearDirty | Clears the IsDirty flag. Call this method when saving the diagram.
FindConnectionElement | Returns the DiagramConnectionElement that represents the visual for the given IDiagramConnection. This method returns null if no such DiagramConnectionElement can be found.
FindElementAtPoint | Returns the DiagramElement that interescts with the given Point. This could be a DiagramNodeElement or a DiagramConnectionElement. Returns null if there is no DiagramElement at the given point.
FindMouseOverElement | Returns the DiagramElement that the mouse is currently over. This could be a DiagramNodeElement or a DiagramConnectionElement. Returns null if the mouse is not currently over any DiagramElement.
FindNodeElement | Returns the DiagramNodeElement that represents the visual for the given IDiagramNode. This method returns null if no such DiagramNodeElement can be found.
GetLogicalBounds | Gets the diagram model bounds corresponding to a rectangle on the display (in control coordinates). This method is used to compensate for the effects of zooming and scrolling on a DiagramSurface.
GetMousePosition | Returns a Point reflecting the position of the mouse pointer relative to the (0, 0) coordinate on this DiagramSurface.
GetPhysicalBounds | Gets the display rectangle (in control coordinates) corresponding to a region of the diagram model. This method is used to compensate for the effects of zooming and scrolling on a DiagramSurface.
GetViewport | Gets the viewport (the part of the diagram which is visible).
InstallLicense | Performs manual licensing for specialized deployment scenarios.
OnApplyTemplate | Called by the framework when a template is applied to the control. (Overrides FrameworkElement ..::. OnApplyTemplate()()().)
OnKeyDown | Called when a key is pressed while this DiagramSurface has focus. (Overrides UIElement ..::. OnKeyDown(KeyEventArgs).)
OnKeyUp | Called when a key is released while this DiagramSurface has focus. (Overrides UIElement ..::. OnKeyUp(KeyEventArgs).)
OnMouseDown | Invoked when an unhandled Mouse.MouseDown attached event reaches an element in its route that is derived from this class. (Overrides UIElement ..::. OnMouseDown(MouseButtonEventArgs).)
OnMouseMove | Invoked when an unhandled Mouse.MouseUp attached event reaches an element in its route that is derived from this class. (Overrides UIElement ..::. OnMouseMove(MouseEventArgs).)
OnMouseUp | Invoked when an unhandled Mouse.MouseUp attached event reaches an element in its route that is derived from this class. (Overrides UIElement ..::. OnMouseUp(MouseButtonEventArgs).)
ResetUndo | Resets the undo feature by clearing all the snapshots that have been made up to now.
SetDirty | Marks the diagram as dirty (having changed).
SetViewport | Sets the viewport (the part of the diagram which is visible).
SizeToFit | Sets the viewport of the ScrollViewer to fit the entire diagram of this DiagramSurface.
TakeSnapshot | Saves the current state of the diagram that this DiagramSurface is displaying. This saved state is used for undo purposes. This method should be called AFTER an action has modified the DiagramSurface.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ApplyLayoutAlgorithm Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ApplyLayoutAlgorithm Method
DiagramSurface Class See Also Send Feedback
Applies the given layout algorithm to the diagram, re-formats all the connections and takes a snapshot for undo/redo integration.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ApplyLayoutAlgorithm(
    ILayoutAlgorithm algorithm
)
Visual Basic (Declaration)
Public Sub ApplyLayoutAlgorithm ( _
    algorithm As ILayoutAlgorithm _
)

Parameters

algorithm
Type: Mindscape.WpfDiagramming.Foundation..::.ILayoutAlgorithm
The layout algorithm to run.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CancelLastSnapshot Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CancelLastSnapshot Method
DiagramSurface Class See Also Send Feedback
Cancels the last snapshot that was taken so that it is ignored by the undo command.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CancelLastSnapshot()
Visual Basic (Declaration)
Public Sub CancelLastSnapshot

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ClearDirty Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ClearDirty Method
DiagramSurface Class See Also Send Feedback
Clears the IsDirty flag. Call this method when saving the diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ClearDirty()
Visual Basic (Declaration)
Public Sub ClearDirty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


FindConnectionElement Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.FindConnectionElement Method
DiagramSurface Class See Also Send Feedback
Returns the DiagramConnectionElement that represents the visual for the given IDiagramConnection. This method returns null if no such DiagramConnectionElement can be found.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionElement FindConnectionElement(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Function FindConnectionElement ( _
    connection As IDiagramConnection _
) As DiagramConnectionElement

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to find the DiagramConnectionElement for.

Return Value

The DiagramConnectionElement that represents the given IDiagramConnection.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


FindElementAtPoint Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.FindElementAtPoint Method
DiagramSurface Class See Also Send Feedback
Returns the DiagramElement that interescts with the given Point. This could be a DiagramNodeElement or a DiagramConnectionElement. Returns null if there is no DiagramElement at the given point.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramElement FindElementAtPoint(
    Point point
)
Visual Basic (Declaration)
Public Function FindElementAtPoint ( _
    point As Point _
) As DiagramElement

Parameters

point
Type: System.Windows..::.Point
The Point object used to search for a DiagramElement.

Return Value

The DiagramElement that intersects with the given point.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


FindMouseOverElement Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.FindMouseOverElement Method
DiagramSurface Class See Also Send Feedback
Returns the DiagramElement that the mouse is currently over. This could be a DiagramNodeElement or a DiagramConnectionElement. Returns null if the mouse is not currently over any DiagramElement.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramElement FindMouseOverElement()
Visual Basic (Declaration)
Public Function FindMouseOverElement As DiagramElement

Return Value

The DiagramElement that the mouse is currently over if any.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


FindNodeElement Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.FindNodeElement Method
DiagramSurface Class See Also Send Feedback
Returns the DiagramNodeElement that represents the visual for the given IDiagramNode. This method returns null if no such DiagramNodeElement can be found.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramNodeElement FindNodeElement(
    IDiagramNode node
)
Visual Basic (Declaration)
Public Function FindNodeElement ( _
    node As IDiagramNode _
) As DiagramNodeElement

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
An IDiagramNode to find the DiagramNodeElement for.

Return Value

The DiagramNodeElement representing the given IDiagramNode.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


GetLogicalBounds Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.GetLogicalBounds Method
DiagramSurface Class See Also Send Feedback
Gets the diagram model bounds corresponding to a rectangle on the display (in control coordinates). This method is used to compensate for the effects of zooming and scrolling on a DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect GetLogicalBounds(
    Rect physicalBounds
)
Visual Basic (Declaration)
Public Function GetLogicalBounds ( _
    physicalBounds As Rect _
) As Rect

Parameters

physicalBounds
Type: System.Windows..::.Rect
The physical bounds, typically obtained from a tool drop event.

Return Value

A Rect containing the equivalent coordinates in the unscaled diagram model.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


GetMousePosition Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.GetMousePosition Method
DiagramSurface Class See Also Send Feedback
Returns a Point reflecting the position of the mouse pointer relative to the (0, 0) coordinate on this DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point GetMousePosition()
Visual Basic (Declaration)
Public Function GetMousePosition As Point

Return Value

The mouse position relative to (0, 0) on this DiagramSurface.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


GetPhysicalBounds Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.GetPhysicalBounds Method
DiagramSurface Class See Also Send Feedback
Gets the display rectangle (in control coordinates) corresponding to a region of the diagram model. This method is used to compensate for the effects of zooming and scrolling on a DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect GetPhysicalBounds(
    Rect logicalBounds
)
Visual Basic (Declaration)
Public Function GetPhysicalBounds ( _
    logicalBounds As Rect _
) As Rect

Parameters

logicalBounds
Type: System.Windows..::.Rect
The logical bounds.

Return Value

A Rect containing the equivalent coordinates in control coordinates.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


GetViewport Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.GetViewport Method
DiagramSurface Class See Also Send Feedback
Gets the viewport (the part of the diagram which is visible).

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect GetViewport()
Visual Basic (Declaration)
Public Function GetViewport As Rect

Return Value

The current viewport (in diagram coordinates).

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


InstallLicense Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.InstallLicense Method
DiagramSurface Class See Also Send Feedback
Performs manual licensing for specialized deployment scenarios.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public static void InstallLicense(
    string licenseKey
)
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Shared Sub InstallLicense ( _
    licenseKey As String _
)

Parameters

licenseKey
Type: System..::.String
A runtime license key.

Remarks

In normal deployment scenarios, the DiagramSurface control is automatically licensed. Install a license key manually only under advisement from Mindscape support.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OnApplyTemplate Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OnApplyTemplate Method
DiagramSurface Class See Also Send Feedback
Called by the framework when a template is applied to the control.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OnKeyDown Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OnKeyDown Method
DiagramSurface Class See Also Send Feedback
Called when a key is pressed while this DiagramSurface has focus.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.KeyEventArgs
The event data.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OnKeyUp Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OnKeyUp Method
DiagramSurface Class See Also Send Feedback
Called when a key is released while this DiagramSurface has focus.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnKeyUp(
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyUp ( _
    e As KeyEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.KeyEventArgs
The event data.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OnMouseDown Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OnMouseDown Method
DiagramSurface Class See Also Send Feedback
Invoked when an unhandled Mouse.MouseDown attached event reaches an element in its route that is derived from this class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnMouseDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OnMouseMove Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OnMouseMove Method
DiagramSurface Class See Also Send Feedback
Invoked when an unhandled Mouse.MouseUp attached event reaches an element in its route that is derived from this class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OnMouseUp Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OnMouseUp Method
DiagramSurface Class See Also Send Feedback
Invoked when an unhandled Mouse.MouseUp attached event reaches an element in its route that is derived from this class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnMouseUp(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ResetUndo Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ResetUndo Method
DiagramSurface Class See Also Send Feedback
Resets the undo feature by clearing all the snapshots that have been made up to now.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ResetUndo()
Visual Basic (Declaration)
Public Sub ResetUndo

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SetDirty Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SetDirty Method
DiagramSurface Class See Also Send Feedback
Marks the diagram as dirty (having changed).

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetDirty()
Visual Basic (Declaration)
Public Sub SetDirty

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SetViewport Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SetViewport Method
DiagramSurface Class See Also Send Feedback
Sets the viewport (the part of the diagram which is visible).

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetViewport(
    Rect viewport
)
Visual Basic (Declaration)
Public Sub SetViewport ( _
    viewport As Rect _
)

Parameters

viewport
Type: System.Windows..::.Rect
The desired viewport, in diagram coordinates.

Remarks

In order to preserve the aspect ratio of the diagram, the displayed viewport may be larger than the requested viewport.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SizeToFit Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SizeToFit Method
DiagramSurface Class See Also Send Feedback
Sets the viewport of the ScrollViewer to fit the entire diagram of this DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SizeToFit()
Visual Basic (Declaration)
Public Sub SizeToFit

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


TakeSnapshot Method

[image]

Mindscape WPF Diagrams
DiagramSurface..::.TakeSnapshot Method
DiagramSurface Class See Also Send Feedback
Saves the current state of the diagram that this DiagramSurface is displaying. This saved state is used for undo purposes. This method should be called AFTER an action has modified the DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void TakeSnapshot()
Visual Basic (Declaration)
Public Sub TakeSnapshot

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramSurface Properties

[image] [image]

Mindscape WPF Diagrams
DiagramSurface Properties
DiagramSurface Class See Also Send Feedback

The DiagramSurface type exposes the following members.

Properties

Name | Description
AllowNodeCollisions | Gets or sets whether this DiagramSurface should detect and manage collisions between two IDiagramNode objects. If this property is set to true, then collisions will be ignored.
AllowSegmentToNodeCollisions | Gets or sets whether this DiagramSurface should detect and manage collisions between DiagramConnectionSegment objects and DiagramNodeElement objects. If this property is set to true, then collisions will be ignored. Note that if this property is set to true, collisions still can not occur with a segment and the node that it is directly connected to.
CanAddOrRemoveNodes | Gets or sets if diagram nodes can be added or removed from the diagram of this DiagramSurface. The default is true. This is a dependency property.
CanConnectToConnections | Gets or sets whether or not connections are allowed to be connected to other connections from the time this property is set.
CanModifyConnectionContent | Gets or sets if the content of a connection within this DiagramSurface can be changed or not. The default is true; This is a dependency property.
CanModifyConnectivity | Gets or sets if connections can be relocated, added or removed from the diagram of this DiagramSurface. The default is true; This is a dependency property.
CanModifyNodeContent | Gets or sets if the content of a node within this DiagramSurface can be changed or not. The default is true; This is a dependency property.
CanRotateNodes | Gets or sets whether or not diagram nodes can be rotated. The default is false. This is a dependency property.
CollisionBuffer | Gets or sets the minimum distance between nodes and connection segments. This is a dependency property.
ConnectionElements | Gets all the DiagramConnectionElement objects displayed on this DiagramSurface.
DefaultCreateConnectionLineStyle | Gets or sets the Style used when the user drags to create a connection, if no DiagramConnectionTool is selected or the tool does not specify its own style. This is a dependency property.
DefaultMarqueeStyleKey | Gets the ResourceKey for the default Style used for drawing marquee selection rectangles.
Diagram | Gets or sets the diagram to be displayed. This is a dependency property.
DiagramBounds | Gets the bounding Rect of this DiagramSurface. This such rectangle is the smallest rectangle that fits all of the diagram elements in this DiagramSurface.
DiagramElements | Gets the collection of DiagramElement objects displayed on this DiagramSurface. This collection is sorted based on the ZIndex of the elements. This is a dependency property.
DragAction | Gets or sets the DiagramSurfaceDragAction to determine the behaviour of dragging the DiagramSurface. This is a dependency property.
ElementFactory | Gets or sets the IDiagramElementFactory used to construct DiagramElement objects for custom items. This must be populated if the diagram model contains custom items; it is ignored if the diagram model does not contain custom items. This is a dependency property.
Formatter | Gets or sets formatting and display settings for the diagram. This is a dependency property.
HorizontalOffset | Gets the HorizontalOffset property of the DiagramScrollViewer of this DiagramSurface. If the scroll viewer is null, then 0 is returned.
HorizontalScrollBarVisibility | Gets or sets the HorizontalScrollBarVisibility. The default is ScrollBarVisibility.Visible. This is a dependency property.
HorizontalSnapSpecifier | Gets or sets horizontal snapping for mouse dragging of nodes. This is a dependency property.
IsDirty | Gets or sets whether or not a change has been made to this DiagramSurface since the last time the diagram was saved. This is a dependency property.
IsReadOnly | Gets or sets whether the diagram display is read-only (cannot be modified by the user). This is a dependency property.
IsSmartScrollingEnabled | Gets or sets whether or not this DiagramSurface uses smart scrolling. Smart scrolling allows the viewport of the DiagramScrollViewer to be dynamically updated when an element is moved or sized of the screen. This is a dependency property.
MarqueeStyle | Gets or sets the Style applied to marquee selection rectangles. This is a dependency property.
NodeElements | Gets all the DiagramNodeElement objects displayed on this DiagramSurface.
OverflowBehavior | Gets or sets the overflow behavior. This is a dependency property.
PrintStyleKey | Gets the ResourceKey for the Style for formatting a DiagramSurface for printing.
ReadOnlyCanSelect | Gets or sets whether diagram elements can still be selected in read-only mode. The default is false. This is a dependency property.
ScrollViewer | Gets the DiagramScrollViewer used for scrolling the diagram view. This is a dependency property.
SelectedElement | Gets or sets the selected DiagramElement (node or connection). This is a dependency property.
SelectedElements | Gets the collection of selected elements. This is a dependency property.
SelectedItem | Gets or sets the selected diagram model item (IDiagramNode or IDiagramConnection. This is a dependency property.
SelectedItems | Gets the collection of selected diagram model items. This is a dependency property.
SelectionMode | Gets or sets the selection behavior for a DiagramSurface. The default is Single selection. This is a dependency property.
ShowConnectionPoints | Gets or sets whether to show connection points. This is a dependency property.
SnapLineDrawing | Gets or sets the method used to draw snap lines. This is a dependency property.
VerticalOffset | Gets the VerticalOffset property of the DiagramScrollViewer of this DiagramSurface. If the scroll viewer is null, then 0 is returned.
VerticalScrollBarVisibility | Gets or sets the VerticalScrollBarVisibility. The default is ScrollBarVisibility.Visible. This is a dependency property.
VerticalSnapSpecifier | Gets or sets the vertical snapping for mouse dragging of nodes. This is a dependency property.
Zoom | Gets or sets the zoom factor. This is a dependency property.
ZoomMode | Gets or sets built-in zooming behavior. This is a dependency property.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


AllowNodeCollisions Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.AllowNodeCollisions Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether this DiagramSurface should detect and manage collisions between two IDiagramNode objects. If this property is set to true, then collisions will be ignored.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool AllowNodeCollisions { get; set; }
Visual Basic (Declaration)
Public Overridable Property AllowNodeCollisions As Boolean

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


AllowSegmentToNodeCollisions Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.AllowSegmentToNodeCollisions Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether this DiagramSurface should detect and manage collisions between DiagramConnectionSegment objects and DiagramNodeElement objects. If this property is set to true, then collisions will be ignored. Note that if this property is set to true, collisions still can not occur with a segment and the node that it is directly connected to.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool AllowSegmentToNodeCollisions { get; set; }
Visual Basic (Declaration)
Public Overridable Property AllowSegmentToNodeCollisions As Boolean

Remarks

Collision avoidance is applied only to manually placed connection segments. This setting does not affect automatic routing by an IPathfinder.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanAddOrRemoveNodes Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanAddOrRemoveNodes Property
DiagramSurface Class See Also Send Feedback
Gets or sets if diagram nodes can be added or removed from the diagram of this DiagramSurface. The default is true. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanAddOrRemoveNodes { get; set; }
Visual Basic (Declaration)
Public Overridable Property CanAddOrRemoveNodes As Boolean

Remarks

Dependency Property Information
Identifier field | CanAddOrRemoveNodesProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanConnectToConnections Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanConnectToConnections Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether or not connections are allowed to be connected to other connections from the time this property is set.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanConnectToConnections { get; set; }
Visual Basic (Declaration)
Public Overridable Property CanConnectToConnections As Boolean

Remarks

Dependency Property Information
Identifier field | CanConnectToConnectionsProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanModifyConnectionContent Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanModifyConnectionContent Property
DiagramSurface Class See Also Send Feedback
Gets or sets if the content of a connection within this DiagramSurface can be changed or not. The default is true; This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanModifyConnectionContent { get; set; }
Visual Basic (Declaration)
Public Overridable Property CanModifyConnectionContent As Boolean

Remarks

Dependency Property Information
Identifier field | CanModifyConnectionContentProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanModifyConnectivity Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanModifyConnectivity Property
DiagramSurface Class See Also Send Feedback
Gets or sets if connections can be relocated, added or removed from the diagram of this DiagramSurface. The default is true; This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanModifyConnectivity { get; set; }
Visual Basic (Declaration)
Public Overridable Property CanModifyConnectivity As Boolean

Remarks

Dependency Property Information
Identifier field | CanModifyConnectivityProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanModifyNodeContent Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanModifyNodeContent Property
DiagramSurface Class See Also Send Feedback
Gets or sets if the content of a node within this DiagramSurface can be changed or not. The default is true; This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanModifyNodeContent { get; set; }
Visual Basic (Declaration)
Public Overridable Property CanModifyNodeContent As Boolean

Remarks

Dependency Property Information
Identifier field | CanModifyNodeContentProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CanRotateNodes Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CanRotateNodes Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether or not diagram nodes can be rotated. The default is false. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool CanRotateNodes { get; set; }
Visual Basic (Declaration)
Public Property CanRotateNodes As Boolean

Remarks

Dependency Property Information
Identifier field | CanRotateNodesProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


CollisionBuffer Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.CollisionBuffer Property
DiagramSurface Class See Also Send Feedback
Gets or sets the minimum distance between nodes and connection segments. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double CollisionBuffer { get; set; }
Visual Basic (Declaration)
Public Property CollisionBuffer As Double

Remarks

Dependency Property Information
Identifier field | CollisionBufferProperty
Metadata properties set to true | None

It is advised that this value is not set to be negative.

Note that when using a horizontal or/and vertical ISnapSpecifier, the snap specifiers will be used after collision detection is performed which may negate the effect of the buffer value. Generally, the buffer should be set to be some factor of the distance between snap lines.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ConnectionElements Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ConnectionElements Property
DiagramSurface Class See Also Send Feedback
Gets all the DiagramConnectionElement objects displayed on this DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IEnumerable<DiagramConnectionElement> ConnectionElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectionElements As IEnumerable(Of DiagramConnectionElement)

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DefaultCreateConnectionLineStyle Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DefaultCreateConnectionLineStyle Property
DiagramSurface Class See Also Send Feedback
Gets or sets the Style used when the user drags to create a connection, if no DiagramConnectionTool is selected or the tool does not specify its own style. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style DefaultCreateConnectionLineStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultCreateConnectionLineStyle As Style

Remarks

Dependency Property Information
Identifier field | DefaultCreateConnectionLineStyleProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DefaultMarqueeStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DefaultMarqueeStyleKey Property
DiagramSurface Class See Also Send Feedback
Gets the ResourceKey for the default Style used for drawing marquee selection rectangles.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DefaultMarqueeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DefaultMarqueeStyleKey As ComponentResourceKey

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


Diagram Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.Diagram Property
DiagramSurface Class See Also Send Feedback
Gets or sets the diagram to be displayed. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramModel Diagram { get; set; }
Visual Basic (Declaration)
Public Property Diagram As IDiagramModel

Remarks

Dependency Property Information
Identifier field | DiagramProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramBounds Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DiagramBounds Property
DiagramSurface Class See Also Send Feedback
Gets the bounding Rect of this DiagramSurface. This such rectangle is the smallest rectangle that fits all of the diagram elements in this DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect DiagramBounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property DiagramBounds As Rect

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramElements Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DiagramElements Property
DiagramSurface Class See Also Send Feedback
Gets the collection of DiagramElement objects displayed on this DiagramSurface. This collection is sorted based on the ZIndex of the elements. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ReadOnlyObservableCollection<DiagramElement> DiagramElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property DiagramElements As ReadOnlyObservableCollection(Of DiagramElement)

Remarks

Dependency Property Information
Identifier field | DiagramElementsProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DragAction Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.DragAction Property
DiagramSurface Class See Also Send Feedback
Gets or sets the DiagramSurfaceDragAction to determine the behaviour of dragging the DiagramSurface. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramSurfaceDragAction DragAction { get; set; }
Visual Basic (Declaration)
Public Property DragAction As DiagramSurfaceDragAction

Remarks

Dependency Property Information
Identifier field | DragActionProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ElementFactory Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ElementFactory Property
DiagramSurface Class See Also Send Feedback
Gets or sets the IDiagramElementFactory used to construct DiagramElement objects for custom items. This must be populated if the diagram model contains custom items; it is ignored if the diagram model does not contain custom items. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramElementFactory ElementFactory { get; set; }
Visual Basic (Declaration)
Public Property ElementFactory As IDiagramElementFactory

Remarks

Dependency Property Information
Identifier field | ElementFactoryProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


Formatter Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.Formatter Property
DiagramSurface Class See Also Send Feedback
Gets or sets formatting and display settings for the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramFormatter Formatter { get; set; }
Visual Basic (Declaration)
Public Property Formatter As IDiagramFormatter

Remarks

Dependency Property Information
Identifier field | FormatterProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


HorizontalOffset Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.HorizontalOffset Property
DiagramSurface Class See Also Send Feedback
Gets the HorizontalOffset property of the DiagramScrollViewer of this DiagramSurface. If the scroll viewer is null, then 0 is returned.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalOffset As Double

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


HorizontalScrollBarVisibility Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.HorizontalScrollBarVisibility Property
DiagramSurface Class See Also Send Feedback
Gets or sets the HorizontalScrollBarVisibility. The default is ScrollBarVisibility.Visible. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic (Declaration)
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility

Remarks

Dependency Property Information
Identifier field | HorizontalScrollBarVisibilityProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


HorizontalSnapSpecifier Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.HorizontalSnapSpecifier Property
DiagramSurface Class See Also Send Feedback
Gets or sets horizontal snapping for mouse dragging of nodes. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ISnapSpecifier HorizontalSnapSpecifier { get; set; }
Visual Basic (Declaration)
Public Property HorizontalSnapSpecifier As ISnapSpecifier

Remarks

Dependency Property Information
Identifier field | HorizontalSnapSpecifierProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


IsDirty Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.IsDirty Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether or not a change has been made to this DiagramSurface since the last time the diagram was saved. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsDirty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDirty As Boolean

Remarks

Dependency Property Information
Identifier field | IsDirtyProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


IsReadOnly Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.IsReadOnly Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether the diagram display is read-only (cannot be modified by the user). This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean

Remarks

Dependency Property Information
Identifier field | IsReadOnlyProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


IsSmartScrollingEnabled Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.IsSmartScrollingEnabled Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether or not this DiagramSurface uses smart scrolling. Smart scrolling allows the viewport of the DiagramScrollViewer to be dynamically updated when an element is moved or sized of the screen. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsSmartScrollingEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsSmartScrollingEnabled As Boolean

Remarks

Dependency Property Information
Identifier field | IsSmartScrollingEnabledProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


MarqueeStyle Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.MarqueeStyle Property
DiagramSurface Class See Also Send Feedback
Gets or sets the Style applied to marquee selection rectangles. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style MarqueeStyle { get; set; }
Visual Basic (Declaration)
Public Property MarqueeStyle As Style

Remarks

Dependency Property Information
Identifier field | MarqueeStyleProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


NodeElements Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.NodeElements Property
DiagramSurface Class See Also Send Feedback
Gets all the DiagramNodeElement objects displayed on this DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IEnumerable<DiagramNodeElement> NodeElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property NodeElements As IEnumerable(Of DiagramNodeElement)

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


OverflowBehavior Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.OverflowBehavior Property
DiagramSurface Class See Also Send Feedback
Gets or sets the overflow behavior. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public OverflowBehavior OverflowBehavior { get; set; }
Visual Basic (Declaration)
Public Property OverflowBehavior As OverflowBehavior

Remarks

Dependency Property Information
Identifier field | OverflowBehaviorProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


PrintStyleKey Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.PrintStyleKey Property
DiagramSurface Class See Also Send Feedback
Gets the ResourceKey for the Style for formatting a DiagramSurface for printing.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey PrintStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PrintStyleKey As ComponentResourceKey

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ReadOnlyCanSelect Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ReadOnlyCanSelect Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether diagram elements can still be selected in read-only mode. The default is false. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ReadOnlyCanSelect { get; set; }
Visual Basic (Declaration)
Public Property ReadOnlyCanSelect As Boolean

Remarks

Dependency Property Information
Identifier field | ReadOnlyCanSelectProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ScrollViewer Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ScrollViewer Property
DiagramSurface Class See Also Send Feedback
Gets the DiagramScrollViewer used for scrolling the diagram view. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramScrollViewer ScrollViewer { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScrollViewer As DiagramScrollViewer

Remarks

Dependency Property Information
Identifier field | ScrollViewerProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedElement Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedElement Property
DiagramSurface Class See Also Send Feedback
Gets or sets the selected DiagramElement (node or connection). This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramElement SelectedElement { get; set; }
Visual Basic (Declaration)
Public Property SelectedElement As DiagramElement

Remarks

Dependency Property Information
Identifier field | SelectedElementProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedElements Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedElements Property
DiagramSurface Class See Also Send Feedback
Gets the collection of selected elements. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ReadOnlyCollection<DiagramElement> SelectedElements { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedElements As ReadOnlyCollection(Of DiagramElement)

Remarks

Dependency Property Information
Identifier field | SelectedElementsProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedItem Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedItem Property
DiagramSurface Class See Also Send Feedback
Gets or sets the selected diagram model item (IDiagramNode or IDiagramConnection. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As Object

Remarks

Dependency Property Information
Identifier field | SelectedItemProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedItems Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedItems Property
DiagramSurface Class See Also Send Feedback
Gets the collection of selected diagram model items. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ReadOnlyCollection<Object> SelectedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItems As ReadOnlyCollection(Of Object)

Remarks

Dependency Property Information
Identifier field | SelectedItemsProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectionMode Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectionMode Property
DiagramSurface Class See Also Send Feedback
Gets or sets the selection behavior for a DiagramSurface. The default is Single selection. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As SelectionMode

Remarks

Dependency Property Information
Identifier field | SelectionModeProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ShowConnectionPoints Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ShowConnectionPoints Property
DiagramSurface Class See Also Send Feedback
Gets or sets whether to show connection points. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ShowConnectionPoints { get; set; }
Visual Basic (Declaration)
Public Property ShowConnectionPoints As Boolean

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SnapLineDrawing Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SnapLineDrawing Property
DiagramSurface Class See Also Send Feedback
Gets or sets the method used to draw snap lines. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ISnapLineDrawing SnapLineDrawing { get; set; }
Visual Basic (Declaration)
Public Property SnapLineDrawing As ISnapLineDrawing

Remarks

Dependency Property Information
Identifier field | SnapLineDrawingProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


VerticalOffset Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.VerticalOffset Property
DiagramSurface Class See Also Send Feedback
Gets the VerticalOffset property of the DiagramScrollViewer of this DiagramSurface. If the scroll viewer is null, then 0 is returned.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalOffset As Double

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


VerticalScrollBarVisibility Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.VerticalScrollBarVisibility Property
DiagramSurface Class See Also Send Feedback
Gets or sets the VerticalScrollBarVisibility. The default is ScrollBarVisibility.Visible. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic (Declaration)
Public Property VerticalScrollBarVisibility As ScrollBarVisibility

Remarks

Dependency Property Information
Identifier field | VerticalScrollBarVisibilityProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


VerticalSnapSpecifier Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.VerticalSnapSpecifier Property
DiagramSurface Class See Also Send Feedback
Gets or sets the vertical snapping for mouse dragging of nodes. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ISnapSpecifier VerticalSnapSpecifier { get; set; }
Visual Basic (Declaration)
Public Property VerticalSnapSpecifier As ISnapSpecifier

Remarks

Dependency Property Information
Identifier field | VerticalSnapSpecifierProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


Zoom Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.Zoom Property
DiagramSurface Class See Also Send Feedback
Gets or sets the zoom factor. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Double

Remarks

Dependency Property Information
Identifier field | ZoomProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


ZoomMode Property

[image]

Mindscape WPF Diagrams
DiagramSurface..::.ZoomMode Property
DiagramSurface Class See Also Send Feedback
Gets or sets built-in zooming behavior. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode

Remarks

Dependency Property Information
Identifier field | ZoomModeProperty
Metadata properties set to true | None

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramSurface Events

[image] [image]

Mindscape WPF Diagrams
DiagramSurface Events
DiagramSurface Class See Also Send Feedback

The DiagramSurface type exposes the following members.

Events

Name | Description
MarqueeDragCompleted | Occurs when a marquee drag is completed.
MarqueeDragStarted | Occurs when a marquee drag has begun.
SelectedElementChanged | Raised whenever the SelectedElement property of this DiagramSurface changes.
SelectedElementsChanged | Raised when the SelectedElements property changes.

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


MarqueeDragCompleted Event

[image]

Mindscape WPF Diagrams
DiagramSurface..::.MarqueeDragCompleted Event
DiagramSurface Class See Also Send Feedback
Occurs when a marquee drag is completed.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<MarqueeDragCompletedEventArgs> MarqueeDragCompleted
Visual Basic (Declaration)
Public Event MarqueeDragCompleted As EventHandler(Of MarqueeDragCompletedEventArgs)

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


MarqueeDragStarted Event

[image]

Mindscape WPF Diagrams
DiagramSurface..::.MarqueeDragStarted Event
DiagramSurface Class See Also Send Feedback
Occurs when a marquee drag has begun.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<MarqueeDragStartedEventArgs> MarqueeDragStarted
Visual Basic (Declaration)
Public Event MarqueeDragStarted As EventHandler(Of MarqueeDragStartedEventArgs)

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedElementChanged Event

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedElementChanged Event
DiagramSurface Class See Also Send Feedback
Raised whenever the SelectedElement property of this DiagramSurface changes.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler SelectedElementChanged
Visual Basic (Declaration)
Public Event SelectedElementChanged As PropertyChangedEventHandler

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


SelectedElementsChanged Event

[image]

Mindscape WPF Diagrams
DiagramSurface..::.SelectedElementsChanged Event
DiagramSurface Class See Also Send Feedback
Raised when the SelectedElements property changes.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler SelectedElementsChanged
Visual Basic (Declaration)
Public Event SelectedElementsChanged As EventHandler

See Also

DiagramSurface Class
Mindscape.WpfDiagramming Namespace


DiagramToolBox Class

[image]

Mindscape WPF Diagrams
DiagramToolBox Class
Members See Also Send Feedback
Displays diagram tools and provides various filtering options.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("Groups")]
public class DiagramToolBox : Control
Visual Basic (Declaration)
<ContentPropertyAttribute("Groups")> _
Public Class DiagramToolBox _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.WpfDiagramming..::.DiagramToolBox

See Also

DiagramToolBox Members
Mindscape.WpfDiagramming Namespace


DiagramToolBox Members

[image] [image]

Mindscape WPF Diagrams
DiagramToolBox Members
DiagramToolBox Class Constructors Fields Properties See Also Send Feedback

The DiagramToolBox type exposes the following members.

Constructors

Name | Description
DiagramToolBox | Initializes a new instance of the DiagramToolBox class.

Fields

Name | Description
FilterLabelProperty | Identifies the FilterLabel property.
FilterListProperty | Identifies the FilterList property.

Properties

Name | Description
FilterLabel | Gets a string describing the currently selected filter option. This is a dependency property.
FilterList | Gets the available filters for this DiagramToolBox. This is a dependency property.
Groups | Gets the collection of DiagramToolBoxGroup objects displayed in this DiagramToolBox.

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


DiagramToolBox Constructor

[image]

Mindscape WPF Diagrams
DiagramToolBox Constructor
DiagramToolBox Class See Also Send Feedback
Initializes a new instance of the DiagramToolBox class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramToolBox()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


DiagramToolBox Fields

[image] [image]

Mindscape WPF Diagrams
DiagramToolBox Fields
DiagramToolBox Class See Also Send Feedback

The DiagramToolBox type exposes the following members.

Fields

Name | Description
FilterLabelProperty | Identifies the FilterLabel property.
FilterListProperty | Identifies the FilterList property.

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


FilterLabelProperty Field

[image]

Mindscape WPF Diagrams
DiagramToolBox..::.FilterLabelProperty Field
DiagramToolBox Class See Also Send Feedback
Identifies the FilterLabel property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty FilterLabelProperty
Visual Basic (Declaration)
Public Shared ReadOnly FilterLabelProperty As DependencyProperty

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


FilterListProperty Field

[image]

Mindscape WPF Diagrams
DiagramToolBox..::.FilterListProperty Field
DiagramToolBox Class See Also Send Feedback
Identifies the FilterList property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty FilterListProperty
Visual Basic (Declaration)
Public Shared ReadOnly FilterListProperty As DependencyProperty

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


DiagramToolBox Properties

[image] [image]

Mindscape WPF Diagrams
DiagramToolBox Properties
DiagramToolBox Class See Also Send Feedback

The DiagramToolBox type exposes the following members.

Properties

Name | Description
FilterLabel | Gets a string describing the currently selected filter option. This is a dependency property.
FilterList | Gets the available filters for this DiagramToolBox. This is a dependency property.
Groups | Gets the collection of DiagramToolBoxGroup objects displayed in this DiagramToolBox.

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


FilterLabel Property

[image]

Mindscape WPF Diagrams
DiagramToolBox..::.FilterLabel Property
DiagramToolBox Class See Also Send Feedback
Gets a string describing the currently selected filter option. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string FilterLabel { get; }
Visual Basic (Declaration)
Public ReadOnly Property FilterLabel As String

Remarks

Dependency Property Information
Identifier field | FilterLabelProperty
Metadata properties set to true | None

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


FilterList Property

[image]

Mindscape WPF Diagrams
DiagramToolBox..::.FilterList Property
DiagramToolBox Class See Also Send Feedback
Gets the available filters for this DiagramToolBox. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ReadOnlyCollection<DiagramToolBoxFilterItem> FilterList { get; }
Visual Basic (Declaration)
Public ReadOnly Property FilterList As ReadOnlyCollection(Of DiagramToolBoxFilterItem)

Remarks

Dependency Property Information
Identifier field | FilterListProperty
Metadata properties set to true | None

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


Groups Property

[image]

Mindscape WPF Diagrams
DiagramToolBox..::.Groups Property
DiagramToolBox Class See Also Send Feedback
Gets the collection of DiagramToolBoxGroup objects displayed in this DiagramToolBox.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ObservableCollection<DiagramToolBoxGroup> Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As ObservableCollection(Of DiagramToolBoxGroup)

See Also

DiagramToolBox Class
Mindscape.WpfDiagramming Namespace


DiagramToolBoxGroup Class

[image]

Mindscape WPF Diagrams
DiagramToolBoxGroup Class
Members See Also Send Feedback
Groups together a collection of related diagram tools.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramToolBoxGroup : HeaderedItemsControl
Visual Basic (Declaration)
Public Class DiagramToolBoxGroup _
    Inherits HeaderedItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
System.Windows.Controls..::.HeaderedItemsControl
Mindscape.WpfDiagramming..::.DiagramToolBoxGroup

See Also

DiagramToolBoxGroup Members
Mindscape.WpfDiagramming Namespace


DiagramToolBoxGroup Members

[image] [image]

Mindscape WPF Diagrams
DiagramToolBoxGroup Members
DiagramToolBoxGroup Class Constructors Fields Properties See Also Send Feedback

The DiagramToolBoxGroup type exposes the following members.

Constructors

Name | Description
DiagramToolBoxGroup |

Fields

Name | Description
IsExpandedProperty | Identifies the IsExpanded property.

Properties

Name | Description
IsExpanded | Gets or sets whether or not this DiagramToolBoxGroup is expanded. This is a dependency property.

See Also

DiagramToolBoxGroup Class
Mindscape.WpfDiagramming Namespace


DiagramToolBoxGroup Constructor

[image]

Mindscape WPF Diagrams
DiagramToolBoxGroup Constructor
DiagramToolBoxGroup Class See Also Send Feedback
Initializes a new instance of the DiagramToolBoxGroup class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramToolBoxGroup()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramToolBoxGroup Class
Mindscape.WpfDiagramming Namespace


DiagramToolBoxGroup Fields

[image] [image]

Mindscape WPF Diagrams
DiagramToolBoxGroup Fields
DiagramToolBoxGroup Class See Also Send Feedback

The DiagramToolBoxGroup type exposes the following members.

Fields

Name | Description
IsExpandedProperty | Identifies the IsExpanded property.

See Also

DiagramToolBoxGroup Class
Mindscape.WpfDiagramming Namespace


IsExpandedProperty Field

[image]

Mindscape WPF Diagrams
DiagramToolBoxGroup..::.IsExpandedProperty Field
DiagramToolBoxGroup Class See Also Send Feedback
Identifies the IsExpanded property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsExpandedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

DiagramToolBoxGroup Class
Mindscape.WpfDiagramming Namespace


DiagramToolBoxGroup Properties

[image] [image]

Mindscape WPF Diagrams
DiagramToolBoxGroup Properties
DiagramToolBoxGroup Class See Also Send Feedback

The DiagramToolBoxGroup type exposes the following members.

Properties

Name | Description
IsExpanded | Gets or sets whether or not this DiagramToolBoxGroup is expanded. This is a dependency property.

See Also

DiagramToolBoxGroup Class
Mindscape.WpfDiagramming Namespace


IsExpanded Property

[image]

Mindscape WPF Diagrams
DiagramToolBoxGroup..::.IsExpanded Property
DiagramToolBoxGroup Class See Also Send Feedback
Gets or sets whether or not this DiagramToolBoxGroup is expanded. This is a dependency property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean

Remarks

Dependency Property Information
Identifier field | IsExpandedProperty
Metadata properties set to true | None

See Also

DiagramToolBoxGroup Class
Mindscape.WpfDiagramming Namespace


DiagramXmlSerializer Class

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer Class
Members See Also Send Feedback
Serializes and deserializes Diagram objects as XML.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramXmlSerializer
Visual Basic (Declaration)
Public Class DiagramXmlSerializer

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramXmlSerializer
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramXmlSerializer
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramXmlSerializer

See Also

DiagramXmlSerializer Members
Mindscape.WpfDiagramming Namespace


DiagramXmlSerializer Members

[image] [image]

Mindscape WPF Diagrams
DiagramXmlSerializer Members
DiagramXmlSerializer Class Constructors Methods Properties See Also Send Feedback

The DiagramXmlSerializer type exposes the following members.

Constructors

Name | Description
DiagramXmlSerializer |

Methods

Name | Description
CreateBoolean | Returns a boolean based on the given XAttribute.
CreateConnection | Returns a deserialized connection based on the given XElement.
CreateDiagram | Returns an instance of the diagram that is being deserialized.
CreateDouble | Returns a double based on the given XAttribute.
CreateLong | Returns a long based on the given XAttribute.
CreateNode | Returns a deserialized node based on the given XElement.
CreateString | Returns a string based on the given XAttribute.
Deserialize | Deserializes a Diagram from XML.
Serialize | Serializes a Diagram to XML.
SerializeConnectionCore | Returns an XElement for serializing the given connection.
SerializeNodeCore | Returns an XElement for serializing the given node.
Shape | Returns a DiagramShape based on the given XAttribute value.

Properties

Name | Description
LineTypeNameResolver | Gets or sets a function used to resolve line type names. This supports custom line types. If the LineTypeNameResolver is not set, or returns null, then the default resolver is used.
OnDeserializeCustomConnectionData | Gets or sets a function used to deserialize custom connection data.
OnDeserializeCustomNodeData | Gets or sets a function used to deserialize custom node data.
OnSerializeCustomConnectionData | Gets or sets a function used to serialize custom connection data.
OnSerializeCustomNodeData | Gets or sets a function used to serialize custom node data.
ShapeNameResolver | Gets or sets a function used to resolve shape names. This supports custom shapes. If the ShapeNameResolver is not set, or returns null, then the default resolver is used.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


DiagramXmlSerializer Constructor

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer Constructor
DiagramXmlSerializer Class See Also Send Feedback
Initializes a new instance of the DiagramXmlSerializer class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramXmlSerializer()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


DiagramXmlSerializer Methods

[image] [image]

Mindscape WPF Diagrams
DiagramXmlSerializer Methods
DiagramXmlSerializer Class See Also Send Feedback

The DiagramXmlSerializer type exposes the following members.

Methods

Name | Description
CreateBoolean | Returns a boolean based on the given XAttribute.
CreateConnection | Returns a deserialized connection based on the given XElement.
CreateDiagram | Returns an instance of the diagram that is being deserialized.
CreateDouble | Returns a double based on the given XAttribute.
CreateLong | Returns a long based on the given XAttribute.
CreateNode | Returns a deserialized node based on the given XElement.
CreateString | Returns a string based on the given XAttribute.
Deserialize | Deserializes a Diagram from XML.
Serialize | Serializes a Diagram to XML.
SerializeConnectionCore | Returns an XElement for serializing the given connection.
SerializeNodeCore | Returns an XElement for serializing the given node.
Shape | Returns a DiagramShape based on the given XAttribute value.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


CreateBoolean Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.CreateBoolean Method
DiagramXmlSerializer Class See Also Send Feedback
Returns a boolean based on the given XAttribute.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected static bool CreateBoolean(
    XAttribute xml
)
Visual Basic (Declaration)
Protected Shared Function CreateBoolean ( _
    xml As XAttribute _
) As Boolean

Parameters

xml
Type: System.Xml.Linq..::.XAttribute
The XAttribute to deserialize.

Return Value

The boolean that the XAttribute represents.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


CreateConnection Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.CreateConnection Method
DiagramXmlSerializer Class See Also Send Feedback
Returns a deserialized connection based on the given XElement.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramConnection CreateConnection(
    XElement xml,
    DiagramConnectionPoint source,
    DiagramConnectionPoint destination,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Protected Overridable Function CreateConnection ( _
    xml As XElement, _
    source As DiagramConnectionPoint, _
    destination As DiagramConnectionPoint, _
    segments As IList(Of DiagramConnectionSegment) _
) As DiagramConnection

Parameters

xml
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the connection.
source
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The source connection point of the connection.
destination
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The destination connection point of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects that make up the connection.

Return Value

The deserialized connection.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


CreateDiagram Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.CreateDiagram Method
DiagramXmlSerializer Class See Also Send Feedback
Returns an instance of the diagram that is being deserialized.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual Diagram CreateDiagram()
Visual Basic (Declaration)
Protected Overridable Function CreateDiagram As Diagram

Return Value

The diagram.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


CreateDouble Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.CreateDouble Method
DiagramXmlSerializer Class See Also Send Feedback
Returns a double based on the given XAttribute.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected static double CreateDouble(
    XAttribute xml
)
Visual Basic (Declaration)
Protected Shared Function CreateDouble ( _
    xml As XAttribute _
) As Double

Parameters

xml
Type: System.Xml.Linq..::.XAttribute
The XAttribute to deserialize.

Return Value

The double that the XAttribute represents.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


CreateLong Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.CreateLong Method
DiagramXmlSerializer Class See Also Send Feedback
Returns a long based on the given XAttribute.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected static long CreateLong(
    XAttribute xml
)
Visual Basic (Declaration)
Protected Shared Function CreateLong ( _
    xml As XAttribute _
) As Long

Parameters

xml
Type: System.Xml.Linq..::.XAttribute
The XAttribute to deserialize.

Return Value

The long that the XAttribute represents.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.CreateNode Method
DiagramXmlSerializer Class See Also Send Feedback
Returns a deserialized node based on the given XElement.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramNode CreateNode(
    XElement xml
)
Visual Basic (Declaration)
Protected Overridable Function CreateNode ( _
    xml As XElement _
) As DiagramNode

Parameters

xml
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the node.

Return Value

The deserialized node.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


CreateString Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.CreateString Method
DiagramXmlSerializer Class See Also Send Feedback
Returns a string based on the given XAttribute.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected static string CreateString(
    XAttribute xml
)
Visual Basic (Declaration)
Protected Shared Function CreateString ( _
    xml As XAttribute _
) As String

Parameters

xml
Type: System.Xml.Linq..::.XAttribute
The XAttribute to deserialize.

Return Value

The string that the XAttribute represents.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


Deserialize Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.Deserialize Method
DiagramXmlSerializer Class See Also Send Feedback
Deserializes a Diagram from XML.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Diagram Deserialize(
    XDocument document
)
Visual Basic (Declaration)
Public Function Deserialize ( _
    document As XDocument _
) As Diagram

Parameters

document
Type: System.Xml.Linq..::.XDocument
An XML document containing the serialized diagram.

Return Value

The diagram deserialized from the XML.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


Serialize Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.Serialize Method
DiagramXmlSerializer Class See Also Send Feedback
Serializes a Diagram to XML.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public XDocument Serialize(
    Diagram diagram
)
Visual Basic (Declaration)
Public Function Serialize ( _
    diagram As Diagram _
) As XDocument

Parameters

diagram
Type: Mindscape.WpfDiagramming..::.Diagram
The diagram to be serialized.

Return Value

An XML document containing the serialized diagram.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


SerializeConnectionCore Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.SerializeConnectionCore Method
DiagramXmlSerializer Class See Also Send Feedback
Returns an XElement for serializing the given connection.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual XElement SerializeConnectionCore(
    DiagramConnection connection
)
Visual Basic (Declaration)
Protected Overridable Function SerializeConnectionCore ( _
    connection As DiagramConnection _
) As XElement

Parameters

connection
Type: Mindscape.WpfDiagramming..::.DiagramConnection
The connection to be serialized.

Return Value

The serialized connection.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


SerializeNodeCore Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.SerializeNodeCore Method
DiagramXmlSerializer Class See Also Send Feedback
Returns an XElement for serializing the given node.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual XElement SerializeNodeCore(
    DiagramNode node
)
Visual Basic (Declaration)
Protected Overridable Function SerializeNodeCore ( _
    node As DiagramNode _
) As XElement

Parameters

node
Type: Mindscape.WpfDiagramming..::.DiagramNode
The node to be serialized.

Return Value

The serialized node.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


Shape Method

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.Shape Method
DiagramXmlSerializer Class See Also Send Feedback
Returns a DiagramShape based on the given XAttribute value.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramShape Shape(
    XAttribute xml
)
Visual Basic (Declaration)
Protected Function Shape ( _
    xml As XAttribute _
) As DiagramShape

Parameters

xml
Type: System.Xml.Linq..::.XAttribute
The XAttribute to deserialize to a DiagramShape.

Return Value

The DiagramShape.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


DiagramXmlSerializer Properties

[image] [image]

Mindscape WPF Diagrams
DiagramXmlSerializer Properties
DiagramXmlSerializer Class See Also Send Feedback

The DiagramXmlSerializer type exposes the following members.

Properties

Name | Description
LineTypeNameResolver | Gets or sets a function used to resolve line type names. This supports custom line types. If the LineTypeNameResolver is not set, or returns null, then the default resolver is used.
OnDeserializeCustomConnectionData | Gets or sets a function used to deserialize custom connection data.
OnDeserializeCustomNodeData | Gets or sets a function used to deserialize custom node data.
OnSerializeCustomConnectionData | Gets or sets a function used to serialize custom connection data.
OnSerializeCustomNodeData | Gets or sets a function used to serialize custom node data.
ShapeNameResolver | Gets or sets a function used to resolve shape names. This supports custom shapes. If the ShapeNameResolver is not set, or returns null, then the default resolver is used.

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


LineTypeNameResolver Property

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.LineTypeNameResolver Property
DiagramXmlSerializer Class See Also Send Feedback
Gets or sets a function used to resolve line type names. This supports custom line types. If the LineTypeNameResolver is not set, or returns null, then the default resolver is used.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Func<string, DiagramLineType> LineTypeNameResolver { get; set; }
Visual Basic (Declaration)
Public Property LineTypeNameResolver As Func(Of String, DiagramLineType)

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


OnDeserializeCustomConnectionData Property

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.OnDeserializeCustomConnectionData Property
DiagramXmlSerializer Class See Also Send Feedback
Gets or sets a function used to deserialize custom connection data.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Func<XElement, Object> OnDeserializeCustomConnectionData { get; set; }
Visual Basic (Declaration)
Public Property OnDeserializeCustomConnectionData As Func(Of XElement, Object)

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


OnDeserializeCustomNodeData Property

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.OnDeserializeCustomNodeData Property
DiagramXmlSerializer Class See Also Send Feedback
Gets or sets a function used to deserialize custom node data.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Func<XElement, Object> OnDeserializeCustomNodeData { get; set; }
Visual Basic (Declaration)
Public Property OnDeserializeCustomNodeData As Func(Of XElement, Object)

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


OnSerializeCustomConnectionData Property

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.OnSerializeCustomConnectionData Property
DiagramXmlSerializer Class See Also Send Feedback
Gets or sets a function used to serialize custom connection data.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Func<XElement, DiagramConnection, bool> OnSerializeCustomConnectionData { get; set; }
Visual Basic (Declaration)
Public Property OnSerializeCustomConnectionData As Func(Of XElement, DiagramConnection, Boolean)

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


OnSerializeCustomNodeData Property

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.OnSerializeCustomNodeData Property
DiagramXmlSerializer Class See Also Send Feedback
Gets or sets a function used to serialize custom node data.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Func<XElement, DiagramNode, bool> OnSerializeCustomNodeData { get; set; }
Visual Basic (Declaration)
Public Property OnSerializeCustomNodeData As Func(Of XElement, DiagramNode, Boolean)

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


ShapeNameResolver Property

[image]

Mindscape WPF Diagrams
DiagramXmlSerializer..::.ShapeNameResolver Property
DiagramXmlSerializer Class See Also Send Feedback
Gets or sets a function used to resolve shape names. This supports custom shapes. If the ShapeNameResolver is not set, or returns null, then the default resolver is used.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Func<string, DiagramShape> ShapeNameResolver { get; set; }
Visual Basic (Declaration)
Public Property ShapeNameResolver As Func(Of String, DiagramShape)

See Also

DiagramXmlSerializer Class
Mindscape.WpfDiagramming Namespace


Edge Enumeration

[image]

Mindscape WPF Diagrams
Edge Enumeration
See Also Send Feedback
Identifies the edge of an element.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum Edge
Visual Basic (Declaration)
Public Enumeration Edge

Members

Member name | Description
Top | The top edge.
Right | The right edge.
Bottom | The bottom edge.
Left | The left edge.

See Also

Mindscape.WpfDiagramming Namespace


EdgeHelper Class

[image]

Mindscape WPF Diagrams
EdgeHelper Class
Members See Also Send Feedback
Provides utility methods for working with Edge values.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class EdgeHelper
Visual Basic (Declaration)
Public NotInheritable Class EdgeHelper

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.EdgeHelper

See Also

EdgeHelper Members
Mindscape.WpfDiagramming Namespace


EdgeHelper Members

[image] [image]

Mindscape WPF Diagrams
EdgeHelper Members
EdgeHelper Class Methods See Also Send Feedback

The EdgeHelper type exposes the following members.

Methods

Name | Description
IsAdjacent | Returns true if the two given Edges are adjacent to each other (in any direction), returns false otherwise.
IsOpposite | Returns true if the given two edges are opposite to each other. Returns false otherwise.
OppositeOf | Returns the Edge that is opposite to the given Edge.

See Also

EdgeHelper Class
Mindscape.WpfDiagramming Namespace


EdgeHelper Methods

[image] [image]

Mindscape WPF Diagrams
EdgeHelper Methods
EdgeHelper Class See Also Send Feedback

The EdgeHelper type exposes the following members.

Methods

Name | Description
IsAdjacent | Returns true if the two given Edges are adjacent to each other (in any direction), returns false otherwise.
IsOpposite | Returns true if the given two edges are opposite to each other. Returns false otherwise.
OppositeOf | Returns the Edge that is opposite to the given Edge.

See Also

EdgeHelper Class
Mindscape.WpfDiagramming Namespace


IsAdjacent Method

[image]

Mindscape WPF Diagrams
EdgeHelper..::.IsAdjacent Method
EdgeHelper Class See Also Send Feedback
Returns true if the two given Edges are adjacent to each other (in any direction), returns false otherwise.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static bool IsAdjacent(
    Edge edge1,
    Edge edge2
)
Visual Basic (Declaration)
Public Shared Function IsAdjacent ( _
    edge1 As Edge, _
    edge2 As Edge _
) As Boolean

Parameters

edge1
Type: Mindscape.WpfDiagramming..::.Edge
One of the edges to check for adjacency.
edge2
Type: Mindscape.WpfDiagramming..::.Edge
One of the edges to check for adjacency.

Return Value

Whether or not the two given edges are adjacent to each other (in any direction).

See Also

EdgeHelper Class
Mindscape.WpfDiagramming Namespace


IsOpposite Method

[image]

Mindscape WPF Diagrams
EdgeHelper..::.IsOpposite Method
EdgeHelper Class See Also Send Feedback
Returns true if the given two edges are opposite to each other. Returns false otherwise.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static bool IsOpposite(
    Edge edge1,
    Edge edge2
)
Visual Basic (Declaration)
Public Shared Function IsOpposite ( _
    edge1 As Edge, _
    edge2 As Edge _
) As Boolean

Parameters

edge1
Type: Mindscape.WpfDiagramming..::.Edge
One of the Edges to check for oppositness.
edge2
Type: Mindscape.WpfDiagramming..::.Edge
One of the Edges to check for oppositness.

Return Value

Whether or not the two given edges are opposite to eacj other.

See Also

EdgeHelper Class
Mindscape.WpfDiagramming Namespace


OppositeOf Method

[image]

Mindscape WPF Diagrams
EdgeHelper..::.OppositeOf Method
EdgeHelper Class See Also Send Feedback
Returns the Edge that is opposite to the given Edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Edge OppositeOf(
    Edge edge
)
Visual Basic (Declaration)
Public Shared Function OppositeOf ( _
    edge As Edge _
) As Edge

Parameters

edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge to find the opposite Edge of.

Return Value

The opposite Edge of the given Edge.

See Also

EdgeHelper Class
Mindscape.WpfDiagramming Namespace


LineTypeLayout Class

[image]

Mindscape WPF Diagrams
LineTypeLayout Class
Members See Also Send Feedback
Specifies how to display a DiagramLineType.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class LineTypeLayout
Visual Basic (Declaration)
Public Class LineTypeLayout

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.LineTypeLayout

See Also

LineTypeLayout Members
Mindscape.WpfDiagramming Namespace


LineTypeLayout Members

[image] [image]

Mindscape WPF Diagrams
LineTypeLayout Members
LineTypeLayout Class Constructors Methods Fields Properties See Also Send Feedback

The LineTypeLayout type exposes the following members.

Constructors

Name | Description
LineTypeLayout | Initializes a new instance of the LineTypeLayout class.

Methods

Name | Description
GetToolboxIconStyle | Gets the ToolboxIconStyle to be applied to a Path in a DiagramConnectionTool.
SetToolboxIconStyle | Sets the ToolboxIconStyle to be applied to a Path in a DiagramConnectionTool.

Fields

Name | Description
ToolboxIconStyleProperty | Identifies the ToolboxIconStyle attached property.

Properties

Name | Description
EndArrowhead | Gets or sets the type of arrowhead shown at the end of lines of this type.
StartArrowhead | Gets or sets the type of arrowhead shown at the start of lines of this type.
Stroke | Gets or sets the Brush used to draw lines of this type.
StrokeDashArray | Gets or sets the dash pattern for lines of this type.
StrokeThickness | Gets or sets the thickness of lines of this type.
ToolboxIconPaths | Specifies the paths that represent lines of this type in the toolbox.

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


LineTypeLayout Constructor

[image]

Mindscape WPF Diagrams
LineTypeLayout Constructor
LineTypeLayout Class See Also Send Feedback
Initializes a new instance of the LineTypeLayout class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public LineTypeLayout()
Visual Basic (Declaration)
Public Sub New

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


LineTypeLayout Fields

[image] [image]

Mindscape WPF Diagrams
LineTypeLayout Fields
LineTypeLayout Class See Also Send Feedback

The LineTypeLayout type exposes the following members.

Fields

Name | Description
ToolboxIconStyleProperty | Identifies the ToolboxIconStyle attached property.

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


ToolboxIconStyleProperty Field

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.ToolboxIconStyleProperty Field
LineTypeLayout Class See Also Send Feedback
Identifies the ToolboxIconStyle attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ToolboxIconStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolboxIconStyleProperty As DependencyProperty

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


LineTypeLayout Methods

[image] [image]

Mindscape WPF Diagrams
LineTypeLayout Methods
LineTypeLayout Class See Also Send Feedback

The LineTypeLayout type exposes the following members.

Methods

Name | Description
GetToolboxIconStyle | Gets the ToolboxIconStyle to be applied to a Path in a DiagramConnectionTool.
SetToolboxIconStyle | Sets the ToolboxIconStyle to be applied to a Path in a DiagramConnectionTool.

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


GetToolboxIconStyle Method

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.GetToolboxIconStyle Method
LineTypeLayout Class See Also Send Feedback
Gets the ToolboxIconStyle to be applied to a Path in a DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ToolboxIconStyle GetToolboxIconStyle(
    Path obj
)
Visual Basic (Declaration)
Public Shared Function GetToolboxIconStyle ( _
    obj As Path _
) As ToolboxIconStyle

Parameters

obj
Type: System.Windows.Shapes..::.Path
The Path from which the property value is read.

Return Value

The value of the ToolboxIconStyle attached property on the specified object.

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


SetToolboxIconStyle Method

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.SetToolboxIconStyle Method
LineTypeLayout Class See Also Send Feedback
Sets the ToolboxIconStyle to be applied to a Path in a DiagramConnectionTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetToolboxIconStyle(
    Path obj,
    ToolboxIconStyle value
)
Visual Basic (Declaration)
Public Shared Sub SetToolboxIconStyle ( _
    obj As Path, _
    value As ToolboxIconStyle _
)

Parameters

obj
Type: System.Windows.Shapes..::.Path
The Path to which the property value is written.
value
Type: Mindscape.WpfDiagramming..::.ToolboxIconStyle
The value of the ToolboxIconStyle attached property on the specified object.

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


LineTypeLayout Properties

[image] [image]

Mindscape WPF Diagrams
LineTypeLayout Properties
LineTypeLayout Class See Also Send Feedback

The LineTypeLayout type exposes the following members.

Properties

Name | Description
EndArrowhead | Gets or sets the type of arrowhead shown at the end of lines of this type.
StartArrowhead | Gets or sets the type of arrowhead shown at the start of lines of this type.
Stroke | Gets or sets the Brush used to draw lines of this type.
StrokeDashArray | Gets or sets the dash pattern for lines of this type.
StrokeThickness | Gets or sets the thickness of lines of this type.
ToolboxIconPaths | Specifies the paths that represent lines of this type in the toolbox.

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


EndArrowhead Property

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.EndArrowhead Property
LineTypeLayout Class See Also Send Feedback
Gets or sets the type of arrowhead shown at the end of lines of this type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramArrowheadType EndArrowhead { get; set; }
Visual Basic (Declaration)
Public Property EndArrowhead As DiagramArrowheadType

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


StartArrowhead Property

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.StartArrowhead Property
LineTypeLayout Class See Also Send Feedback
Gets or sets the type of arrowhead shown at the start of lines of this type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramArrowheadType StartArrowhead { get; set; }
Visual Basic (Declaration)
Public Property StartArrowhead As DiagramArrowheadType

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


Stroke Property

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.Stroke Property
LineTypeLayout Class See Also Send Feedback
Gets or sets the Brush used to draw lines of this type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Brush Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Brush

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


StrokeDashArray Property

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.StrokeDashArray Property
LineTypeLayout Class See Also Send Feedback
Gets or sets the dash pattern for lines of this type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DoubleCollection StrokeDashArray { get; set; }
Visual Basic (Declaration)
Public Property StrokeDashArray As DoubleCollection

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


StrokeThickness Property

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.StrokeThickness Property
LineTypeLayout Class See Also Send Feedback
Gets or sets the thickness of lines of this type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property StrokeThickness As Double

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


ToolboxIconPaths Property

[image]

Mindscape WPF Diagrams
LineTypeLayout..::.ToolboxIconPaths Property
LineTypeLayout Class See Also Send Feedback
Specifies the paths that represent lines of this type in the toolbox.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public List<Path> ToolboxIconPaths { get; }
Visual Basic (Declaration)
Public ReadOnly Property ToolboxIconPaths As List(Of Path)

See Also

LineTypeLayout Class
Mindscape.WpfDiagramming Namespace


MarqueeDragCompletedEventArgs Class

[image]

Mindscape WPF Diagrams
MarqueeDragCompletedEventArgs Class
Members See Also Send Feedback
Provides information about the MarqueeDragCompleted event of a DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class MarqueeDragCompletedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class MarqueeDragCompletedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming..::.MarqueeDragCompletedEventArgs

See Also

MarqueeDragCompletedEventArgs Members
Mindscape.WpfDiagramming Namespace


MarqueeDragCompletedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
MarqueeDragCompletedEventArgs Members
MarqueeDragCompletedEventArgs Class Constructors Properties See Also Send Feedback

The MarqueeDragCompletedEventArgs type exposes the following members.

Constructors

Name | Description
MarqueeDragCompletedEventArgs | Initializes a new instance of the MarqueeDragCompletedEventArgs class.

Properties

Name | Description
Marquee | Gets the marquee drag rectangle (in diagram coordinates).

See Also

MarqueeDragCompletedEventArgs Class
Mindscape.WpfDiagramming Namespace


MarqueeDragCompletedEventArgs Constructor

[image]

Mindscape WPF Diagrams
MarqueeDragCompletedEventArgs Constructor
MarqueeDragCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the MarqueeDragCompletedEventArgs class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MarqueeDragCompletedEventArgs(
    Rect marquee
)
Visual Basic (Declaration)
Public Sub New ( _
    marquee As Rect _
)

Parameters

marquee
Type: System.Windows..::.Rect
The marquee drag rectangle (in diagram coordinates).

See Also

MarqueeDragCompletedEventArgs Class
Mindscape.WpfDiagramming Namespace


MarqueeDragCompletedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
MarqueeDragCompletedEventArgs Properties
MarqueeDragCompletedEventArgs Class See Also Send Feedback

The MarqueeDragCompletedEventArgs type exposes the following members.

Properties

Name | Description
Marquee | Gets the marquee drag rectangle (in diagram coordinates).

See Also

MarqueeDragCompletedEventArgs Class
Mindscape.WpfDiagramming Namespace


Marquee Property

[image]

Mindscape WPF Diagrams
MarqueeDragCompletedEventArgs..::.Marquee Property
MarqueeDragCompletedEventArgs Class See Also Send Feedback
Gets the marquee drag rectangle (in diagram coordinates).

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect Marquee { get; }
Visual Basic (Declaration)
Public ReadOnly Property Marquee As Rect

See Also

MarqueeDragCompletedEventArgs Class
Mindscape.WpfDiagramming Namespace


MarqueeDragStartedEventArgs Class

[image]

Mindscape WPF Diagrams
MarqueeDragStartedEventArgs Class
Members See Also Send Feedback
Provides information about the MarqueeDragStarted event of a DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class MarqueeDragStartedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class MarqueeDragStartedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming..::.MarqueeDragStartedEventArgs

See Also

MarqueeDragStartedEventArgs Members
Mindscape.WpfDiagramming Namespace


MarqueeDragStartedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
MarqueeDragStartedEventArgs Members
MarqueeDragStartedEventArgs Class Constructors Properties See Also Send Feedback

The MarqueeDragStartedEventArgs type exposes the following members.

Constructors

Name | Description
MarqueeDragStartedEventArgs | Initializes a new instance of the MarqueeDragStartedEventArgs class.

Properties

Name | Description
StartPosition | Gets the start position of the marquee area relative to the DiagramSurface.

See Also

MarqueeDragStartedEventArgs Class
Mindscape.WpfDiagramming Namespace


MarqueeDragStartedEventArgs Constructor

[image]

Mindscape WPF Diagrams
MarqueeDragStartedEventArgs Constructor
MarqueeDragStartedEventArgs Class See Also Send Feedback
Initializes a new instance of the MarqueeDragStartedEventArgs class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MarqueeDragStartedEventArgs(
    Point startPosition
)
Visual Basic (Declaration)
Public Sub New ( _
    startPosition As Point _
)

Parameters

startPosition
Type: System.Windows..::.Point
The start position of the marquee relative to the DiagramSurface.

See Also

MarqueeDragStartedEventArgs Class
Mindscape.WpfDiagramming Namespace


MarqueeDragStartedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
MarqueeDragStartedEventArgs Properties
MarqueeDragStartedEventArgs Class See Also Send Feedback

The MarqueeDragStartedEventArgs type exposes the following members.

Properties

Name | Description
StartPosition | Gets the start position of the marquee area relative to the DiagramSurface.

See Also

MarqueeDragStartedEventArgs Class
Mindscape.WpfDiagramming Namespace


StartPosition Property

[image]

Mindscape WPF Diagrams
MarqueeDragStartedEventArgs..::.StartPosition Property
MarqueeDragStartedEventArgs Class See Also Send Feedback
Gets the start position of the marquee area relative to the DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point StartPosition { get; private set; }
Visual Basic (Declaration)
Public Property StartPosition As Point

See Also

MarqueeDragStartedEventArgs Class
Mindscape.WpfDiagramming Namespace


OverflowBehavior Enumeration

[image]

Mindscape WPF Diagrams
OverflowBehavior Enumeration
See Also Send Feedback
Specifies the behavior of a DiagramSurface when the diagram is too big for the control to display.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum OverflowBehavior
Visual Basic (Declaration)
Public Enumeration OverflowBehavior

Members

Member name | Description
Scroll | Scroll bars are displayed and the user may scroll the view.
Clip | The diagram display is clipped to the available size.

See Also

Mindscape.WpfDiagramming Namespace


ShapeConnectionPointPosition Class

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPosition Class
Members See Also Send Feedback
Specifies the location of a connection point on a DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ShapeConnectionPointPosition
Visual Basic (Declaration)
Public Class ShapeConnectionPointPosition

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.ShapeConnectionPointPosition

See Also

ShapeConnectionPointPosition Members
Mindscape.WpfDiagramming Namespace


ShapeConnectionPointPosition Members

[image] [image]

Mindscape WPF Diagrams
ShapeConnectionPointPosition Members
ShapeConnectionPointPosition Class Constructors Properties See Also Send Feedback

The ShapeConnectionPointPosition type exposes the following members.

Constructors

Name | Description
ShapeConnectionPointPosition |

Properties

Name | Description
Edge | Gets or sets the edge for whose connection points this specifies a position.
Position | Gets or sets the IPositionCalculator which specifies the position of a connection point.

See Also

ShapeConnectionPointPosition Class
Mindscape.WpfDiagramming Namespace


ShapeConnectionPointPosition Constructor

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPosition Constructor
ShapeConnectionPointPosition Class See Also Send Feedback
Initializes a new instance of the ShapeConnectionPointPosition class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ShapeConnectionPointPosition()
Visual Basic (Declaration)
Public Sub New

See Also

ShapeConnectionPointPosition Class
Mindscape.WpfDiagramming Namespace


ShapeConnectionPointPosition Properties

[image] [image]

Mindscape WPF Diagrams
ShapeConnectionPointPosition Properties
ShapeConnectionPointPosition Class See Also Send Feedback

The ShapeConnectionPointPosition type exposes the following members.

Properties

Name | Description
Edge | Gets or sets the edge for whose connection points this specifies a position.
Position | Gets or sets the IPositionCalculator which specifies the position of a connection point.

See Also

ShapeConnectionPointPosition Class
Mindscape.WpfDiagramming Namespace


Edge Property

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPosition..::.Edge Property
ShapeConnectionPointPosition Class See Also Send Feedback
Gets or sets the edge for whose connection points this specifies a position.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Edge Edge { get; set; }
Visual Basic (Declaration)
Public Property Edge As Edge

See Also

ShapeConnectionPointPosition Class
Mindscape.WpfDiagramming Namespace


Position Property

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPosition..::.Position Property
ShapeConnectionPointPosition Class See Also Send Feedback
Gets or sets the IPositionCalculator which specifies the position of a connection point.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[TypeConverterAttribute(typeof(PositionCalculatorConverter))]
public IPositionCalculator Position { get; set; }
Visual Basic (Declaration)
<TypeConverterAttribute(GetType(PositionCalculatorConverter))> _
Public Property Position As IPositionCalculator

See Also

ShapeConnectionPointPosition Class
Mindscape.WpfDiagramming Namespace


ShapeLayout Class

[image]

Mindscape WPF Diagrams
ShapeLayout Class
Members See Also Send Feedback
Specifies how to display a DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ShapeLayout
Visual Basic (Declaration)
Public Class ShapeLayout

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.ShapeLayout

See Also

ShapeLayout Members
Mindscape.WpfDiagramming Namespace


ShapeLayout Members

[image] [image]

Mindscape WPF Diagrams
ShapeLayout Members
ShapeLayout Class Constructors Methods Fields Properties See Also Send Feedback

The ShapeLayout type exposes the following members.

Constructors

Name | Description
ShapeLayout | Initializes a new instance of the ShapeLayout class.

Methods

Name | Description
GetCursorVisualStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is being displayed as a cursor visual.
GetNodeStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is placed on the diagram.
GetPositionCalculator | Gets the position of the connection point at the specified index along the specified edge.
GetToolboxIconStyle | Gets the style to be used for a Path in a ShapeLayout when the shape appears in the toolbox.
SetCursorVisualStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is being displayed as a cursor visual.
SetNodeStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is placed on the diagram.
SetToolboxIconStyle | Gets the style to be used for a Path in a ShapeLayout when the shape appears in the toolbox.

Fields

Name | Description
CursorVisualStyleProperty | Identifies the CursorVisualStyle attached property.
NodeStyleProperty | Identifies the NodeStyle attached property.
ToolboxIconStyleProperty | Identifies the ToolboxIconStyle attached property.

Properties

Name | Description
ConnectionPointPositions | Specifies how connection points should be positioned on the DiagramShape.
ContentMargin | Specifies how content should be positioned on the DiagramShape.
Geometry | Specifies the geometry of a DiagramShape.
Paths | Specifies the paths that make up a DiagramShape. This is used for shapes that need to apply different fill, stroke or style settings to different figures in the shape. A shape should specify either Paths or Geometry, but not both.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ShapeLayout Constructor

[image]

Mindscape WPF Diagrams
ShapeLayout Constructor
ShapeLayout Class See Also Send Feedback
Initializes a new instance of the ShapeLayout class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ShapeLayout()
Visual Basic (Declaration)
Public Sub New

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ShapeLayout Fields

[image] [image]

Mindscape WPF Diagrams
ShapeLayout Fields
ShapeLayout Class See Also Send Feedback

The ShapeLayout type exposes the following members.

Fields

Name | Description
CursorVisualStyleProperty | Identifies the CursorVisualStyle attached property.
NodeStyleProperty | Identifies the NodeStyle attached property.
ToolboxIconStyleProperty | Identifies the ToolboxIconStyle attached property.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


CursorVisualStyleProperty Field

[image]

Mindscape WPF Diagrams
ShapeLayout..::.CursorVisualStyleProperty Field
ShapeLayout Class See Also Send Feedback
Identifies the CursorVisualStyle attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CursorVisualStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly CursorVisualStyleProperty As DependencyProperty

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


NodeStyleProperty Field

[image]

Mindscape WPF Diagrams
ShapeLayout..::.NodeStyleProperty Field
ShapeLayout Class See Also Send Feedback
Identifies the NodeStyle attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty NodeStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly NodeStyleProperty As DependencyProperty

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ToolboxIconStyleProperty Field

[image]

Mindscape WPF Diagrams
ShapeLayout..::.ToolboxIconStyleProperty Field
ShapeLayout Class See Also Send Feedback
Identifies the ToolboxIconStyle attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ToolboxIconStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToolboxIconStyleProperty As DependencyProperty

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ShapeLayout Methods

[image] [image]

Mindscape WPF Diagrams
ShapeLayout Methods
ShapeLayout Class See Also Send Feedback

The ShapeLayout type exposes the following members.

Methods

Name | Description
GetCursorVisualStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is being displayed as a cursor visual.
GetNodeStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is placed on the diagram.
GetPositionCalculator | Gets the position of the connection point at the specified index along the specified edge.
GetToolboxIconStyle | Gets the style to be used for a Path in a ShapeLayout when the shape appears in the toolbox.
SetCursorVisualStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is being displayed as a cursor visual.
SetNodeStyle | Gets the style to be used for a Path in a ShapeLayout when the shape is placed on the diagram.
SetToolboxIconStyle | Gets the style to be used for a Path in a ShapeLayout when the shape appears in the toolbox.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


GetCursorVisualStyle Method

[image]

Mindscape WPF Diagrams
ShapeLayout..::.GetCursorVisualStyle Method
ShapeLayout Class See Also Send Feedback
Gets the style to be used for a Path in a ShapeLayout when the shape is being displayed as a cursor visual.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Style GetCursorVisualStyle(
    Path obj
)
Visual Basic (Declaration)
Public Shared Function GetCursorVisualStyle ( _
    obj As Path _
) As Style

Parameters

obj
Type: System.Windows.Shapes..::.Path
The element from which the property value is read.

Return Value

The value of the CursorVisualStyle property on the specified element.

Remarks

The default is the Style of the Path.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


GetNodeStyle Method

[image]

Mindscape WPF Diagrams
ShapeLayout..::.GetNodeStyle Method
ShapeLayout Class See Also Send Feedback
Gets the style to be used for a Path in a ShapeLayout when the shape is placed on the diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Style GetNodeStyle(
    Path obj
)
Visual Basic (Declaration)
Public Shared Function GetNodeStyle ( _
    obj As Path _
) As Style

Parameters

obj
Type: System.Windows.Shapes..::.Path
The element from which the property value is read.

Return Value

The value of the NodeStyle property on the specified element.

Remarks

The default is the Style of the Path.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


GetPositionCalculator Method

[image]

Mindscape WPF Diagrams
ShapeLayout..::.GetPositionCalculator Method
ShapeLayout Class See Also Send Feedback
Gets the position of the connection point at the specified index along the specified edge.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IPositionCalculator GetPositionCalculator(
    Edge edge,
    int index
)
Visual Basic (Declaration)
Public Function GetPositionCalculator ( _
    edge As Edge, _
    index As Integer _
) As IPositionCalculator

Parameters

edge
Type: Mindscape.WpfDiagramming..::.Edge
The edge for which to get a connection point position.
index
Type: System..::.Int32
The index of the connection point along that edge.

Return Value

An IPositionCalculator specifying the location of the connection point.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


GetToolboxIconStyle Method

[image]

Mindscape WPF Diagrams
ShapeLayout..::.GetToolboxIconStyle Method
ShapeLayout Class See Also Send Feedback
Gets the style to be used for a Path in a ShapeLayout when the shape appears in the toolbox.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Style GetToolboxIconStyle(
    Path obj
)
Visual Basic (Declaration)
Public Shared Function GetToolboxIconStyle ( _
    obj As Path _
) As Style

Parameters

obj
Type: System.Windows.Shapes..::.Path
The element from which the property value is read.

Return Value

The value of the ToolboxIconStyle property on the specified element.

Remarks

The default is the Style of the Path.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


SetCursorVisualStyle Method

[image]

Mindscape WPF Diagrams
ShapeLayout..::.SetCursorVisualStyle Method
ShapeLayout Class See Also Send Feedback
Gets the style to be used for a Path in a ShapeLayout when the shape is being displayed as a cursor visual.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetCursorVisualStyle(
    Path obj,
    Style value
)
Visual Basic (Declaration)
Public Shared Sub SetCursorVisualStyle ( _
    obj As Path, _
    value As Style _
)

Parameters

obj
Type: System.Windows.Shapes..::.Path
The element to which the property value is written.
value
Type: System.Windows..::.Style
The value of the ToolboxIconStyle property on the specified element.

Remarks

The default is the Style of the Path.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


SetNodeStyle Method

[image]

Mindscape WPF Diagrams
ShapeLayout..::.SetNodeStyle Method
ShapeLayout Class See Also Send Feedback
Gets the style to be used for a Path in a ShapeLayout when the shape is placed on the diagram.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetNodeStyle(
    Path obj,
    Style value
)
Visual Basic (Declaration)
Public Shared Sub SetNodeStyle ( _
    obj As Path, _
    value As Style _
)

Parameters

obj
Type: System.Windows.Shapes..::.Path
The element to which the property value is written.
value
Type: System.Windows..::.Style
The value of the ToolboxIconStyle property on the specified element.

Remarks

The default is the Style of the Path.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


SetToolboxIconStyle Method

[image]

Mindscape WPF Diagrams
ShapeLayout..::.SetToolboxIconStyle Method
ShapeLayout Class See Also Send Feedback
Gets the style to be used for a Path in a ShapeLayout when the shape appears in the toolbox.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetToolboxIconStyle(
    Path obj,
    Style value
)
Visual Basic (Declaration)
Public Shared Sub SetToolboxIconStyle ( _
    obj As Path, _
    value As Style _
)

Parameters

obj
Type: System.Windows.Shapes..::.Path
The element to which the property value is written.
value
Type: System.Windows..::.Style
The value of the ToolboxIconStyle property on the specified element.

Remarks

The default is the Style of the Path.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ShapeLayout Properties

[image] [image]

Mindscape WPF Diagrams
ShapeLayout Properties
ShapeLayout Class See Also Send Feedback

The ShapeLayout type exposes the following members.

Properties

Name | Description
ConnectionPointPositions | Specifies how connection points should be positioned on the DiagramShape.
ContentMargin | Specifies how content should be positioned on the DiagramShape.
Geometry | Specifies the geometry of a DiagramShape.
Paths | Specifies the paths that make up a DiagramShape. This is used for shapes that need to apply different fill, stroke or style settings to different figures in the shape. A shape should specify either Paths or Geometry, but not both.

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ConnectionPointPositions Property

[image]

Mindscape WPF Diagrams
ShapeLayout..::.ConnectionPointPositions Property
ShapeLayout Class See Also Send Feedback
Specifies how connection points should be positioned on the DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[TypeConverterAttribute(typeof(ShapeConnectionPointPositionCollectionConverter))]
public List<ShapeConnectionPointPosition> ConnectionPointPositions { get; set; }
Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ShapeConnectionPointPositionCollectionConverter))> _
Public Property ConnectionPointPositions As List(Of ShapeConnectionPointPosition)

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ContentMargin Property

[image]

Mindscape WPF Diagrams
ShapeLayout..::.ContentMargin Property
ShapeLayout Class See Also Send Feedback
Specifies how content should be positioned on the DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ContentMargin ContentMargin { get; set; }
Visual Basic (Declaration)
Public Property ContentMargin As ContentMargin

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


Geometry Property

[image]

Mindscape WPF Diagrams
ShapeLayout..::.Geometry Property
ShapeLayout Class See Also Send Feedback
Specifies the geometry of a DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Geometry Geometry { get; set; }
Visual Basic (Declaration)
Public Property Geometry As Geometry

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


Paths Property

[image]

Mindscape WPF Diagrams
ShapeLayout..::.Paths Property
ShapeLayout Class See Also Send Feedback
Specifies the paths that make up a DiagramShape. This is used for shapes that need to apply different fill, stroke or style settings to different figures in the shape. A shape should specify either Paths or Geometry, but not both.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public List<Path> Paths { get; }
Visual Basic (Declaration)
Public ReadOnly Property Paths As List(Of Path)

See Also

ShapeLayout Class
Mindscape.WpfDiagramming Namespace


ShapeNode Class

[image]

Mindscape WPF Diagrams
ShapeNode Class
Members See Also Send Feedback
Represents a node in a diagram that displays a geometric shape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ShapeNode : DiagramNode
Visual Basic (Declaration)
Public Class ShapeNode _
    Inherits DiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming..::.ShapeNode
Mindscape.WpfDiagramming.FlowDiagrams..::.StepNode

See Also

ShapeNode Members
Mindscape.WpfDiagramming Namespace


ShapeNode Members

[image] [image]

Mindscape WPF Diagrams
ShapeNode Members
ShapeNode Class Constructors Methods Properties Events See Also Send Feedback

The ShapeNode type exposes the following members.

Constructors

Name | Description
ShapeNode | Initializes a new instance of the ShapeNode class.

Methods

Name | Description
BuildConnectionPoint | Returns a new connection point to be added to this node.
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns true. DiagramNodeBase objects can accept any number of out going connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanReceiveNewConnections | Returns true. DiagramNodeBase objects can accept any number of incomming connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Shape | Gets or sets the DiagramShape displayed by this ShapeNode.
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


ShapeNode Constructor

[image]

Mindscape WPF Diagrams
ShapeNode Constructor
ShapeNode Class See Also Send Feedback
Initializes a new instance of the ShapeNode class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ShapeNode()
Visual Basic (Declaration)
Public Sub New

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


ShapeNode Methods

[image] [image]

Mindscape WPF Diagrams
ShapeNode Methods
ShapeNode Class See Also Send Feedback

The ShapeNode type exposes the following members.

Methods

Name | Description
BuildConnectionPoint | Returns a new connection point to be added to this node.
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


BuildConnectionPoint Method

[image]

Mindscape WPF Diagrams
ShapeNode..::.BuildConnectionPoint Method
ShapeNode Class See Also Send Feedback
Returns a new connection point to be added to this node.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramConnectionPoint BuildConnectionPoint(
    Edge edge
)
Visual Basic (Declaration)
Protected Overridable Function BuildConnectionPoint ( _
    edge As Edge _
) As DiagramConnectionPoint

Parameters

edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge value for the new connection point.

Return Value

A connection point to be added to this node.

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


Clone Method

[image]

Mindscape WPF Diagrams
ShapeNode..::.Clone Method
ShapeNode Class See Also Send Feedback
Gets an IDiagramNodeState that represents the current state of this node at the time this method is called.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IDiagramNodeState Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As IDiagramNodeState

Return Value

An IDiagramNodeState that represents the current state of this node.

Implements

IDiagramNode..::.Clone()()()

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


SetAs Method

[image]

Mindscape WPF Diagrams
ShapeNode..::.SetAs Method
ShapeNode Class See Also Send Feedback
Sets all the properties of this node to match those of the given IDiagramNodeState.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void SetAs(
    IDiagramNodeState state
)
Visual Basic (Declaration)
Public Overrides Sub SetAs ( _
    state As IDiagramNodeState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNodeState
The IDiagramNodeState that will have its property values applied to this node.

Implements

IDiagramNode..::.SetAs(IDiagramNodeState)

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


ShapeNode Properties

[image] [image]

Mindscape WPF Diagrams
ShapeNode Properties
ShapeNode Class See Also Send Feedback

The ShapeNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns true. DiagramNodeBase objects can accept any number of out going connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanReceiveNewConnections | Returns true. DiagramNodeBase objects can accept any number of incomming connections. This can be overriden to provide node specific logic. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Shape | Gets or sets the DiagramShape displayed by this ShapeNode.
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


Shape Property

[image]

Mindscape WPF Diagrams
ShapeNode..::.Shape Property
ShapeNode Class See Also Send Feedback
Gets or sets the DiagramShape displayed by this ShapeNode.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As DiagramShape

See Also

ShapeNode Class
Mindscape.WpfDiagramming Namespace


ShapeNodeStyleSelector Class

[image]

Mindscape WPF Diagrams
ShapeNodeStyleSelector Class
Members See Also Send Feedback
Selects a style for a ShapeNode using the ShapeLayout resource whose key is the ShapeNode object.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ShapeNodeStyleSelector : MatchingStyleSelector
Visual Basic (Declaration)
Public Class ShapeNodeStyleSelector _
    Inherits MatchingStyleSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingStyleSelector
Mindscape.WpfDiagramming.Foundation..::.MatchingStyleSelector
Mindscape.WpfDiagramming..::.ShapeNodeStyleSelector

See Also

ShapeNodeStyleSelector Members
Mindscape.WpfDiagramming Namespace


ShapeNodeStyleSelector Members

[image] [image]

Mindscape WPF Diagrams
ShapeNodeStyleSelector Members
ShapeNodeStyleSelector Class Constructors Methods Properties See Also Send Feedback

The ShapeNodeStyleSelector type exposes the following members.

Constructors

Name | Description
ShapeNodeStyleSelector |

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Selects a style for a ShapeNode. (Overrides MatchingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector. (Inherited from DelegatingStyleSelector.)
DefaultStyle | Gets or sets the default Style. (Inherited from MatchingStyleSelector.)
Styles | Gets the list of styles and matching criteria. (Inherited from MatchingStyleSelector.)

See Also

ShapeNodeStyleSelector Class
Mindscape.WpfDiagramming Namespace


ShapeNodeStyleSelector Constructor

[image]

Mindscape WPF Diagrams
ShapeNodeStyleSelector Constructor
ShapeNodeStyleSelector Class See Also Send Feedback
Initializes a new instance of the ShapeNodeStyleSelector class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ShapeNodeStyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

ShapeNodeStyleSelector Class
Mindscape.WpfDiagramming Namespace


ShapeNodeStyleSelector Methods

[image] [image]

Mindscape WPF Diagrams
ShapeNodeStyleSelector Methods
ShapeNodeStyleSelector Class See Also Send Feedback

The ShapeNodeStyleSelector type exposes the following members.

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Selects a style for a ShapeNode. (Overrides MatchingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

See Also

ShapeNodeStyleSelector Class
Mindscape.WpfDiagramming Namespace


SelectStyleCore Method

[image]

Mindscape WPF Diagrams
ShapeNodeStyleSelector..::.SelectStyleCore Method
ShapeNodeStyleSelector Class See Also Send Feedback
Selects a style for a ShapeNode.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Style SelectStyleCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected Overrides Function SelectStyleCore ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The node whose style is required. If this is not a ShapeNode, the Styles collection is consulted instead as in a normal MatchingStyleSelector.
container
Type: System.Windows..::.DependencyObject
The data bound container object.

Return Value

>A Style for the specified node.

See Also

ShapeNodeStyleSelector Class
Mindscape.WpfDiagramming Namespace


ShapeTool Class

[image]

Mindscape WPF Diagrams
ShapeTool Class
Members See Also Send Feedback
Provides attached properties which configure a DiagramNodeTool to create nodes of a specified DiagramShape.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class ShapeTool
Visual Basic (Declaration)
Public NotInheritable Class ShapeTool

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.ShapeTool

See Also

ShapeTool Members
Mindscape.WpfDiagramming Namespace


ShapeTool Members

[image] [image]

Mindscape WPF Diagrams
ShapeTool Members
ShapeTool Class Methods Fields See Also Send Feedback

The ShapeTool type exposes the following members.

Methods

Name | Description
ConfigureTool | Configures a DiagramNodeTool to create nodes of a particular shape and type.
GetShape | Gets the DiagramShape for this DiagramNodeTool.
GetShapePathStyle | Gets the Style to be applied to the Path part of a ShapeNode created from the DiagramNodeTool that the ShapePathStyle property is attached to.
SetShape | Sets the DiagramShape for this DiagramNodeTool.
SetShapePathStyle | Sets the Style to be applied to the Path part of a ShapeNode created from the DiagramNodeTool that the ShapePathStyle property is attached to.

Fields

Name | Description
ShapePathStyleProperty | Identifies the ShapePathStyle attached property.
ShapeProperty | Identifies the Shape attached property.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


ShapeTool Fields

[image] [image]

Mindscape WPF Diagrams
ShapeTool Fields
ShapeTool Class See Also Send Feedback

The ShapeTool type exposes the following members.

Fields

Name | Description
ShapePathStyleProperty | Identifies the ShapePathStyle attached property.
ShapeProperty | Identifies the Shape attached property.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


ShapePathStyleProperty Field

[image]

Mindscape WPF Diagrams
ShapeTool..::.ShapePathStyleProperty Field
ShapeTool Class See Also Send Feedback
Identifies the ShapePathStyle attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShapePathStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShapePathStyleProperty As DependencyProperty

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


ShapeProperty Field

[image]

Mindscape WPF Diagrams
ShapeTool..::.ShapeProperty Field
ShapeTool Class See Also Send Feedback
Identifies the Shape attached property.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShapeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShapeProperty As DependencyProperty

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


ShapeTool Methods

[image] [image]

Mindscape WPF Diagrams
ShapeTool Methods
ShapeTool Class See Also Send Feedback

The ShapeTool type exposes the following members.

Methods

Name | Description
ConfigureTool | Configures a DiagramNodeTool to create nodes of a particular shape and type.
GetShape | Gets the DiagramShape for this DiagramNodeTool.
GetShapePathStyle | Gets the Style to be applied to the Path part of a ShapeNode created from the DiagramNodeTool that the ShapePathStyle property is attached to.
SetShape | Sets the DiagramShape for this DiagramNodeTool.
SetShapePathStyle | Sets the Style to be applied to the Path part of a ShapeNode created from the DiagramNodeTool that the ShapePathStyle property is attached to.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


ConfigureTool Method

[image]

Mindscape WPF Diagrams
ShapeTool..::.ConfigureTool Method
ShapeTool Class See Also Send Feedback
Configures a DiagramNodeTool to create nodes of a particular shape and type.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void ConfigureTool(
    DiagramNodeTool tool,
    DiagramShape shape,
    Func<DiagramShape, IDiagramNodeBuilder> builder
)
Visual Basic (Declaration)
Public Shared Sub ConfigureTool ( _
    tool As DiagramNodeTool, _
    shape As DiagramShape, _
    builder As Func(Of DiagramShape, IDiagramNodeBuilder) _
)

Parameters

tool
Type: Mindscape.WpfDiagramming..::.DiagramNodeTool
The DiagramNodeTool to be configured.
shape
Type: Mindscape.WpfDiagramming..::.DiagramShape
The DiagramShape representing the desired node shape.
builder
Type: System..::.Func <(Of <( DiagramShape, IDiagramNodeBuilder >)>)
A function which produces an IDiagramNodeBuilder for the desired type of node.

Remarks

You can use this method if you want to leverage the shape tool infrastructure in your own custom diagram types.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


GetShape Method

[image]

Mindscape WPF Diagrams
ShapeTool..::.GetShape Method
ShapeTool Class See Also Send Feedback
Gets the DiagramShape for this DiagramNodeTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static DiagramShape GetShape(
    DiagramNodeTool obj
)
Visual Basic (Declaration)
Public Shared Function GetShape ( _
    obj As DiagramNodeTool _
) As DiagramShape

Parameters

obj
Type: Mindscape.WpfDiagramming..::.DiagramNodeTool
The element from which the property value is read.

Return Value

The DiagramShape of the specified DiagramNodeTool.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


GetShapePathStyle Method

[image]

Mindscape WPF Diagrams
ShapeTool..::.GetShapePathStyle Method
ShapeTool Class See Also Send Feedback
Gets the Style to be applied to the Path part of a ShapeNode created from the DiagramNodeTool that the ShapePathStyle property is attached to.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static Style GetShapePathStyle(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetShapePathStyle ( _
    obj As DependencyObject _
) As Style

Parameters

obj
Type: System.Windows..::.DependencyObject
The DiagramNodeTool or container from which the property value is read.

Return Value

The value of the ShapePathStyle attached property on the specified DependencyObject.

Remarks

ShapePathStyle is inherited and may therefore be applied at the DiagramToolBox level instead of to individual DiagramNodeTool objects.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


SetShape Method

[image]

Mindscape WPF Diagrams
ShapeTool..::.SetShape Method
ShapeTool Class See Also Send Feedback
Sets the DiagramShape for this DiagramNodeTool.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetShape(
    DiagramNodeTool obj,
    DiagramShape value
)
Visual Basic (Declaration)
Public Shared Sub SetShape ( _
    obj As DiagramNodeTool, _
    value As DiagramShape _
)

Parameters

obj
Type: Mindscape.WpfDiagramming..::.DiagramNodeTool
The element to which the property value is written.
value
Type: Mindscape.WpfDiagramming..::.DiagramShape
The DiagramShape of the specified DiagramNodeTool.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


SetShapePathStyle Method

[image]

Mindscape WPF Diagrams
ShapeTool..::.SetShapePathStyle Method
ShapeTool Class See Also Send Feedback
Sets the Style to be applied to the Path part of a ShapeNode created from the DiagramNodeTool that the ShapePathStyle property is attached to.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetShapePathStyle(
    DependencyObject obj,
    Style value
)
Visual Basic (Declaration)
Public Shared Sub SetShapePathStyle ( _
    obj As DependencyObject, _
    value As Style _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The DiagramNodeTool or container to which the property value is written.
value
Type: System.Windows..::.Style
The value of the ShapePathStyle attached property on the specified DependencyObject.

Remarks

ShapePathStyle is inherited and may therefore be applied at the DiagramToolBox level instead of to individual DiagramNodeTool objects.

See Also

ShapeTool Class
Mindscape.WpfDiagramming Namespace


TitleNode Class

[image]

Mindscape WPF Diagrams
TitleNode Class
Members See Also Send Feedback
Displays a title on the diagram, with optional pre-title and subtitle text.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class TitleNode : DiagramNode
Visual Basic (Declaration)
Public Class TitleNode _
    Inherits DiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming..::.TitleNode

See Also

TitleNode Members
Mindscape.WpfDiagramming Namespace


TitleNode Members

[image] [image]

Mindscape WPF Diagrams
TitleNode Members
TitleNode Class Constructors Methods Fields Properties Events See Also Send Feedback

The TitleNode type exposes the following members.

Constructors

Name | Description
TitleNode |

Methods

Name | Description
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

Fields

Name | Description
DefaultBuilder | Gets an IDiagramNodeBuilder that a toolbox item can use to construct TitleNode objects.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false. A TitleNode can not originate any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. A TitleNode can not receive any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PreTitle | Gets or sets text to appear above the title.
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Subtitle | Gets or sets text to appear below the title.
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


TitleNode Constructor

[image]

Mindscape WPF Diagrams
TitleNode Constructor
TitleNode Class See Also Send Feedback
Initializes a new instance of the TitleNode class.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TitleNode()
Visual Basic (Declaration)
Public Sub New

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


TitleNode Fields

[image] [image]

Mindscape WPF Diagrams
TitleNode Fields
TitleNode Class See Also Send Feedback

The TitleNode type exposes the following members.

Fields

Name | Description
DefaultBuilder | Gets an IDiagramNodeBuilder that a toolbox item can use to construct TitleNode objects.

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


DefaultBuilder Field

[image]

Mindscape WPF Diagrams
TitleNode..::.DefaultBuilder Field
TitleNode Class See Also Send Feedback
Gets an IDiagramNodeBuilder that a toolbox item can use to construct TitleNode objects.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly IDiagramNodeBuilder DefaultBuilder
Visual Basic (Declaration)
Public Shared ReadOnly DefaultBuilder As IDiagramNodeBuilder

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


TitleNode Methods

[image] [image]

Mindscape WPF Diagrams
TitleNode Methods
TitleNode Class See Also Send Feedback

The TitleNode type exposes the following members.

Methods

Name | Description
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


Clone Method

[image]

Mindscape WPF Diagrams
TitleNode..::.Clone Method
TitleNode Class See Also Send Feedback
Gets an IDiagramNodeState that represents the current state of this node at the time this method is called.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IDiagramNodeState Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As IDiagramNodeState

Return Value

An IDiagramNodeState that represents the current state of this node.

Implements

IDiagramNode..::.Clone()()()

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


SetAs Method

[image]

Mindscape WPF Diagrams
TitleNode..::.SetAs Method
TitleNode Class See Also Send Feedback
Sets all the properties of this node to match those of the given IDiagramNodeState.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void SetAs(
    IDiagramNodeState state
)
Visual Basic (Declaration)
Public Overrides Sub SetAs ( _
    state As IDiagramNodeState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNodeState
The IDiagramNodeState that will have its property values applied to this node.

Implements

IDiagramNode..::.SetAs(IDiagramNodeState)

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


TitleNode Properties

[image] [image]

Mindscape WPF Diagrams
TitleNode Properties
TitleNode Class See Also Send Feedback

The TitleNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false. A TitleNode can not originate any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. A TitleNode can not receive any connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PreTitle | Gets or sets text to appear above the title.
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Subtitle | Gets or sets text to appear below the title.
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
TitleNode..::.CanOriginateNewConnections Property
TitleNode Class See Also Send Feedback
Returns false. A TitleNode can not originate any connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
TitleNode..::.CanReceiveNewConnections Property
TitleNode Class See Also Send Feedback
Returns false. A TitleNode can not receive any connections.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


PreTitle Property

[image]

Mindscape WPF Diagrams
TitleNode..::.PreTitle Property
TitleNode Class See Also Send Feedback
Gets or sets text to appear above the title.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string PreTitle { get; set; }
Visual Basic (Declaration)
Public Property PreTitle As String

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


Subtitle Property

[image]

Mindscape WPF Diagrams
TitleNode..::.Subtitle Property
TitleNode Class See Also Send Feedback
Gets or sets text to appear below the title.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Subtitle { get; set; }
Visual Basic (Declaration)
Public Property Subtitle As String

See Also

TitleNode Class
Mindscape.WpfDiagramming Namespace


ToolboxIconStyle Enumeration

[image]

Mindscape WPF Diagrams
ToolboxIconStyle Enumeration
See Also Send Feedback
When applied to a Path in ToolboxIconPaths, specifies how the path should be styled if no explicit style is specified.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ToolboxIconStyle
Visual Basic (Declaration)
Public Enumeration ToolboxIconStyle

Members

Member name | Description
Line | The Path represents a line part of the toolbox icon.
Arrow | The Path represents an arrow part of the toolbox icon.

See Also

Mindscape.WpfDiagramming Namespace


ZoomMode Enumeration

[image]

Mindscape WPF Diagrams
ZoomMode Enumeration
See Also Send Feedback
Specifies the zooming behavior of a DiagramSurface.

Namespace: Mindscape.WpfDiagramming
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode

Members

Member name | Description
Manual | No built-in zooming gesture. Applications can zoom by setting the Zoom property.
MouseWheel | The user can zoom the diagram using the mouse wheel.
ControlMouseWheel | The user can zoom the diagram by holding down the Control key and using the mouse wheel.
SizeToFit | The diagram is zoomed to fit the available space. The Zoom value is ignored.

See Also

Mindscape.WpfDiagramming Namespace


Mindscape.WpfDiagramming.FlowDiagrams Namespace

[image]

Mindscape WPF Diagrams
Mindscape.WpfDiagramming.FlowDiagrams Namespace
Send Feedback
Contains classes for displaying and editing flow diagrams.

Classes

Class | Description
CommentFlowDiagramNodeBuilder | A type of IDiagramNodeBuilder for building CommentNode objects.
DecisionFlowDiagramNodeBuilder | A type of IDiagramNodeBuilder for building DecisionNode objects.
DecisionNode | A DiagramNode representing a decision in a FlowDiagramModel.
EndFlowDiagramNodeBuilder | A type of IDiagramNodeBuilder for building EndNode objects.
EndNode | A DiagramNode representing the end of a FlowDiagramModel.
FlowDiagramConnection | Represents a connection in a FlowDiagramModel.
FlowDiagramConnectionBuilder | A type of IDiagramConnectionBuilder that can build FlowDiagramConnection objects between two FlowDiagramConnectionPoint objects and add them to a FlowDiagramModel.
FlowDiagramConnectionPoint | Represents a point on a DiagramNode where a FlowDiagramConnection can connect.
FlowDiagramLayoutAlgorithmInfo | An ILayoutAlgorithmInfo implementation containing Flow Diagram specific layout logic.
FlowDiagramModel | Represents a flow diagram.
FlowDiagramXmlSerializer | Serializes and deserializes FlowDiagramModel objects as XML.
StandardFlowDiagramToolBoxItems | Provides standard toolbox item resources.
StartFlowDiagramNodeBuilder | A type of IDiagramNodeBuilder for building StartNode objects.
StartNode | A DiagramNode representing the start node of a FlowDiagramModel.
StepFlowDiagramNodeBuilder | A type of IDiagramNodeBuilder for building StepNode objects.
StepNode | A DiagramNode representing a step in a FlowDiagramModel. A StepNode can have any number if incomming connections but only allows for a single outbound connection.
StepNodeTool | Provides attached properties which configure a DiagramNodeTool to create StepNode objects with a specified DiagramShape.
TitleFlowDiagramNodeBuilder | A type of IDiagramNodeBuilder for building TitleNode objects.


CommentFlowDiagramNodeBuilder Class

[image]

Mindscape WPF Diagrams
CommentFlowDiagramNodeBuilder Class
Members See Also Send Feedback
A type of IDiagramNodeBuilder for building CommentNode objects.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class CommentFlowDiagramNodeBuilder : IDiagramNodeBuilder
Visual Basic (Declaration)
Public Class CommentFlowDiagramNodeBuilder _
    Implements IDiagramNodeBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.CommentFlowDiagramNodeBuilder

See Also

CommentFlowDiagramNodeBuilder Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CommentFlowDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
CommentFlowDiagramNodeBuilder Members
CommentFlowDiagramNodeBuilder Class Constructors Methods Properties See Also Send Feedback

The CommentFlowDiagramNodeBuilder type exposes the following members.

Constructors

Name | Description
CommentFlowDiagramNodeBuilder |

Methods

Name | Description
CreateNode | Builds a new CommentNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Properties

Name | Description
DefaultSize | Returns the default size of a CommentNode. This CommentFlowDiagramNodeBuilder considers the default size of a CommentNode to be 200x40.

See Also

CommentFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CommentFlowDiagramNodeBuilder Constructor

[image]

Mindscape WPF Diagrams
CommentFlowDiagramNodeBuilder Constructor
CommentFlowDiagramNodeBuilder Class See Also Send Feedback
Initializes a new instance of the CommentFlowDiagramNodeBuilder class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CommentFlowDiagramNodeBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

CommentFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CommentFlowDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
CommentFlowDiagramNodeBuilder Methods
CommentFlowDiagramNodeBuilder Class See Also Send Feedback

The CommentFlowDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Builds a new CommentNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

See Also

CommentFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
CommentFlowDiagramNodeBuilder..::.CreateNode Method
CommentFlowDiagramNodeBuilder Class See Also Send Feedback
Builds a new CommentNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the new CommentNode is added to.
bounds
Type: System.Windows..::.Rect
The position and dimensions of the newly created CommentNode.

See Also

CommentFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CommentFlowDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
CommentFlowDiagramNodeBuilder Properties
CommentFlowDiagramNodeBuilder Class See Also Send Feedback

The CommentFlowDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Returns the default size of a CommentNode. This CommentFlowDiagramNodeBuilder considers the default size of a CommentNode to be 200x40.

See Also

CommentFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
CommentFlowDiagramNodeBuilder..::.DefaultSize Property
CommentFlowDiagramNodeBuilder Class See Also Send Feedback
Returns the default size of a CommentNode. This CommentFlowDiagramNodeBuilder considers the default size of a CommentNode to be 200x40.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSize As Size

See Also

CommentFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionFlowDiagramNodeBuilder Class

[image]

Mindscape WPF Diagrams
DecisionFlowDiagramNodeBuilder Class
Members See Also Send Feedback
A type of IDiagramNodeBuilder for building DecisionNode objects.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DecisionFlowDiagramNodeBuilder : IDiagramNodeBuilder
Visual Basic (Declaration)
Public Class DecisionFlowDiagramNodeBuilder _
    Implements IDiagramNodeBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.DecisionFlowDiagramNodeBuilder

See Also

DecisionFlowDiagramNodeBuilder Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionFlowDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
DecisionFlowDiagramNodeBuilder Members
DecisionFlowDiagramNodeBuilder Class Constructors Methods Properties See Also Send Feedback

The DecisionFlowDiagramNodeBuilder type exposes the following members.

Constructors

Name | Description
DecisionFlowDiagramNodeBuilder |

Methods

Name | Description
CreateNode | Builds a new DecisionNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Properties

Name | Description
DefaultSize | Gets the default size of a DecisionNode. This DecisionFlowDiagramNodeBuilder considers the default size to be 120x80.

See Also

DecisionFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionFlowDiagramNodeBuilder Constructor

[image]

Mindscape WPF Diagrams
DecisionFlowDiagramNodeBuilder Constructor
DecisionFlowDiagramNodeBuilder Class See Also Send Feedback
Initializes a new instance of the DecisionFlowDiagramNodeBuilder class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DecisionFlowDiagramNodeBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

DecisionFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionFlowDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
DecisionFlowDiagramNodeBuilder Methods
DecisionFlowDiagramNodeBuilder Class See Also Send Feedback

The DecisionFlowDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Builds a new DecisionNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

See Also

DecisionFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
DecisionFlowDiagramNodeBuilder..::.CreateNode Method
DecisionFlowDiagramNodeBuilder Class See Also Send Feedback
Builds a new DecisionNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the new DecisionNode is added to.
bounds
Type: System.Windows..::.Rect
The position and dimensions of the newly created DecisionNode.

See Also

DecisionFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionFlowDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
DecisionFlowDiagramNodeBuilder Properties
DecisionFlowDiagramNodeBuilder Class See Also Send Feedback

The DecisionFlowDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Gets the default size of a DecisionNode. This DecisionFlowDiagramNodeBuilder considers the default size to be 120x80.

See Also

DecisionFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
DecisionFlowDiagramNodeBuilder..::.DefaultSize Property
DecisionFlowDiagramNodeBuilder Class See Also Send Feedback
Gets the default size of a DecisionNode. This DecisionFlowDiagramNodeBuilder considers the default size to be 120x80.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSize As Size

See Also

DecisionFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionNode Class

[image]

Mindscape WPF Diagrams
DecisionNode Class
Members See Also Send Feedback
A DiagramNode representing a decision in a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DecisionNode : DiagramNode
Visual Basic (Declaration)
Public Class DecisionNode _
    Inherits DiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming.FlowDiagrams..::.DecisionNode

See Also

DecisionNode Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionNode Members

[image] [image]

Mindscape WPF Diagrams
DecisionNode Members
DecisionNode Class Constructors Methods Properties Events See Also Send Feedback

The DecisionNode type exposes the following members.

Constructors

Name | Description
DecisionNode | Initializes a new instance of the DecisionNode class.

Methods

Name | Description
Clone | Returns an IDiagramNodeState that represents the current state of this DiagramNodeBase at the time this method is called. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this DiagramNodeBase to match those of the given IDiagramNodeState. This method can be overriden to include the setting of other properties introduced by sub classes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns true if there are at least two outbound connection points available. Returns false if there is only one available. This ensures that one side of this DecisionNode is available for a connection to enter this node. That is, a DescisionNode can not be fully taken up by outgoing connections, it must have at least one connection leading into it or the flow chart diagram wouldn't be 'valid'. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns true. DecisionNode objects can accept any number of incomming connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

DecisionNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionNode Constructor

[image]

Mindscape WPF Diagrams
DecisionNode Constructor
DecisionNode Class See Also Send Feedback
Initializes a new instance of the DecisionNode class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DecisionNode()
Visual Basic (Declaration)
Public Sub New

See Also

DecisionNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionNode Properties

[image] [image]

Mindscape WPF Diagrams
DecisionNode Properties
DecisionNode Class See Also Send Feedback

The DecisionNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns true if there are at least two outbound connection points available. Returns false if there is only one available. This ensures that one side of this DecisionNode is available for a connection to enter this node. That is, a DescisionNode can not be fully taken up by outgoing connections, it must have at least one connection leading into it or the flow chart diagram wouldn't be 'valid'. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns true. DecisionNode objects can accept any number of incomming connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

DecisionNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
DecisionNode..::.CanOriginateNewConnections Property
DecisionNode Class See Also Send Feedback
Returns true if there are at least two outbound connection points available. Returns false if there is only one available. This ensures that one side of this DecisionNode is available for a connection to enter this node. That is, a DescisionNode can not be fully taken up by outgoing connections, it must have at least one connection leading into it or the flow chart diagram wouldn't be 'valid'.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

DecisionNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
DecisionNode..::.CanReceiveNewConnections Property
DecisionNode Class See Also Send Feedback
Returns true. DecisionNode objects can accept any number of incomming connections.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

DecisionNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndFlowDiagramNodeBuilder Class

[image]

Mindscape WPF Diagrams
EndFlowDiagramNodeBuilder Class
Members See Also Send Feedback
A type of IDiagramNodeBuilder for building EndNode objects.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class EndFlowDiagramNodeBuilder : IDiagramNodeBuilder
Visual Basic (Declaration)
Public Class EndFlowDiagramNodeBuilder _
    Implements IDiagramNodeBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.EndFlowDiagramNodeBuilder

See Also

EndFlowDiagramNodeBuilder Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndFlowDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
EndFlowDiagramNodeBuilder Members
EndFlowDiagramNodeBuilder Class Constructors Methods Properties See Also Send Feedback

The EndFlowDiagramNodeBuilder type exposes the following members.

Constructors

Name | Description
EndFlowDiagramNodeBuilder |

Methods

Name | Description
CreateNode | Builds a new EndNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Properties

Name | Description
DefaultSize | Gets the default size of a EndNode. This EndFlowDiagramNodeBuilder considers the default size of a EndNode to be 100x40.

See Also

EndFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndFlowDiagramNodeBuilder Constructor

[image]

Mindscape WPF Diagrams
EndFlowDiagramNodeBuilder Constructor
EndFlowDiagramNodeBuilder Class See Also Send Feedback
Initializes a new instance of the EndFlowDiagramNodeBuilder class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public EndFlowDiagramNodeBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

EndFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndFlowDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
EndFlowDiagramNodeBuilder Methods
EndFlowDiagramNodeBuilder Class See Also Send Feedback

The EndFlowDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Builds a new EndNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

See Also

EndFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
EndFlowDiagramNodeBuilder..::.CreateNode Method
EndFlowDiagramNodeBuilder Class See Also Send Feedback
Builds a new EndNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the newly created EndNode is added to.
bounds
Type: System.Windows..::.Rect
The position and dimensions of the newly created EndNode.

See Also

EndFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndFlowDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
EndFlowDiagramNodeBuilder Properties
EndFlowDiagramNodeBuilder Class See Also Send Feedback

The EndFlowDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Gets the default size of a EndNode. This EndFlowDiagramNodeBuilder considers the default size of a EndNode to be 100x40.

See Also

EndFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
EndFlowDiagramNodeBuilder..::.DefaultSize Property
EndFlowDiagramNodeBuilder Class See Also Send Feedback
Gets the default size of a EndNode. This EndFlowDiagramNodeBuilder considers the default size of a EndNode to be 100x40.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSize As Size

See Also

EndFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndNode Class

[image]

Mindscape WPF Diagrams
EndNode Class
Members See Also Send Feedback
A DiagramNode representing the end of a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class EndNode : DiagramNode
Visual Basic (Declaration)
Public Class EndNode _
    Inherits DiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming.FlowDiagrams..::.EndNode

See Also

EndNode Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndNode Members

[image] [image]

Mindscape WPF Diagrams
EndNode Members
EndNode Class Constructors Methods Properties Events See Also Send Feedback

The EndNode type exposes the following members.

Constructors

Name | Description
EndNode | Initializes a new instance of the EndNode class.

Methods

Name | Description
Clone | Returns an IDiagramNodeState that represents the current state of this DiagramNodeBase at the time this method is called. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this DiagramNodeBase to match those of the given IDiagramNodeState. This method can be overriden to include the setting of other properties introduced by sub classes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false. EndNode objects can never originate new connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns true. EndNode objects can accept any number of incomming connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

EndNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndNode Constructor

[image]

Mindscape WPF Diagrams
EndNode Constructor
EndNode Class See Also Send Feedback
Initializes a new instance of the EndNode class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public EndNode()
Visual Basic (Declaration)
Public Sub New

See Also

EndNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndNode Properties

[image] [image]

Mindscape WPF Diagrams
EndNode Properties
EndNode Class See Also Send Feedback

The EndNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false. EndNode objects can never originate new connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns true. EndNode objects can accept any number of incomming connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

EndNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
EndNode..::.CanOriginateNewConnections Property
EndNode Class See Also Send Feedback
Returns false. EndNode objects can never originate new connections.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

EndNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
EndNode..::.CanReceiveNewConnections Property
EndNode Class See Also Send Feedback
Returns true. EndNode objects can accept any number of incomming connections.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

EndNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnection Class

[image]

Mindscape WPF Diagrams
FlowDiagramConnection Class
Members See Also Send Feedback
Represents a connection in a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FlowDiagramConnection : DiagramConnection
Visual Basic (Declaration)
Public Class FlowDiagramConnection _
    Inherits DiagramConnection

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramConnection
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramConnection

See Also

FlowDiagramConnection Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnection Members

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnection Members
FlowDiagramConnection Class Constructors Methods Properties Events See Also Send Feedback

The FlowDiagramConnection type exposes the following members.

Constructors

Name | Description
FlowDiagramConnection | Overloaded.

Methods

Name | Description
AddConnectionPoint | Adds a new mounted connection point to this connection. (Inherited from DiagramConnection.)
ApplyPathfinding | Re-routes this connection using its pathfinder. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Clone | Gets the state of the connection for undo purposes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can be the source of a new outgoing connection. For FlowDiagramConnection objects, this will be false. (Overrides DiagramConnection ..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether the connection can be the destination of a new incoming connection. Always returns true. (Inherited from DiagramConnection.)
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
LineType | Gets or sets the DiagramLineType used to draw the connection. (Inherited from DiagramConnection.)
Pathfinder | Gets the routing algorithm for the connection. (Inherited from DiagramConnection.)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Events

Name | Description
DataChanged | Raised when the Data property changes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

FlowDiagramConnection Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnection Constructor

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnection Constructor
FlowDiagramConnection Class See Also Send Feedback

Overload List

Name | Description
FlowDiagramConnection(DiagramConnectionPoint, DiagramConnectionPoint) | Initializes a new instance of the FlowDiagramConnection class.
FlowDiagramConnection(DiagramConnectionPoint, DiagramConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>)) | Initializes a new instance of the FlowDiagramConnection class.

See Also

FlowDiagramConnection Class
FlowDiagramConnection Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint)

[image]

Mindscape WPF Diagrams
FlowDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint)
FlowDiagramConnection Class See Also Send Feedback
Initializes a new instance of the FlowDiagramConnection class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramConnection(
    DiagramConnectionPoint fromConnectionPoint,
    DiagramConnectionPoint toConnectionPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As DiagramConnectionPoint, _
    toConnectionPoint As DiagramConnectionPoint _
)

Parameters

fromConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The source of the connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The destination of the connection.

See Also

FlowDiagramConnection Class
FlowDiagramConnection Overload
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint, IList(DiagramConnectionSegment))

[image]

Mindscape WPF Diagrams
FlowDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>))
FlowDiagramConnection Class See Also Send Feedback
Initializes a new instance of the FlowDiagramConnection class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramConnection(
    DiagramConnectionPoint fromConnectionPoint,
    DiagramConnectionPoint toConnectionPoint,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As DiagramConnectionPoint, _
    toConnectionPoint As DiagramConnectionPoint, _
    segments As IList(Of DiagramConnectionSegment) _
)

Parameters

fromConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The source of the connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The destination of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects within this FlowDiagramConnection.

See Also

FlowDiagramConnection Class
FlowDiagramConnection Overload
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnection Properties

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnection Properties
FlowDiagramConnection Class See Also Send Feedback

The FlowDiagramConnection type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can be the source of a new outgoing connection. For FlowDiagramConnection objects, this will be false. (Overrides DiagramConnection ..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether the connection can be the destination of a new incoming connection. Always returns true. (Inherited from DiagramConnection.)
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
LineType | Gets or sets the DiagramLineType used to draw the connection. (Inherited from DiagramConnection.)
Pathfinder | Gets the routing algorithm for the connection. (Inherited from DiagramConnection.)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

See Also

FlowDiagramConnection Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
FlowDiagramConnection..::.CanOriginateNewConnections Property
FlowDiagramConnection Class See Also Send Feedback
Gets whether the connection can be the source of a new outgoing connection. For FlowDiagramConnection objects, this will be false.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

FlowDiagramConnection Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionBuilder Class

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionBuilder Class
Members See Also Send Feedback
A type of IDiagramConnectionBuilder that can build FlowDiagramConnection objects between two FlowDiagramConnectionPoint objects and add them to a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FlowDiagramConnectionBuilder : IDiagramConnectionBuilder
Visual Basic (Declaration)
Public Class FlowDiagramConnectionBuilder _
    Implements IDiagramConnectionBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramConnectionBuilder

See Also

FlowDiagramConnectionBuilder Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionBuilder Members

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnectionBuilder Members
FlowDiagramConnectionBuilder Class Constructors Methods See Also Send Feedback

The FlowDiagramConnectionBuilder type exposes the following members.

Constructors

Name | Description
FlowDiagramConnectionBuilder |

Methods

Name | Description
CanCreateConnection | This method can be overriden to provide additional logic for allowing a connection to be made between the given connection point and destination. This implementation always returns true.
CreateConnection | Constructs a new FlowDiagramConnection between the two given FlowDiagramConnectionPoint objects and adds it to the given FlowDiagramModel. If the new connection is originating from a DecisionNode, then this method will also set its Data property by looking at the other connections comming from the node and predicting what the label should be. This method can identify and predict (Yes, No, Maybe), (Y, N), (True, False), and (T, F) in both upper and lower case. If no appropriate label can be predicted, then the Data will be set to be a number following the text "Decision".

See Also

FlowDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionBuilder Constructor

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionBuilder Constructor
FlowDiagramConnectionBuilder Class See Also Send Feedback
Initializes a new instance of the FlowDiagramConnectionBuilder class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramConnectionBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

FlowDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionBuilder Methods

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnectionBuilder Methods
FlowDiagramConnectionBuilder Class See Also Send Feedback

The FlowDiagramConnectionBuilder type exposes the following members.

Methods

Name | Description
CanCreateConnection | This method can be overriden to provide additional logic for allowing a connection to be made between the given connection point and destination. This implementation always returns true.
CreateConnection | Constructs a new FlowDiagramConnection between the two given FlowDiagramConnectionPoint objects and adds it to the given FlowDiagramModel. If the new connection is originating from a DecisionNode, then this method will also set its Data property by looking at the other connections comming from the node and predicting what the label should be. This method can identify and predict (Yes, No, Maybe), (Y, N), (True, False), and (T, F) in both upper and lower case. If no appropriate label can be predicted, then the Data will be set to be a number following the text "Decision".

See Also

FlowDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanCreateConnection Method

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionBuilder..::.CanCreateConnection Method
FlowDiagramConnectionBuilder Class See Also Send Feedback
This method can be overriden to provide additional logic for allowing a connection to be made between the given connection point and destination. This implementation always returns true.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanCreateConnection(
    IDiagramModel diagram,
    IDiagramConnectionPoint fromConnectionPoint,
    ConnectionDropTarget dropTarget
)
Visual Basic (Declaration)
Public Overridable Function CanCreateConnection ( _
    diagram As IDiagramModel, _
    fromConnectionPoint As IDiagramConnectionPoint, _
    dropTarget As ConnectionDropTarget _
) As Boolean

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the connection will belong to.
fromConnectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that represents the start of the connection.
dropTarget
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionDropTarget
Information about the potential destination of the connection.

Return Value

Whether or not a connection can be made.

Implements

IDiagramConnectionBuilder..::.CanCreateConnection(IDiagramModel, IDiagramConnectionPoint, ConnectionDropTarget)

See Also

FlowDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateConnection Method

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionBuilder..::.CreateConnection Method
FlowDiagramConnectionBuilder Class See Also Send Feedback
Constructs a new FlowDiagramConnection between the two given FlowDiagramConnectionPoint objects and adds it to the given FlowDiagramModel. If the new connection is originating from a DecisionNode, then this method will also set its Data property by looking at the other connections comming from the node and predicting what the label should be. This method can identify and predict (Yes, No, Maybe), (Y, N), (True, False), and (T, F) in both upper and lower case. If no appropriate label can be predicted, then the Data will be set to be a number following the text "Decision".

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateConnection(
    IDiagramModel diagram,
    IDiagramConnectionPoint fromConnectionPoint,
    IDiagramConnectionPoint toConnectionPoint
)
Visual Basic (Declaration)
Public Sub CreateConnection ( _
    diagram As IDiagramModel, _
    fromConnectionPoint As IDiagramConnectionPoint, _
    toConnectionPoint As IDiagramConnectionPoint _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The FlowDiagramModel that the new FlowDiagramConnection will be added to.
fromConnectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that is to be the start of the created connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that is to be the end of the created connection.

Implements

IDiagramConnectionBuilder..::.CreateConnection(IDiagramModel, IDiagramConnectionPoint, IDiagramConnectionPoint)

See Also

FlowDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionPoint Class

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint Class
Members See Also Send Feedback
Represents a point on a DiagramNode where a FlowDiagramConnection can connect.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FlowDiagramConnectionPoint : DiagramConnectionPoint
Visual Basic (Declaration)
Public Class FlowDiagramConnectionPoint _
    Inherits DiagramConnectionPoint

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionPointBase <(Of <( DiagramConnection >)>)
Mindscape.WpfDiagramming..::.DiagramConnectionPoint
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramConnectionPoint

See Also

FlowDiagramConnectionPoint Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionPoint Members

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint Members
FlowDiagramConnectionPoint Class Constructors Methods Properties Events See Also Send Feedback

The FlowDiagramConnectionPoint type exposes the following members.

Constructors

Name | Description
FlowDiagramConnectionPoint | Overloaded.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this DiagramConnectionPoint. (Inherited from DiagramConnectionPoint.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
RemoveConnection | Removes the given IDiagramConnection from this DiagramConnectionPoint. (Inherited from DiagramConnectionPoint.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetPosition | Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

Properties

Name | Description
CanOriginateNewConnections | Gets whether this FlowDiagramConnectionPoint can originate new connections. This will be true if this connection point currently has no connections attached to it, and the diagram node can also originate new connections. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether this FlowDiagramConnectionPoint can recieve new connections. This will be true if this connection point does not currently have any outbound connections. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. CanReceiveNewConnections.)
Connectable | Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connections | Gets the connections attached to this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Data | Gets or sets the data object held by this connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Edge | Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
FlowDirection | Gets whether the connection point supports inbound connections, outbound connections or both. (Inherited from DiagramConnectionPoint.)
Index | Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Position | Gets or sets the position of the connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionCalculator | Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

Events

Name | Description
IndexChanged | Raised when the Index property value changes. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionChanged | Raised when the Position property value changes. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

FlowDiagramConnectionPoint Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionPoint Constructor

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint Constructor
FlowDiagramConnectionPoint Class See Also Send Feedback

Overload List

Name | Description
FlowDiagramConnectionPoint(IDiagramConnectable, Edge) | Initializes a new instance of the FlowDiagramConnectionPoint class.
FlowDiagramConnectionPoint(IDiagramConnectable, Edge, ConnectionPointDirection) | Initializes a new instance of the FlowDiagramConnectionPoint class.
FlowDiagramConnectionPoint(IDiagramConnectable, Edge, Int32) | Initializes a new instance of the FlowDiagramConnectionPoint class.

See Also

FlowDiagramConnectionPoint Class
FlowDiagramConnectionPoint Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionPoint Constructor (IDiagramConnectable, Edge)

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint Constructor (IDiagramConnectable, Edge)
FlowDiagramConnectionPoint Class See Also Send Feedback
Initializes a new instance of the FlowDiagramConnectionPoint class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramConnectionPoint(
    IDiagramConnectable connectable,
    Edge edge
)
Visual Basic (Declaration)
Public Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The connectable object (node or connection) on which the connection point is situated.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge of the connectable that this point is situated on.

See Also

FlowDiagramConnectionPoint Class
FlowDiagramConnectionPoint Overload
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionPoint Constructor (IDiagramConnectable, Edge, ConnectionPointDirection)

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint Constructor (IDiagramConnectable, Edge, ConnectionPointDirection)
FlowDiagramConnectionPoint Class See Also Send Feedback
Initializes a new instance of the FlowDiagramConnectionPoint class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramConnectionPoint(
    IDiagramConnectable connectable,
    Edge edge,
    ConnectionPointDirection flowDirection
)
Visual Basic (Declaration)
Public Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge, _
    flowDirection As ConnectionPointDirection _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The connectable object (node or connection) on which the connection point is situated.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge of the connectable that this point is situated on.
flowDirection
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionPointDirection
Specifies whether the connection point supports inbound connections, outbound connections or both.

See Also

FlowDiagramConnectionPoint Class
FlowDiagramConnectionPoint Overload
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionPoint Constructor (IDiagramConnectable, Edge, Int32)

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint Constructor (IDiagramConnectable, Edge, Int32)
FlowDiagramConnectionPoint Class See Also Send Feedback
Initializes a new instance of the FlowDiagramConnectionPoint class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramConnectionPoint(
    IDiagramConnectable connectable,
    Edge edge,
    int index
)
Visual Basic (Declaration)
Public Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge, _
    index As Integer _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The connectable object (node or connection) on which the connection point is situated.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge of the connectable that this point is situated on.
index
Type: System..::.Int32
The index identifier for this connection point.

See Also

FlowDiagramConnectionPoint Class
FlowDiagramConnectionPoint Overload
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramConnectionPoint Properties

[image] [image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint Properties
FlowDiagramConnectionPoint Class See Also Send Feedback

The FlowDiagramConnectionPoint type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether this FlowDiagramConnectionPoint can originate new connections. This will be true if this connection point currently has no connections attached to it, and the diagram node can also originate new connections. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether this FlowDiagramConnectionPoint can recieve new connections. This will be true if this connection point does not currently have any outbound connections. (Overrides DiagramConnectionPointBase <(Of <( DiagramConnection >)>)..::. CanReceiveNewConnections.)
Connectable | Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connections | Gets the connections attached to this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Data | Gets or sets the data object held by this connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Edge | Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
FlowDirection | Gets whether the connection point supports inbound connections, outbound connections or both. (Inherited from DiagramConnectionPoint.)
Index | Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Position | Gets or sets the position of the connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionCalculator | Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

See Also

FlowDiagramConnectionPoint Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint..::.CanOriginateNewConnections Property
FlowDiagramConnectionPoint Class See Also Send Feedback
Gets whether this FlowDiagramConnectionPoint can originate new connections. This will be true if this connection point currently has no connections attached to it, and the diagram node can also originate new connections.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectionPoint..::.CanOriginateNewConnections

See Also

FlowDiagramConnectionPoint Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
FlowDiagramConnectionPoint..::.CanReceiveNewConnections Property
FlowDiagramConnectionPoint Class See Also Send Feedback
Gets whether this FlowDiagramConnectionPoint can recieve new connections. This will be true if this connection point does not currently have any outbound connections.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectionPoint..::.CanReceiveNewConnections

See Also

FlowDiagramConnectionPoint Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramLayoutAlgorithmInfo Class

[image]

Mindscape WPF Diagrams
FlowDiagramLayoutAlgorithmInfo Class
Members See Also Send Feedback
An ILayoutAlgorithmInfo implementation containing Flow Diagram specific layout logic.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FlowDiagramLayoutAlgorithmInfo : ILayoutAlgorithmInfo
Visual Basic (Declaration)
Public Class FlowDiagramLayoutAlgorithmInfo _
    Implements ILayoutAlgorithmInfo

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramLayoutAlgorithmInfo

See Also

FlowDiagramLayoutAlgorithmInfo Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramLayoutAlgorithmInfo Members

[image] [image]

Mindscape WPF Diagrams
FlowDiagramLayoutAlgorithmInfo Members
FlowDiagramLayoutAlgorithmInfo Class Constructors Methods See Also Send Feedback

The FlowDiagramLayoutAlgorithmInfo type exposes the following members.

Constructors

Name | Description
FlowDiagramLayoutAlgorithmInfo |

Methods

Name | Description
IsIncluded | Returns false if the given node is either a CommentNode or a TitleNode.

See Also

FlowDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramLayoutAlgorithmInfo Constructor

[image]

Mindscape WPF Diagrams
FlowDiagramLayoutAlgorithmInfo Constructor
FlowDiagramLayoutAlgorithmInfo Class See Also Send Feedback
Initializes a new instance of the FlowDiagramLayoutAlgorithmInfo class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramLayoutAlgorithmInfo()
Visual Basic (Declaration)
Public Sub New

See Also

FlowDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramLayoutAlgorithmInfo Methods

[image] [image]

Mindscape WPF Diagrams
FlowDiagramLayoutAlgorithmInfo Methods
FlowDiagramLayoutAlgorithmInfo Class See Also Send Feedback

The FlowDiagramLayoutAlgorithmInfo type exposes the following members.

Methods

Name | Description
IsIncluded | Returns false if the given node is either a CommentNode or a TitleNode.

See Also

FlowDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


IsIncluded Method

[image]

Mindscape WPF Diagrams
FlowDiagramLayoutAlgorithmInfo..::.IsIncluded Method
FlowDiagramLayoutAlgorithmInfo Class See Also Send Feedback
Returns false if the given node is either a CommentNode or a TitleNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsIncluded(
    IDiagramNode node
)
Visual Basic (Declaration)
Public Function IsIncluded ( _
    node As IDiagramNode _
) As Boolean

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The IDiagramNode to test.

Return Value

True if the given node can be affected by the layout algorithm. False otherwise.

Implements

ILayoutAlgorithmInfo..::.IsIncluded(IDiagramNode)

See Also

FlowDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramModel Class

[image]

Mindscape WPF Diagrams
FlowDiagramModel Class
Members See Also Send Feedback
Represents a flow diagram.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FlowDiagramModel : Diagram
Visual Basic (Declaration)
Public Class FlowDiagramModel _
    Inherits Diagram

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DiagramModelBase <(Of <( DiagramNode, DiagramConnection >)>)
Mindscape.WpfDiagramming..::.Diagram
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramModel

See Also

FlowDiagramModel Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramModel Members

[image] [image]

Mindscape WPF Diagrams
FlowDiagramModel Members
FlowDiagramModel Class Constructors Properties See Also Send Feedback

The FlowDiagramModel type exposes the following members.

Constructors

Name | Description
FlowDiagramModel | Initializes a new instance of the FlowDiagramModel class.

Properties

Name | Description
ConnectionRelocator | Gets or sets the IDiagramConnectionRelocator for relocating connections in the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
ConnectionRemover | Gets or sets the IDiagramConnectionRemover for removing connections from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Connections | Gets the connections of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
CustomItems | Gets null. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
DefaultConnectionBuilder | Gets or sets the default IDiagramConnectionBuilder for building diagram connections. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
NodeRemover | Gets or sets the IDiagramNodeRemover for removing nodes from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Nodes | Gets the nodes of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Source | Gets the business object represented by the diagram. For the Diagram class this is always null. (Inherited from Diagram.)

See Also

FlowDiagramModel Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramModel Constructor

[image]

Mindscape WPF Diagrams
FlowDiagramModel Constructor
FlowDiagramModel Class See Also Send Feedback
Initializes a new instance of the FlowDiagramModel class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramModel()
Visual Basic (Declaration)
Public Sub New

See Also

FlowDiagramModel Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramXmlSerializer Class

[image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer Class
Members See Also Send Feedback
Serializes and deserializes FlowDiagramModel objects as XML.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FlowDiagramXmlSerializer : DiagramXmlSerializer
Visual Basic (Declaration)
Public Class FlowDiagramXmlSerializer _
    Inherits DiagramXmlSerializer

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramXmlSerializer
Mindscape.WpfDiagramming.FlowDiagrams..::.FlowDiagramXmlSerializer

See Also

FlowDiagramXmlSerializer Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramXmlSerializer Members

[image] [image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer Members
FlowDiagramXmlSerializer Class Constructors Methods Properties See Also Send Feedback

The FlowDiagramXmlSerializer type exposes the following members.

Constructors

Name | Description
FlowDiagramXmlSerializer |

Methods

Name | Description
CreateConnection | Returns a deserialized connection based on the given XElement. (Inherited from DiagramXmlSerializer.)
CreateDiagram | Returns a new instance of FlowDiagramModel. (Overrides DiagramXmlSerializer ..::. CreateDiagram()()().)
CreateNode | Returns a deserialized node based on the given XElement. (Inherited from DiagramXmlSerializer.)
Deserialize | Deserializes a Diagram from XML. (Inherited from DiagramXmlSerializer.)
Serialize | Serializes a Diagram to XML. (Inherited from DiagramXmlSerializer.)
SerializeConnectionCore | Returns an XElement for serializing the given connection. (Overrides DiagramXmlSerializer ..::. SerializeConnectionCore(DiagramConnection).)
SerializeNodeCore | Returns an XElement for serializing the given node. (Overrides DiagramXmlSerializer ..::. SerializeNodeCore(DiagramNode).)
Shape | Returns a DiagramShape based on the given XAttribute value. (Inherited from DiagramXmlSerializer.)

Properties

Name | Description
LineTypeNameResolver | Gets or sets a function used to resolve line type names. This supports custom line types. If the LineTypeNameResolver is not set, or returns null, then the default resolver is used. (Inherited from DiagramXmlSerializer.)
OnDeserializeCustomConnectionData | Gets or sets a function used to deserialize custom connection data. (Inherited from DiagramXmlSerializer.)
OnDeserializeCustomNodeData | Gets or sets a function used to deserialize custom node data. (Inherited from DiagramXmlSerializer.)
OnSerializeCustomConnectionData | Gets or sets a function used to serialize custom connection data. (Inherited from DiagramXmlSerializer.)
OnSerializeCustomNodeData | Gets or sets a function used to serialize custom node data. (Inherited from DiagramXmlSerializer.)
ShapeNameResolver | Gets or sets a function used to resolve shape names. This supports custom shapes. If the ShapeNameResolver is not set, or returns null, then the default resolver is used. (Inherited from DiagramXmlSerializer.)

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramXmlSerializer Constructor

[image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer Constructor
FlowDiagramXmlSerializer Class See Also Send Feedback
Initializes a new instance of the FlowDiagramXmlSerializer class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramXmlSerializer()
Visual Basic (Declaration)
Public Sub New

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


FlowDiagramXmlSerializer Methods

[image] [image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer Methods
FlowDiagramXmlSerializer Class See Also Send Feedback

The FlowDiagramXmlSerializer type exposes the following members.

Methods

Name | Description
CreateConnection | Returns a deserialized connection based on the given XElement. (Inherited from DiagramXmlSerializer.)
CreateDiagram | Returns a new instance of FlowDiagramModel. (Overrides DiagramXmlSerializer ..::. CreateDiagram()()().)
CreateNode | Returns a deserialized node based on the given XElement. (Inherited from DiagramXmlSerializer.)
Deserialize | Deserializes a Diagram from XML. (Inherited from DiagramXmlSerializer.)
Serialize | Serializes a Diagram to XML. (Inherited from DiagramXmlSerializer.)
SerializeConnectionCore | Returns an XElement for serializing the given connection. (Overrides DiagramXmlSerializer ..::. SerializeConnectionCore(DiagramConnection).)
SerializeNodeCore | Returns an XElement for serializing the given node. (Overrides DiagramXmlSerializer ..::. SerializeNodeCore(DiagramNode).)
Shape | Returns a DiagramShape based on the given XAttribute value. (Inherited from DiagramXmlSerializer.)

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateDiagram Method

[image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer..::.CreateDiagram Method
FlowDiagramXmlSerializer Class See Also Send Feedback
Returns a new instance of FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Diagram CreateDiagram()
Visual Basic (Declaration)
Protected Overrides Function CreateDiagram As Diagram

Return Value

A new FlowDiagramModel.

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


SerializeConnectionCore Method

[image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer..::.SerializeConnectionCore Method
FlowDiagramXmlSerializer Class See Also Send Feedback
Returns an XElement for serializing the given connection.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override XElement SerializeConnectionCore(
    DiagramConnection connection
)
Visual Basic (Declaration)
Protected Overrides Function SerializeConnectionCore ( _
    connection As DiagramConnection _
) As XElement

Parameters

connection
Type: Mindscape.WpfDiagramming..::.DiagramConnection
The connection to be serialized.

Return Value

The serialized connection.

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


SerializeNodeCore Method

[image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer..::.SerializeNodeCore Method
FlowDiagramXmlSerializer Class See Also Send Feedback
Returns an XElement for serializing the given node.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override XElement SerializeNodeCore(
    DiagramNode node
)
Visual Basic (Declaration)
Protected Overrides Function SerializeNodeCore ( _
    node As DiagramNode _
) As XElement

Parameters

node
Type: Mindscape.WpfDiagramming..::.DiagramNode
The node to be serialized.

Return Value

The serialized node.

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StandardFlowDiagramToolBoxItems Class

[image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems Class
Members See Also Send Feedback
Provides standard toolbox item resources.
StandardFlowDiagramToolBoxItems

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StandardFlowDiagramToolBoxItems : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class StandardFlowDiagramToolBoxItems _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.FlowDiagrams..::.StandardFlowDiagramToolBoxItems

See Also

StandardFlowDiagramToolBoxItems Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StandardFlowDiagramToolBoxItems Members

[image] [image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems Members
StandardFlowDiagramToolBoxItems Class Constructors Methods Properties See Also Send Feedback

The StandardFlowDiagramToolBoxItems type exposes the following members.

Constructors

Name | Description
StandardFlowDiagramToolBoxItems | Initializes a new instance of the StandardFlowDiagramToolBoxItems class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
DecisionNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add DecisionNode objects to a FlowDiagramModel.
EndNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add EndNode objects to a FlowDiagramModel.
StartNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add StartNode objects to a FlowDiagramModel.

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StandardFlowDiagramToolBoxItems Constructor

[image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems Constructor
StandardFlowDiagramToolBoxItems Class See Also Send Feedback
Initializes a new instance of the StandardFlowDiagramToolBoxItems class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StandardFlowDiagramToolBoxItems()
Visual Basic (Declaration)
Public Sub New

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StandardFlowDiagramToolBoxItems Methods

[image] [image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems Methods
StandardFlowDiagramToolBoxItems Class See Also Send Feedback

The StandardFlowDiagramToolBoxItems type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems..::.InitializeComponent Method
StandardFlowDiagramToolBoxItems Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StandardFlowDiagramToolBoxItems Properties

[image] [image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems Properties
StandardFlowDiagramToolBoxItems Class See Also Send Feedback

The StandardFlowDiagramToolBoxItems type exposes the following members.

Properties

Name | Description
DecisionNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add DecisionNode objects to a FlowDiagramModel.
EndNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add EndNode objects to a FlowDiagramModel.
StartNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add StartNode objects to a FlowDiagramModel.

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DecisionNodeToolKey Property

[image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems..::.DecisionNodeToolKey Property
StandardFlowDiagramToolBoxItems Class See Also Send Feedback
Gets the ResourceKey for the standard DiagramNodeTool used to add DecisionNode objects to a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DecisionNodeToolKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DecisionNodeToolKey As ComponentResourceKey

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


EndNodeToolKey Property

[image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems..::.EndNodeToolKey Property
StandardFlowDiagramToolBoxItems Class See Also Send Feedback
Gets the ResourceKey for the standard DiagramNodeTool used to add EndNode objects to a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey EndNodeToolKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EndNodeToolKey As ComponentResourceKey

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartNodeToolKey Property

[image]

Mindscape WPF Diagrams
StandardFlowDiagramToolBoxItems..::.StartNodeToolKey Property
StandardFlowDiagramToolBoxItems Class See Also Send Feedback
Gets the ResourceKey for the standard DiagramNodeTool used to add StartNode objects to a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey StartNodeToolKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StartNodeToolKey As ComponentResourceKey

See Also

StandardFlowDiagramToolBoxItems Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartFlowDiagramNodeBuilder Class

[image]

Mindscape WPF Diagrams
StartFlowDiagramNodeBuilder Class
Members See Also Send Feedback
A type of IDiagramNodeBuilder for building StartNode objects.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StartFlowDiagramNodeBuilder : IDiagramNodeBuilder
Visual Basic (Declaration)
Public Class StartFlowDiagramNodeBuilder _
    Implements IDiagramNodeBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.StartFlowDiagramNodeBuilder

See Also

StartFlowDiagramNodeBuilder Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartFlowDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
StartFlowDiagramNodeBuilder Members
StartFlowDiagramNodeBuilder Class Constructors Methods Properties See Also Send Feedback

The StartFlowDiagramNodeBuilder type exposes the following members.

Constructors

Name | Description
StartFlowDiagramNodeBuilder |

Methods

Name | Description
CreateNode | Builds a new StartNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Properties

Name | Description
DefaultSize | Gest the dafault size of a StartNode. This StartFlowDiagramNodeBuilder considers the default size of a StartNode to be 100x40.

See Also

StartFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartFlowDiagramNodeBuilder Constructor

[image]

Mindscape WPF Diagrams
StartFlowDiagramNodeBuilder Constructor
StartFlowDiagramNodeBuilder Class See Also Send Feedback
Initializes a new instance of the StartFlowDiagramNodeBuilder class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StartFlowDiagramNodeBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

StartFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartFlowDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
StartFlowDiagramNodeBuilder Methods
StartFlowDiagramNodeBuilder Class See Also Send Feedback

The StartFlowDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Builds a new StartNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

See Also

StartFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
StartFlowDiagramNodeBuilder..::.CreateNode Method
StartFlowDiagramNodeBuilder Class See Also Send Feedback
Builds a new StartNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the newly created StartNode as added to.
bounds
Type: System.Windows..::.Rect
The position and dimensions of the newly created StartNode.

See Also

StartFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartFlowDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
StartFlowDiagramNodeBuilder Properties
StartFlowDiagramNodeBuilder Class See Also Send Feedback

The StartFlowDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Gest the dafault size of a StartNode. This StartFlowDiagramNodeBuilder considers the default size of a StartNode to be 100x40.

See Also

StartFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
StartFlowDiagramNodeBuilder..::.DefaultSize Property
StartFlowDiagramNodeBuilder Class See Also Send Feedback
Gest the dafault size of a StartNode. This StartFlowDiagramNodeBuilder considers the default size of a StartNode to be 100x40.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSize As Size

See Also

StartFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartNode Class

[image]

Mindscape WPF Diagrams
StartNode Class
Members See Also Send Feedback
A DiagramNode representing the start node of a FlowDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StartNode : DiagramNode
Visual Basic (Declaration)
Public Class StartNode _
    Inherits DiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming.FlowDiagrams..::.StartNode

See Also

StartNode Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartNode Members

[image] [image]

Mindscape WPF Diagrams
StartNode Members
StartNode Class Constructors Methods Properties Events See Also Send Feedback

The StartNode type exposes the following members.

Constructors

Name | Description
StartNode | Initializes a new instance of the StartNode class.

Methods

Name | Description
Clone | Returns an IDiagramNodeState that represents the current state of this DiagramNodeBase at the time this method is called. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this DiagramNodeBase to match those of the given IDiagramNodeState. This method can be overriden to include the setting of other properties introduced by sub classes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false if this StartNode already has one outbound connection. Returns true otherwise. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. StartNode objects can never receive new connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

StartNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartNode Constructor

[image]

Mindscape WPF Diagrams
StartNode Constructor
StartNode Class See Also Send Feedback
Initializes a new instance of the StartNode class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StartNode()
Visual Basic (Declaration)
Public Sub New

See Also

StartNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StartNode Properties

[image] [image]

Mindscape WPF Diagrams
StartNode Properties
StartNode Class See Also Send Feedback

The StartNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false if this StartNode already has one outbound connection. Returns true otherwise. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. StartNode objects can never receive new connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

StartNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
StartNode..::.CanOriginateNewConnections Property
StartNode Class See Also Send Feedback
Returns false if this StartNode already has one outbound connection. Returns true otherwise.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

StartNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
StartNode..::.CanReceiveNewConnections Property
StartNode Class See Also Send Feedback
Returns false. StartNode objects can never receive new connections.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

StartNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepFlowDiagramNodeBuilder Class

[image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder Class
Members See Also Send Feedback
A type of IDiagramNodeBuilder for building StepNode objects.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StepFlowDiagramNodeBuilder : IDiagramNodeBuilder
Visual Basic (Declaration)
Public Class StepFlowDiagramNodeBuilder _
    Implements IDiagramNodeBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.StepFlowDiagramNodeBuilder

See Also

StepFlowDiagramNodeBuilder Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepFlowDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder Members
StepFlowDiagramNodeBuilder Class Constructors Methods Properties See Also Send Feedback

The StepFlowDiagramNodeBuilder type exposes the following members.

Constructors

Name | Description
StepFlowDiagramNodeBuilder | Initializes a new instance of the StepFlowDiagramNodeBuilder class.

Methods

Name | Description
CreateNode | Builds a new StepNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Properties

Name | Description
DefaultSize | Gets the default size of a StepNode.
Shape | Gets or sets the shape to be used by the node. The default is DiagramShapes.Process.

See Also

StepFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepFlowDiagramNodeBuilder Constructor

[image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder Constructor
StepFlowDiagramNodeBuilder Class See Also Send Feedback
Initializes a new instance of the StepFlowDiagramNodeBuilder class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StepFlowDiagramNodeBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

StepFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepFlowDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder Methods
StepFlowDiagramNodeBuilder Class See Also Send Feedback

The StepFlowDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Builds a new StepNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

See Also

StepFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder..::.CreateNode Method
StepFlowDiagramNodeBuilder Class See Also Send Feedback
Builds a new StepNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the new StepNode is added to.
bounds
Type: System.Windows..::.Rect
The position and dimensions of the newly created StepNode.

See Also

StepFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepFlowDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder Properties
StepFlowDiagramNodeBuilder Class See Also Send Feedback

The StepFlowDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Gets the default size of a StepNode.
Shape | Gets or sets the shape to be used by the node. The default is DiagramShapes.Process.

See Also

StepFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder..::.DefaultSize Property
StepFlowDiagramNodeBuilder Class See Also Send Feedback
Gets the default size of a StepNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSize As Size

See Also

StepFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


Shape Property

[image]

Mindscape WPF Diagrams
StepFlowDiagramNodeBuilder..::.Shape Property
StepFlowDiagramNodeBuilder Class See Also Send Feedback
Gets or sets the shape to be used by the node. The default is DiagramShapes.Process.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As DiagramShape

See Also

StepFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNode Class

[image]

Mindscape WPF Diagrams
StepNode Class
Members See Also Send Feedback
A DiagramNode representing a step in a FlowDiagramModel. A StepNode can have any number if incomming connections but only allows for a single outbound connection.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StepNode : ShapeNode
Visual Basic (Declaration)
Public Class StepNode _
    Inherits ShapeNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming..::.ShapeNode
Mindscape.WpfDiagramming.FlowDiagrams..::.StepNode

See Also

StepNode Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNode Members

[image] [image]

Mindscape WPF Diagrams
StepNode Members
StepNode Class Constructors Methods Properties Events See Also Send Feedback

The StepNode type exposes the following members.

Constructors

Name | Description
StepNode | Initializes a new instance of the StepNode class.

Methods

Name | Description
BuildConnectionPoint | Builds a connection point that can be added to this node. (Overrides ShapeNode ..::. BuildConnectionPoint(Edge).)
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Inherited from ShapeNode.)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Inherited from ShapeNode.)

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false if this StepNode already has one outbound connection. Returns true otherwise. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns true. StepNode objects can accept any number of incomming connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Shape | Gets or sets the DiagramShape displayed by this ShapeNode. (Inherited from ShapeNode.)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

StepNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNode Constructor

[image]

Mindscape WPF Diagrams
StepNode Constructor
StepNode Class See Also Send Feedback
Initializes a new instance of the StepNode class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StepNode()
Visual Basic (Declaration)
Public Sub New

See Also

StepNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNode Methods

[image] [image]

Mindscape WPF Diagrams
StepNode Methods
StepNode Class See Also Send Feedback

The StepNode type exposes the following members.

Methods

Name | Description
BuildConnectionPoint | Builds a connection point that can be added to this node. (Overrides ShapeNode ..::. BuildConnectionPoint(Edge).)
Clone | Gets an IDiagramNodeState that represents the current state of this node at the time this method is called. (Inherited from ShapeNode.)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this node to match those of the given IDiagramNodeState. (Inherited from ShapeNode.)

See Also

StepNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


BuildConnectionPoint Method

[image]

Mindscape WPF Diagrams
StepNode..::.BuildConnectionPoint Method
StepNode Class See Also Send Feedback
Builds a connection point that can be added to this node.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override DiagramConnectionPoint BuildConnectionPoint(
    Edge edge
)
Visual Basic (Declaration)
Protected Overrides Function BuildConnectionPoint ( _
    edge As Edge _
) As DiagramConnectionPoint

Parameters

edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge of the connection point.

Return Value

The connection point.

See Also

StepNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNode Properties

[image] [image]

Mindscape WPF Diagrams
StepNode Properties
StepNode Class See Also Send Feedback

The StepNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Returns false if this StepNode already has one outbound connection. Returns true otherwise. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns true. StepNode objects can accept any number of incomming connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Shape | Gets or sets the DiagramShape displayed by this ShapeNode. (Inherited from ShapeNode.)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

StepNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
StepNode..::.CanOriginateNewConnections Property
StepNode Class See Also Send Feedback
Returns false if this StepNode already has one outbound connection. Returns true otherwise.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

StepNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
StepNode..::.CanReceiveNewConnections Property
StepNode Class See Also Send Feedback
Returns true. StepNode objects can accept any number of incomming connections.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

StepNode Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNodeTool Class

[image]

Mindscape WPF Diagrams
StepNodeTool Class
Members See Also Send Feedback
Provides attached properties which configure a DiagramNodeTool to create StepNode objects with a specified DiagramShape.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class StepNodeTool
Visual Basic (Declaration)
Public NotInheritable Class StepNodeTool

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.StepNodeTool

See Also

StepNodeTool Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNodeTool Members

[image] [image]

Mindscape WPF Diagrams
StepNodeTool Members
StepNodeTool Class Methods Fields See Also Send Feedback

The StepNodeTool type exposes the following members.

Methods

Name | Description
GetShape | Gets the DiagramShape for this DiagramNodeTool.
SetShape | Sets the DiagramShape for this DiagramNodeTool.

Fields

Name | Description
ShapeProperty | Identifies the Shape attached property.

See Also

StepNodeTool Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNodeTool Fields

[image] [image]

Mindscape WPF Diagrams
StepNodeTool Fields
StepNodeTool Class See Also Send Feedback

The StepNodeTool type exposes the following members.

Fields

Name | Description
ShapeProperty | Identifies the Shape attached property.

See Also

StepNodeTool Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


ShapeProperty Field

[image]

Mindscape WPF Diagrams
StepNodeTool..::.ShapeProperty Field
StepNodeTool Class See Also Send Feedback
Identifies the Shape attached property.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShapeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShapeProperty As DependencyProperty

See Also

StepNodeTool Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


StepNodeTool Methods

[image] [image]

Mindscape WPF Diagrams
StepNodeTool Methods
StepNodeTool Class See Also Send Feedback

The StepNodeTool type exposes the following members.

Methods

Name | Description
GetShape | Gets the DiagramShape for this DiagramNodeTool.
SetShape | Sets the DiagramShape for this DiagramNodeTool.

See Also

StepNodeTool Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


GetShape Method

[image]

Mindscape WPF Diagrams
StepNodeTool..::.GetShape Method
StepNodeTool Class See Also Send Feedback
Gets the DiagramShape for this DiagramNodeTool.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static DiagramShape GetShape(
    DiagramNodeTool obj
)
Visual Basic (Declaration)
Public Shared Function GetShape ( _
    obj As DiagramNodeTool _
) As DiagramShape

Parameters

obj
Type: Mindscape.WpfDiagramming..::.DiagramNodeTool
The element from which the property value is read.

Return Value

The DiagramShape of the specified DiagramNodeTool.

See Also

StepNodeTool Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


SetShape Method

[image]

Mindscape WPF Diagrams
StepNodeTool..::.SetShape Method
StepNodeTool Class See Also Send Feedback
Sets the DiagramShape for this DiagramNodeTool.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetShape(
    DiagramNodeTool obj,
    DiagramShape value
)
Visual Basic (Declaration)
Public Shared Sub SetShape ( _
    obj As DiagramNodeTool, _
    value As DiagramShape _
)

Parameters

obj
Type: Mindscape.WpfDiagramming..::.DiagramNodeTool
The element to which the property value is written.
value
Type: Mindscape.WpfDiagramming..::.DiagramShape
The DiagramShape of the specified DiagramNodeTool.

See Also

StepNodeTool Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


TitleFlowDiagramNodeBuilder Class

[image]

Mindscape WPF Diagrams
TitleFlowDiagramNodeBuilder Class
Members See Also Send Feedback
A type of IDiagramNodeBuilder for building TitleNode objects.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class TitleFlowDiagramNodeBuilder : IDiagramNodeBuilder
Visual Basic (Declaration)
Public Class TitleFlowDiagramNodeBuilder _
    Implements IDiagramNodeBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.FlowDiagrams..::.TitleFlowDiagramNodeBuilder

See Also

TitleFlowDiagramNodeBuilder Members
Mindscape.WpfDiagramming.FlowDiagrams Namespace


TitleFlowDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
TitleFlowDiagramNodeBuilder Members
TitleFlowDiagramNodeBuilder Class Constructors Methods Properties See Also Send Feedback

The TitleFlowDiagramNodeBuilder type exposes the following members.

Constructors

Name | Description
TitleFlowDiagramNodeBuilder |

Methods

Name | Description
CreateNode | Builds a new TitleNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Properties

Name | Description
DefaultSize | Returns the default size of a TitleNode. This TitleFlowDiagramNodeBuilder considers the default size of a TitleNode to be 450x130

See Also

TitleFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


TitleFlowDiagramNodeBuilder Constructor

[image]

Mindscape WPF Diagrams
TitleFlowDiagramNodeBuilder Constructor
TitleFlowDiagramNodeBuilder Class See Also Send Feedback
Initializes a new instance of the TitleFlowDiagramNodeBuilder class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TitleFlowDiagramNodeBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

TitleFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


TitleFlowDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
TitleFlowDiagramNodeBuilder Methods
TitleFlowDiagramNodeBuilder Class See Also Send Feedback

The TitleFlowDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Builds a new TitleNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

See Also

TitleFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
TitleFlowDiagramNodeBuilder..::.CreateNode Method
TitleFlowDiagramNodeBuilder Class See Also Send Feedback
Builds a new TitleNode with the given dropPosition as its bounds and adds it to the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the new TitleNode is added to.
bounds
Type: System.Windows..::.Rect
The position and dimensions of the newly created TitleNode.

See Also

TitleFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


TitleFlowDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
TitleFlowDiagramNodeBuilder Properties
TitleFlowDiagramNodeBuilder Class See Also Send Feedback

The TitleFlowDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Returns the default size of a TitleNode. This TitleFlowDiagramNodeBuilder considers the default size of a TitleNode to be 450x130

See Also

TitleFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
TitleFlowDiagramNodeBuilder..::.DefaultSize Property
TitleFlowDiagramNodeBuilder Class See Also Send Feedback
Returns the default size of a TitleNode. This TitleFlowDiagramNodeBuilder considers the default size of a TitleNode to be 450x130

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSize As Size

See Also

TitleFlowDiagramNodeBuilder Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace

[image]

Mindscape WPF Diagrams
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace
Send Feedback
Contains standard flow diagram visual styles.

Classes

Class | Description
FlowDiagramStyles | A ResourceDictionary containing standard visual styles for flow diagrams.
GradientStyle | A ResourceDictionary containing a pretty visual style for flow diagrams involving gradient brushes.
Whalesong | A ResourceDictionary containing a standard visual style for flow diagrams.


FlowDiagramStyles Class

[image]

Mindscape WPF Diagrams
FlowDiagramStyles Class
Members See Also Send Feedback
A ResourceDictionary containing standard visual styles for flow diagrams.
FlowDiagramStyles

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FlowDiagramStyles : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class FlowDiagramStyles _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.FlowDiagrams.Styles..::.FlowDiagramStyles

See Also

FlowDiagramStyles Members
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


FlowDiagramStyles Members

[image] [image]

Mindscape WPF Diagrams
FlowDiagramStyles Members
FlowDiagramStyles Class Constructors Methods Properties See Also Send Feedback

The FlowDiagramStyles type exposes the following members.

Constructors

Name | Description
FlowDiagramStyles | Initializes a new instance of the FlowDiagramStyles class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
GradientStyleFormatterKey | Gets the ResourceKey for Gradient diagram formatter.
WhalesongFormatterKey | Gets the ResourceKey for the Whalesong diagram formatter.

See Also

FlowDiagramStyles Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


FlowDiagramStyles Constructor

[image]

Mindscape WPF Diagrams
FlowDiagramStyles Constructor
FlowDiagramStyles Class See Also Send Feedback
Initializes a new instance of the FlowDiagramStyles class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FlowDiagramStyles()
Visual Basic (Declaration)
Public Sub New

See Also

FlowDiagramStyles Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


FlowDiagramStyles Methods

[image] [image]

Mindscape WPF Diagrams
FlowDiagramStyles Methods
FlowDiagramStyles Class See Also Send Feedback

The FlowDiagramStyles type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

FlowDiagramStyles Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
FlowDiagramStyles..::.InitializeComponent Method
FlowDiagramStyles Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

FlowDiagramStyles Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


FlowDiagramStyles Properties

[image] [image]

Mindscape WPF Diagrams
FlowDiagramStyles Properties
FlowDiagramStyles Class See Also Send Feedback

The FlowDiagramStyles type exposes the following members.

Properties

Name | Description
GradientStyleFormatterKey | Gets the ResourceKey for Gradient diagram formatter.
WhalesongFormatterKey | Gets the ResourceKey for the Whalesong diagram formatter.

See Also

FlowDiagramStyles Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


GradientStyleFormatterKey Property

[image]

Mindscape WPF Diagrams
FlowDiagramStyles..::.GradientStyleFormatterKey Property
FlowDiagramStyles Class See Also Send Feedback
Gets the ResourceKey for Gradient diagram formatter.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey GradientStyleFormatterKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GradientStyleFormatterKey As ComponentResourceKey

See Also

FlowDiagramStyles Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


WhalesongFormatterKey Property

[image]

Mindscape WPF Diagrams
FlowDiagramStyles..::.WhalesongFormatterKey Property
FlowDiagramStyles Class See Also Send Feedback
Gets the ResourceKey for the Whalesong diagram formatter.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey WhalesongFormatterKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WhalesongFormatterKey As ComponentResourceKey

See Also

FlowDiagramStyles Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


GradientStyle Class

[image]

Mindscape WPF Diagrams
GradientStyle Class
Members See Also Send Feedback
A ResourceDictionary containing a pretty visual style for flow diagrams involving gradient brushes.
GradientStyle

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class GradientStyle : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class GradientStyle _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.FlowDiagrams.Styles..::.GradientStyle

See Also

GradientStyle Members
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


GradientStyle Members

[image] [image]

Mindscape WPF Diagrams
GradientStyle Members
GradientStyle Class Constructors Methods Properties See Also Send Feedback

The GradientStyle type exposes the following members.

Constructors

Name | Description
GradientStyle | Initializes a new instance of the GradientStyle class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle uses to select connection styles.
DecisionNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a DecisionNode.
EndNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a EndNode.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle uses to select node styles.
StartNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a StartNode.
StepNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a StepNode.

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


GradientStyle Constructor

[image]

Mindscape WPF Diagrams
GradientStyle Constructor
GradientStyle Class See Also Send Feedback
Initializes a new instance of the GradientStyle class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public GradientStyle()
Visual Basic (Declaration)
Public Sub New

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


GradientStyle Methods

[image] [image]

Mindscape WPF Diagrams
GradientStyle Methods
GradientStyle Class See Also Send Feedback

The GradientStyle type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
GradientStyle..::.InitializeComponent Method
GradientStyle Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


GradientStyle Properties

[image] [image]

Mindscape WPF Diagrams
GradientStyle Properties
GradientStyle Class See Also Send Feedback

The GradientStyle type exposes the following members.

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle uses to select connection styles.
DecisionNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a DecisionNode.
EndNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a EndNode.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle uses to select node styles.
StartNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a StartNode.
StepNodeStyleKey | Returns the ResourceKey for the Style that the GradientStyle uses for styling a StepNode.

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


ConnectionStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.ConnectionStyleSelectorKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the GradientStyle uses to select connection styles.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey ConnectionStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConnectionStyleSelectorKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


DecisionNodeStyleKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.DecisionNodeStyleKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the Style that the GradientStyle uses for styling a DecisionNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DecisionNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DecisionNodeStyleKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


EndNodeStyleKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.EndNodeStyleKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the Style that the GradientStyle uses for styling a EndNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey EndNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EndNodeStyleKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


NodeStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.NodeStyleSelectorKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the GradientStyle uses to select node styles.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey NodeStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NodeStyleSelectorKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


StartNodeStyleKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.StartNodeStyleKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the Style that the GradientStyle uses for styling a StartNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey StartNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StartNodeStyleKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


StepNodeStyleKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.StepNodeStyleKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the Style that the GradientStyle uses for styling a StepNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey StepNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StepNodeStyleKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


Whalesong Class

[image]

Mindscape WPF Diagrams
Whalesong Class
Members See Also Send Feedback
A ResourceDictionary containing a standard visual style for flow diagrams.
Whalesong

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Whalesong : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class Whalesong _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.FlowDiagrams.Styles..::.Whalesong

See Also

Whalesong Members
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


Whalesong Members

[image] [image]

Mindscape WPF Diagrams
Whalesong Members
Whalesong Class Constructors Methods Properties See Also Send Feedback

The Whalesong type exposes the following members.

Constructors

Name | Description
Whalesong | Initializes a new instance of the Whalesong class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select connection styles.
DecisionNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a DecisionNode.
EndNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a EndNode.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select node styles.
StartNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a StartNode.
StepNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a StepNode.

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


Whalesong Constructor

[image]

Mindscape WPF Diagrams
Whalesong Constructor
Whalesong Class See Also Send Feedback
Initializes a new instance of the Whalesong class.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Whalesong()
Visual Basic (Declaration)
Public Sub New

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


Whalesong Methods

[image] [image]

Mindscape WPF Diagrams
Whalesong Methods
Whalesong Class See Also Send Feedback

The Whalesong type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
Whalesong..::.InitializeComponent Method
Whalesong Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


Whalesong Properties

[image] [image]

Mindscape WPF Diagrams
Whalesong Properties
Whalesong Class See Also Send Feedback

The Whalesong type exposes the following members.

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select connection styles.
DecisionNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a DecisionNode.
EndNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a EndNode.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select node styles.
StartNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a StartNode.
StepNodeStyleKey | Returns the ResourceKey for the Style that the Whalesong uses for styling a StepNode.

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


ConnectionStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.ConnectionStyleSelectorKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select connection styles.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey ConnectionStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConnectionStyleSelectorKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


DecisionNodeStyleKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.DecisionNodeStyleKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the Style that the Whalesong uses for styling a DecisionNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DecisionNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DecisionNodeStyleKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


EndNodeStyleKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.EndNodeStyleKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the Style that the Whalesong uses for styling a EndNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey EndNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EndNodeStyleKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


NodeStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.NodeStyleSelectorKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select node styles.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey NodeStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NodeStyleSelectorKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


StartNodeStyleKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.StartNodeStyleKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the Style that the Whalesong uses for styling a StartNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey StartNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StartNodeStyleKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


StepNodeStyleKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.StepNodeStyleKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the Style that the Whalesong uses for styling a StepNode.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey StepNodeStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property StepNodeStyleKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.FlowDiagrams.Styles Namespace


Mindscape.WpfDiagramming.Foundation Namespace

[image]

Mindscape WPF Diagrams
Mindscape.WpfDiagramming.Foundation Namespace
Send Feedback
Contains low-level diagramming primitives.

Classes

Class | Description
ArithmeticConverter | Converts a number by multiplying it by a factor and adding an offset.
Arrowhead | Can be placed at each end of a DiagramConnectionElement to render an arrow head.
ArrowheadToPathGeometryConverter | Creates a PathGeometry for an Arrowhead.
AStarPathfinder | Determines a path for an IDiagramConnection, using the A* algorithm to plot a course which consists of horizontal and vertical segments and avoids collisions with other nodes and connections.
AttachedThumb | Represents a Thumb which is associated with a specific FrameworkElement.
AutoSizeCanvas | Represents a Canvas that automatically sizes itself to its child items and their layout.
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) | Provides a more basic implementation of diagram connections. This class is good for connections that do not support connection-mounted-connections, and the source/destination connection points are both the same type.
BoundsChangeRequestedEventArgs | Provides information about the DiagramNodeElement.BoundsChangeRequested event of a DiagramNodeElement.
BuilderTypeExtension | Provides a markup shortcut for specifying the Builder associated with a DiagramNodeTool.
CircularLayoutAlgorithm | A type of ILayoutAlgorithm that arranges the nodes in a circle.
ConnectionContentTransformConverter | Creates a TranslateTransform for positioning connection content.
ConnectionDropTarget | Provides information about a potential destination of a connection.
ConnectionPointDirectionTemplate | Maps a ConnectionPointDirection to a DataTemplate.
ConnectionPointPositionConverter | Determines a position from a connection point and an ILayout.
ConnectionPointThumb | A control which can be dragged to create a connection.
ConnectionPointXCoordinateConverter | Determines an X coordinate from a connection point and an ILayout.
ConnectionPointYCoordinateConverter | Determines a Y coordinate from a connection point and an ILayout.
ConnectionRelocatedEventArgs | Provides information about the ConnectionRelocated event of a ConnectionRelocatorThumb.
ConnectionRelocationInfo | Holds information about performing a connection relocation action.
ConnectionRelocatorThumb | Enables and manages relocation of either end of an IDiagramConnection and the DiagramConnectionElement that graphically represents it. That is, this thumb modifies either the ToConnectionPoint or the FromConnectionPoint properties of the connection that this thumb is assigned to. The position of the end of the connection being relocated is dynamically changed as the mouse is dragged allowing for a rubberbanding effect. This thumb can relocate either the 'to' or 'from' connection point to another connection point mounted on either an IDiagramNode or an IDiagramConnection that the mouse is over when released. If the mouse is released over nothing, then the connection being relocated is put back to its original connection points.
ConnectionSegmentThumb | Enables horizontal or vertical movement of a single MovableDiagramConnectionSegment. Note that a ConnectionSegmentThumb only allows horizontal or vertical segments to be moved.
ConnectionState | A standard implementation of IDiagramConnectionState that can store property values of the properties found in the IDiagramConnection interface. This ConnectionState will store the following property values of the given IDiagramConnection: Data, FromConnectionPoint, ToConnectionPoint, Segments, IsUserModified, and ConnectionPoints. Note that a ConnectionState clones the DiagramConnectionSegment objects in the Segments property, but all other property values are stored by refference.
CorneredPathBuilder | Constructs a PathGeometry from a list of DiagramConnectionSegment objects, applying curved or bevelled corners.
CreateConnectionCursorAction | Represents the cursor action to create a connection using a "connection" toolbox item. This action is typically used only when a diagram contains multiple types of connection -- for example, an entity diagram which contains both inheritance and association relationships.
CursorAction | Represents an action associated with the cursor, such as a "charged cursor" for click-and-drop interaction.
CursorActionTypeConverter | Converts a CursorAction to a CursorActionType in a null-safe manner.
CustomPropertyChangedEventArgs | Holds information about the CustomPropertyChanged event. This information tells the DiagramSurface if it should change the dirty-bit or take a snapshot for undoing purposes.
DataTypeStyleSelector | Selects a diagram node style based on the type of the diagram node data.
DataTypeTemplateSelector | Selects a diagram node template based on the type of the diagram node data.
DefaultCursorAction | Represents the default cursor action (when no toolbox item is selected).
DefaultDiagramConnectionRelocator | Provides standard implementation of relocating an IDiagramConnection.
DefaultDiagramConnectionRemover | Provides the standard implementation for removing connections from a diagram.
DefaultDiagramNodeRemover | Provides the standard implementation of removing nodes from a diagram model.
DefaultLayout | Maps between diagram model bounds and element bounds on a DiagramSurface.
DelegatingDataTemplateSelector | Selects a template, falling back to another DataTemplateSelector if no template is found by this selector.
DelegatingStyleSelector | Selects a style, falling back to another StyleSelector if no style is found by this selector.
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) | Provides base diagram connection implementation.
DiagramConnectionCollection<(Of <(TConnection>)>) | A type of ObservableCollection that holds IDiagramConnection objects and allows for cascading removal of IDiagramConnection objects that have other IDiagramConnection objects attached to them. A DiagramConnectionCollection uses the IDiagramConnectionRemover found in the IDiagramModel passed into the constructor to delete the cascading connections from that model.
DiagramConnectionElement | Represents a connection between two DiagramNodeElement elements.
DiagramConnectionPointBase<(Of <(TConnection>)>) | Provides base implementation for diagram connection points.
DiagramConnectionSegment | A single segment within an IDiagramConnection. DiagramConnectionSegment objects have access to the next or previous DiagramConnectionSegment from this themselves allowing them to be chained together. DiagramConnectionSegment objects only have a single Point representing the end point of the segment. The start point of the segment is the end point of the previous segment. So the first segment in a chain is only a single point. DiagramConnectionSegment objects ensure that there is a bidirectional link between the next and previous segments.
DiagramElement | Represents a visual element in a diagram (a node or connection).
DiagramModelBase<(Of <(TNode, TConnection>)>) | Provides a base implementation of the IDiagramModel interface.
DiagramNodeBase<(Of <(TConnectionPoint>)>) | Provides a base implementation for diagram nodes.
DiagramNodeElement | Represents a node (content element) on a diagram.
DiagramPrintDocument | Contains information used when printing a diagram.
DiagramScrollContentPresenter | Displays the content of a DiagramScrollViewer control.
DiagramScrollViewer | Represents a scrollable area that can contain a diagram.
DiagramState | Represents a cloned state of an IDiagramModel.
DiagramStructureException | The exception that is thrown when a diagram has an invalid structure.
DiagramToolBoxFilterItem | Represents a filter option for a DiagramToolBox.
DiagramToolBoxFilterListConverter | Adds a separator to the diagram tool box filter list.
DoubleToScaleTransformConverter | Converts a double value into a ScaleTransform.
ElbowPathfinder | Determines a path for an IDiagramConnection that consists of horizontal and vertical segments, and avoids collisions with the elements which it connects.
FixedStyleSelector | A StyleSelector which always selects a fixed Style.
FixedTemplateSelector | A DataTemplateSelector which always selects a fixed DataTemplate.
FloatingConnectionPoint | This class is part of the WPF Diagramming infrastructure to support dragging the ends of connections, and is not intended to be used in your own code.
ForceBasedLayoutAlgorithm | A layout algorithm that uses physics equations based on charged particles and springs.
GridLayoutAlgorithm | A layout algorithm that takes advantage of the positions and directions of connection points. Lays out all the nodes in a grid like pattern based on the structure of the diagram.
HierarchicalLayoutAlgorithm | A layout algorithm that positions nodes in a hierarchical tree like structure.
IntersectionSnapLineDrawing | Draws snap lines by placing a dot at the intersections of snap lines.
IntervalLineSnapLineDrawing | Draws snap lines as a set of grid lines with some of the lines having a different color.
LayoutAlgorithmBase | A base implementation of ILayoutAlgorithm.
LineSnapLineDrawing | Draws snap lines as a set of grid lines.
MarginConverter | An IValueConverter that uses the LeftFactor, RightFactor, TopFactor, and BottomFactor properties to create a Thickness object. The factor properties are multiplied by the width and height values of a given Rect to calculate the values of the created Thickness values.
MatchingStyleSelector | Selects a Style based on a list of match criteria.
MatchingTemplateSelector | Selects a data template based on a list of match criteria.
MouseWheelZoom | Provides support for mouse wheel based zooming.
MouseZoomEventArgs | Provides information about the MouseZoomEvent routed event.
MovableDiagramConnectionSegment | A type of DiagramConnectionSegment that can be moved by the user.
MovedEventArgs | Provides information about the Moved event of a MoveThumb.
MoveThumb | Enables dragging of the associated FrameworkElement.
NodeState | A general implementation of the IDiagramNodeState interface.
OffsetPositionCalculator | A type of IPositionCalculator that calculates the position according to factors of the width and height of a bounding rectangle.
PathBuilderBase | Provides a standard base implementation of the IPathBuilder interface.
PointToTranslateTransformConverter | Converts a Point into a TranslateTransform.
PositionCalculatorConverter | Converts instances of other types to and from IPositionCalculator instances.
PositionCalculators | Contains IPositionCalculator implementations for common positions.
QueryDropPositionEventArgs | Provides information about the QueryDropPosition event of a ToolThumb.
QuerySegmentDragEventArgs | Provides information to the DiagramSurface about where the ConnectionSegmentThumb wants to place the MovableDiagramConnectionSegment that it is moving. instances of this class can then hold information about where the DiagramSurface allows the DiagramConnectionSegment to be placed.
RandomLayoutAlgorithm | A type of ILayoutAlgorithm that simply randomizes all the positions of the nodes within an IDiagramModel.
RectToDoubleConverter | Converts a Rect to a number based on the width or height of the Rect.
RectToPointConverter | Calculates the position of a Point on a rectangle, relative to the top left of the rectangle.
RectToSizeConverter | Obtains the size of a Rect, optionally applying scaling and/or fixed offsets.
Resizer | Enables resizing of the associated FrameworkElement.
RotatedEventArgs | Provides information about the Rotated event of a RotateThumb.
RotateThumb | A thumb used to rotate diagram nodes.
RotationToSizeThumbCursorConverter | Converts node rotation into the mouse cursor that should be used by a SizeThumb.
ScrollBarMaximumConverter | Derives a scroll bar maximum from a maximum value, viewport dimension and zoom factor.
ScrollBarViewportSizeConverter | Derives a viewport size from a dimension and zoom factor.
SegmentMovedEventArgs | Provides information about the SegmentMoved event of a ConnectionSegmentThumb.
SegmentsToAngleConverter | Uses diagram connection segments to calculate an angle for an Arrowhead.
ShapeConnectionPointPositionCollectionConverter | Converts instances of other types to and from IPositionCalculator instances.
SizedEventArgs | Provides information about the Sized event of a SizeThumb.
SizeThumb | Enables resizing of the associated FrameworkElement.
SizeToFitConverter | Derives a ScaleTransform sizing a diagram to fit the available size.
SnapLineDrawingConverter | Derives a snap line background drawing from DiagramSurface settings.
SnapToIntervalExtension | Provides a markup shortcut for specifying a snap line interval.
SnapToIntervalSnapSpecifier | Represents an ISnapSpecifier which snaps a coordinate to a regular interval.
StraightLinePathfinder | Determines a path for an IDiagramConnection using a straight line from the start to the end of the connection.
ThicknessToDoubleConverter | Converts a Thickness to a double by returning the Thickness.Top property value.
ToolCursorAction<(Of <(TTool>)>) | Represents the cursor action when a toolbox item is selected.
ToolDroppedEventArgs | Provides information about the ToolDropped event of a ToolThumb control.
ToolThumb | Represents a Thumb that, in addition to being dragged, can be clicked to "charge" the cursor.
TypeEdgeCalculator | Maps a data type and an Edge to an IPositionCalculator.
TypeStyle | Maps a data type to a Style.
TypeStyleSelector | Selects a style based on the type of the object.
TypeStyleSelectorBase | selects a style based on a type.
TypeTemplate | Maps a data type to a DataTemplate.
TypeTemplateSelector | Selects a data template based on the type of the object.
TypeTemplateSelectorBase | Selects a data template based on a type.
UndoManager | A class that manages the undo and redo procedures of a DiagramSurface.
ViewModelBase | Provides common observability support for view model classes.

Interfaces

Interface | Description
IDataTemplateMatcher | Maps a selection criterion to a DataTemplate in a MatchingTemplateSelector.
IDiagramAdapter | Represents an adapter that maps a business object model to a diagram model.
IDiagramConnectable | An object within an IDiagramModel that can have IDiagramConnectionPoint objects attached to it.
IDiagramConnection | Represents a relationship between two diagram model entities that should be made visible in the diagram as a DiagramConnectionElement.
IDiagramConnectionBuilder | Provides connection creation services for use by toolbox items.
IDiagramConnectionPoint | Represents a point on an IDiagramConnectable where a connection can be attached.
IDiagramConnectionRelocator | Provides services for relocating an IDiagramConnection to a different source or/and destination IDiagramConnectionPoint.
IDiagramConnectionRemover | Provides connection removal services from a diagram model.
IDiagramConnectionState | Represents a state of an IDiagramConnection. Implementations of this interface will hold the values of the properties of an instance of an IDiagramConnection implementation.
IDiagramElementFactory | Creates DiagramElement objects for custom diagram content.
IDiagramFormatter | Specifies the layout, formatting and visual style of a diagram.
IDiagramModel | Provides an abstract representation of diagram entities, ready for rendering using templates.
IDiagramNode | Represents a diagram model entity that should be made visible in the diagram as a DiagramNodeElement.
IDiagramNodeBuilder | Provides node creation services for use by toolbox items.
IDiagramNodeRemover | Provides node removal services from a diagram model.
IDiagramNodeState | Represents a state of an IDiagramNode. Implementations of this interface will hold the values of the properties of an instance of an IDiagramNode implementation.
IDiagramPositionable | Represents an item which can be positioned in the diagram and the z-order (as opposed to acquiring its position and z-order from other items).
IDiagramPrintCallback | Gets additional elements for printing on a DiagramPrintDocument.
IDiagramToolboxTool | Represents a control which can be dragged from a toolbox onto a DiagramSurface to create new diagram elements.
IDiagramZOrderable | Represents an item in a diagram that can participate in Z-ordering.
ILayout | Maps between diagram model bounds and element bounds on a DiagramSurface.
ILayoutAlgorithm | represents an algorithm that can be applied to an IDiagramModel which will reposition the nodes within the diagram into a sutable position.
ILayoutAlgorithmInfo | Provides additional logic for layout algorithms that may be specific to certain diagram types.
INotifyCustomPropertyChanged | Implementations of IDiagramConnectable that introduce additional properties can implement this interface allowing such properties to be integrated into the dirty-bit and undo features of a DiagramSurface.
IPathBuilder | Builds a PathGeometry for a sequence of diagram connection segments.
IPathfinder | Determines a path for an IDiagramConnection, specified as a sequence of points.
IPositionCalculator | Calculates a position given a rectangle. This is typically used to calculate the position of an IDiagramConnectionPoint on an IDiagramNode.
ISnapLineDrawing | Draws snap lines on the diagram background.
ISnapSpecifier | Defines how a value should be snapped to a guideline.
IStyleMatcher | Represents a criterion for matching an item to a Style.

Enumerations

Enumeration | Description
ConnectionEnd | Identifies the two ends of a connection.
ConnectionPointDirection | The direction that an IDiagramConnectionPoint flows relative to the IDiagramConnectable that it is attached to. That is, whether an IDiagramConnectionPoint receives connections or originates them.
ConnectionPointShowFlags | Describes which type of connection points should have their visibility changed.
CornerType | Represents the style of a corner.
CursorActionType | Specifies the type of operation represented by a CursorAction.
DiagramSurfaceDragAction | Determines the behaviour of clicking and then dragging the mouse over a DiagramSurface.
RectToDoubleConverterType | Specifies the calculation that a RectToDoubleConverter should use to convert a Rect to a number.
SnapLineDisplayMode | Controls how a DiagramSurface displays snap lines.
ZIndexLayer | Specifies how a DiagramElement participates in the z-order.


ArithmeticConverter Class

[image]

Mindscape WPF Diagrams
ArithmeticConverter Class
Members See Also Send Feedback
Converts a number by multiplying it by a factor and adding an offset.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ArithmeticConverter : IValueConverter
Visual Basic (Declaration)
Public Class ArithmeticConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ArithmeticConverter

See Also

ArithmeticConverter Members
Mindscape.WpfDiagramming.Foundation Namespace


ArithmeticConverter Members

[image] [image]

Mindscape WPF Diagrams
ArithmeticConverter Members
ArithmeticConverter Class Constructors Methods Properties See Also Send Feedback

The ArithmeticConverter type exposes the following members.

Constructors

Name | Description
ArithmeticConverter | Initializes a new instance of the ArithmeticConverter class.

Methods

Name | Description
Convert | Returns the result of multiplying and adding the given number by the Factor and Offset properties respectivly.
ConvertBack | Throws a NotImplementedException.

Properties

Name | Description
Factor | Gets or sets the factor to multiply with the number. The default is 1.
Minimum | Gets or sets the minimum return value. The default is Double.MinValue.
Offset | Gets or sets the offset to add to the number. The default is 0.

See Also

ArithmeticConverter Class


ArithmeticConverter Constructor

[image]

Mindscape WPF Diagrams
ArithmeticConverter Constructor
ArithmeticConverter Class See Also Send Feedback
Initializes a new instance of the ArithmeticConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ArithmeticConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ArithmeticConverter Class


ArithmeticConverter Methods

[image] [image]

Mindscape WPF Diagrams
ArithmeticConverter Methods
ArithmeticConverter Class See Also Send Feedback

The ArithmeticConverter type exposes the following members.

Methods

Name | Description
Convert | Returns the result of multiplying and adding the given number by the Factor and Offset properties respectivly.
ConvertBack | Throws a NotImplementedException.

See Also

ArithmeticConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ArithmeticConverter..::.Convert Method
ArithmeticConverter Class See Also Send Feedback
Returns the result of multiplying and adding the given number by the Factor and Offset properties respectivly.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The result of multiplying and adding the given number with the Factor and Offset properties.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ArithmeticConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ArithmeticConverter..::.ConvertBack Method
ArithmeticConverter Class See Also Send Feedback
Throws a NotImplementedException.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ArithmeticConverter Class


ArithmeticConverter Properties

[image] [image]

Mindscape WPF Diagrams
ArithmeticConverter Properties
ArithmeticConverter Class See Also Send Feedback

The ArithmeticConverter type exposes the following members.

Properties

Name | Description
Factor | Gets or sets the factor to multiply with the number. The default is 1.
Minimum | Gets or sets the minimum return value. The default is Double.MinValue.
Offset | Gets or sets the offset to add to the number. The default is 0.

See Also

ArithmeticConverter Class


Factor Property

[image]

Mindscape WPF Diagrams
ArithmeticConverter..::.Factor Property
ArithmeticConverter Class See Also Send Feedback
Gets or sets the factor to multiply with the number. The default is 1.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Factor { get; set; }
Visual Basic (Declaration)
Public Property Factor As Double

See Also

ArithmeticConverter Class


Minimum Property

[image]

Mindscape WPF Diagrams
ArithmeticConverter..::.Minimum Property
ArithmeticConverter Class See Also Send Feedback
Gets or sets the minimum return value. The default is Double.MinValue.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Double

See Also

ArithmeticConverter Class


Offset Property

[image]

Mindscape WPF Diagrams
ArithmeticConverter..::.Offset Property
ArithmeticConverter Class See Also Send Feedback
Gets or sets the offset to add to the number. The default is 0.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Double

See Also

ArithmeticConverter Class


Arrowhead Class

[image]

Mindscape WPF Diagrams
Arrowhead Class
Members See Also Send Feedback
Can be placed at each end of a DiagramConnectionElement to render an arrow head.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Arrowhead : Control
Visual Basic (Declaration)
Public Class Arrowhead _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.WpfDiagramming.Foundation..::.Arrowhead

See Also

Arrowhead Members


Arrowhead Members

[image] [image]

Mindscape WPF Diagrams
Arrowhead Members
Arrowhead Class Constructors Fields Properties See Also Send Feedback

The Arrowhead type exposes the following members.

Constructors

Name | Description
Arrowhead |

Fields

Name | Description
PathStyleProperty | Identifies the PathStyle property.

Properties

Name | Description
BackWidth | Gets or sets the distance between the 2 points adjacent to the arrow tip point.
Length | Gets or sets the distance from the tip of the arrow head to the back edge. Note that the length does not put a negative Notch value into conideration.
Notch | Gets or sets the indentation of the back edge of the arrow head. A possitive value will push this indentation inwards towards the arrow tip. A value of 0 will allow the arrowhead to look like a simple triangle. A negative value will make the arrow look like a kite or a diamond.
PathStyle | Gets or sets the Style applied to the arrow path. This is a dependency property.

See Also

Arrowhead Class


Arrowhead Constructor

[image]

Mindscape WPF Diagrams
Arrowhead Constructor
Arrowhead Class See Also Send Feedback
Initializes a new instance of the Arrowhead class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Arrowhead()
Visual Basic (Declaration)
Public Sub New

See Also

Arrowhead Class


Arrowhead Fields

[image] [image]

Mindscape WPF Diagrams
Arrowhead Fields
Arrowhead Class See Also Send Feedback

The Arrowhead type exposes the following members.

Fields

Name | Description
PathStyleProperty | Identifies the PathStyle property.

See Also

Arrowhead Class


PathStyleProperty Field

[image]

Mindscape WPF Diagrams
Arrowhead..::.PathStyleProperty Field
Arrowhead Class See Also Send Feedback
Identifies the PathStyle property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty PathStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly PathStyleProperty As DependencyProperty

See Also

Arrowhead Class


Arrowhead Properties

[image] [image]

Mindscape WPF Diagrams
Arrowhead Properties
Arrowhead Class See Also Send Feedback

The Arrowhead type exposes the following members.

Properties

Name | Description
BackWidth | Gets or sets the distance between the 2 points adjacent to the arrow tip point.
Length | Gets or sets the distance from the tip of the arrow head to the back edge. Note that the length does not put a negative Notch value into conideration.
Notch | Gets or sets the indentation of the back edge of the arrow head. A possitive value will push this indentation inwards towards the arrow tip. A value of 0 will allow the arrowhead to look like a simple triangle. A negative value will make the arrow look like a kite or a diamond.
PathStyle | Gets or sets the Style applied to the arrow path. This is a dependency property.

See Also

Arrowhead Class


BackWidth Property

[image]

Mindscape WPF Diagrams
Arrowhead..::.BackWidth Property
Arrowhead Class See Also Send Feedback
Gets or sets the distance between the 2 points adjacent to the arrow tip point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int BackWidth { get; set; }
Visual Basic (Declaration)
Public Property BackWidth As Integer

See Also

Arrowhead Class


Length Property

[image]

Mindscape WPF Diagrams
Arrowhead..::.Length Property
Arrowhead Class See Also Send Feedback
Gets or sets the distance from the tip of the arrow head to the back edge. Note that the length does not put a negative Notch value into conideration.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Integer

See Also

Arrowhead Class


Notch Property

[image]

Mindscape WPF Diagrams
Arrowhead..::.Notch Property
Arrowhead Class See Also Send Feedback
Gets or sets the indentation of the back edge of the arrow head. A possitive value will push this indentation inwards towards the arrow tip. A value of 0 will allow the arrowhead to look like a simple triangle. A negative value will make the arrow look like a kite or a diamond.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int Notch { get; set; }
Visual Basic (Declaration)
Public Property Notch As Integer

See Also

Arrowhead Class


PathStyle Property

[image]

Mindscape WPF Diagrams
Arrowhead..::.PathStyle Property
Arrowhead Class See Also Send Feedback
Gets or sets the Style applied to the arrow path. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style PathStyle { get; set; }
Visual Basic (Declaration)
Public Property PathStyle As Style

Remarks

Dependency Property Information
Identifier field | PathStyleProperty
Metadata properties set to true | None

See Also

Arrowhead Class


ArrowheadToPathGeometryConverter Class

[image]

Mindscape WPF Diagrams
ArrowheadToPathGeometryConverter Class
Members See Also Send Feedback
Creates a PathGeometry for an Arrowhead.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ArrowheadToPathGeometryConverter : IValueConverter
Visual Basic (Declaration)
Public Class ArrowheadToPathGeometryConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ArrowheadToPathGeometryConverter

See Also

ArrowheadToPathGeometryConverter Members


ArrowheadToPathGeometryConverter Members

[image] [image]

Mindscape WPF Diagrams
ArrowheadToPathGeometryConverter Members
ArrowheadToPathGeometryConverter Class Constructors Methods See Also Send Feedback

The ArrowheadToPathGeometryConverter type exposes the following members.

Constructors

Name | Description
ArrowheadToPathGeometryConverter |

Methods

Name | Description
Convert | Returns a PathGeometry for the given Arrowhead.
ConvertBack | Throws a NotImplementedException.

See Also

ArrowheadToPathGeometryConverter Class


ArrowheadToPathGeometryConverter Constructor

[image]

Mindscape WPF Diagrams
ArrowheadToPathGeometryConverter Constructor
ArrowheadToPathGeometryConverter Class See Also Send Feedback
Initializes a new instance of the ArrowheadToPathGeometryConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ArrowheadToPathGeometryConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ArrowheadToPathGeometryConverter Class


ArrowheadToPathGeometryConverter Methods

[image] [image]

Mindscape WPF Diagrams
ArrowheadToPathGeometryConverter Methods
ArrowheadToPathGeometryConverter Class See Also Send Feedback

The ArrowheadToPathGeometryConverter type exposes the following members.

Methods

Name | Description
Convert | Returns a PathGeometry for the given Arrowhead.
ConvertBack | Throws a NotImplementedException.

See Also

ArrowheadToPathGeometryConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ArrowheadToPathGeometryConverter..::.Convert Method
ArrowheadToPathGeometryConverter Class See Also Send Feedback
Returns a PathGeometry for the given Arrowhead.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A PathGeometry for the given Arrowhead.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ArrowheadToPathGeometryConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ArrowheadToPathGeometryConverter..::.ConvertBack Method
ArrowheadToPathGeometryConverter Class See Also Send Feedback
Throws a NotImplementedException.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ArrowheadToPathGeometryConverter Class


AStarPathfinder Class

[image]

Mindscape WPF Diagrams
AStarPathfinder Class
Members See Also Send Feedback
Determines a path for an IDiagramConnection, using the A* algorithm to plot a course which consists of horizontal and vertical segments and avoids collisions with other nodes and connections.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class AStarPathfinder : IPathfinder
Visual Basic (Declaration)
Public Class AStarPathfinder _
    Implements IPathfinder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.AStarPathfinder

See Also

AStarPathfinder Members


AStarPathfinder Members

[image] [image]

Mindscape WPF Diagrams
AStarPathfinder Members
AStarPathfinder Class Constructors Methods Properties See Also Send Feedback

The AStarPathfinder type exposes the following members.

Constructors

Name | Description
AStarPathfinder | Initializes a new instance of the AStarPathfinder class.

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection.

Properties

Name | Description
FallbackPathfinder | Gets or sets an IPathfinder to fall back on if the A* algorithm cannot be used.
Instance | Gets a static instance of the AStarPathfinder class.

See Also

AStarPathfinder Class


AStarPathfinder Constructor

[image]

Mindscape WPF Diagrams
AStarPathfinder Constructor
AStarPathfinder Class See Also Send Feedback
Initializes a new instance of the AStarPathfinder class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public AStarPathfinder()
Visual Basic (Declaration)
Public Sub New

See Also

AStarPathfinder Class


AStarPathfinder Methods

[image] [image]

Mindscape WPF Diagrams
AStarPathfinder Methods
AStarPathfinder Class See Also Send Feedback

The AStarPathfinder type exposes the following members.

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection.

See Also

AStarPathfinder Class


FindPath Method

[image]

Mindscape WPF Diagrams
AStarPathfinder..::.FindPath Method
AStarPathfinder Class See Also Send Feedback
Determines a path for the given IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ReadOnlyCollection<Point> FindPath(
    IDiagramConnection connection,
    IDiagramModel diagram
)
Visual Basic (Declaration)
Public Function FindPath ( _
    connection As IDiagramConnection, _
    diagram As IDiagramModel _
) As ReadOnlyCollection(Of Point)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to find a path for.
diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
An IDiagramModel used to obtain other nodes and connections if needed

Return Value

A collection of via points representing the plotted course of the connection, or null to indicate that the connection path did not need to be refreshed.

Implements

IPathfinder..::.FindPath(IDiagramConnection, IDiagramModel)

See Also

AStarPathfinder Class


AStarPathfinder Properties

[image] [image]

Mindscape WPF Diagrams
AStarPathfinder Properties
AStarPathfinder Class See Also Send Feedback

The AStarPathfinder type exposes the following members.

Properties

Name | Description
FallbackPathfinder | Gets or sets an IPathfinder to fall back on if the A* algorithm cannot be used.
Instance | Gets a static instance of the AStarPathfinder class.

See Also

AStarPathfinder Class


FallbackPathfinder Property

[image]

Mindscape WPF Diagrams
AStarPathfinder..::.FallbackPathfinder Property
AStarPathfinder Class See Also Send Feedback
Gets or sets an IPathfinder to fall back on if the A* algorithm cannot be used.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IPathfinder FallbackPathfinder { get; set; }
Visual Basic (Declaration)
Public Property FallbackPathfinder As IPathfinder

Remarks

The fallback pathfinder is used if A* cannot find a path with no collisions, or if either end of the connection is mounted to another connection.

See Also

AStarPathfinder Class


Instance Property

[image]

Mindscape WPF Diagrams
AStarPathfinder..::.Instance Property
AStarPathfinder Class See Also Send Feedback
Gets a static instance of the AStarPathfinder class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static AStarPathfinder Instance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As AStarPathfinder

See Also

AStarPathfinder Class


AttachedThumb Class

[image]

Mindscape WPF Diagrams
AttachedThumb Class
Members See Also Send Feedback
Represents a Thumb which is associated with a specific FrameworkElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class AttachedThumb : Thumb
Visual Basic (Declaration)
Public MustInherit Class AttachedThumb _
    Inherits Thumb

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.AttachedThumb
Mindscape.WpfDiagramming.Foundation..::.MoveThumb
Mindscape.WpfDiagramming.Foundation..::.RotateThumb
Mindscape.WpfDiagramming.Foundation..::.SizeThumb

See Also

AttachedThumb Members


AttachedThumb Members

[image] [image]

Mindscape WPF Diagrams
AttachedThumb Members
AttachedThumb Class Constructors Fields Properties See Also Send Feedback

The AttachedThumb type exposes the following members.

Constructors

Name | Description
AttachedThumb |

Fields

Name | Description
ElementProperty | Identifies the Element property.
SnapToGuidelinesProperty | Identifies the SnapToGuidelines property.

Properties

Name | Description
Element | Gets or sets the element to which the AttachedThumb is attached. This is a dependency property.
SnapToGuidelines | Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property.

See Also

AttachedThumb Class


AttachedThumb Constructor

[image]

Mindscape WPF Diagrams
AttachedThumb Constructor
AttachedThumb Class See Also Send Feedback
Initializes a new instance of the AttachedThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected AttachedThumb()
Visual Basic (Declaration)
Protected Sub New

See Also

AttachedThumb Class


AttachedThumb Fields

[image] [image]

Mindscape WPF Diagrams
AttachedThumb Fields
AttachedThumb Class See Also Send Feedback

The AttachedThumb type exposes the following members.

Fields

Name | Description
ElementProperty | Identifies the Element property.
SnapToGuidelinesProperty | Identifies the SnapToGuidelines property.

See Also

AttachedThumb Class


ElementProperty Field

[image]

Mindscape WPF Diagrams
AttachedThumb..::.ElementProperty Field
AttachedThumb Class See Also Send Feedback
Identifies the Element property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ElementProperty
Visual Basic (Declaration)
Public Shared ReadOnly ElementProperty As DependencyProperty

See Also

AttachedThumb Class


SnapToGuidelinesProperty Field

[image]

Mindscape WPF Diagrams
AttachedThumb..::.SnapToGuidelinesProperty Field
AttachedThumb Class See Also Send Feedback
Identifies the SnapToGuidelines property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SnapToGuidelinesProperty
Visual Basic (Declaration)
Public Shared ReadOnly SnapToGuidelinesProperty As DependencyProperty

See Also

AttachedThumb Class


AttachedThumb Properties

[image] [image]

Mindscape WPF Diagrams
AttachedThumb Properties
AttachedThumb Class See Also Send Feedback

The AttachedThumb type exposes the following members.

Properties

Name | Description
Element | Gets or sets the element to which the AttachedThumb is attached. This is a dependency property.
SnapToGuidelines | Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property.

See Also

AttachedThumb Class


Element Property

[image]

Mindscape WPF Diagrams
AttachedThumb..::.Element Property
AttachedThumb Class See Also Send Feedback
Gets or sets the element to which the AttachedThumb is attached. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FrameworkElement Element { get; set; }
Visual Basic (Declaration)
Public Property Element As FrameworkElement

Remarks

Dependency Property Information
Identifier field | ElementProperty
Metadata properties set to true | None

See Also

AttachedThumb Class


SnapToGuidelines Property

[image]

Mindscape WPF Diagrams
AttachedThumb..::.SnapToGuidelines Property
AttachedThumb Class See Also Send Feedback
Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool SnapToGuidelines { get; set; }
Visual Basic (Declaration)
Public Property SnapToGuidelines As Boolean

Remarks

Dependency Property Information
Identifier field | SnapToGuidelinesProperty
Metadata properties set to true | None

See Also

AttachedThumb Class


AutoSizeCanvas Class

[image]

Mindscape WPF Diagrams
AutoSizeCanvas Class
Members See Also Send Feedback
Represents a Canvas that automatically sizes itself to its child items and their layout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class AutoSizeCanvas : Canvas
Visual Basic (Declaration)
Public Class AutoSizeCanvas _
    Inherits Canvas

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
System.Windows.Controls..::.Canvas
Mindscape.WpfDiagramming.Foundation..::.AutoSizeCanvas

See Also

AutoSizeCanvas Members


AutoSizeCanvas Members

[image] [image]

Mindscape WPF Diagrams
AutoSizeCanvas Members
AutoSizeCanvas Class Constructors Methods Fields Properties See Also Send Feedback

The AutoSizeCanvas type exposes the following members.

Constructors

Name | Description
AutoSizeCanvas |

Methods

Name | Description
MeasureOverride | Measures the child elements of the AutoSizeCanvas and measures the AutoSizeCanvas accordingly. (Overrides Canvas ..::. MeasureOverride(Size).)

Fields

Name | Description
ContentBoundsProperty | Identifies the ContentBounds property.
ContentSizeProperty | Identifies the ContentSize property.

Properties

Name | Description
ContentBounds | Gets the content bounds. This is a dependency property.
ContentSize | Gets the content size. This is a dependency property.

See Also

AutoSizeCanvas Class


AutoSizeCanvas Constructor

[image]

Mindscape WPF Diagrams
AutoSizeCanvas Constructor
AutoSizeCanvas Class See Also Send Feedback
Initializes a new instance of the AutoSizeCanvas class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public AutoSizeCanvas()
Visual Basic (Declaration)
Public Sub New

See Also

AutoSizeCanvas Class


AutoSizeCanvas Fields

[image] [image]

Mindscape WPF Diagrams
AutoSizeCanvas Fields
AutoSizeCanvas Class See Also Send Feedback

The AutoSizeCanvas type exposes the following members.

Fields

Name | Description
ContentBoundsProperty | Identifies the ContentBounds property.
ContentSizeProperty | Identifies the ContentSize property.

See Also

AutoSizeCanvas Class


ContentBoundsProperty Field

[image]

Mindscape WPF Diagrams
AutoSizeCanvas..::.ContentBoundsProperty Field
AutoSizeCanvas Class See Also Send Feedback
Identifies the ContentBounds property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ContentBoundsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentBoundsProperty As DependencyProperty

See Also

AutoSizeCanvas Class


ContentSizeProperty Field

[image]

Mindscape WPF Diagrams
AutoSizeCanvas..::.ContentSizeProperty Field
AutoSizeCanvas Class See Also Send Feedback
Identifies the ContentSize property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ContentSizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentSizeProperty As DependencyProperty

See Also

AutoSizeCanvas Class


AutoSizeCanvas Methods

[image] [image]

Mindscape WPF Diagrams
AutoSizeCanvas Methods
AutoSizeCanvas Class See Also Send Feedback

The AutoSizeCanvas type exposes the following members.

Methods

Name | Description
MeasureOverride | Measures the child elements of the AutoSizeCanvas and measures the AutoSizeCanvas accordingly. (Overrides Canvas ..::. MeasureOverride(Size).)

See Also

AutoSizeCanvas Class


MeasureOverride Method

[image]

Mindscape WPF Diagrams
AutoSizeCanvas..::.MeasureOverride Method
AutoSizeCanvas Class See Also Send Feedback
Measures the child elements of the AutoSizeCanvas and measures the AutoSizeCanvas accordingly.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size

Parameters

constraint
Type: System.Windows..::.Size
An upper limit Size that should not be exceeded.

Return Value

A Size that represents the size that is required to arrange child content.

See Also

AutoSizeCanvas Class


AutoSizeCanvas Properties

[image] [image]

Mindscape WPF Diagrams
AutoSizeCanvas Properties
AutoSizeCanvas Class See Also Send Feedback

The AutoSizeCanvas type exposes the following members.

Properties

Name | Description
ContentBounds | Gets the content bounds. This is a dependency property.
ContentSize | Gets the content size. This is a dependency property.

See Also

AutoSizeCanvas Class


ContentBounds Property

[image]

Mindscape WPF Diagrams
AutoSizeCanvas..::.ContentBounds Property
AutoSizeCanvas Class See Also Send Feedback
Gets the content bounds. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect ContentBounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentBounds As Rect

Remarks

Dependency Property Information
Identifier field | ContentBoundsProperty
Metadata properties set to true | None

See Also

AutoSizeCanvas Class


ContentSize Property

[image]

Mindscape WPF Diagrams
AutoSizeCanvas..::.ContentSize Property
AutoSizeCanvas Class See Also Send Feedback
Gets the content size. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size ContentSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentSize As Size

Remarks

Dependency Property Information
Identifier field | ContentSizeProperty
Metadata properties set to true | None

See Also

AutoSizeCanvas Class


BasicDiagramConnectionBase(TConnectionPoint) Class

[image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class
Members See Also Send Feedback
Provides a more basic implementation of diagram connections. This class is good for connections that do not support connection-mounted-connections, and the source/destination connection points are both the same type.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class BasicDiagramConnectionBase<TConnectionPoint> : DiagramConnectionBase<TConnectionPoint, TConnectionPoint, IDiagramConnectionPoint> where TConnectionPoint : IDiagramConnectionPoint
Visual Basic (Declaration)
Public Class BasicDiagramConnectionBase(Of TConnectionPoint As IDiagramConnectionPoint) _
    Inherits DiagramConnectionBase(Of TConnectionPoint, TConnectionPoint, IDiagramConnectionPoint)

Type Parameters

TConnectionPoint

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionBase <(Of <(TConnectionPoint, TConnectionPoint, IDiagramConnectionPoint >)>)
Mindscape.WpfDiagramming.Foundation..::.BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>)

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Members


BasicDiagramConnectionBase(TConnectionPoint) Members

[image] [image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Members
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class Constructors Methods Properties Events See Also Send Feedback

The BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) type exposes the following members.

Constructors

Name | Description
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) | Overloaded.

Methods

Name | Description
AddConnectionPoint | This type of connection does not support mounted connection points, and throws NotSupportedException. (Overrides DiagramConnectionBase <(Of <( TConnectionPoint, TConnectionPoint, IDiagramConnectionPoint >)>)..::. AddConnectionPoint(Point, Double).)
ApplyPathfinding | Re-routes this connection using its pathfinder. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Clone | Gets the state of the connection for undo purposes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can allow a be the source of a new outgoing connection. The base class implementation always returns false. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
CanReceiveNewConnections | Gets whether the connection can be the destination of a new incoming connection. (Overrides DiagramConnectionBase <(Of <( TConnectionPoint, TConnectionPoint, IDiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Pathfinder | Gets the IPathfinder used to find the segment path of this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Events

Name | Description
DataChanged | Raised when the Data property changes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class


BasicDiagramConnectionBase(TConnectionPoint) Constructor

[image] [image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Constructor
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback

Overload List

Name | Description
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>)(TConnectionPoint, TConnectionPoint) | Initializes a new instance of the BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) class.
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>)(TConnectionPoint, TConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>)) | Initializes a new instance of the BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) class.

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Members


BasicDiagramConnectionBase(TConnectionPoint) Constructor (TConnectionPoint, TConnectionPoint)

[image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Constructor (TConnectionPoint, TConnectionPoint)
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Initializes a new instance of the BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BasicDiagramConnectionBase(
    TConnectionPoint fromConnectionPoint,
    TConnectionPoint toConnectionPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As TConnectionPoint, _
    toConnectionPoint As TConnectionPoint _
)

Parameters

fromConnectionPoint
Type: TConnectionPoint
The source of the connection.
toConnectionPoint
Type: TConnectionPoint
The destination of the connection.

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Overload


BasicDiagramConnectionBase(TConnectionPoint) Constructor (TConnectionPoint, TConnectionPoint, IList(DiagramConnectionSegment))

[image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Constructor (TConnectionPoint, TConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>))
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Initializes a new instance of the BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BasicDiagramConnectionBase(
    TConnectionPoint fromConnectionPoint,
    TConnectionPoint toConnectionPoint,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As TConnectionPoint, _
    toConnectionPoint As TConnectionPoint, _
    segments As IList(Of DiagramConnectionSegment) _
)

Parameters

fromConnectionPoint
Type: TConnectionPoint
The source of the connection.
toConnectionPoint
Type: TConnectionPoint
The destination of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects within this BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>).

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Overload


BasicDiagramConnectionBase(TConnectionPoint) Methods

[image] [image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Methods
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback

The BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) type exposes the following members.

Methods

Name | Description
AddConnectionPoint | This type of connection does not support mounted connection points, and throws NotSupportedException. (Overrides DiagramConnectionBase <(Of <( TConnectionPoint, TConnectionPoint, IDiagramConnectionPoint >)>)..::. AddConnectionPoint(Point, Double).)
ApplyPathfinding | Re-routes this connection using its pathfinder. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Clone | Gets the state of the connection for undo purposes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class


AddConnectionPoint Method

[image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>)..::.AddConnectionPoint Method
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
This type of connection does not support mounted connection points, and throws NotSupportedException.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override sealed IDiagramConnectionPoint AddConnectionPoint(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Public Overrides NotOverridable Function AddConnectionPoint ( _
    point As Point, _
    buffer As Double _
) As IDiagramConnectionPoint

Parameters

point
Type: System.Windows..::.Point
A point used to derive the position of the mounted connection point.
buffer
Type: System..::.Double
The minimum distance away from the connection corners that the mounted point can be placed.

Return Value

Throws NotSupportedException.

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class


BasicDiagramConnectionBase(TConnectionPoint) Properties

[image] [image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Properties
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback

The BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can allow a be the source of a new outgoing connection. The base class implementation always returns false. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
CanReceiveNewConnections | Gets whether the connection can be the destination of a new incoming connection. (Overrides DiagramConnectionBase <(Of <( TConnectionPoint, TConnectionPoint, IDiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Pathfinder | Gets the IPathfinder used to find the segment path of this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>)..::.CanReceiveNewConnections Property
BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets whether the connection can be the destination of a new incoming connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override sealed bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

Remarks

Connections of this type do not support 'connections to connections,' and always return false from this property.

See Also

BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>) Class


BoundsChangeRequestedEventArgs Class

[image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs Class
Members See Also Send Feedback
Provides information about the DiagramNodeElement.BoundsChangeRequested event of a DiagramNodeElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class BoundsChangeRequestedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class BoundsChangeRequestedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.BoundsChangeRequestedEventArgs

See Also

BoundsChangeRequestedEventArgs Members


BoundsChangeRequestedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs Members
BoundsChangeRequestedEventArgs Class Constructors Properties See Also Send Feedback

The BoundsChangeRequestedEventArgs type exposes the following members.

Constructors

Name | Description
BoundsChangeRequestedEventArgs | Initializes a new instance of the BoundsChangeRequestedEventArgs class.

Properties

Name | Description
ContentElement | Gets the FrameworkElement that is causing the bounds change request.
DiagramNodeElement | Gets the DiagramNodeElement that the bounds change is to be applied to.
Height | Gets the actual height of the FrameworkElement causing the bounds change request.
Width | Gets the actual width of the FrameworkElement causing the bounds change request.

See Also

BoundsChangeRequestedEventArgs Class


BoundsChangeRequestedEventArgs Constructor

[image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs Constructor
BoundsChangeRequestedEventArgs Class See Also Send Feedback
Initializes a new instance of the BoundsChangeRequestedEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BoundsChangeRequestedEventArgs(
    DiagramNodeElement node,
    FrameworkElement contentElement
)
Visual Basic (Declaration)
Public Sub New ( _
    node As DiagramNodeElement, _
    contentElement As FrameworkElement _
)

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.DiagramNodeElement
The DiagramNodeElement that the bounds change is to be applied to.
contentElement
Type: System.Windows..::.FrameworkElement
The FrameworkElement that is causing the bounds change request.

See Also

BoundsChangeRequestedEventArgs Class


BoundsChangeRequestedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs Properties
BoundsChangeRequestedEventArgs Class See Also Send Feedback

The BoundsChangeRequestedEventArgs type exposes the following members.

Properties

Name | Description
ContentElement | Gets the FrameworkElement that is causing the bounds change request.
DiagramNodeElement | Gets the DiagramNodeElement that the bounds change is to be applied to.
Height | Gets the actual height of the FrameworkElement causing the bounds change request.
Width | Gets the actual width of the FrameworkElement causing the bounds change request.

See Also

BoundsChangeRequestedEventArgs Class


ContentElement Property

[image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs..::.ContentElement Property
BoundsChangeRequestedEventArgs Class See Also Send Feedback
Gets the FrameworkElement that is causing the bounds change request.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FrameworkElement ContentElement { get; private set; }
Visual Basic (Declaration)
Public Property ContentElement As FrameworkElement

See Also

BoundsChangeRequestedEventArgs Class


DiagramNodeElement Property

[image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs..::.DiagramNodeElement Property
BoundsChangeRequestedEventArgs Class See Also Send Feedback
Gets the DiagramNodeElement that the bounds change is to be applied to.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramNodeElement DiagramNodeElement { get; private set; }
Visual Basic (Declaration)
Public Property DiagramNodeElement As DiagramNodeElement

See Also

BoundsChangeRequestedEventArgs Class


Height Property

[image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs..::.Height Property
BoundsChangeRequestedEventArgs Class See Also Send Feedback
Gets the actual height of the FrameworkElement causing the bounds change request.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Height { get; private set; }
Visual Basic (Declaration)
Public Property Height As Double

See Also

BoundsChangeRequestedEventArgs Class


Width Property

[image]

Mindscape WPF Diagrams
BoundsChangeRequestedEventArgs..::.Width Property
BoundsChangeRequestedEventArgs Class See Also Send Feedback
Gets the actual width of the FrameworkElement causing the bounds change request.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Width { get; private set; }
Visual Basic (Declaration)
Public Property Width As Double

See Also

BoundsChangeRequestedEventArgs Class


BuilderTypeExtension Class

[image]

Mindscape WPF Diagrams
BuilderTypeExtension Class
Members See Also Send Feedback
Provides a markup shortcut for specifying the Builder associated with a DiagramNodeTool.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[MarkupExtensionReturnTypeAttribute(typeof(IDiagramNodeBuilder))]
public class BuilderTypeExtension : MarkupExtension
Visual Basic (Declaration)
<MarkupExtensionReturnTypeAttribute(GetType(IDiagramNodeBuilder))> _
Public Class BuilderTypeExtension _
    Inherits MarkupExtension

Inheritance Hierarchy

System..::.Object
System.Windows.Markup..::.MarkupExtension
Mindscape.WpfDiagramming.Foundation..::.BuilderTypeExtension

See Also

BuilderTypeExtension Members


BuilderTypeExtension Members

[image] [image]

Mindscape WPF Diagrams
BuilderTypeExtension Members
BuilderTypeExtension Class Constructors Methods See Also Send Feedback

The BuilderTypeExtension type exposes the following members.

Constructors

Name | Description
BuilderTypeExtension | Initializes a new instance of the BuilderTypeExtension class.

Methods

Name | Description
ProvideValue | Returns an instance of the specified tool type. (Overrides MarkupExtension ..::. ProvideValue(IServiceProvider).)

See Also

BuilderTypeExtension Class


BuilderTypeExtension Constructor

[image]

Mindscape WPF Diagrams
BuilderTypeExtension Constructor
BuilderTypeExtension Class See Also Send Feedback
Initializes a new instance of the BuilderTypeExtension class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public BuilderTypeExtension(
    Type builderType
)
Visual Basic (Declaration)
Public Sub New ( _
    builderType As Type _
)

Parameters

builderType
Type: System..::.Type
The type of IDiagramNodeBuilder.

See Also

BuilderTypeExtension Class


BuilderTypeExtension Methods

[image] [image]

Mindscape WPF Diagrams
BuilderTypeExtension Methods
BuilderTypeExtension Class See Also Send Feedback

The BuilderTypeExtension type exposes the following members.

Methods

Name | Description
ProvideValue | Returns an instance of the specified tool type. (Overrides MarkupExtension ..::. ProvideValue(IServiceProvider).)

See Also

BuilderTypeExtension Class


ProvideValue Method

[image]

Mindscape WPF Diagrams
BuilderTypeExtension..::.ProvideValue Method
BuilderTypeExtension Class See Also Send Feedback
Returns an instance of the specified tool type.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override Object ProvideValue(
    IServiceProvider serviceProvider
)
Visual Basic (Declaration)
Public Overrides Function ProvideValue ( _
    serviceProvider As IServiceProvider _
) As Object

Parameters

serviceProvider
Type: System..::.IServiceProvider
Object that can provide services for the markup extension.

Return Value

An IDiagramNodeBuilder of the type specified in the constructor.

See Also

BuilderTypeExtension Class


CircularLayoutAlgorithm Class

[image]

Mindscape WPF Diagrams
CircularLayoutAlgorithm Class
Members See Also Send Feedback
A type of ILayoutAlgorithm that arranges the nodes in a circle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class CircularLayoutAlgorithm : LayoutAlgorithmBase
Visual Basic (Declaration)
Public Class CircularLayoutAlgorithm _
    Inherits LayoutAlgorithmBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.LayoutAlgorithmBase
Mindscape.WpfDiagramming.Foundation..::.CircularLayoutAlgorithm

See Also

CircularLayoutAlgorithm Members


CircularLayoutAlgorithm Members

[image] [image]

Mindscape WPF Diagrams
CircularLayoutAlgorithm Members
CircularLayoutAlgorithm Class Constructors Methods Properties See Also Send Feedback

The CircularLayoutAlgorithm type exposes the following members.

Constructors

Name | Description
CircularLayoutAlgorithm |

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

Properties

Name | Description
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
Radius | Gets or sets the desired radius of the circle. Setting this to 0 will allow the radius to be automatically calculated based on the sizes of the nodes. The default is 0.

See Also

CircularLayoutAlgorithm Class


CircularLayoutAlgorithm Constructor

[image]

Mindscape WPF Diagrams
CircularLayoutAlgorithm Constructor
CircularLayoutAlgorithm Class See Also Send Feedback
Initializes a new instance of the CircularLayoutAlgorithm class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CircularLayoutAlgorithm()
Visual Basic (Declaration)
Public Sub New

See Also

CircularLayoutAlgorithm Class


CircularLayoutAlgorithm Methods

[image] [image]

Mindscape WPF Diagrams
CircularLayoutAlgorithm Methods
CircularLayoutAlgorithm Class See Also Send Feedback

The CircularLayoutAlgorithm type exposes the following members.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

See Also

CircularLayoutAlgorithm Class


Run Method

[image]

Mindscape WPF Diagrams
CircularLayoutAlgorithm..::.Run Method
CircularLayoutAlgorithm Class See Also Send Feedback
Runs this layout algorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Public Overrides Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to be laid out.

Implements

ILayoutAlgorithm..::.Run(IDiagramModel)

See Also

CircularLayoutAlgorithm Class


CircularLayoutAlgorithm Properties

[image] [image]

Mindscape WPF Diagrams
CircularLayoutAlgorithm Properties
CircularLayoutAlgorithm Class See Also Send Feedback

The CircularLayoutAlgorithm type exposes the following members.

Properties

Name | Description
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
Radius | Gets or sets the desired radius of the circle. Setting this to 0 will allow the radius to be automatically calculated based on the sizes of the nodes. The default is 0.

See Also

CircularLayoutAlgorithm Class


Radius Property

[image]

Mindscape WPF Diagrams
CircularLayoutAlgorithm..::.Radius Property
CircularLayoutAlgorithm Class See Also Send Feedback
Gets or sets the desired radius of the circle. Setting this to 0 will allow the radius to be automatically calculated based on the sizes of the nodes. The default is 0.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double

See Also

CircularLayoutAlgorithm Class


ConnectionContentTransformConverter Class

[image]

Mindscape WPF Diagrams
ConnectionContentTransformConverter Class
Members See Also Send Feedback
Creates a TranslateTransform for positioning connection content.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionContentTransformConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class ConnectionContentTransformConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionContentTransformConverter

See Also

ConnectionContentTransformConverter Members


ConnectionContentTransformConverter Members

[image] [image]

Mindscape WPF Diagrams
ConnectionContentTransformConverter Members
ConnectionContentTransformConverter Class Constructors Methods See Also Send Feedback

The ConnectionContentTransformConverter type exposes the following members.

Constructors

Name | Description
ConnectionContentTransformConverter |

Methods

Name | Description
Convert | Returns a TranslateTransform that can be used to position the content of an IDiagramConnection.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

ConnectionContentTransformConverter Class


ConnectionContentTransformConverter Constructor

[image]

Mindscape WPF Diagrams
ConnectionContentTransformConverter Constructor
ConnectionContentTransformConverter Class See Also Send Feedback
Initializes a new instance of the ConnectionContentTransformConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionContentTransformConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionContentTransformConverter Class


ConnectionContentTransformConverter Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionContentTransformConverter Methods
ConnectionContentTransformConverter Class See Also Send Feedback

The ConnectionContentTransformConverter type exposes the following members.

Methods

Name | Description
Convert | Returns a TranslateTransform that can be used to position the content of an IDiagramConnection.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

ConnectionContentTransformConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ConnectionContentTransformConverter..::.Convert Method
ConnectionContentTransformConverter Class See Also Send Feedback
Returns a TranslateTransform that can be used to position the content of an IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The values produced by the binding source. The converter expects four values: the position of the 'from' connection point, the edge on which the 'from' connection point appears, the width of the content and the height of the content.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The TranslateTransform for the connection content.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

See Also

ConnectionContentTransformConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ConnectionContentTransformConverter..::.ConvertBack Method
ConnectionContentTransformConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The types to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

ConnectionContentTransformConverter Class


ConnectionDropTarget Class

[image]

Mindscape WPF Diagrams
ConnectionDropTarget Class
Members See Also Send Feedback
Provides information about a potential destination of a connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionDropTarget
Visual Basic (Declaration)
Public Class ConnectionDropTarget

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionDropTarget

See Also

ConnectionDropTarget Members


ConnectionDropTarget Members

[image] [image]

Mindscape WPF Diagrams
ConnectionDropTarget Members
ConnectionDropTarget Class Properties See Also Send Feedback

The ConnectionDropTarget type exposes the following members.

Properties

Name | Description
Connectable | Gets a potential destination connectable for a connection. This could either be a node or another connection.
ConnectionEnd | Gets a ConnectionEnd to determine which end of the connection is being moved.
ConnectionPoint | Gets the IDiagramConnectionPoint that is a potential destination for the connection. This will be null whenever it is not needed for the connection validation.

See Also

ConnectionDropTarget Class


ConnectionDropTarget Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionDropTarget Properties
ConnectionDropTarget Class See Also Send Feedback

The ConnectionDropTarget type exposes the following members.

Properties

Name | Description
Connectable | Gets a potential destination connectable for a connection. This could either be a node or another connection.
ConnectionEnd | Gets a ConnectionEnd to determine which end of the connection is being moved.
ConnectionPoint | Gets the IDiagramConnectionPoint that is a potential destination for the connection. This will be null whenever it is not needed for the connection validation.

See Also

ConnectionDropTarget Class


Connectable Property

[image]

Mindscape WPF Diagrams
ConnectionDropTarget..::.Connectable Property
ConnectionDropTarget Class See Also Send Feedback
Gets a potential destination connectable for a connection. This could either be a node or another connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectable Connectable { get; private set; }
Visual Basic (Declaration)
Public Property Connectable As IDiagramConnectable

See Also

ConnectionDropTarget Class


ConnectionEnd Property

[image]

Mindscape WPF Diagrams
ConnectionDropTarget..::.ConnectionEnd Property
ConnectionDropTarget Class See Also Send Feedback
Gets a ConnectionEnd to determine which end of the connection is being moved.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionEnd ConnectionEnd { get; private set; }
Visual Basic (Declaration)
Public Property ConnectionEnd As ConnectionEnd

See Also

ConnectionDropTarget Class


ConnectionPoint Property

[image]

Mindscape WPF Diagrams
ConnectionDropTarget..::.ConnectionPoint Property
ConnectionDropTarget Class See Also Send Feedback
Gets the IDiagramConnectionPoint that is a potential destination for the connection. This will be null whenever it is not needed for the connection validation.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint ConnectionPoint { get; private set; }
Visual Basic (Declaration)
Public Property ConnectionPoint As IDiagramConnectionPoint

See Also

ConnectionDropTarget Class


ConnectionEnd Enumeration

[image]

Mindscape WPF Diagrams
ConnectionEnd Enumeration
See Also Send Feedback
Identifies the two ends of a connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ConnectionEnd
Visual Basic (Declaration)
Public Enumeration ConnectionEnd

Members

Member name | Description
Start | The start or "from" end of the connection.
Finish | The finish or "to" end of the connection.

See Also


ConnectionPointDirection Enumeration

[image]

Mindscape WPF Diagrams
ConnectionPointDirection Enumeration
See Also Send Feedback
The direction that an IDiagramConnectionPoint flows relative to the IDiagramConnectable that it is attached to. That is, whether an IDiagramConnectionPoint receives connections or originates them.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ConnectionPointDirection
Visual Basic (Declaration)
Public Enumeration ConnectionPointDirection

Members

Member name | Description
Inbound | Signifies that some IDiagramConnectionPoint is designed to receive connections.
Outbound | Signifies that some IDiagramConnectionPoint is designed to originate connections.
Any | Signifies that some IDiagramConnectionPoint is designed to both receive and originate connections.

See Also


ConnectionPointDirectionTemplate Class

[image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate Class
Members See Also Send Feedback
Maps a ConnectionPointDirection to a DataTemplate.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionPointDirectionTemplate : IDataTemplateMatcher
Visual Basic (Declaration)
Public Class ConnectionPointDirectionTemplate _
    Implements IDataTemplateMatcher

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionPointDirectionTemplate

See Also

ConnectionPointDirectionTemplate Members


ConnectionPointDirectionTemplate Members

[image] [image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate Members
ConnectionPointDirectionTemplate Class Constructors Methods Properties See Also Send Feedback

The ConnectionPointDirectionTemplate type exposes the following members.

Constructors

Name | Description
ConnectionPointDirectionTemplate |

Methods

Name | Description
Matches | Tests whether an object is a connection point with the specified ConnectionPointDirection.

Properties

Name | Description
ConnectionPointDirection | Gets or sets the ConnectionPointDirection which this IDataTemplateMatcher matches.
Template | Gets or sets the DataTemplate to be used for connection points with this ConnectionPointDirection.

See Also

ConnectionPointDirectionTemplate Class


ConnectionPointDirectionTemplate Constructor

[image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate Constructor
ConnectionPointDirectionTemplate Class See Also Send Feedback
Initializes a new instance of the ConnectionPointDirectionTemplate class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionPointDirectionTemplate()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionPointDirectionTemplate Class


ConnectionPointDirectionTemplate Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate Methods
ConnectionPointDirectionTemplate Class See Also Send Feedback

The ConnectionPointDirectionTemplate type exposes the following members.

Methods

Name | Description
Matches | Tests whether an object is a connection point with the specified ConnectionPointDirection.

See Also

ConnectionPointDirectionTemplate Class


Matches Method

[image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate..::.Matches Method
ConnectionPointDirectionTemplate Class See Also Send Feedback
Tests whether an object is a connection point with the specified ConnectionPointDirection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool Matches(
    Object item
)
Visual Basic (Declaration)
Public Function Matches ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The object to be tested.

Return Value

True if the object matches the criterion; otherwise false.

Implements

IDataTemplateMatcher..::.Matches(Object)

See Also

ConnectionPointDirectionTemplate Class


ConnectionPointDirectionTemplate Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate Properties
ConnectionPointDirectionTemplate Class See Also Send Feedback

The ConnectionPointDirectionTemplate type exposes the following members.

Properties

Name | Description
ConnectionPointDirection | Gets or sets the ConnectionPointDirection which this IDataTemplateMatcher matches.
Template | Gets or sets the DataTemplate to be used for connection points with this ConnectionPointDirection.

See Also

ConnectionPointDirectionTemplate Class


ConnectionPointDirection Property

[image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate..::.ConnectionPointDirection Property
ConnectionPointDirectionTemplate Class See Also Send Feedback
Gets or sets the ConnectionPointDirection which this IDataTemplateMatcher matches.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionPointDirection ConnectionPointDirection { get; set; }
Visual Basic (Declaration)
Public Property ConnectionPointDirection As ConnectionPointDirection

See Also

ConnectionPointDirectionTemplate Class


Template Property

[image]

Mindscape WPF Diagrams
ConnectionPointDirectionTemplate..::.Template Property
ConnectionPointDirectionTemplate Class See Also Send Feedback
Gets or sets the DataTemplate to be used for connection points with this ConnectionPointDirection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate Template { get; set; }
Visual Basic (Declaration)
Public Property Template As DataTemplate

Implements

IDataTemplateMatcher..::.Template

See Also

ConnectionPointDirectionTemplate Class


ConnectionPointPositionConverter Class

[image]

Mindscape WPF Diagrams
ConnectionPointPositionConverter Class
Members See Also Send Feedback
Determines a position from a connection point and an ILayout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionPointPositionConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class ConnectionPointPositionConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionPointPositionConverter

See Also

ConnectionPointPositionConverter Members


ConnectionPointPositionConverter Members

[image] [image]

Mindscape WPF Diagrams
ConnectionPointPositionConverter Members
ConnectionPointPositionConverter Class Constructors Methods See Also Send Feedback

The ConnectionPointPositionConverter type exposes the following members.

Constructors

Name | Description
ConnectionPointPositionConverter |

Methods

Name | Description
Convert | Determines a position from a connection point and an ILayout.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

ConnectionPointPositionConverter Class


ConnectionPointPositionConverter Constructor

[image]

Mindscape WPF Diagrams
ConnectionPointPositionConverter Constructor
ConnectionPointPositionConverter Class See Also Send Feedback
Initializes a new instance of the ConnectionPointPositionConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionPointPositionConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionPointPositionConverter Class


ConnectionPointPositionConverter Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionPointPositionConverter Methods
ConnectionPointPositionConverter Class See Also Send Feedback

The ConnectionPointPositionConverter type exposes the following members.

Methods

Name | Description
Convert | Determines a position from a connection point and an ILayout.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

ConnectionPointPositionConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ConnectionPointPositionConverter..::.Convert Method
ConnectionPointPositionConverter Class See Also Send Feedback
Determines a position from a connection point and an ILayout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The values produced by the binding sources. The converter expects two values: an IDiagramConnectionPoint and an ILayout.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A Point position.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

See Also

ConnectionPointPositionConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ConnectionPointPositionConverter..::.ConvertBack Method
ConnectionPointPositionConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The types to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

ConnectionPointPositionConverter Class


ConnectionPointShowFlags Enumeration

[image]

Mindscape WPF Diagrams
ConnectionPointShowFlags Enumeration
See Also Send Feedback
Describes which type of connection points should have their visibility changed.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[FlagsAttribute]
public enum ConnectionPointShowFlags
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ConnectionPointShowFlags

Members

Member name | Description
Inbound | Signifies that inbound connection points should have their visibility changed.
Outbound | Signifies that outbound connection points should have their visibility changed.

See Also


ConnectionPointThumb Class

[image]

Mindscape WPF Diagrams
ConnectionPointThumb Class
Members See Also Send Feedback
A control which can be dragged to create a connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionPointThumb : Thumb
Visual Basic (Declaration)
Public Class ConnectionPointThumb _
    Inherits Thumb

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.ConnectionPointThumb

See Also

ConnectionPointThumb Members


ConnectionPointThumb Members

[image] [image]

Mindscape WPF Diagrams
ConnectionPointThumb Members
ConnectionPointThumb Class Constructors Fields Properties See Also Send Feedback

The ConnectionPointThumb type exposes the following members.

Constructors

Name | Description
ConnectionPointThumb | Initializes a new instance of the ConnectionPointThumb class.

Fields

Name | Description
ConnectionPointProperty | Identifies the ConnectionPoint property.
IsFromConnectionDragOverProperty | Identifies the IsFromConnectionDragOver property.
IsToConnectionDragOverProperty | Identifies the IsToConnectionDragOver property.

Properties

Name | Description
ConnectionPoint | Gets or sets the connection point which the thumb represents. This is a dependency property.
IsFromConnectionDragOver | Gets whether or not the mouse is being dragged over the DiagramNodeElement of this connection point thumb allowing it to be displayed. This is useful for connection point validation UI. This is a dependency property.
IsToConnectionDragOver | Gets whether or not the mouse is being dragged over the DiagramNodeElement of this connection point thumb allowing it to be displayed. This is useful for connection point validation UI. This is a dependency property.

See Also

ConnectionPointThumb Class


ConnectionPointThumb Constructor

[image]

Mindscape WPF Diagrams
ConnectionPointThumb Constructor
ConnectionPointThumb Class See Also Send Feedback
Initializes a new instance of the ConnectionPointThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionPointThumb()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionPointThumb Class


ConnectionPointThumb Fields

[image] [image]

Mindscape WPF Diagrams
ConnectionPointThumb Fields
ConnectionPointThumb Class See Also Send Feedback

The ConnectionPointThumb type exposes the following members.

Fields

Name | Description
ConnectionPointProperty | Identifies the ConnectionPoint property.
IsFromConnectionDragOverProperty | Identifies the IsFromConnectionDragOver property.
IsToConnectionDragOverProperty | Identifies the IsToConnectionDragOver property.

See Also

ConnectionPointThumb Class


ConnectionPointProperty Field

[image]

Mindscape WPF Diagrams
ConnectionPointThumb..::.ConnectionPointProperty Field
ConnectionPointThumb Class See Also Send Feedback
Identifies the ConnectionPoint property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionPointProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionPointProperty As DependencyProperty

See Also

ConnectionPointThumb Class


IsFromConnectionDragOverProperty Field

[image]

Mindscape WPF Diagrams
ConnectionPointThumb..::.IsFromConnectionDragOverProperty Field
ConnectionPointThumb Class See Also Send Feedback
Identifies the IsFromConnectionDragOver property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsFromConnectionDragOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFromConnectionDragOverProperty As DependencyProperty

See Also

ConnectionPointThumb Class


IsToConnectionDragOverProperty Field

[image]

Mindscape WPF Diagrams
ConnectionPointThumb..::.IsToConnectionDragOverProperty Field
ConnectionPointThumb Class See Also Send Feedback
Identifies the IsToConnectionDragOver property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsToConnectionDragOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsToConnectionDragOverProperty As DependencyProperty

See Also

ConnectionPointThumb Class


ConnectionPointThumb Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionPointThumb Properties
ConnectionPointThumb Class See Also Send Feedback

The ConnectionPointThumb type exposes the following members.

Properties

Name | Description
ConnectionPoint | Gets or sets the connection point which the thumb represents. This is a dependency property.
IsFromConnectionDragOver | Gets whether or not the mouse is being dragged over the DiagramNodeElement of this connection point thumb allowing it to be displayed. This is useful for connection point validation UI. This is a dependency property.
IsToConnectionDragOver | Gets whether or not the mouse is being dragged over the DiagramNodeElement of this connection point thumb allowing it to be displayed. This is useful for connection point validation UI. This is a dependency property.

See Also

ConnectionPointThumb Class


ConnectionPoint Property

[image]

Mindscape WPF Diagrams
ConnectionPointThumb..::.ConnectionPoint Property
ConnectionPointThumb Class See Also Send Feedback
Gets or sets the connection point which the thumb represents. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint ConnectionPoint { get; set; }
Visual Basic (Declaration)
Public Property ConnectionPoint As IDiagramConnectionPoint

See Also

ConnectionPointThumb Class


IsFromConnectionDragOver Property

[image]

Mindscape WPF Diagrams
ConnectionPointThumb..::.IsFromConnectionDragOver Property
ConnectionPointThumb Class See Also Send Feedback
Gets whether or not the mouse is being dragged over the DiagramNodeElement of this connection point thumb allowing it to be displayed. This is useful for connection point validation UI. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsFromConnectionDragOver { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFromConnectionDragOver As Boolean

Remarks

Dependency Property Information
Identifier field | IsFromConnectionDragOverProperty
Metadata properties set to true | None

See Also

ConnectionPointThumb Class


IsToConnectionDragOver Property

[image]

Mindscape WPF Diagrams
ConnectionPointThumb..::.IsToConnectionDragOver Property
ConnectionPointThumb Class See Also Send Feedback
Gets whether or not the mouse is being dragged over the DiagramNodeElement of this connection point thumb allowing it to be displayed. This is useful for connection point validation UI. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsToConnectionDragOver { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsToConnectionDragOver As Boolean

Remarks

Dependency Property Information
Identifier field | IsToConnectionDragOverProperty
Metadata properties set to true | None

See Also

ConnectionPointThumb Class


ConnectionPointXCoordinateConverter Class

[image]

Mindscape WPF Diagrams
ConnectionPointXCoordinateConverter Class
Members See Also Send Feedback
Determines an X coordinate from a connection point and an ILayout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionPointXCoordinateConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class ConnectionPointXCoordinateConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionPointXCoordinateConverter

See Also

ConnectionPointXCoordinateConverter Members


ConnectionPointXCoordinateConverter Members

[image] [image]

Mindscape WPF Diagrams
ConnectionPointXCoordinateConverter Members
ConnectionPointXCoordinateConverter Class Constructors Methods See Also Send Feedback

The ConnectionPointXCoordinateConverter type exposes the following members.

Constructors

Name | Description
ConnectionPointXCoordinateConverter |

Methods

Name | Description
Convert | Determines an X coordinate from a connection point and an ILayout.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

See Also

ConnectionPointXCoordinateConverter Class


ConnectionPointXCoordinateConverter Constructor

[image]

Mindscape WPF Diagrams
ConnectionPointXCoordinateConverter Constructor
ConnectionPointXCoordinateConverter Class See Also Send Feedback
Initializes a new instance of the ConnectionPointXCoordinateConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionPointXCoordinateConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionPointXCoordinateConverter Class


ConnectionPointXCoordinateConverter Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionPointXCoordinateConverter Methods
ConnectionPointXCoordinateConverter Class See Also Send Feedback

The ConnectionPointXCoordinateConverter type exposes the following members.

Methods

Name | Description
Convert | Determines an X coordinate from a connection point and an ILayout.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

See Also

ConnectionPointXCoordinateConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ConnectionPointXCoordinateConverter..::.Convert Method
ConnectionPointXCoordinateConverter Class See Also Send Feedback
Determines an X coordinate from a connection point and an ILayout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The values produced by the binding sources. The converter expects two values: an IDiagramConnectionPoint and an ILayout.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The X coordinate of the connection point position.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

See Also

ConnectionPointXCoordinateConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ConnectionPointXCoordinateConverter..::.ConvertBack Method
ConnectionPointXCoordinateConverter Class See Also Send Feedback
Converts a value from a binding target for writing to multiple binding sources.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The types to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

ConnectionPointXCoordinateConverter Class


ConnectionPointYCoordinateConverter Class

[image]

Mindscape WPF Diagrams
ConnectionPointYCoordinateConverter Class
Members See Also Send Feedback
Determines a Y coordinate from a connection point and an ILayout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionPointYCoordinateConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class ConnectionPointYCoordinateConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionPointYCoordinateConverter

See Also

ConnectionPointYCoordinateConverter Members


ConnectionPointYCoordinateConverter Members

[image] [image]

Mindscape WPF Diagrams
ConnectionPointYCoordinateConverter Members
ConnectionPointYCoordinateConverter Class Constructors Methods See Also Send Feedback

The ConnectionPointYCoordinateConverter type exposes the following members.

Constructors

Name | Description
ConnectionPointYCoordinateConverter |

Methods

Name | Description
Convert | Determines a Y coordinate from a connection point and an ILayout.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

See Also

ConnectionPointYCoordinateConverter Class


ConnectionPointYCoordinateConverter Constructor

[image]

Mindscape WPF Diagrams
ConnectionPointYCoordinateConverter Constructor
ConnectionPointYCoordinateConverter Class See Also Send Feedback
Initializes a new instance of the ConnectionPointYCoordinateConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionPointYCoordinateConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionPointYCoordinateConverter Class


ConnectionPointYCoordinateConverter Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionPointYCoordinateConverter Methods
ConnectionPointYCoordinateConverter Class See Also Send Feedback

The ConnectionPointYCoordinateConverter type exposes the following members.

Methods

Name | Description
Convert | Determines a Y coordinate from a connection point and an ILayout.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

See Also

ConnectionPointYCoordinateConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ConnectionPointYCoordinateConverter..::.Convert Method
ConnectionPointYCoordinateConverter Class See Also Send Feedback
Determines a Y coordinate from a connection point and an ILayout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The values produced by the binding sources. The converter expects two values: an IDiagramConnectionPoint and an ILayout.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The Y coordinate of the connection point position.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

See Also

ConnectionPointYCoordinateConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ConnectionPointYCoordinateConverter..::.ConvertBack Method
ConnectionPointYCoordinateConverter Class See Also Send Feedback
Converts a value from a binding target for writing to multiple binding sources.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The types to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

ConnectionPointYCoordinateConverter Class


ConnectionRelocatedEventArgs Class

[image]

Mindscape WPF Diagrams
ConnectionRelocatedEventArgs Class
Members See Also Send Feedback
Provides information about the ConnectionRelocated event of a ConnectionRelocatorThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionRelocatedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class ConnectionRelocatedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.ConnectionRelocatedEventArgs

See Also

ConnectionRelocatedEventArgs Members


ConnectionRelocatedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatedEventArgs Members
ConnectionRelocatedEventArgs Class Constructors Properties See Also Send Feedback

The ConnectionRelocatedEventArgs type exposes the following members.

Constructors

Name | Description
ConnectionRelocatedEventArgs | Initializes a new instance of the ConnectionRelocatedEventArgs class.

Properties

Name | Description
Position | Gets the current position of the end of the DiagramConnectionElement that is being relocated.

See Also

ConnectionRelocatedEventArgs Class


ConnectionRelocatedEventArgs Constructor

[image]

Mindscape WPF Diagrams
ConnectionRelocatedEventArgs Constructor
ConnectionRelocatedEventArgs Class See Also Send Feedback
Initializes a new instance of the ConnectionRelocatedEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionRelocatedEventArgs(
    Point position
)
Visual Basic (Declaration)
Public Sub New ( _
    position As Point _
)

Parameters

position
Type: System.Windows..::.Point
The current position of the end of the DiagramConnectionElement that is being moved.

See Also

ConnectionRelocatedEventArgs Class


ConnectionRelocatedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatedEventArgs Properties
ConnectionRelocatedEventArgs Class See Also Send Feedback

The ConnectionRelocatedEventArgs type exposes the following members.

Properties

Name | Description
Position | Gets the current position of the end of the DiagramConnectionElement that is being relocated.

See Also

ConnectionRelocatedEventArgs Class


Position Property

[image]

Mindscape WPF Diagrams
ConnectionRelocatedEventArgs..::.Position Property
ConnectionRelocatedEventArgs Class See Also Send Feedback
Gets the current position of the end of the DiagramConnectionElement that is being relocated.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point Position { get; private set; }
Visual Basic (Declaration)
Public Property Position As Point

See Also

ConnectionRelocatedEventArgs Class


ConnectionRelocationInfo Class

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo Class
Members See Also Send Feedback
Holds information about performing a connection relocation action.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionRelocationInfo
Visual Basic (Declaration)
Public Class ConnectionRelocationInfo

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionRelocationInfo

See Also

ConnectionRelocationInfo Members


ConnectionRelocationInfo Members

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocationInfo Members
ConnectionRelocationInfo Class Constructors Properties See Also Send Feedback

The ConnectionRelocationInfo type exposes the following members.

Constructors

Name | Description
ConnectionRelocationInfo | Initializes a new instance of the ConnectionRelocationInfo class. The given IDiagramModel must contain the IDiagramConnection.

Properties

Name | Description
Connection | Gets the IDiagramConnection that is being relocated.
Model | Gets the IDiagramModel containing the IDiagramConnection that is being relocated.
NewDestination | Gets the requested new destination of the connection. This will be the same as the old destination if the destination end of the connection is not being relocated.
NewSource | Gets the requested new source of the connection. This will be the same as the old source if the source end of the connection is not being relocated.
OldDestination | Gets the old destination of the connection before the connection relocation action began.
OldSource | Gets the old source of the connection before the connection relocation action began.

See Also

ConnectionRelocationInfo Class


ConnectionRelocationInfo Constructor

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo Constructor
ConnectionRelocationInfo Class See Also Send Feedback
Initializes a new instance of the ConnectionRelocationInfo class. The given IDiagramModel must contain the IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionRelocationInfo(
    IDiagramModel model,
    IDiagramConnection connection,
    IDiagramConnectionPoint newSource,
    IDiagramConnectionPoint newDestination,
    IDiagramConnectionPoint oldSource,
    IDiagramConnectionPoint oldDestination
)
Visual Basic (Declaration)
Public Sub New ( _
    model As IDiagramModel, _
    connection As IDiagramConnection, _
    newSource As IDiagramConnectionPoint, _
    newDestination As IDiagramConnectionPoint, _
    oldSource As IDiagramConnectionPoint, _
    oldDestination As IDiagramConnectionPoint _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel containing the given IDiagramConnection to be relocated.
connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to be relocated.
newSource
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The new source of the connection. This may be the same as the old source.
newDestination
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The new destination of the connection. This may be the same as the old destination.
oldSource
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The old source of the connection before starting the relocation.
oldDestination
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The old destination of the connection before starting the relocation.

See Also

ConnectionRelocationInfo Class


ConnectionRelocationInfo Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocationInfo Properties
ConnectionRelocationInfo Class See Also Send Feedback

The ConnectionRelocationInfo type exposes the following members.

Properties

Name | Description
Connection | Gets the IDiagramConnection that is being relocated.
Model | Gets the IDiagramModel containing the IDiagramConnection that is being relocated.
NewDestination | Gets the requested new destination of the connection. This will be the same as the old destination if the destination end of the connection is not being relocated.
NewSource | Gets the requested new source of the connection. This will be the same as the old source if the source end of the connection is not being relocated.
OldDestination | Gets the old destination of the connection before the connection relocation action began.
OldSource | Gets the old source of the connection before the connection relocation action began.

See Also

ConnectionRelocationInfo Class


Connection Property

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo..::.Connection Property
ConnectionRelocationInfo Class See Also Send Feedback
Gets the IDiagramConnection that is being relocated.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnection Connection { get; private set; }
Visual Basic (Declaration)
Public Property Connection As IDiagramConnection

See Also

ConnectionRelocationInfo Class


Model Property

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo..::.Model Property
ConnectionRelocationInfo Class See Also Send Feedback
Gets the IDiagramModel containing the IDiagramConnection that is being relocated.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramModel Model { get; private set; }
Visual Basic (Declaration)
Public Property Model As IDiagramModel

See Also

ConnectionRelocationInfo Class


NewDestination Property

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo..::.NewDestination Property
ConnectionRelocationInfo Class See Also Send Feedback
Gets the requested new destination of the connection. This will be the same as the old destination if the destination end of the connection is not being relocated.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint NewDestination { get; private set; }
Visual Basic (Declaration)
Public Property NewDestination As IDiagramConnectionPoint

See Also

ConnectionRelocationInfo Class


NewSource Property

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo..::.NewSource Property
ConnectionRelocationInfo Class See Also Send Feedback
Gets the requested new source of the connection. This will be the same as the old source if the source end of the connection is not being relocated.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint NewSource { get; private set; }
Visual Basic (Declaration)
Public Property NewSource As IDiagramConnectionPoint

See Also

ConnectionRelocationInfo Class


OldDestination Property

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo..::.OldDestination Property
ConnectionRelocationInfo Class See Also Send Feedback
Gets the old destination of the connection before the connection relocation action began.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint OldDestination { get; private set; }
Visual Basic (Declaration)
Public Property OldDestination As IDiagramConnectionPoint

See Also

ConnectionRelocationInfo Class


OldSource Property

[image]

Mindscape WPF Diagrams
ConnectionRelocationInfo..::.OldSource Property
ConnectionRelocationInfo Class See Also Send Feedback
Gets the old source of the connection before the connection relocation action began.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint OldSource { get; private set; }
Visual Basic (Declaration)
Public Property OldSource As IDiagramConnectionPoint

See Also

ConnectionRelocationInfo Class


ConnectionRelocatorThumb Class

[image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb Class
Members See Also Send Feedback

Enables and manages relocation of either end of an IDiagramConnection and the DiagramConnectionElement that graphically represents it. That is, this thumb modifies either the ToConnectionPoint or the FromConnectionPoint properties of the connection that this thumb is assigned to.

The position of the end of the connection being relocated is dynamically changed as the mouse is dragged allowing for a rubberbanding effect. This thumb can relocate either the 'to' or 'from' connection point to another connection point mounted on either an IDiagramNode or an IDiagramConnection that the mouse is over when released. If the mouse is released over nothing, then the connection being relocated is put back to its original connection points.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionRelocatorThumb : Thumb
Visual Basic (Declaration)
Public Class ConnectionRelocatorThumb _
    Inherits Thumb

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.ConnectionRelocatorThumb

See Also

ConnectionRelocatorThumb Members


ConnectionRelocatorThumb Members

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb Members
ConnectionRelocatorThumb Class Constructors Fields Properties Events See Also Send Feedback

The ConnectionRelocatorThumb type exposes the following members.

Constructors

Name | Description
ConnectionRelocatorThumb | Initializes a new instance of the ConnectionRelocatorThumb class.

Fields

Name | Description
ConnectionElementProperty | Identifies the ConnectionElement property.
ConnectionRelocatedEvent | Identifies the ConnectionRelocated routed event.

Properties

Name | Description
ConnectionElement | Gets or sets the ConnectionElement. This is a dependency property.
MovingEnd | Gets or sets which end of the connection is being moved by this ConnectionRelocatorThumb.

Events

Name | Description
ConnectionRelocated | Occurs whenever the ConnectionRelocatorThumb is dragging the end of a connection around.

See Also

ConnectionRelocatorThumb Class


ConnectionRelocatorThumb Constructor

[image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb Constructor
ConnectionRelocatorThumb Class See Also Send Feedback
Initializes a new instance of the ConnectionRelocatorThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionRelocatorThumb()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionRelocatorThumb Class


ConnectionRelocatorThumb Fields

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb Fields
ConnectionRelocatorThumb Class See Also Send Feedback

The ConnectionRelocatorThumb type exposes the following members.

Fields

Name | Description
ConnectionElementProperty | Identifies the ConnectionElement property.
ConnectionRelocatedEvent | Identifies the ConnectionRelocated routed event.

See Also

ConnectionRelocatorThumb Class


ConnectionElementProperty Field

[image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb..::.ConnectionElementProperty Field
ConnectionRelocatorThumb Class See Also Send Feedback
Identifies the ConnectionElement property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionElementProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionElementProperty As DependencyProperty

See Also

ConnectionRelocatorThumb Class


ConnectionRelocatedEvent Field

[image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb..::.ConnectionRelocatedEvent Field
ConnectionRelocatorThumb Class See Also Send Feedback
Identifies the ConnectionRelocated routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent ConnectionRelocatedEvent
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionRelocatedEvent As RoutedEvent

See Also

ConnectionRelocatorThumb Class


ConnectionRelocatorThumb Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb Properties
ConnectionRelocatorThumb Class See Also Send Feedback

The ConnectionRelocatorThumb type exposes the following members.

Properties

Name | Description
ConnectionElement | Gets or sets the ConnectionElement. This is a dependency property.
MovingEnd | Gets or sets which end of the connection is being moved by this ConnectionRelocatorThumb.

See Also

ConnectionRelocatorThumb Class


ConnectionElement Property

[image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb..::.ConnectionElement Property
ConnectionRelocatorThumb Class See Also Send Feedback
Gets or sets the ConnectionElement. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionElement ConnectionElement { get; set; }
Visual Basic (Declaration)
Public Property ConnectionElement As DiagramConnectionElement

Remarks

Dependency Property Information
Identifier field | ConnectionElementProperty
Metadata properties set to true | None

See Also

ConnectionRelocatorThumb Class


MovingEnd Property

[image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb..::.MovingEnd Property
ConnectionRelocatorThumb Class See Also Send Feedback
Gets or sets which end of the connection is being moved by this ConnectionRelocatorThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionEnd MovingEnd { get; set; }
Visual Basic (Declaration)
Public Property MovingEnd As ConnectionEnd

Remarks

Changing this property while the thumb is being dragged results in an InvalidOperationException.

See Also

ConnectionRelocatorThumb Class


ConnectionRelocatorThumb Events

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb Events
ConnectionRelocatorThumb Class See Also Send Feedback

The ConnectionRelocatorThumb type exposes the following members.

Events

Name | Description
ConnectionRelocated | Occurs whenever the ConnectionRelocatorThumb is dragging the end of a connection around.

See Also

ConnectionRelocatorThumb Class


ConnectionRelocated Event

[image]

Mindscape WPF Diagrams
ConnectionRelocatorThumb..::.ConnectionRelocated Event
ConnectionRelocatorThumb Class See Also Send Feedback
Occurs whenever the ConnectionRelocatorThumb is dragging the end of a connection around.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<SizedEventArgs> ConnectionRelocated
Visual Basic (Declaration)
Public Event ConnectionRelocated As EventHandler(Of SizedEventArgs)

See Also

ConnectionRelocatorThumb Class


ConnectionSegmentThumb Class

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb Class
Members See Also Send Feedback
Enables horizontal or vertical movement of a single MovableDiagramConnectionSegment. Note that a ConnectionSegmentThumb only allows horizontal or vertical segments to be moved.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionSegmentThumb : Thumb
Visual Basic (Declaration)
Public Class ConnectionSegmentThumb _
    Inherits Thumb

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.ConnectionSegmentThumb

See Also

ConnectionSegmentThumb Members


ConnectionSegmentThumb Members

[image] [image]

Mindscape WPF Diagrams
ConnectionSegmentThumb Members
ConnectionSegmentThumb Class Constructors Fields Properties Events See Also Send Feedback

The ConnectionSegmentThumb type exposes the following members.

Constructors

Name | Description
ConnectionSegmentThumb | Initializes a new instance of the ConnectionSegmentThumb class.

Fields

Name | Description
ConnectionSegmentProperty | Identifies the ConnectionSegment property.
QuerySegmentDragEvent | Identifies the QuerySegmentPosition routed event.
SegmentMovedEvent | Identifies the SegmentMoved routed event.

Properties

Name | Description
ConnectionSegment | Gets or sets the MovableDiagramConnectionSegment that this ConnectionSegmentThumb can move. This is a dependency property.

Events

Name | Description
QuerySegmentPosition | Occurs when QueryDropPosition happens.
SegmentMoved | Occurs when the ConnectionSegmentThumb is moved.

See Also

ConnectionSegmentThumb Class


ConnectionSegmentThumb Constructor

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb Constructor
ConnectionSegmentThumb Class See Also Send Feedback
Initializes a new instance of the ConnectionSegmentThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionSegmentThumb()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionSegmentThumb Class


ConnectionSegmentThumb Fields

[image] [image]

Mindscape WPF Diagrams
ConnectionSegmentThumb Fields
ConnectionSegmentThumb Class See Also Send Feedback

The ConnectionSegmentThumb type exposes the following members.

Fields

Name | Description
ConnectionSegmentProperty | Identifies the ConnectionSegment property.
QuerySegmentDragEvent | Identifies the QuerySegmentPosition routed event.
SegmentMovedEvent | Identifies the SegmentMoved routed event.

See Also

ConnectionSegmentThumb Class


ConnectionSegmentProperty Field

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb..::.ConnectionSegmentProperty Field
ConnectionSegmentThumb Class See Also Send Feedback
Identifies the ConnectionSegment property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionSegmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionSegmentProperty As DependencyProperty

See Also

ConnectionSegmentThumb Class


QuerySegmentDragEvent Field

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb..::.QuerySegmentDragEvent Field
ConnectionSegmentThumb Class See Also Send Feedback
Identifies the QuerySegmentPosition routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent QuerySegmentDragEvent
Visual Basic (Declaration)
Public Shared ReadOnly QuerySegmentDragEvent As RoutedEvent

See Also

ConnectionSegmentThumb Class


SegmentMovedEvent Field

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb..::.SegmentMovedEvent Field
ConnectionSegmentThumb Class See Also Send Feedback
Identifies the SegmentMoved routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent SegmentMovedEvent
Visual Basic (Declaration)
Public Shared ReadOnly SegmentMovedEvent As RoutedEvent

See Also

ConnectionSegmentThumb Class


ConnectionSegmentThumb Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionSegmentThumb Properties
ConnectionSegmentThumb Class See Also Send Feedback

The ConnectionSegmentThumb type exposes the following members.

Properties

Name | Description
ConnectionSegment | Gets or sets the MovableDiagramConnectionSegment that this ConnectionSegmentThumb can move. This is a dependency property.

See Also

ConnectionSegmentThumb Class


ConnectionSegment Property

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb..::.ConnectionSegment Property
ConnectionSegmentThumb Class See Also Send Feedback
Gets or sets the MovableDiagramConnectionSegment that this ConnectionSegmentThumb can move. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MovableDiagramConnectionSegment ConnectionSegment { get; set; }
Visual Basic (Declaration)
Public Property ConnectionSegment As MovableDiagramConnectionSegment

Remarks

Dependency Property Information
Identifier field | ConnectionSegmentProperty
Metadata properties set to true | None

See Also

ConnectionSegmentThumb Class


ConnectionSegmentThumb Events

[image] [image]

Mindscape WPF Diagrams
ConnectionSegmentThumb Events
ConnectionSegmentThumb Class See Also Send Feedback

The ConnectionSegmentThumb type exposes the following members.

Events

Name | Description
QuerySegmentPosition | Occurs when QueryDropPosition happens.
SegmentMoved | Occurs when the ConnectionSegmentThumb is moved.

See Also

ConnectionSegmentThumb Class


QuerySegmentPosition Event

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb..::.QuerySegmentPosition Event
ConnectionSegmentThumb Class See Also Send Feedback
Occurs when QueryDropPosition happens.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<QuerySegmentDragEventArgs> QuerySegmentPosition
Visual Basic (Declaration)
Public Event QuerySegmentPosition As EventHandler(Of QuerySegmentDragEventArgs)

See Also

ConnectionSegmentThumb Class


SegmentMoved Event

[image]

Mindscape WPF Diagrams
ConnectionSegmentThumb..::.SegmentMoved Event
ConnectionSegmentThumb Class See Also Send Feedback
Occurs when the ConnectionSegmentThumb is moved.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<SegmentMovedEventArgs> SegmentMoved
Visual Basic (Declaration)
Public Event SegmentMoved As EventHandler(Of SegmentMovedEventArgs)

See Also

ConnectionSegmentThumb Class


ConnectionState Class

[image]

Mindscape WPF Diagrams
ConnectionState Class
Members See Also Send Feedback
A standard implementation of IDiagramConnectionState that can store property values of the properties found in the IDiagramConnection interface. This ConnectionState will store the following property values of the given IDiagramConnection: Data, FromConnectionPoint, ToConnectionPoint, Segments, IsUserModified, and ConnectionPoints. Note that a ConnectionState clones the DiagramConnectionSegment objects in the Segments property, but all other property values are stored by refference.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionState : IDiagramConnectionState
Visual Basic (Declaration)
Public Class ConnectionState _
    Implements IDiagramConnectionState

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionState
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionState

See Also

ConnectionState Members


ConnectionState Members

[image] [image]

Mindscape WPF Diagrams
ConnectionState Members
ConnectionState Class Constructors Methods Properties See Also Send Feedback

The ConnectionState type exposes the following members.

Constructors

Name | Description
ConnectionState | Initializes a new instance of the ConnectionState class.

Methods

Name | Description
Apply | Modifies the Data, FromConnectionPoint, ToConnectionPoint, Segments, IsUserModified, and ConnectionPoints properties of the given IDiagramConnection to match the property values stored by this ConnectionState. Note that because Data is a readonly property on IDiagramConnection, this method can not set it, and so if neccessary, the IDiagramConnection.SetAs method should be responsible for this.

Properties

Name | Description
Data | Gets the data associated with this state of the connection.

See Also

ConnectionState Class


ConnectionState Constructor

[image]

Mindscape WPF Diagrams
ConnectionState Constructor
ConnectionState Class See Also Send Feedback
Initializes a new instance of the ConnectionState class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionState(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Sub New ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
An IDiagramConnection that this ConnectionState copies the properties from.

See Also

ConnectionState Class


ConnectionState Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionState Methods
ConnectionState Class See Also Send Feedback

The ConnectionState type exposes the following members.

Methods

Name | Description
Apply | Modifies the Data, FromConnectionPoint, ToConnectionPoint, Segments, IsUserModified, and ConnectionPoints properties of the given IDiagramConnection to match the property values stored by this ConnectionState. Note that because Data is a readonly property on IDiagramConnection, this method can not set it, and so if neccessary, the IDiagramConnection.SetAs method should be responsible for this.

See Also

ConnectionState Class


Apply Method

[image]

Mindscape WPF Diagrams
ConnectionState..::.Apply Method
ConnectionState Class See Also Send Feedback
Modifies the Data, FromConnectionPoint, ToConnectionPoint, Segments, IsUserModified, and ConnectionPoints properties of the given IDiagramConnection to match the property values stored by this ConnectionState. Note that because Data is a readonly property on IDiagramConnection, this method can not set it, and so if neccessary, the IDiagramConnection.SetAs method should be responsible for this.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void Apply(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overridable Sub Apply ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection that will have its properties modified by this ConnectionState.

Implements

IDiagramConnectionState..::.Apply(IDiagramConnection)

See Also

ConnectionState Class


ConnectionState Properties

[image] [image]

Mindscape WPF Diagrams
ConnectionState Properties
ConnectionState Class See Also Send Feedback

The ConnectionState type exposes the following members.

Properties

Name | Description
Data | Gets the data associated with this state of the connection.

See Also

ConnectionState Class


Data Property

[image]

Mindscape WPF Diagrams
ConnectionState..::.Data Property
ConnectionState Class See Also Send Feedback
Gets the data associated with this state of the connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Data { get; private set; }
Visual Basic (Declaration)
Public Property Data As Object

Implements

IDiagramConnectionState..::.Data

See Also

ConnectionState Class


CorneredPathBuilder Class

[image]

Mindscape WPF Diagrams
CorneredPathBuilder Class
Members See Also Send Feedback
Constructs a PathGeometry from a list of DiagramConnectionSegment objects, applying curved or bevelled corners.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class CorneredPathBuilder : PathBuilderBase
Visual Basic (Declaration)
Public Class CorneredPathBuilder _
    Inherits PathBuilderBase

Remarks

The CorneredPathBuilder softens the corners between adjacent segments, creating curved or bevelled corners in the generated geometry according to the CornerType and CornerRadius properties.

If displaying an arrowhead on the connection, you may need to set up the StartOffset, EndOffset and ArrowLength properties. The StartOffset and EndOffset properties tell the CorneredPathBuilder not to run the path geometry all the way to the end of the first or last segment. This is important for wide connections to prevent them from poking out from under the arrow graphic. The ArrowLength property tells the CorneredPathBuilder the length of the arrow so that it does not curve or bevel a corner in such a way as to overlap the arrow.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.PathBuilderBase
Mindscape.WpfDiagramming.Foundation..::.CorneredPathBuilder

See Also

CorneredPathBuilder Members


CorneredPathBuilder Members

[image] [image]

Mindscape WPF Diagrams
CorneredPathBuilder Members
CorneredPathBuilder Class Constructors Methods Properties See Also Send Feedback

The CorneredPathBuilder type exposes the following members.

Constructors

Name | Description
CorneredPathBuilder | Initializes a new instance of the CorneredPathBuilder class.

Methods

Name | Description
BuildPath | Returns a PathGeometry based on the given connection segment data. (Inherited from PathBuilderBase.)
CreateMultiSegmentFigure | Creates the PathFigure representing a path for the specified segments. (Overrides PathBuilderBase ..::. CreateMultiSegmentFigure(Collection<(Of <(DiagramConnectionSegment>)>)).)

Properties

Name | Description
ArrowLength | Gets or sets the length of the arrow head. The CorneredPathBuilder uses this to suppress cornering geometries that would overlap the arrow.
CornerRadius | Gets or sets the radius of the corners. This specifies how large the curve or bevel of each corner is. This value should be less than or equal to the SegmentEndBuffer property; for optimum visual results, it should be equal to the SegmentEndBuffer.
CornerType | Gets or sets the way that this CorneredPathBuilder creates the geometries for the corner points of a connection path.
EndOffset | Gets or sets how much to cut off the end of the segment. This is used when an arrow is displayed on the connection, so that a wide path does not show around the sides of the arrow.
StartOffset | Gets or sets how much to cut off the start of the segment. This is used when an arrow is displayed on the connection, so that a wide path does not show around the sides of the arrow.

See Also

CorneredPathBuilder Class


CorneredPathBuilder Constructor

[image]

Mindscape WPF Diagrams
CorneredPathBuilder Constructor
CorneredPathBuilder Class See Also Send Feedback
Initializes a new instance of the CorneredPathBuilder class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CorneredPathBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

CorneredPathBuilder Class


CorneredPathBuilder Methods

[image] [image]

Mindscape WPF Diagrams
CorneredPathBuilder Methods
CorneredPathBuilder Class See Also Send Feedback

The CorneredPathBuilder type exposes the following members.

Methods

Name | Description
BuildPath | Returns a PathGeometry based on the given connection segment data. (Inherited from PathBuilderBase.)
CreateMultiSegmentFigure | Creates the PathFigure representing a path for the specified segments. (Overrides PathBuilderBase ..::. CreateMultiSegmentFigure(Collection<(Of <(DiagramConnectionSegment>)>)).)

See Also

CorneredPathBuilder Class


CreateMultiSegmentFigure Method

[image]

Mindscape WPF Diagrams
CorneredPathBuilder..::.CreateMultiSegmentFigure Method
CorneredPathBuilder Class See Also Send Feedback
Creates the PathFigure representing a path for the specified segments.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override PathFigure CreateMultiSegmentFigure(
    Collection<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Protected Overrides Function CreateMultiSegmentFigure ( _
    segments As Collection(Of DiagramConnectionSegment) _
) As PathFigure

Parameters

segments
Type: System.Collections.ObjectModel..::.Collection <(Of <( DiagramConnectionSegment >)>)
The connection segments.

Return Value

A PathFigure representing the connection path.

See Also

CorneredPathBuilder Class


CorneredPathBuilder Properties

[image] [image]

Mindscape WPF Diagrams
CorneredPathBuilder Properties
CorneredPathBuilder Class See Also Send Feedback

The CorneredPathBuilder type exposes the following members.

Properties

Name | Description
ArrowLength | Gets or sets the length of the arrow head. The CorneredPathBuilder uses this to suppress cornering geometries that would overlap the arrow.
CornerRadius | Gets or sets the radius of the corners. This specifies how large the curve or bevel of each corner is. This value should be less than or equal to the SegmentEndBuffer property; for optimum visual results, it should be equal to the SegmentEndBuffer.
CornerType | Gets or sets the way that this CorneredPathBuilder creates the geometries for the corner points of a connection path.
EndOffset | Gets or sets how much to cut off the end of the segment. This is used when an arrow is displayed on the connection, so that a wide path does not show around the sides of the arrow.
StartOffset | Gets or sets how much to cut off the start of the segment. This is used when an arrow is displayed on the connection, so that a wide path does not show around the sides of the arrow.

See Also

CorneredPathBuilder Class


ArrowLength Property

[image]

Mindscape WPF Diagrams
CorneredPathBuilder..::.ArrowLength Property
CorneredPathBuilder Class See Also Send Feedback
Gets or sets the length of the arrow head. The CorneredPathBuilder uses this to suppress cornering geometries that would overlap the arrow.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double ArrowLength { get; set; }
Visual Basic (Declaration)
Public Property ArrowLength As Double

See Also

CorneredPathBuilder Class


CornerRadius Property

[image]

Mindscape WPF Diagrams
CorneredPathBuilder..::.CornerRadius Property
CorneredPathBuilder Class See Also Send Feedback
Gets or sets the radius of the corners. This specifies how large the curve or bevel of each corner is. This value should be less than or equal to the SegmentEndBuffer property; for optimum visual results, it should be equal to the SegmentEndBuffer.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double CornerRadius { get; set; }
Visual Basic (Declaration)
Public Property CornerRadius As Double

Remarks

If CornerRadius is not equal to SegmentEndBuffer, then you may see 'floating' corners on connections that are mounted to other connections.

See Also

CorneredPathBuilder Class


CornerType Property

[image]

Mindscape WPF Diagrams
CorneredPathBuilder..::.CornerType Property
CorneredPathBuilder Class See Also Send Feedback
Gets or sets the way that this CorneredPathBuilder creates the geometries for the corner points of a connection path.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CornerType CornerType { get; set; }
Visual Basic (Declaration)
Public Property CornerType As CornerType

See Also

CorneredPathBuilder Class


EndOffset Property

[image]

Mindscape WPF Diagrams
CorneredPathBuilder..::.EndOffset Property
CorneredPathBuilder Class See Also Send Feedback
Gets or sets how much to cut off the end of the segment. This is used when an arrow is displayed on the connection, so that a wide path does not show around the sides of the arrow.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double EndOffset { get; set; }
Visual Basic (Declaration)
Public Property EndOffset As Double

See Also

CorneredPathBuilder Class


StartOffset Property

[image]

Mindscape WPF Diagrams
CorneredPathBuilder..::.StartOffset Property
CorneredPathBuilder Class See Also Send Feedback
Gets or sets how much to cut off the start of the segment. This is used when an arrow is displayed on the connection, so that a wide path does not show around the sides of the arrow.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double StartOffset { get; set; }
Visual Basic (Declaration)
Public Property StartOffset As Double

See Also

CorneredPathBuilder Class


CornerType Enumeration

[image]

Mindscape WPF Diagrams
CornerType Enumeration
See Also Send Feedback
Represents the style of a corner.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum CornerType
Visual Basic (Declaration)
Public Enumeration CornerType

Members

Member name | Description
Bevel | A beveled corner type.
Curve | A curved corner type.

See Also


CreateConnectionCursorAction Class

[image]

Mindscape WPF Diagrams
CreateConnectionCursorAction Class
Members See Also Send Feedback
Represents the cursor action to create a connection using a "connection" toolbox item. This action is typically used only when a diagram contains multiple types of connection -- for example, an entity diagram which contains both inheritance and association relationships.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class CreateConnectionCursorAction : ToolCursorAction<DiagramConnectionTool>
Visual Basic (Declaration)
Public Class CreateConnectionCursorAction _
    Inherits ToolCursorAction(Of DiagramConnectionTool)

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.CursorAction
Mindscape.WpfDiagramming.Foundation..::.ToolCursorAction <(Of <( DiagramConnectionTool >)>)
Mindscape.WpfDiagramming.Foundation..::.CreateConnectionCursorAction

See Also

CreateConnectionCursorAction Members


CreateConnectionCursorAction Members

[image] [image]

Mindscape WPF Diagrams
CreateConnectionCursorAction Members
CreateConnectionCursorAction Class Constructors Methods Properties See Also Send Feedback

The CreateConnectionCursorAction type exposes the following members.

Constructors

Name | Description
CreateConnectionCursorAction | Initializes a new instance of the CreateConnectionCursorAction class.

Methods

Name | Description
Discharge | Disassociates the toolbox item from the cursor. (Inherited from ToolCursorAction<(Of <(TTool>)>).)
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action. (Inherited from CursorAction.)
ExecuteCore | Executes the cursor action. (Overrides CursorAction ..::. ExecuteCore(DiagramSurface, MouseButtonEventArgs).)

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction. (Overrides CursorAction ..::. CursorActionType.)
Tool | Gets the tool associated with the cursor action. (Inherited from ToolCursorAction<(Of <(TTool>)>).)

See Also

CreateConnectionCursorAction Class


CreateConnectionCursorAction Constructor

[image]

Mindscape WPF Diagrams
CreateConnectionCursorAction Constructor
CreateConnectionCursorAction Class See Also Send Feedback
Initializes a new instance of the CreateConnectionCursorAction class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CreateConnectionCursorAction(
    DiagramConnectionTool tool
)
Visual Basic (Declaration)
Public Sub New ( _
    tool As DiagramConnectionTool _
)

Parameters

tool
Type: Mindscape.WpfDiagramming..::.DiagramConnectionTool
The DiagramConnectionTool associated with the cursor action.

See Also

CreateConnectionCursorAction Class


CreateConnectionCursorAction Methods

[image] [image]

Mindscape WPF Diagrams
CreateConnectionCursorAction Methods
CreateConnectionCursorAction Class See Also Send Feedback

The CreateConnectionCursorAction type exposes the following members.

Methods

Name | Description
Discharge | Disassociates the toolbox item from the cursor. (Inherited from ToolCursorAction<(Of <(TTool>)>).)
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action. (Inherited from CursorAction.)
ExecuteCore | Executes the cursor action. (Overrides CursorAction ..::. ExecuteCore(DiagramSurface, MouseButtonEventArgs).)

See Also

CreateConnectionCursorAction Class


ExecuteCore Method

[image]

Mindscape WPF Diagrams
CreateConnectionCursorAction..::.ExecuteCore Method
CreateConnectionCursorAction Class See Also Send Feedback
Executes the cursor action.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void ExecuteCore(
    DiagramSurface surface,
    MouseButtonEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub ExecuteCore ( _
    surface As DiagramSurface, _
    eventArgs As MouseButtonEventArgs _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface on which to execute the action.
eventArgs
Type: System.Windows.Input..::.MouseButtonEventArgs
The event data associated with the mouse action.

See Also

CreateConnectionCursorAction Class


CreateConnectionCursorAction Properties

[image] [image]

Mindscape WPF Diagrams
CreateConnectionCursorAction Properties
CreateConnectionCursorAction Class See Also Send Feedback

The CreateConnectionCursorAction type exposes the following members.

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction. (Overrides CursorAction ..::. CursorActionType.)
Tool | Gets the tool associated with the cursor action. (Inherited from ToolCursorAction<(Of <(TTool>)>).)

See Also

CreateConnectionCursorAction Class


CursorActionType Property

[image]

Mindscape WPF Diagrams
CreateConnectionCursorAction..::.CursorActionType Property
CreateConnectionCursorAction Class See Also Send Feedback
Gets the type of operation performed by this CursorAction.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override CursorActionType CursorActionType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CursorActionType As CursorActionType

See Also

CreateConnectionCursorAction Class


CursorAction Class

[image]

Mindscape WPF Diagrams
CursorAction Class
Members See Also Send Feedback
Represents an action associated with the cursor, such as a "charged cursor" for click-and-drop interaction.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class CursorAction
Visual Basic (Declaration)
Public MustInherit Class CursorAction

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.CursorAction
Mindscape.WpfDiagramming.Foundation..::.DefaultCursorAction
Mindscape.WpfDiagramming.Foundation..::.ToolCursorAction<(Of <(TTool>)>)

See Also

CursorAction Members


CursorAction Members

[image] [image]

Mindscape WPF Diagrams
CursorAction Members
CursorAction Class Constructors Methods Fields Properties See Also Send Feedback

The CursorAction type exposes the following members.

Constructors

Name | Description
CursorAction |

Methods

Name | Description
Discharge | Disassociates the cursor action from the cursor.
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action.
ExecuteCore | When overridden in a derived class, executes the cursor action.
GetCurrent | Gets the value of the Current attached property for an object.
SetCurrent | Sets the value of the Current attached property for an object.

Fields

Name | Description
CurrentProperty | Gets or sets the action associated with the cursor when it is over a DiagramSurface.
Default | Gets the default cursor action (marquee select).

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction.

See Also

CursorAction Class


CursorAction Constructor

[image]

Mindscape WPF Diagrams
CursorAction Constructor
CursorAction Class See Also Send Feedback
Initializes a new instance of the CursorAction class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected CursorAction()
Visual Basic (Declaration)
Protected Sub New

See Also

CursorAction Class


CursorAction Fields

[image] [image]

Mindscape WPF Diagrams
CursorAction Fields
CursorAction Class See Also Send Feedback

The CursorAction type exposes the following members.

Fields

Name | Description
CurrentProperty | Gets or sets the action associated with the cursor when it is over a DiagramSurface.
Default | Gets the default cursor action (marquee select).

See Also

CursorAction Class


CurrentProperty Field

[image]

Mindscape WPF Diagrams
CursorAction..::.CurrentProperty Field
CursorAction Class See Also Send Feedback
Gets or sets the action associated with the cursor when it is over a DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CurrentProperty
Visual Basic (Declaration)
Public Shared ReadOnly CurrentProperty As DependencyProperty

See Also

CursorAction Class


Default Field

[image]

Mindscape WPF Diagrams
CursorAction..::.Default Field
CursorAction Class See Also Send Feedback
Gets the default cursor action (marquee select).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly CursorAction Default
Visual Basic (Declaration)
Public Shared ReadOnly Default As CursorAction

See Also

CursorAction Class


CursorAction Methods

[image] [image]

Mindscape WPF Diagrams
CursorAction Methods
CursorAction Class See Also Send Feedback

The CursorAction type exposes the following members.

Methods

Name | Description
Discharge | Disassociates the cursor action from the cursor.
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action.
ExecuteCore | When overridden in a derived class, executes the cursor action.
GetCurrent | Gets the value of the Current attached property for an object.
SetCurrent | Sets the value of the Current attached property for an object.

See Also

CursorAction Class


Discharge Method

[image]

Mindscape WPF Diagrams
CursorAction..::.Discharge Method
CursorAction Class See Also Send Feedback
Disassociates the cursor action from the cursor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void Discharge()
Visual Basic (Declaration)
Public Overridable Sub Discharge

See Also

CursorAction Class


Execute Method

[image]

Mindscape WPF Diagrams
CursorAction..::.Execute Method
CursorAction Class See Also Send Feedback
Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Execute(
    DiagramSurface surface,
    MouseButtonEventArgs eventArgs
)
Visual Basic (Declaration)
Public Sub Execute ( _
    surface As DiagramSurface, _
    eventArgs As MouseButtonEventArgs _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface on which to execute the action.
eventArgs
Type: System.Windows.Input..::.MouseButtonEventArgs
The event data associated with the mouse action.

See Also

CursorAction Class


ExecuteCore Method

[image]

Mindscape WPF Diagrams
CursorAction..::.ExecuteCore Method
CursorAction Class See Also Send Feedback
When overridden in a derived class, executes the cursor action.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract void ExecuteCore(
    DiagramSurface surface,
    MouseButtonEventArgs eventArgs
)
Visual Basic (Declaration)
Protected MustOverride Sub ExecuteCore ( _
    surface As DiagramSurface, _
    eventArgs As MouseButtonEventArgs _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface on which to execute the action.
eventArgs
Type: System.Windows.Input..::.MouseButtonEventArgs
The event data associated with the mouse action.

See Also

CursorAction Class


GetCurrent Method

[image]

Mindscape WPF Diagrams
CursorAction..::.GetCurrent Method
CursorAction Class See Also Send Feedback
Gets the value of the Current attached property for an object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static CursorAction GetCurrent(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetCurrent ( _
    obj As DependencyObject _
) As CursorAction

Parameters

obj
Type: System.Windows..::.DependencyObject
The object from which the property value is read.

Return Value

The object's Current property value.

See Also

CursorAction Class


SetCurrent Method

[image]

Mindscape WPF Diagrams
CursorAction..::.SetCurrent Method
CursorAction Class See Also Send Feedback
Sets the value of the Current attached property for an object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetCurrent(
    DependencyObject obj,
    CursorAction value
)
Visual Basic (Declaration)
Public Shared Sub SetCurrent ( _
    obj As DependencyObject, _
    value As CursorAction _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The object to which the property value is written.
value
Type: Mindscape.WpfDiagramming.Foundation..::.CursorAction
The value to set.

See Also

CursorAction Class


CursorAction Properties

[image] [image]

Mindscape WPF Diagrams
CursorAction Properties
CursorAction Class See Also Send Feedback

The CursorAction type exposes the following members.

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction.

See Also

CursorAction Class


CursorActionType Property

[image]

Mindscape WPF Diagrams
CursorAction..::.CursorActionType Property
CursorAction Class See Also Send Feedback
Gets the type of operation performed by this CursorAction.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract CursorActionType CursorActionType { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CursorActionType As CursorActionType

See Also

CursorAction Class


CursorActionType Enumeration

[image]

Mindscape WPF Diagrams
CursorActionType Enumeration
See Also Send Feedback
Specifies the type of operation represented by a CursorAction.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum CursorActionType
Visual Basic (Declaration)
Public Enumeration CursorActionType

Members

Member name | Description
Default | The CursorAction performs the default operation.
CreateNode | The CursorAction creates diagram nodes.
CreateConnection | The CursorAction creates diagram connections.

See Also


CursorActionTypeConverter Class

[image]

Mindscape WPF Diagrams
CursorActionTypeConverter Class
Members See Also Send Feedback
Converts a CursorAction to a CursorActionType in a null-safe manner.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class CursorActionTypeConverter : IValueConverter
Visual Basic (Declaration)
Public Class CursorActionTypeConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.CursorActionTypeConverter

See Also

CursorActionTypeConverter Members


CursorActionTypeConverter Members

[image] [image]

Mindscape WPF Diagrams
CursorActionTypeConverter Members
CursorActionTypeConverter Class Constructors Methods See Also Send Feedback

The CursorActionTypeConverter type exposes the following members.

Constructors

Name | Description
CursorActionTypeConverter |

Methods

Name | Description
Convert | Converts a CursorAction to a CursorActionType in a null-safe manner.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

CursorActionTypeConverter Class


CursorActionTypeConverter Constructor

[image]

Mindscape WPF Diagrams
CursorActionTypeConverter Constructor
CursorActionTypeConverter Class See Also Send Feedback
Initializes a new instance of the CursorActionTypeConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CursorActionTypeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

CursorActionTypeConverter Class


CursorActionTypeConverter Methods

[image] [image]

Mindscape WPF Diagrams
CursorActionTypeConverter Methods
CursorActionTypeConverter Class See Also Send Feedback

The CursorActionTypeConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a CursorAction to a CursorActionType in a null-safe manner.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

CursorActionTypeConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
CursorActionTypeConverter..::.Convert Method
CursorActionTypeConverter Class See Also Send Feedback
Converts a CursorAction to a CursorActionType in a null-safe manner.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The CursorAction.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A CursorActionType suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

CursorActionTypeConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
CursorActionTypeConverter..::.ConvertBack Method
CursorActionTypeConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

CursorActionTypeConverter Class


CustomPropertyChangedEventArgs Class

[image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs Class
Members See Also Send Feedback
Holds information about the CustomPropertyChanged event. This information tells the DiagramSurface if it should change the dirty-bit or take a snapshot for undoing purposes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class CustomPropertyChangedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class CustomPropertyChangedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.CustomPropertyChangedEventArgs

See Also

CustomPropertyChangedEventArgs Members


CustomPropertyChangedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs Members
CustomPropertyChangedEventArgs Class Constructors Properties See Also Send Feedback

The CustomPropertyChangedEventArgs type exposes the following members.

Constructors

Name | Description
CustomPropertyChangedEventArgs | Overloaded.

Properties

Name | Description
ModifyDirtyBit | Gets whether or not the DiagramSurface should set the dirty-bit to true.
TakeSnapshot | Gets whether or not the DiagramSurface should take a snapshot.

See Also

CustomPropertyChangedEventArgs Class


CustomPropertyChangedEventArgs Constructor

[image] [image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs Constructor
CustomPropertyChangedEventArgs Class See Also Send Feedback

Overload List

Name | Description
CustomPropertyChangedEventArgs()()() | Initializes a new instance of the CustomPropertyChangedEventArgs class. Both the ModifyDirtyBit and the TakeSnapshot properties will be set to true;
CustomPropertyChangedEventArgs(Boolean, Boolean) | Initializes a new instance of the CustomPropertyChangedEventArgs class. The ModifyDirtyBit and TakeSnapshot properties will be set to be the given values.

See Also

CustomPropertyChangedEventArgs Class
CustomPropertyChangedEventArgs Members


CustomPropertyChangedEventArgs Constructor

[image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs Constructor
CustomPropertyChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the CustomPropertyChangedEventArgs class. Both the ModifyDirtyBit and the TakeSnapshot properties will be set to true;

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CustomPropertyChangedEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

CustomPropertyChangedEventArgs Class
CustomPropertyChangedEventArgs Overload


CustomPropertyChangedEventArgs Constructor (Boolean, Boolean)

[image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs Constructor (Boolean, Boolean)
CustomPropertyChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the CustomPropertyChangedEventArgs class. The ModifyDirtyBit and TakeSnapshot properties will be set to be the given values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public CustomPropertyChangedEventArgs(
    bool modifyDirtyBit,
    bool takeSnapshot
)
Visual Basic (Declaration)
Public Sub New ( _
    modifyDirtyBit As Boolean, _
    takeSnapshot As Boolean _
)

Parameters

modifyDirtyBit
Type: System..::.Boolean
Whether or not the DiagramSurface should set the dirty-bit to true.
takeSnapshot
Type: System..::.Boolean
Whether or a snapshot should be taken for undo purposes.

See Also

CustomPropertyChangedEventArgs Class
CustomPropertyChangedEventArgs Overload


CustomPropertyChangedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs Properties
CustomPropertyChangedEventArgs Class See Also Send Feedback

The CustomPropertyChangedEventArgs type exposes the following members.

Properties

Name | Description
ModifyDirtyBit | Gets whether or not the DiagramSurface should set the dirty-bit to true.
TakeSnapshot | Gets whether or not the DiagramSurface should take a snapshot.

See Also

CustomPropertyChangedEventArgs Class


ModifyDirtyBit Property

[image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs..::.ModifyDirtyBit Property
CustomPropertyChangedEventArgs Class See Also Send Feedback
Gets whether or not the DiagramSurface should set the dirty-bit to true.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ModifyDirtyBit { get; private set; }
Visual Basic (Declaration)
Public Property ModifyDirtyBit As Boolean

See Also

CustomPropertyChangedEventArgs Class


TakeSnapshot Property

[image]

Mindscape WPF Diagrams
CustomPropertyChangedEventArgs..::.TakeSnapshot Property
CustomPropertyChangedEventArgs Class See Also Send Feedback
Gets whether or not the DiagramSurface should take a snapshot.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool TakeSnapshot { get; private set; }
Visual Basic (Declaration)
Public Property TakeSnapshot As Boolean

See Also

CustomPropertyChangedEventArgs Class


DataTypeStyleSelector Class

[image]

Mindscape WPF Diagrams
DataTypeStyleSelector Class
Members See Also Send Feedback
Selects a diagram node style based on the type of the diagram node data.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("TypeStyles")]
public class DataTypeStyleSelector : StyleSelector
Visual Basic (Declaration)
<ContentPropertyAttribute("TypeStyles")> _
Public Class DataTypeStyleSelector _
    Inherits StyleSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.DataTypeStyleSelector

See Also

DataTypeStyleSelector Members


DataTypeStyleSelector Members

[image] [image]

Mindscape WPF Diagrams
DataTypeStyleSelector Members
DataTypeStyleSelector Class Constructors Methods Properties See Also Send Feedback

The DataTypeStyleSelector type exposes the following members.

Constructors

Name | Description
DataTypeStyleSelector |

Methods

Name | Description
SelectStyle | Returns a Style according to the type of the Data property of the provided IDiagramNode. (Overrides StyleSelector ..::. SelectStyle(Object, DependencyObject).)

Properties

Name | Description
DefaultStyle | Gets or sets the default style. This style is used if there is no specific template for the type of the node data, or if the node data is null.
TypeStyles | Gets the list of type-specific styles.

See Also

DataTypeStyleSelector Class


DataTypeStyleSelector Constructor

[image]

Mindscape WPF Diagrams
DataTypeStyleSelector Constructor
DataTypeStyleSelector Class See Also Send Feedback
Initializes a new instance of the DataTypeStyleSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTypeStyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

DataTypeStyleSelector Class


DataTypeStyleSelector Methods

[image] [image]

Mindscape WPF Diagrams
DataTypeStyleSelector Methods
DataTypeStyleSelector Class See Also Send Feedback

The DataTypeStyleSelector type exposes the following members.

Methods

Name | Description
SelectStyle | Returns a Style according to the type of the Data property of the provided IDiagramNode. (Overrides StyleSelector ..::. SelectStyle(Object, DependencyObject).)

See Also

DataTypeStyleSelector Class


SelectStyle Method

[image]

Mindscape WPF Diagrams
DataTypeStyleSelector..::.SelectStyle Method
DataTypeStyleSelector Class See Also Send Feedback
Returns a Style according to the type of the Data property of the provided IDiagramNode.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overrides Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The IDiagramNode for which to select the style.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The style from the TypeStyles list if one matches; otherwise the DefaultStyle.

See Also

DataTypeStyleSelector Class


DataTypeStyleSelector Properties

[image] [image]

Mindscape WPF Diagrams
DataTypeStyleSelector Properties
DataTypeStyleSelector Class See Also Send Feedback

The DataTypeStyleSelector type exposes the following members.

Properties

Name | Description
DefaultStyle | Gets or sets the default style. This style is used if there is no specific template for the type of the node data, or if the node data is null.
TypeStyles | Gets the list of type-specific styles.

See Also

DataTypeStyleSelector Class


DefaultStyle Property

[image]

Mindscape WPF Diagrams
DataTypeStyleSelector..::.DefaultStyle Property
DataTypeStyleSelector Class See Also Send Feedback
Gets or sets the default style. This style is used if there is no specific template for the type of the node data, or if the node data is null.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style DefaultStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultStyle As Style

See Also

DataTypeStyleSelector Class


TypeStyles Property

[image]

Mindscape WPF Diagrams
DataTypeStyleSelector..::.TypeStyles Property
DataTypeStyleSelector Class See Also Send Feedback
Gets the list of type-specific styles.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Collection<TypeStyle> TypeStyles { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeStyles As Collection(Of TypeStyle)

See Also

DataTypeStyleSelector Class


DataTypeTemplateSelector Class

[image]

Mindscape WPF Diagrams
DataTypeTemplateSelector Class
Members See Also Send Feedback
Selects a diagram node template based on the type of the diagram node data.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DataTypeTemplateSelector : TypeTemplateSelectorBase
Visual Basic (Declaration)
Public Class DataTypeTemplateSelector _
    Inherits TypeTemplateSelectorBase

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.DataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingDataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.TypeTemplateSelectorBase
Mindscape.WpfDiagramming.Foundation..::.DataTypeTemplateSelector

See Also

DataTypeTemplateSelector Members


DataTypeTemplateSelector Members

[image] [image]

Mindscape WPF Diagrams
DataTypeTemplateSelector Members
DataTypeTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The DataTypeTemplateSelector type exposes the following members.

Constructors

Name | Description
DataTypeTemplateSelector |

Methods

Name | Description
GetSelectionType | Gets the type of the data content of an IDiagramNode. (Overrides TypeTemplateSelectorBase ..::. GetSelectionType(Object).)
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns a DataTemplate according to the type of the item. (Inherited from TypeTemplateSelectorBase.)

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector. (Inherited from DelegatingDataTemplateSelector.)
DefaultTemplate | Gets or sets the default data template. (Inherited from TypeTemplateSelectorBase.)
TypeTemplates | Gets the list of type-specific templates. (Inherited from TypeTemplateSelectorBase.)

See Also

DataTypeTemplateSelector Class


DataTypeTemplateSelector Constructor

[image]

Mindscape WPF Diagrams
DataTypeTemplateSelector Constructor
DataTypeTemplateSelector Class See Also Send Feedback
Initializes a new instance of the DataTypeTemplateSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTypeTemplateSelector()
Visual Basic (Declaration)
Public Sub New

See Also

DataTypeTemplateSelector Class


DataTypeTemplateSelector Methods

[image] [image]

Mindscape WPF Diagrams
DataTypeTemplateSelector Methods
DataTypeTemplateSelector Class See Also Send Feedback

The DataTypeTemplateSelector type exposes the following members.

Methods

Name | Description
GetSelectionType | Gets the type of the data content of an IDiagramNode. (Overrides TypeTemplateSelectorBase ..::. GetSelectionType(Object).)
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns a DataTemplate according to the type of the item. (Inherited from TypeTemplateSelectorBase.)

See Also

DataTypeTemplateSelector Class


GetSelectionType Method

[image]

Mindscape WPF Diagrams
DataTypeTemplateSelector..::.GetSelectionType Method
DataTypeTemplateSelector Class See Also Send Feedback
Gets the type of the data content of an IDiagramNode.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Type GetSelectionType(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function GetSelectionType ( _
    item As Object _
) As Type

Parameters

item
Type: System..::.Object
The IDiagramNode for which to obtain a data type.

Return Value

The data type for the item.

See Also

DataTypeTemplateSelector Class


DefaultCursorAction Class

[image]

Mindscape WPF Diagrams
DefaultCursorAction Class
Members See Also Send Feedback
Represents the default cursor action (when no toolbox item is selected).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DefaultCursorAction : CursorAction
Visual Basic (Declaration)
Public Class DefaultCursorAction _
    Inherits CursorAction

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.CursorAction
Mindscape.WpfDiagramming.Foundation..::.DefaultCursorAction

See Also

DefaultCursorAction Members


DefaultCursorAction Members

[image] [image]

Mindscape WPF Diagrams
DefaultCursorAction Members
DefaultCursorAction Class Constructors Methods Properties See Also Send Feedback

The DefaultCursorAction type exposes the following members.

Constructors

Name | Description
DefaultCursorAction |

Methods

Name | Description
Discharge | Disassociates the cursor action from the cursor. (Inherited from CursorAction.)
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action. (Inherited from CursorAction.)
ExecuteCore | Executes the cursor action. (Overrides CursorAction ..::. ExecuteCore(DiagramSurface, MouseButtonEventArgs).)

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction. (Overrides CursorAction ..::. CursorActionType.)

See Also

DefaultCursorAction Class


DefaultCursorAction Constructor

[image]

Mindscape WPF Diagrams
DefaultCursorAction Constructor
DefaultCursorAction Class See Also Send Feedback
Initializes a new instance of the DefaultCursorAction class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DefaultCursorAction()
Visual Basic (Declaration)
Public Sub New

See Also

DefaultCursorAction Class


DefaultCursorAction Methods

[image] [image]

Mindscape WPF Diagrams
DefaultCursorAction Methods
DefaultCursorAction Class See Also Send Feedback

The DefaultCursorAction type exposes the following members.

Methods

Name | Description
Discharge | Disassociates the cursor action from the cursor. (Inherited from CursorAction.)
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action. (Inherited from CursorAction.)
ExecuteCore | Executes the cursor action. (Overrides CursorAction ..::. ExecuteCore(DiagramSurface, MouseButtonEventArgs).)

See Also

DefaultCursorAction Class


ExecuteCore Method

[image]

Mindscape WPF Diagrams
DefaultCursorAction..::.ExecuteCore Method
DefaultCursorAction Class See Also Send Feedback
Executes the cursor action.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void ExecuteCore(
    DiagramSurface surface,
    MouseButtonEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub ExecuteCore ( _
    surface As DiagramSurface, _
    eventArgs As MouseButtonEventArgs _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface on which to execute the action.
eventArgs
Type: System.Windows.Input..::.MouseButtonEventArgs
The event data associated with the mouse action.

See Also

DefaultCursorAction Class


DefaultCursorAction Properties

[image] [image]

Mindscape WPF Diagrams
DefaultCursorAction Properties
DefaultCursorAction Class See Also Send Feedback

The DefaultCursorAction type exposes the following members.

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction. (Overrides CursorAction ..::. CursorActionType.)

See Also

DefaultCursorAction Class


CursorActionType Property

[image]

Mindscape WPF Diagrams
DefaultCursorAction..::.CursorActionType Property
DefaultCursorAction Class See Also Send Feedback
Gets the type of operation performed by this CursorAction.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override CursorActionType CursorActionType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CursorActionType As CursorActionType

See Also

DefaultCursorAction Class


DefaultDiagramConnectionRelocator Class

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator Class
Members See Also Send Feedback
Provides standard implementation of relocating an IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DefaultDiagramConnectionRelocator : IDiagramConnectionRelocator
Visual Basic (Declaration)
Public Class DefaultDiagramConnectionRelocator _
    Implements IDiagramConnectionRelocator

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DefaultDiagramConnectionRelocator
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionRelocator

See Also

DefaultDiagramConnectionRelocator Members


DefaultDiagramConnectionRelocator Members

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator Members
DefaultDiagramConnectionRelocator Class Constructors Methods Fields See Also Send Feedback

The DefaultDiagramConnectionRelocator type exposes the following members.

Constructors

Name | Description
DefaultDiagramConnectionRelocator |

Methods

Name | Description
CanRelocateConnection | Returns whether or not the given connection can be relocated between the given connection point and connectable. This implementation always returns true.
RelocateConnection | Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection.

Fields

Name | Description
Instance | Gets an instance of the DefaultDiagramConnectionRelocator.

See Also

DefaultDiagramConnectionRelocator Class


DefaultDiagramConnectionRelocator Constructor

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator Constructor
DefaultDiagramConnectionRelocator Class See Also Send Feedback
Initializes a new instance of the DefaultDiagramConnectionRelocator class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DefaultDiagramConnectionRelocator()
Visual Basic (Declaration)
Public Sub New

See Also

DefaultDiagramConnectionRelocator Class


DefaultDiagramConnectionRelocator Fields

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator Fields
DefaultDiagramConnectionRelocator Class See Also Send Feedback

The DefaultDiagramConnectionRelocator type exposes the following members.

Fields

Name | Description
Instance | Gets an instance of the DefaultDiagramConnectionRelocator.

See Also

DefaultDiagramConnectionRelocator Class


Instance Field

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator..::.Instance Field
DefaultDiagramConnectionRelocator Class See Also Send Feedback
Gets an instance of the DefaultDiagramConnectionRelocator.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly IDiagramConnectionRelocator Instance
Visual Basic (Declaration)
Public Shared ReadOnly Instance As IDiagramConnectionRelocator

See Also

DefaultDiagramConnectionRelocator Class


DefaultDiagramConnectionRelocator Methods

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator Methods
DefaultDiagramConnectionRelocator Class See Also Send Feedback

The DefaultDiagramConnectionRelocator type exposes the following members.

Methods

Name | Description
CanRelocateConnection | Returns whether or not the given connection can be relocated between the given connection point and connectable. This implementation always returns true.
RelocateConnection | Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection.

See Also

DefaultDiagramConnectionRelocator Class


CanRelocateConnection Method

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator..::.CanRelocateConnection Method
DefaultDiagramConnectionRelocator Class See Also Send Feedback
Returns whether or not the given connection can be relocated between the given connection point and connectable. This implementation always returns true.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanRelocateConnection(
    IDiagramModel diagram,
    IDiagramConnection connection,
    IDiagramConnectionPoint connectionPoint,
    ConnectionDropTarget dropTarget
)
Visual Basic (Declaration)
Public Overridable Function CanRelocateConnection ( _
    diagram As IDiagramModel, _
    connection As IDiagramConnection, _
    connectionPoint As IDiagramConnectionPoint, _
    dropTarget As ConnectionDropTarget _
) As Boolean

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the connection belongs to.
connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection being relocated.
connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that the connection is still attached to.
dropTarget
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionDropTarget
Information about the potential destination that the connection is being relocated to.

Return Value

True.

Implements

IDiagramConnectionRelocator..::.CanRelocateConnection(IDiagramModel, IDiagramConnection, IDiagramConnectionPoint, ConnectionDropTarget)

See Also

DefaultDiagramConnectionRelocator Class


RelocateConnection Method

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRelocator..::.RelocateConnection Method
DefaultDiagramConnectionRelocator Class See Also Send Feedback
Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void RelocateConnection(
    ConnectionRelocationInfo info
)
Visual Basic (Declaration)
Public Sub RelocateConnection ( _
    info As ConnectionRelocationInfo _
)

Parameters

info
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionRelocationInfo
ConnectionRelocationInfo holding information about the connection relocation that is to be performed.

Implements

IDiagramConnectionRelocator..::.RelocateConnection(ConnectionRelocationInfo)

See Also

DefaultDiagramConnectionRelocator Class


DefaultDiagramConnectionRemover Class

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRemover Class
Members See Also Send Feedback
Provides the standard implementation for removing connections from a diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DefaultDiagramConnectionRemover : IDiagramConnectionRemover
Visual Basic (Declaration)
Public Class DefaultDiagramConnectionRemover _
    Implements IDiagramConnectionRemover

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DefaultDiagramConnectionRemover

See Also

DefaultDiagramConnectionRemover Members


DefaultDiagramConnectionRemover Members

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRemover Members
DefaultDiagramConnectionRemover Class Constructors Methods Fields See Also Send Feedback

The DefaultDiagramConnectionRemover type exposes the following members.

Constructors

Name | Description
DefaultDiagramConnectionRemover |

Methods

Name | Description
RemoveConnections | Removes the given IDiagramConnection objects from the given IDiagramModel.

Fields

Name | Description
Instance | Gets an instance of the DefaultDiagramConnectionRemover.

See Also

DefaultDiagramConnectionRemover Class


DefaultDiagramConnectionRemover Constructor

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRemover Constructor
DefaultDiagramConnectionRemover Class See Also Send Feedback
Initializes a new instance of the DefaultDiagramConnectionRemover class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DefaultDiagramConnectionRemover()
Visual Basic (Declaration)
Public Sub New

See Also

DefaultDiagramConnectionRemover Class


DefaultDiagramConnectionRemover Fields

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRemover Fields
DefaultDiagramConnectionRemover Class See Also Send Feedback

The DefaultDiagramConnectionRemover type exposes the following members.

Fields

Name | Description
Instance | Gets an instance of the DefaultDiagramConnectionRemover.

See Also

DefaultDiagramConnectionRemover Class


Instance Field

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRemover..::.Instance Field
DefaultDiagramConnectionRemover Class See Also Send Feedback
Gets an instance of the DefaultDiagramConnectionRemover.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly IDiagramConnectionRemover Instance
Visual Basic (Declaration)
Public Shared ReadOnly Instance As IDiagramConnectionRemover

See Also

DefaultDiagramConnectionRemover Class


DefaultDiagramConnectionRemover Methods

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRemover Methods
DefaultDiagramConnectionRemover Class See Also Send Feedback

The DefaultDiagramConnectionRemover type exposes the following members.

Methods

Name | Description
RemoveConnections | Removes the given IDiagramConnection objects from the given IDiagramModel.

See Also

DefaultDiagramConnectionRemover Class


RemoveConnections Method

[image]

Mindscape WPF Diagrams
DefaultDiagramConnectionRemover..::.RemoveConnections Method
DefaultDiagramConnectionRemover Class See Also Send Feedback
Removes the given IDiagramConnection objects from the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void RemoveConnections(
    IDiagramModel model,
    IList<IDiagramConnection> connections
)
Visual Basic (Declaration)
Public Sub RemoveConnections ( _
    model As IDiagramModel, _
    connections As IList(Of IDiagramConnection) _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to have connections removed from.
connections
Type: System.Collections.Generic..::.IList <(Of <( IDiagramConnection >)>)
The connections to be removed from the model.

Implements

IDiagramConnectionRemover..::.RemoveConnections(IDiagramModel, IList<(Of <(IDiagramConnection>)>))

See Also

DefaultDiagramConnectionRemover Class


DefaultDiagramNodeRemover Class

[image]

Mindscape WPF Diagrams
DefaultDiagramNodeRemover Class
Members See Also Send Feedback
Provides the standard implementation of removing nodes from a diagram model.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DefaultDiagramNodeRemover : IDiagramNodeRemover
Visual Basic (Declaration)
Public Class DefaultDiagramNodeRemover _
    Implements IDiagramNodeRemover

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DefaultDiagramNodeRemover

See Also

DefaultDiagramNodeRemover Members


DefaultDiagramNodeRemover Members

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramNodeRemover Members
DefaultDiagramNodeRemover Class Constructors Methods Fields See Also Send Feedback

The DefaultDiagramNodeRemover type exposes the following members.

Constructors

Name | Description
DefaultDiagramNodeRemover |

Methods

Name | Description
RemoveNodes | Removes the given IDiagramNode objects from the given IDiagramModel.

Fields

Name | Description
Instance | Gets an instance of the DefaultDiagramNodeRemover.

See Also

DefaultDiagramNodeRemover Class


DefaultDiagramNodeRemover Constructor

[image]

Mindscape WPF Diagrams
DefaultDiagramNodeRemover Constructor
DefaultDiagramNodeRemover Class See Also Send Feedback
Initializes a new instance of the DefaultDiagramNodeRemover class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DefaultDiagramNodeRemover()
Visual Basic (Declaration)
Public Sub New

See Also

DefaultDiagramNodeRemover Class


DefaultDiagramNodeRemover Fields

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramNodeRemover Fields
DefaultDiagramNodeRemover Class See Also Send Feedback

The DefaultDiagramNodeRemover type exposes the following members.

Fields

Name | Description
Instance | Gets an instance of the DefaultDiagramNodeRemover.

See Also

DefaultDiagramNodeRemover Class


Instance Field

[image]

Mindscape WPF Diagrams
DefaultDiagramNodeRemover..::.Instance Field
DefaultDiagramNodeRemover Class See Also Send Feedback
Gets an instance of the DefaultDiagramNodeRemover.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly IDiagramNodeRemover Instance
Visual Basic (Declaration)
Public Shared ReadOnly Instance As IDiagramNodeRemover

See Also

DefaultDiagramNodeRemover Class


DefaultDiagramNodeRemover Methods

[image] [image]

Mindscape WPF Diagrams
DefaultDiagramNodeRemover Methods
DefaultDiagramNodeRemover Class See Also Send Feedback

The DefaultDiagramNodeRemover type exposes the following members.

Methods

Name | Description
RemoveNodes | Removes the given IDiagramNode objects from the given IDiagramModel.

See Also

DefaultDiagramNodeRemover Class


RemoveNodes Method

[image]

Mindscape WPF Diagrams
DefaultDiagramNodeRemover..::.RemoveNodes Method
DefaultDiagramNodeRemover Class See Also Send Feedback
Removes the given IDiagramNode objects from the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void RemoveNodes(
    IDiagramModel model,
    IList<IDiagramNode> nodes
)
Visual Basic (Declaration)
Public Sub RemoveNodes ( _
    model As IDiagramModel, _
    nodes As IList(Of IDiagramNode) _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
An IDiagramModel to have nodes removed from.
nodes
Type: System.Collections.Generic..::.IList <(Of <( IDiagramNode >)>)
The nodes to be removed from the model.

Implements

IDiagramNodeRemover..::.RemoveNodes(IDiagramModel, IList<(Of <(IDiagramNode>)>))

See Also

DefaultDiagramNodeRemover Class


DefaultLayout Class

[image]

Mindscape WPF Diagrams
DefaultLayout Class
Members See Also Send Feedback
Maps between diagram model bounds and element bounds on a DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DefaultLayout : ILayout
Visual Basic (Declaration)
Public Class DefaultLayout _
    Implements ILayout

Remarks

This layout is used by default. Use an alternate layout only if you are creating a visual style in which nodes display content outside the bounds specified in the model.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DefaultLayout

See Also

DefaultLayout Members


DefaultLayout Members

[image] [image]

Mindscape WPF Diagrams
DefaultLayout Members
DefaultLayout Class Constructors Methods Properties See Also Send Feedback

The DefaultLayout type exposes the following members.

Constructors

Name | Description
DefaultLayout |

Methods

Name | Description
GetDisplayBounds | Gets the display rectangle for a node.
GetDisplayPosition | Gets the display position for a connection point.
SetNodeBounds | Sets the model bounds for a node, based on its display rectangle.

Properties

Name | Description
Instance | A singleton instance of the DefaultLayout.

See Also

DefaultLayout Class


DefaultLayout Constructor

[image]

Mindscape WPF Diagrams
DefaultLayout Constructor
DefaultLayout Class See Also Send Feedback
Initializes a new instance of the DefaultLayout class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DefaultLayout()
Visual Basic (Declaration)
Public Sub New

See Also

DefaultLayout Class


DefaultLayout Methods

[image] [image]

Mindscape WPF Diagrams
DefaultLayout Methods
DefaultLayout Class See Also Send Feedback

The DefaultLayout type exposes the following members.

Methods

Name | Description
GetDisplayBounds | Gets the display rectangle for a node.
GetDisplayPosition | Gets the display position for a connection point.
SetNodeBounds | Sets the model bounds for a node, based on its display rectangle.

See Also

DefaultLayout Class


GetDisplayBounds Method

[image]

Mindscape WPF Diagrams
DefaultLayout..::.GetDisplayBounds Method
DefaultLayout Class See Also Send Feedback
Gets the display rectangle for a node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect GetDisplayBounds(
    IDiagramNode node
)
Visual Basic (Declaration)
Public Function GetDisplayBounds ( _
    node As IDiagramNode _
) As Rect

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The node for which the display rectangle is required.

Return Value

The display rectangle.

Implements

ILayout..::.GetDisplayBounds(IDiagramNode)

See Also

DefaultLayout Class


GetDisplayPosition Method

[image]

Mindscape WPF Diagrams
DefaultLayout..::.GetDisplayPosition Method
DefaultLayout Class See Also Send Feedback
Gets the display position for a connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point GetDisplayPosition(
    IDiagramConnectionPoint connectionPoint
)
Visual Basic (Declaration)
Public Function GetDisplayPosition ( _
    connectionPoint As IDiagramConnectionPoint _
) As Point

Parameters

connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The connection point for which the display position is required.

Return Value

The display position.

Implements

ILayout..::.GetDisplayPosition(IDiagramConnectionPoint)

See Also

DefaultLayout Class


SetNodeBounds Method

[image]

Mindscape WPF Diagrams
DefaultLayout..::.SetNodeBounds Method
DefaultLayout Class See Also Send Feedback
Sets the model bounds for a node, based on its display rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetNodeBounds(
    IDiagramNode node,
    Rect displayBounds
)
Visual Basic (Declaration)
Public Sub SetNodeBounds ( _
    node As IDiagramNode, _
    displayBounds As Rect _
)

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The node whose bounds are to be set.
displayBounds
Type: System.Windows..::.Rect
The node's display rectangle.

Implements

ILayout..::.SetNodeBounds(IDiagramNode, Rect)

See Also

DefaultLayout Class


DefaultLayout Properties

[image] [image]

Mindscape WPF Diagrams
DefaultLayout Properties
DefaultLayout Class See Also Send Feedback

The DefaultLayout type exposes the following members.

Properties

Name | Description
Instance | A singleton instance of the DefaultLayout.

See Also

DefaultLayout Class


Instance Property

[image]

Mindscape WPF Diagrams
DefaultLayout..::.Instance Property
DefaultLayout Class See Also Send Feedback
A singleton instance of the DefaultLayout.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static DefaultLayout Instance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As DefaultLayout

See Also

DefaultLayout Class


DelegatingDataTemplateSelector Class

[image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector Class
Members See Also Send Feedback
Selects a template, falling back to another DataTemplateSelector if no template is found by this selector.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DelegatingDataTemplateSelector : DataTemplateSelector
Visual Basic (Declaration)
Public MustInherit Class DelegatingDataTemplateSelector _
    Inherits DataTemplateSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.DataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingDataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.MatchingTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.TypeTemplateSelectorBase

See Also

DelegatingDataTemplateSelector Members


DelegatingDataTemplateSelector Members

[image] [image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector Members
DelegatingDataTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The DelegatingDataTemplateSelector type exposes the following members.

Constructors

Name | Description
DelegatingDataTemplateSelector |

Methods

Name | Description
SelectTemplate | Returns a DataTemplate for the item. (Overrides DataTemplateSelector ..::. SelectTemplate(Object, DependencyObject).)
SelectTemplateCore | When overridden in a derived class, gets a DataTemplate for the item. If this method returns null, the item is handed off to the BasedOn DataTemplateSelector.

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector.

See Also

DelegatingDataTemplateSelector Class


DelegatingDataTemplateSelector Constructor

[image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector Constructor
DelegatingDataTemplateSelector Class See Also Send Feedback
Initializes a new instance of the DelegatingDataTemplateSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DelegatingDataTemplateSelector()
Visual Basic (Declaration)
Protected Sub New

See Also

DelegatingDataTemplateSelector Class


DelegatingDataTemplateSelector Methods

[image] [image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector Methods
DelegatingDataTemplateSelector Class See Also Send Feedback

The DelegatingDataTemplateSelector type exposes the following members.

Methods

Name | Description
SelectTemplate | Returns a DataTemplate for the item. (Overrides DataTemplateSelector ..::. SelectTemplate(Object, DependencyObject).)
SelectTemplateCore | When overridden in a derived class, gets a DataTemplate for the item. If this method returns null, the item is handed off to the BasedOn DataTemplateSelector.

See Also

DelegatingDataTemplateSelector Class


SelectTemplate Method

[image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector..::.SelectTemplate Method
DelegatingDataTemplateSelector Class See Also Send Feedback
Returns a DataTemplate for the item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override sealed DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overrides NotOverridable Function SelectTemplate ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
The item for which to select the template.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

A DataTemplate for the item.

See Also

DelegatingDataTemplateSelector Class


SelectTemplateCore Method

[image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector..::.SelectTemplateCore Method
DelegatingDataTemplateSelector Class See Also Send Feedback
When overridden in a derived class, gets a DataTemplate for the item. If this method returns null, the item is handed off to the BasedOn DataTemplateSelector.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract DataTemplate SelectTemplateCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected MustOverride Function SelectTemplateCore ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
The item for which to select the template.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

A DataTemplate for the item, or null to delegate to the BasedOn DataTemplateSelector.

See Also

DelegatingDataTemplateSelector Class


DelegatingDataTemplateSelector Properties

[image] [image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector Properties
DelegatingDataTemplateSelector Class See Also Send Feedback

The DelegatingDataTemplateSelector type exposes the following members.

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector.

See Also

DelegatingDataTemplateSelector Class


BasedOn Property

[image]

Mindscape WPF Diagrams
DelegatingDataTemplateSelector..::.BasedOn Property
DelegatingDataTemplateSelector Class See Also Send Feedback
Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplateSelector BasedOn { get; set; }
Visual Basic (Declaration)
Public Property BasedOn As DataTemplateSelector

See Also

DelegatingDataTemplateSelector Class


DelegatingStyleSelector Class

[image]

Mindscape WPF Diagrams
DelegatingStyleSelector Class
Members See Also Send Feedback
Selects a style, falling back to another StyleSelector if no style is found by this selector.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DelegatingStyleSelector : StyleSelector
Visual Basic (Declaration)
Public MustInherit Class DelegatingStyleSelector _
    Inherits StyleSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingStyleSelector
Mindscape.WpfDiagramming.Foundation..::.MatchingStyleSelector
Mindscape.WpfDiagramming.Foundation..::.TypeStyleSelectorBase

See Also

DelegatingStyleSelector Members


DelegatingStyleSelector Members

[image] [image]

Mindscape WPF Diagrams
DelegatingStyleSelector Members
DelegatingStyleSelector Class Constructors Methods Properties See Also Send Feedback

The DelegatingStyleSelector type exposes the following members.

Constructors

Name | Description
DelegatingStyleSelector |

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Overrides StyleSelector ..::. SelectStyle(Object, DependencyObject).)
SelectStyleCore | When overridden in a derived class, gets a Style for the item. If this method returns null, the item is handed off to the BasedOn DataTemplateSelector.

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector.

See Also

DelegatingStyleSelector Class


DelegatingStyleSelector Constructor

[image]

Mindscape WPF Diagrams
DelegatingStyleSelector Constructor
DelegatingStyleSelector Class See Also Send Feedback
Initializes a new instance of the DelegatingStyleSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DelegatingStyleSelector()
Visual Basic (Declaration)
Protected Sub New

See Also

DelegatingStyleSelector Class


DelegatingStyleSelector Methods

[image] [image]

Mindscape WPF Diagrams
DelegatingStyleSelector Methods
DelegatingStyleSelector Class See Also Send Feedback

The DelegatingStyleSelector type exposes the following members.

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Overrides StyleSelector ..::. SelectStyle(Object, DependencyObject).)
SelectStyleCore | When overridden in a derived class, gets a Style for the item. If this method returns null, the item is handed off to the BasedOn DataTemplateSelector.

See Also

DelegatingStyleSelector Class


SelectStyle Method

[image]

Mindscape WPF Diagrams
DelegatingStyleSelector..::.SelectStyle Method
DelegatingStyleSelector Class See Also Send Feedback
Returns a Style for the item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override sealed Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overrides NotOverridable Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The item for which to select the style.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

A Style for the item.

See Also

DelegatingStyleSelector Class


SelectStyleCore Method

[image]

Mindscape WPF Diagrams
DelegatingStyleSelector..::.SelectStyleCore Method
DelegatingStyleSelector Class See Also Send Feedback
When overridden in a derived class, gets a Style for the item. If this method returns null, the item is handed off to the BasedOn DataTemplateSelector.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract Style SelectStyleCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected MustOverride Function SelectStyleCore ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The item for which to select the style.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

A Style for the item, or null to delegate to the BasedOn StyleSelector.

See Also

DelegatingStyleSelector Class


DelegatingStyleSelector Properties

[image] [image]

Mindscape WPF Diagrams
DelegatingStyleSelector Properties
DelegatingStyleSelector Class See Also Send Feedback

The DelegatingStyleSelector type exposes the following members.

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector.

See Also

DelegatingStyleSelector Class


BasedOn Property

[image]

Mindscape WPF Diagrams
DelegatingStyleSelector..::.BasedOn Property
DelegatingStyleSelector Class See Also Send Feedback
Gets or sets the StyleSelector on which to fall back if no style is found by this selector.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StyleSelector BasedOn { get; set; }
Visual Basic (Declaration)
Public Property BasedOn As StyleSelector

See Also

DelegatingStyleSelector Class


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Class

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class
Members See Also Send Feedback
Provides base diagram connection implementation.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DiagramConnectionBase<TOutboundPoint, TInboundPoint, TMountedPoint> : ViewModelBase, IDiagramConnection,
    IDiagramConnectable, IDiagramZOrderable where TOutboundPoint : IDiagramConnectionPoint where TInboundPoint : IDiagramConnectionPoint where TMountedPoint : IDiagramConnectionPoint
Visual Basic (Declaration)
Public MustInherit Class DiagramConnectionBase(Of TOutboundPoint As IDiagramConnectionPoint, TInboundPoint As IDiagramConnectionPoint, TMountedPoint As IDiagramConnectionPoint) _
    Inherits ViewModelBase _
    Implements IDiagramConnection, IDiagramConnectable, IDiagramZOrderable

Type Parameters

TOutboundPoint
The type of outbound connection point.
TInboundPoint
The type of inbound connection point.
TMountedPoint
The type of mountable connection points.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)
Mindscape.WpfDiagramming.Foundation..::.BasicDiagramConnectionBase<(Of <(TConnectionPoint>)>)
Mindscape.WpfDiagramming..::.DiagramConnection

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Members


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Members
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class Constructors Methods Properties Events See Also Send Feedback

The DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) type exposes the following members.

Constructors

Name | Description
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) | Overloaded.

Methods

Name | Description
AddConnectionPoint | Adds a new mounted connection point to this connection.
ApplyPathfinding | Re-routes this connection using its pathfinder.
Clone | Gets the state of the connection for undo purposes.
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point.
OnDataChanged | Raises the DataChanged event.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can allow a be the source of a new outgoing connection. The base class implementation always returns false.
CanReceiveNewConnections | When overridden in a derived class, gets whether the connection can be the destination of a new incoming connection.
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection.
Data | Gets or sets the data attached to this connection.
Diagram | Gets or sets the IDiagramModel that the connection belongs to.
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source.
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user.
Pathfinder | Gets the IPathfinder used to find the segment path of this connection.
Segments | Returns all the DiagramConnectionSegment objects that build up this connection.
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination.
ZOrder | Gets or sets the relative z-order.

Events

Name | Description
DataChanged | Raised when the Data property changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Constructor

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Constructor
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback

Overload List

Name | Description
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)(TOutboundPoint, TInboundPoint) | Initializes a new instance of the DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) class.
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)(TOutboundPoint, TInboundPoint, IList<(Of <(DiagramConnectionSegment>)>)) | Initializes a new instance of the DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) class.

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Members


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Constructor (TOutboundPoint, TInboundPoint)

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Constructor (TOutboundPoint, TInboundPoint)
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramConnectionBase(
    TOutboundPoint fromConnectionPoint,
    TInboundPoint toConnectionPoint
)
Visual Basic (Declaration)
Protected Sub New ( _
    fromConnectionPoint As TOutboundPoint, _
    toConnectionPoint As TInboundPoint _
)

Parameters

fromConnectionPoint
Type: TOutboundPoint
The source of the connection.
toConnectionPoint
Type: TInboundPoint
The destination of the connection.

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Overload


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Constructor (TOutboundPoint, TInboundPoint, IList(DiagramConnectionSegment))

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Constructor (TOutboundPoint, TInboundPoint, IList<(Of <(DiagramConnectionSegment>)>))
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramConnectionBase(
    TOutboundPoint fromConnectionPoint,
    TInboundPoint toConnectionPoint,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Protected Sub New ( _
    fromConnectionPoint As TOutboundPoint, _
    toConnectionPoint As TInboundPoint, _
    segments As IList(Of DiagramConnectionSegment) _
)

Parameters

fromConnectionPoint
Type: TOutboundPoint
The source of the connection.
toConnectionPoint
Type: TInboundPoint
The destination of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects within this DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Overload


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Methods
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback

The DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) type exposes the following members.

Methods

Name | Description
AddConnectionPoint | Adds a new mounted connection point to this connection.
ApplyPathfinding | Re-routes this connection using its pathfinder.
Clone | Gets the state of the connection for undo purposes.
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point.
OnDataChanged | Raises the DataChanged event.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection.

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


AddConnectionPoint Method

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.AddConnectionPoint Method
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Adds a new mounted connection point to this connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract TMountedPoint AddConnectionPoint(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Public MustOverride Function AddConnectionPoint ( _
    point As Point, _
    buffer As Double _
) As TMountedPoint

Parameters

point
Type: System.Windows..::.Point
A point used to derive the position of the mounted connection point.
buffer
Type: System..::.Double
The minimum distance away from the connection corners that the mounted point can be placed.

Return Value

The connection point that is created and mounted to this connection.

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


ApplyPathfinding Method

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.ApplyPathfinding Method
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Re-routes this connection using its pathfinder.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void ApplyPathfinding()
Visual Basic (Declaration)
Protected Sub ApplyPathfinding

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


Clone Method

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.Clone Method
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets the state of the connection for undo purposes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramConnectionState Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As IDiagramConnectionState

Return Value

The state of the connection, used for undo purposes.

Implements

IDiagramConnection..::.Clone()()()

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


GetCollisionBounds Method

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.GetCollisionBounds Method
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect GetCollisionBounds(
    IDiagramConnectionPoint connectionPoint
)
Visual Basic (Declaration)
Public Function GetCollisionBounds ( _
    connectionPoint As IDiagramConnectionPoint _
) As Rect

Parameters

connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint to find the collision bounds of.

Return Value

A Rect with size 1 by 1 and the same position as the position of the given IDiagramConnectionPoint.

Implements

IDiagramConnectable..::.GetCollisionBounds(IDiagramConnectionPoint)

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


OnDataChanged Method

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.OnDataChanged Method
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Raises the DataChanged event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual void OnDataChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnDataChanged

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


SetAs Method

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.SetAs Method
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Sets all the properties of this connection to match those of the given connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void SetAs(
    IDiagramConnectionState state
)
Visual Basic (Declaration)
Public Overridable Sub SetAs ( _
    state As IDiagramConnectionState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionState
An IDiagramConnectionState holding information about a diagram connection.

Implements

IDiagramConnection..::.SetAs(IDiagramConnectionState)

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Properties

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Properties
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback

The DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the connection can allow a be the source of a new outgoing connection. The base class implementation always returns false.
CanReceiveNewConnections | When overridden in a derived class, gets whether the connection can be the destination of a new incoming connection.
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection.
Data | Gets or sets the data attached to this connection.
Diagram | Gets or sets the IDiagramModel that the connection belongs to.
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source.
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user.
Pathfinder | Gets the IPathfinder used to find the segment path of this connection.
Segments | Returns all the DiagramConnectionSegment objects that build up this connection.
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination.
ZOrder | Gets or sets the relative z-order.

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.CanOriginateNewConnections Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets whether the connection can allow a be the source of a new outgoing connection. The base class implementation always returns false.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.CanReceiveNewConnections Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
When overridden in a derived class, gets whether the connection can be the destination of a new incoming connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


ConnectionPoints Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.ConnectionPoints Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Returns all the IDiagramConnectionPoint objects currently attached to this connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ObservableCollection<IDiagramConnectionPoint> ConnectionPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectionPoints As ObservableCollection(Of IDiagramConnectionPoint)

Implements

IDiagramConnection..::.ConnectionPoints

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


Data Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.Data Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets or sets the data attached to this connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Object

Implements

IDiagramConnectable..::.Data

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


Diagram Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.Diagram Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets or sets the IDiagramModel that the connection belongs to.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramModel Diagram { get; set; }
Visual Basic (Declaration)
Public Property Diagram As IDiagramModel

Implements

IDiagramConnection..::.Diagram

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


FromConnectionPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.FromConnectionPoint Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual TOutboundPoint FromConnectionPoint { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromConnectionPoint As TOutboundPoint

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


IsUserModified Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.IsUserModified Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsUserModified { get; set; }
Visual Basic (Declaration)
Public Property IsUserModified As Boolean

Implements

IDiagramConnection..::.IsUserModified

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


Pathfinder Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.Pathfinder Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets the IPathfinder used to find the segment path of this connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IPathfinder Pathfinder { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Pathfinder As IPathfinder

Implements

IDiagramConnection..::.Pathfinder

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


Segments Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.Segments Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Returns all the DiagramConnectionSegment objects that build up this connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ObservableCollection<DiagramConnectionSegment> Segments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Segments As ObservableCollection(Of DiagramConnectionSegment)

Implements

IDiagramConnection..::.Segments

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


ToConnectionPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.ToConnectionPoint Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual TInboundPoint ToConnectionPoint { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToConnectionPoint As TInboundPoint

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


ZOrder Property

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.ZOrder Property
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Gets or sets the relative z-order.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double ZOrder { get; set; }
Visual Basic (Declaration)
Public Property ZOrder As Double

Implements

IDiagramZOrderable..::.ZOrder

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


DiagramConnectionBase(TOutboundPoint, TInboundPoint, TMountedPoint) Events

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Events
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback

The DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) type exposes the following members.

Events

Name | Description
DataChanged | Raised when the Data property changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


DataChanged Event

[image]

Mindscape WPF Diagrams
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)..::.DataChanged Event
DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class See Also Send Feedback
Raised when the Data property changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler DataChanged
Visual Basic (Declaration)
Public Event DataChanged As EventHandler

Implements

IDiagramConnectable..::.DataChanged

See Also

DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>) Class


DiagramConnectionCollection(TConnection) Class

[image]

Mindscape WPF Diagrams
DiagramConnectionCollection<(Of <(TConnection>)>) Class
Members See Also Send Feedback
A type of ObservableCollection that holds IDiagramConnection objects and allows for cascading removal of IDiagramConnection objects that have other IDiagramConnection objects attached to them. A DiagramConnectionCollection uses the IDiagramConnectionRemover found in the IDiagramModel passed into the constructor to delete the cascading connections from that model.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramConnectionCollection<TConnection> : ObservableCollection<TConnection> where TConnection : IDiagramConnection
Visual Basic (Declaration)
Public Class DiagramConnectionCollection(Of TConnection As IDiagramConnection) _
    Inherits ObservableCollection(Of TConnection)

Type Parameters

TConnection
The type of connection in the collection.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(TConnection>)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <(TConnection>)>)
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionCollection<(Of <(TConnection>)>)

See Also

DiagramConnectionCollection<(Of <(TConnection>)>) Members


DiagramConnectionCollection(TConnection) Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionCollection<(Of <(TConnection>)>) Members
DiagramConnectionCollection<(Of <(TConnection>)>) Class Constructors Methods See Also Send Feedback

The DiagramConnectionCollection<(Of <(TConnection>)>) type exposes the following members.

Constructors

Name | Description
DiagramConnectionCollection<(Of <(TConnection>)>) | Instantiates a new instance of the DiagramConnectionCollection<(Of <(TConnection>)>) class.

Methods

Name | Description
RemoveItem | Removes the IDiagramConnection in this DiagramConnectionCollection found at the given index, and then recursively removes any IDiagramConnection objects that are connected to the one that was removed. (Overrides ObservableCollection <(Of <( TConnection >)>)..::. RemoveItem(Int32).)

See Also

DiagramConnectionCollection<(Of <(TConnection>)>) Class


DiagramConnectionCollection(TConnection) Constructor

[image]

Mindscape WPF Diagrams
DiagramConnectionCollection<(Of <(TConnection>)>) Constructor
DiagramConnectionCollection<(Of <(TConnection>)>) Class See Also Send Feedback
Instantiates a new instance of the DiagramConnectionCollection<(Of <(TConnection>)>) class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionCollection(
    IDiagramModel model
)
Visual Basic (Declaration)
Public Sub New ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to remove connections from if cascading deletion of connections occur.

See Also

DiagramConnectionCollection<(Of <(TConnection>)>) Class


DiagramConnectionCollection(TConnection) Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionCollection<(Of <(TConnection>)>) Methods
DiagramConnectionCollection<(Of <(TConnection>)>) Class See Also Send Feedback

The DiagramConnectionCollection<(Of <(TConnection>)>) type exposes the following members.

Methods

Name | Description
RemoveItem | Removes the IDiagramConnection in this DiagramConnectionCollection found at the given index, and then recursively removes any IDiagramConnection objects that are connected to the one that was removed. (Overrides ObservableCollection <(Of <( TConnection >)>)..::. RemoveItem(Int32).)

See Also

DiagramConnectionCollection<(Of <(TConnection>)>) Class


RemoveItem Method

[image]

Mindscape WPF Diagrams
DiagramConnectionCollection<(Of <(TConnection>)>)..::.RemoveItem Method
DiagramConnectionCollection<(Of <(TConnection>)>) Class See Also Send Feedback
Removes the IDiagramConnection in this DiagramConnectionCollection found at the given index, and then recursively removes any IDiagramConnection objects that are connected to the one that was removed.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The index at which to remove a IDiagramConnection from this DiagramConnectionCollection.

See Also

DiagramConnectionCollection<(Of <(TConnection>)>) Class


DiagramConnectionElement Class

[image]

Mindscape WPF Diagrams
DiagramConnectionElement Class
Members See Also Send Feedback
Represents a connection between two DiagramNodeElement elements.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramConnectionElement : DiagramElement
Visual Basic (Declaration)
Public Class DiagramConnectionElement _
    Inherits DiagramElement

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.WpfDiagramming.Foundation..::.DiagramElement
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionElement

See Also

DiagramConnectionElement Members


DiagramConnectionElement Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionElement Members
DiagramConnectionElement Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramConnectionElement type exposes the following members.

Constructors

Name | Description
DiagramConnectionElement |

Methods

Name | Description
GetStyleSelector | Gets the StyleSelector applicable to this type of element. (Overrides DiagramElement ..::. GetStyleSelector(IDiagramFormatter).)
MoveBy | Moves the DiagramElement by the specified amounts. Diagram elements which are not independently positioned will ignore this call. (Inherited from DiagramElement.)
OnApplyFormatting | Applies additional formatting beyond the template and style selectors. (Overrides DiagramElement ..::. OnApplyFormatting(DiagramSurface).)
OnConnectionDragEnter | Called when a ConnectionPointThumb is being dragged over the element. (Overrides DiagramElement ..::. OnConnectionDragEnter(Nullable<(Of <(Point>)>), IDiagramConnectionPoint).)
OnConnectionDragLeave | Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element. (Overrides DiagramElement ..::. OnConnectionDragLeave()()().)
OnContentChanged | Called when the Content changes. (Overrides DiagramElement ..::. OnContentChanged(Object, Object).)
OnMouseLeave | Called when the mouse leaves this DiagramConnectionElement. (Overrides ListBoxItem ..::. OnMouseLeave(MouseEventArgs).)
OnMouseMove | Called when the mouse moves over this DiagramConnectionElement. (Overrides UIElement ..::. OnMouseMove(MouseEventArgs).)
OnMoveBy | Implements the MoveBy(Double, Double) method. This is a no-op for DiagramConnectionElement because connections are not independently positioned. (Overrides DiagramElement ..::. OnMoveBy(Double, Double).)
OnPreviewMouseDown | Called when the mouse is pressed over this element. (Inherited from DiagramElement.)
SetRequestedConnectionPoint | Sets the RequestedConnectionPoint property to be a point on one of the DiagramConnectionSegment objects of this DiagramConnectionElement that is closest to the given Point. The actual value that is set is then returned.

Fields

Name | Description
BottomProperty | Identifies the Bottom property.
ConnectionContentTemplateSelectorProperty | Identifies the ConnectionContentTemplateSelector property.
EndArrowTemplateProperty | Identifies the EndArrowTemplate property.
FromConnectionPointProperty | Identifies the FromConnectionPoint property.
IsRequestingConnectionPointProperty | Identifies the IsRequestingConnectionPoint property.
LeftProperty | Identifies the Left property.
PathBuilderProperty | Identifies the PathBuilder property.
PathGeometryProperty | Identifies the PathGeometry property.
PathStyleProperty | Identifies the PathStyle property.
RequestedConnectionPointProperty | Identifies the RequestedConnectionPoint property.
RightProperty | Identifies the Left property.
SegmentEndBufferProperty | Identifies the SegmentEndBuffer property.
StartArrowTemplateProperty | Identifies the StartArrowTemplate property.
ToConnectionPointProperty | Identifies the ToConnectionPoint property.
TopProperty | Identifies the Top property.

Properties

Name | Description
Bottom | Gets the the vertical offset of the bottom of this DiagramConnectionElement from the top of the diagram. This is a dependency property.
Bounds | Gets the bounds of the DiagramConnectionElement. (Overrides DiagramElement ..::. Bounds.)
Connection | Gets the IDiagramConnection represented by this DiagramConnectionElement.
ConnectionContentTemplateSelector | Gets or sets the DataTemplateSelector used to the select the DataTemplate for displaying the data within the IDiagramConnection. This is a dependency property.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for connection points. This is a dependency property. (Inherited from DiagramElement.)
EndArrowTemplate | Gets or sets the DataTemplate applied to the end of the connection. This is a dependency property.
FromConnectionPoint | Gets or sets the point from which the connection originates. This is a dependency property.
IsRequestingConnectionPoint | Gets whether a connection point position is being requested (the user is dragging a connection close to this one and the framework wishes to display a potential connection point). This is a dependency property.
LayerKeyCore | Gets an object identifying the layer on which to display this element. For a DiagramConnectionElement, this is the parent of the originating node. (Overrides DiagramElement ..::. LayerKeyCore.)
Left | Gets the the horizontal offset of the DiagramConnectionElement from the left hand side of the diagram. This is a dependency property.
MovableSegments | Returns an IList of all the MovableDiagramConnectionSegment objects that make up the IDiagramConnection that this DiagramConnectionElement graphically represents.
PathBuilder | Gets or sets the IPathBuilder used to create the path geometry for this connection. This is a dependency property.
PathGeometry | Gets the PathGeometry of this DiagramConnectionElement. This is a dependency property.
PathStyle | Gets or sets the Style applied to the connection path. This is a dependency property.
RequestedConnectionPoint | Gets the RequestedConnectionPoint. The requested connection point is a point on one of the DiagramConnectionSegment objects of this DiagramConnectionElement of which is a potential place for a connection to be connected to. This is a dependency property.
Right | Gets the the horizontal offset of the right hand side of this DiagramConnectionElement from the left hand side of the diagram. This is a dependency property.
SegmentEndBuffer | Gets or sets the buffer at each end of a DiagramConnectionSegment that can not have an IDiagramConnectionPoint attached to it. This is a dependency property.
StartArrowTemplate | Gets or sets the DataTemplate applied to the start of the connection.. This is a dependency property.
ToConnectionPoint | Gets or sets the point to which the connection goes. This is a dependency property.
Top | Gets the the vertical offset of the DiagramConnectionElement from the top of the diagram. This is a dependency property.
ZIndexLayer | Gets how the DiagramElement participates in the z-order. (Overrides DiagramElement ..::. ZIndexLayer.)

See Also

DiagramConnectionElement Class


DiagramConnectionElement Constructor

[image]

Mindscape WPF Diagrams
DiagramConnectionElement Constructor
DiagramConnectionElement Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionElement class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionElement()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramConnectionElement Class


DiagramConnectionElement Fields

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionElement Fields
DiagramConnectionElement Class See Also Send Feedback

The DiagramConnectionElement type exposes the following members.

Fields

Name | Description
BottomProperty | Identifies the Bottom property.
ConnectionContentTemplateSelectorProperty | Identifies the ConnectionContentTemplateSelector property.
EndArrowTemplateProperty | Identifies the EndArrowTemplate property.
FromConnectionPointProperty | Identifies the FromConnectionPoint property.
IsRequestingConnectionPointProperty | Identifies the IsRequestingConnectionPoint property.
LeftProperty | Identifies the Left property.
PathBuilderProperty | Identifies the PathBuilder property.
PathGeometryProperty | Identifies the PathGeometry property.
PathStyleProperty | Identifies the PathStyle property.
RequestedConnectionPointProperty | Identifies the RequestedConnectionPoint property.
RightProperty | Identifies the Left property.
SegmentEndBufferProperty | Identifies the SegmentEndBuffer property.
StartArrowTemplateProperty | Identifies the StartArrowTemplate property.
ToConnectionPointProperty | Identifies the ToConnectionPoint property.
TopProperty | Identifies the Top property.

See Also

DiagramConnectionElement Class


BottomProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.BottomProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the Bottom property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty BottomProperty
Visual Basic (Declaration)
Public Shared ReadOnly BottomProperty As DependencyProperty

See Also

DiagramConnectionElement Class


ConnectionContentTemplateSelectorProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.ConnectionContentTemplateSelectorProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the ConnectionContentTemplateSelector property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionContentTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionContentTemplateSelectorProperty As DependencyProperty

See Also

DiagramConnectionElement Class


EndArrowTemplateProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.EndArrowTemplateProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the EndArrowTemplate property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty EndArrowTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly EndArrowTemplateProperty As DependencyProperty

See Also

DiagramConnectionElement Class


FromConnectionPointProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.FromConnectionPointProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the FromConnectionPoint property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty FromConnectionPointProperty
Visual Basic (Declaration)
Public Shared ReadOnly FromConnectionPointProperty As DependencyProperty

See Also

DiagramConnectionElement Class


IsRequestingConnectionPointProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.IsRequestingConnectionPointProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the IsRequestingConnectionPoint property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsRequestingConnectionPointProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsRequestingConnectionPointProperty As DependencyProperty

See Also

DiagramConnectionElement Class


LeftProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.LeftProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the Left property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty LeftProperty
Visual Basic (Declaration)
Public Shared ReadOnly LeftProperty As DependencyProperty

See Also

DiagramConnectionElement Class


PathBuilderProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.PathBuilderProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the PathBuilder property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty PathBuilderProperty
Visual Basic (Declaration)
Public Shared ReadOnly PathBuilderProperty As DependencyProperty

See Also

DiagramConnectionElement Class


PathGeometryProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.PathGeometryProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the PathGeometry property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty PathGeometryProperty
Visual Basic (Declaration)
Public Shared ReadOnly PathGeometryProperty As DependencyProperty

See Also

DiagramConnectionElement Class


PathStyleProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.PathStyleProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the PathStyle property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty PathStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly PathStyleProperty As DependencyProperty

See Also

DiagramConnectionElement Class


RequestedConnectionPointProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.RequestedConnectionPointProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the RequestedConnectionPoint property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty RequestedConnectionPointProperty
Visual Basic (Declaration)
Public Shared ReadOnly RequestedConnectionPointProperty As DependencyProperty

See Also

DiagramConnectionElement Class


RightProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.RightProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the Left property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty RightProperty
Visual Basic (Declaration)
Public Shared ReadOnly RightProperty As DependencyProperty

See Also

DiagramConnectionElement Class


SegmentEndBufferProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.SegmentEndBufferProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the SegmentEndBuffer property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty SegmentEndBufferProperty
Visual Basic (Declaration)
Public Shared ReadOnly SegmentEndBufferProperty As DependencyProperty

See Also

DiagramConnectionElement Class


StartArrowTemplateProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.StartArrowTemplateProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the StartArrowTemplate property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty StartArrowTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly StartArrowTemplateProperty As DependencyProperty

See Also

DiagramConnectionElement Class


ToConnectionPointProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.ToConnectionPointProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the ToConnectionPoint property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ToConnectionPointProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToConnectionPointProperty As DependencyProperty

See Also

DiagramConnectionElement Class


TopProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.TopProperty Field
DiagramConnectionElement Class See Also Send Feedback
Identifies the Top property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty TopProperty
Visual Basic (Declaration)
Public Shared ReadOnly TopProperty As DependencyProperty

See Also

DiagramConnectionElement Class


DiagramConnectionElement Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionElement Methods
DiagramConnectionElement Class See Also Send Feedback

The DiagramConnectionElement type exposes the following members.

Methods

Name | Description
GetStyleSelector | Gets the StyleSelector applicable to this type of element. (Overrides DiagramElement ..::. GetStyleSelector(IDiagramFormatter).)
MoveBy | Moves the DiagramElement by the specified amounts. Diagram elements which are not independently positioned will ignore this call. (Inherited from DiagramElement.)
OnApplyFormatting | Applies additional formatting beyond the template and style selectors. (Overrides DiagramElement ..::. OnApplyFormatting(DiagramSurface).)
OnConnectionDragEnter | Called when a ConnectionPointThumb is being dragged over the element. (Overrides DiagramElement ..::. OnConnectionDragEnter(Nullable<(Of <(Point>)>), IDiagramConnectionPoint).)
OnConnectionDragLeave | Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element. (Overrides DiagramElement ..::. OnConnectionDragLeave()()().)
OnContentChanged | Called when the Content changes. (Overrides DiagramElement ..::. OnContentChanged(Object, Object).)
OnMouseLeave | Called when the mouse leaves this DiagramConnectionElement. (Overrides ListBoxItem ..::. OnMouseLeave(MouseEventArgs).)
OnMouseMove | Called when the mouse moves over this DiagramConnectionElement. (Overrides UIElement ..::. OnMouseMove(MouseEventArgs).)
OnMoveBy | Implements the MoveBy(Double, Double) method. This is a no-op for DiagramConnectionElement because connections are not independently positioned. (Overrides DiagramElement ..::. OnMoveBy(Double, Double).)
OnPreviewMouseDown | Called when the mouse is pressed over this element. (Inherited from DiagramElement.)
SetRequestedConnectionPoint | Sets the RequestedConnectionPoint property to be a point on one of the DiagramConnectionSegment objects of this DiagramConnectionElement that is closest to the given Point. The actual value that is set is then returned.

See Also

DiagramConnectionElement Class


GetStyleSelector Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.GetStyleSelector Method
DiagramConnectionElement Class See Also Send Feedback
Gets the StyleSelector applicable to this type of element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override StyleSelector GetStyleSelector(
    IDiagramFormatter formatter
)
Visual Basic (Declaration)
Protected Overrides Function GetStyleSelector ( _
    formatter As IDiagramFormatter _
) As StyleSelector

Parameters

formatter
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramFormatter
The IDiagramFormatter from which to retrieve the selector.

Return Value

The StyleSelector to be used for this type of DiagramElement.

See Also

DiagramConnectionElement Class


OnApplyFormatting Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.OnApplyFormatting Method
DiagramConnectionElement Class See Also Send Feedback
Applies additional formatting beyond the template and style selectors.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnApplyFormatting(
    DiagramSurface formattingSource
)
Visual Basic (Declaration)
Protected Overrides Sub OnApplyFormatting ( _
    formattingSource As DiagramSurface _
)

Parameters

formattingSource
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface on which the element is displayed.

Remarks

For the DiagramConnectionElement this method is used to apply pathfinding, using the IPathfinder specified on the IDiagramFormatter, or a ElbowPathfinder if no IPathfinder is specified.

See Also

DiagramConnectionElement Class


OnConnectionDragEnter Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.OnConnectionDragEnter Method
DiagramConnectionElement Class See Also Send Feedback
Called when a ConnectionPointThumb is being dragged over the element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal override void OnConnectionDragEnter(
    Nullable<Point> mousePoint,
    IDiagramConnectionPoint source
)
Visual Basic (Declaration)
Protected Friend Overrides Sub OnConnectionDragEnter ( _
    mousePoint As Nullable(Of Point), _
    source As IDiagramConnectionPoint _
)

Parameters

mousePoint
Type: System..::.Nullable <(Of <( Point >)>)
The mouse location of the dragged thumb.
source
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that is the source of the moving connection.

See Also

DiagramConnectionElement Class


OnConnectionDragLeave Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.OnConnectionDragLeave Method
DiagramConnectionElement Class See Also Send Feedback
Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal override void OnConnectionDragLeave()
Visual Basic (Declaration)
Protected Friend Overrides Sub OnConnectionDragLeave

See Also

DiagramConnectionElement Class


OnContentChanged Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.OnContentChanged Method
DiagramConnectionElement Class See Also Send Feedback
Called when the Content changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)

Parameters

oldContent
Type: System..::.Object
The old form of the Content property.
newContent
Type: System..::.Object
The new form of the Content property.

See Also

DiagramConnectionElement Class


OnMouseLeave Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.OnMouseLeave Method
DiagramConnectionElement Class See Also Send Feedback
Called when the mouse leaves this DiagramConnectionElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnMouseLeave(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The event data.

See Also

DiagramConnectionElement Class


OnMouseMove Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.OnMouseMove Method
DiagramConnectionElement Class See Also Send Feedback
Called when the mouse moves over this DiagramConnectionElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
The event data.

See Also

DiagramConnectionElement Class


OnMoveBy Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.OnMoveBy Method
DiagramConnectionElement Class See Also Send Feedback
Implements the MoveBy(Double, Double) method. This is a no-op for DiagramConnectionElement because connections are not independently positioned.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnMoveBy(
    double horizontalChange,
    double verticalChange
)
Visual Basic (Declaration)
Protected Overrides Sub OnMoveBy ( _
    horizontalChange As Double, _
    verticalChange As Double _
)

Parameters

horizontalChange
Type: System..::.Double
The amount to move horizontally.
verticalChange
Type: System..::.Double
The amount to move vertically.

See Also

DiagramConnectionElement Class


SetRequestedConnectionPoint Method

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.SetRequestedConnectionPoint Method
DiagramConnectionElement Class See Also Send Feedback
Sets the RequestedConnectionPoint property to be a point on one of the DiagramConnectionSegment objects of this DiagramConnectionElement that is closest to the given Point. The actual value that is set is then returned.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<Point> SetRequestedConnectionPoint(
    Nullable<Point> point
)
Visual Basic (Declaration)
Public Function SetRequestedConnectionPoint ( _
    point As Nullable(Of Point) _
) As Nullable(Of Point)

Parameters

point
Type: System..::.Nullable <(Of <( Point >)>)
A Point used to derive the value for the RequestedConnectionPoint property.

Return Value

The value that is set to the RequestedConnectionPoint property.

See Also

DiagramConnectionElement Class


DiagramConnectionElement Properties

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionElement Properties
DiagramConnectionElement Class See Also Send Feedback

The DiagramConnectionElement type exposes the following members.

Properties

Name | Description
Bottom | Gets the the vertical offset of the bottom of this DiagramConnectionElement from the top of the diagram. This is a dependency property.
Bounds | Gets the bounds of the DiagramConnectionElement. (Overrides DiagramElement ..::. Bounds.)
Connection | Gets the IDiagramConnection represented by this DiagramConnectionElement.
ConnectionContentTemplateSelector | Gets or sets the DataTemplateSelector used to the select the DataTemplate for displaying the data within the IDiagramConnection. This is a dependency property.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for connection points. This is a dependency property. (Inherited from DiagramElement.)
EndArrowTemplate | Gets or sets the DataTemplate applied to the end of the connection. This is a dependency property.
FromConnectionPoint | Gets or sets the point from which the connection originates. This is a dependency property.
IsRequestingConnectionPoint | Gets whether a connection point position is being requested (the user is dragging a connection close to this one and the framework wishes to display a potential connection point). This is a dependency property.
LayerKeyCore | Gets an object identifying the layer on which to display this element. For a DiagramConnectionElement, this is the parent of the originating node. (Overrides DiagramElement ..::. LayerKeyCore.)
Left | Gets the the horizontal offset of the DiagramConnectionElement from the left hand side of the diagram. This is a dependency property.
MovableSegments | Returns an IList of all the MovableDiagramConnectionSegment objects that make up the IDiagramConnection that this DiagramConnectionElement graphically represents.
PathBuilder | Gets or sets the IPathBuilder used to create the path geometry for this connection. This is a dependency property.
PathGeometry | Gets the PathGeometry of this DiagramConnectionElement. This is a dependency property.
PathStyle | Gets or sets the Style applied to the connection path. This is a dependency property.
RequestedConnectionPoint | Gets the RequestedConnectionPoint. The requested connection point is a point on one of the DiagramConnectionSegment objects of this DiagramConnectionElement of which is a potential place for a connection to be connected to. This is a dependency property.
Right | Gets the the horizontal offset of the right hand side of this DiagramConnectionElement from the left hand side of the diagram. This is a dependency property.
SegmentEndBuffer | Gets or sets the buffer at each end of a DiagramConnectionSegment that can not have an IDiagramConnectionPoint attached to it. This is a dependency property.
StartArrowTemplate | Gets or sets the DataTemplate applied to the start of the connection.. This is a dependency property.
ToConnectionPoint | Gets or sets the point to which the connection goes. This is a dependency property.
Top | Gets the the vertical offset of the DiagramConnectionElement from the top of the diagram. This is a dependency property.
ZIndexLayer | Gets how the DiagramElement participates in the z-order. (Overrides DiagramElement ..::. ZIndexLayer.)

See Also

DiagramConnectionElement Class


Bottom Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.Bottom Property
DiagramConnectionElement Class See Also Send Feedback
Gets the the vertical offset of the bottom of this DiagramConnectionElement from the top of the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Bottom { get; private set; }
Visual Basic (Declaration)
Public Property Bottom As Double

Remarks

Dependency Property Information
Identifier field | BottomProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


Bounds Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.Bounds Property
DiagramConnectionElement Class See Also Send Feedback
Gets the bounds of the DiagramConnectionElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal override Rect Bounds { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property Bounds As Rect

See Also

DiagramConnectionElement Class


Connection Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.Connection Property
DiagramConnectionElement Class See Also Send Feedback
Gets the IDiagramConnection represented by this DiagramConnectionElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnection Connection { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connection As IDiagramConnection

See Also

DiagramConnectionElement Class


ConnectionContentTemplateSelector Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.ConnectionContentTemplateSelector Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the DataTemplateSelector used to the select the DataTemplate for displaying the data within the IDiagramConnection. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplateSelector ConnectionContentTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ConnectionContentTemplateSelector As DataTemplateSelector

Remarks

Dependency Property Information
Identifier field | ConnectionContentTemplateSelectorProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


EndArrowTemplate Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.EndArrowTemplate Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the DataTemplate applied to the end of the connection. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate EndArrowTemplate { get; set; }
Visual Basic (Declaration)
Public Property EndArrowTemplate As DataTemplate

Remarks

Dependency Property Information
Identifier field | EndArrowTemplateProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


FromConnectionPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.FromConnectionPoint Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the point from which the connection originates. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint FromConnectionPoint { get; set; }
Visual Basic (Declaration)
Public Property FromConnectionPoint As IDiagramConnectionPoint

Remarks

Dependency Property Information
Identifier field | FromConnectionPointProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


IsRequestingConnectionPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.IsRequestingConnectionPoint Property
DiagramConnectionElement Class See Also Send Feedback
Gets whether a connection point position is being requested (the user is dragging a connection close to this one and the framework wishes to display a potential connection point). This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsRequestingConnectionPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRequestingConnectionPoint As Boolean

Remarks

Dependency Property Information
Identifier field | IsRequestingConnectionPointProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


LayerKeyCore Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.LayerKeyCore Property
DiagramConnectionElement Class See Also Send Feedback
Gets an object identifying the layer on which to display this element. For a DiagramConnectionElement, this is the parent of the originating node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override IDiagramPositionable LayerKeyCore { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LayerKeyCore As IDiagramPositionable

See Also

DiagramConnectionElement Class


Left Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.Left Property
DiagramConnectionElement Class See Also Send Feedback
Gets the the horizontal offset of the DiagramConnectionElement from the left hand side of the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Left { get; private set; }
Visual Basic (Declaration)
Public Property Left As Double

Remarks

Dependency Property Information
Identifier field | LeftProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


MovableSegments Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.MovableSegments Property
DiagramConnectionElement Class See Also Send Feedback
Returns an IList of all the MovableDiagramConnectionSegment objects that make up the IDiagramConnection that this DiagramConnectionElement graphically represents.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IList<MovableDiagramConnectionSegment> MovableSegments { get; }
Visual Basic (Declaration)
Public ReadOnly Property MovableSegments As IList(Of MovableDiagramConnectionSegment)

See Also

DiagramConnectionElement Class


PathBuilder Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.PathBuilder Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the IPathBuilder used to create the path geometry for this connection. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IPathBuilder PathBuilder { get; set; }
Visual Basic (Declaration)
Public Property PathBuilder As IPathBuilder

Remarks

Dependency Property Information
Identifier field | PathBuilderProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


PathGeometry Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.PathGeometry Property
DiagramConnectionElement Class See Also Send Feedback
Gets the PathGeometry of this DiagramConnectionElement. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public PathGeometry PathGeometry { get; }
Visual Basic (Declaration)
Public ReadOnly Property PathGeometry As PathGeometry

Remarks

Dependency Property Information
Identifier field | PathGeometryProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


PathStyle Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.PathStyle Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the Style applied to the connection path. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style PathStyle { get; set; }
Visual Basic (Declaration)
Public Property PathStyle As Style

Remarks

Dependency Property Information
Identifier field | PathStyleProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


RequestedConnectionPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.RequestedConnectionPoint Property
DiagramConnectionElement Class See Also Send Feedback
Gets the RequestedConnectionPoint. The requested connection point is a point on one of the DiagramConnectionSegment objects of this DiagramConnectionElement of which is a potential place for a connection to be connected to. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Nullable<Point> RequestedConnectionPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property RequestedConnectionPoint As Nullable(Of Point)

Remarks

Dependency Property Information
Identifier field | RequestedConnectionPointProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


Right Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.Right Property
DiagramConnectionElement Class See Also Send Feedback
Gets the the horizontal offset of the right hand side of this DiagramConnectionElement from the left hand side of the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Right { get; private set; }
Visual Basic (Declaration)
Public Property Right As Double

Remarks

Dependency Property Information
Identifier field | RightProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


SegmentEndBuffer Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.SegmentEndBuffer Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the buffer at each end of a DiagramConnectionSegment that can not have an IDiagramConnectionPoint attached to it. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double SegmentEndBuffer { get; set; }
Visual Basic (Declaration)
Public Property SegmentEndBuffer As Double

Remarks

Dependency Property Information
Identifier field | SegmentEndBufferProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


StartArrowTemplate Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.StartArrowTemplate Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the DataTemplate applied to the start of the connection.. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate StartArrowTemplate { get; set; }
Visual Basic (Declaration)
Public Property StartArrowTemplate As DataTemplate

Remarks

Dependency Property Information
Identifier field | StartArrowTemplateProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


ToConnectionPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.ToConnectionPoint Property
DiagramConnectionElement Class See Also Send Feedback
Gets or sets the point to which the connection goes. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint ToConnectionPoint { get; set; }
Visual Basic (Declaration)
Public Property ToConnectionPoint As IDiagramConnectionPoint

Remarks

Dependency Property Information
Identifier field | ToConnectionPointProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


Top Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.Top Property
DiagramConnectionElement Class See Also Send Feedback
Gets the the vertical offset of the DiagramConnectionElement from the top of the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Top { get; private set; }
Visual Basic (Declaration)
Public Property Top As Double

Remarks

Dependency Property Information
Identifier field | TopProperty
Metadata properties set to true | None

See Also

DiagramConnectionElement Class


ZIndexLayer Property

[image]

Mindscape WPF Diagrams
DiagramConnectionElement..::.ZIndexLayer Property
DiagramConnectionElement Class See Also Send Feedback
Gets how the DiagramElement participates in the z-order.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override ZIndexLayer ZIndexLayer { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ZIndexLayer As ZIndexLayer

See Also

DiagramConnectionElement Class


DiagramConnectionPointBase(TConnection) Class

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Class
Members See Also Send Feedback
Provides base implementation for diagram connection points.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DiagramConnectionPointBase<TConnection> : ViewModelBase, IDiagramConnectionPoint where TConnection : IDiagramConnection
Visual Basic (Declaration)
Public MustInherit Class DiagramConnectionPointBase(Of TConnection As IDiagramConnection) _
    Inherits ViewModelBase _
    Implements IDiagramConnectionPoint

Type Parameters

TConnection
The type of diagram connection that can connect to this connection point.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionPointBase<(Of <(TConnection>)>)
Mindscape.WpfDiagramming..::.DiagramConnectionPoint

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Members


DiagramConnectionPointBase(TConnection) Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Members
DiagramConnectionPointBase<(Of <(TConnection>)>) Class Constructors Methods Properties Events See Also Send Feedback

The DiagramConnectionPointBase<(Of <(TConnection>)>) type exposes the following members.

Constructors

Name | Description
DiagramConnectionPointBase<(Of <(TConnection>)>) | Overloaded.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this IDiagramConnectionPoint.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
RemoveConnection | Removes the given IDiagramConnection from this IDiagramConnectionPoint.
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetPosition | Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the user should be allowed to drag new connections from this connection point.
CanReceiveNewConnections | Gets whether the user should be allowed to drop new connections onto this connection point.
Connectable | Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection.
Connections | Gets the connections attached to this connection point.
Data | Gets or sets the data object held by this connection point/>.
Edge | Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator.
FlowDirection | Gets the direction of flow for this connection point.
Index | Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node.
Position | Gets or sets the position of the connection point/>.
PositionCalculator | Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to.

Events

Name | Description
IndexChanged | Raised when the Index property value changes.
PositionChanged | Raised when the Position property value changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


DiagramConnectionPointBase(TConnection) Constructor

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Constructor
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback

Overload List

Name | Description
DiagramConnectionPointBase<(Of <(TConnection>)>)(IDiagramConnectable, Edge) | Initializes a new instance of the DiagramConnectionPointBase class.
DiagramConnectionPointBase<(Of <(TConnection>)>)(IDiagramConnectable, Edge, Int32) | Initializes a new instance of the DiagramConnectionPointBase class.

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class
DiagramConnectionPointBase<(Of <(TConnection>)>) Members


DiagramConnectionPointBase(TConnection) Constructor (IDiagramConnectable, Edge)

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Constructor (IDiagramConnectable, Edge)
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionPointBase class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramConnectionPointBase(
    IDiagramConnectable connectable,
    Edge edge
)
Visual Basic (Declaration)
Protected Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The connectable object (node or connection) on which the connection point is situated.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge of the connectable that this point is situated on.

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class
DiagramConnectionPointBase<(Of <(TConnection>)>) Overload


DiagramConnectionPointBase(TConnection) Constructor (IDiagramConnectable, Edge, Int32)

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Constructor (IDiagramConnectable, Edge, Int32)
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionPointBase class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramConnectionPointBase(
    IDiagramConnectable connectable,
    Edge edge,
    int index
)
Visual Basic (Declaration)
Protected Sub New ( _
    connectable As IDiagramConnectable, _
    edge As Edge, _
    index As Integer _
)

Parameters

connectable
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectable
The connectable object (node or connection) on which the connection point is situated.
edge
Type: Mindscape.WpfDiagramming..::.Edge
The Edge of the connectable that this point is situated on.
index
Type: System..::.Int32
The index identifier for this connection point.

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class
DiagramConnectionPointBase<(Of <(TConnection>)>) Overload


DiagramConnectionPointBase(TConnection) Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Methods
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback

The DiagramConnectionPointBase<(Of <(TConnection>)>) type exposes the following members.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this IDiagramConnectionPoint.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
RemoveConnection | Removes the given IDiagramConnection from this IDiagramConnectionPoint.
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetPosition | Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned.

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


AddConnection Method

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.AddConnection Method
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Attaches the given IDiagramConnection to this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void AddConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overridable Sub AddConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to attach.

Implements

IDiagramConnectionPoint..::.AddConnection(IDiagramConnection)

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


RemoveConnection Method

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.RemoveConnection Method
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Removes the given IDiagramConnection from this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void RemoveConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overridable Sub RemoveConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to remove.

Implements

IDiagramConnectionPoint..::.RemoveConnection(IDiagramConnection)

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


SetPosition Method

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.SetPosition Method
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point SetPosition(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Public Function SetPosition ( _
    point As Point, _
    buffer As Double _
) As Point

Parameters

point
Type: System.Windows..::.Point
A Point that the position of this DiagramConnectionPointBase is derived from.
buffer
Type: System..::.Double
Some distance at each end of the accepting connection where this connection point can not connect to.

Return Value

The actual resulting position of this DiagramConnectionPointBase.

Implements

IDiagramConnectionPoint..::.SetPosition(Point, Double)

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


DiagramConnectionPointBase(TConnection) Properties

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Properties
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback

The DiagramConnectionPointBase<(Of <(TConnection>)>) type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether the user should be allowed to drag new connections from this connection point.
CanReceiveNewConnections | Gets whether the user should be allowed to drop new connections onto this connection point.
Connectable | Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection.
Connections | Gets the connections attached to this connection point.
Data | Gets or sets the data object held by this connection point/>.
Edge | Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator.
FlowDirection | Gets the direction of flow for this connection point.
Index | Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node.
Position | Gets or sets the position of the connection point/>.
PositionCalculator | Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to.

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.CanOriginateNewConnections Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets whether the user should be allowed to drag new connections from this connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectionPoint..::.CanOriginateNewConnections

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.CanReceiveNewConnections Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets whether the user should be allowed to drop new connections onto this connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectionPoint..::.CanReceiveNewConnections

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


Connectable Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.Connectable Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectable Connectable { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connectable As IDiagramConnectable

Implements

IDiagramConnectionPoint..::.Connectable

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


Connections Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.Connections Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets the connections attached to this connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual ReadOnlyCollection<TConnection> Connections { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Connections As ReadOnlyCollection(Of TConnection)

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


Data Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.Data Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets or sets the data object held by this connection point/>.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Object

Implements

IDiagramConnectionPoint..::.Data

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


Edge Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.Edge Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Edge Edge { get; private set; }
Visual Basic (Declaration)
Public Property Edge As Edge

Implements

IDiagramConnectionPoint..::.Edge

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


FlowDirection Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.FlowDirection Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets the direction of flow for this connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract ConnectionPointDirection FlowDirection { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property FlowDirection As ConnectionPointDirection

Implements

IDiagramConnectionPoint..::.FlowDirection

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


Index Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.Index Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer

Implements

IDiagramConnectionPoint..::.Index

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


Position Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.Position Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets or sets the position of the connection point/>.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point Position { get; protected set; }
Visual Basic (Declaration)
Public Property Position As Point

Implements

IDiagramConnectionPoint..::.Position

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


PositionCalculator Property

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.PositionCalculator Property
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IPositionCalculator PositionCalculator { get; set; }
Visual Basic (Declaration)
Public Property PositionCalculator As IPositionCalculator

Implements

IDiagramConnectionPoint..::.PositionCalculator

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


DiagramConnectionPointBase(TConnection) Events

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>) Events
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback

The DiagramConnectionPointBase<(Of <(TConnection>)>) type exposes the following members.

Events

Name | Description
IndexChanged | Raised when the Index property value changes.
PositionChanged | Raised when the Position property value changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


IndexChanged Event

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.IndexChanged Event
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Raised when the Index property value changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler IndexChanged
Visual Basic (Declaration)
Public Event IndexChanged As EventHandler

Implements

IDiagramConnectionPoint..::.IndexChanged

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


PositionChanged Event

[image]

Mindscape WPF Diagrams
DiagramConnectionPointBase<(Of <(TConnection>)>)..::.PositionChanged Event
DiagramConnectionPointBase<(Of <(TConnection>)>) Class See Also Send Feedback
Raised when the Position property value changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler PositionChanged
Visual Basic (Declaration)
Public Event PositionChanged As EventHandler

Implements

IDiagramConnectionPoint..::.PositionChanged

See Also

DiagramConnectionPointBase<(Of <(TConnection>)>) Class


DiagramConnectionSegment Class

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment Class
Members See Also Send Feedback
A single segment within an IDiagramConnection. DiagramConnectionSegment objects have access to the next or previous DiagramConnectionSegment from this themselves allowing them to be chained together. DiagramConnectionSegment objects only have a single Point representing the end point of the segment. The start point of the segment is the end point of the previous segment. So the first segment in a chain is only a single point. DiagramConnectionSegment objects ensure that there is a bidirectional link between the next and previous segments.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramConnectionSegment : DependencyObject
Visual Basic (Declaration)
Public Class DiagramConnectionSegment _
    Inherits DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionSegment
Mindscape.WpfDiagramming.Foundation..::.MovableDiagramConnectionSegment

See Also

DiagramConnectionSegment Members


DiagramConnectionSegment Members

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionSegment Members
DiagramConnectionSegment Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramConnectionSegment type exposes the following members.

Constructors

Name | Description
DiagramConnectionSegment | Overloaded.

Methods

Name | Description
Clone | Returns a deep clone of this DiagramConnectionSegment.
GetClosestPointTo | Returns the Point that lies on this DiagramConnectionSegment that is the closest point to the given one. The returned Point will have integer precision values.
RecalculateLayoutProperties | Calculates and sets the appropriate values for the Midpoint, IsHorizontal, and IsVertical properties.
SetEndPointNoNotify | Just sets the end point of this DiagramConnectionSegment without raising any property changed events.
SetStartPointNoNotify | Just sets the start point of this DiagramConnectionSegment to be the given point without raising any property changed events. If the previous segment is null, then the end point of this segment will be set to be the given point instead.
ShallowClone | Returns a shallow copy of just this DiagramConnectionSegment.

Fields

Name | Description
IsHorizontalProperty | Identifies the IsHorizontal property.
IsVerticalProperty | Identifies the IsVertical property.
MidpointProperty | Identifies the Midpoint property.

Properties

Name | Description
Connection | Gets the IDiagramConnection that the segment belongs to.
EndPoint | Gets or sets the end point of this DiagramConnectionSegment. Note that this value is also used for the start point of the next segment to this one.
IsHorizontal | Gets whether the segment is horizontal. True if this DiagramConnectionSegment is horizontal. False otherwise. This DiagramConnectionSegment is horizontal if the y values of the start and end points are both the same. This is a dependency property.
IsVertical | Gets the whether the segment is vertical. This is a dependency property.
Length | Returns the length of this DiagramConnectionSegment in double precision/>
Midpoint | Gets the midpoint of this DiagramConnectionSegment. This is a dependency property.
NextSegment | Gets or sets the DiagramConnectionSegment that comes next in a chain of segments. Setting this property also makes sure that the previous segment of the set one is set to be this segment.
PreviousSegment | Gets or sets the DiagramConnectionSegment that comes previously before this one in a chain of segments. Setting this property alse makes sure that the next segment of the set one is set to be this segment.
StartPoint | Gets or sets the end point of the previous DiagramConnectionSegment to this one. If this DiagramConnectionSegment does not have a previous segment, then the start point of this DiagramConnectionSegment is its end point.

See Also

DiagramConnectionSegment Class


DiagramConnectionSegment Constructor

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionSegment Constructor
DiagramConnectionSegment Class See Also Send Feedback

Overload List

Name | Description
DiagramConnectionSegment(Point) | Initializes a new instance of the DiagramConnectionSegment class and sets its end point to be the given Point.
DiagramConnectionSegment(Double, Double) | Initializes a new instance of the DiagramConnectionSegment class and sets its end point as having the given x and y values.

See Also

DiagramConnectionSegment Class
DiagramConnectionSegment Members


DiagramConnectionSegment Constructor (Point)

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment Constructor (Point)
DiagramConnectionSegment Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionSegment class and sets its end point to be the given Point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionSegment(
    Point end
)
Visual Basic (Declaration)
Public Sub New ( _
    end As Point _
)

Parameters

end
Type: System.Windows..::.Point
The end point of this DiagramConnectionSegment.

See Also

DiagramConnectionSegment Class
DiagramConnectionSegment Overload


DiagramConnectionSegment Constructor (Double, Double)

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment Constructor (Double, Double)
DiagramConnectionSegment Class See Also Send Feedback
Initializes a new instance of the DiagramConnectionSegment class and sets its end point as having the given x and y values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionSegment(
    double endX,
    double endY
)
Visual Basic (Declaration)
Public Sub New ( _
    endX As Double, _
    endY As Double _
)

Parameters

endX
Type: System..::.Double
The x value of the end point of this DiagramConnectionSegment.
endY
Type: System..::.Double
The y value of the end point of this DiagramConnectionSegment.

See Also

DiagramConnectionSegment Class
DiagramConnectionSegment Overload


DiagramConnectionSegment Fields

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionSegment Fields
DiagramConnectionSegment Class See Also Send Feedback

The DiagramConnectionSegment type exposes the following members.

Fields

Name | Description
IsHorizontalProperty | Identifies the IsHorizontal property.
IsVerticalProperty | Identifies the IsVertical property.
MidpointProperty | Identifies the Midpoint property.

See Also

DiagramConnectionSegment Class


IsHorizontalProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.IsHorizontalProperty Field
DiagramConnectionSegment Class See Also Send Feedback
Identifies the IsHorizontal property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsHorizontalProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsHorizontalProperty As DependencyProperty

See Also

DiagramConnectionSegment Class


IsVerticalProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.IsVerticalProperty Field
DiagramConnectionSegment Class See Also Send Feedback
Identifies the IsVertical property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsVerticalProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsVerticalProperty As DependencyProperty

See Also

DiagramConnectionSegment Class


MidpointProperty Field

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.MidpointProperty Field
DiagramConnectionSegment Class See Also Send Feedback
Identifies the Midpoint property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty MidpointProperty
Visual Basic (Declaration)
Public Shared ReadOnly MidpointProperty As DependencyProperty

See Also

DiagramConnectionSegment Class


DiagramConnectionSegment Methods

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionSegment Methods
DiagramConnectionSegment Class See Also Send Feedback

The DiagramConnectionSegment type exposes the following members.

Methods

Name | Description
Clone | Returns a deep clone of this DiagramConnectionSegment.
GetClosestPointTo | Returns the Point that lies on this DiagramConnectionSegment that is the closest point to the given one. The returned Point will have integer precision values.
RecalculateLayoutProperties | Calculates and sets the appropriate values for the Midpoint, IsHorizontal, and IsVertical properties.
SetEndPointNoNotify | Just sets the end point of this DiagramConnectionSegment without raising any property changed events.
SetStartPointNoNotify | Just sets the start point of this DiagramConnectionSegment to be the given point without raising any property changed events. If the previous segment is null, then the end point of this segment will be set to be the given point instead.
ShallowClone | Returns a shallow copy of just this DiagramConnectionSegment.

See Also

DiagramConnectionSegment Class


Clone Method

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.Clone Method
DiagramConnectionSegment Class See Also Send Feedback
Returns a deep clone of this DiagramConnectionSegment.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionSegment Clone()
Visual Basic (Declaration)
Public Function Clone As DiagramConnectionSegment

Return Value

A deep clone of this DiagramConnectionSegment.

See Also

DiagramConnectionSegment Class


GetClosestPointTo Method

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.GetClosestPointTo Method
DiagramConnectionSegment Class See Also Send Feedback
Returns the Point that lies on this DiagramConnectionSegment that is the closest point to the given one. The returned Point will have integer precision values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point GetClosestPointTo(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Public Function GetClosestPointTo ( _
    point As Point, _
    buffer As Double _
) As Point

Parameters

point
Type: System.Windows..::.Point
some Point.
buffer
Type: System..::.Double
The region from each end of this segment where a connection mounted connection point can not be situated.

Return Value

The closest point on this segment to the given point.

See Also

DiagramConnectionSegment Class


RecalculateLayoutProperties Method

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.RecalculateLayoutProperties Method
DiagramConnectionSegment Class See Also Send Feedback
Calculates and sets the appropriate values for the Midpoint, IsHorizontal, and IsVertical properties.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void RecalculateLayoutProperties()
Visual Basic (Declaration)
Protected Sub RecalculateLayoutProperties

See Also

DiagramConnectionSegment Class


SetEndPointNoNotify Method

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.SetEndPointNoNotify Method
DiagramConnectionSegment Class See Also Send Feedback
Just sets the end point of this DiagramConnectionSegment without raising any property changed events.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void SetEndPointNoNotify(
    Point point
)
Visual Basic (Declaration)
Protected Sub SetEndPointNoNotify ( _
    point As Point _
)

Parameters

point
Type: System.Windows..::.Point
The new end point.

See Also

DiagramConnectionSegment Class


SetStartPointNoNotify Method

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.SetStartPointNoNotify Method
DiagramConnectionSegment Class See Also Send Feedback
Just sets the start point of this DiagramConnectionSegment to be the given point without raising any property changed events. If the previous segment is null, then the end point of this segment will be set to be the given point instead.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void SetStartPointNoNotify(
    Point point
)
Visual Basic (Declaration)
Protected Sub SetStartPointNoNotify ( _
    point As Point _
)

Parameters

point
Type: System.Windows..::.Point
the new start point

See Also

DiagramConnectionSegment Class


ShallowClone Method

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.ShallowClone Method
DiagramConnectionSegment Class See Also Send Feedback
Returns a shallow copy of just this DiagramConnectionSegment.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramConnectionSegment ShallowClone()
Visual Basic (Declaration)
Protected Overridable Function ShallowClone As DiagramConnectionSegment

Return Value

A shallow copy of just this DiagramConnectionSegment.

See Also

DiagramConnectionSegment Class


DiagramConnectionSegment Properties

[image] [image]

Mindscape WPF Diagrams
DiagramConnectionSegment Properties
DiagramConnectionSegment Class See Also Send Feedback

The DiagramConnectionSegment type exposes the following members.

Properties

Name | Description
Connection | Gets the IDiagramConnection that the segment belongs to.
EndPoint | Gets or sets the end point of this DiagramConnectionSegment. Note that this value is also used for the start point of the next segment to this one.
IsHorizontal | Gets whether the segment is horizontal. True if this DiagramConnectionSegment is horizontal. False otherwise. This DiagramConnectionSegment is horizontal if the y values of the start and end points are both the same. This is a dependency property.
IsVertical | Gets the whether the segment is vertical. This is a dependency property.
Length | Returns the length of this DiagramConnectionSegment in double precision/>
Midpoint | Gets the midpoint of this DiagramConnectionSegment. This is a dependency property.
NextSegment | Gets or sets the DiagramConnectionSegment that comes next in a chain of segments. Setting this property also makes sure that the previous segment of the set one is set to be this segment.
PreviousSegment | Gets or sets the DiagramConnectionSegment that comes previously before this one in a chain of segments. Setting this property alse makes sure that the next segment of the set one is set to be this segment.
StartPoint | Gets or sets the end point of the previous DiagramConnectionSegment to this one. If this DiagramConnectionSegment does not have a previous segment, then the start point of this DiagramConnectionSegment is its end point.

See Also

DiagramConnectionSegment Class


Connection Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.Connection Property
DiagramConnectionSegment Class See Also Send Feedback
Gets the IDiagramConnection that the segment belongs to.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnection Connection { get; internal set; }
Visual Basic (Declaration)
Public Property Connection As IDiagramConnection

See Also

DiagramConnectionSegment Class


EndPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.EndPoint Property
DiagramConnectionSegment Class See Also Send Feedback
Gets or sets the end point of this DiagramConnectionSegment. Note that this value is also used for the start point of the next segment to this one.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point

See Also

DiagramConnectionSegment Class


IsHorizontal Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.IsHorizontal Property
DiagramConnectionSegment Class See Also Send Feedback
Gets whether the segment is horizontal. True if this DiagramConnectionSegment is horizontal. False otherwise. This DiagramConnectionSegment is horizontal if the y values of the start and end points are both the same. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsHorizontal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsHorizontal As Boolean

Remarks

Dependency Property Information
Identifier field | IsHorizontalProperty
Metadata properties set to true | None

See Also

DiagramConnectionSegment Class


IsVertical Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.IsVertical Property
DiagramConnectionSegment Class See Also Send Feedback
Gets the whether the segment is vertical. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsVertical { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsVertical As Boolean

Remarks

Dependency Property Information
Identifier field | IsVerticalProperty
Metadata properties set to true | None

See Also

DiagramConnectionSegment Class


Length Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.Length Property
DiagramConnectionSegment Class See Also Send Feedback
Returns the length of this DiagramConnectionSegment in double precision/>

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double

See Also

DiagramConnectionSegment Class


Midpoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.Midpoint Property
DiagramConnectionSegment Class See Also Send Feedback
Gets the midpoint of this DiagramConnectionSegment. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point Midpoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property Midpoint As Point

Remarks

Dependency Property Information
Identifier field | MidpointProperty
Metadata properties set to true | None

See Also

DiagramConnectionSegment Class


NextSegment Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.NextSegment Property
DiagramConnectionSegment Class See Also Send Feedback
Gets or sets the DiagramConnectionSegment that comes next in a chain of segments. Setting this property also makes sure that the previous segment of the set one is set to be this segment.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionSegment NextSegment { get; set; }
Visual Basic (Declaration)
Public Property NextSegment As DiagramConnectionSegment

See Also

DiagramConnectionSegment Class


PreviousSegment Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.PreviousSegment Property
DiagramConnectionSegment Class See Also Send Feedback
Gets or sets the DiagramConnectionSegment that comes previously before this one in a chain of segments. Setting this property alse makes sure that the next segment of the set one is set to be this segment.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionSegment PreviousSegment { get; set; }
Visual Basic (Declaration)
Public Property PreviousSegment As DiagramConnectionSegment

See Also

DiagramConnectionSegment Class


StartPoint Property

[image]

Mindscape WPF Diagrams
DiagramConnectionSegment..::.StartPoint Property
DiagramConnectionSegment Class See Also Send Feedback
Gets or sets the end point of the previous DiagramConnectionSegment to this one. If this DiagramConnectionSegment does not have a previous segment, then the start point of this DiagramConnectionSegment is its end point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point

See Also

DiagramConnectionSegment Class


DiagramElement Class

[image]

Mindscape WPF Diagrams
DiagramElement Class
Members See Also Send Feedback
Represents a visual element in a diagram (a node or connection).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DiagramElement : ListBoxItem
Visual Basic (Declaration)
Public MustInherit Class DiagramElement _
    Inherits ListBoxItem

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.WpfDiagramming.Foundation..::.DiagramElement
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionElement
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeElement

See Also

DiagramElement Members


DiagramElement Members

[image] [image]

Mindscape WPF Diagrams
DiagramElement Members
DiagramElement Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramElement type exposes the following members.

Constructors

Name | Description
DiagramElement |

Methods

Name | Description
GetStyleSelector | When overridden in a derived class, gets the StyleSelector applicable to this type of element.
MoveBy | Moves the DiagramElement by the specified amounts. Diagram elements which are not independently positioned will ignore this call.
OnApplyFormatting | When overridden in a derived class, applies additional formatting beyond the template and style selectors.
OnConnectionDragEnter | Called when a ConnectionPointThumb is being dragged over the element.
OnConnectionDragLeave | Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element.
OnContentChanged | Called when the Content changes. (Overrides ContentControl ..::. OnContentChanged(Object, Object).)
OnMoveBy | When overridden in a derived class, implements the MoveBy(Double, Double) method.
OnPreviewMouseDown | Called when the mouse is pressed over this element. (Overrides UIElement ..::. OnPreviewMouseDown(MouseButtonEventArgs).)

Fields

Name | Description
ConnectionPointTemplateSelectorProperty | Identifies the ConnectionPointTemplateSelector property.

Properties

Name | Description
Bounds | Gets the bounds of this DiagramElement.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for connection points. This is a dependency property.
LayerKeyCore | When overridden in a derived class, gets an object identifying the layer on which this DiagramElement is displayed, or null to specify that the element appears on the main diagram layer.
ZIndexLayer | Gets how the DiagramElement participates in the z-order.

See Also

DiagramElement Class


DiagramElement Constructor

[image]

Mindscape WPF Diagrams
DiagramElement Constructor
DiagramElement Class See Also Send Feedback
Initializes a new instance of the DiagramElement class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramElement()
Visual Basic (Declaration)
Protected Sub New

See Also

DiagramElement Class


DiagramElement Fields

[image] [image]

Mindscape WPF Diagrams
DiagramElement Fields
DiagramElement Class See Also Send Feedback

The DiagramElement type exposes the following members.

Fields

Name | Description
ConnectionPointTemplateSelectorProperty | Identifies the ConnectionPointTemplateSelector property.

See Also

DiagramElement Class


ConnectionPointTemplateSelectorProperty Field

[image]

Mindscape WPF Diagrams
DiagramElement..::.ConnectionPointTemplateSelectorProperty Field
DiagramElement Class See Also Send Feedback
Identifies the ConnectionPointTemplateSelector property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionPointTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionPointTemplateSelectorProperty As DependencyProperty

See Also

DiagramElement Class


DiagramElement Methods

[image] [image]

Mindscape WPF Diagrams
DiagramElement Methods
DiagramElement Class See Also Send Feedback

The DiagramElement type exposes the following members.

Methods

Name | Description
GetStyleSelector | When overridden in a derived class, gets the StyleSelector applicable to this type of element.
MoveBy | Moves the DiagramElement by the specified amounts. Diagram elements which are not independently positioned will ignore this call.
OnApplyFormatting | When overridden in a derived class, applies additional formatting beyond the template and style selectors.
OnConnectionDragEnter | Called when a ConnectionPointThumb is being dragged over the element.
OnConnectionDragLeave | Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element.
OnContentChanged | Called when the Content changes. (Overrides ContentControl ..::. OnContentChanged(Object, Object).)
OnMoveBy | When overridden in a derived class, implements the MoveBy(Double, Double) method.
OnPreviewMouseDown | Called when the mouse is pressed over this element. (Overrides UIElement ..::. OnPreviewMouseDown(MouseButtonEventArgs).)

See Also

DiagramElement Class


GetStyleSelector Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.GetStyleSelector Method
DiagramElement Class See Also Send Feedback
When overridden in a derived class, gets the StyleSelector applicable to this type of element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract StyleSelector GetStyleSelector(
    IDiagramFormatter formatter
)
Visual Basic (Declaration)
Protected MustOverride Function GetStyleSelector ( _
    formatter As IDiagramFormatter _
) As StyleSelector

Parameters

formatter
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramFormatter
The IDiagramFormatter from which to retrieve the selector.

Return Value

The StyleSelector to be used for this type of DiagramElement.

See Also

DiagramElement Class


MoveBy Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.MoveBy Method
DiagramElement Class See Also Send Feedback
Moves the DiagramElement by the specified amounts. Diagram elements which are not independently positioned will ignore this call.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void MoveBy(
    double horizontalChange,
    double verticalChange
)
Visual Basic (Declaration)
Public Sub MoveBy ( _
    horizontalChange As Double, _
    verticalChange As Double _
)

Parameters

horizontalChange
Type: System..::.Double
The amount to move horizontally.
verticalChange
Type: System..::.Double
The amount to move vertically.

See Also

DiagramElement Class


OnApplyFormatting Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.OnApplyFormatting Method
DiagramElement Class See Also Send Feedback
When overridden in a derived class, applies additional formatting beyond the template and style selectors.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual void OnApplyFormatting(
    DiagramSurface formattingSource
)
Visual Basic (Declaration)
Protected Overridable Sub OnApplyFormatting ( _
    formattingSource As DiagramSurface _
)

Parameters

formattingSource
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface on which the element is displayed.

See Also

DiagramElement Class


OnConnectionDragEnter Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.OnConnectionDragEnter Method
DiagramElement Class See Also Send Feedback
Called when a ConnectionPointThumb is being dragged over the element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal virtual void OnConnectionDragEnter(
    Nullable<Point> mousePoint,
    IDiagramConnectionPoint source
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnConnectionDragEnter ( _
    mousePoint As Nullable(Of Point), _
    source As IDiagramConnectionPoint _
)

Parameters

mousePoint
Type: System..::.Nullable <(Of <( Point >)>)
The mouse location of the dragged thumb.
source
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that is the source of the moving connection.

See Also

DiagramElement Class


OnConnectionDragLeave Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.OnConnectionDragLeave Method
DiagramElement Class See Also Send Feedback
Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal virtual void OnConnectionDragLeave()
Visual Basic (Declaration)
Protected Friend Overridable Sub OnConnectionDragLeave

See Also

DiagramElement Class


OnContentChanged Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.OnContentChanged Method
DiagramElement Class See Also Send Feedback
Called when the Content changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)

Parameters

oldContent
Type: System..::.Object
The old form of the Content property.
newContent
Type: System..::.Object
The new form of the Content property.

See Also

DiagramElement Class


OnMoveBy Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.OnMoveBy Method
DiagramElement Class See Also Send Feedback
When overridden in a derived class, implements the MoveBy(Double, Double) method.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract void OnMoveBy(
    double horizontalChange,
    double verticalChange
)
Visual Basic (Declaration)
Protected MustOverride Sub OnMoveBy ( _
    horizontalChange As Double, _
    verticalChange As Double _
)

Parameters

horizontalChange
Type: System..::.Double
The amount to move horizontally.
verticalChange
Type: System..::.Double
The amount to move vertically.

See Also

DiagramElement Class


OnPreviewMouseDown Method

[image]

Mindscape WPF Diagrams
DiagramElement..::.OnPreviewMouseDown Method
DiagramElement Class See Also Send Feedback
Called when the mouse is pressed over this element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnPreviewMouseDown(
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPreviewMouseDown ( _
    e As MouseButtonEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseButtonEventArgs
The event data.

See Also

DiagramElement Class


DiagramElement Properties

[image] [image]

Mindscape WPF Diagrams
DiagramElement Properties
DiagramElement Class See Also Send Feedback

The DiagramElement type exposes the following members.

Properties

Name | Description
Bounds | Gets the bounds of this DiagramElement.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for connection points. This is a dependency property.
LayerKeyCore | When overridden in a derived class, gets an object identifying the layer on which this DiagramElement is displayed, or null to specify that the element appears on the main diagram layer.
ZIndexLayer | Gets how the DiagramElement participates in the z-order.

See Also

DiagramElement Class


Bounds Property

[image]

Mindscape WPF Diagrams
DiagramElement..::.Bounds Property
DiagramElement Class See Also Send Feedback
Gets the bounds of this DiagramElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal virtual Rect Bounds { get; }
Visual Basic (Declaration)
Protected Friend Overridable ReadOnly Property Bounds As Rect

See Also

DiagramElement Class


ConnectionPointTemplateSelector Property

[image]

Mindscape WPF Diagrams
DiagramElement..::.ConnectionPointTemplateSelector Property
DiagramElement Class See Also Send Feedback
Gets or sets the DataTemplateSelector used to select the template for connection points. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplateSelector ConnectionPointTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ConnectionPointTemplateSelector As DataTemplateSelector

Remarks

Dependency Property Information
Identifier field | ConnectionPointTemplateSelectorProperty
Metadata properties set to true | None

See Also

DiagramElement Class


LayerKeyCore Property

[image]

Mindscape WPF Diagrams
DiagramElement..::.LayerKeyCore Property
DiagramElement Class See Also Send Feedback
When overridden in a derived class, gets an object identifying the layer on which this DiagramElement is displayed, or null to specify that the element appears on the main diagram layer.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual IDiagramPositionable LayerKeyCore { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property LayerKeyCore As IDiagramPositionable

Remarks

This is ignored if the ZIndexLayer is DiagramBackground or Topmost.

See Also

DiagramElement Class


ZIndexLayer Property

[image]

Mindscape WPF Diagrams
DiagramElement..::.ZIndexLayer Property
DiagramElement Class See Also Send Feedback
Gets how the DiagramElement participates in the z-order.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual ZIndexLayer ZIndexLayer { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ZIndexLayer As ZIndexLayer

See Also

DiagramElement Class


DiagramModelBase(TNode, TConnection) Class

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>) Class
Members See Also Send Feedback
Provides a base implementation of the IDiagramModel interface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DiagramModelBase<TNode, TConnection> : IDiagramModel where TNode : IDiagramNode where TConnection : IDiagramConnection
Visual Basic (Declaration)
Public MustInherit Class DiagramModelBase(Of TNode As IDiagramNode, TConnection As IDiagramConnection) _
    Implements IDiagramModel

Type Parameters

TNode
The type of nodes that this diagram supports.
TConnection
The type of connection that this diagram supports.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DiagramModelBase<(Of <(TNode, TConnection>)>)
Mindscape.WpfDiagramming..::.Diagram

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Members


DiagramModelBase(TNode, TConnection) Members

[image] [image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>) Members
DiagramModelBase<(Of <(TNode, TConnection>)>) Class Constructors Properties See Also Send Feedback

The DiagramModelBase<(Of <(TNode, TConnection>)>) type exposes the following members.

Constructors

Name | Description
DiagramModelBase<(Of <(TNode, TConnection>)>) | Initializes a new instance of the DiagramModelBase<(Of <(TNode, TConnection>)>) class.

Properties

Name | Description
ConnectionRelocator | Gets or sets the IDiagramConnectionRelocator for relocating connections in the diagram.
ConnectionRemover | Gets or sets the IDiagramConnectionRemover for removing connections from the diagram.
Connections | Gets the connections of the diagram.
CustomItems | Gets null.
DefaultConnectionBuilder | Gets or sets the default IDiagramConnectionBuilder for building diagram connections.
NodeRemover | Gets or sets the IDiagramNodeRemover for removing nodes from the diagram.
Nodes | Gets the nodes of the diagram.
Source | Gets the source of the diagram.

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


DiagramModelBase(TNode, TConnection) Constructor

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>) Constructor
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Initializes a new instance of the DiagramModelBase<(Of <(TNode, TConnection>)>) class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramModelBase()
Visual Basic (Declaration)
Protected Sub New

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


DiagramModelBase(TNode, TConnection) Properties

[image] [image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>) Properties
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback

The DiagramModelBase<(Of <(TNode, TConnection>)>) type exposes the following members.

Properties

Name | Description
ConnectionRelocator | Gets or sets the IDiagramConnectionRelocator for relocating connections in the diagram.
ConnectionRemover | Gets or sets the IDiagramConnectionRemover for removing connections from the diagram.
Connections | Gets the connections of the diagram.
CustomItems | Gets null.
DefaultConnectionBuilder | Gets or sets the default IDiagramConnectionBuilder for building diagram connections.
NodeRemover | Gets or sets the IDiagramNodeRemover for removing nodes from the diagram.
Nodes | Gets the nodes of the diagram.
Source | Gets the source of the diagram.

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


ConnectionRelocator Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.ConnectionRelocator Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets or sets the IDiagramConnectionRelocator for relocating connections in the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramConnectionRelocator ConnectionRelocator { get; set; }
Visual Basic (Declaration)
Public Overridable Property ConnectionRelocator As IDiagramConnectionRelocator

Implements

IDiagramModel..::.ConnectionRelocator

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


ConnectionRemover Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.ConnectionRemover Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets or sets the IDiagramConnectionRemover for removing connections from the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramConnectionRemover ConnectionRemover { get; set; }
Visual Basic (Declaration)
Public Overridable Property ConnectionRemover As IDiagramConnectionRemover

Implements

IDiagramModel..::.ConnectionRemover

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


Connections Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.Connections Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets the connections of the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IList<TConnection> Connections { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connections As IList(Of TConnection)

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


CustomItems Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.CustomItems Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets null.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IList CustomItems { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CustomItems As IList

Implements

IDiagramModel..::.CustomItems

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


DefaultConnectionBuilder Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.DefaultConnectionBuilder Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets or sets the default IDiagramConnectionBuilder for building diagram connections.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramConnectionBuilder DefaultConnectionBuilder { get; set; }
Visual Basic (Declaration)
Public Overridable Property DefaultConnectionBuilder As IDiagramConnectionBuilder

Implements

IDiagramModel..::.DefaultConnectionBuilder

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


NodeRemover Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.NodeRemover Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets or sets the IDiagramNodeRemover for removing nodes from the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramNodeRemover NodeRemover { get; set; }
Visual Basic (Declaration)
Public Overridable Property NodeRemover As IDiagramNodeRemover

Implements

IDiagramModel..::.NodeRemover

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


Nodes Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.Nodes Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets the nodes of the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IList<TNode> Nodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nodes As IList(Of TNode)

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


Source Property

[image]

Mindscape WPF Diagrams
DiagramModelBase<(Of <(TNode, TConnection>)>)..::.Source Property
DiagramModelBase<(Of <(TNode, TConnection>)>) Class See Also Send Feedback
Gets the source of the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract Object Source { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Source As Object

Implements

IDiagramModel..::.Source

See Also

DiagramModelBase<(Of <(TNode, TConnection>)>) Class


DiagramNodeBase(TConnectionPoint) Class

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class
Members See Also Send Feedback
Provides a base implementation for diagram nodes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class DiagramNodeBase<TConnectionPoint> : ViewModelBase, IDiagramNode,
    IDiagramPositionable, IDiagramZOrderable, IDiagramConnectable where TConnectionPoint : IDiagramConnectionPoint
Visual Basic (Declaration)
Public MustInherit Class DiagramNodeBase(Of TConnectionPoint As IDiagramConnectionPoint) _
    Inherits ViewModelBase _
    Implements IDiagramNode, IDiagramPositionable, IDiagramZOrderable, IDiagramConnectable

Type Parameters

TConnectionPoint
The type of connection points that can be attached to this node.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase<(Of <(TConnectionPoint>)>)
Mindscape.WpfDiagramming..::.DiagramNode

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Members


DiagramNodeBase(TConnectionPoint) Members

[image] [image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>) Members
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class Constructors Methods Properties Events See Also Send Feedback

The DiagramNodeBase<(Of <(TConnectionPoint>)>) type exposes the following members.

Constructors

Name | Description
DiagramNodeBase<(Of <(TConnectionPoint>)>) |

Methods

Name | Description
Clone | Returns an IDiagramNodeState that represents the current state of this DiagramNodeBase at the time this method is called.
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase.
OnBoundsChanged | Raises the BoundsChanged event.
OnDataChanged | Raises the DataChanged event.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this DiagramNodeBase to match those of the given IDiagramNodeState. This method can be overriden to include the setting of other properties introduced by sub classes.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node.
CanOriginateNewConnections | Returns true. DiagramNodeBase objects can accept any number of out going connections. This can be overriden to provide node specific logic.
CanReceiveNewConnections | Returns true. DiagramNodeBase objects can accept any number of incomming connections. This can be overriden to provide node specific logic.
ConnectionPoints | Gets a collection of connection points attached to this node.
Data | Gets the data represented by the node.
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified.
IsResizable | Gets or sets whether the DiagramNodeBase can be resized.
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden.
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>).
ZOrder | Gets or sets the relative z-order.

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes.
DataChanged | Raised when the Data property changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes.

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


DiagramNodeBase(TConnectionPoint) Constructor

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>) Constructor
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Initializes a new instance of the DiagramNodeBase<TConnectionPoint> class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramNodeBase()
Visual Basic (Declaration)
Protected Sub New

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


DiagramNodeBase(TConnectionPoint) Methods

[image] [image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>) Methods
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback

The DiagramNodeBase<(Of <(TConnectionPoint>)>) type exposes the following members.

Methods

Name | Description
Clone | Returns an IDiagramNodeState that represents the current state of this DiagramNodeBase at the time this method is called.
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase.
OnBoundsChanged | Raises the BoundsChanged event.
OnDataChanged | Raises the DataChanged event.
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this DiagramNodeBase to match those of the given IDiagramNodeState. This method can be overriden to include the setting of other properties introduced by sub classes.

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


Clone Method

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.Clone Method
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Returns an IDiagramNodeState that represents the current state of this DiagramNodeBase at the time this method is called.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramNodeState Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As IDiagramNodeState

Return Value

An IDiagramNodeState that represents the current state of this DiagramNodeBase.

Implements

IDiagramNode..::.Clone()()()

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


GetCollisionBounds Method

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.GetCollisionBounds Method
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Returns the value of the Bounds property of this DiagramNodeBase.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect GetCollisionBounds(
    IDiagramConnectionPoint connectionPoint
)
Visual Basic (Declaration)
Public Function GetCollisionBounds ( _
    connectionPoint As IDiagramConnectionPoint _
) As Rect

Parameters

connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
An IDiagramConnectionPoint to return the collision bounds of.

Return Value

The value of the Bounds property.

Implements

IDiagramConnectable..::.GetCollisionBounds(IDiagramConnectionPoint)

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


OnBoundsChanged Method

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.OnBoundsChanged Method
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Raises the BoundsChanged event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual void OnBoundsChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnBoundsChanged

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


OnDataChanged Method

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.OnDataChanged Method
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Raises the DataChanged event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual void OnDataChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnDataChanged

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


SetAs Method

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.SetAs Method
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Sets all the properties of this DiagramNodeBase to match those of the given IDiagramNodeState. This method can be overriden to include the setting of other properties introduced by sub classes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void SetAs(
    IDiagramNodeState state
)
Visual Basic (Declaration)
Public Overridable Sub SetAs ( _
    state As IDiagramNodeState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNodeState
The IDiagramNodeState that will have its property values applied to this DiagramNodeBase.

Implements

IDiagramNode..::.SetAs(IDiagramNodeState)

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


DiagramNodeBase(TConnectionPoint) Properties

[image] [image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>) Properties
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback

The DiagramNodeBase<(Of <(TConnectionPoint>)>) type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node.
CanOriginateNewConnections | Returns true. DiagramNodeBase objects can accept any number of out going connections. This can be overriden to provide node specific logic.
CanReceiveNewConnections | Returns true. DiagramNodeBase objects can accept any number of incomming connections. This can be overriden to provide node specific logic.
ConnectionPoints | Gets a collection of connection points attached to this node.
Data | Gets the data represented by the node.
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified.
IsResizable | Gets or sets whether the DiagramNodeBase can be resized.
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden.
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>).
ZOrder | Gets or sets the relative z-order.

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


Bounds Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.Bounds Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets or sets the display location and size of the node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As Rect

Implements

IDiagramPositionable..::.Bounds

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.CanOriginateNewConnections Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Returns true. DiagramNodeBase objects can accept any number of out going connections. This can be overriden to provide node specific logic.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.CanReceiveNewConnections Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Returns true. DiagramNodeBase objects can accept any number of incomming connections. This can be overriden to provide node specific logic.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


ConnectionPoints Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.ConnectionPoints Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets a collection of connection points attached to this node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract IList<TConnectionPoint> ConnectionPoints { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property ConnectionPoints As IList(Of TConnectionPoint)

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


Data Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.Data Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets the data represented by the node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Object

Implements

IDiagramConnectable..::.Data

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


DefaultConnectionPoint Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.DefaultConnectionPoint Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets the connection point to be used if a connection is attached to the node and no other connection point is specified.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramConnectionPoint DefaultConnectionPoint { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property DefaultConnectionPoint As IDiagramConnectionPoint

Implements

IDiagramNode..::.DefaultConnectionPoint

Remarks

This implementation always returns null to indicate that a specific connection point must always be used when creating a connection.

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


IsResizable Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.IsResizable Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets or sets whether the DiagramNodeBase can be resized.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsResizable { get; set; }
Visual Basic (Declaration)
Public Property IsResizable As Boolean

Implements

IDiagramPositionable..::.IsResizable

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


Parent Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.Parent Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual IDiagramPositionable Parent { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Parent As IDiagramPositionable

Implements

IDiagramPositionable..::.Parent

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


Rotation Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.Rotation Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual double Rotation { get; set; }
Visual Basic (Declaration)
Public Overridable Property Rotation As Double

Implements

IDiagramNode..::.Rotation

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


ZOrder Property

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.ZOrder Property
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Gets or sets the relative z-order.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double ZOrder { get; set; }
Visual Basic (Declaration)
Public Property ZOrder As Double

Implements

IDiagramZOrderable..::.ZOrder

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


DiagramNodeBase(TConnectionPoint) Events

[image] [image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>) Events
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback

The DiagramNodeBase<(Of <(TConnectionPoint>)>) type exposes the following members.

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes.
DataChanged | Raised when the Data property changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes.

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


BoundsChanged Event

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.BoundsChanged Event
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Raised when the Bounds property changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler BoundsChanged
Visual Basic (Declaration)
Public Event BoundsChanged As EventHandler

Implements

IDiagramPositionable..::.BoundsChanged

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


DataChanged Event

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.DataChanged Event
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Raised when the Data property changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler DataChanged
Visual Basic (Declaration)
Public Event DataChanged As EventHandler

Implements

IDiagramConnectable..::.DataChanged

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


RotationChanged Event

[image]

Mindscape WPF Diagrams
DiagramNodeBase<(Of <(TConnectionPoint>)>)..::.RotationChanged Event
DiagramNodeBase<(Of <(TConnectionPoint>)>) Class See Also Send Feedback
Raised when the Rotation property changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler RotationChanged
Visual Basic (Declaration)
Public Event RotationChanged As EventHandler

Implements

IDiagramNode..::.RotationChanged

See Also

DiagramNodeBase<(Of <(TConnectionPoint>)>) Class


DiagramNodeElement Class

[image]

Mindscape WPF Diagrams
DiagramNodeElement Class
Members See Also Send Feedback
Represents a node (content element) on a diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramNodeElement : DiagramElement
Visual Basic (Declaration)
Public Class DiagramNodeElement _
    Inherits DiagramElement

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls..::.ListBoxItem
Mindscape.WpfDiagramming.Foundation..::.DiagramElement
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeElement

See Also

DiagramNodeElement Members


DiagramNodeElement Members

[image] [image]

Mindscape WPF Diagrams
DiagramNodeElement Members
DiagramNodeElement Class Constructors Methods Fields Properties Events See Also Send Feedback

The DiagramNodeElement type exposes the following members.

Constructors

Name | Description
DiagramNodeElement |

Methods

Name | Description
FindMouseOverConnectionPoint | Returns the IDiagramConnectionPoint on this node that the mouse is currently over. Returns false if the mouse is not currently over any connection point.
GetIsGeometryProvider | Gets whether or not a binding should be made between the Geometry property of this DiagramNodeElement and the Data property that the IsGeometryProvider attached property is attached to.
GetRaisesBoundsChangeRequested | Gets whether or not the FrameworkElement that the RaisesBoundsChangeRequested attached property is attached to should cause a DiagramNodeElement to raise the BoundsChangeRequested event.
GetStyleSelector | Gets the StyleSelector applicable to this type of element. (Overrides DiagramElement ..::. GetStyleSelector(IDiagramFormatter).)
HideConnectionPointControls | Hides connection points by setting the IsToConnectionDragOver and IsFromConnectionDragOver property values.
MoveBy | Moves the DiagramElement by the specified amounts. Diagram elements which are not independently positioned will ignore this call. (Inherited from DiagramElement.)
OnApplyFormatting | Applies additional formatting beyond the template and style selectors. (Overrides DiagramElement ..::. OnApplyFormatting(DiagramSurface).)
OnConnectionDragEnter | Called when a ConnectionPointThumb is being dragged over the element. (Overrides DiagramElement ..::. OnConnectionDragEnter(Nullable<(Of <(Point>)>), IDiagramConnectionPoint).)
OnConnectionDragLeave | Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element. (Overrides DiagramElement ..::. OnConnectionDragLeave()()().)
OnContentChanged | Called when the Content changes. (Overrides DiagramElement ..::. OnContentChanged(Object, Object).)
OnMoveBy | Implements the MoveBy(Double, Double) method. (Overrides DiagramElement ..::. OnMoveBy(Double, Double).)
OnPreviewMouseDown | Called when the mouse is pressed over this element. (Inherited from DiagramElement.)
SetIsGeometryProvider | Sets whether or not a binding should be made between the Geometry property of this DiagramNodeElement and the Data property that the IsGeometryProvider attached property is attached to.
SetRaisesBoundsChangeRequested | Sets whether or not the FrameworkElement that the RaisesBoundsChangeRequested attached property is attached to should cause a DiagramNodeElement to raise the BoundsChangeRequested event.
ShowConnectionPointControls | Allows connection points to be visible by setting the IsToConnectionDragOver and IsFromConnectionDragOver property values.

Fields

Name | Description
BoundsChangeRequestedEvent | Identifies the BoundsChangeRequested routed event.
ConnectionPointPositionsProperty | Identifies the ConnectionPointPositions property.
GeometryProperty | Identifies the PathGeometry property.
IsFromConnectionDragOverProperty | Identifies the IsFromConnectionDragOver property.
IsGeometryProviderProperty | Identifies the IsGeometryProvider property.
IsResizableProperty | Identifies the IsResizable property.
IsToConnectionDragOverProperty | Identifies the IsToConnectionDragOver property.
LeftProperty | Identifies the Left property.
NodeContentTemplateSelectorProperty | Identifies the NodeContentTemplateSelector property.
NodeTemplateProperty | Identifies the NodeTemplate property.
RaisesBoundsChangeRequestedProperty | Identifies the RaisesBoundsChangeRequested property.
ShowConnectionPointsProperty | Identifies the ShowConnectionPoints property.
TopProperty | Identifies the Top property.

Properties

Name | Description
Bounds | Gets the bounds of this DiagramNodeElement. (Overrides DiagramElement ..::. Bounds.)
ConnectionPointPositions | Gets or sets a collection of ShapeConnectionPointPosition objects that specify how connection points should be positioned on the DiagramNodeElement. This is a dependency property.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for connection points. This is a dependency property. (Inherited from DiagramElement.)
Geometry | Gets or sets the boundary shape of the node. This is a dependency property.
IsFromConnectionDragOver | Gets whether or not the mouse is being dragged over this DiagramNodeElement allowing the outbound connection points to be displayed. This is a dependency property.
IsResizable | Gets or sets whether the DiagramNodeElement can be resized. This is a dependency property.
IsToConnectionDragOver | Gets whether or not the mouse is being dragged over this DiagramNodeElement allowing the inbound connection points to be displayed. This is a dependency property.
LayerKeyCore | Gets an object identifying the layer on which to display this element. For a DiagramNodeElement, this is the parent of the originating node. (Overrides DiagramElement ..::. LayerKeyCore.)
Left | Gets or sets the the horizontal offset of the DiagramNodeElement from the left hand side of the diagram. This is a dependency property.
Node | Gets the IDiagramNode represented by this DiagramNodeElement.
NodeContentTemplateSelector | Gets or sets the DataTemplateSelector used to the select the DataTemplate for displaying the data within the IDiagramNode. This is a dependency property.
NodeTemplate | Gets or sets the DataTemplate used to give shape and color to the node. This is a dependency property.
ShowConnectionPoints | Gets or sets whether to show connection points. This is a dependency property.
Top | Gets or sets the the vertical offset of the DiagramNodeElement from the top of the diagram. This is a dependency property.
ZIndexLayer | Gets how the DiagramElement participates in the z-order. (Inherited from DiagramElement.)

Events

Name | Description
BoundsChangeRequested | Occurs whenever a bounds change for this DiagramNodeElement is requested.

See Also

DiagramNodeElement Class


DiagramNodeElement Constructor

[image]

Mindscape WPF Diagrams
DiagramNodeElement Constructor
DiagramNodeElement Class See Also Send Feedback
Initializes a new instance of the DiagramNodeElement class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramNodeElement()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramNodeElement Class


DiagramNodeElement Fields

[image] [image]

Mindscape WPF Diagrams
DiagramNodeElement Fields
DiagramNodeElement Class See Also Send Feedback

The DiagramNodeElement type exposes the following members.

Fields

Name | Description
BoundsChangeRequestedEvent | Identifies the BoundsChangeRequested routed event.
ConnectionPointPositionsProperty | Identifies the ConnectionPointPositions property.
GeometryProperty | Identifies the PathGeometry property.
IsFromConnectionDragOverProperty | Identifies the IsFromConnectionDragOver property.
IsGeometryProviderProperty | Identifies the IsGeometryProvider property.
IsResizableProperty | Identifies the IsResizable property.
IsToConnectionDragOverProperty | Identifies the IsToConnectionDragOver property.
LeftProperty | Identifies the Left property.
NodeContentTemplateSelectorProperty | Identifies the NodeContentTemplateSelector property.
NodeTemplateProperty | Identifies the NodeTemplate property.
RaisesBoundsChangeRequestedProperty | Identifies the RaisesBoundsChangeRequested property.
ShowConnectionPointsProperty | Identifies the ShowConnectionPoints property.
TopProperty | Identifies the Top property.

See Also

DiagramNodeElement Class


BoundsChangeRequestedEvent Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.BoundsChangeRequestedEvent Field
DiagramNodeElement Class See Also Send Feedback
Identifies the BoundsChangeRequested routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent BoundsChangeRequestedEvent
Visual Basic (Declaration)
Public Shared ReadOnly BoundsChangeRequestedEvent As RoutedEvent

See Also

DiagramNodeElement Class


ConnectionPointPositionsProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.ConnectionPointPositionsProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the ConnectionPointPositions property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ConnectionPointPositionsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionPointPositionsProperty As DependencyProperty

See Also

DiagramNodeElement Class


GeometryProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.GeometryProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the PathGeometry property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty GeometryProperty
Visual Basic (Declaration)
Public Shared ReadOnly GeometryProperty As DependencyProperty

See Also

DiagramNodeElement Class


IsFromConnectionDragOverProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.IsFromConnectionDragOverProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the IsFromConnectionDragOver property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsFromConnectionDragOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFromConnectionDragOverProperty As DependencyProperty

See Also

DiagramNodeElement Class


IsGeometryProviderProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.IsGeometryProviderProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the IsGeometryProvider property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsGeometryProviderProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsGeometryProviderProperty As DependencyProperty

See Also

DiagramNodeElement Class


IsResizableProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.IsResizableProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the IsResizable property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsResizableProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsResizableProperty As DependencyProperty

See Also

DiagramNodeElement Class


IsToConnectionDragOverProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.IsToConnectionDragOverProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the IsToConnectionDragOver property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsToConnectionDragOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsToConnectionDragOverProperty As DependencyProperty

See Also

DiagramNodeElement Class


LeftProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.LeftProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the Left property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty LeftProperty
Visual Basic (Declaration)
Public Shared ReadOnly LeftProperty As DependencyProperty

See Also

DiagramNodeElement Class


NodeContentTemplateSelectorProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.NodeContentTemplateSelectorProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the NodeContentTemplateSelector property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty NodeContentTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly NodeContentTemplateSelectorProperty As DependencyProperty

See Also

DiagramNodeElement Class


NodeTemplateProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.NodeTemplateProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the NodeTemplate property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty NodeTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly NodeTemplateProperty As DependencyProperty

See Also

DiagramNodeElement Class


RaisesBoundsChangeRequestedProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.RaisesBoundsChangeRequestedProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the RaisesBoundsChangeRequested property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty RaisesBoundsChangeRequestedProperty
Visual Basic (Declaration)
Public Shared ReadOnly RaisesBoundsChangeRequestedProperty As DependencyProperty

See Also

DiagramNodeElement Class


ShowConnectionPointsProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.ShowConnectionPointsProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the ShowConnectionPoints property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ShowConnectionPointsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowConnectionPointsProperty As DependencyProperty

See Also

DiagramNodeElement Class


TopProperty Field

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.TopProperty Field
DiagramNodeElement Class See Also Send Feedback
Identifies the Top property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty TopProperty
Visual Basic (Declaration)
Public Shared ReadOnly TopProperty As DependencyProperty

See Also

DiagramNodeElement Class


DiagramNodeElement Methods

[image] [image]

Mindscape WPF Diagrams
DiagramNodeElement Methods
DiagramNodeElement Class See Also Send Feedback

The DiagramNodeElement type exposes the following members.

Methods

Name | Description
FindMouseOverConnectionPoint | Returns the IDiagramConnectionPoint on this node that the mouse is currently over. Returns false if the mouse is not currently over any connection point.
GetIsGeometryProvider | Gets whether or not a binding should be made between the Geometry property of this DiagramNodeElement and the Data property that the IsGeometryProvider attached property is attached to.
GetRaisesBoundsChangeRequested | Gets whether or not the FrameworkElement that the RaisesBoundsChangeRequested attached property is attached to should cause a DiagramNodeElement to raise the BoundsChangeRequested event.
GetStyleSelector | Gets the StyleSelector applicable to this type of element. (Overrides DiagramElement ..::. GetStyleSelector(IDiagramFormatter).)
HideConnectionPointControls | Hides connection points by setting the IsToConnectionDragOver and IsFromConnectionDragOver property values.
MoveBy | Moves the DiagramElement by the specified amounts. Diagram elements which are not independently positioned will ignore this call. (Inherited from DiagramElement.)
OnApplyFormatting | Applies additional formatting beyond the template and style selectors. (Overrides DiagramElement ..::. OnApplyFormatting(DiagramSurface).)
OnConnectionDragEnter | Called when a ConnectionPointThumb is being dragged over the element. (Overrides DiagramElement ..::. OnConnectionDragEnter(Nullable<(Of <(Point>)>), IDiagramConnectionPoint).)
OnConnectionDragLeave | Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element. (Overrides DiagramElement ..::. OnConnectionDragLeave()()().)
OnContentChanged | Called when the Content changes. (Overrides DiagramElement ..::. OnContentChanged(Object, Object).)
OnMoveBy | Implements the MoveBy(Double, Double) method. (Overrides DiagramElement ..::. OnMoveBy(Double, Double).)
OnPreviewMouseDown | Called when the mouse is pressed over this element. (Inherited from DiagramElement.)
SetIsGeometryProvider | Sets whether or not a binding should be made between the Geometry property of this DiagramNodeElement and the Data property that the IsGeometryProvider attached property is attached to.
SetRaisesBoundsChangeRequested | Sets whether or not the FrameworkElement that the RaisesBoundsChangeRequested attached property is attached to should cause a DiagramNodeElement to raise the BoundsChangeRequested event.
ShowConnectionPointControls | Allows connection points to be visible by setting the IsToConnectionDragOver and IsFromConnectionDragOver property values.

See Also

DiagramNodeElement Class


FindMouseOverConnectionPoint Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.FindMouseOverConnectionPoint Method
DiagramNodeElement Class See Also Send Feedback
Returns the IDiagramConnectionPoint on this node that the mouse is currently over. Returns false if the mouse is not currently over any connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramConnectionPoint FindMouseOverConnectionPoint()
Visual Basic (Declaration)
Public Function FindMouseOverConnectionPoint As IDiagramConnectionPoint

Return Value

The IDiagramConnectionPoint that the mouse is currently over.

See Also

DiagramNodeElement Class


GetIsGeometryProvider Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.GetIsGeometryProvider Method
DiagramNodeElement Class See Also Send Feedback
Gets whether or not a binding should be made between the Geometry property of this DiagramNodeElement and the Data property that the IsGeometryProvider attached property is attached to.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static bool GetIsGeometryProvider(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetIsGeometryProvider ( _
    element As DependencyObject _
) As Boolean

Parameters

element
Type: System.Windows..::.DependencyObject
The DependencyObject to get the value from.

Return Value

The value of the IsGeometryProvider attached property.

See Also

DiagramNodeElement Class


GetRaisesBoundsChangeRequested Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.GetRaisesBoundsChangeRequested Method
DiagramNodeElement Class See Also Send Feedback
Gets whether or not the FrameworkElement that the RaisesBoundsChangeRequested attached property is attached to should cause a DiagramNodeElement to raise the BoundsChangeRequested event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static bool GetRaisesBoundsChangeRequested(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetRaisesBoundsChangeRequested ( _
    element As DependencyObject _
) As Boolean

Parameters

element
Type: System.Windows..::.DependencyObject
The DependencyObject to get the value from.

Return Value

The value of the RaisesBoundsChangeRequested attached property.

See Also

DiagramNodeElement Class


GetStyleSelector Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.GetStyleSelector Method
DiagramNodeElement Class See Also Send Feedback
Gets the StyleSelector applicable to this type of element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override StyleSelector GetStyleSelector(
    IDiagramFormatter formatter
)
Visual Basic (Declaration)
Protected Overrides Function GetStyleSelector ( _
    formatter As IDiagramFormatter _
) As StyleSelector

Parameters

formatter
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramFormatter
The IDiagramFormatter from which to retrieve the selector.

Return Value

The StyleSelector to be used for this type of DiagramElement.

See Also

DiagramNodeElement Class


HideConnectionPointControls Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.HideConnectionPointControls Method
DiagramNodeElement Class See Also Send Feedback
Hides connection points by setting the IsToConnectionDragOver and IsFromConnectionDragOver property values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void HideConnectionPointControls(
    ConnectionPointShowFlags showFlags
)
Visual Basic (Declaration)
Public Sub HideConnectionPointControls ( _
    showFlags As ConnectionPointShowFlags _
)

Parameters

showFlags
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionPointShowFlags
States which connection points to hide.

See Also

DiagramNodeElement Class


OnApplyFormatting Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.OnApplyFormatting Method
DiagramNodeElement Class See Also Send Feedback
Applies additional formatting beyond the template and style selectors.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnApplyFormatting(
    DiagramSurface formattingSource
)
Visual Basic (Declaration)
Protected Overrides Sub OnApplyFormatting ( _
    formattingSource As DiagramSurface _
)

Parameters

formattingSource
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface on which the element is displayed.

See Also

DiagramNodeElement Class


OnConnectionDragEnter Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.OnConnectionDragEnter Method
DiagramNodeElement Class See Also Send Feedback
Called when a ConnectionPointThumb is being dragged over the element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal override void OnConnectionDragEnter(
    Nullable<Point> mousePoint,
    IDiagramConnectionPoint source
)
Visual Basic (Declaration)
Protected Friend Overrides Sub OnConnectionDragEnter ( _
    mousePoint As Nullable(Of Point), _
    source As IDiagramConnectionPoint _
)

Parameters

mousePoint
Type: System..::.Nullable <(Of <( Point >)>)
The mouse location of the dragged thumb.
source
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that is the source of the moving connection.

See Also

DiagramNodeElement Class


OnConnectionDragLeave Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.OnConnectionDragLeave Method
DiagramNodeElement Class See Also Send Feedback
Called when a ConnectionPointThumb that was being dragged over the element is dragged away from the element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal override void OnConnectionDragLeave()
Visual Basic (Declaration)
Protected Friend Overrides Sub OnConnectionDragLeave

See Also

DiagramNodeElement Class


OnContentChanged Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.OnContentChanged Method
DiagramNodeElement Class See Also Send Feedback
Called when the Content changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)

Parameters

oldContent
Type: System..::.Object
The old form of the Content property.
newContent
Type: System..::.Object
The new form of the Content property.

See Also

DiagramNodeElement Class


OnMoveBy Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.OnMoveBy Method
DiagramNodeElement Class See Also Send Feedback
Implements the MoveBy(Double, Double) method.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnMoveBy(
    double horizontalChange,
    double verticalChange
)
Visual Basic (Declaration)
Protected Overrides Sub OnMoveBy ( _
    horizontalChange As Double, _
    verticalChange As Double _
)

Parameters

horizontalChange
Type: System..::.Double
The amount to move horizontally.
verticalChange
Type: System..::.Double
The amount to move vertically.

See Also

DiagramNodeElement Class


SetIsGeometryProvider Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.SetIsGeometryProvider Method
DiagramNodeElement Class See Also Send Feedback
Sets whether or not a binding should be made between the Geometry property of this DiagramNodeElement and the Data property that the IsGeometryProvider attached property is attached to.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetIsGeometryProvider(
    DependencyObject element,
    bool value
)
Visual Basic (Declaration)
Public Shared Sub SetIsGeometryProvider ( _
    element As DependencyObject, _
    value As Boolean _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The DependencyObject to set the value to.
value
Type: System..::.Boolean
The value to set to the IsGeometryProvider attached property.

See Also

DiagramNodeElement Class


SetRaisesBoundsChangeRequested Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.SetRaisesBoundsChangeRequested Method
DiagramNodeElement Class See Also Send Feedback
Sets whether or not the FrameworkElement that the RaisesBoundsChangeRequested attached property is attached to should cause a DiagramNodeElement to raise the BoundsChangeRequested event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetRaisesBoundsChangeRequested(
    DependencyObject element,
    bool value
)
Visual Basic (Declaration)
Public Shared Sub SetRaisesBoundsChangeRequested ( _
    element As DependencyObject, _
    value As Boolean _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The DependencyObject to set the value to.
value
Type: System..::.Boolean
The value to set to the RaisesBoundsChangeRequested attached property.

See Also

DiagramNodeElement Class


ShowConnectionPointControls Method

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.ShowConnectionPointControls Method
DiagramNodeElement Class See Also Send Feedback
Allows connection points to be visible by setting the IsToConnectionDragOver and IsFromConnectionDragOver property values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void ShowConnectionPointControls(
    ConnectionPointShowFlags showFlags
)
Visual Basic (Declaration)
Public Sub ShowConnectionPointControls ( _
    showFlags As ConnectionPointShowFlags _
)

Parameters

showFlags
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionPointShowFlags
States which connection points should be made visible.

See Also

DiagramNodeElement Class


DiagramNodeElement Properties

[image] [image]

Mindscape WPF Diagrams
DiagramNodeElement Properties
DiagramNodeElement Class See Also Send Feedback

The DiagramNodeElement type exposes the following members.

Properties

Name | Description
Bounds | Gets the bounds of this DiagramNodeElement. (Overrides DiagramElement ..::. Bounds.)
ConnectionPointPositions | Gets or sets a collection of ShapeConnectionPointPosition objects that specify how connection points should be positioned on the DiagramNodeElement. This is a dependency property.
ConnectionPointTemplateSelector | Gets or sets the DataTemplateSelector used to select the template for connection points. This is a dependency property. (Inherited from DiagramElement.)
Geometry | Gets or sets the boundary shape of the node. This is a dependency property.
IsFromConnectionDragOver | Gets whether or not the mouse is being dragged over this DiagramNodeElement allowing the outbound connection points to be displayed. This is a dependency property.
IsResizable | Gets or sets whether the DiagramNodeElement can be resized. This is a dependency property.
IsToConnectionDragOver | Gets whether or not the mouse is being dragged over this DiagramNodeElement allowing the inbound connection points to be displayed. This is a dependency property.
LayerKeyCore | Gets an object identifying the layer on which to display this element. For a DiagramNodeElement, this is the parent of the originating node. (Overrides DiagramElement ..::. LayerKeyCore.)
Left | Gets or sets the the horizontal offset of the DiagramNodeElement from the left hand side of the diagram. This is a dependency property.
Node | Gets the IDiagramNode represented by this DiagramNodeElement.
NodeContentTemplateSelector | Gets or sets the DataTemplateSelector used to the select the DataTemplate for displaying the data within the IDiagramNode. This is a dependency property.
NodeTemplate | Gets or sets the DataTemplate used to give shape and color to the node. This is a dependency property.
ShowConnectionPoints | Gets or sets whether to show connection points. This is a dependency property.
Top | Gets or sets the the vertical offset of the DiagramNodeElement from the top of the diagram. This is a dependency property.
ZIndexLayer | Gets how the DiagramElement participates in the z-order. (Inherited from DiagramElement.)

See Also

DiagramNodeElement Class


Bounds Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.Bounds Property
DiagramNodeElement Class See Also Send Feedback
Gets the bounds of this DiagramNodeElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected internal override Rect Bounds { get; }
Visual Basic (Declaration)
Protected Friend Overrides ReadOnly Property Bounds As Rect

See Also

DiagramNodeElement Class


ConnectionPointPositions Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.ConnectionPointPositions Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets a collection of ShapeConnectionPointPosition objects that specify how connection points should be positioned on the DiagramNodeElement. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[TypeConverterAttribute(typeof(ShapeConnectionPointPositionCollectionConverter))]
public List<ShapeConnectionPointPosition> ConnectionPointPositions { get; set; }
Visual Basic (Declaration)
<TypeConverterAttribute(GetType(ShapeConnectionPointPositionCollectionConverter))> _
Public Property ConnectionPointPositions As List(Of ShapeConnectionPointPosition)

Remarks

Dependency Property Information
Identifier field | ConnectionPointPositionsProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


Geometry Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.Geometry Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets the boundary shape of the node. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Geometry Geometry { get; set; }
Visual Basic (Declaration)
Public Property Geometry As Geometry

Remarks

Dependency Property Information
Identifier field | GeometryProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


IsFromConnectionDragOver Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.IsFromConnectionDragOver Property
DiagramNodeElement Class See Also Send Feedback
Gets whether or not the mouse is being dragged over this DiagramNodeElement allowing the outbound connection points to be displayed. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsFromConnectionDragOver { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFromConnectionDragOver As Boolean

Remarks

Dependency Property Information
Identifier field | IsFromConnectionDragOverProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


IsResizable Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.IsResizable Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets whether the DiagramNodeElement can be resized. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsResizable { get; set; }
Visual Basic (Declaration)
Public Property IsResizable As Boolean

Remarks

Dependency Property Information
Identifier field | IsResizableProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


IsToConnectionDragOver Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.IsToConnectionDragOver Property
DiagramNodeElement Class See Also Send Feedback
Gets whether or not the mouse is being dragged over this DiagramNodeElement allowing the inbound connection points to be displayed. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsToConnectionDragOver { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsToConnectionDragOver As Boolean

Remarks

Dependency Property Information
Identifier field | IsToConnectionDragOverProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


LayerKeyCore Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.LayerKeyCore Property
DiagramNodeElement Class See Also Send Feedback
Gets an object identifying the layer on which to display this element. For a DiagramNodeElement, this is the parent of the originating node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override IDiagramPositionable LayerKeyCore { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LayerKeyCore As IDiagramPositionable

See Also

DiagramNodeElement Class


Left Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.Left Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets the the horizontal offset of the DiagramNodeElement from the left hand side of the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Double

Remarks

Dependency Property Information
Identifier field | LeftProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


Node Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.Node Property
DiagramNodeElement Class See Also Send Feedback
Gets the IDiagramNode represented by this DiagramNodeElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramNode Node { get; }
Visual Basic (Declaration)
Public ReadOnly Property Node As IDiagramNode

See Also

DiagramNodeElement Class


NodeContentTemplateSelector Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.NodeContentTemplateSelector Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets the DataTemplateSelector used to the select the DataTemplate for displaying the data within the IDiagramNode. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplateSelector NodeContentTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property NodeContentTemplateSelector As DataTemplateSelector

Remarks

Dependency Property Information
Identifier field | NodeContentTemplateSelectorProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


NodeTemplate Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.NodeTemplate Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets the DataTemplate used to give shape and color to the node. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate NodeTemplate { get; set; }
Visual Basic (Declaration)
Public Property NodeTemplate As DataTemplate

Remarks

Dependency Property Information
Identifier field | NodeTemplateProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


ShowConnectionPoints Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.ShowConnectionPoints Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets whether to show connection points. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool ShowConnectionPoints { get; set; }
Visual Basic (Declaration)
Public Property ShowConnectionPoints As Boolean

Remarks

Dependency Property Information
Identifier field | ShowConnectionPointsProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


Top Property

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.Top Property
DiagramNodeElement Class See Also Send Feedback
Gets or sets the the vertical offset of the DiagramNodeElement from the top of the diagram. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Double

Remarks

Dependency Property Information
Identifier field | TopProperty
Metadata properties set to true | None

See Also

DiagramNodeElement Class


DiagramNodeElement Events

[image] [image]

Mindscape WPF Diagrams
DiagramNodeElement Events
DiagramNodeElement Class See Also Send Feedback

The DiagramNodeElement type exposes the following members.

Events

Name | Description
BoundsChangeRequested | Occurs whenever a bounds change for this DiagramNodeElement is requested.

See Also

DiagramNodeElement Class


BoundsChangeRequested Event

[image]

Mindscape WPF Diagrams
DiagramNodeElement..::.BoundsChangeRequested Event
DiagramNodeElement Class See Also Send Feedback
Occurs whenever a bounds change for this DiagramNodeElement is requested.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<BoundsChangeRequestedEventArgs> BoundsChangeRequested
Visual Basic (Declaration)
Public Event BoundsChangeRequested As EventHandler(Of BoundsChangeRequestedEventArgs)

See Also

DiagramNodeElement Class


DiagramPrintDocument Class

[image]

Mindscape WPF Diagrams
DiagramPrintDocument Class
Members See Also Send Feedback
Contains information used when printing a diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramPrintDocument
Visual Basic (Declaration)
Public Class DiagramPrintDocument

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DiagramPrintDocument

See Also

DiagramPrintDocument Members


DiagramPrintDocument Members

[image] [image]

Mindscape WPF Diagrams
DiagramPrintDocument Members
DiagramPrintDocument Class Properties See Also Send Feedback

The DiagramPrintDocument type exposes the following members.

Properties

Name | Description
Document | A FixedDocument suitable for printing.
PageCountHorizontal | The number of pages occupied horizontally by the diagram.
PageCountVertical | The number of pages occupied vertically by the diagram.

See Also

DiagramPrintDocument Class


DiagramPrintDocument Properties

[image] [image]

Mindscape WPF Diagrams
DiagramPrintDocument Properties
DiagramPrintDocument Class See Also Send Feedback

The DiagramPrintDocument type exposes the following members.

Properties

Name | Description
Document | A FixedDocument suitable for printing.
PageCountHorizontal | The number of pages occupied horizontally by the diagram.
PageCountVertical | The number of pages occupied vertically by the diagram.

See Also

DiagramPrintDocument Class


Document Property

[image]

Mindscape WPF Diagrams
DiagramPrintDocument..::.Document Property
DiagramPrintDocument Class See Also Send Feedback
A FixedDocument suitable for printing.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FixedDocument Document { get; }
Visual Basic (Declaration)
Public ReadOnly Property Document As FixedDocument

Remarks

The page order within the document is left to right, top to bottom. For example, if the diagram requires 3 pages horizontally and 2 pages vertically, then page 1 is the top left, page 3 the top right, page 4 the bottom left, and page 6 the bottom right.

See Also

DiagramPrintDocument Class


PageCountHorizontal Property

[image]

Mindscape WPF Diagrams
DiagramPrintDocument..::.PageCountHorizontal Property
DiagramPrintDocument Class See Also Send Feedback
The number of pages occupied horizontally by the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int PageCountHorizontal { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCountHorizontal As Integer

See Also

DiagramPrintDocument Class


PageCountVertical Property

[image]

Mindscape WPF Diagrams
DiagramPrintDocument..::.PageCountVertical Property
DiagramPrintDocument Class See Also Send Feedback
The number of pages occupied vertically by the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int PageCountVertical { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCountVertical As Integer

See Also

DiagramPrintDocument Class


DiagramScrollContentPresenter Class

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter Class
Members See Also Send Feedback
Displays the content of a DiagramScrollViewer control.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramScrollContentPresenter : ContentPresenter
Visual Basic (Declaration)
Public Class DiagramScrollContentPresenter _
    Inherits ContentPresenter

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.ContentPresenter
Mindscape.WpfDiagramming.Foundation..::.DiagramScrollContentPresenter

See Also

DiagramScrollContentPresenter Members


DiagramScrollContentPresenter Members

[image] [image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter Members
DiagramScrollContentPresenter Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramScrollContentPresenter type exposes the following members.

Constructors

Name | Description
DiagramScrollContentPresenter |

Methods

Name | Description
ArrangeOverride | Positions the single child element and determines the content of a DiagramScrollContentPresenter. (Overrides ContentPresenter ..::. ArrangeOverride(Size).)
GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Overrides FrameworkElement ..::. GetLayoutClip(Size).)

Fields

Name | Description
HorizontalOffsetProperty | Identifies the HorizontalOffset property.
VerticalOffsetProperty | Identifies the VerticalOffset property.

Properties

Name | Description
HorizontalOffset | Gets or sets the horizontal offset (scroll position). This is a dependency property.
VerticalOffset | Gets or sets the vertical offset (scroll position). This is a dependency property.

See Also

DiagramScrollContentPresenter Class


DiagramScrollContentPresenter Constructor

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter Constructor
DiagramScrollContentPresenter Class See Also Send Feedback
Initializes a new instance of the DiagramScrollContentPresenter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramScrollContentPresenter()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramScrollContentPresenter Class


DiagramScrollContentPresenter Fields

[image] [image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter Fields
DiagramScrollContentPresenter Class See Also Send Feedback

The DiagramScrollContentPresenter type exposes the following members.

Fields

Name | Description
HorizontalOffsetProperty | Identifies the HorizontalOffset property.
VerticalOffsetProperty | Identifies the VerticalOffset property.

See Also

DiagramScrollContentPresenter Class


HorizontalOffsetProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter..::.HorizontalOffsetProperty Field
DiagramScrollContentPresenter Class See Also Send Feedback
Identifies the HorizontalOffset property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty HorizontalOffsetProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalOffsetProperty As DependencyProperty

See Also

DiagramScrollContentPresenter Class


VerticalOffsetProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter..::.VerticalOffsetProperty Field
DiagramScrollContentPresenter Class See Also Send Feedback
Identifies the VerticalOffset property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty VerticalOffsetProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalOffsetProperty As DependencyProperty

See Also

DiagramScrollContentPresenter Class


DiagramScrollContentPresenter Methods

[image] [image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter Methods
DiagramScrollContentPresenter Class See Also Send Feedback

The DiagramScrollContentPresenter type exposes the following members.

Methods

Name | Description
ArrangeOverride | Positions the single child element and determines the content of a DiagramScrollContentPresenter. (Overrides ContentPresenter ..::. ArrangeOverride(Size).)
GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Overrides FrameworkElement ..::. GetLayoutClip(Size).)

See Also

DiagramScrollContentPresenter Class


ArrangeOverride Method

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter..::.ArrangeOverride Method
DiagramScrollContentPresenter Class See Also Send Feedback
Positions the single child element and determines the content of a DiagramScrollContentPresenter.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Size ArrangeOverride(
    Size arrangeSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    arrangeSize As Size _
) As Size

Parameters

arrangeSize
Type: System.Windows..::.Size
The size that this DiagramScrollContentPresenter should use to arrange its child element.

Return Value

The actual size needed by the element.

See Also

DiagramScrollContentPresenter Class


GetLayoutClip Method

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter..::.GetLayoutClip Method
DiagramScrollContentPresenter Class See Also Send Feedback
Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Geometry GetLayoutClip(
    Size layoutSlotSize
)
Visual Basic (Declaration)
Protected Overrides Function GetLayoutClip ( _
    layoutSlotSize As Size _
) As Geometry

Parameters

layoutSlotSize
Type: System.Windows..::.Size
The size of the part of the element that does visual presentation.

Return Value

The clipping geometry.

See Also

DiagramScrollContentPresenter Class


DiagramScrollContentPresenter Properties

[image] [image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter Properties
DiagramScrollContentPresenter Class See Also Send Feedback

The DiagramScrollContentPresenter type exposes the following members.

Properties

Name | Description
HorizontalOffset | Gets or sets the horizontal offset (scroll position). This is a dependency property.
VerticalOffset | Gets or sets the vertical offset (scroll position). This is a dependency property.

See Also

DiagramScrollContentPresenter Class


HorizontalOffset Property

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter..::.HorizontalOffset Property
DiagramScrollContentPresenter Class See Also Send Feedback
Gets or sets the horizontal offset (scroll position). This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic (Declaration)
Public Property HorizontalOffset As Double

Remarks

Dependency Property Information
Identifier field | HorizontalOffsetProperty
Metadata properties set to true | None

See Also

DiagramScrollContentPresenter Class


VerticalOffset Property

[image]

Mindscape WPF Diagrams
DiagramScrollContentPresenter..::.VerticalOffset Property
DiagramScrollContentPresenter Class See Also Send Feedback
Gets or sets the vertical offset (scroll position). This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic (Declaration)
Public Property VerticalOffset As Double

Remarks

Dependency Property Information
Identifier field | VerticalOffsetProperty
Metadata properties set to true | None

See Also

DiagramScrollContentPresenter Class


DiagramScrollViewer Class

[image]

Mindscape WPF Diagrams
DiagramScrollViewer Class
Members See Also Send Feedback
Represents a scrollable area that can contain a diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("Content")]
public class DiagramScrollViewer : Control
Visual Basic (Declaration)
<ContentPropertyAttribute("Content")> _
Public Class DiagramScrollViewer _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.WpfDiagramming.Foundation..::.DiagramScrollViewer

See Also

DiagramScrollViewer Members


DiagramScrollViewer Members

[image] [image]

Mindscape WPF Diagrams
DiagramScrollViewer Members
DiagramScrollViewer Class Constructors Methods Fields Properties See Also Send Feedback

The DiagramScrollViewer type exposes the following members.

Constructors

Name | Description
DiagramScrollViewer | Initializes a new instance of the DiagramScrollViewer class.

Methods

Name | Description
GetViewport | Gets the viewport (the part of the scroll region which is visible).
OnApplyTemplate | Called by the framework when a template is applied to the control. (Overrides FrameworkElement ..::. OnApplyTemplate()()().)
OnRenderSizeChanged | Called whenever the rendering size of this DiagramScrollViewer changes. (Overrides FrameworkElement ..::. OnRenderSizeChanged(SizeChangedInfo).)
SetViewport | Sets the viewport (the part of the scroll region which is visible).
SizeToFit | Adjusts the zoom values and the viewport to center the whole diagram into the viewport area.
TranslateViewPort | Moves the viewport by the given x and y movement values. Changes the ExtraSpace property to allow for infinite viewport panning.

Fields

Name | Description
CanShowScrollBarsProperty | Identifies the CanShowScrollBars property.
ContentProperty | Identifies the Content property.
DiagramSurfaceProperty | Identifies the DiagramSurface property.
EffectiveZoomProperty | Identifies the EffectiveZoom property.
ExtentProperty | Identifies the Extent property.
ExtraSpaceProperty | Identifies the ExtraSpace property.
HorizontalOffsetProperty | Identifies the HorizontalOffset property.
MinimumExtraSpaceProperty | Identifies the MinimumExtraSpace property.
VerticalOffsetProperty | Identifies the VerticalOffset property.
ZoomModeProperty | Identifies the ZoomMode property.
ZoomProperty | Identifies the Zoom property.

Properties

Name | Description
CanShowScrollBars | Gets or sets whether the DiagramScrollViewer is permitted to display scroll bars. The default is true. This is a dependency property.
Content | Gets or sets the content. This is a dependency property.
DiagramSurface | Gets or sets the DiagramSurface for which this DiagramScrollViewer provides scrolling functionality. This is a dependency property.
EffectiveZoom | Gets the effective zoom. This is a dependency property.
Extent | Gets the content extent. This is a dependency property.
ExtraSpace | Gets the extra space around the content. This is a dependency property.
HorizontalOffset | Gets the horizontal offset. This is a dependency property.
MinimumExtraSpace | Gets or sets the minimum extra space around the content (used for infinite scrolling). This is a dependency property.
VerticalOffset | Gets the vertical offset. This is a dependency property.
Zoom | Gets or sets the zoom. This is a dependency property.
ZoomMode | Gets or sets built-in zooming behavior. This is a dependency property.

See Also

DiagramScrollViewer Class


DiagramScrollViewer Constructor

[image]

Mindscape WPF Diagrams
DiagramScrollViewer Constructor
DiagramScrollViewer Class See Also Send Feedback
Initializes a new instance of the DiagramScrollViewer class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramScrollViewer()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramScrollViewer Class


DiagramScrollViewer Fields

[image] [image]

Mindscape WPF Diagrams
DiagramScrollViewer Fields
DiagramScrollViewer Class See Also Send Feedback

The DiagramScrollViewer type exposes the following members.

Fields

Name | Description
CanShowScrollBarsProperty | Identifies the CanShowScrollBars property.
ContentProperty | Identifies the Content property.
DiagramSurfaceProperty | Identifies the DiagramSurface property.
EffectiveZoomProperty | Identifies the EffectiveZoom property.
ExtentProperty | Identifies the Extent property.
ExtraSpaceProperty | Identifies the ExtraSpace property.
HorizontalOffsetProperty | Identifies the HorizontalOffset property.
MinimumExtraSpaceProperty | Identifies the MinimumExtraSpace property.
VerticalOffsetProperty | Identifies the VerticalOffset property.
ZoomModeProperty | Identifies the ZoomMode property.
ZoomProperty | Identifies the Zoom property.

See Also

DiagramScrollViewer Class


CanShowScrollBarsProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.CanShowScrollBarsProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the CanShowScrollBars property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CanShowScrollBarsProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanShowScrollBarsProperty As DependencyProperty

See Also

DiagramScrollViewer Class


ContentProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.ContentProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the Content property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentProperty As DependencyProperty

See Also

DiagramScrollViewer Class


DiagramSurfaceProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.DiagramSurfaceProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the DiagramSurface property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty DiagramSurfaceProperty
Visual Basic (Declaration)
Public Shared ReadOnly DiagramSurfaceProperty As DependencyProperty

See Also

DiagramScrollViewer Class


EffectiveZoomProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.EffectiveZoomProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the EffectiveZoom property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty EffectiveZoomProperty
Visual Basic (Declaration)
Public Shared ReadOnly EffectiveZoomProperty As DependencyProperty

See Also

DiagramScrollViewer Class


ExtentProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.ExtentProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the Extent property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ExtentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExtentProperty As DependencyProperty

See Also

DiagramScrollViewer Class


ExtraSpaceProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.ExtraSpaceProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the ExtraSpace property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ExtraSpaceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExtraSpaceProperty As DependencyProperty

See Also

DiagramScrollViewer Class


HorizontalOffsetProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.HorizontalOffsetProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the HorizontalOffset property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty HorizontalOffsetProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalOffsetProperty As DependencyProperty

See Also

DiagramScrollViewer Class


MinimumExtraSpaceProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.MinimumExtraSpaceProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the MinimumExtraSpace property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty MinimumExtraSpaceProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinimumExtraSpaceProperty As DependencyProperty

See Also

DiagramScrollViewer Class


VerticalOffsetProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.VerticalOffsetProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the VerticalOffset property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty VerticalOffsetProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalOffsetProperty As DependencyProperty

See Also

DiagramScrollViewer Class


ZoomModeProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.ZoomModeProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the ZoomMode property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ZoomModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomModeProperty As DependencyProperty

See Also

DiagramScrollViewer Class


ZoomProperty Field

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.ZoomProperty Field
DiagramScrollViewer Class See Also Send Feedback
Identifies the Zoom property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ZoomProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomProperty As DependencyProperty

See Also

DiagramScrollViewer Class


DiagramScrollViewer Methods

[image] [image]

Mindscape WPF Diagrams
DiagramScrollViewer Methods
DiagramScrollViewer Class See Also Send Feedback

The DiagramScrollViewer type exposes the following members.

Methods

Name | Description
GetViewport | Gets the viewport (the part of the scroll region which is visible).
OnApplyTemplate | Called by the framework when a template is applied to the control. (Overrides FrameworkElement ..::. OnApplyTemplate()()().)
OnRenderSizeChanged | Called whenever the rendering size of this DiagramScrollViewer changes. (Overrides FrameworkElement ..::. OnRenderSizeChanged(SizeChangedInfo).)
SetViewport | Sets the viewport (the part of the scroll region which is visible).
SizeToFit | Adjusts the zoom values and the viewport to center the whole diagram into the viewport area.
TranslateViewPort | Moves the viewport by the given x and y movement values. Changes the ExtraSpace property to allow for infinite viewport panning.

See Also

DiagramScrollViewer Class


GetViewport Method

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.GetViewport Method
DiagramScrollViewer Class See Also Send Feedback
Gets the viewport (the part of the scroll region which is visible).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect GetViewport()
Visual Basic (Declaration)
Public Function GetViewport As Rect

Return Value

The current viewport (in content coordinates).

See Also

DiagramScrollViewer Class


OnApplyTemplate Method

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.OnApplyTemplate Method
DiagramScrollViewer Class See Also Send Feedback
Called by the framework when a template is applied to the control.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DiagramScrollViewer Class


OnRenderSizeChanged Method

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.OnRenderSizeChanged Method
DiagramScrollViewer Class See Also Send Feedback
Called whenever the rendering size of this DiagramScrollViewer changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override void OnRenderSizeChanged(
    SizeChangedInfo sizeInfo
)
Visual Basic (Declaration)
Protected Overrides Sub OnRenderSizeChanged ( _
    sizeInfo As SizeChangedInfo _
)

Parameters

sizeInfo
Type: System.Windows..::.SizeChangedInfo
Information about the change in render size.

See Also

DiagramScrollViewer Class


SetViewport Method

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.SetViewport Method
DiagramScrollViewer Class See Also Send Feedback
Sets the viewport (the part of the scroll region which is visible).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetViewport(
    Rect viewport
)
Visual Basic (Declaration)
Public Sub SetViewport ( _
    viewport As Rect _
)

Parameters

viewport
Type: System.Windows..::.Rect
The desired viewport (in content coordinates).

Remarks

In order to preserve the aspect ratio of the content, the displayed viewport may be larger than the requested viewport.

See Also

DiagramScrollViewer Class


SizeToFit Method

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.SizeToFit Method
DiagramScrollViewer Class See Also Send Feedback
Adjusts the zoom values and the viewport to center the whole diagram into the viewport area.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SizeToFit()
Visual Basic (Declaration)
Public Sub SizeToFit

See Also

DiagramScrollViewer Class


TranslateViewPort Method

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.TranslateViewPort Method
DiagramScrollViewer Class See Also Send Feedback
Moves the viewport by the given x and y movement values. Changes the ExtraSpace property to allow for infinite viewport panning.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void TranslateViewPort(
    double deltaX,
    double deltaY
)
Visual Basic (Declaration)
Public Sub TranslateViewPort ( _
    deltaX As Double, _
    deltaY As Double _
)

Parameters

deltaX
Type: System..::.Double
The distance to move the viewport horizontally.
deltaY
Type: System..::.Double
The distance to move the viewport vertically.

See Also

DiagramScrollViewer Class


DiagramScrollViewer Properties

[image] [image]

Mindscape WPF Diagrams
DiagramScrollViewer Properties
DiagramScrollViewer Class See Also Send Feedback

The DiagramScrollViewer type exposes the following members.

Properties

Name | Description
CanShowScrollBars | Gets or sets whether the DiagramScrollViewer is permitted to display scroll bars. The default is true. This is a dependency property.
Content | Gets or sets the content. This is a dependency property.
DiagramSurface | Gets or sets the DiagramSurface for which this DiagramScrollViewer provides scrolling functionality. This is a dependency property.
EffectiveZoom | Gets the effective zoom. This is a dependency property.
Extent | Gets the content extent. This is a dependency property.
ExtraSpace | Gets the extra space around the content. This is a dependency property.
HorizontalOffset | Gets the horizontal offset. This is a dependency property.
MinimumExtraSpace | Gets or sets the minimum extra space around the content (used for infinite scrolling). This is a dependency property.
VerticalOffset | Gets the vertical offset. This is a dependency property.
Zoom | Gets or sets the zoom. This is a dependency property.
ZoomMode | Gets or sets built-in zooming behavior. This is a dependency property.

See Also

DiagramScrollViewer Class


CanShowScrollBars Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.CanShowScrollBars Property
DiagramScrollViewer Class See Also Send Feedback
Gets or sets whether the DiagramScrollViewer is permitted to display scroll bars. The default is true. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool CanShowScrollBars { get; set; }
Visual Basic (Declaration)
Public Property CanShowScrollBars As Boolean

Remarks

Dependency Property Information
Identifier field | CanShowScrollBarsProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


Content Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.Content Property
DiagramScrollViewer Class See Also Send Feedback
Gets or sets the content. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public AutoSizeCanvas Content { get; set; }
Visual Basic (Declaration)
Public Property Content As AutoSizeCanvas

Remarks

Dependency Property Information
Identifier field | ContentProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


DiagramSurface Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.DiagramSurface Property
DiagramScrollViewer Class See Also Send Feedback
Gets or sets the DiagramSurface for which this DiagramScrollViewer provides scrolling functionality. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramSurface DiagramSurface { get; set; }
Visual Basic (Declaration)
Public Property DiagramSurface As DiagramSurface

Remarks

Dependency Property Information
Identifier field | DiagramSurfaceProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


EffectiveZoom Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.EffectiveZoom Property
DiagramScrollViewer Class See Also Send Feedback
Gets the effective zoom. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double EffectiveZoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property EffectiveZoom As Double

Remarks

Dependency Property Information
Identifier field | EffectiveZoomProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


Extent Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.Extent Property
DiagramScrollViewer Class See Also Send Feedback
Gets the content extent. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect Extent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Extent As Rect

Remarks

Dependency Property Information
Identifier field | ExtraSpaceProperty
Metadata properties set to true | AffectsArrange, AffectsMeasure

See Also

DiagramScrollViewer Class


ExtraSpace Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.ExtraSpace Property
DiagramScrollViewer Class See Also Send Feedback
Gets the extra space around the content. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Thickness ExtraSpace { get; private set; }
Visual Basic (Declaration)
Public Property ExtraSpace As Thickness

Remarks

Dependency Property Information
Identifier field | ExtraSpaceProperty
Metadata properties set to true | AffectsMeasure

See Also

DiagramScrollViewer Class


HorizontalOffset Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.HorizontalOffset Property
DiagramScrollViewer Class See Also Send Feedback
Gets the horizontal offset. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalOffset As Double

Remarks

Dependency Property Information
Identifier field | HorizontalOffsetProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


MinimumExtraSpace Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.MinimumExtraSpace Property
DiagramScrollViewer Class See Also Send Feedback
Gets or sets the minimum extra space around the content (used for infinite scrolling). This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Thickness MinimumExtraSpace { get; set; }
Visual Basic (Declaration)
Public Property MinimumExtraSpace As Thickness

Remarks

Dependency Property Information
Identifier field | MinimumExtraSpaceProperty
Metadata properties set to true | AffectsMeasure

See Also

DiagramScrollViewer Class


VerticalOffset Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.VerticalOffset Property
DiagramScrollViewer Class See Also Send Feedback
Gets the vertical offset. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalOffset As Double

Remarks

Dependency Property Information
Identifier field | VerticalOffsetProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


Zoom Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.Zoom Property
DiagramScrollViewer Class See Also Send Feedback
Gets or sets the zoom. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Double

Remarks

Dependency Property Information
Identifier field | ZoomProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


ZoomMode Property

[image]

Mindscape WPF Diagrams
DiagramScrollViewer..::.ZoomMode Property
DiagramScrollViewer Class See Also Send Feedback
Gets or sets built-in zooming behavior. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode

Remarks

Dependency Property Information
Identifier field | ZoomModeProperty
Metadata properties set to true | None

See Also

DiagramScrollViewer Class


DiagramState Class

[image]

Mindscape WPF Diagrams
DiagramState Class
Members See Also Send Feedback
Represents a cloned state of an IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramState
Visual Basic (Declaration)
Public Class DiagramState

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DiagramState

See Also

DiagramState Members


DiagramState Members

[image] [image]

Mindscape WPF Diagrams
DiagramState Members
DiagramState Class Constructors Methods See Also Send Feedback

The DiagramState type exposes the following members.

Constructors

Name | Description
DiagramState | Creates a new instance of the DiagramState class. The created DiagramState will represent a clone of the diagram within the given DiagramSurface.

Methods

Name | Description
Apply | Applies this DiagramState to the IDiagramModel in the given DiagramSurface.

See Also

DiagramState Class


DiagramState Constructor

[image]

Mindscape WPF Diagrams
DiagramState Constructor
DiagramState Class See Also Send Feedback
Creates a new instance of the DiagramState class. The created DiagramState will represent a clone of the diagram within the given DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramState(
    DiagramSurface surface
)
Visual Basic (Declaration)
Public Sub New ( _
    surface As DiagramSurface _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface that this DiagramState holds a snapshot of.

See Also

DiagramState Class


DiagramState Methods

[image] [image]

Mindscape WPF Diagrams
DiagramState Methods
DiagramState Class See Also Send Feedback

The DiagramState type exposes the following members.

Methods

Name | Description
Apply | Applies this DiagramState to the IDiagramModel in the given DiagramSurface.

See Also

DiagramState Class


Apply Method

[image]

Mindscape WPF Diagrams
DiagramState..::.Apply Method
DiagramState Class See Also Send Feedback
Applies this DiagramState to the IDiagramModel in the given DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Apply(
    DiagramSurface surface
)
Visual Basic (Declaration)
Public Sub Apply ( _
    surface As DiagramSurface _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface that this DiagramState is applied to.

See Also

DiagramState Class


DiagramStructureException Class

[image]

Mindscape WPF Diagrams
DiagramStructureException Class
Members See Also Send Feedback
The exception that is thrown when a diagram has an invalid structure.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[SerializableAttribute]
public class DiagramStructureException : Exception
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DiagramStructureException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Mindscape.WpfDiagramming.Foundation..::.DiagramStructureException

See Also

DiagramStructureException Members


DiagramStructureException Members

[image] [image]

Mindscape WPF Diagrams
DiagramStructureException Members
DiagramStructureException Class Constructors See Also Send Feedback

Constructors

Name | Description
DiagramStructureException | Overloaded.

See Also

DiagramStructureException Class


DiagramStructureException Constructor

[image] [image]

Mindscape WPF Diagrams
DiagramStructureException Constructor
DiagramStructureException Class See Also Send Feedback

Overload List

Name | Description
DiagramStructureException()()() | Initializes a new instance of the DiagramStructureException class.
DiagramStructureException(String) | Initializes a new instance of the DiagramStructureException class with the specified message.
DiagramStructureException(SerializationInfo, StreamingContext) | Initializes a new instance of the DiagramStructureException class with serialized data.
DiagramStructureException(String, Exception) | Initializes a new instance of the DiagramStructureException class with the specified message and inner exception.

See Also

DiagramStructureException Class
DiagramStructureException Members


DiagramStructureException Constructor

[image]

Mindscape WPF Diagrams
DiagramStructureException Constructor
DiagramStructureException Class See Also Send Feedback
Initializes a new instance of the DiagramStructureException class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramStructureException()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramStructureException Class
DiagramStructureException Overload


DiagramStructureException Constructor (String)

[image]

Mindscape WPF Diagrams
DiagramStructureException Constructor (String)
DiagramStructureException Class See Also Send Feedback
Initializes a new instance of the DiagramStructureException class with the specified message.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramStructureException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::.String
The exception message.

See Also

DiagramStructureException Class
DiagramStructureException Overload


DiagramStructureException Constructor (SerializationInfo, StreamingContext)

[image]

Mindscape WPF Diagrams
DiagramStructureException Constructor (SerializationInfo, StreamingContext)
DiagramStructureException Class See Also Send Feedback
Initializes a new instance of the DiagramStructureException class with serialized data.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected DiagramStructureException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialized data.
context
Type: System.Runtime.Serialization..::.StreamingContext
Describes the source or destination of the serialized data.

See Also

DiagramStructureException Class
DiagramStructureException Overload


DiagramStructureException Constructor (String, Exception)

[image]

Mindscape WPF Diagrams
DiagramStructureException Constructor (String, Exception)
DiagramStructureException Class See Also Send Feedback
Initializes a new instance of the DiagramStructureException class with the specified message and inner exception.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramStructureException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)

Parameters

message
Type: System..::.String
The exception message.
inner
Type: System..::.Exception
The inner exception.

See Also

DiagramStructureException Class
DiagramStructureException Overload


DiagramSurfaceDragAction Enumeration

[image]

Mindscape WPF Diagrams
DiagramSurfaceDragAction Enumeration
See Also Send Feedback
Determines the behaviour of clicking and then dragging the mouse over a DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum DiagramSurfaceDragAction
Visual Basic (Declaration)
Public Enumeration DiagramSurfaceDragAction

Members

Member name | Description
Select | Enables marquee drag select on a DiagramSurface.
Pan | Enables dragging the viewport of a DiagramSurface.

See Also


DiagramToolBoxFilterItem Class

[image]

Mindscape WPF Diagrams
DiagramToolBoxFilterItem Class
Members See Also Send Feedback
Represents a filter option for a DiagramToolBox.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramToolBoxFilterItem : ViewModelBase
Visual Basic (Declaration)
Public Class DiagramToolBoxFilterItem _
    Inherits ViewModelBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramToolBoxFilterItem

See Also

DiagramToolBoxFilterItem Members


DiagramToolBoxFilterItem Members

[image] [image]

Mindscape WPF Diagrams
DiagramToolBoxFilterItem Members
DiagramToolBoxFilterItem Class Methods Properties Events See Also Send Feedback

The DiagramToolBoxFilterItem type exposes the following members.

Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)

Properties

Name | Description
IsSelected | Gets or sets whether or not this filter item is selected.
Name | Gets the name of the filter item.

Events

Name | Description
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

DiagramToolBoxFilterItem Class


DiagramToolBoxFilterItem Properties

[image] [image]

Mindscape WPF Diagrams
DiagramToolBoxFilterItem Properties
DiagramToolBoxFilterItem Class See Also Send Feedback

The DiagramToolBoxFilterItem type exposes the following members.

Properties

Name | Description
IsSelected | Gets or sets whether or not this filter item is selected.
Name | Gets the name of the filter item.

See Also

DiagramToolBoxFilterItem Class


IsSelected Property

[image]

Mindscape WPF Diagrams
DiagramToolBoxFilterItem..::.IsSelected Property
DiagramToolBoxFilterItem Class See Also Send Feedback
Gets or sets whether or not this filter item is selected.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

DiagramToolBoxFilterItem Class


Name Property

[image]

Mindscape WPF Diagrams
DiagramToolBoxFilterItem..::.Name Property
DiagramToolBoxFilterItem Class See Also Send Feedback
Gets the name of the filter item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

DiagramToolBoxFilterItem Class


DiagramToolBoxFilterListConverter Class

[image]

Mindscape WPF Diagrams
DiagramToolBoxFilterListConverter Class
Members See Also Send Feedback
Adds a separator to the diagram tool box filter list.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DiagramToolBoxFilterListConverter : IValueConverter
Visual Basic (Declaration)
Public Class DiagramToolBoxFilterListConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DiagramToolBoxFilterListConverter

See Also

DiagramToolBoxFilterListConverter Members


DiagramToolBoxFilterListConverter Members

[image] [image]

Mindscape WPF Diagrams
DiagramToolBoxFilterListConverter Members
DiagramToolBoxFilterListConverter Class Constructors Methods See Also Send Feedback

The DiagramToolBoxFilterListConverter type exposes the following members.

Constructors

Name | Description
DiagramToolBoxFilterListConverter |

Methods

Name | Description
Convert | Adds a separator to the diagram tool box filter list.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

DiagramToolBoxFilterListConverter Class


DiagramToolBoxFilterListConverter Constructor

[image]

Mindscape WPF Diagrams
DiagramToolBoxFilterListConverter Constructor
DiagramToolBoxFilterListConverter Class See Also Send Feedback
Initializes a new instance of the DiagramToolBoxFilterListConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramToolBoxFilterListConverter()
Visual Basic (Declaration)
Public Sub New

See Also

DiagramToolBoxFilterListConverter Class


DiagramToolBoxFilterListConverter Methods

[image] [image]

Mindscape WPF Diagrams
DiagramToolBoxFilterListConverter Methods
DiagramToolBoxFilterListConverter Class See Also Send Feedback

The DiagramToolBoxFilterListConverter type exposes the following members.

Methods

Name | Description
Convert | Adds a separator to the diagram tool box filter list.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

DiagramToolBoxFilterListConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
DiagramToolBoxFilterListConverter..::.Convert Method
DiagramToolBoxFilterListConverter Class See Also Send Feedback
Adds a separator to the diagram tool box filter list.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The diagram tool box filter list with a separator added after the first item.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DiagramToolBoxFilterListConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
DiagramToolBoxFilterListConverter..::.ConvertBack Method
DiagramToolBoxFilterListConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DiagramToolBoxFilterListConverter Class


DoubleToScaleTransformConverter Class

[image]

Mindscape WPF Diagrams
DoubleToScaleTransformConverter Class
Members See Also Send Feedback
Converts a double value into a ScaleTransform.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DoubleToScaleTransformConverter : IValueConverter
Visual Basic (Declaration)
Public Class DoubleToScaleTransformConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DoubleToScaleTransformConverter

See Also

DoubleToScaleTransformConverter Members


DoubleToScaleTransformConverter Members

[image] [image]

Mindscape WPF Diagrams
DoubleToScaleTransformConverter Members
DoubleToScaleTransformConverter Class Constructors Methods See Also Send Feedback

The DoubleToScaleTransformConverter type exposes the following members.

Constructors

Name | Description
DoubleToScaleTransformConverter |

Methods

Name | Description
Convert | Converts the given number into a ScaleTransform.
ConvertBack | Throws a NotImplementedException.

See Also

DoubleToScaleTransformConverter Class


DoubleToScaleTransformConverter Constructor

[image]

Mindscape WPF Diagrams
DoubleToScaleTransformConverter Constructor
DoubleToScaleTransformConverter Class See Also Send Feedback
Initializes a new instance of the DoubleToScaleTransformConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DoubleToScaleTransformConverter()
Visual Basic (Declaration)
Public Sub New

See Also

DoubleToScaleTransformConverter Class


DoubleToScaleTransformConverter Methods

[image] [image]

Mindscape WPF Diagrams
DoubleToScaleTransformConverter Methods
DoubleToScaleTransformConverter Class See Also Send Feedback

The DoubleToScaleTransformConverter type exposes the following members.

Methods

Name | Description
Convert | Converts the given number into a ScaleTransform.
ConvertBack | Throws a NotImplementedException.

See Also

DoubleToScaleTransformConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
DoubleToScaleTransformConverter..::.Convert Method
DoubleToScaleTransformConverter Class See Also Send Feedback
Converts the given number into a ScaleTransform.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A ScaleTransform that uses the given number for the ScaleX and ScaleY values.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DoubleToScaleTransformConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
DoubleToScaleTransformConverter..::.ConvertBack Method
DoubleToScaleTransformConverter Class See Also Send Feedback
Throws a NotImplementedException.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DoubleToScaleTransformConverter Class


ElbowPathfinder Class

[image]

Mindscape WPF Diagrams
ElbowPathfinder Class
Members See Also Send Feedback
Determines a path for an IDiagramConnection that consists of horizontal and vertical segments, and avoids collisions with the elements which it connects.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ElbowPathfinder : IPathfinder
Visual Basic (Declaration)
Public Class ElbowPathfinder _
    Implements IPathfinder

Remarks

This pathfinder does not attempt to avoid collisions with other elements on the diagram surface. To route a path without collisions, use AStarPathfinder.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ElbowPathfinder

See Also

ElbowPathfinder Members


ElbowPathfinder Members

[image] [image]

Mindscape WPF Diagrams
ElbowPathfinder Members
ElbowPathfinder Class Constructors Methods Properties See Also Send Feedback

The ElbowPathfinder type exposes the following members.

Constructors

Name | Description
ElbowPathfinder | Initializes a new instance of the ElbowPathfinder class.

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection. This method returns null if the given connection element does not need to have its path re-configured.

Properties

Name | Description
Instance | Gets an instance of the ElbowPathfinder class.
Spacing | Gets or sets the desired spacing between nodes and connections in pixels. The default is 20.

See Also

ElbowPathfinder Class


ElbowPathfinder Constructor

[image]

Mindscape WPF Diagrams
ElbowPathfinder Constructor
ElbowPathfinder Class See Also Send Feedback
Initializes a new instance of the ElbowPathfinder class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ElbowPathfinder()
Visual Basic (Declaration)
Public Sub New

See Also

ElbowPathfinder Class


ElbowPathfinder Methods

[image] [image]

Mindscape WPF Diagrams
ElbowPathfinder Methods
ElbowPathfinder Class See Also Send Feedback

The ElbowPathfinder type exposes the following members.

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection. This method returns null if the given connection element does not need to have its path re-configured.

See Also

ElbowPathfinder Class


FindPath Method

[image]

Mindscape WPF Diagrams
ElbowPathfinder..::.FindPath Method
ElbowPathfinder Class See Also Send Feedback
Determines a path for the given IDiagramConnection. This method returns null if the given connection element does not need to have its path re-configured.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ReadOnlyCollection<Point> FindPath(
    IDiagramConnection connection,
    IDiagramModel diagram
)
Visual Basic (Declaration)
Public Function FindPath ( _
    connection As IDiagramConnection, _
    diagram As IDiagramModel _
) As ReadOnlyCollection(Of Point)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to find a path for.
diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
An IDiagramModel used to obtain other nodes and connections if needed

Return Value

A collection of via points representing the plotted course of the connection, or null to indicate that the connection path did not need to be refreshed.

Implements

IPathfinder..::.FindPath(IDiagramConnection, IDiagramModel)

See Also

ElbowPathfinder Class


ElbowPathfinder Properties

[image] [image]

Mindscape WPF Diagrams
ElbowPathfinder Properties
ElbowPathfinder Class See Also Send Feedback

The ElbowPathfinder type exposes the following members.

Properties

Name | Description
Instance | Gets an instance of the ElbowPathfinder class.
Spacing | Gets or sets the desired spacing between nodes and connections in pixels. The default is 20.

See Also

ElbowPathfinder Class


Instance Property

[image]

Mindscape WPF Diagrams
ElbowPathfinder..::.Instance Property
ElbowPathfinder Class See Also Send Feedback
Gets an instance of the ElbowPathfinder class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ElbowPathfinder Instance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As ElbowPathfinder

See Also

ElbowPathfinder Class


Spacing Property

[image]

Mindscape WPF Diagrams
ElbowPathfinder..::.Spacing Property
ElbowPathfinder Class See Also Send Feedback
Gets or sets the desired spacing between nodes and connections in pixels. The default is 20.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int Spacing { get; set; }
Visual Basic (Declaration)
Public Property Spacing As Integer

See Also

ElbowPathfinder Class


FixedStyleSelector Class

[image]

Mindscape WPF Diagrams
FixedStyleSelector Class
Members See Also Send Feedback
A StyleSelector which always selects a fixed Style.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FixedStyleSelector : StyleSelector
Visual Basic (Declaration)
Public Class FixedStyleSelector _
    Inherits StyleSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.FixedStyleSelector

See Also

FixedStyleSelector Members


FixedStyleSelector Members

[image] [image]

Mindscape WPF Diagrams
FixedStyleSelector Members
FixedStyleSelector Class Constructors Methods Properties See Also Send Feedback

The FixedStyleSelector type exposes the following members.

Constructors

Name | Description
FixedStyleSelector |

Methods

Name | Description
SelectStyle | Returns a Style for an item. (Overrides StyleSelector ..::. SelectStyle(Object, DependencyObject).)

Properties

Name | Description
Style | The Style to be selected for all inputs.

See Also

FixedStyleSelector Class


FixedStyleSelector Constructor

[image]

Mindscape WPF Diagrams
FixedStyleSelector Constructor
FixedStyleSelector Class See Also Send Feedback
Initializes a new instance of the FixedStyleSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FixedStyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

FixedStyleSelector Class


FixedStyleSelector Methods

[image] [image]

Mindscape WPF Diagrams
FixedStyleSelector Methods
FixedStyleSelector Class See Also Send Feedback

The FixedStyleSelector type exposes the following members.

Methods

Name | Description
SelectStyle | Returns a Style for an item. (Overrides StyleSelector ..::. SelectStyle(Object, DependencyObject).)

See Also

FixedStyleSelector Class


SelectStyle Method

[image]

Mindscape WPF Diagrams
FixedStyleSelector..::.SelectStyle Method
FixedStyleSelector Class See Also Send Feedback
Returns a Style for an item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overrides Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The item for which to select the style.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The value of the Style property.

See Also

FixedStyleSelector Class


FixedStyleSelector Properties

[image] [image]

Mindscape WPF Diagrams
FixedStyleSelector Properties
FixedStyleSelector Class See Also Send Feedback

The FixedStyleSelector type exposes the following members.

Properties

Name | Description
Style | The Style to be selected for all inputs.

See Also

FixedStyleSelector Class


Style Property

[image]

Mindscape WPF Diagrams
FixedStyleSelector..::.Style Property
FixedStyleSelector Class See Also Send Feedback
The Style to be selected for all inputs.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style Style { get; set; }
Visual Basic (Declaration)
Public Property Style As Style

See Also

FixedStyleSelector Class


FixedTemplateSelector Class

[image]

Mindscape WPF Diagrams
FixedTemplateSelector Class
Members See Also Send Feedback
A DataTemplateSelector which always selects a fixed DataTemplate.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class FixedTemplateSelector : DataTemplateSelector
Visual Basic (Declaration)
Public Class FixedTemplateSelector _
    Inherits DataTemplateSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.DataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.FixedTemplateSelector

See Also

FixedTemplateSelector Members


FixedTemplateSelector Members

[image] [image]

Mindscape WPF Diagrams
FixedTemplateSelector Members
FixedTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The FixedTemplateSelector type exposes the following members.

Constructors

Name | Description
FixedTemplateSelector |

Methods

Name | Description
SelectTemplate | Returns a DataTemplate for an item. (Overrides DataTemplateSelector ..::. SelectTemplate(Object, DependencyObject).)

Properties

Name | Description
Template | The DataTemplate to be selected for all inputs.

See Also

FixedTemplateSelector Class


FixedTemplateSelector Constructor

[image]

Mindscape WPF Diagrams
FixedTemplateSelector Constructor
FixedTemplateSelector Class See Also Send Feedback
Initializes a new instance of the FixedTemplateSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FixedTemplateSelector()
Visual Basic (Declaration)
Public Sub New

See Also

FixedTemplateSelector Class


FixedTemplateSelector Methods

[image] [image]

Mindscape WPF Diagrams
FixedTemplateSelector Methods
FixedTemplateSelector Class See Also Send Feedback

The FixedTemplateSelector type exposes the following members.

Methods

Name | Description
SelectTemplate | Returns a DataTemplate for an item. (Overrides DataTemplateSelector ..::. SelectTemplate(Object, DependencyObject).)

See Also

FixedTemplateSelector Class


SelectTemplate Method

[image]

Mindscape WPF Diagrams
FixedTemplateSelector..::.SelectTemplate Method
FixedTemplateSelector Class See Also Send Feedback
Returns a DataTemplate for an item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overrides Function SelectTemplate ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
The item for which to select the template.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The value of the Template property.

See Also

FixedTemplateSelector Class


FixedTemplateSelector Properties

[image] [image]

Mindscape WPF Diagrams
FixedTemplateSelector Properties
FixedTemplateSelector Class See Also Send Feedback

The FixedTemplateSelector type exposes the following members.

Properties

Name | Description
Template | The DataTemplate to be selected for all inputs.

See Also

FixedTemplateSelector Class


Template Property

[image]

Mindscape WPF Diagrams
FixedTemplateSelector..::.Template Property
FixedTemplateSelector Class See Also Send Feedback
The DataTemplate to be selected for all inputs.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate Template { get; set; }
Visual Basic (Declaration)
Public Property Template As DataTemplate

See Also

FixedTemplateSelector Class


FloatingConnectionPoint Class

[image]

Mindscape WPF Diagrams
FloatingConnectionPoint Class
Members See Also Send Feedback
This class is part of the WPF Diagramming infrastructure to support dragging the ends of connections, and is not intended to be used in your own code.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public sealed class FloatingConnectionPoint : ViewModelBase, IDiagramConnectionPoint
Visual Basic (Declaration)
Public NotInheritable Class FloatingConnectionPoint _
    Inherits ViewModelBase _
    Implements IDiagramConnectionPoint

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.FloatingConnectionPoint

See Also

FloatingConnectionPoint Members


FloatingConnectionPoint Members

[image] [image]

Mindscape WPF Diagrams
FloatingConnectionPoint Members
FloatingConnectionPoint Class Methods Properties Events See Also Send Feedback

The FloatingConnectionPoint type exposes the following members.

Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)

Properties

Name | Description
Edge | Gets or sets the Edge of this connection point. This is used to determine how a connection approches this connection point.
Instance | Gets the currently used instance of FloatingConnectionPoint. This instance represents the connection point that is currently being relocated by the ConnectionRelocatorThumb.
Node | Gets or sets the IDiagramNode that the FloatingConnectionPoint is attached to. This such node is just a place holder which is required by connection points. This property should not be set by something outside the FloatingConnectionPoint class.
Position | Gets or sets the position of this connection point.

Events

Name | Description
IndexChanged | Raised when the Index property value changes.
PositionChanged | Raised when the Position property value changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

FloatingConnectionPoint Class


FloatingConnectionPoint Properties

[image] [image]

Mindscape WPF Diagrams
FloatingConnectionPoint Properties
FloatingConnectionPoint Class See Also Send Feedback

The FloatingConnectionPoint type exposes the following members.

Properties

Name | Description
Edge | Gets or sets the Edge of this connection point. This is used to determine how a connection approches this connection point.
Instance | Gets the currently used instance of FloatingConnectionPoint. This instance represents the connection point that is currently being relocated by the ConnectionRelocatorThumb.
Node | Gets or sets the IDiagramNode that the FloatingConnectionPoint is attached to. This such node is just a place holder which is required by connection points. This property should not be set by something outside the FloatingConnectionPoint class.
Position | Gets or sets the position of this connection point.

See Also

FloatingConnectionPoint Class


Edge Property

[image]

Mindscape WPF Diagrams
FloatingConnectionPoint..::.Edge Property
FloatingConnectionPoint Class See Also Send Feedback
Gets or sets the Edge of this connection point. This is used to determine how a connection approches this connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Edge Edge { get; set; }
Visual Basic (Declaration)
Public Property Edge As Edge

Implements

IDiagramConnectionPoint..::.Edge

See Also

FloatingConnectionPoint Class


Instance Property

[image]

Mindscape WPF Diagrams
FloatingConnectionPoint..::.Instance Property
FloatingConnectionPoint Class See Also Send Feedback
Gets the currently used instance of FloatingConnectionPoint. This instance represents the connection point that is currently being relocated by the ConnectionRelocatorThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static FloatingConnectionPoint Instance { get; internal set; }
Visual Basic (Declaration)
Public Shared Property Instance As FloatingConnectionPoint

See Also

FloatingConnectionPoint Class


Node Property

[image]

Mindscape WPF Diagrams
FloatingConnectionPoint..::.Node Property
FloatingConnectionPoint Class See Also Send Feedback
Gets or sets the IDiagramNode that the FloatingConnectionPoint is attached to. This such node is just a place holder which is required by connection points. This property should not be set by something outside the FloatingConnectionPoint class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramNode Node { get; set; }
Visual Basic (Declaration)
Public Property Node As IDiagramNode

See Also

FloatingConnectionPoint Class


Position Property

[image]

Mindscape WPF Diagrams
FloatingConnectionPoint..::.Position Property
FloatingConnectionPoint Class See Also Send Feedback
Gets or sets the position of this connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point Position { get; internal set; }
Visual Basic (Declaration)
Public Property Position As Point

Implements

IDiagramConnectionPoint..::.Position

See Also

FloatingConnectionPoint Class


FloatingConnectionPoint Events

[image] [image]

Mindscape WPF Diagrams
FloatingConnectionPoint Events
FloatingConnectionPoint Class See Also Send Feedback

The FloatingConnectionPoint type exposes the following members.

Events

Name | Description
IndexChanged | Raised when the Index property value changes.
PositionChanged | Raised when the Position property value changes.
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

FloatingConnectionPoint Class


IndexChanged Event

[image]

Mindscape WPF Diagrams
FloatingConnectionPoint..::.IndexChanged Event
FloatingConnectionPoint Class See Also Send Feedback
Raised when the Index property value changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler IndexChanged
Visual Basic (Declaration)
Public Event IndexChanged As EventHandler

Implements

IDiagramConnectionPoint..::.IndexChanged

See Also

FloatingConnectionPoint Class


PositionChanged Event

[image]

Mindscape WPF Diagrams
FloatingConnectionPoint..::.PositionChanged Event
FloatingConnectionPoint Class See Also Send Feedback
Raised when the Position property value changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler PositionChanged
Visual Basic (Declaration)
Public Event PositionChanged As EventHandler

Implements

IDiagramConnectionPoint..::.PositionChanged

See Also

FloatingConnectionPoint Class


ForceBasedLayoutAlgorithm Class

[image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm Class
Members See Also Send Feedback
A layout algorithm that uses physics equations based on charged particles and springs.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ForceBasedLayoutAlgorithm : LayoutAlgorithmBase
Visual Basic (Declaration)
Public Class ForceBasedLayoutAlgorithm _
    Inherits LayoutAlgorithmBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.LayoutAlgorithmBase
Mindscape.WpfDiagramming.Foundation..::.ForceBasedLayoutAlgorithm

See Also

ForceBasedLayoutAlgorithm Members


ForceBasedLayoutAlgorithm Members

[image] [image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm Members
ForceBasedLayoutAlgorithm Class Constructors Methods Properties See Also Send Feedback

The ForceBasedLayoutAlgorithm type exposes the following members.

Constructors

Name | Description
ForceBasedLayoutAlgorithm |

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this force based layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)
SetSelectedNode | Notifies the ForceBasedLayoutAlgorithm of the node which is currently selected in the diagram. This should be set before calling the Run(IDiagramModel) method so that the algorithm doesn't affect the node that the user may be dragging.

Properties

Name | Description
Damping | Gets or sets the force damping. This should be a value between 0 and 1. Low values produce smooth animations and high values allow for springy animations. The default is 0.5
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)

See Also

ForceBasedLayoutAlgorithm Class


ForceBasedLayoutAlgorithm Constructor

[image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm Constructor
ForceBasedLayoutAlgorithm Class See Also Send Feedback
Initializes a new instance of the ForceBasedLayoutAlgorithm class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ForceBasedLayoutAlgorithm()
Visual Basic (Declaration)
Public Sub New

See Also

ForceBasedLayoutAlgorithm Class


ForceBasedLayoutAlgorithm Methods

[image] [image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm Methods
ForceBasedLayoutAlgorithm Class See Also Send Feedback

The ForceBasedLayoutAlgorithm type exposes the following members.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this force based layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)
SetSelectedNode | Notifies the ForceBasedLayoutAlgorithm of the node which is currently selected in the diagram. This should be set before calling the Run(IDiagramModel) method so that the algorithm doesn't affect the node that the user may be dragging.

See Also

ForceBasedLayoutAlgorithm Class


Run Method

[image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm..::.Run Method
ForceBasedLayoutAlgorithm Class See Also Send Feedback
Runs this force based layout algorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Public Overrides Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to be laid out.

Implements

ILayoutAlgorithm..::.Run(IDiagramModel)

See Also

ForceBasedLayoutAlgorithm Class


SetSelectedNode Method

[image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm..::.SetSelectedNode Method
ForceBasedLayoutAlgorithm Class See Also Send Feedback
Notifies the ForceBasedLayoutAlgorithm of the node which is currently selected in the diagram. This should be set before calling the Run(IDiagramModel) method so that the algorithm doesn't affect the node that the user may be dragging.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetSelectedNode(
    IDiagramModel model,
    IDiagramNode node
)
Visual Basic (Declaration)
Public Sub SetSelectedNode ( _
    model As IDiagramModel, _
    node As IDiagramNode _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The diagram for which the selected node is being set.
node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The selected node in the diagram identified by model.

See Also

ForceBasedLayoutAlgorithm Class


ForceBasedLayoutAlgorithm Properties

[image] [image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm Properties
ForceBasedLayoutAlgorithm Class See Also Send Feedback

The ForceBasedLayoutAlgorithm type exposes the following members.

Properties

Name | Description
Damping | Gets or sets the force damping. This should be a value between 0 and 1. Low values produce smooth animations and high values allow for springy animations. The default is 0.5
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)

See Also

ForceBasedLayoutAlgorithm Class


Damping Property

[image]

Mindscape WPF Diagrams
ForceBasedLayoutAlgorithm..::.Damping Property
ForceBasedLayoutAlgorithm Class See Also Send Feedback
Gets or sets the force damping. This should be a value between 0 and 1. Low values produce smooth animations and high values allow for springy animations. The default is 0.5

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Damping { get; set; }
Visual Basic (Declaration)
Public Property Damping As Double

See Also

ForceBasedLayoutAlgorithm Class


GridLayoutAlgorithm Class

[image]

Mindscape WPF Diagrams
GridLayoutAlgorithm Class
Members See Also Send Feedback
A layout algorithm that takes advantage of the positions and directions of connection points. Lays out all the nodes in a grid like pattern based on the structure of the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class GridLayoutAlgorithm : LayoutAlgorithmBase
Visual Basic (Declaration)
Public Class GridLayoutAlgorithm _
    Inherits LayoutAlgorithmBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.LayoutAlgorithmBase
Mindscape.WpfDiagramming.Foundation..::.GridLayoutAlgorithm

See Also

GridLayoutAlgorithm Members


GridLayoutAlgorithm Members

[image] [image]

Mindscape WPF Diagrams
GridLayoutAlgorithm Members
GridLayoutAlgorithm Class Constructors Methods Properties See Also Send Feedback

The GridLayoutAlgorithm type exposes the following members.

Constructors

Name | Description
GridLayoutAlgorithm | Initializes a new instance of the GridLayoutAlgorithm class.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

Properties

Name | Description
HorizontalOffset | Gets or sets the horizontal offset at which to start layout out nodes.
HorizontalSpacing | Gets or sets the horizontal spacing between the columns of the grid.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
VerticalOffset | Gets or sets the vertical offset at which to start layout out nodes.
VerticalSpacing | Gets or sets the vertical spacing between the rows of the grid.

See Also

GridLayoutAlgorithm Class


GridLayoutAlgorithm Constructor

[image]

Mindscape WPF Diagrams
GridLayoutAlgorithm Constructor
GridLayoutAlgorithm Class See Also Send Feedback
Initializes a new instance of the GridLayoutAlgorithm class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public GridLayoutAlgorithm()
Visual Basic (Declaration)
Public Sub New

See Also

GridLayoutAlgorithm Class


GridLayoutAlgorithm Methods

[image] [image]

Mindscape WPF Diagrams
GridLayoutAlgorithm Methods
GridLayoutAlgorithm Class See Also Send Feedback

The GridLayoutAlgorithm type exposes the following members.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

See Also

GridLayoutAlgorithm Class


Run Method

[image]

Mindscape WPF Diagrams
GridLayoutAlgorithm..::.Run Method
GridLayoutAlgorithm Class See Also Send Feedback
Runs this layout algorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Public Overrides Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to be laid out.

Implements

ILayoutAlgorithm..::.Run(IDiagramModel)

See Also

GridLayoutAlgorithm Class


GridLayoutAlgorithm Properties

[image] [image]

Mindscape WPF Diagrams
GridLayoutAlgorithm Properties
GridLayoutAlgorithm Class See Also Send Feedback

The GridLayoutAlgorithm type exposes the following members.

Properties

Name | Description
HorizontalOffset | Gets or sets the horizontal offset at which to start layout out nodes.
HorizontalSpacing | Gets or sets the horizontal spacing between the columns of the grid.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
VerticalOffset | Gets or sets the vertical offset at which to start layout out nodes.
VerticalSpacing | Gets or sets the vertical spacing between the rows of the grid.

See Also

GridLayoutAlgorithm Class


HorizontalOffset Property

[image]

Mindscape WPF Diagrams
GridLayoutAlgorithm..::.HorizontalOffset Property
GridLayoutAlgorithm Class See Also Send Feedback
Gets or sets the horizontal offset at which to start layout out nodes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic (Declaration)
Public Property HorizontalOffset As Double

See Also

GridLayoutAlgorithm Class


HorizontalSpacing Property

[image]

Mindscape WPF Diagrams
GridLayoutAlgorithm..::.HorizontalSpacing Property
GridLayoutAlgorithm Class See Also Send Feedback
Gets or sets the horizontal spacing between the columns of the grid.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalSpacing { get; set; }
Visual Basic (Declaration)
Public Property HorizontalSpacing As Double

See Also

GridLayoutAlgorithm Class


VerticalOffset Property

[image]

Mindscape WPF Diagrams
GridLayoutAlgorithm..::.VerticalOffset Property
GridLayoutAlgorithm Class See Also Send Feedback
Gets or sets the vertical offset at which to start layout out nodes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic (Declaration)
Public Property VerticalOffset As Double

See Also

GridLayoutAlgorithm Class


VerticalSpacing Property

[image]

Mindscape WPF Diagrams
GridLayoutAlgorithm..::.VerticalSpacing Property
GridLayoutAlgorithm Class See Also Send Feedback
Gets or sets the vertical spacing between the rows of the grid.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalSpacing { get; set; }
Visual Basic (Declaration)
Public Property VerticalSpacing As Double

See Also

GridLayoutAlgorithm Class


HierarchicalLayoutAlgorithm Class

[image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm Class
Members See Also Send Feedback
A layout algorithm that positions nodes in a hierarchical tree like structure.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class HierarchicalLayoutAlgorithm : LayoutAlgorithmBase
Visual Basic (Declaration)
Public Class HierarchicalLayoutAlgorithm _
    Inherits LayoutAlgorithmBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.LayoutAlgorithmBase
Mindscape.WpfDiagramming.Foundation..::.HierarchicalLayoutAlgorithm

See Also

HierarchicalLayoutAlgorithm Members


HierarchicalLayoutAlgorithm Members

[image] [image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm Members
HierarchicalLayoutAlgorithm Class Constructors Methods Properties See Also Send Feedback

The HierarchicalLayoutAlgorithm type exposes the following members.

Constructors

Name | Description
HierarchicalLayoutAlgorithm | Initializes a new instance of the HierarchicalLayoutAlgorithm.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

Properties

Name | Description
HorizontalOffset | Gets or sets the horizontal offset at which to start layout out nodes.
HorizontalSpacing | Gets or sets the spacing that should be kept between sibling nodes within the same level.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
VerticalOffset | Gets or sets the vertical offset at which to start layout out nodes.
VerticalSpacing | Gets or sets the spacing that should be kept between each level of the hierarchical structure.

See Also

HierarchicalLayoutAlgorithm Class


HierarchicalLayoutAlgorithm Constructor

[image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm Constructor
HierarchicalLayoutAlgorithm Class See Also Send Feedback
Initializes a new instance of the HierarchicalLayoutAlgorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public HierarchicalLayoutAlgorithm()
Visual Basic (Declaration)
Public Sub New

See Also

HierarchicalLayoutAlgorithm Class


HierarchicalLayoutAlgorithm Methods

[image] [image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm Methods
HierarchicalLayoutAlgorithm Class See Also Send Feedback

The HierarchicalLayoutAlgorithm type exposes the following members.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this layout algorithm. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

See Also

HierarchicalLayoutAlgorithm Class


Run Method

[image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm..::.Run Method
HierarchicalLayoutAlgorithm Class See Also Send Feedback
Runs this layout algorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Public Overrides Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to be laid out.

Implements

ILayoutAlgorithm..::.Run(IDiagramModel)

See Also

HierarchicalLayoutAlgorithm Class


HierarchicalLayoutAlgorithm Properties

[image] [image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm Properties
HierarchicalLayoutAlgorithm Class See Also Send Feedback

The HierarchicalLayoutAlgorithm type exposes the following members.

Properties

Name | Description
HorizontalOffset | Gets or sets the horizontal offset at which to start layout out nodes.
HorizontalSpacing | Gets or sets the spacing that should be kept between sibling nodes within the same level.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
VerticalOffset | Gets or sets the vertical offset at which to start layout out nodes.
VerticalSpacing | Gets or sets the spacing that should be kept between each level of the hierarchical structure.

See Also

HierarchicalLayoutAlgorithm Class


HorizontalOffset Property

[image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm..::.HorizontalOffset Property
HierarchicalLayoutAlgorithm Class See Also Send Feedback
Gets or sets the horizontal offset at which to start layout out nodes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic (Declaration)
Public Property HorizontalOffset As Double

See Also

HierarchicalLayoutAlgorithm Class


HorizontalSpacing Property

[image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm..::.HorizontalSpacing Property
HierarchicalLayoutAlgorithm Class See Also Send Feedback
Gets or sets the spacing that should be kept between sibling nodes within the same level.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalSpacing { get; set; }
Visual Basic (Declaration)
Public Property HorizontalSpacing As Double

See Also

HierarchicalLayoutAlgorithm Class


VerticalOffset Property

[image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm..::.VerticalOffset Property
HierarchicalLayoutAlgorithm Class See Also Send Feedback
Gets or sets the vertical offset at which to start layout out nodes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic (Declaration)
Public Property VerticalOffset As Double

See Also

HierarchicalLayoutAlgorithm Class


VerticalSpacing Property

[image]

Mindscape WPF Diagrams
HierarchicalLayoutAlgorithm..::.VerticalSpacing Property
HierarchicalLayoutAlgorithm Class See Also Send Feedback
Gets or sets the spacing that should be kept between each level of the hierarchical structure.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalSpacing { get; set; }
Visual Basic (Declaration)
Public Property VerticalSpacing As Double

See Also

HierarchicalLayoutAlgorithm Class


IDataTemplateMatcher Interface

[image]

Mindscape WPF Diagrams
IDataTemplateMatcher Interface
Members See Also Send Feedback
Maps a selection criterion to a DataTemplate in a MatchingTemplateSelector.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDataTemplateMatcher
Visual Basic (Declaration)
Public Interface IDataTemplateMatcher

See Also

IDataTemplateMatcher Members


IDataTemplateMatcher Members

[image] [image]

Mindscape WPF Diagrams
IDataTemplateMatcher Members
IDataTemplateMatcher Interface Methods Properties See Also Send Feedback

The IDataTemplateMatcher type exposes the following members.

Methods

Name | Description
Matches | Tests whether an object matches the criterion for the DataTemplate.

Properties

Name | Description
Template | Gets the DataTemplate to be used for objects that meet this criterion.

See Also

IDataTemplateMatcher Interface


IDataTemplateMatcher Methods

[image] [image]

Mindscape WPF Diagrams
IDataTemplateMatcher Methods
IDataTemplateMatcher Interface See Also Send Feedback

The IDataTemplateMatcher type exposes the following members.

Methods

Name | Description
Matches | Tests whether an object matches the criterion for the DataTemplate.

See Also

IDataTemplateMatcher Interface


Matches Method

[image]

Mindscape WPF Diagrams
IDataTemplateMatcher..::.Matches Method
IDataTemplateMatcher Interface See Also Send Feedback
Tests whether an object matches the criterion for the DataTemplate.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool Matches(
    Object item
)
Visual Basic (Declaration)
Function Matches ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The object to be tested.

Return Value

true if the object matches the criterion; otherwise false.

See Also

IDataTemplateMatcher Interface


IDataTemplateMatcher Properties

[image] [image]

Mindscape WPF Diagrams
IDataTemplateMatcher Properties
IDataTemplateMatcher Interface See Also Send Feedback

The IDataTemplateMatcher type exposes the following members.

Properties

Name | Description
Template | Gets the DataTemplate to be used for objects that meet this criterion.

See Also

IDataTemplateMatcher Interface


Template Property

[image]

Mindscape WPF Diagrams
IDataTemplateMatcher..::.Template Property
IDataTemplateMatcher Interface See Also Send Feedback
Gets the DataTemplate to be used for objects that meet this criterion.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
DataTemplate Template { get; }
Visual Basic (Declaration)
ReadOnly Property Template As DataTemplate

See Also

IDataTemplateMatcher Interface


IDiagramAdapter Interface

[image]

Mindscape WPF Diagrams
IDiagramAdapter Interface
Members See Also Send Feedback
Represents an adapter that maps a business object model to a diagram model.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramAdapter
Visual Basic (Declaration)
Public Interface IDiagramAdapter

See Also

IDiagramAdapter Members


IDiagramAdapter Members

[image] [image]

Mindscape WPF Diagrams
IDiagramAdapter Members
IDiagramAdapter Interface Methods See Also Send Feedback

The IDiagramAdapter type exposes the following members.

Methods

Name | Description
CreateDiagramModel | Creates a diagram model representing a business object model.

See Also

IDiagramAdapter Interface


IDiagramAdapter Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramAdapter Methods
IDiagramAdapter Interface See Also Send Feedback

The IDiagramAdapter type exposes the following members.

Methods

Name | Description
CreateDiagramModel | Creates a diagram model representing a business object model.

See Also

IDiagramAdapter Interface


CreateDiagramModel Method

[image]

Mindscape WPF Diagrams
IDiagramAdapter..::.CreateDiagramModel Method
IDiagramAdapter Interface See Also Send Feedback
Creates a diagram model representing a business object model.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramModel CreateDiagramModel(
    Object businessModel
)
Visual Basic (Declaration)
Function CreateDiagramModel ( _
    businessModel As Object _
) As IDiagramModel

Parameters

businessModel
Type: System..::.Object
The business object model.

Return Value

A diagram model.

See Also

IDiagramAdapter Interface


IDiagramConnectable Interface

[image]

Mindscape WPF Diagrams
IDiagramConnectable Interface
Members See Also Send Feedback
An object within an IDiagramModel that can have IDiagramConnectionPoint objects attached to it.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramConnectable
Visual Basic (Declaration)
Public Interface IDiagramConnectable

See Also

IDiagramConnectable Members


IDiagramConnectable Members

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectable Members
IDiagramConnectable Interface Methods Properties Events See Also Send Feedback

The IDiagramConnectable type exposes the following members.

Methods

Name | Description
GetCollisionBounds | Returns the rectangle that is taken into consideration when a connection path is being constructed to the given IDiagramConnectionPoint. Generally, an IDiagramNode should return its bounds, and an IDiagramConnection should return a Rect with the position of the given IDiagramConnectionPoint and a size of 0.

Properties

Name | Description
CanOriginateNewConnections | Gets whether any more connections can begin at this IDiagramConnectable at all.
CanReceiveNewConnections | Gets whether any more connections can end at this IDiagramConnectable at all.
Data | Gets the data represented by the IDiagramConnectable, such as a business object in the domain being diagrammed.

Events

Name | Description
DataChanged | Raised when the Data property changes.

See Also

IDiagramConnectable Interface


IDiagramConnectable Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectable Methods
IDiagramConnectable Interface See Also Send Feedback

The IDiagramConnectable type exposes the following members.

Methods

Name | Description
GetCollisionBounds | Returns the rectangle that is taken into consideration when a connection path is being constructed to the given IDiagramConnectionPoint. Generally, an IDiagramNode should return its bounds, and an IDiagramConnection should return a Rect with the position of the given IDiagramConnectionPoint and a size of 0.

See Also

IDiagramConnectable Interface


GetCollisionBounds Method

[image]

Mindscape WPF Diagrams
IDiagramConnectable..::.GetCollisionBounds Method
IDiagramConnectable Interface See Also Send Feedback
Returns the rectangle that is taken into consideration when a connection path is being constructed to the given IDiagramConnectionPoint. Generally, an IDiagramNode should return its bounds, and an IDiagramConnection should return a Rect with the position of the given IDiagramConnectionPoint and a size of 0.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Rect GetCollisionBounds(
    IDiagramConnectionPoint connectionPoint
)
Visual Basic (Declaration)
Function GetCollisionBounds ( _
    connectionPoint As IDiagramConnectionPoint _
) As Rect

Parameters

connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The connection point to which a connection is being constructed.

Return Value

The collision bounds to be considered by the path routing algorithm.

See Also

IDiagramConnectable Interface


IDiagramConnectable Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectable Properties
IDiagramConnectable Interface See Also Send Feedback

The IDiagramConnectable type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether any more connections can begin at this IDiagramConnectable at all.
CanReceiveNewConnections | Gets whether any more connections can end at this IDiagramConnectable at all.
Data | Gets the data represented by the IDiagramConnectable, such as a business object in the domain being diagrammed.

See Also

IDiagramConnectable Interface


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
IDiagramConnectable..::.CanOriginateNewConnections Property
IDiagramConnectable Interface See Also Send Feedback
Gets whether any more connections can begin at this IDiagramConnectable at all.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
ReadOnly Property CanOriginateNewConnections As Boolean

See Also

IDiagramConnectable Interface


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
IDiagramConnectable..::.CanReceiveNewConnections Property
IDiagramConnectable Interface See Also Send Feedback
Gets whether any more connections can end at this IDiagramConnectable at all.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
ReadOnly Property CanReceiveNewConnections As Boolean

See Also

IDiagramConnectable Interface


Data Property

[image]

Mindscape WPF Diagrams
IDiagramConnectable..::.Data Property
IDiagramConnectable Interface See Also Send Feedback
Gets the data represented by the IDiagramConnectable, such as a business object in the domain being diagrammed.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Object Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As Object

See Also

IDiagramConnectable Interface


IDiagramConnectable Events

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectable Events
IDiagramConnectable Interface See Also Send Feedback

The IDiagramConnectable type exposes the following members.

Events

Name | Description
DataChanged | Raised when the Data property changes.

See Also

IDiagramConnectable Interface


DataChanged Event

[image]

Mindscape WPF Diagrams
IDiagramConnectable..::.DataChanged Event
IDiagramConnectable Interface See Also Send Feedback
Raised when the Data property changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
event EventHandler DataChanged
Visual Basic (Declaration)
Event DataChanged As EventHandler

See Also

IDiagramConnectable Interface


IDiagramConnection Interface

[image]

Mindscape WPF Diagrams
IDiagramConnection Interface
Members See Also Send Feedback
Represents a relationship between two diagram model entities that should be made visible in the diagram as a DiagramConnectionElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramConnection : IDiagramConnectable,
    IDiagramZOrderable
Visual Basic (Declaration)
Public Interface IDiagramConnection _
    Implements IDiagramConnectable, IDiagramZOrderable

See Also

IDiagramConnection Members


IDiagramConnection Members

[image] [image]

Mindscape WPF Diagrams
IDiagramConnection Members
IDiagramConnection Interface Methods Properties Events See Also Send Feedback

The IDiagramConnection type exposes the following members.

Methods

Name | Description
AddConnectionPoint | Adds a connection point to this connection at an appropriate position derived from the given Point. The newly created and added connection point is then returned.
Clone | Returns an IDiagramConnectionState that holds the property values of this IDiagramConnection as it is at the time this method is called.
GetCollisionBounds | Returns the rectangle that is taken into consideration when a connection path is being constructed to the given IDiagramConnectionPoint. Generally, an IDiagramNode should return its bounds, and an IDiagramConnection should return a Rect with the position of the given IDiagramConnectionPoint and a size of 0. (Inherited from IDiagramConnectable.)
SetAs | Sets all the properties within this IDiagramConnection to be like the properties of the given IDiagramConnectionState.

Properties

Name | Description
CanOriginateNewConnections | Gets whether any more connections can begin at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
CanReceiveNewConnections | Gets whether any more connections can end at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
ConnectionPoints | Gets the collection of IDiagramConnectionPoint objects that are currently attached to this IDiagramConnection.
Data | Gets the data represented by the IDiagramConnectable, such as a business object in the domain being diagrammed. (Inherited from IDiagramConnectable.)
Diagram | Gets or sets the IDiagramModel that the connection belongs to.
FromConnectionPoint | Gets the source of the IDiagramConnection.
IsUserModified | Gets or sets whether this IDiagramConnection has been user modified or not. A user modified connection is one that has had one or more of its DiagramConnectionSegment objects positioned by a user.
Pathfinder | Gets the IPathfinder used to find the segment path for this IDiagramConnection.
Segments | Returns the collection of DiagramConnectionSegment objects that make up this IDiagramConnection.
ToConnectionPoint | Gets the destination of the IDiagramConnection.
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders. (Inherited from IDiagramZOrderable.)

Events

Name | Description
DataChanged | Raised when the Data property changes. (Inherited from IDiagramConnectable.)

See Also

IDiagramConnection Interface


IDiagramConnection Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramConnection Methods
IDiagramConnection Interface See Also Send Feedback

The IDiagramConnection type exposes the following members.

Methods

Name | Description
AddConnectionPoint | Adds a connection point to this connection at an appropriate position derived from the given Point. The newly created and added connection point is then returned.
Clone | Returns an IDiagramConnectionState that holds the property values of this IDiagramConnection as it is at the time this method is called.
GetCollisionBounds | Returns the rectangle that is taken into consideration when a connection path is being constructed to the given IDiagramConnectionPoint. Generally, an IDiagramNode should return its bounds, and an IDiagramConnection should return a Rect with the position of the given IDiagramConnectionPoint and a size of 0. (Inherited from IDiagramConnectable.)
SetAs | Sets all the properties within this IDiagramConnection to be like the properties of the given IDiagramConnectionState.

See Also

IDiagramConnection Interface


AddConnectionPoint Method

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.AddConnectionPoint Method
IDiagramConnection Interface See Also Send Feedback
Adds a connection point to this connection at an appropriate position derived from the given Point. The newly created and added connection point is then returned.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionPoint AddConnectionPoint(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Function AddConnectionPoint ( _
    point As Point, _
    buffer As Double _
) As IDiagramConnectionPoint

Parameters

point
Type: System.Windows..::.Point
A Point that will derive the position of the new connection point to be added to this connection.
buffer
Type: System..::.Double
The size of the region at each end of the connection segments which can not have a connection mounted connection point attached at.

Return Value

The connection point that was just created and added to this connection.

See Also

IDiagramConnection Interface


Clone Method

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.Clone Method
IDiagramConnection Interface See Also Send Feedback
Returns an IDiagramConnectionState that holds the property values of this IDiagramConnection as it is at the time this method is called.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionState Clone()
Visual Basic (Declaration)
Function Clone As IDiagramConnectionState

Return Value

An IDiagramConnectionState holding current property values of this IDiagramConnection.

See Also

IDiagramConnection Interface


SetAs Method

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.SetAs Method
IDiagramConnection Interface See Also Send Feedback
Sets all the properties within this IDiagramConnection to be like the properties of the given IDiagramConnectionState.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void SetAs(
    IDiagramConnectionState state
)
Visual Basic (Declaration)
Sub SetAs ( _
    state As IDiagramConnectionState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionState
The IDiagramConnectionState to copy the properties from.

See Also

IDiagramConnection Interface


IDiagramConnection Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramConnection Properties
IDiagramConnection Interface See Also Send Feedback

The IDiagramConnection type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether any more connections can begin at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
CanReceiveNewConnections | Gets whether any more connections can end at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
ConnectionPoints | Gets the collection of IDiagramConnectionPoint objects that are currently attached to this IDiagramConnection.
Data | Gets the data represented by the IDiagramConnectable, such as a business object in the domain being diagrammed. (Inherited from IDiagramConnectable.)
Diagram | Gets or sets the IDiagramModel that the connection belongs to.
FromConnectionPoint | Gets the source of the IDiagramConnection.
IsUserModified | Gets or sets whether this IDiagramConnection has been user modified or not. A user modified connection is one that has had one or more of its DiagramConnectionSegment objects positioned by a user.
Pathfinder | Gets the IPathfinder used to find the segment path for this IDiagramConnection.
Segments | Returns the collection of DiagramConnectionSegment objects that make up this IDiagramConnection.
ToConnectionPoint | Gets the destination of the IDiagramConnection.
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders. (Inherited from IDiagramZOrderable.)

See Also

IDiagramConnection Interface


ConnectionPoints Property

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.ConnectionPoints Property
IDiagramConnection Interface See Also Send Feedback
Gets the collection of IDiagramConnectionPoint objects that are currently attached to this IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
ObservableCollection<IDiagramConnectionPoint> ConnectionPoints { get; }
Visual Basic (Declaration)
ReadOnly Property ConnectionPoints As ObservableCollection(Of IDiagramConnectionPoint)

Remarks

Do not modify this collection directly: use the AddConnectionPoint method instead.

See Also

IDiagramConnection Interface


Diagram Property

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.Diagram Property
IDiagramConnection Interface See Also Send Feedback
Gets or sets the IDiagramModel that the connection belongs to.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramModel Diagram { get; set; }
Visual Basic (Declaration)
Property Diagram As IDiagramModel

See Also

IDiagramConnection Interface


FromConnectionPoint Property

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.FromConnectionPoint Property
IDiagramConnection Interface See Also Send Feedback
Gets the source of the IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionPoint FromConnectionPoint { get; set; }
Visual Basic (Declaration)
Property FromConnectionPoint As IDiagramConnectionPoint

See Also

IDiagramConnection Interface


IsUserModified Property

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.IsUserModified Property
IDiagramConnection Interface See Also Send Feedback
Gets or sets whether this IDiagramConnection has been user modified or not. A user modified connection is one that has had one or more of its DiagramConnectionSegment objects positioned by a user.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool IsUserModified { get; set; }
Visual Basic (Declaration)
Property IsUserModified As Boolean

See Also

IDiagramConnection Interface


Pathfinder Property

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.Pathfinder Property
IDiagramConnection Interface See Also Send Feedback
Gets the IPathfinder used to find the segment path for this IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IPathfinder Pathfinder { get; }
Visual Basic (Declaration)
ReadOnly Property Pathfinder As IPathfinder

See Also

IDiagramConnection Interface


Segments Property

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.Segments Property
IDiagramConnection Interface See Also Send Feedback
Returns the collection of DiagramConnectionSegment objects that make up this IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
ObservableCollection<DiagramConnectionSegment> Segments { get; }
Visual Basic (Declaration)
ReadOnly Property Segments As ObservableCollection(Of DiagramConnectionSegment)

See Also

IDiagramConnection Interface


ToConnectionPoint Property

[image]

Mindscape WPF Diagrams
IDiagramConnection..::.ToConnectionPoint Property
IDiagramConnection Interface See Also Send Feedback
Gets the destination of the IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionPoint ToConnectionPoint { get; set; }
Visual Basic (Declaration)
Property ToConnectionPoint As IDiagramConnectionPoint

See Also

IDiagramConnection Interface


IDiagramConnectionBuilder Interface

[image]

Mindscape WPF Diagrams
IDiagramConnectionBuilder Interface
Members See Also Send Feedback
Provides connection creation services for use by toolbox items.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramConnectionBuilder
Visual Basic (Declaration)
Public Interface IDiagramConnectionBuilder

See Also

IDiagramConnectionBuilder Members


IDiagramConnectionBuilder Members

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionBuilder Members
IDiagramConnectionBuilder Interface Methods See Also Send Feedback

The IDiagramConnectionBuilder type exposes the following members.

Methods

Name | Description
CanCreateConnection | Returns whether or not a connection can be made between the given connection point and destination.
CreateConnection | Creates a connection between the specified connection points.

See Also

IDiagramConnectionBuilder Interface


IDiagramConnectionBuilder Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionBuilder Methods
IDiagramConnectionBuilder Interface See Also Send Feedback

The IDiagramConnectionBuilder type exposes the following members.

Methods

Name | Description
CanCreateConnection | Returns whether or not a connection can be made between the given connection point and destination.
CreateConnection | Creates a connection between the specified connection points.

See Also

IDiagramConnectionBuilder Interface


CanCreateConnection Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionBuilder..::.CanCreateConnection Method
IDiagramConnectionBuilder Interface See Also Send Feedback
Returns whether or not a connection can be made between the given connection point and destination.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool CanCreateConnection(
    IDiagramModel diagram,
    IDiagramConnectionPoint fromConnectionPoint,
    ConnectionDropTarget dropTarget
)
Visual Basic (Declaration)
Function CanCreateConnection ( _
    diagram As IDiagramModel, _
    fromConnectionPoint As IDiagramConnectionPoint, _
    dropTarget As ConnectionDropTarget _
) As Boolean

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the connection will belong to.
fromConnectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The source connection point of the connection.
dropTarget
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionDropTarget
Information about the potential destination of the connection.

Return Value

True if a connection can be made, otherwise false.

See Also

IDiagramConnectionBuilder Interface


CreateConnection Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionBuilder..::.CreateConnection Method
IDiagramConnectionBuilder Interface See Also Send Feedback
Creates a connection between the specified connection points.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void CreateConnection(
    IDiagramModel diagram,
    IDiagramConnectionPoint fromConnectionPoint,
    IDiagramConnectionPoint toConnectionPoint
)
Visual Basic (Declaration)
Sub CreateConnection ( _
    diagram As IDiagramModel, _
    fromConnectionPoint As IDiagramConnectionPoint, _
    toConnectionPoint As IDiagramConnectionPoint _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to which the connection will be added.
fromConnectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint representing the start of the connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint representing the end of the connection.

Remarks

The builder may implement connection creation by adding a connection to the diagram model, or by creating an object or relationship in a business object model (which is observed by the diagram model.)

See Also

IDiagramConnectionBuilder Interface


IDiagramConnectionPoint Interface

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint Interface
Members See Also Send Feedback
Represents a point on an IDiagramConnectable where a connection can be attached.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramConnectionPoint
Visual Basic (Declaration)
Public Interface IDiagramConnectionPoint

See Also

IDiagramConnectionPoint Members


IDiagramConnectionPoint Members

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionPoint Members
IDiagramConnectionPoint Interface Methods Properties Events See Also Send Feedback

The IDiagramConnectionPoint type exposes the following members.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this IDiagramConnectionPoint.
RemoveConnection | Removes the given IDiagramConnection from this IDiagramConnectionPoint.
SetPosition | Sets the position of this IDiagramConnectionPoint to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned.

Properties

Name | Description
CanOriginateNewConnections | Gets whether new connections may be created beginning at this IDiagramConnectionPoint.
CanReceiveNewConnections | Gets whether new connections may be created ending at this IDiagramConnectionPoint.
Connectable | Gets the connectable object on which the IDiagramConnectionPoint is located.
Connections | Gets a collection of connections attached to this IDiagramConnectionPoint.
Data | Gets a data object held by this IDiagramConnectionPoint.
Edge | Gets the Edge of an object that this IDiagramConnectionPoint logically sits on. This is used to determine how an IDiagramConnection approches this IDiagramConnectionPoint.
FlowDirection | Gets the ConnectionPointDirection of this IDiagramConnectionPoint which states whether this IDiagramConnectionPoint is designed to receive connections, or originate them.
Index | Gets an index identifier for this IDiagramConnectionPoint. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node.
Position | Gets the position at which to render IDiagramConnection objects as starting or finishing.
PositionCalculator | Gets or sets the IPositionCalculator that this IDiagramConnectionPoint Can use for calculating its position.

Events

Name | Description
IndexChanged | Raised when the Index property value changes.
PositionChanged | Raised when the Position property value changes.

See Also

IDiagramConnectionPoint Interface


IDiagramConnectionPoint Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionPoint Methods
IDiagramConnectionPoint Interface See Also Send Feedback

The IDiagramConnectionPoint type exposes the following members.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this IDiagramConnectionPoint.
RemoveConnection | Removes the given IDiagramConnection from this IDiagramConnectionPoint.
SetPosition | Sets the position of this IDiagramConnectionPoint to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned.

See Also

IDiagramConnectionPoint Interface


AddConnection Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.AddConnection Method
IDiagramConnectionPoint Interface See Also Send Feedback
Attaches the given IDiagramConnection to this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void AddConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Sub AddConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to attach.

See Also

IDiagramConnectionPoint Interface


RemoveConnection Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.RemoveConnection Method
IDiagramConnectionPoint Interface See Also Send Feedback
Removes the given IDiagramConnection from this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void RemoveConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Sub RemoveConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to remove.

See Also

IDiagramConnectionPoint Interface


SetPosition Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.SetPosition Method
IDiagramConnectionPoint Interface See Also Send Feedback
Sets the position of this IDiagramConnectionPoint to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Point SetPosition(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Function SetPosition ( _
    point As Point, _
    buffer As Double _
) As Point

Parameters

point
Type: System.Windows..::.Point
A Point that the position of this IDiagramConnectionPoint is derived from.
buffer
Type: System..::.Double
Some distance at each end of the accepting connection where this connection point can not connect to.

Return Value

The actual resulting position of this IDiagramConnectionPoint.

See Also

IDiagramConnectionPoint Interface


IDiagramConnectionPoint Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionPoint Properties
IDiagramConnectionPoint Interface See Also Send Feedback

The IDiagramConnectionPoint type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Gets whether new connections may be created beginning at this IDiagramConnectionPoint.
CanReceiveNewConnections | Gets whether new connections may be created ending at this IDiagramConnectionPoint.
Connectable | Gets the connectable object on which the IDiagramConnectionPoint is located.
Connections | Gets a collection of connections attached to this IDiagramConnectionPoint.
Data | Gets a data object held by this IDiagramConnectionPoint.
Edge | Gets the Edge of an object that this IDiagramConnectionPoint logically sits on. This is used to determine how an IDiagramConnection approches this IDiagramConnectionPoint.
FlowDirection | Gets the ConnectionPointDirection of this IDiagramConnectionPoint which states whether this IDiagramConnectionPoint is designed to receive connections, or originate them.
Index | Gets an index identifier for this IDiagramConnectionPoint. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node.
Position | Gets the position at which to render IDiagramConnection objects as starting or finishing.
PositionCalculator | Gets or sets the IPositionCalculator that this IDiagramConnectionPoint Can use for calculating its position.

See Also

IDiagramConnectionPoint Interface


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.CanOriginateNewConnections Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets whether new connections may be created beginning at this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
ReadOnly Property CanOriginateNewConnections As Boolean

See Also

IDiagramConnectionPoint Interface


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.CanReceiveNewConnections Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets whether new connections may be created ending at this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
ReadOnly Property CanReceiveNewConnections As Boolean

See Also

IDiagramConnectionPoint Interface


Connectable Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.Connectable Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets the connectable object on which the IDiagramConnectionPoint is located.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectable Connectable { get; }
Visual Basic (Declaration)
ReadOnly Property Connectable As IDiagramConnectable

See Also

IDiagramConnectionPoint Interface


Connections Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.Connections Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets a collection of connections attached to this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
ReadOnlyCollection<IDiagramConnection> Connections { get; }
Visual Basic (Declaration)
ReadOnly Property Connections As ReadOnlyCollection(Of IDiagramConnection)

See Also

IDiagramConnectionPoint Interface


Data Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.Data Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets a data object held by this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Object Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As Object

See Also

IDiagramConnectionPoint Interface


Edge Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.Edge Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets the Edge of an object that this IDiagramConnectionPoint logically sits on. This is used to determine how an IDiagramConnection approches this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Edge Edge { get; }
Visual Basic (Declaration)
ReadOnly Property Edge As Edge

See Also

IDiagramConnectionPoint Interface


FlowDirection Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.FlowDirection Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets the ConnectionPointDirection of this IDiagramConnectionPoint which states whether this IDiagramConnectionPoint is designed to receive connections, or originate them.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
ConnectionPointDirection FlowDirection { get; }
Visual Basic (Declaration)
ReadOnly Property FlowDirection As ConnectionPointDirection

See Also

IDiagramConnectionPoint Interface


Index Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.Index Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets an index identifier for this IDiagramConnectionPoint. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
int Index { get; }
Visual Basic (Declaration)
ReadOnly Property Index As Integer

See Also

IDiagramConnectionPoint Interface


Position Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.Position Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets the position at which to render IDiagramConnection objects as starting or finishing.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Point Position { get; }
Visual Basic (Declaration)
ReadOnly Property Position As Point

See Also

IDiagramConnectionPoint Interface


PositionCalculator Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.PositionCalculator Property
IDiagramConnectionPoint Interface See Also Send Feedback
Gets or sets the IPositionCalculator that this IDiagramConnectionPoint Can use for calculating its position.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IPositionCalculator PositionCalculator { get; set; }
Visual Basic (Declaration)
Property PositionCalculator As IPositionCalculator

See Also

IDiagramConnectionPoint Interface


IDiagramConnectionPoint Events

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionPoint Events
IDiagramConnectionPoint Interface See Also Send Feedback

The IDiagramConnectionPoint type exposes the following members.

Events

Name | Description
IndexChanged | Raised when the Index property value changes.
PositionChanged | Raised when the Position property value changes.

See Also

IDiagramConnectionPoint Interface


IndexChanged Event

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.IndexChanged Event
IDiagramConnectionPoint Interface See Also Send Feedback
Raised when the Index property value changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
event EventHandler IndexChanged
Visual Basic (Declaration)
Event IndexChanged As EventHandler

See Also

IDiagramConnectionPoint Interface


PositionChanged Event

[image]

Mindscape WPF Diagrams
IDiagramConnectionPoint..::.PositionChanged Event
IDiagramConnectionPoint Interface See Also Send Feedback
Raised when the Position property value changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
event EventHandler PositionChanged
Visual Basic (Declaration)
Event PositionChanged As EventHandler

See Also

IDiagramConnectionPoint Interface


IDiagramConnectionRelocator Interface

[image]

Mindscape WPF Diagrams
IDiagramConnectionRelocator Interface
Members See Also Send Feedback
Provides services for relocating an IDiagramConnection to a different source or/and destination IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramConnectionRelocator
Visual Basic (Declaration)
Public Interface IDiagramConnectionRelocator

See Also

IDiagramConnectionRelocator Members


IDiagramConnectionRelocator Members

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionRelocator Members
IDiagramConnectionRelocator Interface Methods See Also Send Feedback

The IDiagramConnectionRelocator type exposes the following members.

Methods

Name | Description
CanRelocateConnection | Returns whether or not the connection can be relocated between the given connection point and connectable.
RelocateConnection | Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection.

See Also

IDiagramConnectionRelocator Interface


IDiagramConnectionRelocator Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionRelocator Methods
IDiagramConnectionRelocator Interface See Also Send Feedback

The IDiagramConnectionRelocator type exposes the following members.

Methods

Name | Description
CanRelocateConnection | Returns whether or not the connection can be relocated between the given connection point and connectable.
RelocateConnection | Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection.

See Also

IDiagramConnectionRelocator Interface


CanRelocateConnection Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionRelocator..::.CanRelocateConnection Method
IDiagramConnectionRelocator Interface See Also Send Feedback
Returns whether or not the connection can be relocated between the given connection point and connectable.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool CanRelocateConnection(
    IDiagramModel diagram,
    IDiagramConnection connection,
    IDiagramConnectionPoint connectionPoint,
    ConnectionDropTarget dropTarget
)
Visual Basic (Declaration)
Function CanRelocateConnection ( _
    diagram As IDiagramModel, _
    connection As IDiagramConnection, _
    connectionPoint As IDiagramConnectionPoint, _
    dropTarget As ConnectionDropTarget _
) As Boolean

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the connection belongs to.
connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection that is being relocated.
connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that the connection is still attached to.
dropTarget
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionDropTarget
Information about the potential destination that the connection is being relocated to.

Return Value

True if the connection can be relocated, otherwise false.

See Also

IDiagramConnectionRelocator Interface


RelocateConnection Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionRelocator..::.RelocateConnection Method
IDiagramConnectionRelocator Interface See Also Send Feedback
Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void RelocateConnection(
    ConnectionRelocationInfo info
)
Visual Basic (Declaration)
Sub RelocateConnection ( _
    info As ConnectionRelocationInfo _
)

Parameters

info
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionRelocationInfo
ConnectionRelocationInfo holding information about the connection relocation that is to be performed.

See Also

IDiagramConnectionRelocator Interface


IDiagramConnectionRemover Interface

[image]

Mindscape WPF Diagrams
IDiagramConnectionRemover Interface
Members See Also Send Feedback
Provides connection removal services from a diagram model.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramConnectionRemover
Visual Basic (Declaration)
Public Interface IDiagramConnectionRemover

See Also

IDiagramConnectionRemover Members


IDiagramConnectionRemover Members

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionRemover Members
IDiagramConnectionRemover Interface Methods See Also Send Feedback

The IDiagramConnectionRemover type exposes the following members.

Methods

Name | Description
RemoveConnections | Removes all the given IDiagramConnection objects from the given IDiagramModel.

See Also

IDiagramConnectionRemover Interface


IDiagramConnectionRemover Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionRemover Methods
IDiagramConnectionRemover Interface See Also Send Feedback

The IDiagramConnectionRemover type exposes the following members.

Methods

Name | Description
RemoveConnections | Removes all the given IDiagramConnection objects from the given IDiagramModel.

See Also

IDiagramConnectionRemover Interface


RemoveConnections Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionRemover..::.RemoveConnections Method
IDiagramConnectionRemover Interface See Also Send Feedback
Removes all the given IDiagramConnection objects from the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void RemoveConnections(
    IDiagramModel model,
    IList<IDiagramConnection> connections
)
Visual Basic (Declaration)
Sub RemoveConnections ( _
    model As IDiagramModel, _
    connections As IList(Of IDiagramConnection) _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to have connections removed from.
connections
Type: System.Collections.Generic..::.IList <(Of <( IDiagramConnection >)>)
The connections to be removed from the model.

See Also

IDiagramConnectionRemover Interface


IDiagramConnectionState Interface

[image]

Mindscape WPF Diagrams
IDiagramConnectionState Interface
Members See Also Send Feedback
Represents a state of an IDiagramConnection. Implementations of this interface will hold the values of the properties of an instance of an IDiagramConnection implementation.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramConnectionState
Visual Basic (Declaration)
Public Interface IDiagramConnectionState

Remarks

This interface is used primarily for Undo support.

See Also

IDiagramConnectionState Members


IDiagramConnectionState Members

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionState Members
IDiagramConnectionState Interface Methods Properties See Also Send Feedback

The IDiagramConnectionState type exposes the following members.

Methods

Name | Description
Apply | Applies all the property values held by this IDiagramConnectionState to the given IDiagramConnection.

Properties

Name | Description
Data | Gets the stored Data property value for the IDiagramConnection that this IDiagramConnectionState was made for.

See Also

IDiagramConnectionState Interface


IDiagramConnectionState Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionState Methods
IDiagramConnectionState Interface See Also Send Feedback

The IDiagramConnectionState type exposes the following members.

Methods

Name | Description
Apply | Applies all the property values held by this IDiagramConnectionState to the given IDiagramConnection.

See Also

IDiagramConnectionState Interface


Apply Method

[image]

Mindscape WPF Diagrams
IDiagramConnectionState..::.Apply Method
IDiagramConnectionState Interface See Also Send Feedback
Applies all the property values held by this IDiagramConnectionState to the given IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void Apply(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Sub Apply ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
An IDiagramConnection that will have its properties set to match those held by this IDiagramConnectionState.

See Also

IDiagramConnectionState Interface


IDiagramConnectionState Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramConnectionState Properties
IDiagramConnectionState Interface See Also Send Feedback

The IDiagramConnectionState type exposes the following members.

Properties

Name | Description
Data | Gets the stored Data property value for the IDiagramConnection that this IDiagramConnectionState was made for.

See Also

IDiagramConnectionState Interface


Data Property

[image]

Mindscape WPF Diagrams
IDiagramConnectionState..::.Data Property
IDiagramConnectionState Interface See Also Send Feedback
Gets the stored Data property value for the IDiagramConnection that this IDiagramConnectionState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Object Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As Object

See Also

IDiagramConnectionState Interface


IDiagramElementFactory Interface

[image]

Mindscape WPF Diagrams
IDiagramElementFactory Interface
Members See Also Send Feedback
Creates DiagramElement objects for custom diagram content.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramElementFactory
Visual Basic (Declaration)
Public Interface IDiagramElementFactory

See Also

IDiagramElementFactory Members


IDiagramElementFactory Members

[image] [image]

Mindscape WPF Diagrams
IDiagramElementFactory Members
IDiagramElementFactory Interface Methods See Also Send Feedback

The IDiagramElementFactory type exposes the following members.

Methods

Name | Description
CreateElement | Creates a DiagramElement for the specified diagram model item.

See Also

IDiagramElementFactory Interface


IDiagramElementFactory Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramElementFactory Methods
IDiagramElementFactory Interface See Also Send Feedback

The IDiagramElementFactory type exposes the following members.

Methods

Name | Description
CreateElement | Creates a DiagramElement for the specified diagram model item.

See Also

IDiagramElementFactory Interface


CreateElement Method

[image]

Mindscape WPF Diagrams
IDiagramElementFactory..::.CreateElement Method
IDiagramElementFactory Interface See Also Send Feedback
Creates a DiagramElement for the specified diagram model item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
DiagramElement CreateElement(
    Object diagramItem
)
Visual Basic (Declaration)
Function CreateElement ( _
    diagramItem As Object _
) As DiagramElement

Parameters

diagramItem
Type: System..::.Object
The diagram model item.

Return Value

A DiagramElement that can be used to display the specified item.

Remarks

The framework will set the Content property of the newly created DiagramElement; it is not necessary for the factory to do this itself.

See Also

IDiagramElementFactory Interface


IDiagramFormatter Interface

[image]

Mindscape WPF Diagrams
IDiagramFormatter Interface
Members See Also Send Feedback
Specifies the layout, formatting and visual style of a diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramFormatter
Visual Basic (Declaration)
Public Interface IDiagramFormatter

See Also

IDiagramFormatter Members


IDiagramFormatter Members

[image] [image]

Mindscape WPF Diagrams
IDiagramFormatter Members
IDiagramFormatter Interface Properties See Also Send Feedback

The IDiagramFormatter type exposes the following members.

Properties

Name | Description
ConnectionContentTemplateSelector | Gets a DataTemplateSelector which is used to select templates for the data content of IDiagramConnection objects.
ConnectionPointTemplateSelector | Gets a DataTemplateSelector used for selecting templates for diagram connection points.
ConnectionStyleSelector | Gets a StyleSelector which is used to select styles for diagram connections.
Layout | Gets an ILayout which positions nodes and connection points.
NodeContentTemplateSelector | Gets a DataTemplateSelector which is used to select templates for the data content of IDiagramNode objects.
NodeStyleSelector | Gets a StyleSelector which is used to select styles for diagram nodes.

See Also

IDiagramFormatter Interface


IDiagramFormatter Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramFormatter Properties
IDiagramFormatter Interface See Also Send Feedback

The IDiagramFormatter type exposes the following members.

Properties

Name | Description
ConnectionContentTemplateSelector | Gets a DataTemplateSelector which is used to select templates for the data content of IDiagramConnection objects.
ConnectionPointTemplateSelector | Gets a DataTemplateSelector used for selecting templates for diagram connection points.
ConnectionStyleSelector | Gets a StyleSelector which is used to select styles for diagram connections.
Layout | Gets an ILayout which positions nodes and connection points.
NodeContentTemplateSelector | Gets a DataTemplateSelector which is used to select templates for the data content of IDiagramNode objects.
NodeStyleSelector | Gets a StyleSelector which is used to select styles for diagram nodes.

See Also

IDiagramFormatter Interface


ConnectionContentTemplateSelector Property

[image]

Mindscape WPF Diagrams
IDiagramFormatter..::.ConnectionContentTemplateSelector Property
IDiagramFormatter Interface See Also Send Feedback
Gets a DataTemplateSelector which is used to select templates for the data content of IDiagramConnection objects.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
DataTemplateSelector ConnectionContentTemplateSelector { get; }
Visual Basic (Declaration)
ReadOnly Property ConnectionContentTemplateSelector As DataTemplateSelector

See Also

IDiagramFormatter Interface


ConnectionPointTemplateSelector Property

[image]

Mindscape WPF Diagrams
IDiagramFormatter..::.ConnectionPointTemplateSelector Property
IDiagramFormatter Interface See Also Send Feedback
Gets a DataTemplateSelector used for selecting templates for diagram connection points.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
DataTemplateSelector ConnectionPointTemplateSelector { get; }
Visual Basic (Declaration)
ReadOnly Property ConnectionPointTemplateSelector As DataTemplateSelector

See Also

IDiagramFormatter Interface


ConnectionStyleSelector Property

[image]

Mindscape WPF Diagrams
IDiagramFormatter..::.ConnectionStyleSelector Property
IDiagramFormatter Interface See Also Send Feedback
Gets a StyleSelector which is used to select styles for diagram connections.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
StyleSelector ConnectionStyleSelector { get; }
Visual Basic (Declaration)
ReadOnly Property ConnectionStyleSelector As StyleSelector

See Also

IDiagramFormatter Interface


Layout Property

[image]

Mindscape WPF Diagrams
IDiagramFormatter..::.Layout Property
IDiagramFormatter Interface See Also Send Feedback
Gets an ILayout which positions nodes and connection points.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
ILayout Layout { get; }
Visual Basic (Declaration)
ReadOnly Property Layout As ILayout

See Also

IDiagramFormatter Interface


NodeContentTemplateSelector Property

[image]

Mindscape WPF Diagrams
IDiagramFormatter..::.NodeContentTemplateSelector Property
IDiagramFormatter Interface See Also Send Feedback
Gets a DataTemplateSelector which is used to select templates for the data content of IDiagramNode objects.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
DataTemplateSelector NodeContentTemplateSelector { get; }
Visual Basic (Declaration)
ReadOnly Property NodeContentTemplateSelector As DataTemplateSelector

See Also

IDiagramFormatter Interface


NodeStyleSelector Property

[image]

Mindscape WPF Diagrams
IDiagramFormatter..::.NodeStyleSelector Property
IDiagramFormatter Interface See Also Send Feedback
Gets a StyleSelector which is used to select styles for diagram nodes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
StyleSelector NodeStyleSelector { get; }
Visual Basic (Declaration)
ReadOnly Property NodeStyleSelector As StyleSelector

See Also

IDiagramFormatter Interface


IDiagramModel Interface

[image]

Mindscape WPF Diagrams
IDiagramModel Interface
Members See Also Send Feedback
Provides an abstract representation of diagram entities, ready for rendering using templates.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramModel
Visual Basic (Declaration)
Public Interface IDiagramModel

See Also

IDiagramModel Members


IDiagramModel Members

[image] [image]

Mindscape WPF Diagrams
IDiagramModel Members
IDiagramModel Interface Properties See Also Send Feedback

The IDiagramModel type exposes the following members.

Properties

Name | Description
ConnectionRelocator | Gets the IDiagramConnectionRelocator to be used to relocate an IDiagramConnection.
ConnectionRemover | Gets the IDiagramConnectionRemover to be used to remove connections from the IDiagramModel.
Connections | Gets the connections of the diagram.
CustomItems | Gets any additional custom items to be displayed on the diagram surface.
DefaultConnectionBuilder | Gets a builder for creating connections when no other connection builder is specified.
NodeRemover | Gets the IDiagramNodeRemover to be used for removing nodes from the IDiagramModel.
Nodes | Gets the nodes of the diagram.
Source | Gets the source of the data presented through the IDiagramModel, if any.

See Also

IDiagramModel Interface


IDiagramModel Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramModel Properties
IDiagramModel Interface See Also Send Feedback

The IDiagramModel type exposes the following members.

Properties

Name | Description
ConnectionRelocator | Gets the IDiagramConnectionRelocator to be used to relocate an IDiagramConnection.
ConnectionRemover | Gets the IDiagramConnectionRemover to be used to remove connections from the IDiagramModel.
Connections | Gets the connections of the diagram.
CustomItems | Gets any additional custom items to be displayed on the diagram surface.
DefaultConnectionBuilder | Gets a builder for creating connections when no other connection builder is specified.
NodeRemover | Gets the IDiagramNodeRemover to be used for removing nodes from the IDiagramModel.
Nodes | Gets the nodes of the diagram.
Source | Gets the source of the data presented through the IDiagramModel, if any.

See Also

IDiagramModel Interface


ConnectionRelocator Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.ConnectionRelocator Property
IDiagramModel Interface See Also Send Feedback
Gets the IDiagramConnectionRelocator to be used to relocate an IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionRelocator ConnectionRelocator { get; }
Visual Basic (Declaration)
ReadOnly Property ConnectionRelocator As IDiagramConnectionRelocator

See Also

IDiagramModel Interface


ConnectionRemover Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.ConnectionRemover Property
IDiagramModel Interface See Also Send Feedback
Gets the IDiagramConnectionRemover to be used to remove connections from the IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionRemover ConnectionRemover { get; }
Visual Basic (Declaration)
ReadOnly Property ConnectionRemover As IDiagramConnectionRemover

See Also

IDiagramModel Interface


Connections Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.Connections Property
IDiagramModel Interface See Also Send Feedback
Gets the connections of the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IList Connections { get; }
Visual Basic (Declaration)
ReadOnly Property Connections As IList

Remarks

List elements must implement IDiagramConnection.

See Also

IDiagramModel Interface


CustomItems Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.CustomItems Property
IDiagramModel Interface See Also Send Feedback
Gets any additional custom items to be displayed on the diagram surface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IList CustomItems { get; }
Visual Basic (Declaration)
ReadOnly Property CustomItems As IList

See Also

IDiagramModel Interface


DefaultConnectionBuilder Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.DefaultConnectionBuilder Property
IDiagramModel Interface See Also Send Feedback
Gets a builder for creating connections when no other connection builder is specified.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionBuilder DefaultConnectionBuilder { get; }
Visual Basic (Declaration)
ReadOnly Property DefaultConnectionBuilder As IDiagramConnectionBuilder

See Also

IDiagramModel Interface


NodeRemover Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.NodeRemover Property
IDiagramModel Interface See Also Send Feedback
Gets the IDiagramNodeRemover to be used for removing nodes from the IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramNodeRemover NodeRemover { get; }
Visual Basic (Declaration)
ReadOnly Property NodeRemover As IDiagramNodeRemover

See Also

IDiagramModel Interface


Nodes Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.Nodes Property
IDiagramModel Interface See Also Send Feedback
Gets the nodes of the diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IList Nodes { get; }
Visual Basic (Declaration)
ReadOnly Property Nodes As IList

Remarks

List elements must implement IDiagramNode.

See Also

IDiagramModel Interface


Source Property

[image]

Mindscape WPF Diagrams
IDiagramModel..::.Source Property
IDiagramModel Interface See Also Send Feedback
Gets the source of the data presented through the IDiagramModel, if any.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Object Source { get; }
Visual Basic (Declaration)
ReadOnly Property Source As Object

See Also

IDiagramModel Interface


IDiagramNode Interface

[image]

Mindscape WPF Diagrams
IDiagramNode Interface
Members See Also Send Feedback
Represents a diagram model entity that should be made visible in the diagram as a DiagramNodeElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramNode : IDiagramPositionable,
    IDiagramZOrderable, IDiagramConnectable
Visual Basic (Declaration)
Public Interface IDiagramNode _
    Implements IDiagramPositionable, IDiagramZOrderable, IDiagramConnectable

See Also

IDiagramNode Members


IDiagramNode Members

[image] [image]

Mindscape WPF Diagrams
IDiagramNode Members
IDiagramNode Interface Methods Properties Events See Also Send Feedback

The IDiagramNode type exposes the following members.

Methods

Name | Description
Clone | Returns an IDiagramNodeState that holds current property values of this IDiagramNode at the time this method is called.
GetCollisionBounds | Returns the rectangle that is taken into consideration when a connection path is being constructed to the given IDiagramConnectionPoint. Generally, an IDiagramNode should return its bounds, and an IDiagramConnection should return a Rect with the position of the given IDiagramConnectionPoint and a size of 0. (Inherited from IDiagramConnectable.)
SetAs | Sets all the properties of this IDiagramNode to match those of the given IDiagramNodeState.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the diagram item. (Inherited from IDiagramPositionable.)
CanOriginateNewConnections | Gets whether any more connections can begin at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
CanReceiveNewConnections | Gets whether any more connections can end at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
ConnectionPoints | Gets the points at which connections can attach to the IDiagramNode.
Data | Gets the data represented by the IDiagramConnectable, such as a business object in the domain being diagrammed. (Inherited from IDiagramConnectable.)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified.
IsResizable | Gets or sets whether the IDiagramPositionable can be resized. (Inherited from IDiagramPositionable.)
Parent | Gets the parent of the diagram item, if the item is part of a hierarchy. (Inherited from IDiagramPositionable.)
Rotation | Gets or sets the rotation of the IDiagramNode.
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders. (Inherited from IDiagramZOrderable.)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from IDiagramPositionable.)
DataChanged | Raised when the Data property changes. (Inherited from IDiagramConnectable.)
RotationChanged | Raised when the Rotation property changes.

See Also

IDiagramNode Interface


IDiagramNode Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramNode Methods
IDiagramNode Interface See Also Send Feedback

The IDiagramNode type exposes the following members.

Methods

Name | Description
Clone | Returns an IDiagramNodeState that holds current property values of this IDiagramNode at the time this method is called.
GetCollisionBounds | Returns the rectangle that is taken into consideration when a connection path is being constructed to the given IDiagramConnectionPoint. Generally, an IDiagramNode should return its bounds, and an IDiagramConnection should return a Rect with the position of the given IDiagramConnectionPoint and a size of 0. (Inherited from IDiagramConnectable.)
SetAs | Sets all the properties of this IDiagramNode to match those of the given IDiagramNodeState.

See Also

IDiagramNode Interface


Clone Method

[image]

Mindscape WPF Diagrams
IDiagramNode..::.Clone Method
IDiagramNode Interface See Also Send Feedback
Returns an IDiagramNodeState that holds current property values of this IDiagramNode at the time this method is called.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramNodeState Clone()
Visual Basic (Declaration)
Function Clone As IDiagramNodeState

Return Value

An IDiagramNodeState representing the current state of this IDiagramNode.

See Also

IDiagramNode Interface


SetAs Method

[image]

Mindscape WPF Diagrams
IDiagramNode..::.SetAs Method
IDiagramNode Interface See Also Send Feedback
Sets all the properties of this IDiagramNode to match those of the given IDiagramNodeState.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void SetAs(
    IDiagramNodeState state
)
Visual Basic (Declaration)
Sub SetAs ( _
    state As IDiagramNodeState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNodeState
The IDiagramNodeState to copy the properties from.

See Also

IDiagramNode Interface


IDiagramNode Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramNode Properties
IDiagramNode Interface See Also Send Feedback

The IDiagramNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the diagram item. (Inherited from IDiagramPositionable.)
CanOriginateNewConnections | Gets whether any more connections can begin at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
CanReceiveNewConnections | Gets whether any more connections can end at this IDiagramConnectable at all. (Inherited from IDiagramConnectable.)
ConnectionPoints | Gets the points at which connections can attach to the IDiagramNode.
Data | Gets the data represented by the IDiagramConnectable, such as a business object in the domain being diagrammed. (Inherited from IDiagramConnectable.)
DefaultConnectionPoint | Gets the connection point to be used if a connection is attached to the node and no other connection point is specified.
IsResizable | Gets or sets whether the IDiagramPositionable can be resized. (Inherited from IDiagramPositionable.)
Parent | Gets the parent of the diagram item, if the item is part of a hierarchy. (Inherited from IDiagramPositionable.)
Rotation | Gets or sets the rotation of the IDiagramNode.
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders. (Inherited from IDiagramZOrderable.)

See Also

IDiagramNode Interface


ConnectionPoints Property

[image]

Mindscape WPF Diagrams
IDiagramNode..::.ConnectionPoints Property
IDiagramNode Interface See Also Send Feedback
Gets the points at which connections can attach to the IDiagramNode.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IEnumerable<IDiagramConnectionPoint> ConnectionPoints { get; }
Visual Basic (Declaration)
ReadOnly Property ConnectionPoints As IEnumerable(Of IDiagramConnectionPoint)

See Also

IDiagramNode Interface


DefaultConnectionPoint Property

[image]

Mindscape WPF Diagrams
IDiagramNode..::.DefaultConnectionPoint Property
IDiagramNode Interface See Also Send Feedback
Gets the connection point to be used if a connection is attached to the node and no other connection point is specified.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramConnectionPoint DefaultConnectionPoint { get; }
Visual Basic (Declaration)
ReadOnly Property DefaultConnectionPoint As IDiagramConnectionPoint

Remarks

Implementations may return null to indicate that a specific connection point must always be used when creating a connection.

See Also

IDiagramNode Interface


Rotation Property

[image]

Mindscape WPF Diagrams
IDiagramNode..::.Rotation Property
IDiagramNode Interface See Also Send Feedback
Gets or sets the rotation of the IDiagramNode.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
double Rotation { get; set; }
Visual Basic (Declaration)
Property Rotation As Double

See Also

IDiagramNode Interface


IDiagramNode Events

[image] [image]

Mindscape WPF Diagrams
IDiagramNode Events
IDiagramNode Interface See Also Send Feedback

The IDiagramNode type exposes the following members.

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from IDiagramPositionable.)
DataChanged | Raised when the Data property changes. (Inherited from IDiagramConnectable.)
RotationChanged | Raised when the Rotation property changes.

See Also

IDiagramNode Interface


RotationChanged Event

[image]

Mindscape WPF Diagrams
IDiagramNode..::.RotationChanged Event
IDiagramNode Interface See Also Send Feedback
Raised when the Rotation property changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
event EventHandler RotationChanged
Visual Basic (Declaration)
Event RotationChanged As EventHandler

See Also

IDiagramNode Interface


IDiagramNodeBuilder Interface

[image]

Mindscape WPF Diagrams
IDiagramNodeBuilder Interface
Members See Also Send Feedback
Provides node creation services for use by toolbox items.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramNodeBuilder
Visual Basic (Declaration)
Public Interface IDiagramNodeBuilder

See Also

IDiagramNodeBuilder Members


IDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeBuilder Members
IDiagramNodeBuilder Interface Methods Properties See Also Send Feedback

The IDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Creates a new node in a diagram.

Properties

Name | Description
DefaultSize | Gets the default size, used if the application cannot determine an appropriate size using its own user interface.

See Also

IDiagramNodeBuilder Interface


IDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeBuilder Methods
IDiagramNodeBuilder Interface See Also Send Feedback

The IDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Creates a new node in a diagram.

See Also

IDiagramNodeBuilder Interface


CreateNode Method

[image]

Mindscape WPF Diagrams
IDiagramNodeBuilder..::.CreateNode Method
IDiagramNodeBuilder Interface See Also Send Feedback
Creates a new node in a diagram.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The diagram in which the node is to be placed.
bounds
Type: System.Windows..::.Rect
The bounds within which to create the node, relative to the DiagramSurface.

Remarks

The builder may implement node creation by adding a node to the diagram model, or by creating an object or relationship in a business object model (which is observed by the diagram model.)

See Also

IDiagramNodeBuilder Interface


IDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeBuilder Properties
IDiagramNodeBuilder Interface See Also Send Feedback

The IDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Gets the default size, used if the application cannot determine an appropriate size using its own user interface.

See Also

IDiagramNodeBuilder Interface


DefaultSize Property

[image]

Mindscape WPF Diagrams
IDiagramNodeBuilder..::.DefaultSize Property
IDiagramNodeBuilder Interface See Also Send Feedback
Gets the default size, used if the application cannot determine an appropriate size using its own user interface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Size DefaultSize { get; }
Visual Basic (Declaration)
ReadOnly Property DefaultSize As Size

See Also

IDiagramNodeBuilder Interface


IDiagramNodeRemover Interface

[image]

Mindscape WPF Diagrams
IDiagramNodeRemover Interface
Members See Also Send Feedback
Provides node removal services from a diagram model.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramNodeRemover
Visual Basic (Declaration)
Public Interface IDiagramNodeRemover

See Also

IDiagramNodeRemover Members


IDiagramNodeRemover Members

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeRemover Members
IDiagramNodeRemover Interface Methods See Also Send Feedback

The IDiagramNodeRemover type exposes the following members.

Methods

Name | Description
RemoveNodes | Removes all the given IDiagramNode objects from the given IDiagramModel.

See Also

IDiagramNodeRemover Interface


IDiagramNodeRemover Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeRemover Methods
IDiagramNodeRemover Interface See Also Send Feedback

The IDiagramNodeRemover type exposes the following members.

Methods

Name | Description
RemoveNodes | Removes all the given IDiagramNode objects from the given IDiagramModel.

See Also

IDiagramNodeRemover Interface


RemoveNodes Method

[image]

Mindscape WPF Diagrams
IDiagramNodeRemover..::.RemoveNodes Method
IDiagramNodeRemover Interface See Also Send Feedback
Removes all the given IDiagramNode objects from the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void RemoveNodes(
    IDiagramModel model,
    IList<IDiagramNode> nodes
)
Visual Basic (Declaration)
Sub RemoveNodes ( _
    model As IDiagramModel, _
    nodes As IList(Of IDiagramNode) _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
An IDiagramModel to have nodes removed from.
nodes
Type: System.Collections.Generic..::.IList <(Of <( IDiagramNode >)>)
The nodes to be removed from the model.

See Also

IDiagramNodeRemover Interface


IDiagramNodeState Interface

[image]

Mindscape WPF Diagrams
IDiagramNodeState Interface
Members See Also Send Feedback
Represents a state of an IDiagramNode. Implementations of this interface will hold the values of the properties of an instance of an IDiagramNode implementation.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramNodeState
Visual Basic (Declaration)
Public Interface IDiagramNodeState

Remarks

This interface is used primarily for Undo support.

See Also

IDiagramNodeState Members


IDiagramNodeState Members

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeState Members
IDiagramNodeState Interface Methods Properties See Also Send Feedback

The IDiagramNodeState type exposes the following members.

Methods

Name | Description
Apply | Applies all the property values held by this IDiagramNodeState to the given IDiagramNode.

Properties

Name | Description
Bounds | Gets the stored Bounds property value for the IDiagramNode that this IDiagramNodeState was made for.
Data | Gets the stored Data property value for the IDiagramNode that this IDiagramNodeState was made for.
Parent | Gets the stored Parent property value for the IDiagramNode that this IDiagramNodeState was made for.
ZOrder | Gets the stored ZOrder property value for the IDiagramNode that this IDiagramNodeState was made for.

See Also

IDiagramNodeState Interface


IDiagramNodeState Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeState Methods
IDiagramNodeState Interface See Also Send Feedback

The IDiagramNodeState type exposes the following members.

Methods

Name | Description
Apply | Applies all the property values held by this IDiagramNodeState to the given IDiagramNode.

See Also

IDiagramNodeState Interface


Apply Method

[image]

Mindscape WPF Diagrams
IDiagramNodeState..::.Apply Method
IDiagramNodeState Interface See Also Send Feedback
Applies all the property values held by this IDiagramNodeState to the given IDiagramNode.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void Apply(
    IDiagramNode node
)
Visual Basic (Declaration)
Sub Apply ( _
    node As IDiagramNode _
)

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
An IDiagramNode that will have its properties set to match those held by this IDiagramNodeState.

See Also

IDiagramNodeState Interface


IDiagramNodeState Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramNodeState Properties
IDiagramNodeState Interface See Also Send Feedback

The IDiagramNodeState type exposes the following members.

Properties

Name | Description
Bounds | Gets the stored Bounds property value for the IDiagramNode that this IDiagramNodeState was made for.
Data | Gets the stored Data property value for the IDiagramNode that this IDiagramNodeState was made for.
Parent | Gets the stored Parent property value for the IDiagramNode that this IDiagramNodeState was made for.
ZOrder | Gets the stored ZOrder property value for the IDiagramNode that this IDiagramNodeState was made for.

See Also

IDiagramNodeState Interface


Bounds Property

[image]

Mindscape WPF Diagrams
IDiagramNodeState..::.Bounds Property
IDiagramNodeState Interface See Also Send Feedback
Gets the stored Bounds property value for the IDiagramNode that this IDiagramNodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Rect Bounds { get; }
Visual Basic (Declaration)
ReadOnly Property Bounds As Rect

See Also

IDiagramNodeState Interface


Data Property

[image]

Mindscape WPF Diagrams
IDiagramNodeState..::.Data Property
IDiagramNodeState Interface See Also Send Feedback
Gets the stored Data property value for the IDiagramNode that this IDiagramNodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Object Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As Object

See Also

IDiagramNodeState Interface


Parent Property

[image]

Mindscape WPF Diagrams
IDiagramNodeState..::.Parent Property
IDiagramNodeState Interface See Also Send Feedback
Gets the stored Parent property value for the IDiagramNode that this IDiagramNodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramPositionable Parent { get; }
Visual Basic (Declaration)
ReadOnly Property Parent As IDiagramPositionable

See Also

IDiagramNodeState Interface


ZOrder Property

[image]

Mindscape WPF Diagrams
IDiagramNodeState..::.ZOrder Property
IDiagramNodeState Interface See Also Send Feedback
Gets the stored ZOrder property value for the IDiagramNode that this IDiagramNodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
double ZOrder { get; }
Visual Basic (Declaration)
ReadOnly Property ZOrder As Double

See Also

IDiagramNodeState Interface


IDiagramPositionable Interface

[image]

Mindscape WPF Diagrams
IDiagramPositionable Interface
Members See Also Send Feedback
Represents an item which can be positioned in the diagram and the z-order (as opposed to acquiring its position and z-order from other items).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramPositionable : IDiagramZOrderable
Visual Basic (Declaration)
Public Interface IDiagramPositionable _
    Implements IDiagramZOrderable

See Also

IDiagramPositionable Members


IDiagramPositionable Members

[image] [image]

Mindscape WPF Diagrams
IDiagramPositionable Members
IDiagramPositionable Interface Properties Events See Also Send Feedback

The IDiagramPositionable type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the diagram item.
IsResizable | Gets or sets whether the IDiagramPositionable can be resized.
Parent | Gets the parent of the diagram item, if the item is part of a hierarchy.
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders. (Inherited from IDiagramZOrderable.)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes.

See Also

IDiagramPositionable Interface


IDiagramPositionable Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramPositionable Properties
IDiagramPositionable Interface See Also Send Feedback

The IDiagramPositionable type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the diagram item.
IsResizable | Gets or sets whether the IDiagramPositionable can be resized.
Parent | Gets the parent of the diagram item, if the item is part of a hierarchy.
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders. (Inherited from IDiagramZOrderable.)

See Also

IDiagramPositionable Interface


Bounds Property

[image]

Mindscape WPF Diagrams
IDiagramPositionable..::.Bounds Property
IDiagramPositionable Interface See Also Send Feedback
Gets or sets the display location and size of the diagram item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Rect Bounds { get; set; }
Visual Basic (Declaration)
Property Bounds As Rect

See Also

IDiagramPositionable Interface


IsResizable Property

[image]

Mindscape WPF Diagrams
IDiagramPositionable..::.IsResizable Property
IDiagramPositionable Interface See Also Send Feedback
Gets or sets whether the IDiagramPositionable can be resized.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool IsResizable { get; set; }
Visual Basic (Declaration)
Property IsResizable As Boolean

See Also

IDiagramPositionable Interface


Parent Property

[image]

Mindscape WPF Diagrams
IDiagramPositionable..::.Parent Property
IDiagramPositionable Interface See Also Send Feedback
Gets the parent of the diagram item, if the item is part of a hierarchy.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IDiagramPositionable Parent { get; }
Visual Basic (Declaration)
ReadOnly Property Parent As IDiagramPositionable

See Also

IDiagramPositionable Interface


IDiagramPositionable Events

[image] [image]

Mindscape WPF Diagrams
IDiagramPositionable Events
IDiagramPositionable Interface See Also Send Feedback

The IDiagramPositionable type exposes the following members.

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes.

See Also

IDiagramPositionable Interface


BoundsChanged Event

[image]

Mindscape WPF Diagrams
IDiagramPositionable..::.BoundsChanged Event
IDiagramPositionable Interface See Also Send Feedback
Raised when the Bounds property changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
event EventHandler BoundsChanged
Visual Basic (Declaration)
Event BoundsChanged As EventHandler

See Also

IDiagramPositionable Interface


IDiagramPrintCallback Interface

[image]

Mindscape WPF Diagrams
IDiagramPrintCallback Interface
Members See Also Send Feedback
Gets additional elements for printing on a DiagramPrintDocument.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramPrintCallback
Visual Basic (Declaration)
Public Interface IDiagramPrintCallback

See Also

IDiagramPrintCallback Members


IDiagramPrintCallback Members

[image] [image]

Mindscape WPF Diagrams
IDiagramPrintCallback Members
IDiagramPrintCallback Interface Methods See Also Send Feedback

The IDiagramPrintCallback type exposes the following members.

Methods

Name | Description
GetBackgroundElements | Gets the elements to be printed in the background (behind the diagram itself).
GetForegroundElements | Gets the elements to be printed in the foreground (in front of the diagram itself).

See Also

IDiagramPrintCallback Interface


IDiagramPrintCallback Methods

[image] [image]

Mindscape WPF Diagrams
IDiagramPrintCallback Methods
IDiagramPrintCallback Interface See Also Send Feedback

The IDiagramPrintCallback type exposes the following members.

Methods

Name | Description
GetBackgroundElements | Gets the elements to be printed in the background (behind the diagram itself).
GetForegroundElements | Gets the elements to be printed in the foreground (in front of the diagram itself).

See Also

IDiagramPrintCallback Interface


GetBackgroundElements Method

[image]

Mindscape WPF Diagrams
IDiagramPrintCallback..::.GetBackgroundElements Method
IDiagramPrintCallback Interface See Also Send Feedback
Gets the elements to be printed in the background (behind the diagram itself).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IEnumerable<UIElement> GetBackgroundElements(
    int pageIndex,
    Size pageSize,
    Point printableOrigin,
    Size printableSize
)
Visual Basic (Declaration)
Function GetBackgroundElements ( _
    pageIndex As Integer, _
    pageSize As Size, _
    printableOrigin As Point, _
    printableSize As Size _
) As IEnumerable(Of UIElement)

Parameters

pageIndex
Type: System..::.Int32
The page index (0-based).
pageSize
Type: System.Windows..::.Size
The total page size.
printableOrigin
Type: System.Windows..::.Point
The top left of the printable area.
printableSize
Type: System.Windows..::.Size
The size of the printable area.

Return Value

A sequence of elements to be printed behind the diagram.

See Also

IDiagramPrintCallback Interface


GetForegroundElements Method

[image]

Mindscape WPF Diagrams
IDiagramPrintCallback..::.GetForegroundElements Method
IDiagramPrintCallback Interface See Also Send Feedback
Gets the elements to be printed in the foreground (in front of the diagram itself).

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IEnumerable<UIElement> GetForegroundElements(
    int pageIndex,
    Size pageSize,
    Point printableOrigin,
    Size printableSize
)
Visual Basic (Declaration)
Function GetForegroundElements ( _
    pageIndex As Integer, _
    pageSize As Size, _
    printableOrigin As Point, _
    printableSize As Size _
) As IEnumerable(Of UIElement)

Parameters

pageIndex
Type: System..::.Int32
The page index (0-based).
pageSize
Type: System.Windows..::.Size
The total page size.
printableOrigin
Type: System.Windows..::.Point
The top left of the printable area.
printableSize
Type: System.Windows..::.Size
The size of the printable area.

Return Value

A sequence of elements to be printed in front of the diagram.

See Also

IDiagramPrintCallback Interface


IDiagramToolboxTool Interface

[image]

Mindscape WPF Diagrams
IDiagramToolboxTool Interface
Members See Also Send Feedback
Represents a control which can be dragged from a toolbox onto a DiagramSurface to create new diagram elements.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramToolboxTool
Visual Basic (Declaration)
Public Interface IDiagramToolboxTool

See Also

IDiagramToolboxTool Members


IDiagramToolboxTool Members

[image] [image]

Mindscape WPF Diagrams
IDiagramToolboxTool Members
IDiagramToolboxTool Interface Properties See Also Send Feedback

The IDiagramToolboxTool type exposes the following members.

Properties

Name | Description
ToolScope | Gets the containing object within which the tool can be applied.

See Also

IDiagramToolboxTool Interface


IDiagramToolboxTool Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramToolboxTool Properties
IDiagramToolboxTool Interface See Also Send Feedback

The IDiagramToolboxTool type exposes the following members.

Properties

Name | Description
ToolScope | Gets the containing object within which the tool can be applied.

See Also

IDiagramToolboxTool Interface


ToolScope Property

[image]

Mindscape WPF Diagrams
IDiagramToolboxTool..::.ToolScope Property
IDiagramToolboxTool Interface See Also Send Feedback
Gets the containing object within which the tool can be applied.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
DependencyObject ToolScope { get; }
Visual Basic (Declaration)
ReadOnly Property ToolScope As DependencyObject

See Also

IDiagramToolboxTool Interface


IDiagramZOrderable Interface

[image]

Mindscape WPF Diagrams
IDiagramZOrderable Interface
Members See Also Send Feedback
Represents an item in a diagram that can participate in Z-ordering.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IDiagramZOrderable
Visual Basic (Declaration)
Public Interface IDiagramZOrderable

See Also

IDiagramZOrderable Members


IDiagramZOrderable Members

[image] [image]

Mindscape WPF Diagrams
IDiagramZOrderable Members
IDiagramZOrderable Interface Properties See Also Send Feedback

The IDiagramZOrderable type exposes the following members.

Properties

Name | Description
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders.

See Also

IDiagramZOrderable Interface


IDiagramZOrderable Properties

[image] [image]

Mindscape WPF Diagrams
IDiagramZOrderable Properties
IDiagramZOrderable Interface See Also Send Feedback

The IDiagramZOrderable type exposes the following members.

Properties

Name | Description
ZOrder | Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders.

See Also

IDiagramZOrderable Interface


ZOrder Property

[image]

Mindscape WPF Diagrams
IDiagramZOrderable..::.ZOrder Property
IDiagramZOrderable Interface See Also Send Feedback
Gets or sets the relative z-order of the diagram item. Lower z-orders appear behind higher z-orders.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
double ZOrder { get; set; }
Visual Basic (Declaration)
Property ZOrder As Double

Remarks

This value represents the z-order of the item relative to its siblings. It does not normally equate to the Panel.ZIndex of the element representing the item in the user interface.

See Also

IDiagramZOrderable Interface


ILayout Interface

[image]

Mindscape WPF Diagrams
ILayout Interface
Members See Also Send Feedback
Maps between diagram model bounds and element bounds on a DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface ILayout
Visual Basic (Declaration)
Public Interface ILayout

Remarks

Most formatters need not specify an ILayout, in which case they will get the default layout, and node bounds will be the same in the model and on the diagram surface.

See Also

ILayout Members


ILayout Members

[image] [image]

Mindscape WPF Diagrams
ILayout Members
ILayout Interface Methods See Also Send Feedback

The ILayout type exposes the following members.

Methods

Name | Description
GetDisplayBounds | Gets the display rectangle for a node.
GetDisplayPosition | Gets the display position for a connection point.
SetNodeBounds | Sets the model bounds for a node, based on its display rectangle.

See Also

ILayout Interface


ILayout Methods

[image] [image]

Mindscape WPF Diagrams
ILayout Methods
ILayout Interface See Also Send Feedback

The ILayout type exposes the following members.

Methods

Name | Description
GetDisplayBounds | Gets the display rectangle for a node.
GetDisplayPosition | Gets the display position for a connection point.
SetNodeBounds | Sets the model bounds for a node, based on its display rectangle.

See Also

ILayout Interface


GetDisplayBounds Method

[image]

Mindscape WPF Diagrams
ILayout..::.GetDisplayBounds Method
ILayout Interface See Also Send Feedback
Gets the display rectangle for a node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Rect GetDisplayBounds(
    IDiagramNode node
)
Visual Basic (Declaration)
Function GetDisplayBounds ( _
    node As IDiagramNode _
) As Rect

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The node for which the display rectangle is required.

Return Value

The display rectangle.

Remarks

This operation must be the inverse of SetNodeBounds(IDiagramNode, Rect).

See Also

ILayout Interface


GetDisplayPosition Method

[image]

Mindscape WPF Diagrams
ILayout..::.GetDisplayPosition Method
ILayout Interface See Also Send Feedback
Gets the display position for a connection point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Point GetDisplayPosition(
    IDiagramConnectionPoint connectionPoint
)
Visual Basic (Declaration)
Function GetDisplayPosition ( _
    connectionPoint As IDiagramConnectionPoint _
) As Point

Parameters

connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The connection point for which the display position is required.

Return Value

The display position.

See Also

ILayout Interface


SetNodeBounds Method

[image]

Mindscape WPF Diagrams
ILayout..::.SetNodeBounds Method
ILayout Interface See Also Send Feedback
Sets the model bounds for a node, based on its display rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void SetNodeBounds(
    IDiagramNode node,
    Rect displayBounds
)
Visual Basic (Declaration)
Sub SetNodeBounds ( _
    node As IDiagramNode, _
    displayBounds As Rect _
)

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The node whose bounds are to be set.
displayBounds
Type: System.Windows..::.Rect
The node's display rectangle.

Remarks

This operation must be the inverse of GetDisplayBounds(IDiagramNode).

See Also

ILayout Interface


ILayoutAlgorithm Interface

[image]

Mindscape WPF Diagrams
ILayoutAlgorithm Interface
Members See Also Send Feedback
represents an algorithm that can be applied to an IDiagramModel which will reposition the nodes within the diagram into a sutable position.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface ILayoutAlgorithm
Visual Basic (Declaration)
Public Interface ILayoutAlgorithm

See Also

ILayoutAlgorithm Members


ILayoutAlgorithm Members

[image] [image]

Mindscape WPF Diagrams
ILayoutAlgorithm Members
ILayoutAlgorithm Interface Methods Properties See Also Send Feedback

The ILayoutAlgorithm type exposes the following members.

Methods

Name | Description
Run | Runs the layout algorithm.

Properties

Name | Description
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic.

See Also

ILayoutAlgorithm Interface


ILayoutAlgorithm Methods

[image] [image]

Mindscape WPF Diagrams
ILayoutAlgorithm Methods
ILayoutAlgorithm Interface See Also Send Feedback

The ILayoutAlgorithm type exposes the following members.

Methods

Name | Description
Run | Runs the layout algorithm.

See Also

ILayoutAlgorithm Interface


Run Method

[image]

Mindscape WPF Diagrams
ILayoutAlgorithm..::.Run Method
ILayoutAlgorithm Interface See Also Send Feedback
Runs the layout algorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The diagram to be laid out.

See Also

ILayoutAlgorithm Interface


ILayoutAlgorithm Properties

[image] [image]

Mindscape WPF Diagrams
ILayoutAlgorithm Properties
ILayoutAlgorithm Interface See Also Send Feedback

The ILayoutAlgorithm type exposes the following members.

Properties

Name | Description
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic.

See Also

ILayoutAlgorithm Interface


Info Property

[image]

Mindscape WPF Diagrams
ILayoutAlgorithm..::.Info Property
ILayoutAlgorithm Interface See Also Send Feedback
Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
ILayoutAlgorithmInfo Info { get; set; }
Visual Basic (Declaration)
Property Info As ILayoutAlgorithmInfo

See Also

ILayoutAlgorithm Interface


ILayoutAlgorithmInfo Interface

[image]

Mindscape WPF Diagrams
ILayoutAlgorithmInfo Interface
Members See Also Send Feedback
Provides additional logic for layout algorithms that may be specific to certain diagram types.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface ILayoutAlgorithmInfo
Visual Basic (Declaration)
Public Interface ILayoutAlgorithmInfo

See Also

ILayoutAlgorithmInfo Members


ILayoutAlgorithmInfo Members

[image] [image]

Mindscape WPF Diagrams
ILayoutAlgorithmInfo Members
ILayoutAlgorithmInfo Interface Methods See Also Send Feedback

The ILayoutAlgorithmInfo type exposes the following members.

Methods

Name | Description
IsIncluded | Returns whether or not the given node is to be modified by the layout algorithm. This is so certain diagram types can specify that nodes such as comments or titles should be ignored.

See Also

ILayoutAlgorithmInfo Interface


ILayoutAlgorithmInfo Methods

[image] [image]

Mindscape WPF Diagrams
ILayoutAlgorithmInfo Methods
ILayoutAlgorithmInfo Interface See Also Send Feedback

The ILayoutAlgorithmInfo type exposes the following members.

Methods

Name | Description
IsIncluded | Returns whether or not the given node is to be modified by the layout algorithm. This is so certain diagram types can specify that nodes such as comments or titles should be ignored.

See Also

ILayoutAlgorithmInfo Interface


IsIncluded Method

[image]

Mindscape WPF Diagrams
ILayoutAlgorithmInfo..::.IsIncluded Method
ILayoutAlgorithmInfo Interface See Also Send Feedback
Returns whether or not the given node is to be modified by the layout algorithm. This is so certain diagram types can specify that nodes such as comments or titles should be ignored.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool IsIncluded(
    IDiagramNode node
)
Visual Basic (Declaration)
Function IsIncluded ( _
    node As IDiagramNode _
) As Boolean

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
An IDiagramNode.

Return Value

True if the given node should be managed by the layout algorithm. False otherwise.

See Also

ILayoutAlgorithmInfo Interface


INotifyCustomPropertyChanged Interface

[image]

Mindscape WPF Diagrams
INotifyCustomPropertyChanged Interface
Members See Also Send Feedback
Implementations of IDiagramConnectable that introduce additional properties can implement this interface allowing such properties to be integrated into the dirty-bit and undo features of a DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface INotifyCustomPropertyChanged
Visual Basic (Declaration)
Public Interface INotifyCustomPropertyChanged

See Also

INotifyCustomPropertyChanged Members


INotifyCustomPropertyChanged Members

[image] [image]

Mindscape WPF Diagrams
INotifyCustomPropertyChanged Members
INotifyCustomPropertyChanged Interface Events See Also Send Feedback

The INotifyCustomPropertyChanged type exposes the following members.

Events

Name | Description
CustomPropertyChanged | Raised when a custom property is changed.

See Also

INotifyCustomPropertyChanged Interface


INotifyCustomPropertyChanged Events

[image] [image]

Mindscape WPF Diagrams
INotifyCustomPropertyChanged Events
INotifyCustomPropertyChanged Interface See Also Send Feedback

The INotifyCustomPropertyChanged type exposes the following members.

Events

Name | Description
CustomPropertyChanged | Raised when a custom property is changed.

See Also

INotifyCustomPropertyChanged Interface


CustomPropertyChanged Event

[image]

Mindscape WPF Diagrams
INotifyCustomPropertyChanged..::.CustomPropertyChanged Event
INotifyCustomPropertyChanged Interface See Also Send Feedback
Raised when a custom property is changed.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
event EventHandler<CustomPropertyChangedEventArgs> CustomPropertyChanged
Visual Basic (Declaration)
Event CustomPropertyChanged As EventHandler(Of CustomPropertyChangedEventArgs)

See Also

INotifyCustomPropertyChanged Interface


IntersectionSnapLineDrawing Class

[image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing Class
Members See Also Send Feedback
Draws snap lines by placing a dot at the intersections of snap lines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class IntersectionSnapLineDrawing : DependencyObject, ISnapLineDrawing
Visual Basic (Declaration)
Public Class IntersectionSnapLineDrawing _
    Inherits DependencyObject _
    Implements ISnapLineDrawing

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
Mindscape.WpfDiagramming.Foundation..::.IntersectionSnapLineDrawing

See Also

IntersectionSnapLineDrawing Members


IntersectionSnapLineDrawing Members

[image] [image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing Members
IntersectionSnapLineDrawing Class Constructors Methods Fields Properties See Also Send Feedback

The IntersectionSnapLineDrawing type exposes the following members.

Constructors

Name | Description
IntersectionSnapLineDrawing |

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

Fields

Name | Description
BrushProperty | Identifies the Brush property.
RadiusProperty | Identifies the Radius property.

Properties

Name | Description
Brush | Gets or sets the brush used to draw the dots. This is a dependency property.
Radius | Gets or sets the radius of the dots. This is a dependency property.

See Also

IntersectionSnapLineDrawing Class


IntersectionSnapLineDrawing Constructor

[image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing Constructor
IntersectionSnapLineDrawing Class See Also Send Feedback
Initializes a new instance of the IntersectionSnapLineDrawing class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IntersectionSnapLineDrawing()
Visual Basic (Declaration)
Public Sub New

See Also

IntersectionSnapLineDrawing Class


IntersectionSnapLineDrawing Fields

[image] [image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing Fields
IntersectionSnapLineDrawing Class See Also Send Feedback

The IntersectionSnapLineDrawing type exposes the following members.

Fields

Name | Description
BrushProperty | Identifies the Brush property.
RadiusProperty | Identifies the Radius property.

See Also

IntersectionSnapLineDrawing Class


BrushProperty Field

[image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing..::.BrushProperty Field
IntersectionSnapLineDrawing Class See Also Send Feedback
Identifies the Brush property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty BrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

IntersectionSnapLineDrawing Class


RadiusProperty Field

[image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing..::.RadiusProperty Field
IntersectionSnapLineDrawing Class See Also Send Feedback
Identifies the Radius property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty RadiusProperty
Visual Basic (Declaration)
Public Shared ReadOnly RadiusProperty As DependencyProperty

See Also

IntersectionSnapLineDrawing Class


IntersectionSnapLineDrawing Methods

[image] [image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing Methods
IntersectionSnapLineDrawing Class See Also Send Feedback

The IntersectionSnapLineDrawing type exposes the following members.

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

See Also

IntersectionSnapLineDrawing Class


Draw Method

[image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing..::.Draw Method
IntersectionSnapLineDrawing Class See Also Send Feedback
Gets a Drawing of the snap lines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Drawing Draw(
    ISnapSpecifier horizontalSnap,
    ISnapSpecifier verticalSnap,
    Rect bounds,
    double zoom
)
Visual Basic (Declaration)
Public Function Draw ( _
    horizontalSnap As ISnapSpecifier, _
    verticalSnap As ISnapSpecifier, _
    bounds As Rect, _
    zoom As Double _
) As Drawing

Parameters

horizontalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the x-axis.
verticalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the y-axis.
bounds
Type: System.Windows..::.Rect
The bounds of the drawing required.
zoom
Type: System..::.Double
The zoom level.

Return Value

A drawing of the snap lines.

Implements

ISnapLineDrawing..::.Draw(ISnapSpecifier, ISnapSpecifier, Rect, Double)

Remarks

Either of both of the ISnapSpecifier parameters may be null, indicating that there are no snap points along this axis.

See Also

IntersectionSnapLineDrawing Class


IntersectionSnapLineDrawing Properties

[image] [image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing Properties
IntersectionSnapLineDrawing Class See Also Send Feedback

The IntersectionSnapLineDrawing type exposes the following members.

Properties

Name | Description
Brush | Gets or sets the brush used to draw the dots. This is a dependency property.
Radius | Gets or sets the radius of the dots. This is a dependency property.

See Also

IntersectionSnapLineDrawing Class


Brush Property

[image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing..::.Brush Property
IntersectionSnapLineDrawing Class See Also Send Feedback
Gets or sets the brush used to draw the dots. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Brush Brush { get; set; }
Visual Basic (Declaration)
Public Property Brush As Brush

Remarks

Dependency Property Information
Identifier field | BrushProperty
Metadata properties set to true | None

See Also

IntersectionSnapLineDrawing Class


Radius Property

[image]

Mindscape WPF Diagrams
IntersectionSnapLineDrawing..::.Radius Property
IntersectionSnapLineDrawing Class See Also Send Feedback
Gets or sets the radius of the dots. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double

Remarks

Dependency Property Information
Identifier field | RadiusProperty
Metadata properties set to true | None

See Also

IntersectionSnapLineDrawing Class


IntervalLineSnapLineDrawing Class

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing Class
Members See Also Send Feedback
Draws snap lines as a set of grid lines with some of the lines having a different color.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class IntervalLineSnapLineDrawing : DependencyObject, ISnapLineDrawing
Visual Basic (Declaration)
Public Class IntervalLineSnapLineDrawing _
    Inherits DependencyObject _
    Implements ISnapLineDrawing

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
Mindscape.WpfDiagramming.Foundation..::.IntervalLineSnapLineDrawing

See Also

IntervalLineSnapLineDrawing Members


IntervalLineSnapLineDrawing Members

[image] [image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing Members
IntervalLineSnapLineDrawing Class Constructors Methods Fields Properties See Also Send Feedback

The IntervalLineSnapLineDrawing type exposes the following members.

Constructors

Name | Description
IntervalLineSnapLineDrawing | Initializes a new instance of the IntervalLineSnapLineDrawing class.

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

Fields

Name | Description
HorizontalIntervalProperty | Identifies the HorizontalInterval property.
IntervalPenProperty | Identifies the IntervalPen property.
MainPenProperty | Identifies the MainPen property.
VerticalIntervalProperty | Identifies the VerticalInterval property.

Properties

Name | Description
HorizontalInterval | Gets or sets the interval between the vertical lines that are drawn with the pen in the IntervalPen property. Every line drawn that is divisible by the interval value will be drawn with the IntervalPen.
IntervalPen | Gets or sets the pen used to draw the lines that are drawn every few snaplines appart as defined by the HorizontalInterval and VerticalInterval properties. This is a dependency property.
MainPen | Gets or sets the pen used to draw the main grid lines. This is a dependency property.
VerticalInterval | Gets or sets the interval between the horizontal lines that are drawn with the pen in the IntervalPen property. Every line drawn that is divisible by the interval value will be drawn with the IntervalPen.

See Also

IntervalLineSnapLineDrawing Class


IntervalLineSnapLineDrawing Constructor

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing Constructor
IntervalLineSnapLineDrawing Class See Also Send Feedback
Initializes a new instance of the IntervalLineSnapLineDrawing class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IntervalLineSnapLineDrawing()
Visual Basic (Declaration)
Public Sub New

See Also

IntervalLineSnapLineDrawing Class


IntervalLineSnapLineDrawing Fields

[image] [image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing Fields
IntervalLineSnapLineDrawing Class See Also Send Feedback

The IntervalLineSnapLineDrawing type exposes the following members.

Fields

Name | Description
HorizontalIntervalProperty | Identifies the HorizontalInterval property.
IntervalPenProperty | Identifies the IntervalPen property.
MainPenProperty | Identifies the MainPen property.
VerticalIntervalProperty | Identifies the VerticalInterval property.

See Also

IntervalLineSnapLineDrawing Class


HorizontalIntervalProperty Field

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.HorizontalIntervalProperty Field
IntervalLineSnapLineDrawing Class See Also Send Feedback
Identifies the HorizontalInterval property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty HorizontalIntervalProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalIntervalProperty As DependencyProperty

See Also

IntervalLineSnapLineDrawing Class


IntervalPenProperty Field

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.IntervalPenProperty Field
IntervalLineSnapLineDrawing Class See Also Send Feedback
Identifies the IntervalPen property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IntervalPenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IntervalPenProperty As DependencyProperty

See Also

IntervalLineSnapLineDrawing Class


MainPenProperty Field

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.MainPenProperty Field
IntervalLineSnapLineDrawing Class See Also Send Feedback
Identifies the MainPen property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty MainPenProperty
Visual Basic (Declaration)
Public Shared ReadOnly MainPenProperty As DependencyProperty

See Also

IntervalLineSnapLineDrawing Class


VerticalIntervalProperty Field

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.VerticalIntervalProperty Field
IntervalLineSnapLineDrawing Class See Also Send Feedback
Identifies the VerticalInterval property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty VerticalIntervalProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalIntervalProperty As DependencyProperty

See Also

IntervalLineSnapLineDrawing Class


IntervalLineSnapLineDrawing Methods

[image] [image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing Methods
IntervalLineSnapLineDrawing Class See Also Send Feedback

The IntervalLineSnapLineDrawing type exposes the following members.

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

See Also

IntervalLineSnapLineDrawing Class


Draw Method

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.Draw Method
IntervalLineSnapLineDrawing Class See Also Send Feedback
Gets a Drawing of the snap lines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual Drawing Draw(
    ISnapSpecifier horizontalSnap,
    ISnapSpecifier verticalSnap,
    Rect bounds,
    double zoom
)
Visual Basic (Declaration)
Public Overridable Function Draw ( _
    horizontalSnap As ISnapSpecifier, _
    verticalSnap As ISnapSpecifier, _
    bounds As Rect, _
    zoom As Double _
) As Drawing

Parameters

horizontalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the x-axis.
verticalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the y-axis.
bounds
Type: System.Windows..::.Rect
The bounds of the drawing required.
zoom
Type: System..::.Double
The zoom level.

Return Value

A drawing of the snap lines.

Implements

ISnapLineDrawing..::.Draw(ISnapSpecifier, ISnapSpecifier, Rect, Double)

Remarks

Either of both of the ISnapSpecifier parameters may be null, indicating that there are no snap points along this axis.

See Also

IntervalLineSnapLineDrawing Class


IntervalLineSnapLineDrawing Properties

[image] [image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing Properties
IntervalLineSnapLineDrawing Class See Also Send Feedback

The IntervalLineSnapLineDrawing type exposes the following members.

Properties

Name | Description
HorizontalInterval | Gets or sets the interval between the vertical lines that are drawn with the pen in the IntervalPen property. Every line drawn that is divisible by the interval value will be drawn with the IntervalPen.
IntervalPen | Gets or sets the pen used to draw the lines that are drawn every few snaplines appart as defined by the HorizontalInterval and VerticalInterval properties. This is a dependency property.
MainPen | Gets or sets the pen used to draw the main grid lines. This is a dependency property.
VerticalInterval | Gets or sets the interval between the horizontal lines that are drawn with the pen in the IntervalPen property. Every line drawn that is divisible by the interval value will be drawn with the IntervalPen.

See Also

IntervalLineSnapLineDrawing Class


HorizontalInterval Property

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.HorizontalInterval Property
IntervalLineSnapLineDrawing Class See Also Send Feedback
Gets or sets the interval between the vertical lines that are drawn with the pen in the IntervalPen property. Every line drawn that is divisible by the interval value will be drawn with the IntervalPen.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int HorizontalInterval { get; set; }
Visual Basic (Declaration)
Public Property HorizontalInterval As Integer

See Also

IntervalLineSnapLineDrawing Class


IntervalPen Property

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.IntervalPen Property
IntervalLineSnapLineDrawing Class See Also Send Feedback
Gets or sets the pen used to draw the lines that are drawn every few snaplines appart as defined by the HorizontalInterval and VerticalInterval properties. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Pen IntervalPen { get; set; }
Visual Basic (Declaration)
Public Property IntervalPen As Pen

Remarks

Dependency Property Information
Identifier field | MainPenProperty
Metadata properties set to true | None

See Also

IntervalLineSnapLineDrawing Class


MainPen Property

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.MainPen Property
IntervalLineSnapLineDrawing Class See Also Send Feedback
Gets or sets the pen used to draw the main grid lines. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Pen MainPen { get; set; }
Visual Basic (Declaration)
Public Property MainPen As Pen

Remarks

Dependency Property Information
Identifier field | MainPenProperty
Metadata properties set to true | None

See Also

IntervalLineSnapLineDrawing Class


VerticalInterval Property

[image]

Mindscape WPF Diagrams
IntervalLineSnapLineDrawing..::.VerticalInterval Property
IntervalLineSnapLineDrawing Class See Also Send Feedback
Gets or sets the interval between the horizontal lines that are drawn with the pen in the IntervalPen property. Every line drawn that is divisible by the interval value will be drawn with the IntervalPen.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int VerticalInterval { get; set; }
Visual Basic (Declaration)
Public Property VerticalInterval As Integer

See Also

IntervalLineSnapLineDrawing Class


IPathBuilder Interface

[image]

Mindscape WPF Diagrams
IPathBuilder Interface
Members See Also Send Feedback
Builds a PathGeometry for a sequence of diagram connection segments.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IPathBuilder
Visual Basic (Declaration)
Public Interface IPathBuilder

Remarks

The IPathBuilder interface allows connections to construct their own visual interpretations of the path found by the IPathfinder interface. The canonical example is the CorneredPathBuilder, which constructs a path geometry with smooth corners from the raw segment specification.

See Also

IPathBuilder Members


IPathBuilder Members

[image] [image]

Mindscape WPF Diagrams
IPathBuilder Members
IPathBuilder Interface Methods See Also Send Feedback

The IPathBuilder type exposes the following members.

Methods

Name | Description
BuildPath | Returns a PathGeometry based on the given connection segment data.

See Also

IPathBuilder Interface


IPathBuilder Methods

[image] [image]

Mindscape WPF Diagrams
IPathBuilder Methods
IPathBuilder Interface See Also Send Feedback

The IPathBuilder type exposes the following members.

Methods

Name | Description
BuildPath | Returns a PathGeometry based on the given connection segment data.

See Also

IPathBuilder Interface


BuildPath Method

[image]

Mindscape WPF Diagrams
IPathBuilder..::.BuildPath Method
IPathBuilder Interface See Also Send Feedback
Returns a PathGeometry based on the given connection segment data.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
PathGeometry BuildPath(
    Collection<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Function BuildPath ( _
    segments As Collection(Of DiagramConnectionSegment) _
) As PathGeometry

Parameters

segments
Type: System.Collections.ObjectModel..::.Collection <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects making up the connection.

Return Value

A PathGeometry for the diagram connection.

See Also

IPathBuilder Interface


IPathfinder Interface

[image]

Mindscape WPF Diagrams
IPathfinder Interface
Members See Also Send Feedback
Determines a path for an IDiagramConnection, specified as a sequence of points.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IPathfinder
Visual Basic (Declaration)
Public Interface IPathfinder

See Also

IPathfinder Members


IPathfinder Members

[image] [image]

Mindscape WPF Diagrams
IPathfinder Members
IPathfinder Interface Methods See Also Send Feedback

The IPathfinder type exposes the following members.

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection. The containing IDiagramModel is also supplied as context, so that the implementation can plot a path that avoids other nodes or connections. The method returns a list of "via points" for the path, beginning with the start point of the connection end ending with its end point.

See Also

IPathfinder Interface


IPathfinder Methods

[image] [image]

Mindscape WPF Diagrams
IPathfinder Methods
IPathfinder Interface See Also Send Feedback

The IPathfinder type exposes the following members.

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection. The containing IDiagramModel is also supplied as context, so that the implementation can plot a path that avoids other nodes or connections. The method returns a list of "via points" for the path, beginning with the start point of the connection end ending with its end point.

See Also

IPathfinder Interface


FindPath Method

[image]

Mindscape WPF Diagrams
IPathfinder..::.FindPath Method
IPathfinder Interface See Also Send Feedback
Determines a path for the given IDiagramConnection. The containing IDiagramModel is also supplied as context, so that the implementation can plot a path that avoids other nodes or connections. The method returns a list of "via points" for the path, beginning with the start point of the connection end ending with its end point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
ReadOnlyCollection<Point> FindPath(
    IDiagramConnection connection,
    IDiagramModel diagram
)
Visual Basic (Declaration)
Function FindPath ( _
    connection As IDiagramConnection, _
    diagram As IDiagramModel _
) As ReadOnlyCollection(Of Point)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to find a path for.
diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
An IDiagramModel used to obtain other nodes and connections if needed

Return Value

A collection of via points representing the plotted course of the connection, or null to indicate that the connection path did not need to be refreshed.

Remarks

An implementation may return null to indicate that the connection path did not need to be refreshed.

See Also

IPathfinder Interface


IPositionCalculator Interface

[image]

Mindscape WPF Diagrams
IPositionCalculator Interface
Members See Also Send Feedback
Calculates a position given a rectangle. This is typically used to calculate the position of an IDiagramConnectionPoint on an IDiagramNode.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IPositionCalculator
Visual Basic (Declaration)
Public Interface IPositionCalculator

See Also

IPositionCalculator Members


IPositionCalculator Members

[image] [image]

Mindscape WPF Diagrams
IPositionCalculator Members
IPositionCalculator Interface Methods See Also Send Feedback

The IPositionCalculator type exposes the following members.

Methods

Name | Description
GetPosition | Calculates a position given a rectangle.

See Also

IPositionCalculator Interface


IPositionCalculator Methods

[image] [image]

Mindscape WPF Diagrams
IPositionCalculator Methods
IPositionCalculator Interface See Also Send Feedback

The IPositionCalculator type exposes the following members.

Methods

Name | Description
GetPosition | Calculates a position given a rectangle.

See Also

IPositionCalculator Interface


GetPosition Method

[image]

Mindscape WPF Diagrams
IPositionCalculator..::.GetPosition Method
IPositionCalculator Interface See Also Send Feedback
Calculates a position given a rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Point GetPosition(
    Rect bounds
)
Visual Basic (Declaration)
Function GetPosition ( _
    bounds As Rect _
) As Point

Parameters

bounds
Type: System.Windows..::.Rect
The rectangle.

Return Value

The position.

See Also

IPositionCalculator Interface


ISnapLineDrawing Interface

[image]

Mindscape WPF Diagrams
ISnapLineDrawing Interface
Members See Also Send Feedback
Draws snap lines on the diagram background.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface ISnapLineDrawing
Visual Basic (Declaration)
Public Interface ISnapLineDrawing

See Also

ISnapLineDrawing Members


ISnapLineDrawing Members

[image] [image]

Mindscape WPF Diagrams
ISnapLineDrawing Members
ISnapLineDrawing Interface Methods See Also Send Feedback

The ISnapLineDrawing type exposes the following members.

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

See Also

ISnapLineDrawing Interface


ISnapLineDrawing Methods

[image] [image]

Mindscape WPF Diagrams
ISnapLineDrawing Methods
ISnapLineDrawing Interface See Also Send Feedback

The ISnapLineDrawing type exposes the following members.

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

See Also

ISnapLineDrawing Interface


Draw Method

[image]

Mindscape WPF Diagrams
ISnapLineDrawing..::.Draw Method
ISnapLineDrawing Interface See Also Send Feedback
Gets a Drawing of the snap lines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Drawing Draw(
    ISnapSpecifier horizontalSnap,
    ISnapSpecifier verticalSnap,
    Rect bounds,
    double zoom
)
Visual Basic (Declaration)
Function Draw ( _
    horizontalSnap As ISnapSpecifier, _
    verticalSnap As ISnapSpecifier, _
    bounds As Rect, _
    zoom As Double _
) As Drawing

Parameters

horizontalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the x-axis.
verticalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the y-axis.
bounds
Type: System.Windows..::.Rect
The bounds of the drawing required.
zoom
Type: System..::.Double
The zoom level.

Return Value

A drawing of the snap lines.

Remarks

Either of both of the ISnapSpecifier parameters may be null, indicating that there are no snap points along this axis.

See Also

ISnapLineDrawing Interface


ISnapSpecifier Interface

[image]

Mindscape WPF Diagrams
ISnapSpecifier Interface
Members See Also Send Feedback
Defines how a value should be snapped to a guideline.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface ISnapSpecifier
Visual Basic (Declaration)
Public Interface ISnapSpecifier

See Also

ISnapSpecifier Members


ISnapSpecifier Members

[image] [image]

Mindscape WPF Diagrams
ISnapSpecifier Members
ISnapSpecifier Interface Methods See Also Send Feedback

The ISnapSpecifier type exposes the following members.

Methods

Name | Description
GetGuidelines | Gets snap positions for drawing guidelines.
GetSnappedValue | Gets the snapped value of a coordinate.

See Also

ISnapSpecifier Interface


ISnapSpecifier Methods

[image] [image]

Mindscape WPF Diagrams
ISnapSpecifier Methods
ISnapSpecifier Interface See Also Send Feedback

The ISnapSpecifier type exposes the following members.

Methods

Name | Description
GetGuidelines | Gets snap positions for drawing guidelines.
GetSnappedValue | Gets the snapped value of a coordinate.

See Also

ISnapSpecifier Interface


GetGuidelines Method

[image]

Mindscape WPF Diagrams
ISnapSpecifier..::.GetGuidelines Method
ISnapSpecifier Interface See Also Send Feedback
Gets snap positions for drawing guidelines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
IEnumerable<double> GetGuidelines(
    double startValue,
    double endValue
)
Visual Basic (Declaration)
Function GetGuidelines ( _
    startValue As Double, _
    endValue As Double _
) As IEnumerable(Of Double)

Parameters

startValue
Type: System..::.Double
A value below which guidelines are not required.
endValue
Type: System..::.Double
A value above which guidelines are not required.

Return Value

The set of snap values within the given range.

See Also

ISnapSpecifier Interface


GetSnappedValue Method

[image]

Mindscape WPF Diagrams
ISnapSpecifier..::.GetSnappedValue Method
ISnapSpecifier Interface See Also Send Feedback
Gets the snapped value of a coordinate.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
double GetSnappedValue(
    double value
)
Visual Basic (Declaration)
Function GetSnappedValue ( _
    value As Double _
) As Double

Parameters

value
Type: System..::.Double
The original value of the coordinate.

Return Value

The result of snapping the coordinate.

See Also

ISnapSpecifier Interface


IStyleMatcher Interface

[image]

Mindscape WPF Diagrams
IStyleMatcher Interface
Members See Also Send Feedback
Represents a criterion for matching an item to a Style.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public interface IStyleMatcher
Visual Basic (Declaration)
Public Interface IStyleMatcher

See Also

IStyleMatcher Members


IStyleMatcher Members

[image] [image]

Mindscape WPF Diagrams
IStyleMatcher Members
IStyleMatcher Interface Methods Properties See Also Send Feedback

The IStyleMatcher type exposes the following members.

Methods

Name | Description
Matches | Tests whether an object matches the criterion for the Style.

Properties

Name | Description
Style | Gets the Style to be used for objects that meet this criterion.

See Also

IStyleMatcher Interface


IStyleMatcher Methods

[image] [image]

Mindscape WPF Diagrams
IStyleMatcher Methods
IStyleMatcher Interface See Also Send Feedback

The IStyleMatcher type exposes the following members.

Methods

Name | Description
Matches | Tests whether an object matches the criterion for the Style.

See Also

IStyleMatcher Interface


Matches Method

[image]

Mindscape WPF Diagrams
IStyleMatcher..::.Matches Method
IStyleMatcher Interface See Also Send Feedback
Tests whether an object matches the criterion for the Style.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
bool Matches(
    Object item
)
Visual Basic (Declaration)
Function Matches ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The object to be tested.

Return Value

true if the object matches the criterion; otherwise false.

See Also

IStyleMatcher Interface


IStyleMatcher Properties

[image] [image]

Mindscape WPF Diagrams
IStyleMatcher Properties
IStyleMatcher Interface See Also Send Feedback

The IStyleMatcher type exposes the following members.

Properties

Name | Description
Style | Gets the Style to be used for objects that meet this criterion.

See Also

IStyleMatcher Interface


Style Property

[image]

Mindscape WPF Diagrams
IStyleMatcher..::.Style Property
IStyleMatcher Interface See Also Send Feedback
Gets the Style to be used for objects that meet this criterion.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
Style Style { get; }
Visual Basic (Declaration)
ReadOnly Property Style As Style

See Also

IStyleMatcher Interface


LayoutAlgorithmBase Class

[image]

Mindscape WPF Diagrams
LayoutAlgorithmBase Class
Members See Also Send Feedback
A base implementation of ILayoutAlgorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class LayoutAlgorithmBase : ILayoutAlgorithm
Visual Basic (Declaration)
Public MustInherit Class LayoutAlgorithmBase _
    Implements ILayoutAlgorithm

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.LayoutAlgorithmBase
Mindscape.WpfDiagramming.Foundation..::.HierarchicalLayoutAlgorithm
Mindscape.WpfDiagramming.Foundation..::.RandomLayoutAlgorithm
Mindscape.WpfDiagramming.Foundation..::.ForceBasedLayoutAlgorithm
Mindscape.WpfDiagramming.Foundation..::.CircularLayoutAlgorithm
Mindscape.WpfDiagramming.Foundation..::.GridLayoutAlgorithm
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramForceBasedLayout

See Also

LayoutAlgorithmBase Members


LayoutAlgorithmBase Members

[image] [image]

Mindscape WPF Diagrams
LayoutAlgorithmBase Members
LayoutAlgorithmBase Class Constructors Methods Properties See Also Send Feedback

The LayoutAlgorithmBase type exposes the following members.

Constructors

Name | Description
LayoutAlgorithmBase |

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node.
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm.
Run | When overridden in a derived class, runs this layout algorithm.

Properties

Name | Description
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic.

See Also

LayoutAlgorithmBase Class


LayoutAlgorithmBase Constructor

[image]

Mindscape WPF Diagrams
LayoutAlgorithmBase Constructor
LayoutAlgorithmBase Class See Also Send Feedback
Initializes a new instance of the LayoutAlgorithmBase class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected LayoutAlgorithmBase()
Visual Basic (Declaration)
Protected Sub New

See Also

LayoutAlgorithmBase Class


LayoutAlgorithmBase Methods

[image] [image]

Mindscape WPF Diagrams
LayoutAlgorithmBase Methods
LayoutAlgorithmBase Class See Also Send Feedback

The LayoutAlgorithmBase type exposes the following members.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node.
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm.
Run | When overridden in a derived class, runs this layout algorithm.

See Also

LayoutAlgorithmBase Class


GetStartNodes Method

[image]

Mindscape WPF Diagrams
LayoutAlgorithmBase..::.GetStartNodes Method
LayoutAlgorithmBase Class See Also Send Feedback
Returns a list of 'start nodes' based on the number of inbound connections on each node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected IList<IDiagramNode> GetStartNodes(
    IDiagramModel model
)
Visual Basic (Declaration)
Protected Function GetStartNodes ( _
    model As IDiagramModel _
) As IList(Of IDiagramNode)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel.

Return Value

A list of start nodes within the given model.

See Also

LayoutAlgorithmBase Class


IsIncluded Method

[image]

Mindscape WPF Diagrams
LayoutAlgorithmBase..::.IsIncluded Method
LayoutAlgorithmBase Class See Also Send Feedback
Returns whether or not the given IDiagramNode should be affected by this layout algorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected bool IsIncluded(
    IDiagramNode node
)
Visual Basic (Declaration)
Protected Function IsIncluded ( _
    node As IDiagramNode _
) As Boolean

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
An IDiagramNode.

Return Value

True if the given node should be affected by this layout algorithm. False otherwise.

See Also

LayoutAlgorithmBase Class


Run Method

[image]

Mindscape WPF Diagrams
LayoutAlgorithmBase..::.Run Method
LayoutAlgorithmBase Class See Also Send Feedback
When overridden in a derived class, runs this layout algorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Public MustOverride Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to be laid out.

Implements

ILayoutAlgorithm..::.Run(IDiagramModel)

See Also

LayoutAlgorithmBase Class


LayoutAlgorithmBase Properties

[image] [image]

Mindscape WPF Diagrams
LayoutAlgorithmBase Properties
LayoutAlgorithmBase Class See Also Send Feedback

The LayoutAlgorithmBase type exposes the following members.

Properties

Name | Description
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic.

See Also

LayoutAlgorithmBase Class


Info Property

[image]

Mindscape WPF Diagrams
LayoutAlgorithmBase..::.Info Property
LayoutAlgorithmBase Class See Also Send Feedback
Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ILayoutAlgorithmInfo Info { get; set; }
Visual Basic (Declaration)
Public Property Info As ILayoutAlgorithmInfo

Implements

ILayoutAlgorithm..::.Info

See Also

LayoutAlgorithmBase Class


LineSnapLineDrawing Class

[image]

Mindscape WPF Diagrams
LineSnapLineDrawing Class
Members See Also Send Feedback
Draws snap lines as a set of grid lines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class LineSnapLineDrawing : DependencyObject, ISnapLineDrawing
Visual Basic (Declaration)
Public Class LineSnapLineDrawing _
    Inherits DependencyObject _
    Implements ISnapLineDrawing

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
Mindscape.WpfDiagramming.Foundation..::.LineSnapLineDrawing

See Also

LineSnapLineDrawing Members


LineSnapLineDrawing Members

[image] [image]

Mindscape WPF Diagrams
LineSnapLineDrawing Members
LineSnapLineDrawing Class Constructors Methods Fields Properties See Also Send Feedback

The LineSnapLineDrawing type exposes the following members.

Constructors

Name | Description
LineSnapLineDrawing |

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

Fields

Name | Description
PenProperty | Identifies the Pen property.

Properties

Name | Description
Pen | Gets or sets the pen used to draw the grid lines. This is a dependency property.

See Also

LineSnapLineDrawing Class


LineSnapLineDrawing Constructor

[image]

Mindscape WPF Diagrams
LineSnapLineDrawing Constructor
LineSnapLineDrawing Class See Also Send Feedback
Initializes a new instance of the LineSnapLineDrawing class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public LineSnapLineDrawing()
Visual Basic (Declaration)
Public Sub New

See Also

LineSnapLineDrawing Class


LineSnapLineDrawing Fields

[image] [image]

Mindscape WPF Diagrams
LineSnapLineDrawing Fields
LineSnapLineDrawing Class See Also Send Feedback

The LineSnapLineDrawing type exposes the following members.

Fields

Name | Description
PenProperty | Identifies the Pen property.

See Also

LineSnapLineDrawing Class


PenProperty Field

[image]

Mindscape WPF Diagrams
LineSnapLineDrawing..::.PenProperty Field
LineSnapLineDrawing Class See Also Send Feedback
Identifies the Pen property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty PenProperty
Visual Basic (Declaration)
Public Shared ReadOnly PenProperty As DependencyProperty

See Also

LineSnapLineDrawing Class


LineSnapLineDrawing Methods

[image] [image]

Mindscape WPF Diagrams
LineSnapLineDrawing Methods
LineSnapLineDrawing Class See Also Send Feedback

The LineSnapLineDrawing type exposes the following members.

Methods

Name | Description
Draw | Gets a Drawing of the snap lines.

See Also

LineSnapLineDrawing Class


Draw Method

[image]

Mindscape WPF Diagrams
LineSnapLineDrawing..::.Draw Method
LineSnapLineDrawing Class See Also Send Feedback
Gets a Drawing of the snap lines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual Drawing Draw(
    ISnapSpecifier horizontalSnap,
    ISnapSpecifier verticalSnap,
    Rect bounds,
    double zoom
)
Visual Basic (Declaration)
Public Overridable Function Draw ( _
    horizontalSnap As ISnapSpecifier, _
    verticalSnap As ISnapSpecifier, _
    bounds As Rect, _
    zoom As Double _
) As Drawing

Parameters

horizontalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the x-axis.
verticalSnap
Type: Mindscape.WpfDiagramming.Foundation..::.ISnapSpecifier
Provides snap points along the y-axis.
bounds
Type: System.Windows..::.Rect
The bounds of the drawing required.
zoom
Type: System..::.Double
The zoom level.

Return Value

A drawing of the snap lines.

Implements

ISnapLineDrawing..::.Draw(ISnapSpecifier, ISnapSpecifier, Rect, Double)

Remarks

Either of both of the ISnapSpecifier parameters may be null, indicating that there are no snap points along this axis.

See Also

LineSnapLineDrawing Class


LineSnapLineDrawing Properties

[image] [image]

Mindscape WPF Diagrams
LineSnapLineDrawing Properties
LineSnapLineDrawing Class See Also Send Feedback

The LineSnapLineDrawing type exposes the following members.

Properties

Name | Description
Pen | Gets or sets the pen used to draw the grid lines. This is a dependency property.

See Also

LineSnapLineDrawing Class


Pen Property

[image]

Mindscape WPF Diagrams
LineSnapLineDrawing..::.Pen Property
LineSnapLineDrawing Class See Also Send Feedback
Gets or sets the pen used to draw the grid lines. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Pen Pen { get; set; }
Visual Basic (Declaration)
Public Property Pen As Pen

Remarks

Dependency Property Information
Identifier field | PenProperty
Metadata properties set to true | None

See Also

LineSnapLineDrawing Class


MarginConverter Class

[image]

Mindscape WPF Diagrams
MarginConverter Class
Members See Also Send Feedback
An IValueConverter that uses the LeftFactor, RightFactor, TopFactor, and BottomFactor properties to create a Thickness object. The factor properties are multiplied by the width and height values of a given Rect to calculate the values of the created Thickness values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ValueConversionAttribute(typeof(Rect), typeof(Thickness))]
public class MarginConverter : IValueConverter
Visual Basic (Declaration)
<ValueConversionAttribute(GetType(Rect), GetType(Thickness))> _
Public Class MarginConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.MarginConverter

See Also

MarginConverter Members


MarginConverter Members

[image] [image]

Mindscape WPF Diagrams
MarginConverter Members
MarginConverter Class Constructors Methods Properties See Also Send Feedback

The MarginConverter type exposes the following members.

Constructors

Name | Description
MarginConverter |

Methods

Name | Description
Convert | Converts a value from a binding source for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.

Properties

Name | Description
BottomFactor | A value typically between 0-1 which is multiplied by the height of a Rect given to the Convert method in order to calculate the bottom value of the created Thickness object.
LeftFactor | A value typically between 0-1 which is multiplied by the width of a Rect given to the Convert method in order to calculate the left value of the created Thickness object.
RightFactor | A value typically between 0-1 which is multiplied by the width of a Rect given to the convert method in order to calculate the right value of the created Thickness object.
TopFactor | A value typically between 0-1 which is multiplied by the height of a Rect given to the Convert method in order to calculate the top value of the created Thickness object.

See Also

MarginConverter Class


MarginConverter Constructor

[image]

Mindscape WPF Diagrams
MarginConverter Constructor
MarginConverter Class See Also Send Feedback
Initializes a new instance of the MarginConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MarginConverter()
Visual Basic (Declaration)
Public Sub New

See Also

MarginConverter Class


MarginConverter Methods

[image] [image]

Mindscape WPF Diagrams
MarginConverter Methods
MarginConverter Class See Also Send Feedback

The MarginConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a value from a binding source for use by a binding target.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

MarginConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
MarginConverter..::.Convert Method
MarginConverter Class See Also Send Feedback
Converts a value from a binding source for use by a binding target.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A value suitable for use by the binding target.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

MarginConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
MarginConverter..::.ConvertBack Method
MarginConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

MarginConverter Class


MarginConverter Properties

[image] [image]

Mindscape WPF Diagrams
MarginConverter Properties
MarginConverter Class See Also Send Feedback

The MarginConverter type exposes the following members.

Properties

Name | Description
BottomFactor | A value typically between 0-1 which is multiplied by the height of a Rect given to the Convert method in order to calculate the bottom value of the created Thickness object.
LeftFactor | A value typically between 0-1 which is multiplied by the width of a Rect given to the Convert method in order to calculate the left value of the created Thickness object.
RightFactor | A value typically between 0-1 which is multiplied by the width of a Rect given to the convert method in order to calculate the right value of the created Thickness object.
TopFactor | A value typically between 0-1 which is multiplied by the height of a Rect given to the Convert method in order to calculate the top value of the created Thickness object.

See Also

MarginConverter Class


BottomFactor Property

[image]

Mindscape WPF Diagrams
MarginConverter..::.BottomFactor Property
MarginConverter Class See Also Send Feedback
A value typically between 0-1 which is multiplied by the height of a Rect given to the Convert method in order to calculate the bottom value of the created Thickness object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double BottomFactor { get; set; }
Visual Basic (Declaration)
Public Property BottomFactor As Double

See Also

MarginConverter Class


LeftFactor Property

[image]

Mindscape WPF Diagrams
MarginConverter..::.LeftFactor Property
MarginConverter Class See Also Send Feedback
A value typically between 0-1 which is multiplied by the width of a Rect given to the Convert method in order to calculate the left value of the created Thickness object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double LeftFactor { get; set; }
Visual Basic (Declaration)
Public Property LeftFactor As Double

See Also

MarginConverter Class


RightFactor Property

[image]

Mindscape WPF Diagrams
MarginConverter..::.RightFactor Property
MarginConverter Class See Also Send Feedback
A value typically between 0-1 which is multiplied by the width of a Rect given to the convert method in order to calculate the right value of the created Thickness object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double RightFactor { get; set; }
Visual Basic (Declaration)
Public Property RightFactor As Double

See Also

MarginConverter Class


TopFactor Property

[image]

Mindscape WPF Diagrams
MarginConverter..::.TopFactor Property
MarginConverter Class See Also Send Feedback
A value typically between 0-1 which is multiplied by the height of a Rect given to the Convert method in order to calculate the top value of the created Thickness object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double TopFactor { get; set; }
Visual Basic (Declaration)
Public Property TopFactor As Double

See Also

MarginConverter Class


MatchingStyleSelector Class

[image]

Mindscape WPF Diagrams
MatchingStyleSelector Class
Members See Also Send Feedback
Selects a Style based on a list of match criteria.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("Styles")]
public class MatchingStyleSelector : DelegatingStyleSelector
Visual Basic (Declaration)
<ContentPropertyAttribute("Styles")> _
Public Class MatchingStyleSelector _
    Inherits DelegatingStyleSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingStyleSelector
Mindscape.WpfDiagramming.Foundation..::.MatchingStyleSelector
Mindscape.WpfDiagramming..::.DiagramConnectionStyleSelector
Mindscape.WpfDiagramming..::.ShapeNodeStyleSelector

See Also

MatchingStyleSelector Members


MatchingStyleSelector Members

[image] [image]

Mindscape WPF Diagrams
MatchingStyleSelector Members
MatchingStyleSelector Class Constructors Methods Properties See Also Send Feedback

The MatchingStyleSelector type exposes the following members.

Constructors

Name | Description
MatchingStyleSelector |

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Returns the Style associated with the first criterion to match the item. (Overrides DelegatingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector. (Inherited from DelegatingStyleSelector.)
DefaultStyle | Gets or sets the default Style.
Styles | Gets the list of styles and matching criteria.

See Also

MatchingStyleSelector Class


MatchingStyleSelector Constructor

[image]

Mindscape WPF Diagrams
MatchingStyleSelector Constructor
MatchingStyleSelector Class See Also Send Feedback
Initializes a new instance of the MatchingStyleSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MatchingStyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

MatchingStyleSelector Class


MatchingStyleSelector Methods

[image] [image]

Mindscape WPF Diagrams
MatchingStyleSelector Methods
MatchingStyleSelector Class See Also Send Feedback

The MatchingStyleSelector type exposes the following members.

Methods

Name | Description
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Returns the Style associated with the first criterion to match the item. (Overrides DelegatingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

See Also

MatchingStyleSelector Class


SelectStyleCore Method

[image]

Mindscape WPF Diagrams
MatchingStyleSelector..::.SelectStyleCore Method
MatchingStyleSelector Class See Also Send Feedback
Returns the Style associated with the first criterion to match the item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Style SelectStyleCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected Overrides Function SelectStyleCore ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The item for which to select the style.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The template from the first matching entry in the Styles list if any; otherwise the DefaultStyle.

See Also

MatchingStyleSelector Class


MatchingStyleSelector Properties

[image] [image]

Mindscape WPF Diagrams
MatchingStyleSelector Properties
MatchingStyleSelector Class See Also Send Feedback

The MatchingStyleSelector type exposes the following members.

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector. (Inherited from DelegatingStyleSelector.)
DefaultStyle | Gets or sets the default Style.
Styles | Gets the list of styles and matching criteria.

See Also

MatchingStyleSelector Class


DefaultStyle Property

[image]

Mindscape WPF Diagrams
MatchingStyleSelector..::.DefaultStyle Property
MatchingStyleSelector Class See Also Send Feedback
Gets or sets the default Style.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style DefaultStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultStyle As Style

See Also

MatchingStyleSelector Class


Styles Property

[image]

Mindscape WPF Diagrams
MatchingStyleSelector..::.Styles Property
MatchingStyleSelector Class See Also Send Feedback
Gets the list of styles and matching criteria.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Collection<IStyleMatcher> Styles { get; }
Visual Basic (Declaration)
Public ReadOnly Property Styles As Collection(Of IStyleMatcher)

See Also

MatchingStyleSelector Class


MatchingTemplateSelector Class

[image]

Mindscape WPF Diagrams
MatchingTemplateSelector Class
Members See Also Send Feedback
Selects a data template based on a list of match criteria.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("Templates")]
public class MatchingTemplateSelector : DelegatingDataTemplateSelector
Visual Basic (Declaration)
<ContentPropertyAttribute("Templates")> _
Public Class MatchingTemplateSelector _
    Inherits DelegatingDataTemplateSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.DataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingDataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.MatchingTemplateSelector

See Also

MatchingTemplateSelector Members


MatchingTemplateSelector Members

[image] [image]

Mindscape WPF Diagrams
MatchingTemplateSelector Members
MatchingTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The MatchingTemplateSelector type exposes the following members.

Constructors

Name | Description
MatchingTemplateSelector |

Methods

Name | Description
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns the DataTemplate associated with the first criterion to match the item. (Overrides DelegatingDataTemplateSelector ..::. SelectTemplateCore(Object, DependencyObject).)

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector. (Inherited from DelegatingDataTemplateSelector.)
DefaultTemplate | Gets or sets the default data template.
Templates | Gets the list of templates and matching criteria.

See Also

MatchingTemplateSelector Class


MatchingTemplateSelector Constructor

[image]

Mindscape WPF Diagrams
MatchingTemplateSelector Constructor
MatchingTemplateSelector Class See Also Send Feedback
Initializes a new instance of the MatchingTemplateSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MatchingTemplateSelector()
Visual Basic (Declaration)
Public Sub New

See Also

MatchingTemplateSelector Class


MatchingTemplateSelector Methods

[image] [image]

Mindscape WPF Diagrams
MatchingTemplateSelector Methods
MatchingTemplateSelector Class See Also Send Feedback

The MatchingTemplateSelector type exposes the following members.

Methods

Name | Description
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns the DataTemplate associated with the first criterion to match the item. (Overrides DelegatingDataTemplateSelector ..::. SelectTemplateCore(Object, DependencyObject).)

See Also

MatchingTemplateSelector Class


SelectTemplateCore Method

[image]

Mindscape WPF Diagrams
MatchingTemplateSelector..::.SelectTemplateCore Method
MatchingTemplateSelector Class See Also Send Feedback
Returns the DataTemplate associated with the first criterion to match the item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override DataTemplate SelectTemplateCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected Overrides Function SelectTemplateCore ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
The item for which to select the template.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The template from the first matching entry in the Templates list if any; otherwise the DefaultTemplate.

See Also

MatchingTemplateSelector Class


MatchingTemplateSelector Properties

[image] [image]

Mindscape WPF Diagrams
MatchingTemplateSelector Properties
MatchingTemplateSelector Class See Also Send Feedback

The MatchingTemplateSelector type exposes the following members.

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector. (Inherited from DelegatingDataTemplateSelector.)
DefaultTemplate | Gets or sets the default data template.
Templates | Gets the list of templates and matching criteria.

See Also

MatchingTemplateSelector Class


DefaultTemplate Property

[image]

Mindscape WPF Diagrams
MatchingTemplateSelector..::.DefaultTemplate Property
MatchingTemplateSelector Class See Also Send Feedback
Gets or sets the default data template.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate DefaultTemplate { get; set; }
Visual Basic (Declaration)
Public Property DefaultTemplate As DataTemplate

See Also

MatchingTemplateSelector Class


Templates Property

[image]

Mindscape WPF Diagrams
MatchingTemplateSelector..::.Templates Property
MatchingTemplateSelector Class See Also Send Feedback
Gets the list of templates and matching criteria.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Collection<IDataTemplateMatcher> Templates { get; }
Visual Basic (Declaration)
Public ReadOnly Property Templates As Collection(Of IDataTemplateMatcher)

See Also

MatchingTemplateSelector Class


MouseWheelZoom Class

[image]

Mindscape WPF Diagrams
MouseWheelZoom Class
Members See Also Send Feedback
Provides support for mouse wheel based zooming.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class MouseWheelZoom
Visual Basic (Declaration)
Public NotInheritable Class MouseWheelZoom

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.MouseWheelZoom

See Also

MouseWheelZoom Members


MouseWheelZoom Members

[image] [image]

Mindscape WPF Diagrams
MouseWheelZoom Members
MouseWheelZoom Class Methods Fields See Also Send Feedback

The MouseWheelZoom type exposes the following members.

Methods

Name | Description
GetMinimumZoom | Gets the minimum zoom level that can be attained through the mouse wheel.
GetScaleFactor | Gets the value of the scale factor used to translate mouse wheel movement into zoom changes. A high scale factor means a slow zoom; a low scale factor means a rapid zoom.
SetMinimumZoom | Gets the minimum zoom level that can be attained through the mouse wheel.
SetScaleFactor | Sets the value of the scale factor used to translate mouse wheel movement into zoom changes. A high scale factor means a slow zoom; a low scale factor means a rapid zoom.

Fields

Name | Description
MinimumZoomProperty | Identifies the MinimumZoom attached property.
MouseZoomEvent | Identifies the MouseZoom routed event.
ScaleFactorProperty | Identifies the ScaleFactor attached property.

See Also

MouseWheelZoom Class


MouseWheelZoom Fields

[image] [image]

Mindscape WPF Diagrams
MouseWheelZoom Fields
MouseWheelZoom Class See Also Send Feedback

The MouseWheelZoom type exposes the following members.

Fields

Name | Description
MinimumZoomProperty | Identifies the MinimumZoom attached property.
MouseZoomEvent | Identifies the MouseZoom routed event.
ScaleFactorProperty | Identifies the ScaleFactor attached property.

See Also

MouseWheelZoom Class


MinimumZoomProperty Field

[image]

Mindscape WPF Diagrams
MouseWheelZoom..::.MinimumZoomProperty Field
MouseWheelZoom Class See Also Send Feedback
Identifies the MinimumZoom attached property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty MinimumZoomProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinimumZoomProperty As DependencyProperty

See Also

MouseWheelZoom Class


MouseZoomEvent Field

[image]

Mindscape WPF Diagrams
MouseWheelZoom..::.MouseZoomEvent Field
MouseWheelZoom Class See Also Send Feedback
Identifies the MouseZoom routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent MouseZoomEvent
Visual Basic (Declaration)
Public Shared ReadOnly MouseZoomEvent As RoutedEvent

See Also

MouseWheelZoom Class


ScaleFactorProperty Field

[image]

Mindscape WPF Diagrams
MouseWheelZoom..::.ScaleFactorProperty Field
MouseWheelZoom Class See Also Send Feedback
Identifies the ScaleFactor attached property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ScaleFactorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ScaleFactorProperty As DependencyProperty

See Also

MouseWheelZoom Class


MouseWheelZoom Methods

[image] [image]

Mindscape WPF Diagrams
MouseWheelZoom Methods
MouseWheelZoom Class See Also Send Feedback

The MouseWheelZoom type exposes the following members.

Methods

Name | Description
GetMinimumZoom | Gets the minimum zoom level that can be attained through the mouse wheel.
GetScaleFactor | Gets the value of the scale factor used to translate mouse wheel movement into zoom changes. A high scale factor means a slow zoom; a low scale factor means a rapid zoom.
SetMinimumZoom | Gets the minimum zoom level that can be attained through the mouse wheel.
SetScaleFactor | Sets the value of the scale factor used to translate mouse wheel movement into zoom changes. A high scale factor means a slow zoom; a low scale factor means a rapid zoom.

See Also

MouseWheelZoom Class


GetMinimumZoom Method

[image]

Mindscape WPF Diagrams
MouseWheelZoom..::.GetMinimumZoom Method
MouseWheelZoom Class See Also Send Feedback
Gets the minimum zoom level that can be attained through the mouse wheel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static double GetMinimumZoom(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetMinimumZoom ( _
    obj As DependencyObject _
) As Double

Parameters

obj
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the MinimumZoom property.

See Also

MouseWheelZoom Class


GetScaleFactor Method

[image]

Mindscape WPF Diagrams
MouseWheelZoom..::.GetScaleFactor Method
MouseWheelZoom Class See Also Send Feedback
Gets the value of the scale factor used to translate mouse wheel movement into zoom changes. A high scale factor means a slow zoom; a low scale factor means a rapid zoom.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static double GetScaleFactor(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetScaleFactor ( _
    obj As DependencyObject _
) As Double

Parameters

obj
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the ScaleFactor property.

See Also

MouseWheelZoom Class


SetMinimumZoom Method

[image]

Mindscape WPF Diagrams
MouseWheelZoom..::.SetMinimumZoom Method
MouseWheelZoom Class See Also Send Feedback
Gets the minimum zoom level that can be attained through the mouse wheel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetMinimumZoom(
    DependencyObject obj,
    double value
)
Visual Basic (Declaration)
Public Shared Sub SetMinimumZoom ( _
    obj As DependencyObject, _
    value As Double _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.
value
Type: System..::.Double
The value of the MinimumZoom property.

See Also

MouseWheelZoom Class


SetScaleFactor Method

[image]

Mindscape WPF Diagrams
MouseWheelZoom..::.SetScaleFactor Method
MouseWheelZoom Class See Also Send Feedback
Sets the value of the scale factor used to translate mouse wheel movement into zoom changes. A high scale factor means a slow zoom; a low scale factor means a rapid zoom.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void SetScaleFactor(
    DependencyObject obj,
    double value
)
Visual Basic (Declaration)
Public Shared Sub SetScaleFactor ( _
    obj As DependencyObject, _
    value As Double _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.
value
Type: System..::.Double
The value of the ScaleFactor property.

See Also

MouseWheelZoom Class


MouseZoomEventArgs Class

[image]

Mindscape WPF Diagrams
MouseZoomEventArgs Class
Members See Also Send Feedback
Provides information about the MouseZoomEvent routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class MouseZoomEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class MouseZoomEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.MouseZoomEventArgs

See Also

MouseZoomEventArgs Members


MouseZoomEventArgs Members

[image] [image]

Mindscape WPF Diagrams
MouseZoomEventArgs Members
MouseZoomEventArgs Class Constructors Properties See Also Send Feedback

The MouseZoomEventArgs type exposes the following members.

Constructors

Name | Description
MouseZoomEventArgs | Initializes a new instance of the MouseZoomEventArgs class.

Properties

Name | Description
Delta | Gets the mouse wheel delta. This is the raw delta, not converted into a zoom fraction.
Position | Gets the position of the mouse zoom, relative to the zoomable element.

See Also

MouseZoomEventArgs Class


MouseZoomEventArgs Constructor

[image]

Mindscape WPF Diagrams
MouseZoomEventArgs Constructor
MouseZoomEventArgs Class See Also Send Feedback
Initializes a new instance of the MouseZoomEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MouseZoomEventArgs(
    Point position,
    double delta
)
Visual Basic (Declaration)
Public Sub New ( _
    position As Point, _
    delta As Double _
)

Parameters

position
Type: System.Windows..::.Point
The position of the mouse zoom.
delta
Type: System..::.Double
The mouse wheel delta.

See Also

MouseZoomEventArgs Class


MouseZoomEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
MouseZoomEventArgs Properties
MouseZoomEventArgs Class See Also Send Feedback

The MouseZoomEventArgs type exposes the following members.

Properties

Name | Description
Delta | Gets the mouse wheel delta. This is the raw delta, not converted into a zoom fraction.
Position | Gets the position of the mouse zoom, relative to the zoomable element.

See Also

MouseZoomEventArgs Class


Delta Property

[image]

Mindscape WPF Diagrams
MouseZoomEventArgs..::.Delta Property
MouseZoomEventArgs Class See Also Send Feedback
Gets the mouse wheel delta. This is the raw delta, not converted into a zoom fraction.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Delta { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delta As Double

See Also

MouseZoomEventArgs Class


Position Property

[image]

Mindscape WPF Diagrams
MouseZoomEventArgs..::.Position Property
MouseZoomEventArgs Class See Also Send Feedback
Gets the position of the mouse zoom, relative to the zoomable element.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point Position { get; }
Visual Basic (Declaration)
Public ReadOnly Property Position As Point

See Also

MouseZoomEventArgs Class


MovableDiagramConnectionSegment Class

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment Class
Members See Also Send Feedback
A type of DiagramConnectionSegment that can be moved by the user.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class MovableDiagramConnectionSegment : DiagramConnectionSegment
Visual Basic (Declaration)
Public Class MovableDiagramConnectionSegment _
    Inherits DiagramConnectionSegment

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionSegment
Mindscape.WpfDiagramming.Foundation..::.MovableDiagramConnectionSegment

See Also

MovableDiagramConnectionSegment Members


MovableDiagramConnectionSegment Members

[image] [image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment Members
MovableDiagramConnectionSegment Class Constructors Methods Properties See Also Send Feedback

The MovableDiagramConnectionSegment type exposes the following members.

Constructors

Name | Description
MovableDiagramConnectionSegment | Overloaded.

Methods

Name | Description
Clone | Returns a deep clone of this DiagramConnectionSegment. (Inherited from DiagramConnectionSegment.)
GetClosestPointTo | Returns the Point that lies on this DiagramConnectionSegment that is the closest point to the given one. The returned Point will have integer precision values. (Inherited from DiagramConnectionSegment.)
MoveHorizontally | Changes the x value of the start and end points of this MovableDiagramConnectionSegment by the given value.
MoveVertically | Changes the y value of the start and end points of this MovableDiagramConnectionSegment by the given value.
RecalculateLayoutProperties | Calculates and sets the appropriate values for the Midpoint, IsHorizontal, and IsVertical properties. (Inherited from DiagramConnectionSegment.)
SetEndPointNoNotify | Just sets the end point of this DiagramConnectionSegment without raising any property changed events. (Inherited from DiagramConnectionSegment.)
SetHorizontal | Sets the y value of the start and end points to be the given value thus making this MovableDiagramConnectionSegment horizontal.
SetStartPointNoNotify | Just sets the start point of this DiagramConnectionSegment to be the given point without raising any property changed events. If the previous segment is null, then the end point of this segment will be set to be the given point instead. (Inherited from DiagramConnectionSegment.)
SetVertical | Sets the x value of the start and end points to be the given value thus making this MovableDiagramConnectionSegment vertical.
ShallowClone | Returns a shallow clone of this MovableDiagramConnectionSegment. (Overrides DiagramConnectionSegment ..::. ShallowClone()()().)

Properties

Name | Description
Connection | Gets the IDiagramConnection that the segment belongs to. (Inherited from DiagramConnectionSegment.)
EndPoint | Gets or sets the end point of this DiagramConnectionSegment. Note that this value is also used for the start point of the next segment to this one. (Inherited from DiagramConnectionSegment.)
IsHorizontal | Gets whether the segment is horizontal. True if this DiagramConnectionSegment is horizontal. False otherwise. This DiagramConnectionSegment is horizontal if the y values of the start and end points are both the same. This is a dependency property. (Inherited from DiagramConnectionSegment.)
IsVertical | Gets the whether the segment is vertical. This is a dependency property. (Inherited from DiagramConnectionSegment.)
Length | Returns the length of this DiagramConnectionSegment in double precision/> (Inherited from DiagramConnectionSegment.)
Midpoint | Gets the midpoint of this DiagramConnectionSegment. This is a dependency property. (Inherited from DiagramConnectionSegment.)
NextSegment | Gets or sets the DiagramConnectionSegment that comes next in a chain of segments. Setting this property also makes sure that the previous segment of the set one is set to be this segment. (Inherited from DiagramConnectionSegment.)
PreviousSegment | Gets or sets the DiagramConnectionSegment that comes previously before this one in a chain of segments. Setting this property alse makes sure that the next segment of the set one is set to be this segment. (Inherited from DiagramConnectionSegment.)
StartPoint | Gets or sets the end point of the previous DiagramConnectionSegment to this one. If this DiagramConnectionSegment does not have a previous segment, then the start point of this DiagramConnectionSegment is its end point. (Inherited from DiagramConnectionSegment.)

See Also

MovableDiagramConnectionSegment Class


MovableDiagramConnectionSegment Constructor

[image] [image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment Constructor
MovableDiagramConnectionSegment Class See Also Send Feedback

Overload List

Name | Description
MovableDiagramConnectionSegment(Point) | Initializes a new instance of the MovableDiagramConnectionSegment class with the given end point.
MovableDiagramConnectionSegment(Double, Double) | Initializes a new instance of the MovableDiagramConnectionSegment class with the end point made from the given x and y values.

See Also

MovableDiagramConnectionSegment Class
MovableDiagramConnectionSegment Members


MovableDiagramConnectionSegment Constructor (Point)

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment Constructor (Point)
MovableDiagramConnectionSegment Class See Also Send Feedback
Initializes a new instance of the MovableDiagramConnectionSegment class with the given end point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MovableDiagramConnectionSegment(
    Point endpoint
)
Visual Basic (Declaration)
Public Sub New ( _
    endpoint As Point _
)

Parameters

endpoint
Type: System.Windows..::.Point
The end point of this MovableDiagramConnectionSegment.

See Also

MovableDiagramConnectionSegment Class
MovableDiagramConnectionSegment Overload


MovableDiagramConnectionSegment Constructor (Double, Double)

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment Constructor (Double, Double)
MovableDiagramConnectionSegment Class See Also Send Feedback
Initializes a new instance of the MovableDiagramConnectionSegment class with the end point made from the given x and y values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MovableDiagramConnectionSegment(
    double endX,
    double endY
)
Visual Basic (Declaration)
Public Sub New ( _
    endX As Double, _
    endY As Double _
)

Parameters

endX
Type: System..::.Double
The x value of the end point of this MovableDiagramConnectionSegment.
endY
Type: System..::.Double
The y value of the end point of this MovableDiagramConnectionSegment.

See Also

MovableDiagramConnectionSegment Class
MovableDiagramConnectionSegment Overload


MovableDiagramConnectionSegment Methods

[image] [image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment Methods
MovableDiagramConnectionSegment Class See Also Send Feedback

The MovableDiagramConnectionSegment type exposes the following members.

Methods

Name | Description
Clone | Returns a deep clone of this DiagramConnectionSegment. (Inherited from DiagramConnectionSegment.)
GetClosestPointTo | Returns the Point that lies on this DiagramConnectionSegment that is the closest point to the given one. The returned Point will have integer precision values. (Inherited from DiagramConnectionSegment.)
MoveHorizontally | Changes the x value of the start and end points of this MovableDiagramConnectionSegment by the given value.
MoveVertically | Changes the y value of the start and end points of this MovableDiagramConnectionSegment by the given value.
RecalculateLayoutProperties | Calculates and sets the appropriate values for the Midpoint, IsHorizontal, and IsVertical properties. (Inherited from DiagramConnectionSegment.)
SetEndPointNoNotify | Just sets the end point of this DiagramConnectionSegment without raising any property changed events. (Inherited from DiagramConnectionSegment.)
SetHorizontal | Sets the y value of the start and end points to be the given value thus making this MovableDiagramConnectionSegment horizontal.
SetStartPointNoNotify | Just sets the start point of this DiagramConnectionSegment to be the given point without raising any property changed events. If the previous segment is null, then the end point of this segment will be set to be the given point instead. (Inherited from DiagramConnectionSegment.)
SetVertical | Sets the x value of the start and end points to be the given value thus making this MovableDiagramConnectionSegment vertical.
ShallowClone | Returns a shallow clone of this MovableDiagramConnectionSegment. (Overrides DiagramConnectionSegment ..::. ShallowClone()()().)

See Also

MovableDiagramConnectionSegment Class


MoveHorizontally Method

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment..::.MoveHorizontally Method
MovableDiagramConnectionSegment Class See Also Send Feedback
Changes the x value of the start and end points of this MovableDiagramConnectionSegment by the given value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void MoveHorizontally(
    double delta
)
Visual Basic (Declaration)
Public Sub MoveHorizontally ( _
    delta As Double _
)

Parameters

delta
Type: System..::.Double
The amount to move this MovableDiagramConnectionSegment horizontally by.

See Also

MovableDiagramConnectionSegment Class


MoveVertically Method

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment..::.MoveVertically Method
MovableDiagramConnectionSegment Class See Also Send Feedback
Changes the y value of the start and end points of this MovableDiagramConnectionSegment by the given value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void MoveVertically(
    double delta
)
Visual Basic (Declaration)
Public Sub MoveVertically ( _
    delta As Double _
)

Parameters

delta
Type: System..::.Double
The amount to move this MovableDiagramConnectionSegment vertically by.

See Also

MovableDiagramConnectionSegment Class


SetHorizontal Method

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment..::.SetHorizontal Method
MovableDiagramConnectionSegment Class See Also Send Feedback
Sets the y value of the start and end points to be the given value thus making this MovableDiagramConnectionSegment horizontal.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetHorizontal(
    double axisY
)
Visual Basic (Declaration)
Public Sub SetHorizontal ( _
    axisY As Double _
)

Parameters

axisY
Type: System..::.Double
The new y value of the start and end points of this MovableDiagramConnectionSegment.

See Also

MovableDiagramConnectionSegment Class


SetVertical Method

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment..::.SetVertical Method
MovableDiagramConnectionSegment Class See Also Send Feedback
Sets the x value of the start and end points to be the given value thus making this MovableDiagramConnectionSegment vertical.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void SetVertical(
    double axisX
)
Visual Basic (Declaration)
Public Sub SetVertical ( _
    axisX As Double _
)

Parameters

axisX
Type: System..::.Double
The new x value of the start and end points of this MovableDiagramConnectionSegment.

See Also

MovableDiagramConnectionSegment Class


ShallowClone Method

[image]

Mindscape WPF Diagrams
MovableDiagramConnectionSegment..::.ShallowClone Method
MovableDiagramConnectionSegment Class See Also Send Feedback
Returns a shallow clone of this MovableDiagramConnectionSegment.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override DiagramConnectionSegment ShallowClone()
Visual Basic (Declaration)
Protected Overrides Function ShallowClone As DiagramConnectionSegment

Return Value

A shallow clone of this MovableDiagramConnectionSegment.

See Also

MovableDiagramConnectionSegment Class


MovedEventArgs Class

[image]

Mindscape WPF Diagrams
MovedEventArgs Class
Members See Also Send Feedback
Provides information about the Moved event of a MoveThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class MovedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class MovedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.MovedEventArgs

See Also

MovedEventArgs Members


MovedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
MovedEventArgs Members
MovedEventArgs Class Constructors Properties See Also Send Feedback

The MovedEventArgs type exposes the following members.

Constructors

Name | Description
MovedEventArgs | Initializes a new instance of the MovedEventArgs class.

Properties

Name | Description
HorizontalChange | Gets the horizontal move amount.
VerticalChange | Gets the vertical move amount.

See Also

MovedEventArgs Class


MovedEventArgs Constructor

[image]

Mindscape WPF Diagrams
MovedEventArgs Constructor
MovedEventArgs Class See Also Send Feedback
Initializes a new instance of the MovedEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MovedEventArgs(
    double horizontalChange,
    double verticalChange
)
Visual Basic (Declaration)
Public Sub New ( _
    horizontalChange As Double, _
    verticalChange As Double _
)

Parameters

horizontalChange
Type: System..::.Double
The horizontal move amount.
verticalChange
Type: System..::.Double
The vertical move amount.

See Also

MovedEventArgs Class


MovedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
MovedEventArgs Properties
MovedEventArgs Class See Also Send Feedback

The MovedEventArgs type exposes the following members.

Properties

Name | Description
HorizontalChange | Gets the horizontal move amount.
VerticalChange | Gets the vertical move amount.

See Also

MovedEventArgs Class


HorizontalChange Property

[image]

Mindscape WPF Diagrams
MovedEventArgs..::.HorizontalChange Property
MovedEventArgs Class See Also Send Feedback
Gets the horizontal move amount.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HorizontalChange { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalChange As Double

See Also

MovedEventArgs Class


VerticalChange Property

[image]

Mindscape WPF Diagrams
MovedEventArgs..::.VerticalChange Property
MovedEventArgs Class See Also Send Feedback
Gets the vertical move amount.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double VerticalChange { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalChange As Double

See Also

MovedEventArgs Class


MoveThumb Class

[image]

Mindscape WPF Diagrams
MoveThumb Class
Members See Also Send Feedback
Enables dragging of the associated FrameworkElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class MoveThumb : AttachedThumb
Visual Basic (Declaration)
Public Class MoveThumb _
    Inherits AttachedThumb

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.AttachedThumb
Mindscape.WpfDiagramming.Foundation..::.MoveThumb

See Also

MoveThumb Members


MoveThumb Members

[image] [image]

Mindscape WPF Diagrams
MoveThumb Members
MoveThumb Class Constructors Fields Properties Events See Also Send Feedback

The MoveThumb type exposes the following members.

Constructors

Name | Description
MoveThumb | Initializes a new instance of the MoveThumb class.

Fields

Name | Description
GeometryProperty | Identifies the Geometry property.
MovedEvent | Identifies the Moved routed event.

Properties

Name | Description
Element | Gets or sets the element to which the AttachedThumb is attached. This is a dependency property. (Inherited from AttachedThumb.)
Geometry | Gets or sets the Geometry. This is a dependency property.
InvisibleStyleKey | Gets the ResourceKey for the Style for making a MoveThumb invisible to the user.
SnapToGuidelines | Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property. (Inherited from AttachedThumb.)

Events

Name | Description
Moved | Occurs when the MoveThumb is moved.

See Also

MoveThumb Class


MoveThumb Constructor

[image]

Mindscape WPF Diagrams
MoveThumb Constructor
MoveThumb Class See Also Send Feedback
Initializes a new instance of the MoveThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public MoveThumb()
Visual Basic (Declaration)
Public Sub New

See Also

MoveThumb Class


MoveThumb Fields

[image] [image]

Mindscape WPF Diagrams
MoveThumb Fields
MoveThumb Class See Also Send Feedback

The MoveThumb type exposes the following members.

Fields

Name | Description
GeometryProperty | Identifies the Geometry property.
MovedEvent | Identifies the Moved routed event.

See Also

MoveThumb Class


GeometryProperty Field

[image]

Mindscape WPF Diagrams
MoveThumb..::.GeometryProperty Field
MoveThumb Class See Also Send Feedback
Identifies the Geometry property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty GeometryProperty
Visual Basic (Declaration)
Public Shared ReadOnly GeometryProperty As DependencyProperty

See Also

MoveThumb Class


MovedEvent Field

[image]

Mindscape WPF Diagrams
MoveThumb..::.MovedEvent Field
MoveThumb Class See Also Send Feedback
Identifies the Moved routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent MovedEvent
Visual Basic (Declaration)
Public Shared ReadOnly MovedEvent As RoutedEvent

See Also

MoveThumb Class


MoveThumb Properties

[image] [image]

Mindscape WPF Diagrams
MoveThumb Properties
MoveThumb Class See Also Send Feedback

The MoveThumb type exposes the following members.

Properties

Name | Description
Element | Gets or sets the element to which the AttachedThumb is attached. This is a dependency property. (Inherited from AttachedThumb.)
Geometry | Gets or sets the Geometry. This is a dependency property.
InvisibleStyleKey | Gets the ResourceKey for the Style for making a MoveThumb invisible to the user.
SnapToGuidelines | Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property. (Inherited from AttachedThumb.)

See Also

MoveThumb Class


Geometry Property

[image]

Mindscape WPF Diagrams
MoveThumb..::.Geometry Property
MoveThumb Class See Also Send Feedback
Gets or sets the Geometry. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Geometry Geometry { get; set; }
Visual Basic (Declaration)
Public Property Geometry As Geometry

Remarks

Dependency Property Information
Identifier field | GeometryProperty
Metadata properties set to true | None

See Also

MoveThumb Class


InvisibleStyleKey Property

[image]

Mindscape WPF Diagrams
MoveThumb..::.InvisibleStyleKey Property
MoveThumb Class See Also Send Feedback
Gets the ResourceKey for the Style for making a MoveThumb invisible to the user.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey InvisibleStyleKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property InvisibleStyleKey As ComponentResourceKey

See Also

MoveThumb Class


MoveThumb Events

[image] [image]

Mindscape WPF Diagrams
MoveThumb Events
MoveThumb Class See Also Send Feedback

The MoveThumb type exposes the following members.

Events

Name | Description
Moved | Occurs when the MoveThumb is moved.

See Also

MoveThumb Class


Moved Event

[image]

Mindscape WPF Diagrams
MoveThumb..::.Moved Event
MoveThumb Class See Also Send Feedback
Occurs when the MoveThumb is moved.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<MovedEventArgs> Moved
Visual Basic (Declaration)
Public Event Moved As EventHandler(Of MovedEventArgs)

See Also

MoveThumb Class


NodeState Class

[image]

Mindscape WPF Diagrams
NodeState Class
Members See Also Send Feedback
A general implementation of the IDiagramNodeState interface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class NodeState : IDiagramNodeState
Visual Basic (Declaration)
Public Class NodeState _
    Implements IDiagramNodeState

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.NodeState
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNodeState

See Also

NodeState Members


NodeState Members

[image] [image]

Mindscape WPF Diagrams
NodeState Members
NodeState Class Constructors Methods Properties See Also Send Feedback

The NodeState type exposes the following members.

Constructors

Name | Description
NodeState | Initializes a new instance of the NodeState class. This NodeState will store the ZOrder, Parent, and Data property values of the given IDiagramNode. It will also store a clone of the Bounds property value.

Methods

Name | Description
Apply | Applies the property values stored in this NodeState on to the given IDiagramNode. Note that because the Data and Parent properties are readonly, these must be set by the given IDiagramNode itself if necessary.

Properties

Name | Description
Bounds | Gets the stored Bounds property value for the IDiagramNode that this NodeState was made for.
Data | Gets the stored Data property value for the IDiagramNode that this NodeState was made for.
IsResizable | Gets the stored IsResizable property value for the IDiagramNode that this NodeState was made for.
Parent | Gets the stored Parent property value for the IDiagramNode that this NodeState was made for.
Rotation | Gets the stored Rotation property value for the IDiagramNode that this NodeState was made for.
ZOrder | Gets the stored ZOrder property value for the IDiagramNode that this NodeState was made for.

See Also

NodeState Class


NodeState Constructor

[image]

Mindscape WPF Diagrams
NodeState Constructor
NodeState Class See Also Send Feedback
Initializes a new instance of the NodeState class. This NodeState will store the ZOrder, Parent, and Data property values of the given IDiagramNode. It will also store a clone of the Bounds property value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public NodeState(
    IDiagramNode node
)
Visual Basic (Declaration)
Public Sub New ( _
    node As IDiagramNode _
)

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
An IDiagramNode that this NodeState will represent a state for.

See Also

NodeState Class


NodeState Methods

[image] [image]

Mindscape WPF Diagrams
NodeState Methods
NodeState Class See Also Send Feedback

The NodeState type exposes the following members.

Methods

Name | Description
Apply | Applies the property values stored in this NodeState on to the given IDiagramNode. Note that because the Data and Parent properties are readonly, these must be set by the given IDiagramNode itself if necessary.

See Also

NodeState Class


Apply Method

[image]

Mindscape WPF Diagrams
NodeState..::.Apply Method
NodeState Class See Also Send Feedback
Applies the property values stored in this NodeState on to the given IDiagramNode. Note that because the Data and Parent properties are readonly, these must be set by the given IDiagramNode itself if necessary.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual void Apply(
    IDiagramNode node
)
Visual Basic (Declaration)
Public Overridable Sub Apply ( _
    node As IDiagramNode _
)

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The node onto which the state is being restored.

Implements

IDiagramNodeState..::.Apply(IDiagramNode)

See Also

NodeState Class


NodeState Properties

[image] [image]

Mindscape WPF Diagrams
NodeState Properties
NodeState Class See Also Send Feedback

The NodeState type exposes the following members.

Properties

Name | Description
Bounds | Gets the stored Bounds property value for the IDiagramNode that this NodeState was made for.
Data | Gets the stored Data property value for the IDiagramNode that this NodeState was made for.
IsResizable | Gets the stored IsResizable property value for the IDiagramNode that this NodeState was made for.
Parent | Gets the stored Parent property value for the IDiagramNode that this NodeState was made for.
Rotation | Gets the stored Rotation property value for the IDiagramNode that this NodeState was made for.
ZOrder | Gets the stored ZOrder property value for the IDiagramNode that this NodeState was made for.

See Also

NodeState Class


Bounds Property

[image]

Mindscape WPF Diagrams
NodeState..::.Bounds Property
NodeState Class See Also Send Feedback
Gets the stored Bounds property value for the IDiagramNode that this NodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect Bounds { get; private set; }
Visual Basic (Declaration)
Public Property Bounds As Rect

Implements

IDiagramNodeState..::.Bounds

See Also

NodeState Class


Data Property

[image]

Mindscape WPF Diagrams
NodeState..::.Data Property
NodeState Class See Also Send Feedback
Gets the stored Data property value for the IDiagramNode that this NodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Data { get; private set; }
Visual Basic (Declaration)
Public Property Data As Object

Implements

IDiagramNodeState..::.Data

See Also

NodeState Class


IsResizable Property

[image]

Mindscape WPF Diagrams
NodeState..::.IsResizable Property
NodeState Class See Also Send Feedback
Gets the stored IsResizable property value for the IDiagramNode that this NodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsResizable { get; private set; }
Visual Basic (Declaration)
Public Property IsResizable As Boolean

See Also

NodeState Class


Parent Property

[image]

Mindscape WPF Diagrams
NodeState..::.Parent Property
NodeState Class See Also Send Feedback
Gets the stored Parent property value for the IDiagramNode that this NodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IDiagramPositionable Parent { get; private set; }
Visual Basic (Declaration)
Public Property Parent As IDiagramPositionable

Implements

IDiagramNodeState..::.Parent

See Also

NodeState Class


Rotation Property

[image]

Mindscape WPF Diagrams
NodeState..::.Rotation Property
NodeState Class See Also Send Feedback
Gets the stored Rotation property value for the IDiagramNode that this NodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Rotation { get; private set; }
Visual Basic (Declaration)
Public Property Rotation As Double

See Also

NodeState Class


ZOrder Property

[image]

Mindscape WPF Diagrams
NodeState..::.ZOrder Property
NodeState Class See Also Send Feedback
Gets the stored ZOrder property value for the IDiagramNode that this NodeState was made for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double ZOrder { get; private set; }
Visual Basic (Declaration)
Public Property ZOrder As Double

Implements

IDiagramNodeState..::.ZOrder

See Also

NodeState Class


OffsetPositionCalculator Class

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator Class
Members See Also Send Feedback
A type of IPositionCalculator that calculates the position according to factors of the width and height of a bounding rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class OffsetPositionCalculator : IPositionCalculator
Visual Basic (Declaration)
Public Class OffsetPositionCalculator _
    Implements IPositionCalculator

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.OffsetPositionCalculator

See Also

OffsetPositionCalculator Members


OffsetPositionCalculator Members

[image] [image]

Mindscape WPF Diagrams
OffsetPositionCalculator Members
OffsetPositionCalculator Class Constructors Methods Properties See Also Send Feedback

The OffsetPositionCalculator type exposes the following members.

Constructors

Name | Description
OffsetPositionCalculator | Overloaded.

Methods

Name | Description
GetPosition | Returns a Point that is derived from the given Rect according to the values of the XFactor and YFactor properties.

Properties

Name | Description
XFactor | Gets or sets a value that is ideally but not restricted to the range of 0-1. This is used to find the x position derived from the width of the bounds given to the GetPosition(Rect) method.
XOffset | Gets or sets the offset that contributes to the x value of the position of this OffsetPositionCalculator. This value is added after the XFactor has determined the initial x value.
YFactor | Gets or sets a value that is ideally but not restricted to the range of 0-1. This is used to find the y position derived from the height of the bounds given to the GetPosition(Rect) method.
YOffset | Gets or sets the offset that contributes to the y value of the position of this OffsetPositionCalculator. This value is added after the YFactor has determined the initial y value.

See Also

OffsetPositionCalculator Class


OffsetPositionCalculator Constructor

[image] [image]

Mindscape WPF Diagrams
OffsetPositionCalculator Constructor
OffsetPositionCalculator Class See Also Send Feedback

Overload List

Name | Description
OffsetPositionCalculator()()() | Initializes a new instance of the OffsetPositionCalculator class.
OffsetPositionCalculator(Double, Double) | Initializes a new instance of the OffsetPositionCalculator class using the specified horizontal and vertical proportional offsets.

See Also

OffsetPositionCalculator Class
OffsetPositionCalculator Members


OffsetPositionCalculator Constructor

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator Constructor
OffsetPositionCalculator Class See Also Send Feedback
Initializes a new instance of the OffsetPositionCalculator class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public OffsetPositionCalculator()
Visual Basic (Declaration)
Public Sub New

See Also

OffsetPositionCalculator Class
OffsetPositionCalculator Overload


OffsetPositionCalculator Constructor (Double, Double)

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator Constructor (Double, Double)
OffsetPositionCalculator Class See Also Send Feedback
Initializes a new instance of the OffsetPositionCalculator class using the specified horizontal and vertical proportional offsets.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public OffsetPositionCalculator(
    double horizontalFactor,
    double verticalFactor
)
Visual Basic (Declaration)
Public Sub New ( _
    horizontalFactor As Double, _
    verticalFactor As Double _
)

Parameters

horizontalFactor
Type: System..::.Double
A value typically between 0 and 1 for calculating the x co-ordinate.
verticalFactor
Type: System..::.Double
A value typically between 0 and 1 for calculating the y co-ordinate.

See Also

OffsetPositionCalculator Class
OffsetPositionCalculator Overload


OffsetPositionCalculator Methods

[image] [image]

Mindscape WPF Diagrams
OffsetPositionCalculator Methods
OffsetPositionCalculator Class See Also Send Feedback

The OffsetPositionCalculator type exposes the following members.

Methods

Name | Description
GetPosition | Returns a Point that is derived from the given Rect according to the values of the XFactor and YFactor properties.

See Also

OffsetPositionCalculator Class


GetPosition Method

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator..::.GetPosition Method
OffsetPositionCalculator Class See Also Send Feedback
Returns a Point that is derived from the given Rect according to the values of the XFactor and YFactor properties.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point GetPosition(
    Rect bounds
)
Visual Basic (Declaration)
Public Function GetPosition ( _
    bounds As Rect _
) As Point

Parameters

bounds
Type: System.Windows..::.Rect
The Rect used to derive the returned Point.

Return Value

A Point whose position is relational to the given Rect and the XFactor and YFactor properties.

Implements

IPositionCalculator..::.GetPosition(Rect)

See Also

OffsetPositionCalculator Class


OffsetPositionCalculator Properties

[image] [image]

Mindscape WPF Diagrams
OffsetPositionCalculator Properties
OffsetPositionCalculator Class See Also Send Feedback

The OffsetPositionCalculator type exposes the following members.

Properties

Name | Description
XFactor | Gets or sets a value that is ideally but not restricted to the range of 0-1. This is used to find the x position derived from the width of the bounds given to the GetPosition(Rect) method.
XOffset | Gets or sets the offset that contributes to the x value of the position of this OffsetPositionCalculator. This value is added after the XFactor has determined the initial x value.
YFactor | Gets or sets a value that is ideally but not restricted to the range of 0-1. This is used to find the y position derived from the height of the bounds given to the GetPosition(Rect) method.
YOffset | Gets or sets the offset that contributes to the y value of the position of this OffsetPositionCalculator. This value is added after the YFactor has determined the initial y value.

See Also

OffsetPositionCalculator Class


XFactor Property

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator..::.XFactor Property
OffsetPositionCalculator Class See Also Send Feedback
Gets or sets a value that is ideally but not restricted to the range of 0-1. This is used to find the x position derived from the width of the bounds given to the GetPosition(Rect) method.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double XFactor { get; set; }
Visual Basic (Declaration)
Public Property XFactor As Double

See Also

OffsetPositionCalculator Class


XOffset Property

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator..::.XOffset Property
OffsetPositionCalculator Class See Also Send Feedback
Gets or sets the offset that contributes to the x value of the position of this OffsetPositionCalculator. This value is added after the XFactor has determined the initial x value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double XOffset { get; set; }
Visual Basic (Declaration)
Public Property XOffset As Double

See Also

OffsetPositionCalculator Class


YFactor Property

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator..::.YFactor Property
OffsetPositionCalculator Class See Also Send Feedback
Gets or sets a value that is ideally but not restricted to the range of 0-1. This is used to find the y position derived from the height of the bounds given to the GetPosition(Rect) method.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double YFactor { get; set; }
Visual Basic (Declaration)
Public Property YFactor As Double

See Also

OffsetPositionCalculator Class


YOffset Property

[image]

Mindscape WPF Diagrams
OffsetPositionCalculator..::.YOffset Property
OffsetPositionCalculator Class See Also Send Feedback
Gets or sets the offset that contributes to the y value of the position of this OffsetPositionCalculator. This value is added after the YFactor has determined the initial y value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double YOffset { get; set; }
Visual Basic (Declaration)
Public Property YOffset As Double

See Also

OffsetPositionCalculator Class


PathBuilderBase Class

[image]

Mindscape WPF Diagrams
PathBuilderBase Class
Members See Also Send Feedback
Provides a standard base implementation of the IPathBuilder interface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class PathBuilderBase : IPathBuilder
Visual Basic (Declaration)
Public MustInherit Class PathBuilderBase _
    Implements IPathBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.PathBuilderBase
Mindscape.WpfDiagramming.Foundation..::.CorneredPathBuilder

See Also

PathBuilderBase Members


PathBuilderBase Members

[image] [image]

Mindscape WPF Diagrams
PathBuilderBase Members
PathBuilderBase Class Constructors Methods See Also Send Feedback

The PathBuilderBase type exposes the following members.

Constructors

Name | Description
PathBuilderBase |

Methods

Name | Description
BuildPath | Returns a PathGeometry based on the given connection segment data.
CreateMultiSegmentFigure | When overridden in a derived class, creates the PathFigure representing the path for the specified segments.

See Also

PathBuilderBase Class


PathBuilderBase Constructor

[image]

Mindscape WPF Diagrams
PathBuilderBase Constructor
PathBuilderBase Class See Also Send Feedback
Initializes a new instance of the PathBuilderBase class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected PathBuilderBase()
Visual Basic (Declaration)
Protected Sub New

See Also

PathBuilderBase Class


PathBuilderBase Methods

[image] [image]

Mindscape WPF Diagrams
PathBuilderBase Methods
PathBuilderBase Class See Also Send Feedback

The PathBuilderBase type exposes the following members.

Methods

Name | Description
BuildPath | Returns a PathGeometry based on the given connection segment data.
CreateMultiSegmentFigure | When overridden in a derived class, creates the PathFigure representing the path for the specified segments.

See Also

PathBuilderBase Class


BuildPath Method

[image]

Mindscape WPF Diagrams
PathBuilderBase..::.BuildPath Method
PathBuilderBase Class See Also Send Feedback
Returns a PathGeometry based on the given connection segment data.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public PathGeometry BuildPath(
    Collection<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Public Function BuildPath ( _
    segments As Collection(Of DiagramConnectionSegment) _
) As PathGeometry

Parameters

segments
Type: System.Collections.ObjectModel..::.Collection <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects making up the connection.

Return Value

A PathGeometry for the diagram connection.

Implements

IPathBuilder..::.BuildPath(Collection<(Of <(DiagramConnectionSegment>)>))

See Also

PathBuilderBase Class


CreateMultiSegmentFigure Method

[image]

Mindscape WPF Diagrams
PathBuilderBase..::.CreateMultiSegmentFigure Method
PathBuilderBase Class See Also Send Feedback
When overridden in a derived class, creates the PathFigure representing the path for the specified segments.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract PathFigure CreateMultiSegmentFigure(
    Collection<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Protected MustOverride Function CreateMultiSegmentFigure ( _
    segments As Collection(Of DiagramConnectionSegment) _
) As PathFigure

Parameters

segments
Type: System.Collections.ObjectModel..::.Collection <(Of <( DiagramConnectionSegment >)>)
The connection segments.

Return Value

A PathFigure representing the connection path.

Remarks

This method is called only if there are two or more segments. Implementations may assume that segments.Count is 2 or greater.

See Also

PathBuilderBase Class


PointToTranslateTransformConverter Class

[image]

Mindscape WPF Diagrams
PointToTranslateTransformConverter Class
Members See Also Send Feedback
Converts a Point into a TranslateTransform.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class PointToTranslateTransformConverter : IValueConverter
Visual Basic (Declaration)
Public Class PointToTranslateTransformConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.PointToTranslateTransformConverter

See Also

PointToTranslateTransformConverter Members


PointToTranslateTransformConverter Members

[image] [image]

Mindscape WPF Diagrams
PointToTranslateTransformConverter Members
PointToTranslateTransformConverter Class Constructors Methods See Also Send Feedback

The PointToTranslateTransformConverter type exposes the following members.

Constructors

Name | Description
PointToTranslateTransformConverter |

Methods

Name | Description
Convert | Converts the given Point into a TranslateTransform.
ConvertBack | Throws a NotImplementedException.

See Also

PointToTranslateTransformConverter Class


PointToTranslateTransformConverter Constructor

[image]

Mindscape WPF Diagrams
PointToTranslateTransformConverter Constructor
PointToTranslateTransformConverter Class See Also Send Feedback
Initializes a new instance of the PointToTranslateTransformConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public PointToTranslateTransformConverter()
Visual Basic (Declaration)
Public Sub New

See Also

PointToTranslateTransformConverter Class


PointToTranslateTransformConverter Methods

[image] [image]

Mindscape WPF Diagrams
PointToTranslateTransformConverter Methods
PointToTranslateTransformConverter Class See Also Send Feedback

The PointToTranslateTransformConverter type exposes the following members.

Methods

Name | Description
Convert | Converts the given Point into a TranslateTransform.
ConvertBack | Throws a NotImplementedException.

See Also

PointToTranslateTransformConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
PointToTranslateTransformConverter..::.Convert Method
PointToTranslateTransformConverter Class See Also Send Feedback
Converts the given Point into a TranslateTransform.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A TranslateTransform derived from the given Point.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

PointToTranslateTransformConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
PointToTranslateTransformConverter..::.ConvertBack Method
PointToTranslateTransformConverter Class See Also Send Feedback
Throws a NotImplementedException.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

PointToTranslateTransformConverter Class


PositionCalculatorConverter Class

[image]

Mindscape WPF Diagrams
PositionCalculatorConverter Class
Members See Also Send Feedback
Converts instances of other types to and from IPositionCalculator instances.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class PositionCalculatorConverter : TypeConverter
Visual Basic (Declaration)
Public Class PositionCalculatorConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Mindscape.WpfDiagramming.Foundation..::.PositionCalculatorConverter

See Also

PositionCalculatorConverter Members


PositionCalculatorConverter Members

[image] [image]

Mindscape WPF Diagrams
PositionCalculatorConverter Members
PositionCalculatorConverter Class Constructors Methods See Also Send Feedback

The PositionCalculatorConverter type exposes the following members.

Constructors

Name | Description
PositionCalculatorConverter |

Methods

Name | Description
CanConvertFrom | Determines whether a class can be converted from a given type to an instance of IPositionCalculator. (Overrides TypeConverter ..::. CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Attempts to convert a specified object to an instance of IPositionCalculator. (Overrides TypeConverter ..::. ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

PositionCalculatorConverter Class


PositionCalculatorConverter Constructor

[image]

Mindscape WPF Diagrams
PositionCalculatorConverter Constructor
PositionCalculatorConverter Class See Also Send Feedback
Initializes a new instance of the PositionCalculatorConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public PositionCalculatorConverter()
Visual Basic (Declaration)
Public Sub New

See Also

PositionCalculatorConverter Class


PositionCalculatorConverter Methods

[image] [image]

Mindscape WPF Diagrams
PositionCalculatorConverter Methods
PositionCalculatorConverter Class See Also Send Feedback

The PositionCalculatorConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Determines whether a class can be converted from a given type to an instance of IPositionCalculator. (Overrides TypeConverter ..::. CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Attempts to convert a specified object to an instance of IPositionCalculator. (Overrides TypeConverter ..::. ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

PositionCalculatorConverter Class


CanConvertFrom Method

[image]

Mindscape WPF Diagrams
PositionCalculatorConverter..::.CanConvertFrom Method
PositionCalculatorConverter Class See Also Send Feedback
Determines whether a class can be converted from a given type to an instance of IPositionCalculator.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Describes the context information of a type.
sourceType
Type: System..::.Type
The type of the source that is being evaluated for conversion.

Return Value

true if the converter can convert from the specified type to an instance of IPositionCalculator; otherwise, false.

See Also

PositionCalculatorConverter Class


ConvertFrom Method

[image]

Mindscape WPF Diagrams
PositionCalculatorConverter..::.ConvertFrom Method
PositionCalculatorConverter Class See Also Send Feedback
Attempts to convert a specified object to an instance of IPositionCalculator.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Describes the context information of a type.
culture
Type: System.Globalization..::.CultureInfo
Culture-specific information that should be respected during conversion.
value
Type: System..::.Object
The object being converted.

Return Value

The instance of IPositionCalculator that is created from the converted source.

See Also

PositionCalculatorConverter Class


PositionCalculators Class

[image]

Mindscape WPF Diagrams
PositionCalculators Class
Members See Also Send Feedback
Contains IPositionCalculator implementations for common positions.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static class PositionCalculators
Visual Basic (Declaration)
Public NotInheritable Class PositionCalculators

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.PositionCalculators

See Also

PositionCalculators Members


PositionCalculators Members

[image] [image]

Mindscape WPF Diagrams
PositionCalculators Members
PositionCalculators Class Properties See Also Send Feedback

The PositionCalculators type exposes the following members.

Properties

Name | Description
BottomCenter | Gets an IPositionCalculator for the bottom center of the rectangle.
Center | Gets an IPositionCalculator for the center of the rectangle.
CenterLeft | Gets an IPositionCalculator for the center left of the rectangle.
CenterRight | Gets an IPositionCalculator for the center right of the rectangle.
TopCenter | Gets an IPositionCalculator for the top center of the rectangle.

See Also

PositionCalculators Class


PositionCalculators Properties

[image] [image]

Mindscape WPF Diagrams
PositionCalculators Properties
PositionCalculators Class See Also Send Feedback

The PositionCalculators type exposes the following members.

Properties

Name | Description
BottomCenter | Gets an IPositionCalculator for the bottom center of the rectangle.
Center | Gets an IPositionCalculator for the center of the rectangle.
CenterLeft | Gets an IPositionCalculator for the center left of the rectangle.
CenterRight | Gets an IPositionCalculator for the center right of the rectangle.
TopCenter | Gets an IPositionCalculator for the top center of the rectangle.

See Also

PositionCalculators Class


BottomCenter Property

[image]

Mindscape WPF Diagrams
PositionCalculators..::.BottomCenter Property
PositionCalculators Class See Also Send Feedback
Gets an IPositionCalculator for the bottom center of the rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static IPositionCalculator BottomCenter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BottomCenter As IPositionCalculator

See Also

PositionCalculators Class


Center Property

[image]

Mindscape WPF Diagrams
PositionCalculators..::.Center Property
PositionCalculators Class See Also Send Feedback
Gets an IPositionCalculator for the center of the rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static IPositionCalculator Center { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Center As IPositionCalculator

See Also

PositionCalculators Class


CenterLeft Property

[image]

Mindscape WPF Diagrams
PositionCalculators..::.CenterLeft Property
PositionCalculators Class See Also Send Feedback
Gets an IPositionCalculator for the center left of the rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static IPositionCalculator CenterLeft { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CenterLeft As IPositionCalculator

See Also

PositionCalculators Class


CenterRight Property

[image]

Mindscape WPF Diagrams
PositionCalculators..::.CenterRight Property
PositionCalculators Class See Also Send Feedback
Gets an IPositionCalculator for the center right of the rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static IPositionCalculator CenterRight { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CenterRight As IPositionCalculator

See Also

PositionCalculators Class


TopCenter Property

[image]

Mindscape WPF Diagrams
PositionCalculators..::.TopCenter Property
PositionCalculators Class See Also Send Feedback
Gets an IPositionCalculator for the top center of the rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static IPositionCalculator TopCenter { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TopCenter As IPositionCalculator

See Also

PositionCalculators Class


QueryDropPositionEventArgs Class

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Class
Members See Also Send Feedback
Provides information about the QueryDropPosition event of a ToolThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class QueryDropPositionEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class QueryDropPositionEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.QueryDropPositionEventArgs

See Also

QueryDropPositionEventArgs Members


QueryDropPositionEventArgs Members

[image] [image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Members
QueryDropPositionEventArgs Class Constructors Properties See Also Send Feedback

The QueryDropPositionEventArgs type exposes the following members.

Constructors

Name | Description
QueryDropPositionEventArgs | Overloaded.

Properties

Name | Description
ActualBounds | Gets the actual bounds.
DesiredBounds | Gets or sets the desired bounds.
InputElement | Gets the InputElement of this ToolThumb.

See Also

QueryDropPositionEventArgs Class


QueryDropPositionEventArgs Constructor

[image] [image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Constructor
QueryDropPositionEventArgs Class See Also Send Feedback

Overload List

Name | Description
QueryDropPositionEventArgs(IInputElement, Point) | Initializes a new instance of the QueryDropPositionEventArgs class.
QueryDropPositionEventArgs(IInputElement, Rect) | Initializes a new instance of the QueryDropPositionEventArgs class.
QueryDropPositionEventArgs(IInputElement, Double, Double) | Initializes a new instance of the QueryDropPositionEventArgs class. This constructor sets the width and height of the actual bounds to be 0.
QueryDropPositionEventArgs(IInputElement, Double, Double, Double, Double) | Initializes a new instance of the QueryDropPositionEventArgs class.

See Also

QueryDropPositionEventArgs Class
QueryDropPositionEventArgs Members


QueryDropPositionEventArgs Constructor (IInputElement, Point)

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Constructor (IInputElement, Point)
QueryDropPositionEventArgs Class See Also Send Feedback
Initializes a new instance of the QueryDropPositionEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public QueryDropPositionEventArgs(
    IInputElement inputElement,
    Point pt
)
Visual Basic (Declaration)
Public Sub New ( _
    inputElement As IInputElement, _
    pt As Point _
)

Parameters

inputElement
Type: System.Windows..::.IInputElement
The IInputElement of the ToolThumb.
pt
Type: System.Windows..::.Point
The position of the top left corner of the actual bounds.

See Also

QueryDropPositionEventArgs Class
QueryDropPositionEventArgs Overload


QueryDropPositionEventArgs Constructor (IInputElement, Rect)

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Constructor (IInputElement, Rect)
QueryDropPositionEventArgs Class See Also Send Feedback
Initializes a new instance of the QueryDropPositionEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public QueryDropPositionEventArgs(
    IInputElement inputElement,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub New ( _
    inputElement As IInputElement, _
    bounds As Rect _
)

Parameters

inputElement
Type: System.Windows..::.IInputElement
The IInputElement of the ToolThumb.
bounds
Type: System.Windows..::.Rect
The actual bounds of the IInputElement of the ToolThumb.

See Also

QueryDropPositionEventArgs Class
QueryDropPositionEventArgs Overload


QueryDropPositionEventArgs Constructor (IInputElement, Double, Double)

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Constructor (IInputElement, Double, Double)
QueryDropPositionEventArgs Class See Also Send Feedback
Initializes a new instance of the QueryDropPositionEventArgs class. This constructor sets the width and height of the actual bounds to be 0.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public QueryDropPositionEventArgs(
    IInputElement inputElement,
    double positionX,
    double positionY
)
Visual Basic (Declaration)
Public Sub New ( _
    inputElement As IInputElement, _
    positionX As Double, _
    positionY As Double _
)

Parameters

inputElement
Type: System.Windows..::.IInputElement
The IInputElement of the ToolThumb.
positionX
Type: System..::.Double
The x position of the left edge of the actual bounds.
positionY
Type: System..::.Double
The y position of the top edge of the actual bounds.

See Also

QueryDropPositionEventArgs Class
QueryDropPositionEventArgs Overload


QueryDropPositionEventArgs Constructor (IInputElement, Double, Double, Double, Double)

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Constructor (IInputElement, Double, Double, Double, Double)
QueryDropPositionEventArgs Class See Also Send Feedback
Initializes a new instance of the QueryDropPositionEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public QueryDropPositionEventArgs(
    IInputElement inputElement,
    double positionX,
    double positionY,
    double width,
    double height
)
Visual Basic (Declaration)
Public Sub New ( _
    inputElement As IInputElement, _
    positionX As Double, _
    positionY As Double, _
    width As Double, _
    height As Double _
)

Parameters

inputElement
Type: System.Windows..::.IInputElement
The IInputElement of the ToolThumb.
positionX
Type: System..::.Double
The x position of the left edge of the actual bounds.
positionY
Type: System..::.Double
The y position of the top edge of the actual bounds.
width
Type: System..::.Double
The width of the actual bounds.
height
Type: System..::.Double
The height of the actual bounds.

See Also

QueryDropPositionEventArgs Class
QueryDropPositionEventArgs Overload


QueryDropPositionEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs Properties
QueryDropPositionEventArgs Class See Also Send Feedback

The QueryDropPositionEventArgs type exposes the following members.

Properties

Name | Description
ActualBounds | Gets the actual bounds.
DesiredBounds | Gets or sets the desired bounds.
InputElement | Gets the InputElement of this ToolThumb.

See Also

QueryDropPositionEventArgs Class


ActualBounds Property

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs..::.ActualBounds Property
QueryDropPositionEventArgs Class See Also Send Feedback
Gets the actual bounds.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect ActualBounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActualBounds As Rect

See Also

QueryDropPositionEventArgs Class


DesiredBounds Property

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs..::.DesiredBounds Property
QueryDropPositionEventArgs Class See Also Send Feedback
Gets or sets the desired bounds.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect DesiredBounds { get; set; }
Visual Basic (Declaration)
Public Property DesiredBounds As Rect

See Also

QueryDropPositionEventArgs Class


InputElement Property

[image]

Mindscape WPF Diagrams
QueryDropPositionEventArgs..::.InputElement Property
QueryDropPositionEventArgs Class See Also Send Feedback
Gets the InputElement of this ToolThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IInputElement InputElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputElement As IInputElement

See Also

QueryDropPositionEventArgs Class


QuerySegmentDragEventArgs Class

[image]

Mindscape WPF Diagrams
QuerySegmentDragEventArgs Class
Members See Also Send Feedback
Provides information to the DiagramSurface about where the ConnectionSegmentThumb wants to place the MovableDiagramConnectionSegment that it is moving. instances of this class can then hold information about where the DiagramSurface allows the DiagramConnectionSegment to be placed.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class QuerySegmentDragEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class QuerySegmentDragEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.QuerySegmentDragEventArgs

See Also

QuerySegmentDragEventArgs Members


QuerySegmentDragEventArgs Members

[image] [image]

Mindscape WPF Diagrams
QuerySegmentDragEventArgs Members
QuerySegmentDragEventArgs Class Constructors Properties See Also Send Feedback

The QuerySegmentDragEventArgs type exposes the following members.

Constructors

Name | Description
QuerySegmentDragEventArgs | Initializes a new instance of the QuerySegmentDragEventArgs class.

Properties

Name | Description
DesiredPosition | Gets or sets the position that the MovableDiagramConnectionSegment is allowed to be placed.
RequestedPosition | Gets the position where the ConnectionSegmentThumb wants to place the MovableDiagramConnectionSegment it is moving.

See Also

QuerySegmentDragEventArgs Class


QuerySegmentDragEventArgs Constructor

[image]

Mindscape WPF Diagrams
QuerySegmentDragEventArgs Constructor
QuerySegmentDragEventArgs Class See Also Send Feedback
Initializes a new instance of the QuerySegmentDragEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public QuerySegmentDragEventArgs(
    double requestedPosition
)
Visual Basic (Declaration)
Public Sub New ( _
    requestedPosition As Double _
)

Parameters

requestedPosition
Type: System..::.Double
The position where the ConnectionSegmentThumb wants to place the segment it is moving.

See Also

QuerySegmentDragEventArgs Class


QuerySegmentDragEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
QuerySegmentDragEventArgs Properties
QuerySegmentDragEventArgs Class See Also Send Feedback

The QuerySegmentDragEventArgs type exposes the following members.

Properties

Name | Description
DesiredPosition | Gets or sets the position that the MovableDiagramConnectionSegment is allowed to be placed.
RequestedPosition | Gets the position where the ConnectionSegmentThumb wants to place the MovableDiagramConnectionSegment it is moving.

See Also

QuerySegmentDragEventArgs Class


DesiredPosition Property

[image]

Mindscape WPF Diagrams
QuerySegmentDragEventArgs..::.DesiredPosition Property
QuerySegmentDragEventArgs Class See Also Send Feedback
Gets or sets the position that the MovableDiagramConnectionSegment is allowed to be placed.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double DesiredPosition { get; set; }
Visual Basic (Declaration)
Public Property DesiredPosition As Double

See Also

QuerySegmentDragEventArgs Class


RequestedPosition Property

[image]

Mindscape WPF Diagrams
QuerySegmentDragEventArgs..::.RequestedPosition Property
QuerySegmentDragEventArgs Class See Also Send Feedback
Gets the position where the ConnectionSegmentThumb wants to place the MovableDiagramConnectionSegment it is moving.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double RequestedPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property RequestedPosition As Double

See Also

QuerySegmentDragEventArgs Class


RandomLayoutAlgorithm Class

[image]

Mindscape WPF Diagrams
RandomLayoutAlgorithm Class
Members See Also Send Feedback
A type of ILayoutAlgorithm that simply randomizes all the positions of the nodes within an IDiagramModel.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class RandomLayoutAlgorithm : LayoutAlgorithmBase
Visual Basic (Declaration)
Public Class RandomLayoutAlgorithm _
    Inherits LayoutAlgorithmBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.LayoutAlgorithmBase
Mindscape.WpfDiagramming.Foundation..::.RandomLayoutAlgorithm

See Also

RandomLayoutAlgorithm Members


RandomLayoutAlgorithm Members

[image] [image]

Mindscape WPF Diagrams
RandomLayoutAlgorithm Members
RandomLayoutAlgorithm Class Constructors Methods Properties See Also Send Feedback

The RandomLayoutAlgorithm type exposes the following members.

Constructors

Name | Description
RandomLayoutAlgorithm | Initializes a new instance of the RandomLayoutAlgorithm.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this RandomLayoutAlgorithm by simply randomizing all the positions of the nodes while keeping them all within the area of the DiagramBounds. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

Properties

Name | Description
DiagramBounds | Gets or sets the bounds that this RandomLayoutAlgorithm will keep all the nodes within.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)

See Also

RandomLayoutAlgorithm Class


RandomLayoutAlgorithm Constructor

[image]

Mindscape WPF Diagrams
RandomLayoutAlgorithm Constructor
RandomLayoutAlgorithm Class See Also Send Feedback
Initializes a new instance of the RandomLayoutAlgorithm.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RandomLayoutAlgorithm()
Visual Basic (Declaration)
Public Sub New

See Also

RandomLayoutAlgorithm Class


RandomLayoutAlgorithm Methods

[image] [image]

Mindscape WPF Diagrams
RandomLayoutAlgorithm Methods
RandomLayoutAlgorithm Class See Also Send Feedback

The RandomLayoutAlgorithm type exposes the following members.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Runs this RandomLayoutAlgorithm by simply randomizing all the positions of the nodes while keeping them all within the area of the DiagramBounds. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)

See Also

RandomLayoutAlgorithm Class


Run Method

[image]

Mindscape WPF Diagrams
RandomLayoutAlgorithm..::.Run Method
RandomLayoutAlgorithm Class See Also Send Feedback
Runs this RandomLayoutAlgorithm by simply randomizing all the positions of the nodes while keeping them all within the area of the DiagramBounds.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Public Overrides Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel to be laid out.

Implements

ILayoutAlgorithm..::.Run(IDiagramModel)

See Also

RandomLayoutAlgorithm Class


RandomLayoutAlgorithm Properties

[image] [image]

Mindscape WPF Diagrams
RandomLayoutAlgorithm Properties
RandomLayoutAlgorithm Class See Also Send Feedback

The RandomLayoutAlgorithm type exposes the following members.

Properties

Name | Description
DiagramBounds | Gets or sets the bounds that this RandomLayoutAlgorithm will keep all the nodes within.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)

See Also

RandomLayoutAlgorithm Class


DiagramBounds Property

[image]

Mindscape WPF Diagrams
RandomLayoutAlgorithm..::.DiagramBounds Property
RandomLayoutAlgorithm Class See Also Send Feedback
Gets or sets the bounds that this RandomLayoutAlgorithm will keep all the nodes within.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect DiagramBounds { get; set; }
Visual Basic (Declaration)
Public Property DiagramBounds As Rect

See Also

RandomLayoutAlgorithm Class


RectToDoubleConverter Class

[image]

Mindscape WPF Diagrams
RectToDoubleConverter Class
Members See Also Send Feedback
Converts a Rect to a number based on the width or height of the Rect.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ValueConversionAttribute(typeof(Rect), typeof(double))]
public class RectToDoubleConverter : IValueConverter
Visual Basic (Declaration)
<ValueConversionAttribute(GetType(Rect), GetType(Double))> _
Public Class RectToDoubleConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.RectToDoubleConverter

See Also

RectToDoubleConverter Members


RectToDoubleConverter Members

[image] [image]

Mindscape WPF Diagrams
RectToDoubleConverter Members
RectToDoubleConverter Class Constructors Methods Properties See Also Send Feedback

The RectToDoubleConverter type exposes the following members.

Constructors

Name | Description
RectToDoubleConverter | Initializes a new instance of the RectToDoubleConverter class.

Methods

Name | Description
Convert | Returns a number based on the width or height of the Rect object and the Factor property.
ConvertBack | Converts a value from a binding target for writing to a binding source.

Properties

Name | Description
ConverterType | Gets or sets the RectToDoubleConverterType which specifies which conversion calculation to use.
Factor | Gets or sets the value that is multiplied to the calculated width value before it is returned in the Convert method.

See Also

RectToDoubleConverter Class


RectToDoubleConverter Constructor

[image]

Mindscape WPF Diagrams
RectToDoubleConverter Constructor
RectToDoubleConverter Class See Also Send Feedback
Initializes a new instance of the RectToDoubleConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RectToDoubleConverter()
Visual Basic (Declaration)
Public Sub New

See Also

RectToDoubleConverter Class


RectToDoubleConverter Methods

[image] [image]

Mindscape WPF Diagrams
RectToDoubleConverter Methods
RectToDoubleConverter Class See Also Send Feedback

The RectToDoubleConverter type exposes the following members.

Methods

Name | Description
Convert | Returns a number based on the width or height of the Rect object and the Factor property.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

RectToDoubleConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
RectToDoubleConverter..::.Convert Method
RectToDoubleConverter Class See Also Send Feedback
Returns a number based on the width or height of the Rect object and the Factor property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The Rect value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The calculated number.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

RectToDoubleConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
RectToDoubleConverter..::.ConvertBack Method
RectToDoubleConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

RectToDoubleConverter Class


RectToDoubleConverter Properties

[image] [image]

Mindscape WPF Diagrams
RectToDoubleConverter Properties
RectToDoubleConverter Class See Also Send Feedback

The RectToDoubleConverter type exposes the following members.

Properties

Name | Description
ConverterType | Gets or sets the RectToDoubleConverterType which specifies which conversion calculation to use.
Factor | Gets or sets the value that is multiplied to the calculated width value before it is returned in the Convert method.

See Also

RectToDoubleConverter Class


ConverterType Property

[image]

Mindscape WPF Diagrams
RectToDoubleConverter..::.ConverterType Property
RectToDoubleConverter Class See Also Send Feedback
Gets or sets the RectToDoubleConverterType which specifies which conversion calculation to use.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RectToDoubleConverterType ConverterType { get; set; }
Visual Basic (Declaration)
Public Property ConverterType As RectToDoubleConverterType

See Also

RectToDoubleConverter Class


Factor Property

[image]

Mindscape WPF Diagrams
RectToDoubleConverter..::.Factor Property
RectToDoubleConverter Class See Also Send Feedback
Gets or sets the value that is multiplied to the calculated width value before it is returned in the Convert method.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Factor { get; set; }
Visual Basic (Declaration)
Public Property Factor As Double

See Also

RectToDoubleConverter Class


RectToDoubleConverterType Enumeration

[image]

Mindscape WPF Diagrams
RectToDoubleConverterType Enumeration
See Also Send Feedback
Specifies the calculation that a RectToDoubleConverter should use to convert a Rect to a number.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum RectToDoubleConverterType
Visual Basic (Declaration)
Public Enumeration RectToDoubleConverterType

Members

Member name | Description
Width | The width of the Rect is used.
Height | The height of the Rect is used.
Maximum | Either the width or height of the Rect is used depending on which is largest.

See Also


RectToPointConverter Class

[image]

Mindscape WPF Diagrams
RectToPointConverter Class
Members See Also Send Feedback
Calculates the position of a Point on a rectangle, relative to the top left of the rectangle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class RectToPointConverter : IValueConverter
Visual Basic (Declaration)
Public Class RectToPointConverter _
    Implements IValueConverter

Remarks

This converter is typically used for scaling non-rectangular paths to fit a node.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.RectToPointConverter

See Also

RectToPointConverter Members


RectToPointConverter Members

[image] [image]

Mindscape WPF Diagrams
RectToPointConverter Members
RectToPointConverter Class Constructors Methods Properties See Also Send Feedback

The RectToPointConverter type exposes the following members.

Constructors

Name | Description
RectToPointConverter |

Methods

Name | Description
Convert | Calculates the position of a Point on the input Rect. The point's X coordinate is the XFactor fraction of the width, plus any XOffset; the point's Y coordinate is the YFactor fraction of the height, plus any YOffset.
ConvertBack | Converts a value from a binding target for writing to a binding source.

Properties

Name | Description
XFactor | Gets or sets how far across the Rect the point is in the X direction, as a fraction of the width.
XOffset | Gets or sets an amount which is added to the X coordinate of the point.
YFactor | Gets or sets how far across the Rect the point is in the Y direction, as a fraction of the height.
YOffset | Gets or sets an amount which is added to the Y coordinate of the point.

See Also

RectToPointConverter Class


RectToPointConverter Constructor

[image]

Mindscape WPF Diagrams
RectToPointConverter Constructor
RectToPointConverter Class See Also Send Feedback
Initializes a new instance of the RectToPointConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RectToPointConverter()
Visual Basic (Declaration)
Public Sub New

See Also

RectToPointConverter Class


RectToPointConverter Methods

[image] [image]

Mindscape WPF Diagrams
RectToPointConverter Methods
RectToPointConverter Class See Also Send Feedback

The RectToPointConverter type exposes the following members.

Methods

Name | Description
Convert | Calculates the position of a Point on the input Rect. The point's X coordinate is the XFactor fraction of the width, plus any XOffset; the point's Y coordinate is the YFactor fraction of the height, plus any YOffset.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

RectToPointConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
RectToPointConverter..::.Convert Method
RectToPointConverter Class See Also Send Feedback
Calculates the position of a Point on the input Rect. The point's X coordinate is the XFactor fraction of the width, plus any XOffset; the point's Y coordinate is the YFactor fraction of the height, plus any YOffset.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The Rect value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A Point representing a position relative to the top left of the Rect.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

RectToPointConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
RectToPointConverter..::.ConvertBack Method
RectToPointConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

RectToPointConverter Class


RectToPointConverter Properties

[image] [image]

Mindscape WPF Diagrams
RectToPointConverter Properties
RectToPointConverter Class See Also Send Feedback

The RectToPointConverter type exposes the following members.

Properties

Name | Description
XFactor | Gets or sets how far across the Rect the point is in the X direction, as a fraction of the width.
XOffset | Gets or sets an amount which is added to the X coordinate of the point.
YFactor | Gets or sets how far across the Rect the point is in the Y direction, as a fraction of the height.
YOffset | Gets or sets an amount which is added to the Y coordinate of the point.

See Also

RectToPointConverter Class


XFactor Property

[image]

Mindscape WPF Diagrams
RectToPointConverter..::.XFactor Property
RectToPointConverter Class See Also Send Feedback
Gets or sets how far across the Rect the point is in the X direction, as a fraction of the width.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double XFactor { get; set; }
Visual Basic (Declaration)
Public Property XFactor As Double

See Also

RectToPointConverter Class


XOffset Property

[image]

Mindscape WPF Diagrams
RectToPointConverter..::.XOffset Property
RectToPointConverter Class See Also Send Feedback
Gets or sets an amount which is added to the X coordinate of the point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double XOffset { get; set; }
Visual Basic (Declaration)
Public Property XOffset As Double

See Also

RectToPointConverter Class


YFactor Property

[image]

Mindscape WPF Diagrams
RectToPointConverter..::.YFactor Property
RectToPointConverter Class See Also Send Feedback
Gets or sets how far across the Rect the point is in the Y direction, as a fraction of the height.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double YFactor { get; set; }
Visual Basic (Declaration)
Public Property YFactor As Double

See Also

RectToPointConverter Class


YOffset Property

[image]

Mindscape WPF Diagrams
RectToPointConverter..::.YOffset Property
RectToPointConverter Class See Also Send Feedback
Gets or sets an amount which is added to the Y coordinate of the point.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double YOffset { get; set; }
Visual Basic (Declaration)
Public Property YOffset As Double

See Also

RectToPointConverter Class


RectToSizeConverter Class

[image]

Mindscape WPF Diagrams
RectToSizeConverter Class
Members See Also Send Feedback
Obtains the size of a Rect, optionally applying scaling and/or fixed offsets.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ValueConversionAttribute(typeof(Rect), typeof(Size))]
public class RectToSizeConverter : IValueConverter
Visual Basic (Declaration)
<ValueConversionAttribute(GetType(Rect), GetType(Size))> _
Public Class RectToSizeConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.RectToSizeConverter

See Also

RectToSizeConverter Members


RectToSizeConverter Members

[image] [image]

Mindscape WPF Diagrams
RectToSizeConverter Members
RectToSizeConverter Class Constructors Methods Properties See Also Send Feedback

The RectToSizeConverter type exposes the following members.

Constructors

Name | Description
RectToSizeConverter | Initializes a new instance of the RectToSizeConverter class.

Methods

Name | Description
Convert | Obtains the size of the given Rect object, after applying the WidthFactor and HeightFactor as scale factors and adding the WidthOffset and HeightOffset. property values.
ConvertBack | Converts a value from a binding target for writing to a binding source.

Properties

Name | Description
HeightFactor | Gets or sets a scale factor that is applied to the height of the Rect. The default factor is 1.
HeightOffset | Gets or sets an amount that is added to the (scaled) height of the Rect.
WidthFactor | Gets or sets a scale factor that is applied to the width of the Rect. The default factor is 1.
WidthOffset | Gets or sets an amount that is added to the (scaled) width of the Rect.

See Also

RectToSizeConverter Class


RectToSizeConverter Constructor

[image]

Mindscape WPF Diagrams
RectToSizeConverter Constructor
RectToSizeConverter Class See Also Send Feedback
Initializes a new instance of the RectToSizeConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RectToSizeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

RectToSizeConverter Class


RectToSizeConverter Methods

[image] [image]

Mindscape WPF Diagrams
RectToSizeConverter Methods
RectToSizeConverter Class See Also Send Feedback

The RectToSizeConverter type exposes the following members.

Methods

Name | Description
Convert | Obtains the size of the given Rect object, after applying the WidthFactor and HeightFactor as scale factors and adding the WidthOffset and HeightOffset. property values.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

RectToSizeConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
RectToSizeConverter..::.Convert Method
RectToSizeConverter Class See Also Send Feedback
Obtains the size of the given Rect object, after applying the WidthFactor and HeightFactor as scale factors and adding the WidthOffset and HeightOffset. property values.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The Rect value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The scaled and adjusted size of the input Rect.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

RectToSizeConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
RectToSizeConverter..::.ConvertBack Method
RectToSizeConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

RectToSizeConverter Class


RectToSizeConverter Properties

[image] [image]

Mindscape WPF Diagrams
RectToSizeConverter Properties
RectToSizeConverter Class See Also Send Feedback

The RectToSizeConverter type exposes the following members.

Properties

Name | Description
HeightFactor | Gets or sets a scale factor that is applied to the height of the Rect. The default factor is 1.
HeightOffset | Gets or sets an amount that is added to the (scaled) height of the Rect.
WidthFactor | Gets or sets a scale factor that is applied to the width of the Rect. The default factor is 1.
WidthOffset | Gets or sets an amount that is added to the (scaled) width of the Rect.

See Also

RectToSizeConverter Class


HeightFactor Property

[image]

Mindscape WPF Diagrams
RectToSizeConverter..::.HeightFactor Property
RectToSizeConverter Class See Also Send Feedback
Gets or sets a scale factor that is applied to the height of the Rect. The default factor is 1.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HeightFactor { get; set; }
Visual Basic (Declaration)
Public Property HeightFactor As Double

See Also

RectToSizeConverter Class


HeightOffset Property

[image]

Mindscape WPF Diagrams
RectToSizeConverter..::.HeightOffset Property
RectToSizeConverter Class See Also Send Feedback
Gets or sets an amount that is added to the (scaled) height of the Rect.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HeightOffset { get; set; }
Visual Basic (Declaration)
Public Property HeightOffset As Double

See Also

RectToSizeConverter Class


WidthFactor Property

[image]

Mindscape WPF Diagrams
RectToSizeConverter..::.WidthFactor Property
RectToSizeConverter Class See Also Send Feedback
Gets or sets a scale factor that is applied to the width of the Rect. The default factor is 1.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double WidthFactor { get; set; }
Visual Basic (Declaration)
Public Property WidthFactor As Double

See Also

RectToSizeConverter Class


WidthOffset Property

[image]

Mindscape WPF Diagrams
RectToSizeConverter..::.WidthOffset Property
RectToSizeConverter Class See Also Send Feedback
Gets or sets an amount that is added to the (scaled) width of the Rect.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double WidthOffset { get; set; }
Visual Basic (Declaration)
Public Property WidthOffset As Double

See Also

RectToSizeConverter Class


Resizer Class

[image]

Mindscape WPF Diagrams
Resizer Class
Members See Also Send Feedback
Enables resizing of the associated FrameworkElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Resizer : Control
Visual Basic (Declaration)
Public Class Resizer _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Mindscape.WpfDiagramming.Foundation..::.Resizer

See Also

Resizer Members


Resizer Members

[image] [image]

Mindscape WPF Diagrams
Resizer Members
Resizer Class Constructors Fields Properties See Also Send Feedback

The Resizer type exposes the following members.

Constructors

Name | Description
Resizer |

Fields

Name | Description
ElementProperty | Identifies the Element property.

Properties

Name | Description
Element | Gets or sets the element which will be resized by this control. This is a dependency property.

See Also

Resizer Class


Resizer Constructor

[image]

Mindscape WPF Diagrams
Resizer Constructor
Resizer Class See Also Send Feedback
Initializes a new instance of the Resizer class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Resizer()
Visual Basic (Declaration)
Public Sub New

See Also

Resizer Class


Resizer Fields

[image] [image]

Mindscape WPF Diagrams
Resizer Fields
Resizer Class See Also Send Feedback

The Resizer type exposes the following members.

Fields

Name | Description
ElementProperty | Identifies the Element property.

See Also

Resizer Class


ElementProperty Field

[image]

Mindscape WPF Diagrams
Resizer..::.ElementProperty Field
Resizer Class See Also Send Feedback
Identifies the Element property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty ElementProperty
Visual Basic (Declaration)
Public Shared ReadOnly ElementProperty As DependencyProperty

See Also

Resizer Class


Resizer Properties

[image] [image]

Mindscape WPF Diagrams
Resizer Properties
Resizer Class See Also Send Feedback

The Resizer type exposes the following members.

Properties

Name | Description
Element | Gets or sets the element which will be resized by this control. This is a dependency property.

See Also

Resizer Class


Element Property

[image]

Mindscape WPF Diagrams
Resizer..::.Element Property
Resizer Class See Also Send Feedback
Gets or sets the element which will be resized by this control. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public FrameworkElement Element { get; set; }
Visual Basic (Declaration)
Public Property Element As FrameworkElement

Remarks

Dependency Property Information
Identifier field | ElementProperty
Metadata properties set to true | None

See Also

Resizer Class


RotatedEventArgs Class

[image]

Mindscape WPF Diagrams
RotatedEventArgs Class
Members See Also Send Feedback
Provides information about the Rotated event of a RotateThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class RotatedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class RotatedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.RotatedEventArgs

See Also

RotatedEventArgs Members


RotatedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
RotatedEventArgs Members
RotatedEventArgs Class Constructors Properties See Also Send Feedback

The RotatedEventArgs type exposes the following members.

Constructors

Name | Description
RotatedEventArgs | Initializes a new instance of the RotatedEventArgs class.

Properties

Name | Description
OldRotation | Gets the previous rotation.

See Also

RotatedEventArgs Class


RotatedEventArgs Constructor

[image]

Mindscape WPF Diagrams
RotatedEventArgs Constructor
RotatedEventArgs Class See Also Send Feedback
Initializes a new instance of the RotatedEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RotatedEventArgs(
    double oldRotation
)
Visual Basic (Declaration)
Public Sub New ( _
    oldRotation As Double _
)

Parameters

oldRotation
Type: System..::.Double
The previous rotation.

See Also

RotatedEventArgs Class


RotatedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
RotatedEventArgs Properties
RotatedEventArgs Class See Also Send Feedback

The RotatedEventArgs type exposes the following members.

Properties

Name | Description
OldRotation | Gets the previous rotation.

See Also

RotatedEventArgs Class


OldRotation Property

[image]

Mindscape WPF Diagrams
RotatedEventArgs..::.OldRotation Property
RotatedEventArgs Class See Also Send Feedback
Gets the previous rotation.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double OldRotation { get; }
Visual Basic (Declaration)
Public ReadOnly Property OldRotation As Double

See Also

RotatedEventArgs Class


RotateThumb Class

[image]

Mindscape WPF Diagrams
RotateThumb Class
Members See Also Send Feedback
A thumb used to rotate diagram nodes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class RotateThumb : AttachedThumb
Visual Basic (Declaration)
Public Class RotateThumb _
    Inherits AttachedThumb

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.AttachedThumb
Mindscape.WpfDiagramming.Foundation..::.RotateThumb

See Also

RotateThumb Members


RotateThumb Members

[image] [image]

Mindscape WPF Diagrams
RotateThumb Members
RotateThumb Class Constructors Fields Properties Events See Also Send Feedback

The RotateThumb type exposes the following members.

Constructors

Name | Description
RotateThumb | Initializes a new instance of the RotateThumb class.

Fields

Name | Description
RotatedEvent | Identifies the Rotated routed event.

Properties

Name | Description
Element | Gets or sets the element to which the AttachedThumb is attached. This is a dependency property. (Inherited from AttachedThumb.)
SnapToGuidelines | Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property. (Inherited from AttachedThumb.)

Events

Name | Description
Rotated | Occurs when the RotateThumb is used.

See Also

RotateThumb Class


RotateThumb Constructor

[image]

Mindscape WPF Diagrams
RotateThumb Constructor
RotateThumb Class See Also Send Feedback
Initializes a new instance of the RotateThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RotateThumb()
Visual Basic (Declaration)
Public Sub New

See Also

RotateThumb Class


RotateThumb Fields

[image] [image]

Mindscape WPF Diagrams
RotateThumb Fields
RotateThumb Class See Also Send Feedback

The RotateThumb type exposes the following members.

Fields

Name | Description
RotatedEvent | Identifies the Rotated routed event.

See Also

RotateThumb Class


RotatedEvent Field

[image]

Mindscape WPF Diagrams
RotateThumb..::.RotatedEvent Field
RotateThumb Class See Also Send Feedback
Identifies the Rotated routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent RotatedEvent
Visual Basic (Declaration)
Public Shared ReadOnly RotatedEvent As RoutedEvent

See Also

RotateThumb Class


RotateThumb Events

[image] [image]

Mindscape WPF Diagrams
RotateThumb Events
RotateThumb Class See Also Send Feedback

The RotateThumb type exposes the following members.

Events

Name | Description
Rotated | Occurs when the RotateThumb is used.

See Also

RotateThumb Class


Rotated Event

[image]

Mindscape WPF Diagrams
RotateThumb..::.Rotated Event
RotateThumb Class See Also Send Feedback
Occurs when the RotateThumb is used.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<RotatedEventArgs> Rotated
Visual Basic (Declaration)
Public Event Rotated As EventHandler(Of RotatedEventArgs)

See Also

RotateThumb Class


RotationToSizeThumbCursorConverter Class

[image]

Mindscape WPF Diagrams
RotationToSizeThumbCursorConverter Class
Members See Also Send Feedback
Converts node rotation into the mouse cursor that should be used by a SizeThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class RotationToSizeThumbCursorConverter : IValueConverter
Visual Basic (Declaration)
Public Class RotationToSizeThumbCursorConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.RotationToSizeThumbCursorConverter

See Also

RotationToSizeThumbCursorConverter Members


RotationToSizeThumbCursorConverter Members

[image] [image]

Mindscape WPF Diagrams
RotationToSizeThumbCursorConverter Members
RotationToSizeThumbCursorConverter Class Constructors Methods See Also Send Feedback

The RotationToSizeThumbCursorConverter type exposes the following members.

Constructors

Name | Description
RotationToSizeThumbCursorConverter |

Methods

Name | Description
Convert | Return the mouse cursor that a SizeThumb should use based on the rotation of the node.
ConvertBack | Throws a NotImplementedException.

See Also

RotationToSizeThumbCursorConverter Class


RotationToSizeThumbCursorConverter Constructor

[image]

Mindscape WPF Diagrams
RotationToSizeThumbCursorConverter Constructor
RotationToSizeThumbCursorConverter Class See Also Send Feedback
Initializes a new instance of the RotationToSizeThumbCursorConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public RotationToSizeThumbCursorConverter()
Visual Basic (Declaration)
Public Sub New

See Also

RotationToSizeThumbCursorConverter Class


RotationToSizeThumbCursorConverter Methods

[image] [image]

Mindscape WPF Diagrams
RotationToSizeThumbCursorConverter Methods
RotationToSizeThumbCursorConverter Class See Also Send Feedback

The RotationToSizeThumbCursorConverter type exposes the following members.

Methods

Name | Description
Convert | Return the mouse cursor that a SizeThumb should use based on the rotation of the node.
ConvertBack | Throws a NotImplementedException.

See Also

RotationToSizeThumbCursorConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
RotationToSizeThumbCursorConverter..::.Convert Method
RotationToSizeThumbCursorConverter Class See Also Send Feedback
Return the mouse cursor that a SizeThumb should use based on the rotation of the node.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The rotation of the node.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The mouse cursor that the SizeThumb uses if the rotation is 0.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The mouse cursor that the SizeThumb should use.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

RotationToSizeThumbCursorConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
RotationToSizeThumbCursorConverter..::.ConvertBack Method
RotationToSizeThumbCursorConverter Class See Also Send Feedback
Throws a NotImplementedException.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

RotationToSizeThumbCursorConverter Class


ScrollBarMaximumConverter Class

[image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter Class
Members See Also Send Feedback
Derives a scroll bar maximum from a maximum value, viewport dimension and zoom factor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ScrollBarMaximumConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class ScrollBarMaximumConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ScrollBarMaximumConverter

See Also

ScrollBarMaximumConverter Members


ScrollBarMaximumConverter Members

[image] [image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter Members
ScrollBarMaximumConverter Class Constructors Methods Properties See Also Send Feedback

The ScrollBarMaximumConverter type exposes the following members.

Constructors

Name | Description
ScrollBarMaximumConverter |

Methods

Name | Description
Convert | Derives a scroll bar maximum from a maximum value, viewport dimension and zoom factor.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

Properties

Name | Description
UnusableDimension | Gets or sets an unusable dimension to be compensated for. This should be set to the size of the other scroll bar in the DiagramScrollViewer.

See Also

ScrollBarMaximumConverter Class


ScrollBarMaximumConverter Constructor

[image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter Constructor
ScrollBarMaximumConverter Class See Also Send Feedback
Initializes a new instance of the ScrollBarMaximumConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ScrollBarMaximumConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ScrollBarMaximumConverter Class


ScrollBarMaximumConverter Methods

[image] [image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter Methods
ScrollBarMaximumConverter Class See Also Send Feedback

The ScrollBarMaximumConverter type exposes the following members.

Methods

Name | Description
Convert | Derives a scroll bar maximum from a maximum value, viewport dimension and zoom factor.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

See Also

ScrollBarMaximumConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter..::.Convert Method
ScrollBarMaximumConverter Class See Also Send Feedback
Derives a scroll bar maximum from a maximum value, viewport dimension and zoom factor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The scroll area settings and zoom factor.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The viewport size.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

Remarks

The values are expected to be as follows:

1. The maximum value.

2. The viewport element size.

3. The zoom factor.

See Also

ScrollBarMaximumConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter..::.ConvertBack Method
ScrollBarMaximumConverter Class See Also Send Feedback
Converts a value from a binding target for writing to multiple binding sources.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The types to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

ScrollBarMaximumConverter Class


ScrollBarMaximumConverter Properties

[image] [image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter Properties
ScrollBarMaximumConverter Class See Also Send Feedback

The ScrollBarMaximumConverter type exposes the following members.

Properties

Name | Description
UnusableDimension | Gets or sets an unusable dimension to be compensated for. This should be set to the size of the other scroll bar in the DiagramScrollViewer.

See Also

ScrollBarMaximumConverter Class


UnusableDimension Property

[image]

Mindscape WPF Diagrams
ScrollBarMaximumConverter..::.UnusableDimension Property
ScrollBarMaximumConverter Class See Also Send Feedback
Gets or sets an unusable dimension to be compensated for. This should be set to the size of the other scroll bar in the DiagramScrollViewer.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double UnusableDimension { get; set; }
Visual Basic (Declaration)
Public Property UnusableDimension As Double

See Also

ScrollBarMaximumConverter Class


ScrollBarViewportSizeConverter Class

[image]

Mindscape WPF Diagrams
ScrollBarViewportSizeConverter Class
Members See Also Send Feedback
Derives a viewport size from a dimension and zoom factor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ScrollBarViewportSizeConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class ScrollBarViewportSizeConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ScrollBarViewportSizeConverter

See Also

ScrollBarViewportSizeConverter Members


ScrollBarViewportSizeConverter Members

[image] [image]

Mindscape WPF Diagrams
ScrollBarViewportSizeConverter Members
ScrollBarViewportSizeConverter Class Constructors Methods See Also Send Feedback

The ScrollBarViewportSizeConverter type exposes the following members.

Constructors

Name | Description
ScrollBarViewportSizeConverter |

Methods

Name | Description
Convert | Derives a viewport size from a dimension and zoom factor.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

See Also

ScrollBarViewportSizeConverter Class


ScrollBarViewportSizeConverter Constructor

[image]

Mindscape WPF Diagrams
ScrollBarViewportSizeConverter Constructor
ScrollBarViewportSizeConverter Class See Also Send Feedback
Initializes a new instance of the ScrollBarViewportSizeConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ScrollBarViewportSizeConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ScrollBarViewportSizeConverter Class


ScrollBarViewportSizeConverter Methods

[image] [image]

Mindscape WPF Diagrams
ScrollBarViewportSizeConverter Methods
ScrollBarViewportSizeConverter Class See Also Send Feedback

The ScrollBarViewportSizeConverter type exposes the following members.

Methods

Name | Description
Convert | Derives a viewport size from a dimension and zoom factor.
ConvertBack | Converts a value from a binding target for writing to multiple binding sources.

See Also

ScrollBarViewportSizeConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ScrollBarViewportSizeConverter..::.Convert Method
ScrollBarViewportSizeConverter Class See Also Send Feedback
Derives a viewport size from a dimension and zoom factor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The dimension and zoom factor.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The viewport size.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

Remarks

The values are expected to be as follows:

1. The dimension.

2. The zoom factor.

See Also

ScrollBarViewportSizeConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ScrollBarViewportSizeConverter..::.ConvertBack Method
ScrollBarViewportSizeConverter Class See Also Send Feedback
Converts a value from a binding target for writing to multiple binding sources.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The types to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

ScrollBarViewportSizeConverter Class


SegmentMovedEventArgs Class

[image]

Mindscape WPF Diagrams
SegmentMovedEventArgs Class
Members See Also Send Feedback
Provides information about the SegmentMoved event of a ConnectionSegmentThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SegmentMovedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class SegmentMovedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.SegmentMovedEventArgs

See Also

SegmentMovedEventArgs Members


SegmentMovedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
SegmentMovedEventArgs Members
SegmentMovedEventArgs Class Constructors Properties See Also Send Feedback

The SegmentMovedEventArgs type exposes the following members.

Constructors

Name | Description
SegmentMovedEventArgs | Overloaded.

Properties

Name | Description
DeltaMovement | Gets the distance moved by the segment that raised the SegmentMovedEvent.
Segment | Gets the DiagramConnectionSegment that was moved by the ConnectionSegmentThumb.

See Also

SegmentMovedEventArgs Class


SegmentMovedEventArgs Constructor

[image] [image]

Mindscape WPF Diagrams
SegmentMovedEventArgs Constructor
SegmentMovedEventArgs Class See Also Send Feedback

Overload List

Name | Description
SegmentMovedEventArgs(DiagramConnectionSegment) | Initializes a new instance of the SegmentMovedEventArgs class. The DeltaMovement property is set to be 0.0.
SegmentMovedEventArgs(DiagramConnectionSegment, Double) | Initializes a new instance of the SegmentMovedEventArgs class and sets the DeltaMovement property to be the given deltaMovement value.

See Also

SegmentMovedEventArgs Class
SegmentMovedEventArgs Members


SegmentMovedEventArgs Constructor (DiagramConnectionSegment)

[image]

Mindscape WPF Diagrams
SegmentMovedEventArgs Constructor (DiagramConnectionSegment)
SegmentMovedEventArgs Class See Also Send Feedback
Initializes a new instance of the SegmentMovedEventArgs class. The DeltaMovement property is set to be 0.0.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SegmentMovedEventArgs(
    DiagramConnectionSegment segment
)
Visual Basic (Declaration)
Public Sub New ( _
    segment As DiagramConnectionSegment _
)

Parameters

segment
Type: Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionSegment
The DiagramConnectionSegment that was modified.

See Also

SegmentMovedEventArgs Class
SegmentMovedEventArgs Overload


SegmentMovedEventArgs Constructor (DiagramConnectionSegment, Double)

[image]

Mindscape WPF Diagrams
SegmentMovedEventArgs Constructor (DiagramConnectionSegment, Double)
SegmentMovedEventArgs Class See Also Send Feedback
Initializes a new instance of the SegmentMovedEventArgs class and sets the DeltaMovement property to be the given deltaMovement value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SegmentMovedEventArgs(
    DiagramConnectionSegment segment,
    double deltaMovement
)
Visual Basic (Declaration)
Public Sub New ( _
    segment As DiagramConnectionSegment, _
    deltaMovement As Double _
)

Parameters

segment
Type: Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionSegment
The DiagramConnectionSegment that was modified.
deltaMovement
Type: System..::.Double
The distance moved by the segment.

See Also

SegmentMovedEventArgs Class
SegmentMovedEventArgs Overload


SegmentMovedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
SegmentMovedEventArgs Properties
SegmentMovedEventArgs Class See Also Send Feedback

The SegmentMovedEventArgs type exposes the following members.

Properties

Name | Description
DeltaMovement | Gets the distance moved by the segment that raised the SegmentMovedEvent.
Segment | Gets the DiagramConnectionSegment that was moved by the ConnectionSegmentThumb.

See Also

SegmentMovedEventArgs Class


DeltaMovement Property

[image]

Mindscape WPF Diagrams
SegmentMovedEventArgs..::.DeltaMovement Property
SegmentMovedEventArgs Class See Also Send Feedback
Gets the distance moved by the segment that raised the SegmentMovedEvent.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double DeltaMovement { get; private set; }
Visual Basic (Declaration)
Public Property DeltaMovement As Double

See Also

SegmentMovedEventArgs Class


Segment Property

[image]

Mindscape WPF Diagrams
SegmentMovedEventArgs..::.Segment Property
SegmentMovedEventArgs Class See Also Send Feedback
Gets the DiagramConnectionSegment that was moved by the ConnectionSegmentThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DiagramConnectionSegment Segment { get; private set; }
Visual Basic (Declaration)
Public Property Segment As DiagramConnectionSegment

See Also

SegmentMovedEventArgs Class


SegmentsToAngleConverter Class

[image]

Mindscape WPF Diagrams
SegmentsToAngleConverter Class
Members See Also Send Feedback
Uses diagram connection segments to calculate an angle for an Arrowhead.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SegmentsToAngleConverter : IValueConverter
Visual Basic (Declaration)
Public Class SegmentsToAngleConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.SegmentsToAngleConverter

See Also

SegmentsToAngleConverter Members


SegmentsToAngleConverter Members

[image] [image]

Mindscape WPF Diagrams
SegmentsToAngleConverter Members
SegmentsToAngleConverter Class Constructors Methods Properties See Also Send Feedback

The SegmentsToAngleConverter type exposes the following members.

Constructors

Name | Description
SegmentsToAngleConverter |

Methods

Name | Description
Convert | Returns the angle for an Arrowhead.
ConvertBack | Converts a value from a binding target for writing to a binding source.

Properties

Name | Description
ConnectionEnd | Gets or sets the end of the connection that the angle will be calculated for.

See Also

SegmentsToAngleConverter Class


SegmentsToAngleConverter Constructor

[image]

Mindscape WPF Diagrams
SegmentsToAngleConverter Constructor
SegmentsToAngleConverter Class See Also Send Feedback
Initializes a new instance of the SegmentsToAngleConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SegmentsToAngleConverter()
Visual Basic (Declaration)
Public Sub New

See Also

SegmentsToAngleConverter Class


SegmentsToAngleConverter Methods

[image] [image]

Mindscape WPF Diagrams
SegmentsToAngleConverter Methods
SegmentsToAngleConverter Class See Also Send Feedback

The SegmentsToAngleConverter type exposes the following members.

Methods

Name | Description
Convert | Returns the angle for an Arrowhead.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

SegmentsToAngleConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
SegmentsToAngleConverter..::.Convert Method
SegmentsToAngleConverter Class See Also Send Feedback
Returns the angle for an Arrowhead.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The calculated angle.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

SegmentsToAngleConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
SegmentsToAngleConverter..::.ConvertBack Method
SegmentsToAngleConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

SegmentsToAngleConverter Class


SegmentsToAngleConverter Properties

[image] [image]

Mindscape WPF Diagrams
SegmentsToAngleConverter Properties
SegmentsToAngleConverter Class See Also Send Feedback

The SegmentsToAngleConverter type exposes the following members.

Properties

Name | Description
ConnectionEnd | Gets or sets the end of the connection that the angle will be calculated for.

See Also

SegmentsToAngleConverter Class


ConnectionEnd Property

[image]

Mindscape WPF Diagrams
SegmentsToAngleConverter..::.ConnectionEnd Property
SegmentsToAngleConverter Class See Also Send Feedback
Gets or sets the end of the connection that the angle will be calculated for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionEnd ConnectionEnd { get; set; }
Visual Basic (Declaration)
Public Property ConnectionEnd As ConnectionEnd

See Also

SegmentsToAngleConverter Class


ShapeConnectionPointPositionCollectionConverter Class

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPositionCollectionConverter Class
Members See Also Send Feedback
Converts instances of other types to and from IPositionCalculator instances.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ShapeConnectionPointPositionCollectionConverter : TypeConverter
Visual Basic (Declaration)
Public Class ShapeConnectionPointPositionCollectionConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Mindscape.WpfDiagramming.Foundation..::.ShapeConnectionPointPositionCollectionConverter

See Also

ShapeConnectionPointPositionCollectionConverter Members


ShapeConnectionPointPositionCollectionConverter Members

[image] [image]

Mindscape WPF Diagrams
ShapeConnectionPointPositionCollectionConverter Members
ShapeConnectionPointPositionCollectionConverter Class Constructors Methods See Also Send Feedback

The ShapeConnectionPointPositionCollectionConverter type exposes the following members.

Constructors

Name | Description
ShapeConnectionPointPositionCollectionConverter |

Methods

Name | Description
CanConvertFrom | Determines whether a class can be converted from a given type to a collection of ShapeConnectionPointPosition objects. (Overrides TypeConverter ..::. CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Attempts to convert a specified object to a collection of ShapeConnectionPointPosition objects. (Overrides TypeConverter ..::. ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

ShapeConnectionPointPositionCollectionConverter Class


ShapeConnectionPointPositionCollectionConverter Constructor

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPositionCollectionConverter Constructor
ShapeConnectionPointPositionCollectionConverter Class See Also Send Feedback
Initializes a new instance of the ShapeConnectionPointPositionCollectionConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ShapeConnectionPointPositionCollectionConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ShapeConnectionPointPositionCollectionConverter Class


ShapeConnectionPointPositionCollectionConverter Methods

[image] [image]

Mindscape WPF Diagrams
ShapeConnectionPointPositionCollectionConverter Methods
ShapeConnectionPointPositionCollectionConverter Class See Also Send Feedback

The ShapeConnectionPointPositionCollectionConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Determines whether a class can be converted from a given type to a collection of ShapeConnectionPointPosition objects. (Overrides TypeConverter ..::. CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Attempts to convert a specified object to a collection of ShapeConnectionPointPosition objects. (Overrides TypeConverter ..::. ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

ShapeConnectionPointPositionCollectionConverter Class


CanConvertFrom Method

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPositionCollectionConverter..::.CanConvertFrom Method
ShapeConnectionPointPositionCollectionConverter Class See Also Send Feedback
Determines whether a class can be converted from a given type to a collection of ShapeConnectionPointPosition objects.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Describes the context information of a type.
sourceType
Type: System..::.Type
The type of the source that is being evaluated for conversion.

Return Value

true if the converter can convert from the specified type to an instance of IPositionCalculator; otherwise, false.

See Also

ShapeConnectionPointPositionCollectionConverter Class


ConvertFrom Method

[image]

Mindscape WPF Diagrams
ShapeConnectionPointPositionCollectionConverter..::.ConvertFrom Method
ShapeConnectionPointPositionCollectionConverter Class See Also Send Feedback
Attempts to convert a specified object to a collection of ShapeConnectionPointPosition objects.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Describes the context information of a type.
culture
Type: System.Globalization..::.CultureInfo
Culture-specific information that should be respected during conversion.
value
Type: System..::.Object
The object being converted.

Return Value

The collection of ShapeConnectionPointPosition objects that is created from the converted source.

See Also

ShapeConnectionPointPositionCollectionConverter Class


SizedEventArgs Class

[image]

Mindscape WPF Diagrams
SizedEventArgs Class
Members See Also Send Feedback
Provides information about the Sized event of a SizeThumb.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SizedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class SizedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.SizedEventArgs

See Also

SizedEventArgs Members


SizedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
SizedEventArgs Members
SizedEventArgs Class Constructors Properties See Also Send Feedback

The SizedEventArgs type exposes the following members.

Constructors

Name | Description
SizedEventArgs | Initializes a new instance of the SizedEventArgs class.

Properties

Name | Description
HeightChange | Gets the amount that the height of the IDiagramNode changed by.
WidthChange | Gets the amount that the width of the IDiagramNode changed by.

See Also

SizedEventArgs Class


SizedEventArgs Constructor

[image]

Mindscape WPF Diagrams
SizedEventArgs Constructor
SizedEventArgs Class See Also Send Feedback
Initializes a new instance of the SizedEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SizedEventArgs(
    double widthChange,
    double heightChange
)
Visual Basic (Declaration)
Public Sub New ( _
    widthChange As Double, _
    heightChange As Double _
)

Parameters

widthChange
Type: System..::.Double
The change in the width of the element being resized.
heightChange
Type: System..::.Double
The change in the height of the element being resized.

See Also

SizedEventArgs Class


SizedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
SizedEventArgs Properties
SizedEventArgs Class See Also Send Feedback

The SizedEventArgs type exposes the following members.

Properties

Name | Description
HeightChange | Gets the amount that the height of the IDiagramNode changed by.
WidthChange | Gets the amount that the width of the IDiagramNode changed by.

See Also

SizedEventArgs Class


HeightChange Property

[image]

Mindscape WPF Diagrams
SizedEventArgs..::.HeightChange Property
SizedEventArgs Class See Also Send Feedback
Gets the amount that the height of the IDiagramNode changed by.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double HeightChange { get; }
Visual Basic (Declaration)
Public ReadOnly Property HeightChange As Double

See Also

SizedEventArgs Class


WidthChange Property

[image]

Mindscape WPF Diagrams
SizedEventArgs..::.WidthChange Property
SizedEventArgs Class See Also Send Feedback
Gets the amount that the width of the IDiagramNode changed by.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double WidthChange { get; }
Visual Basic (Declaration)
Public ReadOnly Property WidthChange As Double

See Also

SizedEventArgs Class


SizeThumb Class

[image]

Mindscape WPF Diagrams
SizeThumb Class
Members See Also Send Feedback
Enables resizing of the associated FrameworkElement.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SizeThumb : AttachedThumb
Visual Basic (Declaration)
Public Class SizeThumb _
    Inherits AttachedThumb

Remarks

SizeThumb represents a single resize handle. The location of the handle, and the effect of dragging, are determined by the HorizontalAlignment and VerticalAlignment properties. To enable resizing on all sides and corners, use a Resizer control.

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.AttachedThumb
Mindscape.WpfDiagramming.Foundation..::.SizeThumb

See Also

SizeThumb Members


SizeThumb Members

[image] [image]

Mindscape WPF Diagrams
SizeThumb Members
SizeThumb Class Constructors Fields Properties Events See Also Send Feedback

The SizeThumb type exposes the following members.

Constructors

Name | Description
SizeThumb | Initializes a new instance of the SizeThumb class.

Fields

Name | Description
IsSquareSizingProperty | Identifies the IsSquareSizing property.
SizedEvent | Identifies the Sized routed event.

Properties

Name | Description
Element | Gets or sets the element to which the AttachedThumb is attached. This is a dependency property. (Inherited from AttachedThumb.)
IsSquareSizing | Gets or sets whether or not this SizeThumb is in square sizing mode. In square sizing mode, the vertical change and horizontal change is the same when changing the size of a node via a corner sizing handle.
SnapToGuidelines | Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property. (Inherited from AttachedThumb.)

Events

Name | Description
Sized | Occurs when the MoveThumb is moved.

See Also

SizeThumb Class


SizeThumb Constructor

[image]

Mindscape WPF Diagrams
SizeThumb Constructor
SizeThumb Class See Also Send Feedback
Initializes a new instance of the SizeThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SizeThumb()
Visual Basic (Declaration)
Public Sub New

See Also

SizeThumb Class


SizeThumb Fields

[image] [image]

Mindscape WPF Diagrams
SizeThumb Fields
SizeThumb Class See Also Send Feedback

The SizeThumb type exposes the following members.

Fields

Name | Description
IsSquareSizingProperty | Identifies the IsSquareSizing property.
SizedEvent | Identifies the Sized routed event.

See Also

SizeThumb Class


IsSquareSizingProperty Field

[image]

Mindscape WPF Diagrams
SizeThumb..::.IsSquareSizingProperty Field
SizeThumb Class See Also Send Feedback
Identifies the IsSquareSizing property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsSquareSizingProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSquareSizingProperty As DependencyProperty

See Also

SizeThumb Class


SizedEvent Field

[image]

Mindscape WPF Diagrams
SizeThumb..::.SizedEvent Field
SizeThumb Class See Also Send Feedback
Identifies the Sized routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent SizedEvent
Visual Basic (Declaration)
Public Shared ReadOnly SizedEvent As RoutedEvent

See Also

SizeThumb Class


SizeThumb Properties

[image] [image]

Mindscape WPF Diagrams
SizeThumb Properties
SizeThumb Class See Also Send Feedback

The SizeThumb type exposes the following members.

Properties

Name | Description
Element | Gets or sets the element to which the AttachedThumb is attached. This is a dependency property. (Inherited from AttachedThumb.)
IsSquareSizing | Gets or sets whether or not this SizeThumb is in square sizing mode. In square sizing mode, the vertical change and horizontal change is the same when changing the size of a node via a corner sizing handle.
SnapToGuidelines | Gets or sets whether the AttachedThumb should snap to guidelines when dragged. The default is true. This is a dependency property. (Inherited from AttachedThumb.)

See Also

SizeThumb Class


IsSquareSizing Property

[image]

Mindscape WPF Diagrams
SizeThumb..::.IsSquareSizing Property
SizeThumb Class See Also Send Feedback
Gets or sets whether or not this SizeThumb is in square sizing mode. In square sizing mode, the vertical change and horizontal change is the same when changing the size of a node via a corner sizing handle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsSquareSizing { get; set; }
Visual Basic (Declaration)
Public Property IsSquareSizing As Boolean

Remarks

Dependency Property Information
Identifier field | IsSquareSizingProperty
Metadata properties set to true | None

See Also

SizeThumb Class


SizeThumb Events

[image] [image]

Mindscape WPF Diagrams
SizeThumb Events
SizeThumb Class See Also Send Feedback

The SizeThumb type exposes the following members.

Events

Name | Description
Sized | Occurs when the MoveThumb is moved.

See Also

SizeThumb Class


Sized Event

[image]

Mindscape WPF Diagrams
SizeThumb..::.Sized Event
SizeThumb Class See Also Send Feedback
Occurs when the MoveThumb is moved.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<SizedEventArgs> Sized
Visual Basic (Declaration)
Public Event Sized As EventHandler(Of SizedEventArgs)

See Also

SizeThumb Class


SizeToFitConverter Class

[image]

Mindscape WPF Diagrams
SizeToFitConverter Class
Members See Also Send Feedback
Derives a ScaleTransform sizing a diagram to fit the available size.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SizeToFitConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class SizeToFitConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.SizeToFitConverter

See Also

SizeToFitConverter Members


SizeToFitConverter Members

[image] [image]

Mindscape WPF Diagrams
SizeToFitConverter Members
SizeToFitConverter Class Constructors Methods See Also Send Feedback

The SizeToFitConverter type exposes the following members.

Constructors

Name | Description
SizeToFitConverter |

Methods

Name | Description
Convert | Converts a diagram size and available size to a zoom factor.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

SizeToFitConverter Class


SizeToFitConverter Constructor

[image]

Mindscape WPF Diagrams
SizeToFitConverter Constructor
SizeToFitConverter Class See Also Send Feedback
Initializes a new instance of the SizeToFitConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SizeToFitConverter()
Visual Basic (Declaration)
Public Sub New

See Also

SizeToFitConverter Class


SizeToFitConverter Methods

[image] [image]

Mindscape WPF Diagrams
SizeToFitConverter Methods
SizeToFitConverter Class See Also Send Feedback

The SizeToFitConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a diagram size and available size to a zoom factor.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

SizeToFitConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
SizeToFitConverter..::.Convert Method
SizeToFitConverter Class See Also Send Feedback
Converts a diagram size and available size to a zoom factor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The diagram size and target size.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A zoom factor which fits the diagram into the available space.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

Remarks

The values are expected to be as follows:

1. The diagram size.

2. A Thickness buffer around the diagram bounds.

3. The horizontal available size.

4. The vertical available size.

See Also

SizeToFitConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
SizeToFitConverter..::.ConvertBack Method
SizeToFitConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

SizeToFitConverter Class


SnapLineDisplayMode Enumeration

[image]

Mindscape WPF Diagrams
SnapLineDisplayMode Enumeration
See Also Send Feedback
Controls how a DiagramSurface displays snap lines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum SnapLineDisplayMode
Visual Basic (Declaration)
Public Enumeration SnapLineDisplayMode

Members

Member name | Description
None | Snap lines are not displayed.
Intersection | The intersections of snap lines are displayed.
Line | Snap lines are displayed as lines.

See Also


SnapLineDrawingConverter Class

[image]

Mindscape WPF Diagrams
SnapLineDrawingConverter Class
Members See Also Send Feedback
Derives a snap line background drawing from DiagramSurface settings.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SnapLineDrawingConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class SnapLineDrawingConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.SnapLineDrawingConverter

See Also

SnapLineDrawingConverter Members


SnapLineDrawingConverter Members

[image] [image]

Mindscape WPF Diagrams
SnapLineDrawingConverter Members
SnapLineDrawingConverter Class Constructors Methods See Also Send Feedback

The SnapLineDrawingConverter type exposes the following members.

Constructors

Name | Description
SnapLineDrawingConverter |

Methods

Name | Description
Convert | Derives a snap line background drawing from DiagramSurface settings.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

SnapLineDrawingConverter Class


SnapLineDrawingConverter Constructor

[image]

Mindscape WPF Diagrams
SnapLineDrawingConverter Constructor
SnapLineDrawingConverter Class See Also Send Feedback
Initializes a new instance of the SnapLineDrawingConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SnapLineDrawingConverter()
Visual Basic (Declaration)
Public Sub New

See Also

SnapLineDrawingConverter Class


SnapLineDrawingConverter Methods

[image] [image]

Mindscape WPF Diagrams
SnapLineDrawingConverter Methods
SnapLineDrawingConverter Class See Also Send Feedback

The SnapLineDrawingConverter type exposes the following members.

Methods

Name | Description
Convert | Derives a snap line background drawing from DiagramSurface settings.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

SnapLineDrawingConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
SnapLineDrawingConverter..::.Convert Method
SnapLineDrawingConverter Class See Also Send Feedback
Derives a snap line background drawing from DiagramSurface settings.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The DiagramSurface settings.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A DrawingBrush suitable for use as a background.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

Remarks

The values are expected to be as follows:

1. The HorizontalSnapSpecifier.

2. The HorizontalSnapSpecifier.

3. The Zoom.

4. The ZoomMode.

5. The ActualWidth.

6. The ActualHeight.

7. The current horizontal scroll offset.

8. The current vertical scroll offset.

9. The SnapLineDrawing.

10. The current Extent.

See Also

SnapLineDrawingConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
SnapLineDrawingConverter..::.ConvertBack Method
SnapLineDrawingConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The types to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

SnapLineDrawingConverter Class


SnapToIntervalExtension Class

[image]

Mindscape WPF Diagrams
SnapToIntervalExtension Class
Members See Also Send Feedback
Provides a markup shortcut for specifying a snap line interval.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SnapToIntervalExtension : MarkupExtension
Visual Basic (Declaration)
Public Class SnapToIntervalExtension _
    Inherits MarkupExtension

Inheritance Hierarchy

System..::.Object
System.Windows.Markup..::.MarkupExtension
Mindscape.WpfDiagramming.Foundation..::.SnapToIntervalExtension

See Also

SnapToIntervalExtension Members


SnapToIntervalExtension Members

[image] [image]

Mindscape WPF Diagrams
SnapToIntervalExtension Members
SnapToIntervalExtension Class Constructors Methods See Also Send Feedback

The SnapToIntervalExtension type exposes the following members.

Constructors

Name | Description
SnapToIntervalExtension | Initializes a new instance of the SnapToIntervalExtension class.

Methods

Name | Description
ProvideValue | Returns an ISnapSpecifier reflecting the interval given in the constructor. (Overrides MarkupExtension ..::. ProvideValue(IServiceProvider).)

See Also

SnapToIntervalExtension Class


SnapToIntervalExtension Constructor

[image]

Mindscape WPF Diagrams
SnapToIntervalExtension Constructor
SnapToIntervalExtension Class See Also Send Feedback
Initializes a new instance of the SnapToIntervalExtension class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SnapToIntervalExtension(
    double interval
)
Visual Basic (Declaration)
Public Sub New ( _
    interval As Double _
)

Parameters

interval
Type: System..::.Double
The interval between snap lines.

See Also

SnapToIntervalExtension Class


SnapToIntervalExtension Methods

[image] [image]

Mindscape WPF Diagrams
SnapToIntervalExtension Methods
SnapToIntervalExtension Class See Also Send Feedback

The SnapToIntervalExtension type exposes the following members.

Methods

Name | Description
ProvideValue | Returns an ISnapSpecifier reflecting the interval given in the constructor. (Overrides MarkupExtension ..::. ProvideValue(IServiceProvider).)

See Also

SnapToIntervalExtension Class


ProvideValue Method

[image]

Mindscape WPF Diagrams
SnapToIntervalExtension..::.ProvideValue Method
SnapToIntervalExtension Class See Also Send Feedback
Returns an ISnapSpecifier reflecting the interval given in the constructor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override Object ProvideValue(
    IServiceProvider serviceProvider
)
Visual Basic (Declaration)
Public Overrides Function ProvideValue ( _
    serviceProvider As IServiceProvider _
) As Object

Parameters

serviceProvider
Type: System..::.IServiceProvider
Object that can provide services for the markup extension.

Return Value

An ISnapSpecifier for the interval given in the constructor.

See Also

SnapToIntervalExtension Class


SnapToIntervalSnapSpecifier Class

[image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier Class
Members See Also Send Feedback
Represents an ISnapSpecifier which snaps a coordinate to a regular interval.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class SnapToIntervalSnapSpecifier : DependencyObject, ISnapSpecifier
Visual Basic (Declaration)
Public Class SnapToIntervalSnapSpecifier _
    Inherits DependencyObject _
    Implements ISnapSpecifier

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
Mindscape.WpfDiagramming.Foundation..::.SnapToIntervalSnapSpecifier

See Also

SnapToIntervalSnapSpecifier Members


SnapToIntervalSnapSpecifier Members

[image] [image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier Members
SnapToIntervalSnapSpecifier Class Constructors Methods Fields Properties See Also Send Feedback

The SnapToIntervalSnapSpecifier type exposes the following members.

Constructors

Name | Description
SnapToIntervalSnapSpecifier |

Methods

Name | Description
GetGuidelines | Gets snap positions for drawing guidelines.
GetSnappedValue | Gets the snapped value of a coordinate.

Fields

Name | Description
IntervalProperty | Identifies the Interval property.

Properties

Name | Description
Interval | Gets or sets the interval. This is a dependency property.

See Also

SnapToIntervalSnapSpecifier Class


SnapToIntervalSnapSpecifier Constructor

[image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier Constructor
SnapToIntervalSnapSpecifier Class See Also Send Feedback
Initializes a new instance of the SnapToIntervalSnapSpecifier class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public SnapToIntervalSnapSpecifier()
Visual Basic (Declaration)
Public Sub New

See Also

SnapToIntervalSnapSpecifier Class


SnapToIntervalSnapSpecifier Fields

[image] [image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier Fields
SnapToIntervalSnapSpecifier Class See Also Send Feedback

The SnapToIntervalSnapSpecifier type exposes the following members.

Fields

Name | Description
IntervalProperty | Identifies the Interval property.

See Also

SnapToIntervalSnapSpecifier Class


IntervalProperty Field

[image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier..::.IntervalProperty Field
SnapToIntervalSnapSpecifier Class See Also Send Feedback
Identifies the Interval property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IntervalProperty
Visual Basic (Declaration)
Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

SnapToIntervalSnapSpecifier Class


SnapToIntervalSnapSpecifier Methods

[image] [image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier Methods
SnapToIntervalSnapSpecifier Class See Also Send Feedback

The SnapToIntervalSnapSpecifier type exposes the following members.

Methods

Name | Description
GetGuidelines | Gets snap positions for drawing guidelines.
GetSnappedValue | Gets the snapped value of a coordinate.

See Also

SnapToIntervalSnapSpecifier Class


GetGuidelines Method

[image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier..::.GetGuidelines Method
SnapToIntervalSnapSpecifier Class See Also Send Feedback
Gets snap positions for drawing guidelines.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IEnumerable<double> GetGuidelines(
    double startValue,
    double endValue
)
Visual Basic (Declaration)
Public Function GetGuidelines ( _
    startValue As Double, _
    endValue As Double _
) As IEnumerable(Of Double)

Parameters

startValue
Type: System..::.Double
A value below which guidelines are not required.
endValue
Type: System..::.Double
A value above which guidelines are not required.

Return Value

The set of snap values within the given range.

Implements

ISnapSpecifier..::.GetGuidelines(Double, Double)

See Also

SnapToIntervalSnapSpecifier Class


GetSnappedValue Method

[image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier..::.GetSnappedValue Method
SnapToIntervalSnapSpecifier Class See Also Send Feedback
Gets the snapped value of a coordinate.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double GetSnappedValue(
    double value
)
Visual Basic (Declaration)
Public Function GetSnappedValue ( _
    value As Double _
) As Double

Parameters

value
Type: System..::.Double
The original value of the coordinate.

Return Value

The result of snapping the coordinate.

Implements

ISnapSpecifier..::.GetSnappedValue(Double)

See Also

SnapToIntervalSnapSpecifier Class


SnapToIntervalSnapSpecifier Properties

[image] [image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier Properties
SnapToIntervalSnapSpecifier Class See Also Send Feedback

The SnapToIntervalSnapSpecifier type exposes the following members.

Properties

Name | Description
Interval | Gets or sets the interval. This is a dependency property.

See Also

SnapToIntervalSnapSpecifier Class


Interval Property

[image]

Mindscape WPF Diagrams
SnapToIntervalSnapSpecifier..::.Interval Property
SnapToIntervalSnapSpecifier Class See Also Send Feedback
Gets or sets the interval. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Interval { get; set; }
Visual Basic (Declaration)
Public Property Interval As Double

Remarks

Dependency Property Information
Identifier field | IntervalProperty
Metadata properties set to true | None

See Also

SnapToIntervalSnapSpecifier Class


StraightLinePathfinder Class

[image]

Mindscape WPF Diagrams
StraightLinePathfinder Class
Members See Also Send Feedback
Determines a path for an IDiagramConnection using a straight line from the start to the end of the connection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StraightLinePathfinder : IPathfinder
Visual Basic (Declaration)
Public Class StraightLinePathfinder _
    Implements IPathfinder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.StraightLinePathfinder

See Also

StraightLinePathfinder Members


StraightLinePathfinder Members

[image] [image]

Mindscape WPF Diagrams
StraightLinePathfinder Members
StraightLinePathfinder Class Constructors Methods Properties See Also Send Feedback

The StraightLinePathfinder type exposes the following members.

Constructors

Name | Description
StraightLinePathfinder |

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection.

Properties

Name | Description
Buffer | Gets or sets a length to be added, entering the connection point at right angles, at each end of the connection. This is useful if the connection displays arrowheads, as it ensures the arrow abuts cleanly to the connected element instead of entering at an angle.
Instance | Gets an instance of the StraightLinePathfinder class.

See Also

StraightLinePathfinder Class


StraightLinePathfinder Constructor

[image]

Mindscape WPF Diagrams
StraightLinePathfinder Constructor
StraightLinePathfinder Class See Also Send Feedback
Initializes a new instance of the StraightLinePathfinder class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StraightLinePathfinder()
Visual Basic (Declaration)
Public Sub New

See Also

StraightLinePathfinder Class


StraightLinePathfinder Methods

[image] [image]

Mindscape WPF Diagrams
StraightLinePathfinder Methods
StraightLinePathfinder Class See Also Send Feedback

The StraightLinePathfinder type exposes the following members.

Methods

Name | Description
FindPath | Determines a path for the given IDiagramConnection.

See Also

StraightLinePathfinder Class


FindPath Method

[image]

Mindscape WPF Diagrams
StraightLinePathfinder..::.FindPath Method
StraightLinePathfinder Class See Also Send Feedback
Determines a path for the given IDiagramConnection.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ReadOnlyCollection<Point> FindPath(
    IDiagramConnection connection,
    IDiagramModel diagram
)
Visual Basic (Declaration)
Public Function FindPath ( _
    connection As IDiagramConnection, _
    diagram As IDiagramModel _
) As ReadOnlyCollection(Of Point)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to find a path for.
diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
An IDiagramModel used to obtain other nodes and connections if needed

Return Value

A collection of via points representing the plotted course of the connection, or null to indicate that the connection path did not need to be refreshed.

Implements

IPathfinder..::.FindPath(IDiagramConnection, IDiagramModel)

See Also

StraightLinePathfinder Class


StraightLinePathfinder Properties

[image] [image]

Mindscape WPF Diagrams
StraightLinePathfinder Properties
StraightLinePathfinder Class See Also Send Feedback

The StraightLinePathfinder type exposes the following members.

Properties

Name | Description
Buffer | Gets or sets a length to be added, entering the connection point at right angles, at each end of the connection. This is useful if the connection displays arrowheads, as it ensures the arrow abuts cleanly to the connected element instead of entering at an angle.
Instance | Gets an instance of the StraightLinePathfinder class.

See Also

StraightLinePathfinder Class


Buffer Property

[image]

Mindscape WPF Diagrams
StraightLinePathfinder..::.Buffer Property
StraightLinePathfinder Class See Also Send Feedback
Gets or sets a length to be added, entering the connection point at right angles, at each end of the connection. This is useful if the connection displays arrowheads, as it ensures the arrow abuts cleanly to the connected element instead of entering at an angle.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Buffer { get; set; }
Visual Basic (Declaration)
Public Property Buffer As Double

See Also

StraightLinePathfinder Class


Instance Property

[image]

Mindscape WPF Diagrams
StraightLinePathfinder..::.Instance Property
StraightLinePathfinder Class See Also Send Feedback
Gets an instance of the StraightLinePathfinder class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static StraightLinePathfinder Instance { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Instance As StraightLinePathfinder

See Also

StraightLinePathfinder Class


ThicknessToDoubleConverter Class

[image]

Mindscape WPF Diagrams
ThicknessToDoubleConverter Class
Members See Also Send Feedback
Converts a Thickness to a double by returning the Thickness.Top property value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ThicknessToDoubleConverter : IValueConverter
Visual Basic (Declaration)
Public Class ThicknessToDoubleConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ThicknessToDoubleConverter

See Also

ThicknessToDoubleConverter Members


ThicknessToDoubleConverter Members

[image] [image]

Mindscape WPF Diagrams
ThicknessToDoubleConverter Members
ThicknessToDoubleConverter Class Constructors Methods See Also Send Feedback

The ThicknessToDoubleConverter type exposes the following members.

Constructors

Name | Description
ThicknessToDoubleConverter |

Methods

Name | Description
Convert | Converts a Thickness to a double by returning the Thickness.Top property value.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

ThicknessToDoubleConverter Class


ThicknessToDoubleConverter Constructor

[image]

Mindscape WPF Diagrams
ThicknessToDoubleConverter Constructor
ThicknessToDoubleConverter Class See Also Send Feedback
Initializes a new instance of the ThicknessToDoubleConverter class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ThicknessToDoubleConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ThicknessToDoubleConverter Class


ThicknessToDoubleConverter Methods

[image] [image]

Mindscape WPF Diagrams
ThicknessToDoubleConverter Methods
ThicknessToDoubleConverter Class See Also Send Feedback

The ThicknessToDoubleConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a Thickness to a double by returning the Thickness.Top property value.
ConvertBack | Converts a value from a binding target for writing to a binding source.

See Also

ThicknessToDoubleConverter Class


Convert Method

[image]

Mindscape WPF Diagrams
ThicknessToDoubleConverter..::.Convert Method
ThicknessToDoubleConverter Class See Also Send Feedback
Converts a Thickness to a double by returning the Thickness.Top property value.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The Thickness value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

The Thickness.Top property value of the given Thickness.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ThicknessToDoubleConverter Class


ConvertBack Method

[image]

Mindscape WPF Diagrams
ThicknessToDoubleConverter..::.ConvertBack Method
ThicknessToDoubleConverter Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ThicknessToDoubleConverter Class


ToolCursorAction(TTool) Class

[image]

Mindscape WPF Diagrams
ToolCursorAction<(Of <(TTool>)>) Class
Members See Also Send Feedback
Represents the cursor action when a toolbox item is selected.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class ToolCursorAction<TTool> : CursorAction where TTool : IDiagramToolboxTool
Visual Basic (Declaration)
Public MustInherit Class ToolCursorAction(Of TTool As IDiagramToolboxTool) _
    Inherits CursorAction

Type Parameters

TTool
The type of tool selected.

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.CursorAction
Mindscape.WpfDiagramming.Foundation..::.ToolCursorAction<(Of <(TTool>)>)
Mindscape.WpfDiagramming.Foundation..::.CreateConnectionCursorAction

See Also

ToolCursorAction<(Of <(TTool>)>) Members


ToolCursorAction(TTool) Members

[image] [image]

Mindscape WPF Diagrams
ToolCursorAction<(Of <(TTool>)>) Members
ToolCursorAction<(Of <(TTool>)>) Class Constructors Methods Properties See Also Send Feedback

The ToolCursorAction<(Of <(TTool>)>) type exposes the following members.

Constructors

Name | Description
ToolCursorAction<(Of <(TTool>)>) | Initializes a new instance of the ToolCursorAction<(Of <(TTool>)>) class.

Methods

Name | Description
Discharge | Disassociates the toolbox item from the cursor. (Overrides CursorAction ..::. Discharge()()().)
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action. (Inherited from CursorAction.)
ExecuteCore | When overridden in a derived class, executes the cursor action. (Inherited from CursorAction.)

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction. (Inherited from CursorAction.)
Tool | Gets the tool associated with the cursor action.

See Also

ToolCursorAction<(Of <(TTool>)>) Class


ToolCursorAction(TTool) Constructor

[image]

Mindscape WPF Diagrams
ToolCursorAction<(Of <(TTool>)>) Constructor
ToolCursorAction<(Of <(TTool>)>) Class See Also Send Feedback
Initializes a new instance of the ToolCursorAction<(Of <(TTool>)>) class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected ToolCursorAction(
    TTool tool
)
Visual Basic (Declaration)
Protected Sub New ( _
    tool As TTool _
)

Parameters

tool
Type: TTool
The tool associated with the cursor action.

See Also

ToolCursorAction<(Of <(TTool>)>) Class


ToolCursorAction(TTool) Methods

[image] [image]

Mindscape WPF Diagrams
ToolCursorAction<(Of <(TTool>)>) Methods
ToolCursorAction<(Of <(TTool>)>) Class See Also Send Feedback

The ToolCursorAction<(Of <(TTool>)>) type exposes the following members.

Methods

Name | Description
Discharge | Disassociates the toolbox item from the cursor. (Overrides CursorAction ..::. Discharge()()().)
Execute | Executes the cursor action. This is typically called when the mouse is released after a click or press-and-drag action. (Inherited from CursorAction.)
ExecuteCore | When overridden in a derived class, executes the cursor action. (Inherited from CursorAction.)

See Also

ToolCursorAction<(Of <(TTool>)>) Class


Discharge Method

[image]

Mindscape WPF Diagrams
ToolCursorAction<(Of <(TTool>)>)..::.Discharge Method
ToolCursorAction<(Of <(TTool>)>) Class See Also Send Feedback
Disassociates the toolbox item from the cursor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Discharge()
Visual Basic (Declaration)
Public Overrides Sub Discharge

See Also

ToolCursorAction<(Of <(TTool>)>) Class


ToolCursorAction(TTool) Properties

[image] [image]

Mindscape WPF Diagrams
ToolCursorAction<(Of <(TTool>)>) Properties
ToolCursorAction<(Of <(TTool>)>) Class See Also Send Feedback

The ToolCursorAction<(Of <(TTool>)>) type exposes the following members.

Properties

Name | Description
CursorActionType | Gets the type of operation performed by this CursorAction. (Inherited from CursorAction.)
Tool | Gets the tool associated with the cursor action.

See Also

ToolCursorAction<(Of <(TTool>)>) Class


Tool Property

[image]

Mindscape WPF Diagrams
ToolCursorAction<(Of <(TTool>)>)..::.Tool Property
ToolCursorAction<(Of <(TTool>)>) Class See Also Send Feedback
Gets the tool associated with the cursor action.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TTool Tool { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tool As TTool

See Also

ToolCursorAction<(Of <(TTool>)>) Class


ToolDroppedEventArgs Class

[image]

Mindscape WPF Diagrams
ToolDroppedEventArgs Class
Members See Also Send Feedback
Provides information about the ToolDropped event of a ToolThumb control.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ToolDroppedEventArgs : RoutedEventArgs
Visual Basic (Declaration)
Public Class ToolDroppedEventArgs _
    Inherits RoutedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.Windows..::.RoutedEventArgs
Mindscape.WpfDiagramming.Foundation..::.ToolDroppedEventArgs

See Also

ToolDroppedEventArgs Members


ToolDroppedEventArgs Members

[image] [image]

Mindscape WPF Diagrams
ToolDroppedEventArgs Members
ToolDroppedEventArgs Class Constructors Properties See Also Send Feedback

The ToolDroppedEventArgs type exposes the following members.

Constructors

Name | Description
ToolDroppedEventArgs | Overloaded.

Properties

Name | Description
Bounds | Gets the bounds of the drop, in thumb coordinates.
DroppedOn | Gets the element on which the tool was dropped. In the case of a drag-size, this is the element where the drag-size began.

See Also

ToolDroppedEventArgs Class


ToolDroppedEventArgs Constructor

[image] [image]

Mindscape WPF Diagrams
ToolDroppedEventArgs Constructor
ToolDroppedEventArgs Class See Also Send Feedback

Overload List

Name | Description
ToolDroppedEventArgs(IInputElement, Rect) | Initializes a new instance of the ToolDroppedEventArgs class.
ToolDroppedEventArgs(IInputElement, Double, Double, Double, Double) | Initializes a new instance of the ToolDroppedEventArgs class.

See Also

ToolDroppedEventArgs Class
ToolDroppedEventArgs Members


ToolDroppedEventArgs Constructor (IInputElement, Rect)

[image]

Mindscape WPF Diagrams
ToolDroppedEventArgs Constructor (IInputElement, Rect)
ToolDroppedEventArgs Class See Also Send Feedback
Initializes a new instance of the ToolDroppedEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ToolDroppedEventArgs(
    IInputElement droppedOn,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub New ( _
    droppedOn As IInputElement, _
    bounds As Rect _
)

Parameters

droppedOn
Type: System.Windows..::.IInputElement
The element on which the tool was dropped.
bounds
Type: System.Windows..::.Rect
The bounds of the drop, in thumb coordinates.

See Also

ToolDroppedEventArgs Class
ToolDroppedEventArgs Overload


ToolDroppedEventArgs Constructor (IInputElement, Double, Double, Double, Double)

[image]

Mindscape WPF Diagrams
ToolDroppedEventArgs Constructor (IInputElement, Double, Double, Double, Double)
ToolDroppedEventArgs Class See Also Send Feedback
Initializes a new instance of the ToolDroppedEventArgs class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ToolDroppedEventArgs(
    IInputElement droppedOn,
    double left,
    double top,
    double width,
    double height
)
Visual Basic (Declaration)
Public Sub New ( _
    droppedOn As IInputElement, _
    left As Double, _
    top As Double, _
    width As Double, _
    height As Double _
)

Parameters

droppedOn
Type: System.Windows..::.IInputElement
The element on which the tool is being dropped.
left
Type: System..::.Double
The x-coordinate of the drop bounds.
top
Type: System..::.Double
The y-coordinate of the drop bounds.
width
Type: System..::.Double
The width of the drop bounds.
height
Type: System..::.Double
The height of the drop bounds.

See Also

ToolDroppedEventArgs Class
ToolDroppedEventArgs Overload


ToolDroppedEventArgs Properties

[image] [image]

Mindscape WPF Diagrams
ToolDroppedEventArgs Properties
ToolDroppedEventArgs Class See Also Send Feedback

The ToolDroppedEventArgs type exposes the following members.

Properties

Name | Description
Bounds | Gets the bounds of the drop, in thumb coordinates.
DroppedOn | Gets the element on which the tool was dropped. In the case of a drag-size, this is the element where the drag-size began.

See Also

ToolDroppedEventArgs Class


Bounds Property

[image]

Mindscape WPF Diagrams
ToolDroppedEventArgs..::.Bounds Property
ToolDroppedEventArgs Class See Also Send Feedback
Gets the bounds of the drop, in thumb coordinates.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Rect Bounds { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bounds As Rect

See Also

ToolDroppedEventArgs Class


DroppedOn Property

[image]

Mindscape WPF Diagrams
ToolDroppedEventArgs..::.DroppedOn Property
ToolDroppedEventArgs Class See Also Send Feedback
Gets the element on which the tool was dropped. In the case of a drag-size, this is the element where the drag-size began.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IInputElement DroppedOn { get; }
Visual Basic (Declaration)
Public ReadOnly Property DroppedOn As IInputElement

See Also

ToolDroppedEventArgs Class


ToolThumb Class

[image]

Mindscape WPF Diagrams
ToolThumb Class
Members See Also Send Feedback
Represents a Thumb that, in addition to being dragged, can be clicked to "charge" the cursor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ToolThumb : Thumb
Visual Basic (Declaration)
Public Class ToolThumb _
    Inherits Thumb

Remarks

This control is used in the implementation of diagram tools and is not intended for use outside that context.

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.Thumb
Mindscape.WpfDiagramming.Foundation..::.ToolThumb

See Also

ToolThumb Members


ToolThumb Members

[image] [image]

Mindscape WPF Diagrams
ToolThumb Members
ToolThumb Class Constructors Fields Properties Events See Also Send Feedback

The ToolThumb type exposes the following members.

Constructors

Name | Description
ToolThumb | Initializes a new instance of the ToolThumb class.

Fields

Name | Description
AllowToolDragProperty | Identifies the AllowToolDrag property.
CursorVisualProperty | Identifies the CursorVisual property.
IsSquareSizingProperty | Identifies the IsSquareSizing property.
QueryDropPositionEvent | Identifies the QueryDropPosition routed event.
ToolDroppedEvent | Identifies the ToolDropped routed event.

Properties

Name | Description
AllowToolDrag | Gets or sets whether the tool may be dragged. If this is false, the tool may be used only by selecting it, and then clicking or click-dragging. The default is true. This is a dependency property.
CursorVisual | Gets or sets the Visual displayed while dragging or when the cursor is charged. This is a dependency property.
IsSquareSizing | Gets or sets whether or not this ToolThumb is in 'square sizing mode'. In square sizing mode, Dragging a charged tool on a DiagramSurface will change the width and height of the cursor visual by the same amounts. This is a dependency property.

Events

Name | Description
QueryDropPosition | Occurs when QueryDropPosition happens.
ToolDropped | Occurs when a user drags the tool across an area using a charged cursor.

See Also

ToolThumb Class


ToolThumb Constructor

[image]

Mindscape WPF Diagrams
ToolThumb Constructor
ToolThumb Class See Also Send Feedback
Initializes a new instance of the ToolThumb class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ToolThumb()
Visual Basic (Declaration)
Public Sub New

See Also

ToolThumb Class


ToolThumb Fields

[image] [image]

Mindscape WPF Diagrams
ToolThumb Fields
ToolThumb Class See Also Send Feedback

The ToolThumb type exposes the following members.

Fields

Name | Description
AllowToolDragProperty | Identifies the AllowToolDrag property.
CursorVisualProperty | Identifies the CursorVisual property.
IsSquareSizingProperty | Identifies the IsSquareSizing property.
QueryDropPositionEvent | Identifies the QueryDropPosition routed event.
ToolDroppedEvent | Identifies the ToolDropped routed event.

See Also

ToolThumb Class


AllowToolDragProperty Field

[image]

Mindscape WPF Diagrams
ToolThumb..::.AllowToolDragProperty Field
ToolThumb Class See Also Send Feedback
Identifies the AllowToolDrag property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty AllowToolDragProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowToolDragProperty As DependencyProperty

See Also

ToolThumb Class


CursorVisualProperty Field

[image]

Mindscape WPF Diagrams
ToolThumb..::.CursorVisualProperty Field
ToolThumb Class See Also Send Feedback
Identifies the CursorVisual property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty CursorVisualProperty
Visual Basic (Declaration)
Public Shared ReadOnly CursorVisualProperty As DependencyProperty

See Also

ToolThumb Class


IsSquareSizingProperty Field

[image]

Mindscape WPF Diagrams
ToolThumb..::.IsSquareSizingProperty Field
ToolThumb Class See Also Send Feedback
Identifies the IsSquareSizing property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly DependencyProperty IsSquareSizingProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSquareSizingProperty As DependencyProperty

See Also

ToolThumb Class


QueryDropPositionEvent Field

[image]

Mindscape WPF Diagrams
ToolThumb..::.QueryDropPositionEvent Field
ToolThumb Class See Also Send Feedback
Identifies the QueryDropPosition routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent QueryDropPositionEvent
Visual Basic (Declaration)
Public Shared ReadOnly QueryDropPositionEvent As RoutedEvent

See Also

ToolThumb Class


ToolDroppedEvent Field

[image]

Mindscape WPF Diagrams
ToolThumb..::.ToolDroppedEvent Field
ToolThumb Class See Also Send Feedback
Identifies the ToolDropped routed event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static readonly RoutedEvent ToolDroppedEvent
Visual Basic (Declaration)
Public Shared ReadOnly ToolDroppedEvent As RoutedEvent

See Also

ToolThumb Class


ToolThumb Properties

[image] [image]

Mindscape WPF Diagrams
ToolThumb Properties
ToolThumb Class See Also Send Feedback

The ToolThumb type exposes the following members.

Properties

Name | Description
AllowToolDrag | Gets or sets whether the tool may be dragged. If this is false, the tool may be used only by selecting it, and then clicking or click-dragging. The default is true. This is a dependency property.
CursorVisual | Gets or sets the Visual displayed while dragging or when the cursor is charged. This is a dependency property.
IsSquareSizing | Gets or sets whether or not this ToolThumb is in 'square sizing mode'. In square sizing mode, Dragging a charged tool on a DiagramSurface will change the width and height of the cursor visual by the same amounts. This is a dependency property.

See Also

ToolThumb Class


AllowToolDrag Property

[image]

Mindscape WPF Diagrams
ToolThumb..::.AllowToolDrag Property
ToolThumb Class See Also Send Feedback
Gets or sets whether the tool may be dragged. If this is false, the tool may be used only by selecting it, and then clicking or click-dragging. The default is true. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool AllowToolDrag { get; set; }
Visual Basic (Declaration)
Public Property AllowToolDrag As Boolean

Remarks

Dependency Property Information
Identifier field | AllowToolDragProperty
Metadata properties set to true | None

See Also

ToolThumb Class


CursorVisual Property

[image]

Mindscape WPF Diagrams
ToolThumb..::.CursorVisual Property
ToolThumb Class See Also Send Feedback
Gets or sets the Visual displayed while dragging or when the cursor is charged. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Visual CursorVisual { get; set; }
Visual Basic (Declaration)
Public Property CursorVisual As Visual

Remarks

Dependency Property Information
Identifier field | CursorVisualProperty
Metadata properties set to true | None

See Also

ToolThumb Class


IsSquareSizing Property

[image]

Mindscape WPF Diagrams
ToolThumb..::.IsSquareSizing Property
ToolThumb Class See Also Send Feedback
Gets or sets whether or not this ToolThumb is in 'square sizing mode'. In square sizing mode, Dragging a charged tool on a DiagramSurface will change the width and height of the cursor visual by the same amounts. This is a dependency property.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsSquareSizing { get; set; }
Visual Basic (Declaration)
Public Property IsSquareSizing As Boolean

Remarks

Dependency Property Information
Identifier field | IsSquareSizingProperty
Metadata properties set to false | None

See Also

ToolThumb Class


ToolThumb Events

[image] [image]

Mindscape WPF Diagrams
ToolThumb Events
ToolThumb Class See Also Send Feedback

The ToolThumb type exposes the following members.

Events

Name | Description
QueryDropPosition | Occurs when QueryDropPosition happens.
ToolDropped | Occurs when a user drags the tool across an area using a charged cursor.

See Also

ToolThumb Class


QueryDropPosition Event

[image]

Mindscape WPF Diagrams
ToolThumb..::.QueryDropPosition Event
ToolThumb Class See Also Send Feedback
Occurs when QueryDropPosition happens.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<QueryDropPositionEventArgs> QueryDropPosition
Visual Basic (Declaration)
Public Event QueryDropPosition As EventHandler(Of QueryDropPositionEventArgs)

See Also

ToolThumb Class


ToolDropped Event

[image]

Mindscape WPF Diagrams
ToolThumb..::.ToolDropped Event
ToolThumb Class See Also Send Feedback
Occurs when a user drags the tool across an area using a charged cursor.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event EventHandler<ToolDroppedEventArgs> ToolDropped
Visual Basic (Declaration)
Public Event ToolDropped As EventHandler(Of ToolDroppedEventArgs)

See Also

ToolThumb Class


TypeEdgeCalculator Class

[image]

Mindscape WPF Diagrams
TypeEdgeCalculator Class
Members See Also Send Feedback
Maps a data type and an Edge to an IPositionCalculator.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class TypeEdgeCalculator
Visual Basic (Declaration)
Public Class TypeEdgeCalculator

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.TypeEdgeCalculator

See Also

TypeEdgeCalculator Members


TypeEdgeCalculator Members

[image] [image]

Mindscape WPF Diagrams
TypeEdgeCalculator Members
TypeEdgeCalculator Class Constructors Methods Properties See Also Send Feedback

The TypeEdgeCalculator type exposes the following members.

Constructors

Name | Description
TypeEdgeCalculator |

Methods

Name | Description
Matches | Returns true if the given object matches the criterion of being mapped to the calculator.

Properties

Name | Description
DataType | The data type to which the IPositionCalculator is for.
Edge | The Edge of the IDiagramConnectionPoint that the IPositionCalculator is for.
Index | Gets or sets the index identifier used for selecting the calculator.
PositionCalculator | The IPositionCalculator that is mapped to the DataType and Edge properties.

See Also

TypeEdgeCalculator Class


TypeEdgeCalculator Constructor

[image]

Mindscape WPF Diagrams
TypeEdgeCalculator Constructor
TypeEdgeCalculator Class See Also Send Feedback
Initializes a new instance of the TypeEdgeCalculator class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TypeEdgeCalculator()
Visual Basic (Declaration)
Public Sub New

See Also

TypeEdgeCalculator Class


TypeEdgeCalculator Methods

[image] [image]

Mindscape WPF Diagrams
TypeEdgeCalculator Methods
TypeEdgeCalculator Class See Also Send Feedback

The TypeEdgeCalculator type exposes the following members.

Methods

Name | Description
Matches | Returns true if the given object matches the criterion of being mapped to the calculator.

See Also

TypeEdgeCalculator Class


Matches Method

[image]

Mindscape WPF Diagrams
TypeEdgeCalculator..::.Matches Method
TypeEdgeCalculator Class See Also Send Feedback
Returns true if the given object matches the criterion of being mapped to the calculator.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool Matches(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Matches ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The object to test.

Return Value

True if the given object matches the mapping criterion. False otherwise.

See Also

TypeEdgeCalculator Class


TypeEdgeCalculator Properties

[image] [image]

Mindscape WPF Diagrams
TypeEdgeCalculator Properties
TypeEdgeCalculator Class See Also Send Feedback

The TypeEdgeCalculator type exposes the following members.

Properties

Name | Description
DataType | The data type to which the IPositionCalculator is for.
Edge | The Edge of the IDiagramConnectionPoint that the IPositionCalculator is for.
Index | Gets or sets the index identifier used for selecting the calculator.
PositionCalculator | The IPositionCalculator that is mapped to the DataType and Edge properties.

See Also

TypeEdgeCalculator Class


DataType Property

[image]

Mindscape WPF Diagrams
TypeEdgeCalculator..::.DataType Property
TypeEdgeCalculator Class See Also Send Feedback
The data type to which the IPositionCalculator is for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type

See Also

TypeEdgeCalculator Class


Edge Property

[image]

Mindscape WPF Diagrams
TypeEdgeCalculator..::.Edge Property
TypeEdgeCalculator Class See Also Send Feedback
The Edge of the IDiagramConnectionPoint that the IPositionCalculator is for.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Edge Edge { get; set; }
Visual Basic (Declaration)
Public Property Edge As Edge

See Also

TypeEdgeCalculator Class


Index Property

[image]

Mindscape WPF Diagrams
TypeEdgeCalculator..::.Index Property
TypeEdgeCalculator Class See Also Send Feedback
Gets or sets the index identifier used for selecting the calculator.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer

See Also

TypeEdgeCalculator Class


PositionCalculator Property

[image]

Mindscape WPF Diagrams
TypeEdgeCalculator..::.PositionCalculator Property
TypeEdgeCalculator Class See Also Send Feedback
The IPositionCalculator that is mapped to the DataType and Edge properties.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IPositionCalculator PositionCalculator { get; set; }
Visual Basic (Declaration)
Public Property PositionCalculator As IPositionCalculator

See Also

TypeEdgeCalculator Class


TypeStyle Class

[image]

Mindscape WPF Diagrams
TypeStyle Class
Members See Also Send Feedback
Maps a data type to a Style.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class TypeStyle : IStyleMatcher
Visual Basic (Declaration)
Public Class TypeStyle _
    Implements IStyleMatcher

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.TypeStyle

See Also

TypeStyle Members


TypeStyle Members

[image] [image]

Mindscape WPF Diagrams
TypeStyle Members
TypeStyle Class Constructors Methods Properties See Also Send Feedback

The TypeStyle type exposes the following members.

Constructors

Name | Description
TypeStyle |

Methods

Name | Description
Matches | Tests whether an object matches the criterion for the Style.

Properties

Name | Description
DataType | The data type to which the Style property applies.
Style | Gets or sets the Style to be used for the specified DataType.

See Also

TypeStyle Class


TypeStyle Constructor

[image]

Mindscape WPF Diagrams
TypeStyle Constructor
TypeStyle Class See Also Send Feedback
Initializes a new instance of the TypeStyle class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TypeStyle()
Visual Basic (Declaration)
Public Sub New

See Also

TypeStyle Class


TypeStyle Methods

[image] [image]

Mindscape WPF Diagrams
TypeStyle Methods
TypeStyle Class See Also Send Feedback

The TypeStyle type exposes the following members.

Methods

Name | Description
Matches | Tests whether an object matches the criterion for the Style.

See Also

TypeStyle Class


Matches Method

[image]

Mindscape WPF Diagrams
TypeStyle..::.Matches Method
TypeStyle Class See Also Send Feedback
Tests whether an object matches the criterion for the Style.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool Matches(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Matches ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The object to be tested.

Return Value

true if the object matches the criterion; otherwise false.

Implements

IStyleMatcher..::.Matches(Object)

See Also

TypeStyle Class


TypeStyle Properties

[image] [image]

Mindscape WPF Diagrams
TypeStyle Properties
TypeStyle Class See Also Send Feedback

The TypeStyle type exposes the following members.

Properties

Name | Description
DataType | The data type to which the Style property applies.
Style | Gets or sets the Style to be used for the specified DataType.

See Also

TypeStyle Class


DataType Property

[image]

Mindscape WPF Diagrams
TypeStyle..::.DataType Property
TypeStyle Class See Also Send Feedback
The data type to which the Style property applies.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type

See Also

TypeStyle Class


Style Property

[image]

Mindscape WPF Diagrams
TypeStyle..::.Style Property
TypeStyle Class See Also Send Feedback
Gets or sets the Style to be used for the specified DataType.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style Style { get; set; }
Visual Basic (Declaration)
Public Property Style As Style

Implements

IStyleMatcher..::.Style

See Also

TypeStyle Class


TypeStyleSelector Class

[image]

Mindscape WPF Diagrams
TypeStyleSelector Class
Members See Also Send Feedback
Selects a style based on the type of the object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class TypeStyleSelector : TypeStyleSelectorBase
Visual Basic (Declaration)
Public Class TypeStyleSelector _
    Inherits TypeStyleSelectorBase

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingStyleSelector
Mindscape.WpfDiagramming.Foundation..::.TypeStyleSelectorBase
Mindscape.WpfDiagramming.Foundation..::.TypeStyleSelector

See Also

TypeStyleSelector Members


TypeStyleSelector Members

[image] [image]

Mindscape WPF Diagrams
TypeStyleSelector Members
TypeStyleSelector Class Constructors Methods Properties See Also Send Feedback

The TypeStyleSelector type exposes the following members.

Constructors

Name | Description
TypeStyleSelector |

Methods

Name | Description
GetSelectionType | Gets the type to be used in selecting a template for an item, being the CLR type of the object itself. (Overrides TypeStyleSelectorBase ..::. GetSelectionType(Object).)
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Returns a DataTemplate according to the type of the item. (Inherited from TypeStyleSelectorBase.)

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector. (Inherited from DelegatingStyleSelector.)
DefaultStyle | Gets or sets the default style. (Inherited from TypeStyleSelectorBase.)
TypeStyles | Gets the list of type-specific styles. (Inherited from TypeStyleSelectorBase.)

See Also

TypeStyleSelector Class


TypeStyleSelector Constructor

[image]

Mindscape WPF Diagrams
TypeStyleSelector Constructor
TypeStyleSelector Class See Also Send Feedback
Initializes a new instance of the TypeStyleSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TypeStyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

TypeStyleSelector Class


TypeStyleSelector Methods

[image] [image]

Mindscape WPF Diagrams
TypeStyleSelector Methods
TypeStyleSelector Class See Also Send Feedback

The TypeStyleSelector type exposes the following members.

Methods

Name | Description
GetSelectionType | Gets the type to be used in selecting a template for an item, being the CLR type of the object itself. (Overrides TypeStyleSelectorBase ..::. GetSelectionType(Object).)
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Returns a DataTemplate according to the type of the item. (Inherited from TypeStyleSelectorBase.)

See Also

TypeStyleSelector Class


GetSelectionType Method

[image]

Mindscape WPF Diagrams
TypeStyleSelector..::.GetSelectionType Method
TypeStyleSelector Class See Also Send Feedback
Gets the type to be used in selecting a template for an item, being the CLR type of the object itself.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Type GetSelectionType(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function GetSelectionType ( _
    item As Object _
) As Type

Parameters

item
Type: System..::.Object
The item for which to obtain a data type.

Return Value

The data type for the item.

See Also

TypeStyleSelector Class


TypeStyleSelectorBase Class

[image]

Mindscape WPF Diagrams
TypeStyleSelectorBase Class
Members See Also Send Feedback
selects a style based on a type.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("TypeStyles")]
public abstract class TypeStyleSelectorBase : DelegatingStyleSelector
Visual Basic (Declaration)
<ContentPropertyAttribute("TypeStyles")> _
Public MustInherit Class TypeStyleSelectorBase _
    Inherits DelegatingStyleSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.StyleSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingStyleSelector
Mindscape.WpfDiagramming.Foundation..::.TypeStyleSelectorBase
Mindscape.WpfDiagramming.Foundation..::.TypeStyleSelector

See Also

TypeStyleSelectorBase Members


TypeStyleSelectorBase Members

[image] [image]

Mindscape WPF Diagrams
TypeStyleSelectorBase Members
TypeStyleSelectorBase Class Constructors Methods Properties See Also Send Feedback

The TypeStyleSelectorBase type exposes the following members.

Constructors

Name | Description
TypeStyleSelectorBase |

Methods

Name | Description
GetSelectionType | When overridden in a derived class, gets the type to be used in selecting a style for an item.
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Returns a DataTemplate according to the type of the item. (Overrides DelegatingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector. (Inherited from DelegatingStyleSelector.)
DefaultStyle | Gets or sets the default style.
TypeStyles | Gets the list of type-specific styles.

See Also

TypeStyleSelectorBase Class


TypeStyleSelectorBase Constructor

[image]

Mindscape WPF Diagrams
TypeStyleSelectorBase Constructor
TypeStyleSelectorBase Class See Also Send Feedback
Initializes a new instance of the TypeStyleSelectorBase class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected TypeStyleSelectorBase()
Visual Basic (Declaration)
Protected Sub New

See Also

TypeStyleSelectorBase Class


TypeStyleSelectorBase Methods

[image] [image]

Mindscape WPF Diagrams
TypeStyleSelectorBase Methods
TypeStyleSelectorBase Class See Also Send Feedback

The TypeStyleSelectorBase type exposes the following members.

Methods

Name | Description
GetSelectionType | When overridden in a derived class, gets the type to be used in selecting a style for an item.
SelectStyle | Returns a Style for the item. (Inherited from DelegatingStyleSelector.)
SelectStyleCore | Returns a DataTemplate according to the type of the item. (Overrides DelegatingStyleSelector ..::. SelectStyleCore(Object, DependencyObject).)

See Also

TypeStyleSelectorBase Class


GetSelectionType Method

[image]

Mindscape WPF Diagrams
TypeStyleSelectorBase..::.GetSelectionType Method
TypeStyleSelectorBase Class See Also Send Feedback
When overridden in a derived class, gets the type to be used in selecting a style for an item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract Type GetSelectionType(
    Object item
)
Visual Basic (Declaration)
Protected MustOverride Function GetSelectionType ( _
    item As Object _
) As Type

Parameters

item
Type: System..::.Object
The item for which to obtain a data type.

Return Value

The data type for the item.

Remarks

Implementations should return null to request fall-through to the default template.

See Also

TypeStyleSelectorBase Class


SelectStyleCore Method

[image]

Mindscape WPF Diagrams
TypeStyleSelectorBase..::.SelectStyleCore Method
TypeStyleSelectorBase Class See Also Send Feedback
Returns a DataTemplate according to the type of the item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override sealed Style SelectStyleCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected Overrides NotOverridable Function SelectStyleCore ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The item for which to select the style.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The style from the TypeStyles list if one matches; otherwise the DefaultStyle.

See Also

TypeStyleSelectorBase Class


TypeStyleSelectorBase Properties

[image] [image]

Mindscape WPF Diagrams
TypeStyleSelectorBase Properties
TypeStyleSelectorBase Class See Also Send Feedback

The TypeStyleSelectorBase type exposes the following members.

Properties

Name | Description
BasedOn | Gets or sets the StyleSelector on which to fall back if no style is found by this selector. (Inherited from DelegatingStyleSelector.)
DefaultStyle | Gets or sets the default style.
TypeStyles | Gets the list of type-specific styles.

See Also

TypeStyleSelectorBase Class


DefaultStyle Property

[image]

Mindscape WPF Diagrams
TypeStyleSelectorBase..::.DefaultStyle Property
TypeStyleSelectorBase Class See Also Send Feedback
Gets or sets the default style.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Style DefaultStyle { get; set; }
Visual Basic (Declaration)
Public Property DefaultStyle As Style

See Also

TypeStyleSelectorBase Class


TypeStyles Property

[image]

Mindscape WPF Diagrams
TypeStyleSelectorBase..::.TypeStyles Property
TypeStyleSelectorBase Class See Also Send Feedback
Gets the list of type-specific styles.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Collection<TypeStyle> TypeStyles { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeStyles As Collection(Of TypeStyle)

See Also

TypeStyleSelectorBase Class


TypeTemplate Class

[image]

Mindscape WPF Diagrams
TypeTemplate Class
Members See Also Send Feedback
Maps a data type to a DataTemplate.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class TypeTemplate : IDataTemplateMatcher
Visual Basic (Declaration)
Public Class TypeTemplate _
    Implements IDataTemplateMatcher

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.TypeTemplate

See Also

TypeTemplate Members


TypeTemplate Members

[image] [image]

Mindscape WPF Diagrams
TypeTemplate Members
TypeTemplate Class Constructors Methods Properties See Also Send Feedback

The TypeTemplate type exposes the following members.

Constructors

Name | Description
TypeTemplate |

Methods

Name | Description
Matches | Tests whether an object matches the criterion for this DataTemplate.

Properties

Name | Description
DataType | The data type to which the Template property applies.
Template | Gets or sets the DataTemplate to be used for the specified DataType.

See Also

TypeTemplate Class


TypeTemplate Constructor

[image]

Mindscape WPF Diagrams
TypeTemplate Constructor
TypeTemplate Class See Also Send Feedback
Initializes a new instance of the TypeTemplate class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TypeTemplate()
Visual Basic (Declaration)
Public Sub New

See Also

TypeTemplate Class


TypeTemplate Methods

[image] [image]

Mindscape WPF Diagrams
TypeTemplate Methods
TypeTemplate Class See Also Send Feedback

The TypeTemplate type exposes the following members.

Methods

Name | Description
Matches | Tests whether an object matches the criterion for this DataTemplate.

See Also

TypeTemplate Class


Matches Method

[image]

Mindscape WPF Diagrams
TypeTemplate..::.Matches Method
TypeTemplate Class See Also Send Feedback
Tests whether an object matches the criterion for this DataTemplate.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool Matches(
    Object item
)
Visual Basic (Declaration)
Public Overridable Function Matches ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The object to be tested.

Return Value

true if the object matches the criterion; otherwise false.

Implements

IDataTemplateMatcher..::.Matches(Object)

See Also

TypeTemplate Class


TypeTemplate Properties

[image] [image]

Mindscape WPF Diagrams
TypeTemplate Properties
TypeTemplate Class See Also Send Feedback

The TypeTemplate type exposes the following members.

Properties

Name | Description
DataType | The data type to which the Template property applies.
Template | Gets or sets the DataTemplate to be used for the specified DataType.

See Also

TypeTemplate Class


DataType Property

[image]

Mindscape WPF Diagrams
TypeTemplate..::.DataType Property
TypeTemplate Class See Also Send Feedback
The data type to which the Template property applies.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type

See Also

TypeTemplate Class


Template Property

[image]

Mindscape WPF Diagrams
TypeTemplate..::.Template Property
TypeTemplate Class See Also Send Feedback
Gets or sets the DataTemplate to be used for the specified DataType.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate Template { get; set; }
Visual Basic (Declaration)
Public Property Template As DataTemplate

Implements

IDataTemplateMatcher..::.Template

See Also

TypeTemplate Class


TypeTemplateSelector Class

[image]

Mindscape WPF Diagrams
TypeTemplateSelector Class
Members See Also Send Feedback
Selects a data template based on the type of the object.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class TypeTemplateSelector : TypeTemplateSelectorBase
Visual Basic (Declaration)
Public Class TypeTemplateSelector _
    Inherits TypeTemplateSelectorBase

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.DataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingDataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.TypeTemplateSelectorBase
Mindscape.WpfDiagramming.Foundation..::.TypeTemplateSelector

See Also

TypeTemplateSelector Members


TypeTemplateSelector Members

[image] [image]

Mindscape WPF Diagrams
TypeTemplateSelector Members
TypeTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The TypeTemplateSelector type exposes the following members.

Constructors

Name | Description
TypeTemplateSelector |

Methods

Name | Description
GetSelectionType | Gets the type to be used in selecting a template for an item, being the CLR type of the object itself. (Overrides TypeTemplateSelectorBase ..::. GetSelectionType(Object).)
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns a DataTemplate according to the type of the item. (Inherited from TypeTemplateSelectorBase.)

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector. (Inherited from DelegatingDataTemplateSelector.)
DefaultTemplate | Gets or sets the default data template. (Inherited from TypeTemplateSelectorBase.)
TypeTemplates | Gets the list of type-specific templates. (Inherited from TypeTemplateSelectorBase.)

See Also

TypeTemplateSelector Class


TypeTemplateSelector Constructor

[image]

Mindscape WPF Diagrams
TypeTemplateSelector Constructor
TypeTemplateSelector Class See Also Send Feedback
Initializes a new instance of the TypeTemplateSelector class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public TypeTemplateSelector()
Visual Basic (Declaration)
Public Sub New

See Also

TypeTemplateSelector Class


TypeTemplateSelector Methods

[image] [image]

Mindscape WPF Diagrams
TypeTemplateSelector Methods
TypeTemplateSelector Class See Also Send Feedback

The TypeTemplateSelector type exposes the following members.

Methods

Name | Description
GetSelectionType | Gets the type to be used in selecting a template for an item, being the CLR type of the object itself. (Overrides TypeTemplateSelectorBase ..::. GetSelectionType(Object).)
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns a DataTemplate according to the type of the item. (Inherited from TypeTemplateSelectorBase.)

See Also

TypeTemplateSelector Class


GetSelectionType Method

[image]

Mindscape WPF Diagrams
TypeTemplateSelector..::.GetSelectionType Method
TypeTemplateSelector Class See Also Send Feedback
Gets the type to be used in selecting a template for an item, being the CLR type of the object itself.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Type GetSelectionType(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function GetSelectionType ( _
    item As Object _
) As Type

Parameters

item
Type: System..::.Object
The item for which to obtain a data type.

Return Value

The data type for the item.

See Also

TypeTemplateSelector Class


TypeTemplateSelectorBase Class

[image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase Class
Members See Also Send Feedback
Selects a data template based on a type.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("TypeTemplates")]
public abstract class TypeTemplateSelectorBase : DelegatingDataTemplateSelector
Visual Basic (Declaration)
<ContentPropertyAttribute("TypeTemplates")> _
Public MustInherit Class TypeTemplateSelectorBase _
    Inherits DelegatingDataTemplateSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.DataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.DelegatingDataTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.TypeTemplateSelectorBase
Mindscape.WpfDiagramming.Foundation..::.TypeTemplateSelector
Mindscape.WpfDiagramming.Foundation..::.DataTypeTemplateSelector

See Also

TypeTemplateSelectorBase Members


TypeTemplateSelectorBase Members

[image] [image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase Members
TypeTemplateSelectorBase Class Constructors Methods Properties See Also Send Feedback

The TypeTemplateSelectorBase type exposes the following members.

Constructors

Name | Description
TypeTemplateSelectorBase |

Methods

Name | Description
GetSelectionType | When overridden in a derived class, gets the type to be used in selecting a template for an item.
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns a DataTemplate according to the type of the item. (Overrides DelegatingDataTemplateSelector ..::. SelectTemplateCore(Object, DependencyObject).)

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector. (Inherited from DelegatingDataTemplateSelector.)
DefaultTemplate | Gets or sets the default data template.
TypeTemplates | Gets the list of type-specific templates.

See Also

TypeTemplateSelectorBase Class


TypeTemplateSelectorBase Constructor

[image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase Constructor
TypeTemplateSelectorBase Class See Also Send Feedback
Initializes a new instance of the TypeTemplateSelectorBase class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected TypeTemplateSelectorBase()
Visual Basic (Declaration)
Protected Sub New

See Also

TypeTemplateSelectorBase Class


TypeTemplateSelectorBase Methods

[image] [image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase Methods
TypeTemplateSelectorBase Class See Also Send Feedback

The TypeTemplateSelectorBase type exposes the following members.

Methods

Name | Description
GetSelectionType | When overridden in a derived class, gets the type to be used in selecting a template for an item.
SelectTemplate | Returns a DataTemplate for the item. (Inherited from DelegatingDataTemplateSelector.)
SelectTemplateCore | Returns a DataTemplate according to the type of the item. (Overrides DelegatingDataTemplateSelector ..::. SelectTemplateCore(Object, DependencyObject).)

See Also

TypeTemplateSelectorBase Class


GetSelectionType Method

[image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase..::.GetSelectionType Method
TypeTemplateSelectorBase Class See Also Send Feedback
When overridden in a derived class, gets the type to be used in selecting a template for an item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract Type GetSelectionType(
    Object item
)
Visual Basic (Declaration)
Protected MustOverride Function GetSelectionType ( _
    item As Object _
) As Type

Parameters

item
Type: System..::.Object
The item for which to obtain a data type.

Return Value

The data type for the item.

Remarks

Implementations should return null to request fall-through to the default template.

See Also

TypeTemplateSelectorBase Class


SelectTemplateCore Method

[image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase..::.SelectTemplateCore Method
TypeTemplateSelectorBase Class See Also Send Feedback
Returns a DataTemplate according to the type of the item.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override sealed DataTemplate SelectTemplateCore(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Protected Overrides NotOverridable Function SelectTemplateCore ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
The item for which to select the template.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

The template from the TypeTemplates list if one matches; otherwise the DefaultTemplate.

See Also

TypeTemplateSelectorBase Class


TypeTemplateSelectorBase Properties

[image] [image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase Properties
TypeTemplateSelectorBase Class See Also Send Feedback

The TypeTemplateSelectorBase type exposes the following members.

Properties

Name | Description
BasedOn | Gets or sets the DataTemplateSelector on which to fall back if no template is found by this selector. (Inherited from DelegatingDataTemplateSelector.)
DefaultTemplate | Gets or sets the default data template.
TypeTemplates | Gets the list of type-specific templates.

See Also

TypeTemplateSelectorBase Class


DefaultTemplate Property

[image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase..::.DefaultTemplate Property
TypeTemplateSelectorBase Class See Also Send Feedback
Gets or sets the default data template.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataTemplate DefaultTemplate { get; set; }
Visual Basic (Declaration)
Public Property DefaultTemplate As DataTemplate

See Also

TypeTemplateSelectorBase Class


TypeTemplates Property

[image]

Mindscape WPF Diagrams
TypeTemplateSelectorBase..::.TypeTemplates Property
TypeTemplateSelectorBase Class See Also Send Feedback
Gets the list of type-specific templates.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Collection<TypeTemplate> TypeTemplates { get; }
Visual Basic (Declaration)
Public ReadOnly Property TypeTemplates As Collection(Of TypeTemplate)

See Also

TypeTemplateSelectorBase Class


UndoManager Class

[image]

Mindscape WPF Diagrams
UndoManager Class
Members See Also Send Feedback
A class that manages the undo and redo procedures of a DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class UndoManager
Visual Basic (Declaration)
Public Class UndoManager

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.UndoManager

See Also

UndoManager Members


UndoManager Members

[image] [image]

Mindscape WPF Diagrams
UndoManager Members
UndoManager Class Constructors Methods See Also Send Feedback

The UndoManager type exposes the following members.

Constructors

Name | Description
UndoManager | Initializes a new instance of the UndoManager.

Methods

Name | Description
CancelLastSnapshot | Removes the last snapshot from the undo stack, and restores the redo stack.
CanRedo | Returns true if this UndoManager can currently perform a redo. returns false otherwise.
CanUndo | Returns true if this UndoManager can currently perform an undo. Returns false otherwise.
Redo | Performs a redo on the DiagramSurface known to this UndoManager.
Reset | Resets this UndoManager by deleting its undo history.
TakeSnapshot | Saves a DiagramState 'snapshot' of the DiagramSurface known to this UndoManager. This method should be called AFTER an action has modified the DiagramSurface.
Undo | Performs an undo on the DiagramSurface known to this UndoManager.

See Also

UndoManager Class


UndoManager Constructor

[image]

Mindscape WPF Diagrams
UndoManager Constructor
UndoManager Class See Also Send Feedback
Initializes a new instance of the UndoManager.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public UndoManager(
    DiagramSurface surface
)
Visual Basic (Declaration)
Public Sub New ( _
    surface As DiagramSurface _
)

Parameters

surface
Type: Mindscape.WpfDiagramming..::.DiagramSurface
The DiagramSurface that this UndoManager performs undo actions on.

See Also

UndoManager Class


UndoManager Methods

[image] [image]

Mindscape WPF Diagrams
UndoManager Methods
UndoManager Class See Also Send Feedback

The UndoManager type exposes the following members.

Methods

Name | Description
CancelLastSnapshot | Removes the last snapshot from the undo stack, and restores the redo stack.
CanRedo | Returns true if this UndoManager can currently perform a redo. returns false otherwise.
CanUndo | Returns true if this UndoManager can currently perform an undo. Returns false otherwise.
Redo | Performs a redo on the DiagramSurface known to this UndoManager.
Reset | Resets this UndoManager by deleting its undo history.
TakeSnapshot | Saves a DiagramState 'snapshot' of the DiagramSurface known to this UndoManager. This method should be called AFTER an action has modified the DiagramSurface.
Undo | Performs an undo on the DiagramSurface known to this UndoManager.

See Also

UndoManager Class


CancelLastSnapshot Method

[image]

Mindscape WPF Diagrams
UndoManager..::.CancelLastSnapshot Method
UndoManager Class See Also Send Feedback
Removes the last snapshot from the undo stack, and restores the redo stack.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CancelLastSnapshot()
Visual Basic (Declaration)
Public Sub CancelLastSnapshot

See Also

UndoManager Class


CanRedo Method

[image]

Mindscape WPF Diagrams
UndoManager..::.CanRedo Method
UndoManager Class See Also Send Feedback
Returns true if this UndoManager can currently perform a redo. returns false otherwise.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool CanRedo()
Visual Basic (Declaration)
Public Function CanRedo As Boolean

Return Value

True if a redo can be performed at the time this method is called. False otherwise.

See Also

UndoManager Class


CanUndo Method

[image]

Mindscape WPF Diagrams
UndoManager..::.CanUndo Method
UndoManager Class See Also Send Feedback
Returns true if this UndoManager can currently perform an undo. Returns false otherwise.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool CanUndo()
Visual Basic (Declaration)
Public Function CanUndo As Boolean

Return Value

True if an undo can be performed at the time this method is called. False otherwise.

See Also

UndoManager Class


Redo Method

[image]

Mindscape WPF Diagrams
UndoManager..::.Redo Method
UndoManager Class See Also Send Feedback
Performs a redo on the DiagramSurface known to this UndoManager.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Redo()
Visual Basic (Declaration)
Public Sub Redo

See Also

UndoManager Class


Reset Method

[image]

Mindscape WPF Diagrams
UndoManager..::.Reset Method
UndoManager Class See Also Send Feedback
Resets this UndoManager by deleting its undo history.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Reset()
Visual Basic (Declaration)
Public Sub Reset

See Also

UndoManager Class


TakeSnapshot Method

[image]

Mindscape WPF Diagrams
UndoManager..::.TakeSnapshot Method
UndoManager Class See Also Send Feedback
Saves a DiagramState 'snapshot' of the DiagramSurface known to this UndoManager. This method should be called AFTER an action has modified the DiagramSurface.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void TakeSnapshot()
Visual Basic (Declaration)
Public Sub TakeSnapshot

See Also

UndoManager Class


Undo Method

[image]

Mindscape WPF Diagrams
UndoManager..::.Undo Method
UndoManager Class See Also Send Feedback
Performs an undo on the DiagramSurface known to this UndoManager.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Undo()
Visual Basic (Declaration)
Public Sub Undo

See Also

UndoManager Class


ViewModelBase Class

[image]

Mindscape WPF Diagrams
ViewModelBase Class
Members See Also Send Feedback
Provides common observability support for view model classes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ViewModelBase : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ViewModelBase _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionPointBase<(Of <(TConnection>)>)
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase<(Of <(TConnectionPoint>)>)
Mindscape.WpfDiagramming.Foundation..::.DiagramToolBoxFilterItem
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>)
Mindscape.WpfDiagramming.Foundation..::.FloatingConnectionPoint

See Also

ViewModelBase Members


ViewModelBase Members

[image] [image]

Mindscape WPF Diagrams
ViewModelBase Members
ViewModelBase Class Constructors Methods Events See Also Send Feedback

The ViewModelBase type exposes the following members.

Constructors

Name | Description
ViewModelBase |

Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

ViewModelBase Class


ViewModelBase Constructor

[image]

Mindscape WPF Diagrams
ViewModelBase Constructor
ViewModelBase Class See Also Send Feedback
Initializes a new instance of the ViewModelBase class.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ViewModelBase()
Visual Basic (Declaration)
Public Sub New

See Also

ViewModelBase Class


ViewModelBase Methods

[image] [image]

Mindscape WPF Diagrams
ViewModelBase Methods
ViewModelBase Class See Also Send Feedback

The ViewModelBase type exposes the following members.

Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required.

See Also

ViewModelBase Class


OnPropertyChanged Method

[image]

Mindscape WPF Diagrams
ViewModelBase..::.OnPropertyChanged Method
ViewModelBase Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::.String
The name of the property whose value has changed.

See Also

ViewModelBase Class


Set(T) Method

[image]

Mindscape WPF Diagrams
ViewModelBase..::.Set<(Of <(T>)>) Method
ViewModelBase Class See Also Send Feedback
Sets the value of a field, raising the PropertyChanged event if required.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void Set<T>(
    ref T field,
    T value,
    string propertyName
)
Visual Basic (Declaration)
Protected Sub Set(Of T) ( _
    ByRef field As T, _
    value As T, _
    propertyName As String _
)

Parameters

field
Type: T %
The field to be set.
value
Type: T
The value to which to set the field.
propertyName
Type: System..::.String
The name of the property for which to raise a change notification.

Type Parameters

T
The data type of the field.

Remarks

Derived types can use this method to implement property setters.

See Also

ViewModelBase Class


ViewModelBase Events

[image] [image]

Mindscape WPF Diagrams
ViewModelBase Events
ViewModelBase Class See Also Send Feedback

The ViewModelBase type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

ViewModelBase Class


PropertyChanged Event

[image]

Mindscape WPF Diagrams
ViewModelBase..::.PropertyChanged Event
ViewModelBase Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ViewModelBase Class


ZIndexLayer Enumeration

[image]

Mindscape WPF Diagrams
ZIndexLayer Enumeration
See Also Send Feedback
Specifies how a DiagramElement participates in the z-order.

Namespace: Mindscape.WpfDiagramming.Foundation
Assembly: Mindscape.WpfDiagramming.Foundation (in Mindscape.WpfDiagramming.Foundation.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public enum ZIndexLayer
Visual Basic (Declaration)
Public Enumeration ZIndexLayer

Members

Member name | Description
Normal | The element participates normally in the z-order.
LayerBackground | The element appears behind all Normal elements at the same level in the parenting hierarchy. The relative order of LayerBackground elements is not determined.
Topmost | The element appears in front of all non-Topmost elements. The relative order of Topmost elements is not determined.
DiagramBackground | The element appears behind all non-DiagramBackground elements. The relative order of DiagramBackground elements is not determined.

See Also


Mindscape.WpfDiagramming.StarDiagrams Namespace

[image]

Mindscape WPF Diagrams
Mindscape.WpfDiagramming.StarDiagrams Namespace
Send Feedback
Contains classes for displaying and editing star diagrams.

Classes

Class | Description
ConnectionRelocatorPositionConverter | Determines the offset of a StarDiagramConnectionRelocator from its connection points.
DataNode | Represents the general type of StarDiagramNode which simply holds some data. DataNode objects have a single StarDiagramConnectionPoint attached to them.
DataStarDiagramNodeBuilder | A type of IDiagramNodeBuilder used to build DataNode objects and add them to a StarDiagramModel.
LevelToBrushConverter | An IValueConverter that selects a SolidColorBrush based on the given integer value.
LevelToBrushConverterBase | Provides common functionality for value converters which convert node levels to brushes.
LevelToGradientBrushConverter | Converts the level value of a star diagram node into a LinearGradientBrush. The level value indicates what color will be used in the brush.
StandardStarDiagramToolBoxItems | Provides standard toolbox item resources.
StarDiagramConnection | Represents a connection in a StarDiagramModel that connects between two StarDiagramNode objects.
StarDiagramConnectionBuilder | A type of IDiagramConnectionBuilder that can build StarDiagramConnection objects between two StarDiagramNode objects and adds them to a StarDiagramModel.
StarDiagramConnectionPoint | Represents a point on a StarDiagramNode where a StarDiagramConnection can connect.
StarDiagramConnectionRelocator | Provides connection validation logic for star diagrams.
StarDiagramConnectionState | An extension of ConnectionState that holds extra information specific to StarDiagramConnection objects.
StarDiagramForceBasedLayout | A type of ILayoutAlgorithm that uses physics equations revolving around spring theory and particle theory to force all the nodes of a StarDiagramModel into a sutable position. The StarDiagramForceBasedLayout does not modify the positions of CommentNode or TitleNode objects within the StarDiagramModel.
StarDiagramLayoutAlgorithmInfo | An ILayoutAlgorithmInfo implementation containing Star Diagram specific layout logic.
StarDiagramModel | Represents a star diagram.
StarDiagramNode | Represents a node in a StarDiagramModel.
StarDiagramNodeState | An extension of NodeState which holds extra information about a StarDiagramNode.
StarDiagramXmlSerializer | Serializes or deserializes a StarDiagramModel using an XML stream.


ConnectionRelocatorPositionConverter Class

[image]

Mindscape WPF Diagrams
ConnectionRelocatorPositionConverter Class
Members See Also Send Feedback
Determines the offset of a StarDiagramConnectionRelocator from its connection points.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class ConnectionRelocatorPositionConverter : IMultiValueConverter
Visual Basic (Declaration)
Public Class ConnectionRelocatorPositionConverter _
    Implements IMultiValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.StarDiagrams..::.ConnectionRelocatorPositionConverter

See Also

ConnectionRelocatorPositionConverter Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConnectionRelocatorPositionConverter Members

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatorPositionConverter Members
ConnectionRelocatorPositionConverter Class Constructors Methods See Also Send Feedback

The ConnectionRelocatorPositionConverter type exposes the following members.

Constructors

Name | Description
ConnectionRelocatorPositionConverter |

Methods

Name | Description
Convert | Determines the offset of a StarDiagramConnectionRelocator from its connection points.
ConvertBack | Throws a NotImplementedException.

See Also

ConnectionRelocatorPositionConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConnectionRelocatorPositionConverter Constructor

[image]

Mindscape WPF Diagrams
ConnectionRelocatorPositionConverter Constructor
ConnectionRelocatorPositionConverter Class See Also Send Feedback
Initializes a new instance of the ConnectionRelocatorPositionConverter class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ConnectionRelocatorPositionConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ConnectionRelocatorPositionConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConnectionRelocatorPositionConverter Methods

[image] [image]

Mindscape WPF Diagrams
ConnectionRelocatorPositionConverter Methods
ConnectionRelocatorPositionConverter Class See Also Send Feedback

The ConnectionRelocatorPositionConverter type exposes the following members.

Methods

Name | Description
Convert | Determines the offset of a StarDiagramConnectionRelocator from its connection points.
ConvertBack | Throws a NotImplementedException.

See Also

ConnectionRelocatorPositionConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Convert Method

[image]

Mindscape WPF Diagrams
ConnectionRelocatorPositionConverter..::.Convert Method
ConnectionRelocatorPositionConverter Class See Also Send Feedback
Determines the offset of a StarDiagramConnectionRelocator from its connection points.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object[] values,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    values As Object(), _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

values
Type: array< System..::.Object >[]()[]
The values produced by the binding source. The first value is the destination connection point. The second value is the origin connection point. The third is the IDiagramConnectable to which the destination connection point is attached.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A TranslateTransform representing the offset of the connection relocator.

Implements

IMultiValueConverter..::.Convert(array<Object>[]()[], Type, Object, CultureInfo)

See Also

ConnectionRelocatorPositionConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConvertBack Method

[image]

Mindscape WPF Diagrams
ConnectionRelocatorPositionConverter..::.ConvertBack Method
ConnectionRelocatorPositionConverter Class See Also Send Feedback
Throws a NotImplementedException.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object[] ConvertBack(
    Object value,
    Type[] targetTypes,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetTypes As Type(), _
    parameter As Object, _
    culture As CultureInfo _
) As Object()

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetTypes
Type: array< System..::.Type >[]()[]
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IMultiValueConverter..::.ConvertBack(Object, array<Type>[]()[], Object, CultureInfo)

See Also

ConnectionRelocatorPositionConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataNode Class

[image]

Mindscape WPF Diagrams
DataNode Class
Members See Also Send Feedback
Represents the general type of StarDiagramNode which simply holds some data. DataNode objects have a single StarDiagramConnectionPoint attached to them.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DataNode : StarDiagramNode
Visual Basic (Declaration)
Public Class DataNode _
    Inherits StarDiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode
Mindscape.WpfDiagramming.StarDiagrams..::.DataNode

See Also

DataNode Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataNode Members

[image] [image]

Mindscape WPF Diagrams
DataNode Members
DataNode Class Constructors Methods Properties Events See Also Send Feedback

The DataNode type exposes the following members.

Constructors

Name | Description
DataNode | Initializes a new instance of the DataNode class.

Methods

Name | Description
Clone | Gets a StarDiagramNodeState holding information about this StarDiagramNode. (Inherited from StarDiagramNode.)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsAncestorOf | Returns true if this StarDiagramNode is higher up in the star diagram parent hierachy than the given node. That is, this method returns true if the given node is a child or sub-child of this node. Returns false otherwise. (Inherited from StarDiagramNode.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Unloads all the information from the given IDiagramNodeState and applies it to this StarDiagramNode. (Inherited from StarDiagramNode.)

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Gets whether or not this StarDiagramNode can originate new connections. StarDiagramNode objects can originate any number of connections. (Inherited from StarDiagramNode.)
CanReceiveNewConnections | Gets whether or not this StarDiagramNode can recieve new connection. StarDiagramNode objects can accept any number of inbound connections. (Inherited from StarDiagramNode.)
Children | Gets a list of all the StarDiagramNode objects that this StarDiagramNode is a StarDiagramParent of. (Inherited from StarDiagramNode.)
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the MainConnectionPoint. (Inherited from StarDiagramNode.)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsRoot | Gets or sets whether or not this StarDiagramNode is a central root of a collection of nodes. (Inherited from StarDiagramNode.)
Level | Gets the level that this node sits in the star diagram node hierarchy. A StarDiagramNode that has no StarDiagramParent is at level 0. (Inherited from StarDiagramNode.)
MainConnectionPoint | Gets the main StarDiagramConnectionPoint situated on this StarDiagramNode. Generally this will either be the only found StarDiagramConnectionPoint. null is obtained if there are no connection points situated on this node. (Inherited from StarDiagramNode.)
Mass | Gets or sets the mass of this node. This is useful for layout algorithms. (Inherited from StarDiagramNode.)
NumberOfChildren | Gets the number of nodes that this StarDiagramNode is a StarDiagramParent of. This value is calculated on the fly. (Inherited from StarDiagramNode.)
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Root | Gets the absolute root of this StarDiagramNode. The absolute root is the recursive star diagram parent of this one that has a null StarDiagramParent. A StarDiagramNode that has a null star diagram parent is the root of itself. (Inherited from StarDiagramNode.)
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
StarDiagramParent | Gets the star diagram parent of this StarDiagramNode. This parent is the StarDiagramNode at the 'source' end of a connection that this node is the destination of. (Inherited from StarDiagramNode.)
Velocity | Gets or sets the velocity vector of this StarDiagramNode. This is useful for layout algorithms. (Inherited from StarDiagramNode.)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

DataNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataNode Constructor

[image]

Mindscape WPF Diagrams
DataNode Constructor
DataNode Class See Also Send Feedback
Initializes a new instance of the DataNode class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataNode()
Visual Basic (Declaration)
Public Sub New

See Also

DataNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataStarDiagramNodeBuilder Class

[image]

Mindscape WPF Diagrams
DataStarDiagramNodeBuilder Class
Members See Also Send Feedback
A type of IDiagramNodeBuilder used to build DataNode objects and add them to a StarDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class DataStarDiagramNodeBuilder : IDiagramNodeBuilder
Visual Basic (Declaration)
Public Class DataStarDiagramNodeBuilder _
    Implements IDiagramNodeBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.StarDiagrams..::.DataStarDiagramNodeBuilder

See Also

DataStarDiagramNodeBuilder Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataStarDiagramNodeBuilder Members

[image] [image]

Mindscape WPF Diagrams
DataStarDiagramNodeBuilder Members
DataStarDiagramNodeBuilder Class Constructors Methods Properties See Also Send Feedback

The DataStarDiagramNodeBuilder type exposes the following members.

Constructors

Name | Description
DataStarDiagramNodeBuilder |

Methods

Name | Description
CreateNode | Creates a new DataNode with the given position and dimensions, and then adds it to the given IDiagramModel.

Properties

Name | Description
DefaultSize | Gets the default size of a DataNode. This DataNode considers the default size of a DataNode to be 60 x 60.

See Also

DataStarDiagramNodeBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataStarDiagramNodeBuilder Constructor

[image]

Mindscape WPF Diagrams
DataStarDiagramNodeBuilder Constructor
DataStarDiagramNodeBuilder Class See Also Send Feedback
Initializes a new instance of the DataStarDiagramNodeBuilder class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public DataStarDiagramNodeBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

DataStarDiagramNodeBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataStarDiagramNodeBuilder Methods

[image] [image]

Mindscape WPF Diagrams
DataStarDiagramNodeBuilder Methods
DataStarDiagramNodeBuilder Class See Also Send Feedback

The DataStarDiagramNodeBuilder type exposes the following members.

Methods

Name | Description
CreateNode | Creates a new DataNode with the given position and dimensions, and then adds it to the given IDiagramModel.

See Also

DataStarDiagramNodeBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
DataStarDiagramNodeBuilder..::.CreateNode Method
DataStarDiagramNodeBuilder Class See Also Send Feedback
Creates a new DataNode with the given position and dimensions, and then adds it to the given IDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void CreateNode(
    IDiagramModel diagram,
    Rect bounds
)
Visual Basic (Declaration)
Public Sub CreateNode ( _
    diagram As IDiagramModel, _
    bounds As Rect _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the new DataNode will be added to.
bounds
Type: System.Windows..::.Rect
The position and dimensions of the newly created DataNode.

See Also

DataStarDiagramNodeBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataStarDiagramNodeBuilder Properties

[image] [image]

Mindscape WPF Diagrams
DataStarDiagramNodeBuilder Properties
DataStarDiagramNodeBuilder Class See Also Send Feedback

The DataStarDiagramNodeBuilder type exposes the following members.

Properties

Name | Description
DefaultSize | Gets the default size of a DataNode. This DataNode considers the default size of a DataNode to be 60 x 60.

See Also

DataStarDiagramNodeBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DefaultSize Property

[image]

Mindscape WPF Diagrams
DataStarDiagramNodeBuilder..::.DefaultSize Property
DataStarDiagramNodeBuilder Class See Also Send Feedback
Gets the default size of a DataNode. This DataNode considers the default size of a DataNode to be 60 x 60.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Size DefaultSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultSize As Size

See Also

DataStarDiagramNodeBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverter Class

[image]

Mindscape WPF Diagrams
LevelToBrushConverter Class
Members See Also Send Feedback
An IValueConverter that selects a SolidColorBrush based on the given integer value.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ContentPropertyAttribute("Colors")]
[ValueConversionAttribute(typeof(int), typeof(Brush))]
public class LevelToBrushConverter : LevelToBrushConverterBase
Visual Basic (Declaration)
<ContentPropertyAttribute("Colors")> _
<ValueConversionAttribute(GetType(Integer), GetType(Brush))> _
Public Class LevelToBrushConverter _
    Inherits LevelToBrushConverterBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.StarDiagrams..::.LevelToBrushConverterBase
Mindscape.WpfDiagramming.StarDiagrams..::.LevelToBrushConverter

See Also

LevelToBrushConverter Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverter Members

[image] [image]

Mindscape WPF Diagrams
LevelToBrushConverter Members
LevelToBrushConverter Class Constructors Methods Properties See Also Send Feedback

The LevelToBrushConverter type exposes the following members.

Constructors

Name | Description
LevelToBrushConverter |

Methods

Name | Description
Convert | Picks a color from an array of colors according to the given integer. A SolidColourBrush with the picked color is then returned. (Inherited from LevelToBrushConverterBase.)
ConvertBack | Converts a value from a binding target for writing to a binding source. (Inherited from LevelToBrushConverterBase.)
ConvertLevelToBrush | Gets the solid color brush for nodes of the specified level. (Overrides LevelToBrushConverterBase ..::. ConvertLevelToBrush(Int32).)

Properties

Name | Description
Colors | Gets the list of colors to be used for drawing the nodes, in level order.

See Also

LevelToBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverter Constructor

[image]

Mindscape WPF Diagrams
LevelToBrushConverter Constructor
LevelToBrushConverter Class See Also Send Feedback
Initializes a new instance of the LevelToBrushConverter class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public LevelToBrushConverter()
Visual Basic (Declaration)
Public Sub New

See Also

LevelToBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverter Methods

[image] [image]

Mindscape WPF Diagrams
LevelToBrushConverter Methods
LevelToBrushConverter Class See Also Send Feedback

The LevelToBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Picks a color from an array of colors according to the given integer. A SolidColourBrush with the picked color is then returned. (Inherited from LevelToBrushConverterBase.)
ConvertBack | Converts a value from a binding target for writing to a binding source. (Inherited from LevelToBrushConverterBase.)
ConvertLevelToBrush | Gets the solid color brush for nodes of the specified level. (Overrides LevelToBrushConverterBase ..::. ConvertLevelToBrush(Int32).)

See Also

LevelToBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConvertLevelToBrush Method

[image]

Mindscape WPF Diagrams
LevelToBrushConverter..::.ConvertLevelToBrush Method
LevelToBrushConverter Class See Also Send Feedback
Gets the solid color brush for nodes of the specified level.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Brush ConvertLevelToBrush(
    int level
)
Visual Basic (Declaration)
Protected Overrides Function ConvertLevelToBrush ( _
    level As Integer _
) As Brush

Parameters

level
Type: System..::.Int32
The level of the node in the diagram.

Return Value

A brush that can be used to draw the node.

See Also

LevelToBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverter Properties

[image] [image]

Mindscape WPF Diagrams
LevelToBrushConverter Properties
LevelToBrushConverter Class See Also Send Feedback

The LevelToBrushConverter type exposes the following members.

Properties

Name | Description
Colors | Gets the list of colors to be used for drawing the nodes, in level order.

See Also

LevelToBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Colors Property

[image]

Mindscape WPF Diagrams
LevelToBrushConverter..::.Colors Property
LevelToBrushConverter Class See Also Send Feedback
Gets the list of colors to be used for drawing the nodes, in level order.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ObservableCollection<Color> Colors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Colors As ObservableCollection(Of Color)

See Also

LevelToBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverterBase Class

[image]

Mindscape WPF Diagrams
LevelToBrushConverterBase Class
Members See Also Send Feedback
Provides common functionality for value converters which convert node levels to brushes.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ValueConversionAttribute(typeof(int), typeof(Color))]
public abstract class LevelToBrushConverterBase : IValueConverter
Visual Basic (Declaration)
<ValueConversionAttribute(GetType(Integer), GetType(Color))> _
Public MustInherit Class LevelToBrushConverterBase _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.StarDiagrams..::.LevelToBrushConverterBase
Mindscape.WpfDiagramming.StarDiagrams..::.LevelToGradientBrushConverter
Mindscape.WpfDiagramming.StarDiagrams..::.LevelToBrushConverter

See Also

LevelToBrushConverterBase Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverterBase Members

[image] [image]

Mindscape WPF Diagrams
LevelToBrushConverterBase Members
LevelToBrushConverterBase Class Constructors Methods See Also Send Feedback

The LevelToBrushConverterBase type exposes the following members.

Constructors

Name | Description
LevelToBrushConverterBase |

Methods

Name | Description
Convert | Picks a color from an array of colors according to the given integer. A SolidColourBrush with the picked color is then returned.
ConvertBack | Converts a value from a binding target for writing to a binding source.
ConvertLevelToBrush | When overridden in a derived class, converts a node level to a Brush.

See Also

LevelToBrushConverterBase Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverterBase Constructor

[image]

Mindscape WPF Diagrams
LevelToBrushConverterBase Constructor
LevelToBrushConverterBase Class See Also Send Feedback
Initializes a new instance of the LevelToBrushConverterBase class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected LevelToBrushConverterBase()
Visual Basic (Declaration)
Protected Sub New

See Also

LevelToBrushConverterBase Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToBrushConverterBase Methods

[image] [image]

Mindscape WPF Diagrams
LevelToBrushConverterBase Methods
LevelToBrushConverterBase Class See Also Send Feedback

The LevelToBrushConverterBase type exposes the following members.

Methods

Name | Description
Convert | Picks a color from an array of colors according to the given integer. A SolidColourBrush with the picked color is then returned.
ConvertBack | Converts a value from a binding target for writing to a binding source.
ConvertLevelToBrush | When overridden in a derived class, converts a node level to a Brush.

See Also

LevelToBrushConverterBase Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Convert Method

[image]

Mindscape WPF Diagrams
LevelToBrushConverterBase..::.Convert Method
LevelToBrushConverterBase Class See Also Send Feedback
Picks a color from an array of colors according to the given integer. A SolidColourBrush with the picked color is then returned.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The int value produced by the binding source.
targetType
Type: System..::.Type
The type of the binding target property.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

A SolidColorBrush picked according to the given integer.

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

LevelToBrushConverterBase Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConvertBack Method

[image]

Mindscape WPF Diagrams
LevelToBrushConverterBase..::.ConvertBack Method
LevelToBrushConverterBase Class See Also Send Feedback
Converts a value from a binding target for writing to a binding source.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
The value produced by the binding target.
targetType
Type: System..::.Type
The type to convert to.
parameter
Type: System..::.Object
The converter parameter to use.
culture
Type: System.Globalization..::.CultureInfo
The culture to use in the conversion.

Return Value

This conversion direction is not implemented by this converter.

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

LevelToBrushConverterBase Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConvertLevelToBrush Method

[image]

Mindscape WPF Diagrams
LevelToBrushConverterBase..::.ConvertLevelToBrush Method
LevelToBrushConverterBase Class See Also Send Feedback
When overridden in a derived class, converts a node level to a Brush.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected abstract Brush ConvertLevelToBrush(
    int level
)
Visual Basic (Declaration)
Protected MustOverride Function ConvertLevelToBrush ( _
    level As Integer _
) As Brush

Parameters

level
Type: System..::.Int32
The level of the node in the diagram.

Return Value

A brush that can be used to draw the node.

See Also

LevelToBrushConverterBase Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToGradientBrushConverter Class

[image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter Class
Members See Also Send Feedback
Converts the level value of a star diagram node into a LinearGradientBrush. The level value indicates what color will be used in the brush.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
[ValueConversionAttribute(typeof(int), typeof(Brush))]
[ContentPropertyAttribute("Colors")]
public class LevelToGradientBrushConverter : LevelToBrushConverterBase
Visual Basic (Declaration)
<ValueConversionAttribute(GetType(Integer), GetType(Brush))> _
<ContentPropertyAttribute("Colors")> _
Public Class LevelToGradientBrushConverter _
    Inherits LevelToBrushConverterBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.StarDiagrams..::.LevelToBrushConverterBase
Mindscape.WpfDiagramming.StarDiagrams..::.LevelToGradientBrushConverter

See Also

LevelToGradientBrushConverter Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToGradientBrushConverter Members

[image] [image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter Members
LevelToGradientBrushConverter Class Constructors Methods Properties See Also Send Feedback

The LevelToGradientBrushConverter type exposes the following members.

Constructors

Name | Description
LevelToGradientBrushConverter |

Methods

Name | Description
Convert | Picks a color from an array of colors according to the given integer. A SolidColourBrush with the picked color is then returned. (Inherited from LevelToBrushConverterBase.)
ConvertBack | Converts a value from a binding target for writing to a binding source. (Inherited from LevelToBrushConverterBase.)
ConvertLevelToBrush | Gets the gradient brush for nodes of the specified level. (Overrides LevelToBrushConverterBase ..::. ConvertLevelToBrush(Int32).)

Properties

Name | Description
ColorFactor | Gets or sets the factor that is used to derive the two gradient colors. This value should typically be between 0-1, and the smaller the value, the larger the distance between the two colors.
Colors | Gets the list of colors to be used for drawing the nodes, in level order.
EndPoint | Gets or sets the ending point of the gradient.
StartPoint | Gets or sets the starting point of the gradient.

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToGradientBrushConverter Constructor

[image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter Constructor
LevelToGradientBrushConverter Class See Also Send Feedback
Initializes a new instance of the LevelToGradientBrushConverter class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public LevelToGradientBrushConverter()
Visual Basic (Declaration)
Public Sub New

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToGradientBrushConverter Methods

[image] [image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter Methods
LevelToGradientBrushConverter Class See Also Send Feedback

The LevelToGradientBrushConverter type exposes the following members.

Methods

Name | Description
Convert | Picks a color from an array of colors according to the given integer. A SolidColourBrush with the picked color is then returned. (Inherited from LevelToBrushConverterBase.)
ConvertBack | Converts a value from a binding target for writing to a binding source. (Inherited from LevelToBrushConverterBase.)
ConvertLevelToBrush | Gets the gradient brush for nodes of the specified level. (Overrides LevelToBrushConverterBase ..::. ConvertLevelToBrush(Int32).)

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ConvertLevelToBrush Method

[image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter..::.ConvertLevelToBrush Method
LevelToGradientBrushConverter Class See Also Send Feedback
Gets the gradient brush for nodes of the specified level.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Brush ConvertLevelToBrush(
    int level
)
Visual Basic (Declaration)
Protected Overrides Function ConvertLevelToBrush ( _
    level As Integer _
) As Brush

Parameters

level
Type: System..::.Int32
The level of the node in the diagram.

Return Value

A brush that can be used to draw the node.

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


LevelToGradientBrushConverter Properties

[image] [image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter Properties
LevelToGradientBrushConverter Class See Also Send Feedback

The LevelToGradientBrushConverter type exposes the following members.

Properties

Name | Description
ColorFactor | Gets or sets the factor that is used to derive the two gradient colors. This value should typically be between 0-1, and the smaller the value, the larger the distance between the two colors.
Colors | Gets the list of colors to be used for drawing the nodes, in level order.
EndPoint | Gets or sets the ending point of the gradient.
StartPoint | Gets or sets the starting point of the gradient.

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ColorFactor Property

[image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter..::.ColorFactor Property
LevelToGradientBrushConverter Class See Also Send Feedback
Gets or sets the factor that is used to derive the two gradient colors. This value should typically be between 0-1, and the smaller the value, the larger the distance between the two colors.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double ColorFactor { get; set; }
Visual Basic (Declaration)
Public Property ColorFactor As Double

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Colors Property

[image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter..::.Colors Property
LevelToGradientBrushConverter Class See Also Send Feedback
Gets the list of colors to be used for drawing the nodes, in level order.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public ObservableCollection<Color> Colors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Colors As ObservableCollection(Of Color)

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


EndPoint Property

[image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter..::.EndPoint Property
LevelToGradientBrushConverter Class See Also Send Feedback
Gets or sets the ending point of the gradient.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As Point

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StartPoint Property

[image]

Mindscape WPF Diagrams
LevelToGradientBrushConverter..::.StartPoint Property
LevelToGradientBrushConverter Class See Also Send Feedback
Gets or sets the starting point of the gradient.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As Point

See Also

LevelToGradientBrushConverter Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StandardStarDiagramToolBoxItems Class

[image]

Mindscape WPF Diagrams
StandardStarDiagramToolBoxItems Class
Members See Also Send Feedback
Provides standard toolbox item resources.
StandardStarDiagramToolBoxItems

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StandardStarDiagramToolBoxItems : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class StandardStarDiagramToolBoxItems _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.StarDiagrams..::.StandardStarDiagramToolBoxItems

See Also

StandardStarDiagramToolBoxItems Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StandardStarDiagramToolBoxItems Members

[image] [image]

Mindscape WPF Diagrams
StandardStarDiagramToolBoxItems Members
StandardStarDiagramToolBoxItems Class Constructors Methods Properties See Also Send Feedback

The StandardStarDiagramToolBoxItems type exposes the following members.

Constructors

Name | Description
StandardStarDiagramToolBoxItems | Initializes a new instance of the StandardStarDiagramToolBoxItems class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
DataNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add DataNode objects to a StarDiagramModel.

See Also

StandardStarDiagramToolBoxItems Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StandardStarDiagramToolBoxItems Constructor

[image]

Mindscape WPF Diagrams
StandardStarDiagramToolBoxItems Constructor
StandardStarDiagramToolBoxItems Class See Also Send Feedback
Initializes a new instance of the StandardStarDiagramToolBoxItems class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StandardStarDiagramToolBoxItems()
Visual Basic (Declaration)
Public Sub New

See Also

StandardStarDiagramToolBoxItems Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StandardStarDiagramToolBoxItems Methods

[image] [image]

Mindscape WPF Diagrams
StandardStarDiagramToolBoxItems Methods
StandardStarDiagramToolBoxItems Class See Also Send Feedback

The StandardStarDiagramToolBoxItems type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

StandardStarDiagramToolBoxItems Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
StandardStarDiagramToolBoxItems..::.InitializeComponent Method
StandardStarDiagramToolBoxItems Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

StandardStarDiagramToolBoxItems Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StandardStarDiagramToolBoxItems Properties

[image] [image]

Mindscape WPF Diagrams
StandardStarDiagramToolBoxItems Properties
StandardStarDiagramToolBoxItems Class See Also Send Feedback

The StandardStarDiagramToolBoxItems type exposes the following members.

Properties

Name | Description
DataNodeToolKey | Gets the ResourceKey for the standard DiagramNodeTool used to add DataNode objects to a StarDiagramModel.

See Also

StandardStarDiagramToolBoxItems Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DataNodeToolKey Property

[image]

Mindscape WPF Diagrams
StandardStarDiagramToolBoxItems..::.DataNodeToolKey Property
StandardStarDiagramToolBoxItems Class See Also Send Feedback
Gets the ResourceKey for the standard DiagramNodeTool used to add DataNode objects to a StarDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey DataNodeToolKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DataNodeToolKey As ComponentResourceKey

See Also

StandardStarDiagramToolBoxItems Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Class

[image]

Mindscape WPF Diagrams
StarDiagramConnection Class
Members See Also Send Feedback
Represents a connection in a StarDiagramModel that connects between two StarDiagramNode objects.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramConnection : DiagramConnection
Visual Basic (Declaration)
Public Class StarDiagramConnection _
    Inherits DiagramConnection

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramConnection
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnection

See Also

StarDiagramConnection Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnection Members
StarDiagramConnection Class Constructors Methods Fields Properties Events See Also Send Feedback

The StarDiagramConnection type exposes the following members.

Constructors

Name | Description
StarDiagramConnection | Overloaded.

Methods

Name | Description
AddConnectionPoint | Adds a new mounted connection point to this connection. (Inherited from DiagramConnection.)
ApplyPathfinding | Re-routes this connection using its pathfinder. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Clone | Returns a ConnectionState holding information about this StarDiagramConnection. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Fields

Name | Description
DefaultDesiredLength | The default value for the DesiredLength property.

Properties

Name | Description
CanOriginateNewConnections | Returns false. StarDiagramConnection objects can not originate connections. (Overrides DiagramConnection ..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. StarDiagramConnection objects can not receive connections. (Overrides DiagramConnection ..::. CanReceiveNewConnections.)
ChildNode | Gets the StarDiagramNode that this StarDiagramConnection is attached to of which is the child of the other node that this connection is attached to.
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
DesiredLength | Gets or sets the desired length of this StarDiagramConnection. This property is useful for layout algorithms which can atempt to allow the length of this StarDiagramConnection to get as close to the desired length as possible.
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Length | Gets the distance between the positions of the StarDiagramConnectionPoint objects at each end of this StarDiagramConnection.
LineType | Gets or sets the DiagramLineType used to draw the connection. (Inherited from DiagramConnection.)
ParentNode | Gets the StarDiagramNode that this StarDiagramConnection is attached to of which is the star-diagram-parent of the other node that this connection is attached to.
Pathfinder | Gets a StraightLinePathfinder. (Overrides DiagramConnection ..::. Pathfinder.)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

Events

Name | Description
DataChanged | Raised when the Data property changes. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Constructor

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnection Constructor
StarDiagramConnection Class See Also Send Feedback

Overload List

Name | Description
StarDiagramConnection(DiagramConnectionPoint, DiagramConnectionPoint) | Initializes a new instance of the StarDiagramConnection class.
StarDiagramConnection(DiagramConnectionPoint, DiagramConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>)) | Initializes a new instance of the StarDiagramConnection class.

See Also

StarDiagramConnection Class
StarDiagramConnection Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint)

[image]

Mindscape WPF Diagrams
StarDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint)
StarDiagramConnection Class See Also Send Feedback
Initializes a new instance of the StarDiagramConnection class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramConnection(
    DiagramConnectionPoint fromConnectionPoint,
    DiagramConnectionPoint toConnectionPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As DiagramConnectionPoint, _
    toConnectionPoint As DiagramConnectionPoint _
)

Parameters

fromConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The StarDiagramConnectionPoint at the start of the connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The StarDiagramConnectionPoint at the end of the connection.

See Also

StarDiagramConnection Class
StarDiagramConnection Overload
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint, IList(DiagramConnectionSegment))

[image]

Mindscape WPF Diagrams
StarDiagramConnection Constructor (DiagramConnectionPoint, DiagramConnectionPoint, IList<(Of <(DiagramConnectionSegment>)>))
StarDiagramConnection Class See Also Send Feedback
Initializes a new instance of the StarDiagramConnection class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramConnection(
    DiagramConnectionPoint fromConnectionPoint,
    DiagramConnectionPoint toConnectionPoint,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Public Sub New ( _
    fromConnectionPoint As DiagramConnectionPoint, _
    toConnectionPoint As DiagramConnectionPoint, _
    segments As IList(Of DiagramConnectionSegment) _
)

Parameters

fromConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The StarDiagramConnectionPoint at the start of the connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The StarDiagramConnectionPoint at the end of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects within this connection.

See Also

StarDiagramConnection Class
StarDiagramConnection Overload
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Fields

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnection Fields
StarDiagramConnection Class See Also Send Feedback

The StarDiagramConnection type exposes the following members.

Fields

Name | Description
DefaultDesiredLength | The default value for the DesiredLength property.

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DefaultDesiredLength Field

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.DefaultDesiredLength Field
StarDiagramConnection Class See Also Send Feedback
The default value for the DesiredLength property.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public const double DefaultDesiredLength
Visual Basic (Declaration)
Public Const DefaultDesiredLength As Double

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnection Methods
StarDiagramConnection Class See Also Send Feedback

The StarDiagramConnection type exposes the following members.

Methods

Name | Description
AddConnectionPoint | Adds a new mounted connection point to this connection. (Inherited from DiagramConnection.)
ApplyPathfinding | Re-routes this connection using its pathfinder. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Clone | Returns a ConnectionState holding information about this StarDiagramConnection. (Overrides DiagramConnectionBase <(Of <( DiagramConnectionPoint, DiagramConnectionPoint, DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns a Rect with a position being the same as the position of the given IDiagramConnectionPoint, and a size of 1 by 1. This Rect is the bounds to be taken into consideration when path finding to the given connection point. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Sets all the properties of this connection to match those of the given connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Clone Method

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.Clone Method
StarDiagramConnection Class See Also Send Feedback
Returns a ConnectionState holding information about this StarDiagramConnection.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IDiagramConnectionState Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As IDiagramConnectionState

Return Value

A ConnectionState representing this StarDiagramConnection.

Implements

IDiagramConnection..::.Clone()()()

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnection Properties

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnection Properties
StarDiagramConnection Class See Also Send Feedback

The StarDiagramConnection type exposes the following members.

Properties

Name | Description
CanOriginateNewConnections | Returns false. StarDiagramConnection objects can not originate connections. (Overrides DiagramConnection ..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Returns false. StarDiagramConnection objects can not receive connections. (Overrides DiagramConnection ..::. CanReceiveNewConnections.)
ChildNode | Gets the StarDiagramNode that this StarDiagramConnection is attached to of which is the child of the other node that this connection is attached to.
ConnectionPoints | Returns all the IDiagramConnectionPoint objects currently attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Data | Gets or sets the data attached to this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
DesiredLength | Gets or sets the desired length of this StarDiagramConnection. This property is useful for layout algorithms which can atempt to allow the length of this StarDiagramConnection to get as close to the desired length as possible.
Diagram | Gets or sets the IDiagramModel that the connection belongs to. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
FromConnectionPoint | Gets or sets the source of the connection. When setting the source, this connection is first removed from any original source. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
IsUserModified | Gets or sets whether this connection has had one of its DiagramConnectionSegment objects modified by a user. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
Length | Gets the distance between the positions of the StarDiagramConnectionPoint objects at each end of this StarDiagramConnection.
LineType | Gets or sets the DiagramLineType used to draw the connection. (Inherited from DiagramConnection.)
ParentNode | Gets the StarDiagramNode that this StarDiagramConnection is attached to of which is the star-diagram-parent of the other node that this connection is attached to.
Pathfinder | Gets a StraightLinePathfinder. (Overrides DiagramConnection ..::. Pathfinder.)
Segments | Returns all the DiagramConnectionSegment objects that build up this connection. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ToConnectionPoint | Gets or sets the destination of the connection. When setting the destination, this connection is first removed from any original destination. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramConnectionBase<(Of <(TOutboundPoint, TInboundPoint, TMountedPoint>)>).)

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.CanOriginateNewConnections Property
StarDiagramConnection Class See Also Send Feedback
Returns false. StarDiagramConnection objects can not originate connections.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.CanReceiveNewConnections Property
StarDiagramConnection Class See Also Send Feedback
Returns false. StarDiagramConnection objects can not receive connections.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ChildNode Property

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.ChildNode Property
StarDiagramConnection Class See Also Send Feedback
Gets the StarDiagramNode that this StarDiagramConnection is attached to of which is the child of the other node that this connection is attached to.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramNode ChildNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildNode As StarDiagramNode

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DesiredLength Property

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.DesiredLength Property
StarDiagramConnection Class See Also Send Feedback
Gets or sets the desired length of this StarDiagramConnection. This property is useful for layout algorithms which can atempt to allow the length of this StarDiagramConnection to get as close to the desired length as possible.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double DesiredLength { get; set; }
Visual Basic (Declaration)
Public Property DesiredLength As Double

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Length Property

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.Length Property
StarDiagramConnection Class See Also Send Feedback
Gets the distance between the positions of the StarDiagramConnectionPoint objects at each end of this StarDiagramConnection.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Double

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


ParentNode Property

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.ParentNode Property
StarDiagramConnection Class See Also Send Feedback
Gets the StarDiagramNode that this StarDiagramConnection is attached to of which is the star-diagram-parent of the other node that this connection is attached to.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramNode ParentNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentNode As StarDiagramNode

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Pathfinder Property

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.Pathfinder Property
StarDiagramConnection Class See Also Send Feedback
Gets a StraightLinePathfinder.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IPathfinder Pathfinder { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Pathfinder As IPathfinder

Implements

IDiagramConnection..::.Pathfinder

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionBuilder Class

[image]

Mindscape WPF Diagrams
StarDiagramConnectionBuilder Class
Members See Also Send Feedback
A type of IDiagramConnectionBuilder that can build StarDiagramConnection objects between two StarDiagramNode objects and adds them to a StarDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramConnectionBuilder : IDiagramConnectionBuilder
Visual Basic (Declaration)
Public Class StarDiagramConnectionBuilder _
    Implements IDiagramConnectionBuilder

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionBuilder

See Also

StarDiagramConnectionBuilder Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionBuilder Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionBuilder Members
StarDiagramConnectionBuilder Class Constructors Methods See Also Send Feedback

The StarDiagramConnectionBuilder type exposes the following members.

Constructors

Name | Description
StarDiagramConnectionBuilder |

Methods

Name | Description
CanCreateConnection | This method can be overriden to provide additional logic for allowing a connection to be made between the given connection point and destination. This implementation always returns true.
CreateConnection | Creates a new StarDiagramConnection between the two given StarDiagramConnectionPoint objects. The connection is then added to this given StarDiagramModel.

See Also

StarDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionBuilder Constructor

[image]

Mindscape WPF Diagrams
StarDiagramConnectionBuilder Constructor
StarDiagramConnectionBuilder Class See Also Send Feedback
Initializes a new instance of the StarDiagramConnectionBuilder class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramConnectionBuilder()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionBuilder Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionBuilder Methods
StarDiagramConnectionBuilder Class See Also Send Feedback

The StarDiagramConnectionBuilder type exposes the following members.

Methods

Name | Description
CanCreateConnection | This method can be overriden to provide additional logic for allowing a connection to be made between the given connection point and destination. This implementation always returns true.
CreateConnection | Creates a new StarDiagramConnection between the two given StarDiagramConnectionPoint objects. The connection is then added to this given StarDiagramModel.

See Also

StarDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CanCreateConnection Method

[image]

Mindscape WPF Diagrams
StarDiagramConnectionBuilder..::.CanCreateConnection Method
StarDiagramConnectionBuilder Class See Also Send Feedback
This method can be overriden to provide additional logic for allowing a connection to be made between the given connection point and destination. This implementation always returns true.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual bool CanCreateConnection(
    IDiagramModel diagram,
    IDiagramConnectionPoint fromConnectionPoint,
    ConnectionDropTarget destination
)
Visual Basic (Declaration)
Public Overridable Function CanCreateConnection ( _
    diagram As IDiagramModel, _
    fromConnectionPoint As IDiagramConnectionPoint, _
    destination As ConnectionDropTarget _
) As Boolean

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel that the connection will belong to.
fromConnectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The IDiagramConnectionPoint that represents the start of the connection.
destination
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionDropTarget
Information about the potential destination of the connection.

Return Value

Whether or not a connection can be made.

Implements

IDiagramConnectionBuilder..::.CanCreateConnection(IDiagramModel, IDiagramConnectionPoint, ConnectionDropTarget)

See Also

StarDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CreateConnection Method

[image]

Mindscape WPF Diagrams
StarDiagramConnectionBuilder..::.CreateConnection Method
StarDiagramConnectionBuilder Class See Also Send Feedback
Creates a new StarDiagramConnection between the two given StarDiagramConnectionPoint objects. The connection is then added to this given StarDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static void CreateConnection(
    StarDiagramModel diagram,
    StarDiagramConnectionPoint fromConnectionPoint,
    StarDiagramConnectionPoint toConnectionPoint
)
Visual Basic (Declaration)
Public Shared Sub CreateConnection ( _
    diagram As StarDiagramModel, _
    fromConnectionPoint As StarDiagramConnectionPoint, _
    toConnectionPoint As StarDiagramConnectionPoint _
)

Parameters

diagram
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramModel
The StarDiagramModel that the new connection will be added to.
fromConnectionPoint
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionPoint
The StarDiagramConnectionPoint to be the source of the new connection.
toConnectionPoint
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionPoint
The StarDiagramConnectionPoint to be the destination of the new connection.

See Also

StarDiagramConnectionBuilder Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionPoint Class

[image]

Mindscape WPF Diagrams
StarDiagramConnectionPoint Class
Members See Also Send Feedback
Represents a point on a StarDiagramNode where a StarDiagramConnection can connect.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramConnectionPoint : DiagramConnectionPoint
Visual Basic (Declaration)
Public Class StarDiagramConnectionPoint _
    Inherits DiagramConnectionPoint

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramConnectionPointBase <(Of <( DiagramConnection >)>)
Mindscape.WpfDiagramming..::.DiagramConnectionPoint
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionPoint

See Also

StarDiagramConnectionPoint Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionPoint Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionPoint Members
StarDiagramConnectionPoint Class Constructors Methods Properties Events See Also Send Feedback

The StarDiagramConnectionPoint type exposes the following members.

Constructors

Name | Description
StarDiagramConnectionPoint | Initializes a new instance of the StarDiagramConnectionPoint class.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this IDiagramConnectionPoint. (Overrides DiagramConnectionPoint ..::. AddConnection(IDiagramConnection).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
RemoveConnection | Removes the given IDiagramConnection from this IDiagramConnectionPoint. (Overrides DiagramConnectionPoint ..::. RemoveConnection(IDiagramConnection).)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetPosition | Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

Properties

Name | Description
CanOriginateNewConnections | Gets whether the user should be allowed to drag new connections from this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
CanReceiveNewConnections | Gets whether the user should be allowed to drop new connections onto this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connectable | Gets the IDiagramConnectable on which the IDiagramConnectionPoint is situated. This will either be a node or a connection. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Connections | Gets the connections attached to this connection point. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Data | Gets or sets the data object held by this connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Edge | Returns the edge of the node that this DiagramConnectionPointBase will sit on according to its position calculator. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
FlowDirection | Gets whether the connection point supports inbound connections, outbound connections or both. (Inherited from DiagramConnectionPoint.)
Index | Gets an index identifier for this connection point. This is useful for selecting a connection point calculator when there are multiple connection points on the same edge of a node. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
Position | Gets or sets the position of the connection point/>. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionCalculator | Gets or sets the IPositionCalculator that this connection point uses to calculate its position relative to the connectable it is attached to. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

Events

Name | Description
IndexChanged | Raised when the Index property value changes. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PositionChanged | Raised when the Position property value changes. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)

See Also

StarDiagramConnectionPoint Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionPoint Constructor

[image]

Mindscape WPF Diagrams
StarDiagramConnectionPoint Constructor
StarDiagramConnectionPoint Class See Also Send Feedback
Initializes a new instance of the StarDiagramConnectionPoint class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramConnectionPoint(
    StarDiagramNode node
)
Visual Basic (Declaration)
Public Sub New ( _
    node As StarDiagramNode _
)

Parameters

node
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode
The StarDiagramNode that this connection point is to be situated on.

See Also

StarDiagramConnectionPoint Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionPoint Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionPoint Methods
StarDiagramConnectionPoint Class See Also Send Feedback

The StarDiagramConnectionPoint type exposes the following members.

Methods

Name | Description
AddConnection | Attaches the given IDiagramConnection to this IDiagramConnectionPoint. (Overrides DiagramConnectionPoint ..::. AddConnection(IDiagramConnection).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
RemoveConnection | Removes the given IDiagramConnection from this IDiagramConnectionPoint. (Overrides DiagramConnectionPoint ..::. RemoveConnection(IDiagramConnection).)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetPosition | Sets the position of this DiagramConnectionPointBase<(Of <(TConnection>)>) to be a point on the connection that it is attached to that is closest to the given Point. The actual position that was set is then returned. (Inherited from DiagramConnectionPointBase<(Of <(TConnection>)>).)

See Also

StarDiagramConnectionPoint Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


AddConnection Method

[image]

Mindscape WPF Diagrams
StarDiagramConnectionPoint..::.AddConnection Method
StarDiagramConnectionPoint Class See Also Send Feedback
Attaches the given IDiagramConnection to this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void AddConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overrides Sub AddConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to attach.

Implements

IDiagramConnectionPoint..::.AddConnection(IDiagramConnection)

See Also

StarDiagramConnectionPoint Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


RemoveConnection Method

[image]

Mindscape WPF Diagrams
StarDiagramConnectionPoint..::.RemoveConnection Method
StarDiagramConnectionPoint Class See Also Send Feedback
Removes the given IDiagramConnection from this IDiagramConnectionPoint.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void RemoveConnection(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overrides Sub RemoveConnection ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection to remove.

Implements

IDiagramConnectionPoint..::.RemoveConnection(IDiagramConnection)

See Also

StarDiagramConnectionPoint Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionRelocator Class

[image]

Mindscape WPF Diagrams
StarDiagramConnectionRelocator Class
Members See Also Send Feedback
Provides connection validation logic for star diagrams.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramConnectionRelocator : DefaultDiagramConnectionRelocator
Visual Basic (Declaration)
Public Class StarDiagramConnectionRelocator _
    Inherits DefaultDiagramConnectionRelocator

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DefaultDiagramConnectionRelocator
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionRelocator

See Also

StarDiagramConnectionRelocator Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionRelocator Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionRelocator Members
StarDiagramConnectionRelocator Class Constructors Methods See Also Send Feedback

The StarDiagramConnectionRelocator type exposes the following members.

Constructors

Name | Description
StarDiagramConnectionRelocator |

Methods

Name | Description
CanRelocateConnection | Returns true if a connection can be made between the given source and destination. Returns false otherwise. Star diagram connection validation logic prevents any kind of cycles or loops being created. (Overrides DefaultDiagramConnectionRelocator ..::. CanRelocateConnection(IDiagramModel, IDiagramConnection, IDiagramConnectionPoint, ConnectionDropTarget).)
RelocateConnection | Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection. (Inherited from DefaultDiagramConnectionRelocator.)

See Also

StarDiagramConnectionRelocator Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionRelocator Constructor

[image]

Mindscape WPF Diagrams
StarDiagramConnectionRelocator Constructor
StarDiagramConnectionRelocator Class See Also Send Feedback
Initializes a new instance of the StarDiagramConnectionRelocator class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramConnectionRelocator()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramConnectionRelocator Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionRelocator Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionRelocator Methods
StarDiagramConnectionRelocator Class See Also Send Feedback

The StarDiagramConnectionRelocator type exposes the following members.

Methods

Name | Description
CanRelocateConnection | Returns true if a connection can be made between the given source and destination. Returns false otherwise. Star diagram connection validation logic prevents any kind of cycles or loops being created. (Overrides DefaultDiagramConnectionRelocator ..::. CanRelocateConnection(IDiagramModel, IDiagramConnection, IDiagramConnectionPoint, ConnectionDropTarget).)
RelocateConnection | Relocates the given IDiagramConnection to have the given IDiagramConnectionPoint objects as its new source and destination. Note that one of the given connection points may be the same as the current source or destination of the connection. (Inherited from DefaultDiagramConnectionRelocator.)

See Also

StarDiagramConnectionRelocator Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CanRelocateConnection Method

[image]

Mindscape WPF Diagrams
StarDiagramConnectionRelocator..::.CanRelocateConnection Method
StarDiagramConnectionRelocator Class See Also Send Feedback
Returns true if a connection can be made between the given source and destination. Returns false otherwise. Star diagram connection validation logic prevents any kind of cycles or loops being created.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanRelocateConnection(
    IDiagramModel diagram,
    IDiagramConnection connection,
    IDiagramConnectionPoint connectionPoint,
    ConnectionDropTarget dropTarget
)
Visual Basic (Declaration)
Public Overrides Function CanRelocateConnection ( _
    diagram As IDiagramModel, _
    connection As IDiagramConnection, _
    connectionPoint As IDiagramConnectionPoint, _
    dropTarget As ConnectionDropTarget _
) As Boolean

Parameters

diagram
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The IDiagramModel where the connection relocation is taking place.
connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The IDiagramConnection that is being relocated.
connectionPoint
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnectionPoint
The connection point at the end of the connection that is not being moved.
dropTarget
Type: Mindscape.WpfDiagramming.Foundation..::.ConnectionDropTarget
Information about the possible destination of the connection.

Return Value

True if a connection is allowed to be made. False otherwise.

Implements

IDiagramConnectionRelocator..::.CanRelocateConnection(IDiagramModel, IDiagramConnection, IDiagramConnectionPoint, ConnectionDropTarget)

See Also

StarDiagramConnectionRelocator Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionState Class

[image]

Mindscape WPF Diagrams
StarDiagramConnectionState Class
Members See Also Send Feedback
An extension of ConnectionState that holds extra information specific to StarDiagramConnection objects.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramConnectionState : ConnectionState
Visual Basic (Declaration)
Public Class StarDiagramConnectionState _
    Inherits ConnectionState

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ConnectionState
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnectionState

See Also

StarDiagramConnectionState Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionState Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionState Members
StarDiagramConnectionState Class Constructors Methods Properties See Also Send Feedback

The StarDiagramConnectionState type exposes the following members.

Constructors

Name | Description
StarDiagramConnectionState | Initializes a new instance of the StarDiagramConnectionState by storing all the important property values of the given StarDiagramConnection.

Methods

Name | Description
Apply | Applies the property values stored in this StarDiagramConnectionState on to the given IDiagramConnection. Note that because the Data property is readonly, it must be set by the given IDiagramConnection itself if neccessary. This method throws an InvalidOperationException if the given connection is not an instance of StarDiagramConnection. (Overrides ConnectionState ..::. Apply(IDiagramConnection).)

Properties

Name | Description
Data | Gets the data associated with this state of the connection. (Inherited from ConnectionState.)
DesiredLength | Gets the stored value for the DesiredLength property of a StarDiagramConnection object.

See Also

StarDiagramConnectionState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionState Constructor

[image]

Mindscape WPF Diagrams
StarDiagramConnectionState Constructor
StarDiagramConnectionState Class See Also Send Feedback
Initializes a new instance of the StarDiagramConnectionState by storing all the important property values of the given StarDiagramConnection.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramConnectionState(
    StarDiagramConnection connection
)
Visual Basic (Declaration)
Public Sub New ( _
    connection As StarDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnection
The StarDiagramConnection that this state will hold information about.

See Also

StarDiagramConnectionState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionState Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionState Methods
StarDiagramConnectionState Class See Also Send Feedback

The StarDiagramConnectionState type exposes the following members.

Methods

Name | Description
Apply | Applies the property values stored in this StarDiagramConnectionState on to the given IDiagramConnection. Note that because the Data property is readonly, it must be set by the given IDiagramConnection itself if neccessary. This method throws an InvalidOperationException if the given connection is not an instance of StarDiagramConnection. (Overrides ConnectionState ..::. Apply(IDiagramConnection).)

See Also

StarDiagramConnectionState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Apply Method

[image]

Mindscape WPF Diagrams
StarDiagramConnectionState..::.Apply Method
StarDiagramConnectionState Class See Also Send Feedback
Applies the property values stored in this StarDiagramConnectionState on to the given IDiagramConnection. Note that because the Data property is readonly, it must be set by the given IDiagramConnection itself if neccessary. This method throws an InvalidOperationException if the given connection is not an instance of StarDiagramConnection.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Apply(
    IDiagramConnection connection
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    connection As IDiagramConnection _
)

Parameters

connection
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramConnection
The connection onto which the state is being restored.

Implements

IDiagramConnectionState..::.Apply(IDiagramConnection)

See Also

StarDiagramConnectionState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramConnectionState Properties

[image] [image]

Mindscape WPF Diagrams
StarDiagramConnectionState Properties
StarDiagramConnectionState Class See Also Send Feedback

The StarDiagramConnectionState type exposes the following members.

Properties

Name | Description
Data | Gets the data associated with this state of the connection. (Inherited from ConnectionState.)
DesiredLength | Gets the stored value for the DesiredLength property of a StarDiagramConnection object.

See Also

StarDiagramConnectionState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DesiredLength Property

[image]

Mindscape WPF Diagrams
StarDiagramConnectionState..::.DesiredLength Property
StarDiagramConnectionState Class See Also Send Feedback
Gets the stored value for the DesiredLength property of a StarDiagramConnection object.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double DesiredLength { get; private set; }
Visual Basic (Declaration)
Public Property DesiredLength As Double

See Also

StarDiagramConnectionState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramForceBasedLayout Class

[image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout Class
Members See Also Send Feedback
A type of ILayoutAlgorithm that uses physics equations revolving around spring theory and particle theory to force all the nodes of a StarDiagramModel into a sutable position. The StarDiagramForceBasedLayout does not modify the positions of CommentNode or TitleNode objects within the StarDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramForceBasedLayout : LayoutAlgorithmBase
Visual Basic (Declaration)
Public Class StarDiagramForceBasedLayout _
    Inherits LayoutAlgorithmBase

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.LayoutAlgorithmBase
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramForceBasedLayout

See Also

StarDiagramForceBasedLayout Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramForceBasedLayout Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout Members
StarDiagramForceBasedLayout Class Constructors Methods Properties See Also Send Feedback

The StarDiagramForceBasedLayout type exposes the following members.

Constructors

Name | Description
StarDiagramForceBasedLayout | Initializes a new instance of the StarDiagramForceBasedLayout class.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Overloaded.

Properties

Name | Description
Damping | Gets or sets the damping of the force-based layout algorithm. This is typically between 0 - 1. The higher the value, the faster the algorithm can run. The lower the value, the more stable the algorithm will be. A relatively good value for this is 0.6f. 0.9f is ideal if the MaxIterations is 1.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
MaxIterations | Gets or sets the maximum number of iterations of the algorithm within one call to the Run method.
SeparationDistance | Gets or sets the distance that this StarDiagramForceBasedLayout uses to separate different collections of StarDiagramNode objects within a diagram.

See Also

StarDiagramForceBasedLayout Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramForceBasedLayout Constructor

[image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout Constructor
StarDiagramForceBasedLayout Class See Also Send Feedback
Initializes a new instance of the StarDiagramForceBasedLayout class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramForceBasedLayout()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramForceBasedLayout Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramForceBasedLayout Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout Methods
StarDiagramForceBasedLayout Class See Also Send Feedback

The StarDiagramForceBasedLayout type exposes the following members.

Methods

Name | Description
GetStartNodes | Returns a list of 'start nodes' based on the number of inbound connections on each node. (Inherited from LayoutAlgorithmBase.)
IsIncluded | Returns whether or not the given IDiagramNode should be affected by this layout algorithm. (Inherited from LayoutAlgorithmBase.)
Run | Overloaded.

See Also

StarDiagramForceBasedLayout Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Run Method

[image] [image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout..::.Run Method
StarDiagramForceBasedLayout Class See Also Send Feedback

Overload List

Name | Description
Run(IDiagramModel) | Runs the force-based layout algorithm on the given StarDiagramModel for the number of iterations defined by MaxIterations or until a suitable layout has been reached. (Overrides LayoutAlgorithmBase ..::. Run(IDiagramModel).)
Run(IDiagramModel, IDiagramNode) | Runs this layout algorithm on the given model while making sure the given node is not affected. This is useful when the user is dragging a node.

See Also

StarDiagramForceBasedLayout Class
StarDiagramForceBasedLayout Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


Run Method (IDiagramModel)

[image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout..::.Run Method (IDiagramModel)
StarDiagramForceBasedLayout Class See Also Send Feedback
Runs the force-based layout algorithm on the given StarDiagramModel for the number of iterations defined by MaxIterations or until a suitable layout has been reached.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Run(
    IDiagramModel model
)
Visual Basic (Declaration)
Public Overrides Sub Run ( _
    model As IDiagramModel _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The StarDiagramModel to apply the force-based layout algorithm to.

Implements

ILayoutAlgorithm..::.Run(IDiagramModel)

See Also

StarDiagramForceBasedLayout Class
Run Overload
Mindscape.WpfDiagramming.StarDiagrams Namespace


Run Method (IDiagramModel, IDiagramNode)

[image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout..::.Run Method (IDiagramModel, IDiagramNode)
StarDiagramForceBasedLayout Class See Also Send Feedback
Runs this layout algorithm on the given model while making sure the given node is not affected. This is useful when the user is dragging a node.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void Run(
    IDiagramModel model,
    IDiagramNode node
)
Visual Basic (Declaration)
Public Sub Run ( _
    model As IDiagramModel, _
    node As IDiagramNode _
)

Parameters

model
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramModel
The diagram model to apply this layout algorithm to.
node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The node that should not be affected by this algorithm.

See Also

StarDiagramForceBasedLayout Class
Run Overload
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramForceBasedLayout Properties

[image] [image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout Properties
StarDiagramForceBasedLayout Class See Also Send Feedback

The StarDiagramForceBasedLayout type exposes the following members.

Properties

Name | Description
Damping | Gets or sets the damping of the force-based layout algorithm. This is typically between 0 - 1. The higher the value, the faster the algorithm can run. The lower the value, the more stable the algorithm will be. A relatively good value for this is 0.6f. 0.9f is ideal if the MaxIterations is 1.
Info | Gets or sets the ILayoutAlgorithmInfo used to provide additional diagram specific logic. (Inherited from LayoutAlgorithmBase.)
MaxIterations | Gets or sets the maximum number of iterations of the algorithm within one call to the Run method.
SeparationDistance | Gets or sets the distance that this StarDiagramForceBasedLayout uses to separate different collections of StarDiagramNode objects within a diagram.

See Also

StarDiagramForceBasedLayout Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Damping Property

[image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout..::.Damping Property
StarDiagramForceBasedLayout Class See Also Send Feedback
Gets or sets the damping of the force-based layout algorithm. This is typically between 0 - 1. The higher the value, the faster the algorithm can run. The lower the value, the more stable the algorithm will be. A relatively good value for this is 0.6f. 0.9f is ideal if the MaxIterations is 1.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Damping { get; set; }
Visual Basic (Declaration)
Public Property Damping As Double

See Also

StarDiagramForceBasedLayout Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


MaxIterations Property

[image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout..::.MaxIterations Property
StarDiagramForceBasedLayout Class See Also Send Feedback
Gets or sets the maximum number of iterations of the algorithm within one call to the Run method.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int MaxIterations { get; set; }
Visual Basic (Declaration)
Public Property MaxIterations As Integer

See Also

StarDiagramForceBasedLayout Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


SeparationDistance Property

[image]

Mindscape WPF Diagrams
StarDiagramForceBasedLayout..::.SeparationDistance Property
StarDiagramForceBasedLayout Class See Also Send Feedback
Gets or sets the distance that this StarDiagramForceBasedLayout uses to separate different collections of StarDiagramNode objects within a diagram.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int SeparationDistance { get; set; }
Visual Basic (Declaration)
Public Property SeparationDistance As Integer

See Also

StarDiagramForceBasedLayout Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramLayoutAlgorithmInfo Class

[image]

Mindscape WPF Diagrams
StarDiagramLayoutAlgorithmInfo Class
Members See Also Send Feedback
An ILayoutAlgorithmInfo implementation containing Star Diagram specific layout logic.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramLayoutAlgorithmInfo : ILayoutAlgorithmInfo
Visual Basic (Declaration)
Public Class StarDiagramLayoutAlgorithmInfo _
    Implements ILayoutAlgorithmInfo

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramLayoutAlgorithmInfo

See Also

StarDiagramLayoutAlgorithmInfo Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramLayoutAlgorithmInfo Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramLayoutAlgorithmInfo Members
StarDiagramLayoutAlgorithmInfo Class Constructors Methods See Also Send Feedback

The StarDiagramLayoutAlgorithmInfo type exposes the following members.

Constructors

Name | Description
StarDiagramLayoutAlgorithmInfo |

Methods

Name | Description
IsIncluded | Returns false if the given node is either a CommentNode or a TitleNode.

See Also

StarDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramLayoutAlgorithmInfo Constructor

[image]

Mindscape WPF Diagrams
StarDiagramLayoutAlgorithmInfo Constructor
StarDiagramLayoutAlgorithmInfo Class See Also Send Feedback
Initializes a new instance of the StarDiagramLayoutAlgorithmInfo class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramLayoutAlgorithmInfo()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramLayoutAlgorithmInfo Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramLayoutAlgorithmInfo Methods
StarDiagramLayoutAlgorithmInfo Class See Also Send Feedback

The StarDiagramLayoutAlgorithmInfo type exposes the following members.

Methods

Name | Description
IsIncluded | Returns false if the given node is either a CommentNode or a TitleNode.

See Also

StarDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


IsIncluded Method

[image]

Mindscape WPF Diagrams
StarDiagramLayoutAlgorithmInfo..::.IsIncluded Method
StarDiagramLayoutAlgorithmInfo Class See Also Send Feedback
Returns false if the given node is either a CommentNode or a TitleNode.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsIncluded(
    IDiagramNode node
)
Visual Basic (Declaration)
Public Function IsIncluded ( _
    node As IDiagramNode _
) As Boolean

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The IDiagramNode to test.

Return Value

True if the given node can be affected by the layout algorithm. False otherwise.

Implements

ILayoutAlgorithmInfo..::.IsIncluded(IDiagramNode)

See Also

StarDiagramLayoutAlgorithmInfo Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramModel Class

[image]

Mindscape WPF Diagrams
StarDiagramModel Class
Members See Also Send Feedback
Represents a star diagram.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramModel : Diagram
Visual Basic (Declaration)
Public Class StarDiagramModel _
    Inherits Diagram

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.DiagramModelBase <(Of <( DiagramNode, DiagramConnection >)>)
Mindscape.WpfDiagramming..::.Diagram
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramModel

See Also

StarDiagramModel Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramModel Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramModel Members
StarDiagramModel Class Constructors Properties See Also Send Feedback

The StarDiagramModel type exposes the following members.

Constructors

Name | Description
StarDiagramModel | Initializes a new instance of the StarDiagramModel class.

Properties

Name | Description
ConnectionRelocator | Gets or sets the IDiagramConnectionRelocator for relocating connections in the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
ConnectionRemover | Gets or sets the IDiagramConnectionRemover for removing connections from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Connections | Gets the connections of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
CustomItems | Gets null. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
DefaultConnectionBuilder | Gets or sets the default IDiagramConnectionBuilder for building diagram connections. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
NodeRemover | Gets or sets the IDiagramNodeRemover for removing nodes from the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Nodes | Gets the nodes of the diagram. (Inherited from DiagramModelBase<(Of <(TNode, TConnection>)>).)
Source | Gets the business object represented by the diagram. For the Diagram class this is always null. (Inherited from Diagram.)

See Also

StarDiagramModel Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramModel Constructor

[image]

Mindscape WPF Diagrams
StarDiagramModel Constructor
StarDiagramModel Class See Also Send Feedback
Initializes a new instance of the StarDiagramModel class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramModel()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramModel Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNode Class

[image]

Mindscape WPF Diagrams
StarDiagramNode Class
Members See Also Send Feedback
Represents a node in a StarDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public abstract class StarDiagramNode : DiagramNode
Visual Basic (Declaration)
Public MustInherit Class StarDiagramNode _
    Inherits DiagramNode

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.ViewModelBase
Mindscape.WpfDiagramming.Foundation..::.DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)
Mindscape.WpfDiagramming..::.DiagramNode
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode
Mindscape.WpfDiagramming.StarDiagrams..::.DataNode

See Also

StarDiagramNode Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNode Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramNode Members
StarDiagramNode Class Constructors Methods Fields Properties Events See Also Send Feedback

The StarDiagramNode type exposes the following members.

Constructors

Name | Description
StarDiagramNode | Initializes a new instance of the StarDiagramNode class.

Methods

Name | Description
Clone | Gets a StarDiagramNodeState holding information about this StarDiagramNode. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsAncestorOf | Returns true if this StarDiagramNode is higher up in the star diagram parent hierachy than the given node. That is, this method returns true if the given node is a child or sub-child of this node. Returns false otherwise.
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Unloads all the information from the given IDiagramNodeState and applies it to this StarDiagramNode. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

Fields

Name | Description
DefaultMass | The default value for the Mass property.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Gets whether or not this StarDiagramNode can originate new connections. StarDiagramNode objects can originate any number of connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether or not this StarDiagramNode can recieve new connection. StarDiagramNode objects can accept any number of inbound connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
Children | Gets a list of all the StarDiagramNode objects that this StarDiagramNode is a StarDiagramParent of.
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the MainConnectionPoint. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. DefaultConnectionPoint.)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsRoot | Gets or sets whether or not this StarDiagramNode is a central root of a collection of nodes.
Level | Gets the level that this node sits in the star diagram node hierarchy. A StarDiagramNode that has no StarDiagramParent is at level 0.
MainConnectionPoint | Gets the main StarDiagramConnectionPoint situated on this StarDiagramNode. Generally this will either be the only found StarDiagramConnectionPoint. null is obtained if there are no connection points situated on this node.
Mass | Gets or sets the mass of this node. This is useful for layout algorithms.
NumberOfChildren | Gets the number of nodes that this StarDiagramNode is a StarDiagramParent of. This value is calculated on the fly.
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Root | Gets the absolute root of this StarDiagramNode. The absolute root is the recursive star diagram parent of this one that has a null StarDiagramParent. A StarDiagramNode that has a null star diagram parent is the root of itself.
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
StarDiagramParent | Gets the star diagram parent of this StarDiagramNode. This parent is the StarDiagramNode at the 'source' end of a connection that this node is the destination of.
Velocity | Gets or sets the velocity vector of this StarDiagramNode. This is useful for layout algorithms.
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

Events

Name | Description
BoundsChanged | Raised when the Bounds property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DataChanged | Raised when the Data property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
PropertyChanged | Occurs when a property value changes. (Inherited from ViewModelBase.)
RotationChanged | Raised when the Rotation property changes. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNode Constructor

[image]

Mindscape WPF Diagrams
StarDiagramNode Constructor
StarDiagramNode Class See Also Send Feedback
Initializes a new instance of the StarDiagramNode class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramNode()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNode Fields

[image] [image]

Mindscape WPF Diagrams
StarDiagramNode Fields
StarDiagramNode Class See Also Send Feedback

The StarDiagramNode type exposes the following members.

Fields

Name | Description
DefaultMass | The default value for the Mass property.

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DefaultMass Field

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.DefaultMass Field
StarDiagramNode Class See Also Send Feedback
The default value for the Mass property.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public const double DefaultMass
Visual Basic (Declaration)
Public Const DefaultMass As Double

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNode Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramNode Methods
StarDiagramNode Class See Also Send Feedback

The StarDiagramNode type exposes the following members.

Methods

Name | Description
Clone | Gets a StarDiagramNodeState holding information about this StarDiagramNode. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. Clone()()().)
GetCollisionBounds | Returns the value of the Bounds property of this DiagramNodeBase. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsAncestorOf | Returns true if this StarDiagramNode is higher up in the star diagram parent hierachy than the given node. That is, this method returns true if the given node is a child or sub-child of this node. Returns false otherwise.
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnDataChanged | Raises the DataChanged event. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from ViewModelBase.)
Set<(Of <(T>)>) | Sets the value of a field, raising the PropertyChanged event if required. (Inherited from ViewModelBase.)
SetAs | Unloads all the information from the given IDiagramNodeState and applies it to this StarDiagramNode. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. SetAs(IDiagramNodeState).)

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Clone Method

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.Clone Method
StarDiagramNode Class See Also Send Feedback
Gets a StarDiagramNodeState holding information about this StarDiagramNode.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IDiagramNodeState Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As IDiagramNodeState

Return Value

A StarDiagramNodeState representing this StarDiagramNode.

Implements

IDiagramNode..::.Clone()()()

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


IsAncestorOf Method

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.IsAncestorOf Method
StarDiagramNode Class See Also Send Feedback
Returns true if this StarDiagramNode is higher up in the star diagram parent hierachy than the given node. That is, this method returns true if the given node is a child or sub-child of this node. Returns false otherwise.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsAncestorOf(
    StarDiagramNode node
)
Visual Basic (Declaration)
Public Function IsAncestorOf ( _
    node As StarDiagramNode _
) As Boolean

Parameters

node
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode
A StarDiagramNode that may or may not be a child of this node.

Return Value

True if this node is an ancestor of the given node. False otherwise.

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


SetAs Method

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.SetAs Method
StarDiagramNode Class See Also Send Feedback
Unloads all the information from the given IDiagramNodeState and applies it to this StarDiagramNode.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void SetAs(
    IDiagramNodeState state
)
Visual Basic (Declaration)
Public Overrides Sub SetAs ( _
    state As IDiagramNodeState _
)

Parameters

state
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNodeState
An IDiagramNodeState holding information about a StarDiagramNode.

Implements

IDiagramNode..::.SetAs(IDiagramNodeState)

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNode Properties

[image] [image]

Mindscape WPF Diagrams
StarDiagramNode Properties
StarDiagramNode Class See Also Send Feedback

The StarDiagramNode type exposes the following members.

Properties

Name | Description
Bounds | Gets or sets the display location and size of the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
CanOriginateNewConnections | Gets whether or not this StarDiagramNode can originate new connections. StarDiagramNode objects can originate any number of connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanOriginateNewConnections.)
CanReceiveNewConnections | Gets whether or not this StarDiagramNode can recieve new connection. StarDiagramNode objects can accept any number of inbound connections. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. CanReceiveNewConnections.)
Children | Gets a list of all the StarDiagramNode objects that this StarDiagramNode is a StarDiagramParent of.
ConnectionPoints | Gets the collection of connection points on this DiagramNode. (Inherited from DiagramNode.)
Data | Gets the data represented by the node. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
DefaultConnectionPoint | Gets the MainConnectionPoint. (Overrides DiagramNodeBase <(Of <( DiagramConnectionPoint >)>)..::. DefaultConnectionPoint.)
IsResizable | Gets or sets whether the DiagramNodeBase can be resized. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
IsRoot | Gets or sets whether or not this StarDiagramNode is a central root of a collection of nodes.
Level | Gets the level that this node sits in the star diagram node hierarchy. A StarDiagramNode that has no StarDiagramParent is at level 0.
MainConnectionPoint | Gets the main StarDiagramConnectionPoint situated on this StarDiagramNode. Generally this will either be the only found StarDiagramConnectionPoint. null is obtained if there are no connection points situated on this node.
Mass | Gets or sets the mass of this node. This is useful for layout algorithms.
NumberOfChildren | Gets the number of nodes that this StarDiagramNode is a StarDiagramParent of. This value is calculated on the fly.
Parent | Gets the parent of the DiagramNodeBase. This implementation returns null, but can be overriden. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
Root | Gets the absolute root of this StarDiagramNode. The absolute root is the recursive star diagram parent of this one that has a null StarDiagramParent. A StarDiagramNode that has a null star diagram parent is the root of itself.
Rotation | Gets or sets the rotation of this DiagramNodeBase<(Of <(TConnectionPoint>)>). (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)
StarDiagramParent | Gets the star diagram parent of this StarDiagramNode. This parent is the StarDiagramNode at the 'source' end of a connection that this node is the destination of.
Velocity | Gets or sets the velocity vector of this StarDiagramNode. This is useful for layout algorithms.
ZOrder | Gets or sets the relative z-order. (Inherited from DiagramNodeBase<(Of <(TConnectionPoint>)>).)

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CanOriginateNewConnections Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.CanOriginateNewConnections Property
StarDiagramNode Class See Also Send Feedback
Gets whether or not this StarDiagramNode can originate new connections. StarDiagramNode objects can originate any number of connections.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanOriginateNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanOriginateNewConnections As Boolean

Implements

IDiagramConnectable..::.CanOriginateNewConnections

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CanReceiveNewConnections Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.CanReceiveNewConnections Property
StarDiagramNode Class See Also Send Feedback
Gets whether or not this StarDiagramNode can recieve new connection. StarDiagramNode objects can accept any number of inbound connections.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override bool CanReceiveNewConnections { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanReceiveNewConnections As Boolean

Implements

IDiagramConnectable..::.CanReceiveNewConnections

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Children Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.Children Property
StarDiagramNode Class See Also Send Feedback
Gets a list of all the StarDiagramNode objects that this StarDiagramNode is a StarDiagramParent of.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public IList<StarDiagramNode> Children { get; }
Visual Basic (Declaration)
Public ReadOnly Property Children As IList(Of StarDiagramNode)

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


DefaultConnectionPoint Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.DefaultConnectionPoint Property
StarDiagramNode Class See Also Send Feedback
Gets the MainConnectionPoint.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override IDiagramConnectionPoint DefaultConnectionPoint { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultConnectionPoint As IDiagramConnectionPoint

Implements

IDiagramNode..::.DefaultConnectionPoint

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


IsRoot Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.IsRoot Property
StarDiagramNode Class See Also Send Feedback
Gets or sets whether or not this StarDiagramNode is a central root of a collection of nodes.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public bool IsRoot { get; set; }
Visual Basic (Declaration)
Public Property IsRoot As Boolean

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Level Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.Level Property
StarDiagramNode Class See Also Send Feedback
Gets the level that this node sits in the star diagram node hierarchy. A StarDiagramNode that has no StarDiagramParent is at level 0.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As Integer

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


MainConnectionPoint Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.MainConnectionPoint Property
StarDiagramNode Class See Also Send Feedback
Gets the main StarDiagramConnectionPoint situated on this StarDiagramNode. Generally this will either be the only found StarDiagramConnectionPoint. null is obtained if there are no connection points situated on this node.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual StarDiagramConnectionPoint MainConnectionPoint { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property MainConnectionPoint As StarDiagramConnectionPoint

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Mass Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.Mass Property
StarDiagramNode Class See Also Send Feedback
Gets or sets the mass of this node. This is useful for layout algorithms.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Mass { get; set; }
Visual Basic (Declaration)
Public Property Mass As Double

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


NumberOfChildren Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.NumberOfChildren Property
StarDiagramNode Class See Also Send Feedback
Gets the number of nodes that this StarDiagramNode is a StarDiagramParent of. This value is calculated on the fly.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public int NumberOfChildren { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfChildren As Integer

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Root Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.Root Property
StarDiagramNode Class See Also Send Feedback
Gets the absolute root of this StarDiagramNode. The absolute root is the recursive star diagram parent of this one that has a null StarDiagramParent. A StarDiagramNode that has a null star diagram parent is the root of itself.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramNode Root { get; }
Visual Basic (Declaration)
Public ReadOnly Property Root As StarDiagramNode

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramParent Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.StarDiagramParent Property
StarDiagramNode Class See Also Send Feedback
Gets the star diagram parent of this StarDiagramNode. This parent is the StarDiagramNode at the 'source' end of a connection that this node is the destination of.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramNode StarDiagramParent { get; internal set; }
Visual Basic (Declaration)
Public Property StarDiagramParent As StarDiagramNode

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Velocity Property

[image]

Mindscape WPF Diagrams
StarDiagramNode..::.Velocity Property
StarDiagramNode Class See Also Send Feedback
Gets or sets the velocity vector of this StarDiagramNode. This is useful for layout algorithms.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Vector Velocity { get; set; }
Visual Basic (Declaration)
Public Property Velocity As Vector

See Also

StarDiagramNode Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNodeState Class

[image]

Mindscape WPF Diagrams
StarDiagramNodeState Class
Members See Also Send Feedback
An extension of NodeState which holds extra information about a StarDiagramNode.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramNodeState : NodeState
Visual Basic (Declaration)
Public Class StarDiagramNodeState _
    Inherits NodeState

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming.Foundation..::.NodeState
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNodeState

See Also

StarDiagramNodeState Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNodeState Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramNodeState Members
StarDiagramNodeState Class Constructors Methods Properties See Also Send Feedback

The StarDiagramNodeState type exposes the following members.

Constructors

Name | Description
StarDiagramNodeState | Initializes a new instance of the StarDiagramNodeState class.

Methods

Name | Description
Apply | Applies the property values stored in this StarDiagramNodeState on to the given IDiagramNode. Note that because the Data and Parent properties are readonly, these must be set by the given IDiagramNode itself if neccessary. (Overrides NodeState ..::. Apply(IDiagramNode).)

Properties

Name | Description
Bounds | Gets the stored Bounds property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
Data | Gets the stored Data property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
IsResizable | Gets the stored IsResizable property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
Mass | Gets the stored value for the mass property of a StarDiagramNode.
Parent | Gets the stored Parent property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
Rotation | Gets the stored Rotation property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
ZOrder | Gets the stored ZOrder property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)

See Also

StarDiagramNodeState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNodeState Constructor

[image]

Mindscape WPF Diagrams
StarDiagramNodeState Constructor
StarDiagramNodeState Class See Also Send Feedback
Initializes a new instance of the StarDiagramNodeState class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramNodeState(
    StarDiagramNode node
)
Visual Basic (Declaration)
Public Sub New ( _
    node As StarDiagramNode _
)

Parameters

node
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode
The node whose state is to be snapshotted.

See Also

StarDiagramNodeState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNodeState Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramNodeState Methods
StarDiagramNodeState Class See Also Send Feedback

The StarDiagramNodeState type exposes the following members.

Methods

Name | Description
Apply | Applies the property values stored in this StarDiagramNodeState on to the given IDiagramNode. Note that because the Data and Parent properties are readonly, these must be set by the given IDiagramNode itself if neccessary. (Overrides NodeState ..::. Apply(IDiagramNode).)

See Also

StarDiagramNodeState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Apply Method

[image]

Mindscape WPF Diagrams
StarDiagramNodeState..::.Apply Method
StarDiagramNodeState Class See Also Send Feedback
Applies the property values stored in this StarDiagramNodeState on to the given IDiagramNode. Note that because the Data and Parent properties are readonly, these must be set by the given IDiagramNode itself if neccessary.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public override void Apply(
    IDiagramNode node
)
Visual Basic (Declaration)
Public Overrides Sub Apply ( _
    node As IDiagramNode _
)

Parameters

node
Type: Mindscape.WpfDiagramming.Foundation..::.IDiagramNode
The node onto which the state is being restored.

Implements

IDiagramNodeState..::.Apply(IDiagramNode)

See Also

StarDiagramNodeState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramNodeState Properties

[image] [image]

Mindscape WPF Diagrams
StarDiagramNodeState Properties
StarDiagramNodeState Class See Also Send Feedback

The StarDiagramNodeState type exposes the following members.

Properties

Name | Description
Bounds | Gets the stored Bounds property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
Data | Gets the stored Data property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
IsResizable | Gets the stored IsResizable property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
Mass | Gets the stored value for the mass property of a StarDiagramNode.
Parent | Gets the stored Parent property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
Rotation | Gets the stored Rotation property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)
ZOrder | Gets the stored ZOrder property value for the IDiagramNode that this NodeState was made for. (Inherited from NodeState.)

See Also

StarDiagramNodeState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Mass Property

[image]

Mindscape WPF Diagrams
StarDiagramNodeState..::.Mass Property
StarDiagramNodeState Class See Also Send Feedback
Gets the stored value for the mass property of a StarDiagramNode.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public double Mass { get; private set; }
Visual Basic (Declaration)
Public Property Mass As Double

See Also

StarDiagramNodeState Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramXmlSerializer Class

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer Class
Members See Also Send Feedback
Serializes or deserializes a StarDiagramModel using an XML stream.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramXmlSerializer : DiagramXmlSerializer
Visual Basic (Declaration)
Public Class StarDiagramXmlSerializer _
    Inherits DiagramXmlSerializer

Inheritance Hierarchy

System..::.Object
Mindscape.WpfDiagramming..::.DiagramXmlSerializer
Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramXmlSerializer

See Also

StarDiagramXmlSerializer Members
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramXmlSerializer Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer Members
StarDiagramXmlSerializer Class Constructors Methods Properties See Also Send Feedback

The StarDiagramXmlSerializer type exposes the following members.

Constructors

Name | Description
StarDiagramXmlSerializer |

Methods

Name | Description
AddStarDiagramConnectionAttributes | Adds star diagram connection specific attributes to the given XElement for the given StarDiagramConnection. This can be called when serializing custom star diagram connections.
AddStarDiagramNodeAttributes | Adds star diagram node specific attributes to the given XElement for the given StarDiagramNode. This can be called when serializing custom star diagram nodes.
CreateConnection | Returns a deserialized connection based on the given XElement. (Inherited from DiagramXmlSerializer.)
CreateDiagram | Returns a new instance of StarDiagramModel. (Overrides DiagramXmlSerializer ..::. CreateDiagram()()().)
CreateNode | Returns a deserialized node based on the given XElement. (Inherited from DiagramXmlSerializer.)
Deserialize | Deserializes a Diagram from XML. (Inherited from DiagramXmlSerializer.)
Serialize | Serializes a Diagram to XML. (Inherited from DiagramXmlSerializer.)
SerializeConnectionCore | Returns an XElement for serializing the given connection. (Overrides DiagramXmlSerializer ..::. SerializeConnectionCore(DiagramConnection).)
SerializeNodeCore | Returns an XElement for serializing the given node. (Overrides DiagramXmlSerializer ..::. SerializeNodeCore(DiagramNode).)
SetStarDiagramConnectionProperties | Deserializes the star diagram connection specific attributes on the given XElement to set properties on the given StarDiagramConnection. This can be called when deserializing custom star diagram connections.
SetStarDiagramNodeProperties | Deserializes the star diagram node specific attributes on the given XElement to set properties on the given StarDiagramNode. This can be called when deserializing custom star diagram nodes.
Shape | Returns a DiagramShape based on the given XAttribute value. (Inherited from DiagramXmlSerializer.)

Properties

Name | Description
LineTypeNameResolver | Gets or sets a function used to resolve line type names. This supports custom line types. If the LineTypeNameResolver is not set, or returns null, then the default resolver is used. (Inherited from DiagramXmlSerializer.)
OnDeserializeCustomConnectionData | Gets or sets a function used to deserialize custom connection data. (Inherited from DiagramXmlSerializer.)
OnDeserializeCustomNodeData | Gets or sets a function used to deserialize custom node data. (Inherited from DiagramXmlSerializer.)
OnSerializeCustomConnectionData | Gets or sets a function used to serialize custom connection data. (Inherited from DiagramXmlSerializer.)
OnSerializeCustomNodeData | Gets or sets a function used to serialize custom node data. (Inherited from DiagramXmlSerializer.)
ShapeNameResolver | Gets or sets a function used to resolve shape names. This supports custom shapes. If the ShapeNameResolver is not set, or returns null, then the default resolver is used. (Inherited from DiagramXmlSerializer.)

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramXmlSerializer Constructor

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer Constructor
StarDiagramXmlSerializer Class See Also Send Feedback
Initializes a new instance of the StarDiagramXmlSerializer class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramXmlSerializer()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


StarDiagramXmlSerializer Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer Methods
StarDiagramXmlSerializer Class See Also Send Feedback

The StarDiagramXmlSerializer type exposes the following members.

Methods

Name | Description
AddStarDiagramConnectionAttributes | Adds star diagram connection specific attributes to the given XElement for the given StarDiagramConnection. This can be called when serializing custom star diagram connections.
AddStarDiagramNodeAttributes | Adds star diagram node specific attributes to the given XElement for the given StarDiagramNode. This can be called when serializing custom star diagram nodes.
CreateConnection | Returns a deserialized connection based on the given XElement. (Inherited from DiagramXmlSerializer.)
CreateDiagram | Returns a new instance of StarDiagramModel. (Overrides DiagramXmlSerializer ..::. CreateDiagram()()().)
CreateNode | Returns a deserialized node based on the given XElement. (Inherited from DiagramXmlSerializer.)
Deserialize | Deserializes a Diagram from XML. (Inherited from DiagramXmlSerializer.)
Serialize | Serializes a Diagram to XML. (Inherited from DiagramXmlSerializer.)
SerializeConnectionCore | Returns an XElement for serializing the given connection. (Overrides DiagramXmlSerializer ..::. SerializeConnectionCore(DiagramConnection).)
SerializeNodeCore | Returns an XElement for serializing the given node. (Overrides DiagramXmlSerializer ..::. SerializeNodeCore(DiagramNode).)
SetStarDiagramConnectionProperties | Deserializes the star diagram connection specific attributes on the given XElement to set properties on the given StarDiagramConnection. This can be called when deserializing custom star diagram connections.
SetStarDiagramNodeProperties | Deserializes the star diagram node specific attributes on the given XElement to set properties on the given StarDiagramNode. This can be called when deserializing custom star diagram nodes.
Shape | Returns a DiagramShape based on the given XAttribute value. (Inherited from DiagramXmlSerializer.)

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


AddStarDiagramConnectionAttributes Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.AddStarDiagramConnectionAttributes Method
StarDiagramXmlSerializer Class See Also Send Feedback
Adds star diagram connection specific attributes to the given XElement for the given StarDiagramConnection. This can be called when serializing custom star diagram connections.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void AddStarDiagramConnectionAttributes(
    XElement element,
    StarDiagramConnection connection
)
Visual Basic (Declaration)
Protected Sub AddStarDiagramConnectionAttributes ( _
    element As XElement, _
    connection As StarDiagramConnection _
)

Parameters

element
Type: System.Xml.Linq..::.XElement
The XElement to add the attributes to.
connection
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnection
The StarDiagramConnection being deserialized.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


AddStarDiagramNodeAttributes Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.AddStarDiagramNodeAttributes Method
StarDiagramXmlSerializer Class See Also Send Feedback
Adds star diagram node specific attributes to the given XElement for the given StarDiagramNode. This can be called when serializing custom star diagram nodes.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void AddStarDiagramNodeAttributes(
    XElement element,
    StarDiagramNode node
)
Visual Basic (Declaration)
Protected Sub AddStarDiagramNodeAttributes ( _
    element As XElement, _
    node As StarDiagramNode _
)

Parameters

element
Type: System.Xml.Linq..::.XElement
The XElement to add the attributes to.
node
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode
The StarDiagramNode being serialized.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CreateDiagram Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.CreateDiagram Method
StarDiagramXmlSerializer Class See Also Send Feedback
Returns a new instance of StarDiagramModel.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override Diagram CreateDiagram()
Visual Basic (Declaration)
Protected Overrides Function CreateDiagram As Diagram

Return Value

A new StarDiagramModel.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


SerializeConnectionCore Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.SerializeConnectionCore Method
StarDiagramXmlSerializer Class See Also Send Feedback
Returns an XElement for serializing the given connection.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override XElement SerializeConnectionCore(
    DiagramConnection connection
)
Visual Basic (Declaration)
Protected Overrides Function SerializeConnectionCore ( _
    connection As DiagramConnection _
) As XElement

Parameters

connection
Type: Mindscape.WpfDiagramming..::.DiagramConnection
The connection to be serialized.

Return Value

The serialized connection.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


SerializeNodeCore Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.SerializeNodeCore Method
StarDiagramXmlSerializer Class See Also Send Feedback
Returns an XElement for serializing the given node.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected override XElement SerializeNodeCore(
    DiagramNode node
)
Visual Basic (Declaration)
Protected Overrides Function SerializeNodeCore ( _
    node As DiagramNode _
) As XElement

Parameters

node
Type: Mindscape.WpfDiagramming..::.DiagramNode
The node to be serialized.

Return Value

The serialized node.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


SetStarDiagramConnectionProperties Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.SetStarDiagramConnectionProperties Method
StarDiagramXmlSerializer Class See Also Send Feedback
Deserializes the star diagram connection specific attributes on the given XElement to set properties on the given StarDiagramConnection. This can be called when deserializing custom star diagram connections.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void SetStarDiagramConnectionProperties(
    XElement element,
    StarDiagramConnection connection
)
Visual Basic (Declaration)
Protected Sub SetStarDiagramConnectionProperties ( _
    element As XElement, _
    connection As StarDiagramConnection _
)

Parameters

element
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the attributes.
connection
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramConnection
The StarDiagramConnection being deserialized.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


SetStarDiagramNodeProperties Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.SetStarDiagramNodeProperties Method
StarDiagramXmlSerializer Class See Also Send Feedback
Deserializes the star diagram node specific attributes on the given XElement to set properties on the given StarDiagramNode. This can be called when deserializing custom star diagram nodes.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected void SetStarDiagramNodeProperties(
    XElement element,
    StarDiagramNode node
)
Visual Basic (Declaration)
Protected Sub SetStarDiagramNodeProperties ( _
    element As XElement, _
    node As StarDiagramNode _
)

Parameters

element
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the attributes.
node
Type: Mindscape.WpfDiagramming.StarDiagrams..::.StarDiagramNode
The StarDiagramNode being deserialized.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace

[image]

Mindscape WPF Diagrams
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace
Send Feedback
Contains standard star diagram visual styles.

Classes

Class | Description
GradientStyle | GradientStyle
StarDiagramStyles | A ResourceDictionary containing standard visual styles for flow diagrams.
Whalesong | Whalesong


GradientStyle Class

[image]

Mindscape WPF Diagrams
GradientStyle Class
Members See Also Send Feedback
GradientStyle

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class GradientStyle : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class GradientStyle _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.StarDiagrams.Styles..::.GradientStyle

See Also

GradientStyle Members
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


GradientStyle Members

[image] [image]

Mindscape WPF Diagrams
GradientStyle Members
GradientStyle Class Constructors Methods Properties See Also Send Feedback

The GradientStyle type exposes the following members.

Constructors

Name | Description
GradientStyle | Initializes a new instance of the GradientStyle class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle style uses to select connection styles.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle style uses to select node styles.
NodeTemplateSelectorKey | Returns the ResourceKey for the DataTemplateSelector that the GradientStyle style uses to select node templates.

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


GradientStyle Constructor

[image]

Mindscape WPF Diagrams
GradientStyle Constructor
GradientStyle Class See Also Send Feedback
Initializes a new instance of the GradientStyle class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public GradientStyle()
Visual Basic (Declaration)
Public Sub New

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


GradientStyle Methods

[image] [image]

Mindscape WPF Diagrams
GradientStyle Methods
GradientStyle Class See Also Send Feedback

The GradientStyle type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
GradientStyle..::.InitializeComponent Method
GradientStyle Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


GradientStyle Properties

[image] [image]

Mindscape WPF Diagrams
GradientStyle Properties
GradientStyle Class See Also Send Feedback

The GradientStyle type exposes the following members.

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle style uses to select connection styles.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the GradientStyle style uses to select node styles.
NodeTemplateSelectorKey | Returns the ResourceKey for the DataTemplateSelector that the GradientStyle style uses to select node templates.

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


ConnectionStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.ConnectionStyleSelectorKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the GradientStyle style uses to select connection styles.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey ConnectionStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConnectionStyleSelectorKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


NodeStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.NodeStyleSelectorKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the GradientStyle style uses to select node styles.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey NodeStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NodeStyleSelectorKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


NodeTemplateSelectorKey Property

[image]

Mindscape WPF Diagrams
GradientStyle..::.NodeTemplateSelectorKey Property
GradientStyle Class See Also Send Feedback
Returns the ResourceKey for the DataTemplateSelector that the GradientStyle style uses to select node templates.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey NodeTemplateSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NodeTemplateSelectorKey As ComponentResourceKey

See Also

GradientStyle Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


StarDiagramStyles Class

[image]

Mindscape WPF Diagrams
StarDiagramStyles Class
Members See Also Send Feedback
A ResourceDictionary containing standard visual styles for flow diagrams.
StarDiagramStyles

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class StarDiagramStyles : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class StarDiagramStyles _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.StarDiagrams.Styles..::.StarDiagramStyles

See Also

StarDiagramStyles Members
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


StarDiagramStyles Members

[image] [image]

Mindscape WPF Diagrams
StarDiagramStyles Members
StarDiagramStyles Class Constructors Methods Properties See Also Send Feedback

The StarDiagramStyles type exposes the following members.

Constructors

Name | Description
StarDiagramStyles | Initializes a new instance of the StarDiagramStyles class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
GradientStyleFormatterKey | Gets the ResourceKey for the GradientStyle diagram formatter.
WhalesongFormatterKey | Gets the ResourceKey for the Whalesong diagram formatter.

See Also

StarDiagramStyles Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


StarDiagramStyles Constructor

[image]

Mindscape WPF Diagrams
StarDiagramStyles Constructor
StarDiagramStyles Class See Also Send Feedback
Initializes a new instance of the StarDiagramStyles class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public StarDiagramStyles()
Visual Basic (Declaration)
Public Sub New

See Also

StarDiagramStyles Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


StarDiagramStyles Methods

[image] [image]

Mindscape WPF Diagrams
StarDiagramStyles Methods
StarDiagramStyles Class See Also Send Feedback

The StarDiagramStyles type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

StarDiagramStyles Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
StarDiagramStyles..::.InitializeComponent Method
StarDiagramStyles Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

StarDiagramStyles Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


StarDiagramStyles Properties

[image] [image]

Mindscape WPF Diagrams
StarDiagramStyles Properties
StarDiagramStyles Class See Also Send Feedback

The StarDiagramStyles type exposes the following members.

Properties

Name | Description
GradientStyleFormatterKey | Gets the ResourceKey for the GradientStyle diagram formatter.
WhalesongFormatterKey | Gets the ResourceKey for the Whalesong diagram formatter.

See Also

StarDiagramStyles Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


GradientStyleFormatterKey Property

[image]

Mindscape WPF Diagrams
StarDiagramStyles..::.GradientStyleFormatterKey Property
StarDiagramStyles Class See Also Send Feedback
Gets the ResourceKey for the GradientStyle diagram formatter.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey GradientStyleFormatterKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GradientStyleFormatterKey As ComponentResourceKey

See Also

StarDiagramStyles Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


WhalesongFormatterKey Property

[image]

Mindscape WPF Diagrams
StarDiagramStyles..::.WhalesongFormatterKey Property
StarDiagramStyles Class See Also Send Feedback
Gets the ResourceKey for the Whalesong diagram formatter.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey WhalesongFormatterKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WhalesongFormatterKey As ComponentResourceKey

See Also

StarDiagramStyles Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


Whalesong Class

[image]

Mindscape WPF Diagrams
Whalesong Class
Members See Also Send Feedback
Whalesong

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public class Whalesong : ResourceDictionary, IComponentConnector
Visual Basic (Declaration)
Public Class Whalesong _
    Inherits ResourceDictionary _
    Implements IComponentConnector

Inheritance Hierarchy

System..::.Object
System.Windows..::.ResourceDictionary
Mindscape.WpfDiagramming.StarDiagrams.Styles..::.Whalesong

See Also

Whalesong Members
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


Whalesong Members

[image] [image]

Mindscape WPF Diagrams
Whalesong Members
Whalesong Class Constructors Methods Properties See Also Send Feedback

The Whalesong type exposes the following members.

Constructors

Name | Description
Whalesong | Initializes a new instance of the Whalesong class.

Methods

Name | Description
InitializeComponent | InitializeComponent

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select connection styles.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select node styles.
NodeTemplateSelectorKey | Returns the ResourceKey for the DataTemplateSelector that the Whalesong style uses to select node templates.

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


Whalesong Constructor

[image]

Mindscape WPF Diagrams
Whalesong Constructor
Whalesong Class See Also Send Feedback
Initializes a new instance of the Whalesong class.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public Whalesong()
Visual Basic (Declaration)
Public Sub New

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


Whalesong Methods

[image] [image]

Mindscape WPF Diagrams
Whalesong Methods
Whalesong Class See Also Send Feedback

The Whalesong type exposes the following members.

Methods

Name | Description
InitializeComponent | InitializeComponent

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


InitializeComponent Method

[image]

Mindscape WPF Diagrams
Whalesong..::.InitializeComponent Method
Whalesong Class See Also Send Feedback
InitializeComponent

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public void InitializeComponent()
Visual Basic (Declaration)
Public Sub InitializeComponent

Implements

IComponentConnector..::.InitializeComponent()()()

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


Whalesong Properties

[image] [image]

Mindscape WPF Diagrams
Whalesong Properties
Whalesong Class See Also Send Feedback

The Whalesong type exposes the following members.

Properties

Name | Description
ConnectionStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select connection styles.
NodeStyleSelectorKey | Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select node styles.
NodeTemplateSelectorKey | Returns the ResourceKey for the DataTemplateSelector that the Whalesong style uses to select node templates.

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


ConnectionStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.ConnectionStyleSelectorKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select connection styles.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey ConnectionStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConnectionStyleSelectorKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


NodeStyleSelectorKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.NodeStyleSelectorKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the StyleSelector that the Whalesong style uses to select node styles.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey NodeStyleSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NodeStyleSelectorKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


NodeTemplateSelectorKey Property

[image]

Mindscape WPF Diagrams
Whalesong..::.NodeTemplateSelectorKey Property
Whalesong Class See Also Send Feedback
Returns the ResourceKey for the DataTemplateSelector that the Whalesong style uses to select node templates.

Namespace: Mindscape.WpfDiagramming.StarDiagrams.Styles
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public static ComponentResourceKey NodeTemplateSelectorKey { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property NodeTemplateSelectorKey As ComponentResourceKey

See Also

Whalesong Class
Mindscape.WpfDiagramming.StarDiagrams.Styles Namespace


CreateConnection Method

[image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer..::.CreateConnection Method
FlowDiagramXmlSerializer Class See Also Send Feedback
Returns a deserialized connection based on the given XElement.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramConnection CreateConnection(
    XElement xml,
    DiagramConnectionPoint source,
    DiagramConnectionPoint destination,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Protected Overridable Function CreateConnection ( _
    xml As XElement, _
    source As DiagramConnectionPoint, _
    destination As DiagramConnectionPoint, _
    segments As IList(Of DiagramConnectionSegment) _
) As DiagramConnection

Parameters

xml
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the connection.
source
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The source connection point of the connection.
destination
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The destination connection point of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects that make up the connection.

Return Value

The deserialized connection.

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
FlowDiagramXmlSerializer..::.CreateNode Method
FlowDiagramXmlSerializer Class See Also Send Feedback
Returns a deserialized node based on the given XElement.

Namespace: Mindscape.WpfDiagramming.FlowDiagrams
Assembly: Mindscape.WpfDiagramming.FlowDiagrams (in Mindscape.WpfDiagramming.FlowDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramNode CreateNode(
    XElement xml
)
Visual Basic (Declaration)
Protected Overridable Function CreateNode ( _
    xml As XElement _
) As DiagramNode

Parameters

xml
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the node.

Return Value

The deserialized node.

See Also

FlowDiagramXmlSerializer Class
Mindscape.WpfDiagramming.FlowDiagrams Namespace


AddConnectionPoint Method

[image]

Mindscape WPF Diagrams
StarDiagramConnection..::.AddConnectionPoint Method
StarDiagramConnection Class See Also Send Feedback
Throws a NotSupportedException. StarDiagramConnection objects do not support mounted connections.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
public virtual DiagramConnectionPoint AddConnectionPoint(
    Point point,
    double buffer
)
Visual Basic (Declaration)
Public Overridable Function AddConnectionPoint ( _
    point As Point, _
    buffer As Double _
) As DiagramConnectionPoint

Parameters

point
Type: System.Windows..::.Point
Not used.
buffer
Type: System..::.Double
Not used.

Return Value

Throws a NotSupportedException.

See Also

StarDiagramConnection Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CreateConnection Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.CreateConnection Method
StarDiagramXmlSerializer Class See Also Send Feedback
Returns a deserialized connection based on the given XElement.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramConnection CreateConnection(
    XElement xml,
    DiagramConnectionPoint source,
    DiagramConnectionPoint destination,
    IList<DiagramConnectionSegment> segments
)
Visual Basic (Declaration)
Protected Overridable Function CreateConnection ( _
    xml As XElement, _
    source As DiagramConnectionPoint, _
    destination As DiagramConnectionPoint, _
    segments As IList(Of DiagramConnectionSegment) _
) As DiagramConnection

Parameters

xml
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the connection.
source
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The source connection point of the connection.
destination
Type: Mindscape.WpfDiagramming..::.DiagramConnectionPoint
The destination connection point of the connection.
segments
Type: System.Collections.Generic..::.IList <(Of <( DiagramConnectionSegment >)>)
The DiagramConnectionSegment objects that make up the connection.

Return Value

The deserialized connection.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace


CreateNode Method

[image]

Mindscape WPF Diagrams
StarDiagramXmlSerializer..::.CreateNode Method
StarDiagramXmlSerializer Class See Also Send Feedback
Returns a deserialized node based on the given XElement.

Namespace: Mindscape.WpfDiagramming.StarDiagrams
Assembly: Mindscape.WpfDiagramming.StarDiagrams (in Mindscape.WpfDiagramming.StarDiagrams.dll)
Version: 2.0.0.0 (2.0.0.0)

Syntax

C#
protected virtual DiagramNode CreateNode(
    XElement xml
)
Visual Basic (Declaration)
Protected Overridable Function CreateNode ( _
    xml As XElement _
) As DiagramNode

Parameters

xml
Type: System.Xml.Linq..::.XElement
The XElement for deserializing the node.

Return Value

The deserialized node.

See Also

StarDiagramXmlSerializer Class
Mindscape.WpfDiagramming.StarDiagrams Namespace